Bosch.Dcn.Ecpc.Client.Api.Interfaces Namespace

Bosch DCN Conference Software Application Programmable Interface
Bosch.Dcn.Ecpc.Client.Api.Interfaces Namespace
[image]

Bosch DCN Conference Software Application Programmable Interface

Introduction

This specification describes the DCN-SW API (Application Programmable Interface) for the DCN-SW software. This specification is intended to be used by developers who want to use this interface to develop a PC-based client application to have limited configuration functionality available.

Definition, Acronym or Abbreviation | Description
API | Application Programmable Interface
CCU | Central Control Unit which is controlled by DCN-SW server.
DCN | Digital Congress Network
NCO | Network Controller, the master-CCU in a multi-CCU system.

Scope

This user manual describes the use of the DCN-SW API for the DCN (Next Generation) system. To understand this manual, knowledge is expected on the following issues:

  • The Microsoft .NET Framework 4 and one of its development languages.
  • The Microsoft Visual Studio.NET development environment.
  • The DCN system and its installation.

This user manual is intended for users, who want to use the DCN-SW API into their application.

The current version of the DCN-SW API provides functionality to:

  • Add, change and remove delegate from the system and register them for meetings.
  • Assign, unassign, read and produce ID-cards for delegates.
  • Assign or remove delegates as participant to or from a prepared or active meeting.
  • Add, change, and remove voting rounds to a session of a meeting.
  • Stop and start meetings and sessions.
  • Control participants microphones.
  • Control request and response lists.

This manual uses code-fragments (in the C# programming language) to clarify the use of the DCN-SW API.

Authentication Key and Permissions

Before the DCN-SW API can be used, the correct license key must be installed on the master-CCU. This key must provide:

  • At least the authorization to use the DCN-SW API for configuration purposes.
  • Optionally the authorization to produce ID-cards for delegates of a meeting.

In addition to the license key, the DCN-SW API is subject to the user management principles of the DCN(-SW) system. Users of the system are therefore required to authenticate themselves before access is allowed. This also applies for the DCN-SW API to use.

To successfully 'logon' the DCN-SW API, initialization of a connection to the DCN-SW server requires a username and password. To make sure the DCN-SW API is properly authenticated by the DCN-SW server:

  • A user group with meeting preparation (PMe), voting preparation (PVo) and person registration (RP) must be defined.
  • A user must be defined for the DCN-SW API and assigned to the proper user group.
NOTE: Refer to the online helpfile of DCN-SW how to define user groups and assign users!

Access rights available on the DCN-SW API's interface are derived from the permissions configured for the user and the set of authorizations defined by the license key present in available on the master-CCU of the DCN (Next Generation) system. These authorizations are only available when the connection between the DCN-SW server and the master-CCU is available!

Properties are available on the DCN-SW API to query for the available access rights on the interface. In addition, events are available for registering on notifications in changes of access rights.

Some (important enough to mention here) properties and events regarding access rights are:

Properties and Events | Description
IsConfigAllowed | This property indicates that using the DCN-SW API for configuration purposes is allowed and is dependent on (1) the availability of the DCN-SW API (see IsAvailable()()()()), and (2) the availability of the license to use the DCN-SW API for configuration purposes.
IsControlAllowed | This property indicates that using the DCN-SW API for operational purposes is allowed and is dependent on (1) the availability of the DCN-SW API (see IsAvailable()()()()), and (2) the availability of the license to use the DCN-SW API for operational purposes.
AuthorizationChange | This event occurs when either permissions change, the license key has changed or the connection between the master-CCU and DCN-SW server has become available or was lost.
IsCardProductionAllowed | This property indicates that ID-cards can be produced and read using an ID-card reader/writer connected to the local host running the DCN-SW API interface. This property is dependent on IsAvailable, IsConfigAllowed and the availability of the license to use an ID-card reader/writer on the master-CCU.
Other properties indicating access rights on the DCN-SW API are IsDelegateRegistrationAllowed and IsVoteRegistrationAllowed. It is good practice to check these properties before calling a function on the DCN-SW API. If the connection to the DCN-SW server is available but the appropriate access right is missing to execute a function on the DCN-SW API, NO_AUTHORIZATION()()()() will be returned by the called function!

Which access rights are required for calling a function on the interface, will clearly be indicated in the documentation of the particular function.

Setting up the DCN-SW API

For setting up the DCN-SW API, the following items are required in your project:

  • A reference to the Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll assembly containing all interfaces required to use the DCN-SW API.
  • A reference to the Bosch.Dcn.Ecp.Client.Api.Logic.dll assembly containing the functional logic of the DCN-SW API.
  • The Bosch.Dcn.Ecpc.Client.Logic.dll.config file copied to your local directory. This file contains all settings required to run the DCN-SW API.

The starting point for using the DCN-SW API is the DcnApi class, located in the Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll assembly.

This class is to be used for retrieving the interface to the actual DCN-SW API, which implements the IApi interface. This interface acts as the main entry point to initialize and terminate the DCN-SW API functionality. Initializing the DCN-SW API will establish a link to the DCN-SW server.

The IApi interface provides events and properties to receive notifications and query the state of the DCN-SW API. The AvailabilityChange event can be used to register for the availability update notification of the DCN-SW API. When the DCN-SW API is indicated available, a connection with the DCN-SW server is available and the user is logged on.

The following derived versions of the IApi interface are available for use by programmers:

Type of interface | Description
IConfigApi | Provides an interface for performing limited configuration.
IControlApi | Provides an interface for performing limited control.

Examples

To retrieve a reference to a DCN-SW API interface for configuration purposes and initialize a connection to the DCN-SW server:
Copy image Copy Code
using Bosch.Dcn.Ecpc.Client.Api.Interfaces;
using Bosch.Dcn.Ecpc.Client.Api.Logic;

class Example
{
    public static void Main()
    {
        IConfigApi configApi = DcnApi.ConfigApi;

        configApi.AvailabilityChange += new EventHandler(OnAvailabilityChange);
        configApi.AuthorizationChange += new EventHandler(OnAuthorizationChange);
        if (API_ERROR.NONE == configApi.Initialize("tcp://localhost:9461",
        "SomeUser", "SomePassword"))
        {
            // Ok!
        }
        else
        {
            // Error...
        }
    }

    private void OnAvailabilityChange(object sender, EventArgs args)
    {
        // Handle the availability change here...the DCN-SW API has established
        // connection to DCN-SW server
    }

    private void OnAuthorizationChange(object sender, EventArgs args)
    {
        IConfigApi configApi = DcnApi.ConfigApi;

        if (configApi.IsConfigAllowed)
        {
            // (Re-)gained authorization to use the configuration interface...
            // Resync with configuration data on DCN-SW server...
        }
        else
        {
            //  Cannot use the configuration interface (anymore)...
        }
    }
}

To call the IApi function in a non-blocking manner, use the .NET Asynchronous Programming Model.

Examples

Copy image Copy Code
using Bosch.Dcn.Ecpc.Client.Api.Interfaces;
using Bosch.Dcn.Ecpc.Client.Api.Logic;

class Example
{
    public static void Main()
    {
        IConfigApi configApi = DcnApi.ConfigApi;

        configApi.AvailabilityChange += new EventHandler(OnAvailabilityChange);
        configApi.AuthorizationChange += new EventHandler(OnAuthorizationChange);

        AsyncInitializer initializer = new AsyncInitializer(configApi.Initialize);
        IAsyncResult result = initializer.BeginInvoke("localhost", "SomeUser", "SomePassword",
            new AsyncCallback(InitializerCallback), initializer);
    }

    private delegate API_ERROR AsyncInitializer(string username, string password);

    private void InitializerCallback(IAsyncResult ar)
    {
        AsyncInitializer initializer = ar.AsyncState as AsyncInitializer;
        API_ERROR returnValue = initializer.EndInvoke(ar);

        if (API_ERROR.NONE == returnValue)
        {
            // Ok!
        }
        else
        {
            // Error...
        }
    }

    private void OnAvailabilityChange(object sender, EventArgs args)
    {
        // Handle the availability change here...
    }

    private void OnAuthorizationChange(object sender, EventArgs args)
    {
        // Handle the authorization update here...
    }
}

Examples

To retrieve a reference to a DCN-SW API interface for operational purposes and initialize a connection to the DCN-SW server:
Copy image Copy Code
using Bosch.Dcn.Ecpc.Client.Api.Interfaces;
using Bosch.Dcn.Ecpc.Client.Api.Logic;

class Example
{
    public static void Main()
    {
        IControlApi controlApi = DcnApi.ControlApi;

        controlApi.AvailabilityChange += new EventHandler(OnAvailabilityChange);
        controlApi.AuthorizationChange += new EventHandler(OnAuthorizationChange);
        if (API_ERROR.NONE == controlApi.Initialize("tcp://localhost:9461",
        "SomeUser", "SomePassword"))
        {
            // Ok!
        }
        else
        {
            // Error...
        }
    }

    private void OnAvailabilityChange(object sender, EventArgs args)
    {
        // Handle the availability change here...the DCN-SW API has established
        // connection to DCN-SW server
    }

    private void OnAuthorizationChange(object sender, EventArgs args)
    {
        IControlApi controlApi = DcnApi.ControlApi;

        if (controlApi.IsControlAllowed)
        {
            // (Re-)gained authorization to use the operational interface...
            // Resync with operational data on DCN-SW server...
        }
        else
        {
            //  Cannot use the operational interface (anymore)...
        }
    }
}

To call the IApi function in a non-blocking manner, use the .NET Asynchronous Programming Model.

Examples

Copy image Copy Code
using Bosch.Dcn.Ecpc.Client.Api.Interfaces;
using Bosch.Dcn.Ecpc.Client.Api.Logic;

class Example
{
    public static void Main()
    {
       IControlApi controlApi = DcnApi.ControlApi;

        controlApi.AvailabilityChange += new EventHandler(OnAvailabilityChange);
        controlApi.AuthorizationChange += new EventHandler(OnAuthorizationChange);

        AsyncInitializer initializer = new AsyncInitializer(controlApi.Initialize);
        IAsyncResult result = initializer.BeginInvoke("localhost", "SomeUser", "SomePassword",
            new AsyncCallback(InitializerCallback), initializer);
    }

    private delegate API_ERROR AsyncInitializer(string username, string password);

    private void InitializerCallback(IAsyncResult ar)
    {
        AsyncInitializer initializer = ar.AsyncState as AsyncInitializer;
        API_ERROR returnValue = initializer.EndInvoke(ar);

        if (API_ERROR.NONE == returnValue)
        {
            // Ok!
        }
        else
        {
            // Error...
        }
    }

    private void OnAvailabilityChange(object sender, EventArgs args)
    {
        // Handle the availability change here...
    }

    private void OnAuthorizationChange(object sender, EventArgs args)
    {
        // Handle the authorization update here...
    }
}

Classes

 | Class | Description
Public class | BoothSettingsEventArgs | Provides data for a BoothSettingsUpdate event.
Public class | ChairmanPriorityListUpdatedEventArgs | Placeholder to contain the information about the active prios.
Public class | ChannelDefinitionDataChangedEventArgs | Provides data for a ChannelDefinitionUpdate event.
Public class | ConfigChangedEventArgs | Base container for holding the list of changed ID's in configuration events.
Public class | CountEventArgs | Placeholder to contain the count value as argument.
Public class | DelegateDataChangedEventArgs | Provides data for a DelegateStore, DelegateUpdate or DelegateDeletion event.
Public class | DelegateRegistrationEventArgs | Provides data for a DelegateRegistration, DelegateRegistrationUpdate or DelegateUnregistration event.
Public class | DeskSettingsEventArgs | Provides data for a DeskSettingsUpdate event.
Public class | DISCUSSION_INFO | The settings of an current session's discussion.
Public class | DiscussionControlEventArgs | Container for holding the configuration- and service-ID of the discussion service triggering the event.
Public class | DiscussionSettingsEventArgs | Container for holding the configuration- and service-ID of the discussion service triggering the event.
Public class | GroupTimerControlEventArgs | Placeholder to contain the session group timer delegate event argument
Public class | LanguageDataChangedEventArgs | Provides data for a LanguageStore, LanguageUpdate or LanguageDeletion event.
Public class | MeetingControlEventArgs | Container for holding the configuration- and service-ID of the meeting or session service triggering the event.
Public class | MeetingDataChangedEventArgs | Provides data for a MeetingStore, MeetingUpdate or MeetingDeletion event.
Public class | MeetingGroupDataChangedEventArgs | Provides data for a MeetingGroupStore, MeetingGroupUpdate or MeetingGroupDeletion event.
Public class | MeetingInterpretationDataChangedEventArgs | Provides data for a MeetingInterpretationUpdate event.
Public class | NotebookerControlEventArgs | Placeholder to contain the notebooker delegate event argument.
Public class | OnOffEventArgs | Placeholder to contain the on/off setting as argument.
Public class | RequestDataChangedEventArgs | Provides data for a RequestStore, RequestUpdate or RequestDeletion event.
Public class | SessionDataChangedEventArgs | Provides data for a SessionStore, SessionUpdate or SessionDeletion event.
Public class | TimeLeftControlEventArgs | Placeholder to contain the speaker's time left event argument
Public class | TimerToHoldSpeakSlowlyRequestDataChangedEventArgs | Provides data for a TimerToHoldSpeakSlowlyRequestUpdate event.
Public class | UseOfHelpSignallingDataChangedEventArgs | Provides data for a UseOfHelpSignallingUpdate event.
Public class | VoteDataChangedEventArgs | Provides data for a VoteStore, VoteUpdate or VoteDeletion event.
Public class | VoteTemplateDataChangedEventArgs | Provides data for a VoteTemplateStore, VoteTemplateUpdate or VoteTemplateDeletion event.
Public class | VotingTimerControlEventArgs | Placeholder to contain the vote time left event argument

Structures

 | Structure | Description
Public structure | ADHOC_VOTING_SETTINGS | Adhoch voting settings.
Public structure | BOOTH_INFO | Represents a container holding all information of a booth within a meeting.
Public structure | DELEGATE | Contains delegateId of current meeting.
Public structure | DELEGATE_INFO | Represents a container holding all information of a delegate.
Public structure | DESK_INFO | Represents a container holding all information of a desk within a meeting.
Public structure | INTERPRETATION_LANGUAGE_INFO | Represents a container holding all information of a interpretation language
Public structure | LANGUAGE_INFO | Depricated
Public structure | MEETING_GROUP_INFO | Represents a container holding all information of a meeting group.
Public structure | MEETING_INFO | Represents a container holding all information of a meeting.
Public structure | MEETING_INTERPRETATION_INFO | Represents a container holding all information of a desk within a meeting.
Public structure | NOTEBOOKER_INFO | Represents a delegate notebooker entry in the notebook.
Public structure | PARTICIPANT | Contains the participant information as in the discussion activity with current speech time limitation settings.
Public structure | PARTICIPATION_INFO | Represents a container containing the information required to register a delegate as participant to a meeting.
Public structure | SEAT_ASSIGNMENT | Defines a container defining the seating arrangements in the rooms used in the meeting.
Public structure | SEAT_MICROPHONE_STATUS | Contains the status of microphone.
Public structure | SESSION_GROUP_TIMER | Contains the group timers of the session.
Public structure | SESSION_INFO | Represents a container describing a session of a meeting.
Public structure | SPEAKER_TIMELEFT_INFO | Contains the participant's time left
Public structure | VOTE_INFO | Represents a container holding all information of a vote.
Public structure | VOTE_TEMPLATE_INFO | Represents a container holding all information of a vote template.
Public structure | VOTING_TIMER_INFO | Contains the voting time left

Interfaces

Interface Description
Public interface IApi
Base interface for the DCN-SW API, used to manage the connection to the DCN-SW server. See also IApi Members
Public interface IApiEvents
Interface defining the events on the base interface for the DCN-SW API. See also IApiEvents Members
Public interface IConfigApi
This interface represents the main entrypoint for performing limited configuration functionality through the DCN-SW API.

To start using the configuration interface, some understanding is required regarding the structuring of meetings as used in the DCN-SW application software, and the configuration items in general.

To configure meetings, the following should be understood:

  • The DCN-SW application software supports preparation of multiple meetings, of which one can be active.
  • Each meeting has delegates assigned, which are defined in the configuration and assigned as participant to the meeting in two separate step. When assigned to a meeting, the delegate can be assigned to a seat in the room where the meeting is to take place, or is taking place when active.
  • Each meeting consists of one or more configurable sessions, where each session represents an item on the agenda of the meeting. The list of sessions in fact represents the agenda of the meeting.
  • Each session can have a voting script prepared, where each vote in the script is based on a predefind vote template.

All configurable items used by the DCN-SW application software are identified with a unique identifier. This means that e.g. delegates, meetings, meeting groups, seats in a room, sessions, vote templates, votes in a voting script etc., are uniquely identified.

  • In order to retrieve the meetings and sessions that have been prepared and available in the system, use the IMeetingDataApi interface.
  • To find out which meeting groups have been defined to assign delegates to, use the IMeetingGroupDataApi interface.
  • To find out which display-, native- and spoken-languages are supported for delegates, use the ILanguageDataApi interface.
  • To define delegates and assign them to a meeting, use the IDelegateDataApi interface.
  • To retrieve the vote templates defined in the system and use them to prepare a voting script for a session, use the IVoteDataApi interface.

The interfaces as mentioned above, can be retrieved from this IConfigApi interface.

Each configurable item from the configuration, defines a set of events to register for receiving change notifications on the configurable items. Each individual configurable item provides events for:

  • Receiving store notifications. These notifications are received when one or more configuration items are newly added to the configuration.
  • Receiving update notifications. These notifications are received when one or more existing configuration items are updated in the configuration.
  • Receiving delete notifications. These notifications are received when one or more existing configuration items are removed from the configuration.

The event arguments for the events contain the identifier(s) of the configurable items stored, updated or deleted.

The amount of processing in the eventhandler function registered for an event should be kept to a minimum!

See also IConfigApi Members

Public interface IControlApi
Interface representing the main entrypoint for performing limited control functionality through the DCN-SW API.

To start using the operational interface, some understanding is required regarding the structuring of meetings as used in the DCN-SW application software, and the operational items in general.

To control meetings, the following should be understood:

  • In order to control functionality of meetings IsControlAllowed should be set to true.
  • In order to retrieve the meetings and sessions that have been prepared and available in the system, use the IMeetingDataApi interface.
  • After retrieval of meetings, select meetingid to start meeting. Only one meeting at a time can be active. If meeting is already running, trying to run same or other meeting will return with API_ERROR.
  • Each meeting consists of one or more operational sessions, where each session represents an item on the agenda of the meeting. After retrieval of all sessions of a meeting select sessionid to start session.Trying to start session when meeting is not running or trying to start a session that is already runnning or trying to stop session which is not running will return with API_ERROR. If one session is already running,trying to start another session will stop the session that is running and starts selected session.

All operational items used by the DCN-SW application software are identified with a unique identifier. This means that e.g. delegates, meetings,sessions etc., are uniquely identified.

  • In order to operate the meetings and sessions that have been prepared and available in the system, use the IMeetingApi interface.
  • In order to operate the discussion settings for meeting/sessions or to perform operations on participants and seats(i.e. Insert Request, Append Request, Cancel Request etc) or to retrieve request, comment request, speaker, notebooker list ,to set chairman priority and get chairman priority, use the IDiscussionApi interface.
  • In order to operate the voting(i.e. start, stop, hold, resume, select etc) that have been prepared and available in the system, use the IVoteApi interface.
  • In order to control the master volume, master mute, use the IDcnSystemApi IDcnSystemApi interface.

The interfaces as mentioned above, can be retrieved from this IControlApi interface.

Each operational item from the operation, defines a set of events to register for receiving change notifications on the operational items. Each individual operational item provides events for:

  • Receiving start notifications. These notifications are received when one or more operational items are started.
  • Receiving stop notifications. These notifications are received when one or more existing operational items are stopped.

The event arguments for the events contain the identifier(s) of the operational items started or stopped.

The amount of processing in the eventhandler function registered for an event should be kept to a minimum!

See also IControlApi Members

Public interface IDcnSystemApi
Interface that can be used to control and retrieve Dcn System master volume and mute Settings
Public interface IDcnSystemApiEvents
Interface defining events for the DCN system master volume and master mute settings
Public interface IDelegateDataApi
Interface that is to be used to add, remove, change delegate information and (un)register delegates as participant to a meeting. See also IDelegateDataApi Members
Public interface IDelegateDataApiEvents
Interface defining all events for the delegate API data-interface. See also IDelegateDataApiEvents Members
Public interface IDiscussionApi
Interface that can be used to operate discussion activities during a session of a meeting. See also IDiscussionApi Members
Public interface IDiscussionApiEvents
Interface defining all events for the discussion API control-interface. See also IDiscussionApiEvents Members
Public interface ILanguageDataApi
Interface that can be used to retrieve the supported languages available in the system. See also ILanguageDataApi Members
Public interface ILanguageDataApiEvents
Interface defining all events for the languages API data-interface. See alsoILanguageDataApiEvents Members
Public interface IMeetingApi
Interface defining all events for the meeting API control-interface. See also IMeetingApi Members
Public interface IMeetingApiEvents
Interface defining all events for the meeting API control-interface. See also IMeetingApiEvents Members
Public interface IMeetingDataApi
Interface that can be used to retrieve the meetings available in the system. See also IMeetingDataApi Members
Public interface IMeetingDataApiEvents
Interface defining all events for the meetings API data-interface. See also IMeetingDataApiEvents Members
Public interface IMeetingGroupDataApi
Interface that can be used to retrieve the meeting groups available in the system. See also IMeetingGroupDataApi Members
Public interface IMeetingGroupDataApiEvents
Interface defining all events for the meeting groups API data-interface. See also IMeetingGroupDataApiEvents Members
Public interface ISystemDataApi
Interface that is to be used to configure system data. See also ISystemDataApi Members
Public interface ISystemDataApiEvents
Interface defining all events for the votes API data-interface. See also ISystemDataApiEvents Members
Public interface IVoteApi
Interface that can be used to control and retrieve voting related operational state. See also IVoteApi Members
Public interface IVoteApiEvents
Interface defining all events for the voting API control-interface. See also IVoteApiEvents Members
Public interface IVoteDataApi
Interface that is to be used to add, remove, change voting temlates and voting scripts to a session of a meeting. See also IVoteDataApi Members
Public interface IVoteDataApiEvents
Interface defining all events for the votes API data-interface. See also IVoteDataApiEvents Members

Delegates

 | Delegate | Description
Public delegate | GroupTimerControlEventHandler | Event handler for a session group timer change events.
Public delegate | TimeLeftControlEventHandler | Event handler for a speaker's time left change events.
Public delegate | VotingTimerControlEventHandler | Event handler for a voting time left change events.

Enumerations

 | Enumeration | Description
Public enumeration | API_ERROR | Defines all errors supported as return values in the DCN-SW API's interface.
Public enumeration | ChannelType | Channel types for definition of the channel configuration
Public enumeration | InterlockMode | Modes for the interlock setting within and between booths
Public enumeration | MicrophoneStatus | status of Microphone
Public enumeration | VotingAnswerSetType | Voting answer set type
Public enumeration | WEB_STREAMING_LICENSE | Modes for the webcast internet streaming license.
Copyright (c) 2014 Bosch Security Systems B.V.4.30.0011


ADHOC_VOTING_SETTINGS Structure

ADHOC_VOTING_SETTINGS Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Adhoch voting settings.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Structure ADHOC_VOTING_SETTINGS
C#
[SerializableAttribute]
[ObfuscationAttribute]
public struct ADHOC_VOTING_SETTINGS

See Also

ADHOC_VOTING_SETTINGS Members
Bosch.Dcn.Ecpc.Client.Api.Interfaces Namespace


ADHOC_VOTING_SETTINGS Members

ADHOC_VOTING_SETTINGS Members
ADHOC_VOTING_SETTINGS Structure Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ADHOC_VOTING_SETTINGS type exposes the following members.

Constructors

 | Name | Description
Public method | ADHOC_VOTING_SETTINGS | contstructor

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Properties

 | Name | Description
Public property | AnswerSet | Adhoc voting answerset
Public property | Subject | Adhoc voting subject.
Public property | VotingName | Adhoc voting name
Public property | VotingNumber | Adhoc voting number
Public property | VotingTemplateId | Adhoc voting template id.

See Also

ADHOC_VOTING_SETTINGS Structure


ADHOC_VOTING_SETTINGS Constructor

ADHOC_VOTING_SETTINGS Constructor
ADHOC_VOTING_SETTINGS Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
contstructor

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    AnswerSet As VotingAnswerSetType, _
    Subject As String, _
    VotingName As String, _
    VotingNumber As String, _
    VotingTemplateId As Integer _
)
C#
public ADHOC_VOTING_SETTINGS(
    VotingAnswerSetType AnswerSet,
    string Subject,
    string VotingName,
    string VotingNumber,
    int VotingTemplateId
)

Parameters

AnswerSet
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VotingAnswerSetType
Adhoc voting answerset
Subject
Type: System..::..String
Adhoc voting subject
VotingName
Type: System..::..String
Adhoc voting name
VotingNumber
Type: System..::..String
Adhoc voting number
VotingTemplateId
Type: System..::..Int32
Adhoc voting template id

See Also

ADHOC_VOTING_SETTINGS Structure


ADHOC_VOTING_SETTINGS Methods

ADHOC_VOTING_SETTINGS Methods
ADHOC_VOTING_SETTINGS Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ADHOC_VOTING_SETTINGS type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

ADHOC_VOTING_SETTINGS Structure


ADHOC_VOTING_SETTINGS Properties

ADHOC_VOTING_SETTINGS Properties
ADHOC_VOTING_SETTINGS Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ADHOC_VOTING_SETTINGS type exposes the following members.

Properties

 | Name | Description
Public property | AnswerSet | Adhoc voting answerset
Public property | Subject | Adhoc voting subject.
Public property | VotingName | Adhoc voting name
Public property | VotingNumber | Adhoc voting number
Public property | VotingTemplateId | Adhoc voting template id.

See Also

ADHOC_VOTING_SETTINGS Structure


AnswerSet Property

ADHOC_VOTING_SETTINGS..::..AnswerSet Property
ADHOC_VOTING_SETTINGS Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Adhoc voting answerset

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property AnswerSet As VotingAnswerSetType
    Get
    Set
C#
public VotingAnswerSetType AnswerSet { get; set; }

See Also

ADHOC_VOTING_SETTINGS Structure


Subject Property

ADHOC_VOTING_SETTINGS..::..Subject Property
ADHOC_VOTING_SETTINGS Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Adhoc voting subject.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property Subject As String
    Get
    Set
C#
public string Subject { get; set; }

See Also

ADHOC_VOTING_SETTINGS Structure


VotingName Property

ADHOC_VOTING_SETTINGS..::..VotingName Property
ADHOC_VOTING_SETTINGS Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Adhoc voting name

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property VotingName As String
    Get
    Set
C#
public string VotingName { get; set; }

See Also

ADHOC_VOTING_SETTINGS Structure


VotingNumber Property

ADHOC_VOTING_SETTINGS..::..VotingNumber Property
ADHOC_VOTING_SETTINGS Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Adhoc voting number

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property VotingNumber As String
    Get
    Set
C#
public string VotingNumber { get; set; }

See Also

ADHOC_VOTING_SETTINGS Structure


VotingTemplateId Property

ADHOC_VOTING_SETTINGS..::..VotingTemplateId Property
ADHOC_VOTING_SETTINGS Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Adhoc voting template id.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property VotingTemplateId As Integer
    Get
    Set
C#
public int VotingTemplateId { get; set; }

See Also

ADHOC_VOTING_SETTINGS Structure


API_ERROR Enumeration

API_ERROR Enumeration
See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Defines all errors supported as return values in the DCN-SW API's interface.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Enumeration API_ERROR
C#
[ObfuscationAttribute]
public enum API_ERROR

Members

Member name | Value | Description
NONE | 0 | No error.
ALREADY_INITIALIZED | -1 | Initialization of the DCN-SW API not done, DCN-SW API already initialized.
NOT_INITIALIZED | -2 | Cannot perform request, DCN-SW API not initialized.
SETUP_LINK_FAILED | -3 | DCN-SW API failed to setup connection to DCN-SW server and logon user.
NOT_AVAILABLE | -4 | Cannot perform request, the DCN-SW API is not available for use.
NO_AUTHORIZATION | -5 | User is unknown on DCN-SW server, does not have the required access rights to perform request or the connection between DCN-SW server and Master-CCU of the DCN (Next Generation) system is unavailable.
RETRIEVE_FAILED | -10 | Retrieving the requested configuration data from DCN-SW server failed.
STORE_FAILED | -11 | Storing the supplied configuration data on the DCN-SW server failed.
UPDATE_FAILED | -12 | Updating the supplied configuration data on the DCN-SW server failed.
DELETE_FAILED | -13 | Deleting the supplied configuration data on the DCN-SW server failed.
ASSIGNMENT_FAILED | -14 | (Un)assigning an ID-card code to a delegate on the DCN-SW server failed.
REGISTRATION_FAILED | -15 | Registering a delegate for a meeting on the DCN-SW server failed.
NO_CARD_DEVICE | -16 | Producing a card is not possible, card production device not available.
NO_CARD_INSERTED | -17 | Cannot produce card, no card inserted in card production device.
CARD_PRODUCTION_FAILED | -18 | Failure producing card.
CARD_READ_FAILED | -19 | Failure reading inserted card.
OUT_OF_RANGE | -20 | Channel number out of range of available system channels.
ALREADY_ACTIVE | -50 | Cannot start the meeting, session or vote since already active.
NOT_ACTIVE | -51 | Cannot stop the meeting, session or vote since its not active.
START_FAILED | -52 | Cannot start meeting, session or vote on DCN-SW server.
STOP_FAILED | -53 | Cannot stop meeting, session or vote on DCN-SW server.
SUMMON_FOR_VOTE_FAILED | -54 | Summon for vote failed.
UNKNOWN_MEETING | -55 | Unknown Meeting id or database is disconnected.
INCORRECT_MODE | -56 | Incorrect mode for selected functionality.
PARTICIPANT_NOT_ASSIGNED | -57 | Participant is not assigned to seat.
INVALID_PARAMETER | -58 | Parameter is invalid.
UNKNOWN_SESSION | -59 | Unknown Session id or database is disconnected.
INVALID_PARTICIPANT_FOR_MEETING | -60 | Delegate is not assigned as participant for meeting.
REQUEST_QUEUE_NOT_ENABLED | -61 | In Discussion settings Allow requests is set to false.
VOICE_MODE_CANNOT_BE_SET | -62 | If interpretaion channels greater than 26 and try to set voice mode.
EXCEED_MAX_REQUEST_COUNT | -63 | When requesting seat/participant count is more than no. of max request count.
INVALID_ACTIVE_MIC_COUNT | -64 | Number of Open Mic [NOM] range depends on the CCU firmware version. NOM range for CCU firmware version 4.2 and above is 1 - 25. NOM range for CCU firmware version below 4.2 is 1 - 4. NOM count range should be within 1 - 4 / 1 - 25. NOM is 1 for Response, 2 - 4 for Voice mode.
INVALID_PRIORITY_TONE | -65 | Priority tone range should be within 1 - 4. 1 - Priority Tone Off 2 - Priority Tone Type 1 3 - Priority Tone Type 2 4 - Priority Tone Type 3.
INVALID_MAX_REQUEST | -66 | Max request count should be within the range of 0 - 100.
INVALID_MIC_CONTROL_MODE | -67 | Mic control mode range should be within 1 - 6. 1 - Mic Control Mode Open 2 - Mic Control Mode Override 3 - Mic Control Mode Operator 4 - Mic Control Mode Response 5 - Mic Control Mode Voice 6 - Mic Control Mode Push To Talk.
NOT_IN_REQUEST_LIST | -68 | When delegate or seat is not requesting to speak.
UNKNOWN_MEETING_GROUP | -69 | When Meeting group is unknown.
INVALID_SEAT_ID | -70 | When seat is master ccu.
HOLD_FAILED | -71 | Cannot put the voting on HOLD
RESUME_FAILED | -72 | Cannot RESUME the voting that is on HOLD
NOT_ON_HOLD | -73 | Cannot RESUME the voting that is not on HOLD
ON_HOLD | -74 | Cannot put the vote on hold as it is already on HOLD
UNKNOWN_VOTING | -75 | When Voting is unknown.
SELECT_FAILED | -76 | Cannot Select a vote.
COPY_FAILED | -77 | Cannot copy the voting
INVALID_MAX_RESPONSE_REQUEST | -78 | Max response request range is 1 - 25 for DCN-CCU2 and DCN-CCUB2.
INVALID_RESPONSE_LENGTH_CCU | -79 | Response list length cannot be changed for DCN-CCU, DCN-CCUB or DCN-NCO. It can only be changed for DCN-CCU2 and DCN-CCUB2.
ERROR | -100 | An internal DCN-SW API-error occurred calling the function.

See Also

Bosch.Dcn.Ecpc.Client.Api.Interfaces Namespace
Copyright (c) 2014 Bosch Security Systems B.V.4.30.0011


BOOTH_INFO Structure

BOOTH_INFO Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Represents a container holding all information of a booth within a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Structure BOOTH_INFO
C#
[ObfuscationAttribute]
public struct BOOTH_INFO

See Also

BOOTH_INFO Members


BOOTH_INFO Members

BOOTH_INFO Members
BOOTH_INFO Structure Methods Operators Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The BOOTH_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two BOOTH_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a BOOTH_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Operators

Name | Description
Equality | Checks the equality of two BOOTH_INFO structures.
Inequality | Checks the non-equality of two BOOTH_INFO structures.

Fields

 | Name | Description
Public field | Autorelay | Indicates the Autorelay for booth.
Public field | DeskIds | Desk identifications which are presented in this booth.

See Also

BOOTH_INFO Structure


BOOTH_INFO Fields

BOOTH_INFO Fields
BOOTH_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The BOOTH_INFO type exposes the following members.

Fields

 | Name | Description
Public field | Autorelay | Indicates the Autorelay for booth.
Public field | DeskIds | Desk identifications which are presented in this booth.

See Also

BOOTH_INFO Structure


Autorelay Field

BOOTH_INFO..::..Autorelay Field
BOOTH_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates the Autorelay for booth.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Autorelay As Boolean
C#
public bool Autorelay

See Also

BOOTH_INFO Structure


DeskIds Field

BOOTH_INFO..::..DeskIds Field
BOOTH_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Desk identifications which are presented in this booth.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public DeskIds As Integer()
C#
public int[] DeskIds

See Also

BOOTH_INFO Structure


BOOTH_INFO Methods

BOOTH_INFO Methods
BOOTH_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The BOOTH_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two BOOTH_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a BOOTH_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

BOOTH_INFO Structure


Equals Method

BOOTH_INFO..::..Equals Method
BOOTH_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Determines whether two BOOTH_INFO instances are equal.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::..Object
The BOOTH_INFO to compare with the current Object.

Return Value

true if the specified BOOTH_INFO is equal to the current Object; otherwise, false.

See Also

BOOTH_INFO Structure


GetHashCode Method

BOOTH_INFO..::..GetHashCode Method
BOOTH_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Serves as a hash function for a BOOTH_INFO type.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current BOOTH_INFO.

See Also

BOOTH_INFO Structure


BOOTH_INFO Operators

BOOTH_INFO Operators
BOOTH_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The BOOTH_INFO type exposes the following members.

Operators

Name | Description
Equality | Checks the equality of two BOOTH_INFO structures.
Inequality | Checks the non-equality of two BOOTH_INFO structures.

See Also

BOOTH_INFO Structure


Equality Operator

BOOTH_INFO..::..Equality Operator
BOOTH_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the equality of two BOOTH_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    a As BOOTH_INFO, _
    b As BOOTH_INFO _
) As Boolean
C#
public static bool operator ==(
    BOOTH_INFO a,
    BOOTH_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..BOOTH_INFO
The first BOOTH_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..BOOTH_INFO
The next BOOTH_INFO to compare.

Return Value

true if the specified BOOTH_INFO structures are the same; otherwise, false.

See Also

BOOTH_INFO Structure


Inequality Operator

BOOTH_INFO..::..Inequality Operator
BOOTH_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the non-equality of two BOOTH_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    a As BOOTH_INFO, _
    b As BOOTH_INFO _
) As Boolean
C#
public static bool operator !=(
    BOOTH_INFO a,
    BOOTH_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..BOOTH_INFO
The first BOOTH_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..BOOTH_INFO
The next BOOTH_INFO to compare.

Return Value

true if the specified BOOTH_INFO structures are not the same; otherwise, false.

See Also

BOOTH_INFO Structure


BoothSettingsEventArgs Class

BoothSettingsEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Provides data for a BoothSettingsUpdate event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class BoothSettingsEventArgs _
    Inherits ConfigChangedEventArgs
C#
[ObfuscationAttribute]
public class BoothSettingsEventArgs : ConfigChangedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ConfigChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..BoothSettingsEventArgs

See Also

BoothSettingsEventArgs Members


BoothSettingsEventArgs Members

BoothSettingsEventArgs Members
BoothSettingsEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The BoothSettingsEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | BoothSettingsEventArgs()()()() | Default constructor...
Public method | BoothSettingsEventArgs(array<Int32>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)

See Also

BoothSettingsEventArgs Class


BoothSettingsEventArgs Constructor

BoothSettingsEventArgs Constructor
BoothSettingsEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | BoothSettingsEventArgs()()()() | Default constructor...
Public method | BoothSettingsEventArgs(array<Int32>[]()[][]) | Constructor...

See Also

BoothSettingsEventArgs Class
BoothSettingsEventArgs Members


BoothSettingsEventArgs Constructor

BoothSettingsEventArgs Constructor
BoothSettingsEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Default constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BoothSettingsEventArgs()

See Also

BoothSettingsEventArgs Class
BoothSettingsEventArgs Overload


BoothSettingsEventArgs Constructor (Int32[])

BoothSettingsEventArgs Constructor (array<Int32>[]()[][])
BoothSettingsEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    boothIds As Integer() _
)
C#
public BoothSettingsEventArgs(
    int[] boothIds
)

Parameters

boothIds
Type: array< System..::..Int32 >[]()[][]
The identifiers of the booth settings changed. Use ConfigIds to retrieve.

See Also

BoothSettingsEventArgs Class
BoothSettingsEventArgs Overload


BoothSettingsEventArgs Methods

BoothSettingsEventArgs Methods
BoothSettingsEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The BoothSettingsEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

BoothSettingsEventArgs Class


BoothSettingsEventArgs Properties

BoothSettingsEventArgs Properties
BoothSettingsEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The BoothSettingsEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)

See Also

BoothSettingsEventArgs Class


ChairmanPriorityListUpdatedEventArgs Class

ChairmanPriorityListUpdatedEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Placeholder to contain the information about the active prios.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class ChairmanPriorityListUpdatedEventArgs _
    Inherits EventArgs
C#
[ObfuscationAttribute]
public class ChairmanPriorityListUpdatedEventArgs : EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ChairmanPriorityListUpdatedEventArgs

See Also

ChairmanPriorityListUpdatedEventArgs Members


ChairmanPriorityListUpdatedEventArgs Members

ChairmanPriorityListUpdatedEventArgs Members
ChairmanPriorityListUpdatedEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ChairmanPriorityListUpdatedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ChairmanPriorityListUpdatedEventArgs | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Keyprio | Number of units.
Public property | Virtualkeyprio | Number of virtual units.

See Also

ChairmanPriorityListUpdatedEventArgs Class


ChairmanPriorityListUpdatedEventArgs Constructor

ChairmanPriorityListUpdatedEventArgs Constructor
ChairmanPriorityListUpdatedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    kprio As Integer, _
    vkeyprio As Integer _
)
C#
public ChairmanPriorityListUpdatedEventArgs(
    int kprio,
    int vkeyprio
)

Parameters

kprio
Type: System..::..Int32
Number of units.
vkeyprio
Type: System..::..Int32
Number of virtual units.

See Also

ChairmanPriorityListUpdatedEventArgs Class


ChairmanPriorityListUpdatedEventArgs Methods

ChairmanPriorityListUpdatedEventArgs Methods
ChairmanPriorityListUpdatedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ChairmanPriorityListUpdatedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ChairmanPriorityListUpdatedEventArgs Class


ChairmanPriorityListUpdatedEventArgs Properties

ChairmanPriorityListUpdatedEventArgs Properties
ChairmanPriorityListUpdatedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ChairmanPriorityListUpdatedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Keyprio | Number of units.
Public property | Virtualkeyprio | Number of virtual units.

See Also

ChairmanPriorityListUpdatedEventArgs Class


Keyprio Property

ChairmanPriorityListUpdatedEventArgs..::..Keyprio Property
ChairmanPriorityListUpdatedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Number of units.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property Keyprio As Integer
    Get
    Set
C#
public int Keyprio { get; set; }

See Also

ChairmanPriorityListUpdatedEventArgs Class


Virtualkeyprio Property

ChairmanPriorityListUpdatedEventArgs..::..Virtualkeyprio Property
ChairmanPriorityListUpdatedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Number of virtual units.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property Virtualkeyprio As Integer
    Get
    Set
C#
public int Virtualkeyprio { get; set; }

See Also

ChairmanPriorityListUpdatedEventArgs Class


ChannelDefinitionDataChangedEventArgs Class

ChannelDefinitionDataChangedEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Provides data for a ChannelDefinitionUpdate event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class ChannelDefinitionDataChangedEventArgs _
    Inherits EventArgs
C#
[ObfuscationAttribute]
public class ChannelDefinitionDataChangedEventArgs : EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ChannelDefinitionDataChangedEventArgs

See Also

ChannelDefinitionDataChangedEventArgs Members


ChannelDefinitionDataChangedEventArgs Members

ChannelDefinitionDataChangedEventArgs Members
ChannelDefinitionDataChangedEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ChannelDefinitionDataChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ChannelDefinitionDataChangedEventArgs()()()() | Default Constructor...
Public method | ChannelDefinitionDataChangedEventArgs(array<ChannelType>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ChannelDefinition | The identifiers for the channels having changes to their definition applied.

See Also

ChannelDefinitionDataChangedEventArgs Class


ChannelDefinitionDataChangedEventArgs Constructor

ChannelDefinitionDataChangedEventArgs Constructor
ChannelDefinitionDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | ChannelDefinitionDataChangedEventArgs()()()() | Default Constructor...
Public method | ChannelDefinitionDataChangedEventArgs(array<ChannelType>[]()[][]) | Constructor...

See Also

ChannelDefinitionDataChangedEventArgs Class
ChannelDefinitionDataChangedEventArgs Members


ChannelDefinitionDataChangedEventArgs Constructor

ChannelDefinitionDataChangedEventArgs Constructor
ChannelDefinitionDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Default Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChannelDefinitionDataChangedEventArgs()

See Also

ChannelDefinitionDataChangedEventArgs Class
ChannelDefinitionDataChangedEventArgs Overload


ChannelDefinitionDataChangedEventArgs Constructor (ChannelType[])

ChannelDefinitionDataChangedEventArgs Constructor (array<ChannelType>[]()[][])
ChannelDefinitionDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    channelDefinition As ChannelType() _
)
C#
public ChannelDefinitionDataChangedEventArgs(
    ChannelType[] channelDefinition
)

Parameters

channelDefinition
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ChannelType >[]()[][]
The identifiers of the Channel Definition

See Also

ChannelDefinitionDataChangedEventArgs Class
ChannelDefinitionDataChangedEventArgs Overload


ChannelDefinitionDataChangedEventArgs Methods

ChannelDefinitionDataChangedEventArgs Methods
ChannelDefinitionDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ChannelDefinitionDataChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ChannelDefinitionDataChangedEventArgs Class


ChannelDefinitionDataChangedEventArgs Properties

ChannelDefinitionDataChangedEventArgs Properties
ChannelDefinitionDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ChannelDefinitionDataChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ChannelDefinition | The identifiers for the channels having changes to their definition applied.

See Also

ChannelDefinitionDataChangedEventArgs Class


ChannelDefinition Property

ChannelDefinitionDataChangedEventArgs..::..ChannelDefinition Property
ChannelDefinitionDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The identifiers for the channels having changes to their definition applied.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChannelDefinition As ChannelType()
    Get
C#
public ChannelType[] ChannelDefinition { get; }

Field Value

See ChannelType.

See Also

ChannelDefinitionDataChangedEventArgs Class


ChannelType Enumeration

ChannelType Enumeration
See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Channel types for definition of the channel configuration

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Enumeration ChannelType
C#
[ObfuscationAttribute]
public enum ChannelType

Members

Member name | Value | Description
Unassigned | 0 | Channel is not used
Floor | 1 | Channel is used fo the floor audio
Interpretation | 2 | Channel is assigned for interpreted audio (language distribution).
Individual | 3 | Channel is assigned for individual unit audio transport.
Intercom | 4 | Channel is assigned for intercom audio.
PublicAddress | 5 | Channel is assigned for the public address (floor audio)
AttenuatedDelegate | 6 | Channel is assigned for the attenuated delegate loudspeaker audio.
DelegateLoudspeaker | 7 | Channel is assigned for the delegate loudspeaker audio.
BusyRingTone | 8 | Channel is assigned for Busy and ring tone related to Intercom.

See Also

Bosch.Dcn.Ecpc.Client.Api.Interfaces Namespace
Copyright (c) 2014 Bosch Security Systems B.V.4.30.0011


ConfigChangedEventArgs Class

ConfigChangedEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Base container for holding the list of changed ID's in configuration events.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class ConfigChangedEventArgs _
    Inherits EventArgs
C#
[ObfuscationAttribute]
public class ConfigChangedEventArgs : EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ConfigChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..BoothSettingsEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DelegateDataChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DelegateRegistrationEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DeskSettingsEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..LanguageDataChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MeetingDataChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MeetingGroupDataChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MeetingInterpretationDataChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..RequestDataChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SessionDataChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VoteDataChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VoteTemplateDataChangedEventArgs

See Also

ConfigChangedEventArgs Members


ConfigChangedEventArgs Members

ConfigChangedEventArgs Members
ConfigChangedEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ConfigChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Protected method | ConfigChangedEventArgs()()()() | Default constructor...
Protected method | ConfigChangedEventArgs(array<Int32>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed.

See Also

ConfigChangedEventArgs Class


ConfigChangedEventArgs Constructor

ConfigChangedEventArgs Constructor
ConfigChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Protected method | ConfigChangedEventArgs()()()() | Default constructor...
Protected method | ConfigChangedEventArgs(array<Int32>[]()[][]) | Constructor...

See Also

ConfigChangedEventArgs Class
ConfigChangedEventArgs Members


ConfigChangedEventArgs Constructor

ConfigChangedEventArgs Constructor
ConfigChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Default constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected ConfigChangedEventArgs()

See Also

ConfigChangedEventArgs Class
ConfigChangedEventArgs Overload


ConfigChangedEventArgs Constructor (Int32[])

ConfigChangedEventArgs Constructor (array<Int32>[]()[][])
ConfigChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    changedIds As Integer() _
)
C#
protected ConfigChangedEventArgs(
    int[] changedIds
)

Parameters

changedIds
Type: array< System..::..Int32 >[]()[][]
The identifiers of the configuration data changed.

See Also

ConfigChangedEventArgs Class
ConfigChangedEventArgs Overload


ConfigChangedEventArgs Methods

ConfigChangedEventArgs Methods
ConfigChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ConfigChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ConfigChangedEventArgs Class


ConfigChangedEventArgs Properties

ConfigChangedEventArgs Properties
ConfigChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ConfigChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed.

See Also

ConfigChangedEventArgs Class


ConfigIds Property

ConfigChangedEventArgs..::..ConfigIds Property
ConfigChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The target identifiers of the specific configuration data changed.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConfigIds As Integer()
    Get
C#
public int[] ConfigIds { get; }

See Also

ConfigChangedEventArgs Class


CountEventArgs Class

CountEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Placeholder to contain the count value as argument.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class CountEventArgs _
    Inherits ControlEventArgs
C#
[ObfuscationAttribute]
public class CountEventArgs : ControlEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ControlEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..CountEventArgs

See Also

CountEventArgs Members


CountEventArgs Members

CountEventArgs Members
CountEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The CountEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CountEventArgs | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | The count setting.

See Also

CountEventArgs Class


CountEventArgs Constructor

CountEventArgs Constructor
CountEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    serviceId As Integer, _
    count As Integer _
)
C#
public CountEventArgs(
    int serviceId,
    int count
)

Parameters

serviceId
Type: System..::..Int32
The ID of the service as source of the event.
count
Type: System..::..Int32
The count setting.

See Also

CountEventArgs Class


CountEventArgs Methods

CountEventArgs Methods
CountEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The CountEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

CountEventArgs Class


CountEventArgs Properties

CountEventArgs Properties
CountEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The CountEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Count | The count setting.

See Also

CountEventArgs Class


Count Property

CountEventArgs..::..Count Property
CountEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The count setting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
    Get
C#
public int Count { get; }

Field Value

Any value >= 0.

See Also

CountEventArgs Class


DELEGATE Structure

DELEGATE Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Contains delegateId of current meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Structure DELEGATE
C#
[ObfuscationAttribute]
public struct DELEGATE

See Also

DELEGATE Members


DELEGATE Members

DELEGATE Members
DELEGATE Structure Methods Operators Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DELEGATE type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two DELEGATE instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a DELEGATE type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Operators

Name | Description
Equality | Checks the equality of two DELEGATE structures.
Inequality | Checks the non-equality of two DELEGATE structures.

Fields

 | Name | Description
Public field | DelegateId | The unique identifier of the participant.

See Also

DELEGATE Structure


DELEGATE Fields

DELEGATE Fields
DELEGATE Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DELEGATE type exposes the following members.

Fields

 | Name | Description
Public field | DelegateId | The unique identifier of the participant.

See Also

DELEGATE Structure


DelegateId Field

DELEGATE..::..DelegateId Field
DELEGATE Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The unique identifier of the participant.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public DelegateId As Integer
C#
public int DelegateId

See Also

DELEGATE Structure


DELEGATE Methods

DELEGATE Methods
DELEGATE Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DELEGATE type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two DELEGATE instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a DELEGATE type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

DELEGATE Structure


Equals Method

DELEGATE..::..Equals Method
DELEGATE Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Determines whether two DELEGATE instances are equal.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::..Object
The DELEGATE to compare with the current Object.

Return Value

true if the specified DELEGATE is equal to the current Object; otherwise, false.

See Also

DELEGATE Structure


GetHashCode Method

DELEGATE..::..GetHashCode Method
DELEGATE Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Serves as a hash function for a DELEGATE type.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current DELEGATE.

See Also

DELEGATE Structure


DELEGATE Operators

DELEGATE Operators
DELEGATE Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DELEGATE type exposes the following members.

Operators

Name | Description
Equality | Checks the equality of two DELEGATE structures.
Inequality | Checks the non-equality of two DELEGATE structures.

See Also

DELEGATE Structure


Equality Operator

DELEGATE..::..Equality Operator
DELEGATE Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the equality of two DELEGATE structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    a As DELEGATE, _
    b As DELEGATE _
) As Boolean
C#
public static bool operator ==(
    DELEGATE a,
    DELEGATE b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DELEGATE
The first DELEGATE to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DELEGATE
The next DELEGATE to compare.

Return Value

true if the specified DELEGATE structures are the same; otherwise, false.

See Also

DELEGATE Structure


Inequality Operator

DELEGATE..::..Inequality Operator
DELEGATE Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the non-equality of two DELEGATE structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    a As DELEGATE, _
    b As DELEGATE _
) As Boolean
C#
public static bool operator !=(
    DELEGATE a,
    DELEGATE b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DELEGATE
The first DELEGATE to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DELEGATE
The next DELEGATE to compare.

Return Value

true if the specified DELEGATE structures are not the same; otherwise, false.

See Also

DELEGATE Structure


DELEGATE_INFO Structure

DELEGATE_INFO Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Represents a container holding all information of a delegate.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Structure DELEGATE_INFO
C#
[ObfuscationAttribute]
public struct DELEGATE_INFO

See Also

DELEGATE_INFO Members


DELEGATE_INFO Members

DELEGATE_INFO Members
DELEGATE_INFO Structure Methods Operators Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DELEGATE_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two DELEGATE_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a DELEGATE_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Operators

Name | Description
Equality | Checks the equality of two DELEGATE_INFO structures.
Inequality | Checks the non-equality of two DELEGATE_INFO structures.

Fields

 | Name | Description
Public field | Country | Defines the freely definable country of origin of the delegate.
 | DEFAULT_MEETINGGROUP_ID | Identifier for the default meeting group to which a delegate can be assigned.
 | DEFAULT_PINCODE | The default PIN-code a delegate receives.
Public field | DisplayLanguageId | Defines the display language to apply for the delegate.
Public field | FirstName | Defines the first name of a delegate.
Public field | LastName | Defines the last name of a delegate.
Public field | MeetingGroupId | Defines the meeting group to which the delegate is assigned.
Public field | MiddleName | Defines the middle name of a delegate.
Public field | NativeLanguageId | Depricated
 | NO_CARD | No ID-card to be assigned to a delegate.
Public field | PinCode | Defines the PIN-code for the delegate to use.
Public field | Region | Defines the freely definable regional information of the delegate.
Public field | SpokenLanguageId | Depricated
Public field | Title | Defines the freely definable title of a delegate.

See Also

DELEGATE_INFO Structure


DELEGATE_INFO Fields

DELEGATE_INFO Fields
DELEGATE_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DELEGATE_INFO type exposes the following members.

Fields

 | Name | Description
Public field | Country | Defines the freely definable country of origin of the delegate.
 | DEFAULT_MEETINGGROUP_ID | Identifier for the default meeting group to which a delegate can be assigned.
 | DEFAULT_PINCODE | The default PIN-code a delegate receives.
Public field | DisplayLanguageId | Defines the display language to apply for the delegate.
Public field | FirstName | Defines the first name of a delegate.
Public field | LastName | Defines the last name of a delegate.
Public field | MeetingGroupId | Defines the meeting group to which the delegate is assigned.
Public field | MiddleName | Defines the middle name of a delegate.
Public field | NativeLanguageId | Depricated
 | NO_CARD | No ID-card to be assigned to a delegate.
Public field | PinCode | Defines the PIN-code for the delegate to use.
Public field | Region | Defines the freely definable regional information of the delegate.
Public field | SpokenLanguageId | Depricated
Public field | Title | Defines the freely definable title of a delegate.

See Also

DELEGATE_INFO Structure


Country Field

DELEGATE_INFO..::..Country Field
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Defines the freely definable country of origin of the delegate.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Country As String
C#
public string Country

See Also

DELEGATE_INFO Structure


DEFAULT_MEETINGGROUP_ID Field

DELEGATE_INFO..::..DEFAULT_MEETINGGROUP_ID Field
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Identifier for the default meeting group to which a delegate can be assigned.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const DEFAULT_MEETINGGROUP_ID As Integer
C#
public const int DEFAULT_MEETINGGROUP_ID

See Also

DELEGATE_INFO Structure


DEFAULT_PINCODE Field

DELEGATE_INFO..::..DEFAULT_PINCODE Field
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The default PIN-code a delegate receives.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const DEFAULT_PINCODE As Integer
C#
public const int DEFAULT_PINCODE

See Also

DELEGATE_INFO Structure


DisplayLanguageId Field

DELEGATE_INFO..::..DisplayLanguageId Field
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Defines the display language to apply for the delegate.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public DisplayLanguageId As Integer
C#
public int DisplayLanguageId

Remarks

Use the ILanguageDataApi interface to retrieve the list of available display languages.

See Also

DELEGATE_INFO Structure


FirstName Field

DELEGATE_INFO..::..FirstName Field
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Defines the first name of a delegate.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public FirstName As String
C#
public string FirstName

See Also

DELEGATE_INFO Structure


LastName Field

DELEGATE_INFO..::..LastName Field
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Defines the last name of a delegate.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public LastName As String
C#
public string LastName

See Also

DELEGATE_INFO Structure


MeetingGroupId Field

DELEGATE_INFO..::..MeetingGroupId Field
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Defines the meeting group to which the delegate is assigned.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public MeetingGroupId As Integer
C#
public int MeetingGroupId

Remarks

Use the IMeetingGroupDataApi interface to retrieve the list of available meeting groups.

See Also

DELEGATE_INFO Structure


MiddleName Field

DELEGATE_INFO..::..MiddleName Field
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Defines the middle name of a delegate.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public MiddleName As String
C#
public string MiddleName

See Also

DELEGATE_INFO Structure


NativeLanguageId Field

DELEGATE_INFO..::..NativeLanguageId Field
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Depricated

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public NativeLanguageId As Integer
C#
public int NativeLanguageId

See Also

DELEGATE_INFO Structure


NO_CARD Field

DELEGATE_INFO..::..NO_CARD Field
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
No ID-card to be assigned to a delegate.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const NO_CARD As Integer
C#
public const int NO_CARD

See Also

DELEGATE_INFO Structure


PinCode Field

DELEGATE_INFO..::..PinCode Field
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Defines the PIN-code for the delegate to use.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public PinCode As Integer
C#
public int PinCode

Remarks

A value ranging from 111 to 55555, or DEFAULT_PINCODE.

The PIN-code will always be expanded to become 5-digits wide. The missing digits will automatically be appended with value 1. This means that e.g. PIN-code 139 will be stored as 13911, 1398 as 13981, but 13985 as 13985.

During operation, the system will verify the digits according the used PIN-code size system setting.

See Also

DELEGATE_INFO Structure


Region Field

DELEGATE_INFO..::..Region Field
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Defines the freely definable regional information of the delegate.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Region As String
C#
public string Region

See Also

DELEGATE_INFO Structure


SpokenLanguageId Field

DELEGATE_INFO..::..SpokenLanguageId Field
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Depricated

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public SpokenLanguageId As Integer
C#
public int SpokenLanguageId

See Also

DELEGATE_INFO Structure


Title Field

DELEGATE_INFO..::..Title Field
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Defines the freely definable title of a delegate.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Title As String
C#
public string Title

See Also

DELEGATE_INFO Structure


DELEGATE_INFO Methods

DELEGATE_INFO Methods
DELEGATE_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DELEGATE_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two DELEGATE_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a DELEGATE_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

DELEGATE_INFO Structure


Equals Method

DELEGATE_INFO..::..Equals Method
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Determines whether two DELEGATE_INFO instances are equal.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::..Object
The DELEGATE_INFO to compare with the current Object.

Return Value

true if the specified DELEGATE_INFO is equal to the current Object; otherwise, false.

See Also

DELEGATE_INFO Structure


GetHashCode Method

DELEGATE_INFO..::..GetHashCode Method
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Serves as a hash function for a DELEGATE_INFO type.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current DELEGATE_INFO.

See Also

DELEGATE_INFO Structure


DELEGATE_INFO Operators

DELEGATE_INFO Operators
DELEGATE_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DELEGATE_INFO type exposes the following members.

Operators

Name | Description
Equality | Checks the equality of two DELEGATE_INFO structures.
Inequality | Checks the non-equality of two DELEGATE_INFO structures.

See Also

DELEGATE_INFO Structure


Equality Operator

DELEGATE_INFO..::..Equality Operator
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the equality of two DELEGATE_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    a As DELEGATE_INFO, _
    b As DELEGATE_INFO _
) As Boolean
C#
public static bool operator ==(
    DELEGATE_INFO a,
    DELEGATE_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DELEGATE_INFO
The first DELEGATE_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DELEGATE_INFO
The next DELEGATE_INFO to compare.

Return Value

true if the specified DELEGATE_INFO structures are the same; otherwise, false.

See Also

DELEGATE_INFO Structure


Inequality Operator

DELEGATE_INFO..::..Inequality Operator
DELEGATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the non-equality of two DELEGATE_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    a As DELEGATE_INFO, _
    b As DELEGATE_INFO _
) As Boolean
C#
public static bool operator !=(
    DELEGATE_INFO a,
    DELEGATE_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DELEGATE_INFO
The first DELEGATE_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DELEGATE_INFO
The next DELEGATE_INFO to compare.

Return Value

true if the specified DELEGATE_INFO structures are not the same; otherwise, false.

See Also

DELEGATE_INFO Structure


DelegateDataChangedEventArgs Class

DelegateDataChangedEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Provides data for a DelegateStore, DelegateUpdate or DelegateDeletion event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class DelegateDataChangedEventArgs _
    Inherits ConfigChangedEventArgs
C#
[ObfuscationAttribute]
public class DelegateDataChangedEventArgs : ConfigChangedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ConfigChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DelegateDataChangedEventArgs

See Also

DelegateDataChangedEventArgs Members


DelegateDataChangedEventArgs Members

DelegateDataChangedEventArgs Members
DelegateDataChangedEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DelegateDataChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DelegateDataChangedEventArgs()()()() | Default constructor...
Public method | DelegateDataChangedEventArgs(array<Int32>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)

See Also

DelegateDataChangedEventArgs Class


DelegateDataChangedEventArgs Constructor

DelegateDataChangedEventArgs Constructor
DelegateDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | DelegateDataChangedEventArgs()()()() | Default constructor...
Public method | DelegateDataChangedEventArgs(array<Int32>[]()[][]) | Constructor...

See Also

DelegateDataChangedEventArgs Class
DelegateDataChangedEventArgs Members


DelegateDataChangedEventArgs Constructor

DelegateDataChangedEventArgs Constructor
DelegateDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Default constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelegateDataChangedEventArgs()

See Also

DelegateDataChangedEventArgs Class
DelegateDataChangedEventArgs Overload


DelegateDataChangedEventArgs Constructor (Int32[])

DelegateDataChangedEventArgs Constructor (array<Int32>[]()[][])
DelegateDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    delegateIds As Integer() _
)
C#
public DelegateDataChangedEventArgs(
    int[] delegateIds
)

Parameters

delegateIds
Type: array< System..::..Int32 >[]()[][]
The identifiers of the delegate changed. Use ConfigIds to retrieve.

See Also

DelegateDataChangedEventArgs Class
DelegateDataChangedEventArgs Overload


DelegateDataChangedEventArgs Methods

DelegateDataChangedEventArgs Methods
DelegateDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DelegateDataChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

DelegateDataChangedEventArgs Class


DelegateDataChangedEventArgs Properties

DelegateDataChangedEventArgs Properties
DelegateDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DelegateDataChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)

See Also

DelegateDataChangedEventArgs Class


DelegateRegistrationEventArgs Class

DelegateRegistrationEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Provides data for a DelegateRegistration, DelegateRegistrationUpdate or DelegateUnregistration event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class DelegateRegistrationEventArgs _
    Inherits ConfigChangedEventArgs
C#
[ObfuscationAttribute]
public class DelegateRegistrationEventArgs : ConfigChangedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ConfigChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DelegateRegistrationEventArgs

See Also

DelegateRegistrationEventArgs Members


DelegateRegistrationEventArgs Members

DelegateRegistrationEventArgs Members
DelegateRegistrationEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DelegateRegistrationEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DelegateRegistrationEventArgs()()()() | Default constructor...
Public method | DelegateRegistrationEventArgs(array<Int32>[]()[][], array<Int32>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)
Public property | MeetingIds | The identifiers of the meetings registration occurred on.

See Also

DelegateRegistrationEventArgs Class


DelegateRegistrationEventArgs Constructor

DelegateRegistrationEventArgs Constructor
DelegateRegistrationEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | DelegateRegistrationEventArgs()()()() | Default constructor...
Public method | DelegateRegistrationEventArgs(array<Int32>[]()[][], array<Int32>[]()[][]) | Constructor...

See Also

DelegateRegistrationEventArgs Class
DelegateRegistrationEventArgs Members


DelegateRegistrationEventArgs Constructor

DelegateRegistrationEventArgs Constructor
DelegateRegistrationEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Default constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelegateRegistrationEventArgs()

See Also

DelegateRegistrationEventArgs Class
DelegateRegistrationEventArgs Overload


DelegateRegistrationEventArgs Constructor (Int32[], Int32[])

DelegateRegistrationEventArgs Constructor (array<Int32>[]()[][], array<Int32>[]()[][])
DelegateRegistrationEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    delegateIds As Integer(), _
    meetingIds As Integer() _
)
C#
public DelegateRegistrationEventArgs(
    int[] delegateIds,
    int[] meetingIds
)

Parameters

delegateIds
Type: array< System..::..Int32 >[]()[][]
The identifiers of the delegates registered. Use ConfigIds to retrieve.
meetingIds
Type: array< System..::..Int32 >[]()[][]
The identifiers for the meetings registered.

See Also

DelegateRegistrationEventArgs Class
DelegateRegistrationEventArgs Overload


DelegateRegistrationEventArgs Methods

DelegateRegistrationEventArgs Methods
DelegateRegistrationEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DelegateRegistrationEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

DelegateRegistrationEventArgs Class


DelegateRegistrationEventArgs Properties

DelegateRegistrationEventArgs Properties
DelegateRegistrationEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DelegateRegistrationEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)
Public property | MeetingIds | The identifiers of the meetings registration occurred on.

See Also

DelegateRegistrationEventArgs Class


MeetingIds Property

DelegateRegistrationEventArgs..::..MeetingIds Property
DelegateRegistrationEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The identifiers of the meetings registration occurred on.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MeetingIds As Integer()
    Get
C#
public int[] MeetingIds { get; }

See Also

DelegateRegistrationEventArgs Class


DESK_INFO Structure

DESK_INFO Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Represents a container holding all information of a desk within a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Structure DESK_INFO
C#
[ObfuscationAttribute]
public struct DESK_INFO

See Also

DESK_INFO Members


DESK_INFO Members

DESK_INFO Members
DESK_INFO Structure Methods Operators Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DESK_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two DESK_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a DESK_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Operators

Name | Description
Equality | Checks the equality of two DESK_INFO structures.
Inequality | Checks the non-equality of two DESK_INFO structures.

Fields

 | Name | Description
Public field | AOutLanguageId | Indicates the language selected for desk for A output channel.
Public field | BoothId | Booth identification where this desk is present.
Public field | BOutLangugeIds | Indicates the language selected for desk for B output channels.
Public field | BToggle | Indicates if BToggle allowed for the desk or not.

See Also

DESK_INFO Structure


DESK_INFO Fields

DESK_INFO Fields
DESK_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DESK_INFO type exposes the following members.

Fields

 | Name | Description
Public field | AOutLanguageId | Indicates the language selected for desk for A output channel.
Public field | BoothId | Booth identification where this desk is present.
Public field | BOutLangugeIds | Indicates the language selected for desk for B output channels.
Public field | BToggle | Indicates if BToggle allowed for the desk or not.

See Also

DESK_INFO Structure


AOutLanguageId Field

DESK_INFO..::..AOutLanguageId Field
DESK_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates the language selected for desk for A output channel.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public AOutLanguageId As Integer
C#
public int AOutLanguageId

See Also

DESK_INFO Structure


BoothId Field

DESK_INFO..::..BoothId Field
DESK_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Booth identification where this desk is present.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public BoothId As Integer
C#
public int BoothId

See Also

DESK_INFO Structure


BOutLangugeIds Field

DESK_INFO..::..BOutLangugeIds Field
DESK_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates the language selected for desk for B output channels.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public BOutLangugeIds As Integer()
C#
public int[] BOutLangugeIds

See Also

DESK_INFO Structure


BToggle Field

DESK_INFO..::..BToggle Field
DESK_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates if BToggle allowed for the desk or not.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public BToggle As Boolean
C#
public bool BToggle

See Also

DESK_INFO Structure


DESK_INFO Methods

DESK_INFO Methods
DESK_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DESK_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two DESK_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a DESK_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

DESK_INFO Structure


Equals Method

DESK_INFO..::..Equals Method
DESK_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Determines whether two DESK_INFO instances are equal.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::..Object
The DESK_INFO to compare with the current Object.

Return Value

true if the specified DESK_INFO is equal to the current Object; otherwise, false.

See Also

DESK_INFO Structure


GetHashCode Method

DESK_INFO..::..GetHashCode Method
DESK_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Serves as a hash function for a DESK_INFO type.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current DESK_INFO.

See Also

DESK_INFO Structure


DESK_INFO Operators

DESK_INFO Operators
DESK_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DESK_INFO type exposes the following members.

Operators

Name | Description
Equality | Checks the equality of two DESK_INFO structures.
Inequality | Checks the non-equality of two DESK_INFO structures.

See Also

DESK_INFO Structure


Equality Operator

DESK_INFO..::..Equality Operator
DESK_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the equality of two DESK_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    a As DESK_INFO, _
    b As DESK_INFO _
) As Boolean
C#
public static bool operator ==(
    DESK_INFO a,
    DESK_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DESK_INFO
The first DESK_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DESK_INFO
The next DESK_INFO to compare.

Return Value

true if the specified DESK_INFO structures are the same; otherwise, false.

See Also

DESK_INFO Structure


Inequality Operator

DESK_INFO..::..Inequality Operator
DESK_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the non-equality of two DESK_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    a As DESK_INFO, _
    b As DESK_INFO _
) As Boolean
C#
public static bool operator !=(
    DESK_INFO a,
    DESK_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DESK_INFO
The first DESK_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DESK_INFO
The next DESK_INFO to compare.

Return Value

true if the specified DESK_INFO structures are not the same; otherwise, false.

See Also

DESK_INFO Structure


DeskSettingsEventArgs Class

DeskSettingsEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Provides data for a DeskSettingsUpdate event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class DeskSettingsEventArgs _
    Inherits ConfigChangedEventArgs
C#
[ObfuscationAttribute]
public class DeskSettingsEventArgs : ConfigChangedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ConfigChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DeskSettingsEventArgs

See Also

DeskSettingsEventArgs Members


DeskSettingsEventArgs Members

DeskSettingsEventArgs Members
DeskSettingsEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DeskSettingsEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DeskSettingsEventArgs()()()() | Default constructor...
Public method | DeskSettingsEventArgs(array<Int32>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)

See Also

DeskSettingsEventArgs Class


DeskSettingsEventArgs Constructor

DeskSettingsEventArgs Constructor
DeskSettingsEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | DeskSettingsEventArgs()()()() | Default constructor...
Public method | DeskSettingsEventArgs(array<Int32>[]()[][]) | Constructor...

See Also

DeskSettingsEventArgs Class
DeskSettingsEventArgs Members


DeskSettingsEventArgs Constructor

DeskSettingsEventArgs Constructor
DeskSettingsEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Default constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DeskSettingsEventArgs()

See Also

DeskSettingsEventArgs Class
DeskSettingsEventArgs Overload


DeskSettingsEventArgs Constructor (Int32[])

DeskSettingsEventArgs Constructor (array<Int32>[]()[][])
DeskSettingsEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    deskIds As Integer() _
)
C#
public DeskSettingsEventArgs(
    int[] deskIds
)

Parameters

deskIds
Type: array< System..::..Int32 >[]()[][]
The identifiers of the booth settings changed. Use ConfigIds to retrieve.

See Also

DeskSettingsEventArgs Class
DeskSettingsEventArgs Overload


DeskSettingsEventArgs Methods

DeskSettingsEventArgs Methods
DeskSettingsEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DeskSettingsEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

DeskSettingsEventArgs Class


DeskSettingsEventArgs Properties

DeskSettingsEventArgs Properties
DeskSettingsEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DeskSettingsEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)

See Also

DeskSettingsEventArgs Class


DISCUSSION_INFO Class

DISCUSSION_INFO Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The settings of an current session's discussion.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Class DISCUSSION_INFO
C#
[SerializableAttribute]
[ObfuscationAttribute]
public class DISCUSSION_INFO

Inheritance Hierarchy

System..::..Object
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DISCUSSION_INFO

See Also

DISCUSSION_INFO Members


DISCUSSION_INFO Members

DISCUSSION_INFO Members
DISCUSSION_INFO Class Constructors Methods Fields Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DISCUSSION_INFO type exposes the following members.

Constructors

 | Name | Description
Public method | DISCUSSION_INFO()()()() | default constructor for discussion settings info.
Public method | DISCUSSION_INFO(Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Int32, Boolean, Boolean, Int32) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | MicControlMode | Microphone mode.

Properties

 | Name | Description
Public property | AllowCancelRequest | Participants may cancel their request to speak.
Public property | AllowMicrophoneOff | Participants may switch off their microphone.
Public property | AmbientMicrophone | The ambient microphone is switched on when all other microphones are off.
Public property | AttentionTone | Enables and defines the chairman priority attention tone (0 is Off).
Public property | AutomaticMicrophoneOff | Microphones are switched off automatically when they are not used for 30 seconds. This function can be used for wireless units to save battery power, or when participants forget to switch off the microphone manually.
Public property | CancelAllSpeakersAndRequests | Cancels all speakers and requests when the chairman uses priority.
Public property | ChairmanMicrosOnCount | Number of chairman microphones on count. It is not cofigurable property.Whenever chairman microphone will get on/off, value of it will be updated.
Public property | LedFollowsMicLed | Shows the red microphone indicator on the mic, when the last minute of speech is reached.
Public property | MaximumNumberOfRequests | Sets the maximum number of request to speak (0 means requests are not allowed).
Public property | MaximumNumberOfRequestToRespond | Gets or sets the maximum number of request to respond. Max request to respond range is 1 - 25 for DCN-CCU2 and DCN-CCUB2. Max request to respond range is fixed i.e 5 for DCN-CCU, DCN-CCUB or DCN-NCO. It cannot be changed.
Public property | MicrophonesOffAfterShift | Microphones in the speaker list are switched off after a shift of a request.
Public property | NumberOfOpenMicrophones | The maximum number of microphones in the speakers list.
Public property | ShowLastMinuteOnDelegateUnits | Shows the red microphone indicator when the last minute of speech is reached.

See Also

DISCUSSION_INFO Class


DISCUSSION_INFO Constructor

DISCUSSION_INFO Constructor
DISCUSSION_INFO Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | DISCUSSION_INFO()()()() | default constructor for discussion settings info.
Public method | DISCUSSION_INFO(Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Int32, Boolean, Boolean, Int32) | Constructor...

See Also

DISCUSSION_INFO Class
DISCUSSION_INFO Members


DISCUSSION_INFO Constructor

DISCUSSION_INFO Constructor
DISCUSSION_INFO Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
default constructor for discussion settings info.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DISCUSSION_INFO()

See Also

DISCUSSION_INFO Class
DISCUSSION_INFO Overload


DISCUSSION_INFO Constructor (Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Int32, Boolean, Boolean, Int32)

DISCUSSION_INFO Constructor (Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Int32, Boolean, Boolean, Int32)
DISCUSSION_INFO Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    numberOfOpenMicrophones As Integer, _
    maximumNumberOfRequests As Integer, _
    microControlMode As Integer, _
    attentionTone As Integer, _
    microphonesOffAfterShift As Boolean, _
    allowCancelRequest As Boolean, _
    allowMicrophoneOff As Boolean, _
    automaticMicrophoneOff As Boolean, _
    ambientMicrophone As Boolean, _
    cancelAllSpeakersAndRequests As Boolean, _
    chairmanMicrosOnCount As Integer, _
    showLastMinuteOnDelegateUnits As Boolean, _
    ledFollowsMicLed As Boolean, _
    maxNumberOfResponseRequest As Integer _
)
C#
public DISCUSSION_INFO(
    int numberOfOpenMicrophones,
    int maximumNumberOfRequests,
    int microControlMode,
    int attentionTone,
    bool microphonesOffAfterShift,
    bool allowCancelRequest,
    bool allowMicrophoneOff,
    bool automaticMicrophoneOff,
    bool ambientMicrophone,
    bool cancelAllSpeakersAndRequests,
    int chairmanMicrosOnCount,
    bool showLastMinuteOnDelegateUnits,
    bool ledFollowsMicLed,
    int maxNumberOfResponseRequest
)

Parameters

numberOfOpenMicrophones
Type: System..::..Int32
The maximum number of microphones in the speakers list.
maximumNumberOfRequests
Type: System..::..Int32
Sets the maximum number of request to speak (0 means requests are not allowed).
microControlMode
Type: System..::..Int32
Microphone mode.
attentionTone
Type: System..::..Int32
Enables and defines the chairman priority attention tone (0 is Off).
microphonesOffAfterShift
Type: System..::..Boolean
Microphones in the speaker list are switched off after a shift of a request.
allowCancelRequest
Type: System..::..Boolean
Participants may cancel their request to speak.
allowMicrophoneOff
Type: System..::..Boolean
Participants may switch off their microphone.
automaticMicrophoneOff
Type: System..::..Boolean
Microphones are switched off automatically when they are not used for 30 seconds. This function can be used for wireless units to save battery power, or when participants forget to switch off the microphone manually..
ambientMicrophone
Type: System..::..Boolean
The ambient microphone is switched on when all other microphones are off.
cancelAllSpeakersAndRequests
Type: System..::..Boolean
Cancels all speakers and requests when the chairman uses priority.
chairmanMicrosOnCount
Type: System..::..Int32
Number of chairman microphones on count.
showLastMinuteOnDelegateUnits
Type: System..::..Boolean
Shows the red microphone indicator when the last minute of speech is reached.
ledFollowsMicLed
Type: System..::..Boolean
Shows the red microphone indicator on the mic, when the last minute of speech is reached.
maxNumberOfResponseRequest
Type: System..::..Int32
Sets the maximum number of response request to speak (0 means requests are not allowed).

See Also

DISCUSSION_INFO Class
DISCUSSION_INFO Overload


DISCUSSION_INFO Fields

DISCUSSION_INFO Fields
DISCUSSION_INFO Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DISCUSSION_INFO type exposes the following members.

Fields

 | Name | Description
Public field | MicControlMode | Microphone mode.

See Also

DISCUSSION_INFO Class


MicControlMode Field

DISCUSSION_INFO..::..MicControlMode Field
DISCUSSION_INFO Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Microphone mode.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public MicControlMode As Integer
C#
public int MicControlMode

Remarks

Following values can be set for Micro control mode.
1 - CONTROL_MODE_OPEN
2 - CONTROL_MODE_OVERRIDE
3 - CONTROL_MODE_OPERATOR
4 - CONTROL_MODE_RESPONSE
5 - CONTROL_MODE_VOICE
6 - CONTROL_MODE_PUSHTOTALK

See Also

DISCUSSION_INFO Class


DISCUSSION_INFO Methods

DISCUSSION_INFO Methods
DISCUSSION_INFO Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DISCUSSION_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

DISCUSSION_INFO Class


DISCUSSION_INFO Properties

DISCUSSION_INFO Properties
DISCUSSION_INFO Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DISCUSSION_INFO type exposes the following members.

Properties

 | Name | Description
Public property | AllowCancelRequest | Participants may cancel their request to speak.
Public property | AllowMicrophoneOff | Participants may switch off their microphone.
Public property | AmbientMicrophone | The ambient microphone is switched on when all other microphones are off.
Public property | AttentionTone | Enables and defines the chairman priority attention tone (0 is Off).
Public property | AutomaticMicrophoneOff | Microphones are switched off automatically when they are not used for 30 seconds. This function can be used for wireless units to save battery power, or when participants forget to switch off the microphone manually.
Public property | CancelAllSpeakersAndRequests | Cancels all speakers and requests when the chairman uses priority.
Public property | ChairmanMicrosOnCount | Number of chairman microphones on count. It is not cofigurable property.Whenever chairman microphone will get on/off, value of it will be updated.
Public property | LedFollowsMicLed | Shows the red microphone indicator on the mic, when the last minute of speech is reached.
Public property | MaximumNumberOfRequests | Sets the maximum number of request to speak (0 means requests are not allowed).
Public property | MaximumNumberOfRequestToRespond | Gets or sets the maximum number of request to respond. Max request to respond range is 1 - 25 for DCN-CCU2 and DCN-CCUB2. Max request to respond range is fixed i.e 5 for DCN-CCU, DCN-CCUB or DCN-NCO. It cannot be changed.
Public property | MicrophonesOffAfterShift | Microphones in the speaker list are switched off after a shift of a request.
Public property | NumberOfOpenMicrophones | The maximum number of microphones in the speakers list.
Public property | ShowLastMinuteOnDelegateUnits | Shows the red microphone indicator when the last minute of speech is reached.

See Also

DISCUSSION_INFO Class


AllowCancelRequest Property

DISCUSSION_INFO..::..AllowCancelRequest Property
DISCUSSION_INFO Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Participants may cancel their request to speak.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowCancelRequest As Boolean
    Get
    Set
C#
public bool AllowCancelRequest { get; set; }

See Also

DISCUSSION_INFO Class


AllowMicrophoneOff Property

DISCUSSION_INFO..::..AllowMicrophoneOff Property
DISCUSSION_INFO Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Participants may switch off their microphone.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowMicrophoneOff As Boolean
    Get
    Set
C#
public bool AllowMicrophoneOff { get; set; }

See Also

DISCUSSION_INFO Class


AmbientMicrophone Property

DISCUSSION_INFO..::..AmbientMicrophone Property
DISCUSSION_INFO Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The ambient microphone is switched on when all other microphones are off.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property AmbientMicrophone As Boolean
    Get
    Set
C#
public bool AmbientMicrophone { get; set; }

See Also

DISCUSSION_INFO Class


AttentionTone Property

DISCUSSION_INFO..::..AttentionTone Property
DISCUSSION_INFO Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Enables and defines the chairman priority attention tone (0 is Off).

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property AttentionTone As Integer
    Get
    Set
C#
public int AttentionTone { get; set; }

See Also

DISCUSSION_INFO Class


AutomaticMicrophoneOff Property

DISCUSSION_INFO..::..AutomaticMicrophoneOff Property
DISCUSSION_INFO Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Microphones are switched off automatically when they are not used for 30 seconds. This function can be used for wireless units to save battery power, or when participants forget to switch off the microphone manually.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property AutomaticMicrophoneOff As Boolean
    Get
    Set
C#
public bool AutomaticMicrophoneOff { get; set; }

See Also

DISCUSSION_INFO Class


CancelAllSpeakersAndRequests Property

DISCUSSION_INFO..::..CancelAllSpeakersAndRequests Property
DISCUSSION_INFO Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Cancels all speakers and requests when the chairman uses priority.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property CancelAllSpeakersAndRequests As Boolean
    Get
    Set
C#
public bool CancelAllSpeakersAndRequests { get; set; }

See Also

DISCUSSION_INFO Class


ChairmanMicrosOnCount Property

DISCUSSION_INFO..::..ChairmanMicrosOnCount Property
DISCUSSION_INFO Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Number of chairman microphones on count. It is not cofigurable property.Whenever chairman microphone will get on/off, value of it will be updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property ChairmanMicrosOnCount As Integer
    Get
    Set
C#
public int ChairmanMicrosOnCount { get; set; }

See Also

DISCUSSION_INFO Class


LedFollowsMicLed Property

DISCUSSION_INFO..::..LedFollowsMicLed Property
DISCUSSION_INFO Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Shows the red microphone indicator on the mic, when the last minute of speech is reached.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property LedFollowsMicLed As Boolean
    Get
    Set
C#
public bool LedFollowsMicLed { get; set; }

See Also

DISCUSSION_INFO Class


MaximumNumberOfRequests Property

DISCUSSION_INFO..::..MaximumNumberOfRequests Property
DISCUSSION_INFO Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Sets the maximum number of request to speak (0 means requests are not allowed).

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property MaximumNumberOfRequests As Integer
    Get
    Set
C#
public int MaximumNumberOfRequests { get; set; }

See Also

DISCUSSION_INFO Class


MaximumNumberOfRequestToRespond Property

DISCUSSION_INFO..::..MaximumNumberOfRequestToRespond Property
DISCUSSION_INFO Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Gets or sets the maximum number of request to respond.
Max request to respond range is 1 - 25 for DCN-CCU2 and DCN-CCUB2.
Max request to respond range is fixed i.e 5 for DCN-CCU, DCN-CCUB or DCN-NCO. It cannot be changed.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property MaximumNumberOfRequestToRespond As Integer
    Get
    Set
C#
public int MaximumNumberOfRequestToRespond { get; set; }

See Also

DISCUSSION_INFO Class


MicrophonesOffAfterShift Property

DISCUSSION_INFO..::..MicrophonesOffAfterShift Property
DISCUSSION_INFO Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Microphones in the speaker list are switched off after a shift of a request.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property MicrophonesOffAfterShift As Boolean
    Get
    Set
C#
public bool MicrophonesOffAfterShift { get; set; }

See Also

DISCUSSION_INFO Class


NumberOfOpenMicrophones Property

DISCUSSION_INFO..::..NumberOfOpenMicrophones Property
DISCUSSION_INFO Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The maximum number of microphones in the speakers list.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property NumberOfOpenMicrophones As Integer
    Get
    Set
C#
public int NumberOfOpenMicrophones { get; set; }

See Also

DISCUSSION_INFO Class


ShowLastMinuteOnDelegateUnits Property

DISCUSSION_INFO..::..ShowLastMinuteOnDelegateUnits Property
DISCUSSION_INFO Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Shows the red microphone indicator when the last minute of speech is reached.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowLastMinuteOnDelegateUnits As Boolean
    Get
    Set
C#
public bool ShowLastMinuteOnDelegateUnits { get; set; }

See Also

DISCUSSION_INFO Class


DiscussionControlEventArgs Class

DiscussionControlEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Container for holding the configuration- and service-ID of the discussion service triggering the event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class DiscussionControlEventArgs _
    Inherits ControlEventArgs
C#
[ObfuscationAttribute]
public class DiscussionControlEventArgs : ControlEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ControlEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DiscussionControlEventArgs

See Also

DiscussionControlEventArgs Members


DiscussionControlEventArgs Members

DiscussionControlEventArgs Members
DiscussionControlEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DiscussionControlEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DiscussionControlEventArgs()()()() | Constructor...
Public method | DiscussionControlEventArgs(Int32, Int32, array<PARTICIPANT>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ParticiantInfo | Represents Particiant of the discussion service.

See Also

DiscussionControlEventArgs Class


DiscussionControlEventArgs Constructor

DiscussionControlEventArgs Constructor
DiscussionControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | DiscussionControlEventArgs()()()() | Constructor...
Public method | DiscussionControlEventArgs(Int32, Int32, array<PARTICIPANT>[]()[][]) | Constructor...

See Also

DiscussionControlEventArgs Class
DiscussionControlEventArgs Members


DiscussionControlEventArgs Constructor

DiscussionControlEventArgs Constructor
DiscussionControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DiscussionControlEventArgs()

See Also

DiscussionControlEventArgs Class
DiscussionControlEventArgs Overload


DiscussionControlEventArgs Constructor (Int32, Int32, PARTICIPANT[])

DiscussionControlEventArgs Constructor (Int32, Int32, array<PARTICIPANT>[]()[][])
DiscussionControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    configId As Integer, _
    serviceId As Integer, _
    participantInfo As PARTICIPANT() _
)
C#
public DiscussionControlEventArgs(
    int configId,
    int serviceId,
    PARTICIPANT[] participantInfo
)

Parameters

configId
Type: System..::..Int32
The configuration identifier of the discussion service.
serviceId
Type: System..::..Int32
The service identifier of the discussion service.
participantInfo
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..PARTICIPANT >[]()[][]
Represents Particiant of the discussion service.

See Also

DiscussionControlEventArgs Class
DiscussionControlEventArgs Overload


DiscussionControlEventArgs Methods

DiscussionControlEventArgs Methods
DiscussionControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DiscussionControlEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

DiscussionControlEventArgs Class


DiscussionControlEventArgs Properties

DiscussionControlEventArgs Properties
DiscussionControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DiscussionControlEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ParticiantInfo | Represents Particiant of the discussion service.

See Also

DiscussionControlEventArgs Class


ParticiantInfo Property

DiscussionControlEventArgs..::..ParticiantInfo Property
DiscussionControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Represents Particiant of the discussion service.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParticiantInfo As PARTICIPANT()
    Get
C#
public PARTICIPANT[] ParticiantInfo { get; }

See Also

DiscussionControlEventArgs Class


DiscussionSettingsEventArgs Class

DiscussionSettingsEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Container for holding the configuration- and service-ID of the discussion service triggering the event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class DiscussionSettingsEventArgs _
    Inherits ControlEventArgs
C#
[ObfuscationAttribute]
public class DiscussionSettingsEventArgs : ControlEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ControlEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DiscussionSettingsEventArgs

See Also

DiscussionSettingsEventArgs Members


DiscussionSettingsEventArgs Members

DiscussionSettingsEventArgs Members
DiscussionSettingsEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DiscussionSettingsEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DiscussionSettingsEventArgs()()()() | Constructor...
Public method | DiscussionSettingsEventArgs(Int32, Int32, KeyValuePair<(Of <<'(String, String>)>>)) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | DiscussionInfo | Represents settings of the discussion service.

See Also

DiscussionSettingsEventArgs Class


DiscussionSettingsEventArgs Constructor

DiscussionSettingsEventArgs Constructor
DiscussionSettingsEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | DiscussionSettingsEventArgs()()()() | Constructor...
Public method | DiscussionSettingsEventArgs(Int32, Int32, KeyValuePair<(Of <<'(String, String>)>>)) | Constructor...

See Also

DiscussionSettingsEventArgs Class
DiscussionSettingsEventArgs Members


DiscussionSettingsEventArgs Constructor

DiscussionSettingsEventArgs Constructor
DiscussionSettingsEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DiscussionSettingsEventArgs()

See Also

DiscussionSettingsEventArgs Class
DiscussionSettingsEventArgs Overload


DiscussionSettingsEventArgs Constructor (Int32, Int32, KeyValuePair(String, String))

DiscussionSettingsEventArgs Constructor (Int32, Int32, KeyValuePair<(Of <(<'String, String>)>)>)
DiscussionSettingsEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    configId As Integer, _
    serviceId As Integer, _
    discussionInfo As KeyValuePair(Of String, String) _
)
C#
public DiscussionSettingsEventArgs(
    int configId,
    int serviceId,
    KeyValuePair<string, string> discussionInfo
)

Parameters

configId
Type: System..::..Int32
The configuration identifier of the discussion service.
serviceId
Type: System..::..Int32
The service identifier of the discussion service.
discussionInfo
Type: System.Collections.Generic..::..KeyValuePair <(Of <(<' String, String >)>)>
Represents settings of the discussion service.

See Also

DiscussionSettingsEventArgs Class
DiscussionSettingsEventArgs Overload


DiscussionSettingsEventArgs Methods

DiscussionSettingsEventArgs Methods
DiscussionSettingsEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DiscussionSettingsEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

DiscussionSettingsEventArgs Class


DiscussionSettingsEventArgs Properties

DiscussionSettingsEventArgs Properties
DiscussionSettingsEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DiscussionSettingsEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | DiscussionInfo | Represents settings of the discussion service.

See Also

DiscussionSettingsEventArgs Class


DiscussionInfo Property

DiscussionSettingsEventArgs..::..DiscussionInfo Property
DiscussionSettingsEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Represents settings of the discussion service.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DiscussionInfo As KeyValuePair(Of String, String)
    Get
C#
public KeyValuePair<string, string> DiscussionInfo { get; }

See Also

DiscussionSettingsEventArgs Class


GroupTimerControlEventArgs Class

GroupTimerControlEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Placeholder to contain the session group timer delegate event argument

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class GroupTimerControlEventArgs _
    Inherits EventArgs
C#
[ObfuscationAttribute]
public class GroupTimerControlEventArgs : EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..GroupTimerControlEventArgs

See Also

GroupTimerControlEventArgs Members


GroupTimerControlEventArgs Members

GroupTimerControlEventArgs Members
GroupTimerControlEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The GroupTimerControlEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GroupTimerControlEventArgs()()()() | Constructor...
Public method | GroupTimerControlEventArgs(SESSION_GROUP_TIMER) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | GroupTimer | Represents Particiant of the discussion service.

See Also

GroupTimerControlEventArgs Class


GroupTimerControlEventArgs Constructor

GroupTimerControlEventArgs Constructor
GroupTimerControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | GroupTimerControlEventArgs()()()() | Constructor...
Public method | GroupTimerControlEventArgs(SESSION_GROUP_TIMER) | Constructor...

See Also

GroupTimerControlEventArgs Class
GroupTimerControlEventArgs Members


GroupTimerControlEventArgs Constructor

GroupTimerControlEventArgs Constructor
GroupTimerControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GroupTimerControlEventArgs()

See Also

GroupTimerControlEventArgs Class
GroupTimerControlEventArgs Overload


GroupTimerControlEventArgs Constructor (SESSION_GROUP_TIMER)

GroupTimerControlEventArgs Constructor (SESSION_GROUP_TIMER)
GroupTimerControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    groupTimer As SESSION_GROUP_TIMER _
)
C#
public GroupTimerControlEventArgs(
    SESSION_GROUP_TIMER groupTimer
)

Parameters

groupTimer
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SESSION_GROUP_TIMER
Represents Particiant of the discussion service.

See Also

GroupTimerControlEventArgs Class
GroupTimerControlEventArgs Overload


GroupTimerControlEventArgs Methods

GroupTimerControlEventArgs Methods
GroupTimerControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The GroupTimerControlEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

GroupTimerControlEventArgs Class


GroupTimerControlEventArgs Properties

GroupTimerControlEventArgs Properties
GroupTimerControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The GroupTimerControlEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | GroupTimer | Represents Particiant of the discussion service.

See Also

GroupTimerControlEventArgs Class


GroupTimer Property

GroupTimerControlEventArgs..::..GroupTimer Property
GroupTimerControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Represents Particiant of the discussion service.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GroupTimer As SESSION_GROUP_TIMER
    Get
C#
public SESSION_GROUP_TIMER GroupTimer { get; }

See Also

GroupTimerControlEventArgs Class


GroupTimerControlEventHandler Delegate

GroupTimerControlEventHandler Delegate
See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Event handler for a session group timer change events.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Delegate Sub GroupTimerControlEventHandler ( _
    sender As Object, _
    e As GroupTimerControlEventArgs _
)
C#
[ObfuscationAttribute]
public delegate void GroupTimerControlEventHandler(
    Object sender,
    GroupTimerControlEventArgs e
)

Parameters

sender
Type: System..::..Object
The source of the event
e
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..GroupTimerControlEventArgs
A GroupTimerControlEventArgs that contains the event data

See Also

Bosch.Dcn.Ecpc.Client.Api.Interfaces Namespace
Copyright (c) 2014 Bosch Security Systems B.V.4.30.0011


IApi Interface

IApi Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Base interface for the DCN-SW API, used to manage the connection to the DCN-SW server. See also IApi Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IApi _
    Inherits IApiEvents, IDisposable
C#
[ObfuscationAttribute]
public interface IApi : IApiEvents, IDisposable

See Also

IApi Members


IApi Members

IApi Members
IApi Interface Methods Properties Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IApi type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | Initialize | Initializes the software DCN-SW API by opening a connection to the DCN-SW server and logging on as user using the given credentials.
Public method | Terminate | Terminates the DCN-SW API and logs the user off from the DCN-SW server.

Properties

 | Name | Description
Public property | IsAvailable | Gets the availability-status of the DCN-SW API. Use this getter to determine whether a function on the API can be called.

Events

 | Name | Description
Public event | AuthorizationChange | Occurs when there is a change in the authorization state of the user of the DCN-SW API. (Inherited from IApiEvents.)
Public event | AvailabilityChange | Occurs when there is a change in the availability state of the DCN-SW API. (Inherited from IApiEvents.)

See Also

IApi Interface


IApi Methods

IApi Methods
IApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IApi type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | Initialize | Initializes the software DCN-SW API by opening a connection to the DCN-SW server and logging on as user using the given credentials.
Public method | Terminate | Terminates the DCN-SW API and logs the user off from the DCN-SW server.

See Also

IApi Interface


Initialize Method

IApi..::..Initialize Method
IApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Initializes the software DCN-SW API by opening a connection to the DCN-SW server and logging on as user using the given credentials.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function Initialize ( _
    connectionString As String, _
    userName As String, _
    password As String _
) As API_ERROR
C#
API_ERROR Initialize(
    string connectionString,
    string userName,
    string password
)

Parameters

connectionString
Type: System..::..String
The string describing the connection to the DCN-SW server to connect to. The string should have the format according tcp://[host]:[port] where the hostname and port are to be filled in (e.g. tcp://localhost:9461).
userName
Type: System..::..String
The username of the user logging in on the DCN-SW server.
password
Type: System..::..String
The password of the user logging in.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

After calling this function, the DCN-SW API will block until the connection to the DCN-SW server has been setup and the user provided has been authenticated. This function blocks until Terminate()()()() has been called. When, after the connection has been established to the DCN-SW server, the connection is lost the DCN-SW API will retry establishing the link again until the DCN-SW API is terminated.If user has logged in with invalid username/password then it will wait till timeout of 5 seconds and will return with API_ERROR - NO_AUTHORIZATION.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | When a null reference (nothing in Visual Basic) is passed as username and/or password.

See Also

IApi Interface


Terminate Method

IApi..::..Terminate Method
IApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Terminates the DCN-SW API and logs the user off from the DCN-SW server.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function Terminate As API_ERROR
C#
API_ERROR Terminate()

Return Value

See API_ERROR for applicable errorcodes.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IApi Interface


IApi Properties

IApi Properties
IApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IApi type exposes the following members.

Properties

 | Name | Description
Public property | IsAvailable | Gets the availability-status of the DCN-SW API. Use this getter to determine whether a function on the API can be called.

See Also

IApi Interface


IsAvailable Property

IApi..::..IsAvailable Property
IApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Gets the availability-status of the DCN-SW API. Use this getter to determine whether a function on the API can be called.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsAvailable As Boolean
    Get
C#
bool IsAvailable { get; }

Field Value

true if a connection to the DCN-SW server has been setup and the user is authenticated, false otherwise, the API interfaces cannot be requested and operations on existing interfaces will fail.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IApi Interface


IApi Events

IApi Events
IApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IApi type exposes the following members.

Events

 | Name | Description
Public event | AuthorizationChange | Occurs when there is a change in the authorization state of the user of the DCN-SW API. (Inherited from IApiEvents.)
Public event | AvailabilityChange | Occurs when there is a change in the availability state of the DCN-SW API. (Inherited from IApiEvents.)

See Also

IApi Interface


IApiEvents Interface

IApiEvents Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface defining the events on the base interface for the DCN-SW API. See also IApiEvents Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IApiEvents _
    Inherits IDisposable
C#
[ObfuscationAttribute]
public interface IApiEvents : IDisposable

See Also

IApiEvents Members


IApiEvents Members

IApiEvents Members
IApiEvents Interface Methods Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IApiEvents type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)

Events

 | Name | Description
Public event | AuthorizationChange | Occurs when there is a change in the authorization state of the user of the DCN-SW API.
Public event | AvailabilityChange | Occurs when there is a change in the availability state of the DCN-SW API.

See Also

IApiEvents Interface


IApiEvents Methods

IApiEvents Methods
IApiEvents Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IApiEvents type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)

See Also

IApiEvents Interface


IApiEvents Events

IApiEvents Events
IApiEvents Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IApiEvents type exposes the following members.

Events

 | Name | Description
Public event | AuthorizationChange | Occurs when there is a change in the authorization state of the user of the DCN-SW API.
Public event | AvailabilityChange | Occurs when there is a change in the availability state of the DCN-SW API.

See Also

IApiEvents Interface


AuthorizationChange Event

IApiEvents..::..AuthorizationChange Event
IApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when there is a change in the authorization state of the user of the DCN-SW API.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event AuthorizationChange As EventHandler
C#
event EventHandler AuthorizationChange

Remarks

If the DCN-SW API is available, the authenticated user may still not have proper access rights to perform a dedicated configuration function on the DCN-SW API. When e.g. using the DCN-SW API for registering delegates, it can occur that the authenticated user does not have that right (anymore). Whether the right for registering delegates is still present can be retrieved from the interface dedicated for registering delegates, i.e. IDelegateDataApi through the IsDelegateRegistrationAllowed attribute. Similarly, the same applies when configuring voting rounds where the IsVoteRegistrationAllowed attribute in the IVoteDataApi interface indicates the presence of this access right.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IApiEvents Interface


AvailabilityChange Event

IApiEvents..::..AvailabilityChange Event
IApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when there is a change in the availability state of the DCN-SW API.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event AvailabilityChange As EventHandler
C#
event EventHandler AvailabilityChange

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IApiEvents Interface


IConfigApi Interface

IConfigApi Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
This interface represents the main entrypoint for performing limited configuration functionality through the DCN-SW API.

To start using the configuration interface, some understanding is required regarding the structuring of meetings as used in the DCN-SW application software, and the configuration items in general.

To configure meetings, the following should be understood:

  • The DCN-SW application software supports preparation of multiple meetings, of which one can be active.
  • Each meeting has delegates assigned, which are defined in the configuration and assigned as participant to the meeting in two separate step. When assigned to a meeting, the delegate can be assigned to a seat in the room where the meeting is to take place, or is taking place when active.
  • Each meeting consists of one or more configurable sessions, where each session represents an item on the agenda of the meeting. The list of sessions in fact represents the agenda of the meeting.
  • Each session can have a voting script prepared, where each vote in the script is based on a predefind vote template.

All configurable items used by the DCN-SW application software are identified with a unique identifier. This means that e.g. delegates, meetings, meeting groups, seats in a room, sessions, vote templates, votes in a voting script etc., are uniquely identified.

  • In order to retrieve the meetings and sessions that have been prepared and available in the system, use the IMeetingDataApi interface.
  • To find out which meeting groups have been defined to assign delegates to, use the IMeetingGroupDataApi interface.
  • To find out which display-, native- and spoken-languages are supported for delegates, use the ILanguageDataApi interface.
  • To define delegates and assign them to a meeting, use the IDelegateDataApi interface.
  • To retrieve the vote templates defined in the system and use them to prepare a voting script for a session, use the IVoteDataApi interface.

The interfaces as mentioned above, can be retrieved from this IConfigApi interface.

Each configurable item from the configuration, defines a set of events to register for receiving change notifications on the configurable items. Each individual configurable item provides events for:

  • Receiving store notifications. These notifications are received when one or more configuration items are newly added to the configuration.
  • Receiving update notifications. These notifications are received when one or more existing configuration items are updated in the configuration.
  • Receiving delete notifications. These notifications are received when one or more existing configuration items are removed from the configuration.

The event arguments for the events contain the identifier(s) of the configurable items stored, updated or deleted.

The amount of processing in the eventhandler function registered for an event should be kept to a minimum!

See also IConfigApi Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IConfigApi _
    Inherits IApi, IApiEvents, IDisposable
C#
[ObfuscationAttribute]
public interface IConfigApi : IApi,
    IApiEvents, IDisposable

See Also

IConfigApi Members


IConfigApi Members

IConfigApi Members
IConfigApi Interface Methods Properties Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IConfigApi type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | Initialize | Initializes the software DCN-SW API by opening a connection to the DCN-SW server and logging on as user using the given credentials. (Inherited from IApi.)
Public method | Terminate | Terminates the DCN-SW API and logs the user off from the DCN-SW server. (Inherited from IApi.)

Properties

 | Name | Description
Public property | DelegateApi | Gets a reference to a dedicated configuration data interface for retrieving, adding, deleting, changing and registering delegates. for meetings in the system.
Public property | IsAvailable | Gets the availability-status of the DCN-SW API. Use this getter to determine whether a function on the API can be called. (Inherited from IApi.)
Public property | IsConfigAllowed | Indicates whether the authorization is present to use this interface.
Public property | LanguageApi | Gets a reference to a dedicated configuration data interface for retrieving all native-, display- and spoken-languages in the system.
Public property | MeetingApi | Gets a reference to a dedicated configuration data interface for retrieving, changing and adding session specific configuration data.
Public property | MeetingGroupApi | Gets a reference to a dedicated configuration data interface for retrieving the meeting groups from the system.
Public property | SystemApi | Gets a reference to a dedicated configuration data interface for system configuration (Channels and Test).
Public property | VoteApi | Gets a reference to a dedicated configuration data interface for retrieving, adding, deleting and changing votes in a voting script for a session of a meeting.

Events

 | Name | Description
Public event | AuthorizationChange | Occurs when there is a change in the authorization state of the user of the DCN-SW API. (Inherited from IApiEvents.)
Public event | AvailabilityChange | Occurs when there is a change in the availability state of the DCN-SW API. (Inherited from IApiEvents.)

See Also

IConfigApi Interface


IConfigApi Methods

IConfigApi Methods
IConfigApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IConfigApi type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | Initialize | Initializes the software DCN-SW API by opening a connection to the DCN-SW server and logging on as user using the given credentials. (Inherited from IApi.)
Public method | Terminate | Terminates the DCN-SW API and logs the user off from the DCN-SW server. (Inherited from IApi.)

See Also

IConfigApi Interface


IConfigApi Properties

IConfigApi Properties
IConfigApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IConfigApi type exposes the following members.

Properties

 | Name | Description
Public property | DelegateApi | Gets a reference to a dedicated configuration data interface for retrieving, adding, deleting, changing and registering delegates. for meetings in the system.
Public property | IsAvailable | Gets the availability-status of the DCN-SW API. Use this getter to determine whether a function on the API can be called. (Inherited from IApi.)
Public property | IsConfigAllowed | Indicates whether the authorization is present to use this interface.
Public property | LanguageApi | Gets a reference to a dedicated configuration data interface for retrieving all native-, display- and spoken-languages in the system.
Public property | MeetingApi | Gets a reference to a dedicated configuration data interface for retrieving, changing and adding session specific configuration data.
Public property | MeetingGroupApi | Gets a reference to a dedicated configuration data interface for retrieving the meeting groups from the system.
Public property | SystemApi | Gets a reference to a dedicated configuration data interface for system configuration (Channels and Test).
Public property | VoteApi | Gets a reference to a dedicated configuration data interface for retrieving, adding, deleting and changing votes in a voting script for a session of a meeting.

See Also

IConfigApi Interface


DelegateApi Property

IConfigApi..::..DelegateApi Property
IConfigApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Gets a reference to a dedicated configuration data interface for retrieving, adding, deleting, changing and registering delegates. for meetings in the system.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DelegateApi As IDelegateDataApi
    Get
C#
IDelegateDataApi DelegateApi { get; }

Field Value

A reference to a IDelegateDataApi object.

See Also

IConfigApi Interface


IsConfigAllowed Property

IConfigApi..::..IsConfigAllowed Property
IConfigApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates whether the authorization is present to use this interface.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsConfigAllowed As Boolean
    Get
C#
bool IsConfigAllowed { get; }

Field Value

true if the authorization for using the DCN-SW API for configuration purposes is present, false otherwise.

Remarks

The property value is dependent on (1) the availability of the DCN-SW API (see IsAvailable) , and (2) the availability of the license key to use the DCN-SW API for configuration purposes.

See Also

IConfigApi Interface


LanguageApi Property

IConfigApi..::..LanguageApi Property
IConfigApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Gets a reference to a dedicated configuration data interface for retrieving all native-, display- and spoken-languages in the system.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property LanguageApi As ILanguageDataApi
    Get
C#
ILanguageDataApi LanguageApi { get; }

Field Value

A reference to a ILanguageDataApi object.

See Also

IConfigApi Interface


MeetingApi Property

IConfigApi..::..MeetingApi Property
IConfigApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Gets a reference to a dedicated configuration data interface for retrieving, changing and adding session specific configuration data.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property MeetingApi As IMeetingDataApi
    Get
C#
IMeetingDataApi MeetingApi { get; }

Field Value

A reference to a IMeetingDataApi object.

See Also

IConfigApi Interface


MeetingGroupApi Property

IConfigApi..::..MeetingGroupApi Property
IConfigApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Gets a reference to a dedicated configuration data interface for retrieving the meeting groups from the system.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property MeetingGroupApi As IMeetingGroupDataApi
    Get
C#
IMeetingGroupDataApi MeetingGroupApi { get; }

Field Value

A reference to a IMeetingGroupDataApi object.

See Also

IConfigApi Interface


SystemApi Property

IConfigApi..::..SystemApi Property
IConfigApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Gets a reference to a dedicated configuration data interface for system configuration (Channels and Test).

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SystemApi As ISystemDataApi
    Get
C#
ISystemDataApi SystemApi { get; }

Field Value

A reference to a ISystemDataApi object.

See Also

IConfigApi Interface


VoteApi Property

IConfigApi..::..VoteApi Property
IConfigApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Gets a reference to a dedicated configuration data interface for retrieving, adding, deleting and changing votes in a voting script for a session of a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property VoteApi As IVoteDataApi
    Get
C#
IVoteDataApi VoteApi { get; }

Field Value

A reference to a IVoteDataApi object.

See Also

IConfigApi Interface


IConfigApi Events

IConfigApi Events
IConfigApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IConfigApi type exposes the following members.

Events

 | Name | Description
Public event | AuthorizationChange | Occurs when there is a change in the authorization state of the user of the DCN-SW API. (Inherited from IApiEvents.)
Public event | AvailabilityChange | Occurs when there is a change in the availability state of the DCN-SW API. (Inherited from IApiEvents.)

See Also

IConfigApi Interface


IControlApi Interface

IControlApi Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface representing the main entrypoint for performing limited control functionality through the DCN-SW API.

To start using the operational interface, some understanding is required regarding the structuring of meetings as used in the DCN-SW application software, and the operational items in general.

To control meetings, the following should be understood:

  • In order to control functionality of meetings IsControlAllowed should be set to true.
  • In order to retrieve the meetings and sessions that have been prepared and available in the system, use the IMeetingDataApi interface.
  • After retrieval of meetings, select meetingid to start meeting. Only one meeting at a time can be active. If meeting is already running, trying to run same or other meeting will return with API_ERROR.
  • Each meeting consists of one or more operational sessions, where each session represents an item on the agenda of the meeting. After retrieval of all sessions of a meeting select sessionid to start session.Trying to start session when meeting is not running or trying to start a session that is already runnning or trying to stop session which is not running will return with API_ERROR. If one session is already running,trying to start another session will stop the session that is running and starts selected session.

All operational items used by the DCN-SW application software are identified with a unique identifier. This means that e.g. delegates, meetings,sessions etc., are uniquely identified.

  • In order to operate the meetings and sessions that have been prepared and available in the system, use the IMeetingApi interface.
  • In order to operate the discussion settings for meeting/sessions or to perform operations on participants and seats(i.e. Insert Request, Append Request, Cancel Request etc) or to retrieve request, comment request, speaker, notebooker list ,to set chairman priority and get chairman priority, use the IDiscussionApi interface.
  • In order to operate the voting(i.e. start, stop, hold, resume, select etc) that have been prepared and available in the system, use the IVoteApi interface.
  • In order to control the master volume, master mute, use the IDcnSystemApi IDcnSystemApi interface.

The interfaces as mentioned above, can be retrieved from this IControlApi interface.

Each operational item from the operation, defines a set of events to register for receiving change notifications on the operational items. Each individual operational item provides events for:

  • Receiving start notifications. These notifications are received when one or more operational items are started.
  • Receiving stop notifications. These notifications are received when one or more existing operational items are stopped.

The event arguments for the events contain the identifier(s) of the operational items started or stopped.

The amount of processing in the eventhandler function registered for an event should be kept to a minimum!

See also IControlApi Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IControlApi _
    Inherits IApi, IApiEvents, IDisposable
C#
[ObfuscationAttribute]
public interface IControlApi : IApi,
    IApiEvents, IDisposable

See Also

IControlApi Members


IControlApi Members

IControlApi Members
IControlApi Interface Methods Properties Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IControlApi type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | Initialize | Initializes the software DCN-SW API by opening a connection to the DCN-SW server and logging on as user using the given credentials. (Inherited from IApi.)
Public method | Terminate | Terminates the DCN-SW API and logs the user off from the DCN-SW server. (Inherited from IApi.)

Properties

 | Name | Description
Public property | DcnSystemApi | Gets a reference to a dedicated control data interface for dcn system.
Public property | DiscussionApi | Gets a reference to a dedicated control data interface for managing discussions in the system.
Public property | IsAvailable | Gets the availability-status of the DCN-SW API. Use this getter to determine whether a function on the API can be called. (Inherited from IApi.)
Public property | IsControlAllowed | This property indicates that using the DCN-SW API for operational purposes is allowed and is dependent on (1) the availability of the DCN-SW API IsAvailable, and (2) the availability of the license to use the DCN-SW API for operational purposes.
Public property | MeetingApi | Gets a reference to a dedicated control data interface for managing meeting and sessions in the system.
Public property | VoteApi | Gets a reference to a dedicated control data interface for managing votings and voting scripts in the system.

Events

 | Name | Description
Public event | AuthorizationChange | Occurs when there is a change in the authorization state of the user of the DCN-SW API. (Inherited from IApiEvents.)
Public event | AvailabilityChange | Occurs when there is a change in the availability state of the DCN-SW API. (Inherited from IApiEvents.)

See Also

IControlApi Interface


IControlApi Methods

IControlApi Methods
IControlApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IControlApi type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | Initialize | Initializes the software DCN-SW API by opening a connection to the DCN-SW server and logging on as user using the given credentials. (Inherited from IApi.)
Public method | Terminate | Terminates the DCN-SW API and logs the user off from the DCN-SW server. (Inherited from IApi.)

See Also

IControlApi Interface


IControlApi Properties

IControlApi Properties
IControlApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IControlApi type exposes the following members.

Properties

 | Name | Description
Public property | DcnSystemApi | Gets a reference to a dedicated control data interface for dcn system.
Public property | DiscussionApi | Gets a reference to a dedicated control data interface for managing discussions in the system.
Public property | IsAvailable | Gets the availability-status of the DCN-SW API. Use this getter to determine whether a function on the API can be called. (Inherited from IApi.)
Public property | IsControlAllowed | This property indicates that using the DCN-SW API for operational purposes is allowed and is dependent on (1) the availability of the DCN-SW API IsAvailable, and (2) the availability of the license to use the DCN-SW API for operational purposes.
Public property | MeetingApi | Gets a reference to a dedicated control data interface for managing meeting and sessions in the system.
Public property | VoteApi | Gets a reference to a dedicated control data interface for managing votings and voting scripts in the system.

See Also

IControlApi Interface


DcnSystemApi Property

IControlApi..::..DcnSystemApi Property
IControlApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Gets a reference to a dedicated control data interface for dcn system.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DcnSystemApi As IDcnSystemApi
    Get
C#
IDcnSystemApi DcnSystemApi { get; }

Field Value

A reference to a IDcnSystemApi object.

See Also

IControlApi Interface


DiscussionApi Property

IControlApi..::..DiscussionApi Property
IControlApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Gets a reference to a dedicated control data interface for managing discussions in the system.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DiscussionApi As IDiscussionApi
    Get
C#
IDiscussionApi DiscussionApi { get; }

Field Value

A reference to a IDiscussionApi object.

See Also

IControlApi Interface


IsControlAllowed Property

IControlApi..::..IsControlAllowed Property
IControlApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
This property indicates that using the DCN-SW API for operational purposes is allowed and is dependent on (1) the availability of the DCN-SW API IsAvailable, and (2) the availability of the license to use the DCN-SW API for operational purposes.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsControlAllowed As Boolean
    Get
C#
bool IsControlAllowed { get; }

Field Value

true if the authorization for using the DCN-SW API for control purposes is present, false otherwise.

Remarks

When one user is already conencted to DCN-SW Server via API, and then another user connecting through API to DNC-SW Server from different PCs / IP address, requires DCN-SWMPC (Muilti PC) license. But, still user can start API client more than once (in single PC) without the need for DCN-SWMPC.

See Also

IControlApi Interface


MeetingApi Property

IControlApi..::..MeetingApi Property
IControlApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Gets a reference to a dedicated control data interface for managing meeting and sessions in the system.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property MeetingApi As IMeetingApi
    Get
C#
IMeetingApi MeetingApi { get; }

Field Value

A reference to a IMeetingApi object.

See Also

IControlApi Interface


VoteApi Property

IControlApi..::..VoteApi Property
IControlApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Gets a reference to a dedicated control data interface for managing votings and voting scripts in the system.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property VoteApi As IVoteApi
    Get
C#
IVoteApi VoteApi { get; }

Field Value

A reference to a IVoteApi object.

See Also

IControlApi Interface


IControlApi Events

IControlApi Events
IControlApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IControlApi type exposes the following members.

Events

 | Name | Description
Public event | AuthorizationChange | Occurs when there is a change in the authorization state of the user of the DCN-SW API. (Inherited from IApiEvents.)
Public event | AvailabilityChange | Occurs when there is a change in the availability state of the DCN-SW API. (Inherited from IApiEvents.)

See Also

IControlApi Interface


IDcnSystemApi Interface

IDcnSystemApi Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface that can be used to control and retrieve Dcn System master volume and mute Settings

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IDcnSystemApi _
    Inherits IDcnSystemApiEvents
C#
[ObfuscationAttribute]
public interface IDcnSystemApi : IDcnSystemApiEvents

See Also

IDcnSystemApi Members


IDcnSystemApi Members

IDcnSystemApi Members
IDcnSystemApi Interface Methods Properties Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDcnSystemApi type exposes the following members.

Methods

 | Name | Description
Public method | GetMasterMute | Get the audio mute state of the DCN System.
Public method | GetMasterVolume | Get the master volume level of the DCN System
Public method | SetMasterMute | Set the audio mute state of the DCN System.
Public method | SetMasterVolume | Set the master volume level of the DCN System.

Properties

 | Name | Description
Public property | IsSensitivityAndVolumeLevelsChangeAllowed | Information which will indicate whether the user can control master volume and mute. When licenses DCN-SW and privilege CD are present, value will be set to true.

Events

 | Name | Description
Public event | masterMuteChange | Occurs when the DCN system audio mute changes. (Inherited from IDcnSystemApiEvents.)
Public event | masterVolumeChange | Occurs when the DCN system master volume changes. (Inherited from IDcnSystemApiEvents.)

See Also

IDcnSystemApi Interface


IDcnSystemApi Methods

IDcnSystemApi Methods
IDcnSystemApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDcnSystemApi type exposes the following members.

Methods

 | Name | Description
Public method | GetMasterMute | Get the audio mute state of the DCN System.
Public method | GetMasterVolume | Get the master volume level of the DCN System
Public method | SetMasterMute | Set the audio mute state of the DCN System.
Public method | SetMasterVolume | Set the master volume level of the DCN System.

See Also

IDcnSystemApi Interface


GetMasterMute Method

IDcnSystemApi..::..GetMasterMute Method
IDcnSystemApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Get the audio mute state of the DCN System.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function GetMasterMute ( _
    <OutAttribute> ByRef masterMute As Boolean _
) As API_ERROR
C#
API_ERROR GetMasterMute(
    out bool masterMute
)

Parameters

masterMute
Type: System..::..Boolean %
The master volume level

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsSensitivityAndVolumeLevelsChangeAllowed is set to false.
NOT_ACTIVE - meeting is not running.
ERROR - Exception.

Examples

Below example shows how to get master volume using API method - GetMasterVolume.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDcnSystemApi dcnSystemApi = controlApi.DcnSystemApi;

                          //Call Api method to get master mute status.
                          bool masterMute =0;
                          error = dcnSystemApi.GetMasterMute(out masterMute);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDcnSystemApi Interface


GetMasterVolume Method

IDcnSystemApi..::..GetMasterVolume Method
IDcnSystemApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Get the master volume level of the DCN System

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function GetMasterVolume ( _
    <OutAttribute> ByRef masterVolume As Integer _
) As API_ERROR
C#
API_ERROR GetMasterVolume(
    out int masterVolume
)

Parameters

masterVolume
Type: System..::..Int32 %
The master volume level

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsSensitivityAndVolumeLevelsChangeAllowed is set to false.
NOT_ACTIVE - meeting is not running.
ERROR - Exception.

Examples

Below example shows how to get master volume using API method - GetMasterVolume.

Copy image Copy Code
             Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                     IDcnSystemApi dcnSystemApi = controlApi.DcnSystemApi;

                     //Call Api method to get master volume count.
                     int masterVolume =0;
                     error = dcnSystemApi.GetMasterVolume(out masterVolume);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDcnSystemApi Interface


SetMasterMute Method

IDcnSystemApi..::..SetMasterMute Method
IDcnSystemApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Set the audio mute state of the DCN System.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function SetMasterMute ( _
    masterMute As Boolean _
) As API_ERROR
C#
API_ERROR SetMasterMute(
    bool masterMute
)

Parameters

masterMute
Type: System..::..Boolean
The master mute state

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
INVALID_PARAMETER - master volume value is invalid
NO_AUTHORIZATION - IsSensitivityAndVolumeLevelsChangeAllowed is set to false.
NOT_ACTIVE - meeting is not running.
ERROR - Exception.

Examples

Below example shows how to get master volume using API method - GetMasterVolume.

Copy image Copy Code
             Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                     IDcnSystemApi dcnSystemApi = controlApi.DcnSystemApi;

                     //Call Api method to get master volume count.
                     error = dcnSystemApi.SetMasterVolume(masterVolume);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDcnSystemApi Interface


SetMasterVolume Method

IDcnSystemApi..::..SetMasterVolume Method
IDcnSystemApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Set the master volume level of the DCN System.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function SetMasterVolume ( _
    masterVolume As Integer _
) As API_ERROR
C#
API_ERROR SetMasterVolume(
    int masterVolume
)

Parameters

masterVolume
Type: System..::..Int32
The masterVolume level

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
INVALID_PARAMETER - master volume value is invalid , Minimum value -12 and Maximum Value +12
NO_AUTHORIZATION - IsSensitivityAndVolumeLevelsChangeAllowed is set to false.
NOT_ACTIVE - meeting is not running.
ERROR - Exception.

Examples

Below example shows how to get master volume using API method - GetMasterVolume.

Copy image Copy Code
             Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                     IDcnSystemApi dcnSystemApi = controlApi.DcnSystemApi;

                     //Call Api method to get master volume count.
                     error = dcnSystemApi.SetMasterVolume(masterVolume);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDcnSystemApi Interface


IDcnSystemApi Properties

IDcnSystemApi Properties
IDcnSystemApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDcnSystemApi type exposes the following members.

Properties

 | Name | Description
Public property | IsSensitivityAndVolumeLevelsChangeAllowed | Information which will indicate whether the user can control master volume and mute. When licenses DCN-SW and privilege CD are present, value will be set to true.

See Also

IDcnSystemApi Interface


IsSensitivityAndVolumeLevelsChangeAllowed Property

IDcnSystemApi..::..IsSensitivityAndVolumeLevelsChangeAllowed Property
IDcnSystemApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Information which will indicate whether the user can control master volume and mute.
When licenses DCN-SW and privilege CD are present, value will be set to true.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsSensitivityAndVolumeLevelsChangeAllowed As Boolean
    Get
C#
bool IsSensitivityAndVolumeLevelsChangeAllowed { get; }

Field Value

true if this is allowed, false otherwise.

See Also

IDcnSystemApi Interface


IDcnSystemApi Events

IDcnSystemApi Events
IDcnSystemApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDcnSystemApi type exposes the following members.

Events

 | Name | Description
Public event | masterMuteChange | Occurs when the DCN system audio mute changes. (Inherited from IDcnSystemApiEvents.)
Public event | masterVolumeChange | Occurs when the DCN system master volume changes. (Inherited from IDcnSystemApiEvents.)

See Also

IDcnSystemApi Interface


IDcnSystemApiEvents Interface

IDcnSystemApiEvents Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface defining events for the DCN system master volume and master mute settings

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IDcnSystemApiEvents
C#
[ObfuscationAttribute]
public interface IDcnSystemApiEvents

See Also

IDcnSystemApiEvents Members


IDcnSystemApiEvents Members

IDcnSystemApiEvents Members
IDcnSystemApiEvents Interface Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDcnSystemApiEvents type exposes the following members.

Events

 | Name | Description
Public event | masterMuteChange | Occurs when the DCN system audio mute changes.
Public event | masterVolumeChange | Occurs when the DCN system master volume changes.

See Also

IDcnSystemApiEvents Interface


IDcnSystemApiEvents Events

IDcnSystemApiEvents Events
IDcnSystemApiEvents Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDcnSystemApiEvents type exposes the following members.

Events

 | Name | Description
Public event | masterMuteChange | Occurs when the DCN system audio mute changes.
Public event | masterVolumeChange | Occurs when the DCN system master volume changes.

See Also

IDcnSystemApiEvents Interface


masterMuteChange Event

IDcnSystemApiEvents..::..masterMuteChange Event
IDcnSystemApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when the DCN system audio mute changes.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event masterMuteChange As EventHandler(Of OnOffEventArgs)
C#
event EventHandler<OnOffEventArgs> masterMuteChange

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDcnSystemApiEvents Interface


masterVolumeChange Event

IDcnSystemApiEvents..::..masterVolumeChange Event
IDcnSystemApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when the DCN system master volume changes.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event masterVolumeChange As EventHandler(Of CountEventArgs)
C#
event EventHandler<CountEventArgs> masterVolumeChange

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDcnSystemApiEvents Interface


IDelegateDataApi Interface

IDelegateDataApi Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface that is to be used to add, remove, change delegate information and (un)register delegates as participant to a meeting. See also IDelegateDataApi Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IDelegateDataApi _
    Inherits IDelegateDataApiEvents
C#
[ObfuscationAttribute]
public interface IDelegateDataApi : IDelegateDataApiEvents

Remarks

To successfully allow a delegate to participate in a meeting, 2 criteria must be met:

  • The delegate must be available in the configuration on the DCN-SW server.
  • The delegate must be registered as participant to a meeting.

To achieve this, functions are provided on this interface to:

  • Retrieve the set of delegates already in the configuration on the DCN-SW server.
  • Add, change or delete the configuration data of individual delegates in the configuration on the DCN-SW server.
  • Retrieve the set of delegates already registered as participant to a meeting from the configuration on the DCN-SW server.
  • Register, unregister or change the meeting-registration information of individual delegates in the configuration on the DCN-SW server.

The following example shows how to add a new delegate and register him as participant to a meeting:

Examples

Copy image Copy Code
               using Bosch.Dcn.Ecpc.Client.Api.Interfaces;
               using Bosch.Dcn.Ecpc.Client.Api.Logic;

               class Example
               {
                   public static void Main()
                   {
                       IConfigApi configApi = DcnApi.ConfigApi;

                       // ...handle initialization of the DCN-SW API here....

                       IMeetingGroupDataApi meetingGroupApi = configApi.MeetingGroupApi;

                       int[] meetingGroupIds;
                       MEETING_GROUP_INFO[] groups;
                       API_ERROR error;

                       if (configApi.IsAvailable)
                       {
                            error = meetingGroupApi.RetrieveMeetingGroups(out meetingGroupIds, out groups);
                            if (API_ERROR.NONE == error)
                            {
                                int meetingGroup = meetingGroupIds[0];     // As an example, simply pick a meeting group...
                                ILanguageDataApi languageApi = configApi.LanguageApi;
                                int[] languageIds;
                                LANGUAGE_INFO[] languages;
                                int displayLanguage;
                                int nativeLanguage;
                                int spokenLanguage;

                                error = languageApi.RetrieveDisplayLanguages(out languageIds, out languages);
                                displayLanguage = languageIds[0];        // As an example, simply pick a language...

                                error = languageApi.RetrieveNativeLanguages(out languageIds, out languages);
                                nativeLanguage = languageIds[0];         // As an example, simply pick a language...

                                error = languageApi.RetrieveSpokenLanguages(out languageIds, out languages);
                                spokenLanguage = languageIds[0];         // As an example, simply pick a language...

                                if (API_ERROR.NONE == error)
                                {
                                    DELEGATE_INFO theDelegate = new DELEGATE_INFO();
                                    IDelegateDataApi delegateApi = configApi.DelegateApi;

                                    delegateApi.DelegateStore += OnNewDelegates;
                                    delegateApi.DelegateUpdate += OnDelegatesChanged;
                                    delegateApi.DelegateDeletion += OnDelegatesRemoved;
                                    delegateApi.DelegateRegistration += OnDelegatesRegisteredToMeeting;
                                    delegateApi.DelegateRegistrationUpdate += OnDelegateRegistrationsChanged;
                                    delegateApi.DelegateUnregistration += OnDelegatesUnregisteredFromMeeting;

                                    theDelegate.FirstName = "MijnDelegate";
                                    theDelegate.MiddleName = "van";
                                    theDelegate.LastName = "";
                                    theDelegate.Region = "nl";
                                    theDelegate.Title = "Mr.";
                                    theDelegate.Country = "Nederland";
                                    theDelegate.MeetingGroupId = meetingGroup;
                                    theDelegate.NativeLanguageId = nativeLanguage;
                                    theDelegate.SpokenLanguageId = spokenLanguage;
                                    theDelegate.DisplayLanguageId = displayLanguage;

                                    int[] newDelegateIds;

                                    if (delegateApi.IsDelegateRegistrationAllowed)
                                    {
                                        error = delegateApi.StoreDelegates(new DELEGATE_INFO[1] { theDelegate }, out newDelegateIds);

                                        int delegateId = newDelegateIds[0];  // First entry contains ID for newly stored delegate...

                                        error = delegageApi.AssignDelegateIdCards(new int[1] { delegateId }, new int[1] { 5000 });   // ID-card 5000 assigned

                                        int[] meetingIds;
                                        MEETING_INFO[] meetings;

                                        error = configApi.MeetingApi.RetrieveMeetings(out meetingIds, out meetings);
                                        if (API_ERROR.NONE == error)
                                        {
                                            PARTICIPATION_INFO theParticipant = new PARTICIPATION_INFO();

                                            theParticipant.VoteWeight = PARTICIPATION_INFO.MIN_VOTE_WEIGHT;
                                            theParticipant.AssignedSeatId = PARTICIPATION_INFO.NO_SEAT;
                                            theParticipant.Rights = (PARTICIPATION_INFO.RIGHT_DISCUSS | PARTICIPATION_INFO.RIGHT_VOTE);

                                            int meetingId = meetingIds[0];         // As an example, simply pick a meeting...

                                            if (API_ERROR.NONE == delegateApi.RegisterDelegatesForMeeting(meetingId, new int[1] { delegateId }, new PARTICIPATION_INFO[1] { theParticipant }))
                                            {
                                                // Delegate registered for meeting...!!!
                                            }
                                        }
                                    }
                                }
                            }
                        }
                   }

                   private void OnNewDelegates(object sender, DelegateDataChangedEventArgs args)
                   {
                       // Handle addition of new delegates here...
                   }

                   private void OnDelegatesRemoved(object sender, DelegateDataChangedEventArgs args)
                   {
                       // Handle removal of delegates here...
                   }

                   private void OnDelegatesChanged(object sender, DelegateDataChangedEventArgs args)
                   {
                       // Handle changes to delegates here...
                   }

                   private void OnDelegatesRegisteredToMeeting(object sender, DelegateRegistrationEventArgs args)
                   {
                       // Handle registration of delegates here...
                   }

                   private void OnDelegatesUnregisteredFromMeeting(object sender, DelegateRegistrationEventArgs args)
                   {
                       // Handle unregistration of delegates here...
                   }

                   private void OnDelegateRegistrationsChanged(object sender, DelegateRegistrationEventArgs args)
                   {
                       // Handle changes to delegate registrations here...
                   }
               }

See Also

IDelegateDataApi Members


IDelegateDataApi Members

IDelegateDataApi Members
IDelegateDataApi Interface Methods Properties Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDelegateDataApi type exposes the following members.

Methods

 | Name | Description
Public method | AddRequestToSpeak | Add request to speak for participant to the request list of a session of a meeting.
Public method | AssignDelegateIdCards | Assigns ID-cards to delegates.
Public method | DeleteDelegates | Deletes a delegate from the configuration.
Public method | ProduceCardForDelegate | Produces an ID-card for the given delegate. The delegate must have an ID-card assigned first.
Public method | ReadCard | Reads the ID-card inserted in the card reader.
Public method | RegisterDelegatesForMeeting | Registers (a) delegate(s) for a meeting.
Public method | RemoveAllRequestToSpeak | Remove All participants from request list of a session of a meeting.
Public method | RemoveRequestToSpeak | Remove participant from request list of a session of a meeting.
Public method | RetrieveDelegateIdCardAssignments | Retrieves the list of ID-card assigned to the identified delegates.
Public method | RetrieveDelegates | Retrieves the set of delegates defined in the system.
Public method | RetrieveDelegatesById | Retrieves the set of delegates, identified by delegate ID.
Public method | RetrieveRegisteredDelegatesForMeeting | Retrieves the registration information of delegates for a meeting.
Public method | RetrieveSeatAssignmentForArea | Retrieves the seat assignment of delegates currently registered for a meeting.
Public method | StoreDelegates | Adds (a) new delegate(s) in the configuration.
Public method | UnregisterDelegatesForMeeting | Unregisters the given list of delegates from the given meeting.
Public method | UpdateDelegates | Updates the information of (a) delegate(s) in the configuration.
Public method | UpdateRegistrationForDelegates | Updates the registration information of (a) delegate(s) of a meeting.

Properties

 | Name | Description
Public property | IsCardProductionAllowed | Indicates whether production of ID-cards is allowed.
Public property | IsDelegateRegistrationAllowed | Indicates whether store, update, deletion and registration of delegates to meetings is allowed from this interface.

Events

 | Name | Description
Public event | DelegateDeletion | Occurs when a delegate was deleted. (Inherited from IDelegateDataApiEvents.)
Public event | DelegateRegistration | Occurs when (a) delegate(s) is/are registered for a meeting. (Inherited from IDelegateDataApiEvents.)
Public event | DelegateRegistrationUpdate | Occurs when the meeting registration of (a) delegate(s) is/are updated. (Inherited from IDelegateDataApiEvents.)
Public event | DelegateStore | Occurs when (a) new delegate was added. (Inherited from IDelegateDataApiEvents.)
Public event | DelegateUnregistration | Occurs when a delegate is unregistered from a meeting. (Inherited from IDelegateDataApiEvents.)
Public event | DelegateUpdate | Occurs when (a) delegate(s) is/are updated, or his ID-card assigment has been updated. (Inherited from IDelegateDataApiEvents.)
Public event | RequestDeletion | Occcurs when a request is deleted from the database on the server. (Inherited from IDelegateDataApiEvents.)
Public event | RequestStore | Occcurs when a new request is stored in the database on the server. (Inherited from IDelegateDataApiEvents.)
Public event | RequestUpdate | Occcurs when a request is updated from the database on the server. (Inherited from IDelegateDataApiEvents.)

See Also

IDelegateDataApi Interface


IDelegateDataApi Methods

IDelegateDataApi Methods
IDelegateDataApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDelegateDataApi type exposes the following members.

Methods

 | Name | Description
Public method | AddRequestToSpeak | Add request to speak for participant to the request list of a session of a meeting.
Public method | AssignDelegateIdCards | Assigns ID-cards to delegates.
Public method | DeleteDelegates | Deletes a delegate from the configuration.
Public method | ProduceCardForDelegate | Produces an ID-card for the given delegate. The delegate must have an ID-card assigned first.
Public method | ReadCard | Reads the ID-card inserted in the card reader.
Public method | RegisterDelegatesForMeeting | Registers (a) delegate(s) for a meeting.
Public method | RemoveAllRequestToSpeak | Remove All participants from request list of a session of a meeting.
Public method | RemoveRequestToSpeak | Remove participant from request list of a session of a meeting.
Public method | RetrieveDelegateIdCardAssignments | Retrieves the list of ID-card assigned to the identified delegates.
Public method | RetrieveDelegates | Retrieves the set of delegates defined in the system.
Public method | RetrieveDelegatesById | Retrieves the set of delegates, identified by delegate ID.
Public method | RetrieveRegisteredDelegatesForMeeting | Retrieves the registration information of delegates for a meeting.
Public method | RetrieveSeatAssignmentForArea | Retrieves the seat assignment of delegates currently registered for a meeting.
Public method | StoreDelegates | Adds (a) new delegate(s) in the configuration.
Public method | UnregisterDelegatesForMeeting | Unregisters the given list of delegates from the given meeting.
Public method | UpdateDelegates | Updates the information of (a) delegate(s) in the configuration.
Public method | UpdateRegistrationForDelegates | Updates the registration information of (a) delegate(s) of a meeting.

See Also

IDelegateDataApi Interface


AddRequestToSpeak Method

IDelegateDataApi..::..AddRequestToSpeak Method
IDelegateDataApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Add request to speak for participant to the request list of a session of a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function AddRequestToSpeak ( _
    sessionId As Integer, _
    delegateId As Integer _
) As API_ERROR
C#
API_ERROR AddRequestToSpeak(
    int sessionId,
    int delegateId
)

Parameters

sessionId
Type: System..::..Int32
The session to which participant being Added.
delegateId
Type: System..::..Int32
The participant to be added to request list.

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - if authorization is not for configuration.
UNKNOWN_SESSION - if unknown session id or database is disconnected.
INVALID_PARAMETER - if delegate id or session id parameter is invalid or delegate is not part of the meeting.
ERROR - Exception.

Examples

Below example shows how to add request to session using API method - AddRequestToSpeak.

Copy image Copy Code
             //Get Config API.
             configApi = DcnApi.ConfigApi;
             configApi.DelegateApi.RequestStore += onRequestStore;
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (configApi.IsAvailable)
                  {
                     IDelegateDataApi requestDataApi = configApi.DelegateApi;
                      //Call Api method to adding request to session.
                      error = requestDataApi.AddRequestToSpeak(sessionId,delegateId );
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while adding request to session.
             }
             ....

             private void onRequestStore(object sender, RequestDataChangedEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDelegateDataApi Interface


AssignDelegateIdCards Method

IDelegateDataApi..::..AssignDelegateIdCards Method
IDelegateDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Assigns ID-cards to delegates.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function AssignDelegateIdCards ( _
    delegateIds As Integer(), _
    cardCodes As Integer() _
) As API_ERROR
C#
API_ERROR AssignDelegateIdCards(
    int[] delegateIds,
    int[] cardCodes
)

Parameters

delegateIds
Type: array< System..::..Int32 >[]()[][]
The list of ID's for delegates to assign a card to.
cardCodes
Type: array< System..::..Int32 >[]()[][]
Defines the list of ID-card codes that are assigned to the delegates. A value ranging from 1 to 999999999, or NO_CARD to unassign the card from a delegate.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

If an ID-card code is assigned to a delegate already assigned to another delegate, the ID-card code assignment will be removed first before it is re-assigned to the new delegate.

Remarks

This function may potentionally block. It will block if the DCN-SW server is not ready to accept the request!

Remarks

Requires IsDelegateRegistrationAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..ArgumentOutOfRangeException | If the sizes of the argument arrays do not match.
System..::..FormatException | If the delegate information in the list contains invalid data, or the list if ID-card contains an invalid ID-card code to assign.

See Also

IDelegateDataApi Interface


DeleteDelegates Method

IDelegateDataApi..::..DeleteDelegates Method
IDelegateDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Deletes a delegate from the configuration.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function DeleteDelegates ( _
    delegateIds As Integer() _
) As API_ERROR
C#
API_ERROR DeleteDelegates(
    int[] delegateIds
)

Parameters

delegateIds
Type: array< System..::..Int32 >[]()[][]
The list of ID's for delegates to delete.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Deleting a delegates will automatically clear the delegate's registration information.

Remarks

Deletion of delegates will fail if delegate is registered for a meeting currently active.

Remarks

This function may potentionally block. It will block if the DCN-SW server is not ready to accept the request!

Remarks

Requires IsDelegateRegistrationAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | If one or more of the delegate ID's is invalid.

See Also

IDelegateDataApi Interface


ProduceCardForDelegate Method

IDelegateDataApi..::..ProduceCardForDelegate Method
IDelegateDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Produces an ID-card for the given delegate. The delegate must have an ID-card assigned first.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function ProduceCardForDelegate ( _
    delegateId As Integer _
) As API_ERROR
C#
API_ERROR ProduceCardForDelegate(
    int delegateId
)

Parameters

delegateId
Type: System..::..Int32
The identifier of the delegate to produce a card for.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsCardProductionAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..FormatException | If delegate ID is invalid.

See Also

IDelegateDataApi Interface


ReadCard Method

IDelegateDataApi..::..ReadCard Method
IDelegateDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Reads the ID-card inserted in the card reader.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function ReadCard ( _
    <OutAttribute> ByRef cardCode As Integer, _
    <OutAttribute> ByRef delegateId As Integer _
) As API_ERROR
C#
API_ERROR ReadCard(
    out int cardCode,
    out int delegateId
)

Parameters

cardCode
Type: System..::..Int32 %
The cardcode of the ID-card. A value 0 indicates the card is empty.
delegateId
Type: System..::..Int32 %
The delegate to whom the read card is assigned. Value NO_CARD indicates the card is not assigned to a delegate.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsCardProductionAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDelegateDataApi Interface


RegisterDelegatesForMeeting Method

IDelegateDataApi..::..RegisterDelegatesForMeeting Method
IDelegateDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Registers (a) delegate(s) for a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RegisterDelegatesForMeeting ( _
    meetingId As Integer, _
    delegateIds As Integer(), _
    participation As PARTICIPATION_INFO() _
) As API_ERROR
C#
API_ERROR RegisterDelegatesForMeeting(
    int meetingId,
    int[] delegateIds,
    PARTICIPATION_INFO[] participation
)

Parameters

meetingId
Type: System..::..Int32
The ID of the meeting to register for.
delegateIds
Type: array< System..::..Int32 >[]()[][]
The list of ID's for delegates.
participation
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..PARTICIPATION_INFO >[]()[][]
The participation information for registration.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

This function may potentionally block. It will block if the DCN-SW server is not ready to accept the request.
Assignment of delegate to seat type DCN-SW OPR, DCN-CCU, DCN-CCU Slave, DCN-IDESK, DCN-DDI Entrance, DCN-DDI Exit and DCN-FVU returns with api error INVALID_SEAT_ID.

Remarks

Requires IsDelegateRegistrationAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..ArgumentOutOfRangeException | If the array-lengths do not correspond, or an out-of-range value is supplied as participation info.
System..::..FormatException | If one or more of the delegate ID's is invalid, the participation information contains invalid data or the meeting ID is invalid.

See Also

IDelegateDataApi Interface


RemoveAllRequestToSpeak Method

IDelegateDataApi..::..RemoveAllRequestToSpeak Method
IDelegateDataApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Remove All participants from request list of a session of a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RemoveAllRequestToSpeak ( _
    sessionId As Integer _
) As API_ERROR
C#
API_ERROR RemoveAllRequestToSpeak(
    int sessionId
)

Parameters

sessionId
Type: System..::..Int32
The session from which all participants in request list will be removed.

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - if authorization is not for configuration.
UNKNOWN_SESSION - if unknown session id or database is disconnected.
INVALID_PARAMETER - if session id paramter is invalid.
ERROR - Exception.

Examples

Below example shows how to remove all requests from session using API method - RemoveAllRequestToSpeak.

Copy image Copy Code
             //Get Config API.
             configApi = DcnApi.ConfigApi;
             configApi.DelegateApi.RequestDeletion += onRequestDeletion;
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (configApi.IsAvailable)
                  {
                     IDelegateDataApi requestDataApi = configApi.DelegateApi;
                      //Call Api method to removing all requests from session.
                      error = requestDataApi.RemoveAllRequestToSpeak(sessionId );
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while removing all requests
             }
             ....

             private void onRequestDeletion(object sender, RequestDataChangedEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDelegateDataApi Interface


RemoveRequestToSpeak Method

IDelegateDataApi..::..RemoveRequestToSpeak Method
IDelegateDataApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Remove participant from request list of a session of a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RemoveRequestToSpeak ( _
    sessionId As Integer, _
    delegateId As Integer _
) As API_ERROR
C#
API_ERROR RemoveRequestToSpeak(
    int sessionId,
    int delegateId
)

Parameters

sessionId
Type: System..::..Int32
The session from which participant being removed.
delegateId
Type: System..::..Int32
The participant to be removed from request list.

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - if authorization is not for configuration.
UNKNOWN_SESSION - if unknown session id or database is disconnected.
INVALID_PARAMETER - if delegate id or session id parameter is invalid.
NOT_IN_REQUEST_LIST - if delegate id is not part of the request list.
ERROR - Exception.

Examples

Below example shows how to remove request from session using API method - RemoveRequestToSpeak.

Copy image Copy Code
             //Get Config API.
             configApi = DcnApi.ConfigApi;
             configApi.DelegateApi.RequestDeletion += onRequestDeletion;
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (configApi.IsAvailable)
                  {
                     IDelegateDataApi requestDataApi = configApi.DelegateApi;
                      //Call Api method to removing request from session.
                      error = requestDataApi.RemoveRequestToSpeak(sessionId,delegateId );
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while removing request
             }
             ....

             private void onRequestDeletion(object sender, RequestDataChangedEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDelegateDataApi Interface


RetrieveDelegateIdCardAssignments Method

IDelegateDataApi..::..RetrieveDelegateIdCardAssignments Method
IDelegateDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the list of ID-card assigned to the identified delegates.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveDelegateIdCardAssignments ( _
    delegateIds As Integer(), _
    <OutAttribute> ByRef cardCodes As Integer() _
) As API_ERROR
C#
API_ERROR RetrieveDelegateIdCardAssignments(
    int[] delegateIds,
    out int[] cardCodes
)

Parameters

delegateIds
Type: array< System..::..Int32 >[]()[][]
The list of ID's for delegates to retrieve the ID-card assignments for.
cardCodes
Type: array< System..::..Int32 >[]()[][]%
The list of ID-card codes that are assigned to each individual delegate.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | If one or more of the delegate ID's is invalid.

See Also

IDelegateDataApi Interface


RetrieveDelegates Method

IDelegateDataApi..::..RetrieveDelegates Method
IDelegateDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the set of delegates defined in the system.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveDelegates ( _
    <OutAttribute> ByRef delegateIds As Integer(), _
    <OutAttribute> ByRef delegates As DELEGATE_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveDelegates(
    out int[] delegateIds,
    out DELEGATE_INFO[] delegates
)

Parameters

delegateIds
Type: array< System..::..Int32 >[]()[][]%
The list of ID's defining the set of available delegates.
delegates
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DELEGATE_INFO >[]()[][]%
The list of delegates.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDelegateDataApi Interface


RetrieveDelegatesById Method

IDelegateDataApi..::..RetrieveDelegatesById Method
IDelegateDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the set of delegates, identified by delegate ID.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveDelegatesById ( _
    delegateIds As Integer(), _
    <OutAttribute> ByRef delegates As DELEGATE_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveDelegatesById(
    int[] delegateIds,
    out DELEGATE_INFO[] delegates
)

Parameters

delegateIds
Type: array< System..::..Int32 >[]()[][]
The list of ID's defining the set of delegates to retrieve.
delegates
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DELEGATE_INFO >[]()[][]%
The list of delegates.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | if the list of delegate ID's contains an invalid ID.

See Also

IDelegateDataApi Interface


RetrieveRegisteredDelegatesForMeeting Method

IDelegateDataApi..::..RetrieveRegisteredDelegatesForMeeting Method
IDelegateDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the registration information of delegates for a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveRegisteredDelegatesForMeeting ( _
    meetingId As Integer, _
    <OutAttribute> ByRef delegateIds As Integer(), _
    <OutAttribute> ByRef participation As PARTICIPATION_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveRegisteredDelegatesForMeeting(
    int meetingId,
    out int[] delegateIds,
    out PARTICIPATION_INFO[] participation
)

Parameters

meetingId
Type: System..::..Int32
The ID of the meeting to retrieve information for.
delegateIds
Type: array< System..::..Int32 >[]()[][]%
The list of ID's for delegates.
participation
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..PARTICIPATION_INFO >[]()[][]%
The registration information of the given delegates.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..FormatException | If one or more of the delegate ID's is invalid or the meeting ID is invalid.

See Also

IDelegateDataApi Interface


RetrieveSeatAssignmentForArea Method

IDelegateDataApi..::..RetrieveSeatAssignmentForArea Method
IDelegateDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the seat assignment of delegates currently registered for a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveSeatAssignmentForArea ( _
    meetingId As Integer, _
    areaId As Integer, _
    <OutAttribute> ByRef assignments As SEAT_ASSIGNMENT() _
) As API_ERROR
C#
API_ERROR RetrieveSeatAssignmentForArea(
    int meetingId,
    int areaId,
    out SEAT_ASSIGNMENT[] assignments
)

Parameters

meetingId
Type: System..::..Int32
The meeting ID to retrieve registrations for.
areaId
Type: System..::..Int32
The area of the meeting to retrieve the seating arrangement for.
assignments
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SEAT_ASSIGNMENT >[]()[][]%
The seating arrangement for the meeting.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Only DEFAULT_AREA is supported.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..FormatException | If the ID for the meeting or the area is/are invalid.

See Also

IDelegateDataApi Interface


StoreDelegates Method

IDelegateDataApi..::..StoreDelegates Method
IDelegateDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Adds (a) new delegate(s) in the configuration.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function StoreDelegates ( _
    delegates As DELEGATE_INFO(), _
    <OutAttribute> ByRef delegateIds As Integer() _
) As API_ERROR
C#
API_ERROR StoreDelegates(
    DELEGATE_INFO[] delegates,
    out int[] delegateIds
)

Parameters

delegates
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DELEGATE_INFO >[]()[][]
The delegates to store.
delegateIds
Type: array< System..::..Int32 >[]()[][]%
The list of ID's identifying the new delegates.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

The stored delegates will not have an ID-card assigned, use AssignDelegateIdCards(array<Int32>[]()[][], array<Int32>[]()[][]) to assign the delegate an ID-card.

Remarks

This function may potentionally block. It will block if the DCN-SW server is not ready to accept the request!

Remarks

Requires IsDelegateRegistrationAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | If the delegate information in the list contains invalid data.

See Also

IDelegateDataApi Interface


UnregisterDelegatesForMeeting Method

IDelegateDataApi..::..UnregisterDelegatesForMeeting Method
IDelegateDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Unregisters the given list of delegates from the given meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function UnregisterDelegatesForMeeting ( _
    meetingId As Integer, _
    delegateIds As Integer() _
) As API_ERROR
C#
API_ERROR UnregisterDelegatesForMeeting(
    int meetingId,
    int[] delegateIds
)

Parameters

meetingId
Type: System..::..Int32
The ID of the meeting to unregister delegates for.
delegateIds
Type: array< System..::..Int32 >[]()[][]
The list of ID's for delegates.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Unregistration of delegates for a meeting will fail when the meeting is currently active.

Remarks

This function may potentionally block. It will block if the DCN-SW server is not ready to accept the request!

Remarks

Requires IsDelegateRegistrationAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | If one or more of the delegate ID's is invalid or the meeting ID is invalid.

See Also

IDelegateDataApi Interface


UpdateDelegates Method

IDelegateDataApi..::..UpdateDelegates Method
IDelegateDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Updates the information of (a) delegate(s) in the configuration.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function UpdateDelegates ( _
    delegateIds As Integer(), _
    delegates As DELEGATE_INFO() _
) As API_ERROR
C#
API_ERROR UpdateDelegates(
    int[] delegateIds,
    DELEGATE_INFO[] delegates
)

Parameters

delegateIds
Type: array< System..::..Int32 >[]()[][]
The list of ID's identifying the delegates.
delegates
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DELEGATE_INFO >[]()[][]
The delegates to update.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

This function may potentionally block. It will block if the DCN-SW server is not ready to accept the request!

Remarks

Requires IsDelegateRegistrationAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..ArgumentOutOfRangeException | If the sizes of the argument arrays do not match.
System..::..FormatException | If one or more of the delegate ID's is invalid or one or more of the passed delegate information in the list contains invalid data.

See Also

IDelegateDataApi Interface


UpdateRegistrationForDelegates Method

IDelegateDataApi..::..UpdateRegistrationForDelegates Method
IDelegateDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Updates the registration information of (a) delegate(s) of a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function UpdateRegistrationForDelegates ( _
    meetingId As Integer, _
    delegateIds As Integer(), _
    participation As PARTICIPATION_INFO() _
) As API_ERROR
C#
API_ERROR UpdateRegistrationForDelegates(
    int meetingId,
    int[] delegateIds,
    PARTICIPATION_INFO[] participation
)

Parameters

meetingId
Type: System..::..Int32
The ID of the meeting to update registration.
delegateIds
Type: array< System..::..Int32 >[]()[][]
The list of ID's for delegates.
participation
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..PARTICIPATION_INFO >[]()[][]
The participation information for registration.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

This function may potentionally block. It will block if the DCN-SW server is not ready to accept the request.
Assignment of delegate to seat type DCN-SW OPR, DCN-CCU, DCN-CCU Slave, DCN-IDESK, DCN-DDI Entrance, DCN-DDI Exit and DCN-FVU returns with api error INVALID_SEAT_ID.

Remarks

Requires IsDelegateRegistrationAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..ArgumentOutOfRangeException | If the array-lengths do not correspond, or an out-of-range value is supplied as participation info.
System..::..FormatException | If one or more of the delegate ID's is invalid, the participation information contains invalid data or the meeting ID is invalid.

See Also

IDelegateDataApi Interface


IDelegateDataApi Properties

IDelegateDataApi Properties
IDelegateDataApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDelegateDataApi type exposes the following members.

Properties

 | Name | Description
Public property | IsCardProductionAllowed | Indicates whether production of ID-cards is allowed.
Public property | IsDelegateRegistrationAllowed | Indicates whether store, update, deletion and registration of delegates to meetings is allowed from this interface.

See Also

IDelegateDataApi Interface


IsCardProductionAllowed Property

IDelegateDataApi..::..IsCardProductionAllowed Property
IDelegateDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates whether production of ID-cards is allowed.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsCardProductionAllowed As Boolean
    Get
C#
bool IsCardProductionAllowed { get; }

Field Value

true if allowed, false if not.

See Also

IDelegateDataApi Interface


IsDelegateRegistrationAllowed Property

IDelegateDataApi..::..IsDelegateRegistrationAllowed Property
IDelegateDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates whether store, update, deletion and registration of delegates to meetings is allowed from this interface.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsDelegateRegistrationAllowed As Boolean
    Get
C#
bool IsDelegateRegistrationAllowed { get; }

Field Value

true if this is allowed, false otherwise.

See Also

IDelegateDataApi Interface


IDelegateDataApi Events

IDelegateDataApi Events
IDelegateDataApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDelegateDataApi type exposes the following members.

Events

 | Name | Description
Public event | DelegateDeletion | Occurs when a delegate was deleted. (Inherited from IDelegateDataApiEvents.)
Public event | DelegateRegistration | Occurs when (a) delegate(s) is/are registered for a meeting. (Inherited from IDelegateDataApiEvents.)
Public event | DelegateRegistrationUpdate | Occurs when the meeting registration of (a) delegate(s) is/are updated. (Inherited from IDelegateDataApiEvents.)
Public event | DelegateStore | Occurs when (a) new delegate was added. (Inherited from IDelegateDataApiEvents.)
Public event | DelegateUnregistration | Occurs when a delegate is unregistered from a meeting. (Inherited from IDelegateDataApiEvents.)
Public event | DelegateUpdate | Occurs when (a) delegate(s) is/are updated, or his ID-card assigment has been updated. (Inherited from IDelegateDataApiEvents.)
Public event | RequestDeletion | Occcurs when a request is deleted from the database on the server. (Inherited from IDelegateDataApiEvents.)
Public event | RequestStore | Occcurs when a new request is stored in the database on the server. (Inherited from IDelegateDataApiEvents.)
Public event | RequestUpdate | Occcurs when a request is updated from the database on the server. (Inherited from IDelegateDataApiEvents.)

See Also

IDelegateDataApi Interface


IDelegateDataApiEvents Interface

IDelegateDataApiEvents Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface defining all events for the delegate API data-interface. See also IDelegateDataApiEvents Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IDelegateDataApiEvents
C#
[ObfuscationAttribute]
public interface IDelegateDataApiEvents

See Also

IDelegateDataApiEvents Members


IDelegateDataApiEvents Members

IDelegateDataApiEvents Members
IDelegateDataApiEvents Interface Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDelegateDataApiEvents type exposes the following members.

Events

 | Name | Description
Public event | DelegateDeletion | Occurs when a delegate was deleted.
Public event | DelegateRegistration | Occurs when (a) delegate(s) is/are registered for a meeting.
Public event | DelegateRegistrationUpdate | Occurs when the meeting registration of (a) delegate(s) is/are updated.
Public event | DelegateStore | Occurs when (a) new delegate was added.
Public event | DelegateUnregistration | Occurs when a delegate is unregistered from a meeting.
Public event | DelegateUpdate | Occurs when (a) delegate(s) is/are updated, or his ID-card assigment has been updated.
Public event | RequestDeletion | Occcurs when a request is deleted from the database on the server.
Public event | RequestStore | Occcurs when a new request is stored in the database on the server.
Public event | RequestUpdate | Occcurs when a request is updated from the database on the server.

See Also

IDelegateDataApiEvents Interface


IDelegateDataApiEvents Events

IDelegateDataApiEvents Events
IDelegateDataApiEvents Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDelegateDataApiEvents type exposes the following members.

Events

 | Name | Description
Public event | DelegateDeletion | Occurs when a delegate was deleted.
Public event | DelegateRegistration | Occurs when (a) delegate(s) is/are registered for a meeting.
Public event | DelegateRegistrationUpdate | Occurs when the meeting registration of (a) delegate(s) is/are updated.
Public event | DelegateStore | Occurs when (a) new delegate was added.
Public event | DelegateUnregistration | Occurs when a delegate is unregistered from a meeting.
Public event | DelegateUpdate | Occurs when (a) delegate(s) is/are updated, or his ID-card assigment has been updated.
Public event | RequestDeletion | Occcurs when a request is deleted from the database on the server.
Public event | RequestStore | Occcurs when a new request is stored in the database on the server.
Public event | RequestUpdate | Occcurs when a request is updated from the database on the server.

See Also

IDelegateDataApiEvents Interface


DelegateDeletion Event

IDelegateDataApiEvents..::..DelegateDeletion Event
IDelegateDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a delegate was deleted.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event DelegateDeletion As EventHandler(Of DelegateDataChangedEventArgs)
C#
event EventHandler<DelegateDataChangedEventArgs> DelegateDeletion

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDelegateDataApiEvents Interface


DelegateRegistration Event

IDelegateDataApiEvents..::..DelegateRegistration Event
IDelegateDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) delegate(s) is/are registered for a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event DelegateRegistration As EventHandler(Of DelegateRegistrationEventArgs)
C#
event EventHandler<DelegateRegistrationEventArgs> DelegateRegistration

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDelegateDataApiEvents Interface


DelegateRegistrationUpdate Event

IDelegateDataApiEvents..::..DelegateRegistrationUpdate Event
IDelegateDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when the meeting registration of (a) delegate(s) is/are updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event DelegateRegistrationUpdate As EventHandler(Of DelegateRegistrationEventArgs)
C#
event EventHandler<DelegateRegistrationEventArgs> DelegateRegistrationUpdate

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDelegateDataApiEvents Interface


DelegateStore Event

IDelegateDataApiEvents..::..DelegateStore Event
IDelegateDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) new delegate was added.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event DelegateStore As EventHandler(Of DelegateDataChangedEventArgs)
C#
event EventHandler<DelegateDataChangedEventArgs> DelegateStore

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDelegateDataApiEvents Interface


DelegateUnregistration Event

IDelegateDataApiEvents..::..DelegateUnregistration Event
IDelegateDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a delegate is unregistered from a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event DelegateUnregistration As EventHandler(Of DelegateRegistrationEventArgs)
C#
event EventHandler<DelegateRegistrationEventArgs> DelegateUnregistration

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDelegateDataApiEvents Interface


DelegateUpdate Event

IDelegateDataApiEvents..::..DelegateUpdate Event
IDelegateDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) delegate(s) is/are updated, or his ID-card assigment has been updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event DelegateUpdate As EventHandler(Of DelegateDataChangedEventArgs)
C#
event EventHandler<DelegateDataChangedEventArgs> DelegateUpdate

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDelegateDataApiEvents Interface


RequestDeletion Event

IDelegateDataApiEvents..::..RequestDeletion Event
IDelegateDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occcurs when a request is deleted from the database on the server.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event RequestDeletion As EventHandler(Of RequestDataChangedEventArgs)
C#
event EventHandler<RequestDataChangedEventArgs> RequestDeletion

See Also

IDelegateDataApiEvents Interface


RequestStore Event

IDelegateDataApiEvents..::..RequestStore Event
IDelegateDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occcurs when a new request is stored in the database on the server.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event RequestStore As EventHandler(Of RequestDataChangedEventArgs)
C#
event EventHandler<RequestDataChangedEventArgs> RequestStore

See Also

IDelegateDataApiEvents Interface


RequestUpdate Event

IDelegateDataApiEvents..::..RequestUpdate Event
IDelegateDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occcurs when a request is updated from the database on the server.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event RequestUpdate As EventHandler(Of RequestDataChangedEventArgs)
C#
event EventHandler<RequestDataChangedEventArgs> RequestUpdate

See Also

IDelegateDataApiEvents Interface


IDiscussionApi Interface

IDiscussionApi Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface that can be used to operate discussion activities during a session of a meeting. See also IDiscussionApi Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IDiscussionApi _
    Inherits IDiscussionApiEvents
C#
[ObfuscationAttribute]
public interface IDiscussionApi : IDiscussionApiEvents

Remarks

Calling discussion method(i.e. SpeakNow, Append request, Cancel Request etc) by seatid(having seat type DCN-SW OPR, DCN-SW API, DCN-CCU, DCN-CCU Slave, DCN-IDESK and DCN-FVU) will not perform any action. To check whether method is called and performed successfully need to wait for relavant events. Seat id 1 is Master CCU. Trying to call method by seat id 1 will return with API_ERROR.NONE and no events will be logged. Internally it will not perform any action.

The following example shows how to append request to speak by participantId and remove request to speak by participantId.

Examples

Copy image Copy Code
               using Bosch.Dcn.Ecpc.Client.Api.Interfaces;
               using Bosch.Dcn.Ecpc.Client.Api.Logic;

               class Example
               {
                   public static void Main()
                   {
                       IConfigApi configApi = DcnApi.ConfigApi;
                       IControlApi controlApi = DcnApi.ControlApi;
                       // ...handle initialization of the DCN-SW API here....

                        controlApi.DiscussionApi.RequestToSpeakListUpdated += OnRequestToSpeakListUpdated;
                        controlApi.DiscussionApi.RequestToRespondListUpdated += OnRequestToRespondListUpdated;
                        controlApi.DiscussionApi.SpeakersListUpdated += OnSpeakersListUpdated;

                       API_ERROR error;

                       if (configApi.IsAvailable)
                       {
                            //Add participant
                            List<DELEGATE_INFO> lstDelegateInfo = new List<DELEGATE_INFO>();
                            for (int count = 0; count < 10; i++)
                            {
                                 DELEGATE_INFO temp = new DELEGATE_INFO();
                                 temp.FirstName = "FirstName" + count.ToString();
                                 temp.LastName = "LastName" + count.ToString();
                                 temp.MiddleName = "middLeName" + count.ToString();
                                 temp.NativeLanguageId = temp.DisplayLanguageId = temp.MeetingGroupId = temp.SpokenLanguageId = 1;
                                 temp.Title = temp.Country = temp.Region = "";
                                temp.PinCode = 11111;
                                lstDelegateInfo.Add(temp);
                            }
                            int[] delegateIds = null;
                            int areaId = 1;
                            int meetingid;
                            error =  configApi.DelegateApi.StoreDelegates(lstDelegateInfo.ToArray(), out delegateIds));

                           //start meeting if it is not running

                            SEAT_ASSIGNMENT[] seatAssignments = null;
                            API_ERROR error = configApi.DelegateApi.RetrieveSeatAssignmentForArea(meetingid, areaId, out seatAssignments);
                            List<PARTICIPATION_INFO> lstparticipantInfo = new List<PARTICIPATION_INFO>();
                            for (int i = 0; i < seatAssignments.Length; i++)
                            {
                                //if seat is not operator then add it to lstparticipantInfo
                                    PARTICIPATION_INFO participant = new PARTICIPATION_INFO();
                                    participant.AssignedSeatId = seatAssignments[i].SeatId;
                                    participant.Rights = PARTICIPATION_INFO.RIGHT_DISCUSS | PARTICIPATION_INFO.RIGHT_INTERCOM | PARTICIPATION_INFO.RIGHT_VOTE;
                                    participant.VoteWeight = PARTICIPATION_INFO.MAX_VOTE_WEIGHT;
                                    lstparticipantInfo.Add(participant);

                            }
                            error =  configApi.DelegateApi.RegisterDelegatesForMeeting(meetingid, delegateIds, lstparticipantInfo.ToArray()));
                            if(error == API_ERROR.NONE)
                            {
                                  if(delegateIds.Length > 3)
                                  {
                                      int participantId;
                                      int seatId;
                                      //Fill participantId/seatId for append request to speak
                                      ...
                                      //call API method to append request to speak.
                                      error = controlApi.DiscussionApi.AppendRequestToSpeak(participantId, seatId);
                                      if(error == API_ERROR.NONE)
                                      {
                                          //call API method to remove request to speak
                                           error = controlApi.DiscussionApi.RemoveRequestToSpeak(participantId, seatId);
                                           if(error == API_ERROR.NONE)
                                           {
                                                 //your code
                                           }
                                      }
                                  }
                            }
                        }
                   }

                   private void OnRequestToSpeakListUpdated(object sender, DiscussionActivityEventArgs arguments)
                   {
                       /// Handles a request list update.
                   }

                   private void OnRequestToRespondListUpdated(object sender, DiscussionActivityEventArgs arguments)
                   {
                      /// Handles a comment request update.
                   }
                   private void OnSpeakersListUpdated(object sender, DiscussionActivityEventArgs arguments)
                   {
                       /// Handles a speaker list update.
                   }
               }

See Also

IDiscussionApi Members


IDiscussionApi Members

IDiscussionApi Members
IDiscussionApi Interface Methods Properties Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDiscussionApi type exposes the following members.

Methods

 | Name | Description
Public method | AppendRequestToSpeak | Appends a request to speak for participant or seat to the request list.
Public method | CancelAll | Cancels all active speakers and clears all requests from the request- and response-lists.
Public method | GetNumberOfActivePrios | Gets the number of active prios.
Public method | InsertRequestToSpeak | Inserts a request to speak for specific participant or seat in the request to speak list before a specified participant or seat.
Public method | RemoveAllRequests | Cancels all requests from the request to speak and request to respond list
Public method | RemoveRequestToRespond | Cancels the requests to respond for specific participant or seat.
Public method | RemoveRequestToSpeak | Cancels the requests to speak for specific participant or seat.
Public method | ReplaceRequestToSpeak | Issues a request to speak for specific participants or seat, however replacing the requests before a by the operator selected participant or seat.
Public method | RetrieveDiscussionSettings | Retrieves the discussion settings for the active Meeting or Session
Public method | RetrieveGroupTimers | Retrieves the timer limits that a group can speak within this session.
Public method | RetrieveMicrophoneStatus | Retrieves the microphone status of the seat.
Public method | RetrieveNotebookersList | Retrieves the list of participants or seats in the notebook.
Public method | RetrieveRequestToRespondList | Retrieves the ordered list of participants or seats in the request-to-respond list.
Public method | RetrieveRequestToSpeakList | Retrieves the ordered list of participants or seats in the request-to-speak list.
Public method | RetrieveRespondList | Retrieves the ordered list of participants or seats in the respond list.
Public method | RetrieveSpeakersList | Retrieves the ordered list of participants or seats in the speakers list.
Public method | SetChairmanPriority | Activates the chairman priority function for a participant using a chairman device or seatId which is a chairman device. When seatId 0 is used, this function will be executed and the CCU will be a virtual chairman.
Public method | SetDiscussionSettings | Sets Discussion settings
Public method | Shift | Shifts the participant or seat by ID from the request list to the speakers list.
Public method | SpeakNow | Activates a microphone of participants or seats, allowing the participant to speak (microphone on).
Public method | StopSpeaking | Deactivates a microphone of participants or seats (microphone off).

Properties

 | Name | Description
Public property | IsDiscussMicrophoneManagementControllAllowed | Indicates whether control of Microphone management is allowed from this interface. When licenses DCN-SW,DCN-SWAPI and DCN-SWMM and privilege CD are present, value will be set to true.
Public property | IsDiscussMicrophoneManagementViewAllowed | Indicates whether Microphone Management view is allowed from this interface. When licenses DCN-SW,DCN-SWAPI and DCN-SWMM and privilege VMS,VMeS are present, value will be set to true.
Public property | IsDiscussStandardControllAllowed | Indicates whether control of discussion is allowed from this interface. When licenses DCN-SW and DCN-SWAPI and privilege CD are present, value will be set to true.
Public property | IsDiscussStandardViewAllowed | Indicates whether discussion view is allowed from this interface. When licenses DCN-SW,DCN-SWAPI and privilege VMS,VMeS are present, value will be set to true.

Events

 | Name | Description
Public event | ChairmanPriorityListUpdated | Shows the number of activated chairman priority activations. (Inherited from IDiscussionApiEvents.)
Public event | DiscussionSettingsUpdate | The discussion settings are updated. (Inherited from IDiscussionApiEvents.)
Public event | GroupSpeechTimeUpdated | Group Speech timer of session. (Inherited from IDiscussionApiEvents.)
Public event | MicOff | A microphone was deactivated. (Inherited from IDiscussionApiEvents.)
Public event | MicOn | A microphone was activated. (Inherited from IDiscussionApiEvents.)
Public event | NotebookersListUpdated | The Notebookers list is updated. (Inherited from IDiscussionApiEvents.)
Public event | ParticipantTimeLeftUpdated | Time left of participant in session. (Inherited from IDiscussionApiEvents.)
Public event | RequestToRespondListUpdated | The request-to-respond list is updated. (Inherited from IDiscussionApiEvents.)
Public event | RequestToSpeakListUpdated | The request-to-speak list is updated. (Inherited from IDiscussionApiEvents.)
Public event | RespondListUpdated | The respond-speaker list is updated. (Inherited from IDiscussionApiEvents.)
Public event | SpeakersListUpdated | The list of speakers is updated. (Inherited from IDiscussionApiEvents.)

See Also

IDiscussionApi Interface


IDiscussionApi Methods

IDiscussionApi Methods
IDiscussionApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDiscussionApi type exposes the following members.

Methods

 | Name | Description
Public method | AppendRequestToSpeak | Appends a request to speak for participant or seat to the request list.
Public method | CancelAll | Cancels all active speakers and clears all requests from the request- and response-lists.
Public method | GetNumberOfActivePrios | Gets the number of active prios.
Public method | InsertRequestToSpeak | Inserts a request to speak for specific participant or seat in the request to speak list before a specified participant or seat.
Public method | RemoveAllRequests | Cancels all requests from the request to speak and request to respond list
Public method | RemoveRequestToRespond | Cancels the requests to respond for specific participant or seat.
Public method | RemoveRequestToSpeak | Cancels the requests to speak for specific participant or seat.
Public method | ReplaceRequestToSpeak | Issues a request to speak for specific participants or seat, however replacing the requests before a by the operator selected participant or seat.
Public method | RetrieveDiscussionSettings | Retrieves the discussion settings for the active Meeting or Session
Public method | RetrieveGroupTimers | Retrieves the timer limits that a group can speak within this session.
Public method | RetrieveMicrophoneStatus | Retrieves the microphone status of the seat.
Public method | RetrieveNotebookersList | Retrieves the list of participants or seats in the notebook.
Public method | RetrieveRequestToRespondList | Retrieves the ordered list of participants or seats in the request-to-respond list.
Public method | RetrieveRequestToSpeakList | Retrieves the ordered list of participants or seats in the request-to-speak list.
Public method | RetrieveRespondList | Retrieves the ordered list of participants or seats in the respond list.
Public method | RetrieveSpeakersList | Retrieves the ordered list of participants or seats in the speakers list.
Public method | SetChairmanPriority | Activates the chairman priority function for a participant using a chairman device or seatId which is a chairman device. When seatId 0 is used, this function will be executed and the CCU will be a virtual chairman.
Public method | SetDiscussionSettings | Sets Discussion settings
Public method | Shift | Shifts the participant or seat by ID from the request list to the speakers list.
Public method | SpeakNow | Activates a microphone of participants or seats, allowing the participant to speak (microphone on).
Public method | StopSpeaking | Deactivates a microphone of participants or seats (microphone off).

See Also

IDiscussionApi Interface


AppendRequestToSpeak Method

IDiscussionApi..::..AppendRequestToSpeak Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Appends a request to speak for participant or seat to the request list.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function AppendRequestToSpeak ( _
    participantId As Integer, _
    seatId As Integer _
) As API_ERROR
C#
API_ERROR AppendRequestToSpeak(
    int participantId,
    int seatId
)

Parameters

participantId
Type: System..::..Int32
Participant being appended for request to speak.
seatId
Type: System..::..Int32
Seat being appended for request to speak.

Return Value

Following API_ERROR can be returned:

NONE - Success.
INVALID_PARAMETER - If participant/seat ids are invalid.
INVALID_PARTICIPANT_FOR_MEETING - If delegate is not added as participant for meeting.
PARTICIPANT_NOT_ASSIGNED - If Participant is not assigned to seat.
NOT_AVAILABLE - API is not initialize properly
NO_AUTHORIZATION - IsDiscussStandardControllAllowed is set to false.
NOT_ACTIVE - Meeting is not running.
INCORRECT_MODE - Microphone Mode is Override,Push to talk or Voice.
REQUEST_QUEUE_NOT_ENABLED - If allow requests in discussion settings is set to false.
EXCEED_MAX_REQUEST_COUNT - if requesting seat/participant count is more than no. of max request count.
ERROR - Exception.

Remarks

ParticipantId will be having high priority than seatId. When participantId is valid, seatId will be ignored. If user doesn't know participantid or participant is not assigned to seat, fill participantId as 0 and pass valid seatId. If user doesn't know seatId,fill seatId as 0 and pass valid participantId.To call method by participantid DCN-SWDB license is required.

Examples

Below Example shows how to append request to speak using API method - AppendRequestToSpeak.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             controlApi.DiscussionApi.RequestToSpeakListUpdated += OnRequestToSpeakListUpdated;
             //start meeting if it is not running
             ...
             int participantId;
             int seatId;
             // Fill participantId/seatId for append request to speak
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method to append request to speak.
                       error = discussApi.AppendRequestToSpeak(participantId,seatId);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while Appending request to speak.
             }
             ....

             private void OnRequestToSpeakListUpdated(object sender, DiscussionActivityEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDiscussionApi Interface


CancelAll Method

IDiscussionApi..::..CancelAll Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Cancels all active speakers and clears all requests from the request- and response-lists.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function CancelAll As API_ERROR
C#
API_ERROR CancelAll()

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_ACTIVE - If Meeting is not running.
INCORRECT_MODE- Microphone Mode is Voice.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - IsDiscussStandardControllAllowed is set to false.
ERROR - Exception.

Examples

Below Example shows how to cancel all speakers and clear requests using API method - CancelAll.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             controlApi.DiscussionApi.RequestToSpeakListUpdated += OnRequestToSpeakListUpdated;
             controlApi.DiscussionApi.SpeakerListUpdated += OnSpeakerListUpdated;
             controlApi.DiscussionApi.RequestToRespondListUpdated += OnRequestToRespondListUpdated;
             controlApi.DiscussionApi.RespondListUpdated += OnRespondListUpdated;
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method to cancel all speakers and clear requests.
                      error = discussApi.CancelAll();
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while cancelling all requests and speakers.
             }
             ....

             private void OnRequestToSpeakListUpdated(object sender, DiscussionActivityEventArgs arguments)
             {
                 //your code...
             }
             private void OnRequestToRespondListUpdated(object sender, DiscussionActivityEventArgs arguments)
             {
                 //your code...
             }
             private void OnRespondListUpdated(object sender, DiscussionActivityEventArgs arguments)
             {
                 //your code...
             }
             private void OnSpeakerListUpdated(object sender, DiscussionActivityEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ObjectDisposedException | If object already disposed.

See Also

IDiscussionApi Interface


GetNumberOfActivePrios Method

IDiscussionApi..::..GetNumberOfActivePrios Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Gets the number of active prios.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function GetNumberOfActivePrios ( _
    <OutAttribute> ByRef keyPrio As Integer, _
    <OutAttribute> ByRef virtualPrio As Integer _
) As API_ERROR
C#
API_ERROR GetNumberOfActivePrios(
    out int keyPrio,
    out int virtualPrio
)

Parameters

keyPrio
Type: System..::..Int32 %
Number of units active.
virtualPrio
Type: System..::..Int32 %
Number of virtual units active.

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_ACTIVE - If Meeting is not running.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - IsDiscussStandardViewAllowed is set to false.
ERROR - Exception.

Examples

Below Example shows how to retrieve number of prios active using API method - GetNumberOfActivePrios.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method to get number of active prios.
                      error = discussApi.GetNumberOfActivePrios(out keyPrio,out int virtualPrio);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while retrieving active prios.
             }

See Also

IDiscussionApi Interface


InsertRequestToSpeak Method

IDiscussionApi..::..InsertRequestToSpeak Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Inserts a request to speak for specific participant or seat in the request to speak list before a specified participant or seat.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function InsertRequestToSpeak ( _
    newParticipantId As Integer, _
    newSeatId As Integer, _
    oldParticipantId As Integer, _
    oldSeatId As Integer _
) As API_ERROR
C#
API_ERROR InsertRequestToSpeak(
    int newParticipantId,
    int newSeatId,
    int oldParticipantId,
    int oldSeatId
)

Parameters

newParticipantId
Type: System..::..Int32
Participant activates the request for.
newSeatId
Type: System..::..Int32
Seat activates the request for.
oldParticipantId
Type: System..::..Int32
Requesting participant to add before.
oldSeatId
Type: System..::..Int32
Requesting seat to add before.

Return Value

Following API_ERROR can be returned.

NONE - Success.
INVALID_PARAMETER - If participant/seat ids are invalid.
INVALID_PARTICIPANT_FOR_MEETING - If delegate is not added as participant for meeting.
PARTICIPANT_NOT_ASSIGNED - If Participant is not assigned to seat.
NOT_AVAILABLE - API is not initialize properly
NO_AUTHORIZATION - IsDiscussMicrophoneManagementControllAllowed is set to false.
NOT_ACTIVE - Meeting is not running.
INCORRECT_MODE - Microphone Mode is Override,Push to talk or Voice.
REQUEST_QUEUE_NOT_ENABLED - If allow requests in discussion settings is set to false.
EXCEED_MAX_REQUEST_COUNT - if requesting seat/participant count is more than no. of max request count.
ERROR - Exception.

Remarks

ParticipantId will be having high priority than seatId. When participantId is valid, seatId will be ignored. If user doesn't know participantid or participant is not assigned to seat, fill participantId as 0 and pass valid seatId. If user doesn't know seatId,fill seatId as 0 and pass valid participantId.To call method by participantid DCN-SWDB license is required.

Examples

Below Example shows how to insert request to speak for specific participant or seat using API method - InsertRequestToSpeak.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             controlApi.DiscussionApi.RequestToSpeakListUpdated += OnRequestToSpeakListUpdated;
             ...
             //start meeting if it is not running.
             ...
             int newParticipantId;
             int newSeatId;
             int oldParticipantId;
             int oldSeatId;
             //select delegate/seat from requesting to speak and fill information in oldParticipantId/oldSeatId.
             ...
             //select delegate/seat for insert request to speak and  fill information in newParticipantId/newSeatId.
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method to insert request to speak.
                      error = discussApi.InsertRequestToSpeak(newParticipantId, newSeatId, oldParticipantId, oldSeatId);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while inserting request to speak.
             }
             ....

             private void OnRequestToSpeakListUpdated(object sender, DiscussionActivityEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDiscussionApi Interface


RemoveAllRequests Method

IDiscussionApi..::..RemoveAllRequests Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Cancels all requests from the request to speak and request to respond list

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RemoveAllRequests As API_ERROR
C#
API_ERROR RemoveAllRequests()

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_ACTIVE - If Meeting is not running.
INCORRECT_MODE- If mode is not valid.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - IsDiscussMicrophoneManagementControllAllowed is set to false.
ERROR - Exception.

Examples

Below Example shows how to remove all requests using API method - RemoveAllRequests.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             controlApi.DiscussionApi.RequestToSpeakListUpdated += OnRequestToSpeakListUpdated;
             controlApi.DiscussionApi.RequestToRespondListUpdated += OnRequestToRespondListUpdated;
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method to remove requests and comment requests.
                      error = discussApi.RemoveAllRequests();
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while removing all requests.
             }
             ....

             private void OnRequestToSpeakListUpdated(object sender, DiscussionActivityEventArgs arguments)
             {
                 //your code...
             }
             private void OnResponseRequestListUpdated(object sender, DiscussionActivityEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDiscussionApi Interface


RemoveRequestToRespond Method

IDiscussionApi..::..RemoveRequestToRespond Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Cancels the requests to respond for specific participant or seat.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RemoveRequestToRespond ( _
    participantId As Integer, _
    seatId As Integer _
) As API_ERROR
C#
API_ERROR RemoveRequestToRespond(
    int participantId,
    int seatId
)

Parameters

participantId
Type: System..::..Int32
Participant being cancelled for comment request.
seatId
Type: System..::..Int32
Seat being cancelled for comment request.

Return Value

Following API_ERROR can be returned:

NONE - Success.
INVALID_PARAMETER - If participant/seat ids are invalid.
INVALID_PARTICIPANT_FOR_MEETING - If delegate is not added as participant for meeting.
PARTICIPANT_NOT_ASSIGNED - If Participant is not assigned to seat.
NOT_AVAILABLE - API is not initialize properly
NO_AUTHORIZATION - IsDiscussMicrophoneManagementControllAllowed is set to false.
NOT_ACTIVE - Meeting is not running.
INCORRECT_MODE - Microphone Mode is not operator with response
ERROR - Exception.

Remarks

ParticipantId will be having high priority than seatId. When participantId is valid, seatId will be ignored. If user doesn't know participantid or participant is not assigned to seat, fill participantId as 0 and pass valid seatId. If user doesn't know seatId,fill seatId as 0 and pass valid participantId.To call method by participantid DCN-SWDB license is required.

Examples

Below Example shows how to remove request to response using API method - RemoveRequestToRespond.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
              controlApi.DiscussionApi.RequestToRespondListUpdated += OnRequestToRespondListUpdated;
             ...
             //start meeting if it is not running.
             ...
             //retrieve delegate/seat for requesting to response for meeting
             ...

             int participantId;
             int seatId;
             //select delegate/seat to remove request to response and set it to participantId/seatId.
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method to cancel request to response by participantid.
                      error = discussApi.RemoveRequestToRespond(participantId,seatId);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while removing request to response.
             }
             ....

             private void OnRequestToRespondListUpdated(object sender, DiscussionActivityEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDiscussionApi Interface


RemoveRequestToSpeak Method

IDiscussionApi..::..RemoveRequestToSpeak Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Cancels the requests to speak for specific participant or seat.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RemoveRequestToSpeak ( _
    participantId As Integer, _
    seatId As Integer _
) As API_ERROR
C#
API_ERROR RemoveRequestToSpeak(
    int participantId,
    int seatId
)

Parameters

participantId
Type: System..::..Int32
Participant being cancelled for request to speak.
seatId
Type: System..::..Int32
Seat being cancelled for request to speak.

Return Value

Following API_ERROR can be returned:

NONE - Success.
INVALID_PARAMETER - If participant/seat ids are invalid.
INVALID_PARTICIPANT_FOR_MEETING - If delegate is not added as participant for meeting.
PARTICIPANT_NOT_ASSIGNED - If Participant is not assigned to seat.
NOT_AVAILABLE - API is not initialize properly
NO_AUTHORIZATION - IsDiscussStandardControllAllowed is set to false.
NOT_ACTIVE - Meeting is not running.
INCORRECT_MODE - Microphone Mode is Override,Push to talk or Voice.
ERROR - Exception.

Remarks

ParticipantId will be having high priority than seatId. When participantId is valid, seatId will be ignored. If user doesn't know participantid or participant is not assigned to seat, fill participantId as 0 and pass valid seatId. If user doesn't know seatId,fill seatId as 0 and pass valid participantId.To call method by participantid DCN-SWDB license is required.

Examples

Below Example shows how to canel request to speak using API method - RemoveRequestToSpeak.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
              controlApi.DiscussionApi.RequestToSpeakListUpdated += OnRequestToSpeakListUpdated;
             ...
             //start meeting if it is not running.
             ...
             //retrieve delegate/seat for requesting to speak for meeting
             ...
             int participantId;
             int seatId;
             //select delegate/seat to cancel request to speak and set it to participantId/seatId.
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method to cancel request to speak.
                      error = discussApi.RemoveRequestToSpeak(participantId, seatId);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while canceling request to speak.
             }
             ....

             private void OnRequestToSpeakListUpdated(object sender, DiscussionActivityEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDiscussionApi Interface


ReplaceRequestToSpeak Method

IDiscussionApi..::..ReplaceRequestToSpeak Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Issues a request to speak for specific participants or seat, however replacing the requests before a by the operator selected participant or seat.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function ReplaceRequestToSpeak ( _
    participantId As Integer, _
    seatId As Integer, _
    withParticipantId As Integer, _
    withSeatId As Integer _
) As API_ERROR
C#
API_ERROR ReplaceRequestToSpeak(
    int participantId,
    int seatId,
    int withParticipantId,
    int withSeatId
)

Parameters

participantId
Type: System..::..Int32
The participant to replace the request for
seatId
Type: System..::..Int32
The seat to replace the request for
withParticipantId
Type: System..::..Int32
The participant to replace with
withSeatId
Type: System..::..Int32
The seat to replace with

Return Value

Following API_ERROR can be returned.

NONE - Success.
INVALID_PARAMETER - If participant/seat ids are invalid.
INVALID_PARTICIPANT_FOR_MEETING - If delegate is not added as participant for meeting.
PARTICIPANT_NOT_ASSIGNED - If Participant is not assigned to seat.
NOT_AVAILABLE - API is not initialize properly
NO_AUTHORIZATION - IsDiscussMicrophoneManagementControllAllowed is set to false.
NOT_ACTIVE - Meeting is not running.
INCORRECT_MODE - Microphone Mode is Override,Push to talk or Voice.
REQUEST_QUEUE_NOT_ENABLED - If allow requests in discussion settings is set to false.
ERROR - Exception.

Remarks

ParticipantId will be having high priority than seatId. When participantId is valid, seatId will be ignored. If user doesn't know participantid or participant is not assigned to seat, fill participantId as 0 and pass valid seatId. If user doesn't know seatId,fill seatId as 0 and pass valid participantId.To call method by participantid DCN-SWDB license is required.

Examples

Below Example shows how to repalce request to speak using API method - ReplaceRequestToSpeak.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             controlApi.DiscussionApi.RequestToSpeakListUpdated += OnRequestToSpeakListUpdated;
             ...
             //start meeting if it is not running.
             ...
             //retrieve delegates or seats information for requesting to speak for meeting
             ...
             int participantId;
             int seatId;
             int withParticipantId;
             int withSeatId;
             ...
             //select currently requesting delegate or seat and set it to participantId/seatId.
             //select delegate or seat for replacement of currenting requesting to speak and set it to withParticipantId/withSeatId.
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method for replace request to speak.
                      error = discussApi.ReplaceRequestToSpeak(participantId, seatId, withParticipantId, withSeatId);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while replace request to speak.
             }
             ....

             private void OnRequestToSpeakListUpdated(object sender, DiscussionActivityEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDiscussionApi Interface


RetrieveDiscussionSettings Method

IDiscussionApi..::..RetrieveDiscussionSettings Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the discussion settings for the active Meeting or Session

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveDiscussionSettings ( _
    <OutAttribute> ByRef discussionInfo As DISCUSSION_INFO _
) As API_ERROR
C#
API_ERROR RetrieveDiscussionSettings(
    out DISCUSSION_INFO discussionInfo
)

Parameters

discussionInfo
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DISCUSSION_INFO %
Contains Discussion settings of the session.

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_ACTIVE - If Meeting is not running.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - IsDiscussStandardViewAllowed is set to false.
ERROR - Exception.

Examples

Below Example shows how to retrieve DiscussionSettings using API method - RetrieveDiscussionSettings.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;

                      //Call Api method to retrieve DiscussionSettings.
                      //If DiscussionSettings is not available then discussionInfo object will be null.
                      DISCUSSION_INFO discussionInfo;
                      error = discussApi.RetrieveDiscussionSettings(out discussionInfo);

                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while retrieving DiscussionSettings.
             }

See Also

IDiscussionApi Interface


RetrieveGroupTimers Method

IDiscussionApi..::..RetrieveGroupTimers Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the timer limits that a group can speak within this session.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveGroupTimers ( _
    <OutAttribute> ByRef sessionGroupTimer As SESSION_GROUP_TIMER() _
) As API_ERROR
C#
API_ERROR RetrieveGroupTimers(
    out SESSION_GROUP_TIMER[] sessionGroupTimer
)

Parameters

sessionGroupTimer
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SESSION_GROUP_TIMER >[]()[][]%
Contains timer info of the groups.If grouptimer is not defined or session is not active, value will be null.

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_ACTIVE - If Meeting is not running.
NOT_AVAILABLE - API is not initialize properly.
ERROR - Exception
NO_AUTHORIZATION - IsDiscussMicrophoneManagementViewAllowed is set to false.

Examples

Below Example shows how to retrieve Retrieve group timers using API method - RetrieveGroupTimers.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method to retrieve group timer.
                      //If group timer is not enabled for session,  sessionGroupTimer object will be null.
                      SESSION_GROUP_TIMER[] sessionGroupTimer;
                      error = discussApi.RetrieveGroupTimers(out sessionGroupTimer);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while retrieving group timer.
             }

See Also

IDiscussionApi Interface


RetrieveMicrophoneStatus Method

IDiscussionApi..::..RetrieveMicrophoneStatus Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the microphone status of the seat.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveMicrophoneStatus ( _
    <OutAttribute> ByRef seatMicStatus As SEAT_MICROPHONE_STATUS() _
) As API_ERROR
C#
API_ERROR RetrieveMicrophoneStatus(
    out SEAT_MICROPHONE_STATUS[] seatMicStatus
)

Parameters

seatMicStatus
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SEAT_MICROPHONE_STATUS >[]()[][]%
contains seat microphone status

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_ACTIVE - If Meeting is not running.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - IsDiscussStandardViewAllowed is set to false.
ERROR - Exception.

Examples

Below Example shows how to retrieve Microphone status using API method - RetrieveMicrophoneStatus.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method to retrieve microphone status.
                      SEAT_MICROPHONE_STATUS[] seatMicStatus;
                      error = discussApi.RetrieveMicrophoneStatus(out seatMicStatus);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while retrieving microphone status .
             }

See Also

IDiscussionApi Interface


RetrieveNotebookersList Method

IDiscussionApi..::..RetrieveNotebookersList Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the list of participants or seats in the notebook.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveNotebookersList ( _
    <OutAttribute> ByRef notebookers As NOTEBOOKER_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveNotebookersList(
    out NOTEBOOKER_INFO[] notebookers
)

Parameters

notebookers
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..NOTEBOOKER_INFO >[]()[][]%
List of notebook delegates in the notebook.

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_ACTIVE - If Meeting is not running.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - IsDiscussMicrophoneManagementViewAllowed is set to false.
ERROR - Exception.

Examples

Below Example shows how to retrieve notebooker list using API method - RetrieveNotebookersList.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method to retrieve notebooker list.
                      //If notebooker list is empty, notebookers object will be null.
                      NOTEBOOKER_INFO[] notebookers = null;
                      error = discussApi.RetrieveNotebookersList(out notebookers);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while retrieving notebooker list.
             }

See Also

IDiscussionApi Interface


RetrieveRequestToRespondList Method

IDiscussionApi..::..RetrieveRequestToRespondList Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the ordered list of participants or seats in the request-to-respond list.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveRequestToRespondList ( _
    <OutAttribute> ByRef participants As PARTICIPANT() _
) As API_ERROR
C#
API_ERROR RetrieveRequestToRespondList(
    out PARTICIPANT[] participants
)

Parameters

participants
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..PARTICIPANT >[]()[][]%
List of participants or seats in the comment requests list.

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_ACTIVE - If Meeting is not running.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - IsDiscussMicrophoneManagementViewAllowed is set to false.
INCORRECT_MODE - If microphone Mode is not operator with response.
ERROR - Exception.

Examples

Below Example shows how to retrieve comment request list using API method - RetrieveRequestToRespondList.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method to retrieve comment request list.
                      //If Response Request list is empty, participant object will be null.
                      PARTICIPANT[] participant = null;
                      error = discussApi.RetrieveRequestToRespondList(out participant);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while retrieving request to response list.
             }

See Also

IDiscussionApi Interface


RetrieveRequestToSpeakList Method

IDiscussionApi..::..RetrieveRequestToSpeakList Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the ordered list of participants or seats in the request-to-speak list.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveRequestToSpeakList ( _
    <OutAttribute> ByRef participants As PARTICIPANT() _
) As API_ERROR
C#
API_ERROR RetrieveRequestToSpeakList(
    out PARTICIPANT[] participants
)

Parameters

participants
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..PARTICIPANT >[]()[][]%
List of participants or seats requesting to speak.

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_ACTIVE - If Meeting is not running.
INCORRECT_MODE - If Microphone Mode is Override,Push to talk or Voice
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - IsDiscussMicrophoneManagementViewAllowed is set to false.
ERROR - Exception.

Examples

Below Example shows how to retrieve request to speak list using API method - RetrieveRequestToSpeakList.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method to retrieve request list.
                      //If Request list is empty, participant object will be null.
                      PARTICIPANT[] participant = null;
                      error = discussApi.RetrieveRequestToSpeakList(out participant);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while retrieving request list.
             }

See Also

IDiscussionApi Interface


RetrieveRespondList Method

IDiscussionApi..::..RetrieveRespondList Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the ordered list of participants or seats in the respond list.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveRespondList ( _
    <OutAttribute> ByRef participants As PARTICIPANT() _
) As API_ERROR
C#
API_ERROR RetrieveRespondList(
    out PARTICIPANT[] participants
)

Parameters

participants
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..PARTICIPANT >[]()[][]%
List of participants or seats in the comment speaker list.

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_ACTIVE - If Meeting is not running.
NOT_AVAILABLE - API is not initialize properly.
INCORRECT_MODE - If microphone Mode is not operator with response.
NO_AUTHORIZATION - IsDiscussMicrophoneManagementViewAllowed is set to false.
ERROR - Exception.

Return Value

Examples

Below Example shows how to retrieve comment speaker list using API method - RetrieveRespondList.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method to retrieve request list.
                      //If comment speaker list is empty, participant object will be null.
                      PARTICIPANT[] participant = null;
                      error = discussApi.RetrieveRespondList(out participant);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while retrieving respond list.
             }

See Also

IDiscussionApi Interface


RetrieveSpeakersList Method

IDiscussionApi..::..RetrieveSpeakersList Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the ordered list of participants or seats in the speakers list.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveSpeakersList ( _
    <OutAttribute> ByRef participants As PARTICIPANT() _
) As API_ERROR
C#
API_ERROR RetrieveSpeakersList(
    out PARTICIPANT[] participants
)

Parameters

participants
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..PARTICIPANT >[]()[][]%
List of participants in the active speakers list.

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_ACTIVE - If Meeting is not running.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - IsDiscussMicrophoneManagementViewAllowed is set to false.
ERROR - Exception.

Examples

Below Example shows how to retrieve speaker list using API method - RetrieveSpeakersList.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method to retrieve speaker list.
                      //If speaker list is empty, participant object will be null.
                      PARTICIPANT[] participant = null;
                      error = discussApi.RetrieveSpeakersList(out participant);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while retrieving speaker list.
             }

See Also

IDiscussionApi Interface


SetChairmanPriority Method

IDiscussionApi..::..SetChairmanPriority Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Activates the chairman priority function for a participant using a chairman device or seatId which is a chairman device. When seatId 0 is used, this function will be executed and the CCU will be a virtual chairman.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function SetChairmanPriority ( _
    participantId As Integer, _
    seatId As Integer, _
    priorityStatus As Boolean _
) As API_ERROR
C#
API_ERROR SetChairmanPriority(
    int participantId,
    int seatId,
    bool priorityStatus
)

Parameters

participantId
Type: System..::..Int32
Id of participant
seatId
Type: System..::..Int32
Seat id
priorityStatus
Type: System..::..Boolean
true or false to start or stop the priority

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_ACTIVE - If Meeting is not running.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - IsDiscussStandardViewAllowed is set to false.
ERROR - Exception.

Examples

Below Example shows how to Activates the chairman priority function using API method - SetChairmanPriority.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                     IDiscussionApi discussApi = controlApi.DiscussionApi;
                     //Call Api method to Set external prio.
                     error = discussApi.SetChairmanPriority(int participantId, int seatId, bool priorityStatus);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while setting the chairman priority function.
             }

See Also

IDiscussionApi Interface


SetDiscussionSettings Method

IDiscussionApi..::..SetDiscussionSettings Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Sets Discussion settings

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function SetDiscussionSettings ( _
    discussionInfo As DISCUSSION_INFO _
) As API_ERROR
C#
API_ERROR SetDiscussionSettings(
    DISCUSSION_INFO discussionInfo
)

Parameters

discussionInfo
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DISCUSSION_INFO
Discussion settings of the session.

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_ACTIVE - If Meeting is not running.
NOT_AVAILABLE - API is not initialize properly.
VOICE_MODE_CANNOT_BE_SET - If interpretaion channels greater than 26 and try to set voice mode.
NO_AUTHORIZATION - IsDiscussMicrophoneManagementControllAllowed is set to false.
INVALID_MIC_CONTROL_MODE - API_ERROR
INVALID_MAX_REQUEST - Max request count should be within the range of 0 - 100.
INVALID_MAX_RESPONSE_REQUEST - API_ERROR
INVALID_RESPONSE_LENGTH_CCU - when tried to set response length in DCN-CCU, DCN-CCUB or DCN-NCO.
Rest of the setting will be loaded to CCU but it will return this error.API_ERROR
INVALID_PRIORITY_TONE - API_ERROR
INVALID_ACTIVE_MIC_COUNT -API_ERROR

Examples

Below Example shows how to set DiscussionSettingsInfo using API method - SetDiscussionSettings.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
              controlApi.DiscussionApi.DiscussionSettingsUpdate += OnDiscussionSettingsUpdate;
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      DISCUSSION_INFO discussionInfo;
                      //Set Discussion Settings in discussionInfo
                      ...

                      //Call Api method to set DiscussionSettings.
                      error = discussApi.SetDiscussionSettings(discussionInfo);

                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while setting DiscussionSettings.
             }

             private void OnDiscussionSettingsUpdate(object sender, DiscussionActivityEventArgs arguments)
             {
                 //your code...
             }

See Also

IDiscussionApi Interface


Shift Method

IDiscussionApi..::..Shift Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Shifts the participant or seat by ID from the request list to the speakers list.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function Shift ( _
    participantId As Integer, _
    seatId As Integer _
) As API_ERROR
C#
API_ERROR Shift(
    int participantId,
    int seatId
)

Parameters

participantId
Type: System..::..Int32
Participant being shifted from the request list to the speakers list.
seatId
Type: System..::..Int32
Seat being shifted from the request list to the speakers list.

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_ACTIVE - If Meeting is not running.
INCORRECT_MODE - If mode is not valid.
NOT_IN_REQUEST_LIST - If seat or delegate is not in request to speak or comment request to speak list.
INVALID_PARTICIPANT_FOR_MEETING - If delegate is not added as participant for meeting.
PARTICIPANT_NOT_ASSIGNED - If Participant is not assigned to seat.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - IsDiscussMicrophoneManagementControllAllowed is set to false.
ERROR - Exception.

Remarks

ParticipantId will be having high priority than seatId. When participantId is valid, seatId will be ignored. If user doesn't know participantid or participant is not assigned to seat, fill participantId as 0 and pass valid seatId. If user doesn't know seatId,fill seatId as 0 and pass valid participantId.To call method by participantid DCN-SWDB license is required.

Examples

Below Example shows how to call Shift using API method - Shift.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             controlApi.DiscussionApi.RequestToSpeakListUpdated += OnRequestToSpeakListUpdated;
             controlApi.DiscussionApi.SpeakersListUpdated += OnSpeakersListUpdated;
             ...
             //start meeting if it is not running .
             ...
             //select delegate/seat for append request to speak.
             ...
             int participantId;
             int seatId;
             //Select participant/seat to shift request to speaker list and set it to participantId/seatId.
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method to append request to speak
                      ...
                      //Call Api method to shift reqest to speak
                      error = discussApi.Shift(participantId,seatId);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while shifting request to speak.
             }
             ....

             private void OnRequestToSpeakListUpdated(object sender, DiscussionActivityEventArgs arguments)
             {
                 //your code...
             }
             private void OnSpeakersListUpdated(object sender, DiscussionActivityEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDiscussionApi Interface


SpeakNow Method

IDiscussionApi..::..SpeakNow Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Activates a microphone of participants or seats, allowing the participant to speak (microphone on).

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function SpeakNow ( _
    participantId As Integer, _
    seatId As Integer _
) As API_ERROR
C#
API_ERROR SpeakNow(
    int participantId,
    int seatId
)

Parameters

participantId
Type: System..::..Int32
The participant to start speaking.
seatId
Type: System..::..Int32
The seat to start speaking.

Return Value

Following API_ERROR can be returned:

NONE - Success.
INVALID_PARAMETER - If participant/seat ids are invalid.
INVALID_PARTICIPANT_FOR_MEETING - If delegate is not added as participant for meeting.
PARTICIPANT_NOT_ASSIGNED - If Participant is not assigned to seat.
NOT_AVAILABLE - API is not initialize properly
NO_AUTHORIZATION - IsDiscussStandardControllAllowed is set to false.
NOT_ACTIVE - Meeting is not running.
INCORRECT_MODE - Microphone Mode is Voice.
ERROR - Exception.

Remarks

ParticipantId will be having high priority than seatId. When participantId is valid, seatId will be ignored. If user doesn't know participantid or participant is not assigned to seat, fill participantId as 0 and pass valid seatId. If user doesn't know seatId,fill seatId as 0 and pass valid participantId.To call method by participantid DCN-SWDB license is required.

Examples

Below Example shows how to add participant or seat to speaker list using API method - SpeakNow.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             controlApi.DiscussionApi.SpeakersListUpdated += OnSpeakersListUpdated;
             //start meeting if it is not running.
             ...
             int participantId;
             int seatId;
             //select participant/seat to add to speaker list and set it to participantId/seatId.
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method to add speaker.
                      error = discussApi.SpeakNow(participantId, seatId);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while Appending participant/seat to speaker list.
             }
             ....

             private void OnSpeakersListUpdated(object sender, DiscussionActivityEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDiscussionApi Interface


StopSpeaking Method

IDiscussionApi..::..StopSpeaking Method
IDiscussionApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Deactivates a microphone of participants or seats (microphone off).

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function StopSpeaking ( _
    participantId As Integer, _
    seatId As Integer _
) As API_ERROR
C#
API_ERROR StopSpeaking(
    int participantId,
    int seatId
)

Parameters

participantId
Type: System..::..Int32
Participant to deactivate microphone.
seatId
Type: System..::..Int32
Seat to deactivate microphone.

Return Value

Following API_ERROR can be returned:

NONE - Success.
INVALID_PARAMETER - If participant/seat ids are invalid.
INVALID_PARTICIPANT_FOR_MEETING - If delegate is not added as participant for meeting.
PARTICIPANT_NOT_ASSIGNED - If Participant is not assigned to seat.
NOT_AVAILABLE - API is not initialize properly
NO_AUTHORIZATION - IsDiscussStandardControllAllowed is set to false.
NOT_ACTIVE - Meeting is not running.
INCORRECT_MODE - Microphone Mode is Voice.
ERROR - Exception.

Remarks

ParticipantId will be having high priority than seatId. When participantId is valid, seatId will be ignored. If user doesn't know participantid or participant is not assigned to seat, fill participantId as 0 and pass valid seatId. If user doesn't know seatId,fill seatId as 0 and pass valid participantId.To call method by participantid DCN-SWDB license is required.

Examples

Below Example shows how to stop speaking using API method - StopSpeaking.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             controlApi.DiscussionApi.SpeakersListUpdated += OnSpeakersListUpdated;
             //start meeting if it is not running.
             ...
             ...
             //select delegate or seat to add to speaker list
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IDiscussionApi discussApi = controlApi.DiscussionApi;
                      //Call Api method SpeakNow to add speaker.
                      ...
                      int participantId;
                      int seatId;
                      //set participantId or seatId or both to remove from speaker list.
                      ...
                      discussApi.StopSpeaking(participantId, seatId);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while stop speaking.
             }
             ....

             private void OnSpeakersListUpdated(object sender, DiscussionActivityEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IDiscussionApi Interface


IDiscussionApi Properties

IDiscussionApi Properties
IDiscussionApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDiscussionApi type exposes the following members.

Properties

 | Name | Description
Public property | IsDiscussMicrophoneManagementControllAllowed | Indicates whether control of Microphone management is allowed from this interface. When licenses DCN-SW,DCN-SWAPI and DCN-SWMM and privilege CD are present, value will be set to true.
Public property | IsDiscussMicrophoneManagementViewAllowed | Indicates whether Microphone Management view is allowed from this interface. When licenses DCN-SW,DCN-SWAPI and DCN-SWMM and privilege VMS,VMeS are present, value will be set to true.
Public property | IsDiscussStandardControllAllowed | Indicates whether control of discussion is allowed from this interface. When licenses DCN-SW and DCN-SWAPI and privilege CD are present, value will be set to true.
Public property | IsDiscussStandardViewAllowed | Indicates whether discussion view is allowed from this interface. When licenses DCN-SW,DCN-SWAPI and privilege VMS,VMeS are present, value will be set to true.

See Also

IDiscussionApi Interface


IsDiscussMicrophoneManagementControllAllowed Property

IDiscussionApi..::..IsDiscussMicrophoneManagementControllAllowed Property
IDiscussionApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates whether control of Microphone management is allowed from this interface.
When licenses DCN-SW,DCN-SWAPI and DCN-SWMM and privilege CD are present, value will be set to true.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsDiscussMicrophoneManagementControllAllowed As Boolean
    Get
C#
bool IsDiscussMicrophoneManagementControllAllowed { get; }

Field Value

true if this is allowed, false otherwise.

See Also

IDiscussionApi Interface


IsDiscussMicrophoneManagementViewAllowed Property

IDiscussionApi..::..IsDiscussMicrophoneManagementViewAllowed Property
IDiscussionApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates whether Microphone Management view is allowed from this interface.
When licenses DCN-SW,DCN-SWAPI and DCN-SWMM and privilege VMS,VMeS are present, value will be set to true.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsDiscussMicrophoneManagementViewAllowed As Boolean
    Get
C#
bool IsDiscussMicrophoneManagementViewAllowed { get; }

Field Value

true if this is allowed, false otherwise.

See Also

IDiscussionApi Interface


IsDiscussStandardControllAllowed Property

IDiscussionApi..::..IsDiscussStandardControllAllowed Property
IDiscussionApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates whether control of discussion is allowed from this interface.
When licenses DCN-SW and DCN-SWAPI and privilege CD are present, value will be set to true.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsDiscussStandardControllAllowed As Boolean
    Get
C#
bool IsDiscussStandardControllAllowed { get; }

Field Value

true if this is allowed, false otherwise.

See Also

IDiscussionApi Interface


IsDiscussStandardViewAllowed Property

IDiscussionApi..::..IsDiscussStandardViewAllowed Property
IDiscussionApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates whether discussion view is allowed from this interface.
When licenses DCN-SW,DCN-SWAPI and privilege VMS,VMeS are present, value will be set to true.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsDiscussStandardViewAllowed As Boolean
    Get
C#
bool IsDiscussStandardViewAllowed { get; }

Field Value

true if this is allowed, false otherwise.

See Also

IDiscussionApi Interface


IDiscussionApi Events

IDiscussionApi Events
IDiscussionApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDiscussionApi type exposes the following members.

Events

 | Name | Description
Public event | ChairmanPriorityListUpdated | Shows the number of activated chairman priority activations. (Inherited from IDiscussionApiEvents.)
Public event | DiscussionSettingsUpdate | The discussion settings are updated. (Inherited from IDiscussionApiEvents.)
Public event | GroupSpeechTimeUpdated | Group Speech timer of session. (Inherited from IDiscussionApiEvents.)
Public event | MicOff | A microphone was deactivated. (Inherited from IDiscussionApiEvents.)
Public event | MicOn | A microphone was activated. (Inherited from IDiscussionApiEvents.)
Public event | NotebookersListUpdated | The Notebookers list is updated. (Inherited from IDiscussionApiEvents.)
Public event | ParticipantTimeLeftUpdated | Time left of participant in session. (Inherited from IDiscussionApiEvents.)
Public event | RequestToRespondListUpdated | The request-to-respond list is updated. (Inherited from IDiscussionApiEvents.)
Public event | RequestToSpeakListUpdated | The request-to-speak list is updated. (Inherited from IDiscussionApiEvents.)
Public event | RespondListUpdated | The respond-speaker list is updated. (Inherited from IDiscussionApiEvents.)
Public event | SpeakersListUpdated | The list of speakers is updated. (Inherited from IDiscussionApiEvents.)

See Also

IDiscussionApi Interface


IDiscussionApiEvents Interface

IDiscussionApiEvents Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface defining all events for the discussion API control-interface. See also IDiscussionApiEvents Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IDiscussionApiEvents
C#
[ObfuscationAttribute]
public interface IDiscussionApiEvents

See Also

IDiscussionApiEvents Members


IDiscussionApiEvents Members

IDiscussionApiEvents Members
IDiscussionApiEvents Interface Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDiscussionApiEvents type exposes the following members.

Events

 | Name | Description
Public event | ChairmanPriorityListUpdated | Shows the number of activated chairman priority activations.
Public event | DiscussionSettingsUpdate | The discussion settings are updated.
Public event | GroupSpeechTimeUpdated | Group Speech timer of session.
Public event | MicOff | A microphone was deactivated.
Public event | MicOn | A microphone was activated.
Public event | NotebookersListUpdated | The Notebookers list is updated.
Public event | ParticipantTimeLeftUpdated | Time left of participant in session.
Public event | RequestToRespondListUpdated | The request-to-respond list is updated.
Public event | RequestToSpeakListUpdated | The request-to-speak list is updated.
Public event | RespondListUpdated | The respond-speaker list is updated.
Public event | SpeakersListUpdated | The list of speakers is updated.

See Also

IDiscussionApiEvents Interface


IDiscussionApiEvents Events

IDiscussionApiEvents Events
IDiscussionApiEvents Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDiscussionApiEvents type exposes the following members.

Events

 | Name | Description
Public event | ChairmanPriorityListUpdated | Shows the number of activated chairman priority activations.
Public event | DiscussionSettingsUpdate | The discussion settings are updated.
Public event | GroupSpeechTimeUpdated | Group Speech timer of session.
Public event | MicOff | A microphone was deactivated.
Public event | MicOn | A microphone was activated.
Public event | NotebookersListUpdated | The Notebookers list is updated.
Public event | ParticipantTimeLeftUpdated | Time left of participant in session.
Public event | RequestToRespondListUpdated | The request-to-respond list is updated.
Public event | RequestToSpeakListUpdated | The request-to-speak list is updated.
Public event | RespondListUpdated | The respond-speaker list is updated.
Public event | SpeakersListUpdated | The list of speakers is updated.

See Also

IDiscussionApiEvents Interface


ChairmanPriorityListUpdated Event

IDiscussionApiEvents..::..ChairmanPriorityListUpdated Event
IDiscussionApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Shows the number of activated chairman priority activations.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event ChairmanPriorityListUpdated As EventHandler(Of ChairmanPriorityListUpdatedEventArgs)
C#
event EventHandler<ChairmanPriorityListUpdatedEventArgs> ChairmanPriorityListUpdated

Remarks

If IsDiscussMicrophoneManagementViewAllowed is set to false, event will not be fired.

See Also

IDiscussionApiEvents Interface


DiscussionSettingsUpdate Event

IDiscussionApiEvents..::..DiscussionSettingsUpdate Event
IDiscussionApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The discussion settings are updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event DiscussionSettingsUpdate As EventHandler(Of DiscussionSettingsEventArgs)
C#
event EventHandler<DiscussionSettingsEventArgs> DiscussionSettingsUpdate

Remarks

If IsDiscussStandardViewAllowed is set to false, event will not be fired.

See Also

IDiscussionApiEvents Interface


GroupSpeechTimeUpdated Event

IDiscussionApiEvents..::..GroupSpeechTimeUpdated Event
IDiscussionApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Group Speech timer of session.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event GroupSpeechTimeUpdated As EventHandler(Of GroupTimerControlEventArgs)
C#
event EventHandler<GroupTimerControlEventArgs> GroupSpeechTimeUpdated

Remarks

If IsDiscussMicrophoneManagementViewAllowed is set to false, event will not be fired.

See Also

IDiscussionApiEvents Interface


MicOff Event

IDiscussionApiEvents..::..MicOff Event
IDiscussionApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
A microphone was deactivated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event MicOff As EventHandler(Of DiscussionControlEventArgs)
C#
event EventHandler<DiscussionControlEventArgs> MicOff

Remarks

If IsDiscussStandardViewAllowed is set to false, event will not be fired.

See Also

IDiscussionApiEvents Interface


MicOn Event

IDiscussionApiEvents..::..MicOn Event
IDiscussionApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
A microphone was activated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event MicOn As EventHandler(Of DiscussionControlEventArgs)
C#
event EventHandler<DiscussionControlEventArgs> MicOn

Remarks

If IsDiscussStandardViewAllowed is set to false, event will not be fired.

See Also

IDiscussionApiEvents Interface


NotebookersListUpdated Event

IDiscussionApiEvents..::..NotebookersListUpdated Event
IDiscussionApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The Notebookers list is updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event NotebookersListUpdated As EventHandler(Of NotebookerControlEventArgs)
C#
event EventHandler<NotebookerControlEventArgs> NotebookersListUpdated

Remarks

If IsDiscussMicrophoneManagementViewAllowed is set to false, event will not be fired.

See Also

IDiscussionApiEvents Interface


ParticipantTimeLeftUpdated Event

IDiscussionApiEvents..::..ParticipantTimeLeftUpdated Event
IDiscussionApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Time left of participant in session.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event ParticipantTimeLeftUpdated As EventHandler(Of TimeLeftControlEventArgs)
C#
event EventHandler<TimeLeftControlEventArgs> ParticipantTimeLeftUpdated

Remarks

If IsDiscussMicrophoneManagementViewAllowed is set to false, event will not be fired.

See Also

IDiscussionApiEvents Interface


RequestToRespondListUpdated Event

IDiscussionApiEvents..::..RequestToRespondListUpdated Event
IDiscussionApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The request-to-respond list is updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event RequestToRespondListUpdated As EventHandler(Of DiscussionControlEventArgs)
C#
event EventHandler<DiscussionControlEventArgs> RequestToRespondListUpdated

Remarks

If IsDiscussMicrophoneManagementViewAllowed is set to false, event will not be fired.

See Also

IDiscussionApiEvents Interface


RequestToSpeakListUpdated Event

IDiscussionApiEvents..::..RequestToSpeakListUpdated Event
IDiscussionApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The request-to-speak list is updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event RequestToSpeakListUpdated As EventHandler(Of DiscussionControlEventArgs)
C#
event EventHandler<DiscussionControlEventArgs> RequestToSpeakListUpdated

Remarks

If IsDiscussStandardViewAllowed is set to false, event will not be fired.

See Also

IDiscussionApiEvents Interface


RespondListUpdated Event

IDiscussionApiEvents..::..RespondListUpdated Event
IDiscussionApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The respond-speaker list is updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event RespondListUpdated As EventHandler(Of DiscussionControlEventArgs)
C#
event EventHandler<DiscussionControlEventArgs> RespondListUpdated

Remarks

If IsDiscussMicrophoneManagementViewAllowed is set to false, event will not be fired.

See Also

IDiscussionApiEvents Interface


SpeakersListUpdated Event

IDiscussionApiEvents..::..SpeakersListUpdated Event
IDiscussionApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The list of speakers is updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event SpeakersListUpdated As EventHandler(Of DiscussionControlEventArgs)
C#
event EventHandler<DiscussionControlEventArgs> SpeakersListUpdated

Remarks

If IsDiscussStandardViewAllowed is set to false, event will not be fired.

See Also

IDiscussionApiEvents Interface


ILanguageDataApi Interface

ILanguageDataApi Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface that can be used to retrieve the supported languages available in the system. See also ILanguageDataApi Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface ILanguageDataApi _
    Inherits ILanguageDataApiEvents
C#
[ObfuscationAttribute]
public interface ILanguageDataApi : ILanguageDataApiEvents

See Also

ILanguageDataApi Members


ILanguageDataApi Members

ILanguageDataApi Members
ILanguageDataApi Interface Methods Properties Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ILanguageDataApi type exposes the following members.

Methods

 | Name | Description
Public method | AddInterpretationLanguages | Stores a new interpretation language(s).
Public method | DeleteInterpretationLanguages | Deletes the given interpretation languages, only user defined languages!
Public method | RetrieveDisplayLanguages | Retrieves the set of available display languages from the system.
Public method | RetrieveInterpretationLanguages | Retrieves the set of available interpretation languages from the system.
Public method | RetrieveNativeLanguages | This function is depricated.
Public method | RetrieveSpokenLanguages | This function is depricated.
Public method | UpdateInterpretationLanguages | Updates the given interpretation languages, only user defined languages!

Properties

 | Name | Description
Public property | IsInterpretationConfigurationAllowed | Indicates whether adding, updating and deleting interpretation languages is allowed from this interface.

Events

 | Name | Description
Public event | LanguageDeletion | Occurs when a language was deleted from the system's configuration. (Inherited from ILanguageDataApiEvents.)
Public event | LanguageStore | Occurs when (a) new language(s) was added to the system. (Inherited from ILanguageDataApiEvents.)
Public event | LanguageUpdate | Occurs when (a) language(s) is/are updated in the system. (Inherited from ILanguageDataApiEvents.)

See Also

ILanguageDataApi Interface


ILanguageDataApi Methods

ILanguageDataApi Methods
ILanguageDataApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ILanguageDataApi type exposes the following members.

Methods

 | Name | Description
Public method | AddInterpretationLanguages | Stores a new interpretation language(s).
Public method | DeleteInterpretationLanguages | Deletes the given interpretation languages, only user defined languages!
Public method | RetrieveDisplayLanguages | Retrieves the set of available display languages from the system.
Public method | RetrieveInterpretationLanguages | Retrieves the set of available interpretation languages from the system.
Public method | RetrieveNativeLanguages | This function is depricated.
Public method | RetrieveSpokenLanguages | This function is depricated.
Public method | UpdateInterpretationLanguages | Updates the given interpretation languages, only user defined languages!

See Also

ILanguageDataApi Interface


AddInterpretationLanguages Method

ILanguageDataApi..::..AddInterpretationLanguages Method
ILanguageDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Stores a new interpretation language(s).

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function AddInterpretationLanguages ( _
    languages As INTERPRETATION_LANGUAGE_INFO(), _
    <OutAttribute> ByRef interpretationLanguageIds As Integer() _
) As API_ERROR
C#
API_ERROR AddInterpretationLanguages(
    INTERPRETATION_LANGUAGE_INFO[] languages,
    out int[] interpretationLanguageIds
)

Parameters

languages
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..INTERPRETATION_LANGUAGE_INFO >[]()[][]
The list of interpretation languages to be added.
interpretationLanguageIds
Type: array< System..::..Int32 >[]()[][]%
The list of ID's identifying the new languages.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed and IsInterpretationConfigurationAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

ILanguageDataApi Interface


DeleteInterpretationLanguages Method

ILanguageDataApi..::..DeleteInterpretationLanguages Method
ILanguageDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Deletes the given interpretation languages, only user defined languages!

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function DeleteInterpretationLanguages ( _
    interpretationLanguageIds As Integer() _
) As API_ERROR
C#
API_ERROR DeleteInterpretationLanguages(
    int[] interpretationLanguageIds
)

Parameters

interpretationLanguageIds
Type: array< System..::..Int32 >[]()[][]
The list of language id's which needs to deleted.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed and IsInterpretationConfigurationAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

ILanguageDataApi Interface


RetrieveDisplayLanguages Method

ILanguageDataApi..::..RetrieveDisplayLanguages Method
ILanguageDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the set of available display languages from the system.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveDisplayLanguages ( _
    <OutAttribute> ByRef displayLanguageIds As Integer(), _
    <OutAttribute> ByRef languages As LANGUAGE_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveDisplayLanguages(
    out int[] displayLanguageIds,
    out LANGUAGE_INFO[] languages
)

Parameters

displayLanguageIds
Type: array< System..::..Int32 >[]()[][]%
The list of ID's defining the set of available display languages.
languages
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..LANGUAGE_INFO >[]()[][]%
The list of display languages.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Please add this is to retrieve languages which can be assigned to DCN Concentus. Assignment is done in DELEGATE_INFO DisplayLanguageId.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

ILanguageDataApi Interface


RetrieveInterpretationLanguages Method

ILanguageDataApi..::..RetrieveInterpretationLanguages Method
ILanguageDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the set of available interpretation languages from the system.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveInterpretationLanguages ( _
    <OutAttribute> ByRef interpretationLanguageIds As Integer(), _
    <OutAttribute> ByRef languages As INTERPRETATION_LANGUAGE_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveInterpretationLanguages(
    out int[] interpretationLanguageIds,
    out INTERPRETATION_LANGUAGE_INFO[] languages
)

Parameters

interpretationLanguageIds
Type: array< System..::..Int32 >[]()[][]%
The list of ID's defining the set of available interpretation languages.
languages
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..INTERPRETATION_LANGUAGE_INFO >[]()[][]%
The list of interpretation languages.

Return Value

See API_ERROR for applicable errorcodes.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

ILanguageDataApi Interface


RetrieveNativeLanguages Method

ILanguageDataApi..::..RetrieveNativeLanguages Method
ILanguageDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
This function is depricated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveNativeLanguages ( _
    <OutAttribute> ByRef nativeLanguageIds As Integer(), _
    <OutAttribute> ByRef languages As LANGUAGE_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveNativeLanguages(
    out int[] nativeLanguageIds,
    out LANGUAGE_INFO[] languages
)

Parameters

nativeLanguageIds
Type: array< System..::..Int32 >[]()[][]%
The list of ID's defining the set of available native languages.
languages
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..LANGUAGE_INFO >[]()[][]%
The list of native languages.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

ILanguageDataApi Interface


RetrieveSpokenLanguages Method

ILanguageDataApi..::..RetrieveSpokenLanguages Method
ILanguageDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
This function is depricated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveSpokenLanguages ( _
    <OutAttribute> ByRef spokenLanguageIds As Integer(), _
    <OutAttribute> ByRef languages As LANGUAGE_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveSpokenLanguages(
    out int[] spokenLanguageIds,
    out LANGUAGE_INFO[] languages
)

Parameters

spokenLanguageIds
Type: array< System..::..Int32 >[]()[][]%
The list of ID's defining the set of available spoken languages.
languages
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..LANGUAGE_INFO >[]()[][]%
The list of spoken languages.

Return Value

See API_ERROR for applicable errorcodes.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

ILanguageDataApi Interface


UpdateInterpretationLanguages Method

ILanguageDataApi..::..UpdateInterpretationLanguages Method
ILanguageDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Updates the given interpretation languages, only user defined languages!

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function UpdateInterpretationLanguages ( _
    interpretationLanguageIds As Integer(), _
    languages As INTERPRETATION_LANGUAGE_INFO() _
) As API_ERROR
C#
API_ERROR UpdateInterpretationLanguages(
    int[] interpretationLanguageIds,
    INTERPRETATION_LANGUAGE_INFO[] languages
)

Parameters

interpretationLanguageIds
Type: array< System..::..Int32 >[]()[][]
The list of language id's which needs to updated.
languages
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..INTERPRETATION_LANGUAGE_INFO >[]()[][]
The list of language id's which needs to updated.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed and IsInterpretationConfigurationAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

ILanguageDataApi Interface


ILanguageDataApi Properties

ILanguageDataApi Properties
ILanguageDataApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ILanguageDataApi type exposes the following members.

Properties

 | Name | Description
Public property | IsInterpretationConfigurationAllowed | Indicates whether adding, updating and deleting interpretation languages is allowed from this interface.

See Also

ILanguageDataApi Interface


IsInterpretationConfigurationAllowed Property

ILanguageDataApi..::..IsInterpretationConfigurationAllowed Property
ILanguageDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates whether adding, updating and deleting interpretation languages is allowed from this interface.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsInterpretationConfigurationAllowed As Boolean
    Get
C#
bool IsInterpretationConfigurationAllowed { get; }

Field Value

true if this is allowed, false otherwise.

See Also

ILanguageDataApi Interface


ILanguageDataApi Events

ILanguageDataApi Events
ILanguageDataApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ILanguageDataApi type exposes the following members.

Events

 | Name | Description
Public event | LanguageDeletion | Occurs when a language was deleted from the system's configuration. (Inherited from ILanguageDataApiEvents.)
Public event | LanguageStore | Occurs when (a) new language(s) was added to the system. (Inherited from ILanguageDataApiEvents.)
Public event | LanguageUpdate | Occurs when (a) language(s) is/are updated in the system. (Inherited from ILanguageDataApiEvents.)

See Also

ILanguageDataApi Interface


ILanguageDataApiEvents Interface

ILanguageDataApiEvents Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface defining all events for the languages API data-interface. See alsoILanguageDataApiEvents Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface ILanguageDataApiEvents
C#
[ObfuscationAttribute]
public interface ILanguageDataApiEvents

See Also

ILanguageDataApiEvents Members


ILanguageDataApiEvents Members

ILanguageDataApiEvents Members
ILanguageDataApiEvents Interface Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ILanguageDataApiEvents type exposes the following members.

Events

 | Name | Description
Public event | LanguageDeletion | Occurs when a language was deleted from the system's configuration.
Public event | LanguageStore | Occurs when (a) new language(s) was added to the system.
Public event | LanguageUpdate | Occurs when (a) language(s) is/are updated in the system.

See Also

ILanguageDataApiEvents Interface


ILanguageDataApiEvents Events

ILanguageDataApiEvents Events
ILanguageDataApiEvents Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ILanguageDataApiEvents type exposes the following members.

Events

 | Name | Description
Public event | LanguageDeletion | Occurs when a language was deleted from the system's configuration.
Public event | LanguageStore | Occurs when (a) new language(s) was added to the system.
Public event | LanguageUpdate | Occurs when (a) language(s) is/are updated in the system.

See Also

ILanguageDataApiEvents Interface


LanguageDeletion Event

ILanguageDataApiEvents..::..LanguageDeletion Event
ILanguageDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a language was deleted from the system's configuration.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event LanguageDeletion As EventHandler(Of LanguageDataChangedEventArgs)
C#
event EventHandler<LanguageDataChangedEventArgs> LanguageDeletion

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

ILanguageDataApiEvents Interface


LanguageStore Event

ILanguageDataApiEvents..::..LanguageStore Event
ILanguageDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) new language(s) was added to the system.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event LanguageStore As EventHandler(Of LanguageDataChangedEventArgs)
C#
event EventHandler<LanguageDataChangedEventArgs> LanguageStore

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

ILanguageDataApiEvents Interface


LanguageUpdate Event

ILanguageDataApiEvents..::..LanguageUpdate Event
ILanguageDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) language(s) is/are updated in the system.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event LanguageUpdate As EventHandler(Of LanguageDataChangedEventArgs)
C#
event EventHandler<LanguageDataChangedEventArgs> LanguageUpdate

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

ILanguageDataApiEvents Interface


IMeetingApi Interface

IMeetingApi Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface defining all events for the meeting API control-interface. See also IMeetingApi Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IMeetingApi _
    Inherits IMeetingApiEvents
C#
[ObfuscationAttribute]
public interface IMeetingApi : IMeetingApiEvents

Remarks

Examples

Below Example shows how to start/stop meeting and session.

Copy image Copy Code
            using Bosch.Dcn.Ecpc.Client.Api.Interfaces;
            using Bosch.Dcn.Ecpc.Client.Api.Logic;
              class Example
              {
                  public static void Main()
                  {
                        IConfigApi configApi = DcnApi.ConfigApi;
                        IControlApi controlApi = DcnApi.ControlApi;
                        // ...handle initialization of the DCN-SW API here....

                        IMeetingDataApi meetingDataApi = configApi.MeetingApi;
                        IMeetingApi meetingApi = controlApi.MeetingApi;
                        /// for example meetingId is assigned a value 1.
                        int[] meetingIds = null;
                        MEETING_INFO[] meetinginfo = null;
                        API_ERROR error;
                        int meetingid = 0;
                        int sessionid = 0;
                        if (configApi.IsAvailable)
                        {
                             /// for retrieving Meetings
                            error = meetingDataApi.RetrieveMeetings(out meetingIds, out meetinginfo);
                            if (API_ERROR.NONE == error)
                            {
                               // Your Code...
                               //set meetingid to start meeting
                                meetingApi.MeetingStart += OnMeetingStart;
                                if (meetingApi.IsMeetingControlAllowed)
                                {
                                    //Call Api method to start meeting
                                    error = meetingApi.StartMeetingById(meetingid);
                                }
                            }
                            else
                            {
                               error = API_ERROR.NO_AUTHORIZATION;
                            }
                            meetingApi.MeetingStop += OnMeetingStop;
                            if (meetingApi.IsMeetingControlAllowed)
                            {
                               //Call Api method to stop meeting
                               error = meetingApi.StopMeetingById(meetingid);
                            }
                            else
                            {
                               error = API_ERROR.NO_AUTHORIZATION;
                            }
                            int[] sessionIds = null;
                            SESSION_INFO[] sessions = null;
                            // for retrieving sessions of meetings
                            error = meetingDataApi.RetrieveMeetingSessions(meetingid, out sessionIds, out sessions);
                            if (API_ERROR.NONE == error)
                            {
                                // Your Code...
                                //set sessionid to start session
                                meetingApi.SessionStart += OnSessionStart;
                                if (meetingApi.IsSessionControlAllowed)
                                {
                                    //Call Api method to start session
                                    error = meetingApi.StartSessionById(sessionid);
                                }
                                else
                                {
                                    error = API_ERROR.NO_AUTHORIZATION;
                                }
                                meetingApi.SessionStop += OnSessionStop;
                                if (meetingApi.IsSessionControlAllowed)
                                {
                                    //Call Api method to stop session
                                    error = meetingApi.StopSessionById(sessionid);
                                }
                                else
                                {
                                    error = API_ERROR.NO_AUTHORIZATION;
                                }
                            }
                         }
                  }
               private void OnMeetingStart(object sender, MeetingControlEventArgs args)
               {
                   //Handles the meeting start event
               }
               private void OnMeetingStop(object sender, MeetingControlEventArgs args)
               {
                   //Handles the meeting stop event
               }
               private void OnSessionStart(object sender, MeetingControlEventArgs args)
               {
                   //Handles the session start event
               }
               private void OnSessionStop(object sender, MeetingControlEventArgs args)
               {
                   //Handles the session stop event
               }
              }

See Also

IMeetingApi Members


IMeetingApi Members

IMeetingApi Members
IMeetingApi Interface Methods Properties Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingApi type exposes the following members.

Methods

 | Name | Description
Public method | RetrieveActiveMeetingId | Retrieves the configuration identifier of the currently active meeting.
Public method | RetrieveActiveSessionId | Retrieves the configuration identifier of the currently active session.
Public method | RetrieveDelegatesForActiveMeeting | Retrieves the list of operational identifiers for the delegates assigned to the running meeting.
Public method | StartMeetingById | Starts a meeting.
Public method | StartSessionById | Starts a prepared session of a meeting.
Public method | StopMeetingById | Stops a meeting.
Public method | StopSessionById | Stops a running session of a meeting.

Properties

 | Name | Description
Public property | IsMeetingControlAllowed | Indicates whether control of meeting is allowed from this interface. When licenses DCN-SW and DCN-SWAPI and privilege CMe are present,value will be set to true.
Public property | IsMeetingViewAllowed | Indicates whether meeting view is allowed from this interface. When licenses DCN-SW and DCN-SWAPI and privilege VMeS are present,value will be set to true.
Public property | IsSessionControlAllowed | Indicates whether control of session is allowed from this interface. When licenses DCN-SW,DCN-SWAPI and (DCN-SWMM or DCN-SWPV) and privilege CMe are present,value will be set to true.
Public property | IsSessionViewAllowed | Indicates whether session view is allowed from this interface. When licenses DCN-SW,DCN-SWAPI and (DCN-SWMM or DCN-SWPV) and privilege VMeS are present,value will be set to true.

Events

 | Name | Description
Public event | MeetingStart | Occurs when a meeting has been started. (Inherited from IMeetingApiEvents.)
Public event | MeetingStop | Occurs when a meeting has been stopped. (Inherited from IMeetingApiEvents.)
Public event | SessionStart | Occurs when a session has been started. (Inherited from IMeetingApiEvents.)
Public event | SessionStop | Occurs when a session has been stopped. (Inherited from IMeetingApiEvents.)

See Also

IMeetingApi Interface


IMeetingApi Methods

IMeetingApi Methods
IMeetingApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingApi type exposes the following members.

Methods

 | Name | Description
Public method | RetrieveActiveMeetingId | Retrieves the configuration identifier of the currently active meeting.
Public method | RetrieveActiveSessionId | Retrieves the configuration identifier of the currently active session.
Public method | RetrieveDelegatesForActiveMeeting | Retrieves the list of operational identifiers for the delegates assigned to the running meeting.
Public method | StartMeetingById | Starts a meeting.
Public method | StartSessionById | Starts a prepared session of a meeting.
Public method | StopMeetingById | Stops a meeting.
Public method | StopSessionById | Stops a running session of a meeting.

See Also

IMeetingApi Interface


RetrieveActiveMeetingId Method

IMeetingApi..::..RetrieveActiveMeetingId Method
IMeetingApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the configuration identifier of the currently active meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveActiveMeetingId ( _
    <OutAttribute> ByRef meetingId As Integer _
) As API_ERROR
C#
API_ERROR RetrieveActiveMeetingId(
    out int meetingId
)

Parameters

meetingId
Type: System..::..Int32 %
The currently active meeting's id, or '0' if none of the meetings is active.

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsMeetingViewAllowed is set to false.
NOT_ACTIVE - None of the meeting is running.
ERROR - Exception.

Examples

Below Example shows how to get active meeting using API method - RetrieveActiveMeetingId.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IMeetingApi meetingApi = controlApi.MeetingApi;
                      if(meetingApi.IsMeetingViewAllowed)
                      {
                          //Call Api method to get active meeting
                          int meetingid;
                          error = meetingApi.RetrieveActiveMeetingId(out meetingid);
                          if(meetingid == 0)
                          {
                             error = API_ERROR.NOT_ACTIVE;
                          }
                          else
                          {
                             //your code.
                          }
                      }
                      else
                      {
                          error = API_ERROR.NO_AUTHORIZATION;
                      }
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingApi Interface


RetrieveActiveSessionId Method

IMeetingApi..::..RetrieveActiveSessionId Method
IMeetingApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the configuration identifier of the currently active session.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveActiveSessionId ( _
    <OutAttribute> ByRef sessionId As Integer _
) As API_ERROR
C#
API_ERROR RetrieveActiveSessionId(
    out int sessionId
)

Parameters

sessionId
Type: System..::..Int32 %
The currently active session's id, or '0' if none of the sessions is active.

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsSessionViewAllowed is set to false.
NOT_ACTIVE - None of the session is running.
ERROR - Exception.

Examples

Below Example shows how to get active session using API method - RetrieveActiveSessionId.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IMeetingApi meetingApi = controlApi.MeetingApi;
                      //Call Api method to get active session
                      int sessionId;
                      error = meetingApi.RetrieveActiveSessionId(out sessionId);
                      if(sessionId == 0)
                      {
                          error = API_ERROR.NOT_ACTIVE;
                      }
                      else
                      {
                         //your code.
                      }
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingApi Interface


RetrieveDelegatesForActiveMeeting Method

IMeetingApi..::..RetrieveDelegatesForActiveMeeting Method
IMeetingApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the list of operational identifiers for the delegates assigned to the running meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveDelegatesForActiveMeeting ( _
    <OutAttribute> ByRef delegates As DELEGATE() _
) As API_ERROR
C#
API_ERROR RetrieveDelegatesForActiveMeeting(
    out DELEGATE[] delegates
)

Parameters

delegates
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DELEGATE >[]()[][]%
The list of delegate identifiers.

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsMeetingViewAllowed is set to false.
NOT_ACTIVE - Meeting is not running.
ERROR - Exception.

Examples

Below Example shows how to Retrieve delegates for meeting using API method - RetrieveDelegatesForActiveMeeting.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IMeetingApi meetingApi = controlApi.MeetingApi;
                      //Call Api method to get delegate for meeting
                      DELEGATE[] delegates;
                      error = meetingApi.RetrieveDelegatesForActiveMeeting(out delegates)
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingApi Interface


StartMeetingById Method

IMeetingApi..::..StartMeetingById Method
IMeetingApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Starts a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function StartMeetingById ( _
    meetingId As Integer _
) As API_ERROR
C#
API_ERROR StartMeetingById(
    int meetingId
)

Parameters

meetingId
Type: System..::..Int32
The configuration identifier of the meeting to be started.

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsMeetingControlAllowed is set to false.
ALREADY_ACTIVE - Meeting is already running.
START_FAILED - Unable to start meeting.
UNKNOWN_MEETING - Unknown Meeting Id/Database is not available.
ERROR - Exception.

Remarks

If method is returning API_ERROR.NONE and MeetingStart event is received then meeting is started successfully, otherwise not.

Examples

Below Example shows how to start a meeting using API method - StartMeetingById.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             //Get All Meetings.
             configApi.MeetingApi.RetrieveMeetings(out meetingIds, out meetinginfo)
             ...
             //Select meetingid to start meeting.
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IMeetingApi meetingApi = controlApi.MeetingApi;
                      //Call Api method to start meeting
                      error = meetingApi.StartMeetingById(meetingid);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingApi Interface


StartSessionById Method

IMeetingApi..::..StartSessionById Method
IMeetingApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Starts a prepared session of a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function StartSessionById ( _
    sessionId As Integer _
) As API_ERROR
C#
API_ERROR StartSessionById(
    int sessionId
)

Parameters

sessionId
Type: System..::..Int32
The configuration identifier of the session to be started.

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsSessionControlAllowed is set to false.
ALREADY_ACTIVE - Session is already running.
START_FAILED - Unable to start session.
UNKNOWN_SESSION - Unknown session Id/Database is not available.
NOT_ACTIVE - Meeting is not running.
ERROR - Exception.

Examples

Below example shows how to start a session using API method - StartSessionById.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             //Get meetingid of session.
             ...
             //Get All sessions of meeting.
             configApi.MeetingApi.RetrieveMeetingSessions(int meetingId, out int[] sessionIds, out SESSION_INFO[] sessions)
             ...
             //Select sessionid to start session.
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IMeetingApi meetingApi = controlApi.MeetingApi;
                      if(meetingApi.IsSessionControlAllowed)
                      {
                          //Call Api method to start session.
                          error = meetingApi.StartSessionById(sessionid);
                      }
                      else
                      {
                          error = API_ERROR.NO_AUTHORIZATION;
                      }
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingApi Interface


StopMeetingById Method

IMeetingApi..::..StopMeetingById Method
IMeetingApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Stops a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function StopMeetingById ( _
    meetingId As Integer _
) As API_ERROR
C#
API_ERROR StopMeetingById(
    int meetingId
)

Parameters

meetingId
Type: System..::..Int32
The configuration identifier of the meeting to be stopped.

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsMeetingControlAllowed is set to false.
NOT_ACTIVE - Meeting is not running.
STOP_FAILED - Unable to stop meeting.
UNKNOWN_MEETING - Unknown Meeting Id/Database is not available.
ERROR - Exception.

Remarks

If method is returning API_ERROR.NONE and MeetingStop event is received then meeting is stopped successfully, otherwise not.

Examples

Below Example shows how to stop a meeting using API method - StopMeetingById.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             //Get All Meetings.
             configApi.MeetingApi.RetrieveMeetings(out meetingIds, out meetinginfo)
             ...
             //Select meetingid to stop meeting.
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IMeetingApi meetingApi = controlApi.MeetingApi;
                      if(meetingApi.IsMeetingControlAllowed)
                      {
                          //Call Api method to stop meeting
                          error = meetingApi.StopMeetingById(meetingid);
                      }
                      else
                      {
                          error = API_ERROR.NO_AUTHORIZATION;
                      }
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingApi Interface


StopSessionById Method

IMeetingApi..::..StopSessionById Method
IMeetingApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Stops a running session of a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function StopSessionById ( _
    sessionId As Integer _
) As API_ERROR
C#
API_ERROR StopSessionById(
    int sessionId
)

Parameters

sessionId
Type: System..::..Int32
The configuration identifier of the session to be stopped.

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsSessionControlAllowed is set to false.
NOT_ACTIVE - Session is not running.
STOP_FAILED - Unable to stop session.
UNKNOWN_SESSION - Unknown session Id/Database is not available.
ERROR - Exception.

Remarks

On session stop, default session will be started with sessionId 0. Session settings will remains same as last stopped session.

Examples

Below example shows how to stop a session using API method - StopSessionById.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             //Get meetingid of session.
             ...
             //Get All sessions of meeting.
             configApi.MeetingApi.RetrieveMeetingSessions(int meetingId, out int[] sessionIds, out SESSION_INFO[] sessions)
             ...
             //Select sessionid to stop session.
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IMeetingApi meetingApi = controlApi.MeetingApi;
                      if(meetingApi.IsSessionControlAllowed)
                      {
                          //Call Api method to stop session.
                          error = meetingApi.StopSessionById(sessionid);
                      }
                      else
                      {
                          error = API_ERROR.NO_AUTHORIZATION;
                      }
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingApi Interface


IMeetingApi Properties

IMeetingApi Properties
IMeetingApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingApi type exposes the following members.

Properties

 | Name | Description
Public property | IsMeetingControlAllowed | Indicates whether control of meeting is allowed from this interface. When licenses DCN-SW and DCN-SWAPI and privilege CMe are present,value will be set to true.
Public property | IsMeetingViewAllowed | Indicates whether meeting view is allowed from this interface. When licenses DCN-SW and DCN-SWAPI and privilege VMeS are present,value will be set to true.
Public property | IsSessionControlAllowed | Indicates whether control of session is allowed from this interface. When licenses DCN-SW,DCN-SWAPI and (DCN-SWMM or DCN-SWPV) and privilege CMe are present,value will be set to true.
Public property | IsSessionViewAllowed | Indicates whether session view is allowed from this interface. When licenses DCN-SW,DCN-SWAPI and (DCN-SWMM or DCN-SWPV) and privilege VMeS are present,value will be set to true.

See Also

IMeetingApi Interface


IsMeetingControlAllowed Property

IMeetingApi..::..IsMeetingControlAllowed Property
IMeetingApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates whether control of meeting is allowed from this interface.
When licenses DCN-SW and DCN-SWAPI and privilege CMe are present,value will be set to true.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsMeetingControlAllowed As Boolean
    Get
C#
bool IsMeetingControlAllowed { get; }

Field Value

true if this is allowed, false otherwise.

See Also

IMeetingApi Interface


IsMeetingViewAllowed Property

IMeetingApi..::..IsMeetingViewAllowed Property
IMeetingApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates whether meeting view is allowed from this interface.
When licenses DCN-SW and DCN-SWAPI and privilege VMeS are present,value will be set to true.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsMeetingViewAllowed As Boolean
    Get
C#
bool IsMeetingViewAllowed { get; }

Field Value

true if this is allowed, false otherwise.

See Also

IMeetingApi Interface


IsSessionControlAllowed Property

IMeetingApi..::..IsSessionControlAllowed Property
IMeetingApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates whether control of session is allowed from this interface.
When licenses DCN-SW,DCN-SWAPI and (DCN-SWMM or DCN-SWPV) and privilege CMe are present,value will be set to true.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsSessionControlAllowed As Boolean
    Get
C#
bool IsSessionControlAllowed { get; }

Field Value

true if this is allowed, false otherwise.

See Also

IMeetingApi Interface


IsSessionViewAllowed Property

IMeetingApi..::..IsSessionViewAllowed Property
IMeetingApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates whether session view is allowed from this interface.
When licenses DCN-SW,DCN-SWAPI and (DCN-SWMM or DCN-SWPV) and privilege VMeS are present,value will be set to true.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsSessionViewAllowed As Boolean
    Get
C#
bool IsSessionViewAllowed { get; }

Field Value

true if this is allowed, false otherwise.

See Also

IMeetingApi Interface


IMeetingApi Events

IMeetingApi Events
IMeetingApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingApi type exposes the following members.

Events

 | Name | Description
Public event | MeetingStart | Occurs when a meeting has been started. (Inherited from IMeetingApiEvents.)
Public event | MeetingStop | Occurs when a meeting has been stopped. (Inherited from IMeetingApiEvents.)
Public event | SessionStart | Occurs when a session has been started. (Inherited from IMeetingApiEvents.)
Public event | SessionStop | Occurs when a session has been stopped. (Inherited from IMeetingApiEvents.)

See Also

IMeetingApi Interface


IMeetingApiEvents Interface

IMeetingApiEvents Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface defining all events for the meeting API control-interface. See also IMeetingApiEvents Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IMeetingApiEvents
C#
[ObfuscationAttribute]
public interface IMeetingApiEvents

See Also

IMeetingApiEvents Members


IMeetingApiEvents Members

IMeetingApiEvents Members
IMeetingApiEvents Interface Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingApiEvents type exposes the following members.

Events

 | Name | Description
Public event | MeetingStart | Occurs when a meeting has been started.
Public event | MeetingStop | Occurs when a meeting has been stopped.
Public event | SessionStart | Occurs when a session has been started.
Public event | SessionStop | Occurs when a session has been stopped.

See Also

IMeetingApiEvents Interface


IMeetingApiEvents Events

IMeetingApiEvents Events
IMeetingApiEvents Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingApiEvents type exposes the following members.

Events

 | Name | Description
Public event | MeetingStart | Occurs when a meeting has been started.
Public event | MeetingStop | Occurs when a meeting has been stopped.
Public event | SessionStart | Occurs when a session has been started.
Public event | SessionStop | Occurs when a session has been stopped.

See Also

IMeetingApiEvents Interface


MeetingStart Event

IMeetingApiEvents..::..MeetingStart Event
IMeetingApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a meeting has been started.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event MeetingStart As EventHandler(Of MeetingControlEventArgs)
C#
event EventHandler<MeetingControlEventArgs> MeetingStart

Remarks

If IsMeetingViewAllowed is set to false, event will not be fired.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingApiEvents Interface


MeetingStop Event

IMeetingApiEvents..::..MeetingStop Event
IMeetingApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a meeting has been stopped.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event MeetingStop As EventHandler(Of MeetingControlEventArgs)
C#
event EventHandler<MeetingControlEventArgs> MeetingStop

Remarks

If IsMeetingViewAllowed is set to false, event will not be fired.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingApiEvents Interface


SessionStart Event

IMeetingApiEvents..::..SessionStart Event
IMeetingApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a session has been started.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event SessionStart As EventHandler(Of MeetingControlEventArgs)
C#
event EventHandler<MeetingControlEventArgs> SessionStart

Remarks

If IsSessionViewAllowed is set to false, event will not be fired.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingApiEvents Interface


SessionStop Event

IMeetingApiEvents..::..SessionStop Event
IMeetingApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a session has been stopped.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event SessionStop As EventHandler(Of MeetingControlEventArgs)
C#
event EventHandler<MeetingControlEventArgs> SessionStop

Remarks

If IsSessionViewAllowed is set to false, event will not be fired.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingApiEvents Interface


IMeetingDataApi Interface

IMeetingDataApi Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface that can be used to retrieve the meetings available in the system. See also IMeetingDataApi Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IMeetingDataApi _
    Inherits IMeetingDataApiEvents
C#
[ObfuscationAttribute]
public interface IMeetingDataApi : IMeetingDataApiEvents

Remarks

Examples

Copy image Copy Code
             using Bosch.Dcn.Ecpc.Client.Api.Interfaces;
             using Bosch.Dcn.Ecpc.Client.Api.Logic;
               class Example
               {
                   public static void Main()
                   {
                       IConfigApi configApi = DcnApi.ConfigApi;

                       // ...handle initialization of the DCN-SW API here....

                       IMeetingDataApi meetingDataApi = configApi.MeetingApi;

                       // for example meetingId is assigned a value 1.
                       int meetingId = 1;

                       BOOTH_INFO[] booths;
                       int[]  boothIds;

                       DESK_INFO[] desks;
                       int[]  deskIds;
                       API_ERROR error;

                       MEETING_INTERPRETATION_INFO meetingInterpretationInfo;

                       if (configApi.IsAvailable)
                       {
                           // for configuring booth settings

                           error = meetingDataApi.RetrieveMeetingBooths(meetingId, out BoothId, out booth);
                           if (API_ERROR.NONE == error)
                           {
                               // Your Code...
                           }
                           //
                           //Your code
                           //

                           error = meetingDataApi.RetrieveBoothsById(BoothId, out booth);
                           if (API_ERROR.NONE == error)
                           {
                               // Your Code...
                           }
                           //
                           //Your code
                           //

                           meetingDataApi.BoothSettingsUpdate += OnBoothSettingsUpdate;
                           //
                           //Your code
                           //

                           // enter / change booth settings
                           error = meetingDataApi.UpdateBooths(BoothId, booth);
                           if (API_ERROR.NONE == error)
                           {
                               // Your Code...
                           }

                           // for configuring desk settings

                           error = meetingDataApi.RetrieveMeetingDesks(meetingId, out deskId, out desk);
                           if (API_ERROR.NONE == error)
                           {
                               // Your Code...
                           }
                           //
                           //Your code
                           //

                           error = meetingDataApi.RetrieveDesksById(deskId, out desk);
                           if (API_ERROR.NONE == error)
                           {
                               // Your Code...
                           }
                           //
                           //Your code
                           //

                           meetingDataApi.DeskSettingsUpdate += OnDeskSettingsUpdate;
                           //
                           //Your code
                           //

                           // enter / change booth settings
                           error = meetingDataApi.UpdateDesks(deskId, desk);
                           if (API_ERROR.NONE == error)
                           {
                               // Your Code...
                           }

                           // for configuring meeting interpretation data

                           error = meetingDataApi.RetrieveMeetingInterpretationData(meetingId, out meetingInterpretationInfo);
                           if (API_ERROR.NONE == error)
                           {
                               // Your Code...
                           }
                           //
                           //Your code
                           //
                           meetingDataApi.MeetingInterpretationUpdate += OnMeetingInterpretationUpdate;
                           error = meetingDataApi.UpdateMeetingInterpretationData(meetingId, meetingInterpretationInfo);
                           if (API_ERROR.NONE == error)
                           {
                               // Your Code...
                           }    ///
                        }
                   }

                   private void OnBoothSettingsUpdate(object sender, BoothSettingsEventArgs args)
                   {
                       // Handle the updates in booth settings here...
                   }

                   private void OnDeskSettingsUpdate(object sender, DeskSettingsEventArgs args)
                   {
                       // Handle the updates in desk settings here...
                   }

                   private void OnMeetingInterpretationUpdate(object sender, MeetingInterpretationDataChangedEventArgs args)
                   {
                       // Handle the updates in meeting interpretation data changed/updated here...
                   }
               }

See Also

IMeetingDataApi Members


IMeetingDataApi Members

IMeetingDataApi Members
IMeetingDataApi Interface Methods Properties Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingDataApi type exposes the following members.

Methods

 | Name | Description
Public method | AddSessionsToMeeting | Adds sessions to the given meeting.
Public method | CopyMeeting | Create a copy of the Meeting details based on the meeting id provided
Public method | CopySession | Create a copy of the session details based on the session id provided
Public method | DeleteSessions | Deletes a session from the configuration.
Public method | RetrieveBoothsById | Retrieves the set of Booths, identified by booth ID.
Public method | RetrieveDesksById | Retrieves the set of Desks, identified by desk ID.
Public method | RetrieveMeetingBooths | For each meeting the booth can be configured in a different way.
Public method | RetrieveMeetingDesks | For each meeting the desk can be configured in a different way.
Public method | RetrieveMeetingInterpretationData | Retrieves the interpretation information of the meeting
Public method | RetrieveMeetings | Retrieves the set of meetings.
Public method | RetrieveMeetingsById | Retrieves the set of meetings, identified by meeting ID.
Public method | RetrieveMeetingSessions | Retrieves the list of sessions configured for the meeting.
Public method | RetrieveSessionsById | Retrieves the set of sessions, identified by session ID.
Public method | UpdateBooths | Updates the set of Booths, identified by booth ID.
Public method | UpdateDesks | Updates the set of Desks, identified by desk ID.
Public method | UpdateMeetingInterpretationData | Updates the interpretation information for the meeting
Public method | UpdateMeetingTitle | Rename the existing meeting title.
Public method | UpdateSessionTitle | Rename the existing session subject.

Properties

 | Name | Description
Public property | IsMeetingConfigurationAllowed | Indicates whether adding, updating and deleting meetings and sessions is allowed from this interface.

Events

 | Name | Description
Public event | BoothSettingsUpdate | Occurs when (a) booth settings is/are updated. (Inherited from IMeetingDataApiEvents.)
Public event | DeskSettingsUpdate | Occurs when (a) desk settings is/are updated. (Inherited from IMeetingDataApiEvents.)
Public event | MeetingDeletion | Occurs when a meeting was deleted. (Inherited from IMeetingDataApiEvents.)
Public event | MeetingInterpretationUpdate | Occurs when (a) meeting(s) is/are updated with respect to the interpretation data. (Inherited from IMeetingDataApiEvents.)
Public event | MeetingStore | Occurs when (a) new meeting(s) was added. (Inherited from IMeetingDataApiEvents.)
Public event | MeetingUpdate | Occurs when (a) meeting(s) is/are updated. (Inherited from IMeetingDataApiEvents.)
Public event | SessionDeletion | Occurs when a session was deleted from a meeting. (Inherited from IMeetingDataApiEvents.)
Public event | SessionStore | Occurs when (a) new sessions(s) was added to a meeting. (Inherited from IMeetingDataApiEvents.)
Public event | SessionUpdate | Occurs when (a) session(s) is/are updated. (Inherited from IMeetingDataApiEvents.)
Public event | SortPositionChanged | Occurs when a session order is changed (Inherited from IMeetingDataApiEvents.)

See Also

IMeetingDataApi Interface


IMeetingDataApi Methods

IMeetingDataApi Methods
IMeetingDataApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingDataApi type exposes the following members.

Methods

 | Name | Description
Public method | AddSessionsToMeeting | Adds sessions to the given meeting.
Public method | CopyMeeting | Create a copy of the Meeting details based on the meeting id provided
Public method | CopySession | Create a copy of the session details based on the session id provided
Public method | DeleteSessions | Deletes a session from the configuration.
Public method | RetrieveBoothsById | Retrieves the set of Booths, identified by booth ID.
Public method | RetrieveDesksById | Retrieves the set of Desks, identified by desk ID.
Public method | RetrieveMeetingBooths | For each meeting the booth can be configured in a different way.
Public method | RetrieveMeetingDesks | For each meeting the desk can be configured in a different way.
Public method | RetrieveMeetingInterpretationData | Retrieves the interpretation information of the meeting
Public method | RetrieveMeetings | Retrieves the set of meetings.
Public method | RetrieveMeetingsById | Retrieves the set of meetings, identified by meeting ID.
Public method | RetrieveMeetingSessions | Retrieves the list of sessions configured for the meeting.
Public method | RetrieveSessionsById | Retrieves the set of sessions, identified by session ID.
Public method | UpdateBooths | Updates the set of Booths, identified by booth ID.
Public method | UpdateDesks | Updates the set of Desks, identified by desk ID.
Public method | UpdateMeetingInterpretationData | Updates the interpretation information for the meeting
Public method | UpdateMeetingTitle | Rename the existing meeting title.
Public method | UpdateSessionTitle | Rename the existing session subject.

See Also

IMeetingDataApi Interface


AddSessionsToMeeting Method

IMeetingDataApi..::..AddSessionsToMeeting Method
IMeetingDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Adds sessions to the given meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function AddSessionsToMeeting ( _
    meetingId As Integer, _
    sessions As SESSION_INFO(), _
    <OutAttribute> ByRef sessionIds As Integer() _
) As API_ERROR
C#
API_ERROR AddSessionsToMeeting(
    int meetingId,
    SESSION_INFO[] sessions,
    out int[] sessionIds
)

Parameters

meetingId
Type: System..::..Int32
The ID of the meeting to add sessions to.
sessions
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SESSION_INFO >[]()[][]
The list of sessions to add.
sessionIds
Type: array< System..::..Int32 >[]()[][]%
The list of ID's identifying the new sessions added to the meeting.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

This function may potentionally block. It will block if the DCN-SW server is not ready to accept the request!

Remarks

Requires IsMeetingConfigurationAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | If the session information in the list contains invalid data.

See Also

IMeetingDataApi Interface


CopyMeeting Method

IMeetingDataApi..::..CopyMeeting Method
IMeetingDataApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Create a copy of the Meeting details based on the meeting id provided

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function CopyMeeting ( _
    meetingId As Integer, _
    <OutAttribute> ByRef newMeetingId As Integer _
) As API_ERROR
C#
API_ERROR CopyMeeting(
    int meetingId,
    out int newMeetingId
)

Parameters

meetingId
Type: System..::..Int32
Existing meeting id from which copying is being done.
newMeetingId
Type: System..::..Int32 %
Copied meeting's meeting id.

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - if authorization is not for configuration.
UNKNOWN_MEETING - if meeting is unknown.
ERROR - Exception.

Examples

Below Example shows how to copy meeting using API method - CopyMeeting.

Copy image Copy Code
             //Get Config API.
             configApi = DcnApi.ConfigApi;
             configApi.MeetingApi.MeetingStore += OnMeetingStore;
             ...
             //select meeting id from which copying is being done and set it as meetingId and
              for copied meeting's id, declare meeting id as newMeetingId.
              int newMeetingId;
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (configApi.IsAvailable)
                  {
                     IMeetingDataApi meetingApi = configApi.MeetingApi;
                      //Call Api method to copy meeting.
                      error = meetingApi.CopyMeeting(meetingId,out newMeetingId);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while copying meeting.
             }
             ....

             private void OnMeetingStore(object sender, MeetingDataChangedEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApi Interface


CopySession Method

IMeetingDataApi..::..CopySession Method
IMeetingDataApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Create a copy of the session details based on the session id provided

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function CopySession ( _
    sessionId As Integer, _
    <OutAttribute> ByRef newSessionId As Integer _
) As API_ERROR
C#
API_ERROR CopySession(
    int sessionId,
    out int newSessionId
)

Parameters

sessionId
Type: System..::..Int32
Existing session id from which copying is being done.
newSessionId
Type: System..::..Int32 %
Copied session's session id.

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - if authorization is not for configuration.
UNKNOWN_SESSION - if session is unknown.
ERROR - Exception.

Examples

Below Example shows how to copy session using API method - CopySession.

Copy image Copy Code
             //Get Config API.
             configApi = DcnApi.ConfigApi;
             configApi.MeetingApi.SessionStore += OnSessionStore;
             ...
             //select session id from which copying is being done and set it as sessionId and
              for copied session's id, declare session id as newSessionId.
              int newSessionId;
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (configApi.IsAvailable)
                  {
                     IMeetingDataApi meetingApi = configApi.MeetingApi;
                      //Call Api method to copy meeting.
                      error = meetingApi.CopySession(sessionId,out newSessionId);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while copying session.
             }
             ....

             private void OnSessionStore(object sender, SessionDataChangedEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApi Interface


DeleteSessions Method

IMeetingDataApi..::..DeleteSessions Method
IMeetingDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Deletes a session from the configuration.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function DeleteSessions ( _
    sessionIds As Integer() _
) As API_ERROR
C#
API_ERROR DeleteSessions(
    int[] sessionIds
)

Parameters

sessionIds
Type: array< System..::..Int32 >[]()[][]
The list of ID's identifying the sessions to delete.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

This function may potentionally block. It will block if the DCN-SW server is not ready to accept the request!

Remarks

Requires IsMeetingConfigurationAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | If one or more of the session ID's is invalid.

See Also

IMeetingDataApi Interface


RetrieveBoothsById Method

IMeetingDataApi..::..RetrieveBoothsById Method
IMeetingDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the set of Booths, identified by booth ID.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveBoothsById ( _
    boothIds As Integer(), _
    <OutAttribute> ByRef booths As BOOTH_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveBoothsById(
    int[] boothIds,
    out BOOTH_INFO[] booths
)

Parameters

boothIds
Type: array< System..::..Int32 >[]()[][]
booths
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..BOOTH_INFO >[]()[][]%

Return Value

See API_ERROR for applicable errorcodes.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApi Interface


RetrieveDesksById Method

IMeetingDataApi..::..RetrieveDesksById Method
IMeetingDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the set of Desks, identified by desk ID.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveDesksById ( _
    deskIds As Integer(), _
    <OutAttribute> ByRef desks As DESK_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveDesksById(
    int[] deskIds,
    out DESK_INFO[] desks
)

Parameters

deskIds
Type: array< System..::..Int32 >[]()[][]
desks
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DESK_INFO >[]()[][]%

Return Value

See API_ERROR for applicable errorcodes.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApi Interface


RetrieveMeetingBooths Method

IMeetingDataApi..::..RetrieveMeetingBooths Method
IMeetingDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
For each meeting the booth can be configured in a different way.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveMeetingBooths ( _
    meetingId As Integer, _
    <OutAttribute> ByRef boothIds As Integer(), _
    <OutAttribute> ByRef booths As BOOTH_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveMeetingBooths(
    int meetingId,
    out int[] boothIds,
    out BOOTH_INFO[] booths
)

Parameters

meetingId
Type: System..::..Int32
boothIds
Type: array< System..::..Int32 >[]()[][]%
booths
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..BOOTH_INFO >[]()[][]%

Return Value

See API_ERROR for applicable errorcodes.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApi Interface


RetrieveMeetingDesks Method

IMeetingDataApi..::..RetrieveMeetingDesks Method
IMeetingDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
For each meeting the desk can be configured in a different way.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveMeetingDesks ( _
    meetingId As Integer, _
    <OutAttribute> ByRef deskIds As Integer(), _
    <OutAttribute> ByRef desks As DESK_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveMeetingDesks(
    int meetingId,
    out int[] deskIds,
    out DESK_INFO[] desks
)

Parameters

meetingId
Type: System..::..Int32
deskIds
Type: array< System..::..Int32 >[]()[][]%
desks
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DESK_INFO >[]()[][]%

Return Value

See API_ERROR for applicable errorcodes.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApi Interface


RetrieveMeetingInterpretationData Method

IMeetingDataApi..::..RetrieveMeetingInterpretationData Method
IMeetingDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the interpretation information of the meeting

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveMeetingInterpretationData ( _
    meetingId As Integer, _
    <OutAttribute> ByRef meetingInterpretationInfo As MEETING_INTERPRETATION_INFO _
) As API_ERROR
C#
API_ERROR RetrieveMeetingInterpretationData(
    int meetingId,
    out MEETING_INTERPRETATION_INFO meetingInterpretationInfo
)

Parameters

meetingId
Type: System..::..Int32
The ID defining the available meeting.
meetingInterpretationInfo
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_INTERPRETATION_INFO %
The interpretation information of the meeting.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApi Interface


RetrieveMeetings Method

IMeetingDataApi..::..RetrieveMeetings Method
IMeetingDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the set of meetings.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveMeetings ( _
    <OutAttribute> ByRef meetingIds As Integer(), _
    <OutAttribute> ByRef meetings As MEETING_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveMeetings(
    out int[] meetingIds,
    out MEETING_INFO[] meetings
)

Parameters

meetingIds
Type: array< System..::..Int32 >[]()[][]%
The list of ID's defining the set of available meetings.
meetings
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_INFO >[]()[][]%
The list of meetings.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApi Interface


RetrieveMeetingsById Method

IMeetingDataApi..::..RetrieveMeetingsById Method
IMeetingDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the set of meetings, identified by meeting ID.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveMeetingsById ( _
    meetingIds As Integer(), _
    <OutAttribute> ByRef meetings As MEETING_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveMeetingsById(
    int[] meetingIds,
    out MEETING_INFO[] meetings
)

Parameters

meetingIds
Type: array< System..::..Int32 >[]()[][]
The list of ID's of the meetings to retrieve.
meetings
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_INFO >[]()[][]%
The list of meetings.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | if the list of meeting ID's contains an invalid ID.

See Also

IMeetingDataApi Interface


RetrieveMeetingSessions Method

IMeetingDataApi..::..RetrieveMeetingSessions Method
IMeetingDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the list of sessions configured for the meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveMeetingSessions ( _
    meetingId As Integer, _
    <OutAttribute> ByRef sessionIds As Integer(), _
    <OutAttribute> ByRef sessions As SESSION_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveMeetingSessions(
    int meetingId,
    out int[] sessionIds,
    out SESSION_INFO[] sessions
)

Parameters

meetingId
Type: System..::..Int32
The ID of the meeting to retrieve the sessions for.
sessionIds
Type: array< System..::..Int32 >[]()[][]%
The list of ID's defining the sessions configured for the given meeting.
sessions
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SESSION_INFO >[]()[][]%
The list of sessions.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..FormatException | if the meeting ID is invalid.

See Also

IMeetingDataApi Interface


RetrieveSessionsById Method

IMeetingDataApi..::..RetrieveSessionsById Method
IMeetingDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the set of sessions, identified by session ID.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveSessionsById ( _
    sessionIds As Integer(), _
    <OutAttribute> ByRef sessions As SESSION_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveSessionsById(
    int[] sessionIds,
    out SESSION_INFO[] sessions
)

Parameters

sessionIds
Type: array< System..::..Int32 >[]()[][]
The list of ID's of the sessions to retrieve.
sessions
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SESSION_INFO >[]()[][]%
The list of sessions.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | if the list of session ID's contains an invalid ID.

See Also

IMeetingDataApi Interface


UpdateBooths Method

IMeetingDataApi..::..UpdateBooths Method
IMeetingDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Updates the set of Booths, identified by booth ID.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function UpdateBooths ( _
    boothIds As Integer(), _
    booths As BOOTH_INFO() _
) As API_ERROR
C#
API_ERROR UpdateBooths(
    int[] boothIds,
    BOOTH_INFO[] booths
)

Parameters

boothIds
Type: array< System..::..Int32 >[]()[][]
booths
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..BOOTH_INFO >[]()[][]

Return Value

See API_ERROR for applicable errorcodes.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApi Interface


UpdateDesks Method

IMeetingDataApi..::..UpdateDesks Method
IMeetingDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Updates the set of Desks, identified by desk ID.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function UpdateDesks ( _
    deskIds As Integer(), _
    desks As DESK_INFO() _
) As API_ERROR
C#
API_ERROR UpdateDesks(
    int[] deskIds,
    DESK_INFO[] desks
)

Parameters

deskIds
Type: array< System..::..Int32 >[]()[][]
desks
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..DESK_INFO >[]()[][]

Return Value

See API_ERROR for applicable errorcodes.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApi Interface


UpdateMeetingInterpretationData Method

IMeetingDataApi..::..UpdateMeetingInterpretationData Method
IMeetingDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Updates the interpretation information for the meeting

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function UpdateMeetingInterpretationData ( _
    meetingId As Integer, _
    meetingInterpretationInfo As MEETING_INTERPRETATION_INFO _
) As API_ERROR
C#
API_ERROR UpdateMeetingInterpretationData(
    int meetingId,
    MEETING_INTERPRETATION_INFO meetingInterpretationInfo
)

Parameters

meetingId
Type: System..::..Int32
The ID defining the available meeting.
meetingInterpretationInfo
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_INTERPRETATION_INFO
The interpretation information of the meeting.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApi Interface


UpdateMeetingTitle Method

IMeetingDataApi..::..UpdateMeetingTitle Method
IMeetingDataApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Rename the existing meeting title.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function UpdateMeetingTitle ( _
    meetingId As Integer, _
    newMeetingTitle As String _
) As API_ERROR
C#
API_ERROR UpdateMeetingTitle(
    int meetingId,
    string newMeetingTitle
)

Parameters

meetingId
Type: System..::..Int32
MeetingId
newMeetingTitle
Type: System..::..String
New meeting title (maximum character allowed is 50 characters).

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - if authorization is not for configuration.
UNKNOWN_MEETING - if unknown meeting id or database is disconnected.
INVALID_ID - if meeting id parameter is invalid.
ERROR - if Exception or When meeting title characters exceed maximum.

Examples

Below example shows how to update meeting title using API method - UpdateMeetingTitle.

Copy image Copy Code
             //Get Config API.
             configApi = DcnApi.ConfigApi;
             configApi.MeetingApi.MeetingUpdate += OnMeetingUpdate;
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (configApi.IsAvailable)
                  {
                     IMeetingDataApi meetingApi = configApi.MeetingApi;
                      //Call Api method to Update meeting title.
                      error = meetingApi.UpdateMeetingTitle(meetingId,newMeetingTitle);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while updating Meeting title.
             }
             ....

             private void OnMeetingUpdate(object sender, MeetingDataChangedEventArgs args)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApi Interface


UpdateSessionTitle Method

IMeetingDataApi..::..UpdateSessionTitle Method
IMeetingDataApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Rename the existing session subject.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function UpdateSessionTitle ( _
    sessionId As Integer, _
    newSessionTitle As String _
) As API_ERROR
C#
API_ERROR UpdateSessionTitle(
    int sessionId,
    string newSessionTitle
)

Parameters

sessionId
Type: System..::..Int32
Existing session id.
newSessionTitle
Type: System..::..String
New session title (maximum character allowed is 50 characters).

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - if authorization is not for configuration.
UNKNOWN_SESSION - if unknown session id or database is disconnected.
INVALID_ID - if session id parameter is invalid.
ERROR - if Exception or When session title characters exceed maximum.

Examples

Below example shows how to Update session subject using API method - UpdateSessionTitle.

Copy image Copy Code
             //Get Config API.
             configApi = DcnApi.ConfigApi;
             configApi.MeetingApi.SessionUpdate += OnSessionUpdate;
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (configApi.IsAvailable)
                  {
                     ISessionData meetingApi = configApi.MeetingApi;
                      //Call Api method to Update session subject.
                      error = meetingApi.UpdateSessionTitle(SessionId,newSessionSubject);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while updating Session Subject.
             }
             ....

             private void OnSessionUpdate(object sender, SessionDataChangedEventArgs args)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApi Interface


IMeetingDataApi Properties

IMeetingDataApi Properties
IMeetingDataApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingDataApi type exposes the following members.

Properties

 | Name | Description
Public property | IsMeetingConfigurationAllowed | Indicates whether adding, updating and deleting meetings and sessions is allowed from this interface.

See Also

IMeetingDataApi Interface


IsMeetingConfigurationAllowed Property

IMeetingDataApi..::..IsMeetingConfigurationAllowed Property
IMeetingDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates whether adding, updating and deleting meetings and sessions is allowed from this interface.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsMeetingConfigurationAllowed As Boolean
    Get
C#
bool IsMeetingConfigurationAllowed { get; }

Field Value

true if this is allowed, false otherwise.

See Also

IMeetingDataApi Interface


IMeetingDataApi Events

IMeetingDataApi Events
IMeetingDataApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingDataApi type exposes the following members.

Events

 | Name | Description
Public event | BoothSettingsUpdate | Occurs when (a) booth settings is/are updated. (Inherited from IMeetingDataApiEvents.)
Public event | DeskSettingsUpdate | Occurs when (a) desk settings is/are updated. (Inherited from IMeetingDataApiEvents.)
Public event | MeetingDeletion | Occurs when a meeting was deleted. (Inherited from IMeetingDataApiEvents.)
Public event | MeetingInterpretationUpdate | Occurs when (a) meeting(s) is/are updated with respect to the interpretation data. (Inherited from IMeetingDataApiEvents.)
Public event | MeetingStore | Occurs when (a) new meeting(s) was added. (Inherited from IMeetingDataApiEvents.)
Public event | MeetingUpdate | Occurs when (a) meeting(s) is/are updated. (Inherited from IMeetingDataApiEvents.)
Public event | SessionDeletion | Occurs when a session was deleted from a meeting. (Inherited from IMeetingDataApiEvents.)
Public event | SessionStore | Occurs when (a) new sessions(s) was added to a meeting. (Inherited from IMeetingDataApiEvents.)
Public event | SessionUpdate | Occurs when (a) session(s) is/are updated. (Inherited from IMeetingDataApiEvents.)
Public event | SortPositionChanged | Occurs when a session order is changed (Inherited from IMeetingDataApiEvents.)

See Also

IMeetingDataApi Interface


IMeetingDataApiEvents Interface

IMeetingDataApiEvents Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface defining all events for the meetings API data-interface. See also IMeetingDataApiEvents Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IMeetingDataApiEvents
C#
[ObfuscationAttribute]
public interface IMeetingDataApiEvents

See Also

IMeetingDataApiEvents Members


IMeetingDataApiEvents Members

IMeetingDataApiEvents Members
IMeetingDataApiEvents Interface Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingDataApiEvents type exposes the following members.

Events

 | Name | Description
Public event | BoothSettingsUpdate | Occurs when (a) booth settings is/are updated.
Public event | DeskSettingsUpdate | Occurs when (a) desk settings is/are updated.
Public event | MeetingDeletion | Occurs when a meeting was deleted.
Public event | MeetingInterpretationUpdate | Occurs when (a) meeting(s) is/are updated with respect to the interpretation data.
Public event | MeetingStore | Occurs when (a) new meeting(s) was added.
Public event | MeetingUpdate | Occurs when (a) meeting(s) is/are updated.
Public event | SessionDeletion | Occurs when a session was deleted from a meeting.
Public event | SessionStore | Occurs when (a) new sessions(s) was added to a meeting.
Public event | SessionUpdate | Occurs when (a) session(s) is/are updated.
Public event | SortPositionChanged | Occurs when a session order is changed

See Also

IMeetingDataApiEvents Interface


IMeetingDataApiEvents Events

IMeetingDataApiEvents Events
IMeetingDataApiEvents Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingDataApiEvents type exposes the following members.

Events

 | Name | Description
Public event | BoothSettingsUpdate | Occurs when (a) booth settings is/are updated.
Public event | DeskSettingsUpdate | Occurs when (a) desk settings is/are updated.
Public event | MeetingDeletion | Occurs when a meeting was deleted.
Public event | MeetingInterpretationUpdate | Occurs when (a) meeting(s) is/are updated with respect to the interpretation data.
Public event | MeetingStore | Occurs when (a) new meeting(s) was added.
Public event | MeetingUpdate | Occurs when (a) meeting(s) is/are updated.
Public event | SessionDeletion | Occurs when a session was deleted from a meeting.
Public event | SessionStore | Occurs when (a) new sessions(s) was added to a meeting.
Public event | SessionUpdate | Occurs when (a) session(s) is/are updated.
Public event | SortPositionChanged | Occurs when a session order is changed

See Also

IMeetingDataApiEvents Interface


BoothSettingsUpdate Event

IMeetingDataApiEvents..::..BoothSettingsUpdate Event
IMeetingDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) booth settings is/are updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event BoothSettingsUpdate As EventHandler(Of BoothSettingsEventArgs)
C#
event EventHandler<BoothSettingsEventArgs> BoothSettingsUpdate

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApiEvents Interface


DeskSettingsUpdate Event

IMeetingDataApiEvents..::..DeskSettingsUpdate Event
IMeetingDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) desk settings is/are updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event DeskSettingsUpdate As EventHandler(Of DeskSettingsEventArgs)
C#
event EventHandler<DeskSettingsEventArgs> DeskSettingsUpdate

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApiEvents Interface


MeetingDeletion Event

IMeetingDataApiEvents..::..MeetingDeletion Event
IMeetingDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a meeting was deleted.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event MeetingDeletion As EventHandler(Of MeetingDataChangedEventArgs)
C#
event EventHandler<MeetingDataChangedEventArgs> MeetingDeletion

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApiEvents Interface


MeetingInterpretationUpdate Event

IMeetingDataApiEvents..::..MeetingInterpretationUpdate Event
IMeetingDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) meeting(s) is/are updated with respect to the interpretation data.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event MeetingInterpretationUpdate As EventHandler(Of MeetingInterpretationDataChangedEventArgs)
C#
event EventHandler<MeetingInterpretationDataChangedEventArgs> MeetingInterpretationUpdate

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApiEvents Interface


MeetingStore Event

IMeetingDataApiEvents..::..MeetingStore Event
IMeetingDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) new meeting(s) was added.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event MeetingStore As EventHandler(Of MeetingDataChangedEventArgs)
C#
event EventHandler<MeetingDataChangedEventArgs> MeetingStore

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApiEvents Interface


MeetingUpdate Event

IMeetingDataApiEvents..::..MeetingUpdate Event
IMeetingDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) meeting(s) is/are updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event MeetingUpdate As EventHandler(Of MeetingDataChangedEventArgs)
C#
event EventHandler<MeetingDataChangedEventArgs> MeetingUpdate

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApiEvents Interface


SessionDeletion Event

IMeetingDataApiEvents..::..SessionDeletion Event
IMeetingDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a session was deleted from a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event SessionDeletion As EventHandler(Of SessionDataChangedEventArgs)
C#
event EventHandler<SessionDataChangedEventArgs> SessionDeletion

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApiEvents Interface


SessionStore Event

IMeetingDataApiEvents..::..SessionStore Event
IMeetingDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) new sessions(s) was added to a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event SessionStore As EventHandler(Of SessionDataChangedEventArgs)
C#
event EventHandler<SessionDataChangedEventArgs> SessionStore

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApiEvents Interface


SessionUpdate Event

IMeetingDataApiEvents..::..SessionUpdate Event
IMeetingDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) session(s) is/are updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event SessionUpdate As EventHandler(Of SessionDataChangedEventArgs)
C#
event EventHandler<SessionDataChangedEventArgs> SessionUpdate

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApiEvents Interface


SortPositionChanged Event

IMeetingDataApiEvents..::..SortPositionChanged Event
IMeetingDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a session order is changed

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event SortPositionChanged As EventHandler(Of SessionDataChangedEventArgs)
C#
event EventHandler<SessionDataChangedEventArgs> SortPositionChanged

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingDataApiEvents Interface


IMeetingGroupDataApi Interface

IMeetingGroupDataApi Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface that can be used to retrieve the meeting groups available in the system. See also IMeetingGroupDataApi Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IMeetingGroupDataApi _
    Inherits IMeetingGroupDataApiEvents
C#
[ObfuscationAttribute]
public interface IMeetingGroupDataApi : IMeetingGroupDataApiEvents

See Also

IMeetingGroupDataApi Members


IMeetingGroupDataApi Members

IMeetingGroupDataApi Members
IMeetingGroupDataApi Interface Methods Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingGroupDataApi type exposes the following members.

Methods

 | Name | Description
Public method | AddMeetingGroup | Add meeting group.
Public method | RetrieveMeetingGroups | Retrieves the set of meeting groups.
Public method | RetrieveMeetingGroupsById | Retrieves the set of meeting groups, identified by meeting group ID.
Public method | UpdateMeetingGroup | Updates existing meeting group name and description.

Events

 | Name | Description
Public event | MeetingGroupDeletion | Occurs when a meeting group was deleted. (Inherited from IMeetingGroupDataApiEvents.)
Public event | MeetingGroupStore | Occurs when (a) new meeting group(s) was added. (Inherited from IMeetingGroupDataApiEvents.)
Public event | MeetingGroupUpdate | Occurs when (a) meeting group(s) is/are updated. (Inherited from IMeetingGroupDataApiEvents.)

See Also

IMeetingGroupDataApi Interface


IMeetingGroupDataApi Methods

IMeetingGroupDataApi Methods
IMeetingGroupDataApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingGroupDataApi type exposes the following members.

Methods

 | Name | Description
Public method | AddMeetingGroup | Add meeting group.
Public method | RetrieveMeetingGroups | Retrieves the set of meeting groups.
Public method | RetrieveMeetingGroupsById | Retrieves the set of meeting groups, identified by meeting group ID.
Public method | UpdateMeetingGroup | Updates existing meeting group name and description.

See Also

IMeetingGroupDataApi Interface


AddMeetingGroup Method

IMeetingGroupDataApi..::..AddMeetingGroup Method
IMeetingGroupDataApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Add meeting group.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function AddMeetingGroup ( _
    <OutAttribute> ByRef meetingGroupId As Integer _
) As API_ERROR
C#
API_ERROR AddMeetingGroup(
    out int meetingGroupId
)

Parameters

meetingGroupId
Type: System..::..Int32 %
new meeting group id

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - if authorization is not for configuration.
ERROR - Exception.

Examples

Below example shows how to add new meeting group using API method - AddMeetingGroup.

Copy image Copy Code
             //Get Config API.
             configApi = DcnApi.ConfigApi;
             configApi.MeetingGroupApi.MeetingGroupStore += onMeetingGroupStore;
             ...
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (configApi.IsAvailable)
                  {
                     IMeetingGroupData meetingGroupApi = configApi.MeetingGroupData;
                      //Call Api method to adding meeting group.
                      error = meetingApi.AddMeetingGroup(out meetingGroupId);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while adding meeting group
             }
             ....

             private void onMeetingGroupStore(object sender, MeetingGroupDataChangedEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingGroupDataApi Interface


RetrieveMeetingGroups Method

IMeetingGroupDataApi..::..RetrieveMeetingGroups Method
IMeetingGroupDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the set of meeting groups.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveMeetingGroups ( _
    <OutAttribute> ByRef meetingGroupIds As Integer(), _
    <OutAttribute> ByRef meetingGroups As MEETING_GROUP_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveMeetingGroups(
    out int[] meetingGroupIds,
    out MEETING_GROUP_INFO[] meetingGroups
)

Parameters

meetingGroupIds
Type: array< System..::..Int32 >[]()[][]%
The list of ID's defining the set of available meeting groups.
meetingGroups
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_GROUP_INFO >[]()[][]%
The list of meeting groups.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingGroupDataApi Interface


RetrieveMeetingGroupsById Method

IMeetingGroupDataApi..::..RetrieveMeetingGroupsById Method
IMeetingGroupDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the set of meeting groups, identified by meeting group ID.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveMeetingGroupsById ( _
    meetingGroupIds As Integer(), _
    <OutAttribute> ByRef meetingGroups As MEETING_GROUP_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveMeetingGroupsById(
    int[] meetingGroupIds,
    out MEETING_GROUP_INFO[] meetingGroups
)

Parameters

meetingGroupIds
Type: array< System..::..Int32 >[]()[][]
The list of ID's of the meeting groups to retrieve.
meetingGroups
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_GROUP_INFO >[]()[][]%
The list of meeting groups.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | if the list of meeting group ID's contains an invalid ID.

See Also

IMeetingGroupDataApi Interface


UpdateMeetingGroup Method

IMeetingGroupDataApi..::..UpdateMeetingGroup Method
IMeetingGroupDataApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Updates existing meeting group name and description.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function UpdateMeetingGroup ( _
    meetingGroupId As Integer, _
    meetingGroupName As String, _
    description As String _
) As API_ERROR
C#
API_ERROR UpdateMeetingGroup(
    int meetingGroupId,
    string meetingGroupName,
    string description
)

Parameters

meetingGroupId
Type: System..::..Int32
Existing meeting group ID.
meetingGroupName
Type: System..::..String
New meeting group name (maximum character allowed is 50 characters).
description
Type: System..::..String
Meeting group description (maximum character allowed is 255 characters).

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - if authorization is not for configuration.
INVALID_PARAMETER- if meetingGroupId parameter is invalid.
UNKNOWN_MEETING_GROUP - if meeting group id is unknown.
ERROR -if Exception or when group name or description characters exceed maximum.

Examples

Below example shows how to rename meeting group name and description by meeting group id using API method - RenameMeetingGroupNameById.

Copy image Copy Code
             //Get Config API.
             configApi = DcnApi.ConfigApi;
             configApi.MeetingGroupApi.MeetingGroupUpdate += onMeetingGroupUpdate;
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (configApi.IsAvailable)
                  {
                     IMeetingGroupData meetingGroupApi = configApi.MeetingGroupData;
                      //Call Api method to rename meeting group name.
                      error = meetingApi.UpdateMeetingGroup(int meetingGroupId, string meetingGroupName,string description);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }
             else
             {
                 //failure while renaming meeting group name
             }
             ....

             private void onMeetingGroupUpdate(object sender, MeetingGroupDataChangedEventArgs arguments)
             {
                 //your code...
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingGroupDataApi Interface


IMeetingGroupDataApi Events

IMeetingGroupDataApi Events
IMeetingGroupDataApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingGroupDataApi type exposes the following members.

Events

 | Name | Description
Public event | MeetingGroupDeletion | Occurs when a meeting group was deleted. (Inherited from IMeetingGroupDataApiEvents.)
Public event | MeetingGroupStore | Occurs when (a) new meeting group(s) was added. (Inherited from IMeetingGroupDataApiEvents.)
Public event | MeetingGroupUpdate | Occurs when (a) meeting group(s) is/are updated. (Inherited from IMeetingGroupDataApiEvents.)

See Also

IMeetingGroupDataApi Interface


IMeetingGroupDataApiEvents Interface

IMeetingGroupDataApiEvents Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface defining all events for the meeting groups API data-interface. See also IMeetingGroupDataApiEvents Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IMeetingGroupDataApiEvents
C#
[ObfuscationAttribute]
public interface IMeetingGroupDataApiEvents

See Also

IMeetingGroupDataApiEvents Members


IMeetingGroupDataApiEvents Members

IMeetingGroupDataApiEvents Members
IMeetingGroupDataApiEvents Interface Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingGroupDataApiEvents type exposes the following members.

Events

 | Name | Description
Public event | MeetingGroupDeletion | Occurs when a meeting group was deleted.
Public event | MeetingGroupStore | Occurs when (a) new meeting group(s) was added.
Public event | MeetingGroupUpdate | Occurs when (a) meeting group(s) is/are updated.

See Also

IMeetingGroupDataApiEvents Interface


IMeetingGroupDataApiEvents Events

IMeetingGroupDataApiEvents Events
IMeetingGroupDataApiEvents Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IMeetingGroupDataApiEvents type exposes the following members.

Events

 | Name | Description
Public event | MeetingGroupDeletion | Occurs when a meeting group was deleted.
Public event | MeetingGroupStore | Occurs when (a) new meeting group(s) was added.
Public event | MeetingGroupUpdate | Occurs when (a) meeting group(s) is/are updated.

See Also

IMeetingGroupDataApiEvents Interface


MeetingGroupDeletion Event

IMeetingGroupDataApiEvents..::..MeetingGroupDeletion Event
IMeetingGroupDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a meeting group was deleted.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event MeetingGroupDeletion As EventHandler(Of MeetingGroupDataChangedEventArgs)
C#
event EventHandler<MeetingGroupDataChangedEventArgs> MeetingGroupDeletion

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingGroupDataApiEvents Interface


MeetingGroupStore Event

IMeetingGroupDataApiEvents..::..MeetingGroupStore Event
IMeetingGroupDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) new meeting group(s) was added.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event MeetingGroupStore As EventHandler(Of MeetingGroupDataChangedEventArgs)
C#
event EventHandler<MeetingGroupDataChangedEventArgs> MeetingGroupStore

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingGroupDataApiEvents Interface


MeetingGroupUpdate Event

IMeetingGroupDataApiEvents..::..MeetingGroupUpdate Event
IMeetingGroupDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) meeting group(s) is/are updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event MeetingGroupUpdate As EventHandler(Of MeetingGroupDataChangedEventArgs)
C#
event EventHandler<MeetingGroupDataChangedEventArgs> MeetingGroupUpdate

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IMeetingGroupDataApiEvents Interface


InterlockMode Enumeration

InterlockMode Enumeration
See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Modes for the interlock setting within and between booths

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Enumeration InterlockMode
C#
[ObfuscationAttribute]
public enum InterlockMode

Members

Member name | Value | Description
None | 0 | During speech of the interpreter having the channel others cannot interrupt.
Interlock | 1 | Only a single interpreter can use the channel.
Override | 2 | The second interpreter can override the current interpreter and gets the channel when he activates the channel.
InterlockOnAOverrideOnB | 3 | The second interpreter only may override the current when the current uses his B-Output for translations.

See Also

Bosch.Dcn.Ecpc.Client.Api.Interfaces Namespace
Copyright (c) 2014 Bosch Security Systems B.V.4.30.0011


INTERPRETATION_LANGUAGE_INFO Structure

INTERPRETATION_LANGUAGE_INFO Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Represents a container holding all information of a interpretation language

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Structure INTERPRETATION_LANGUAGE_INFO
C#
[ObfuscationAttribute]
public struct INTERPRETATION_LANGUAGE_INFO

See Also

INTERPRETATION_LANGUAGE_INFO Members


INTERPRETATION_LANGUAGE_INFO Members

INTERPRETATION_LANGUAGE_INFO Members
INTERPRETATION_LANGUAGE_INFO Structure Methods Operators Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The INTERPRETATION_LANGUAGE_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two INTERPRETATION_LANGUAGE_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a INTERPRETATION_LANGUAGE_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Operators

Name | Description
Equality | Checks the equality of two INTERPRETATION_LANGUAGE_INFO structures.
Inequality | Checks the non-equality of two INTERPRETATION_LANGUAGE_INFO structures.

Fields

 | Name | Description
Public field | Abbreviation | The abbreviation for the language.
Public field | Name | The name of the language.
Public field | OriginalName | The original name of the language.
Public field | UserDefined | True when the language is defined by the user. False when the language is defined by the system.

See Also

INTERPRETATION_LANGUAGE_INFO Structure


INTERPRETATION_LANGUAGE_INFO Fields

INTERPRETATION_LANGUAGE_INFO Fields
INTERPRETATION_LANGUAGE_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The INTERPRETATION_LANGUAGE_INFO type exposes the following members.

Fields

 | Name | Description
Public field | Abbreviation | The abbreviation for the language.
Public field | Name | The name of the language.
Public field | OriginalName | The original name of the language.
Public field | UserDefined | True when the language is defined by the user. False when the language is defined by the system.

See Also

INTERPRETATION_LANGUAGE_INFO Structure


Abbreviation Field

INTERPRETATION_LANGUAGE_INFO..::..Abbreviation Field
INTERPRETATION_LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The abbreviation for the language.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Abbreviation As String
C#
public string Abbreviation

See Also

INTERPRETATION_LANGUAGE_INFO Structure


Name Field

INTERPRETATION_LANGUAGE_INFO..::..Name Field
INTERPRETATION_LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The name of the language.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Name As String
C#
public string Name

See Also

INTERPRETATION_LANGUAGE_INFO Structure


OriginalName Field

INTERPRETATION_LANGUAGE_INFO..::..OriginalName Field
INTERPRETATION_LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The original name of the language.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public OriginalName As String
C#
public string OriginalName

See Also

INTERPRETATION_LANGUAGE_INFO Structure


UserDefined Field

INTERPRETATION_LANGUAGE_INFO..::..UserDefined Field
INTERPRETATION_LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
True when the language is defined by the user. False when the language is defined by the system.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public UserDefined As Boolean
C#
public bool UserDefined

See Also

INTERPRETATION_LANGUAGE_INFO Structure


INTERPRETATION_LANGUAGE_INFO Methods

INTERPRETATION_LANGUAGE_INFO Methods
INTERPRETATION_LANGUAGE_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The INTERPRETATION_LANGUAGE_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two INTERPRETATION_LANGUAGE_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a INTERPRETATION_LANGUAGE_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

INTERPRETATION_LANGUAGE_INFO Structure


Equals Method

INTERPRETATION_LANGUAGE_INFO..::..Equals Method
INTERPRETATION_LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Determines whether two INTERPRETATION_LANGUAGE_INFO instances are equal.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::..Object
The INTERPRETATION_LANGUAGE_INFO to compare with the current Object.

Return Value

true if the specified INTERPRETATION_LANGUAGE_INFO is equal to the current Object; otherwise, false.

See Also

INTERPRETATION_LANGUAGE_INFO Structure


GetHashCode Method

INTERPRETATION_LANGUAGE_INFO..::..GetHashCode Method
INTERPRETATION_LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Serves as a hash function for a INTERPRETATION_LANGUAGE_INFO type.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current INTERPRETATION_LANGUAGE_INFO.

See Also

INTERPRETATION_LANGUAGE_INFO Structure


INTERPRETATION_LANGUAGE_INFO Operators

INTERPRETATION_LANGUAGE_INFO Operators
INTERPRETATION_LANGUAGE_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The INTERPRETATION_LANGUAGE_INFO type exposes the following members.

Operators

Name | Description
Equality | Checks the equality of two INTERPRETATION_LANGUAGE_INFO structures.
Inequality | Checks the non-equality of two INTERPRETATION_LANGUAGE_INFO structures.

See Also

INTERPRETATION_LANGUAGE_INFO Structure


Equality Operator

INTERPRETATION_LANGUAGE_INFO..::..Equality Operator
INTERPRETATION_LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the equality of two INTERPRETATION_LANGUAGE_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    a As INTERPRETATION_LANGUAGE_INFO, _
    b As INTERPRETATION_LANGUAGE_INFO _
) As Boolean
C#
public static bool operator ==(
    INTERPRETATION_LANGUAGE_INFO a,
    INTERPRETATION_LANGUAGE_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..INTERPRETATION_LANGUAGE_INFO
The first INTERPRETATION_LANGUAGE_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..INTERPRETATION_LANGUAGE_INFO
The next INTERPRETATION_LANGUAGE_INFO to compare.

Return Value

true if the specified INTERPRETATION_LANGUAGE_INFO structures are the same; otherwise, false.

See Also

INTERPRETATION_LANGUAGE_INFO Structure


Inequality Operator

INTERPRETATION_LANGUAGE_INFO..::..Inequality Operator
INTERPRETATION_LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the non-equality of two INTERPRETATION_LANGUAGE_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    a As INTERPRETATION_LANGUAGE_INFO, _
    b As INTERPRETATION_LANGUAGE_INFO _
) As Boolean
C#
public static bool operator !=(
    INTERPRETATION_LANGUAGE_INFO a,
    INTERPRETATION_LANGUAGE_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..INTERPRETATION_LANGUAGE_INFO
The first INTERPRETATION_LANGUAGE_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..INTERPRETATION_LANGUAGE_INFO
The next INTERPRETATION_LANGUAGE_INFO to compare.

Return Value

true if the specified INTERPRETATION_LANGUAGE_INFO structures are not the same; otherwise, false.

See Also

INTERPRETATION_LANGUAGE_INFO Structure


ISystemDataApi Interface

ISystemDataApi Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface that is to be used to configure system data. See also ISystemDataApi Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface ISystemDataApi _
    Inherits ISystemDataApiEvents
C#
[ObfuscationAttribute]
public interface ISystemDataApi : ISystemDataApiEvents

Remarks

Examples

Copy image Copy Code
             using Bosch.Dcn.Ecpc.Client.Api.Interfaces;
             using Bosch.Dcn.Ecpc.Client.Api.Logic;
               class Example
               {
                   public static void Main()
                   {
                       IConfigApi configApi = DcnApi.ConfigApi;

                      // ...handle initialization of the DCN-SW API here....

                       ISystemDataApi systemApi = configApi.SystemApi;

                      ChannelType[] channelType;
                       API_ERROR error;
                       if (configApi.IsAvailable)
                       {
                           error = systemApi.RetrieveChannelDefinition(out channelType);
                           if (API_ERROR.NONE == error)
                           {
                               // Your Code...
                           }
                           //
                           //Your code
                           //
                           systemApi.ChannelDefinitionUpdate += OnChannelDefinitionUpdate;
                           //
                           //Your code
                           //
                           error = systemApi.UpdateChannelDefinition(12, 5);
                           if (API_ERROR.NONE == error)
                           {
                               // Your Code...
                           }
                        }
                   }

                   private void OnChannelDefinitionUpdate(object sender, ChannelDefinitionDataChangedEventArgs args)
                   {
                       // Handle the updates in Channel Definition here...
                   }

               }

See Also

ISystemDataApi Members


ISystemDataApi Members

ISystemDataApi Members
ISystemDataApi Interface Methods Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ISystemDataApi type exposes the following members.

Methods

 | Name | Description
Public method | RetrieveChannelDefinition | Retrieves the channel definition of the system.
Public method | RetrieveTimerToHoldSpeakSlowlyRequest | Retrieves the timer value to hold the speak slowly request.
Public method | RetrieveUseOfHelpSignalling | Retrieves the configuration of using the help signalling.
Public method | RetrieveWebStreamingLicense | Retrieve the license for webcast internet streaming.
Public method | UpdateChannelDefinition | Updates the information of the channel definition.
Public method | UpdateTimerToHoldSpeakSlowlyRequest | Updates the timer value to hold the speak slowly request.
Public method | UpdateUseOfHelpSignalling | Updates the configuration of using the help signalling.

Events

 | Name | Description
Public event | ChannelDefinitionUpdate | Occurs when the channel definition is updated. (Inherited from ISystemDataApiEvents.)
Public event | TimerToHoldSpeakSlowlyRequestUpdate | Occurs when the timer value to hold the speak slowly request is updated. (Inherited from ISystemDataApiEvents.)
Public event | UseOfHelpSignallingUpdate | Occurs when the use of help signalling is updated. (Inherited from ISystemDataApiEvents.)

See Also

ISystemDataApi Interface


ISystemDataApi Methods

ISystemDataApi Methods
ISystemDataApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ISystemDataApi type exposes the following members.

Methods

 | Name | Description
Public method | RetrieveChannelDefinition | Retrieves the channel definition of the system.
Public method | RetrieveTimerToHoldSpeakSlowlyRequest | Retrieves the timer value to hold the speak slowly request.
Public method | RetrieveUseOfHelpSignalling | Retrieves the configuration of using the help signalling.
Public method | RetrieveWebStreamingLicense | Retrieve the license for webcast internet streaming.
Public method | UpdateChannelDefinition | Updates the information of the channel definition.
Public method | UpdateTimerToHoldSpeakSlowlyRequest | Updates the timer value to hold the speak slowly request.
Public method | UpdateUseOfHelpSignalling | Updates the configuration of using the help signalling.

See Also

ISystemDataApi Interface


RetrieveChannelDefinition Method

ISystemDataApi..::..RetrieveChannelDefinition Method
ISystemDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the channel definition of the system.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveChannelDefinition ( _
    <OutAttribute> ByRef channelDefinition As ChannelType() _
) As API_ERROR
C#
API_ERROR RetrieveChannelDefinition(
    out ChannelType[] channelDefinition
)

Parameters

channelDefinition
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ChannelType >[]()[][]%
The list of Channel types that are defined for the channels.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

ISystemDataApi Interface


RetrieveTimerToHoldSpeakSlowlyRequest Method

ISystemDataApi..::..RetrieveTimerToHoldSpeakSlowlyRequest Method
ISystemDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the timer value to hold the speak slowly request.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveTimerToHoldSpeakSlowlyRequest ( _
    <OutAttribute> ByRef timer As Integer _
) As API_ERROR
C#
API_ERROR RetrieveTimerToHoldSpeakSlowlyRequest(
    out int timer
)

Parameters

timer
Type: System..::..Int32 %
Timer to hold the speak slowly request in seconds

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException |

See Also

ISystemDataApi Interface


RetrieveUseOfHelpSignalling Method

ISystemDataApi..::..RetrieveUseOfHelpSignalling Method
ISystemDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the configuration of using the help signalling.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveUseOfHelpSignalling ( _
    <OutAttribute> ByRef enableForParticipants As Boolean, _
    <OutAttribute> ByRef enableForInterpreters As Boolean _
) As API_ERROR
C#
API_ERROR RetrieveUseOfHelpSignalling(
    out bool enableForParticipants,
    out bool enableForInterpreters
)

Parameters

enableForParticipants
Type: System..::..Boolean %
If true the help signalling is enabled for participants
enableForInterpreters
Type: System..::..Boolean %
If true the help signalling is enabled for interpreters

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException |

See Also

ISystemDataApi Interface


RetrieveWebStreamingLicense Method

ISystemDataApi..::..RetrieveWebStreamingLicense Method
ISystemDataApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieve the license for webcast internet streaming.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveWebStreamingLicense ( _
    <OutAttribute> ByRef license As WEB_STREAMING_LICENSE _
) As API_ERROR
C#
API_ERROR RetrieveWebStreamingLicense(
    out WEB_STREAMING_LICENSE license
)

Parameters

license
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..WEB_STREAMING_LICENSE %
returns license details.

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - IsConfigAllowed is set to false.

Examples

Below Example shows how to retrieve Web streaming license using API method - RetrieveWebStreamingLicense.

Copy image Copy Code
             //Get config API.
             configApi = DcnApi.ConfigApi;
             WEB_STREAMING_LICENSE license = new WEB_STREAMING_LICENSE();
             ...
             API_ERROR error = API_ERROR.NONE;
             //Check if a connection to the DCN-SW server is available
             if (configApi.IsAvailable)
             {
                  ISystemDataApi systemDataApi = configApi.SystemApi;
                  systemDataApi.RetrieveWebStreamingLicense(out license);
             }
             else
             {
                 error = API_ERROR.NOT_AVAILABLE;
             }

             if(error == API_ERROR.NONE)
             {
                 //your code
             }

See Also

ISystemDataApi Interface


UpdateChannelDefinition Method

ISystemDataApi..::..UpdateChannelDefinition Method
ISystemDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Updates the information of the channel definition.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function UpdateChannelDefinition ( _
    nrOfInterpretationChannels As Integer, _
    nrOfIntercomChannels As Integer _
) As API_ERROR
C#
API_ERROR UpdateChannelDefinition(
    int nrOfInterpretationChannels,
    int nrOfIntercomChannels
)

Parameters

nrOfInterpretationChannels
Type: System..::..Int32
Number of channels that are to be set as Interpretaion Channels(0-31)
nrOfIntercomChannels
Type: System..::..Int32
Number of channels that are to be set as Intercom Channels (0-6)

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | If cahnnel definition for one or more channels has failed.

See Also

ISystemDataApi Interface


UpdateTimerToHoldSpeakSlowlyRequest Method

ISystemDataApi..::..UpdateTimerToHoldSpeakSlowlyRequest Method
ISystemDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Updates the timer value to hold the speak slowly request.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function UpdateTimerToHoldSpeakSlowlyRequest ( _
    timer As Integer _
) As API_ERROR
C#
API_ERROR UpdateTimerToHoldSpeakSlowlyRequest(
    int timer
)

Parameters

timer
Type: System..::..Int32
Timer to hold the speak slowly request in seconds (0-30)

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException |

See Also

ISystemDataApi Interface


UpdateUseOfHelpSignalling Method

ISystemDataApi..::..UpdateUseOfHelpSignalling Method
ISystemDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Updates the configuration of using the help signalling.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function UpdateUseOfHelpSignalling ( _
    enableForParticipants As Boolean, _
    enableForInterpreters As Boolean _
) As API_ERROR
C#
API_ERROR UpdateUseOfHelpSignalling(
    bool enableForParticipants,
    bool enableForInterpreters
)

Parameters

enableForParticipants
Type: System..::..Boolean
If true the help signalling is enabled for participants
enableForInterpreters
Type: System..::..Boolean
If true the help signalling is enabled for interpreters

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException |

See Also

ISystemDataApi Interface


ISystemDataApi Events

ISystemDataApi Events
ISystemDataApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ISystemDataApi type exposes the following members.

Events

 | Name | Description
Public event | ChannelDefinitionUpdate | Occurs when the channel definition is updated. (Inherited from ISystemDataApiEvents.)
Public event | TimerToHoldSpeakSlowlyRequestUpdate | Occurs when the timer value to hold the speak slowly request is updated. (Inherited from ISystemDataApiEvents.)
Public event | UseOfHelpSignallingUpdate | Occurs when the use of help signalling is updated. (Inherited from ISystemDataApiEvents.)

See Also

ISystemDataApi Interface


ISystemDataApiEvents Interface

ISystemDataApiEvents Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface defining all events for the votes API data-interface. See also ISystemDataApiEvents Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface ISystemDataApiEvents
C#
[ObfuscationAttribute]
public interface ISystemDataApiEvents

See Also

ISystemDataApiEvents Members


ISystemDataApiEvents Members

ISystemDataApiEvents Members
ISystemDataApiEvents Interface Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ISystemDataApiEvents type exposes the following members.

Events

 | Name | Description
Public event | ChannelDefinitionUpdate | Occurs when the channel definition is updated.
Public event | TimerToHoldSpeakSlowlyRequestUpdate | Occurs when the timer value to hold the speak slowly request is updated.
Public event | UseOfHelpSignallingUpdate | Occurs when the use of help signalling is updated.

See Also

ISystemDataApiEvents Interface


ISystemDataApiEvents Events

ISystemDataApiEvents Events
ISystemDataApiEvents Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The ISystemDataApiEvents type exposes the following members.

Events

 | Name | Description
Public event | ChannelDefinitionUpdate | Occurs when the channel definition is updated.
Public event | TimerToHoldSpeakSlowlyRequestUpdate | Occurs when the timer value to hold the speak slowly request is updated.
Public event | UseOfHelpSignallingUpdate | Occurs when the use of help signalling is updated.

See Also

ISystemDataApiEvents Interface


ChannelDefinitionUpdate Event

ISystemDataApiEvents..::..ChannelDefinitionUpdate Event
ISystemDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when the channel definition is updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event ChannelDefinitionUpdate As EventHandler(Of ChannelDefinitionDataChangedEventArgs)
C#
event EventHandler<ChannelDefinitionDataChangedEventArgs> ChannelDefinitionUpdate

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

ISystemDataApiEvents Interface


TimerToHoldSpeakSlowlyRequestUpdate Event

ISystemDataApiEvents..::..TimerToHoldSpeakSlowlyRequestUpdate Event
ISystemDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when the timer value to hold the speak slowly request is updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event TimerToHoldSpeakSlowlyRequestUpdate As EventHandler(Of TimerToHoldSpeakSlowlyRequestDataChangedEventArgs)
C#
event EventHandler<TimerToHoldSpeakSlowlyRequestDataChangedEventArgs> TimerToHoldSpeakSlowlyRequestUpdate

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

ISystemDataApiEvents Interface


UseOfHelpSignallingUpdate Event

ISystemDataApiEvents..::..UseOfHelpSignallingUpdate Event
ISystemDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when the use of help signalling is updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event UseOfHelpSignallingUpdate As EventHandler(Of UseOfHelpSignallingDataChangedEventArgs)
C#
event EventHandler<UseOfHelpSignallingDataChangedEventArgs> UseOfHelpSignallingUpdate

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

ISystemDataApiEvents Interface


IVoteApi Interface

IVoteApi Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface that can be used to control and retrieve voting related operational state. See also IVoteApi Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IVoteApi _
    Inherits IVoteApiEvents
C#
[ObfuscationAttribute]
public interface IVoteApi : IVoteApiEvents

See Also

IVoteApi Members


IVoteApi Members

IVoteApi Members
IVoteApi Interface Methods Properties Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IVoteApi type exposes the following members.

Methods

 | Name | Description
Public method | ContinueVoting | Continues the active voting.
Public method | HoldVoting | Holds the active voting.
Public method | RetrieveActiveVotingId | Retrieves the configuration identifier of the currently active voting.
Public method | RetrieveVotingsForActiveSession | Retrieves active session voting ids.
Public method | SelectVotingById | The voting number and subject of the selected voting are sent to the chairman unit.
Public method | StartAdhocVoting | Starts an adhoc voting.
Public method | StartVotingById | Starts voting of the given id.
Public method | StopVoting | Stops the active vote.
Public method | SummonVoting | Plays an attention sound summon the participants to voting

Properties

 | Name | Description
Public property | IsMultiVotingControlAllowed | Information which will indicate whether the user can control multi voting. When licenses DCN-SW, DCN-SWAPI and DCN-SWMV and privilege CV are present, value will be set to true.
Public property | IsParliamentaryVotingControlAllowed | Information which will indicate whether the user can control parliamentary voting. When licenses DCN-SW, DCN-SWAPI and DCN-SWPV and privilege CV are present, value will be set to true.
Public property | IsVotingStandardViewAllowed | Information which will indicate whether the user can view voting status. When licenses DCN-SW, DCN-SWAPI and privilege VMS are present, value will be set to true.

Events

 | Name | Description
Public event | VoteResults | Occurs when a vote results have been received. (Inherited from IVoteApiEvents.)
Public event | VotingAccepted | Occurs when the configured majority and quorum reaches or when an majority reaches. (Inherited from IVoteApiEvents.)
Public event | VotingContinue | Occurs when the voting continues. (Inherited from IVoteApiEvents.)
Public event | VotingHold | Occurs when a vote has been put on hold. (Inherited from IVoteApiEvents.)
Public event | VotingQuorumUpdated | Occurs when the quorum regarding a voting is updated. (Inherited from IVoteApiEvents.)
Public event | VotingRejected | Occurs when the configured majority and quorum not reached or when an majority not reached. (Inherited from IVoteApiEvents.)
Public event | VotingSelect | Occurs when a vote has been selected. (Inherited from IVoteApiEvents.)
Public event | VotingStart | Occurs when a vote has been started. (Inherited from IVoteApiEvents.)
Public event | VotingStop | Occurs when a vote has been stopped. (Inherited from IVoteApiEvents.)
Public event | VotingTimer | Time left of voting in session. (Inherited from IVoteApiEvents.)

See Also

IVoteApi Interface


IVoteApi Methods

IVoteApi Methods
IVoteApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IVoteApi type exposes the following members.

Methods

 | Name | Description
Public method | ContinueVoting | Continues the active voting.
Public method | HoldVoting | Holds the active voting.
Public method | RetrieveActiveVotingId | Retrieves the configuration identifier of the currently active voting.
Public method | RetrieveVotingsForActiveSession | Retrieves active session voting ids.
Public method | SelectVotingById | The voting number and subject of the selected voting are sent to the chairman unit.
Public method | StartAdhocVoting | Starts an adhoc voting.
Public method | StartVotingById | Starts voting of the given id.
Public method | StopVoting | Stops the active vote.
Public method | SummonVoting | Plays an attention sound summon the participants to voting

See Also

IVoteApi Interface


ContinueVoting Method

IVoteApi..::..ContinueVoting Method
IVoteApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Continues the active voting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function ContinueVoting As API_ERROR
C#
API_ERROR ContinueVoting()

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsMultiVotingControlAllowed and IsParliamentaryVotingControlAllowed is set to false.
NOT_ACTIVE - Voting is not running.
NOT_ON_HOLD - When voting is not on hold to resume.
RESUME_FAILED - When voting can't be resumed.
ERROR - Exception.

Examples

Below example shows how to resume a voting using API method - ResumeVoting.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IVoteApi voteApi = controlApi.VoteApi;

                          //Call Api method to resume voting.
                          error = voteApi.ResumeVoting();
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApi Interface


HoldVoting Method

IVoteApi..::..HoldVoting Method
IVoteApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Holds the active voting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function HoldVoting As API_ERROR
C#
API_ERROR HoldVoting()

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsMultiVotingControlAllowed and IsParliamentaryVotingControlAllowed is set to false.
NOT_ACTIVE - Voting is not running.
ON_HOLD - When voting is already on hold.
HOLD_FAILED - When voting can't be put on hold.
ERROR - Exception.

Examples

Below example shows how to hold a voting using API method - HoldVoting.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IVoteApi voteApi = controlApi.VoteApi;

                          //Call Api method to hold voting.
                          error = voteApi.HoldVoting();
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApi Interface


RetrieveActiveVotingId Method

IVoteApi..::..RetrieveActiveVotingId Method
IVoteApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the configuration identifier of the currently active voting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveActiveVotingId ( _
    <OutAttribute> ByRef votingId As Integer _
) As API_ERROR
C#
API_ERROR RetrieveActiveVotingId(
    out int votingId
)

Parameters

votingId
Type: System..::..Int32 %
container to hold the active voting id

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsVotingStandardViewAllowed is set to false.
NOT_ACTIVE - Voting is not running.
ERROR - Exception.

Examples

Below example shows how to retrieve active voting id using API method - RetrieveActiveVotingId.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                     int votingId;
                      IVoteApi voteApi = controlApi.VoteApi;

                          //Call Api method to Retrieve Active Voting Id.
                          error = voteApi.RetrieveActiveVotingId(out votingId);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApi Interface


RetrieveVotingsForActiveSession Method

IVoteApi..::..RetrieveVotingsForActiveSession Method
IVoteApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves active session voting ids.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveVotingsForActiveSession ( _
    <OutAttribute> ByRef votingIds As Integer() _
) As API_ERROR
C#
API_ERROR RetrieveVotingsForActiveSession(
    out int[] votingIds
)

Parameters

votingIds
Type: array< System..::..Int32 >[]()[][]%
Array which contians active session voting id.

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsVotingStandardViewAllowed is set to false.
NOT_ACTIVE - Voting is not running.
ERROR - Exception.

Examples

Below example shows how to retrieve active session voting ids using API method - RetrieveVotingsForActiveSession.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                     int[] votingIds = null;
                      IVoteApi voteApi = controlApi.VoteApi;

                          //Call Api method to Retrieve Active session Voting ids.
                          error = voteApi.RetrieveVotingsForActiveSession(out votingIds);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApi Interface


SelectVotingById Method

IVoteApi..::..SelectVotingById Method
IVoteApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The voting number and subject of the selected voting are sent to the chairman unit.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function SelectVotingById ( _
    votingId As Integer _
) As API_ERROR
C#
API_ERROR SelectVotingById(
    int votingId
)

Parameters

votingId
Type: System..::..Int32
voting id which has to be started.

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsMultiVotingControlAllowed and IsParliamentaryVotingControlAllowed is set to false.
ALREADY_ACTIVE - Voting is already running.
UNKNOWN_VOTING - Unknown Voting Id/Database is not available.
NOT_ACTIVE - Meeting is not running.
SELECT_FAILED - When voting couldn't be selected.
ERROR - Exception.

Examples

Below example shows how to select a voting using API method - SelectVotingById.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             //Get votingid of session.
             ...
             controlApi.VoteApi.RetrieveVotingsForActiveSession(out int[] votingIds )
             ...
             //Select votingid to select voting.
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IVoteApi voteApi = controlApi.VoteApi;

                          //Call Api method to select voting.
                          error = voteApi.SelectVotingById(votingid);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApi Interface


StartAdhocVoting Method

IVoteApi..::..StartAdhocVoting Method
IVoteApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Starts an adhoc voting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function StartAdhocVoting ( _
    votingSettings As ADHOC_VOTING_SETTINGS _
) As API_ERROR
C#
API_ERROR StartAdhocVoting(
    ADHOC_VOTING_SETTINGS votingSettings
)

Parameters

votingSettings
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ADHOC_VOTING_SETTINGS
Container for the adhoc voting settings

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsMultiVotingControlAllowed and IsParliamentaryVotingControlAllowed is set to false.
NOT_ACTIVE - Meeting is not running.
INVALID_PARAMETER - When ADHOC_VOTING_SETTINGS contains some invalid values.
SELECT_FAILED - When voting couldn't be selected.
START_FAILED - When voting couldn't be started.
ERROR - Exception.

Examples

Below example shows how to start an adhoc voting using API method - StartAdhocVoting.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             //Get votingid of session.
             ...
             retrieve voting templates.
             configApi.VoteApi.RetrieveVoteTemplates(out int[] voteTemplatedIds, out VOTE_TEMPLATE_INFO[] voteTemplates )

             select which voting template required

             //Set adhoc votings settings.
              ADHOC_VOTING_SETTINGS votingSetting = new ADHOC_VOTING_SETTINGS("111",
                                                        "Adhoc voting",
                                                        "Adhoc voting test",
                                                        VotingAnswerSetType.AudienceResponse,
                                                        voteTemplatedIds[0]);
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IVoteApi voteApi = controlApi.VoteApi;

                          //Call Api method to start adhoc voting.
                          error = voteApi.StartAdhocVoting(votingSetting);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApi Interface


StartVotingById Method

IVoteApi..::..StartVotingById Method
IVoteApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Starts voting of the given id.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function StartVotingById ( _
    votingId As Integer _
) As API_ERROR
C#
API_ERROR StartVotingById(
    int votingId
)

Parameters

votingId
Type: System..::..Int32
voting id which has to be started.

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsMultiVotingControlAllowed and IsParliamentaryVotingControlAllowed is set to false.
ALREADY_ACTIVE - Voting is already running.
UNKNOWN_VOTING - Unknown Voting Id/Database is not available.
NOT_ACTIVE - Meeting is not running.
SELECT_FAILED - When voting couldn't be selected.
START_FAILED - When voting couldn't be started.
ERROR - Exception.

Examples

Below example shows how to start a voting using API method - StartVotingById.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             //Get votingid of session.
             ...
             controlApi.VoteApi.RetrieveVotingsForActiveSession(out int[] votingIds )
             ...
             //Select votingid to start voting.
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IVoteApi voteApi = controlApi.VoteApi;

                          //Call Api method to start voting.
                          error = voteApi.StartVotingById(votingid);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApi Interface


StopVoting Method

IVoteApi..::..StopVoting Method
IVoteApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Stops the active vote.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function StopVoting As API_ERROR
C#
API_ERROR StopVoting()

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsMultiVotingControlAllowed and IsParliamentaryVotingControlAllowed is set to false.
NOT_ACTIVE - Voting is not running.
STOP_FAILED - When voting could not be stopped.s
ERROR - Exception.

Examples

Below example shows how to stop a voting using API method - StopVote.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IVoteApi voteApi = controlApi.VoteApi;

                          //Call Api method to stop voting.
                          error = voteApi.StopVoting();
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApi Interface


SummonVoting Method

IVoteApi..::..SummonVoting Method
IVoteApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Plays an attention sound summon the participants to voting

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function SummonVoting As API_ERROR
C#
API_ERROR SummonVoting()

Return Value

Following API_ERROR can be returned:

NONE - Success.
NOT_AVAILABLE - API is not initialized properly.
NO_AUTHORIZATION - IsMultiVotingControlAllowed and IsParliamentaryVotingControlAllowed is set to false.
NOT_ACTIVE - Voting is not running.
SUMMON_FOR_VOTE_FAILED - When couldn't summon.
ERROR - Exception.

Examples

Below example shows how to summon voting using API method - SummonVoting.

Copy image Copy Code
             //Get Control and Config API.
             configApi = DcnApi.ConfigApi;
             controlApi = DcnApi.ControlApi;
             ...
             API_ERROR error = API_ERROR.ERROR;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (controlApi.IsAvailable)
                  {
                      IVoteApi voteApi = controlApi.VoteApi;

                          //Call Api method to summon voting.
                          error = voteApi.SummonVoting();
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApi Interface


IVoteApi Properties

IVoteApi Properties
IVoteApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IVoteApi type exposes the following members.

Properties

 | Name | Description
Public property | IsMultiVotingControlAllowed | Information which will indicate whether the user can control multi voting. When licenses DCN-SW, DCN-SWAPI and DCN-SWMV and privilege CV are present, value will be set to true.
Public property | IsParliamentaryVotingControlAllowed | Information which will indicate whether the user can control parliamentary voting. When licenses DCN-SW, DCN-SWAPI and DCN-SWPV and privilege CV are present, value will be set to true.
Public property | IsVotingStandardViewAllowed | Information which will indicate whether the user can view voting status. When licenses DCN-SW, DCN-SWAPI and privilege VMS are present, value will be set to true.

See Also

IVoteApi Interface


IsMultiVotingControlAllowed Property

IVoteApi..::..IsMultiVotingControlAllowed Property
IVoteApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Information which will indicate whether the user can control multi voting.
When licenses DCN-SW, DCN-SWAPI and DCN-SWMV and privilege CV are present, value will be set to true.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsMultiVotingControlAllowed As Boolean
    Get
C#
bool IsMultiVotingControlAllowed { get; }

Field Value

true if this is allowed, false otherwise.

See Also

IVoteApi Interface


IsParliamentaryVotingControlAllowed Property

IVoteApi..::..IsParliamentaryVotingControlAllowed Property
IVoteApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Information which will indicate whether the user can control parliamentary voting.
When licenses DCN-SW, DCN-SWAPI and DCN-SWPV and privilege CV are present, value will be set to true.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsParliamentaryVotingControlAllowed As Boolean
    Get
C#
bool IsParliamentaryVotingControlAllowed { get; }

Field Value

true if this is allowed, false otherwise.

See Also

IVoteApi Interface


IsVotingStandardViewAllowed Property

IVoteApi..::..IsVotingStandardViewAllowed Property
IVoteApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Information which will indicate whether the user can view voting status.
When licenses DCN-SW, DCN-SWAPI and privilege VMS are present, value will be set to true.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsVotingStandardViewAllowed As Boolean
    Get
C#
bool IsVotingStandardViewAllowed { get; }

Field Value

true if this is allowed, false otherwise.

See Also

IVoteApi Interface


IVoteApi Events

IVoteApi Events
IVoteApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IVoteApi type exposes the following members.

Events

 | Name | Description
Public event | VoteResults | Occurs when a vote results have been received. (Inherited from IVoteApiEvents.)
Public event | VotingAccepted | Occurs when the configured majority and quorum reaches or when an majority reaches. (Inherited from IVoteApiEvents.)
Public event | VotingContinue | Occurs when the voting continues. (Inherited from IVoteApiEvents.)
Public event | VotingHold | Occurs when a vote has been put on hold. (Inherited from IVoteApiEvents.)
Public event | VotingQuorumUpdated | Occurs when the quorum regarding a voting is updated. (Inherited from IVoteApiEvents.)
Public event | VotingRejected | Occurs when the configured majority and quorum not reached or when an majority not reached. (Inherited from IVoteApiEvents.)
Public event | VotingSelect | Occurs when a vote has been selected. (Inherited from IVoteApiEvents.)
Public event | VotingStart | Occurs when a vote has been started. (Inherited from IVoteApiEvents.)
Public event | VotingStop | Occurs when a vote has been stopped. (Inherited from IVoteApiEvents.)
Public event | VotingTimer | Time left of voting in session. (Inherited from IVoteApiEvents.)

See Also

IVoteApi Interface


IVoteApiEvents Interface

IVoteApiEvents Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface defining all events for the voting API control-interface. See also IVoteApiEvents Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IVoteApiEvents
C#
[ObfuscationAttribute]
public interface IVoteApiEvents

See Also

IVoteApiEvents Members


IVoteApiEvents Members

IVoteApiEvents Members
IVoteApiEvents Interface Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IVoteApiEvents type exposes the following members.

Events

 | Name | Description
Public event | VoteResults | Occurs when a vote results have been received.
Public event | VotingAccepted | Occurs when the configured majority and quorum reaches or when an majority reaches.
Public event | VotingContinue | Occurs when the voting continues.
Public event | VotingHold | Occurs when a vote has been put on hold.
Public event | VotingQuorumUpdated | Occurs when the quorum regarding a voting is updated.
Public event | VotingRejected | Occurs when the configured majority and quorum not reached or when an majority not reached.
Public event | VotingSelect | Occurs when a vote has been selected.
Public event | VotingStart | Occurs when a vote has been started.
Public event | VotingStop | Occurs when a vote has been stopped.
Public event | VotingTimer | Time left of voting in session.

See Also

IVoteApiEvents Interface


IVoteApiEvents Events

IVoteApiEvents Events
IVoteApiEvents Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IVoteApiEvents type exposes the following members.

Events

 | Name | Description
Public event | VoteResults | Occurs when a vote results have been received.
Public event | VotingAccepted | Occurs when the configured majority and quorum reaches or when an majority reaches.
Public event | VotingContinue | Occurs when the voting continues.
Public event | VotingHold | Occurs when a vote has been put on hold.
Public event | VotingQuorumUpdated | Occurs when the quorum regarding a voting is updated.
Public event | VotingRejected | Occurs when the configured majority and quorum not reached or when an majority not reached.
Public event | VotingSelect | Occurs when a vote has been selected.
Public event | VotingStart | Occurs when a vote has been started.
Public event | VotingStop | Occurs when a vote has been stopped.
Public event | VotingTimer | Time left of voting in session.

See Also

IVoteApiEvents Interface


VoteResults Event

IVoteApiEvents..::..VoteResults Event
IVoteApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a vote results have been received.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event VoteResults As EventHandler(Of VoteResultEventArgs)
C#
event EventHandler<VoteResultEventArgs> VoteResults

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApiEvents Interface


VotingAccepted Event

IVoteApiEvents..::..VotingAccepted Event
IVoteApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when the configured majority and quorum reaches or when an majority reaches.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event VotingAccepted As EventHandler(Of EventArgs)
C#
event EventHandler<EventArgs> VotingAccepted

Remarks

If IsVotingStandardViewAllowed is set to false, event will not be fired.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApiEvents Interface


VotingContinue Event

IVoteApiEvents..::..VotingContinue Event
IVoteApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when the voting continues.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event VotingContinue As EventHandler(Of VoteControlEventArgs)
C#
event EventHandler<VoteControlEventArgs> VotingContinue

Remarks

If IsVotingStandardViewAllowed is set to false, event will not be fired.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApiEvents Interface


VotingHold Event

IVoteApiEvents..::..VotingHold Event
IVoteApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a vote has been put on hold.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event VotingHold As EventHandler(Of VoteControlEventArgs)
C#
event EventHandler<VoteControlEventArgs> VotingHold

Remarks

If IsVotingStandardViewAllowed is set to false, event will not be fired.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApiEvents Interface


VotingQuorumUpdated Event

IVoteApiEvents..::..VotingQuorumUpdated Event
IVoteApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when the quorum regarding a voting is updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event VotingQuorumUpdated As EventHandler(Of VoteResultEventArgs)
C#
event EventHandler<VoteResultEventArgs> VotingQuorumUpdated

Remarks

If IsVotingStandardViewAllowed is set to false, event will not be fired.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApiEvents Interface


VotingRejected Event

IVoteApiEvents..::..VotingRejected Event
IVoteApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when the configured majority and quorum not reached or when an majority not reached.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event VotingRejected As EventHandler(Of EventArgs)
C#
event EventHandler<EventArgs> VotingRejected

Remarks

If IsVotingStandardViewAllowed is set to false, event will not be fired.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApiEvents Interface


VotingSelect Event

IVoteApiEvents..::..VotingSelect Event
IVoteApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a vote has been selected.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event VotingSelect As EventHandler(Of VoteControlEventArgs)
C#
event EventHandler<VoteControlEventArgs> VotingSelect

Remarks

If IsVotingStandardViewAllowed is set to false, event will not be fired.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApiEvents Interface


VotingStart Event

IVoteApiEvents..::..VotingStart Event
IVoteApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a vote has been started.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event VotingStart As EventHandler(Of VoteControlEventArgs)
C#
event EventHandler<VoteControlEventArgs> VotingStart

Remarks

If IsVotingStandardViewAllowed is set to false, event will not be fired.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApiEvents Interface


VotingStop Event

IVoteApiEvents..::..VotingStop Event
IVoteApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a vote has been stopped.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event VotingStop As EventHandler(Of VoteControlEventArgs)
C#
event EventHandler<VoteControlEventArgs> VotingStop

Remarks

If IsVotingStandardViewAllowed is set to false, event will not be fired.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteApiEvents Interface


VotingTimer Event

IVoteApiEvents..::..VotingTimer Event
IVoteApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Time left of voting in session.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event VotingTimer As EventHandler(Of VotingTimerControlEventArgs)
C#
event EventHandler<VotingTimerControlEventArgs> VotingTimer

Remarks

If IsVotingStandardViewAllowed is set to false, event will not be fired.

See Also

IVoteApiEvents Interface


IVoteDataApi Interface

IVoteDataApi Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface that is to be used to add, remove, change voting temlates and voting scripts to a session of a meeting. See also IVoteDataApi Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IVoteDataApi _
    Inherits IVoteDataApiEvents
C#
[ObfuscationAttribute]
public interface IVoteDataApi : IVoteDataApiEvents

Remarks

Each vote that can be prepared as part of a voting script, is based on a vote template. To be able to prepare a script it is required to know:

  • Which vote templates are available for use in the system.
  • Which meetings are prepared in the configuration.
  • Which sessions are configured for a meeting.

The following example shows how to define a voting script for a session of a meeting:

Examples

Copy image Copy Code
               using Bosch.Dcn.Ecpc.Client.Api.Interfaces;
               using Bosch.Dcn.Ecpc.Client.Api.Logic;

               class Example
               {
                   public static void Main()
                   {
                       IConfigApi configApi = DcnApi.ConfigApi;

                       // ...handle initialization of the DCN-SW API here....

                       IMeetingApi meetingApi = configApi.MeetingApi;

                       int[] meetingIds;
                       MEETING_INFO[] meetings;
                       API_ERROR error;

                       if (configApi.IsAvailable)
                       {
                            error = meetingApi.RetrieveMeetings(out meetingIds, out meetings);
                            if (API_ERROR.NONE == error)
                            {
                                int meetingId = meetingIds[0];  // Simply take the first meeting...
                                int[] sessionIds;
                                SESSION_INFO[] sessions;

                                error = meetingApi.RetrieveMeetingSessions(meetingId, out sessionIds, out sessions);
                                if (API_ERROR.NONE == error)
                                {
                                    int sessionId = sessionIds[0];  // Simply take the first session...
                                    int templateIds[];
                                    VOTE_TEMPLATE_INFO[] voteTemplates;
                                    IVoteDataApi voteApi = configApi.VoteApi;

                                    error = voteApi.RetrieveVoteTemplates(out templateIds, out voteTemplates);
                                    int templateId = templateIds[0]; // Simply take the first available vote template...

                                    voteApi.VoteStore += OnNewVotes;
                                    voteApi.VoteUpdate += OnVotesChanged;
                                    voteApi.VoteDeletion += OnVotesRemoved;

                                    VOTE_INFO theVote = new VOTE_INFO();

                                    theVote.VotingName = "MijnVote";
                                    theVote.VotingNumber = "T0001";
                                    theVote.Subject = "Een leuke voorbereide stemming.";
                                    theVote.DocumentationURL = string.Empty;
                                    theVote.VoteAnswerSet = VOTE_INFO.ANSWERSET_YES_NO;
                                    theVote.VoteTemplateId = VOTE_INFO.DEFAULT_VOTINGTEMPLATE_ID;
                                    theVote.RegisterVotePresenceId = VOTE_INFO.VOTING_PRESENCE.PRESENCE_BUTTON;

                                    int newVoteIds[];

                                    if (voteApi.IsVoteRegistrationAllowed)
                                    {
                                        error = voteApi.StoreVotesInVotingScript(sessionId, new VOTE_INFO[1] { theVote }, out newVoteIds));

                                    }
                                }
                            }
                        }
                   }

                   private void OnNewVotes(object sender, VoteDataChangedEventArgs args)
                   {
                       // Handle addition of new votes here...
                   }

                   private void OnVotesRemoved(object sender, VoteDataChangedEventArgs args)
                   {
                       // Handle removal of votes here...
                   }

                   private void OnVotesChanged(object sender, VoteDataChangedEventArgs args)
                   {
                       // Handle changes to votes here...
                   }
               }

See Also

IVoteDataApi Members


IVoteDataApi Members

IVoteDataApi Members
IVoteDataApi Interface Methods Properties Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IVoteDataApi type exposes the following members.

Methods

 | Name | Description
Public method | CopyVoting | Create a copy of the Voting details based on the voting id provided
Public method | DeleteVotes | Deletes a vote from the configuration.
Public method | RetrieveVotesById | Retrieves the set of votes from the voting script for the given session of a meeting, identifying the votes by ID.
Public method | RetrieveVoteTemplates | Retrieves the vote templates available for use in defining votes in a voting script.
Public method | RetrieveVoteTemplatesById | Retrieves the set of vote templates, identified by voting template ID.
Public method | RetrieveVotingScript | Retrieves the voting script for the given session of a meeting.
Public method | StoreVotesInVotingScript | Adds (a) new votes(s) in the voting script OF the given session of a meeting.
Public method | UpdateVotes | Updates the information of (a) vote(s) in the voting script of a session of a meeting.

Properties

 | Name | Description
Public property | IsVoteRegistrationAllowed | Indicates whether store, update, deletion and registration of voting templates and scripts to sessions of meetings is allowed from this interface.

Events

 | Name | Description
Public event | VoteDeletion | Occurs when a vote was deleted. (Inherited from IVoteDataApiEvents.)
Public event | VoteStore | Occurs when (a) new vote was added. (Inherited from IVoteDataApiEvents.)
Public event | VoteTemplateDeletion | Occurs when a vote template was deleted. (Inherited from IVoteDataApiEvents.)
Public event | VoteTemplateStore | Occurs when (a) new vote template was added. (Inherited from IVoteDataApiEvents.)
Public event | VoteTemplateUpdate | Occurs when (a) vote template(s) is/are updated. (Inherited from IVoteDataApiEvents.)
Public event | VoteUpdate | Occurs when (a) vote(s) is/are updated. (Inherited from IVoteDataApiEvents.)

See Also

IVoteDataApi Interface


IVoteDataApi Methods

IVoteDataApi Methods
IVoteDataApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IVoteDataApi type exposes the following members.

Methods

 | Name | Description
Public method | CopyVoting | Create a copy of the Voting details based on the voting id provided
Public method | DeleteVotes | Deletes a vote from the configuration.
Public method | RetrieveVotesById | Retrieves the set of votes from the voting script for the given session of a meeting, identifying the votes by ID.
Public method | RetrieveVoteTemplates | Retrieves the vote templates available for use in defining votes in a voting script.
Public method | RetrieveVoteTemplatesById | Retrieves the set of vote templates, identified by voting template ID.
Public method | RetrieveVotingScript | Retrieves the voting script for the given session of a meeting.
Public method | StoreVotesInVotingScript | Adds (a) new votes(s) in the voting script OF the given session of a meeting.
Public method | UpdateVotes | Updates the information of (a) vote(s) in the voting script of a session of a meeting.

See Also

IVoteDataApi Interface


CopyVoting Method

IVoteDataApi..::..CopyVoting Method
IVoteDataApi Interface Example See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Create a copy of the Voting details based on the voting id provided

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function CopyVoting ( _
    votingId As Integer, _
    <OutAttribute> ByRef newVotingId As Integer _
) As API_ERROR
C#
API_ERROR CopyVoting(
    int votingId,
    out int newVotingId
)

Parameters

votingId
Type: System..::..Int32
Existing voting id from which copying is being done.
newVotingId
Type: System..::..Int32 %
Copied Voting's voting id.

Return Value

Following API_ERROR can be returned.

NONE - Success.
NOT_AVAILABLE - API is not initialize properly.
NO_AUTHORIZATION - if authorization is not for configuration.
COPY_FAILED - if copy is failed.
ERROR - Exception.

Examples

Below Example shows how to copy voting using API method - CopyVoting.

Copy image Copy Code
             //Get Config API.
             configApi = DcnApi.ConfigApi;
             ...
             //select voting id from which copying is being done and set it as votingid and
              for copied voting's id, declare voting id as newVotingId.
              int newMeetingId;
             API_ERROR error = API_ERROR.NONE;
             try
             {
                  //Check if a connection to the DCN-SW server is available
                  if (configApi.IsAvailable)
                  {
                     IVoteDataApi voteApi = configApi.VoteApi;
                      //Call Api method to copy voting.
                      error = voteApi.CopyVoting(votingid,out newVotingId);
                  }
                  else
                  {
                      error = API_ERROR.NOT_AVAILABLE;
                  }
             }
             catch (Exception ex)
             {
                 error =  API_ERROR.ERROR;
             }

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteDataApi Interface


DeleteVotes Method

IVoteDataApi..::..DeleteVotes Method
IVoteDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Deletes a vote from the configuration.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function DeleteVotes ( _
    voteIds As Integer() _
) As API_ERROR
C#
API_ERROR DeleteVotes(
    int[] voteIds
)

Parameters

voteIds
Type: array< System..::..Int32 >[]()[][]
The list of ID's for votes to delete.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Deletion of votes will fail if the vote is currently active.

Remarks

This function may potentionally block. It will block if the DCN-SW server is not ready to accept the request!

Remarks

Requires IsVoteRegistrationAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | If one or more of the vote ID's is invalid.

See Also

IVoteDataApi Interface


RetrieveVotesById Method

IVoteDataApi..::..RetrieveVotesById Method
IVoteDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the set of votes from the voting script for the given session of a meeting, identifying the votes by ID.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveVotesById ( _
    voteIds As Integer(), _
    <OutAttribute> ByRef votes As VOTE_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveVotesById(
    int[] voteIds,
    out VOTE_INFO[] votes
)

Parameters

voteIds
Type: array< System..::..Int32 >[]()[][]
The list of ID's defining the set of votes to retrieve from the voting script.
votes
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VOTE_INFO >[]()[][]%
The list of votes.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | If the list or vote ID's contains an invalid ID.

See Also

IVoteDataApi Interface


RetrieveVoteTemplates Method

IVoteDataApi..::..RetrieveVoteTemplates Method
IVoteDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the vote templates available for use in defining votes in a voting script.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveVoteTemplates ( _
    <OutAttribute> ByRef voteTemplatedIds As Integer(), _
    <OutAttribute> ByRef voteTemplates As VOTE_TEMPLATE_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveVoteTemplates(
    out int[] voteTemplatedIds,
    out VOTE_TEMPLATE_INFO[] voteTemplates
)

Parameters

voteTemplatedIds
Type: array< System..::..Int32 >[]()[][]%
The list of ID's defining the set of available vote tempaltes.
voteTemplates
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VOTE_TEMPLATE_INFO >[]()[][]%
The list of vote templates available for use.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.

See Also

IVoteDataApi Interface


RetrieveVoteTemplatesById Method

IVoteDataApi..::..RetrieveVoteTemplatesById Method
IVoteDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the set of vote templates, identified by voting template ID.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveVoteTemplatesById ( _
    voteTemplatedIds As Integer(), _
    <OutAttribute> ByRef voteTemplates As VOTE_TEMPLATE_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveVoteTemplatesById(
    int[] voteTemplatedIds,
    out VOTE_TEMPLATE_INFO[] voteTemplates
)

Parameters

voteTemplatedIds
Type: array< System..::..Int32 >[]()[][]
The list of ID's defining the set of available vote tempaltes.
voteTemplates
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VOTE_TEMPLATE_INFO >[]()[][]%
The list of vote templates available for use.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | if the list of meeting ID's contains an invalid ID.

See Also

IVoteDataApi Interface


RetrieveVotingScript Method

IVoteDataApi..::..RetrieveVotingScript Method
IVoteDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Retrieves the voting script for the given session of a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function RetrieveVotingScript ( _
    sessionId As Integer, _
    <OutAttribute> ByRef voteIds As Integer(), _
    <OutAttribute> ByRef votes As VOTE_INFO() _
) As API_ERROR
C#
API_ERROR RetrieveVotingScript(
    int sessionId,
    out int[] voteIds,
    out VOTE_INFO[] votes
)

Parameters

sessionId
Type: System..::..Int32
The ID of the session to retrieve the votes from.
voteIds
Type: array< System..::..Int32 >[]()[][]%
The list of ID's defining the set of available votes in the voting script of the session.
votes
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VOTE_INFO >[]()[][]%
The list of votes in the voting script.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

Requires IsConfigAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | If the session identifier is invalid.

See Also

IVoteDataApi Interface


StoreVotesInVotingScript Method

IVoteDataApi..::..StoreVotesInVotingScript Method
IVoteDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Adds (a) new votes(s) in the voting script OF the given session of a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function StoreVotesInVotingScript ( _
    sessionId As Integer, _
    votes As VOTE_INFO(), _
    <OutAttribute> ByRef voteIds As Integer() _
) As API_ERROR
C#
API_ERROR StoreVotesInVotingScript(
    int sessionId,
    VOTE_INFO[] votes,
    out int[] voteIds
)

Parameters

sessionId
Type: System..::..Int32
The ID of the session to store the votes in the voting script for.
votes
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VOTE_INFO >[]()[][]
The list of votes.
voteIds
Type: array< System..::..Int32 >[]()[][]%
The list of ID's identifying the new votes.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

This function may potentionally block. It will block if the DCN-SW server is not ready to accept the request!

Remarks

Requires IsVoteRegistrationAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | If the vote information in the list contains invalid data or session identifier is invalid.

See Also

IVoteDataApi Interface


UpdateVotes Method

IVoteDataApi..::..UpdateVotes Method
IVoteDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Updates the information of (a) vote(s) in the voting script of a session of a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Function UpdateVotes ( _
    voteIds As Integer(), _
    votes As VOTE_INFO() _
) As API_ERROR
C#
API_ERROR UpdateVotes(
    int[] voteIds,
    VOTE_INFO[] votes
)

Parameters

voteIds
Type: array< System..::..Int32 >[]()[][]
The list of ID's defining the set of votes to update in the voting script.
votes
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VOTE_INFO >[]()[][]
The list of votes.

Return Value

See API_ERROR for applicable errorcodes.

Remarks

This function may potentionally block. It will block if the DCN-SW server is not ready to accept the request!

Remarks

Requires IsVoteRegistrationAllowed to be true.

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.
System..::..ArgumentNullException | If null is passed as an argument.
System..::..FormatException | If one or more of the delegate ID's is invalid or one or more of the passed delegate information in the list contains invalid data.

See Also

IVoteDataApi Interface


IVoteDataApi Properties

IVoteDataApi Properties
IVoteDataApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IVoteDataApi type exposes the following members.

Properties

 | Name | Description
Public property | IsVoteRegistrationAllowed | Indicates whether store, update, deletion and registration of voting templates and scripts to sessions of meetings is allowed from this interface.

See Also

IVoteDataApi Interface


IsVoteRegistrationAllowed Property

IVoteDataApi..::..IsVoteRegistrationAllowed Property
IVoteDataApi Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates whether store, update, deletion and registration of voting templates and scripts to sessions of meetings is allowed from this interface.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsVoteRegistrationAllowed As Boolean
    Get
C#
bool IsVoteRegistrationAllowed { get; }

Field Value

true if this is allowed, false otherwise.

See Also

IVoteDataApi Interface


IVoteDataApi Events

IVoteDataApi Events
IVoteDataApi Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IVoteDataApi type exposes the following members.

Events

 | Name | Description
Public event | VoteDeletion | Occurs when a vote was deleted. (Inherited from IVoteDataApiEvents.)
Public event | VoteStore | Occurs when (a) new vote was added. (Inherited from IVoteDataApiEvents.)
Public event | VoteTemplateDeletion | Occurs when a vote template was deleted. (Inherited from IVoteDataApiEvents.)
Public event | VoteTemplateStore | Occurs when (a) new vote template was added. (Inherited from IVoteDataApiEvents.)
Public event | VoteTemplateUpdate | Occurs when (a) vote template(s) is/are updated. (Inherited from IVoteDataApiEvents.)
Public event | VoteUpdate | Occurs when (a) vote(s) is/are updated. (Inherited from IVoteDataApiEvents.)

See Also

IVoteDataApi Interface


IVoteDataApiEvents Interface

IVoteDataApiEvents Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interface defining all events for the votes API data-interface. See also IVoteDataApiEvents Members

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IVoteDataApiEvents
C#
[ObfuscationAttribute]
public interface IVoteDataApiEvents

See Also

IVoteDataApiEvents Members


IVoteDataApiEvents Members

IVoteDataApiEvents Members
IVoteDataApiEvents Interface Events See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IVoteDataApiEvents type exposes the following members.

Events

 | Name | Description
Public event | VoteDeletion | Occurs when a vote was deleted.
Public event | VoteStore | Occurs when (a) new vote was added.
Public event | VoteTemplateDeletion | Occurs when a vote template was deleted.
Public event | VoteTemplateStore | Occurs when (a) new vote template was added.
Public event | VoteTemplateUpdate | Occurs when (a) vote template(s) is/are updated.
Public event | VoteUpdate | Occurs when (a) vote(s) is/are updated.

See Also

IVoteDataApiEvents Interface


IVoteDataApiEvents Events

IVoteDataApiEvents Events
IVoteDataApiEvents Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IVoteDataApiEvents type exposes the following members.

Events

 | Name | Description
Public event | VoteDeletion | Occurs when a vote was deleted.
Public event | VoteStore | Occurs when (a) new vote was added.
Public event | VoteTemplateDeletion | Occurs when a vote template was deleted.
Public event | VoteTemplateStore | Occurs when (a) new vote template was added.
Public event | VoteTemplateUpdate | Occurs when (a) vote template(s) is/are updated.
Public event | VoteUpdate | Occurs when (a) vote(s) is/are updated.

See Also

IVoteDataApiEvents Interface


VoteDeletion Event

IVoteDataApiEvents..::..VoteDeletion Event
IVoteDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a vote was deleted.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event VoteDeletion As EventHandler(Of VoteDataChangedEventArgs)
C#
event EventHandler<VoteDataChangedEventArgs> VoteDeletion

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteDataApiEvents Interface


VoteStore Event

IVoteDataApiEvents..::..VoteStore Event
IVoteDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) new vote was added.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event VoteStore As EventHandler(Of VoteDataChangedEventArgs)
C#
event EventHandler<VoteDataChangedEventArgs> VoteStore

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteDataApiEvents Interface


VoteTemplateDeletion Event

IVoteDataApiEvents..::..VoteTemplateDeletion Event
IVoteDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when a vote template was deleted.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event VoteTemplateDeletion As EventHandler(Of VoteTemplateDataChangedEventArgs)
C#
event EventHandler<VoteTemplateDataChangedEventArgs> VoteTemplateDeletion

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteDataApiEvents Interface


VoteTemplateStore Event

IVoteDataApiEvents..::..VoteTemplateStore Event
IVoteDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) new vote template was added.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event VoteTemplateStore As EventHandler(Of VoteTemplateDataChangedEventArgs)
C#
event EventHandler<VoteTemplateDataChangedEventArgs> VoteTemplateStore

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteDataApiEvents Interface


VoteTemplateUpdate Event

IVoteDataApiEvents..::..VoteTemplateUpdate Event
IVoteDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) vote template(s) is/are updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event VoteTemplateUpdate As EventHandler(Of VoteTemplateDataChangedEventArgs)
C#
event EventHandler<VoteTemplateDataChangedEventArgs> VoteTemplateUpdate

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteDataApiEvents Interface


VoteUpdate Event

IVoteDataApiEvents..::..VoteUpdate Event
IVoteDataApiEvents Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Occurs when (a) vote(s) is/are updated.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Event VoteUpdate As EventHandler(Of VoteDataChangedEventArgs)
C#
event EventHandler<VoteDataChangedEventArgs> VoteUpdate

Exceptions

Exception | Condition
System..::..ObjectDisposedException | If object already disposed.

See Also

IVoteDataApiEvents Interface


LANGUAGE_INFO Structure

LANGUAGE_INFO Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Depricated

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Structure LANGUAGE_INFO
C#
[ObfuscationAttribute]
public struct LANGUAGE_INFO

See Also

LANGUAGE_INFO Members


LANGUAGE_INFO Members

LANGUAGE_INFO Members
LANGUAGE_INFO Structure Methods Operators Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The LANGUAGE_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two LANGUAGE_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a LANGUAGE_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Operators

Name | Description
Equality | Checks the equality of two LANGUAGE_INFO structures.
Inequality | Checks the non-equality of two LANGUAGE_INFO structures.

Fields

 | Name | Description
Public field | EnglishAbbr | Depricated
Public field | EnglishName | Depricated
Public field | FrenchAbbr | Depricated
Public field | FrenchName | Depricated
Public field | OriginalAbbr | Depricated
Public field | OriginalName | Depricated

See Also

LANGUAGE_INFO Structure


LANGUAGE_INFO Fields

LANGUAGE_INFO Fields
LANGUAGE_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The LANGUAGE_INFO type exposes the following members.

Fields

 | Name | Description
Public field | EnglishAbbr | Depricated
Public field | EnglishName | Depricated
Public field | FrenchAbbr | Depricated
Public field | FrenchName | Depricated
Public field | OriginalAbbr | Depricated
Public field | OriginalName | Depricated

See Also

LANGUAGE_INFO Structure


EnglishAbbr Field

LANGUAGE_INFO..::..EnglishAbbr Field
LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Depricated

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public EnglishAbbr As String
C#
public string EnglishAbbr

See Also

LANGUAGE_INFO Structure


EnglishName Field

LANGUAGE_INFO..::..EnglishName Field
LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Depricated

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public EnglishName As String
C#
public string EnglishName

See Also

LANGUAGE_INFO Structure


FrenchAbbr Field

LANGUAGE_INFO..::..FrenchAbbr Field
LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Depricated

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public FrenchAbbr As String
C#
public string FrenchAbbr

See Also

LANGUAGE_INFO Structure


FrenchName Field

LANGUAGE_INFO..::..FrenchName Field
LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Depricated

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public FrenchName As String
C#
public string FrenchName

See Also

LANGUAGE_INFO Structure


OriginalAbbr Field

LANGUAGE_INFO..::..OriginalAbbr Field
LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Depricated

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public OriginalAbbr As String
C#
public string OriginalAbbr

See Also

LANGUAGE_INFO Structure


OriginalName Field

LANGUAGE_INFO..::..OriginalName Field
LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Depricated

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public OriginalName As String
C#
public string OriginalName

See Also

LANGUAGE_INFO Structure


LANGUAGE_INFO Methods

LANGUAGE_INFO Methods
LANGUAGE_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The LANGUAGE_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two LANGUAGE_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a LANGUAGE_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

LANGUAGE_INFO Structure


Equals Method

LANGUAGE_INFO..::..Equals Method
LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Determines whether two LANGUAGE_INFO instances are equal.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::..Object
The LANGUAGE_INFO to compare with the current Object.

Return Value

true if the specified LANGUAGE_INFO is equal to the current Object; otherwise, false.

See Also

LANGUAGE_INFO Structure


GetHashCode Method

LANGUAGE_INFO..::..GetHashCode Method
LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Serves as a hash function for a LANGUAGE_INFO type.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current LANGUAGE_INFO.

See Also

LANGUAGE_INFO Structure


LANGUAGE_INFO Operators

LANGUAGE_INFO Operators
LANGUAGE_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The LANGUAGE_INFO type exposes the following members.

Operators

Name | Description
Equality | Checks the equality of two LANGUAGE_INFO structures.
Inequality | Checks the non-equality of two LANGUAGE_INFO structures.

See Also

LANGUAGE_INFO Structure


Equality Operator

LANGUAGE_INFO..::..Equality Operator
LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the equality of two LANGUAGE_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    a As LANGUAGE_INFO, _
    b As LANGUAGE_INFO _
) As Boolean
C#
public static bool operator ==(
    LANGUAGE_INFO a,
    LANGUAGE_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..LANGUAGE_INFO
The first LANGUAGE_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..LANGUAGE_INFO
The next LANGUAGE_INFO to compare.

Return Value

true if the specified LANGUAGE_INFO structures are the same; otherwise, false.

See Also

LANGUAGE_INFO Structure


Inequality Operator

LANGUAGE_INFO..::..Inequality Operator
LANGUAGE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the non-equality of two LANGUAGE_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    a As LANGUAGE_INFO, _
    b As LANGUAGE_INFO _
) As Boolean
C#
public static bool operator !=(
    LANGUAGE_INFO a,
    LANGUAGE_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..LANGUAGE_INFO
The first LANGUAGE_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..LANGUAGE_INFO
The next LANGUAGE_INFO to compare.

Return Value

true if the specified LANGUAGE_INFO structures are not the same; otherwise, false.

See Also

LANGUAGE_INFO Structure


LanguageDataChangedEventArgs Class

LanguageDataChangedEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Provides data for a LanguageStore, LanguageUpdate or LanguageDeletion event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class LanguageDataChangedEventArgs _
    Inherits ConfigChangedEventArgs
C#
[ObfuscationAttribute]
public class LanguageDataChangedEventArgs : ConfigChangedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ConfigChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..LanguageDataChangedEventArgs

See Also

LanguageDataChangedEventArgs Members


LanguageDataChangedEventArgs Members

LanguageDataChangedEventArgs Members
LanguageDataChangedEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The LanguageDataChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | LanguageDataChangedEventArgs()()()() | Default constructor...
Public method | LanguageDataChangedEventArgs(array<Int32>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)

See Also

LanguageDataChangedEventArgs Class


LanguageDataChangedEventArgs Constructor

LanguageDataChangedEventArgs Constructor
LanguageDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | LanguageDataChangedEventArgs()()()() | Default constructor...
Public method | LanguageDataChangedEventArgs(array<Int32>[]()[][]) | Constructor...

See Also

LanguageDataChangedEventArgs Class
LanguageDataChangedEventArgs Members


LanguageDataChangedEventArgs Constructor

LanguageDataChangedEventArgs Constructor
LanguageDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Default constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LanguageDataChangedEventArgs()

See Also

LanguageDataChangedEventArgs Class
LanguageDataChangedEventArgs Overload


LanguageDataChangedEventArgs Constructor (Int32[])

LanguageDataChangedEventArgs Constructor (array<Int32>[]()[][])
LanguageDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    languageIds As Integer() _
)
C#
public LanguageDataChangedEventArgs(
    int[] languageIds
)

Parameters

languageIds
Type: array< System..::..Int32 >[]()[][]
The identifiers of the languages changed. Use ConfigIds to retrieve.

See Also

LanguageDataChangedEventArgs Class
LanguageDataChangedEventArgs Overload


LanguageDataChangedEventArgs Methods

LanguageDataChangedEventArgs Methods
LanguageDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The LanguageDataChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

LanguageDataChangedEventArgs Class


LanguageDataChangedEventArgs Properties

LanguageDataChangedEventArgs Properties
LanguageDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The LanguageDataChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)

See Also

LanguageDataChangedEventArgs Class


MEETING_GROUP_INFO Structure

MEETING_GROUP_INFO Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Represents a container holding all information of a meeting group.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Structure MEETING_GROUP_INFO
C#
[ObfuscationAttribute]
public struct MEETING_GROUP_INFO

See Also

MEETING_GROUP_INFO Members


MEETING_GROUP_INFO Members

MEETING_GROUP_INFO Members
MEETING_GROUP_INFO Structure Methods Operators Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MEETING_GROUP_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two MEETING_GROUP_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a MEETING_GROUP_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display MEETING_GROUP_INFO data in proper format. (Overrides ValueType..::..ToString()()()().)

Operators

Name | Description
Equality | Checks the equality of two MEETING_GROUP_INFO structures.
Inequality | Checks the non-equality of two MEETING_GROUP_INFO structures.

Fields

 | Name | Description
Public field | Description | The description of the meeting group.
Public field | Name | The name of the meeting group.

See Also

MEETING_GROUP_INFO Structure


MEETING_GROUP_INFO Fields

MEETING_GROUP_INFO Fields
MEETING_GROUP_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MEETING_GROUP_INFO type exposes the following members.

Fields

 | Name | Description
Public field | Description | The description of the meeting group.
Public field | Name | The name of the meeting group.

See Also

MEETING_GROUP_INFO Structure


Description Field

MEETING_GROUP_INFO..::..Description Field
MEETING_GROUP_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The description of the meeting group.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Description As String
C#
public string Description

See Also

MEETING_GROUP_INFO Structure


Name Field

MEETING_GROUP_INFO..::..Name Field
MEETING_GROUP_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The name of the meeting group.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Name As String
C#
public string Name

See Also

MEETING_GROUP_INFO Structure


MEETING_GROUP_INFO Methods

MEETING_GROUP_INFO Methods
MEETING_GROUP_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MEETING_GROUP_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two MEETING_GROUP_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a MEETING_GROUP_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display MEETING_GROUP_INFO data in proper format. (Overrides ValueType..::..ToString()()()().)

See Also

MEETING_GROUP_INFO Structure


Equals Method

MEETING_GROUP_INFO..::..Equals Method
MEETING_GROUP_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Determines whether two MEETING_GROUP_INFO instances are equal.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::..Object
The MEETING_GROUP_INFO to compare with the current Object.

Return Value

true if the specified MEETING_GROUP_INFO is equal to the current Object; otherwise, false.

See Also

MEETING_GROUP_INFO Structure


GetHashCode Method

MEETING_GROUP_INFO..::..GetHashCode Method
MEETING_GROUP_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Serves as a hash function for a MEETING_GROUP_INFO type.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current MEETING_GROUP_INFO.

See Also

MEETING_GROUP_INFO Structure


ToString Method

MEETING_GROUP_INFO..::..ToString Method
MEETING_GROUP_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
To display MEETING_GROUP_INFO data in proper format.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()

Return Value

See Also

MEETING_GROUP_INFO Structure


MEETING_GROUP_INFO Operators

MEETING_GROUP_INFO Operators
MEETING_GROUP_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MEETING_GROUP_INFO type exposes the following members.

Operators

Name | Description
Equality | Checks the equality of two MEETING_GROUP_INFO structures.
Inequality | Checks the non-equality of two MEETING_GROUP_INFO structures.

See Also

MEETING_GROUP_INFO Structure


Equality Operator

MEETING_GROUP_INFO..::..Equality Operator
MEETING_GROUP_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the equality of two MEETING_GROUP_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    a As MEETING_GROUP_INFO, _
    b As MEETING_GROUP_INFO _
) As Boolean
C#
public static bool operator ==(
    MEETING_GROUP_INFO a,
    MEETING_GROUP_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_GROUP_INFO
The first MEETING_GROUP_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_GROUP_INFO
The next MEETING_GROUP_INFO to compare.

Return Value

true if the specified MEETING_GROUP_INFO structures are the same; otherwise, false.

See Also

MEETING_GROUP_INFO Structure


Inequality Operator

MEETING_GROUP_INFO..::..Inequality Operator
MEETING_GROUP_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the non-equality of two MEETING_GROUP_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    a As MEETING_GROUP_INFO, _
    b As MEETING_GROUP_INFO _
) As Boolean
C#
public static bool operator !=(
    MEETING_GROUP_INFO a,
    MEETING_GROUP_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_GROUP_INFO
The first MEETING_GROUP_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_GROUP_INFO
The next MEETING_GROUP_INFO to compare.

Return Value

true if the specified MEETING_GROUP_INFO structures are not the same; otherwise, false.

See Also

MEETING_GROUP_INFO Structure


MEETING_INFO Structure

MEETING_INFO Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Represents a container holding all information of a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Structure MEETING_INFO
C#
[ObfuscationAttribute]
public struct MEETING_INFO

See Also

MEETING_INFO Members


MEETING_INFO Members

MEETING_INFO Members
MEETING_INFO Structure Methods Operators Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MEETING_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two MEETING_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a MEETING_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display MEETING_INFO data in proper format. (Overrides ValueType..::..ToString()()()().)

Operators

Name | Description
Equality | Checks the equality of two MEETING_INFO structures.
Inequality | Checks the non-equality of two MEETING_INFO structures.

Fields

 | Name | Description
Public field | Description | The description of the meeting.
Public field | Title | The title of the meeting.

See Also

MEETING_INFO Structure


MEETING_INFO Fields

MEETING_INFO Fields
MEETING_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MEETING_INFO type exposes the following members.

Fields

 | Name | Description
Public field | Description | The description of the meeting.
Public field | Title | The title of the meeting.

See Also

MEETING_INFO Structure


Description Field

MEETING_INFO..::..Description Field
MEETING_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The description of the meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Description As String
C#
public string Description

See Also

MEETING_INFO Structure


Title Field

MEETING_INFO..::..Title Field
MEETING_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The title of the meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Title As String
C#
public string Title

See Also

MEETING_INFO Structure


MEETING_INFO Methods

MEETING_INFO Methods
MEETING_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MEETING_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two MEETING_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a MEETING_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display MEETING_INFO data in proper format. (Overrides ValueType..::..ToString()()()().)

See Also

MEETING_INFO Structure


Equals Method

MEETING_INFO..::..Equals Method
MEETING_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Determines whether two MEETING_INFO instances are equal.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::..Object
The MEETING_INFO to compare with the current Object.

Return Value

true if the specified MEETING_INFO is equal to the current Object; otherwise, false.

See Also

MEETING_INFO Structure


GetHashCode Method

MEETING_INFO..::..GetHashCode Method
MEETING_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Serves as a hash function for a MEETING_INFO type.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current MEETING_INFO.

See Also

MEETING_INFO Structure


ToString Method

MEETING_INFO..::..ToString Method
MEETING_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
To display MEETING_INFO data in proper format.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()

Return Value

See Also

MEETING_INFO Structure


MEETING_INFO Operators

MEETING_INFO Operators
MEETING_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MEETING_INFO type exposes the following members.

Operators

Name | Description
Equality | Checks the equality of two MEETING_INFO structures.
Inequality | Checks the non-equality of two MEETING_INFO structures.

See Also

MEETING_INFO Structure


Equality Operator

MEETING_INFO..::..Equality Operator
MEETING_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the equality of two MEETING_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    a As MEETING_INFO, _
    b As MEETING_INFO _
) As Boolean
C#
public static bool operator ==(
    MEETING_INFO a,
    MEETING_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_INFO
The first MEETING_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_INFO
The next MEETING_INFO to compare.

Return Value

true if the specified MEETING_INFO structures are the same; otherwise, false.

See Also

MEETING_INFO Structure


Inequality Operator

MEETING_INFO..::..Inequality Operator
MEETING_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the non-equality of two MEETING_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    a As MEETING_INFO, _
    b As MEETING_INFO _
) As Boolean
C#
public static bool operator !=(
    MEETING_INFO a,
    MEETING_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_INFO
The first MEETING_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_INFO
The next MEETING_INFO to compare.

Return Value

true if the specified MEETING_INFO structures are not the same; otherwise, false.

See Also

MEETING_INFO Structure


MEETING_INTERPRETATION_INFO Structure

MEETING_INTERPRETATION_INFO Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Represents a container holding all information of a desk within a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Structure MEETING_INTERPRETATION_INFO
C#
[ObfuscationAttribute]
public struct MEETING_INTERPRETATION_INFO

See Also

MEETING_INTERPRETATION_INFO Members


MEETING_INTERPRETATION_INFO Members

MEETING_INTERPRETATION_INFO Members
MEETING_INTERPRETATION_INFO Structure Methods Operators Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MEETING_INTERPRETATION_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two MEETING_INTERPRETATION_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a MEETING_INTERPRETATION_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Operators

Name | Description
Equality | Checks the equality of two MEETING_INTERPRETATION_INFO structures.
Inequality | Checks the non-equality of two MEETING_INTERPRETATION_INFO structures.

Fields

 | Name | Description
Public field | EngagedIndication | To enable engaged indication during interlock and overide modes.
Public field | FlashingMicrophoneWhenEngaged | To enable microphone flashing if the channel is engaged.
Public field | FloorDistribution | To enable floor language over the interpretation channel.
Public field | InterlockBetweenBooths | Indicates the type of interlock mode for IDesks between booths- None, Interlock, Override, InterlockOnAOverrideOnB.
Public field | InterlockWithinBooths | Indicates the type of interlock mode for IDesks within booths- None, Interlock, Override.
Public field | LanguageIds | List of languages for the meeting Length is the number of languages. Index is the channel number
Public field | SignalSpeakSlowly | To enable the signal speak slowly facility.

See Also

MEETING_INTERPRETATION_INFO Structure


MEETING_INTERPRETATION_INFO Fields

MEETING_INTERPRETATION_INFO Fields
MEETING_INTERPRETATION_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MEETING_INTERPRETATION_INFO type exposes the following members.

Fields

 | Name | Description
Public field | EngagedIndication | To enable engaged indication during interlock and overide modes.
Public field | FlashingMicrophoneWhenEngaged | To enable microphone flashing if the channel is engaged.
Public field | FloorDistribution | To enable floor language over the interpretation channel.
Public field | InterlockBetweenBooths | Indicates the type of interlock mode for IDesks between booths- None, Interlock, Override, InterlockOnAOverrideOnB.
Public field | InterlockWithinBooths | Indicates the type of interlock mode for IDesks within booths- None, Interlock, Override.
Public field | LanguageIds | List of languages for the meeting Length is the number of languages. Index is the channel number
Public field | SignalSpeakSlowly | To enable the signal speak slowly facility.

See Also

MEETING_INTERPRETATION_INFO Structure


EngagedIndication Field

MEETING_INTERPRETATION_INFO..::..EngagedIndication Field
MEETING_INTERPRETATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
To enable engaged indication during interlock and overide modes.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public EngagedIndication As Boolean
C#
public bool EngagedIndication

See Also

MEETING_INTERPRETATION_INFO Structure


FlashingMicrophoneWhenEngaged Field

MEETING_INTERPRETATION_INFO..::..FlashingMicrophoneWhenEngaged Field
MEETING_INTERPRETATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
To enable microphone flashing if the channel is engaged.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public FlashingMicrophoneWhenEngaged As Boolean
C#
public bool FlashingMicrophoneWhenEngaged

See Also

MEETING_INTERPRETATION_INFO Structure


FloorDistribution Field

MEETING_INTERPRETATION_INFO..::..FloorDistribution Field
MEETING_INTERPRETATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
To enable floor language over the interpretation channel.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public FloorDistribution As Boolean
C#
public bool FloorDistribution

See Also

MEETING_INTERPRETATION_INFO Structure


InterlockBetweenBooths Field

MEETING_INTERPRETATION_INFO..::..InterlockBetweenBooths Field
MEETING_INTERPRETATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates the type of interlock mode for IDesks between booths- None, Interlock, Override, InterlockOnAOverrideOnB.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public InterlockBetweenBooths As InterlockMode
C#
public InterlockMode InterlockBetweenBooths

See Also

MEETING_INTERPRETATION_INFO Structure


InterlockWithinBooths Field

MEETING_INTERPRETATION_INFO..::..InterlockWithinBooths Field
MEETING_INTERPRETATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates the type of interlock mode for IDesks within booths- None, Interlock, Override.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public InterlockWithinBooths As InterlockMode
C#
public InterlockMode InterlockWithinBooths

See Also

MEETING_INTERPRETATION_INFO Structure


LanguageIds Field

MEETING_INTERPRETATION_INFO..::..LanguageIds Field
MEETING_INTERPRETATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
List of languages for the meeting Length is the number of languages. Index is the channel number

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public LanguageIds As Integer()
C#
public int[] LanguageIds

See Also

MEETING_INTERPRETATION_INFO Structure


SignalSpeakSlowly Field

MEETING_INTERPRETATION_INFO..::..SignalSpeakSlowly Field
MEETING_INTERPRETATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
To enable the signal speak slowly facility.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public SignalSpeakSlowly As Boolean
C#
public bool SignalSpeakSlowly

See Also

MEETING_INTERPRETATION_INFO Structure


MEETING_INTERPRETATION_INFO Methods

MEETING_INTERPRETATION_INFO Methods
MEETING_INTERPRETATION_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MEETING_INTERPRETATION_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two MEETING_INTERPRETATION_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a MEETING_INTERPRETATION_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

MEETING_INTERPRETATION_INFO Structure


Equals Method

MEETING_INTERPRETATION_INFO..::..Equals Method
MEETING_INTERPRETATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Determines whether two MEETING_INTERPRETATION_INFO instances are equal.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::..Object
The MEETING_INTERPRETATION_INFO to compare with the current Object.

Return Value

true if the specified MEETING_INTERPRETATION_INFO is equal to the current Object; otherwise, false.

See Also

MEETING_INTERPRETATION_INFO Structure


GetHashCode Method

MEETING_INTERPRETATION_INFO..::..GetHashCode Method
MEETING_INTERPRETATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Serves as a hash function for a MEETING_INTERPRETATION_INFO type.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current MEETING_INTERPRETATION_INFO.

See Also

MEETING_INTERPRETATION_INFO Structure


MEETING_INTERPRETATION_INFO Operators

MEETING_INTERPRETATION_INFO Operators
MEETING_INTERPRETATION_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MEETING_INTERPRETATION_INFO type exposes the following members.

Operators

Name | Description
Equality | Checks the equality of two MEETING_INTERPRETATION_INFO structures.
Inequality | Checks the non-equality of two MEETING_INTERPRETATION_INFO structures.

See Also

MEETING_INTERPRETATION_INFO Structure


Equality Operator

MEETING_INTERPRETATION_INFO..::..Equality Operator
MEETING_INTERPRETATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the equality of two MEETING_INTERPRETATION_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    a As MEETING_INTERPRETATION_INFO, _
    b As MEETING_INTERPRETATION_INFO _
) As Boolean
C#
public static bool operator ==(
    MEETING_INTERPRETATION_INFO a,
    MEETING_INTERPRETATION_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_INTERPRETATION_INFO
The first MEETING_INTERPRETATION_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_INTERPRETATION_INFO
The next MEETING_INTERPRETATION_INFO to compare.

Return Value

true if the specified MEETING_INTERPRETATION_INFO structures are the same; otherwise, false.

See Also

MEETING_INTERPRETATION_INFO Structure


Inequality Operator

MEETING_INTERPRETATION_INFO..::..Inequality Operator
MEETING_INTERPRETATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the non-equality of two MEETING_INTERPRETATION_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    a As MEETING_INTERPRETATION_INFO, _
    b As MEETING_INTERPRETATION_INFO _
) As Boolean
C#
public static bool operator !=(
    MEETING_INTERPRETATION_INFO a,
    MEETING_INTERPRETATION_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_INTERPRETATION_INFO
The first MEETING_INTERPRETATION_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MEETING_INTERPRETATION_INFO
The next MEETING_INTERPRETATION_INFO to compare.

Return Value

true if the specified MEETING_INTERPRETATION_INFO structures are not the same; otherwise, false.

See Also

MEETING_INTERPRETATION_INFO Structure


MeetingControlEventArgs Class

MeetingControlEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Container for holding the configuration- and service-ID of the meeting or session service triggering the event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class MeetingControlEventArgs _
    Inherits ControlEventArgs
C#
[ObfuscationAttribute]
public class MeetingControlEventArgs : ControlEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ControlEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MeetingControlEventArgs

See Also

MeetingControlEventArgs Members


MeetingControlEventArgs Members

MeetingControlEventArgs Members
MeetingControlEventArgs Class Constructors Methods See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MeetingControlEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | MeetingControlEventArgs()()()() | Constructor...
Public method | MeetingControlEventArgs(Int32, Int32) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

MeetingControlEventArgs Class


MeetingControlEventArgs Constructor

MeetingControlEventArgs Constructor
MeetingControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | MeetingControlEventArgs()()()() | Constructor...
Public method | MeetingControlEventArgs(Int32, Int32) | Constructor...

See Also

MeetingControlEventArgs Class
MeetingControlEventArgs Members


MeetingControlEventArgs Constructor

MeetingControlEventArgs Constructor
MeetingControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MeetingControlEventArgs()

See Also

MeetingControlEventArgs Class
MeetingControlEventArgs Overload


MeetingControlEventArgs Constructor (Int32, Int32)

MeetingControlEventArgs Constructor (Int32, Int32)
MeetingControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    configId As Integer, _
    serviceId As Integer _
)
C#
public MeetingControlEventArgs(
    int configId,
    int serviceId
)

Parameters

configId
Type: System..::..Int32
The configuration identifier of either the meeting or session service.
serviceId
Type: System..::..Int32
The service identifier of either the meeting or session service.

See Also

MeetingControlEventArgs Class
MeetingControlEventArgs Overload


MeetingControlEventArgs Methods

MeetingControlEventArgs Methods
MeetingControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MeetingControlEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

MeetingControlEventArgs Class


MeetingDataChangedEventArgs Class

MeetingDataChangedEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Provides data for a MeetingStore, MeetingUpdate or MeetingDeletion event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class MeetingDataChangedEventArgs _
    Inherits ConfigChangedEventArgs
C#
[ObfuscationAttribute]
public class MeetingDataChangedEventArgs : ConfigChangedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ConfigChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MeetingDataChangedEventArgs

See Also

MeetingDataChangedEventArgs Members


MeetingDataChangedEventArgs Members

MeetingDataChangedEventArgs Members
MeetingDataChangedEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MeetingDataChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | MeetingDataChangedEventArgs()()()() | Default constructor...
Public method | MeetingDataChangedEventArgs(array<Int32>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)

See Also

MeetingDataChangedEventArgs Class


MeetingDataChangedEventArgs Constructor

MeetingDataChangedEventArgs Constructor
MeetingDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | MeetingDataChangedEventArgs()()()() | Default constructor...
Public method | MeetingDataChangedEventArgs(array<Int32>[]()[][]) | Constructor...

See Also

MeetingDataChangedEventArgs Class
MeetingDataChangedEventArgs Members


MeetingDataChangedEventArgs Constructor

MeetingDataChangedEventArgs Constructor
MeetingDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Default constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MeetingDataChangedEventArgs()

See Also

MeetingDataChangedEventArgs Class
MeetingDataChangedEventArgs Overload


MeetingDataChangedEventArgs Constructor (Int32[])

MeetingDataChangedEventArgs Constructor (array<Int32>[]()[][])
MeetingDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    meetingIds As Integer() _
)
C#
public MeetingDataChangedEventArgs(
    int[] meetingIds
)

Parameters

meetingIds
Type: array< System..::..Int32 >[]()[][]
The identifiers of the meetings changed. Use ConfigIds to retrieve.

See Also

MeetingDataChangedEventArgs Class
MeetingDataChangedEventArgs Overload


MeetingDataChangedEventArgs Methods

MeetingDataChangedEventArgs Methods
MeetingDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MeetingDataChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

MeetingDataChangedEventArgs Class


MeetingDataChangedEventArgs Properties

MeetingDataChangedEventArgs Properties
MeetingDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MeetingDataChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)

See Also

MeetingDataChangedEventArgs Class


MeetingGroupDataChangedEventArgs Class

MeetingGroupDataChangedEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Provides data for a MeetingGroupStore, MeetingGroupUpdate or MeetingGroupDeletion event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class MeetingGroupDataChangedEventArgs _
    Inherits ConfigChangedEventArgs
C#
[ObfuscationAttribute]
public class MeetingGroupDataChangedEventArgs : ConfigChangedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ConfigChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MeetingGroupDataChangedEventArgs

See Also

MeetingGroupDataChangedEventArgs Members


MeetingGroupDataChangedEventArgs Members

MeetingGroupDataChangedEventArgs Members
MeetingGroupDataChangedEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MeetingGroupDataChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | MeetingGroupDataChangedEventArgs()()()() | Default constructor...
Public method | MeetingGroupDataChangedEventArgs(array<Int32>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)

See Also

MeetingGroupDataChangedEventArgs Class


MeetingGroupDataChangedEventArgs Constructor

MeetingGroupDataChangedEventArgs Constructor
MeetingGroupDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | MeetingGroupDataChangedEventArgs()()()() | Default constructor...
Public method | MeetingGroupDataChangedEventArgs(array<Int32>[]()[][]) | Constructor...

See Also

MeetingGroupDataChangedEventArgs Class
MeetingGroupDataChangedEventArgs Members


MeetingGroupDataChangedEventArgs Constructor

MeetingGroupDataChangedEventArgs Constructor
MeetingGroupDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Default constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MeetingGroupDataChangedEventArgs()

See Also

MeetingGroupDataChangedEventArgs Class
MeetingGroupDataChangedEventArgs Overload


MeetingGroupDataChangedEventArgs Constructor (Int32[])

MeetingGroupDataChangedEventArgs Constructor (array<Int32>[]()[][])
MeetingGroupDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    meetingGroupIds As Integer() _
)
C#
public MeetingGroupDataChangedEventArgs(
    int[] meetingGroupIds
)

Parameters

meetingGroupIds
Type: array< System..::..Int32 >[]()[][]
The identifiers of the meeting groups changed. Use ConfigIds to retrieve.

See Also

MeetingGroupDataChangedEventArgs Class
MeetingGroupDataChangedEventArgs Overload


MeetingGroupDataChangedEventArgs Methods

MeetingGroupDataChangedEventArgs Methods
MeetingGroupDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MeetingGroupDataChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

MeetingGroupDataChangedEventArgs Class


MeetingGroupDataChangedEventArgs Properties

MeetingGroupDataChangedEventArgs Properties
MeetingGroupDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MeetingGroupDataChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)

See Also

MeetingGroupDataChangedEventArgs Class


MeetingInterpretationDataChangedEventArgs Class

MeetingInterpretationDataChangedEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Provides data for a MeetingInterpretationUpdate event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class MeetingInterpretationDataChangedEventArgs _
    Inherits ConfigChangedEventArgs
C#
[ObfuscationAttribute]
public class MeetingInterpretationDataChangedEventArgs : ConfigChangedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ConfigChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..MeetingInterpretationDataChangedEventArgs

See Also

MeetingInterpretationDataChangedEventArgs Members


MeetingInterpretationDataChangedEventArgs Members

MeetingInterpretationDataChangedEventArgs Members
MeetingInterpretationDataChangedEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MeetingInterpretationDataChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | MeetingInterpretationDataChangedEventArgs()()()() | Default constructor...
Public method | MeetingInterpretationDataChangedEventArgs(array<Int32>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)

See Also

MeetingInterpretationDataChangedEventArgs Class


MeetingInterpretationDataChangedEventArgs Constructor

MeetingInterpretationDataChangedEventArgs Constructor
MeetingInterpretationDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | MeetingInterpretationDataChangedEventArgs()()()() | Default constructor...
Public method | MeetingInterpretationDataChangedEventArgs(array<Int32>[]()[][]) | Constructor...

See Also

MeetingInterpretationDataChangedEventArgs Class
MeetingInterpretationDataChangedEventArgs Members


MeetingInterpretationDataChangedEventArgs Constructor

MeetingInterpretationDataChangedEventArgs Constructor
MeetingInterpretationDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Default constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MeetingInterpretationDataChangedEventArgs()

See Also

MeetingInterpretationDataChangedEventArgs Class
MeetingInterpretationDataChangedEventArgs Overload


MeetingInterpretationDataChangedEventArgs Constructor (Int32[])

MeetingInterpretationDataChangedEventArgs Constructor (array<Int32>[]()[][])
MeetingInterpretationDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    meetingIds As Integer() _
)
C#
public MeetingInterpretationDataChangedEventArgs(
    int[] meetingIds
)

Parameters

meetingIds
Type: array< System..::..Int32 >[]()[][]
The identifiers of the meetings changed. Use ConfigIds to retrieve.

See Also

MeetingInterpretationDataChangedEventArgs Class
MeetingInterpretationDataChangedEventArgs Overload


MeetingInterpretationDataChangedEventArgs Methods

MeetingInterpretationDataChangedEventArgs Methods
MeetingInterpretationDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MeetingInterpretationDataChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

MeetingInterpretationDataChangedEventArgs Class


MeetingInterpretationDataChangedEventArgs Properties

MeetingInterpretationDataChangedEventArgs Properties
MeetingInterpretationDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The MeetingInterpretationDataChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)

See Also

MeetingInterpretationDataChangedEventArgs Class


MicrophoneStatus Enumeration

MicrophoneStatus Enumeration
See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
status of Microphone

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Enumeration MicrophoneStatus
C#
[ObfuscationAttribute]
public enum MicrophoneStatus

Members

Member name | Value | Description
OFF | 0 | Seat Microphone is Off.
ON | 1 | Seat Microphone is On.
FIRST_REQUEST | 2 | Seat is next to speak.
REQUEST | 3 | Seat is in request to speak list.
VOICE_MODE | 4 | Seat is in voice mode.

See Also

Bosch.Dcn.Ecpc.Client.Api.Interfaces Namespace
Copyright (c) 2014 Bosch Security Systems B.V.4.30.0011


NOTEBOOKER_INFO Structure

NOTEBOOKER_INFO Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Represents a delegate notebooker entry in the notebook.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Structure NOTEBOOKER_INFO
C#
[SerializableAttribute]
[ObfuscationAttribute]
public struct NOTEBOOKER_INFO

See Also

NOTEBOOKER_INFO Members


NOTEBOOKER_INFO Members

NOTEBOOKER_INFO Members
NOTEBOOKER_INFO Structure Methods Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The NOTEBOOKER_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display Notebooker data in proper format. (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | CanSpeak | Indicates whether the particpant is able to speak.
Public field | IsSpeaking | Whether or not the participant is speaking currently.
Public field | ParticipantId | The participant in the notebook.
Public field | SeatId | The seat in the notebooker.

See Also

NOTEBOOKER_INFO Structure


NOTEBOOKER_INFO Fields

NOTEBOOKER_INFO Fields
NOTEBOOKER_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The NOTEBOOKER_INFO type exposes the following members.

Fields

 | Name | Description
Public field | CanSpeak | Indicates whether the particpant is able to speak.
Public field | IsSpeaking | Whether or not the participant is speaking currently.
Public field | ParticipantId | The participant in the notebook.
Public field | SeatId | The seat in the notebooker.

See Also

NOTEBOOKER_INFO Structure


CanSpeak Field

NOTEBOOKER_INFO..::..CanSpeak Field
NOTEBOOKER_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates whether the particpant is able to speak.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public CanSpeak As Boolean
C#
public bool CanSpeak

Remarks

This status is effected by the participant having the seat available for speech. Disconnected nodes, node unassignment and seat unassignment of the participant affect this setting.

See Also

NOTEBOOKER_INFO Structure


IsSpeaking Field

NOTEBOOKER_INFO..::..IsSpeaking Field
NOTEBOOKER_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Whether or not the participant is speaking currently.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public IsSpeaking As Boolean
C#
public bool IsSpeaking

See Also

NOTEBOOKER_INFO Structure


ParticipantId Field

NOTEBOOKER_INFO..::..ParticipantId Field
NOTEBOOKER_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The participant in the notebook.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ParticipantId As Integer
C#
public int ParticipantId

See Also

NOTEBOOKER_INFO Structure


SeatId Field

NOTEBOOKER_INFO..::..SeatId Field
NOTEBOOKER_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The seat in the notebooker.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public SeatId As Integer
C#
public int SeatId

See Also

NOTEBOOKER_INFO Structure


NOTEBOOKER_INFO Methods

NOTEBOOKER_INFO Methods
NOTEBOOKER_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The NOTEBOOKER_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display Notebooker data in proper format. (Overrides ValueType..::..ToString()()()().)

See Also

NOTEBOOKER_INFO Structure


ToString Method

NOTEBOOKER_INFO..::..ToString Method
NOTEBOOKER_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
To display Notebooker data in proper format.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()

Return Value

See Also

NOTEBOOKER_INFO Structure


NotebookerControlEventArgs Class

NotebookerControlEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Placeholder to contain the notebooker delegate event argument.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class NotebookerControlEventArgs _
    Inherits ControlEventArgs
C#
[ObfuscationAttribute]
public class NotebookerControlEventArgs : ControlEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ControlEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..NotebookerControlEventArgs

See Also

NotebookerControlEventArgs Members


NotebookerControlEventArgs Members

NotebookerControlEventArgs Members
NotebookerControlEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The NotebookerControlEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | NotebookerControlEventArgs()()()() | Constructor...
Public method | NotebookerControlEventArgs(Int32, Int32, array<NOTEBOOKER_INFO>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | NotebookersInfo | The list of notebooker delegate concerned.

See Also

NotebookerControlEventArgs Class


NotebookerControlEventArgs Constructor

NotebookerControlEventArgs Constructor
NotebookerControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | NotebookerControlEventArgs()()()() | Constructor...
Public method | NotebookerControlEventArgs(Int32, Int32, array<NOTEBOOKER_INFO>[]()[][]) | Constructor...

See Also

NotebookerControlEventArgs Class
NotebookerControlEventArgs Members


NotebookerControlEventArgs Constructor

NotebookerControlEventArgs Constructor
NotebookerControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public NotebookerControlEventArgs()

See Also

NotebookerControlEventArgs Class
NotebookerControlEventArgs Overload


NotebookerControlEventArgs Constructor (Int32, Int32, NOTEBOOKER_INFO[])

NotebookerControlEventArgs Constructor (Int32, Int32, array<NOTEBOOKER_INFO>[]()[][])
NotebookerControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    configId As Integer, _
    serviceId As Integer, _
    notebookersInfo As NOTEBOOKER_INFO() _
)
C#
public NotebookerControlEventArgs(
    int configId,
    int serviceId,
    NOTEBOOKER_INFO[] notebookersInfo
)

Parameters

configId
Type: System..::..Int32
The configuration identifier of the notebooker service.
serviceId
Type: System..::..Int32
The ID of the service as source of the event.
notebookersInfo
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..NOTEBOOKER_INFO >[]()[][]
The list of notebooker delegate concerned.

See Also

NotebookerControlEventArgs Class
NotebookerControlEventArgs Overload


NotebookerControlEventArgs Methods

NotebookerControlEventArgs Methods
NotebookerControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The NotebookerControlEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

NotebookerControlEventArgs Class


NotebookerControlEventArgs Properties

NotebookerControlEventArgs Properties
NotebookerControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The NotebookerControlEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | NotebookersInfo | The list of notebooker delegate concerned.

See Also

NotebookerControlEventArgs Class


NotebookersInfo Property

NotebookerControlEventArgs..::..NotebookersInfo Property
NotebookerControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The list of notebooker delegate concerned.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NotebookersInfo As NOTEBOOKER_INFO()
    Get
C#
public NOTEBOOKER_INFO[] NotebookersInfo { get; }

See Also

NotebookerControlEventArgs Class


OnOffEventArgs Class

OnOffEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Placeholder to contain the on/off setting as argument.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class OnOffEventArgs _
    Inherits ControlEventArgs
C#
[ObfuscationAttribute]
public class OnOffEventArgs : ControlEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ControlEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..OnOffEventArgs

See Also

OnOffEventArgs Members


OnOffEventArgs Members

OnOffEventArgs Members
OnOffEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The OnOffEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | OnOffEventArgs | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | OnOff | The on/off setting.

See Also

OnOffEventArgs Class


OnOffEventArgs Constructor

OnOffEventArgs Constructor
OnOffEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    serviceId As Integer, _
    onOff As Boolean _
)
C#
public OnOffEventArgs(
    int serviceId,
    bool onOff
)

Parameters

serviceId
Type: System..::..Int32
The ID of the service as source of the event.
onOff
Type: System..::..Boolean
the on/off setting.

See Also

OnOffEventArgs Class


OnOffEventArgs Methods

OnOffEventArgs Methods
OnOffEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The OnOffEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

OnOffEventArgs Class


OnOffEventArgs Properties

OnOffEventArgs Properties
OnOffEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The OnOffEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | OnOff | The on/off setting.

See Also

OnOffEventArgs Class


OnOff Property

OnOffEventArgs..::..OnOff Property
OnOffEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The on/off setting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OnOff As Boolean
    Get
C#
public bool OnOff { get; }

Field Value

true if on, false of off.

See Also

OnOffEventArgs Class


PARTICIPANT Structure

PARTICIPANT Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Contains the participant information as in the discussion activity with current speech time limitation settings.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Structure PARTICIPANT
C#
[SerializableAttribute]
[ObfuscationAttribute]
public struct PARTICIPANT

See Also

PARTICIPANT Members


PARTICIPANT Members

PARTICIPANT Members
PARTICIPANT Structure Methods Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The PARTICIPANT type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display Participant data in proper format. (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | GroupSpeechTimeLimitInMillis | The operational group speech time limit of the participant.
Public field | IndividualSpeechTimeLimitInMillis | The operational individual speech time limit of the participant.
Public field | IsInterrupted | Indicator if participant is interrupted
Public field | IsNextToSpeak | Indicator if participant is next to speak.
Public field | IsSpeaking | Indicator if participant is speaking
Public field | ParticipantId | The participant identified at the seat.
Public field | SeatId | Identifier or the seat.
Public field | SpeechTimeLimitInMillis | The operational speech time limit/respond time limit of the participant.

See Also

PARTICIPANT Structure


PARTICIPANT Fields

PARTICIPANT Fields
PARTICIPANT Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The PARTICIPANT type exposes the following members.

Fields

 | Name | Description
Public field | GroupSpeechTimeLimitInMillis | The operational group speech time limit of the participant.
Public field | IndividualSpeechTimeLimitInMillis | The operational individual speech time limit of the participant.
Public field | IsInterrupted | Indicator if participant is interrupted
Public field | IsNextToSpeak | Indicator if participant is next to speak.
Public field | IsSpeaking | Indicator if participant is speaking
Public field | ParticipantId | The participant identified at the seat.
Public field | SeatId | Identifier or the seat.
Public field | SpeechTimeLimitInMillis | The operational speech time limit/respond time limit of the participant.

See Also

PARTICIPANT Structure


GroupSpeechTimeLimitInMillis Field

PARTICIPANT..::..GroupSpeechTimeLimitInMillis Field
PARTICIPANT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The operational group speech time limit of the participant.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public GroupSpeechTimeLimitInMillis As Long
C#
public long GroupSpeechTimeLimitInMillis

See Also

PARTICIPANT Structure


IndividualSpeechTimeLimitInMillis Field

PARTICIPANT..::..IndividualSpeechTimeLimitInMillis Field
PARTICIPANT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The operational individual speech time limit of the participant.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public IndividualSpeechTimeLimitInMillis As Long
C#
public long IndividualSpeechTimeLimitInMillis

See Also

PARTICIPANT Structure


IsInterrupted Field

PARTICIPANT..::..IsInterrupted Field
PARTICIPANT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicator if participant is interrupted

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public IsInterrupted As Boolean
C#
public bool IsInterrupted

See Also

PARTICIPANT Structure


IsNextToSpeak Field

PARTICIPANT..::..IsNextToSpeak Field
PARTICIPANT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicator if participant is next to speak.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public IsNextToSpeak As Boolean
C#
public bool IsNextToSpeak

See Also

PARTICIPANT Structure


IsSpeaking Field

PARTICIPANT..::..IsSpeaking Field
PARTICIPANT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicator if participant is speaking

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public IsSpeaking As Boolean
C#
public bool IsSpeaking

See Also

PARTICIPANT Structure


ParticipantId Field

PARTICIPANT..::..ParticipantId Field
PARTICIPANT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The participant identified at the seat.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ParticipantId As Integer
C#
public int ParticipantId

See Also

PARTICIPANT Structure


SeatId Field

PARTICIPANT..::..SeatId Field
PARTICIPANT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Identifier or the seat.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public SeatId As Integer
C#
public int SeatId

See Also

PARTICIPANT Structure


SpeechTimeLimitInMillis Field

PARTICIPANT..::..SpeechTimeLimitInMillis Field
PARTICIPANT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The operational speech time limit/respond time limit of the participant.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public SpeechTimeLimitInMillis As Long
C#
public long SpeechTimeLimitInMillis

See Also

PARTICIPANT Structure


PARTICIPANT Methods

PARTICIPANT Methods
PARTICIPANT Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The PARTICIPANT type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display Participant data in proper format. (Overrides ValueType..::..ToString()()()().)

See Also

PARTICIPANT Structure


ToString Method

PARTICIPANT..::..ToString Method
PARTICIPANT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
To display Participant data in proper format.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()

Return Value

See Also

PARTICIPANT Structure


PARTICIPATION_INFO Structure

PARTICIPATION_INFO Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Represents a container containing the information required to register a delegate as participant to a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Structure PARTICIPATION_INFO
C#
[ObfuscationAttribute]
public struct PARTICIPATION_INFO

See Also

PARTICIPATION_INFO Members


PARTICIPATION_INFO Members

PARTICIPATION_INFO Members
PARTICIPATION_INFO Structure Methods Operators Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The PARTICIPATION_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two PARTICIPATION_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a PARTICIPATION_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display PARTICIPATION_INFO data in proper format. (Overrides ValueType..::..ToString()()()().)

Operators

Name | Description
Equality | Checks the equality of two PARTICIPATION_INFO structures.
Inequality | Checks the non-equality of two PARTICIPATION_INFO structures.

Fields

 | Name | Description
Public field | AssignedSeatId | Defines the seat to which the delegate will be assigned during the meeting.
 | MAX_VOTE_WEIGHT | The maximum voting weight that can be set for a delegate.
 | MIN_VOTE_WEIGHT | The minimum voting weight that can be set for a delegate.
 | NO_SEAT | Identifier to use to indicate a delegate is not assigned to a seat in a room of the meeting.
 | RIGHT_DISCUSS | The value indicating the delegate's right to operate his microphone during the meeting.
 | RIGHT_INTERCOM | The value indicating the delegate's right to place intercom calls during the meeting.
 | RIGHT_VOTE | The value indicating the delegate's right to participate in voting rounds during the meeting.
Public field | Rights | Bit mask indicating the access rights of the delegate during the meeting.
Public field | VoteWeight | The voting weight the delegate will received during the a voting round.

See Also

PARTICIPATION_INFO Structure


PARTICIPATION_INFO Fields

PARTICIPATION_INFO Fields
PARTICIPATION_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The PARTICIPATION_INFO type exposes the following members.

Fields

 | Name | Description
Public field | AssignedSeatId | Defines the seat to which the delegate will be assigned during the meeting.
 | MAX_VOTE_WEIGHT | The maximum voting weight that can be set for a delegate.
 | MIN_VOTE_WEIGHT | The minimum voting weight that can be set for a delegate.
 | NO_SEAT | Identifier to use to indicate a delegate is not assigned to a seat in a room of the meeting.
 | RIGHT_DISCUSS | The value indicating the delegate's right to operate his microphone during the meeting.
 | RIGHT_INTERCOM | The value indicating the delegate's right to place intercom calls during the meeting.
 | RIGHT_VOTE | The value indicating the delegate's right to participate in voting rounds during the meeting.
Public field | Rights | Bit mask indicating the access rights of the delegate during the meeting.
Public field | VoteWeight | The voting weight the delegate will received during the a voting round.

See Also

PARTICIPATION_INFO Structure


AssignedSeatId Field

PARTICIPATION_INFO..::..AssignedSeatId Field
PARTICIPATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Defines the seat to which the delegate will be assigned during the meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public AssignedSeatId As Integer
C#
public int AssignedSeatId

Remarks

Use the RetrieveSeatAssignmentForArea(Int32, Int32, array<SEAT_ASSIGNMENT>[]()[][]%) function to retrieve the seat assignments.

See Also

PARTICIPATION_INFO Structure


MAX_VOTE_WEIGHT Field

PARTICIPATION_INFO..::..MAX_VOTE_WEIGHT Field
PARTICIPATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The maximum voting weight that can be set for a delegate.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const MAX_VOTE_WEIGHT As Integer
C#
public const int MAX_VOTE_WEIGHT

See Also

PARTICIPATION_INFO Structure


MIN_VOTE_WEIGHT Field

PARTICIPATION_INFO..::..MIN_VOTE_WEIGHT Field
PARTICIPATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The minimum voting weight that can be set for a delegate.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const MIN_VOTE_WEIGHT As Integer
C#
public const int MIN_VOTE_WEIGHT

See Also

PARTICIPATION_INFO Structure


NO_SEAT Field

PARTICIPATION_INFO..::..NO_SEAT Field
PARTICIPATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Identifier to use to indicate a delegate is not assigned to a seat in a room of the meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const NO_SEAT As Integer
C#
public const int NO_SEAT

See Also

PARTICIPATION_INFO Structure


RIGHT_DISCUSS Field

PARTICIPATION_INFO..::..RIGHT_DISCUSS Field
PARTICIPATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The value indicating the delegate's right to operate his microphone during the meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const RIGHT_DISCUSS As Byte
C#
public const byte RIGHT_DISCUSS

See Also

PARTICIPATION_INFO Structure


RIGHT_INTERCOM Field

PARTICIPATION_INFO..::..RIGHT_INTERCOM Field
PARTICIPATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The value indicating the delegate's right to place intercom calls during the meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const RIGHT_INTERCOM As Byte
C#
public const byte RIGHT_INTERCOM

See Also

PARTICIPATION_INFO Structure


RIGHT_VOTE Field

PARTICIPATION_INFO..::..RIGHT_VOTE Field
PARTICIPATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The value indicating the delegate's right to participate in voting rounds during the meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const RIGHT_VOTE As Byte
C#
public const byte RIGHT_VOTE

See Also

PARTICIPATION_INFO Structure


Rights Field

PARTICIPATION_INFO..::..Rights Field
PARTICIPATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Bit mask indicating the access rights of the delegate during the meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Rights As Byte
C#
public byte Rights

Field Value

Consists of bitwise-OR of RIGHT_DISCUSS, RIGHT_VOTE and RIGHT_INTERCOM.

See Also

PARTICIPATION_INFO Structure


VoteWeight Field

PARTICIPATION_INFO..::..VoteWeight Field
PARTICIPATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The voting weight the delegate will received during the a voting round.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public VoteWeight As Integer
C#
public int VoteWeight

Field Value

Ranging from MIN_VOTE_WEIGHT to MAX_VOTE_WEIGHT.

See Also

PARTICIPATION_INFO Structure


PARTICIPATION_INFO Methods

PARTICIPATION_INFO Methods
PARTICIPATION_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The PARTICIPATION_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two PARTICIPATION_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a PARTICIPATION_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display PARTICIPATION_INFO data in proper format. (Overrides ValueType..::..ToString()()()().)

See Also

PARTICIPATION_INFO Structure


Equals Method

PARTICIPATION_INFO..::..Equals Method
PARTICIPATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Determines whether two PARTICIPATION_INFO instances are equal.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::..Object
The PARTICIPATION_INFO to compare with the current Object.

Return Value

true if the specified PARTICIPATION_INFO is equal to the current Object; otherwise, false.

See Also

PARTICIPATION_INFO Structure


GetHashCode Method

PARTICIPATION_INFO..::..GetHashCode Method
PARTICIPATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Serves as a hash function for a PARTICIPATION_INFO type.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current PARTICIPATION_INFO.

See Also

PARTICIPATION_INFO Structure


ToString Method

PARTICIPATION_INFO..::..ToString Method
PARTICIPATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
To display PARTICIPATION_INFO data in proper format.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()

Return Value

See Also

PARTICIPATION_INFO Structure


PARTICIPATION_INFO Operators

PARTICIPATION_INFO Operators
PARTICIPATION_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The PARTICIPATION_INFO type exposes the following members.

Operators

Name | Description
Equality | Checks the equality of two PARTICIPATION_INFO structures.
Inequality | Checks the non-equality of two PARTICIPATION_INFO structures.

See Also

PARTICIPATION_INFO Structure


Equality Operator

PARTICIPATION_INFO..::..Equality Operator
PARTICIPATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the equality of two PARTICIPATION_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    a As PARTICIPATION_INFO, _
    b As PARTICIPATION_INFO _
) As Boolean
C#
public static bool operator ==(
    PARTICIPATION_INFO a,
    PARTICIPATION_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..PARTICIPATION_INFO
The first PARTICIPATION_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..PARTICIPATION_INFO
The next PARTICIPATION_INFO to compare.

Return Value

true if the specified PARTICIPATION_INFO structures are the same; otherwise, false.

See Also

PARTICIPATION_INFO Structure


Inequality Operator

PARTICIPATION_INFO..::..Inequality Operator
PARTICIPATION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the non-equality of two PARTICIPATION_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    a As PARTICIPATION_INFO, _
    b As PARTICIPATION_INFO _
) As Boolean
C#
public static bool operator !=(
    PARTICIPATION_INFO a,
    PARTICIPATION_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..PARTICIPATION_INFO
The first PARTICIPATION_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..PARTICIPATION_INFO
The next PARTICIPATION_INFO to compare.

Return Value

true if the specified PARTICIPATION_INFO structures are not the same; otherwise, false.

See Also

PARTICIPATION_INFO Structure


RequestDataChangedEventArgs Class

RequestDataChangedEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Provides data for a RequestStore, RequestUpdate or RequestDeletion event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class RequestDataChangedEventArgs _
    Inherits ConfigChangedEventArgs
C#
[ObfuscationAttribute]
public class RequestDataChangedEventArgs : ConfigChangedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ConfigChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..RequestDataChangedEventArgs

See Also

RequestDataChangedEventArgs Members


RequestDataChangedEventArgs Members

RequestDataChangedEventArgs Members
RequestDataChangedEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The RequestDataChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | RequestDataChangedEventArgs()()()() | Default constructor...
Public method | RequestDataChangedEventArgs(array<Int32>[]()[][], array<Int32>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)
Public property | SessionIds | The identifiers of the session request list.

See Also

RequestDataChangedEventArgs Class


RequestDataChangedEventArgs Constructor

RequestDataChangedEventArgs Constructor
RequestDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | RequestDataChangedEventArgs()()()() | Default constructor...
Public method | RequestDataChangedEventArgs(array<Int32>[]()[][], array<Int32>[]()[][]) | Constructor...

See Also

RequestDataChangedEventArgs Class
RequestDataChangedEventArgs Members


RequestDataChangedEventArgs Constructor

RequestDataChangedEventArgs Constructor
RequestDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Default constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RequestDataChangedEventArgs()

See Also

RequestDataChangedEventArgs Class
RequestDataChangedEventArgs Overload


RequestDataChangedEventArgs Constructor (Int32[], Int32[])

RequestDataChangedEventArgs Constructor (array<Int32>[]()[][], array<Int32>[]()[][])
RequestDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    sessionIds As Integer(), _
    delegateIds As Integer() _
)
C#
public RequestDataChangedEventArgs(
    int[] sessionIds,
    int[] delegateIds
)

Parameters

sessionIds
Type: array< System..::..Int32 >[]()[][]
The identifiers of the sessions request list changed. Use ConfigIds to retrieve.
delegateIds
Type: array< System..::..Int32 >[]()[][]
The identifiers of the delegates of the request list changed. Use ConfigIds to retrieve.

See Also

RequestDataChangedEventArgs Class
RequestDataChangedEventArgs Overload


RequestDataChangedEventArgs Methods

RequestDataChangedEventArgs Methods
RequestDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The RequestDataChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

RequestDataChangedEventArgs Class


RequestDataChangedEventArgs Properties

RequestDataChangedEventArgs Properties
RequestDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The RequestDataChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)
Public property | SessionIds | The identifiers of the session request list.

See Also

RequestDataChangedEventArgs Class


SessionIds Property

RequestDataChangedEventArgs..::..SessionIds Property
RequestDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The identifiers of the session request list.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SessionIds As Integer()
    Get
C#
public int[] SessionIds { get; }

See Also

RequestDataChangedEventArgs Class


SEAT_ASSIGNMENT Structure

SEAT_ASSIGNMENT Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Defines a container defining the seating arrangements in the rooms used in the meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Structure SEAT_ASSIGNMENT
C#
[ObfuscationAttribute]
public struct SEAT_ASSIGNMENT

See Also

SEAT_ASSIGNMENT Members


SEAT_ASSIGNMENT Members

SEAT_ASSIGNMENT Members
SEAT_ASSIGNMENT Structure Methods Operators Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SEAT_ASSIGNMENT type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two SEAT_ASSIGNMENT instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a SEAT_ASSIGNMENT type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display SEAT_ASSIGNMENT data in proper format. (Overrides ValueType..::..ToString()()()().)

Operators

Name | Description
Equality | Checks the equality of two SEAT_ASSIGNMENT structures.
Inequality | Checks the non-equality of two SEAT_ASSIGNMENT structures.

Fields

 | Name | Description
 | DEFAULT_AREA | The default area supported to hold meetings in.
Public field | DelegateId | The identification of the delegate assigned to be sitting at the given seat in given area.
 | NO_DELEGATE | There is no delegate assigned to the seat.
Public field | SeatId | A seat identified physically present in the given area.
Public field | SeatName | The name of the seat in the area.

See Also

SEAT_ASSIGNMENT Structure


SEAT_ASSIGNMENT Fields

SEAT_ASSIGNMENT Fields
SEAT_ASSIGNMENT Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SEAT_ASSIGNMENT type exposes the following members.

Fields

 | Name | Description
 | DEFAULT_AREA | The default area supported to hold meetings in.
Public field | DelegateId | The identification of the delegate assigned to be sitting at the given seat in given area.
 | NO_DELEGATE | There is no delegate assigned to the seat.
Public field | SeatId | A seat identified physically present in the given area.
Public field | SeatName | The name of the seat in the area.

See Also

SEAT_ASSIGNMENT Structure


DEFAULT_AREA Field

SEAT_ASSIGNMENT..::..DEFAULT_AREA Field
SEAT_ASSIGNMENT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The default area supported to hold meetings in.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const DEFAULT_AREA As Integer
C#
public const int DEFAULT_AREA

See Also

SEAT_ASSIGNMENT Structure


DelegateId Field

SEAT_ASSIGNMENT..::..DelegateId Field
SEAT_ASSIGNMENT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The identification of the delegate assigned to be sitting at the given seat in given area.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public DelegateId As Integer
C#
public int DelegateId

Field Value

A valid delegate identification, or NO_DELEGATE if empty seat.

See Also

SEAT_ASSIGNMENT Structure


NO_DELEGATE Field

SEAT_ASSIGNMENT..::..NO_DELEGATE Field
SEAT_ASSIGNMENT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
There is no delegate assigned to the seat.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const NO_DELEGATE As Integer
C#
public const int NO_DELEGATE

See Also

SEAT_ASSIGNMENT Structure


SeatId Field

SEAT_ASSIGNMENT..::..SeatId Field
SEAT_ASSIGNMENT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
A seat identified physically present in the given area.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public SeatId As Integer
C#
public int SeatId

See Also

SEAT_ASSIGNMENT Structure


SeatName Field

SEAT_ASSIGNMENT..::..SeatName Field
SEAT_ASSIGNMENT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The name of the seat in the area.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public SeatName As String
C#
public string SeatName

See Also

SEAT_ASSIGNMENT Structure


SEAT_ASSIGNMENT Methods

SEAT_ASSIGNMENT Methods
SEAT_ASSIGNMENT Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SEAT_ASSIGNMENT type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two SEAT_ASSIGNMENT instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a SEAT_ASSIGNMENT type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display SEAT_ASSIGNMENT data in proper format. (Overrides ValueType..::..ToString()()()().)

See Also

SEAT_ASSIGNMENT Structure


Equals Method

SEAT_ASSIGNMENT..::..Equals Method
SEAT_ASSIGNMENT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Determines whether two SEAT_ASSIGNMENT instances are equal.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::..Object
The SEAT_ASSIGNMENT to compare with the current Object.

Return Value

true if the specified SEAT_ASSIGNMENT is equal to the current Object; otherwise, false.

See Also

SEAT_ASSIGNMENT Structure


GetHashCode Method

SEAT_ASSIGNMENT..::..GetHashCode Method
SEAT_ASSIGNMENT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Serves as a hash function for a SEAT_ASSIGNMENT type.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current SEAT_ASSIGNMENT.

See Also

SEAT_ASSIGNMENT Structure


ToString Method

SEAT_ASSIGNMENT..::..ToString Method
SEAT_ASSIGNMENT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
To display SEAT_ASSIGNMENT data in proper format.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()

Return Value

See Also

SEAT_ASSIGNMENT Structure


SEAT_ASSIGNMENT Operators

SEAT_ASSIGNMENT Operators
SEAT_ASSIGNMENT Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SEAT_ASSIGNMENT type exposes the following members.

Operators

Name | Description
Equality | Checks the equality of two SEAT_ASSIGNMENT structures.
Inequality | Checks the non-equality of two SEAT_ASSIGNMENT structures.

See Also

SEAT_ASSIGNMENT Structure


Equality Operator

SEAT_ASSIGNMENT..::..Equality Operator
SEAT_ASSIGNMENT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the equality of two SEAT_ASSIGNMENT structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    a As SEAT_ASSIGNMENT, _
    b As SEAT_ASSIGNMENT _
) As Boolean
C#
public static bool operator ==(
    SEAT_ASSIGNMENT a,
    SEAT_ASSIGNMENT b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SEAT_ASSIGNMENT
The first SEAT_ASSIGNMENT to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SEAT_ASSIGNMENT
The next SEAT_ASSIGNMENT to compare.

Return Value

true if the specified SEAT_ASSIGNMENT structures are the same; otherwise, false.

See Also

SEAT_ASSIGNMENT Structure


Inequality Operator

SEAT_ASSIGNMENT..::..Inequality Operator
SEAT_ASSIGNMENT Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the non-equality of two SEAT_ASSIGNMENT structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    a As SEAT_ASSIGNMENT, _
    b As SEAT_ASSIGNMENT _
) As Boolean
C#
public static bool operator !=(
    SEAT_ASSIGNMENT a,
    SEAT_ASSIGNMENT b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SEAT_ASSIGNMENT
The first SEAT_ASSIGNMENT to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SEAT_ASSIGNMENT
The next SEAT_ASSIGNMENT to compare.

Return Value

true if the specified SEAT_ASSIGNMENT structures are not the same; otherwise, false.

See Also

SEAT_ASSIGNMENT Structure


SEAT_MICROPHONE_STATUS Structure

SEAT_MICROPHONE_STATUS Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Contains the status of microphone.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Structure SEAT_MICROPHONE_STATUS
C#
[SerializableAttribute]
[ObfuscationAttribute]
public struct SEAT_MICROPHONE_STATUS

See Also

SEAT_MICROPHONE_STATUS Members


SEAT_MICROPHONE_STATUS Members

SEAT_MICROPHONE_STATUS Members
SEAT_MICROPHONE_STATUS Structure Methods Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SEAT_MICROPHONE_STATUS type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display Seat mic data in proper format. (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | MicStatus | Mic status enum.
Public field | SeatId | Seat Id

See Also

SEAT_MICROPHONE_STATUS Structure


SEAT_MICROPHONE_STATUS Fields

SEAT_MICROPHONE_STATUS Fields
SEAT_MICROPHONE_STATUS Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SEAT_MICROPHONE_STATUS type exposes the following members.

Fields

 | Name | Description
Public field | MicStatus | Mic status enum.
Public field | SeatId | Seat Id

See Also

SEAT_MICROPHONE_STATUS Structure


MicStatus Field

SEAT_MICROPHONE_STATUS..::..MicStatus Field
SEAT_MICROPHONE_STATUS Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Mic status enum.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public MicStatus As MicrophoneStatus
C#
public MicrophoneStatus MicStatus

See Also

SEAT_MICROPHONE_STATUS Structure


SeatId Field

SEAT_MICROPHONE_STATUS..::..SeatId Field
SEAT_MICROPHONE_STATUS Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Seat Id

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public SeatId As Integer
C#
public int SeatId

See Also

SEAT_MICROPHONE_STATUS Structure


SEAT_MICROPHONE_STATUS Methods

SEAT_MICROPHONE_STATUS Methods
SEAT_MICROPHONE_STATUS Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SEAT_MICROPHONE_STATUS type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display Seat mic data in proper format. (Overrides ValueType..::..ToString()()()().)

See Also

SEAT_MICROPHONE_STATUS Structure


ToString Method

SEAT_MICROPHONE_STATUS..::..ToString Method
SEAT_MICROPHONE_STATUS Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
To display Seat mic data in proper format.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()

Return Value

See Also

SEAT_MICROPHONE_STATUS Structure


SESSION_GROUP_TIMER Structure

SESSION_GROUP_TIMER Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Contains the group timers of the session.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Structure SESSION_GROUP_TIMER
C#
[SerializableAttribute]
[ObfuscationAttribute]
public struct SESSION_GROUP_TIMER

See Also

SESSION_GROUP_TIMER Members


SESSION_GROUP_TIMER Members

SESSION_GROUP_TIMER Members
SESSION_GROUP_TIMER Structure Methods Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SESSION_GROUP_TIMER type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display Session group timer data in proper format. (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | GroupId | The Group identifier.
Public field | GroupTimerLimitInMillis | The timer limit of the group.

See Also

SESSION_GROUP_TIMER Structure


SESSION_GROUP_TIMER Fields

SESSION_GROUP_TIMER Fields
SESSION_GROUP_TIMER Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SESSION_GROUP_TIMER type exposes the following members.

Fields

 | Name | Description
Public field | GroupId | The Group identifier.
Public field | GroupTimerLimitInMillis | The timer limit of the group.

See Also

SESSION_GROUP_TIMER Structure


GroupId Field

SESSION_GROUP_TIMER..::..GroupId Field
SESSION_GROUP_TIMER Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The Group identifier.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public GroupId As Integer
C#
public int GroupId

See Also

SESSION_GROUP_TIMER Structure


GroupTimerLimitInMillis Field

SESSION_GROUP_TIMER..::..GroupTimerLimitInMillis Field
SESSION_GROUP_TIMER Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The timer limit of the group.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public GroupTimerLimitInMillis As Long
C#
public long GroupTimerLimitInMillis

See Also

SESSION_GROUP_TIMER Structure


SESSION_GROUP_TIMER Methods

SESSION_GROUP_TIMER Methods
SESSION_GROUP_TIMER Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SESSION_GROUP_TIMER type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display Session group timer data in proper format. (Overrides ValueType..::..ToString()()()().)

See Also

SESSION_GROUP_TIMER Structure


ToString Method

SESSION_GROUP_TIMER..::..ToString Method
SESSION_GROUP_TIMER Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
To display Session group timer data in proper format.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()

Return Value

See Also

SESSION_GROUP_TIMER Structure


SESSION_INFO Structure

SESSION_INFO Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Represents a container describing a session of a meeting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Structure SESSION_INFO
C#
[ObfuscationAttribute]
public struct SESSION_INFO

See Also

SESSION_INFO Members


SESSION_INFO Members

SESSION_INFO Members
SESSION_INFO Structure Methods Operators Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SESSION_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two SESSION_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a SESSION_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display SESSION_INFO data in proper format. (Overrides ValueType..::..ToString()()()().)

Operators

Name | Description
Equality | Checks the equality of two SESSION_INFO structures.
Inequality | Checks the non-equality of two SESSION_INFO structures.

Fields

 | Name | Description
Public field | Description | The description of the session.
Public field | Subject | The subject of the session.

See Also

SESSION_INFO Structure


SESSION_INFO Fields

SESSION_INFO Fields
SESSION_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SESSION_INFO type exposes the following members.

Fields

 | Name | Description
Public field | Description | The description of the session.
Public field | Subject | The subject of the session.

See Also

SESSION_INFO Structure


Description Field

SESSION_INFO..::..Description Field
SESSION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The description of the session.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Description As String
C#
public string Description

See Also

SESSION_INFO Structure


Subject Field

SESSION_INFO..::..Subject Field
SESSION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The subject of the session.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Subject As String
C#
public string Subject

See Also

SESSION_INFO Structure


SESSION_INFO Methods

SESSION_INFO Methods
SESSION_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SESSION_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two SESSION_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a SESSION_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display SESSION_INFO data in proper format. (Overrides ValueType..::..ToString()()()().)

See Also

SESSION_INFO Structure


Equals Method

SESSION_INFO..::..Equals Method
SESSION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Determines whether two SESSION_INFO instances are equal.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::..Object
The SESSION_INFO to compare with the current Object.

Return Value

true if the specified SESSION_INFO is equal to the current Object; otherwise, false.

See Also

SESSION_INFO Structure


GetHashCode Method

SESSION_INFO..::..GetHashCode Method
SESSION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Serves as a hash function for a SESSION_INFO type.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current SESSION_INFO.

See Also

SESSION_INFO Structure


ToString Method

SESSION_INFO..::..ToString Method
SESSION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
To display SESSION_INFO data in proper format.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()

Return Value

See Also

SESSION_INFO Structure


SESSION_INFO Operators

SESSION_INFO Operators
SESSION_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SESSION_INFO type exposes the following members.

Operators

Name | Description
Equality | Checks the equality of two SESSION_INFO structures.
Inequality | Checks the non-equality of two SESSION_INFO structures.

See Also

SESSION_INFO Structure


Equality Operator

SESSION_INFO..::..Equality Operator
SESSION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the equality of two SESSION_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    a As SESSION_INFO, _
    b As SESSION_INFO _
) As Boolean
C#
public static bool operator ==(
    SESSION_INFO a,
    SESSION_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SESSION_INFO
The first SESSION_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SESSION_INFO
The next SESSION_INFO to compare.

Return Value

true if the specified SESSION_INFO structures are the same; otherwise, false.

See Also

SESSION_INFO Structure


Inequality Operator

SESSION_INFO..::..Inequality Operator
SESSION_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the non-equality of two SESSION_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    a As SESSION_INFO, _
    b As SESSION_INFO _
) As Boolean
C#
public static bool operator !=(
    SESSION_INFO a,
    SESSION_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SESSION_INFO
The first SESSION_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SESSION_INFO
The next SESSION_INFO to compare.

Return Value

true if the specified SESSION_INFO structures are not the same; otherwise, false.

See Also

SESSION_INFO Structure


SessionDataChangedEventArgs Class

SessionDataChangedEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Provides data for a SessionStore, SessionUpdate or SessionDeletion event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class SessionDataChangedEventArgs _
    Inherits ConfigChangedEventArgs
C#
[ObfuscationAttribute]
public class SessionDataChangedEventArgs : ConfigChangedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ConfigChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SessionDataChangedEventArgs

See Also

SessionDataChangedEventArgs Members


SessionDataChangedEventArgs Members

SessionDataChangedEventArgs Members
SessionDataChangedEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SessionDataChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SessionDataChangedEventArgs()()()() | Default constructor...
Public method | SessionDataChangedEventArgs(array<Int32>[]()[][], array<Int32>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)
Public property | MeetingIds | The identifiers for the meetings having changes to their sessions applied.

See Also

SessionDataChangedEventArgs Class


SessionDataChangedEventArgs Constructor

SessionDataChangedEventArgs Constructor
SessionDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | SessionDataChangedEventArgs()()()() | Default constructor...
Public method | SessionDataChangedEventArgs(array<Int32>[]()[][], array<Int32>[]()[][]) | Constructor...

See Also

SessionDataChangedEventArgs Class
SessionDataChangedEventArgs Members


SessionDataChangedEventArgs Constructor

SessionDataChangedEventArgs Constructor
SessionDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Default constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SessionDataChangedEventArgs()

See Also

SessionDataChangedEventArgs Class
SessionDataChangedEventArgs Overload


SessionDataChangedEventArgs Constructor (Int32[], Int32[])

SessionDataChangedEventArgs Constructor (array<Int32>[]()[][], array<Int32>[]()[][])
SessionDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    sessionIds As Integer(), _
    meetingIds As Integer() _
)
C#
public SessionDataChangedEventArgs(
    int[] sessionIds,
    int[] meetingIds
)

Parameters

sessionIds
Type: array< System..::..Int32 >[]()[][]
The identifiers of the sessions changed. Use ConfigIds to retrieve.
meetingIds
Type: array< System..::..Int32 >[]()[][]
The identifiers for the meetings having changes to their sessions applied.

See Also

SessionDataChangedEventArgs Class
SessionDataChangedEventArgs Overload


SessionDataChangedEventArgs Methods

SessionDataChangedEventArgs Methods
SessionDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SessionDataChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

SessionDataChangedEventArgs Class


SessionDataChangedEventArgs Properties

SessionDataChangedEventArgs Properties
SessionDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SessionDataChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)
Public property | MeetingIds | The identifiers for the meetings having changes to their sessions applied.

See Also

SessionDataChangedEventArgs Class


MeetingIds Property

SessionDataChangedEventArgs..::..MeetingIds Property
SessionDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The identifiers for the meetings having changes to their sessions applied.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MeetingIds As Integer()
    Get
C#
public int[] MeetingIds { get; }

See Also

SessionDataChangedEventArgs Class


SPEAKER_TIMELEFT_INFO Structure

SPEAKER_TIMELEFT_INFO Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Contains the participant's time left

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Structure SPEAKER_TIMELEFT_INFO
C#
[SerializableAttribute]
[ObfuscationAttribute]
public struct SPEAKER_TIMELEFT_INFO

See Also

SPEAKER_TIMELEFT_INFO Members


SPEAKER_TIMELEFT_INFO Members

SPEAKER_TIMELEFT_INFO Members
SPEAKER_TIMELEFT_INFO Structure Methods Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SPEAKER_TIMELEFT_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Fields

 | Name | Description
Public field | ParticipantId | The participant identifier.
Public field | TimeLeft | The time left of the particpant.

See Also

SPEAKER_TIMELEFT_INFO Structure


SPEAKER_TIMELEFT_INFO Fields

SPEAKER_TIMELEFT_INFO Fields
SPEAKER_TIMELEFT_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SPEAKER_TIMELEFT_INFO type exposes the following members.

Fields

 | Name | Description
Public field | ParticipantId | The participant identifier.
Public field | TimeLeft | The time left of the particpant.

See Also

SPEAKER_TIMELEFT_INFO Structure


ParticipantId Field

SPEAKER_TIMELEFT_INFO..::..ParticipantId Field
SPEAKER_TIMELEFT_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The participant identifier.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ParticipantId As Integer
C#
public int ParticipantId

See Also

SPEAKER_TIMELEFT_INFO Structure


TimeLeft Field

SPEAKER_TIMELEFT_INFO..::..TimeLeft Field
SPEAKER_TIMELEFT_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The time left of the particpant.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public TimeLeft As Long
C#
public long TimeLeft

See Also

SPEAKER_TIMELEFT_INFO Structure


SPEAKER_TIMELEFT_INFO Methods

SPEAKER_TIMELEFT_INFO Methods
SPEAKER_TIMELEFT_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The SPEAKER_TIMELEFT_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

SPEAKER_TIMELEFT_INFO Structure


TimeLeftControlEventArgs Class

TimeLeftControlEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Placeholder to contain the speaker's time left event argument

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class TimeLeftControlEventArgs _
    Inherits EventArgs
C#
[ObfuscationAttribute]
public class TimeLeftControlEventArgs : EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..TimeLeftControlEventArgs

See Also

TimeLeftControlEventArgs Members


TimeLeftControlEventArgs Members

TimeLeftControlEventArgs Members
TimeLeftControlEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The TimeLeftControlEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | TimeLeftControlEventArgs()()()() | Constructor...
Public method | TimeLeftControlEventArgs(array<SPEAKER_TIMELEFT_INFO>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | SpeakerTimeLeft | Contains the participant's time left.

See Also

TimeLeftControlEventArgs Class


TimeLeftControlEventArgs Constructor

TimeLeftControlEventArgs Constructor
TimeLeftControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | TimeLeftControlEventArgs()()()() | Constructor...
Public method | TimeLeftControlEventArgs(array<SPEAKER_TIMELEFT_INFO>[]()[][]) | Constructor...

See Also

TimeLeftControlEventArgs Class
TimeLeftControlEventArgs Members


TimeLeftControlEventArgs Constructor

TimeLeftControlEventArgs Constructor
TimeLeftControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TimeLeftControlEventArgs()

See Also

TimeLeftControlEventArgs Class
TimeLeftControlEventArgs Overload


TimeLeftControlEventArgs Constructor (SPEAKER_TIMELEFT_INFO[])

TimeLeftControlEventArgs Constructor (array<SPEAKER_TIMELEFT_INFO>[]()[][])
TimeLeftControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    speakerTimeLeft As SPEAKER_TIMELEFT_INFO() _
)
C#
public TimeLeftControlEventArgs(
    SPEAKER_TIMELEFT_INFO[] speakerTimeLeft
)

Parameters

speakerTimeLeft
Type: array< Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..SPEAKER_TIMELEFT_INFO >[]()[][]
Represents speaker's time left in Millis.

See Also

TimeLeftControlEventArgs Class
TimeLeftControlEventArgs Overload


TimeLeftControlEventArgs Methods

TimeLeftControlEventArgs Methods
TimeLeftControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The TimeLeftControlEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

TimeLeftControlEventArgs Class


TimeLeftControlEventArgs Properties

TimeLeftControlEventArgs Properties
TimeLeftControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The TimeLeftControlEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | SpeakerTimeLeft | Contains the participant's time left.

See Also

TimeLeftControlEventArgs Class


SpeakerTimeLeft Property

TimeLeftControlEventArgs..::..SpeakerTimeLeft Property
TimeLeftControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Contains the participant's time left.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SpeakerTimeLeft As SPEAKER_TIMELEFT_INFO()
    Get
C#
public SPEAKER_TIMELEFT_INFO[] SpeakerTimeLeft { get; }

See Also

TimeLeftControlEventArgs Class


TimeLeftControlEventHandler Delegate

TimeLeftControlEventHandler Delegate
See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Event handler for a speaker's time left change events.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Delegate Sub TimeLeftControlEventHandler ( _
    sender As Object, _
    e As TimeLeftControlEventArgs _
)
C#
[ObfuscationAttribute]
public delegate void TimeLeftControlEventHandler(
    Object sender,
    TimeLeftControlEventArgs e
)

Parameters

sender
Type: System..::..Object
The source of the event
e
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..TimeLeftControlEventArgs
A TimeLeftControlEventArgs that contains the event data

See Also

Bosch.Dcn.Ecpc.Client.Api.Interfaces Namespace
Copyright (c) 2014 Bosch Security Systems B.V.4.30.0011


TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Class

TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Provides data for a TimerToHoldSpeakSlowlyRequestUpdate event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class TimerToHoldSpeakSlowlyRequestDataChangedEventArgs _
    Inherits EventArgs
C#
[ObfuscationAttribute]
public class TimerToHoldSpeakSlowlyRequestDataChangedEventArgs : EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..TimerToHoldSpeakSlowlyRequestDataChangedEventArgs

See Also

TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Members


TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Members

TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Members
TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The TimerToHoldSpeakSlowlyRequestDataChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | TimerToHoldSpeakSlowlyRequestDataChangedEventArgs()()()() | Default Constructor...
Public method | TimerToHoldSpeakSlowlyRequestDataChangedEventArgs(Int32) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Timer | If true the help signalling is enabled for participants

See Also

TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Class


TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Constructor

TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Constructor
TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | TimerToHoldSpeakSlowlyRequestDataChangedEventArgs()()()() | Default Constructor...
Public method | TimerToHoldSpeakSlowlyRequestDataChangedEventArgs(Int32) | Constructor...

See Also

TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Class
TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Members


TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Constructor

TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Constructor
TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Default Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TimerToHoldSpeakSlowlyRequestDataChangedEventArgs()

See Also

TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Class
TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Overload


TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Constructor (Int32)

TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Constructor (Int32)
TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    timer As Integer _
)
C#
public TimerToHoldSpeakSlowlyRequestDataChangedEventArgs(
    int timer
)

Parameters

timer
Type: System..::..Int32
Timer to hold the speak slowly request in seconds

See Also

TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Class
TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Overload


TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Methods

TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Methods
TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The TimerToHoldSpeakSlowlyRequestDataChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Class


TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Properties

TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Properties
TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The TimerToHoldSpeakSlowlyRequestDataChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Timer | If true the help signalling is enabled for participants

See Also

TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Class


Timer Property

TimerToHoldSpeakSlowlyRequestDataChangedEventArgs..::..Timer Property
TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
If true the help signalling is enabled for participants

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Timer As Integer
    Get
C#
public int Timer { get; }

See Also

TimerToHoldSpeakSlowlyRequestDataChangedEventArgs Class


UseOfHelpSignallingDataChangedEventArgs Class

UseOfHelpSignallingDataChangedEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Provides data for a UseOfHelpSignallingUpdate event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class UseOfHelpSignallingDataChangedEventArgs _
    Inherits EventArgs
C#
[ObfuscationAttribute]
public class UseOfHelpSignallingDataChangedEventArgs : EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..UseOfHelpSignallingDataChangedEventArgs

See Also

UseOfHelpSignallingDataChangedEventArgs Members


UseOfHelpSignallingDataChangedEventArgs Members

UseOfHelpSignallingDataChangedEventArgs Members
UseOfHelpSignallingDataChangedEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The UseOfHelpSignallingDataChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | UseOfHelpSignallingDataChangedEventArgs()()()() | Default Constructor...
Public method | UseOfHelpSignallingDataChangedEventArgs(Boolean, Boolean) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEnableForInterpreters | If true the help signalling is enabled for interpreters
Public property | IsEnableForParticipants | If true the help signalling is enabled for participants

See Also

UseOfHelpSignallingDataChangedEventArgs Class


UseOfHelpSignallingDataChangedEventArgs Constructor

UseOfHelpSignallingDataChangedEventArgs Constructor
UseOfHelpSignallingDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | UseOfHelpSignallingDataChangedEventArgs()()()() | Default Constructor...
Public method | UseOfHelpSignallingDataChangedEventArgs(Boolean, Boolean) | Constructor...

See Also

UseOfHelpSignallingDataChangedEventArgs Class
UseOfHelpSignallingDataChangedEventArgs Members


UseOfHelpSignallingDataChangedEventArgs Constructor

UseOfHelpSignallingDataChangedEventArgs Constructor
UseOfHelpSignallingDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Default Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UseOfHelpSignallingDataChangedEventArgs()

See Also

UseOfHelpSignallingDataChangedEventArgs Class
UseOfHelpSignallingDataChangedEventArgs Overload


UseOfHelpSignallingDataChangedEventArgs Constructor (Boolean, Boolean)

UseOfHelpSignallingDataChangedEventArgs Constructor (Boolean, Boolean)
UseOfHelpSignallingDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    isEnableForParticipants As Boolean, _
    isEnableForInterpreters As Boolean _
)
C#
public UseOfHelpSignallingDataChangedEventArgs(
    bool isEnableForParticipants,
    bool isEnableForInterpreters
)

Parameters

isEnableForParticipants
Type: System..::..Boolean
If true the help signalling is enabled for participants
isEnableForInterpreters
Type: System..::..Boolean
If true the help signalling is enabled for interpreters

See Also

UseOfHelpSignallingDataChangedEventArgs Class
UseOfHelpSignallingDataChangedEventArgs Overload


UseOfHelpSignallingDataChangedEventArgs Methods

UseOfHelpSignallingDataChangedEventArgs Methods
UseOfHelpSignallingDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The UseOfHelpSignallingDataChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

UseOfHelpSignallingDataChangedEventArgs Class


UseOfHelpSignallingDataChangedEventArgs Properties

UseOfHelpSignallingDataChangedEventArgs Properties
UseOfHelpSignallingDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The UseOfHelpSignallingDataChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | IsEnableForInterpreters | If true the help signalling is enabled for interpreters
Public property | IsEnableForParticipants | If true the help signalling is enabled for participants

See Also

UseOfHelpSignallingDataChangedEventArgs Class


IsEnableForInterpreters Property

UseOfHelpSignallingDataChangedEventArgs..::..IsEnableForInterpreters Property
UseOfHelpSignallingDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
If true the help signalling is enabled for interpreters

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEnableForInterpreters As Boolean
    Get
C#
public bool IsEnableForInterpreters { get; }

See Also

UseOfHelpSignallingDataChangedEventArgs Class


IsEnableForParticipants Property

UseOfHelpSignallingDataChangedEventArgs..::..IsEnableForParticipants Property
UseOfHelpSignallingDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
If true the help signalling is enabled for participants

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEnableForParticipants As Boolean
    Get
C#
public bool IsEnableForParticipants { get; }

See Also

UseOfHelpSignallingDataChangedEventArgs Class


VOTE_INFO Structure

VOTE_INFO Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Represents a container holding all information of a vote.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Structure VOTE_INFO
C#
[ObfuscationAttribute]
public struct VOTE_INFO

See Also

VOTE_INFO Members


VOTE_INFO Members

VOTE_INFO Members
VOTE_INFO Structure Methods Operators Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VOTE_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two VOTE_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a VOTE_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display VOTE_INFO data in proper format. (Overrides ValueType..::..ToString()()()().)

Operators

Name | Description
Equality | Checks the equality of two VOTE_INFO structures.
Inequality | Checks the non-equality of two VOTE_INFO structures.

Fields

 | Name | Description
 | ANSWERSET_AUDIENCERESPONSE | The answer set for a voting for --/-/0/+/++
 | ANSWERSET_OPINIONPOLL | The answer set for a voting for 1/2/3/4/5
 | ANSWERSET_YES_NO | The answer set for a voting for YES/NO.
 | ANSWERSET_YES_NO_ABSTAIN | The answer set for a voting for YES/NO/ABSTAIN.
 | ANSWERSET_YES_NO_ABSTAIN_DNPV | The answer set for a voting for YES/NO/ABSTAIN/DNPV
 | DEFAULT_VOTINGTEMPLATE_ID | Identifier for the default voting template to define for a vote.
Public field | DocumentationURL | A freely definable URL to refer to additional documentation for the vote.
Public field | RegisterVotePresenceId | Indicates how to determine 100% voting presence.
Public field | Subject | The subject of the vote.
Public field | VoteAnswerSet | The answer set to use in the vote.
Public field | VoteTemplateId |
Public field | VotingName | The name of the vote.
Public field | VotingNumber | Freely definable number for the vote.

See Also

VOTE_INFO Structure


VOTE_INFO Fields

VOTE_INFO Fields
VOTE_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VOTE_INFO type exposes the following members.

Fields

 | Name | Description
 | ANSWERSET_AUDIENCERESPONSE | The answer set for a voting for --/-/0/+/++
 | ANSWERSET_OPINIONPOLL | The answer set for a voting for 1/2/3/4/5
 | ANSWERSET_YES_NO | The answer set for a voting for YES/NO.
 | ANSWERSET_YES_NO_ABSTAIN | The answer set for a voting for YES/NO/ABSTAIN.
 | ANSWERSET_YES_NO_ABSTAIN_DNPV | The answer set for a voting for YES/NO/ABSTAIN/DNPV
 | DEFAULT_VOTINGTEMPLATE_ID | Identifier for the default voting template to define for a vote.
Public field | DocumentationURL | A freely definable URL to refer to additional documentation for the vote.
Public field | RegisterVotePresenceId | Indicates how to determine 100% voting presence.
Public field | Subject | The subject of the vote.
Public field | VoteAnswerSet | The answer set to use in the vote.
Public field | VoteTemplateId |
Public field | VotingName | The name of the vote.
Public field | VotingNumber | Freely definable number for the vote.

See Also

VOTE_INFO Structure


ANSWERSET_AUDIENCERESPONSE Field

VOTE_INFO..::..ANSWERSET_AUDIENCERESPONSE Field
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The answer set for a voting for --/-/0/+/++

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const ANSWERSET_AUDIENCERESPONSE As Integer
C#
public const int ANSWERSET_AUDIENCERESPONSE

See Also

VOTE_INFO Structure


ANSWERSET_OPINIONPOLL Field

VOTE_INFO..::..ANSWERSET_OPINIONPOLL Field
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The answer set for a voting for 1/2/3/4/5

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const ANSWERSET_OPINIONPOLL As Integer
C#
public const int ANSWERSET_OPINIONPOLL

See Also

VOTE_INFO Structure


ANSWERSET_YES_NO Field

VOTE_INFO..::..ANSWERSET_YES_NO Field
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The answer set for a voting for YES/NO.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const ANSWERSET_YES_NO As Integer
C#
public const int ANSWERSET_YES_NO

See Also

VOTE_INFO Structure


ANSWERSET_YES_NO_ABSTAIN Field

VOTE_INFO..::..ANSWERSET_YES_NO_ABSTAIN Field
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The answer set for a voting for YES/NO/ABSTAIN.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const ANSWERSET_YES_NO_ABSTAIN As Integer
C#
public const int ANSWERSET_YES_NO_ABSTAIN

See Also

VOTE_INFO Structure


ANSWERSET_YES_NO_ABSTAIN_DNPV Field

VOTE_INFO..::..ANSWERSET_YES_NO_ABSTAIN_DNPV Field
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The answer set for a voting for YES/NO/ABSTAIN/DNPV

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const ANSWERSET_YES_NO_ABSTAIN_DNPV As Integer
C#
public const int ANSWERSET_YES_NO_ABSTAIN_DNPV

See Also

VOTE_INFO Structure


DEFAULT_VOTINGTEMPLATE_ID Field

VOTE_INFO..::..DEFAULT_VOTINGTEMPLATE_ID Field
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Identifier for the default voting template to define for a vote.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Const DEFAULT_VOTINGTEMPLATE_ID As Integer
C#
public const int DEFAULT_VOTINGTEMPLATE_ID

See Also

VOTE_INFO Structure


DocumentationURL Field

VOTE_INFO..::..DocumentationURL Field
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
A freely definable URL to refer to additional documentation for the vote.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public DocumentationURL As String
C#
public string DocumentationURL

See Also

VOTE_INFO Structure


RegisterVotePresenceId Field

VOTE_INFO..::..RegisterVotePresenceId Field
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Indicates how to determine 100% voting presence.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public RegisterVotePresenceId As VOTING_PRESENCE
C#
public VOTING_PRESENCE RegisterVotePresenceId

Remarks

Following values can be set for Voting Presence.
0 - NONE
1 - PRESENCE_BUTTON
2 - FRAUD_SWITCH
3 - EXTERNAL_DEVICE
4 - VOTE_AUTHORIZATION
5 - CASTED_VOTES

See Also

VOTE_INFO Structure


Subject Field

VOTE_INFO..::..Subject Field
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The subject of the vote.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Subject As String
C#
public string Subject

See Also

VOTE_INFO Structure


VoteAnswerSet Field

VOTE_INFO..::..VoteAnswerSet Field
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The answer set to use in the vote.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public VoteAnswerSet As Integer
C#
public int VoteAnswerSet

Field Value

See ANSWERSET_YES_NO, ANSWERSET_YES_NO_ABSTAIN or ANSWERSET_YES_NO_ABSTAIN_DNPV for applicable values.

See Also

VOTE_INFO Structure


VoteTemplateId Field

VOTE_INFO..::..VoteTemplateId Field
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public VoteTemplateId As Integer
C#
public int VoteTemplateId

See Also

VOTE_INFO Structure


VotingName Field

VOTE_INFO..::..VotingName Field
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The name of the vote.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public VotingName As String
C#
public string VotingName

See Also

VOTE_INFO Structure


VotingNumber Field

VOTE_INFO..::..VotingNumber Field
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Freely definable number for the vote.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public VotingNumber As String
C#
public string VotingNumber

See Also

VOTE_INFO Structure


VOTE_INFO Methods

VOTE_INFO Methods
VOTE_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VOTE_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two VOTE_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a VOTE_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display VOTE_INFO data in proper format. (Overrides ValueType..::..ToString()()()().)

See Also

VOTE_INFO Structure


Equals Method

VOTE_INFO..::..Equals Method
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Determines whether two VOTE_INFO instances are equal.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::..Object
The VOTE_INFO to compare with the current Object.

Return Value

true if the specified VOTE_INFO is equal to the current Object; otherwise, false.

See Also

VOTE_INFO Structure


GetHashCode Method

VOTE_INFO..::..GetHashCode Method
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Serves as a hash function for a VOTE_INFO type.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current VOTE_INFO.

See Also

VOTE_INFO Structure


ToString Method

VOTE_INFO..::..ToString Method
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
To display VOTE_INFO data in proper format.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()

Return Value

See Also

VOTE_INFO Structure


VOTE_INFO Operators

VOTE_INFO Operators
VOTE_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VOTE_INFO type exposes the following members.

Operators

Name | Description
Equality | Checks the equality of two VOTE_INFO structures.
Inequality | Checks the non-equality of two VOTE_INFO structures.

See Also

VOTE_INFO Structure


Equality Operator

VOTE_INFO..::..Equality Operator
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the equality of two VOTE_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    a As VOTE_INFO, _
    b As VOTE_INFO _
) As Boolean
C#
public static bool operator ==(
    VOTE_INFO a,
    VOTE_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VOTE_INFO
The first VOTE_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VOTE_INFO
The next VOTE_INFO to compare.

Return Value

true if the specified VOTE_INFO structures are the same; otherwise, false.

See Also

VOTE_INFO Structure


Inequality Operator

VOTE_INFO..::..Inequality Operator
VOTE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the non-equality of two VOTE_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    a As VOTE_INFO, _
    b As VOTE_INFO _
) As Boolean
C#
public static bool operator !=(
    VOTE_INFO a,
    VOTE_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VOTE_INFO
The first VOTE_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VOTE_INFO
The next VOTE_INFO to compare.

Return Value

true if the specified VOTE_INFO structures are not the same; otherwise, false.

See Also

VOTE_INFO Structure


VOTE_TEMPLATE_INFO Structure

VOTE_TEMPLATE_INFO Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Represents a container holding all information of a vote template.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Structure VOTE_TEMPLATE_INFO
C#
[ObfuscationAttribute]
public struct VOTE_TEMPLATE_INFO

See Also

VOTE_TEMPLATE_INFO Members


VOTE_TEMPLATE_INFO Members

VOTE_TEMPLATE_INFO Members
VOTE_TEMPLATE_INFO Structure Methods Operators Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VOTE_TEMPLATE_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two VOTE_TEMPLATE_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a VOTE_TEMPLATE_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display VOTE_TEMPLATE_INFO data in proper format. (Overrides ValueType..::..ToString()()()().)

Operators

Name | Description
Equality | Checks the equality of two VOTE_TEMPLATE_INFO structures.
Inequality | Checks the non-equality of two VOTE_TEMPLATE_INFO structures.

Fields

 | Name | Description
Public field | Description | The description of the template.
Public field | TemplateName | The name of the vote template.

See Also

VOTE_TEMPLATE_INFO Structure


VOTE_TEMPLATE_INFO Fields

VOTE_TEMPLATE_INFO Fields
VOTE_TEMPLATE_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VOTE_TEMPLATE_INFO type exposes the following members.

Fields

 | Name | Description
Public field | Description | The description of the template.
Public field | TemplateName | The name of the vote template.

See Also

VOTE_TEMPLATE_INFO Structure


Description Field

VOTE_TEMPLATE_INFO..::..Description Field
VOTE_TEMPLATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The description of the template.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Description As String
C#
public string Description

See Also

VOTE_TEMPLATE_INFO Structure


TemplateName Field

VOTE_TEMPLATE_INFO..::..TemplateName Field
VOTE_TEMPLATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The name of the vote template.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public TemplateName As String
C#
public string TemplateName

See Also

VOTE_TEMPLATE_INFO Structure


VOTE_TEMPLATE_INFO Methods

VOTE_TEMPLATE_INFO Methods
VOTE_TEMPLATE_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VOTE_TEMPLATE_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether two VOTE_TEMPLATE_INFO instances are equal. (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a VOTE_TEMPLATE_INFO type. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | To display VOTE_TEMPLATE_INFO data in proper format. (Overrides ValueType..::..ToString()()()().)

See Also

VOTE_TEMPLATE_INFO Structure


Equals Method

VOTE_TEMPLATE_INFO..::..Equals Method
VOTE_TEMPLATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Determines whether two VOTE_TEMPLATE_INFO instances are equal.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::..Object
The VOTE_TEMPLATE_INFO to compare with the current Object.

Return Value

true if the specified VOTE_TEMPLATE_INFO is equal to the current Object; otherwise, false.

See Also

VOTE_TEMPLATE_INFO Structure


GetHashCode Method

VOTE_TEMPLATE_INFO..::..GetHashCode Method
VOTE_TEMPLATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Serves as a hash function for a VOTE_TEMPLATE_INFO type.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current VOTE_TEMPLATE_INFO.

See Also

VOTE_TEMPLATE_INFO Structure


ToString Method

VOTE_TEMPLATE_INFO..::..ToString Method
VOTE_TEMPLATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
To display VOTE_TEMPLATE_INFO data in proper format.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()

Return Value

See Also

VOTE_TEMPLATE_INFO Structure


VOTE_TEMPLATE_INFO Operators

VOTE_TEMPLATE_INFO Operators
VOTE_TEMPLATE_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VOTE_TEMPLATE_INFO type exposes the following members.

Operators

Name | Description
Equality | Checks the equality of two VOTE_TEMPLATE_INFO structures.
Inequality | Checks the non-equality of two VOTE_TEMPLATE_INFO structures.

See Also

VOTE_TEMPLATE_INFO Structure


Equality Operator

VOTE_TEMPLATE_INFO..::..Equality Operator
VOTE_TEMPLATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the equality of two VOTE_TEMPLATE_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    a As VOTE_TEMPLATE_INFO, _
    b As VOTE_TEMPLATE_INFO _
) As Boolean
C#
public static bool operator ==(
    VOTE_TEMPLATE_INFO a,
    VOTE_TEMPLATE_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VOTE_TEMPLATE_INFO
The first VOTE_TEMPLATE_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VOTE_TEMPLATE_INFO
The next VOTE_TEMPLATE_INFO to compare.

Return Value

true if the specified VOTE_TEMPLATE_INFO structures are the same; otherwise, false.

See Also

VOTE_TEMPLATE_INFO Structure


Inequality Operator

VOTE_TEMPLATE_INFO..::..Inequality Operator
VOTE_TEMPLATE_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Checks the non-equality of two VOTE_TEMPLATE_INFO structures.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    a As VOTE_TEMPLATE_INFO, _
    b As VOTE_TEMPLATE_INFO _
) As Boolean
C#
public static bool operator !=(
    VOTE_TEMPLATE_INFO a,
    VOTE_TEMPLATE_INFO b
)

Parameters

a
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VOTE_TEMPLATE_INFO
The first VOTE_TEMPLATE_INFO to compare.
b
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VOTE_TEMPLATE_INFO
The next VOTE_TEMPLATE_INFO to compare.

Return Value

true if the specified VOTE_TEMPLATE_INFO structures are not the same; otherwise, false.

See Also

VOTE_TEMPLATE_INFO Structure


VoteDataChangedEventArgs Class

VoteDataChangedEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Provides data for a VoteStore, VoteUpdate or VoteDeletion event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class VoteDataChangedEventArgs _
    Inherits ConfigChangedEventArgs
C#
[ObfuscationAttribute]
public class VoteDataChangedEventArgs : ConfigChangedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ConfigChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VoteDataChangedEventArgs

See Also

VoteDataChangedEventArgs Members


VoteDataChangedEventArgs Members

VoteDataChangedEventArgs Members
VoteDataChangedEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VoteDataChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | VoteDataChangedEventArgs()()()() | Default constructor...
Public method | VoteDataChangedEventArgs(array<Int32>[]()[][], array<Int32>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)
Public property | SessionIds | The identifiers for the sessions having changes to their voting scripts applied.

See Also

VoteDataChangedEventArgs Class


VoteDataChangedEventArgs Constructor

VoteDataChangedEventArgs Constructor
VoteDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | VoteDataChangedEventArgs()()()() | Default constructor...
Public method | VoteDataChangedEventArgs(array<Int32>[]()[][], array<Int32>[]()[][]) | Constructor...

See Also

VoteDataChangedEventArgs Class
VoteDataChangedEventArgs Members


VoteDataChangedEventArgs Constructor

VoteDataChangedEventArgs Constructor
VoteDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Default constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VoteDataChangedEventArgs()

See Also

VoteDataChangedEventArgs Class
VoteDataChangedEventArgs Overload


VoteDataChangedEventArgs Constructor (Int32[], Int32[])

VoteDataChangedEventArgs Constructor (array<Int32>[]()[][], array<Int32>[]()[][])
VoteDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    voteIds As Integer(), _
    sessionIds As Integer() _
)
C#
public VoteDataChangedEventArgs(
    int[] voteIds,
    int[] sessionIds
)

Parameters

voteIds
Type: array< System..::..Int32 >[]()[][]
The identifiers of the vote changed. Use ConfigIds to retrieve.
sessionIds
Type: array< System..::..Int32 >[]()[][]
The identifiers for the sessions having changes to their voting scripts applied.

See Also

VoteDataChangedEventArgs Class
VoteDataChangedEventArgs Overload


VoteDataChangedEventArgs Methods

VoteDataChangedEventArgs Methods
VoteDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VoteDataChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

VoteDataChangedEventArgs Class


VoteDataChangedEventArgs Properties

VoteDataChangedEventArgs Properties
VoteDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VoteDataChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)
Public property | SessionIds | The identifiers for the sessions having changes to their voting scripts applied.

See Also

VoteDataChangedEventArgs Class


SessionIds Property

VoteDataChangedEventArgs..::..SessionIds Property
VoteDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The identifiers for the sessions having changes to their voting scripts applied.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SessionIds As Integer()
    Get
C#
public int[] SessionIds { get; }

See Also

VoteDataChangedEventArgs Class


VoteTemplateDataChangedEventArgs Class

VoteTemplateDataChangedEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Provides data for a VoteTemplateStore, VoteTemplateUpdate or VoteTemplateDeletion event.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class VoteTemplateDataChangedEventArgs _
    Inherits ConfigChangedEventArgs
C#
[ObfuscationAttribute]
public class VoteTemplateDataChangedEventArgs : ConfigChangedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..ConfigChangedEventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VoteTemplateDataChangedEventArgs

See Also

VoteTemplateDataChangedEventArgs Members


VoteTemplateDataChangedEventArgs Members

VoteTemplateDataChangedEventArgs Members
VoteTemplateDataChangedEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VoteTemplateDataChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | VoteTemplateDataChangedEventArgs()()()() | Default constructor...
Public method | VoteTemplateDataChangedEventArgs(array<Int32>[]()[][]) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)

See Also

VoteTemplateDataChangedEventArgs Class


VoteTemplateDataChangedEventArgs Constructor

VoteTemplateDataChangedEventArgs Constructor
VoteTemplateDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | VoteTemplateDataChangedEventArgs()()()() | Default constructor...
Public method | VoteTemplateDataChangedEventArgs(array<Int32>[]()[][]) | Constructor...

See Also

VoteTemplateDataChangedEventArgs Class
VoteTemplateDataChangedEventArgs Members


VoteTemplateDataChangedEventArgs Constructor

VoteTemplateDataChangedEventArgs Constructor
VoteTemplateDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Default constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VoteTemplateDataChangedEventArgs()

See Also

VoteTemplateDataChangedEventArgs Class
VoteTemplateDataChangedEventArgs Overload


VoteTemplateDataChangedEventArgs Constructor (Int32[])

VoteTemplateDataChangedEventArgs Constructor (array<Int32>[]()[][])
VoteTemplateDataChangedEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    voteTemplateIds As Integer() _
)
C#
public VoteTemplateDataChangedEventArgs(
    int[] voteTemplateIds
)

Parameters

voteTemplateIds
Type: array< System..::..Int32 >[]()[][]
The identifiers of the vote templates changed. Use ConfigIds to retrieve.

See Also

VoteTemplateDataChangedEventArgs Class
VoteTemplateDataChangedEventArgs Overload


VoteTemplateDataChangedEventArgs Methods

VoteTemplateDataChangedEventArgs Methods
VoteTemplateDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VoteTemplateDataChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

VoteTemplateDataChangedEventArgs Class


VoteTemplateDataChangedEventArgs Properties

VoteTemplateDataChangedEventArgs Properties
VoteTemplateDataChangedEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VoteTemplateDataChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConfigIds | The target identifiers of the specific configuration data changed. (Inherited from ConfigChangedEventArgs.)

See Also

VoteTemplateDataChangedEventArgs Class


VOTING_TIMER_INFO Structure

VOTING_TIMER_INFO Structure
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Contains the voting time left

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Structure VOTING_TIMER_INFO
C#
[SerializableAttribute]
[ObfuscationAttribute]
public struct VOTING_TIMER_INFO

See Also

VOTING_TIMER_INFO Members


VOTING_TIMER_INFO Members

VOTING_TIMER_INFO Members
VOTING_TIMER_INFO Structure Methods Fields See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VOTING_TIMER_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Fields

 | Name | Description
Public field | VotingTimeLeft | The time left of the voting.

See Also

VOTING_TIMER_INFO Structure


VOTING_TIMER_INFO Fields

VOTING_TIMER_INFO Fields
VOTING_TIMER_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VOTING_TIMER_INFO type exposes the following members.

Fields

 | Name | Description
Public field | VotingTimeLeft | The time left of the voting.

See Also

VOTING_TIMER_INFO Structure


VotingTimeLeft Field

VOTING_TIMER_INFO..::..VotingTimeLeft Field
VOTING_TIMER_INFO Structure See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
The time left of the voting.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public VotingTimeLeft As Long
C#
public long VotingTimeLeft

See Also

VOTING_TIMER_INFO Structure


VOTING_TIMER_INFO Methods

VOTING_TIMER_INFO Methods
VOTING_TIMER_INFO Structure See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VOTING_TIMER_INFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

VOTING_TIMER_INFO Structure


VotingAnswerSetType Enumeration

VotingAnswerSetType Enumeration
See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Voting answer set type

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Enumeration VotingAnswerSetType
C#
[ObfuscationAttribute]
public enum VotingAnswerSetType

Members

Member name | Value | Description
Invalid | 0 | Invalid voting answer set.
ParliamentaryYesNo | 1 | Voting answer set will be Yes / No.
ParliamentaryYesNoAbstain | 2 | Voting answer set will be Yes / No / Abstain.
ParliamentaryYesNoAbstainDnpv | 3 | Voting answer set will be Yes / No/ Abstain / Dnpv.
AudienceResponse | 4 | Voting answer set will be -- / - / 0 / + / ++.
OpinionPoll | 5 | Voting answer set will be 1 / 2 / 3 / 4 / 5

See Also

Bosch.Dcn.Ecpc.Client.Api.Interfaces Namespace
Copyright (c) 2014 Bosch Security Systems B.V.4.30.0011


VotingTimerControlEventArgs Class

VotingTimerControlEventArgs Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Placeholder to contain the vote time left event argument

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Class VotingTimerControlEventArgs _
    Inherits EventArgs
C#
[ObfuscationAttribute]
public class VotingTimerControlEventArgs : EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VotingTimerControlEventArgs

See Also

VotingTimerControlEventArgs Members


VotingTimerControlEventArgs Members

VotingTimerControlEventArgs Members
VotingTimerControlEventArgs Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VotingTimerControlEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | VotingTimerControlEventArgs()()()() | Constructor...
Public method | VotingTimerControlEventArgs(VOTING_TIMER_INFO) | Constructor...

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | VotingTimer | Contains the voting time left.

See Also

VotingTimerControlEventArgs Class


VotingTimerControlEventArgs Constructor

VotingTimerControlEventArgs Constructor
VotingTimerControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

Overload List

 | Name | Description
Public method | VotingTimerControlEventArgs()()()() | Constructor...
Public method | VotingTimerControlEventArgs(VOTING_TIMER_INFO) | Constructor...

See Also

VotingTimerControlEventArgs Class
VotingTimerControlEventArgs Members


VotingTimerControlEventArgs Constructor

VotingTimerControlEventArgs Constructor
VotingTimerControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VotingTimerControlEventArgs()

See Also

VotingTimerControlEventArgs Class
VotingTimerControlEventArgs Overload


VotingTimerControlEventArgs Constructor (VOTING_TIMER_INFO)

VotingTimerControlEventArgs Constructor (VOTING_TIMER_INFO)
VotingTimerControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Constructor...

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    votingTimer As VOTING_TIMER_INFO _
)
C#
public VotingTimerControlEventArgs(
    VOTING_TIMER_INFO votingTimer
)

Parameters

votingTimer
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VOTING_TIMER_INFO
Represents voting time left in Millis.

See Also

VotingTimerControlEventArgs Class
VotingTimerControlEventArgs Overload


VotingTimerControlEventArgs Methods

VotingTimerControlEventArgs Methods
VotingTimerControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VotingTimerControlEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

VotingTimerControlEventArgs Class


VotingTimerControlEventArgs Properties

VotingTimerControlEventArgs Properties
VotingTimerControlEventArgs Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The VotingTimerControlEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | VotingTimer | Contains the voting time left.

See Also

VotingTimerControlEventArgs Class


VotingTimer Property

VotingTimerControlEventArgs..::..VotingTimer Property
VotingTimerControlEventArgs Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Contains the voting time left.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VotingTimer As VOTING_TIMER_INFO
    Get
C#
public VOTING_TIMER_INFO VotingTimer { get; }

See Also

VotingTimerControlEventArgs Class


VotingTimerControlEventHandler Delegate

VotingTimerControlEventHandler Delegate
See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Event handler for a voting time left change events.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Delegate Sub VotingTimerControlEventHandler ( _
    sender As Object, _
    e As VotingTimerControlEventArgs _
)
C#
[ObfuscationAttribute]
public delegate void VotingTimerControlEventHandler(
    Object sender,
    VotingTimerControlEventArgs e
)

Parameters

sender
Type: System..::..Object
The source of the event
e
Type: Bosch.Dcn.Ecpc.Client.Api.Interfaces..::..VotingTimerControlEventArgs
A VotingTimerControlEventArgs that contains the event data

See Also

Bosch.Dcn.Ecpc.Client.Api.Interfaces Namespace
Copyright (c) 2014 Bosch Security Systems B.V.4.30.0011


WEB_STREAMING_LICENSE Enumeration

WEB_STREAMING_LICENSE Enumeration
See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Modes for the webcast internet streaming license.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Interfaces
Assembly: Bosch.Dcn.Ecpc.Client.Api.Interfaces (in Bosch.Dcn.Ecpc.Client.Api.Interfaces.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
<ObfuscationAttribute> _
Public Enumeration WEB_STREAMING_LICENSE
C#
[FlagsAttribute]
[ObfuscationAttribute]
public enum WEB_STREAMING_LICENSE

Members

Member name | Value | Description
None | 0 | No license
WA | 1 | License is available for webcast internet streaming.
WAEC | 2 | License is available for webcast and 1 extra channels.
WA2EC | 3 | License is available for webcast and 2 extra channels.

See Also

Bosch.Dcn.Ecpc.Client.Api.Interfaces Namespace
Copyright (c) 2014 Bosch Security Systems B.V.4.30.0011


Bosch.Dcn.Ecpc.Client.Api.Logic Namespace

Bosch.Dcn.Ecpc.Client.Api.Logic Namespace
[image]

Bosch DCN Conference Software Application Programmable Interface
This namespace contains all business logic components of the DCN-SW API.

Use the DcnApi class to start using the DCN-SW API.

Classes

 | Class | Description
Public class | DcnApi | Main class for obtaining a reference to the DCN-SW API entry point IApi.
Public class | DcnApiObject | Represents an object version of DcnApi DCN-SW API entry point.

Interfaces

 | Interface | Description
Public interface | IDcnApiObject | Interop interface for the object version of DcnApi DCN-SW API entry point.


DcnApi Class

DcnApi Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Main class for obtaining a reference to the DCN-SW API entry point IApi.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Logic
Assembly: Bosch.Dcn.Ecpc.Client.Api.Logic (in Bosch.Dcn.Ecpc.Client.Api.Logic.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public NotInheritable Class DcnApi
C#
[ObfuscationAttribute]
public static class DcnApi

Inheritance Hierarchy

System..::..Object
Bosch.Dcn.Ecpc.Client.Api.Logic..::..DcnApi

See Also

DcnApi Members
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace


DcnApi Members

DcnApi Members
DcnApi Class Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DcnApi type exposes the following members.

Properties

Name | Description
ConfigApi | Returns a reference to the configuration interface of the DCN-SW API.
ControlApi | Returns a reference to the control interface of the DCN-SW API.

See Also

DcnApi Class
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace


DcnApi Properties

DcnApi Properties
DcnApi Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DcnApi type exposes the following members.

Properties

Name | Description
ConfigApi | Returns a reference to the configuration interface of the DCN-SW API.
ControlApi | Returns a reference to the control interface of the DCN-SW API.

See Also

DcnApi Class
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace


ConfigApi Property

DcnApi..::..ConfigApi Property
DcnApi Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Returns a reference to the configuration interface of the DCN-SW API.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Logic
Assembly: Bosch.Dcn.Ecpc.Client.Api.Logic (in Bosch.Dcn.Ecpc.Client.Api.Logic.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ConfigApi As IConfigApi
    Get
C#
public static IConfigApi ConfigApi { get; }

Field Value

A reference to the requested DCN-SW API configuration interface, or null if the type is not supported.

See Also

DcnApi Class
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace


ControlApi Property

DcnApi..::..ControlApi Property
DcnApi Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Returns a reference to the control interface of the DCN-SW API.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Logic
Assembly: Bosch.Dcn.Ecpc.Client.Api.Logic (in Bosch.Dcn.Ecpc.Client.Api.Logic.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ControlApi As IControlApi
    Get
C#
public static IControlApi ControlApi { get; }

Field Value

A reference to the requested DCN-SW API configuration interface, or null if the type is not supported.

See Also

DcnApi Class
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace


DcnApiObject Class

DcnApiObject Class
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Represents an object version of DcnApi DCN-SW API entry point.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Logic
Assembly: Bosch.Dcn.Ecpc.Client.Api.Logic (in Bosch.Dcn.Ecpc.Client.Api.Logic.dll)

Syntax

Visual Basic (Declaration)
<ClassInterfaceAttribute(ClassInterfaceType.None)> _
<ObfuscationAttribute> _
Public NotInheritable Class DcnApiObject _
    Implements IDcnApiObject
C#
[ClassInterfaceAttribute(ClassInterfaceType.None)]
[ObfuscationAttribute]
public sealed class DcnApiObject : IDcnApiObject

Remarks

Specifically intended for interop purposes!

Inheritance Hierarchy

System..::..Object
Bosch.Dcn.Ecpc.Client.Api.Logic..::..DcnApiObject

See Also

DcnApiObject Members
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace


DcnApiObject Members

DcnApiObject Members
DcnApiObject Class Constructors Methods Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DcnApiObject type exposes the following members.

Constructors

 | Name | Description
Public method | DcnApiObject | Creates an instance of DcnApiObject.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigApi | See ConfigApi.
Public property | ControlApi | See ControlApi.

See Also

DcnApiObject Class
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace


DcnApiObject Constructor

DcnApiObject Constructor
DcnApiObject Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Creates an instance of DcnApiObject.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Logic
Assembly: Bosch.Dcn.Ecpc.Client.Api.Logic (in Bosch.Dcn.Ecpc.Client.Api.Logic.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DcnApiObject()

See Also

DcnApiObject Class
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace


DcnApiObject Methods

DcnApiObject Methods
DcnApiObject Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DcnApiObject type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

DcnApiObject Class
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace


DcnApiObject Properties

DcnApiObject Properties
DcnApiObject Class See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The DcnApiObject type exposes the following members.

Properties

 | Name | Description
Public property | ConfigApi | See ConfigApi.
Public property | ControlApi | See ControlApi.

See Also

DcnApiObject Class
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace


ConfigApi Property

DcnApiObject..::..ConfigApi Property
DcnApiObject Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
See ConfigApi.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Logic
Assembly: Bosch.Dcn.Ecpc.Client.Api.Logic (in Bosch.Dcn.Ecpc.Client.Api.Logic.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConfigApi As IConfigApi
    Get
C#
public IConfigApi ConfigApi { get; }

Field Value

See ConfigApi.

Implements

IDcnApiObject..::..ConfigApi

See Also

DcnApiObject Class
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace


ControlApi Property

DcnApiObject..::..ControlApi Property
DcnApiObject Class See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
See ControlApi.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Logic
Assembly: Bosch.Dcn.Ecpc.Client.Api.Logic (in Bosch.Dcn.Ecpc.Client.Api.Logic.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ControlApi As IControlApi
    Get
C#
public IControlApi ControlApi { get; }

Field Value

See ControlApi.

Implements

IDcnApiObject..::..ControlApi

See Also

DcnApiObject Class
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace


IDcnApiObject Interface

IDcnApiObject Interface
Members See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
Interop interface for the object version of DcnApi DCN-SW API entry point.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Logic
Assembly: Bosch.Dcn.Ecpc.Client.Api.Logic (in Bosch.Dcn.Ecpc.Client.Api.Logic.dll)

Syntax

Visual Basic (Declaration)
<ObfuscationAttribute> _
Public Interface IDcnApiObject
C#
[ObfuscationAttribute]
public interface IDcnApiObject

See Also

IDcnApiObject Members
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace


IDcnApiObject Members

IDcnApiObject Members
IDcnApiObject Interface Properties See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDcnApiObject type exposes the following members.

Properties

 | Name | Description
Public property | ConfigApi | See ConfigApi.
Public property | ControlApi | See ControlApi.

See Also

IDcnApiObject Interface
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace


IDcnApiObject Properties

IDcnApiObject Properties
IDcnApiObject Interface See Also
[image] [image]

Bosch DCN Conference Software Application Programmable Interface

The IDcnApiObject type exposes the following members.

Properties

 | Name | Description
Public property | ConfigApi | See ConfigApi.
Public property | ControlApi | See ControlApi.

See Also

IDcnApiObject Interface
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace


ConfigApi Property

IDcnApiObject..::..ConfigApi Property
IDcnApiObject Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
See ConfigApi.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Logic
Assembly: Bosch.Dcn.Ecpc.Client.Api.Logic (in Bosch.Dcn.Ecpc.Client.Api.Logic.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ConfigApi As IConfigApi
    Get
C#
IConfigApi ConfigApi { get; }

Field Value

See ConfigApi.

See Also

IDcnApiObject Interface
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace


ControlApi Property

IDcnApiObject..::..ControlApi Property
IDcnApiObject Interface See Also
[image]

Bosch DCN Conference Software Application Programmable Interface
See ControlApi.

Namespace: Bosch.Dcn.Ecpc.Client.Api.Logic
Assembly: Bosch.Dcn.Ecpc.Client.Api.Logic (in Bosch.Dcn.Ecpc.Client.Api.Logic.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ControlApi As IControlApi
    Get
C#
IControlApi ControlApi { get; }

Field Value

See ControlApi.

See Also

IDcnApiObject Interface
Bosch.Dcn.Ecpc.Client.Api.Logic Namespace