Introduction

 Bosch Logo

Introduction, Goals of DICENTIS network based conference system

This specification describes the DCNm API (Application Programmable Interface) for the DICENTIS network based conference system. This specification is intended to be used by developers who want to use this interface to develop a PC-based client application to control the functionality available.

Detailed information about the system, its configuration and operation can be found in DCNM-SW.pdf.

Note Note

The PDF document is available in multiple languages. See the DVD content for details.

Prepare System

Before the system can be used it needs to be prepared. Prepare system is defined as:

This section contains the following subsections:

  • Installing the hardware
  • Install the software
  • License the system
  • Update the system
  • Configure the system
  • Administrate system users
  • Test the system
  • Diagnose the system
  • Backup the configuration

A VAR is normally responsibility for Prepare system. Depending on the system size some parts of Prepare system might be outsourced to other companies. In this case these other companies are responsible for the outsourced parts.

Installing the hardware

At first the customer receives the purchased goods at their site. It is important that the installation of the system is done very efficient because a significant part of the system price is the installation costs. For large systems it might be that the devices and system parts are pre-configured / pre-wired in the VAR's workshop.

On the site an installer unpacks all system parts and visually checks the quality. In case the quality fails the products needs to be returned for replacement (DOA; RMA request). After the quality check the installer places the devices on the tabletop, in cable ducts, on walls, in racks, etc.

During this installation process cables and rack mounted devices need to be identifiable and are therefore often labeled with tags. Devices details (Type number, serial number, etc) are recorded for inventory.

After placing the devices the installer checks and tests the quality of the physical installation. If all is correct the installer is finished and leaves the site.

Install the software

When all physical devices have been installed the VAR (Technician) installs the software on all PCs used in the system. When the software is installed it starts automatically. In case the system is connected to the internet the Software installer might indicate that a newer version is available and gives the option to the VAR to download this newer version before the actual SW installation is started. If the software license maintenance period is expired no notification is given and updates cannot be downloaded.

License the system

The software="" requests the VAR to license the system. Licensing requires an internet connection which is in many cases not available on the customers site. In case the system is not connected to the internet the VAR uses his own notebook (UMTS, Internet) to license the system.

Update the system

In case updates are available the VAR updates the software and the firmware of the devices.

Configure the system

For many systems the VAR only needs to configure device properties like: chairman position, microphone, input and output sensitivities, etc. In case of a small system no configuration is needed (out of the box). In larger systems the VAR configures seats and creates synoptic layouts, room equalization, etc.

Administrate system users

In case of a larger systems it might be needed that more than one person interacts with the system. These persons might be an operator or Usher. For each of these persons the VAR needs to administrate a system user account.

Test the system

After configuration the VAR start the test to test the system. When the system test is successfully passed a report is made and given to the customer.

Diagnose the system

In case the test failed the VAR diagnoses the system to solve the errors and start the test again.

Backup the configuration

The final action is to backup the configuration.

Meet & Agenda

Typical application scenarios of having meetings

Municipal/city/regional councils.

Participants of meetings. Once in approximately 4 years members of the council are elected. Within the 4 year period members can leave the council, but in general the council remains the same. Most content is pre-discussed in committee meetings. In general all parties are represented in each committee. Depending on the size of the party the committee member have substitutes and/or advisor. Especially during committee meetings also clerks and external advisors can bring in information in the meeting. Often the speech is done from a rostrum.

Identification

For most meetings identification is not necessary for the participants in the meeting: all participants know each other. Though for broadcasting purposes, screen-lines on hall displays and for indexing of recordings it is desired to know who is speaking when. For this purpose identification is desired in these applications. As (especially in the plenary meeting room) normally each participant has a fixed seat, identification is defined by the seat, except when a participant needs to go to the rostrum position.

Note Note

large parliaments identification with all kind of measures to prevent fraud (e.g. fingerprint reading, external contact) is desired, as it is less visible if someone votes on two or more Seats and the decisions have larger consequences (thus more vulnerable for bribes and fraud).

In some meetings identification is needed because the chairperson needs to have the possibility to take any seat. In this case the seat must have all capabilities needed by the chairperson.

Schedule

The schedule for the meetings is announced in general long before the meetings take place. The schedule is determined long on forehand, although ad hoc meetings can be planned in case highly political issues arise.

Agenda

The agenda of the meeting is similar for recurring meetings (e.g. budget meeting).

Openness

Depending on the country culture and the subject, the plenary and committee meetings are open for the public and/or broadcasted and web streamed to the inhabitants. Voting is in general done in all openness (so that inhabitants know what their representatives have voted). Exceptions are voting (election voting) on persons, which are almost always “secret voting”.

Discussions

Discussions take place in a certain format. E.g. normally every speech is directed to the “chairperson”. The chairperson also announces who is the next speaker. Further e.g. during a budget discussion, every party can provide their main statements (first round / “termijn”), then comment on it (second round) and then comment on the comment (third round), ….The chairperson determines the amount of rounds and how to come to a conclusion. In case needed the discussion can end with a voting. The voting is not always processed in a electronic way, in case the chairperson has the feeling everybody agrees, he will say something like “in case nobody objects, I propose to approve the proposal” and the proposal will be approved without having a electronic voting. Sometimes the voting is done by raising hands(as example refer to the AIIC meeting). The chairperson/Meeting secretary will make notes of the Voting results.

Keeping time

In order to keep the time for the agenda, normally a maximum time is given to each speaker. The time can be set per round, per party, per member, etceteras. The chairperson can also decide to adjust the time.

Place of speech

Depending on the country, there can be different places to speak. E.g. for short interruptions from the seat and for longer speeches from the rostrum. Therefore there is also a distinction between the difference kind of “requests to speak”. Furthermore on forehand a member of the council (or in some cases also a clerk, inhabitant, or expert) can request time to speak.

Voting

Depending on the culture, many or only a few votings are done per year.

E.g. in the Netherlands in general the party specialist on a certain topic is authorized by his party to decide on their vote on a certain subject. Hardly any topic is done by electronic voting as hardly never every member needs to vote (only on personal matters or highly political issues).

In Italy & Spain in contrary it is custom to vote personally on each issue and motion. In Spain it is common to have voting sessions, the total votings held can be more than 100 votings sequentially. In this case a voting takes about 10 seconds before the next one is started.

Quorum

Quorum defines if the chairperson starts a voting.

Rules

In general the rules around how to discuss, how to vote and how a meeting should take place are described. For each council in a country this can be different. The rules around voting can even differ largely upon the topic on which a decision should take place. E.g. in case a voting should take place on a person who is relative of one of the members, he might not be allowed to vote. Furthermore the voting might not take place in case a certain percentage (and/or amount) of people attend the meeting. For some issues the chairperson/ “major" are allowed to vote and for some issues not.

Multipurpose room

Depending on the country and the building, the meeting rooms are also used for other purposes. This can be other type of meetings, weddings, performances, etcetera. For some of these happenings the conference systems can be useful and for some it is highly desired that the equipment is taken away or at least unobtrusive. Some organizations choose to keep the infrastructure in place and take away the units on the tables away.

Bosch Security Systems

(c) Bosch Security System B.V., 2025


License

Bosch License Statement of use

This topic contains the following sections:

  • SOFTWARE LICENSE FOR UNITED STATES OF AMERICA, CANADA, MEXICO, BRAZIL, ARGENTINA, PARAGUAY, URUGUAY, VENEZUELA, COLOMBIA AND ECUADOR
  • Software license for Russia
  • SOFTWARE LICENSE FOR ANY OTHER COUNTRY
  • Software maintenance Agreement
SOFTWARE LICENSE FOR UNITED STATES OF AMERICA, CANADA, MEXICO, BRAZIL, ARGENTINA, PARAGUAY, URUGUAY, VENEZUELA, COLOMBIA AND ECUADOR

STOP!

PLEASE READ THE FOLLOWING TERMS AND CONDITIONS CAREFULLY

IF YOU DO NOT AGREE WITH THESE TERMS AND CONDITIONS, DO NOT REGISTER THE AUTHORIZATION CODES MENTIONED IN THIS DOCUMENT, INSTEAD, PROMPTLY REMOVE AND DELETE THIS DOCUMENT AND ASK FOR A FULL REFUND AT YOUR SUPPLIER.

BOSCH SECURITY SYSTEMS B.V. LICENSE AGREEMENT FOR SOFTWARE

Bosch Security Systems B.V. (hereinafter referred to as “Bosch") licenses this computer program and all associated documentation (the “Software”) for your non-exclusive use subject to the following terms and conditions:

  1. LICENSE - Under the terms of this license:

    • You may use the Software only on a single computer at a time and only for the operation of Bosch products.

    • You may not modify, decompile, disassemble or reverse engineer the Software.

    • You may, not sublicense, lease or otherwise rent the Software without Bosch 's prior written consent.

    • You may make one copy of the Software solely for backup or archival purposes. No other copying of the Software or the accompanying documentation is permitted.

    • This license will terminate automatically if you fail at any time to comply with any of its terms or conditions. Upon termination, you shall immediately destroy the Software or return it to Bosch along with any copies you have made, and to delete any installed copy from your hardware.

  2. TRANSFER OF OWNERSHIP - You may transfer this license to another party only if you:

    • Also transfer this Agreement, the Software and all accompanying documentation and (by sale or lease) ownership of the associated Bosch hardware, if applicable

    • Require the other party to abide by the terms of this license agreement, and

    • Destroy all copies of the Software and any updates that you do not transfer to the other party.

  3. OWNERSHIP AND COPYRIGHT OF THE SOFTWARE - Although the media containing the Software is yours, the Software is owned and copyrighted by Bosch and/or its suppliers. You may not remove, change or delete the copyright notice from the Software. The Software contains confidential and trade secret information of Bosch. You will instruct your employees and others having access to the Software in and ensure their compliance with the terms of this agreement. You will use your best efforts to prevent any unauthorized copying of the Software.

  4. Updated: Bosch will be entitled to update and/or modify the Licensed Software.

  5. Responcibility for Webcasting

    You will be exclusively responsible for any liability arising from unauthorized access or alteration to the Webcast Data or Content. You will also be responsible for any liability arising from any material or data which has been Webcast that includes any threatening, defamatory, obscene, offensive or illegal material or any material which infringes any person's intellectual property rights. Except as expressly otherwise stated in the Agreement, we will not be responsible for any liability arising from the failure to Webcast any material or data.

  6. Purpose of Transmission

    • You will use the Services and Equipment only as may be lawful and for lawful purposes

    • So far as permitted by law and save as expressly herein set out you will not have and you waive and assign to us all and any rights relating to our Website the Hardware and the Software and/or any code and/or the names or designations thereof.

  7. Consent

    You will obtain the consent of any person to be filmed or Webcast, or, in the case of minor children, obtain the consent of their parent or guardian.

  8. Reproduction of the Content

    You will not copy or reproduce the Content or the Webcast Data on to any other server or location for further reproduction without our prior written consent, which will not be unreasonably withheld. However, you may provide third parties with links to the Webcasts so that they can view them.

  9. TAXES - must pay all taxes that may now or hereafter be imposed, levied, or assessed with respect to the possession or use of the Software or this license. You shall file all reports required in connection with such taxes.

  10. WARRANTY, LIMITATION OF LIABILITY, REMEDIES - THE SOFTWARE IS PROVIDED “AS IS” WITHOUT WARRANTY OR CONDITION OF ANY KIND INCLUDING WARRANTIES FOR MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. NEITHER BOSCH NOR ITS SUPPLIERS SHALL BE LIABLE FOR ANY LOSS OF PROFITS, LOSS OF USE, INTERRUPTION OF BUSINESS, LOSS OF DATA, NOR FOR INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY KIND WHETHER UNDER THIS AGREEMENT OR OTHERWISE, OR FOR ANY CLAIM BY ANY OTHER PARTY.

    Bosch does not warrant the functions provided by the Software. However, Bosch warrants the media on which the Software is furnished to be free from defects in materials and workmanship under normal use for a period of 90 days from the date of original purchase. Bosch's entire liability to you, and your exclusive remedy, shall be the replacement of the media containing the Software not meeting Bosch's warranty, provided you return the same to Bosch. The replacement will be warranted for the remainder of the term of the original warranty or 30 days, whichever is longer. You assume responsibility for the selection of the Software to achieve your intended results, and for the installation, use and results obtained from the Software.

  11. U.S. GOVERNMENT RESTRICTED RIGHTS - The Software is provided with restricted rights. Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at 52.227-7013 or its successor.

  12. EXPORT LAWS, APPLICABLE LAW - The deliveries and services (fulfillment of contract) are under the proviso that their fulfillment is not contrary to the compliance with national or international regulations, especially export control regulations, embargoes or other sanctions. The contract parties commit themselves to supply all necessary information and documents needed for the export / transfer to other EU member states / import. Delays due to export control assessments or export control licensing procedures invalidate terms and dates of delivery. When licenses are not granted respectively the delivery and service is not licensable, this contract becomes void regarding to the affected parts. Claims for damages resulting from the above mentioned reasons and from mentioned delivery delays are excluded.

    The customer commits himself to comply with all relevant export control regulations in case of resale or onward delivery, i.e. all national regulations or EC regulations as well as US regulations). The resale or onward delivery of listed commodities (products, software and technology), the resale to embargoed countries or to blocked persons, organizations or companies or to consignees which use the commodities for a military end-use, for nuclear, biological or chemical weapons or nuclear technology could require an export license. The reseller or the customer who makes the onward delivery has to apply for the necessary licenses.

    The customer should note that the US export control law is also applicable when the commodities are completely or only partly originated in the USA. This can also be the case if the components are of US origin although the contract has no other reference to the USA.

    Infringements of the rules of law are subject to contract annulation.

  13. If any terms or conditions of this Agreement are declared illegal, null or void or for any other reason considered non-applicable, such terms or conditions will be considered eliminated or non-existing in the Agreement and will not affect the validity and applicability of the other terms and conditions.

  14. This Agreement shall exclusively be governed by the laws of The Netherlands.

Software license for Russia

ВНИМАНИЕ!

ВНИМАТЕЛЬНО ПРОЧТИТЕ СЛЕДУЮЩИЕ УСЛОВИЯ

ЕСЛИ ВЫ НЕ СОГЛАСНЫ С ДАННЫМИ УСЛОВИЯМИ, НЕ РЕГИСТРИРУЙТЕ КОДЫ АВТОРИЗАЦИИ, УПОМИНАЕМЫЕ В ДАННОМ ДОКУМЕНТЕ, ВМЕСТО ЭТОГО СВОЕВРЕМЕННО УДАЛИТЕ И УНИЧТОЖЬТЕ ДАННЫЙ ДОКУМЕНТ И ОБРАТИТЕСЬ К ПОСТАВЩИКУ ЗА ПОЛНЫМ ВОЗМЕЩЕНИЕМ УПЛАЧЕННОЙ ЗА НЕГО СУММЫ. Использование данного Программного обеспечения означает, что вы принимаете указанные ниже условия.

BOSCH SECURITY SYSTEMS B.V. ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ НА ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ

Программное обеспечение, устанавливаемое в настоящий момент (именуемое в дальнейшем «Лицензионное программное обеспечение»), разработано Bosch Security Systems B.V. (именуемой в дальнейшем «Bosch»). Bosch предлагает Конечному пользователю лицензию для его использования на указанных ниже условиях. Регистрация кодов авторизации Лицензионного программного обеспечения и (или) использование Лицензионного программного обеспечения означает, что Конечный пользователь принимает условия настоящего лицензионного соглашения с Конечным пользователем (именуемого в дальнейшем «настоящее Соглашение»), в частности, Конечный пользователь принимает следующие условия.

  1. Определения

    Соглашение:

    настоящее лицензионное соглашение на программное обеспечение.

    Bosch:

    Bosch Security Systems B.V.

    Содержимое:

    весь добавляемый и транслируемый материал.

    Конечный пользователь:

    физическое или юридическое лицо, для которого предназначено программное обеспечение или оборудование. Этот термин основан на том, что назначение программного продукта или оборудования может быть полезно для клиента. Конечного пользователя можно противопоставить разработчикам и программистам продукта. Конечные пользователи также находятся в группе, отдельной от установщиков или администраторов продукта. (http://www.techterms.com/definition/enduser).

    Оборудование:

    инструменты и другие элементы, необходимые для выполнения конкретной операции или задачи.

    Лицензионное программное обеспечение:

    программное обеспечение, для работы которого требуется легальный код авторизации.

    Услуги:

    нематериальные продукты, такие как хранение и распространение информации и содержимого.

    Данные веб-трансляции:

    содержимое веб-трансляции.

    Веб-трансляция:

    веб-трансляция представляет собой мультимедийную презентацию, которая распространяется через Интернет с использованием технологии потоковой передачи мультимедийных данных для одновременной трансляции одного исходного содержимого нескольким слушателям или зрителям. Веб-трансляция может распространяться в режиме реального времени или по требованию. Веб-трансляция главным образом передается через Интернет.

  2. Авторские права

    Лицензионное программное обеспечение является интеллектуальной собственностью Bosch, которой принадлежат все соответствующие авторские права. Bosch сохраняет за собой навсегда право собственности Лицензионного программного обеспечения.

  3. Право на использование

    Конечный пользователь получает персональное неисключительное право на использование Лицензионного программного обеспечения только при условии его использования на 1 (одном) компьютере одновременно без размещения каких-либо ссылок в сетях. Bosch также сохраняет за собой все права, не переданные явным образом Конечному пользователю по настоящему Соглашению.

    Конечный пользователь не вправе продавать, передавать в аренду или иное пользование Лицензионное программное обеспечение или иным образом передавать или уступать права на его использование. Конечный пользователь не вправе декомпилировать, разбирать, осуществлять обратную разработку или каким-либо образом изменять программный код без предварительного письменного согласия Bosch. Несанкционированное копирование Лицензионного программного обеспечения запрещено в прямой форме.

  4. Гарантия

    Bosch гарантирует, что Лицензионное программное обеспечение будет функционировать в значительной мере в соответствии со всей доступной документацией, поставляемой с этой или с предыдущими версиями Лицензионного программного обеспечения. Bosch не делает никакие дополнительные заявления и не предоставляет никакие дополнительные гарантии (явные или подразумеваемые), в том числе, среди прочего, относительно пригодности Лицензионного программного обеспечения для продажи и соответствия другим конкретным целям, отсутствия ошибок в Лицензионном программном обеспечении, а также, что в результате использования Лицензионного программного обеспечения или любых его копий не нарушаются права на интеллектуальную или промышленную собственность (например, патенты, авторские права или товарные знаки) третьих лиц.

  5. Обновления

    Bosch имеет право обновлять и (или) модифицировать Лицензионное программное обеспечение.

  6. Цель передачи

    Принимая условия настоящего соглашения, вы в явной форме подтверждаете свое согласие и обязуетесь использовать Лицензионное программное обеспечение, Услуги и Оборудование только для целей, для которых они предназначены, в соответствии с применимыми (местными) законами и нормативными актами. Вы не вправе привлекать к ответственности Bosch за убытки или претензии в связи с незаконным и (или) запрещенным использованием Лицензионного программного обеспечения, Услуг и (или) Оборудования и должны оградить компанию Bosch от любых подобных претензий, возникших в результате таких действий (например, от третьих лиц). Если установка или использование Лицензионного программного обеспечения, Услуг или Оборудования ведет к получению вами каких-либо прав, считается, что вы отказались от этих прав и передали их Bosch, если иное не определено в явной форме в настоящем Соглашении.

  7. Ответственность за веб-трансляцию (применяется только в случае веб-трансляции)

    Вы несете полную ответственность по обязательствам, возникающим в результате несанкционированного доступа к данным или содержимому веб-трансляций, а также за их изменение. Вы также несете ответственность по обязательствам, возникающим в результате незаконной веб-трансляции материалов и данных, а также за распространение угрожающих, непристойных, клеветнических, оскорбительных или незаконных материалов или материалов, размещение которых нарушает права на интеллектуальную собственность третьих лиц. Мы не несем ответственность по обязательствам, возникающим в результате сбоев веб-трансляции материалов или данных, если иное не выражено явно в настоящем Соглашении.

  8. Согласие

    Вы должны получить согласие лица на его съемку, в случае съемки несовершеннолетних — получить согласие родителей или опекуна.

  9. Воспроизведение содержимого

    Вы не должны копировать или воспроизводить Содержимое или Данные веб-трансляции на какой-либо другой сервер или в другое место для дальнейшего воспроизведения без получения предварительного письменного согласия, в предоставлении которого может быть отказано только при наличии разумныъх причин. Тем не менее, вы вправе предоставлять третьим лицам ссылки на веб-трансляции для просмотра.

  10. Изменение настоящего Соглашения

    Изменения настоящего Соглашения действительны в случае их письменного одобрения Bosch и Конечным пользователем. Условия в отношении Конечного пользователя применяются вне зависимости от их упоминания в формах заказа или в другом виде, если иное не принято компанией Bosch в письменной форме путем дополнения настоящего Соглашения.

  11. Ограничение ответственности

    Bosch не несет перед Конечным пользователем ответственность за убытки, в том числе за упущенную выгоду, потерю сбережений или любые другие случайные или косвенные убытки Конечного пользователя, возникшие в результате использования или невозможности использования Лицензионного программного обеспечения, даже если Bosch или его представители были уведомлены заранее о возможности таких убытков или претензий от любой другой стороны. Обязательные (императивные) законные требования Конечного пользователя остаются не затронутыми.

  12. Срок действия и расторжение Соглашения

    Настоящее Соглашение вступает в силу с момента открытия Конечным пользователем пакета, содержащего Лицензионное программное обеспечение.

    Конечный пользователь имеет право расторгнуть данное Соглашение в любое время. Для этого он должен предоставить письменное заявление в Bosch в соответствии с положениями, указанными в настоящем Соглашении.

    Bosch имеет право расторгнуть данное Соглашение в любое время путем предоставления письменного уведомления Конечному пользователю, но только в том случае, если Конечный пользователь не соблюдает те или иные обязательства в рамках данного Соглашения. В случае расторжения Соглашения Конечным пользователем или компанией Bosch Конечный пользователь должен незамедлительно прекратить использование Лицензионного программного обеспечения и всех его копий, а также вернуть его Bosch или уничтожить Лицензионное программное обеспечение и все его копии. Кроме этого, Конечный пользователь должен своевременно (но не позднее, чем в течение пяти дней с момента расторжения) предоставить в компанию Bosch письменное подтверждение осуществления возврата или уничтожения Лицензионного программного обеспечения и всех его копий, а также прекращения его использования. В дополнение к этому при расторжении по причине несоблюдения обязательств Конечным пользователем Bosch сохраняет право применить любые средства защиты своих прав, которые доступны в рамках закона и по соглашению, включая право на возмещение убытков.

  13. Экспортный контроль

    В отношении поставки продуктов и предоставления услуг (выполнения соглашения) действует положение о том, что их осуществление не должно противоречить национальным и международным нормам, в частности, нормативным актам по экспортному контролю, эмбарго и другим санкциям. Стороны обязуются предоставлять всю информацию и документы, необходимые для экспорта / передачи другим государствам ЕС / импорта. При возникновении задержек в результате оценки в рамках экспортного контроля или процедуры лицензирования в рамках экспортного контроля сроки и даты поставки аннулируются. Если не предоставляются соответствующие лицензии, и в отношении поставки товаров или предоставления услуг не могут быть предоставлены лицензии , данное соглашение становится недействительным для вовлеченных сторон. Требования по возмещению убытков в результате указанных выше причин и задержек поставки исключаются.

    Клиент обязуется соблюдать все требования, связанные с экспортным контролем, в случае перепродажи или последующей поставки, то есть все национальные нормативные требования или нормативные требования ЕС, а также нормативные требования США. При перепродаже или последующей поставке перечисленных товаров (продуктов, Лицензионного программного обеспечения и технологии), перепродаже в страны, на которые наложено эмбарго, или лицам, организациям и компаниям, чьи активы заморожены, а также адресатам, которые используют товары в военных целях, для создания ядерного, биологического или химического оружия или разработки ядерных технологий, может потребоваться лицензия на экспорт. Реселлер или клиент, осуществляющий последующую поставку, должен обращаться за получением необходимых лицензий.

    Клиент также должен учитывать, что законодательство по экспортному контролю США применяется также тогда, когда товары полностью или частично произведены в США. Данное положение также может применяться, если компоненты произведены в США, но несмотря на это в соглашении отсутствуют прочие упоминания США.

    Нарушение правил, установленных законодательством, является основанием для расторжения данного Соглашения.

  14. Конфиденциальность

    Стороны обязуются обеспечивать конфиденциальность информации или данных, предоставляемых раскрывающей стороной, если получающая сторона знает или должна разумно знать, что эти данные являются секретными и (или) конфиденциальными и (или) что такое разглашение может нанести вред раскрывающей их стороне. Получающая сторона не должна раскрывать эти данные другим сторонам, не участвующим в настоящем Соглашении, кроме случаев наличия предварительного явного письменного разрешения на разглашение соответствующей информации или раскрытие осуществляется согласно требованиям закона или по требованию компетентных органов власти.

  15. Прочие условия

    Если любое положение настоящего Соглашения стало или должно стать недействительным, оно не влияет на действительность остальных положений. В таких случаях недействительное положение должно быть заменено любым другим допустимым положением, похожим по значению и цели на оригинальное положение.

    Если это явно не согласовано сторонами в письменной или иной форме в рамках данного Соглашения, срок для предъявления претензий к Bosch составляет 1 (один) год с момента получения Конечным пользователем персонального неисключительного права на использование Лицензионного программного обеспечения.

  16. Применимое законодательство

    Настоящее Соглашение регулируется правом Нидерландов исключая применение коллизионных норм.

SOFTWARE LICENSE FOR ANY OTHER COUNTRY

STOP!

PLEASE READ THE FOLLOWING TERMS AND CONDITIONS CAREFULLY

IF YOU DO NOT AGREE WITH THESE TERMS AND CONDITIONS, DO NOT REGISTER THE AUTHORIZATION CODES MENTIONED IN THIS DOCUMENT, INSTEAD, PROMPTLY REMOVE AND DISTROY THIS DOCUMENT AND ASK FOR A FULL REFUND AT YOUR SUPPLIER. By using this Software you accept the terms stated below:

BOSCH SECURITY SYSTEMS B.V. LICENSE AGREEMENT FOR SOFTWARE

The software program that is currently being installed (hereinafter referred to as “the Licensed Software") has been developed by Bosch Security Systems B.V. (hereinafter referred to as “Bosch"). Bosch hereby offers End-User a license to use it under the following terms and conditions. By registering the authorization codes of the Licensed Software and/or using the Licensed Software End-User agrees to be bound by the terms and conditions of this End-User license agreement (hereinafter referred to as "this Agreement") and more specifically End-User agrees to the following:

  1. Definitions

    Agreement:

    this license agreement for software;

    Bosch:

    Bosch Security Systems B.V.;

    Content:

    all added and broadcasted material;

    End-User:

    an end-user is the person or organization that a software program or equipment is designed for. The term is based on the idea that the "end goal" of a software or hardware product is to be useful to the consumer. The end-user can be contrasted with the developers or programmers of the product. End-users are also in a separate group from the installers or administrators of the product. (http://www.techterms.com/definition/enduser);

    Equipment

    the tools, or other items needed for a particular activity or purpose;

    Licensed Software:

    software that need a legal authorization code to work;

    Services:

    intangible products such as storage and distribution of information or content;

    Webcast Data:

    content of the webcast;

    Webcast/Webcasting:

    a webcast is a media presentation distributed over the Internet using streaming media technology to distribute a single content source to many simultaneous listeners/viewers. A webcast may either be distributed live or on demand. Essentially, webcasting is “broadcasting” over the internet.

  2. Copyright

    The Licensed Software is a proprietary product of Bosch and Bosch owns all copyrights therein. Bosch retains title and ownership of the Licensed Software at all times.

  3. Right to use

    End-User is hereby granted the personal non-exclusive right to use the Licensed Software only on and in conjunction with one (1) computer at one (1) time and without further linkups in networks and the like. Bosch also reserves all rights not expressly granted to End-User herein.

    End-User may not sell, rent or lease the Licensed Software or otherwise transfer or assign the right to use it. End-User may not decompile, disassemble, reverse engineer or in any way modify program code without the prior written consent of Bosch. Unauthorised copying of the Licensed Software is expressly forbidden.

  4. Warranty

    Bosch warrants that the Licensed Software will perform in substantial compliance with all available documentation supplied either with this or with previous versions of the Licensed Software. Bosch makes no further representations or warranties, expressly or implied, such as, by way of example but not of limitation, regarding merchantability or fitness for any particular purpose, that Licensed Software is error-free, that the use of the Licensed Software or any copies thereof will not infringe any intellectual or industrial property rights like patent, copyright or trademark of any third parties.

  5. Updates

    Bosch is always entitled to update and/or modify the Licensed Software.

  6. Purpose of transmission

    By accepting this agreement you explicitly acknowledge and oblige yourself to only use the Licensed Software, the Services and the Equipment for their intended purposes and according to the applicable (local) laws and regulations. You can never hold Bosch liable for any damage or claims in connection with illegal and/or otherwise prohibited use of the Licensed Software, the Services and/or the Equipment and shall indemnify Bosch from any claims in this respect (e.g. of third parties). If installing and use of the Licensed Software, Services and Equipment would lead to any right for you, you are deemed to waive this rights and assign them to Bosch, unless expressly stated in this Agreement otherwise.

  7. Responsibility for Webcasting (only applicable in case of webcasting)

    You will be exclusively responsible for any liability arising from unauthorized access or alteration to the Webcast Data or Content. You will also be responsible for any liability arising from any material or data which has been webcast unlawfully or that includes e.g. any threatening, defamatory, obscene, offensive or illegal material or any material which infringes any person's intellectual property rights. Except as expressly stated otherwise in this Agreement, we will not be responsible for any liability arising from the failure to webcast any material or data.

  8. Consent>

    You will obtain the consent of any person to be filmed, or, in the case of minor children, obtain the consent of their parent or guardian.

  9. Reproduction of the Content

    You will not copy or reproduce the Content or the Webcast Data on to any other server or location for further reproduction without our prior written consent, which will not be unreasonably withheld. However, you may provide third parties with links to the Webcasts so that they can view them.

  10. Changes to this Agreement

    No changes to this Agreement are valid unless with Bosch's and End-User's written approval. The terms and conditions of End-User are applicable whether or not contained in order forms or otherwise, unless specifically accepted by Bosch in writing by means of an addition to this Agreement.

  11. Limitations of liability

    Bosch shall not be liable to End-User for any damages, including any loss of profit, loss of savings or other End-User's incidental or consequential damages arising out of End-User's use or inability to use the Licensed Software, even if Bosch or its representatives have been advised of the possibility of such damages or for any claim by any other party.

  12. Validity and termination

    This Agreement shall be valid with effect as of the date End-User has opened the package containing the Licensed Software.

    End-User is entitled to terminate this Agreement at any time by simple written notice to Bosch subject to the provisions set out hereinafter.

    Bosch is entitled to terminate this Agreement by simple written notice to End-User but only in the event End-User fails to comply with any of its obligations pursuant to this Agreement. In the event of termination, whether by End-User or by Bosch, End-user shall immediately stop any use of the Licensed Software and of all copies thereof and shall return to Bosch or destroy the Licensed Software and all copies thereof and End-User shall promptly (but at the latest within five days after termination) confirm in writing to Bosch that it has returned or destroyed Licensed Software and all copies thereof and has terminated use. In addition, in the event of termination because of End-User's failure to comply with its obligations, Bosch reserves the right to invoke any and all other remedies available to it in law or contract including the right to claim damages.

  13. Export control

    The deliveries and services (fulfillment of contract) are under the proviso that their fulfillment is not contrary to the compliance with national or international regulations, especially export control regulations, embargoes or other sanctions. The contract parties commit themselves to supply all necessary information and documents needed for the export / transfer to other EU member states / import. Delays due to export control assessments or export control licensing procedures invalidate terms and dates of delivery. When licenses are not granted respectively the delivery and service is not licensable, this contract becomes void regarding to the affected parts. Claims for damages resulting from the above mentioned reasons and from mentioned delivery delays are excluded.

    The customer commits himself to comply with all relevant export control regulations in case of resale or onward delivery, i.e. all national regulations or EC regulations as well as US regulations). The resale or onward delivery of listed commodities (products, Licensed software and technology), the resale to embargoed countries or to blocked persons, organizations or companies or to consignees which use the commodities for a military end-use, for nuclear, biological or chemical weapons or nuclear technology could require an export license. The reseller or the customer who makes the onward delivery has to apply for the necessary licenses.

    The customer should note that the US export control law is also applicable when the commodities are completely or only partly originated in the USA. This can also be the case if the components are of US origin although the contract has no other reference to the USA.

    Infringements of the rules of law are subject to this agreement termination.

  14. Confidentiality

    Parties shall keep confidential any information or data provided by or on behalf of the disclosing party, which the receiving party knows or should reasonably know is secret and / or confidential and / or that disclosure may be harmful to the disclosing party. The receiving party shall not disclose this to others, not involved in the performance of the Agreement, unless the disclosing party has given explicit prior written consent to disclose the relevant information or disclosure occurs because the law or a competent authority obliges the receiving party to do so

  15. Miscellaneous

    If any provision contained in this agreement should be or become invalid, this shall not affect the remaining provisions. In such cases the invalid provision shall be replaced by a valid provision approximating as closely as possible to the sense and purpose of the original provision.

    Unless explicitly agreed otherwise by the parties in writing, or otherwise provided for in this Agreement, any claim against Bosch shall in any case expire after one (1) year from the time that End-User was granted the personal non-exclusive right to use the Licensed Software.

  16. Applicable law

    This Agreement shall exclusively be governed by the laws of The Netherlands.

Software maintenance Agreement

MAINTENANCE SERVICE LEVEL AGREEMENT

Supplement to the Software Maintenance Agreement

Bosch Security Systems B.V. ("Bosch") develops, markets and licenses software for use in Conference, Public Address, Voice Evacuation and Networked Audio systems. The Bosch Software Maintenance Agreement (the “Agreement”) sets out the terms and conditions under which Bosch will provide "Maintenance Services" for the "Software" (as defined in the Agreement).

This Service Level Agreement Supplement (the "Supplement") is a supplement to and a part of the Agreement, and sets forth the extent, detail and dependencies of the Maintenance Services to be provided by Bosch to a system integrator (“Customer”) of the software (the “Software”). The provision of Maintenance Services under the Agreement is subject to and conditioned on the terms of this Supplement.

Bosch only provides Maintenance Services on the Software to a Customer who has obtained a valid user license to the Software pursuant to the Agreement.

Terms defined in the Agreement shall have the same meaning when used in this Supplement unless otherwise expressly stated.

  • Maintenance Services. Maintenance Services include:

  • bug-fixing ("Support Services"); and

  • issuing new Releases of the Software.

  • Support.

  • Support Services are comprised of the analysis and correction of an "Error" (define below) in the Software.

  • An "Error" is a "Reproducible" (defined below) malfunction or issue in the Software that causes the Software to operate in a way that is materially different from what is described in the applicable documentation.

  • "Reproducible" means that the issue that causes the Error must re-occur when the operation and configuration of the Customer implemented version of the Software is repeated in Bosch’s support center, indicating that the issue is caused by a bug or other issue inherent to the software, rather than caused by the specific Customer environment or use.

  • In case of doubt on the Reproducible character of an issue, Bosch will normally provide Services as if the issue was reproducible (i.e. without any additional fee); provided, however, if, at any time during analysis or resolution, an issue appears to be not Reproducible, Bosch's continued resolution efforts will be subject to Customer agreeing to pay Bosch's then current fees and charges for such efforts.

  • If, on initial analysis, an issue appears not be Reproducible, Bosch may still choose to assist the Customer in finding a solution, but Bosch does not have any contractual duty to do so, and Bosch is entitled to charge additional fees, and such continued Bosch assistance will be subject to Customer agreeing to pay Bosch's then current fees and charges for such efforts.

  • If, after final analysis, an issue is found to be Reproducible (even if it appeared as non-Reproducible at initial logging), Bosch will not charge any additional such fees.

  • Different levels of Errors. Errors shall be categorized in accordance to their severity as defined in the following four (4) Severity Levels:

  • Severity Level 1 (Critical). An Error is Severity Level 1, when, in the production environment, the Software is completely down, or a major function of the Software is not working at all or is inaccessible, and there is no workaround available.

  • Severity Level 2 (Serious). An Error is Severity Level 2, when, in the production environment, the Software is significantly impaired (e.g. loss or degradation of a substantial functionality), which causes the Software to perform materially less than as described in the applicable documentation, or, in a test or back-up environment, the Software is completely down, or a major function of the Software is not working at all or is inaccessible, and there is no workaround available.

  • Severity Level 3 (Moderate). An Error is Severity Level 3, when, in the production environment, the Software encounters a technical or functional problem, but a temporary workaround is available, or, in a test or back-up environment, the Software is significantly impaired (e.g. loss or degradation of a substantial functionality), which causes the Software to perform materially less than as described in the applicable documentation.

  • Severity Level 4 (Minor). An Error is Severity Level 4, when there is an issue that relates to improvement of performance or functionality, or there is an issue for which a permanent workaround has been provided.

  • Support Services.

  • Errors have to be logged by Customer through the designed telephone hot-line, or via a dedicated support helpdesk website or email address ("First Line Support"). Bosch will indicate to Customer the exact contact details for First Line Support.

  • Bosch will use its reasonable efforts to provide Customer with a solution to the Error.

  • Solution times. Since Bosch will not know in advance of receipt of Customer's notice of an Error what the cause of an Error is, or how it can be resolved, Bosch cannot commit to solution times. Bosch will use reasonable commercial efforts to resolve the Error as soon as possible, taking into account the Severity Level of the Error.

  • Availability of First Line Support.

  • First Line Support is available during normal business hours of your Bosch sales representative, excluding weekends and holidays.

  • Remote Access and On-Site Support.

  • It is an essential condition of Support Services that Customer provides on-line remote access to the production environment of the Software. If no such remote access is provided, the level of Service may be severely impacted, and the response times will be delayed as a result.

  • The standard Support Services do not include On-Site Support. Upon Customer written request, and subject to Customer's agreement to pay Bosch's then current fees and charges therefor, Bosch may (but is under no obligation to) agree to provide On-Site Support. In such case, all travel and accommodation costs shall be charged in addition to Bosch's then current fees and charges.

  • Conditions to be able to call upon Support Services.

  • In order to be able to call upon Support Services, the Customer must:

  • have a valid user license to the Software, and not be in breach of any of the terms of the Software license;

  • have effectively paid all due and owing license, maintenance, and other fees owed to Bosch;

  • use the Software strictly in accordance with the applicable documentation and the Bosch instructions (including but not limited to the hardware and technological environment and usage instructions as issued by Bosch from time to time);

  • comply with the instructions on installment of the latest Software release as set out in this document or as instructed by Bosch from time to time;

  • ensure that the Software is only used by Customer's personnel that is properly qualified and trained in the use of the Software;

  • Bosch is entitled to request Customer to impose certain minimum training and certification requirements to the staff using the Software, in order to comply with the latest condition above.

  • If at the time Customer contacts First Line Support, it appears that Customer does not comply with one or more of the above conditions, Bosch will be entitled (but is not obligated) to make the provision of Support Services subject to payment of additional fees and charges.

  • If at the time Customer contacts First Line Support, it appears that the issue to be logged has been resolved by a new Release (either a Major or Minor Release, including fixes and hot patches) that has already been made generally available by Bosch, then Customer will first have to implement such Release, prior to Bosch performing any Support Services.

  • The following are not included in Software Support Services (“Out-of-Scope Services”):

  • data retrieval;

  • support of issues that are not Reproducible, or that otherwise fail to be qualified as Errors;

  • support of interfaces;

  • support of Customer-specific development software;

  • support of the technological environment in which the Software is installed;

  • support of hardware (Bosch cameras, or other parts of the Bosch hardware configuration are covered by separate agreements, and are specifically excluded from Software Support Services); and

  • support of third party software.

  • Upon Customer’s request, Bosch may (but has no obligation to) accept to provide Out-of-Scope Services, subject to Customer agreeing to pay Bosch's then current fees and charges therefor for time and materials. Any such Out-of-Scope Services will be provided on a reasonable effort basis, without any commitment as to Response or Solution times.

  • New Releases.

  • Bosch will make available to Customer new Releases of the Software as and when they are made “generally available” by Bosch to similarly situated customers. New Releases are made available to Customers with valid Maintenance Agreements at no additional cost.

  • Implementation (e.g. installation, license activation, and configuration) of new Releases is not included in the Maintenance Services. If Customer wants to receive such implementation services, they need to be ordered separately.

  • ALTHOUGH BOSCH WILL USE COMMERCIALLY REASONABLE EFFORTS TO ENSURE BACKWARDS COMPATIBILITY BETWEEN RELEASES, BOSCH DOES NOT GUARANTEE FULL BACKWARDS COMPATIBILITY, AND THE IMPLEMENTATION OF A NEW RELEASE MAY CAUSE SOME DATA LOSS. CUSTOMER SHOULD MAKE A FULL BACK-UP OF ALL DATA THAT CUSTOMER WISHES TO RETAIN PRIOR TO THE IMPLEMENTATION OF A NEW RELEASE.


Scope

Scope

This user manual describes the use of the API for the DICENTIS network based conference system. To understand this manual, knowledge is expected on the following issues:

  • The Microsoft .NET framework and one of its development languages. In this documentation definitions are defined for the languages C#, VB and C++ but all examples are defined using the C# language. When using a different language, the developer using the API is responsible in converting the examples to the appropriate language.

  • The use of Lambda expressions in the C# language. See also Microsoft Lambda expressions (C# Programming Guide).

  • The Microsoft Visual Studio.NET development environment. Not directly needed but it will speed up the development. Both the professional as the express editions can be used.

  • The DICENTIS network based conference system and its installation.

This user manual is intended for users, who want to use the DICENTIS API into their application.

The current version of the DICENTIS API provides functionality to:

  • Control participants microphones.

  • Control waiting and speaker lists.

  • Participate in a running meeting / Discussion

This manual uses code-fragments (in the C# programming language) to clarify the use of the DCN-SW API.

See Also

Other Resources

Introduction


Principles of the API interface

This section provides several common aspects related to the DICENTIS API. These concepts define how the API can be used, the relation between methods and other interface elements and a short overview of the DICENTIS related rights.

In This Section

  • Methods and Events

    Describes the relations between the DICENTIS API methods, Events and properties within a given interface.

  • Using the Interface Methods

    Describes different ways to use the methods which are asynchronous based.

  • System licenses, User and participant rights

    Describes an overview of the rights involved in the system and the effect on the use of Interfaces, Methods and Properties.


Methods and Events

This topic contains the following sections:

  • Retrieval of data using events
  • Capabilities of an Interface
  • State properties of an Interface
  • See Also

This section describes the principle of the DICENTIS methods and events. It provides a global insight about the use of methods to enable/disabled the triggers present by means of events.

Secondly the relation of the CapabilitiesChanged (and derived classes) event and the properties on the interface are explained.

Retrieval of data using events

When working with active data which change due to activities done on the devices, there are two ways to get the changes.

  1. During application start you like to retrieve the data to get aligned to the current state of the system.

  2. While the application is running, having an event which triggers and sends the new data on activities done on the devices.

Drawback of the two options is that two methods are required to work with the data received in both cases.

The API solves both by providing the mechanism to let the event trigger for the first use. This means that when the application starts it registers for the specific event, followed by a request of the data. The system honors the request by triggering the event with data of the current state.

Important note Important

The amount of processing in the eventhandler function registered for an event should be kept to a minimum.

The code-sample shows this mechanism for the speakers-list:

C#
Copy
IControlSpeaker controlSpeaker = MainWindowsApi.Base.ControlSpeaker;

if (controlSpeaker.CanControlSpeaker)
{
    // Register event handler
    controlSpeaker.SpeakersListChanged += (s,e) =>
    {
        // Handle the new/changed list of speakers
        Ilist<DcnmSpeakerInfo> speakerList = e.Parameter;
    };

    // Perform initial request for the speaker-list
    controlSpeaker.RequestSpeakersListAsync(T =>
    {
        if (!T.Result)
        {
            // Failure on sending the request
        }
    });

}
Capabilities of an Interface

Many interfaces have capabilities which start with the prefix "Can". These "Can" properties provide information whether one or more functions in the interface perform the expected action. In case a "Can" property returns false, the related fuctions also fail in there operation.

The API interface is not designed for polling the properties. When polling the properties, this can block proper updates of the property. When the third party system is interested in changes of the "Can" properties, the application should use the "CapabilitiesChanged" event. Register a event handler to that event and check the new state of the "Can" properties in that eventhandler. When needed you can cache the property in case polling is required.

The code snippet below shows the handling of the IAttention Interface.

C#
Copy
IAttebtion attention = MainWindowsApi.Base.Attention;
attention.CapabilitiesChanged += (s,e) =>
{
    if (attention.CanIssuePriority)
    {
        // it is possible to issue priority
    }
    if (attention.CanSummon)
    {
        // it is possible to use the summon function
    }
};
State properties of an Interface

Some of the interfaces have properties which represents a state. E.g. whether the connection is established. In normal circumstances the next step has to be done when the state has reached a specific value.

The API interface is not designed for polling the properties although it might be handy to construct a continuous method performing some actions, Wait for the appropriate state and continue with the next actions. Instead of polling you should use the corresponding state events to handle the state changes of the state property.

Handling the state changes in the event handler has the following advantages:

  • No polling is required and therefore avoiding continuous processing by the application. When the application has an user interface and the API is processed on the user interface thread, the user interface remains responsive.

  • In the eventhandler, all the new states can be handled and thus avoiding the situation that you are waiting for a specific state which did not come due an error

The code snippet below shows the handling of the CurrentApiState property.

C#
Copy
IApi apiBase = MainWindowsApi.Base;
// Add the eventhandler
apiBase.ApiStateChanged += (s,e) =>
{
    DcnmApiState state = e.Parameter as DcnmApiState;
    if (null != state)
    {
        switch (state)
        {
            case DcnmApiState.Offline:
                // API is disconnected from the system...
                break;
            case DcnmApiState.Online:
                // API is connected to the sysem, the API is open.
                // Define the initial steps when getting online.
                break;
            case DcnmApiState.Opening:
                // The API is busy with establishing the connection to reach the Online state.
                break;
            case DcnmApiState.Closing:
                // The API is busy disconnecting from the system to reach the Offline state.
                break;
            default:
                // The (future) API is extended with additional state not yet known to the system.
                break;
        }
    }
};
See Also

Other Resources

User-Rights
How to connect as an application


Using the Interface Methods

Calling methods of the DICENTIS API

This topic contains the following sections:

  • Synchronously calling the methods
  • Method calls with exception handling
  • Method calls with Lambda expression handling the result asynchronously
  • Trigger a method call and do not wait for the result
  • Start multiple method calls asynchronously and handle results when all finished
  • Calling the method using the Framework 4.5 async keyword

The DICENTIS API handles the methods in an asynchronous way. The asynchronous way of calling enables a smooth user interface and background processing. However more knowledge is required to understand the asynchronous behavior of the methods in the DICENTIS API.

The sections below describe various ways to use the asynchronous methods of the API.

Synchronously calling the methods

Using the synchronously calling method, each method returns the result of the method call. During the execution of the method the calling thread is blocked.

A synchronous method call example
Copy
bool result = discussApi.OpenDiscussionAsync(discussionId).Result;
Note Note

Do not forget the .Result at the end of the method call. The use of the Result property ensures that the correct result of the method is returned.

Method calls with exception handling

A method call with exception handling example
Copy
bool result;
try
{
    Task<bool> task = discussApi.OpenDiscussionAsync(discussionId);
    task.Wait();
    result = task.Result;
}
catch (AggregationException ae)
{
    foreach (Exception ex in ae.InnerExceptions)
    { /* Handling of exception */ }
}
Method calls with Lambda expression handling the result asynchronously

Lambda expression for result handling example
Copy
discussApi.OpenDiscussionAsync(discussionId, (t) =>
{
    bool result = t.Result;
    // ... additional code processing the result.
});
Trigger a method call and do not wait for the result

Trigger and forget example
Copy
discussApi.RequestDiscussionOptionsAsync();
Start multiple method calls asynchronously and handle results when all finished

Multiple calls parallel example
Copy
List<Task> tasklist = new List<Task>();
tasklist.Add(discussApi.RequestDiscussionOptionsAsync());
tasklist.Add(discussApi.RequestMicropjoneOptionsAsync());
tasklist.Add(discussApi.RequestPriorityOptionsAsync());

// Handle the common wait and result handling on separate task.
Task.Factory.StartNew(() =>
    {
        // Wait for all task to complete
        Task.WaitAll(tasklist.ToArray());
        // Each result property will return the value immediately
        DcnmDiscussionOptions discussionOptions = ((Task<DcnmDiscussionOptions>) tasklist[0]).Result;
        DcnmMicrophoneOptions microphoneOptions = ((Task<DcnmMicrophoneOptions>) tasklist[0]).Result;
        DcnmPriorityOptions priorityOptions = ((Task<DcnmPriorityOptions>) tasklist[0]).Result;
        // Continue processing with the three options values...
    });
Calling the method using the Framework 4.5 async keyword

A Framework 4.5 async/await caling example
Copy
private async void OnloadDialog(object sender, EventArgs e)
{
    DcnmDiscussionOptions discussionOptions = await discussApi.RequestDiscussionOptionsAsync();
    DcnmMicrophoneOptions microphoneOptions = await discussApi.RequestMicropjoneOptionsAsync();
    DcnmPriorityOptions priorityOptions = await discussApi.RequestPriorityOptionsAsync();
    // Continue processing with the three options values...
}


User Right effect on API

The use of Interfaces and the functions present in the DICENTIS API are depending on the following parts as present in the DICENTIS network based conference system:

  • License bought for the system

  • User-Rights defined for the user logged in.

  • The seat rights for the seat assigned to the API connection.

  • The participant rights seated on the defined seat.

This topic contains the following sections:

  • DICENTIS network based conference system Licenses
  • Rights assigned to users defined in the system
  • Rights defined for a seat
  • Rights defined for a participant (who is seated at a seat)
DICENTIS network based conference system Licenses

The table below provides an overview of the license, which can be bought for the DICENTIS network based conference system. In the table also a global overview is given about the set of interfaces not present when the license is not present.

DCNM-LPP-PE Participant premium perpetual

The DCNM-LPP-PE is a participant based perpetual license that enables the premium feature pack. It contains features to enable voting and interpreting functionalities together with multiple identification options.

DCNM-LPU-PE Participant ultimate perpetual

The DCNM-LPU-PE is a participant based perpetual license that enables the ultimate feature pack. It contains the complete set of features to enable advanced voting and interpreting functionalities together with multiple identification options.

DCNM-LPSMA-PE Software Maintenance Agreement

Software Maintenance Agreements (SMAs) are available for one, two, or five year(s). Includes the licensed system and seat software upgrades, as well as third-party compatible updates.

– Enables best‑possible system performance

– Convenient upgrade of software instead of expensive hardware

– Regular updates

DCNM-LPPP-P1Y Participant premium pro prepaid

The DCNM-LPPP-P1Y is a participant based yearly prepaid license that enables a premium feature pack. The premium feature pack enables a voting and interpreting functionality together with multiple identification options. The meeting manager can prepare and manage the meetings easily and effectively using the powerful DICENTIS Software.

DCNM-LPUP-P1Y Participant ultimate pro prepaid

The DCNM-LPUP-P1Y participant based yearly prepaid license plan enabling the ultimate feature pack for participants. It contains all features to enable advance voting and interpreting functionalities together with multiple identification options. The meeting manager can prepare and manage meetings in an easy and effective way using the powerful DICENTIS Software Suite.

DCNM-LPPP-S1Y Participant premium pro automatic subscription

The DCNM-LPPP-S1Y is a participant based perpetual license that enables the premium feature pack. It contains features to enable voting and interpreting functionality together with multiple identification options. The meeting manager can prepare and manage the meetings easily and effectively by using the powerful DICENTIS Software Suite.

DCNM-LPUP-S1Y Participant ultimate pro subscription

The DCNM-LPUP-S1Y is a participant based yearly subscription license plan enabling the ultimate feature pack for participants. It contains the complete set of features to enable advanced voting and interpreting functionalities together with multiple identification options. The meeting manager can prepare and manage meetings in an easy and effective way using the powerful DICENTIS Software Suite.

DCNM-LDANTE DICENTIS License for 1 Dante stream

This software license enables the sending or receiving of Dante audio streams, allowing the interfacing of the DICENTIS Conference System with other systems based on Dante and providing the ability to record the interpreted languages or to interface with a 3rd party discussion or interpreting system.

– Enables sending up to 100 interpreted languages as Dante audio streams

– Enables receiving up to 100 interpreted languages as Dante audio streams

– One license per stream required

License Collections

Special Licenses

This license collection contains DCNM-DEMO, DCNM-RENTAL and DCNM-CRN.

Premium Licenses

This license collection contains DCNM_LPPP_P1Y, DCNM_LPPP_S1Y and DCNM_LPP_PE.

Ultimate Licenses

This license collection contains DCNM_LPUP_P1Y, DCNM_LPUP_S1Y and DCNM_LPU_PE.

Out of box license

This license collection contains DCNM_TECH_REGISTERED.

Rights assigned to users defined in the system

For the users a set of user rights can be set to define the capabilities of that user. These rights are organized by means of user-groups, where each group define a set of the available user-rights. Within the system the following rights are defined:

Configure System

Provides the user the right to configure the DICENTIS network based conference system. Configuring means the configuration of devices and seats, cameras and system audio settings.

Activate Meeting

Provides the user the right to activate (deactivate) a meeting. In general this right is assigned to the secretary so that he can activate the meeting before the participants arrive in the meeting room

Note Note

In order to open the meeting, the user also has to be assigned to the meeting (participant) and must have the participant right to manage the meeting.

Prepare Meeting and Agenda

Provides the user the right to prepare meetings and agenda topics. In order to get this right effect the system must be equipped with the DCNM-LMPM license.

Assign Access Rights

Provides the user the right to manipulate the user-rights.

By default two user-groups are defined to assign user to:

Administrator

Fixed group having all rights. This group cannot be modified.

Participant

Default group for the meeting persons (participants) and has no assigned system rights.

Rights defined for a seat

Within the system rights can be assigned to seats. These rights are active when no participants are assigned (or seated) to the seat. When a participant is assigned to (seated on) the seat, the participant rights are applicable, see next section.

The seat rights define the capabilities of the seat and controls the allowed set of functions on the seat. The following seat right are defined in the system:

Can Discuss

Provides the seat capability to join discussion using the seat.

Can Manage

Provides the seat capability to manage the meeting on the seat (open/close the meeting/agenda, manage the speaker and waiting list).

Can Priority

Provides the seat capability to use the priority function on the seat. Setting this right changes the second device button into the priority button. The mute function is then no longer available.

Seat operation type

Defines the operation type of the seat. The following operation types are available for the seat:

Normal

Normal operation for the seat. When pressing the request button the normal behavior is applicable depending on the discussion operation mode (see DcnmDiscussionOptions)

Button operated

Button operation for the seat. This implies that the seat does not follow the discussion operation mode. When the request button is pressed, the speech is always granted. Button operated seats are not counted for the 'number of microphones'.

Push to Talk operated

Push to talk operation for the seat. Like button operated, but the user has to keep the request button pressed as long he like to speak.

Can Vote

Provides the seat capability for voting on the seat.

Can Identify

Provides the seat capability to Identify the specified participant by its ID at the seat in the active meeting.

Can Select Language

Provides the seat capability to select languages for the headphone on the seat.

Rights defined for a participant (who is seated at a seat)

Within a meeting some of the participants have different role than the normal participants. The role each participant has within the meeting is controlled by assigning rights to a participant. When rights are assigned to a participant and that participant is assigned (seated), the seat right are no longer effective.

The following participant rights are available in the system:

Can Discuss

Provides the participant capability to join discussion.

Can Vote

Provides the participant the authority to join the votings being held during the meeting.

Can Manage

Provides the participant capability to manage the meeting (open/close the meeting/agenda, manage the speaker and waiting list).

Can Priority

Provides the participant capability to use the priority function. Setting this right changes the second device button into the priority button. The mute function is then no longer available.

Participant operation type

Defines the operation type of the seat. The following operation types are available for the seat:

Normal

Normal operation for the participant. When pressing the request button the normal behavior is applicable depending on the discussion operation mode (see DcnmDiscussionOptions)

Button operated

Button operation for the participant. This implies that the participant does not follow the discussion operation mode. When the request button is pressed, the speech is always granted. Button operated participants are not counted for the 'number of microphones'.

Push to Talk operated

Push to talk operation for the participant. Like button operated, but the participant has to keep the request button pressed as long he like to speak.


HowTo Overview

This section includes How To documentation for performing common DICENTIS API tasks.

In This Section

  • How to setup the connection with the system

  • How to check the API version

  • How to power-on the system using Python

  • How to manage meetings and agenda

  • How to manage microphones

  • How to manage votings

  • How to make your own External Video Switcher


How to check the Api version

How to check the version of the API

The DICENTIS network based conference system provides a API interface for third party software development. Although the intention is to keep the interface version unchanged, it can happen that the interface no longer can be kept as is. In the latter case the interface version number will change.

Note Note

When the interface changes only exist in extensions to the interface, the API version is kept as is, since the outstanding applications do not use the newly added methods, properties and events.

To have good feedback to the user of the system and the third party application using the DICENTIS API, the third part should include version checking on the interface used. In the steps below a way to check the API's version is explained. Additional to the API version check also steps are included to see whether the system is upgraded and that the PC running the API and the third party application is missed.

Verifying the API version

  1. Load the assembly in a try-catch block. When a FileLoadException is caught, the API cannot be loaded (missing resources) or is removed from the system

    C#
    Copy
    try
{
    // Load the API-dll and retrieve the version of it. The load fails when:
    // * The DLL is not there or could not be loaded (or its decendents)
    // * The DLL with the intended version is not available.
    Version apiVersion = Assembly.Load("Bosch.Dcnm.Interfaces.Api, Version=1.0.0.0, Culture=neutral, PublicKeyToken=c2d802bb1c65cbe5").GetName().Version;
    // Optionally check of the API version based on string compare
}
catch (FileLoadException ex)
{
    // Assembly could not be loaded (or its dependancies).
}
    Note Note

    Be sure to execute the code above before any reference to the actual API is made. This means that the check has to be done as early as possible

  2. When code completes normally, the local member "correctVersion" is filled with the condition whether the API DLL is the correct version

Detecting version conflict with the system

  1. Before opening the API register to the VersionMismatchErrorDetected event

  2. Open the API using the default method as described in How to Connect

  3. When the event is triggered while waiting for the open state, the system has an different version than the API.

    C#
    Copy
    apiBase.VerionMismatchErrorDetected += (s,e) =>
{
    // System has different version
}

apiBase.OpenAsync((task) =>
{
    bool isOpening = task.Result;
    if (isOpening)
    {
        // ...
    }
}
See Also

Reference

VersionMismatchErrorDetected

Other Resources

How to Connect


How to setup connect to the system

How to connect as Application

This section provides a stepwise description of building an application connected to the DICENTIS network based conference system.

How to make a connection with the DICENTIS network based conference system

  1. Using the WindowsApiInstance class you should get a reference to the IApi interface.

    IApi interface reference
    Copy
    IApi apiBase = WindowsApiInstance.Base

  2. Open the API using the OpenAsync(ActionTaskBoolean) method.

  3. Subscribe to the API events OpenStateChanged of the IApi interface in order to get notified about the API state.

    OpenStateChanged event handler get the notification when API transits to or from DcnmApiState True, if online. False, if no longer online.

    In the example below shows how to connect to an API using Asynchronous method OpenAsync(ActionTaskBoolean). Using this method it does not require to wait for the result (Does not freeze the UI). Subscribing to OpenStateChanged event handler, you will be notified with the result of OpenAsync() method.

    Code for connecting to the API
    Copy
    apiBase.OpenStateChanged += OnOpenStateChanged;
apiBase.OpenAsync((task) =>
{
    bool isOpening = task.Result;
    if (isOpening)
    {
        // Post connection logic
    }
    else
    {
        apiBase.OpenStateChanged -= OnOpenStateChanged;
    }
});

  4. Status of the API can be known using:

    1. OpenStateChanged event handler if you have subscribed.

    2. IsOpen property for status of the connection to the API.

How to connect as a device with DICENTIS network based conference system

  1. Prerequisites

    Important note Important

    How to make a connection with the DICENTIS network based conference system

  2. Using the WindowsApiInstance class you should get a reference to the IDeviceApi interface.

    IDeviceApi interface reference
    Copy
    IDeviceApi apiDevice = WindowsApiInstance.Device

  3. Check for properties before connecting as device:

    1. IsOpen property for status of the connection to the API.

    2. CanConnectAsDevice indicates the possibilities to connect as a device to the system.

    3. CurrentDeviceConnectionState indicates the device status of the connection.

  4. Subscribe to the API events ConnectionStateChanged, EnabledStateChanged and ApplicationModeStateChanged of the IDeviceApi interface in order to get notified about the Device API state.

  5. Connect as a device using the API ConnectAsDeviceAsync(String, ActionTaskBoolean) method:

    Important note Important

    It has to be connected with the Unique device Id

    Code to connect as a Device
    Copy
    if (opened && apiBase.IsOpen)
{
    if (apiDevice.CanConnectAsDevice
        && (DeviceConnectionState.Disconnected == apiDevice.CurrentDeviceConnectionState))
    {
        apiDevice.ConnectionStateChanged += OnDeviceConnectionStateChanged;
        apiDevice.EnabledStateChanged += OnDeviceEnabledStateChanged;
        apiDevice.ApplicationModeStateChanged += OnApplicationModeChanged;

        apiDevice.ConnectAsDeviceAsync("UniqueDeviceNameHere", (task) =>
        {
            bool isConnected = task.Result;

            if (isConnected)
            {

            }
            else
            {
                apiDevice.ConnectionStateChanged -= OnDeviceConnectionStateChanged;
                apiDevice.EnabledStateChanged -= OnDeviceEnabledStateChanged;
                apiDevice.ApplicationModeStateChanged -= OnApplicationModeChanged;
            }
        });
    }
}

  6. Connection state of the device can be known by subscribing to DeviceApiConnectionStateChanged. Subscribe to ConnectionStateChanged to get device status. true if connected, false if not connected

How to logon to the DICENTIS network based conference system

  1. Prerequisites

    Important note Important

    How to make a connection with the DICENTIS network based conference system

    How to connect as a device with DICENTIS network based conference system

  2. Using the IApi interfaces there are two methods you can use to login to the system:

    1. The AuthenticateWindowsSystemUserAsync(ActionTaskBoolean) method tries to login to the DICENTIS network based conference system using the current Windows user login-name and without password.

    2. The AuthenticateUserAsync(String, String, ActionTaskBoolean) method allows you to login using a user-name and password.

    In the example below first the Windowsname is used to login and when failed a login is done using the username and password:

    User Authentication
    Copy
    bool loggedOn = apiBase.AuthenticateWindowsSystemUserAsync().Result;
while (!loggedOn)
{
    string username = "";
    string password = "";
    // Query the username and password (e.g. login dialog)
    loggedOn = apiBase.AuthenticateUserAsync(userName, password).Result;
}

  3. Wait for the DICENTIS network based conference system to authenticate and Logs on the user in the system. Check IsUserLoggedOn property to get Login Status.

Example

In the code below the complete script to connect with the DICENTIS network based conference system. Create an instance of the class in your application for use.

C#
Copy
using Bosch.Dcnm.Interfaces.Api;
using Bosch.Dcnm.Interfaces.Api.Interfaces;

public class ConnectAPI
{
    /// <summary>Opens the API.</summary>
    public void Open()
    {
        apiBase = WindowsApiInstance.Base;
        // Subscribe to API base events to get the state
        apiBase.OpenStateChanged += OnOpenStateChanged;
        apiBase.ApiStateChanged += OnApiStateChanged;

        apiBase.OpenAsync((task) =>
        {
            bool isOpening = task.Result;

            if (isOpening)
            {
                // You can also connect a device with the system or Authenticate the user to the system here by checking the API state.
            }
            else
            {
                apiBase.OpenStateChanged -= OnOpenStateChanged;
                apiBase.ApiStateChanged -= OnApiStateChanged;
            }
        });
    }

    /// <summary>Closes the API</summary>
    public void Close()
    {
        apiBase.CloseAsync((task) =>
        {
            apiDevice.ConnectionStateChanged -= OnDeviceConnectionStateChanged;
            apiBase.OpenStateChanged -= OnOpenStateChanged;
            apiBase.ApiStateChanged -= OnApiStateChanged;

        });
    }

    /// <summary>Logons the specified username.</summary>
    /// <param name="username">The username.</param>
    /// <param name="password">The password.</param>
    public void Logon(string username, string password)
    {
        // By default authentication using Logged-in Windows account
        bool loggedOn = apiBase.AuthenticateWindowsSystemUserAsync().Result;
        // If Authentication with windows account fails then login using specified username
        while (!loggedOn)
        {
            // Query the username and password (e.g. login dialog)
            loggedOn = apiBase.AuthenticateUserAsync(username, password).Result;
        }
    }

    /// <summary>Logoffs this instance.</summary>
    public void Logoff()
    {
        WindowsApiInstance.Base.RevokeUserAsync((task) =>
        {
        });
    }

    /// <summary>Handles the opened state changed reported by the API.</summary>
    /// <remarks>Connect a Device when API state is "Open"</remarks>
    private void OnOpenStateChanged(object sender, ApiEventArgs<bool> e)
    {
        apiDevice = WindowsApiInstance.Device;
        // Parameter value is the state of API
        bool opened = (bool)e.Parameter;
        if (opened && apiBase.IsOpen)
        {
            if (apiDevice.CanConnectAsDevice
                && (DeviceConnectionState.Disconnected == apiDevice.CurrentDeviceConnectionState))
            {
                //Subscribe to Device API event handlers
                apiDevice.ConnectionStateChanged += OnDeviceConnectionStateChanged;
                apiDevice.EnabledStateChanged += OnDeviceEnabledStateChanged;
                apiDevice.ApplicationModeStateChanged += OnDeviceApplicationModeChanged;

                //Call API method to connect as a device by given a unique identifier
                apiDevice.ConnectAsDeviceAsync("UniqueDeviceNameHere", (task) =>
                {
                    bool isConnected = task.Result;

                    if (isConnected)
                    {
                        // Post operation when successfully connected as a device
                    }
                    else
                    {
                        // If connection is unsuccessful unsubscribe from the event handlers
                        apiDevice.ConnectionStateChanged -= OnDeviceConnectionStateChanged;
                        apiDevice.ApplicationModeStateChanged -= OnDeviceApplicationModeChanged;
                    }
                });
            }
        }
    }

    /// <summary>Handles the operational state change of the API.</summary>
    private void OnApiStateChanged(object sender, ApiEventArgs<DcnmApiState> e)
    {
        DcnmApiState state = e.Parameter as DcnmApiState;
        if (null != state)
        {
            // ...
        }
    }

    /// <summary>The connection state of the device representation has changed.</summary>
    private void OnDeviceConnectionStateChanged(object sender, ApiEventArgs<bool> e)
    {
        IsApiConnected = (bool)e.Parameter;
        // Unsubscribe to Device API events if not connected
        if (!IsApiConnected && !IsApiOpen)
        {
            apiDevice.ConnectionStateChanged -= OnDeviceConnectionStateChanged;
        }
    }

    /// <summary>Handles the enabled state change of the device.</summary>
    private void OnDeviceEnabledStateChanged(object sender, ApiEventArgs<bool> e)
    {
        IsDeviceEnabled = (bool)e.Parameter;
    }

    /// <summary>Handles the installation mode state change of the device.</summary>
    private void OnDeviceApplicationModeChanged(object sender, ApiEventArgs<ApplicationState> e)
    {
        ApplicationState applicationMode = (ApplicationState)e.Parameter;
        IsApiConferenceMode = (ApplicationState.ConferenceMode == applicationMode);
    }

    /// <summary>Indicates the API is in conference mode.</summary>
    public bool IsApiConferenceMode { get; set; }

    /// <summary>Indicates the API is connected.</summary>
    public bool IsApiConnected { get; set; }

    /// <summary>Indicates the API is open.</summary>
    public bool IsApiOpen { get; set; }

    /// <summary>Indicates the API is enabled.</summary>
    public bool IsDeviceEnabled { get; set; }

    /// <summary>API Interface reference </summary>
    public IApi apiBase { get; set; }

    /// <summary>Interface reference to Device API </summary>
    public IDeviceApi apiDevice { get; set; }
}
See Also

Reference

OpenStateChanged
ApiStateChanged
IsEnabledAsDevice
IsUserLoggedOn
IsOpen

Other Resources

Calling methods of the DICENTIS API methods


How to power-on the system using Python

In some situations no real user interface is required, but only some simple functions are to be triggered on the DICENTIS network based conference system. This section provides you a Description how to use Python to turn on the DICENTIS network based conference system.

Note Note

When using Python for building scripts, it is not possible to use the eventing mechanism as supplied within the DICENTIS API. In the examples below these shortcomings are bypassed by checking the related properties before continuing the flow of control.

Related to the inability to work with events, the Python scripting language cannot be used for all possible solutions.

Before you can use the DICENTIS API using Python, you have to install the latest version of IronPython for .NET.

IronPython preparations

  1. First we need to import the DICENTIS API. To use an external assembly within Python the path of the assembly and the reference to the assembly have to be defined before Python can import the assembly definitions.

    The code sample below defined the assembly path, the reference and the import of the Bosch.Dcnm.Interfaces.Api and Bosch.Dcnm.Interfaces.Api.Interfaces assemblies. After the type import in Python the object reference to the WindowsApiInstance

    Python
    Copy
    sys.path.append(r"C:\Program Files\Bosch\DICENTIS")
clr.AddReference("Bosch.Dcnm.Interfaces.Api")
import Bosch.Dcnm.Interfaces.Api
clr.AddReference("Bosch.Dcnm.Interfaces.Api.Interfaces")
from Bosch.Dcnm.Interfaces.Api.Interfaces import *

api = Bosch.Dcnm.Interfaces.Api.WindowsApiInstance
# load other interface required in variables.
# This creates the interfaces and enables registrations when getting connected to the system.
apiBase = api.Base
apiDevice = api.Device
apiEquipment = api.Equipment

  2. As described in the how to connect as application page, several properties of the IApi interface have to be checked. For this we create a specific Phyton function, which does wait until the specified properties has got the expected value:

    Python
    Copy
    # Wait for a property to become a certain value. Maximum number of
# attempts and text when the property is not set in time
# are given as parameters.
def WaitForProperty(object, property, value, max_attempts, failure_text):
    i = max_attempts
    propvalue = property.GetValue(object)
    while ( (propvalue != value) and (i > 0) ):
        i = i - 1
        time.sleep(1)
        propvalue = property.GetValue(object)
    if (propvalue != value):
        print (failure_text)
        api.Shutdown()
        raise Exception(failure_text)

  3. Having the method to wait for a property to be set to a value, we can open the API and connect to the system. For details, see: how to connect as application.

    Python
    Copy
    # Open the api
r = IApi.OpenAsync(apiBase).Result
WaitForProperty(apiBase, IApi.IsOpen, True, 60, "Opening API not succeeded in time")

# Logon a as admin
WaitForProperty(apiBase, IApi.CanAuthenticate, True, 30, "Can authenticate still not possible")
r = IApi.AuthenticateUserAsync(apiBase, "admin", "").Result
# Wait for ability to connect as a device
WaitForProperty(apiDevice, IDeviceApi.CanConnectAsDevice, True, 30, "Timeout while waiting for ability to connect as a device")

# Now connect as a device
r = IDeviceApi.ConnectAsDeviceAsync(apiDevice, socket.gethostname() + "-PythonTestScript").Result
WaitForProperty(apiDevice, IDeviceApi.CurrentDeviceConnectionState, DcnmDeviceConnectionState.Connected, 30, "Connect as a device not done in time")

# Print the state of the API
WaitForProperty(apiDevice, IDeviceApi.IsEnabledAsDevice, True, 60, "Open of API not enabled in time")

  4. We are ready to define and execute the power command off the DICENTIS network based conference system.

    Python
    Copy
    def WaitForPowerState(state, timeout):
    for i in range(timeout):
        if IEquipment.EquipmentPowerState.GetValue(apiEquipment) == state:
              return
        time.sleep(1)
    print ("Timeout waiting for power state ", state)

    Execute the power-on command.

    Python
    Copy
    WaitForPowerState(DcnmPowerState.PoweredOff, 3)

if not apiEquipment.PowerOnEquipmentAsync().Result:
    print ("Could not power on equipment")
    Note Note

    In the same manner as power-on the power-off command can be executed.

    Be sure to have the Power Off rights assigned to the user.

Example

In the code below the complete python script is present to power-on the system.

Python
Copy
import clr
import sys
import time
import socket
import System
import os

sys.path.append(r"C:\Program Files\Bosch\DICENTIS")
clr.AddReference("Bosch.Dcnm.Interfaces.Api")
import Bosch.Dcnm.Interfaces.Api
clr.AddReference("Bosch.Dcnm.Interfaces.Api.Interfaces")
from Bosch.Dcnm.Interfaces.Api.Interfaces import *

api = Bosch.Dcnm.Interfaces.Api.WindowsApiInstance
# load other interface required in variables.
# This creates the interfaces and enables registrations when getting connected to the system.
apiBase = api.Base
apiDevice = api.Device
apiEquiment = api.Equipment

# Wait for a property to become a certain value. Maximum number of
# attempts and text when the property is not set in time
# are given as parameters.
def WaitForProperty(object, property, value, max_attempts, failure_text):
    i = max_attempts
    propvalue = property.GetValue(object)
    while ( (propvalue != value) and (i > 0) ):
        i = i - 1
        time.sleep(1)
        propvalue = property.GetValue(object)
    if (propvalue != value):
        print (failure_text)
        api.Shutdown()
        raise Exception(failure_text)

def WaitForPowerState(state, timeout):
    for i in range(timeout):
        if IEquipment.EquipmentPowerState.GetValue(apiEquipment) == state:
              return
        time.sleep(1)

    print ("Timeout waiting for power state ", state)

# Open the api
r = IApi.OpenAsync(apiBase).Result
WaitForProperty(apiBase, IApi.IsOpen, True, 60, "Openen API not succeeded in time")

# Logon a as admin
WaitForProperty(apiBase, IApi.CanAuthenticate, True, 30, "Can authenticate still not possible")
r = IApi.AuthenticateUserAsync(apiBase, "admin", "").Result
# Wait for ability to connect as a device
WaitForProperty(apiDevice, IDeviceApi.CanConnectAsDevice, True, 30, "Timeout while waiting for ability to connect as a device")

# Now connect as a device
r = IDeviceApi.ConnectAsDeviceAsync(apiDevice, socket.gethostname() + "-PythonTestScript").Result
WaitForProperty(apiDevice, IDeviceApi.CurrentDeviceConnectionState, DcnmDeviceConnectionState.Connected, 30, "Connect as a device not done in time")

# Print the state of the API
WaitForProperty(apiDevice, IDeviceApi.IsEnabledAsDevice, True, 60, "Open of API not enabled in time")

# Only Power-on the system when it is in the power-off state.
WaitForPowerState(DcnmPowerState.PoweredOff, 3)

# Power-On the system
if not apiEquipment.PowerOnEquipmentAsync().Result:
    print ("Could not power on equipment")

# Terminate the connection
api.Shutdown()
See Also

Other Resources

IronPhyton for .NET
Phyton 3.6 documentation


How to control meetings and agenda topics

This section of "How To" describes the controlling of a Meeting and Agenda.

Note Note

In order to complete the steps described below, the following pre-conditions have to be fulfilled:

  • The API has to be connected to the system, see System Connection setup

  • The API-client is discovered as a device by the server. It needs to be assigned to a seat and given manage rights. (See Seat rights settings).

  • The special licenses, premium licenses or ultimate licenses must be present.

Preparing the environment to control a Meeting.

  1. Get a reference to the meeting control API using the WindowsApiInstance:

    C#
    Copy
    IControlMeeting controlMeeting = MainWindowApi.ControlMeeting

  2. Check whether the API is allowed to control meetings by checking the CanActivateMeeting property.

  3. Changes on the meeting list can be received by registering to the MeetingsListChanged event. This ensures that your application does received an updated meeting-list when it changes. This event is triggered when:

    • a meeting is activated, deactivated, opened or closed.

    • a agenda is opened or closed.

  4. In order get the existing list of meetings when the application starts, use the RequestMeetingsListAsync(ActionTaskBoolean) method. This will trigger MeetingsListChanged and meeting list is updated. The result is sent using the event handler.

  5. The status of a meeting can be determined by State property of DcnmMeetingStatusInfo. To the know the status of a active meeting use RequestActiveMeetingStatusAsync(ActionTaskBoolean). This will trigger ActiveMeetingStatusChanged event which contains the result.

Controlling the meeting flow

  • Meeting has several states. The application can control the meeting flow using IControlMeeting interface.

    The image below depicts the state diagram of a meeting.

    The states of a meeting are broadly categorized into two. In the table below the states of a meeting are described.

    Main state

    DcnmMeetingState state

    Description

    Deactivated

    The meeting is Deactivated. We can edit/update the properties of meeting such as name, description, identification method etc. Once the meeting has been activated these parameters cannot be edited.

    Activated

    The meeting is Activated. we cannot the modify the properties of a meeting. Once the meeting has been activated the participant can go through the description and visit the URL to know the details of the meeting. Activated meeting can be in two states, Opened and Closed

    Opened

    The meeting is Opened. In this state we can open a agenda and start discussion or we can start a voting round.

    For details about meeting control see Preparing the environment to control a Agenda section below.

    For details about meeting control see How to control votings section.

    Closed

    The meeting is Closed. If any agenda or voting are running, they will be closed. Closed

  • The table below defines the action to execute to change the meeting state.

    Action performed

    New state of the meeting

    From state Deactivated:

    controlMeeting.ActivateMeetingAsync(meetingId);

    Activated

    From state Activated:

    controlMeeting.DeactivateMeetingAsync();

    Deactivated

    controlMeeting.OpenMeetingAsync();

    Opened

    From state Opened:

    controlMeeting.DeactivateMeetingAsync();

    Deactivated

    controlMeeting.CloseMeetingAsync();

    Closed

    From state Closed:

    controlMeeting.DeactivateMeetingAsync();

    Deactivated

    controlMeeting.OpenMeetingAsync();

    Opened

Preparing the environment to control a Agenda.

  1. Get a reference to the meeting control API using the WindowsApiInstance:

    C#
    Copy
    IControlMeeting controlMeeting = MainWindowApi.ControlMeeting

  2. Check whether the API is allowed to control meetings by checking the CanControlMeeting property.

  3. Changes on the agenda list, when a agenda is opened or closed can be received by registering to the MeetingsListChanged event. This ensures that your application does received an updated agenda-list when it changes.

  4. In order get the existing list of agenda when the application starts, use the RequestAgendaForPreparedMeetingAsync(Guid, ActionTaskBoolean) method. This will trigger AgendaForMeetingReceived and agenda list is updated. The result is sent using the event handler.

  5. The status of a agenda can be determined by Active property of DcnmAgendaTopicStatusInfo.

Sample Implementation

  • Example

    C#
    Copy
    public class MeetingControl
{
    public MeetingControl()
    {
        IControlMeeting controlMeeting = WindowsApiInstance.ControlMeeting;
        controlMeeting.ActiveMeetingStatusChanged += OnActiveMeetingStatusChanged;
        controlMeeting.MeetingsListChanged += OnMeetingsListChanged;
        controlMeeting.AgendaForMeetingReceived += OnAgendaForMeetingReceived;
    }
    #region EventHandlers
    /// <summary>
    /// Handler for AgendaForMeetingReceived. This event is triggered when a request to get the list of agenda for a meeting is successfully processed.
    /// </summary>
    /// <param name="sender"> Control meeting api </param>
    /// <param name="e">List of of Type DcnmAgendaTopicStatusInfo </param>
    private void OnAgendaForMeetingReceived(object sender, ApiEventArgs<IList<DcnmAgendaTopicStatusInfo>> e)
    {
        AgendaList = e.Parameter;
    }

    /// <summary>
    /// Handler for MeetingsListChanged, which is triggered when a meeting is activated, deactivated, opened or closed. This event is also triggered when a agenda is opened or closed.
    /// </summary>
    /// <param name="sender"> Control meeting api</param>
    /// <param name="e">List of type DcnmMeetingStatusInfo</param>
    private void OnMeetingsListChanged(object sender, ApiEventArgs<IList<DcnmMeetingStatusInfo>> e)
    {
        MeetingList = e.Parameter;
    }
    /// <summary>
    /// Handler for ActiveMeetingStatusChanged, which is triggered when the state of a meeting changes.
    /// </summary>
    /// <param name="sender"> Control meeting api </param>
    /// <param name="e">List of type DcnmMeetingStatusInfo </param>
    private void OnActiveMeetingStatusChanged(object sender, ApiEventArgs<DcnmMeetingStatusInfo> e)
    {
        ActiveMeeting = e.Parameter;
    }

    #endregion

    #region Methods
    /// <summary>
    /// Activate a meeting
    /// </summary>
    /// <param name="meeting">Selected Meeting.</param>
    /// <returns>True if the request is delivered, else false.</returns>
    public bool ActivateMeeting(DcnmMeetingStatusInfo meeting)
    {
        bool success = false;
        if (meeting.State != DcnmMeetingState.Deactivated)
        {
            controlMeeting.ActivateMeetingAsync(meeting.MeetingId, (task) =>
            {
                success = task.Result;
            });
        }
        return success;
    }

    /// <summary>
    /// Open a meeting.
    /// </summary>
    /// <returns>True if the request is delivered, else false.</returns>
    public bool OpenMeeting()
    {
        bool success = false;
        if (controlMeeting.CanControlMeeting)
        {
            controlMeeting.OpenMeetingAsync((task) =>
            {
                success = task.Result;
            });
        }
        return success;
    }

    /// <summary>
    /// Close a meeting.
    /// </summary>
    /// <returns> True if the request is delivered, else false.</returns>
    public bool CloseMeeting()
    {
        bool success = false;
        if (controlMeeting.CanControlMeeting)
        {
            controlMeeting.CloseMeetingAsync((task) =>
            {
                success = task.Result;
            });
        }
        return success;
    }

    /// <summary>
    /// Deactivate a meeting.
    /// </summary>
    /// <returns>True if the request is delivered, else false.</returns>
    public bool DeactivateMeeting()
    {
        bool success = false;
        controlMeeting.DeactivateMeetingAsync((task) =>
        {
            success = task.Result;
        });
        return success;
    }

    /// <summary>
    /// Request to get the list of meetings.
    /// </summary>
    /// <returns>True if the request is delivered, else false.</returns>
    public bool RequestMeetingsList()
    {
        bool success = false;
        controlMeeting.RequestMeetingsListAsync((task) =>;
        {
            success = task.Result;
        });
        return success;
    }

    /// <summary>
    /// Request to get the status of a active meeting.
    /// </summary>
    /// <returns>True if the request is delivered, else false.</returns>
    public bool RequestActiveMeetingStatus()
    {
        bool success = false;
        controlMeeting.RequestActiveMeetingStatusAsync((task) =>;
        {
            success = task.Result;
        });
        return success;
    }

    /// <summary>
    /// Opens a agenda.
    /// </summary>
    /// <param name="agendaTopicId">Id of agenda</param>
    /// <returns>True if the request is delivered, else false.</returns>
    public bool OpenAgendaTopic(Guid agendaTopicId)
    {
        bool success = false;
        controlMeeting.OpenAgendaTopicAsync(agendaTopicId, (task) =>
        {
            success = task.Result;
        });
        return success;
    }

    /// <summary>
    /// Close a agenda.
    /// </summary>
    /// <param name="agendaTopicId">Id of agenda</param>
    /// <returns>True if the request is delivered, else false.</returns>
    public bool CloseAgendaTopic(Guid agendaTopicId)
    {
        bool success = false;
        controlMeeting.CloseAgendaTopicAsync(agendaTopicId, (task) =>
        {
            success = task.Result;
        });
        return success;
    }

    /// <summary>
    /// Request to get the list of agenda of a meeting.
    /// </summary>
    /// <param name="meetingId"> Id of the meeting.</param>
    /// <returns>True if the request is delivered, else false.</returns>
    public bool RequestAgendaForPreparedMeeting(Guid meetingId)
    {
        bool success = false;
        controlMeeting.RequestAgendaForPreparedMeetingAsync(meetingId, (task) =>
        {
            success = task.Result;
        });
        return success;
    }

    #endregion

    #region Properties
    /// <summary>List of Meetings.</summary>
    public IList<DcnmMeetingStatusInfo> MeetingList
    {
        get { return _meetingList; }
        set { _meetingList = value; }
    }

    /// <summary>List of Agenda.</summary>
    public IList<DcnmAgendaTopicStatusInfo> AgendaList
    {
        get { return _agendaList; }
        set { _agendaList = value; }
    }

    /// <summary>Instance of active meeting.</summary>
    public DcnmMeetingStatusInfo ActiveMeeting
    {
        get { return _activeMeeting; }
        set { _activeMeeting = value; }
    }

    /// <summary>Indicates whether possible to activate a meeting.</summary>
    public bool CanActivateMeeting
    {
        get
        {
            return controlMeeting.CanActivateMeeting;
        }
    }

    /// <summary>Indicates whether possible to control meeting.</summary>
    public bool CanControlMeeting
    {
        get
        {
            return controlMeeting.CanControlMeeting;
        }
    }

    #endregion

    #region Fields

    IList<DcnmAgendaTopicStatusInfo> _agendaList = new List<DcnmAgendaTopicStatusInfo>();

    IList<DcnmMeetingStatusInfo> _meetingList = new List<DcnmMeetingStatusInfo>();

    DcnmMeetingStatusInfo _activeMeeting;
    #endregion
}

  • Usage Example

    C#
    Copy
    {
    .
    .
    .
    MeetingControl meetingController = new MeetingControl();
    Guid activeMeetingId;

    // Request meeting list.
    meetingController.RequestMeetingsList();

    // Request the list of agenda.
    meetingController.RequestAgendaForPreparedMeeting(meetingId);

    // Printing the state of meeting before activating the meeting.
    Console.WriteLine(meetingController.MeetingList[0].State.ToString());

    meetingController.ActivateMeeting(meetingController.MeetingList[0]);
    Console.WriteLine(meetingController.ActiveMeeting.State.ToString());

    activeMeetingId = meetingController.ActiveMeeting.MeetingId;

    meetingController.OpenMeeting();
    Console.WriteLine(meetingController.ActiveMeeting.State.ToString())

    // Open first agenda of the meeting.
    if (meetingController.ActiveMeeting.AgendaList.Count > 0)
    {
        meetingController.OpenAgendaTopic(meetingController.ActiveMeeting.AgendaList[0].AgendaTopicId);
    }

    // To close a meeting.
    meetingController.CloseMeeting();
    Console.WriteLine(meetingController.ActiveMeeting.State.ToString());

    // To Deactivate a meeting.
    meetingController.DeactivateMeeting();
    Console.WriteLine(meetingController.ActiveMeeting.State.ToString());
    .
    .
    .

}
    Note Note

    activeMeetingId can be used as parameter for RequestVotingListForMeeting method in the How to control votings


How to control microphones

Discuss Management allows controlling the microphones in the conference hall. Typical control issues are e.g.: turning a Microphone on/off, adding a participant to the waiting list, changing the Discussion settings etc.

Discuss management is controlled by the IControlSpeaker interface and consist of the following parts:

  • Speaker-list control

  • Waiting-List control

  • Priority-list control

  • Response-list control

Note Note

In order to use the control functions on the interface the seat whereto the API is assigned to must have the CanManage rights (either from the seat or from the participant, see User-Rights ). This also includes that the API must be connected as device in order to manage the discussion, see How to Connect.

Beside the control of the discussion the API also provides the ability to operate for a specific assigned participant. This participant can join the discussion using the ISpeak interface as provides the following functions.

  • Request for speech: Depending on the selected discussion mode the request is honored immediately (added to the speaker-list) or the participant is put into the waiting list.

  • Mute its speech: Disabled temporarily the microphone without removing the participant from the speaker-list.

Note Note

In order to use the speak function the API must be connected as a device, see How to Connect

Note Note

When using the API to act as a participant, no real audio is present unless to the same seat also a DICENTIS device is connected.

A chairman is the leader of the meeting and (in general) keeps the overview of the meeting and the discussions about the subjects. When discussions take too long or deviates from the subject, the chairman can interrupt the discussion. In order to differentiate a chairman with normal participants the chairman has got the Can Priority participant right, see User-Rights.

Retrieving the speaker-list

  1. Get the IControlSpeaker object using the WindowsApiInstance

  2. Check whether the API is allowed to control speakers by checking the CanControlSpeaker property.

  3. Register for changes on the speaker-list using the SpeakersListChanged event. This ensure that your application does received an updated speaker-list when it changes.

  4. During setup of the application you like to have the current state of the speaker-list without waiting for the speaker-list to be changed. Use the RequestSpeakersListAsync(ActionTaskBoolean) method to trigger and speaker-list update for the API. The result is send using the event handler.

  5. Manage the speaker-list by using the methods: GrantSpeechAsync(Guid, ActionTaskBoolean), CancelSpeakersAsync(IListGuid, ActionTaskBoolean) and the shift functions (when also having the waiting lilst): ShiftFirstRequestAsync(ActionTaskBoolean) and ShiftRequestsAsync(IListGuid, ActionTaskBoolean).

    Note Note

    The described techniques for retrieving the list is also applicable for the waiting and the priority lists.

Joining a discussion as participant

  1. Get the ISpeak object using the WindowsApiInstance

  2. Check whether the API is allowed to control speakers by checking the CanIssueRequest property.

  3. Add event handlers to the appropriate events in order to get notified whether the speech is granted, rejected or you are placed in (removed from) the waiting-list.

  4. Request for speech using the method IssueRequestToSpeakAsync(ActionTaskBoolean)

  5. Cancel your speech using the method CancelRequestAsync(ActionTaskBoolean)

Joining a discussion as a participant having special rights (VIP)

  1. Add event handlers to the appropriate events in order to get notified whether the speech is granted, rejected.

  2. Request for speech using the method IssueImportantRequestToSpeakAsync(ActionTaskBoolean)

  3. Cancel your speech using the method CancelImportantRequestAsync(ActionTaskBoolean)

Joining a discussion as a chairman

  1. Get the IControlSpeaker and the IAttention objects using the WindowsApiInstance

  2. Check whether the API is allowed to control speakers by checking the CanControlSpeaker property and the CanIssuePriority

  3. Add event handlers to the appropriate events in order to get notified whether the priority is granted.

  4. Request for speech using the method IssuePriorityAsync(ActionTaskBoolean) on the IAttention interface

  5. Cancel your speech using the method StopPriorityAsync(ActionTaskBoolean)

See Also

Reference

CanIssueRequest
CanControlSpeaker
CanIssuePriority

Other Resources

User-Rights
How to Connect


How to control votings

People Vote in a meeting for the following reasons:

  1. formal decision taking / formal approval.

  2. elect someone.

  3. get feedback on a certain subject.

Voting can be done by hand, by paper or electronically.

This section of "How To" focuses on setting up and controlling a voting, electronically. The described steps assume that for the current meeting a voting script is made.

Note Note

In order to complete the steps described below, the following pre-conditions have to be fulfilled:

  • The API has to be connected to the system, see System Connection setup

  • The API-client is discovered as a device by the server. It needs to be assigned to a seat and given manage rights. (See Seat rights settings).

  • The special licenses, premium licenses or ultimate licenses must be present.

Controlling the voting flow

  • A voting has several states to present information and collect the voting results. Using the IControlVoting interface the API application can control the flow of the voting.

    The image below depicts the state diagram of a voting.

    A voting is divided into three main states, which are further divided into actual states. In the table below the states are described.

    Main state

    DcnmVotingState state

    Description

    Idle

    The voting is idle. The voting parameters can be changed/edited and even deleted.

    Closed

    The voting is Closed. This is the initial state of the voting when it has not been run yet.

    Ready

    The voting is Ready to be opened. The information of the voting like the subject is presented to the participants on their conference device to inform them of the fact that a voting is going to be run.

    Running

    The voting is running and the voting parameters cannot be changed. The following actions are blocked for this voting:

    • Change of any element in the voting.

    • Delete of the voting.

    Opened

    The voting is opened, meaning that the participants can cast their vote on the subject. Participants can view the progress and interim results of the voting.

    OnHold

    The voting is put to hold. The participants cannot cast their vote until the voting is resumed. Participants can view the results of the voting.

    Done

    The voting is closed. The results are final and ready for the chairman to be accepted or rejected. Participants can view the results of the voting.

    Finished

    The voting is finished and the results will be stored.

    Accepted

    The outcome of the voting have been formally accepted by the chairman. The voting results are stored.

    Rejected

    The outcome of the voting has been formally rejected by the chairman. The voting results are nevertheless stored.

    Canceled

    The voting is aborted and all voting results are discarded. The voting results are stored without any result.

  • Controlling the voting sequence can be done by using it's actual state, initially starting in state: Closed.

    The table below defines the action to execute to change the voting state.

    Action performed

    New state of the voting

    From state Closed:

    voteControl.ActivateVotingAsync(votingId);

    Ready

    From state Ready:

    voteControl.DeactivateVotingAsync(false);

    Closed

    voteControl.OpenVotingAsync();

    Opened

    From state Opened:

    voteControl.HoldVotingAsync();

    OnHold

    voteControl.CloseVotingAsync();

    Done

    voteControl.DeactivateVotingAsync(false);

    Cancelled

    From state OnHold:

    voteControl.ResumeVotingAsync();

    Opened

    voteControl.CloseVotingAsync();

    Done

    voteControl.DeactivateVotingAsync(false);

    Cancelled

    From state Done:

    voteControl.DeactivateVotingAsync(true);

    Accepted

    voteControl.DeactivateVotingAsync(false);

    Rejected

    Note Note

    The boolean parameter in the method DeactivateVotingAsync(Boolean, ActionTaskBoolean) is only used when the voting is in the state Done. It then defines whether the voting is accepted (true) or rejected (false). In any other state the value of the parameter is ignored.

Prepared Voting

A prepared voting round is created by the user. Prepared voting allows the user to create a voting round according to his requirement i.e, the user can choose the voting answer set, voting type, choose interim results type, update description, subject and reference number of a voting round. Below example shows how to activate a prepared voting.

Below example assumes that the active meeting is available in the variable meetingId. For details about meeting control see Meeting and agenda control section.

  • Usage - Activate the prepared voting and make it visible for the participants.

    C#
    Copy
    {
    .
    .
    .

    VotingControl votingController = new VotingControl();

    votingController.RequestVotingListForMeeting(meetingController.ActiveMeeting.MeetingId);

    votingController.ActivateVoting(votingCntroller.VotingList[0]);
    Console.WriteLine(votingController.VotingList[0].State.ToString());

    votingController.OpenVoting();
    Console.WriteLine(votingController.ActiveVoting.State.ToString());

    votingController.HoldVoting();
    Console.WriteLine(votingController.ActiveVoting.State.ToString());

    votingController.ResumeVoting();
    Console.WriteLine(votingController.ActiveVoting.State.ToString());

    votingController.CloseVoting();
    Console.WriteLine(votingController.ActiveVoting.State.ToString());

    votingController.DecativateVoting();
    Console.WriteLine(votingController.ActiveVoting.State.ToString());

    .
    .
    .
}

  • Sample implementation.

    C#
    Copy
    public class VotingControl
{
    public VotingControl()
    {
        controlVoting = WindowsApiInstance.ControlVoting;
        controlVoting.VotingScriptForMeetingReceived += OnVotingScriptForMeetingReceived;
    }

    #region Event handlers

    /// <summary>
    /// Handler for VotingScriptForMeetingReceived, which is triggered when a request to get the list of votings is successfully processed.
    /// </summary>
    /// <param name="sender">Control voting api. </param>
    /// <param name="e">List of type DcnmVotingStatusInfo </param>
    private void OnVotingScriptForMeetingReceived(object sender, ApiEventArgs <IList <DcnmVotingStatusInfo>> e)
    {
        votingList = e.Parameter;
    }

    #endregion

    #region Methods
    /// <summary>
    /// Request to retrieve the list of  votings.
    /// </summary>
    /// <param name="meetingId">Meeting id</param>
    /// <returns>True if the request is delivered, else false.</returns>
    public bool RequestVotingListForMeeting(Guid meetingId)
    {
        bool success = false;

        controlVoting.RequestVotingScriptForMeetingAsync(meetingId, (task) =>
        {
            success = task.Result;
        });

        return success;
    }

    /// <summary>
    /// Activates a voting round.
    /// </summary>
    /// <param name="votinginfo">Selected Voting round.</param>
    /// <returns>True if the request is delivered, else false</returns>
    public bool ActivateVoting(DcnmVotingStatusInfo votinginfo)
    {
        bool success = false;

        controlVoting.ActivateVotingAsync(votinginfo.VotingId, (task) =>
        {
            success = task.Result;
        });

        return success;
    }

    #endregion

    #region Properties

    /// <summary>
    /// List of Votings.
    /// </summary>
    public IList <DcnmVotingStatusInfo> VotingList
    {
        get { return votingList; }
        set { votingList = value; }
    }

    #endregion

    #region Fields

    IList <DcnmVotingStatusInfo> votingList;

    IControlVoting controlVoting;

    #endregion
}
Voting Timers

A voting round can be configured to be time bound. In order to receive the changes in remaining voting time, subscribe to RemainingVotingTimeChanged. Remaining voting time is available as event data, which is a string in the format mm:ss.

For detailed description of voting timers, see DcnmVotingTimerType.

Following example is an extension of the above sample implementation.

C#
Copy
public class VotingControl
{
    public VotingControl()
    {
        controlVoting = WindowsApiInstance.ControlVoting;
        controlVoting.VotingScriptForMeetingReceived += OnVotingScriptForMeetingReceived;
        controlVoting.RemainingVotingTimeChanged+= OnRemainingVotingTimeChanged;
    }

    #region Event handlers
    ...
    ...

    /// <summary>
    /// called when the remaining voting time changes.
    /// </summary>
    /// <param name="sender">Control voting api. </param>
    /// <param name="e">Remaining voting time. </param>
    private void OnRemainingVotingTimeChanged(object sender, ApiEventArgs<string> e)
    {
        Console.WriteLine(e.Parameter);
    }

    #endregion

    .
    .

    #region Fields
    ...
    ...

    IControlVoting controlVoting;

    ...
    #endregion
}
Voting Results

  • Voting results are categorized into two types of results.:

    • Individual Voting Results is comprised of DcnmPersonInfo, and DcnmVotingAnswer. Individual voting results and total results are received when voting type is set to OpenWithTotalAndIndividualInterimResults of DcnmVotingType

    • Total Voting Results is comprised of DcnmVotingAnswer. and Count. Total voting results are received when voting type is set to OpenWithTotalInterimResults or SecretBallotWithTotalInterimResults of DcnmVotingType

    Note Note

    If the voting type is set to PreventInfluence or SecretBallotWithNoInterimResults of DcnmVotingType, then voting results are received only when the state of the voting round is either Closed or OnHold of DcnmVotingState

  • Following steps describe how to manage voting results, which is common to all types of voting (Prepared Voting, Ad-hoc Voting and Basic Voting).

    1. Get a reference to the voting results API using the WindowsApiInstance:

      C#
      Copy
      IVotingResult votingResult = MainWindowApi.VotingResult

    2. Changes on the voting results can be received by registering to below events:

      • IndividualVotingResultUpdated : for individual results.

      • VotingResultUpdated : for total results.

    3. To be able to receive the available voting results when the application starts, call:

      • RequestIndividualVotingResultAsync(ActionTaskBoolean) for individual results. This will trigger IndividualVotingResultUpdated and the individual result list will be updated.

        C#
        Copy
        public void GetIndividualVotingResults()
{
    votingResult.RequestIndividualVotingResultAsync((task) =>
    {
        bool success = task.Result;
        if (!success)
        {
            // Error handling...
        }
    });
}

      • RequestVotingResultAsync(ActionTaskBoolean) for total results. This will trigger VotingResultUpdated and the total result list will be updated.

        C#
        Copy
        public void GetTotalVotingResults()
{
    votingResult.RequestVotingResultAsync((task) =>
    {
        bool success = task.Result;
        if (!success)
        {
            // Error handling...
        }
    });
}
See Also

Reference

DcnmVotingState
IControlVoting

Other Resources

How to control Meetings


How to make your own External Video Switcher

This section provides a high-level description of how to make your own external video switcher implementation that uses the DICENTIS network based conference system.

What to make

  • Create your own application which connects the camera-id's provided by the API to an input of your specific video-switcher.

  • Within your own application, listen to the necessary events on the API. The triggered events inform which camera was the last active camera in the system. With the information from these events, you can implement the required actions towards your specific video-switcher.

Usage of the API

  • Read the API documentation on how to use the API.

  • Connect to the API as a device, using How to setup the connection with the system.

Retrieving the connected cameras

  • Use the API function GetCamerasAsync(ActionTaskIListDcnmCameraPreparationInfo) to retrieve a list of DcnmCameraPreparationInfo objects.

  • These objects contain properties like Id and Name.

  • With this you can build your list of connected camera's to the system within your own application.

Receiving triggers of the last active camera

  • Subscribe to the CameraActiveStateChanged event. This event returns a DcnmCameraStatusInfo object with the content CameraId and Active. This indicates which camera was the last one that was active.

  • This CameraId you can use to identify the corresponding camera in your system e.g. by matching it to the list of connected camera's and this match will give you the corresponding camera name.

See Also

Reference

IPrepareCamera
IControlCamera
DcnmCameraStatusInfo
DcnmCameraPreparationInfo


DICENTIS API Reference

This help file describes the DICENTIS Application Programming Interface.
Namespaces
Namespace | Description
Bosch.Dcnm.Interfaces.Api | Main entry namespace for the API. This namespace holds the main entry classes to retrieve the interfaces implementation object as defined in the Interfaces namespace.
Bosch.Dcnm.Interfaces.Api.Interfaces | Namespace holding the interfaces of the DICENTIS API.
Bosch.Dcnm.Interfaces.Api.Logic.Plugins | Namespace holding the interfaces of the Plugins.
Bosch.Dcnm.Interfaces.Api.Services | Namespace holding the interfaces of the Services.


Bosch.Dcnm.Interfaces.Api Namespace

Main entry namespace for the API. This namespace holds the main entry classes to retrieve the interfaces implementation object as defined in the Interfaces namespace.
Classes
 | Class | Description
Public class | WindowsApiInstance | Main entry of the Windows API. This class is used to retrieve the specific functional interfaces and provides logging functionality for the higher application.


WindowsApiInstance Class

Main entry of the Windows API. This class is used to retrieve the specific functional interfaces and provides logging functionality for the higher application.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.ApiWindowsApiInstance

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class WindowsApiInstance : IDisposable
Public Class WindowsApiInstance
    Implements IDisposable
public ref class WindowsApiInstance : IDisposable

The WindowsApiInstance type exposes the following members.

Constructors
 | Name | Description
Public method | WindowsApiInstance | Constructor of WindowsApiInstance.
Top
Properties
 | Name | Description
Public property | Attention | Gets the object implementing the IAttention interface to handle priority in the system.
Public property | Base | The base interface to the Windows API.
Public property | ConfigArea | The area interface to configure areas.
Public property | ConfigInterpretation | The interface to configure interpretation.
Public property | ConfigLanguage | The interface to configure languages.
Public property | ConfigSite | The site interface to configure sites.
Public property | ConfigUserDefinedDeviceInstances | The area interface to configure user defined device instance.
Public property | ControlDiscussion | The interface to control a discussion.
Public property | ControlInterpretation | The interface to control interpretation.
Public property | ControlMeeting | The interface to control a meeting.
Public property | ControlParticipant | The interface to control a participant.
Public property | ControlPresentationApi | Gets the control presentation API.
Public property | ControlSpeaker | The interface to control a speaker.
Public property | ControlVoting | The interface to control a voting.
Public property | Device | The device specific interface to the Windows API.
Public property | Equipment | The equipment interface to manage devices.
Public property | InstallArea | The area interface to install areas.
Public property | NotesFiles | An interface for operation related to meeting and voting notes xml's.
Public property | Plugins | Plugin interface to allow third party components to communicate with one another.
Public property | PrepareAgendaTopic | The interface to prepare agenda topics.
Public property | PrepareDiscussion | The interface to prepare discussion.
Public property | PrepareMeeting | The interface to prepare meetings.
Public property | PrepareParticipant2 | The interface to prepare participants.
Public property | PrepareSystemChannels | Gets the system channels preparation API.
Public property | PrepareVoting | The interface to prepare voting
Public property | RegisterPerson | The interface to register a person.
Public property | RegisterUser | The interface to register a user.
Public property | Speaker | The speakers interface to participate in a discussion.
Public property | SystemAudioControlApi | Gets the system audio control API.
Public property | Voting | The voting interface to participate in a voting.
Public property | VotingResult | The interface for the voting result.
Top
Methods
 | Name | Description
Public method | Dispose | Dispose method.
Protected method | Dispose(Boolean) | Dispose method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Shutdown | Closes the api.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance Constructor

Constructor of WindowsApiInstance.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public WindowsApiInstance()
Public Sub New
public:
WindowsApiInstance()
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance Properties

The WindowsApiInstance type exposes the following members.

Properties
 | Name | Description
Public property | Attention | Gets the object implementing the IAttention interface to handle priority in the system.
Public property | Base | The base interface to the Windows API.
Public property | ConfigArea | The area interface to configure areas.
Public property | ConfigInterpretation | The interface to configure interpretation.
Public property | ConfigLanguage | The interface to configure languages.
Public property | ConfigSite | The site interface to configure sites.
Public property | ConfigUserDefinedDeviceInstances | The area interface to configure user defined device instance.
Public property | ControlDiscussion | The interface to control a discussion.
Public property | ControlInterpretation | The interface to control interpretation.
Public property | ControlMeeting | The interface to control a meeting.
Public property | ControlParticipant | The interface to control a participant.
Public property | ControlPresentationApi | Gets the control presentation API.
Public property | ControlSpeaker | The interface to control a speaker.
Public property | ControlVoting | The interface to control a voting.
Public property | Device | The device specific interface to the Windows API.
Public property | Equipment | The equipment interface to manage devices.
Public property | InstallArea | The area interface to install areas.
Public property | NotesFiles | An interface for operation related to meeting and voting notes xml's.
Public property | Plugins | Plugin interface to allow third party components to communicate with one another.
Public property | PrepareAgendaTopic | The interface to prepare agenda topics.
Public property | PrepareDiscussion | The interface to prepare discussion.
Public property | PrepareMeeting | The interface to prepare meetings.
Public property | PrepareParticipant2 | The interface to prepare participants.
Public property | PrepareSystemChannels | Gets the system channels preparation API.
Public property | PrepareVoting | The interface to prepare voting
Public property | RegisterPerson | The interface to register a person.
Public property | RegisterUser | The interface to register a user.
Public property | Speaker | The speakers interface to participate in a discussion.
Public property | SystemAudioControlApi | Gets the system audio control API.
Public property | Voting | The voting interface to participate in a voting.
Public property | VotingResult | The interface for the voting result.
Top
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.Attention Property

DICENTIS API documentation

WindowsApiInstanceAttention Property

Gets the object implementing the IAttention interface to handle priority in the system.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IAttention Attention { get; }
Public ReadOnly Property Attention As IAttention
    Get
public:
virtual property IAttention^ Attention {
    IAttention^ get () sealed;
}

Property Value

Type: IAttention
Reference to the object implementing the IAttention interface or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.Base Property

WindowsApiInstanceBase Property

The base interface to the Windows API.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IApi Base { get; }
Public ReadOnly Property Base As IApi
    Get
public:
virtual property IApi^ Base {
    IApi^ get () sealed;
}

Property Value

Type: IApi
Reference to the object.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.ConfigArea Property

WindowsApiInstanceConfigArea Property

The area interface to configure areas.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IConfigArea ConfigArea { get; }
Public ReadOnly Property ConfigArea As IConfigArea
    Get
public:
virtual property IConfigArea^ ConfigArea {
    IConfigArea^ get () sealed;
}

Property Value

Type: IConfigArea
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.ConfigInterpretation Property

WindowsApiInstanceConfigInterpretation Property

The interface to configure interpretation.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IConfigInterpretation ConfigInterpretation { get; }
Public ReadOnly Property ConfigInterpretation As IConfigInterpretation
    Get
public:
virtual property IConfigInterpretation^ ConfigInterpretation {
    IConfigInterpretation^ get () sealed;
}

Property Value

Type: IConfigInterpretation
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.ConfigLanguage Property

WindowsApiInstanceConfigLanguage Property

The interface to configure languages.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IConfigLanguage ConfigLanguage { get; }
Public ReadOnly Property ConfigLanguage As IConfigLanguage
    Get
public:
virtual property IConfigLanguage^ ConfigLanguage {
    IConfigLanguage^ get () sealed;
}

Property Value

Type: IConfigLanguage
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.ConfigSite Property

WindowsApiInstanceConfigSite Property

The site interface to configure sites.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IConfigSite ConfigSite { get; }
Public ReadOnly Property ConfigSite As IConfigSite
    Get
public:
virtual property IConfigSite^ ConfigSite {
    IConfigSite^ get () sealed;
}

Property Value

Type: IConfigSite
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.ConfigUserDefinedDeviceInstances Property

WindowsApiInstanceConfigUserDefinedDeviceInstances Property

The area interface to configure user defined device instance.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IConfigUserDefinedDeviceInstances ConfigUserDefinedDeviceInstances { get; }
Public ReadOnly Property ConfigUserDefinedDeviceInstances As IConfigUserDefinedDeviceInstances
    Get
public:
virtual property IConfigUserDefinedDeviceInstances^ ConfigUserDefinedDeviceInstances {
    IConfigUserDefinedDeviceInstances^ get () sealed;
}

Property Value

Type: IConfigUserDefinedDeviceInstances
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.ControlDiscussion Property

WindowsApiInstanceControlDiscussion Property

The interface to control a discussion.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IControlDiscussion ControlDiscussion { get; }
Public ReadOnly Property ControlDiscussion As IControlDiscussion
    Get
public:
virtual property IControlDiscussion^ ControlDiscussion {
    IControlDiscussion^ get () sealed;
}

Property Value

Type: IControlDiscussion
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.ControlInterpretation Property

WindowsApiInstanceControlInterpretation Property

The interface to control interpretation.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IControlInterpretation ControlInterpretation { get; }
Public ReadOnly Property ControlInterpretation As IControlInterpretation
    Get
public:
virtual property IControlInterpretation^ ControlInterpretation {
    IControlInterpretation^ get () sealed;
}

Property Value

Type: IControlInterpretation
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.ControlMeeting Property

WindowsApiInstanceControlMeeting Property

The interface to control a meeting.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IControlMeeting ControlMeeting { get; }
Public ReadOnly Property ControlMeeting As IControlMeeting
    Get
public:
virtual property IControlMeeting^ ControlMeeting {
    IControlMeeting^ get () sealed;
}

Property Value

Type: IControlMeeting
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.ControlParticipant Property

WindowsApiInstanceControlParticipant Property

The interface to control a participant.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IControlParticipant ControlParticipant { get; }
Public ReadOnly Property ControlParticipant As IControlParticipant
    Get
public:
virtual property IControlParticipant^ ControlParticipant {
    IControlParticipant^ get () sealed;
}

Property Value

Type: IControlParticipant
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.ControlPresentationApi Property

WindowsApiInstanceControlPresentationApi Property

Gets the control presentation API.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IControlPresentation ControlPresentationApi { get; }
Public ReadOnly Property ControlPresentationApi As IControlPresentation
    Get
public:
virtual property IControlPresentation^ ControlPresentationApi {
    IControlPresentation^ get () sealed;
}

Property Value

Type: IControlPresentation
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.ControlSpeaker Property

WindowsApiInstanceControlSpeaker Property

The interface to control a speaker.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IControlSpeaker ControlSpeaker { get; }
Public ReadOnly Property ControlSpeaker As IControlSpeaker
    Get
public:
virtual property IControlSpeaker^ ControlSpeaker {
    IControlSpeaker^ get () sealed;
}

Property Value

Type: IControlSpeaker
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.ControlVoting Property

WindowsApiInstanceControlVoting Property

The interface to control a voting.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IControlVoting ControlVoting { get; }
Public ReadOnly Property ControlVoting As IControlVoting
    Get
public:
virtual property IControlVoting^ ControlVoting {
    IControlVoting^ get () sealed;
}

Property Value

Type: IControlVoting
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.Device Property

WindowsApiInstanceDevice Property

The device specific interface to the Windows API.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IDeviceApi Device { get; }
Public ReadOnly Property Device As IDeviceApi
    Get
public:
virtual property IDeviceApi^ Device {
    IDeviceApi^ get () sealed;
}

Property Value

Type: IDeviceApi
Reference to the object.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.Equipment Property

WindowsApiInstanceEquipment Property

The equipment interface to manage devices.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IEquipment Equipment { get; }
Public ReadOnly Property Equipment As IEquipment
    Get
public:
virtual property IEquipment^ Equipment {
    IEquipment^ get () sealed;
}

Property Value

Type: IEquipment
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.InstallArea Property

WindowsApiInstanceInstallArea Property

The area interface to install areas.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IInstallArea InstallArea { get; }
Public ReadOnly Property InstallArea As IInstallArea
    Get
public:
virtual property IInstallArea^ InstallArea {
    IInstallArea^ get () sealed;
}

Property Value

Type: IInstallArea
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.NotesFiles Property

WindowsApiInstanceNotesFiles Property

An interface for operation related to meeting and voting notes xml's.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public INotesFiles NotesFiles { get; }
Public ReadOnly Property NotesFiles As INotesFiles
    Get
public:
virtual property INotesFiles^ NotesFiles {
    INotesFiles^ get () sealed;
}

Property Value

Type: INotesFiles
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.Plugins Property

WindowsApiInstancePlugins Property

Plugin interface to allow third party components to communicate with one another.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IPlugin Plugins { get; }
Public ReadOnly Property Plugins As IPlugin
    Get
public:
virtual property IPlugin^ Plugins {
    IPlugin^ get () sealed;
}

Property Value

Type: IPlugin
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.PrepareAgendaTopic Property

WindowsApiInstancePrepareAgendaTopic Property

The interface to prepare agenda topics.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IPrepareAgendaTopic PrepareAgendaTopic { get; }
Public ReadOnly Property PrepareAgendaTopic As IPrepareAgendaTopic
    Get
public:
virtual property IPrepareAgendaTopic^ PrepareAgendaTopic {
    IPrepareAgendaTopic^ get () sealed;
}

Property Value

Type: IPrepareAgendaTopic
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.PrepareDiscussion Property

WindowsApiInstancePrepareDiscussion Property

The interface to prepare discussion.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IPrepareDiscussion PrepareDiscussion { get; }
Public ReadOnly Property PrepareDiscussion As IPrepareDiscussion
    Get
public:
virtual property IPrepareDiscussion^ PrepareDiscussion {
    IPrepareDiscussion^ get () sealed;
}

Property Value

Type: IPrepareDiscussion
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.PrepareMeeting Property

WindowsApiInstancePrepareMeeting Property

The interface to prepare meetings.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IPrepareMeeting PrepareMeeting { get; }
Public ReadOnly Property PrepareMeeting As IPrepareMeeting
    Get
public:
virtual property IPrepareMeeting^ PrepareMeeting {
    IPrepareMeeting^ get () sealed;
}

Property Value

Type: IPrepareMeeting
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.PrepareParticipant2 Property

WindowsApiInstancePrepareParticipant2 Property

The interface to prepare participants.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IPrepareParticipant2 PrepareParticipant2 { get; }
Public ReadOnly Property PrepareParticipant2 As IPrepareParticipant2
    Get
public:
virtual property IPrepareParticipant2^ PrepareParticipant2 {
    IPrepareParticipant2^ get () sealed;
}

Property Value

Type: IPrepareParticipant2
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.PrepareSystemChannels Property

WindowsApiInstancePrepareSystemChannels Property

Gets the system channels preparation API.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IPrepareSystemChannels PrepareSystemChannels { get; }
Public ReadOnly Property PrepareSystemChannels As IPrepareSystemChannels
    Get
public:
virtual property IPrepareSystemChannels^ PrepareSystemChannels {
    IPrepareSystemChannels^ get () sealed;
}

Property Value

Type: IPrepareSystemChannels
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.PrepareVoting Property

WindowsApiInstancePrepareVoting Property

The interface to prepare voting

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IPrepareVoting PrepareVoting { get; }
Public ReadOnly Property PrepareVoting As IPrepareVoting
    Get
public:
virtual property IPrepareVoting^ PrepareVoting {
    IPrepareVoting^ get () sealed;
}

Property Value

Type: IPrepareVoting
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.RegisterPerson Property

WindowsApiInstanceRegisterPerson Property

The interface to register a person.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IPreparePerson RegisterPerson { get; }
Public ReadOnly Property RegisterPerson As IPreparePerson
    Get
public:
virtual property IPreparePerson^ RegisterPerson {
    IPreparePerson^ get () sealed;
}

Property Value

Type: IPreparePerson
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.RegisterUser Property

WindowsApiInstanceRegisterUser Property

The interface to register a user.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IPrepareUser RegisterUser { get; }
Public ReadOnly Property RegisterUser As IPrepareUser
    Get
public:
virtual property IPrepareUser^ RegisterUser {
    IPrepareUser^ get () sealed;
}

Property Value

Type: IPrepareUser
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.Speaker Property

WindowsApiInstanceSpeaker Property

The speakers interface to participate in a discussion.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public ISpeak Speaker { get; }
Public ReadOnly Property Speaker As ISpeak
    Get
public:
virtual property ISpeak^ Speaker {
    ISpeak^ get () sealed;
}

Property Value

Type: ISpeak
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.SystemAudioControlApi Property

WindowsApiInstanceSystemAudioControlApi Property

Gets the system audio control API.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public ISystemAudioControl SystemAudioControlApi { get; }
Public ReadOnly Property SystemAudioControlApi As ISystemAudioControl
    Get
public:
virtual property ISystemAudioControl^ SystemAudioControlApi {
    ISystemAudioControl^ get () sealed;
}

Property Value

Type: ISystemAudioControl
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.Voting Property

WindowsApiInstanceVoting Property

The voting interface to participate in a voting.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IVote Voting { get; }
Public ReadOnly Property Voting As IVote
    Get
public:
virtual property IVote^ Voting {
    IVote^ get () sealed;
}

Property Value

Type: IVote
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.VotingResult Property

WindowsApiInstanceVotingResult Property

The interface for the voting result.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IVotingResult VotingResult { get; }
Public ReadOnly Property VotingResult As IVotingResult
    Get
public:
virtual property IVotingResult^ VotingResult {
    IVotingResult^ get () sealed;
}

Property Value

Type: IVotingResult
Reference to the object or null if unavailable for use.
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance Methods

The WindowsApiInstance type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose method.
Protected method | Dispose(Boolean) | Dispose method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Shutdown | Closes the api.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.Dispose Method

WindowsApiInstanceDispose Method

Overload List
 | Name | Description
Public method | Dispose | Dispose method.
Protected method | Dispose(Boolean) | Dispose method.
Top
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.Dispose Method

WindowsApiInstanceDispose Method

Dispose method.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

WindowsApiInstance Class
Dispose Overload
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.Dispose Method (Boolean)

WindowsApiInstanceDispose Method (Boolean)

 Bosch Logo
Dispose method.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
protected void Dispose(
    bool disposing
)
Protected Sub Dispose (
    disposing As Boolean
)
protected:
void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

WindowsApiInstance Class
Dispose Overload
Bosch.Dcnm.Interfaces.Api Namespace


WindowsApiInstance.Shutdown Method

WindowsApiInstanceShutdown Method

Closes the api.

Namespace: Bosch.Dcnm.Interfaces.Api
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public void Shutdown()
Public Sub Shutdown
public:
virtual void Shutdown() sealed
See Also

Reference

WindowsApiInstance Class
Bosch.Dcnm.Interfaces.Api Namespace


Bosch.Dcnm.Interfaces.Api.Interfaces Namespace

Namespace holding the interfaces of the DICENTIS API.
Classes
 | Class | Description
Public class | ApiEventArgsT | This is the definition for a generic eventargs class with one parameter.
Public class | ApiOperationFailedException | Exception for Api failures. Will be thrown when a caller isn't able to enter a function which isn't released by the previous caller.
Public class | AudioSettingConstants | The AudioSetting constants
Public class | BoothNotifications | The supported Booth notifications.
Public class | ConfigurationConstants | The Configuration constants
Public class | DcnmActionCommand | Defines the type of action.
Public class | DcnmAgendaTopicPreparationInfo | Agenda topic definition.
Public class | DcnmAgendaTopicStatusInfo | Agenda topic definition.
Public class | DcnmApplicationInfo | Contains the application info in the DICENTIS system.
Public class | DcnmAreaConfigurationInfo | Represents a container for the information about an area.
Public class | DcnmAttendanceInfo | Contains the attendance summary of the participant in the active meeting.
Public class | DcnmAudioEqualizerSettings | Container holding the equalizer settings.
Public class | DcnmAudioGainSetting | The gain setting supported by the Dcnm system.
Public class | DcnmAudioSelectionSetting | The audio selection setting supported by the Dcnm system.
Public class | DcnmBoothNotificationInfo | Represents the booth notification info.
Public class | DcnmCameraPreparationInfo | Container for the camera preparation information.
Public class | DcnmCameraStatusInfo | Represents a container for the information about a camera.
Public class | DcnmChannelMappingInfo | Map which can be descriptive to a channel as input or output
Public class | DcnmDeskConfiguration | Represents the desk configuration.
Public class | DcnmDeviceAtSeat | Device information assigned at seat.
Public class | DcnmDeviceCapabilities | Represents a container for the capabilities of a device.
Public class | DcnmDeviceInfo | Defines a container for the information about a device.
Public class | DcnmDiscussionInfo | The discussion info supported by the Dcnm system.
Public class | DcnmDiscussionOptions | The different discussion options supported by the Dcnm system.
Public class | DcnmDiscussionPreparationInfo | Message container for the discussion preparation info.
Public class | DcnmDocumentVerificationResponse | Class holds details of verification of document.
Public class | DcnmFlushDevicePanelInfo | Class representing the flush device panel information.
Public class | DcnmGainSetting | Obsolete. The gain setting supported by the Dcnm system.
Public class | DcnmImageServerInfo | Defines the container for Dcnm image server info.
Public class | DcnmIndividualVotingResult | Contains voting result information
Public class | DcnmInterpretationLanguageId | Represents the interpretation language.
Public class | DcnmInterpretationLanguageInfo | Represents the interpretation language info
Public class | DcnmInterpretationMetaRequestInfo | Class hold interpretation meta request status
Public class | DcnmInterpretationRoutingInfo | Represents the interpretation routing info
Public class | DcnmInterpretationSeatMetaRequestInfo | Class hold seat with active interpretation requests.
Public class | DcnmInterpretationSettingsInfo | Class representing the interpretation settings information.
Public class | DcnmLanguageInfo | Represents the language information.
Public class | DcnmLanguageStream | Audio stream source.
Public class | DcnmMajorityResult | Class holds majority results.
Public class | DcnmMeetingBoothInfo | Class representinng the meeting booth information within a meeting
Public class | DcnmMeetingDeskInfo | Class representing the prepared desk information.
Public class | DcnmMeetingLanguageInfo | Class representing the meeting language information within a meeting.
Public class | DcnmMeetingPreparationInfo | Container holding the information of a meeting.
Public class | DcnmMeetingStatusInfo | Container holding the information of a meeting.
Public class | DcnmMicrophoneOptions | The microphone options
Public class | DcnmMicrophoneSensitivityForSeat | Container holding the microphone sensitivity settings of a seat.
Public class | DcnmNotesFileInfo | Represents the notes file information.
Public class | DcnmOverviewCameraPreparationInfo | Container for the overview camera information.
Public class | DcnmParticipantAccessDeniedInfo | Contains the participant access denied reasons
Public class | DcnmParticipantAndUserInfo | Defines the container for participant and user information.
Public class | DcnmParticipantInfo | Defines the container for Dcnm participant information.
Public class | DcnmParticipantPreparationInfo | Defines the container for Dcnm user information.
Public class | DcnmParticipantPreparationInfo2 | Defines the container for Dcnm user information.
Public class | DcnmParticipantSeatAssignmentInfo | Container for participant seat assignment info.
Public class | DcnmParticipationInfo | Contains the participation info for the participant in the active meeting.
Public class | DcnmParticipationListInfo | Contains the participation info for the participants in a prepared meeting and is retreived during an active meeting.
Public class | DcnmPersonInfo | Contains the person information.
Public class | DcnmPluginCommand | A command message that gets sent from an API client to a plugin
Public class | DcnmPluginCommandDescription | Describes a single command that can be executed on a plugin
Public class | DcnmPluginDescription | Describes a plugin
Public class | DcnmPluginEvent | An event sent by a plugin
Public class | DcnmPluginEventDescription | Describes an event that can be generated by a plugin
Public class | DcnmPluginRegistrations | Maintains changes in plugin registrations
Public class | DcnmPriorityOptions | The priority settings for the active discussion
Public class | DcnmQuorumInfo | Holds quorum information.
Public class | DcnmQuorumResult | Class repesents quorum results.
Public class | DcnmRequesterInfo | Defines a request entry
Public class | DcnmRequestToResponseOptions | Defines a container for the request to response options.
Public class | DcnmRequestToSpeakOptions | Defines a container for the request to speak options.
Public class | DcnmRoomAudioSettingsInfo | Implementation of the DcnmRoomAudioSettingsInfo class.
Public class | DcnmSeatAssignmentInfo | Represents a container for seat installation information.
Public class | DcnmSeatConfigurationInfo | Container for the seat information.
Public class | DcnmSeatInfo | Container for the seat information.
Public class | DcnmSpeakerInfo | Defines a speaker entry in the speakersList
Public class | DcnmSpeakerViewingOptions | The different speaker viewing options supported by the Dcnm system.
Public class | DcnmSpeechTimerInfo | Contains speech timer information
Public class | DcnmSpeechTimerOptions | Message container for the speech timer options
Public class | DcnmSystemChannelMappingNumbers | DcnmSystemChannelMappingNumbers class statically defines the system channel numbers for the mapping.
Public class | DcnmTemplatePreparationInfo | Message container for the template preparation info.
Public class | DcnmUserAccountPreparationInfo | Defines a container for the user account info.
Public class | DcnmUserDefinedDeviceInstance | User defined device instance.
Public class | DcnmUserInfo | Represents the account of a user logged on, including his personal information.
Public class | DcnmUserPreparationInfo | Defines the container for Dcnm user information.
Public class | DcnmUserSecurityClaimsInfo | Contains user security claims.
Public class | DcnmVoiceModeOptions | Message container for speaker in voice mode options.
Public class | DcnmVoteMajorityInfo | Holds voting majority information.
Public class | DcnmVotingPreparationInfo | Definition of Voting
Public class | DcnmVotingResult | Contains voting result information
Public class | DcnmVotingResultDisplaySetting | Class holds display voting results option.
Public class | DcnmVotingSettingsInfo | Definition of Voting Settings Info
Public class | DcnmVotingStatusInfo | Container holding the information of a voting.
Public class | DcnmVUMeterReadings | Implementation of the DcnmVUMeterReadings class.
Public class | DcnmWaitingSpeakerInfo | Container for the waiting speaker entry.
Public class | DeviceAttributes | The overall set of attributes that can be present at a device.
Public class | DiscussionConstants | The supported discussion constants
Public class | HeadphoneDescription | Tag for headphone name
Public class | InterpreterConstants | The supported interpreter constants
Public class | MeetingConstants | The supported Meeting constants
Public class | VotingConstants | The supported Voting constants
Interfaces
 | Interface | Description
Public interface | IApi | Main interface of the Windows API, providing basic functionality.
Public interface | IAttention | Represents the attention interface to put attention to the meeting.
Public interface | IConfigArea | Represents an interface to configure an area.
Public interface | IConfigInterpretation | Represents the interface to configure interpretation for the default meeting.
Public interface | IConfigLanguage | Represents the interface to configure / extend the languages present in the system
Public interface | IConfigSite | Represents an interface to configure a site.
Public interface | IConfigUserDefinedDeviceInstances | An interface for configuring user defined device instances.
Public interface | IControlCamera | Defines the interface to control the active camera.
Public interface | IControlDiscussion | Defines the interface for discussion control
Public interface | IControlInterpretation | Represents the interface to control interpretation.
Public interface | IControlMeeting | Defines the interface for meeting control
Public interface | IControlParticipant | Defines the interface for participant control
Public interface | IControlPresentation | Interface for control presentation
Public interface | IControlSpeaker | Defines the interface for speaker control
Public interface | IControlVoting | Defines the interface for voting control.
Public interface | IDeviceApi | Special interface providing, on top of the base functionality, the device specific functions.
Public interface | IEquipment | Represents an interface to retrieve info about equipment in the system.
Public interface | IInstallArea | Represents an interface to install an area.
Public interface | INotesFiles | An interface for operation related to meeting and voting notes xml's.
Public interface | IPlugin | Plugin interface to allow third party components to communicate with one another
Public interface | IPluginInstance | Represents Plugin instance interface.
Public interface | IPrepareAgendaTopic | Defines the interface for preparing agenda topics
Public interface | IPrepareCamera | Defines the interface to register cameras.
Public interface | IPrepareDiscussion | Defines the interface for preparing discussions and discussion profiles.
Public interface | IPrepareMeeting | Defines the interface for preparing meetings
Public interface | IPrepareParticipant | Obsolete. Defines the interface for preparing participants
Public interface | IPrepareParticipant2 | Defines the interface for assigning participant , assigning seat to participant, un assigning seat from participant , retrieving and updating screen line format for participants.
Public interface | IPreparePerson | Defines the interface to register users.
Public interface | IPrepareSystemChannels | Defines the interface to create, updated, delete system channels.
Public interface | IPrepareUser | Defines the interface to register users.
Public interface | IPrepareVoting | Interface for the voting preparation
Public interface | IRoomAudioControl | Interface for room audio control
Public interface | ISpeak | Represents an interface to participate in an ongoing discussion.
Public interface | ISystemAudioControl | Obsolete. Interface for system audio control
Public interface | ISystemVideoControl | Interface for system video functions.
Public interface | IVote | Represents an interface to participate in an ongoing voting.
Public interface | IVotingResult | Defines the interface for voting result.
Delegates
 | Delegate | Description
Public delegate | PluginCommandDelegate | Delegate that gets called when a plugin needs to execute a command
Public delegate | PluginEventDelegate | Delegate that gets called when a plugin sends an event to an API application
Enumerations
Enumeration Description
Public enumeration DcnmAccessDeniedReason
Represents various access denied reasons
Public enumeration DcnmAccessMethod
Definition on how it is expected a user will identify/authenticate himself.
Public enumeration DcnmAccessRights
The user group access rights supported by the Dcnm system.
Public enumeration DcnmAcousticFeedbackSuppression
Represents the acoustic feedback suppression
Public enumeration DcnmActionCommandType
Defines the type of action.
Public enumeration DcnmApiState
Represents the open states of the Windows API.
Public enumeration DcnmApplicationState
Represents the system mode states on the device.
Remarks
The system mode state can be modified by changing the IDeviceApi.CurrentApplicationState property as below.
  • To change the system mode state to install mode, IDeviceApi.CurrentApplicationState should be set to DcnmApplicationState.InstallMode
  • To change the system mode state to conference mode, IDeviceApi.CurrentApplicationState should be set to DcnmApplicationState.ConferenceMode
Public enumeration DcnmApplicationType
Defines the web application type.
Public enumeration DcnmAreaType
Defines the available area types within the system.
Public enumeration DcnmAudioEqualizerFilterType
Represents the equalizer filter type
Public enumeration DcnmAudioEqualizerType
Represents the equalizer type
Public enumeration DcnmAudioGainSettingType
The different device types supported by the Dcnm system.
Public enumeration DcnmAudioSelectionSettingType
Enumeration of audio selection setting types.
Public enumeration DcnmCameraControlProtocol
Enum represents camera controlling protocol
Public enumeration DcnmCameraType
The different camera types supported by the Dcnm system.
Public enumeration DcnmChannelMapType
Defines the type a channel map can have.
Public enumeration DcnmChimeTunes
Represents the type of a chimetune.
Public enumeration DcnmComparisonOperators
Defines condition for formulas
Public enumeration DcnmConferenceSecurityClaim
Contains Conference Security rights.
Public enumeration DcnmDeviceConnectionState
The connection states of a device.
Public enumeration DcnmDeviceOperationalState
The different operational states a device can have.
Public enumeration DcnmDeviceType
The different device types supported by the Dcnm system.
Public enumeration DcnmDiscussionMode
The different device types supported by the Dcnm system.
Public enumeration DcnmDiscussionState
The different discussion states supported by the Dcnm system.
Public enumeration DcnmDiscussionType
This hold discussion type participant
Public enumeration DcnmDisplayInterpretationLanguageOptions
Represents the options for displaying interpretation language.
Public enumeration DcnmDisplayVotingResultType
Defines the available options to see voting results.
Public enumeration DcnmEquipmentCapabilities
The capabilities equipment in the system can have.
Public enumeration DcnmFlushPanelType
The different flushpanel types supported by the Dcnm system.
Public enumeration DcnmGainSettingType Obsolete.
The different device types supported by the Dcnm system.
Public enumeration DcnmHeadphoneTypes
Headphones supported in meeting desk
Public enumeration DcnmIdentificationMethod
The method how the person should identify himself.
Public enumeration DcnmIdentificationSetting
Defines the available Identification types within the system.
Public enumeration DcnmIDeskButtonFunctionType
Defines the IDesk button function type
Public enumeration DcnmInterimResultType
Defines the interim result type
Public enumeration DcnmInterpretationInPresetState
The Interpretation in preset state
Public enumeration DcnmInterpretationLanguageQualityType
Contains the definition of all Channel types.
Public enumeration DcnmInterpretationMetaRequestType
Request type used for interpretation meta requests
Public enumeration DcnmInterpretationMicrophoneState
The Interpretation microphone state
Public enumeration DcnmInterpretationModeType
Type providing the values set for the interpretation modes.
Public enumeration DcnmInterpretationOutPresetState
The Interpretation out preset state
Public enumeration DcnmLanguageSourceType
Enumeration of all types of language sources.
Public enumeration DcnmLevelSensorType
Enumeration of level sensor types.
Public enumeration DcnmLicenseStateType
Defines the license state types within the system.
Public enumeration DcnmMeetingState
Defines the meeting states
Public enumeration DcnmMicrophoneState
The microphone state
Public enumeration DcnmNotesFileType
Represents various notes file types
Public enumeration DcnmPowerState
The power state
Public enumeration DcnmPriorityMode
The different priority modes supported by the Dcnm system.
Public enumeration DcnmSeatType
Defines the available seat types within the system.
Public enumeration DcnmSpecialOperationType
Defines the available VIP types within the system.
Public enumeration DcnmStatusType
This is for holding Majority and Quorum status
Public enumeration DcnmStoreVotingResultType
Defines the available options to store voting results.
Public enumeration DcnmVerificationMethod
The method how the person should prove his identity.
Public enumeration DcnmVotingAnswer
Represents the voting answers
Public enumeration DcnmVotingAnswerSet
Voting answer set info
Public enumeration DcnmVotingHundredPercentSettings
Represents the voting hundred percent settings.
Public enumeration DcnmVotingState
Defines the voting states.
Public enumeration DcnmVotingTimerType
Type of voting timer.
Public enumeration DcnmVotingType
The type of voting
Public enumeration DcnmWebcastingLicense
This class contains the webcasting license definitions
Public enumeration DeviceInstanceNames
The different device instance names supported by the Dcnm system.


ApiEventArgs(T) Class

ApiEventArgsT Class

This is the definition for a generic eventargs class with one parameter.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Bosch.Dcnm.Interfaces.Api.InterfacesApiEventArgsT

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class ApiEventArgs<T> : EventArgs

Public Class ApiEventArgs(Of T)
    Inherits EventArgs
generic<typename T>
public ref class ApiEventArgs : public EventArgs

Type Parameters

T
The type of parameter used for the generic class.

The ApiEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | ApiEventArgsT | Constructor...
Top
Properties
 | Name | Description
Public property | Parameter | Gets the parameter from the event arguments.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace


ApiEventArgs(T) Constructor

ApiEventArgsT Constructor

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public ApiEventArgs(
    T parameter
)
Public Sub New (
    parameter As T
)
public:
ApiEventArgs(
    T parameter
)

Parameters

parameter
Type: T
The parameter to pass.
See Also

Reference

ApiEventArgsT Class


ApiEventArgs(T) Properties

ApiEventArgsT Properties

The ApiEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Parameter | Gets the parameter from the event arguments.
Top
See Also

Reference

ApiEventArgsT Class


ApiEventArgs(T).Parameter Property

ApiEventArgsTParameter Property

Gets the parameter from the event arguments.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public T Parameter { get; }
Public ReadOnly Property Parameter As T
    Get
public:
property T Parameter {
    T get ();
}

Property Value

Type: T
See Also

Reference

ApiEventArgsT Class


ApiEventArgs(T) Methods

ApiEventArgsT Methods

The ApiEventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ApiEventArgsT Class


ApiOperationFailedException Class

Exception for Api failures. Will be thrown when a caller isn't able to enter a function which isn't released by the previous caller.
Inheritance Hierarchy
SystemObject
SystemException
Bosch.Dcnm.Interfaces.Api.InterfacesApiOperationFailedException

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[SerializableAttribute]
public class ApiOperationFailedException : Exception
<SerializableAttribute>
Public Class ApiOperationFailedException
    Inherits Exception
[SerializableAttribute]
public ref class ApiOperationFailedException : public Exception

The ApiOperationFailedException type exposes the following members.

Constructors
 | Name | Description
Public method | ApiOperationFailedException | Default constructor for class
Public method | ApiOperationFailedException(String) | Constructor for class
Protected method | ApiOperationFailedException(SerializationInfo, StreamingContext) | Serialization constructor
Public method | ApiOperationFailedException(String, Exception) | Constructor for class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


ApiOperationFailedException Constructor

Overload List
 | Name | Description
Public method | ApiOperationFailedException | Default constructor for class
Public method | ApiOperationFailedException(String) | Constructor for class
Protected method | ApiOperationFailedException(SerializationInfo, StreamingContext) | Serialization constructor
Public method | ApiOperationFailedException(String, Exception) | Constructor for class
Top
See Also

Reference

ApiOperationFailedException Class


ApiOperationFailedException Constructor

Default constructor for class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public ApiOperationFailedException()
Public Sub New
public:
ApiOperationFailedException()
See Also

Reference

ApiOperationFailedException Class
ApiOperationFailedException Overload


ApiOperationFailedException Constructor (String)

Constructor for class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public ApiOperationFailedException(
    string message
)
Public Sub New (
    message As String
)
public:
ApiOperationFailedException(
    String^ message
)

Parameters

message
Type: SystemString
The exception message to display.
See Also

Reference

ApiOperationFailedException Class
ApiOperationFailedException Overload


ApiOperationFailedException Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
protected ApiOperationFailedException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
ApiOperationFailedException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The serialization information.
context
Type: System.Runtime.SerializationStreamingContext
The streaming context.
See Also

Reference

ApiOperationFailedException Class
ApiOperationFailedException Overload


ApiOperationFailedException Constructor (String, Exception)

Constructor for class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public ApiOperationFailedException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)
public:
ApiOperationFailedException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: SystemString
The exception message to display.
innerException
Type: SystemException
The inner exception.
See Also

Reference

ApiOperationFailedException Class
ApiOperationFailedException Overload


ApiOperationFailedException Properties

The ApiOperationFailedException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ApiOperationFailedException Class


ApiOperationFailedException Methods

The ApiOperationFailedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ApiOperationFailedException Class


ApiOperationFailedException Events

The ApiOperationFailedException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ApiOperationFailedException Class


AudioSettingConstants Class

The AudioSetting constants
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesAudioSettingConstants

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static class AudioSettingConstants
Public NotInheritable Class AudioSettingConstants
public ref class AudioSettingConstants abstract sealed

The AudioSettingConstants type exposes the following members.

Fields
Name | Description
DEFAULT_MAX_SLIDER_VALUE | Default Maximum Slider value.
DEFAULT_MIN_SLIDER_VALUE | Default Minimum Slider value.
DEFAULT_MIN_VU_METER_VALUE | Default Minimum Vu meter value.
MAX_ATTENUATION_VALUE | Default Maximum Attenuation value.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


AudioSettingConstants Fields

The AudioSettingConstants type exposes the following members.

Fields
Name | Description
DEFAULT_MAX_SLIDER_VALUE | Default Maximum Slider value.
DEFAULT_MIN_SLIDER_VALUE | Default Minimum Slider value.
DEFAULT_MIN_VU_METER_VALUE | Default Minimum Vu meter value.
MAX_ATTENUATION_VALUE | Default Maximum Attenuation value.
Top
See Also

Reference

AudioSettingConstants Class


AudioSettingConstants.DEFAULT_MAX_SLIDER_VALUE Field

AudioSettingConstantsDEFAULT_MAX_SLIDER_VALUE Field

Default Maximum Slider value.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const float DEFAULT_MAX_SLIDER_VALUE = 12f
Public Const DEFAULT_MAX_SLIDER_VALUE As Single = 12F
public:
literal float DEFAULT_MAX_SLIDER_VALUE = 12f

Field Value

Type: Single
See Also

Reference

AudioSettingConstants Class


AudioSettingConstants.DEFAULT_MIN_SLIDER_VALUE Field

AudioSettingConstantsDEFAULT_MIN_SLIDER_VALUE Field

Default Minimum Slider value.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const float DEFAULT_MIN_SLIDER_VALUE = -12f
Public Const DEFAULT_MIN_SLIDER_VALUE As Single = -12F
public:
literal float DEFAULT_MIN_SLIDER_VALUE = -12f

Field Value

Type: Single
See Also

Reference

AudioSettingConstants Class


AudioSettingConstants.DEFAULT_MIN_VU_METER_VALUE Field

AudioSettingConstantsDEFAULT_MIN_VU_METER_VALUE Field

Default Minimum Vu meter value.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const float DEFAULT_MIN_VU_METER_VALUE = -60f
Public Const DEFAULT_MIN_VU_METER_VALUE As Single = -60F
public:
literal float DEFAULT_MIN_VU_METER_VALUE = -60f

Field Value

Type: Single
See Also

Reference

AudioSettingConstants Class


AudioSettingConstants.MAX_ATTENUATION_VALUE Field

AudioSettingConstantsMAX_ATTENUATION_VALUE Field

Default Maximum Attenuation value.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAX_ATTENUATION_VALUE = 12
Public Const MAX_ATTENUATION_VALUE As Integer = 12
public:
literal int MAX_ATTENUATION_VALUE = 12

Field Value

Type: Int32
See Also

Reference

AudioSettingConstants Class


BoothNotifications Class

The supported Booth notifications.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesBoothNotifications

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static class BoothNotifications
Public NotInheritable Class BoothNotifications
public ref class BoothNotifications abstract sealed

The BoothNotifications type exposes the following members.

Fields
Name | Description
AlarmNotification | Default Alarm notification.
PhoneCallNotification | Default Phone call notification.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


BoothNotifications Fields

The BoothNotifications type exposes the following members.

Fields
Name | Description
AlarmNotification | Default Alarm notification.
PhoneCallNotification | Default Phone call notification.
Top
See Also

Reference

BoothNotifications Class


BoothNotifications.AlarmNotification Field

BoothNotificationsAlarmNotification Field

Default Alarm notification.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string AlarmNotification = "Alarm"
Public Const AlarmNotification As String = "Alarm"
public:
literal String^ AlarmNotification = "Alarm"

Field Value

Type: String
See Also

Reference

BoothNotifications Class


BoothNotifications.PhoneCallNotification Field

BoothNotificationsPhoneCallNotification Field

Default Phone call notification.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string PhoneCallNotification = "PhoneCall"
Public Const PhoneCallNotification As String = "PhoneCall"
public:
literal String^ PhoneCallNotification = "PhoneCall"

Field Value

Type: String
See Also

Reference

BoothNotifications Class


ConfigurationConstants Class

The Configuration constants
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesConfigurationConstants

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static class ConfigurationConstants
Public NotInheritable Class ConfigurationConstants
public ref class ConfigurationConstants abstract sealed

The ConfigurationConstants type exposes the following members.

Fields
Name | Description
ADMIN_USERGROUP_ID | Admin UserGroup GUID
DATETIMEFORMAT | Date time Format
DEFAULT_AREA_ID | Default Area Id
MAX_EMAIL_LENGTH | The maximum number of characters allowed for an email.
MAX_FIELD_LENGTH | The maximum characters the fields like FirstName, MiddleName, Title, Country, Region, Group can take.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


ConfigurationConstants Fields

The ConfigurationConstants type exposes the following members.

Fields
Name | Description
ADMIN_USERGROUP_ID | Admin UserGroup GUID
DATETIMEFORMAT | Date time Format
DEFAULT_AREA_ID | Default Area Id
MAX_EMAIL_LENGTH | The maximum number of characters allowed for an email.
MAX_FIELD_LENGTH | The maximum characters the fields like FirstName, MiddleName, Title, Country, Region, Group can take.
Top
See Also

Reference

ConfigurationConstants Class


ConfigurationConstants.ADMIN_USERGROUP_ID Field

ConfigurationConstantsADMIN_USERGROUP_ID Field

Admin UserGroup GUID

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static readonly Guid ADMIN_USERGROUP_ID
Public Shared ReadOnly ADMIN_USERGROUP_ID As Guid
public:
static initonly Guid ADMIN_USERGROUP_ID

Field Value

Type: Guid
See Also

Reference

ConfigurationConstants Class


ConfigurationConstants.DATETIMEFORMAT Field

ConfigurationConstantsDATETIMEFORMAT Field

Date time Format

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string DATETIMEFORMAT = "yyyy-MM-dd HH:mm:ss"
Public Const DATETIMEFORMAT As String = "yyyy-MM-dd HH:mm:ss"
public:
literal String^ DATETIMEFORMAT = "yyyy-MM-dd HH:mm:ss"

Field Value

Type: String
See Also

Reference

ConfigurationConstants Class


ConfigurationConstants.DEFAULT_AREA_ID Field

ConfigurationConstantsDEFAULT_AREA_ID Field

Default Area Id

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static readonly Guid DEFAULT_AREA_ID
Public Shared ReadOnly DEFAULT_AREA_ID As Guid
public:
static initonly Guid DEFAULT_AREA_ID

Field Value

Type: Guid
See Also

Reference

ConfigurationConstants Class


ConfigurationConstants.MAX_EMAIL_LENGTH Field

ConfigurationConstantsMAX_EMAIL_LENGTH Field

The maximum number of characters allowed for an email.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAX_EMAIL_LENGTH = 320
Public Const MAX_EMAIL_LENGTH As Integer = 320
public:
literal int MAX_EMAIL_LENGTH = 320

Field Value

Type: Int32
See Also

Reference

ConfigurationConstants Class


ConfigurationConstants.MAX_FIELD_LENGTH Field

ConfigurationConstantsMAX_FIELD_LENGTH Field

The maximum characters the fields like FirstName, MiddleName, Title, Country, Region, Group can take.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAX_FIELD_LENGTH = 50
Public Const MAX_FIELD_LENGTH As Integer = 50
public:
literal int MAX_FIELD_LENGTH = 50

Field Value

Type: Int32
Remarks
If the size exceeds this limit, the text is truncatad.
See Also

Reference

ConfigurationConstants Class


DcnmAccessDeniedReason Enumeration

Represents various access denied reasons

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmAccessDeniedReason
Public Enumeration DcnmAccessDeniedReason
public enum class DcnmAccessDeniedReason
Members
Member name | Value | Description
NoReason | 0 | No reason
InvalidUserCredentials | 1 | Invalid user credential
NotParticipantToMeeting | 2 | Not a participant for the meeting
IncorrectSeat | 3 | Incorrect seat
GrantFailure | 4 | Grant failure
InsufficientLicense | 5 | Insufficient license
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmAccessMethod Enumeration

Definition on how it is expected a user will identify/authenticate himself.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmAccessMethod
Public Enumeration DcnmAccessMethod
public enum class DcnmAccessMethod
Members
Member name | Value | Description
AccessEnabled | 0 | No identification or authentication required.
IdentifyUsingConfirmation | 1 | Participant needs to identify using confirmation.
IdentifyUsingUserName | 2 | Participant needs to identify using his username.
IdentifyUsingSelectFromList | 3 | Participant needs to identify by selecting himself from the list.
AuthenticateUsingUserNameAndPassword | 4 | Participant needs to authenticate using his username and password.
AuthenticateUsingSelectFromListAndPassword | 5 | Participant needs to authenticate by selecting himself from a list and entering a password.
AccessDenied | 6 | Participant cannot do anything, access for him is denied.
IdentifyUsingNFC | 7 | Participant needs to identify using NFC card.
AuthenticateUsingNFCAndPassword | 8 | Participant needs to authenticate using his NFC card and password.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmAccessRights Enumeration

The user group access rights supported by the Dcnm system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmAccessRights
Public Enumeration DcnmAccessRights
public enum class DcnmAccessRights
Members
Member name | Value | Description
ActivateMeeting | 0 | Indicates the user group can manage meetings and agendas.
PrepareMeetingAndAgenda | 1 | Indicates the user group can prepare meeting and agenda's.
PrepareUsers | 2 | Indicates the user group can prepare user groups and assign access rights to them.
ConfigureSystem | 3 | Indicates the user group can prepare and configure the system.
WindowsAuthentication | 4 | Indicates the authentication of username and password done at windows server.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmAcousticFeedbackSuppression Enumeration

Represents the acoustic feedback suppression

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmAcousticFeedbackSuppression
Public Enumeration DcnmAcousticFeedbackSuppression
public enum class DcnmAcousticFeedbackSuppression
Members
Member name | Value | Description
Off | 0 | No acoustic feedback suppression
Natural | 1 | Natural acoustic feedback suppression
Maximum | 2 | Maximum acoustic feedback suppression
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmActionCommand Class

Defines the type of action.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmActionCommand

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmActionCommand
Public Class DcnmActionCommand
public ref class DcnmActionCommand

The DcnmActionCommand type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmActionCommand | Initializes a new instance of the DcnmActionCommandType class.
Top
Properties
 | Name | Description
Public property | ActionId | Type of action to execute.
Public property | Command | The command to send with the type of action to perform.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmActionCommand Constructor

Initializes a new instance of the DcnmActionCommandType class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmActionCommand(
    int actionId,
    string command
)
Public Sub New (
    actionId As Integer,
    command As String
)
public:
DcnmActionCommand(
    int actionId,
    String^ command
)

Parameters

actionId
Type: SystemInt32
The action id.
command
Type: SystemString
The command.
See Also

Reference

DcnmActionCommand Class


DcnmActionCommand Properties

The DcnmActionCommand type exposes the following members.

Properties
 | Name | Description
Public property | ActionId | Type of action to execute.
Public property | Command | The command to send with the type of action to perform.
Top
See Also

Reference

DcnmActionCommand Class


DcnmActionCommand.ActionId Property

DcnmActionCommandActionId Property

Type of action to execute.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int ActionId { get; }
Public ReadOnly Property ActionId As Integer
    Get
public:
property int ActionId {
    int get ();
}

Property Value

Type: Int32
Remarks
User defined values range from UserDefined upto SystemDefined. System defined values are reserved for use and start above SystemDefined.
See Also

Reference

DcnmActionCommand Class


DcnmActionCommand.Command Property

DcnmActionCommandCommand Property

The command to send with the type of action to perform.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Command { get; }
Public ReadOnly Property Command As String
    Get
public:
property String^ Command {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmActionCommand Class


DcnmActionCommand Methods

The DcnmActionCommand type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmActionCommand Class


DcnmActionCommandType Enumeration

Defines the type of action.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmActionCommandType
Public Enumeration DcnmActionCommandType
public enum class DcnmActionCommandType
Members
Member name | Value | Description
UserDefined | 0 | The user defined start index
SystemDefined | 999 | Start index for system-wide reserved actions.
StartExternalApp | 1000 | Starts an external application at a device during the meeting.
StopExternalApp | 1001 | Stops an external application at a device during the meeting.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmAgendaTopicPreparationInfo Class

Agenda topic definition.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAgendaTopicPreparationInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmAgendaTopicPreparationInfo
Public Class DcnmAgendaTopicPreparationInfo
public ref class DcnmAgendaTopicPreparationInfo

The DcnmAgendaTopicPreparationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmAgendaTopicPreparationInfo | Default constructor for class
Public method | DcnmAgendaTopicPreparationInfo(Guid, String, String, String, Guid) | Initializes a new instance of the DcnmAgendaTopicPreparationInfo class.
Public method | DcnmAgendaTopicPreparationInfo(Guid, String, String, String, Guid, Guid) | Initializes a new instance of the DcnmAgendaTopicPreparationInfo class.
Top
Properties
 | Name | Description
Public property | AgendaTopicId | The id of this agenda topic.
Public property | Description | The description.
Public property | DiscussionId | The related discussion id.
Public property | DocumentationLink | The documentation link.
Public property | MeetingId | The meeting id this agenda topic belongs to.
Public property | Subject | The subject.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmAgendaTopicPreparationInfo Constructor

Overload List
 | Name | Description
Public method | DcnmAgendaTopicPreparationInfo | Default constructor for class
Public method | DcnmAgendaTopicPreparationInfo(Guid, String, String, String, Guid) | Initializes a new instance of the DcnmAgendaTopicPreparationInfo class.
Public method | DcnmAgendaTopicPreparationInfo(Guid, String, String, String, Guid, Guid) | Initializes a new instance of the DcnmAgendaTopicPreparationInfo class.
Top
See Also

Reference

DcnmAgendaTopicPreparationInfo Class


DcnmAgendaTopicPreparationInfo Constructor

Default constructor for class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmAgendaTopicPreparationInfo()
Public Sub New
public:
DcnmAgendaTopicPreparationInfo()
See Also

Reference

DcnmAgendaTopicPreparationInfo Class
DcnmAgendaTopicPreparationInfo Overload


DcnmAgendaTopicPreparationInfo Constructor (Guid, String, String, String, Guid)

Initializes a new instance of the DcnmAgendaTopicPreparationInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmAgendaTopicPreparationInfo(
    Guid meetingId,
    string subject,
    string description,
    string documentationLink,
    Guid discussionId
)
Public Sub New (
    meetingId As Guid,
    subject As String,
    description As String,
    documentationLink As String,
    discussionId As Guid
)
public:
DcnmAgendaTopicPreparationInfo(
    Guid meetingId,
    String^ subject,
    String^ description,
    String^ documentationLink,
    Guid discussionId
)

Parameters

meetingId
Type: SystemGuid
The meeting id.
subject
Type: SystemString
The subject.
description
Type: SystemString
The description.
documentationLink
Type: SystemString
The documentation link.
discussionId
Type: SystemGuid
The discussion id.
See Also

Reference

DcnmAgendaTopicPreparationInfo Class
DcnmAgendaTopicPreparationInfo Overload


DcnmAgendaTopicPreparationInfo Constructor (Guid, String, String, String, Guid, Guid)

Initializes a new instance of the DcnmAgendaTopicPreparationInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmAgendaTopicPreparationInfo(
    Guid meetingId,
    string subject,
    string description,
    string documentationLink,
    Guid discussionId,
    Guid agendaTopicId
)
Public Sub New (
    meetingId As Guid,
    subject As String,
    description As String,
    documentationLink As String,
    discussionId As Guid,
    agendaTopicId As Guid
)
public:
DcnmAgendaTopicPreparationInfo(
    Guid meetingId,
    String^ subject,
    String^ description,
    String^ documentationLink,
    Guid discussionId,
    Guid agendaTopicId
)

Parameters

meetingId
Type: SystemGuid
The meeting id.
subject
Type: SystemString
The subject.
description
Type: SystemString
The description.
documentationLink
Type: SystemString
The documentation link.
discussionId
Type: SystemGuid
The discussion id.
agendaTopicId
Type: SystemGuid
The agenda topic id.
See Also

Reference

DcnmAgendaTopicPreparationInfo Class
DcnmAgendaTopicPreparationInfo Overload


DcnmAgendaTopicPreparationInfo Properties

The DcnmAgendaTopicPreparationInfo type exposes the following members.

Properties
 | Name | Description
Public property | AgendaTopicId | The id of this agenda topic.
Public property | Description | The description.
Public property | DiscussionId | The related discussion id.
Public property | DocumentationLink | The documentation link.
Public property | MeetingId | The meeting id this agenda topic belongs to.
Public property | Subject | The subject.
Top
See Also

Reference

DcnmAgendaTopicPreparationInfo Class


DcnmAgendaTopicPreparationInfo.AgendaTopicId Property

DcnmAgendaTopicPreparationInfoAgendaTopicId Property

The id of this agenda topic.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid AgendaTopicId { get; }
Public ReadOnly Property AgendaTopicId As Guid
    Get
public:
property Guid AgendaTopicId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmAgendaTopicPreparationInfo Class


DcnmAgendaTopicPreparationInfo.Description Property

DcnmAgendaTopicPreparationInfoDescription Property

The description.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmAgendaTopicPreparationInfo Class


DcnmAgendaTopicPreparationInfo.DiscussionId Property

DcnmAgendaTopicPreparationInfoDiscussionId Property

The related discussion id.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid DiscussionId { get; }
Public ReadOnly Property DiscussionId As Guid
    Get
public:
property Guid DiscussionId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmAgendaTopicPreparationInfo Class


DcnmAgendaTopicPreparationInfo.DocumentationLink Property

DcnmAgendaTopicPreparationInfoDocumentationLink Property

The documentation link.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string DocumentationLink { get; }
Public ReadOnly Property DocumentationLink As String
    Get
public:
property String^ DocumentationLink {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmAgendaTopicPreparationInfo Class


DcnmAgendaTopicPreparationInfo.MeetingId Property

DcnmAgendaTopicPreparationInfoMeetingId Property

The meeting id this agenda topic belongs to.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid MeetingId { get; }
Public ReadOnly Property MeetingId As Guid
    Get
public:
property Guid MeetingId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmAgendaTopicPreparationInfo Class


DcnmAgendaTopicPreparationInfo.Subject Property

DcnmAgendaTopicPreparationInfoSubject Property

The subject.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Subject { get; }
Public ReadOnly Property Subject As String
    Get
public:
property String^ Subject {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmAgendaTopicPreparationInfo Class


DcnmAgendaTopicPreparationInfo Methods

The DcnmAgendaTopicPreparationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmAgendaTopicPreparationInfo Class


DcnmAgendaTopicStatusInfo Class

Agenda topic definition.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAgendaTopicStatusInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmAgendaTopicStatusInfo
Public Class DcnmAgendaTopicStatusInfo
public ref class DcnmAgendaTopicStatusInfo

The DcnmAgendaTopicStatusInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmAgendaTopicStatusInfo | Initializes a new instance of the DcnmAgendaTopicStatusInfo class.
Top
Properties
 | Name | Description
Public property | Active | the state of this agenda topic.
Public property | AgendaTopicId | The id of this agenda topic.
Public property | Description | The description.
Public property | DiscussionId | The related discussion id.
Public property | DocumentationLink | The documentation link.
Public property | MeetingId | The meeting id this agenda topic belongs to.
Public property | Subject | The subject.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmAgendaTopicStatusInfo Constructor

Initializes a new instance of the DcnmAgendaTopicStatusInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmAgendaTopicStatusInfo(
    Guid meetingId,
    string subject,
    string description,
    string documentationLink,
    Guid discussionId,
    Guid agendaTopicId,
    bool active
)
Public Sub New (
    meetingId As Guid,
    subject As String,
    description As String,
    documentationLink As String,
    discussionId As Guid,
    agendaTopicId As Guid,
    active As Boolean
)
public:
DcnmAgendaTopicStatusInfo(
    Guid meetingId,
    String^ subject,
    String^ description,
    String^ documentationLink,
    Guid discussionId,
    Guid agendaTopicId,
    bool active
)

Parameters

meetingId
Type: SystemGuid
The meeting id.
subject
Type: SystemString
The subject.
description
Type: SystemString
The description.
documentationLink
Type: SystemString
The documentation link.
discussionId
Type: SystemGuid
The discussion id.
agendaTopicId
Type: SystemGuid
The agenda topic id.
active
Type: SystemBoolean
The state of the agenda topic.
See Also

Reference

DcnmAgendaTopicStatusInfo Class


DcnmAgendaTopicStatusInfo Properties

The DcnmAgendaTopicStatusInfo type exposes the following members.

Properties
 | Name | Description
Public property | Active | the state of this agenda topic.
Public property | AgendaTopicId | The id of this agenda topic.
Public property | Description | The description.
Public property | DiscussionId | The related discussion id.
Public property | DocumentationLink | The documentation link.
Public property | MeetingId | The meeting id this agenda topic belongs to.
Public property | Subject | The subject.
Top
See Also

Reference

DcnmAgendaTopicStatusInfo Class


DcnmAgendaTopicStatusInfo.Active Property

DcnmAgendaTopicStatusInfoActive Property

the state of this agenda topic.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool Active { get; }
Public ReadOnly Property Active As Boolean
    Get
public:
property bool Active {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmAgendaTopicStatusInfo Class


DcnmAgendaTopicStatusInfo.AgendaTopicId Property

DcnmAgendaTopicStatusInfoAgendaTopicId Property

The id of this agenda topic.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid AgendaTopicId { get; }
Public ReadOnly Property AgendaTopicId As Guid
    Get
public:
property Guid AgendaTopicId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmAgendaTopicStatusInfo Class


DcnmAgendaTopicStatusInfo.Description Property

DcnmAgendaTopicStatusInfoDescription Property

The description.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmAgendaTopicStatusInfo Class


DcnmAgendaTopicStatusInfo.DiscussionId Property

DcnmAgendaTopicStatusInfoDiscussionId Property

The related discussion id.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid DiscussionId { get; }
Public ReadOnly Property DiscussionId As Guid
    Get
public:
property Guid DiscussionId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmAgendaTopicStatusInfo Class


DcnmAgendaTopicStatusInfo.DocumentationLink Property

DcnmAgendaTopicStatusInfoDocumentationLink Property

The documentation link.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string DocumentationLink { get; }
Public ReadOnly Property DocumentationLink As String
    Get
public:
property String^ DocumentationLink {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmAgendaTopicStatusInfo Class


DcnmAgendaTopicStatusInfo.MeetingId Property

DcnmAgendaTopicStatusInfoMeetingId Property

The meeting id this agenda topic belongs to.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid MeetingId { get; }
Public ReadOnly Property MeetingId As Guid
    Get
public:
property Guid MeetingId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmAgendaTopicStatusInfo Class


DcnmAgendaTopicStatusInfo.Subject Property

DcnmAgendaTopicStatusInfoSubject Property

The subject.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Subject { get; }
Public ReadOnly Property Subject As String
    Get
public:
property String^ Subject {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmAgendaTopicStatusInfo Class


DcnmAgendaTopicStatusInfo Methods

The DcnmAgendaTopicStatusInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmAgendaTopicStatusInfo Class


DcnmApiState Enumeration

Represents the open states of the Windows API.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmApiState
Public Enumeration DcnmApiState
public enum class DcnmApiState
Members
Member name | Value | Description
Offline | 0 | Not open.
Online | 1 | Windows API is open.
Opening | 2 | Attempting to open the Windows API.
Closing | 3 | Attempting to close the Windows API.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmApplicationInfo Class

Contains the application info in the DICENTIS system.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmApplicationInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmApplicationInfo
Public Class DcnmApplicationInfo
public ref class DcnmApplicationInfo

The DcnmApplicationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmApplicationInfo | Constructor...
Top
Properties
 | Name | Description
Public property | ApplicationType | Gets the application type
Public property | ApplicationUri | Gets the application uri
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
An ApplicationInfo is used to register the application with the services The DcnmApplicationInfo represents
  • Type of application
  • Uri of the application
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmApplicationInfo Constructor

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmApplicationInfo(
    DcnmApplicationType applicationType,
    Uri applicationUri
)
Public Sub New (
    applicationType As DcnmApplicationType,
    applicationUri As Uri
)
public:
DcnmApplicationInfo(
    DcnmApplicationType applicationType,
    Uri^ applicationUri
)

Parameters

applicationType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmApplicationType
Type of application
applicationUri
Type: SystemUri
Uri of the application
See Also

Reference

DcnmApplicationInfo Class


DcnmApplicationInfo Properties

The DcnmApplicationInfo type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationType | Gets the application type
Public property | ApplicationUri | Gets the application uri
Top
See Also

Reference

DcnmApplicationInfo Class


DcnmApplicationInfo.ApplicationType Property

DcnmApplicationInfoApplicationType Property

Gets the application type

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmApplicationType ApplicationType { get; }
Public ReadOnly Property ApplicationType As DcnmApplicationType
    Get
public:
property DcnmApplicationType ApplicationType {
    DcnmApplicationType get ();
}

Property Value

Type: DcnmApplicationType
See Also

Reference

DcnmApplicationInfo Class


DcnmApplicationInfo.ApplicationUri Property

DcnmApplicationInfoApplicationUri Property

Gets the application uri

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Uri ApplicationUri { get; }
Public ReadOnly Property ApplicationUri As Uri
    Get
public:
property Uri^ ApplicationUri {
    Uri^ get ();
}

Property Value

Type: Uri
See Also

Reference

DcnmApplicationInfo Class


DcnmApplicationInfo Methods

The DcnmApplicationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmApplicationInfo Class


DcnmApplicationState Enumeration

Represents the system mode states on the device.
Remarks
The system mode state can be modified by changing the IDeviceApi.CurrentApplicationState property as below.
  • To change the system mode state to install mode, IDeviceApi.CurrentApplicationState should be set to DcnmApplicationState.InstallMode
  • To change the system mode state to conference mode, IDeviceApi.CurrentApplicationState should be set to DcnmApplicationState.ConferenceMode

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmApplicationState
Public Enumeration DcnmApplicationState
public enum class DcnmApplicationState
Members
Member name | Value | Description
WaitForMode | 0 | Not in an system mode yet, waiting for one.
InstallMode | 1 | The system is in installation mode.
ConferenceMode | 2 | The system is in conference mode.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmApplicationType Enumeration

Defines the web application type.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmApplicationType
Public Enumeration DcnmApplicationType
public enum class DcnmApplicationType
Members
Member name | Value | Description
Undefined | 0 | Undefined
SynopticLayout | 1 | The synoptic application
ImageServer | 2 | The image server.
MeetingDocuments | 3 | The meeting documents.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmAreaConfigurationInfo Class

Represents a container for the information about an area.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAreaConfigurationInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmAreaConfigurationInfo
Public Class DcnmAreaConfigurationInfo
public ref class DcnmAreaConfigurationInfo

The DcnmAreaConfigurationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmAreaConfigurationInfo(Guid, String) | Obsolete. Initializes a new instance of the DcnmAreaConfigurationInfo class by a specified area identifier and name.
Public method | DcnmAreaConfigurationInfo(Guid, String, Guid) | Obsolete. Initializes a new instance of the DcnmAreaConfigurationInfo class by a specified area identifier, name and controller id.
Public method | DcnmAreaConfigurationInfo(Guid, String, Guid, DcnmAreaType, Int32) | Initializes a new instance of the DcnmAreaConfigurationInfo class by a specified area identifier, name, controller id, type and number.
Top
Properties
 | Name | Description
Public property | AreaControllerId | The identifier of the area controller.
Public property | AreaNumber | The area number.
Public property | AreaType | Represents the type of the area
Public property | Id | Identifies the area, it will not change during the lifetime of the area.
Public property | Name | The name of the area.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmAreaConfigurationInfo Constructor

There are three overloads for this method
Overload List
 | Name | Description
Public method | DcnmAreaConfigurationInfo(Guid, String) | Obsolete. Initializes a new instance of the DcnmAreaConfigurationInfo class by a specified area identifier and name.
Public method | DcnmAreaConfigurationInfo(Guid, String, Guid) | Obsolete. Initializes a new instance of the DcnmAreaConfigurationInfo class by a specified area identifier, name and controller id.
Public method | DcnmAreaConfigurationInfo(Guid, String, Guid, DcnmAreaType, Int32) | Initializes a new instance of the DcnmAreaConfigurationInfo class by a specified area identifier, name, controller id, type and number.
Top
See Also

Reference

DcnmAreaConfigurationInfo Class


DcnmAreaConfigurationInfo Constructor (Guid, String)

Note: This API is now obsolete.

Initializes a new instance of the DcnmAreaConfigurationInfo class by a specified area identifier and name.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with AreaType enumeration")]
public DcnmAreaConfigurationInfo(
    Guid areaId,
    string areaName
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with AreaType enumeration")>
Public Sub New (
    areaId As Guid,
    areaName As String
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with AreaType enumeration")]
DcnmAreaConfigurationInfo(
    Guid areaId,
    String^ areaName
)

Parameters

areaId
Type: SystemGuid
The identifier of the area.
areaName
Type: SystemString
The name of the area.
See Also

Reference

DcnmAreaConfigurationInfo Class
DcnmAreaConfigurationInfo Overload


DcnmAreaConfigurationInfo Constructor (Guid, String, Guid)

Note: This API is now obsolete.

Initializes a new instance of the DcnmAreaConfigurationInfo class by a specified area identifier, name and controller id.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with AreaType enumeration")]
public DcnmAreaConfigurationInfo(
    Guid areaId,
    string areaName,
    Guid areaControllerId
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with AreaType enumeration")>
Public Sub New (
    areaId As Guid,
    areaName As String,
    areaControllerId As Guid
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with AreaType enumeration")]
DcnmAreaConfigurationInfo(
    Guid areaId,
    String^ areaName,
    Guid areaControllerId
)

Parameters

areaId
Type: SystemGuid
The identifier of the area.
areaName
Type: SystemString
The name of the area.
areaControllerId
Type: SystemGuid
The identifier of the area controller.
See Also

Reference

DcnmAreaConfigurationInfo Class
DcnmAreaConfigurationInfo Overload


DcnmAreaConfigurationInfo Constructor (Guid, String, Guid, DcnmAreaType, Int32)

Initializes a new instance of the DcnmAreaConfigurationInfo class by a specified area identifier, name, controller id, type and number.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmAreaConfigurationInfo(
    Guid areaId,
    string areaName,
    Guid areaControllerId,
    DcnmAreaType areaType,
    int areaNumber
)
Public Sub New (
    areaId As Guid,
    areaName As String,
    areaControllerId As Guid,
    areaType As DcnmAreaType,
    areaNumber As Integer
)
public:
DcnmAreaConfigurationInfo(
    Guid areaId,
    String^ areaName,
    Guid areaControllerId,
    DcnmAreaType areaType,
    int areaNumber
)

Parameters

areaId
Type: SystemGuid
The identifier of the area.
areaName
Type: SystemString
The name of the area.
areaControllerId
Type: SystemGuid
The identifier of the area controller.
areaType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAreaType
Represents the type of the area. DcnmAreaType
areaNumber
Type: SystemInt32
The area number.
See Also

Reference

DcnmAreaConfigurationInfo Class
DcnmAreaConfigurationInfo Overload


DcnmAreaConfigurationInfo Properties

The DcnmAreaConfigurationInfo type exposes the following members.

Properties
 | Name | Description
Public property | AreaControllerId | The identifier of the area controller.
Public property | AreaNumber | The area number.
Public property | AreaType | Represents the type of the area
Public property | Id | Identifies the area, it will not change during the lifetime of the area.
Public property | Name | The name of the area.
Top
See Also

Reference

DcnmAreaConfigurationInfo Class


DcnmAreaConfigurationInfo.AreaControllerId Property

DcnmAreaConfigurationInfoAreaControllerId Property

The identifier of the area controller.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid AreaControllerId { get; set; }
Public Property AreaControllerId As Guid
    Get
    Set
public:
property Guid AreaControllerId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmAreaConfigurationInfo Class


DcnmAreaConfigurationInfo.AreaNumber Property

DcnmAreaConfigurationInfoAreaNumber Property

The area number.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int AreaNumber { get; set; }
Public Property AreaNumber As Integer
    Get
    Set
public:
property int AreaNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DcnmAreaConfigurationInfo Class


DcnmAreaConfigurationInfo.AreaType Property

DcnmAreaConfigurationInfoAreaType Property

Represents the type of the area

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmAreaType AreaType { get; set; }
Public Property AreaType As DcnmAreaType
    Get
    Set
public:
property DcnmAreaType AreaType {
    DcnmAreaType get ();
    void set (DcnmAreaType value);
}

Property Value

Type: DcnmAreaType
See Also

Reference

DcnmAreaConfigurationInfo Class
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAreaType


DcnmAreaConfigurationInfo.Id Property

DcnmAreaConfigurationInfoId Property

Identifies the area, it will not change during the lifetime of the area.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmAreaConfigurationInfo Class


DcnmAreaConfigurationInfo.Name Property

DcnmAreaConfigurationInfoName Property

The name of the area.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DcnmAreaConfigurationInfo Class


DcnmAreaConfigurationInfo Methods

The DcnmAreaConfigurationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmAreaConfigurationInfo Class


DcnmAreaType Enumeration

Defines the available area types within the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmAreaType
Public Enumeration DcnmAreaType
public enum class DcnmAreaType
Members
Member name | Value | Description
MeetingArea | 0 | The meeting area. Remarks This area that contains all the meeting participant seats
BoothArea | 1 | The booth area. Remarks This area contains all the meeting interpreter seats
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmAttendanceInfo Class

Contains the attendance summary of the participant in the active meeting.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAttendanceInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmAttendanceInfo
Public Class DcnmAttendanceInfo
public ref class DcnmAttendanceInfo

The DcnmAttendanceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmAttendanceInfo(Int32, Int32, Int32, Int32) | Obsolete. Constructor...
Public method | DcnmAttendanceInfo(Int32, Int32, Int32, Int32, DcnmQuorumResult) | Constructor...
Top
Properties
 | Name | Description
Public property | QuorumResult | Holds quorum result information.
Public property | TotalParticipants | Gets the total participant count in an active meeting
Public property | TotalPresent | Gets the total present count in an active meeting
Public property | TotalPresentVoteAuthorization | Gets the total count of participant present in a meeting having vote authorization.
Public property | TotalVoteAuthorization | Gets the total count of participants having vote authorization in an active meeting
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
An AttendanceInfo is used to retrieve the count of participant in a meeting, total present and count of particpant having the vote authorization The DcnmAttendanceInfo represents
  • Total participants in an active meeting
  • Count of total participant present
  • Count of participant having the vote authorization
  • Count of participant present having the vote authorization
The IControlParticipant interface.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmAttendanceInfo Constructor

Overload List
 | Name | Description
Public method | DcnmAttendanceInfo(Int32, Int32, Int32, Int32) | Obsolete. Constructor...
Public method | DcnmAttendanceInfo(Int32, Int32, Int32, Int32, DcnmQuorumResult) | Constructor...
Top
See Also

Reference

DcnmAttendanceInfo Class


DcnmAttendanceInfo Constructor (Int32, Int32, Int32, Int32)

Note: This API is now obsolete.

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmAttendanceInfo(
    int totalParticipants,
    int totalPresent,
    int totalVoteAuthorization,
    int totalPresentVoteAuthorization
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    totalParticipants As Integer,
    totalPresent As Integer,
    totalVoteAuthorization As Integer,
    totalPresentVoteAuthorization As Integer
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmAttendanceInfo(
    int totalParticipants,
    int totalPresent,
    int totalVoteAuthorization,
    int totalPresentVoteAuthorization
)

Parameters

totalParticipants
Type: SystemInt32
Total participants
totalPresent
Type: SystemInt32
Total present
totalVoteAuthorization
Type: SystemInt32
Total participants having vote authorization
totalPresentVoteAuthorization
Type: SystemInt32
Total participant present having vote authorization
See Also

Reference

DcnmAttendanceInfo Class
DcnmAttendanceInfo Overload


DcnmAttendanceInfo Constructor (Int32, Int32, Int32, Int32, DcnmQuorumResult)

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmAttendanceInfo(
    int totalParticipants,
    int totalPresent,
    int totalVoteAuthorization,
    int totalPresentVoteAuthorization,
    DcnmQuorumResult quorumResult
)
Public Sub New (
    totalParticipants As Integer,
    totalPresent As Integer,
    totalVoteAuthorization As Integer,
    totalPresentVoteAuthorization As Integer,
    quorumResult As DcnmQuorumResult
)
public:
DcnmAttendanceInfo(
    int totalParticipants,
    int totalPresent,
    int totalVoteAuthorization,
    int totalPresentVoteAuthorization,
    DcnmQuorumResult^ quorumResult
)

Parameters

totalParticipants
Type: SystemInt32
Total participants in meeting
totalPresent
Type: SystemInt32
Total participants present in meeeting
totalVoteAuthorization
Type: SystemInt32
Total participants having vote authorization
totalPresentVoteAuthorization
Type: SystemInt32
Total participant present having vote authorization
quorumResult
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmQuorumResult
Quorum result info of meetingDcnmQuorumResult
See Also

Reference

DcnmAttendanceInfo Class
DcnmAttendanceInfo Overload


DcnmAttendanceInfo Properties

The DcnmAttendanceInfo type exposes the following members.

Properties
 | Name | Description
Public property | QuorumResult | Holds quorum result information.
Public property | TotalParticipants | Gets the total participant count in an active meeting
Public property | TotalPresent | Gets the total present count in an active meeting
Public property | TotalPresentVoteAuthorization | Gets the total count of participant present in a meeting having vote authorization.
Public property | TotalVoteAuthorization | Gets the total count of participants having vote authorization in an active meeting
Top
See Also

Reference

DcnmAttendanceInfo Class


DcnmAttendanceInfo.QuorumResult Property

DcnmAttendanceInfoQuorumResult Property

Holds quorum result information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmQuorumResult QuorumResult { get; }
Public ReadOnly Property QuorumResult As DcnmQuorumResult
    Get
public:
property DcnmQuorumResult^ QuorumResult {
    DcnmQuorumResult^ get ();
}

Property Value

Type: DcnmQuorumResult
See Also

Reference

DcnmAttendanceInfo Class


DcnmAttendanceInfo.TotalParticipants Property

DcnmAttendanceInfoTotalParticipants Property

Gets the total participant count in an active meeting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int TotalParticipants { get; }
Public ReadOnly Property TotalParticipants As Integer
    Get
public:
property int TotalParticipants {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmAttendanceInfo Class


DcnmAttendanceInfo.TotalPresent Property

DcnmAttendanceInfoTotalPresent Property

Gets the total present count in an active meeting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int TotalPresent { get; }
Public ReadOnly Property TotalPresent As Integer
    Get
public:
property int TotalPresent {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmAttendanceInfo Class


DcnmAttendanceInfo.TotalPresentVoteAuthorization Property

DcnmAttendanceInfoTotalPresentVoteAuthorization Property

Gets the total count of participant present in a meeting having vote authorization.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int TotalPresentVoteAuthorization { get; }
Public ReadOnly Property TotalPresentVoteAuthorization As Integer
    Get
public:
property int TotalPresentVoteAuthorization {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmAttendanceInfo Class


DcnmAttendanceInfo.TotalVoteAuthorization Property

DcnmAttendanceInfoTotalVoteAuthorization Property

Gets the total count of participants having vote authorization in an active meeting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int TotalVoteAuthorization { get; }
Public ReadOnly Property TotalVoteAuthorization As Integer
    Get
public:
property int TotalVoteAuthorization {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmAttendanceInfo Class


DcnmAttendanceInfo Methods

The DcnmAttendanceInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmAttendanceInfo Class


DcnmAudioEqualizerFilterType Enumeration

Represents the equalizer filter type

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmAudioEqualizerFilterType
Public Enumeration DcnmAudioEqualizerFilterType
public enum class DcnmAudioEqualizerFilterType
Members
Member name | Value | Description
LowShelving | 0 | Low Shelving filter
Notch | 1 | Notch filter
HighShelving | 2 | High shelving filter
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmAudioEqualizerSettings Class

Container holding the equalizer settings.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAudioEqualizerSettings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmAudioEqualizerSettings
Public Class DcnmAudioEqualizerSettings
public ref class DcnmAudioEqualizerSettings

The DcnmAudioEqualizerSettings type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmAudioEqualizerSettings | Constructor...
Top
Properties
 | Name | Description
Public property | EqualizerType | Type of the equalizer
Public property | FilterEnabled | Indicates if filter is enabled
Public property | FilterNumber | Number of the filter band (0..4)
Public property | FilterType | Type of the filter
Public property | Frequency | Frequency of the filter.
Public property | Gain | Gain of the filter.
Public property | QFactor | Q-Factor of the filter, if applicable.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
EQUALIZER_DEFAULT_MAX_FREQUENCY | Maximum value for equalizer filter frequency.
EQUALIZER_DEFAULT_MAX_GAIN | Maximum value for equalizer filter gain.
EQUALIZER_DEFAULT_MAX_QFACTOR | Maximum value for equalizer filter Q-factor.
EQUALIZER_DEFAULT_MIN_FREQUENCY | Minimum value for equalizer filter frequency.
EQUALIZER_DEFAULT_MIN_GAIN | Minimum value for equalizer filter gain.
EQUALIZER_DEFAULT_MIN_QFACTOR | Minimum value for equalizer filter Q-factor.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmAudioEqualizerSettings Constructor

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmAudioEqualizerSettings(
    DcnmAudioEqualizerType equalizerType,
    int filterNumber,
    DcnmAudioEqualizerFilterType filterType,
    bool filterEnabled,
    float gain,
    int frequency,
    float qualityFactor
)
Public Sub New (
    equalizerType As DcnmAudioEqualizerType,
    filterNumber As Integer,
    filterType As DcnmAudioEqualizerFilterType,
    filterEnabled As Boolean,
    gain As Single,
    frequency As Integer,
    qualityFactor As Single
)
public:
DcnmAudioEqualizerSettings(
    DcnmAudioEqualizerType equalizerType,
    int filterNumber,
    DcnmAudioEqualizerFilterType filterType,
    bool filterEnabled,
    float gain,
    int frequency,
    float qualityFactor
)

Parameters

equalizerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAudioEqualizerType
Type of the equalizer
filterNumber
Type: SystemInt32
Number of the filter band (0..4)
filterType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAudioEqualizerFilterType
Type of the filter
filterEnabled
Type: SystemBoolean
Indicates if filter is enabled
gain
Type: SystemSingle
Gain of the filter
frequency
Type: SystemInt32
Frequency of the filter
qualityFactor
Type: SystemSingle
Q-Factor of the filter
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerSettings Properties

The DcnmAudioEqualizerSettings type exposes the following members.

Properties
 | Name | Description
Public property | EqualizerType | Type of the equalizer
Public property | FilterEnabled | Indicates if filter is enabled
Public property | FilterNumber | Number of the filter band (0..4)
Public property | FilterType | Type of the filter
Public property | Frequency | Frequency of the filter.
Public property | Gain | Gain of the filter.
Public property | QFactor | Q-Factor of the filter, if applicable.
Top
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerSettings.EqualizerType Property

DcnmAudioEqualizerSettingsEqualizerType Property

Type of the equalizer

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmAudioEqualizerType EqualizerType { get; set; }
Public Property EqualizerType As DcnmAudioEqualizerType
    Get
    Set
public:
property DcnmAudioEqualizerType EqualizerType {
    DcnmAudioEqualizerType get ();
    void set (DcnmAudioEqualizerType value);
}

Property Value

Type: DcnmAudioEqualizerType
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerSettings.FilterEnabled Property

DcnmAudioEqualizerSettingsFilterEnabled Property

Indicates if filter is enabled

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool FilterEnabled { get; set; }
Public Property FilterEnabled As Boolean
    Get
    Set
public:
property bool FilterEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerSettings.FilterNumber Property

DcnmAudioEqualizerSettingsFilterNumber Property

Number of the filter band (0..4)

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int FilterNumber { get; set; }
Public Property FilterNumber As Integer
    Get
    Set
public:
property int FilterNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerSettings.FilterType Property

DcnmAudioEqualizerSettingsFilterType Property

Type of the filter

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmAudioEqualizerFilterType FilterType { get; set; }
Public Property FilterType As DcnmAudioEqualizerFilterType
    Get
    Set
public:
property DcnmAudioEqualizerFilterType FilterType {
    DcnmAudioEqualizerFilterType get ();
    void set (DcnmAudioEqualizerFilterType value);
}

Property Value

Type: DcnmAudioEqualizerFilterType
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerSettings.Frequency Property

DcnmAudioEqualizerSettingsFrequency Property

Frequency of the filter.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int Frequency { get; set; }
Public Property Frequency As Integer
    Get
    Set
public:
property int Frequency {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerSettings.Gain Property

DcnmAudioEqualizerSettingsGain Property

Gain of the filter.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public float Gain { get; set; }
Public Property Gain As Single
    Get
    Set
public:
property float Gain {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerSettings.QFactor Property

DcnmAudioEqualizerSettingsQFactor Property

Q-Factor of the filter, if applicable.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public float QFactor { get; set; }
Public Property QFactor As Single
    Get
    Set
public:
property float QFactor {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerSettings Methods

The DcnmAudioEqualizerSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerSettings Fields

The DcnmAudioEqualizerSettings type exposes the following members.

Fields
Name | Description
EQUALIZER_DEFAULT_MAX_FREQUENCY | Maximum value for equalizer filter frequency.
EQUALIZER_DEFAULT_MAX_GAIN | Maximum value for equalizer filter gain.
EQUALIZER_DEFAULT_MAX_QFACTOR | Maximum value for equalizer filter Q-factor.
EQUALIZER_DEFAULT_MIN_FREQUENCY | Minimum value for equalizer filter frequency.
EQUALIZER_DEFAULT_MIN_GAIN | Minimum value for equalizer filter gain.
EQUALIZER_DEFAULT_MIN_QFACTOR | Minimum value for equalizer filter Q-factor.
Top
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerSettings.EQUALIZER_DEFAULT_MAX_FREQUENCY Field

DcnmAudioEqualizerSettingsEQUALIZER_DEFAULT_MAX_FREQUENCY Field

 Bosch Logo
Maximum value for equalizer filter frequency.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int EQUALIZER_DEFAULT_MAX_FREQUENCY = 18000
Public Const EQUALIZER_DEFAULT_MAX_FREQUENCY As Integer = 18000
public:
literal int EQUALIZER_DEFAULT_MAX_FREQUENCY = 18000

Field Value

Type: Int32
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerSettings.EQUALIZER_DEFAULT_MAX_GAIN Field

DcnmAudioEqualizerSettingsEQUALIZER_DEFAULT_MAX_GAIN Field

Maximum value for equalizer filter gain.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int EQUALIZER_DEFAULT_MAX_GAIN = 12
Public Const EQUALIZER_DEFAULT_MAX_GAIN As Integer = 12
public:
literal int EQUALIZER_DEFAULT_MAX_GAIN = 12

Field Value

Type: Int32
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerSettings.EQUALIZER_DEFAULT_MAX_QFACTOR Field

DcnmAudioEqualizerSettingsEQUALIZER_DEFAULT_MAX_QFACTOR Field

 Bosch Logo
Maximum value for equalizer filter Q-factor.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const float EQUALIZER_DEFAULT_MAX_QFACTOR = 14f
Public Const EQUALIZER_DEFAULT_MAX_QFACTOR As Single = 14F
public:
literal float EQUALIZER_DEFAULT_MAX_QFACTOR = 14f

Field Value

Type: Single
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerSettings.EQUALIZER_DEFAULT_MIN_FREQUENCY Field

DcnmAudioEqualizerSettingsEQUALIZER_DEFAULT_MIN_FREQUENCY Field

 Bosch Logo
Minimum value for equalizer filter frequency.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int EQUALIZER_DEFAULT_MIN_FREQUENCY = 50
Public Const EQUALIZER_DEFAULT_MIN_FREQUENCY As Integer = 50
public:
literal int EQUALIZER_DEFAULT_MIN_FREQUENCY = 50

Field Value

Type: Int32
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerSettings.EQUALIZER_DEFAULT_MIN_GAIN Field

DcnmAudioEqualizerSettingsEQUALIZER_DEFAULT_MIN_GAIN Field

Minimum value for equalizer filter gain.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int EQUALIZER_DEFAULT_MIN_GAIN = -12
Public Const EQUALIZER_DEFAULT_MIN_GAIN As Integer = -12
public:
literal int EQUALIZER_DEFAULT_MIN_GAIN = -12

Field Value

Type: Int32
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerSettings.EQUALIZER_DEFAULT_MIN_QFACTOR Field

DcnmAudioEqualizerSettingsEQUALIZER_DEFAULT_MIN_QFACTOR Field

 Bosch Logo
Minimum value for equalizer filter Q-factor.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const float EQUALIZER_DEFAULT_MIN_QFACTOR = 0.4f
Public Const EQUALIZER_DEFAULT_MIN_QFACTOR As Single = 0.4F
public:
literal float EQUALIZER_DEFAULT_MIN_QFACTOR = 0.4f

Field Value

Type: Single
See Also

Reference

DcnmAudioEqualizerSettings Class


DcnmAudioEqualizerType Enumeration

Represents the equalizer type

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmAudioEqualizerType
Public Enumeration DcnmAudioEqualizerType
public enum class DcnmAudioEqualizerType
Members
Member name | Value | Description
Loudspeaker | 0 | Delegate loudspeaker equalizer
SoundReinforcement | 1 | Sound reinforcement equalizer
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmAudioGainSetting Class

The gain setting supported by the Dcnm system.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAudioGainSetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmAudioGainSetting
Public Class DcnmAudioGainSetting
public ref class DcnmAudioGainSetting

The DcnmAudioGainSetting type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmAudioGainSetting(DcnmAudioGainSettingType, Single) | Constructor...
Public method | DcnmAudioGainSetting(DcnmAudioGainSettingType, Single, Boolean, Boolean) | Constructor...
Public method | DcnmAudioGainSetting(DcnmAudioGainSettingType, Single, Single, Single, Single, Boolean, Boolean) | Constructor...
Top
Properties
 | Name | Description
Public property | GainSettingType | The type of the gain.
Public property | IsMuted | Indication if audio is muted.
Public property | IsPlayingTestTone | Indication if a test tone is playing.
Public property | MaximumGain | The maximum gain value in dB.
Public property | MinimumGain | The minimum gain value in dB.
Public property | StepSize | The step size value in dB.
Public property | Value | The gain value in a range from 0 to 1.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmAudioGainSetting Constructor

Overload List
 | Name | Description
Public method | DcnmAudioGainSetting(DcnmAudioGainSettingType, Single) | Constructor...
Public method | DcnmAudioGainSetting(DcnmAudioGainSettingType, Single, Boolean, Boolean) | Constructor...
Public method | DcnmAudioGainSetting(DcnmAudioGainSettingType, Single, Single, Single, Single, Boolean, Boolean) | Constructor...
Top
See Also

Reference

DcnmAudioGainSetting Class


DcnmAudioGainSetting Constructor (DcnmAudioGainSettingType, Single)

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmAudioGainSetting(
    DcnmAudioGainSettingType gainSettingType,
    float value
)
Public Sub New (
    gainSettingType As DcnmAudioGainSettingType,
    value As Single
)
public:
DcnmAudioGainSetting(
    DcnmAudioGainSettingType gainSettingType,
    float value
)

Parameters

gainSettingType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAudioGainSettingType
The type of gain.
value
Type: SystemSingle
The gain value in a range from 0 to 1.
See Also

Reference

DcnmAudioGainSetting Class
DcnmAudioGainSetting Overload


DcnmAudioGainSetting Constructor (DcnmAudioGainSettingType, Single, Boolean, Boolean)

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmAudioGainSetting(
    DcnmAudioGainSettingType gainSettingType,
    float value,
    bool isMuted,
    bool isPlayingTestTone
)
Public Sub New (
    gainSettingType As DcnmAudioGainSettingType,
    value As Single,
    isMuted As Boolean,
    isPlayingTestTone As Boolean
)
public:
DcnmAudioGainSetting(
    DcnmAudioGainSettingType gainSettingType,
    float value,
    bool isMuted,
    bool isPlayingTestTone
)

Parameters

gainSettingType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAudioGainSettingType
The type of gain.
value
Type: SystemSingle
The gain value in a range from 0 to 1.
isMuted
Type: SystemBoolean
The indication if audio is muted.
isPlayingTestTone
Type: SystemBoolean
The indication if test tone is played.
See Also

Reference

DcnmAudioGainSetting Class
DcnmAudioGainSetting Overload


DcnmAudioGainSetting Constructor (DcnmAudioGainSettingType, Single, Single, Single, Single, Boolean, Boolean)

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmAudioGainSetting(
    DcnmAudioGainSettingType gainSettingType,
    float value,
    float minimumGain,
    float maximumGain,
    float stepSize,
    bool isMuted,
    bool isPlayingTestTone
)
Public Sub New (
    gainSettingType As DcnmAudioGainSettingType,
    value As Single,
    minimumGain As Single,
    maximumGain As Single,
    stepSize As Single,
    isMuted As Boolean,
    isPlayingTestTone As Boolean
)
public:
DcnmAudioGainSetting(
    DcnmAudioGainSettingType gainSettingType,
    float value,
    float minimumGain,
    float maximumGain,
    float stepSize,
    bool isMuted,
    bool isPlayingTestTone
)

Parameters

gainSettingType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAudioGainSettingType
The type of gain.
value
Type: SystemSingle
The gain value in a range from 0 to 1.
minimumGain
Type: SystemSingle
The minimum gain in dB.
maximumGain
Type: SystemSingle
The maximum gain in dB.
stepSize
Type: SystemSingle
The step size in dB.
isMuted
Type: SystemBoolean
The indication if audio is muted.
isPlayingTestTone
Type: SystemBoolean
The indication if test tone is played.
See Also

Reference

DcnmAudioGainSetting Class
DcnmAudioGainSetting Overload


DcnmAudioGainSetting Properties

The DcnmAudioGainSetting type exposes the following members.

Properties
 | Name | Description
Public property | GainSettingType | The type of the gain.
Public property | IsMuted | Indication if audio is muted.
Public property | IsPlayingTestTone | Indication if a test tone is playing.
Public property | MaximumGain | The maximum gain value in dB.
Public property | MinimumGain | The minimum gain value in dB.
Public property | StepSize | The step size value in dB.
Public property | Value | The gain value in a range from 0 to 1.
Top
See Also

Reference

DcnmAudioGainSetting Class


DcnmAudioGainSetting.GainSettingType Property

DcnmAudioGainSettingGainSettingType Property

The type of the gain.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmAudioGainSettingType GainSettingType { get; }
Public ReadOnly Property GainSettingType As DcnmAudioGainSettingType
    Get
public:
property DcnmAudioGainSettingType GainSettingType {
    DcnmAudioGainSettingType get ();
}

Property Value

Type: DcnmAudioGainSettingType
See Also

Reference

DcnmAudioGainSetting Class


DcnmAudioGainSetting.IsMuted Property

DcnmAudioGainSettingIsMuted Property

Indication if audio is muted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsMuted { get; }
Public ReadOnly Property IsMuted As Boolean
    Get
public:
property bool IsMuted {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmAudioGainSetting Class


DcnmAudioGainSetting.IsPlayingTestTone Property

DcnmAudioGainSettingIsPlayingTestTone Property

Indication if a test tone is playing.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsPlayingTestTone { get; }
Public ReadOnly Property IsPlayingTestTone As Boolean
    Get
public:
property bool IsPlayingTestTone {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmAudioGainSetting Class


DcnmAudioGainSetting.MaximumGain Property

DcnmAudioGainSettingMaximumGain Property

The maximum gain value in dB.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public float MaximumGain { get; }
Public ReadOnly Property MaximumGain As Single
    Get
public:
property float MaximumGain {
    float get ();
}

Property Value

Type: Single
See Also

Reference

DcnmAudioGainSetting Class


DcnmAudioGainSetting.MinimumGain Property

DcnmAudioGainSettingMinimumGain Property

The minimum gain value in dB.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public float MinimumGain { get; }
Public ReadOnly Property MinimumGain As Single
    Get
public:
property float MinimumGain {
    float get ();
}

Property Value

Type: Single
See Also

Reference

DcnmAudioGainSetting Class


DcnmAudioGainSetting.StepSize Property

DcnmAudioGainSettingStepSize Property

The step size value in dB.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public float StepSize { get; }
Public ReadOnly Property StepSize As Single
    Get
public:
property float StepSize {
    float get ();
}

Property Value

Type: Single
See Also

Reference

DcnmAudioGainSetting Class


DcnmAudioGainSetting.Value Property

DcnmAudioGainSettingValue Property

The gain value in a range from 0 to 1.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public float Value { get; }
Public ReadOnly Property Value As Single
    Get
public:
property float Value {
    float get ();
}

Property Value

Type: Single
See Also

Reference

DcnmAudioGainSetting Class


DcnmAudioGainSetting Methods

The DcnmAudioGainSetting type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmAudioGainSetting Class


DcnmAudioGainSettingType Enumeration

The different device types supported by the Dcnm system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmAudioGainSettingType
Public Enumeration DcnmAudioGainSettingType
public enum class DcnmAudioGainSettingType
Members
Member name | Value | Description
Master | 0 | Master Volume
Loudspeaker | 1 | LoudSpeaker
SoundReinforcement | 2 | Sound reinforcement
AnalogIn0 | 3 | Analog In 0
AnalogOut0 | 4 | Analog Out 0
AnalogIn1 | 5 | Analog In 1
AnalogOut1 | 6 | Analog Out 1
DanteDigitalIn0 | 7 | Dante digital In 0
DanteDigitalOut0 | 8 | Dante digital Out 0
DanteDigitalIn1 | 9 | Dante digital In 1
DanteDigitalOut1 | 10 | Dante digital Out 1
AnalogHeadroom | 11 | Headroom on analog (local) APS I/O
DanteHeadroom | 12 | Headroom on Dante (external) APS I/O
OmneoHeadroom | 13 | Headroom on Omneo (local) APS I/O
OmneoDigitalIn0 | 14 | Omneo digital In 0
OmneoDigitalOut0 | 15 | Omneo digital Out 0
OmneoDigitalIn1 | 16 | Omneo digital In 1
OmneoDigitalOut1 | 17 | Omneo digital Out 0
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmAudioSelectionSetting Class

The audio selection setting supported by the Dcnm system.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAudioSelectionSetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmAudioSelectionSetting
Public Class DcnmAudioSelectionSetting
public ref class DcnmAudioSelectionSetting

The DcnmAudioSelectionSetting type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmAudioSelectionSetting | Constructor...
Top
Properties
 | Name | Description
Public property | SelectionSettingType | The type of the audio selection setting.
Public property | Value | The value of the audio selection setting.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmAudioSelectionSetting Constructor

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmAudioSelectionSetting(
    DcnmAudioSelectionSettingType selectionSettingType,
    int value
)
Public Sub New (
    selectionSettingType As DcnmAudioSelectionSettingType,
    value As Integer
)
public:
DcnmAudioSelectionSetting(
    DcnmAudioSelectionSettingType selectionSettingType,
    int value
)

Parameters

selectionSettingType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAudioSelectionSettingType
The audio selection type.
value
Type: SystemInt32
The audio selection value.
See Also

Reference

DcnmAudioSelectionSetting Class


DcnmAudioSelectionSetting Properties

The DcnmAudioSelectionSetting type exposes the following members.

Properties
 | Name | Description
Public property | SelectionSettingType | The type of the audio selection setting.
Public property | Value | The value of the audio selection setting.
Top
See Also

Reference

DcnmAudioSelectionSetting Class


DcnmAudioSelectionSetting.SelectionSettingType Property

DcnmAudioSelectionSettingSelectionSettingType Property

The type of the audio selection setting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmAudioSelectionSettingType SelectionSettingType { get; }
Public ReadOnly Property SelectionSettingType As DcnmAudioSelectionSettingType
    Get
public:
property DcnmAudioSelectionSettingType SelectionSettingType {
    DcnmAudioSelectionSettingType get ();
}

Property Value

Type: DcnmAudioSelectionSettingType
See Also

Reference

DcnmAudioSelectionSetting Class


DcnmAudioSelectionSetting.Value Property

DcnmAudioSelectionSettingValue Property

The value of the audio selection setting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int Value { get; }
Public ReadOnly Property Value As Integer
    Get
public:
property int Value {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmAudioSelectionSetting Class


DcnmAudioSelectionSetting Methods

The DcnmAudioSelectionSetting type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmAudioSelectionSetting Class


DcnmAudioSelectionSettingType Enumeration

Enumeration of audio selection setting types.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmAudioSelectionSettingType
Public Enumeration DcnmAudioSelectionSettingType
public enum class DcnmAudioSelectionSettingType
Members
Member name | Value | Description
LoudspeakerActiveWhenSpeaking | 0 | Loudspeaker active when speaking.
HeadphoneAttenuationWhenSpeaking | 1 | Headphone attenuation when speaking.
MinimumHeadphoneAttenuationWhenSpeakingValue | 2 | Minimum headphone attenuation when speaking value.
MaximumHeadphoneAttenuationWhenSpeakingValue | 3 | Maximum headphone attenuation when speaking value.
HeadphoneAttenuationWhenSpeakingValue | 4 | Headphone attenuation when speaking value.
AcousticFeedbackSuppression | 5 | Acoustic feedback suppression.
AudioIn1Mode | 6 | Audio In1 mode (ambient mic).
AudioRoutingMode | 7 | Audio routing mode.
TestToneType | 8 | Type of test tone.
DanteAudioIn1Mode | 9 | Dante audio In1 mode (ambient mic).
DanteAudioRoutingMode | 10 | Dante audio routing mode.
ChimesOnHeadphones | 11 | Can chimes be heard on headphones?
OmneoAudioIn1Mode | 12 | Omneo audio In1 mode (ambient mic).
OmneoAudioRoutingMode | 13 | Omneo audio routing mode.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmBoothNotificationInfo Class

Represents the booth notification info.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmBoothNotificationInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmBoothNotificationInfo
Public Class DcnmBoothNotificationInfo
public ref class DcnmBoothNotificationInfo

The DcnmBoothNotificationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmBoothNotificationInfo | /// Initializes a new instance of the DcnmBoothNotificationInfo class.
Top
Properties
 | Name | Description
Public property | BoothId | Gets the booth identifier of the booth with active notifications
Public property | Notifications | Gets the list of active notifications as a list of strings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmBoothNotificationInfo Constructor

/// Initializes a new instance of the DcnmBoothNotificationInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmBoothNotificationInfo(
    Guid boothId,
    IEnumerable<string> notifications
)
Public Sub New (
    boothId As Guid,
    notifications As IEnumerable(Of String)
)
public:
DcnmBoothNotificationInfo(
    Guid boothId,
    IEnumerable<String^>^ notifications
)

Parameters

boothId
Type: SystemGuid
The booth identifier.
notifications
Type: System.Collections.GenericIEnumerable String
The list of active notifications, refer to BoothNotifications.
See Also

Reference

DcnmBoothNotificationInfo Class


DcnmBoothNotificationInfo Properties

The DcnmBoothNotificationInfo type exposes the following members.

Properties
 | Name | Description
Public property | BoothId | Gets the booth identifier of the booth with active notifications
Public property | Notifications | Gets the list of active notifications as a list of strings.
Top
See Also

Reference

DcnmBoothNotificationInfo Class


DcnmBoothNotificationInfo.BoothId Property

DcnmBoothNotificationInfoBoothId Property

Gets the booth identifier of the booth with active notifications

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid BoothId { get; }
Public ReadOnly Property BoothId As Guid
    Get
public:
property Guid BoothId {
    Guid get ();
}

Property Value

Type: Guid
The booth identifier.
See Also

Reference

DcnmBoothNotificationInfo Class


DcnmBoothNotificationInfo.Notifications Property

DcnmBoothNotificationInfoNotifications Property

Gets the list of active notifications as a list of strings.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<string> Notifications { get; }
Public ReadOnly Property Notifications As IList(Of String)
    Get
public:
property IList<String^>^ Notifications {
    IList<String^>^ get ();
}

Property Value

Type: IList String
The list of active notifications.
See Also

Reference

DcnmBoothNotificationInfo Class


DcnmBoothNotificationInfo Methods

The DcnmBoothNotificationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmBoothNotificationInfo Class


DcnmCameraControlProtocol Enumeration

Enum represents camera controlling protocol

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmCameraControlProtocol
Public Enumeration DcnmCameraControlProtocol
public enum class DcnmCameraControlProtocol
Members
Member name | Value | Description
Unknown | 0 | Unknown camera protocol.
Onvif | 1 | Support for onvif camera.
Sony | 2 | Support for sony camera.
Panasonic | 3 | Support for panasonic camera.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmCameraPreparationInfo Class

Container for the camera preparation information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmCameraPreparationInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmCameraPreparationInfo
Public Class DcnmCameraPreparationInfo
public ref class DcnmCameraPreparationInfo

The DcnmCameraPreparationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmCameraPreparationInfo | Default constructor for class
Public method | DcnmCameraPreparationInfo(Guid, String, String, Int32, DcnmCameraType) | Initializes a new instance of the DcnmCameraPreparationInfo class.
Public method | DcnmCameraPreparationInfo(Guid, String, String, Int32, DcnmCameraType, String, Boolean) | Initializes a new instance of the DcnmCameraPreparationInfo class.
Public method | DcnmCameraPreparationInfo(Guid, String, String, Int32, DcnmCameraType, String, Boolean, String, String, String, DcnmCameraControlProtocol, String, Boolean, Boolean) | Initializes a new instance of the DcnmCameraPreparationInfo class.
Top
Properties
 | Name | Description
Public property | CameraType | The type of the camera.
Public property | ControlProtocol | The camera controlling protocol.
Public property | Id | The identifier of the camera.
Public property | IpAddress | The IP address of the camera.
Public property | IsAuthenticationSuccessful | Verifies username and password valid or not.
Public property | IsAutoDetectedCamera | The camera is auto detected by Dcnm Service or not.
Public property | IsConnected | The camera connection state.
Public property | MacAddress | The mac address of camera.
Public property | MaxNrPrepositions | The maximum number of prepositions of the camera.
Public property | Name | The name of the camera.
Public property | Password | The camera password.
Public property | Serial | The serial of the camera.
Public property | UserName | The camera username.
Public property | VideoStream | The h264 video stream.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmCameraPreparationInfo Constructor

Overload List
 | Name | Description
Public method | DcnmCameraPreparationInfo | Default constructor for class
Public method | DcnmCameraPreparationInfo(Guid, String, String, Int32, DcnmCameraType) | Initializes a new instance of the DcnmCameraPreparationInfo class.
Public method | DcnmCameraPreparationInfo(Guid, String, String, Int32, DcnmCameraType, String, Boolean) | Initializes a new instance of the DcnmCameraPreparationInfo class.
Public method | DcnmCameraPreparationInfo(Guid, String, String, Int32, DcnmCameraType, String, Boolean, String, String, String, DcnmCameraControlProtocol, String, Boolean, Boolean) | Initializes a new instance of the DcnmCameraPreparationInfo class.
Top
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraPreparationInfo Constructor

Default constructor for class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmCameraPreparationInfo()
Public Sub New
public:
DcnmCameraPreparationInfo()
See Also

Reference

DcnmCameraPreparationInfo Class
DcnmCameraPreparationInfo Overload


DcnmCameraPreparationInfo Constructor (Guid, String, String, Int32, DcnmCameraType)

Initializes a new instance of the DcnmCameraPreparationInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmCameraPreparationInfo(
    Guid id,
    string name,
    string serial,
    int maxNrPrepositions,
    DcnmCameraType cameraType
)
Public Sub New (
    id As Guid,
    name As String,
    serial As String,
    maxNrPrepositions As Integer,
    cameraType As DcnmCameraType
)
public:
DcnmCameraPreparationInfo(
    Guid id,
    String^ name,
    String^ serial,
    int maxNrPrepositions,
    DcnmCameraType cameraType
)

Parameters

id
Type: SystemGuid
The identifier of the camera.
name
Type: SystemString
The name of the camera.
serial
Type: SystemString
the serial of the camera
maxNrPrepositions
Type: SystemInt32
the maximum number of prepositions of the camera
cameraType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmCameraType
the camera type
See Also

Reference

DcnmCameraPreparationInfo Class
DcnmCameraPreparationInfo Overload


DcnmCameraPreparationInfo Constructor (Guid, String, String, Int32, DcnmCameraType, String, Boolean)

Initializes a new instance of the DcnmCameraPreparationInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmCameraPreparationInfo(
    Guid id,
    string name,
    string serial,
    int maxNrPrepositions,
    DcnmCameraType cameraType,
    string ipAddress,
    bool isConnected
)
Public Sub New (
    id As Guid,
    name As String,
    serial As String,
    maxNrPrepositions As Integer,
    cameraType As DcnmCameraType,
    ipAddress As String,
    isConnected As Boolean
)
public:
DcnmCameraPreparationInfo(
    Guid id,
    String^ name,
    String^ serial,
    int maxNrPrepositions,
    DcnmCameraType cameraType,
    String^ ipAddress,
    bool isConnected
)

Parameters

id
Type: SystemGuid
The identifier of the camera.
name
Type: SystemString
The name of the camera.
serial
Type: SystemString
The serial of the camera
maxNrPrepositions
Type: SystemInt32
The maximum number of prepositions of the camera
cameraType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmCameraType
The camera type
ipAddress
Type: SystemString
The IP address of the camera
isConnected
Type: SystemBoolean
The camera connection state
See Also

Reference

DcnmCameraPreparationInfo Class
DcnmCameraPreparationInfo Overload


DcnmCameraPreparationInfo Constructor (Guid, String, String, Int32, DcnmCameraType, String, Boolean, String, String, String, DcnmCameraControlProtocol, String, Boolean, Boolean)

Initializes a new instance of the DcnmCameraPreparationInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmCameraPreparationInfo(
    Guid id,
    string name,
    string serial,
    int maxNrPrepositions,
    DcnmCameraType cameraType,
    string ipAddress,
    bool isConnected,
    string userName,
    string password,
    string videoStream,
    DcnmCameraControlProtocol controlProtocol,
    string macAddress,
    bool isAuthenticationSuccessful,
    bool isAutoDetectedCamera
)
Public Sub New (
    id As Guid,
    name As String,
    serial As String,
    maxNrPrepositions As Integer,
    cameraType As DcnmCameraType,
    ipAddress As String,
    isConnected As Boolean,
    userName As String,
    password As String,
    videoStream As String,
    controlProtocol As DcnmCameraControlProtocol,
    macAddress As String,
    isAuthenticationSuccessful As Boolean,
    isAutoDetectedCamera As Boolean
)
public:
DcnmCameraPreparationInfo(
    Guid id,
    String^ name,
    String^ serial,
    int maxNrPrepositions,
    DcnmCameraType cameraType,
    String^ ipAddress,
    bool isConnected,
    String^ userName,
    String^ password,
    String^ videoStream,
    DcnmCameraControlProtocol controlProtocol,
    String^ macAddress,
    bool isAuthenticationSuccessful,
    bool isAutoDetectedCamera
)

Parameters

id
Type: SystemGuid
The identifier of the camera.
name
Type: SystemString
The name of the camera.
serial
Type: SystemString
The serial of the camera
maxNrPrepositions
Type: SystemInt32
The maximum number of prepositions of the camera
cameraType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmCameraType
The camera type
ipAddress
Type: SystemString
The IP address of the camera
isConnected
Type: SystemBoolean
The camera connection state
userName
Type: SystemString
The camera usename.
password
Type: SystemString
The camera password.
videoStream
Type: SystemString
The h264 video stream.
controlProtocol
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmCameraControlProtocol
The camera controlling protocol.
macAddress
Type: SystemString
The mac address of camera.
isAuthenticationSuccessful
Type: SystemBoolean
Authentication status of camera.
isAutoDetectedCamera
Type: SystemBoolean
The camera is auto detected by dcnm server or not.
See Also

Reference

DcnmCameraPreparationInfo Class
DcnmCameraPreparationInfo Overload


DcnmCameraPreparationInfo Properties

The DcnmCameraPreparationInfo type exposes the following members.

Properties
 | Name | Description
Public property | CameraType | The type of the camera.
Public property | ControlProtocol | The camera controlling protocol.
Public property | Id | The identifier of the camera.
Public property | IpAddress | The IP address of the camera.
Public property | IsAuthenticationSuccessful | Verifies username and password valid or not.
Public property | IsAutoDetectedCamera | The camera is auto detected by Dcnm Service or not.
Public property | IsConnected | The camera connection state.
Public property | MacAddress | The mac address of camera.
Public property | MaxNrPrepositions | The maximum number of prepositions of the camera.
Public property | Name | The name of the camera.
Public property | Password | The camera password.
Public property | Serial | The serial of the camera.
Public property | UserName | The camera username.
Public property | VideoStream | The h264 video stream.
Top
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraPreparationInfo.CameraType Property

DcnmCameraPreparationInfoCameraType Property

The type of the camera.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmCameraType CameraType { get; }
Public ReadOnly Property CameraType As DcnmCameraType
    Get
public:
property DcnmCameraType CameraType {
    DcnmCameraType get ();
}

Property Value

Type: DcnmCameraType
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraPreparationInfo.ControlProtocol Property

DcnmCameraPreparationInfoControlProtocol Property

The camera controlling protocol.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmCameraControlProtocol ControlProtocol { get; }
Public ReadOnly Property ControlProtocol As DcnmCameraControlProtocol
    Get
public:
property DcnmCameraControlProtocol ControlProtocol {
    DcnmCameraControlProtocol get ();
}

Property Value

Type: DcnmCameraControlProtocol
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraPreparationInfo.Id Property

DcnmCameraPreparationInfoId Property

The identifier of the camera.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid Id { get; }
Public ReadOnly Property Id As Guid
    Get
public:
property Guid Id {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraPreparationInfo.IpAddress Property

DcnmCameraPreparationInfoIpAddress Property

The IP address of the camera.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string IpAddress { get; }
Public ReadOnly Property IpAddress As String
    Get
public:
property String^ IpAddress {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraPreparationInfo.IsAuthenticationSuccessful Property

DcnmCameraPreparationInfoIsAuthenticationSuccessful Property

Verifies username and password valid or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsAuthenticationSuccessful { get; }
Public ReadOnly Property IsAuthenticationSuccessful As Boolean
    Get
public:
property bool IsAuthenticationSuccessful {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraPreparationInfo.IsAutoDetectedCamera Property

DcnmCameraPreparationInfoIsAutoDetectedCamera Property

The camera is auto detected by Dcnm Service or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsAutoDetectedCamera { get; }
Public ReadOnly Property IsAutoDetectedCamera As Boolean
    Get
public:
property bool IsAutoDetectedCamera {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraPreparationInfo.IsConnected Property

DcnmCameraPreparationInfoIsConnected Property

The camera connection state.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsConnected { get; }
Public ReadOnly Property IsConnected As Boolean
    Get
public:
property bool IsConnected {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraPreparationInfo.MacAddress Property

DcnmCameraPreparationInfoMacAddress Property

The mac address of camera.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string MacAddress { get; }
Public ReadOnly Property MacAddress As String
    Get
public:
property String^ MacAddress {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraPreparationInfo.MaxNrPrepositions Property

DcnmCameraPreparationInfoMaxNrPrepositions Property

The maximum number of prepositions of the camera.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int MaxNrPrepositions { get; }
Public ReadOnly Property MaxNrPrepositions As Integer
    Get
public:
property int MaxNrPrepositions {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraPreparationInfo.Name Property

DcnmCameraPreparationInfoName Property

The name of the camera.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraPreparationInfo.Password Property

DcnmCameraPreparationInfoPassword Property

The camera password.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Password { get; }
Public ReadOnly Property Password As String
    Get
public:
property String^ Password {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraPreparationInfo.Serial Property

DcnmCameraPreparationInfoSerial Property

The serial of the camera.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Serial { get; }
Public ReadOnly Property Serial As String
    Get
public:
property String^ Serial {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraPreparationInfo.UserName Property

DcnmCameraPreparationInfoUserName Property

The camera username.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string UserName { get; }
Public ReadOnly Property UserName As String
    Get
public:
property String^ UserName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraPreparationInfo.VideoStream Property

DcnmCameraPreparationInfoVideoStream Property

The h264 video stream.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string VideoStream { get; }
Public ReadOnly Property VideoStream As String
    Get
public:
property String^ VideoStream {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraPreparationInfo Methods

The DcnmCameraPreparationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmCameraPreparationInfo Class


DcnmCameraStatusInfo Class

Represents a container for the information about a camera.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmCameraStatusInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmCameraStatusInfo
Public Class DcnmCameraStatusInfo
public ref class DcnmCameraStatusInfo

The DcnmCameraStatusInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmCameraStatusInfo | Initializes a new instance of the DcnmCameraStatusInfo class.
Top
Properties
 | Name | Description
Public property | Active | Indicates whether the camera is active.
Public property | CameraId | The camera id.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmCameraStatusInfo Constructor

Initializes a new instance of the DcnmCameraStatusInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmCameraStatusInfo(
    Guid cameraId,
    bool active
)
Public Sub New (
    cameraId As Guid,
    active As Boolean
)
public:
DcnmCameraStatusInfo(
    Guid cameraId,
    bool active
)

Parameters

cameraId
Type: SystemGuid
The camera id.
active
Type: SystemBoolean
if set to true camera is active.
See Also

Reference

DcnmCameraStatusInfo Class


DcnmCameraStatusInfo Properties

The DcnmCameraStatusInfo type exposes the following members.

Properties
 | Name | Description
Public property | Active | Indicates whether the camera is active.
Public property | CameraId | The camera id.
Top
See Also

Reference

DcnmCameraStatusInfo Class


DcnmCameraStatusInfo.Active Property

DcnmCameraStatusInfoActive Property

Indicates whether the camera is active.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool Active { get; }
Public ReadOnly Property Active As Boolean
    Get
public:
property bool Active {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmCameraStatusInfo Class


DcnmCameraStatusInfo.CameraId Property

DcnmCameraStatusInfoCameraId Property

The camera id.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid CameraId { get; }
Public ReadOnly Property CameraId As Guid
    Get
public:
property Guid CameraId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmCameraStatusInfo Class


DcnmCameraStatusInfo Methods

The DcnmCameraStatusInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmCameraStatusInfo Class


DcnmCameraType Enumeration

The different camera types supported by the Dcnm system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmCameraType
Public Enumeration DcnmCameraType
public enum class DcnmCameraType
Members
Member name | Value | Description
Fixed | 0 | Used to indicate that the camera type is fixed .
PTZ | 1 | Used to indicate that the camera is equipped with Pan Tilt Zoom functionality.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmChannelMappingInfo Class

Map which can be descriptive to a channel as input or output
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmChannelMappingInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmChannelMappingInfo
Public Class DcnmChannelMappingInfo
public ref class DcnmChannelMappingInfo

The DcnmChannelMappingInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmChannelMappingInfo | Constructor...
Public method | DcnmChannelMappingInfo(Guid, DcnmChannelMapType, Int32, Int32, Guid) | Obsolete. Construct an input or output mapping.
Public method | DcnmChannelMappingInfo(Guid, DcnmChannelMapType, Int32, Int32, Int32, Guid) | Construct an input or output mapping.
Top
Properties
 | Name | Description
Public property | ChannelMapId | Identifier of the channel map.
Public property | ChannelMapType | The type of the channel map, input or output.
Public property | ChannelNumber | The DcnmSystemChannelMappingNumbers (in/out index) associated with the channel map.
Public property | DeviceId | The device hosting the channel map, e.g. the identifier for a 4OMI4.
Public property | LanguageNumber | Obsolete. The language number (in/out index) associated with the channel map.
Public property | PortNumber | The port number (index).
Public property | SubChannelNumber | The audio subchannel being mapped. Only applicable when ChannelMapType equals DicentisToExternal
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmChannelMappingInfo Constructor

Overload List
 | Name | Description
Public method | DcnmChannelMappingInfo | Constructor...
Public method | DcnmChannelMappingInfo(Guid, DcnmChannelMapType, Int32, Int32, Guid) | Obsolete. Construct an input or output mapping.
Public method | DcnmChannelMappingInfo(Guid, DcnmChannelMapType, Int32, Int32, Int32, Guid) | Construct an input or output mapping.
Top
See Also

Reference

DcnmChannelMappingInfo Class


DcnmChannelMappingInfo Constructor

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmChannelMappingInfo()
Public Sub New
public:
DcnmChannelMappingInfo()
See Also

Reference

DcnmChannelMappingInfo Class
DcnmChannelMappingInfo Overload


DcnmChannelMappingInfo Constructor (Guid, DcnmChannelMapType, Int32, Int32, Guid)

Note: This API is now obsolete.

Construct an input or output mapping.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This constructor is deprecated, please use the constructor with subChannelNr instead.")]
public DcnmChannelMappingInfo(
    Guid channelMapId,
    DcnmChannelMapType channelMapType,
    int channelNumber,
    int portNumber,
    Guid deviceId
)
<ObsoleteAttribute("This constructor is deprecated, please use the constructor with subChannelNr instead.")>
Public Sub New (
    channelMapId As Guid,
    channelMapType As DcnmChannelMapType,
    channelNumber As Integer,
    portNumber As Integer,
    deviceId As Guid
)
public:
[ObsoleteAttribute(L"This constructor is deprecated, please use the constructor with subChannelNr instead.")]
DcnmChannelMappingInfo(
    Guid channelMapId,
    DcnmChannelMapType channelMapType,
    int channelNumber,
    int portNumber,
    Guid deviceId
)

Parameters

channelMapId
Type: SystemGuid
Identifier of the channel map.
channelMapType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmChannelMapType
The type of the channel map, input or output.
channelNumber
Type: SystemInt32
The number (in/out index) associated with the channel map.
portNumber
Type: SystemInt32
The port number (index)
deviceId
Type: SystemGuid
The device hosting the channel map, e.g. the identifier for a 4OMI4
Remarks
This constructor is deprecated, please use DcnmChannelMappingInfo(Guid, DcnmChannelMapType, Int32, Int32, Int32, Guid) instead.
See Also

Reference

DcnmChannelMappingInfo Class
DcnmChannelMappingInfo Overload


DcnmChannelMappingInfo Constructor (Guid, DcnmChannelMapType, Int32, Int32, Int32, Guid)

Construct an input or output mapping.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmChannelMappingInfo(
    Guid channelMapId,
    DcnmChannelMapType channelMapType,
    int channelNumber,
    int subChannelNumber,
    int portNumber,
    Guid deviceId
)
Public Sub New (
    channelMapId As Guid,
    channelMapType As DcnmChannelMapType,
    channelNumber As Integer,
    subChannelNumber As Integer,
    portNumber As Integer,
    deviceId As Guid
)
public:
DcnmChannelMappingInfo(
    Guid channelMapId,
    DcnmChannelMapType channelMapType,
    int channelNumber,
    int subChannelNumber,
    int portNumber,
    Guid deviceId
)

Parameters

channelMapId
Type: SystemGuid
Identifier of the channel map.
channelMapType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmChannelMapType
The type of the channel map, input or output.
channelNumber
Type: SystemInt32
The DICENTIS audio channel number associated with the map.
subChannelNumber
Type: SystemInt32
The audio subchannel number to map. This is only applicable for output mappings (DicentisToExternal) for input mappings the value of subChannelNumber must be 0.
Subchannel | Description
0 | Processed audio stream as it is used in the DICENTS conference system.
1 | Unprocessed audio stream for use in external systems.
portNumber
Type: SystemInt32
The port number (index)
deviceId
Type: SystemGuid
The device hosting the channel map, e.g. the identifier for a 4OMI4
See Also

Reference

DcnmChannelMappingInfo Class
DcnmChannelMappingInfo Overload


DcnmChannelMappingInfo Properties

The DcnmChannelMappingInfo type exposes the following members.

Properties
 | Name | Description
Public property | ChannelMapId | Identifier of the channel map.
Public property | ChannelMapType | The type of the channel map, input or output.
Public property | ChannelNumber | The DcnmSystemChannelMappingNumbers (in/out index) associated with the channel map.
Public property | DeviceId | The device hosting the channel map, e.g. the identifier for a 4OMI4.
Public property | LanguageNumber | Obsolete. The language number (in/out index) associated with the channel map.
Public property | PortNumber | The port number (index).
Public property | SubChannelNumber | The audio subchannel being mapped. Only applicable when ChannelMapType equals DicentisToExternal
Top
See Also

Reference

DcnmChannelMappingInfo Class


DcnmChannelMappingInfo.ChannelMapId Property

DcnmChannelMappingInfoChannelMapId Property

Identifier of the channel map.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid ChannelMapId { get; set; }
Public Property ChannelMapId As Guid
    Get
    Set
public:
property Guid ChannelMapId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmChannelMappingInfo Class


DcnmChannelMappingInfo.ChannelMapType Property

DcnmChannelMappingInfoChannelMapType Property

The type of the channel map, input or output.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmChannelMapType ChannelMapType { get; set; }
Public Property ChannelMapType As DcnmChannelMapType
    Get
    Set
public:
property DcnmChannelMapType ChannelMapType {
    DcnmChannelMapType get ();
    void set (DcnmChannelMapType value);
}

Property Value

Type: DcnmChannelMapType
See Also

Reference

DcnmChannelMappingInfo Class


DcnmChannelMappingInfo.ChannelNumber Property

DcnmChannelMappingInfoChannelNumber Property

The DcnmSystemChannelMappingNumbers (in/out index) associated with the channel map.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int ChannelNumber { get; set; }
Public Property ChannelNumber As Integer
    Get
    Set
public:
property int ChannelNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DcnmChannelMappingInfo Class


DcnmChannelMappingInfo.DeviceId Property

DcnmChannelMappingInfoDeviceId Property

The device hosting the channel map, e.g. the identifier for a 4OMI4.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid DeviceId { get; set; }
Public Property DeviceId As Guid
    Get
    Set
public:
property Guid DeviceId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmChannelMappingInfo Class


DcnmChannelMappingInfo.LanguageNumber Property

DcnmChannelMappingInfoLanguageNumber Property

Note: This API is now obsolete.

The language number (in/out index) associated with the channel map.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("LanguageNumber property is deprecated, please use ChannelNumber property instead.")]
public int LanguageNumber { get; set; }
<ObsoleteAttribute("LanguageNumber property is deprecated, please use ChannelNumber property instead.")>
Public Property LanguageNumber As Integer
    Get
    Set
public:
[ObsoleteAttribute(L"LanguageNumber property is deprecated, please use ChannelNumber property instead.")]
property int LanguageNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DcnmChannelMappingInfo Class


DcnmChannelMappingInfo.PortNumber Property

DcnmChannelMappingInfoPortNumber Property

The port number (index).

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int PortNumber { get; set; }
Public Property PortNumber As Integer
    Get
    Set
public:
property int PortNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DcnmChannelMappingInfo Class


DcnmChannelMappingInfo.SubChannelNumber Property

DcnmChannelMappingInfoSubChannelNumber Property

The audio subchannel being mapped. Only applicable when ChannelMapType equals DicentisToExternal

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int SubChannelNumber { get; set; }
Public Property SubChannelNumber As Integer
    Get
    Set
public:
property int SubChannelNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DcnmChannelMappingInfo Class


DcnmChannelMappingInfo Methods

The DcnmChannelMappingInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmChannelMappingInfo Class


DcnmChannelMapType Enumeration

Defines the type a channel map can have.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmChannelMapType
Public Enumeration DcnmChannelMapType
public enum class DcnmChannelMapType
Members
Member name | Value | Description
ExternalToDicentis | 0 | From external system to Dicentis.
DicentisToExternal | 1 | From Dicentis to an external system.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmChimeTunes Enumeration

Represents the type of a chimetune.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmChimeTunes
Public Enumeration DcnmChimeTunes
public enum class DcnmChimeTunes
Members
Member name | Value | Description
Summon | 0 | Summon
Priority | 1 | Priority
Voting | 2 | Voting
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmComparisonOperators Enumeration

Defines condition for formulas

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmComparisonOperators
Public Enumeration DcnmComparisonOperators
public enum class DcnmComparisonOperators
Members
Member name | Value | Description
GreaterThan | 0 | Used to indicate LHS > RHS
GreaterThanOrEqualTo | 1 | Used to indicate LHS >= RHS
Equals | 2 | Used to indicate LHS = RHS
LessThan | 3 | Used to indicates LHS < RHS.
LessThanOrEqualTo | 4 | Used to indicate LHS <= RHS
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmConferenceSecurityClaim Enumeration

Contains Conference Security rights.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmConferenceSecurityClaim
Public Enumeration DcnmConferenceSecurityClaim
public enum class DcnmConferenceSecurityClaim
Members
Member name | Value | Description
ActivateMeeting | 0 | Indicates the user group can activate and deactivate meetings.
PrepareMeetingAndAgenda | 1 | Indicates the user group can prepare meeting and agenda's.
PrepareUsers | 2 | Indicates the user group can prepare users and user groups and assign access rights to them.
ConfigureSystem | 3 | Indicates the user group can prepare and configure the system.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDeskConfiguration Class

Represents the desk configuration.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeskConfiguration

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmDeskConfiguration
Public Class DcnmDeskConfiguration
public ref class DcnmDeskConfiguration

The DcnmDeskConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmDeskConfiguration | The default constructor
Public method | DcnmDeskConfiguration(Int32, Int32, IListGuid, IListGuid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Boolean) | The constructor with all parameters
Top
Properties
 | Name | Description
Public property | AInputLanguageId | Language set on A input.
Public property | BeepsEnabled | Indicates if audio feedback is enabled or not.
Public property | BInputLanguageId | Language set on B input.
Public property | BoothNumber | BoothNumber of Desk.
Public property | CInputLanguageId | Language set on C input.
Public property | DeskNumber | DeskNumber of Desk.
Public property | DInputLanguageId | Language set on D input.
Public property | EInputLanguageId | Language set on E input.
Public property | FInputLanguageId | Language set on F input.
Public property | GInputLanguageId | Language set on G input.
Public property | SelectableLanguagesForOutputB | Languages selectable for the B output.
Public property | SelectableLanguagesForOutputC | Languages selectable for the C output.
Public property | SelectedAOutputLanguage | language on A output.
Public property | SelectedBOutputLanguage | language on B output.
Public property | SelectedCOutputLanguage | language on C output.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDeskConfiguration Constructor

Overload List
 | Name | Description
Public method | DcnmDeskConfiguration | The default constructor
Public method | DcnmDeskConfiguration(Int32, Int32, IListGuid, IListGuid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Boolean) | The constructor with all parameters
Top
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration Constructor

The default constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDeskConfiguration()
Public Sub New
public:
DcnmDeskConfiguration()
See Also

Reference

DcnmDeskConfiguration Class
DcnmDeskConfiguration Overload


DcnmDeskConfiguration Constructor (Int32, Int32, IList(Guid), IList(Guid), Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Boolean)

DcnmDeskConfiguration Constructor (Int32, Int32, IListGuid, IListGuid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Boolean)

 Bosch Logo
The constructor with all parameters

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDeskConfiguration(
    int boothNumber,
    int deskNumber,
    IList<Guid> selectableLanguagesForOutputB,
    IList<Guid> selectableLanguagesForOutputC,
    Guid inputA,
    Guid inputB,
    Guid inputC,
    Guid inputD,
    Guid inputE,
    Guid inputF,
    Guid inputG,
    Guid selectedAOutputLanguage,
    Guid selectedBOutputLanguage,
    Guid selectedCOutputLanguage,
    bool beepsEnabled
)
Public Sub New (
    boothNumber As Integer,
    deskNumber As Integer,
    selectableLanguagesForOutputB As IList(Of Guid),
    selectableLanguagesForOutputC As IList(Of Guid),
    inputA As Guid,
    inputB As Guid,
    inputC As Guid,
    inputD As Guid,
    inputE As Guid,
    inputF As Guid,
    inputG As Guid,
    selectedAOutputLanguage As Guid,
    selectedBOutputLanguage As Guid,
    selectedCOutputLanguage As Guid,
    beepsEnabled As Boolean
)
public:
DcnmDeskConfiguration(
    int boothNumber,
    int deskNumber,
    IList<Guid>^ selectableLanguagesForOutputB,
    IList<Guid>^ selectableLanguagesForOutputC,
    Guid inputA,
    Guid inputB,
    Guid inputC,
    Guid inputD,
    Guid inputE,
    Guid inputF,
    Guid inputG,
    Guid selectedAOutputLanguage,
    Guid selectedBOutputLanguage,
    Guid selectedCOutputLanguage,
    bool beepsEnabled
)

Parameters

boothNumber
Type: SystemInt32
BoothNumber of Desk.
deskNumber
Type: SystemInt32
Desknumber of the desk
selectableLanguagesForOutputB
Type: System.Collections.GenericIList Guid
Languages set for the B output.
selectableLanguagesForOutputC
Type: System.Collections.GenericIList Guid
Languages set for the B output.
inputA
Type: SystemGuid
Input A select language preference.
inputB
Type: SystemGuid
Input B select language preference.
inputC
Type: SystemGuid
Input C select language preference.
inputD
Type: SystemGuid
Input D select language preference.
inputE
Type: SystemGuid
Input E select language preference.
inputF
Type: SystemGuid
Input F select language preference.
inputG
Type: SystemGuid
Input G select language preference.
selectedAOutputLanguage
Type: SystemGuid
Output A language.
selectedBOutputLanguage
Type: SystemGuid
Selected output B language.
selectedCOutputLanguage
Type: SystemGuid
Selected output C language.
beepsEnabled
Type: SystemBoolean
Indication whether beeps are enabled.
See Also

Reference

DcnmDeskConfiguration Class
DcnmDeskConfiguration Overload


DcnmDeskConfiguration Properties

The DcnmDeskConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AInputLanguageId | Language set on A input.
Public property | BeepsEnabled | Indicates if audio feedback is enabled or not.
Public property | BInputLanguageId | Language set on B input.
Public property | BoothNumber | BoothNumber of Desk.
Public property | CInputLanguageId | Language set on C input.
Public property | DeskNumber | DeskNumber of Desk.
Public property | DInputLanguageId | Language set on D input.
Public property | EInputLanguageId | Language set on E input.
Public property | FInputLanguageId | Language set on F input.
Public property | GInputLanguageId | Language set on G input.
Public property | SelectableLanguagesForOutputB | Languages selectable for the B output.
Public property | SelectableLanguagesForOutputC | Languages selectable for the C output.
Public property | SelectedAOutputLanguage | language on A output.
Public property | SelectedBOutputLanguage | language on B output.
Public property | SelectedCOutputLanguage | language on C output.
Top
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration.AInputLanguageId Property

DcnmDeskConfigurationAInputLanguageId Property

Language set on A input.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid AInputLanguageId { get; set; }
Public Property AInputLanguageId As Guid
    Get
    Set
public:
property Guid AInputLanguageId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration.BeepsEnabled Property

DcnmDeskConfigurationBeepsEnabled Property

Indicates if audio feedback is enabled or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool BeepsEnabled { get; set; }
Public Property BeepsEnabled As Boolean
    Get
    Set
public:
property bool BeepsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration.BInputLanguageId Property

DcnmDeskConfigurationBInputLanguageId Property

Language set on B input.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid BInputLanguageId { get; set; }
Public Property BInputLanguageId As Guid
    Get
    Set
public:
property Guid BInputLanguageId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration.BoothNumber Property

DcnmDeskConfigurationBoothNumber Property

BoothNumber of Desk.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int BoothNumber { get; set; }
Public Property BoothNumber As Integer
    Get
    Set
public:
property int BoothNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration.CInputLanguageId Property

DcnmDeskConfigurationCInputLanguageId Property

Language set on C input.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid CInputLanguageId { get; set; }
Public Property CInputLanguageId As Guid
    Get
    Set
public:
property Guid CInputLanguageId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration.DeskNumber Property

DcnmDeskConfigurationDeskNumber Property

DeskNumber of Desk.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int DeskNumber { get; set; }
Public Property DeskNumber As Integer
    Get
    Set
public:
property int DeskNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration.DInputLanguageId Property

DcnmDeskConfigurationDInputLanguageId Property

Language set on D input.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid DInputLanguageId { get; set; }
Public Property DInputLanguageId As Guid
    Get
    Set
public:
property Guid DInputLanguageId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration.EInputLanguageId Property

DcnmDeskConfigurationEInputLanguageId Property

Language set on E input.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid EInputLanguageId { get; set; }
Public Property EInputLanguageId As Guid
    Get
    Set
public:
property Guid EInputLanguageId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration.FInputLanguageId Property

DcnmDeskConfigurationFInputLanguageId Property

Language set on F input.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid FInputLanguageId { get; set; }
Public Property FInputLanguageId As Guid
    Get
    Set
public:
property Guid FInputLanguageId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration.GInputLanguageId Property

DcnmDeskConfigurationGInputLanguageId Property

Language set on G input.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid GInputLanguageId { get; set; }
Public Property GInputLanguageId As Guid
    Get
    Set
public:
property Guid GInputLanguageId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration.SelectableLanguagesForOutputB Property

DcnmDeskConfigurationSelectableLanguagesForOutputB Property

Languages selectable for the B output.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<Guid> SelectableLanguagesForOutputB { get; }
Public ReadOnly Property SelectableLanguagesForOutputB As IList(Of Guid)
    Get
public:
property IList<Guid>^ SelectableLanguagesForOutputB {
    IList<Guid>^ get ();
}

Property Value

Type: IList Guid
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration.SelectableLanguagesForOutputC Property

DcnmDeskConfigurationSelectableLanguagesForOutputC Property

Languages selectable for the C output.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<Guid> SelectableLanguagesForOutputC { get; }
Public ReadOnly Property SelectableLanguagesForOutputC As IList(Of Guid)
    Get
public:
property IList<Guid>^ SelectableLanguagesForOutputC {
    IList<Guid>^ get ();
}

Property Value

Type: IList Guid
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration.SelectedAOutputLanguage Property

DcnmDeskConfigurationSelectedAOutputLanguage Property

language on A output.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid SelectedAOutputLanguage { get; set; }
Public Property SelectedAOutputLanguage As Guid
    Get
    Set
public:
property Guid SelectedAOutputLanguage {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration.SelectedBOutputLanguage Property

DcnmDeskConfigurationSelectedBOutputLanguage Property

language on B output.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid SelectedBOutputLanguage { get; set; }
Public Property SelectedBOutputLanguage As Guid
    Get
    Set
public:
property Guid SelectedBOutputLanguage {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration.SelectedCOutputLanguage Property

DcnmDeskConfigurationSelectedCOutputLanguage Property

language on C output.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid SelectedCOutputLanguage { get; set; }
Public Property SelectedCOutputLanguage As Guid
    Get
    Set
public:
property Guid SelectedCOutputLanguage {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeskConfiguration Methods

The DcnmDeskConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmDeskConfiguration Class


DcnmDeviceAtSeat Class

Device information assigned at seat.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceInfo
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceAtSeat

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmDeviceAtSeat : DcnmDeviceInfo
Public Class DcnmDeviceAtSeat
    Inherits DcnmDeviceInfo
public ref class DcnmDeviceAtSeat : public DcnmDeviceInfo

The DcnmDeviceAtSeat type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmDeviceAtSeat(Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, DcnmDeviceOperationalState, Boolean) | Obsolete. Initializes a new instance of the DcnmDeviceAtSeat class.
Public method | DcnmDeviceAtSeat(Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, DcnmDeviceOperationalState, Boolean, Int32) | Obsolete. Initializes a new instance of the DcnmDeviceAtSeat class.
Public method | DcnmDeviceAtSeat(Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, IListString, DcnmDeviceOperationalState, Boolean) | Initializes a new instance of the DcnmDeviceAtSeat class.
Public method | DcnmDeviceAtSeat(Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, IListString, DcnmDeviceOperationalState, Boolean, Int32) | Initializes a new instance of the DcnmDeviceAtSeat class.
Top
Properties
 | Name | Description
Public property | Attributes | The attributes of the device. Refer to DeviceAttributes for explanation on device attributes. (Inherited from DcnmDeviceInfo.)
Public property | Capabilities | The capabilities of the device. (Inherited from DcnmDeviceInfo.)
Public property | DeviceState | The operational state of the state. (Inherited from DcnmDeviceInfo.)
Public property | Id | Identifies the device, it will not change during the lifetime of the device. (Inherited from DcnmDeviceInfo.)
Public property | IsFoundAtSeat | Whether the device is found at the assigned seat.
Public property | IsSelected | Gets a value indicating whether this DcnmDeviceInfo is selected. (Inherited from DcnmDeviceInfo.)
Public property | Name | The name of the device. (Inherited from DcnmDeviceInfo.)
Public property | SerialNumber | The serial number of this device. (Inherited from DcnmDeviceInfo.)
Public property | SubDeviceInstance | Gets the device instance of this device. (Inherited from DcnmDeviceInfo.)
Public property | TypeOf | The type of this device. (Inherited from DcnmDeviceInfo.)
Public property | Version | The version of this device. (Inherited from DcnmDeviceInfo.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDeviceAtSeat Constructor

Overload List
 | Name | Description
Public method | DcnmDeviceAtSeat(Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, DcnmDeviceOperationalState, Boolean) | Obsolete. Initializes a new instance of the DcnmDeviceAtSeat class.
Public method | DcnmDeviceAtSeat(Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, DcnmDeviceOperationalState, Boolean, Int32) | Obsolete. Initializes a new instance of the DcnmDeviceAtSeat class.
Public method | DcnmDeviceAtSeat(Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, IListString, DcnmDeviceOperationalState, Boolean) | Initializes a new instance of the DcnmDeviceAtSeat class.
Public method | DcnmDeviceAtSeat(Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, IListString, DcnmDeviceOperationalState, Boolean, Int32) | Initializes a new instance of the DcnmDeviceAtSeat class.
Top
See Also

Reference

DcnmDeviceAtSeat Class


DcnmDeviceAtSeat Constructor (Guid, DcnmDeviceType, String, String, String, IList(DcnmEquipmentCapabilities), DcnmDeviceOperationalState, Boolean)

DcnmDeviceAtSeat Constructor (Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, DcnmDeviceOperationalState, Boolean)

 Bosch Logo

Note: This API is now obsolete.

Initializes a new instance of the DcnmDeviceAtSeat class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection")]
public DcnmDeviceAtSeat(
    Guid id,
    DcnmDeviceType type,
    string name,
    string version,
    string serialNumber,
    IList<DcnmEquipmentCapabilities> capabilities,
    DcnmDeviceOperationalState state,
    bool isFoundAtSeat
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection")>
Public Sub New (
    id As Guid,
    type As DcnmDeviceType,
    name As String,
    version As String,
    serialNumber As String,
    capabilities As IList(Of DcnmEquipmentCapabilities),
    state As DcnmDeviceOperationalState,
    isFoundAtSeat As Boolean
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection")]
DcnmDeviceAtSeat(
    Guid id,
    DcnmDeviceType type,
    String^ name,
    String^ version,
    String^ serialNumber,
    IList<DcnmEquipmentCapabilities>^ capabilities,
    DcnmDeviceOperationalState state,
    bool isFoundAtSeat
)

Parameters

id
Type: SystemGuid
The identifier of the device.
type
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceType
The type of the device
name
Type: SystemString
The name of the device
version
Type: SystemString
The version of the device
serialNumber
Type: SystemString
The serial number of the device
capabilities
Type: System.Collections.GenericIList DcnmEquipmentCapabilities
The capabilities.
state
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceOperationalState
The operational state of the device.
isFoundAtSeat
Type: SystemBoolean
Whether the device is found at the assigned seat.
See Also

Reference

DcnmDeviceAtSeat Class
DcnmDeviceAtSeat Overload


DcnmDeviceAtSeat Constructor (Guid, DcnmDeviceType, String, String, String, IList(DcnmEquipmentCapabilities), DcnmDeviceOperationalState, Boolean, Int32)

DcnmDeviceAtSeat Constructor (Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, DcnmDeviceOperationalState, Boolean, Int32)

 Bosch Logo

Note: This API is now obsolete.

Initializes a new instance of the DcnmDeviceAtSeat class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection")]
public DcnmDeviceAtSeat(
    Guid id,
    DcnmDeviceType type,
    string name,
    string version,
    string serialNumber,
    IList<DcnmEquipmentCapabilities> capabilities,
    DcnmDeviceOperationalState state,
    bool isFoundAtSeat,
    int subDeviceInstance
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection")>
Public Sub New (
    id As Guid,
    type As DcnmDeviceType,
    name As String,
    version As String,
    serialNumber As String,
    capabilities As IList(Of DcnmEquipmentCapabilities),
    state As DcnmDeviceOperationalState,
    isFoundAtSeat As Boolean,
    subDeviceInstance As Integer
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection")]
DcnmDeviceAtSeat(
    Guid id,
    DcnmDeviceType type,
    String^ name,
    String^ version,
    String^ serialNumber,
    IList<DcnmEquipmentCapabilities>^ capabilities,
    DcnmDeviceOperationalState state,
    bool isFoundAtSeat,
    int subDeviceInstance
)

Parameters

id
Type: SystemGuid
The identifier of the device.
type
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceType
The type of the device
name
Type: SystemString
The name of the device
version
Type: SystemString
The version of the device
serialNumber
Type: SystemString
The serial number of the device
capabilities
Type: System.Collections.GenericIList DcnmEquipmentCapabilities
The capabilities.
state
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceOperationalState
The operational state of the device.
isFoundAtSeat
Type: SystemBoolean
Whether the device is found at the assigned seat.
subDeviceInstance
Type: SystemInt32
the device instance number (wrt dual use) where zero represents the primary device.
See Also

Reference

DcnmDeviceAtSeat Class
DcnmDeviceAtSeat Overload


DcnmDeviceAtSeat Constructor (Guid, DcnmDeviceType, String, String, String, IList(DcnmEquipmentCapabilities), IList(String), DcnmDeviceOperationalState, Boolean)

DcnmDeviceAtSeat Constructor (Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, IListString, DcnmDeviceOperationalState, Boolean)

 Bosch Logo
Initializes a new instance of the DcnmDeviceAtSeat class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDeviceAtSeat(
    Guid id,
    DcnmDeviceType type,
    string name,
    string version,
    string serialNumber,
    IList<DcnmEquipmentCapabilities> capabilities,
    IList<string> attributes,
    DcnmDeviceOperationalState state,
    bool isFoundAtSeat
)
Public Sub New (
    id As Guid,
    type As DcnmDeviceType,
    name As String,
    version As String,
    serialNumber As String,
    capabilities As IList(Of DcnmEquipmentCapabilities),
    attributes As IList(Of String),
    state As DcnmDeviceOperationalState,
    isFoundAtSeat As Boolean
)
public:
DcnmDeviceAtSeat(
    Guid id,
    DcnmDeviceType type,
    String^ name,
    String^ version,
    String^ serialNumber,
    IList<DcnmEquipmentCapabilities>^ capabilities,
    IList<String^>^ attributes,
    DcnmDeviceOperationalState state,
    bool isFoundAtSeat
)

Parameters

id
Type: SystemGuid
The identifier of the device.
type
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceType
The type of the device
name
Type: SystemString
The name of the device
version
Type: SystemString
The version of the device
serialNumber
Type: SystemString
The serial number of the device
capabilities
Type: System.Collections.GenericIList DcnmEquipmentCapabilities
The capabilities.
attributes
Type: System.Collections.GenericIList String
The attributes of the device, refer to DeviceAttributes.
state
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceOperationalState
The operational state of the device.
isFoundAtSeat
Type: SystemBoolean
Whether the device is found at the assigned seat.
See Also

Reference

DcnmDeviceAtSeat Class
DcnmDeviceAtSeat Overload


DcnmDeviceAtSeat Constructor (Guid, DcnmDeviceType, String, String, String, IList(DcnmEquipmentCapabilities), IList(String), DcnmDeviceOperationalState, Boolean, Int32)

DcnmDeviceAtSeat Constructor (Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, IListString, DcnmDeviceOperationalState, Boolean, Int32)

 Bosch Logo
Initializes a new instance of the DcnmDeviceAtSeat class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDeviceAtSeat(
    Guid id,
    DcnmDeviceType type,
    string name,
    string version,
    string serialNumber,
    IList<DcnmEquipmentCapabilities> capabilities,
    IList<string> attributes,
    DcnmDeviceOperationalState state,
    bool isFoundAtSeat,
    int subDeviceInstance
)
Public Sub New (
    id As Guid,
    type As DcnmDeviceType,
    name As String,
    version As String,
    serialNumber As String,
    capabilities As IList(Of DcnmEquipmentCapabilities),
    attributes As IList(Of String),
    state As DcnmDeviceOperationalState,
    isFoundAtSeat As Boolean,
    subDeviceInstance As Integer
)
public:
DcnmDeviceAtSeat(
    Guid id,
    DcnmDeviceType type,
    String^ name,
    String^ version,
    String^ serialNumber,
    IList<DcnmEquipmentCapabilities>^ capabilities,
    IList<String^>^ attributes,
    DcnmDeviceOperationalState state,
    bool isFoundAtSeat,
    int subDeviceInstance
)

Parameters

id
Type: SystemGuid
The identifier of the device.
type
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceType
The type of the device
name
Type: SystemString
The name of the device
version
Type: SystemString
The version of the device
serialNumber
Type: SystemString
The serial number of the device
capabilities
Type: System.Collections.GenericIList DcnmEquipmentCapabilities
The capabilities.
attributes
Type: System.Collections.GenericIList String
The attributes of the device, refer to DeviceAttributes.
state
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceOperationalState
The operational state of the device.
isFoundAtSeat
Type: SystemBoolean
Whether the device is found at the assigned seat.
subDeviceInstance
Type: SystemInt32
the device instance number (wrt dual use) where zero represents the primary device.
See Also

Reference

DcnmDeviceAtSeat Class
DcnmDeviceAtSeat Overload


DcnmDeviceAtSeat Properties

The DcnmDeviceAtSeat type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | The attributes of the device. Refer to DeviceAttributes for explanation on device attributes. (Inherited from DcnmDeviceInfo.)
Public property | Capabilities | The capabilities of the device. (Inherited from DcnmDeviceInfo.)
Public property | DeviceState | The operational state of the state. (Inherited from DcnmDeviceInfo.)
Public property | Id | Identifies the device, it will not change during the lifetime of the device. (Inherited from DcnmDeviceInfo.)
Public property | IsFoundAtSeat | Whether the device is found at the assigned seat.
Public property | IsSelected | Gets a value indicating whether this DcnmDeviceInfo is selected. (Inherited from DcnmDeviceInfo.)
Public property | Name | The name of the device. (Inherited from DcnmDeviceInfo.)
Public property | SerialNumber | The serial number of this device. (Inherited from DcnmDeviceInfo.)
Public property | SubDeviceInstance | Gets the device instance of this device. (Inherited from DcnmDeviceInfo.)
Public property | TypeOf | The type of this device. (Inherited from DcnmDeviceInfo.)
Public property | Version | The version of this device. (Inherited from DcnmDeviceInfo.)
Top
See Also

Reference

DcnmDeviceAtSeat Class


DcnmDeviceAtSeat.IsFoundAtSeat Property

DcnmDeviceAtSeatIsFoundAtSeat Property

Whether the device is found at the assigned seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsFoundAtSeat { get; }
Public ReadOnly Property IsFoundAtSeat As Boolean
    Get
public:
property bool IsFoundAtSeat {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmDeviceAtSeat Class


DcnmDeviceAtSeat Methods

The DcnmDeviceAtSeat type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmDeviceAtSeat Class


DcnmDeviceCapabilities Class

Represents a container for the capabilities of a device.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceCapabilities

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmDeviceCapabilities
Public Class DcnmDeviceCapabilities
public ref class DcnmDeviceCapabilities

The DcnmDeviceCapabilities type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmDeviceCapabilities | Constructor...
Top
Properties
 | Name | Description
Public property | Capabilities | Gets the capabilities.
Public property | Id | Identifies the area, it will not change during the lifetime of the area.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDeviceCapabilities Constructor

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDeviceCapabilities(
    Guid id,
    IList<DcnmEquipmentCapabilities> capabilities
)
Public Sub New (
    id As Guid,
    capabilities As IList(Of DcnmEquipmentCapabilities)
)
public:
DcnmDeviceCapabilities(
    Guid id,
    IList<DcnmEquipmentCapabilities>^ capabilities
)

Parameters

id
Type: SystemGuid
The identifier of the area.
capabilities
Type: System.Collections.GenericIList DcnmEquipmentCapabilities
The capabilities.
See Also

Reference

DcnmDeviceCapabilities Class


DcnmDeviceCapabilities Properties

The DcnmDeviceCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | Capabilities | Gets the capabilities.
Public property | Id | Identifies the area, it will not change during the lifetime of the area.
Top
See Also

Reference

DcnmDeviceCapabilities Class


DcnmDeviceCapabilities.Capabilities Property

DcnmDeviceCapabilitiesCapabilities Property

Gets the capabilities.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<DcnmEquipmentCapabilities> Capabilities { get; }
Public ReadOnly Property Capabilities As IList(Of DcnmEquipmentCapabilities)
    Get
public:
property IList<DcnmEquipmentCapabilities>^ Capabilities {
    IList<DcnmEquipmentCapabilities>^ get ();
}

Property Value

Type: IList DcnmEquipmentCapabilities
See Also

Reference

DcnmDeviceCapabilities Class


DcnmDeviceCapabilities.Id Property

DcnmDeviceCapabilitiesId Property

Identifies the area, it will not change during the lifetime of the area.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid Id { get; }
Public ReadOnly Property Id As Guid
    Get
public:
property Guid Id {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmDeviceCapabilities Class


DcnmDeviceCapabilities Methods

The DcnmDeviceCapabilities type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmDeviceCapabilities Class


DcnmDeviceConnectionState Enumeration

The connection states of a device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmDeviceConnectionState
Public Enumeration DcnmDeviceConnectionState
public enum class DcnmDeviceConnectionState
Members
Member name | Value | Description
Disconnected | 0 | Not connected.
Connecting | 1 | Attempting to connect.
Connected | 2 | Connection established.
Disconnecting | 3 | Attempting to disconnect.
Reconnecting | 4 | Re-establishing connection.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDeviceInfo Class

Defines a container for the information about a device.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceInfo
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceAtSeat

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmDeviceInfo
Public Class DcnmDeviceInfo
public ref class DcnmDeviceInfo

The DcnmDeviceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmDeviceInfo(Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, DcnmDeviceOperationalState, Boolean) | Obsolete. Constructor.
Public method | DcnmDeviceInfo(Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, DcnmDeviceOperationalState, Boolean, Int32) | Obsolete. Constructor.
Public method | DcnmDeviceInfo(Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, IListString, DcnmDeviceOperationalState, Boolean) | Constructor.
Public method | DcnmDeviceInfo(Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, IListString, DcnmDeviceOperationalState, Boolean, Int32) | Constructor.
Top
Properties
 | Name | Description
Public property | Attributes | The attributes of the device. Refer to DeviceAttributes for explanation on device attributes.
Public property | Capabilities | The capabilities of the device.
Public property | DeviceState | The operational state of the state.
Public property | Id | Identifies the device, it will not change during the lifetime of the device.
Public property | IsSelected | Gets a value indicating whether this DcnmDeviceInfo is selected.
Public property | Name | The name of the device.
Public property | SerialNumber | The serial number of this device.
Public property | SubDeviceInstance | Gets the device instance of this device.
Public property | TypeOf | The type of this device.
Public property | Version | The version of this device.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDeviceInfo Constructor

Overload List
 | Name | Description
Public method | DcnmDeviceInfo(Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, DcnmDeviceOperationalState, Boolean) | Obsolete. Constructor.
Public method | DcnmDeviceInfo(Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, DcnmDeviceOperationalState, Boolean, Int32) | Obsolete. Constructor.
Public method | DcnmDeviceInfo(Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, IListString, DcnmDeviceOperationalState, Boolean) | Constructor.
Public method | DcnmDeviceInfo(Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, IListString, DcnmDeviceOperationalState, Boolean, Int32) | Constructor.
Top
See Also

Reference

DcnmDeviceInfo Class


DcnmDeviceInfo Constructor (Guid, DcnmDeviceType, String, String, String, IList(DcnmEquipmentCapabilities), DcnmDeviceOperationalState, Boolean)

DcnmDeviceInfo Constructor (Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, DcnmDeviceOperationalState, Boolean)

 Bosch Logo

Note: This API is now obsolete.

Constructor.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection")]
public DcnmDeviceInfo(
    Guid id,
    DcnmDeviceType type,
    string name,
    string version,
    string serialNumber,
    IList<DcnmEquipmentCapabilities> capabilities,
    DcnmDeviceOperationalState deviceState,
    bool selected
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection")>
Public Sub New (
    id As Guid,
    type As DcnmDeviceType,
    name As String,
    version As String,
    serialNumber As String,
    capabilities As IList(Of DcnmEquipmentCapabilities),
    deviceState As DcnmDeviceOperationalState,
    selected As Boolean
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection")]
DcnmDeviceInfo(
    Guid id,
    DcnmDeviceType type,
    String^ name,
    String^ version,
    String^ serialNumber,
    IList<DcnmEquipmentCapabilities>^ capabilities,
    DcnmDeviceOperationalState deviceState,
    bool selected
)

Parameters

id
Type: SystemGuid
The identifier of the device.
type
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceType
The type of the device
name
Type: SystemString
The name of the device
version
Type: SystemString
The version of the device
serialNumber
Type: SystemString
The serial number of the device
capabilities
Type: System.Collections.GenericIList DcnmEquipmentCapabilities
The capabilities.
deviceState
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceOperationalState
The operational state of the device.
selected
Type: SystemBoolean
if set to true selected.
See Also

Reference

DcnmDeviceInfo Class
DcnmDeviceInfo Overload


DcnmDeviceInfo Constructor (Guid, DcnmDeviceType, String, String, String, IList(DcnmEquipmentCapabilities), DcnmDeviceOperationalState, Boolean, Int32)

DcnmDeviceInfo Constructor (Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, DcnmDeviceOperationalState, Boolean, Int32)

 Bosch Logo

Note: This API is now obsolete.

Constructor.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection")]
public DcnmDeviceInfo(
    Guid id,
    DcnmDeviceType type,
    string name,
    string version,
    string serialNumber,
    IList<DcnmEquipmentCapabilities> capabilities,
    DcnmDeviceOperationalState deviceState,
    bool selected,
    int subDeviceInstance
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection")>
Public Sub New (
    id As Guid,
    type As DcnmDeviceType,
    name As String,
    version As String,
    serialNumber As String,
    capabilities As IList(Of DcnmEquipmentCapabilities),
    deviceState As DcnmDeviceOperationalState,
    selected As Boolean,
    subDeviceInstance As Integer
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection")]
DcnmDeviceInfo(
    Guid id,
    DcnmDeviceType type,
    String^ name,
    String^ version,
    String^ serialNumber,
    IList<DcnmEquipmentCapabilities>^ capabilities,
    DcnmDeviceOperationalState deviceState,
    bool selected,
    int subDeviceInstance
)

Parameters

id
Type: SystemGuid
The identifier of the device.
type
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceType
The type of the device
name
Type: SystemString
The name of the device
version
Type: SystemString
The version of the device
serialNumber
Type: SystemString
The serial number of the device
capabilities
Type: System.Collections.GenericIList DcnmEquipmentCapabilities
The capabilities.
deviceState
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceOperationalState
The operational state of the device.
selected
Type: SystemBoolean
if set to true selected.
subDeviceInstance
Type: SystemInt32
the device instance number where zero represents the primary device.
See Also

Reference

DcnmDeviceInfo Class
DcnmDeviceInfo Overload


DcnmDeviceInfo Constructor (Guid, DcnmDeviceType, String, String, String, IList(DcnmEquipmentCapabilities), IList(String), DcnmDeviceOperationalState, Boolean)

DcnmDeviceInfo Constructor (Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, IListString, DcnmDeviceOperationalState, Boolean)

 Bosch Logo
Constructor.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDeviceInfo(
    Guid id,
    DcnmDeviceType type,
    string name,
    string version,
    string serialNumber,
    IList<DcnmEquipmentCapabilities> capabilities,
    IList<string> attributes,
    DcnmDeviceOperationalState deviceState,
    bool selected
)
Public Sub New (
    id As Guid,
    type As DcnmDeviceType,
    name As String,
    version As String,
    serialNumber As String,
    capabilities As IList(Of DcnmEquipmentCapabilities),
    attributes As IList(Of String),
    deviceState As DcnmDeviceOperationalState,
    selected As Boolean
)
public:
DcnmDeviceInfo(
    Guid id,
    DcnmDeviceType type,
    String^ name,
    String^ version,
    String^ serialNumber,
    IList<DcnmEquipmentCapabilities>^ capabilities,
    IList<String^>^ attributes,
    DcnmDeviceOperationalState deviceState,
    bool selected
)

Parameters

id
Type: SystemGuid
The identifier of the device.
type
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceType
The type of the device
name
Type: SystemString
The name of the device
version
Type: SystemString
The version of the device
serialNumber
Type: SystemString
The serial number of the device
capabilities
Type: System.Collections.GenericIList DcnmEquipmentCapabilities
The capabilities.
attributes
Type: System.Collections.GenericIList String
The attributes of the device, refer to DeviceAttributes.
deviceState
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceOperationalState
The operational state of the device.
selected
Type: SystemBoolean
if set to true selected.
See Also

Reference

DcnmDeviceInfo Class
DcnmDeviceInfo Overload


DcnmDeviceInfo Constructor (Guid, DcnmDeviceType, String, String, String, IList(DcnmEquipmentCapabilities), IList(String), DcnmDeviceOperationalState, Boolean, Int32)

DcnmDeviceInfo Constructor (Guid, DcnmDeviceType, String, String, String, IListDcnmEquipmentCapabilities, IListString, DcnmDeviceOperationalState, Boolean, Int32)

 Bosch Logo
Constructor.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDeviceInfo(
    Guid id,
    DcnmDeviceType type,
    string name,
    string version,
    string serialNumber,
    IList<DcnmEquipmentCapabilities> capabilities,
    IList<string> attributes,
    DcnmDeviceOperationalState deviceState,
    bool selected,
    int subDeviceInstance
)
Public Sub New (
    id As Guid,
    type As DcnmDeviceType,
    name As String,
    version As String,
    serialNumber As String,
    capabilities As IList(Of DcnmEquipmentCapabilities),
    attributes As IList(Of String),
    deviceState As DcnmDeviceOperationalState,
    selected As Boolean,
    subDeviceInstance As Integer
)
public:
DcnmDeviceInfo(
    Guid id,
    DcnmDeviceType type,
    String^ name,
    String^ version,
    String^ serialNumber,
    IList<DcnmEquipmentCapabilities>^ capabilities,
    IList<String^>^ attributes,
    DcnmDeviceOperationalState deviceState,
    bool selected,
    int subDeviceInstance
)

Parameters

id
Type: SystemGuid
The identifier of the device.
type
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceType
The type of the device
name
Type: SystemString
The name of the device
version
Type: SystemString
The version of the device
serialNumber
Type: SystemString
The serial number of the device
capabilities
Type: System.Collections.GenericIList DcnmEquipmentCapabilities
The capabilities.
attributes
Type: System.Collections.GenericIList String
The attributes of the device, refer to DeviceAttributes.
deviceState
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDeviceOperationalState
The operational state of the device.
selected
Type: SystemBoolean
if set to true selected.
subDeviceInstance
Type: SystemInt32
the device instance number where zero represents the primary device.
See Also

Reference

DcnmDeviceInfo Class
DcnmDeviceInfo Overload


DcnmDeviceInfo Properties

The DcnmDeviceInfo type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | The attributes of the device. Refer to DeviceAttributes for explanation on device attributes.
Public property | Capabilities | The capabilities of the device.
Public property | DeviceState | The operational state of the state.
Public property | Id | Identifies the device, it will not change during the lifetime of the device.
Public property | IsSelected | Gets a value indicating whether this DcnmDeviceInfo is selected.
Public property | Name | The name of the device.
Public property | SerialNumber | The serial number of this device.
Public property | SubDeviceInstance | Gets the device instance of this device.
Public property | TypeOf | The type of this device.
Public property | Version | The version of this device.
Top
See Also

Reference

DcnmDeviceInfo Class


DcnmDeviceInfo.Attributes Property

DcnmDeviceInfoAttributes Property

The attributes of the device. Refer to DeviceAttributes for explanation on device attributes.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<string> Attributes { get; }
Public ReadOnly Property Attributes As IList(Of String)
    Get
public:
property IList<String^>^ Attributes {
    IList<String^>^ get ();
}

Property Value

Type: IList String
See Also

Reference

DcnmDeviceInfo Class


DcnmDeviceInfo.Capabilities Property

DcnmDeviceInfoCapabilities Property

The capabilities of the device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<DcnmEquipmentCapabilities> Capabilities { get; }
Public ReadOnly Property Capabilities As IList(Of DcnmEquipmentCapabilities)
    Get
public:
property IList<DcnmEquipmentCapabilities>^ Capabilities {
    IList<DcnmEquipmentCapabilities>^ get ();
}

Property Value

Type: IList DcnmEquipmentCapabilities
See Also

Reference

DcnmDeviceInfo Class


DcnmDeviceInfo.DeviceState Property

DcnmDeviceInfoDeviceState Property

The operational state of the state.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDeviceOperationalState DeviceState { get; }
Public ReadOnly Property DeviceState As DcnmDeviceOperationalState
    Get
public:
property DcnmDeviceOperationalState DeviceState {
    DcnmDeviceOperationalState get ();
}

Property Value

Type: DcnmDeviceOperationalState
See Also

Reference

DcnmDeviceInfo Class


DcnmDeviceInfo.Id Property

DcnmDeviceInfoId Property

Identifies the device, it will not change during the lifetime of the device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid Id { get; }
Public ReadOnly Property Id As Guid
    Get
public:
property Guid Id {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmDeviceInfo Class


DcnmDeviceInfo.IsSelected Property

DcnmDeviceInfoIsSelected Property

Gets a value indicating whether this DcnmDeviceInfo is selected.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsSelected { get; }
Public ReadOnly Property IsSelected As Boolean
    Get
public:
property bool IsSelected {
    bool get ();
}

Property Value

Type: Boolean
true if selected; otherwise, false.
See Also

Reference

DcnmDeviceInfo Class


DcnmDeviceInfo.Name Property

DcnmDeviceInfoName Property

The name of the device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmDeviceInfo Class


DcnmDeviceInfo.SerialNumber Property

DcnmDeviceInfoSerialNumber Property

The serial number of this device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string SerialNumber { get; }
Public ReadOnly Property SerialNumber As String
    Get
public:
property String^ SerialNumber {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmDeviceInfo Class


DcnmDeviceInfo.SubDeviceInstance Property

DcnmDeviceInfoSubDeviceInstance Property

Gets the device instance of this device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int SubDeviceInstance { get; }
Public ReadOnly Property SubDeviceInstance As Integer
    Get
public:
property int SubDeviceInstance {
    int get ();
}

Property Value

Type: Int32
Remarks

Special device types can provide an interface for multiple participants. These devices are then divided into multiple (internal) devices each having a unique instance number.

When the value of the instance equals zero, the device represents the primary device. Number above zero represents the sub-devices.

See Also

Reference

DcnmDeviceInfo Class


DcnmDeviceInfo.TypeOf Property

DcnmDeviceInfoTypeOf Property

The type of this device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDeviceType TypeOf { get; }
Public ReadOnly Property TypeOf As DcnmDeviceType
    Get
public:
property DcnmDeviceType TypeOf {
    DcnmDeviceType get ();
}

Property Value

Type: DcnmDeviceType
See Also

Reference

DcnmDeviceInfo Class


DcnmDeviceInfo.Version Property

DcnmDeviceInfoVersion Property

The version of this device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Version { get; }
Public ReadOnly Property Version As String
    Get
public:
property String^ Version {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmDeviceInfo Class


DcnmDeviceInfo Methods

The DcnmDeviceInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmDeviceInfo Class


DcnmDeviceOperationalState Enumeration

The different operational states a device can have.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmDeviceOperationalState
Public Enumeration DcnmDeviceOperationalState
public enum class DcnmDeviceOperationalState
Members
Member name | Value | Description
VersionMismatch | -1 | The device does not have the version expected.
Error | 0 | The device is connected, but there has been an error.
Operational | 1 | The device is connected
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDeviceType Enumeration

The different device types supported by the Dcnm system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmDeviceType
Public Enumeration DcnmDeviceType
public enum class DcnmDeviceType
Members
Member name | Value | Description
Unknown | 0 | Used to indicate that the device type is unknown.
StandardConferenceDevice | 1 | Used to indicate that the device is a standard conference device.
InterpretationDevice | 2 | Used to indicate that the device is one which is used for interpretation.
OnvifCamera | 3 | Used to indicate that the device is an Onvif camera.
AudioPoweringSwitch | 4 | Used to indicate that the device is an audio processing device.
MeetingApplication | 5 | Used to indicate that the device is a through the SW-API connected application device
PTZOnvifCamera | 6 | PTZ onvif camera
VideoSwitch | 7 | Video Switch
ExternalVideoSwitch | 8 | External Video Switch
PresentationDevice | 9 | Presentation device
PoweringSwitch | 10 | Powering switch
MultimediaDevice | 11 | Multimedia device
MultimediaDeviceSimulator | 12 | The simulation of the mmd part.
VideoStream | 13 | Video stream device
OMI | 14 | OMI device
DiscussionDeviceBasic | 15 | Discussion device basic
DiscussionDevice | 15 | Discussion device
DiscussionDeviceVoting | 16 | Discussion device voting
DiscussionDeviceLanguageSelection | 17 | Discussion device language selection
DiscussionDeviceExtended | 18 | Discussion device extended
SonyCameraDevice | 19 | Sony camera
PanasonicCameraDevice | 20 | Panasonic camera
InterpretationDeviceWithVideo | 21 | Interpreter desk with video support
FlushDeviceSelectLanguage | 22 | Flush mounted language selection device
DanteGateway | 23 | The dante gateway
FlushBaseDevice | 24 | The flush base device
IntTxoDevice | 25 | The Integrus Transmitter
FlushBaseDeviceV2 | 26 | The flush base device V2
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDiscussionInfo Class

The discussion info supported by the Dcnm system.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDiscussionInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmDiscussionInfo
Public Class DcnmDiscussionInfo
public ref class DcnmDiscussionInfo

The DcnmDiscussionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmDiscussionInfo | Comstructor...
Top
Properties
 | Name | Description
Public property | IsDefault | Indicates whether this is the default (true) discussion or not (false).
Public property | State | The state of discussion.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDiscussionInfo Constructor

Comstructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDiscussionInfo(
    DcnmDiscussionState state,
    bool isDefault
)
Public Sub New (
    state As DcnmDiscussionState,
    isDefault As Boolean
)
public:
DcnmDiscussionInfo(
    DcnmDiscussionState state,
    bool isDefault
)

Parameters

state
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDiscussionState
The state of discussion.
isDefault
Type: SystemBoolean
Indicates whether this is a default (true) discussion or not (false).
See Also

Reference

DcnmDiscussionInfo Class


DcnmDiscussionInfo Properties

The DcnmDiscussionInfo type exposes the following members.

Properties
 | Name | Description
Public property | IsDefault | Indicates whether this is the default (true) discussion or not (false).
Public property | State | The state of discussion.
Top
See Also

Reference

DcnmDiscussionInfo Class


DcnmDiscussionInfo.IsDefault Property

DcnmDiscussionInfoIsDefault Property

Indicates whether this is the default (true) discussion or not (false).

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsDefault { get; }
Public ReadOnly Property IsDefault As Boolean
    Get
public:
property bool IsDefault {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmDiscussionInfo Class


DcnmDiscussionInfo.State Property

DcnmDiscussionInfoState Property

The state of discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDiscussionState State { get; }
Public ReadOnly Property State As DcnmDiscussionState
    Get
public:
property DcnmDiscussionState State {
    DcnmDiscussionState get ();
}

Property Value

Type: DcnmDiscussionState
See Also

Reference

DcnmDiscussionInfo Class


DcnmDiscussionInfo Methods

The DcnmDiscussionInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmDiscussionInfo Class


DcnmDiscussionMode Enumeration

The different device types supported by the Dcnm system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmDiscussionMode
Public Enumeration DcnmDiscussionMode
public enum class DcnmDiscussionMode
Members
Member name | Value | Description
Override | 0 | Discussion control override mode.
Open | 1 | Discussion control open mode.
Response | 2 | Discussion control response mode
Voice | 3 | Discussion control voice mode
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDiscussionOptions Class

The different discussion options supported by the Dcnm system.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDiscussionOptions

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmDiscussionOptions
Public Class DcnmDiscussionOptions
public ref class DcnmDiscussionOptions

The DcnmDiscussionOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmDiscussionOptions | Default constructor
Public method | DcnmDiscussionOptions(DcnmDiscussionMode, Boolean) | Obsolete. Constructor.
Public method | DcnmDiscussionOptions(DcnmDiscussionMode, Boolean, DcnmVoiceModeOptions) | Constructor.
Top
Properties
 | Name | Description
Public property | AllowAutoShift | Indicates whether auto shift is allowed in this mode of discussion or not.
Public property | Mode | The mode of discussion.
Public property | VoiceModeOptions | The speaker options in voice mode
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DEFAULT_AUTO_SHIFT | The default value for auto shift.
DEFAULT_DISCUSSION_MODE | The default conference mode "Open"
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDiscussionOptions Constructor

Overload List
 | Name | Description
Public method | DcnmDiscussionOptions | Default constructor
Public method | DcnmDiscussionOptions(DcnmDiscussionMode, Boolean) | Obsolete. Constructor.
Public method | DcnmDiscussionOptions(DcnmDiscussionMode, Boolean, DcnmVoiceModeOptions) | Constructor.
Top
See Also

Reference

DcnmDiscussionOptions Class


DcnmDiscussionOptions Constructor

Default constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDiscussionOptions()
Public Sub New
public:
DcnmDiscussionOptions()
See Also

Reference

DcnmDiscussionOptions Class
DcnmDiscussionOptions Overload


DcnmDiscussionOptions Constructor (DcnmDiscussionMode, Boolean)

Note: This API is now obsolete.

Constructor.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This constructor is deprecated.")]
public DcnmDiscussionOptions(
    DcnmDiscussionMode mode,
    bool allowAutoShift
)
<ObsoleteAttribute("This constructor is deprecated.")>
Public Sub New (
    mode As DcnmDiscussionMode,
    allowAutoShift As Boolean
)
public:
[ObsoleteAttribute(L"This constructor is deprecated.")]
DcnmDiscussionOptions(
    DcnmDiscussionMode mode,
    bool allowAutoShift
)

Parameters

mode
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDiscussionMode
The mode of discussion.
allowAutoShift
Type: SystemBoolean
Indicates whether auto shift is allowed in this mode of discussion or not.
See Also

Reference

DcnmDiscussionOptions Class
DcnmDiscussionOptions Overload


DcnmDiscussionOptions Constructor (DcnmDiscussionMode, Boolean, DcnmVoiceModeOptions)

Constructor.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDiscussionOptions(
    DcnmDiscussionMode mode,
    bool allowAutoShift,
    DcnmVoiceModeOptions voiceModeOptions
)
Public Sub New (
    mode As DcnmDiscussionMode,
    allowAutoShift As Boolean,
    voiceModeOptions As DcnmVoiceModeOptions
)
public:
DcnmDiscussionOptions(
    DcnmDiscussionMode mode,
    bool allowAutoShift,
    DcnmVoiceModeOptions^ voiceModeOptions
)

Parameters

mode
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDiscussionMode
The mode of discussion.
allowAutoShift
Type: SystemBoolean
Indicates whether auto shift is allowed in this mode of discussion or not.
voiceModeOptions
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVoiceModeOptions
The speaker options in voice mode.
See Also

Reference

DcnmDiscussionOptions Class
DcnmDiscussionOptions Overload


DcnmDiscussionOptions Properties

The DcnmDiscussionOptions type exposes the following members.

Properties
 | Name | Description
Public property | AllowAutoShift | Indicates whether auto shift is allowed in this mode of discussion or not.
Public property | Mode | The mode of discussion.
Public property | VoiceModeOptions | The speaker options in voice mode
Top
See Also

Reference

DcnmDiscussionOptions Class


DcnmDiscussionOptions.AllowAutoShift Property

DcnmDiscussionOptionsAllowAutoShift Property

Indicates whether auto shift is allowed in this mode of discussion or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AllowAutoShift { get; }
Public ReadOnly Property AllowAutoShift As Boolean
    Get
public:
property bool AllowAutoShift {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmDiscussionOptions Class


DcnmDiscussionOptions.Mode Property

DcnmDiscussionOptionsMode Property

The mode of discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDiscussionMode Mode { get; }
Public ReadOnly Property Mode As DcnmDiscussionMode
    Get
public:
property DcnmDiscussionMode Mode {
    DcnmDiscussionMode get ();
}

Property Value

Type: DcnmDiscussionMode
See Also

Reference

DcnmDiscussionOptions Class


DcnmDiscussionOptions.VoiceModeOptions Property

DcnmDiscussionOptionsVoiceModeOptions Property

The speaker options in voice mode

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVoiceModeOptions VoiceModeOptions { get; }
Public ReadOnly Property VoiceModeOptions As DcnmVoiceModeOptions
    Get
public:
property DcnmVoiceModeOptions^ VoiceModeOptions {
    DcnmVoiceModeOptions^ get ();
}

Property Value

Type: DcnmVoiceModeOptions
See Also

Reference

DcnmDiscussionOptions Class


DcnmDiscussionOptions Methods

The DcnmDiscussionOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmDiscussionOptions Class


DcnmDiscussionOptions Fields

The DcnmDiscussionOptions type exposes the following members.

Fields
Name | Description
DEFAULT_AUTO_SHIFT | The default value for auto shift.
DEFAULT_DISCUSSION_MODE | The default conference mode "Open"
Top
See Also

Reference

DcnmDiscussionOptions Class


DcnmDiscussionOptions.DEFAULT_AUTO_SHIFT Field

DcnmDiscussionOptionsDEFAULT_AUTO_SHIFT Field

The default value for auto shift.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DEFAULT_AUTO_SHIFT = true
Public Const DEFAULT_AUTO_SHIFT As Boolean = True
public:
literal bool DEFAULT_AUTO_SHIFT = true

Field Value

Type: Boolean
See Also

Reference

DcnmDiscussionOptions Class


DcnmDiscussionOptions.DEFAULT_DISCUSSION_MODE Field

DcnmDiscussionOptionsDEFAULT_DISCUSSION_MODE Field

The default conference mode "Open"

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const DcnmDiscussionMode DEFAULT_DISCUSSION_MODE = DcnmDiscussionMode.Open
Public Const DEFAULT_DISCUSSION_MODE As DcnmDiscussionMode = DcnmDiscussionMode.Open
public:
literal DcnmDiscussionMode DEFAULT_DISCUSSION_MODE = DcnmDiscussionMode.Open

Field Value

Type: DcnmDiscussionMode
See Also

Reference

DcnmDiscussionOptions Class


DcnmDiscussionPreparationInfo Class

Message container for the discussion preparation info.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmTemplatePreparationInfo
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDiscussionPreparationInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmDiscussionPreparationInfo : DcnmTemplatePreparationInfo
Public Class DcnmDiscussionPreparationInfo
    Inherits DcnmTemplatePreparationInfo
public ref class DcnmDiscussionPreparationInfo : public DcnmTemplatePreparationInfo

The DcnmDiscussionPreparationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmDiscussionPreparationInfo | Initializes a new instance of the DcnmDiscussionPreparationInfo class.
Top
Properties
 | Name | Description
Public property | AdditionalInformation | Additional info related to the discussion
Public property | DiscussionId | The discussion id
Public property | DiscussionOptions | the discussion control mode (Inherited from DcnmTemplatePreparationInfo.)
Public property | IsDefaultMeeting | True if the current meeting is the Default Meeting
Public property | MicrophoneOptions | The microphone options. (Inherited from DcnmTemplatePreparationInfo.)
Public property | Name | The name of the discussion template. (Inherited from DcnmTemplatePreparationInfo.)
Public property | PriorityOptions | The priority options. (Inherited from DcnmTemplatePreparationInfo.)
Public property | RequestOptions | The request options. (Inherited from DcnmTemplatePreparationInfo.)
Public property | ResponseOptions | The response options. (Inherited from DcnmTemplatePreparationInfo.)
Public property | SpeakerViewingOptions | The speaker viewing options (Inherited from DcnmTemplatePreparationInfo.)
Public property | SpeechTimerOptions | The speech timer options (Inherited from DcnmTemplatePreparationInfo.)
Public property | Subject | The subject of the discussion
Public property | TemplateId | The template identifier (Inherited from DcnmTemplatePreparationInfo.)
Public property | Title | The title of the discussion
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDiscussionPreparationInfo Constructor

Initializes a new instance of the DcnmDiscussionPreparationInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDiscussionPreparationInfo(
    Guid discussionId,
    string title,
    string subject,
    string additionalInformation,
    bool isDefaultMeeting,
    DcnmTemplatePreparationInfo templateInfo
)
Public Sub New (
    discussionId As Guid,
    title As String,
    subject As String,
    additionalInformation As String,
    isDefaultMeeting As Boolean,
    templateInfo As DcnmTemplatePreparationInfo
)
public:
DcnmDiscussionPreparationInfo(
    Guid discussionId,
    String^ title,
    String^ subject,
    String^ additionalInformation,
    bool isDefaultMeeting,
    DcnmTemplatePreparationInfo^ templateInfo
)

Parameters

discussionId
Type: SystemGuid
The discussion id.
title
Type: SystemString
The title.
subject
Type: SystemString
The subject.
additionalInformation
Type: SystemString
The additional information.
isDefaultMeeting
Type: SystemBoolean
if set to true [is default meeting].
templateInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmTemplatePreparationInfo
The template info.
See Also

Reference

DcnmDiscussionPreparationInfo Class


DcnmDiscussionPreparationInfo Properties

The DcnmDiscussionPreparationInfo type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInformation | Additional info related to the discussion
Public property | DiscussionId | The discussion id
Public property | DiscussionOptions | the discussion control mode (Inherited from DcnmTemplatePreparationInfo.)
Public property | IsDefaultMeeting | True if the current meeting is the Default Meeting
Public property | MicrophoneOptions | The microphone options. (Inherited from DcnmTemplatePreparationInfo.)
Public property | Name | The name of the discussion template. (Inherited from DcnmTemplatePreparationInfo.)
Public property | PriorityOptions | The priority options. (Inherited from DcnmTemplatePreparationInfo.)
Public property | RequestOptions | The request options. (Inherited from DcnmTemplatePreparationInfo.)
Public property | ResponseOptions | The response options. (Inherited from DcnmTemplatePreparationInfo.)
Public property | SpeakerViewingOptions | The speaker viewing options (Inherited from DcnmTemplatePreparationInfo.)
Public property | SpeechTimerOptions | The speech timer options (Inherited from DcnmTemplatePreparationInfo.)
Public property | Subject | The subject of the discussion
Public property | TemplateId | The template identifier (Inherited from DcnmTemplatePreparationInfo.)
Public property | Title | The title of the discussion
Top
See Also

Reference

DcnmDiscussionPreparationInfo Class


DcnmDiscussionPreparationInfo.AdditionalInformation Property

DcnmDiscussionPreparationInfoAdditionalInformation Property

Additional info related to the discussion

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string AdditionalInformation { get; }
Public ReadOnly Property AdditionalInformation As String
    Get
public:
property String^ AdditionalInformation {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmDiscussionPreparationInfo Class


DcnmDiscussionPreparationInfo.DiscussionId Property

DcnmDiscussionPreparationInfoDiscussionId Property

The discussion id

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid DiscussionId { get; }
Public ReadOnly Property DiscussionId As Guid
    Get
public:
property Guid DiscussionId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmDiscussionPreparationInfo Class


DcnmDiscussionPreparationInfo.IsDefaultMeeting Property

DcnmDiscussionPreparationInfoIsDefaultMeeting Property

True if the current meeting is the Default Meeting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsDefaultMeeting { get; }
Public ReadOnly Property IsDefaultMeeting As Boolean
    Get
public:
property bool IsDefaultMeeting {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmDiscussionPreparationInfo Class


DcnmDiscussionPreparationInfo.Subject Property

DcnmDiscussionPreparationInfoSubject Property

The subject of the discussion

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Subject { get; }
Public ReadOnly Property Subject As String
    Get
public:
property String^ Subject {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmDiscussionPreparationInfo Class


DcnmDiscussionPreparationInfo.Title Property

DcnmDiscussionPreparationInfoTitle Property

The title of the discussion

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmDiscussionPreparationInfo Class


DcnmDiscussionPreparationInfo Methods

The DcnmDiscussionPreparationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmDiscussionPreparationInfo Class


DcnmDiscussionState Enumeration

The different discussion states supported by the Dcnm system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmDiscussionState
Public Enumeration DcnmDiscussionState
public enum class DcnmDiscussionState
Members
Member name | Value | Description
Closed | 0 | Discussion control override mode.
Opened | 1 | Discussion control open mode.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDiscussionType Enumeration

This hold discussion type participant

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmDiscussionType
Public Enumeration DcnmDiscussionType
public enum class DcnmDiscussionType
Members
Member name | Value | Description
Speaker | 0 | Discussion speaker type
Requester | 1 | Discussion requester type
Responder | 2 | Discussion responder type
ResponseRequester | 3 | Discussion response requester type
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDisplayInterpretationLanguageOptions Enumeration

Represents the options for displaying interpretation language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmDisplayInterpretationLanguageOptions
Public Enumeration DcnmDisplayInterpretationLanguageOptions
public enum class DcnmDisplayInterpretationLanguageOptions
Members
Member name | Value | Description
Original | 0 | Represents display interpretation language by language original
NumberAndAbbreviation | 1 | Representso display interpretation language by language number and abbreviation
NumberAndOriginal | 2 | Represents display interpretation language by language number and original
Abbreviation | 3 | Represents display interpretation language by language abbreviation
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDisplayVotingResultType Enumeration

Defines the available options to see voting results.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmDisplayVotingResultType
Public Enumeration DcnmDisplayVotingResultType
public enum class DcnmDisplayVotingResultType
Members
Member name | Value | Description
Always | 0 |
OnHoldOrClosed | 1 |
OnAcceptedOrRejected | 2 |
Never | 3 |
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDocumentVerificationResponse Class

Class holds details of verification of document.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDocumentVerificationResponse

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmDocumentVerificationResponse
Public Class DcnmDocumentVerificationResponse
public ref class DcnmDocumentVerificationResponse

The DcnmDocumentVerificationResponse type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmDocumentVerificationResponse(Boolean, Boolean, Boolean) | Obsolete. Initializes new instance of with given values
Public method | DcnmDocumentVerificationResponse(Boolean, Boolean, Boolean, Boolean) | Initializes new instance of with given values
Top
Properties
 | Name | Description
Public property | HasHashTag | Indicates file has hash tag.
Public property | IsAuthenticatedUsingCertificate | Indicates whether file is authenticated with certificate or not.
Public property | IsDocumentSigned | Indicates if file contains digital signature. Files with size exceeding 50 MB are not signed, hence this property returns 'false' for such files.
Public property | IsTampered | Indicates file is tampered or not.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmDocumentVerificationResponse Constructor

Overload List
 | Name | Description
Public method | DcnmDocumentVerificationResponse(Boolean, Boolean, Boolean) | Obsolete. Initializes new instance of with given values
Public method | DcnmDocumentVerificationResponse(Boolean, Boolean, Boolean, Boolean) | Initializes new instance of with given values
Top
See Also

Reference

DcnmDocumentVerificationResponse Class


DcnmDocumentVerificationResponse Constructor (Boolean, Boolean, Boolean)

Note: This API is now obsolete.

Initializes new instance of with given values

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the non obsolete constructor")]
public DcnmDocumentVerificationResponse(
    bool hasHashTag,
    bool isTampered,
    bool isAuthenticatedUsingCertificate
)
<ObsoleteAttribute("This method is obsolete, please use the non obsolete constructor")>
Public Sub New (
    hasHashTag As Boolean,
    isTampered As Boolean,
    isAuthenticatedUsingCertificate As Boolean
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the non obsolete constructor")]
DcnmDocumentVerificationResponse(
    bool hasHashTag,
    bool isTampered,
    bool isAuthenticatedUsingCertificate
)

Parameters

hasHashTag
Type: SystemBoolean
Is file has hash tag
isTampered
Type: SystemBoolean
Is file tampered
isAuthenticatedUsingCertificate
Type: SystemBoolean
Is file is validated with root certificate.
See Also

Reference

DcnmDocumentVerificationResponse Class
DcnmDocumentVerificationResponse Overload
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDocumentVerificationResponse


DcnmDocumentVerificationResponse Constructor (Boolean, Boolean, Boolean, Boolean)

Initializes new instance of with given values

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDocumentVerificationResponse(
    bool hasHashTag,
    bool isTampered,
    bool isAuthenticatedUsingCertificate,
    bool isDocumentSigned
)
Public Sub New (
    hasHashTag As Boolean,
    isTampered As Boolean,
    isAuthenticatedUsingCertificate As Boolean,
    isDocumentSigned As Boolean
)
public:
DcnmDocumentVerificationResponse(
    bool hasHashTag,
    bool isTampered,
    bool isAuthenticatedUsingCertificate,
    bool isDocumentSigned
)

Parameters

hasHashTag
Type: SystemBoolean
Is file has hash tag
isTampered
Type: SystemBoolean
Is file tampered
isAuthenticatedUsingCertificate
Type: SystemBoolean
Is file is validated with root certificate.
isDocumentSigned
Type: SystemBoolean
Is file contains digital signature.
See Also

Reference

DcnmDocumentVerificationResponse Class
DcnmDocumentVerificationResponse Overload
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDocumentVerificationResponse


DcnmDocumentVerificationResponse Properties

The DcnmDocumentVerificationResponse type exposes the following members.

Properties
 | Name | Description
Public property | HasHashTag | Indicates file has hash tag.
Public property | IsAuthenticatedUsingCertificate | Indicates whether file is authenticated with certificate or not.
Public property | IsDocumentSigned | Indicates if file contains digital signature. Files with size exceeding 50 MB are not signed, hence this property returns 'false' for such files.
Public property | IsTampered | Indicates file is tampered or not.
Top
See Also

Reference

DcnmDocumentVerificationResponse Class


DcnmDocumentVerificationResponse.HasHashTag Property

DcnmDocumentVerificationResponseHasHashTag Property

Indicates file has hash tag.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool HasHashTag { get; }
Public ReadOnly Property HasHashTag As Boolean
    Get
public:
property bool HasHashTag {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmDocumentVerificationResponse Class


DcnmDocumentVerificationResponse.IsAuthenticatedUsingCertificate Property

DcnmDocumentVerificationResponseIsAuthenticatedUsingCertificate Property

Bosch Logo
Indicates whether file is authenticated with certificate or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsAuthenticatedUsingCertificate { get; }
Public ReadOnly Property IsAuthenticatedUsingCertificate As Boolean
    Get
public:
property bool IsAuthenticatedUsingCertificate {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmDocumentVerificationResponse Class


DcnmDocumentVerificationResponse.IsDocumentSigned Property

DcnmDocumentVerificationResponseIsDocumentSigned Property

Indicates if file contains digital signature. Files with size exceeding 50 MB are not signed, hence this property returns 'false' for such files.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsDocumentSigned { get; }
Public ReadOnly Property IsDocumentSigned As Boolean
    Get
public:
property bool IsDocumentSigned {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmDocumentVerificationResponse Class


DcnmDocumentVerificationResponse.IsTampered Property

DcnmDocumentVerificationResponseIsTampered Property

Indicates file is tampered or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsTampered { get; }
Public ReadOnly Property IsTampered As Boolean
    Get
public:
property bool IsTampered {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmDocumentVerificationResponse Class


DcnmDocumentVerificationResponse Methods

The DcnmDocumentVerificationResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmDocumentVerificationResponse Class


DcnmEquipmentCapabilities Enumeration

The capabilities equipment in the system can have.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmEquipmentCapabilities
Public Enumeration DcnmEquipmentCapabilities
public enum class DcnmEquipmentCapabilities
Members
Member name | Value | Description
HasNone | 0 | No capabilities set, this is the default value.
HasPowerOn | 1 | Has the capability to power on.
HasPowerOff | 2 | Has the capability to power off.
HasVolumeControl | 3 | Has the capability to control the volume.
HasDualUse | 4 | Has the capability to act as a dual-use device.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmFlushDevicePanelInfo Class

Class representing the flush device panel information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmFlushDevicePanelInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmFlushDevicePanelInfo
Public Class DcnmFlushDevicePanelInfo
public ref class DcnmFlushDevicePanelInfo

The DcnmFlushDevicePanelInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmFlushDevicePanelInfo | Initializes a new instance of the DcnmFlushDevicePanelInfo class
Top
Properties
 | Name | Description
Public property | ConnectedPanels | Gets the IList of Connected Panel types in flush device panel.
Public property | DeviceId | Gets the device Id of flush device panel.
Public property | DeviceName | Gets the device Name of flush device panel.
Public property | SubDeviceInstance | Gets the number of subDevice instance of flush device panel.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmFlushDevicePanelInfo Constructor

Initializes a new instance of the DcnmFlushDevicePanelInfo class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmFlushDevicePanelInfo(
    Guid deviceId,
    string deviceName,
    int subDeviceInstance,
    IList<DcnmFlushPanelType> connectedPanels
)
Public Sub New (
    deviceId As Guid,
    deviceName As String,
    subDeviceInstance As Integer,
    connectedPanels As IList(Of DcnmFlushPanelType)
)
public:
DcnmFlushDevicePanelInfo(
    Guid deviceId,
    String^ deviceName,
    int subDeviceInstance,
    IList<DcnmFlushPanelType>^ connectedPanels
)

Parameters

deviceId
Type: SystemGuid
Flush device panel : Device Id.
deviceName
Type: SystemString
Flush device panel : Device Name.
subDeviceInstance
Type: SystemInt32
Flush device panel : Number of subDevice instance.
connectedPanels
Type: System.Collections.GenericIList DcnmFlushPanelType
Flush device panel : IList of connected panel types.
See Also

Reference

DcnmFlushDevicePanelInfo Class


DcnmFlushDevicePanelInfo Properties

The DcnmFlushDevicePanelInfo type exposes the following members.

Properties
 | Name | Description
Public property | ConnectedPanels | Gets the IList of Connected Panel types in flush device panel.
Public property | DeviceId | Gets the device Id of flush device panel.
Public property | DeviceName | Gets the device Name of flush device panel.
Public property | SubDeviceInstance | Gets the number of subDevice instance of flush device panel.
Top
See Also

Reference

DcnmFlushDevicePanelInfo Class


DcnmFlushDevicePanelInfo.ConnectedPanels Property

DcnmFlushDevicePanelInfoConnectedPanels Property

Gets the IList of Connected Panel types in flush device panel.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<DcnmFlushPanelType> ConnectedPanels { get; }
Public ReadOnly Property ConnectedPanels As IList(Of DcnmFlushPanelType)
    Get
public:
property IList<DcnmFlushPanelType>^ ConnectedPanels {
    IList<DcnmFlushPanelType>^ get ();
}

Property Value

Type: IList DcnmFlushPanelType
See Also

Reference

DcnmFlushDevicePanelInfo Class


DcnmFlushDevicePanelInfo.DeviceId Property

DcnmFlushDevicePanelInfoDeviceId Property

Gets the device Id of flush device panel.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid DeviceId { get; }
Public ReadOnly Property DeviceId As Guid
    Get
public:
property Guid DeviceId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmFlushDevicePanelInfo Class


DcnmFlushDevicePanelInfo.DeviceName Property

DcnmFlushDevicePanelInfoDeviceName Property

Gets the device Name of flush device panel.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string DeviceName { get; }
Public ReadOnly Property DeviceName As String
    Get
public:
property String^ DeviceName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmFlushDevicePanelInfo Class


DcnmFlushDevicePanelInfo.SubDeviceInstance Property

DcnmFlushDevicePanelInfoSubDeviceInstance Property

Gets the number of subDevice instance of flush device panel.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int SubDeviceInstance { get; }
Public ReadOnly Property SubDeviceInstance As Integer
    Get
public:
property int SubDeviceInstance {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmFlushDevicePanelInfo Class


DcnmFlushDevicePanelInfo Methods

The DcnmFlushDevicePanelInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmFlushDevicePanelInfo Class


DcnmFlushPanelType Enumeration

The different flushpanel types supported by the Dcnm system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmFlushPanelType
Public Enumeration DcnmFlushPanelType
public enum class DcnmFlushPanelType
Members
Member name | Value | Description
Unknown | 0 | Used to indicate that the flushpanel is unknown.
FlushMicButtonPanel | 1 | Flushpanel with microphone-button DCNM_FMICB.
FlushMicButtonPanelWithMic | 2 | Flushpanel with microphone-button DCNM_FMICB and connected microphone.
FlushPrioButtonPanel | 3 | Flushpanel with prio-button DCNM_FPRIOB.
FlushPrioPanelButtonWithMic | 4 | Flushpanel with prio-button DCNM_FPRIOB and connected microphone.
FlushIdentificationPanel | 5 | Flushpanel identification through NFC DCNM_FIDP.
FlushVotingPanel | 6 | Flushpanel voting DCNM_FVP.
FlushAudioInterfacePanel | 7 | Flushpanel audio interface DCNM_FAI.
FlushAudioInterfacePanelWithMic | 8 | Flushpanel audio interface DCNM_FAI and connected microphone.
FlushLanguageSelectPanel | 9 | Flushpanel language selection DCNM_FSLP.
FlushAudioInterfacePanelWith3rdPartyMic | 10 | Flushpanel audio interface DCNM_FAI with 3rd party microphone connected.
FlushAudioInterfacePanelWithFmcpOnOutput1 | 11 | Flushpanel audio interface DCNM_FAI with FMCP conneted to output 1.
FlushAudioInterfacePanelWithFmcpOnOutput2 | 12 | Flushpanel audio interface DCNM_FAI with FMCP conneted to output 2.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmGainSetting Class

Note: This API is now obsolete.

The gain setting supported by the Dcnm system.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmGainSetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The DcnmGainSetting API class is deprecated; please use DcnmAudioGainSetting instead.")]
public class DcnmGainSetting
<ObsoleteAttribute("The DcnmGainSetting API class is deprecated; please use DcnmAudioGainSetting instead.")>
Public Class DcnmGainSetting
[ObsoleteAttribute(L"The DcnmGainSetting API class is deprecated; please use DcnmAudioGainSetting instead.")]
public ref class DcnmGainSetting

The DcnmGainSetting type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmGainSetting | Obsolete. Comstructor...
Top
Properties
 | Name | Description
Public property | GainSettingType | The type of the gainsetting.
Public property | GainSettingValue | The value of the gainsetting.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmGainSetting Constructor

Note: This API is now obsolete.

Comstructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The DcnmGainSetting API class is deprecated; please use DcnmAudioGainSetting instead.")]
public DcnmGainSetting(
    DcnmGainSettingType type,
    int value
)
<ObsoleteAttribute("The DcnmGainSetting API class is deprecated; please use DcnmAudioGainSetting instead.")>
Public Sub New (
    type As DcnmGainSettingType,
    value As Integer
)
public:
[ObsoleteAttribute(L"The DcnmGainSetting API class is deprecated; please use DcnmAudioGainSetting instead.")]
DcnmGainSetting(
    DcnmGainSettingType type,
    int value
)

Parameters

type
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmGainSettingType
The gain type.
value
Type: SystemInt32
The gain value.
See Also

Reference

DcnmGainSetting Class


DcnmGainSetting Properties

The DcnmGainSetting type exposes the following members.

Properties
 | Name | Description
Public property | GainSettingType | The type of the gainsetting.
Public property | GainSettingValue | The value of the gainsetting.
Top
See Also

Reference

DcnmGainSetting Class


DcnmGainSetting.GainSettingType Property

DcnmGainSettingGainSettingType Property

The type of the gainsetting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmGainSettingType GainSettingType { get; }
Public ReadOnly Property GainSettingType As DcnmGainSettingType
    Get
public:
property DcnmGainSettingType GainSettingType {
    DcnmGainSettingType get ();
}

Property Value

Type: DcnmGainSettingType
See Also

Reference

DcnmGainSetting Class


DcnmGainSetting.GainSettingValue Property

DcnmGainSettingGainSettingValue Property

The value of the gainsetting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int GainSettingValue { get; }
Public ReadOnly Property GainSettingValue As Integer
    Get
public:
property int GainSettingValue {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmGainSetting Class


DcnmGainSetting Methods

The DcnmGainSetting type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmGainSetting Class


DcnmGainSettingType Enumeration

Note: This API is now obsolete.

The different device types supported by the Dcnm system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The DcnmGainSettingType API enumeration is deprecated; please use DcnmAudioGainSettingType instead.")]
public enum DcnmGainSettingType
<ObsoleteAttribute("The DcnmGainSettingType API enumeration is deprecated; please use DcnmAudioGainSettingType instead.")>
Public Enumeration DcnmGainSettingType
[ObsoleteAttribute(L"The DcnmGainSettingType API enumeration is deprecated; please use DcnmAudioGainSettingType instead.")]
public enum class DcnmGainSettingType
Members
Member name | Value | Description
Master | 0 | Master Volume
LoudspeakerFactor | 1 | LoudSpeaker
SoundReinforcementFactor | 2 | Sound reinforcement
AnalogIn0 | 3 | Analog In 0
AnalogOut0 | 4 | Analog Out 0
AnalogIn1 | 5 | Analog In 1
AnalogOut1 | 6 | Analog Out 1
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmHeadphoneTypes Enumeration

Headphones supported in meeting desk

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmHeadphoneTypes
Public Enumeration DcnmHeadphoneTypes
public enum class DcnmHeadphoneTypes
Members
Member name | Value | Description
NoProtection | 0 |
Bosch_LBB3443 | 1 |
Bosch_HDP_LWN | 2 |
Bosch_HDP_HQ | 3 |
Sennheiser_PX100_II | 4 |
Sennheiser_PX200_II | 5 |
Koss_Porta_Pro_Classic | 6 |
Bang_Olufsen_Form_2i | 7 |
Bang_Olufsen_Play_3i | 8 |
Harman_Kardon_Soho | 9 |
Apple_MB770 | 10 |
Apple_MD827ZM_B | 11 |
Sennheiser_HME_46_DCN | 12 |
Bosch_HDP_IHDS | 13 |
Bosch_HDP_IHDS_no_pads | 14 |
Bosch_HDP_IHDP | 15 |
Bosch_HDP_IHDP_no_pads | 16 |
AKG_HSC15 | 17 |
Shure_IH6500 | 18 |
Sennheiser_HD300 | 19 |
Sennheiser_HD2_10 | 20 |
Bang_Olufsen_A8 | 21 |
Creative_Aurvana_Air | 22 |
AKG_K15 | 23 |
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmIdentificationMethod Enumeration

The method how the person should identify himself.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmIdentificationMethod
Public Enumeration DcnmIdentificationMethod
public enum class DcnmIdentificationMethod
Members
Member name | Value | Description
Fixed | 0 | Participant is fixed on the seat; pre-set identification.
UserName | 1 | Identification by username.
SelectFromList | 2 | Identification by selecting from a list.
ExternalSystem | 4 | Identification by external system.
NFC | 5 | Identification by swiping NFC at device
NFCKeptAtDevice | 6 | Identification by keeping NFC at device, participant logs off if NFC is removed from the device
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmIdentificationSetting Enumeration

Defines the available Identification types within the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmIdentificationSetting
Public Enumeration DcnmIdentificationSetting
public enum class DcnmIdentificationSetting
Members
Member name | Value | Description
NoIdentification | 0 | No need for a participant to identify or authenticate.
IdentifyConfirm | 1 | Participants need to identify themselves at seat (confirmation).
IdentifyUserName | 2 | Participants need to identify themselves at seat (username).
IdentifySelectFromList | 3 | Participants need to identify themselves at seat (password).
AuthenticateUserNamePassword | 4 | Participants need to actually authenticate themselves at a seat (username / password).
AuthenticateSelectFromListPassword | 5 | Participants need to actually authenticate themselves at a seat (list select / password).
IdentifyExternalSystem | 6 | Participants need to identify themselves at seat (via external system).
IdentifyNFC | 7 | Participants need to identify themselves at seat (via NFC)
AuthenticateExternalSystem | 8 | Participants need to authenticate themselves at seat (via external system).
AuthenticateNFCPassword | 9 | Participants need to actually authenticate themselves at a seat (NFC / password).
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmIDeskButtonFunctionType Enumeration

Defines the IDesk button function type

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmIDeskButtonFunctionType
Public Enumeration DcnmIDeskButtonFunctionType
public enum class DcnmIDeskButtonFunctionType
Members
Member name | Value | Description
None | 0 | No button function
StopWatchSwitch | 1 | Switch between clock and speech time
VideoSwitch | 2 | Switch between video and presentation
LanguageOverview | 3 | Language overview
SpeakSlow | 4 | Signalling that the current speaker is speaking too fast
HeadphoneSelection | 5 | Headphone selection
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmImageServerInfo Class

Defines the container for Dcnm image server info.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmImageServerInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmImageServerInfo
Public Class DcnmImageServerInfo
public ref class DcnmImageServerInfo

The DcnmImageServerInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmImageServerInfo | Constructor
Top
Properties
 | Name | Description
Public property | ConnectionStatus | Connection status of image server.
Public property | CustomerLogoName | Customer logo name stored in image web server
Public property | CustomerLogoUpdatedNumber | Customer logo updated number
Public property | Password | The password to connect to the participant picture web server
Public property | ServerUri | The server uri of the participant picture web server
Public property | UserName | The user name to connect to the participant picture web server
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmImageServerInfo Constructor

Constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmImageServerInfo(
    Uri serverUri,
    string userName,
    string password,
    string customerLogoName,
    int customerLogoUpdatedNumber,
    bool connectionStatus
)
Public Sub New (
    serverUri As Uri,
    userName As String,
    password As String,
    customerLogoName As String,
    customerLogoUpdatedNumber As Integer,
    connectionStatus As Boolean
)
public:
DcnmImageServerInfo(
    Uri^ serverUri,
    String^ userName,
    String^ password,
    String^ customerLogoName,
    int customerLogoUpdatedNumber,
    bool connectionStatus
)

Parameters

serverUri
Type: SystemUri
Server Uri
userName
Type: SystemString
User name
password
Type: SystemString
Password
customerLogoName
Type: SystemString
Customer logo name
customerLogoUpdatedNumber
Type: SystemInt32
Customer logo updated number
connectionStatus
Type: SystemBoolean
Connection status of image server
See Also

Reference

DcnmImageServerInfo Class


DcnmImageServerInfo Properties

The DcnmImageServerInfo type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionStatus | Connection status of image server.
Public property | CustomerLogoName | Customer logo name stored in image web server
Public property | CustomerLogoUpdatedNumber | Customer logo updated number
Public property | Password | The password to connect to the participant picture web server
Public property | ServerUri | The server uri of the participant picture web server
Public property | UserName | The user name to connect to the participant picture web server
Top
See Also

Reference

DcnmImageServerInfo Class


DcnmImageServerInfo.ConnectionStatus Property

DcnmImageServerInfoConnectionStatus Property

Connection status of image server.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool ConnectionStatus { get; }
Public ReadOnly Property ConnectionStatus As Boolean
    Get
public:
property bool ConnectionStatus {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmImageServerInfo Class


DcnmImageServerInfo.CustomerLogoName Property

DcnmImageServerInfoCustomerLogoName Property

Customer logo name stored in image web server

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string CustomerLogoName { get; }
Public ReadOnly Property CustomerLogoName As String
    Get
public:
property String^ CustomerLogoName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmImageServerInfo Class


DcnmImageServerInfo.CustomerLogoUpdatedNumber Property

DcnmImageServerInfoCustomerLogoUpdatedNumber Property

Customer logo updated number

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int CustomerLogoUpdatedNumber { get; }
Public ReadOnly Property CustomerLogoUpdatedNumber As Integer
    Get
public:
property int CustomerLogoUpdatedNumber {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmImageServerInfo Class


DcnmImageServerInfo.Password Property

DcnmImageServerInfoPassword Property

The password to connect to the participant picture web server

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Password { get; }
Public ReadOnly Property Password As String
    Get
public:
property String^ Password {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmImageServerInfo Class


DcnmImageServerInfo.ServerUri Property

DcnmImageServerInfoServerUri Property

The server uri of the participant picture web server

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Uri ServerUri { get; }
Public ReadOnly Property ServerUri As Uri
    Get
public:
property Uri^ ServerUri {
    Uri^ get ();
}

Property Value

Type: Uri
See Also

Reference

DcnmImageServerInfo Class


DcnmImageServerInfo.UserName Property

DcnmImageServerInfoUserName Property

The user name to connect to the participant picture web server

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string UserName { get; }
Public ReadOnly Property UserName As String
    Get
public:
property String^ UserName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmImageServerInfo Class


DcnmImageServerInfo Methods

The DcnmImageServerInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmImageServerInfo Class


DcnmIndividualVotingResult Class

Contains voting result information
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmIndividualVotingResult

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmIndividualVotingResult
Public Class DcnmIndividualVotingResult
public ref class DcnmIndividualVotingResult

The DcnmIndividualVotingResult type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmIndividualVotingResult | Constructor
Top
Properties
 | Name | Description
Public property | ParticipantId | Holds the identifier of the participant.
Public property | VotingAnswer | Holds voting answer
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmIndividualVotingResult Constructor

Constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmIndividualVotingResult(
    Guid participantId,
    DcnmVotingAnswer votingAnswer
)
Public Sub New (
    participantId As Guid,
    votingAnswer As DcnmVotingAnswer
)
public:
DcnmIndividualVotingResult(
    Guid participantId,
    DcnmVotingAnswer votingAnswer
)

Parameters

participantId
Type: SystemGuid
Participant Id
votingAnswer
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswer
Answer type
See Also

Reference

DcnmIndividualVotingResult Class


DcnmIndividualVotingResult Properties

The DcnmIndividualVotingResult type exposes the following members.

Properties
 | Name | Description
Public property | ParticipantId | Holds the identifier of the participant.
Public property | VotingAnswer | Holds voting answer
Top
See Also

Reference

DcnmIndividualVotingResult Class


DcnmIndividualVotingResult.ParticipantId Property

DcnmIndividualVotingResultParticipantId Property

Holds the identifier of the participant.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid ParticipantId { get; }
Public ReadOnly Property ParticipantId As Guid
    Get
public:
property Guid ParticipantId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmIndividualVotingResult Class


DcnmIndividualVotingResult.VotingAnswer Property

DcnmIndividualVotingResultVotingAnswer Property

Holds voting answer

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingAnswer VotingAnswer { get; }
Public ReadOnly Property VotingAnswer As DcnmVotingAnswer
    Get
public:
property DcnmVotingAnswer VotingAnswer {
    DcnmVotingAnswer get ();
}

Property Value

Type: DcnmVotingAnswer
See Also

Reference

DcnmIndividualVotingResult Class


DcnmIndividualVotingResult Methods

The DcnmIndividualVotingResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmIndividualVotingResult Class


DcnmInterimResultType Enumeration

Defines the interim result type

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmInterimResultType
Public Enumeration DcnmInterimResultType
public enum class DcnmInterimResultType
Members
Member name | Value | Description
None | 0 | The interim result type is "None"
TotalResults | 1 | The interim result type is "Total results"
IndividualResults | 2 | The interim result type is "Individual results"
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmInterpretationInPresetState Enumeration

The Interpretation in preset state

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmInterpretationInPresetState
Public Enumeration DcnmInterpretationInPresetState
public enum class DcnmInterpretationInPresetState
Members
Member name | Value | Description
PresetForInputA | 0 | The preset for input A
PresetForInputB | 1 | The preset for input B
PresetForInputC | 2 | The preset for input C
PresetForInputD | 3 | The preset for input D
PresetForInputE | 4 | The preset for input E
PresetForInputF | 5 | The preset for input F
PresetForInputG | 6 | The preset for input G
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmInterpretationLanguageId Class

Represents the interpretation language.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationLanguageId

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmInterpretationLanguageId
Public Class DcnmInterpretationLanguageId
public ref class DcnmInterpretationLanguageId

The DcnmInterpretationLanguageId type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmInterpretationLanguageId | The default constructor, obviously
Public method | DcnmInterpretationLanguageId(Guid) | The constructor with all parameters
Top
Properties
 | Name | Description
Public property | LanguageId | Index of the language.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmInterpretationLanguageId Constructor

Overload List
 | Name | Description
Public method | DcnmInterpretationLanguageId | The default constructor, obviously
Public method | DcnmInterpretationLanguageId(Guid) | The constructor with all parameters
Top
See Also

Reference

DcnmInterpretationLanguageId Class


DcnmInterpretationLanguageId Constructor

The default constructor, obviously

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmInterpretationLanguageId()
Public Sub New
public:
DcnmInterpretationLanguageId()
See Also

Reference

DcnmInterpretationLanguageId Class
DcnmInterpretationLanguageId Overload


DcnmInterpretationLanguageId Constructor (Guid)

The constructor with all parameters

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmInterpretationLanguageId(
    Guid id
)
Public Sub New (
    id As Guid
)
public:
DcnmInterpretationLanguageId(
    Guid id
)

Parameters

id
Type: SystemGuid
Index
See Also

Reference

DcnmInterpretationLanguageId Class
DcnmInterpretationLanguageId Overload


DcnmInterpretationLanguageId Properties

The DcnmInterpretationLanguageId type exposes the following members.

Properties
 | Name | Description
Public property | LanguageId | Index of the language.
Top
See Also

Reference

DcnmInterpretationLanguageId Class


DcnmInterpretationLanguageId.LanguageId Property

DcnmInterpretationLanguageIdLanguageId Property

Index of the language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid LanguageId { get; set; }
Public Property LanguageId As Guid
    Get
    Set
public:
property Guid LanguageId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmInterpretationLanguageId Class


DcnmInterpretationLanguageId Methods

The DcnmInterpretationLanguageId type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmInterpretationLanguageId Class


DcnmInterpretationLanguageInfo Class

Represents the interpretation language info
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationLanguageInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmInterpretationLanguageInfo
Public Class DcnmInterpretationLanguageInfo
public ref class DcnmInterpretationLanguageInfo

The DcnmInterpretationLanguageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmInterpretationLanguageInfo(Guid, Int32, String, String, IEnumerableDcnmLanguageStream) | Initializes a new instance of the DcnmInterpretationLanguageInfo class.
Public method | DcnmInterpretationLanguageInfo(Guid, Int32, String, String, String, Boolean) | Obsolete. Initializes a new instance of the DcnmInterpretationLanguageInfo class.
Top
Properties
 | Name | Description
Public property | IsLanguageSecure | Obsolete. Gets a value indicating whether this instance is language secure.
Public property | LanguageAbbreviation | Gets or sets the language abbreviation.
Public property | LanguageAddress | Obsolete. Gets the language address.
Public property | LanguageId | Gets the language identifier.
Public property | LanguageIndex | Gets the index of the language.
Public property | ShortLanguageLabel | Gets the short language label.
Public property | Streams | Access the audio streams
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmInterpretationLanguageInfo Constructor

Overload List
 | Name | Description
Public method | DcnmInterpretationLanguageInfo(Guid, Int32, String, String, IEnumerableDcnmLanguageStream) | Initializes a new instance of the DcnmInterpretationLanguageInfo class.
Public method | DcnmInterpretationLanguageInfo(Guid, Int32, String, String, String, Boolean) | Obsolete. Initializes a new instance of the DcnmInterpretationLanguageInfo class.
Top
See Also

Reference

DcnmInterpretationLanguageInfo Class


DcnmInterpretationLanguageInfo Constructor (Guid, Int32, String, String, IEnumerable(DcnmLanguageStream))

DcnmInterpretationLanguageInfo Constructor (Guid, Int32, String, String, IEnumerableDcnmLanguageStream)

 Bosch Logo
Initializes a new instance of the DcnmInterpretationLanguageInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmInterpretationLanguageInfo(
    Guid languageId,
    int languageIndex,
    string shortLanguageLabel,
    string languageAbbreviation,
    IEnumerable<DcnmLanguageStream> streams
)
Public Sub New (
    languageId As Guid,
    languageIndex As Integer,
    shortLanguageLabel As String,
    languageAbbreviation As String,
    streams As IEnumerable(Of DcnmLanguageStream)
)
public:
DcnmInterpretationLanguageInfo(
    Guid languageId,
    int languageIndex,
    String^ shortLanguageLabel,
    String^ languageAbbreviation,
    IEnumerable<DcnmLanguageStream^>^ streams
)

Parameters

languageId
Type: SystemGuid
The language identifier.
languageIndex
Type: SystemInt32
Index of the language.
shortLanguageLabel
Type: SystemString
The short language label.
languageAbbreviation
Type: SystemString
The language abbreviation.
streams
Type: System.Collections.GenericIEnumerable DcnmLanguageStream
A collection of streams on which the language is transmitted.
See Also

Reference

DcnmInterpretationLanguageInfo Class
DcnmInterpretationLanguageInfo Overload


DcnmInterpretationLanguageInfo Constructor (Guid, Int32, String, String, String, Boolean)

Note: This API is now obsolete.

Initializes a new instance of the DcnmInterpretationLanguageInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This constructor is deprecated. Please use a different constructor with the streams collection.")]
public DcnmInterpretationLanguageInfo(
    Guid languageId,
    int languageIndex,
    string shortLanguageLabel,
    string languageAbbreviation,
    string languageAddress,
    bool isLanguageSecure
)
<ObsoleteAttribute("This constructor is deprecated. Please use a different constructor with the streams collection.")>
Public Sub New (
    languageId As Guid,
    languageIndex As Integer,
    shortLanguageLabel As String,
    languageAbbreviation As String,
    languageAddress As String,
    isLanguageSecure As Boolean
)
public:
[ObsoleteAttribute(L"This constructor is deprecated. Please use a different constructor with the streams collection.")]
DcnmInterpretationLanguageInfo(
    Guid languageId,
    int languageIndex,
    String^ shortLanguageLabel,
    String^ languageAbbreviation,
    String^ languageAddress,
    bool isLanguageSecure
)

Parameters

languageId
Type: SystemGuid
The language identifier.
languageIndex
Type: SystemInt32
Index of the language.
shortLanguageLabel
Type: SystemString
The short language label.
languageAbbreviation
Type: SystemString
The language abbreviation.
languageAddress
Type: SystemString
The language address.
isLanguageSecure
Type: SystemBoolean
Holds whether language is secure or not.
See Also

Reference

DcnmInterpretationLanguageInfo Class
DcnmInterpretationLanguageInfo Overload


DcnmInterpretationLanguageInfo Properties

The DcnmInterpretationLanguageInfo type exposes the following members.

Properties
 | Name | Description
Public property | IsLanguageSecure | Obsolete. Gets a value indicating whether this instance is language secure.
Public property | LanguageAbbreviation | Gets or sets the language abbreviation.
Public property | LanguageAddress | Obsolete. Gets the language address.
Public property | LanguageId | Gets the language identifier.
Public property | LanguageIndex | Gets the index of the language.
Public property | ShortLanguageLabel | Gets the short language label.
Public property | Streams | Access the audio streams
Top
See Also

Reference

DcnmInterpretationLanguageInfo Class


DcnmInterpretationLanguageInfo.IsLanguageSecure Property

DcnmInterpretationLanguageInfoIsLanguageSecure Property

Note: This API is now obsolete.

Gets a value indicating whether this instance is language secure.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("DcnmInterpretationLanguageInfo.IsLanguageSecure is deprecated. Please use DcnmInterpretationLanguageInfo.Streams[0].IsSecure instead.")]
public bool IsLanguageSecure { get; }
<ObsoleteAttribute("DcnmInterpretationLanguageInfo.IsLanguageSecure is deprecated. Please use DcnmInterpretationLanguageInfo.Streams[0].IsSecure instead.")>
Public ReadOnly Property IsLanguageSecure As Boolean
    Get
public:
[ObsoleteAttribute(L"DcnmInterpretationLanguageInfo.IsLanguageSecure is deprecated. Please use DcnmInterpretationLanguageInfo.Streams[0].IsSecure instead.")]
property bool IsLanguageSecure {
    bool get ();
}

Property Value

Type: Boolean
true if this instance is language secure; otherwise, false.
See Also

Reference

DcnmInterpretationLanguageInfo Class


DcnmInterpretationLanguageInfo.LanguageAbbreviation Property

DcnmInterpretationLanguageInfoLanguageAbbreviation Property

Gets or sets the language abbreviation.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string LanguageAbbreviation { get; }
Public ReadOnly Property LanguageAbbreviation As String
    Get
public:
property String^ LanguageAbbreviation {
    String^ get ();
}

Property Value

Type: String
The language abbreviation.
See Also

Reference

DcnmInterpretationLanguageInfo Class


DcnmInterpretationLanguageInfo.LanguageAddress Property

DcnmInterpretationLanguageInfoLanguageAddress Property

Note: This API is now obsolete.

Gets the language address.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("DcnmInterpretationLanguageInfo.LanguageAddress is deprecated. Please use DcnmInterpretationLanguageInfo.Streams[0].Address instead.")]
public string LanguageAddress { get; }
<ObsoleteAttribute("DcnmInterpretationLanguageInfo.LanguageAddress is deprecated. Please use DcnmInterpretationLanguageInfo.Streams[0].Address instead.")>
Public ReadOnly Property LanguageAddress As String
    Get
public:
[ObsoleteAttribute(L"DcnmInterpretationLanguageInfo.LanguageAddress is deprecated. Please use DcnmInterpretationLanguageInfo.Streams[0].Address instead.")]
property String^ LanguageAddress {
    String^ get ();
}

Property Value

Type: String
The language address.
See Also

Reference

DcnmInterpretationLanguageInfo Class


DcnmInterpretationLanguageInfo.LanguageId Property

DcnmInterpretationLanguageInfoLanguageId Property

Gets the language identifier.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid LanguageId { get; }
Public ReadOnly Property LanguageId As Guid
    Get
public:
property Guid LanguageId {
    Guid get ();
}

Property Value

Type: Guid
The language identifier.
See Also

Reference

DcnmInterpretationLanguageInfo Class


DcnmInterpretationLanguageInfo.LanguageIndex Property

DcnmInterpretationLanguageInfoLanguageIndex Property

Gets the index of the language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int LanguageIndex { get; }
Public ReadOnly Property LanguageIndex As Integer
    Get
public:
property int LanguageIndex {
    int get ();
}

Property Value

Type: Int32
The index of the language.
See Also

Reference

DcnmInterpretationLanguageInfo Class


DcnmInterpretationLanguageInfo.ShortLanguageLabel Property

DcnmInterpretationLanguageInfoShortLanguageLabel Property

Gets the short language label.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string ShortLanguageLabel { get; }
Public ReadOnly Property ShortLanguageLabel As String
    Get
public:
property String^ ShortLanguageLabel {
    String^ get ();
}

Property Value

Type: String
The short language label.
See Also

Reference

DcnmInterpretationLanguageInfo Class


DcnmInterpretationLanguageInfo.Streams Property

DcnmInterpretationLanguageInfoStreams Property

Access the audio streams

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IReadOnlyList<DcnmLanguageStream> Streams { get; }
Public ReadOnly Property Streams As IReadOnlyList(Of DcnmLanguageStream)
    Get
public:
property IReadOnlyList<DcnmLanguageStream^>^ Streams {
    IReadOnlyList<DcnmLanguageStream^>^ get ();
}

Property Value

Type: IReadOnlyList DcnmLanguageStream
See Also

Reference

DcnmInterpretationLanguageInfo Class


DcnmInterpretationLanguageInfo Methods

The DcnmInterpretationLanguageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmInterpretationLanguageInfo Class


DcnmInterpretationLanguageQualityType Enumeration

Contains the definition of all Channel types.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmInterpretationLanguageQualityType
Public Enumeration DcnmInterpretationLanguageQualityType
public enum class DcnmInterpretationLanguageQualityType
Members
Member name | Value | Description
Floor | 0 | Floor copy done for the language
Plus | 1 | Interpreted by listening to the floor (direct interpretation)
Minus | 2 | Interpreted by listening to an interpreter (indirect interpretation)
MinusMinus | 3 | Interpreted by listening to a chain of interpreters (multi interpretation)
Unknown | 4 | Interpreted by listening to an interpreter with an unknown quality (external sources without quality indication)
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmInterpretationMetaRequestInfo Class

Class hold interpretation meta request status
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationMetaRequestInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmInterpretationMetaRequestInfo
Public Class DcnmInterpretationMetaRequestInfo
public ref class DcnmInterpretationMetaRequestInfo

The DcnmInterpretationMetaRequestInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmInterpretationMetaRequestInfo | Constructor for class
Top
Properties
 | Name | Description
Public property | ActiveInterpretationMetaRequests | List of interpretation meta request active in system.
Public property | SeatMetaRequestInfo | List seat ids with active meta request.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmInterpretationMetaRequestInfo Constructor

Constructor for class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmInterpretationMetaRequestInfo(
    List<DcnmInterpretationMetaRequestType> activeInterpretationMetaRequests,
    List<DcnmInterpretationSeatMetaRequestInfo> seatMetaRequestInfo
)
Public Sub New (
    activeInterpretationMetaRequests As List(Of DcnmInterpretationMetaRequestType),
    seatMetaRequestInfo As List(Of DcnmInterpretationSeatMetaRequestInfo)
)
public:
DcnmInterpretationMetaRequestInfo(
    List<DcnmInterpretationMetaRequestType>^ activeInterpretationMetaRequests,
    List<DcnmInterpretationSeatMetaRequestInfo^>^ seatMetaRequestInfo
)

Parameters

activeInterpretationMetaRequests
Type: System.Collections.GenericList DcnmInterpretationMetaRequestType
Meta request active for system
seatMetaRequestInfo
Type: System.Collections.GenericList DcnmInterpretationSeatMetaRequestInfo
Meta request info for seats.
See Also

Reference

DcnmInterpretationMetaRequestInfo Class
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationMetaRequestType
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationSeatMetaRequestInfo


DcnmInterpretationMetaRequestInfo Properties

The DcnmInterpretationMetaRequestInfo type exposes the following members.

Properties
 | Name | Description
Public property | ActiveInterpretationMetaRequests | List of interpretation meta request active in system.
Public property | SeatMetaRequestInfo | List seat ids with active meta request.
Top
See Also

Reference

DcnmInterpretationMetaRequestInfo Class


DcnmInterpretationMetaRequestInfo.ActiveInterpretationMetaRequests Property

DcnmInterpretationMetaRequestInfoActiveInterpretationMetaRequests Property

Bosch Logo
List of interpretation meta request active in system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public List<DcnmInterpretationMetaRequestType> ActiveInterpretationMetaRequests { get; }
Public ReadOnly Property ActiveInterpretationMetaRequests As List(Of DcnmInterpretationMetaRequestType)
    Get
public:
property List<DcnmInterpretationMetaRequestType>^ ActiveInterpretationMetaRequests {
    List<DcnmInterpretationMetaRequestType>^ get ();
}

Property Value

Type: List DcnmInterpretationMetaRequestType
See Also

Reference

DcnmInterpretationMetaRequestInfo Class


DcnmInterpretationMetaRequestInfo.SeatMetaRequestInfo Property

DcnmInterpretationMetaRequestInfoSeatMetaRequestInfo Property

Bosch Logo
List seat ids with active meta request.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public List<DcnmInterpretationSeatMetaRequestInfo> SeatMetaRequestInfo { get; }
Public ReadOnly Property SeatMetaRequestInfo As List(Of DcnmInterpretationSeatMetaRequestInfo)
    Get
public:
property List<DcnmInterpretationSeatMetaRequestInfo^>^ SeatMetaRequestInfo {
    List<DcnmInterpretationSeatMetaRequestInfo^>^ get ();
}

Property Value

Type: List DcnmInterpretationSeatMetaRequestInfo
See Also

Reference

DcnmInterpretationMetaRequestInfo Class


DcnmInterpretationMetaRequestInfo Methods

The DcnmInterpretationMetaRequestInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmInterpretationMetaRequestInfo Class


DcnmInterpretationMetaRequestType Enumeration

Request type used for interpretation meta requests

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmInterpretationMetaRequestType
Public Enumeration DcnmInterpretationMetaRequestType
public enum class DcnmInterpretationMetaRequestType
Members
Member name | Value | Description
SpeakSlow | 0 | Indicates meta request type is speak slow.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmInterpretationMicrophoneState Enumeration

The Interpretation microphone state

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmInterpretationMicrophoneState
Public Enumeration DcnmInterpretationMicrophoneState
public enum class DcnmInterpretationMicrophoneState
Members
Member name | Value | Description
Off | 0 | Microphone is off.
ActiveOnOutputA | 1 | The active on output a
ActiveOnOutputB | 2 | The active on output b
ActiveOnOutputC | 3 | The active on output c
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmInterpretationModeType Enumeration

Type providing the values set for the interpretation modes.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmInterpretationModeType
Public Enumeration DcnmInterpretationModeType
public enum class DcnmInterpretationModeType
Members
Member name | Value | Description
Interlock | 0 | Defines the interpretation mode where the activation of a microphone can only be done if the channel is not engaged.
Override | 1 | Defines the interpretation mode where the currently active microphone will be overridden.
Merge | 2 | Defines the interpretation mode where multiple interpreters can activate their microphone simultaniously.
InterlockAOverrideB | 3 | Defines the interpretation mode mix for managing the microphone between booths. In case the A-Output is used, interlock is applicable and when the B/C-Output is used, it can be overridden by another interpreter (using his A-Ouput)
InterlockBOverrideA | 4 | Defines the interpretation mode mix for managing the microphone between booths. In case the B-Output is used, interlock is applicable and when the A-Output is used, it can be overridden by another interpreter (using his A or B/C-Ouput)
Remarks
The interpretation mode values define the behavior of the microphone activation within and between booths.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmInterpretationOutPresetState Enumeration

The Interpretation out preset state

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmInterpretationOutPresetState
Public Enumeration DcnmInterpretationOutPresetState
public enum class DcnmInterpretationOutPresetState
Members
Member name | Value | Description
PresetForOutputB | 0 | The active on output B
PresetForOutputC | 1 | The active on output C
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmInterpretationRoutingInfo Class

Represents the interpretation routing info
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationRoutingInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmInterpretationRoutingInfo
Public Class DcnmInterpretationRoutingInfo
public ref class DcnmInterpretationRoutingInfo

The DcnmInterpretationRoutingInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmInterpretationRoutingInfo(Guid, DcnmInterpretationMicrophoneState, Guid, Guid, Boolean) | Obsolete. Initializes a new instance of the DcnmInterpretationRoutingInfo class.
Public method | DcnmInterpretationRoutingInfo(Guid, DcnmInterpretationMicrophoneState, Guid, DcnmInterpretationLanguageQualityType, Guid, Boolean) | Initializes a new instance of the DcnmInterpretationRoutingInfo class.
Top
Properties
 | Name | Description
Public property | DestinationLanguage | Gets the destination language.
Public property | DestinationLanguageQuality | The interpretation quality indication for the language.
Public property | InterpretationMicrophoneState | Gets the state of the interpretation microphone.
Public property | IsContributingAutoRelay | Indicates whether the seat is actively contributing to auto-relay.
Public property | SeatId | Gets the seat identifier.
Public property | SourceLanguage | Gets the source language.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmInterpretationRoutingInfo Constructor

Overload List
 | Name | Description
Public method | DcnmInterpretationRoutingInfo(Guid, DcnmInterpretationMicrophoneState, Guid, Guid, Boolean) | Obsolete. Initializes a new instance of the DcnmInterpretationRoutingInfo class.
Public method | DcnmInterpretationRoutingInfo(Guid, DcnmInterpretationMicrophoneState, Guid, DcnmInterpretationLanguageQualityType, Guid, Boolean) | Initializes a new instance of the DcnmInterpretationRoutingInfo class.
Top
See Also

Reference

DcnmInterpretationRoutingInfo Class


DcnmInterpretationRoutingInfo Constructor (Guid, DcnmInterpretationMicrophoneState, Guid, Guid, Boolean)

Note: This API is now obsolete.

Initializes a new instance of the DcnmInterpretationRoutingInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This constructor is deprecated. Please use a different constructor.")]
public DcnmInterpretationRoutingInfo(
    Guid seatId,
    DcnmInterpretationMicrophoneState interpretationMicrophoneState,
    Guid destinationLanguage,
    Guid sourceLanguage,
    bool isContributingAutoRelay
)
<ObsoleteAttribute("This constructor is deprecated. Please use a different constructor.")>
Public Sub New (
    seatId As Guid,
    interpretationMicrophoneState As DcnmInterpretationMicrophoneState,
    destinationLanguage As Guid,
    sourceLanguage As Guid,
    isContributingAutoRelay As Boolean
)
public:
[ObsoleteAttribute(L"This constructor is deprecated. Please use a different constructor.")]
DcnmInterpretationRoutingInfo(
    Guid seatId,
    DcnmInterpretationMicrophoneState interpretationMicrophoneState,
    Guid destinationLanguage,
    Guid sourceLanguage,
    bool isContributingAutoRelay
)

Parameters

seatId
Type: SystemGuid
The seat identifier.
interpretationMicrophoneState
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationMicrophoneState
State of the interpretation microphone.
destinationLanguage
Type: SystemGuid
The destination language.
sourceLanguage
Type: SystemGuid
The source language.
isContributingAutoRelay
Type: SystemBoolean
Indicates whether the seat is actively contributing to auto-relay.
See Also

Reference

DcnmInterpretationRoutingInfo Class
DcnmInterpretationRoutingInfo Overload


DcnmInterpretationRoutingInfo Constructor (Guid, DcnmInterpretationMicrophoneState, Guid, DcnmInterpretationLanguageQualityType, Guid, Boolean)

Initializes a new instance of the DcnmInterpretationRoutingInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmInterpretationRoutingInfo(
    Guid seatId,
    DcnmInterpretationMicrophoneState interpretationMicrophoneState,
    Guid destinationLanguage,
    DcnmInterpretationLanguageQualityType destinationLanguageQuality,
    Guid sourceLanguage,
    bool isContributingAutoRelay
)
Public Sub New (
    seatId As Guid,
    interpretationMicrophoneState As DcnmInterpretationMicrophoneState,
    destinationLanguage As Guid,
    destinationLanguageQuality As DcnmInterpretationLanguageQualityType,
    sourceLanguage As Guid,
    isContributingAutoRelay As Boolean
)
public:
DcnmInterpretationRoutingInfo(
    Guid seatId,
    DcnmInterpretationMicrophoneState interpretationMicrophoneState,
    Guid destinationLanguage,
    DcnmInterpretationLanguageQualityType destinationLanguageQuality,
    Guid sourceLanguage,
    bool isContributingAutoRelay
)

Parameters

seatId
Type: SystemGuid
The seat identifier.
interpretationMicrophoneState
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationMicrophoneState
State of the interpretation microphone.
destinationLanguage
Type: SystemGuid
The destination language.
destinationLanguageQuality
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationLanguageQualityType
The interpretation quality the destination language has.
sourceLanguage
Type: SystemGuid
The source language.
isContributingAutoRelay
Type: SystemBoolean
Indicates whether the seat is actively contributing to auto-relay.
See Also

Reference

DcnmInterpretationRoutingInfo Class
DcnmInterpretationRoutingInfo Overload


DcnmInterpretationRoutingInfo Properties

The DcnmInterpretationRoutingInfo type exposes the following members.

Properties
 | Name | Description
Public property | DestinationLanguage | Gets the destination language.
Public property | DestinationLanguageQuality | The interpretation quality indication for the language.
Public property | InterpretationMicrophoneState | Gets the state of the interpretation microphone.
Public property | IsContributingAutoRelay | Indicates whether the seat is actively contributing to auto-relay.
Public property | SeatId | Gets the seat identifier.
Public property | SourceLanguage | Gets the source language.
Top
See Also

Reference

DcnmInterpretationRoutingInfo Class


DcnmInterpretationRoutingInfo.DestinationLanguage Property

DcnmInterpretationRoutingInfoDestinationLanguage Property

Gets the destination language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid DestinationLanguage { get; }
Public ReadOnly Property DestinationLanguage As Guid
    Get
public:
property Guid DestinationLanguage {
    Guid get ();
}

Property Value

Type: Guid
The destination language.
See Also

Reference

DcnmInterpretationRoutingInfo Class


DcnmInterpretationRoutingInfo.DestinationLanguageQuality Property

DcnmInterpretationRoutingInfoDestinationLanguageQuality Property

Bosch Logo
The interpretation quality indication for the language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmInterpretationLanguageQualityType DestinationLanguageQuality { get; }
Public ReadOnly Property DestinationLanguageQuality As DcnmInterpretationLanguageQualityType
    Get
public:
property DcnmInterpretationLanguageQualityType DestinationLanguageQuality {
    DcnmInterpretationLanguageQualityType get ();
}

Property Value

Type: DcnmInterpretationLanguageQualityType
See Also

Reference

DcnmInterpretationRoutingInfo Class


DcnmInterpretationRoutingInfo.InterpretationMicrophoneState Property

DcnmInterpretationRoutingInfoInterpretationMicrophoneState Property

Bosch Logo
Gets the state of the interpretation microphone.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmInterpretationMicrophoneState InterpretationMicrophoneState { get; }
Public ReadOnly Property InterpretationMicrophoneState As DcnmInterpretationMicrophoneState
    Get
public:
property DcnmInterpretationMicrophoneState InterpretationMicrophoneState {
    DcnmInterpretationMicrophoneState get ();
}

Property Value

Type: DcnmInterpretationMicrophoneState
The state of the interpretation microphone.
See Also

Reference

DcnmInterpretationRoutingInfo Class


DcnmInterpretationRoutingInfo.IsContributingAutoRelay Property

DcnmInterpretationRoutingInfoIsContributingAutoRelay Property

Bosch Logo
Indicates whether the seat is actively contributing to auto-relay.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsContributingAutoRelay { get; }
Public ReadOnly Property IsContributingAutoRelay As Boolean
    Get
public:
property bool IsContributingAutoRelay {
    bool get ();
}

Property Value

Type: Boolean
True when actively contributing to auto-relay, false otherwise.
See Also

Reference

DcnmInterpretationRoutingInfo Class


DcnmInterpretationRoutingInfo.SeatId Property

DcnmInterpretationRoutingInfoSeatId Property

Gets the seat identifier.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid SeatId { get; }
Public ReadOnly Property SeatId As Guid
    Get
public:
property Guid SeatId {
    Guid get ();
}

Property Value

Type: Guid
The seat identifier.
See Also

Reference

DcnmInterpretationRoutingInfo Class


DcnmInterpretationRoutingInfo.SourceLanguage Property

DcnmInterpretationRoutingInfoSourceLanguage Property

Gets the source language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid SourceLanguage { get; }
Public ReadOnly Property SourceLanguage As Guid
    Get
public:
property Guid SourceLanguage {
    Guid get ();
}

Property Value

Type: Guid
The source language.
See Also

Reference

DcnmInterpretationRoutingInfo Class


DcnmInterpretationRoutingInfo Methods

The DcnmInterpretationRoutingInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmInterpretationRoutingInfo Class


DcnmInterpretationSeatMetaRequestInfo Class

Class hold seat with active interpretation requests.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationSeatMetaRequestInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmInterpretationSeatMetaRequestInfo
Public Class DcnmInterpretationSeatMetaRequestInfo
public ref class DcnmInterpretationSeatMetaRequestInfo

The DcnmInterpretationSeatMetaRequestInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmInterpretationSeatMetaRequestInfo | Class hold interpretation meta request info.
Top
Properties
 | Name | Description
Public property | MetaRequests | meta request type.
Public property | SeatId | Seat id requesting.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmInterpretationSeatMetaRequestInfo Constructor

Class hold interpretation meta request info.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmInterpretationSeatMetaRequestInfo(
    Guid seatId,
    List<DcnmInterpretationMetaRequestType> metaRequests
)
Public Sub New (
    seatId As Guid,
    metaRequests As List(Of DcnmInterpretationMetaRequestType)
)
public:
DcnmInterpretationSeatMetaRequestInfo(
    Guid seatId,
    List<DcnmInterpretationMetaRequestType>^ metaRequests
)

Parameters

seatId
Type: SystemGuid
Requesting seat id
metaRequests
Type: System.Collections.GenericList DcnmInterpretationMetaRequestType
Meta request type DcnmInterpretationMetaRequestType
See Also

Reference

DcnmInterpretationSeatMetaRequestInfo Class


DcnmInterpretationSeatMetaRequestInfo Properties

The DcnmInterpretationSeatMetaRequestInfo type exposes the following members.

Properties
 | Name | Description
Public property | MetaRequests | meta request type.
Public property | SeatId | Seat id requesting.
Top
See Also

Reference

DcnmInterpretationSeatMetaRequestInfo Class


DcnmInterpretationSeatMetaRequestInfo.MetaRequests Property

DcnmInterpretationSeatMetaRequestInfoMetaRequests Property

meta request type.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public List<DcnmInterpretationMetaRequestType> MetaRequests { get; }
Public ReadOnly Property MetaRequests As List(Of DcnmInterpretationMetaRequestType)
    Get
public:
property List<DcnmInterpretationMetaRequestType>^ MetaRequests {
    List<DcnmInterpretationMetaRequestType>^ get ();
}

Property Value

Type: List DcnmInterpretationMetaRequestType
See Also

Reference

DcnmInterpretationSeatMetaRequestInfo Class


DcnmInterpretationSeatMetaRequestInfo.SeatId Property

DcnmInterpretationSeatMetaRequestInfoSeatId Property

Seat id requesting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid SeatId { get; }
Public ReadOnly Property SeatId As Guid
    Get
public:
property Guid SeatId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmInterpretationSeatMetaRequestInfo Class


DcnmInterpretationSeatMetaRequestInfo Methods

The DcnmInterpretationSeatMetaRequestInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmInterpretationSeatMetaRequestInfo Class


DcnmInterpretationSettingsInfo Class

Class representing the interpretation settings information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationSettingsInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmInterpretationSettingsInfo
Public Class DcnmInterpretationSettingsInfo
public ref class DcnmInterpretationSettingsInfo

The DcnmInterpretationSettingsInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmInterpretationSettingsInfo(Guid, DcnmInterpretationModeType, DcnmInterpretationModeType, Boolean, Boolean, Boolean) | Obsolete. Constructor with arguments.
Public method | DcnmInterpretationSettingsInfo(Guid, DcnmInterpretationModeType, DcnmInterpretationModeType, Boolean, Boolean, Boolean, Int32, Int32, Int32) | Obsolete. Constructor with arguments.
Public method | DcnmInterpretationSettingsInfo(Guid, DcnmInterpretationModeType, DcnmInterpretationModeType, Boolean, Boolean, Boolean, Int32, Int32, Int32, Boolean, IListDcnmHeadphoneTypes) | Constructor with arguments.
Top
Properties
 | Name | Description
Public property | BetweenBoothInterpretationMode | Gets or sets the indication if interpretation between booths.
Public property | EnableConfigurationFromDesk | This enables configuration from desk.
Public property | FlashingMicrophoneOnEngaged | Gets or sets the indication if microphone flashing on engaged.
Public property | MeetingId | Gets or sets the identifier of the meeting.
Public property | MinimumSpeakSlowRequest | Gets or sets the minimum speak slow requests.
Public property | SelectedHeadphones | Gets or sets the selected headphones list.
Public property | SpeakSlowly | Gets or sets the indication if speak slowly enabled.
Public property | SpeakSlowRequestReleaseTime | Gets or sets the speak slow request release time.
Public property | SpeakSlowSignallingReleaseTime | Gets or sets the speak slow signalling release time.
Public property | WithinBoothEngagedIndication | Gets or sets the indication if engaged within booth.
Public property | WithinBoothInterpretationMode | Gets or sets the indication if interpretation within booth.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmInterpretationSettingsInfo Constructor

Overload List
 | Name | Description
Public method | DcnmInterpretationSettingsInfo(Guid, DcnmInterpretationModeType, DcnmInterpretationModeType, Boolean, Boolean, Boolean) | Obsolete. Constructor with arguments.
Public method | DcnmInterpretationSettingsInfo(Guid, DcnmInterpretationModeType, DcnmInterpretationModeType, Boolean, Boolean, Boolean, Int32, Int32, Int32) | Obsolete. Constructor with arguments.
Public method | DcnmInterpretationSettingsInfo(Guid, DcnmInterpretationModeType, DcnmInterpretationModeType, Boolean, Boolean, Boolean, Int32, Int32, Int32, Boolean, IListDcnmHeadphoneTypes) | Constructor with arguments.
Top
See Also

Reference

DcnmInterpretationSettingsInfo Class


DcnmInterpretationSettingsInfo Constructor (Guid, DcnmInterpretationModeType, DcnmInterpretationModeType, Boolean, Boolean, Boolean)

Note: This API is now obsolete.

Constructor with arguments.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with speak slow configuration settings")]
public DcnmInterpretationSettingsInfo(
    Guid meetingId,
    DcnmInterpretationModeType withinBoothInterpretationMode,
    DcnmInterpretationModeType betweenBoothInterpretationMode,
    bool withinBoothEngagedIndication,
    bool flashingMicrophoneOnEngaged,
    bool speakSlowly
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with speak slow configuration settings")>
Public Sub New (
    meetingId As Guid,
    withinBoothInterpretationMode As DcnmInterpretationModeType,
    betweenBoothInterpretationMode As DcnmInterpretationModeType,
    withinBoothEngagedIndication As Boolean,
    flashingMicrophoneOnEngaged As Boolean,
    speakSlowly As Boolean
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with speak slow configuration settings")]
DcnmInterpretationSettingsInfo(
    Guid meetingId,
    DcnmInterpretationModeType withinBoothInterpretationMode,
    DcnmInterpretationModeType betweenBoothInterpretationMode,
    bool withinBoothEngagedIndication,
    bool flashingMicrophoneOnEngaged,
    bool speakSlowly
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting.
withinBoothInterpretationMode
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationModeType
Indication within booth interpretation mode.
betweenBoothInterpretationMode
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationModeType
Indication between booth interpretation mode.
withinBoothEngagedIndication
Type: SystemBoolean
Indication booth engaged.
flashingMicrophoneOnEngaged
Type: SystemBoolean
Indication flashing microphone on engaged.
speakSlowly
Type: SystemBoolean
Indication speak slowly.
See Also

Reference

DcnmInterpretationSettingsInfo Class
DcnmInterpretationSettingsInfo Overload


DcnmInterpretationSettingsInfo Constructor (Guid, DcnmInterpretationModeType, DcnmInterpretationModeType, Boolean, Boolean, Boolean, Int32, Int32, Int32)

Note: This API is now obsolete.

Constructor with arguments.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with enable configuration from desk settings")]
public DcnmInterpretationSettingsInfo(
    Guid meetingId,
    DcnmInterpretationModeType withinBoothInterpretationMode,
    DcnmInterpretationModeType betweenBoothInterpretationMode,
    bool withinBoothEngagedIndication,
    bool flashingMicrophoneOnEngaged,
    bool speakSlowly,
    int speakSlowRequestReleaseTime,
    int minimumSpeakSlowRequest,
    int speakSlowSignallingReleaseTime
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with enable configuration from desk settings")>
Public Sub New (
    meetingId As Guid,
    withinBoothInterpretationMode As DcnmInterpretationModeType,
    betweenBoothInterpretationMode As DcnmInterpretationModeType,
    withinBoothEngagedIndication As Boolean,
    flashingMicrophoneOnEngaged As Boolean,
    speakSlowly As Boolean,
    speakSlowRequestReleaseTime As Integer,
    minimumSpeakSlowRequest As Integer,
    speakSlowSignallingReleaseTime As Integer
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with enable configuration from desk settings")]
DcnmInterpretationSettingsInfo(
    Guid meetingId,
    DcnmInterpretationModeType withinBoothInterpretationMode,
    DcnmInterpretationModeType betweenBoothInterpretationMode,
    bool withinBoothEngagedIndication,
    bool flashingMicrophoneOnEngaged,
    bool speakSlowly,
    int speakSlowRequestReleaseTime,
    int minimumSpeakSlowRequest,
    int speakSlowSignallingReleaseTime
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting.
withinBoothInterpretationMode
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationModeType
Indication within booth interpretation mode.
betweenBoothInterpretationMode
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationModeType
Indication between booth interpretation mode.
withinBoothEngagedIndication
Type: SystemBoolean
Indication booth engaged.
flashingMicrophoneOnEngaged
Type: SystemBoolean
Indication flashing microphone on engaged.
speakSlowly
Type: SystemBoolean
Indication speak slowly.
speakSlowRequestReleaseTime
Type: SystemInt32
The speak slow request release time
minimumSpeakSlowRequest
Type: SystemInt32
The minimum speak slow requests
speakSlowSignallingReleaseTime
Type: SystemInt32
The speak slow signalling release time
See Also

Reference

DcnmInterpretationSettingsInfo Class
DcnmInterpretationSettingsInfo Overload


DcnmInterpretationSettingsInfo Constructor (Guid, DcnmInterpretationModeType, DcnmInterpretationModeType, Boolean, Boolean, Boolean, Int32, Int32, Int32, Boolean, IList(DcnmHeadphoneTypes))

DcnmInterpretationSettingsInfo Constructor (Guid, DcnmInterpretationModeType, DcnmInterpretationModeType, Boolean, Boolean, Boolean, Int32, Int32, Int32, Boolean, IListDcnmHeadphoneTypes)

 Bosch Logo
Constructor with arguments.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmInterpretationSettingsInfo(
    Guid meetingId,
    DcnmInterpretationModeType withinBoothInterpretationMode,
    DcnmInterpretationModeType betweenBoothInterpretationMode,
    bool withinBoothEngagedIndication,
    bool flashingMicrophoneOnEngaged,
    bool speakSlowly,
    int speakSlowRequestReleaseTime,
    int minimumSpeakSlowRequest,
    int speakSlowSignallingReleaseTime,
    bool enableConfigurationFromDesk,
    IList<DcnmHeadphoneTypes> selectedHeadphones
)
Public Sub New (
    meetingId As Guid,
    withinBoothInterpretationMode As DcnmInterpretationModeType,
    betweenBoothInterpretationMode As DcnmInterpretationModeType,
    withinBoothEngagedIndication As Boolean,
    flashingMicrophoneOnEngaged As Boolean,
    speakSlowly As Boolean,
    speakSlowRequestReleaseTime As Integer,
    minimumSpeakSlowRequest As Integer,
    speakSlowSignallingReleaseTime As Integer,
    enableConfigurationFromDesk As Boolean,
    selectedHeadphones As IList(Of DcnmHeadphoneTypes)
)
public:
DcnmInterpretationSettingsInfo(
    Guid meetingId,
    DcnmInterpretationModeType withinBoothInterpretationMode,
    DcnmInterpretationModeType betweenBoothInterpretationMode,
    bool withinBoothEngagedIndication,
    bool flashingMicrophoneOnEngaged,
    bool speakSlowly,
    int speakSlowRequestReleaseTime,
    int minimumSpeakSlowRequest,
    int speakSlowSignallingReleaseTime,
    bool enableConfigurationFromDesk,
    IList<DcnmHeadphoneTypes>^ selectedHeadphones
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting.
withinBoothInterpretationMode
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationModeType
Indication within booth interpretation mode.
betweenBoothInterpretationMode
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationModeType
Indication between booth interpretation mode.
withinBoothEngagedIndication
Type: SystemBoolean
Indication booth engaged.
flashingMicrophoneOnEngaged
Type: SystemBoolean
Indication flashing microphone on engaged.
speakSlowly
Type: SystemBoolean
Indication speak slowly.
speakSlowRequestReleaseTime
Type: SystemInt32
The speak slow request release time
minimumSpeakSlowRequest
Type: SystemInt32
The minimum speak slow requests
speakSlowSignallingReleaseTime
Type: SystemInt32
The speak slow signalling release time
enableConfigurationFromDesk
Type: SystemBoolean
This enables configuration from desk
selectedHeadphones
Type: System.Collections.GenericIList DcnmHeadphoneTypes
Gets or sets the selected headphones list.
See Also

Reference

DcnmInterpretationSettingsInfo Class
DcnmInterpretationSettingsInfo Overload


DcnmInterpretationSettingsInfo Properties

The DcnmInterpretationSettingsInfo type exposes the following members.

Properties
 | Name | Description
Public property | BetweenBoothInterpretationMode | Gets or sets the indication if interpretation between booths.
Public property | EnableConfigurationFromDesk | This enables configuration from desk.
Public property | FlashingMicrophoneOnEngaged | Gets or sets the indication if microphone flashing on engaged.
Public property | MeetingId | Gets or sets the identifier of the meeting.
Public property | MinimumSpeakSlowRequest | Gets or sets the minimum speak slow requests.
Public property | SelectedHeadphones | Gets or sets the selected headphones list.
Public property | SpeakSlowly | Gets or sets the indication if speak slowly enabled.
Public property | SpeakSlowRequestReleaseTime | Gets or sets the speak slow request release time.
Public property | SpeakSlowSignallingReleaseTime | Gets or sets the speak slow signalling release time.
Public property | WithinBoothEngagedIndication | Gets or sets the indication if engaged within booth.
Public property | WithinBoothInterpretationMode | Gets or sets the indication if interpretation within booth.
Top
See Also

Reference

DcnmInterpretationSettingsInfo Class


DcnmInterpretationSettingsInfo.BetweenBoothInterpretationMode Property

DcnmInterpretationSettingsInfoBetweenBoothInterpretationMode Property

Bosch Logo
Gets or sets the indication if interpretation between booths.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmInterpretationModeType BetweenBoothInterpretationMode { get; }
Public ReadOnly Property BetweenBoothInterpretationMode As DcnmInterpretationModeType
    Get
public:
property DcnmInterpretationModeType BetweenBoothInterpretationMode {
    DcnmInterpretationModeType get ();
}

Property Value

Type: DcnmInterpretationModeType
See Also

Reference

DcnmInterpretationSettingsInfo Class


DcnmInterpretationSettingsInfo.EnableConfigurationFromDesk Property

DcnmInterpretationSettingsInfoEnableConfigurationFromDesk Property

Bosch Logo
This enables configuration from desk.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool EnableConfigurationFromDesk { get; }
Public ReadOnly Property EnableConfigurationFromDesk As Boolean
    Get
public:
property bool EnableConfigurationFromDesk {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmInterpretationSettingsInfo Class


DcnmInterpretationSettingsInfo.FlashingMicrophoneOnEngaged Property

DcnmInterpretationSettingsInfoFlashingMicrophoneOnEngaged Property

Bosch Logo
Gets or sets the indication if microphone flashing on engaged.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool FlashingMicrophoneOnEngaged { get; }
Public ReadOnly Property FlashingMicrophoneOnEngaged As Boolean
    Get
public:
property bool FlashingMicrophoneOnEngaged {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmInterpretationSettingsInfo Class


DcnmInterpretationSettingsInfo.MeetingId Property

DcnmInterpretationSettingsInfoMeetingId Property

Gets or sets the identifier of the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid MeetingId { get; set; }
Public Property MeetingId As Guid
    Get
    Set
public:
property Guid MeetingId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmInterpretationSettingsInfo Class


DcnmInterpretationSettingsInfo.MinimumSpeakSlowRequest Property

DcnmInterpretationSettingsInfoMinimumSpeakSlowRequest Property

Bosch Logo
Gets or sets the minimum speak slow requests.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int MinimumSpeakSlowRequest { get; }
Public ReadOnly Property MinimumSpeakSlowRequest As Integer
    Get
public:
property int MinimumSpeakSlowRequest {
    int get ();
}

Property Value

Type: Int32
Remarks
Value between ranage SPEAKSLOW_MIN_REQUESTS and SPEAKSLOW_MAX_CONFIGVALUE
See Also

Reference

DcnmInterpretationSettingsInfo Class


DcnmInterpretationSettingsInfo.SelectedHeadphones Property

DcnmInterpretationSettingsInfoSelectedHeadphones Property

Gets or sets the selected headphones list.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<DcnmHeadphoneTypes> SelectedHeadphones { get; }
Public ReadOnly Property SelectedHeadphones As IList(Of DcnmHeadphoneTypes)
    Get
public:
property IList<DcnmHeadphoneTypes>^ SelectedHeadphones {
    IList<DcnmHeadphoneTypes>^ get ();
}

Property Value

Type: IList DcnmHeadphoneTypes
See Also

Reference

DcnmInterpretationSettingsInfo Class


DcnmInterpretationSettingsInfo.SpeakSlowly Property

DcnmInterpretationSettingsInfoSpeakSlowly Property

Gets or sets the indication if speak slowly enabled.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool SpeakSlowly { get; }
Public ReadOnly Property SpeakSlowly As Boolean
    Get
public:
property bool SpeakSlowly {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmInterpretationSettingsInfo Class


DcnmInterpretationSettingsInfo.SpeakSlowRequestReleaseTime Property

DcnmInterpretationSettingsInfoSpeakSlowRequestReleaseTime Property

Bosch Logo
Gets or sets the speak slow request release time.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int SpeakSlowRequestReleaseTime { get; }
Public ReadOnly Property SpeakSlowRequestReleaseTime As Integer
    Get
public:
property int SpeakSlowRequestReleaseTime {
    int get ();
}

Property Value

Type: Int32
Remarks
Value between ranage SPEAKSLOW_MIN_RELEASETIME and SPEAKSLOW_MAX_CONFIGVALUE
See Also

Reference

DcnmInterpretationSettingsInfo Class


DcnmInterpretationSettingsInfo.SpeakSlowSignallingReleaseTime Property

DcnmInterpretationSettingsInfoSpeakSlowSignallingReleaseTime Property

Bosch Logo
Gets or sets the speak slow signalling release time.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int SpeakSlowSignallingReleaseTime { get; }
Public ReadOnly Property SpeakSlowSignallingReleaseTime As Integer
    Get
public:
property int SpeakSlowSignallingReleaseTime {
    int get ();
}

Property Value

Type: Int32
Remarks
Value between ranage SPEAKSLOW_MIN_RELEASETIME and SPEAKSLOW_MAX_CONFIGVALUE
See Also

Reference

DcnmInterpretationSettingsInfo Class


DcnmInterpretationSettingsInfo.WithinBoothEngagedIndication Property

DcnmInterpretationSettingsInfoWithinBoothEngagedIndication Property

Bosch Logo
Gets or sets the indication if engaged within booth.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool WithinBoothEngagedIndication { get; }
Public ReadOnly Property WithinBoothEngagedIndication As Boolean
    Get
public:
property bool WithinBoothEngagedIndication {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmInterpretationSettingsInfo Class


DcnmInterpretationSettingsInfo.WithinBoothInterpretationMode Property

DcnmInterpretationSettingsInfoWithinBoothInterpretationMode Property

Bosch Logo
Gets or sets the indication if interpretation within booth.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmInterpretationModeType WithinBoothInterpretationMode { get; }
Public ReadOnly Property WithinBoothInterpretationMode As DcnmInterpretationModeType
    Get
public:
property DcnmInterpretationModeType WithinBoothInterpretationMode {
    DcnmInterpretationModeType get ();
}

Property Value

Type: DcnmInterpretationModeType
See Also

Reference

DcnmInterpretationSettingsInfo Class


DcnmInterpretationSettingsInfo Methods

The DcnmInterpretationSettingsInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmInterpretationSettingsInfo Class


DcnmLanguageInfo Class

Represents the language information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLanguageInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmLanguageInfo
Public Class DcnmLanguageInfo
public ref class DcnmLanguageInfo

The DcnmLanguageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmLanguageInfo(String, String, String, String, Boolean, Int32) | Constructor
Public method | DcnmLanguageInfo(Guid, String, String, String, String, Boolean, Int32) | Constructor
Top
Properties
 | Name | Description
Public property | Abbreviation | Gets the abbreviation of the language
Public property | EnLabel | Gets the english name of the language
Public property | LanguageId | Gets the identification of the language
Public property | OrderId | Gets the order of the language
Public property | OrgLabel | Gets the orginal name of the language
Public property | ShortAbbreviation | Gets the two letter abbreviation of the language
Public property | UserDefined | Gets the indication whether the languageis user defined
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmLanguageInfo Constructor

Overload List
 | Name | Description
Public method | DcnmLanguageInfo(String, String, String, String, Boolean, Int32) | Constructor
Public method | DcnmLanguageInfo(Guid, String, String, String, String, Boolean, Int32) | Constructor
Top
See Also

Reference

DcnmLanguageInfo Class


DcnmLanguageInfo Constructor (String, String, String, String, Boolean, Int32)

Constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmLanguageInfo(
    string abbreviation,
    string shortAbbreviation,
    string enLabel,
    string orgLabel,
    bool userDefined,
    int orderId
)
Public Sub New (
    abbreviation As String,
    shortAbbreviation As String,
    enLabel As String,
    orgLabel As String,
    userDefined As Boolean,
    orderId As Integer
)
public:
DcnmLanguageInfo(
    String^ abbreviation,
    String^ shortAbbreviation,
    String^ enLabel,
    String^ orgLabel,
    bool userDefined,
    int orderId
)

Parameters

abbreviation
Type: SystemString
The (three letter) abbreviation of the language. Must be unique.
shortAbbreviation
Type: SystemString
The (two letter) abbreviation of the language. Must be unique.
enLabel
Type: SystemString
The english name of the language.
orgLabel
Type: SystemString
The original name of the language.
userDefined
Type: SystemBoolean
Indication whether the language is user defined.
orderId
Type: SystemInt32
The order identifier of the language.
Exceptions
Exception | Condition
ArgumentException | If orderId is less than 1.
See Also

Reference

DcnmLanguageInfo Class
DcnmLanguageInfo Overload


DcnmLanguageInfo Constructor (Guid, String, String, String, String, Boolean, Int32)

Constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmLanguageInfo(
    Guid languageId,
    string abbreviation,
    string shortAbbreviation,
    string enLabel,
    string orgLabel,
    bool userDefined,
    int orderId
)
Public Sub New (
    languageId As Guid,
    abbreviation As String,
    shortAbbreviation As String,
    enLabel As String,
    orgLabel As String,
    userDefined As Boolean,
    orderId As Integer
)
public:
DcnmLanguageInfo(
    Guid languageId,
    String^ abbreviation,
    String^ shortAbbreviation,
    String^ enLabel,
    String^ orgLabel,
    bool userDefined,
    int orderId
)

Parameters

languageId
Type: SystemGuid
The identifier (Guid) of the language
abbreviation
Type: SystemString
The (three letter) abbreviation of the language. Must be unique.
shortAbbreviation
Type: SystemString
The (two letter) abbreviation of the language. Must be unique.
enLabel
Type: SystemString
The english name of the language
orgLabel
Type: SystemString
The original name of the languege
userDefined
Type: SystemBoolean
Indication whether the language is user defined.
orderId
Type: SystemInt32
volgorde parameter voor de taal.
Exceptions
Exception | Condition
ArgumentException | If orderId is less than 1.
See Also

Reference

DcnmLanguageInfo Class
DcnmLanguageInfo Overload


DcnmLanguageInfo Properties

The DcnmLanguageInfo type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviation | Gets the abbreviation of the language
Public property | EnLabel | Gets the english name of the language
Public property | LanguageId | Gets the identification of the language
Public property | OrderId | Gets the order of the language
Public property | OrgLabel | Gets the orginal name of the language
Public property | ShortAbbreviation | Gets the two letter abbreviation of the language
Public property | UserDefined | Gets the indication whether the languageis user defined
Top
See Also

Reference

DcnmLanguageInfo Class


DcnmLanguageInfo.Abbreviation Property

DcnmLanguageInfoAbbreviation Property

Gets the abbreviation of the language

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Abbreviation { get; }
Public ReadOnly Property Abbreviation As String
    Get
public:
property String^ Abbreviation {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmLanguageInfo Class


DcnmLanguageInfo.EnLabel Property

DcnmLanguageInfoEnLabel Property

Gets the english name of the language

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string EnLabel { get; }
Public ReadOnly Property EnLabel As String
    Get
public:
property String^ EnLabel {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmLanguageInfo Class


DcnmLanguageInfo.LanguageId Property

DcnmLanguageInfoLanguageId Property

Gets the identification of the language

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid LanguageId { get; }
Public ReadOnly Property LanguageId As Guid
    Get
public:
property Guid LanguageId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmLanguageInfo Class


DcnmLanguageInfo.OrderId Property

DcnmLanguageInfoOrderId Property

Gets the order of the language

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int OrderId { get; }
Public ReadOnly Property OrderId As Integer
    Get
public:
property int OrderId {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmLanguageInfo Class


DcnmLanguageInfo.OrgLabel Property

DcnmLanguageInfoOrgLabel Property

Gets the orginal name of the language

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string OrgLabel { get; }
Public ReadOnly Property OrgLabel As String
    Get
public:
property String^ OrgLabel {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmLanguageInfo Class


DcnmLanguageInfo.ShortAbbreviation Property

DcnmLanguageInfoShortAbbreviation Property

Gets the two letter abbreviation of the language

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string ShortAbbreviation { get; }
Public ReadOnly Property ShortAbbreviation As String
    Get
public:
property String^ ShortAbbreviation {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmLanguageInfo Class


DcnmLanguageInfo.UserDefined Property

DcnmLanguageInfoUserDefined Property

Gets the indication whether the languageis user defined

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool UserDefined { get; }
Public ReadOnly Property UserDefined As Boolean
    Get
public:
property bool UserDefined {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmLanguageInfo Class


DcnmLanguageInfo Methods

The DcnmLanguageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmLanguageInfo Class


DcnmLanguageSourceType Enumeration

Enumeration of all types of language sources.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmLanguageSourceType
Public Enumeration DcnmLanguageSourceType
public enum class DcnmLanguageSourceType
Members
Member name | Value | Description
Dicentis | 0 | DICENTIS
DcnNgOmi | 1 | DCN NG - OMI
Dante | 2 | Dante
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmLanguageStream Class

Audio stream source.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLanguageStream

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmLanguageStream
Public Class DcnmLanguageStream
public ref class DcnmLanguageStream

The DcnmLanguageStream type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmLanguageStream | Constructor.
Top
Properties
 | Name | Description
Public property | Address | Gets the language address.
Public property | IsSecure | Gets a value indicating whether this audio stream is secured.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmLanguageStream Constructor

Constructor.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmLanguageStream(
    string address,
    bool isSecure
)
Public Sub New (
    address As String,
    isSecure As Boolean
)
public:
DcnmLanguageStream(
    String^ address,
    bool isSecure
)

Parameters

address
Type: SystemString
The stream address.
isSecure
Type: SystemBoolean
Holds whether language is secure or not.
See Also

Reference

DcnmLanguageStream Class


DcnmLanguageStream Properties

The DcnmLanguageStream type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets the language address.
Public property | IsSecure | Gets a value indicating whether this audio stream is secured.
Top
See Also

Reference

DcnmLanguageStream Class


DcnmLanguageStream.Address Property

DcnmLanguageStreamAddress Property

Gets the language address.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The language address.
See Also

Reference

DcnmLanguageStream Class


DcnmLanguageStream.IsSecure Property

DcnmLanguageStreamIsSecure Property

Gets a value indicating whether this audio stream is secured.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsSecure { get; set; }
Public Property IsSecure As Boolean
    Get
    Set
public:
property bool IsSecure {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Is true when this audio stream is encrypted and is false otherwise.
See Also

Reference

DcnmLanguageStream Class


DcnmLanguageStream Methods

The DcnmLanguageStream type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmLanguageStream Class


DcnmLevelSensorType Enumeration

Enumeration of level sensor types.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmLevelSensorType
Public Enumeration DcnmLevelSensorType
public enum class DcnmLevelSensorType
Members
Member name | Value | Description
Loudspeaker | 0 | Loudspeaker level
Microphone | 1 | Microphone level
SoundReinforcement | 2 | Sound reinforcement or PA level
AnalogIn0 | 3 | APS analog input 1 level
AnalogIn1 | 4 | APS analog input 2 level
AnalogOut0 | 5 | APS analog output 1 level
AnalogOut1 | 6 | APS analog output 2 level
DanteIn0 | 7 | APS Dante input 1 level
DanteIn1 | 8 | APS Dante input 2 level
DanteOut0 | 9 | APS Dante output 1 level
DanteOut1 | 10 | APS Dante output 2 level
OmneoIn0 | 11 | APS Omneo input 1 level
OmneoIn1 | 12 | APS Omneo input 2 level
OmneoOut0 | 13 | APS Omneo output 1 level
OmneoOut1 | 14 | APS Omneo output 2 level
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmLicenseStateType Enumeration

Defines the license state types within the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmLicenseStateType
Public Enumeration DcnmLicenseStateType
public enum class DcnmLicenseStateType
Members
Member name | Value | Description
LicenseAbsent | 0 | The license in not present
LicenseApplied | 1 | The license is applied
ImpliedDisconnected | 2 | The license is derived from a not connected device
ImpliedConnected | 3 | The license is derived from a device and present (device is connected)
Remarks
The licnese state provides the state of the function based on licensing. The license can either be a bought license of be a derived license from an attached (specific) device. When the specific device is attached, the license state is depended on the connection state of that device. When disconnected, the license is present, but not operational.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmMajorityResult Class

Class holds majority results.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMajorityResult

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmMajorityResult
Public Class DcnmMajorityResult
public ref class DcnmMajorityResult

The DcnmMajorityResult type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmMajorityResult | Constructor.
Top
Properties
 | Name | Description
Public property | ComparisonOperator | Comparison operator used in expression.
Public property | DenominatorExpressionValue | Majority denominator expression evaluated value.
Public property | IsEnabled | Indicates whether majority is enabled.
Public property | NumeratorExpressionValue | Majority numerator expression evaluated value.
Public property | Status | Indicates majority status .
Public property | ThresholdExpressionValue | Evaluated majority threshold expression value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmMajorityResult Constructor

Constructor.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmMajorityResult(
    bool isEnabled,
    float numeratorValue,
    float denominatorValue,
    float thresholdValue,
    DcnmStatusType status,
    DcnmComparisonOperators comparisonOperators
)
Public Sub New (
    isEnabled As Boolean,
    numeratorValue As Single,
    denominatorValue As Single,
    thresholdValue As Single,
    status As DcnmStatusType,
    comparisonOperators As DcnmComparisonOperators
)
public:
DcnmMajorityResult(
    bool isEnabled,
    float numeratorValue,
    float denominatorValue,
    float thresholdValue,
    DcnmStatusType status,
    DcnmComparisonOperators comparisonOperators
)

Parameters

isEnabled
Type: SystemBoolean
Indicates whether majority is enabled.
numeratorValue
Type: SystemSingle
Evaluated numerator expression value.
denominatorValue
Type: SystemSingle
Evaluated denominator expression value.
thresholdValue
Type: SystemSingle
Evaluated majority threshold expression value.
status
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStatusType
Indicates majority status .
comparisonOperators
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmComparisonOperators
Comparison operator used in expression.
See Also

Reference

DcnmMajorityResult Class
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStatusType


DcnmMajorityResult Properties

The DcnmMajorityResult type exposes the following members.

Properties
 | Name | Description
Public property | ComparisonOperator | Comparison operator used in expression.
Public property | DenominatorExpressionValue | Majority denominator expression evaluated value.
Public property | IsEnabled | Indicates whether majority is enabled.
Public property | NumeratorExpressionValue | Majority numerator expression evaluated value.
Public property | Status | Indicates majority status .
Public property | ThresholdExpressionValue | Evaluated majority threshold expression value.
Top
See Also

Reference

DcnmMajorityResult Class


DcnmMajorityResult.ComparisonOperator Property

DcnmMajorityResultComparisonOperator Property

Comparison operator used in expression.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmComparisonOperators ComparisonOperator { get; }
Public ReadOnly Property ComparisonOperator As DcnmComparisonOperators
    Get
public:
property DcnmComparisonOperators ComparisonOperator {
    DcnmComparisonOperators get ();
}

Property Value

Type: DcnmComparisonOperators
See Also

Reference

DcnmMajorityResult Class


DcnmMajorityResult.DenominatorExpressionValue Property

DcnmMajorityResultDenominatorExpressionValue Property

Majority denominator expression evaluated value.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public float DenominatorExpressionValue { get; }
Public ReadOnly Property DenominatorExpressionValue As Single
    Get
public:
property float DenominatorExpressionValue {
    float get ();
}

Property Value

Type: Single
See Also

Reference

DcnmMajorityResult Class


DcnmMajorityResult.IsEnabled Property

DcnmMajorityResultIsEnabled Property

Indicates whether majority is enabled.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsEnabled { get; }
Public ReadOnly Property IsEnabled As Boolean
    Get
public:
property bool IsEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmMajorityResult Class


DcnmMajorityResult.NumeratorExpressionValue Property

DcnmMajorityResultNumeratorExpressionValue Property

Majority numerator expression evaluated value.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public float NumeratorExpressionValue { get; }
Public ReadOnly Property NumeratorExpressionValue As Single
    Get
public:
property float NumeratorExpressionValue {
    float get ();
}

Property Value

Type: Single
See Also

Reference

DcnmMajorityResult Class


DcnmMajorityResult.Status Property

DcnmMajorityResultStatus Property

Indicates majority status .

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmStatusType Status { get; }
Public ReadOnly Property Status As DcnmStatusType
    Get
public:
property DcnmStatusType Status {
    DcnmStatusType get ();
}

Property Value

Type: DcnmStatusType
See Also

Reference

DcnmMajorityResult Class
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStatusType


DcnmMajorityResult.ThresholdExpressionValue Property

DcnmMajorityResultThresholdExpressionValue Property

Evaluated majority threshold expression value.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public float ThresholdExpressionValue { get; }
Public ReadOnly Property ThresholdExpressionValue As Single
    Get
public:
property float ThresholdExpressionValue {
    float get ();
}

Property Value

Type: Single
See Also

Reference

DcnmMajorityResult Class


DcnmMajorityResult Methods

The DcnmMajorityResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmMajorityResult Class


DcnmMeetingBoothInfo Class

Class representinng the meeting booth information within a meeting
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMeetingBoothInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmMeetingBoothInfo
Public Class DcnmMeetingBoothInfo
public ref class DcnmMeetingBoothInfo

The DcnmMeetingBoothInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmMeetingBoothInfo | Initializes a new instance of the DcnmMeetingBoothInfo class
Top
Properties
 | Name | Description
Public property | AreaId | Gets the related area (booth) assigned for this meeting booth.
Public property | AutoRelay | Gets the indication whether the auto-relay option for this language
Public property | MeetingId | Gets or sets the related meeting of this Meeting booth.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

The meeting booth information defines the booth area used within the meeting to meeting languages.

Although multiple booth can provide the same meeting language, this information adds extra information for the booth (like the auto-relay option)

See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmMeetingBoothInfo Constructor

Initializes a new instance of the DcnmMeetingBoothInfo class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmMeetingBoothInfo(
    Guid meetingId,
    Guid areaId,
    bool autoRelay
)
Public Sub New (
    meetingId As Guid,
    areaId As Guid,
    autoRelay As Boolean
)
public:
DcnmMeetingBoothInfo(
    Guid meetingId,
    Guid areaId,
    bool autoRelay
)

Parameters

meetingId
Type: SystemGuid
Identifier of the meeting this booth is part of.
areaId
Type: SystemGuid
Identifier of the area assigned to this meeting booth.
autoRelay
Type: SystemBoolean
Auto relay.
See Also

Reference

DcnmMeetingBoothInfo Class


DcnmMeetingBoothInfo Properties

The DcnmMeetingBoothInfo type exposes the following members.

Properties
 | Name | Description
Public property | AreaId | Gets the related area (booth) assigned for this meeting booth.
Public property | AutoRelay | Gets the indication whether the auto-relay option for this language
Public property | MeetingId | Gets or sets the related meeting of this Meeting booth.
Top
See Also

Reference

DcnmMeetingBoothInfo Class


DcnmMeetingBoothInfo.AreaId Property

DcnmMeetingBoothInfoAreaId Property

Gets the related area (booth) assigned for this meeting booth.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid AreaId { get; }
Public ReadOnly Property AreaId As Guid
    Get
public:
property Guid AreaId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingBoothInfo Class


DcnmMeetingBoothInfo.AutoRelay Property

DcnmMeetingBoothInfoAutoRelay Property

Gets the indication whether the auto-relay option for this language

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AutoRelay { get; }
Public ReadOnly Property AutoRelay As Boolean
    Get
public:
property bool AutoRelay {
    bool get ();
}

Property Value

Type: Boolean
Remarks
In case the auto-relay option is activated, and in the related booth an interpretation is started on the B- or C- Output, any interpreter listening to the floor are switches (automatically) to the language produced on the B-output.
See Also

Reference

DcnmMeetingBoothInfo Class


DcnmMeetingBoothInfo.MeetingId Property

DcnmMeetingBoothInfoMeetingId Property

Gets or sets the related meeting of this Meeting booth.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid MeetingId { get; set; }
Public Property MeetingId As Guid
    Get
    Set
public:
property Guid MeetingId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingBoothInfo Class


DcnmMeetingBoothInfo Methods

The DcnmMeetingBoothInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmMeetingBoothInfo Class


DcnmMeetingDeskInfo Class

Class representing the prepared desk information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMeetingDeskInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmMeetingDeskInfo
Public Class DcnmMeetingDeskInfo
public ref class DcnmMeetingDeskInfo

The DcnmMeetingDeskInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmMeetingDeskInfo(Guid, Guid, Guid, Int32, ICollectionGuid, ICollectionGuid, DcnmHeadphoneTypes, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid) | Obsolete. Initializes a new instance of the DcnmMeetingDeskInfo class
Public method | DcnmMeetingDeskInfo(Guid, Guid, Guid, Int32, ICollectionGuid, ICollectionGuid, DcnmHeadphoneTypes, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Boolean) | Obsolete. Initializes a new instance of the DcnmMeetingDeskInfo class
Public method | DcnmMeetingDeskInfo(Guid, Guid, Guid, Int32, ICollectionGuid, ICollectionGuid, DcnmHeadphoneTypes, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Boolean, DcnmIDeskButtonFunctionType, DcnmIDeskButtonFunctionType, DcnmIDeskButtonFunctionType, IListDcnmIDeskButtonFunctionType, IListDcnmIDeskButtonFunctionType, IListDcnmIDeskButtonFunctionType) | Initializes a new instance of the DcnmMeetingDeskInfo class
Top
Properties
 | Name | Description
Public property | AudioVideoDelay | Gets the delay of the audio to be in sync with the video.
Public property | AutomaticMicrophoneSelection | Gets or sets a value indicating whether automatic microphone selection is enabled or not.
Public property | EButtonFunctionSet | Gets the button functions' set of E.
Public property | FButtonFunctionSet | Gets the button functions' set of F.
Public property | GButtonFunctionSet | Gets the button functions' set of G.
Public property | Headphone | Gets the headphone used for the Desk
Public property | LanguageIdOfOutputA | Gets the language used for the A-output on the Desk
Public property | MeetingId | Gets or sets the related meeting of this Meeting booth.
Public property | OutBLanguageId | Gets the language used for the B-Output.
Public property | OutCLanguageId | Gets the language used for the C-Output.
Public property | OutputLanguageSetB | Gets the language list for the B-output selection options
Public property | OutputLanguageSetC | Gets the language list for the C-output selection options
Public property | PreselectALanguageId | Gets the language used for the preselect A language.
Public property | PreselectBLanguageId | Gets the language used for the preselect B language.
Public property | PreselectCLanguageId | Gets the language used for the preselect C language.
Public property | PreselectDLanguageId | Gets the language used for the preselect D language.
Public property | PreselectEButtonFunction | Gets the button function used for preselect E button function.
Public property | PreselectELanguageId | Gets the language used for the preselect E language.
Public property | PreselectFButtonFunction | Gets the button function used for preselect F button function.
Public property | PreselectFLanguageId | Gets the language used for the preselect F language.
Public property | PreselectGButtonFunction | Gets the button function used for preselect G button function.
Public property | PreselectGLanguageId | Gets the language used for the preselect G language.
Public property | SeatId | Gets the related seat (Interpreter desk) assigned for this meeting desk.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmMeetingDeskInfo Constructor

Overload List
 | Name | Description
Public method | DcnmMeetingDeskInfo(Guid, Guid, Guid, Int32, ICollectionGuid, ICollectionGuid, DcnmHeadphoneTypes, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid) | Obsolete. Initializes a new instance of the DcnmMeetingDeskInfo class
Public method | DcnmMeetingDeskInfo(Guid, Guid, Guid, Int32, ICollectionGuid, ICollectionGuid, DcnmHeadphoneTypes, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Boolean) | Obsolete. Initializes a new instance of the DcnmMeetingDeskInfo class
Public method | DcnmMeetingDeskInfo(Guid, Guid, Guid, Int32, ICollectionGuid, ICollectionGuid, DcnmHeadphoneTypes, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Boolean, DcnmIDeskButtonFunctionType, DcnmIDeskButtonFunctionType, DcnmIDeskButtonFunctionType, IListDcnmIDeskButtonFunctionType, IListDcnmIDeskButtonFunctionType, IListDcnmIDeskButtonFunctionType) | Initializes a new instance of the DcnmMeetingDeskInfo class
Top
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo Constructor (Guid, Guid, Guid, Int32, ICollection(Guid), ICollection(Guid), DcnmHeadphoneTypes, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid)

DcnmMeetingDeskInfo Constructor (Guid, Guid, Guid, Int32, ICollectionGuid, ICollectionGuid, DcnmHeadphoneTypes, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid)

 Bosch Logo

Note: This API is now obsolete.

Initializes a new instance of the DcnmMeetingDeskInfo class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmMeetingDeskInfo(
    Guid meetingId,
    Guid seatId,
    Guid languageIdOfOutputA,
    int audioVideoDelay,
    ICollection<Guid> outputLanguageSetB,
    ICollection<Guid> outputLanguageSetC,
    DcnmHeadphoneTypes headphone,
    Guid outBLanguageId,
    Guid outCLanguageId,
    Guid preselectALanguageId,
    Guid preselectBLanguageId,
    Guid preselectCLanguageId,
    Guid preselectDLanguageId,
    Guid preselectELanguageId,
    Guid preselectFLanguageId,
    Guid preselectGLanguageId
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    meetingId As Guid,
    seatId As Guid,
    languageIdOfOutputA As Guid,
    audioVideoDelay As Integer,
    outputLanguageSetB As ICollection(Of Guid),
    outputLanguageSetC As ICollection(Of Guid),
    headphone As DcnmHeadphoneTypes,
    outBLanguageId As Guid,
    outCLanguageId As Guid,
    preselectALanguageId As Guid,
    preselectBLanguageId As Guid,
    preselectCLanguageId As Guid,
    preselectDLanguageId As Guid,
    preselectELanguageId As Guid,
    preselectFLanguageId As Guid,
    preselectGLanguageId As Guid
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmMeetingDeskInfo(
    Guid meetingId,
    Guid seatId,
    Guid languageIdOfOutputA,
    int audioVideoDelay,
    ICollection<Guid>^ outputLanguageSetB,
    ICollection<Guid>^ outputLanguageSetC,
    DcnmHeadphoneTypes headphone,
    Guid outBLanguageId,
    Guid outCLanguageId,
    Guid preselectALanguageId,
    Guid preselectBLanguageId,
    Guid preselectCLanguageId,
    Guid preselectDLanguageId,
    Guid preselectELanguageId,
    Guid preselectFLanguageId,
    Guid preselectGLanguageId
)

Parameters

meetingId
Type: SystemGuid
Identifier of the meeting this desk is part of.
seatId
Type: SystemGuid
Identifier of the seat assigned to this meeting desk.
languageIdOfOutputA
Type: SystemGuid
Identifier of the language related to the meeting desk.
audioVideoDelay
Type: SystemInt32
The delay of the audio to be in sync with the video.
outputLanguageSetB
Type: System.Collections.GenericICollection Guid
Language set for output B.
outputLanguageSetC
Type: System.Collections.GenericICollection Guid
Language set for output C.
headphone
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmHeadphoneTypes
Headphone used for meeting desk.
outBLanguageId
Type: SystemGuid
Language set for out B.
outCLanguageId
Type: SystemGuid
Language set for out C.
preselectALanguageId
Type: SystemGuid
Pre selected A Language.
preselectBLanguageId
Type: SystemGuid
Pre selected B Language.
preselectCLanguageId
Type: SystemGuid
Pre selected C Language.
preselectDLanguageId
Type: SystemGuid
Pre selected D Language.
preselectELanguageId
Type: SystemGuid
Pre selected E Language.
preselectFLanguageId
Type: SystemGuid
Pre selected F Language.
preselectGLanguageId
Type: SystemGuid
Pre selected G Language.
See Also

Reference

DcnmMeetingDeskInfo Class
DcnmMeetingDeskInfo Overload


DcnmMeetingDeskInfo Constructor (Guid, Guid, Guid, Int32, ICollection(Guid), ICollection(Guid), DcnmHeadphoneTypes, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Boolean)

DcnmMeetingDeskInfo Constructor (Guid, Guid, Guid, Int32, ICollectionGuid, ICollectionGuid, DcnmHeadphoneTypes, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Boolean)

 Bosch Logo

Note: This API is now obsolete.

Initializes a new instance of the DcnmMeetingDeskInfo class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmMeetingDeskInfo(
    Guid meetingId,
    Guid seatId,
    Guid languageIdOfOutputA,
    int audioVideoDelay,
    ICollection<Guid> outputLanguageSetB,
    ICollection<Guid> outputLanguageSetC,
    DcnmHeadphoneTypes headphone,
    Guid outBLanguageId,
    Guid outCLanguageId,
    Guid preselectALanguageId,
    Guid preselectBLanguageId,
    Guid preselectCLanguageId,
    Guid preselectDLanguageId,
    Guid preselectELanguageId,
    Guid preselectFLanguageId,
    Guid preselectGLanguageId,
    bool automaticMicrophoneSelection
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    meetingId As Guid,
    seatId As Guid,
    languageIdOfOutputA As Guid,
    audioVideoDelay As Integer,
    outputLanguageSetB As ICollection(Of Guid),
    outputLanguageSetC As ICollection(Of Guid),
    headphone As DcnmHeadphoneTypes,
    outBLanguageId As Guid,
    outCLanguageId As Guid,
    preselectALanguageId As Guid,
    preselectBLanguageId As Guid,
    preselectCLanguageId As Guid,
    preselectDLanguageId As Guid,
    preselectELanguageId As Guid,
    preselectFLanguageId As Guid,
    preselectGLanguageId As Guid,
    automaticMicrophoneSelection As Boolean
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmMeetingDeskInfo(
    Guid meetingId,
    Guid seatId,
    Guid languageIdOfOutputA,
    int audioVideoDelay,
    ICollection<Guid>^ outputLanguageSetB,
    ICollection<Guid>^ outputLanguageSetC,
    DcnmHeadphoneTypes headphone,
    Guid outBLanguageId,
    Guid outCLanguageId,
    Guid preselectALanguageId,
    Guid preselectBLanguageId,
    Guid preselectCLanguageId,
    Guid preselectDLanguageId,
    Guid preselectELanguageId,
    Guid preselectFLanguageId,
    Guid preselectGLanguageId,
    bool automaticMicrophoneSelection
)

Parameters

meetingId
Type: SystemGuid
Identifier of the meeting this desk is part of.
seatId
Type: SystemGuid
Identifier of the seat assigned to this meeting desk.
languageIdOfOutputA
Type: SystemGuid
Identifier of the language related to the meeting desk.
audioVideoDelay
Type: SystemInt32
The delay of the audio to be in sync with the video.
outputLanguageSetB
Type: System.Collections.GenericICollection Guid
Language set for output B.
outputLanguageSetC
Type: System.Collections.GenericICollection Guid
Language set for output C.
headphone
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmHeadphoneTypes
Headphone used for meeting desk.
outBLanguageId
Type: SystemGuid
Language set for out B.
outCLanguageId
Type: SystemGuid
Language set for out C.
preselectALanguageId
Type: SystemGuid
Pre selected A Language.
preselectBLanguageId
Type: SystemGuid
Pre selected B Language.
preselectCLanguageId
Type: SystemGuid
Pre selected C Language.
preselectDLanguageId
Type: SystemGuid
Pre selected D Language.
preselectELanguageId
Type: SystemGuid
Pre selected E Language.
preselectFLanguageId
Type: SystemGuid
Pre selected F Language.
preselectGLanguageId
Type: SystemGuid
Pre selected G Language.
automaticMicrophoneSelection
Type: SystemBoolean
Automatic microphone selection setting.
See Also

Reference

DcnmMeetingDeskInfo Class
DcnmMeetingDeskInfo Overload


DcnmMeetingDeskInfo Constructor (Guid, Guid, Guid, Int32, ICollection(Guid), ICollection(Guid), DcnmHeadphoneTypes, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Boolean, DcnmIDeskButtonFunctionType, DcnmIDeskButtonFunctionType, DcnmIDeskButtonFunctionType, IList(DcnmIDeskButtonFunctionType)

DcnmMeetingDeskInfo Constructor (Guid, Guid, Guid, Int32, ICollectionGuid, ICollectionGuid, DcnmHeadphoneTypes, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Guid, Boolean, DcnmIDeskButtonFunctionType, DcnmIDeskButtonFunctionType, DcnmIDeskButtonFunctionType, IListDcnmIDeskButtonFunctionType, IListDcnmIDeskButtonFunctionType, IListDcnmIDeskButtonFunctionType)

 Bosch Logo
Initializes a new instance of the DcnmMeetingDeskInfo class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmMeetingDeskInfo(
    Guid meetingId,
    Guid seatId,
    Guid languageIdOfOutputA,
    int audioVideoDelay,
    ICollection<Guid> outputLanguageSetB,
    ICollection<Guid> outputLanguageSetC,
    DcnmHeadphoneTypes headphone,
    Guid outBLanguageId,
    Guid outCLanguageId,
    Guid preselectALanguageId,
    Guid preselectBLanguageId,
    Guid preselectCLanguageId,
    Guid preselectDLanguageId,
    Guid preselectELanguageId,
    Guid preselectFLanguageId,
    Guid preselectGLanguageId,
    bool automaticMicrophoneSelection,
    DcnmIDeskButtonFunctionType preselectEButtonFunction,
    DcnmIDeskButtonFunctionType preselectFButtonFunction,
    DcnmIDeskButtonFunctionType preselectGButtonFunction,
    IList<DcnmIDeskButtonFunctionType> eButtonFunctionSet,
    IList<DcnmIDeskButtonFunctionType> fButtonFunctionSet,
    IList<DcnmIDeskButtonFunctionType> gButtonFunctionSet
)
Public Sub New (
    meetingId As Guid,
    seatId As Guid,
    languageIdOfOutputA As Guid,
    audioVideoDelay As Integer,
    outputLanguageSetB As ICollection(Of Guid),
    outputLanguageSetC As ICollection(Of Guid),
    headphone As DcnmHeadphoneTypes,
    outBLanguageId As Guid,
    outCLanguageId As Guid,
    preselectALanguageId As Guid,
    preselectBLanguageId As Guid,
    preselectCLanguageId As Guid,
    preselectDLanguageId As Guid,
    preselectELanguageId As Guid,
    preselectFLanguageId As Guid,
    preselectGLanguageId As Guid,
    automaticMicrophoneSelection As Boolean,
    preselectEButtonFunction As DcnmIDeskButtonFunctionType,
    preselectFButtonFunction As DcnmIDeskButtonFunctionType,
    preselectGButtonFunction As DcnmIDeskButtonFunctionType,
    eButtonFunctionSet As IList(Of DcnmIDeskButtonFunctionType),
    fButtonFunctionSet As IList(Of DcnmIDeskButtonFunctionType),
    gButtonFunctionSet As IList(Of DcnmIDeskButtonFunctionType)
)
public:
DcnmMeetingDeskInfo(
    Guid meetingId,
    Guid seatId,
    Guid languageIdOfOutputA,
    int audioVideoDelay,
    ICollection<Guid>^ outputLanguageSetB,
    ICollection<Guid>^ outputLanguageSetC,
    DcnmHeadphoneTypes headphone,
    Guid outBLanguageId,
    Guid outCLanguageId,
    Guid preselectALanguageId,
    Guid preselectBLanguageId,
    Guid preselectCLanguageId,
    Guid preselectDLanguageId,
    Guid preselectELanguageId,
    Guid preselectFLanguageId,
    Guid preselectGLanguageId,
    bool automaticMicrophoneSelection,
    DcnmIDeskButtonFunctionType preselectEButtonFunction,
    DcnmIDeskButtonFunctionType preselectFButtonFunction,
    DcnmIDeskButtonFunctionType preselectGButtonFunction,
    IList<DcnmIDeskButtonFunctionType>^ eButtonFunctionSet,
    IList<DcnmIDeskButtonFunctionType>^ fButtonFunctionSet,
    IList<DcnmIDeskButtonFunctionType>^ gButtonFunctionSet
)

Parameters

meetingId
Type: SystemGuid
Identifier of the meeting this desk is part of.
seatId
Type: SystemGuid
Identifier of the seat assigned to this meeting desk.
languageIdOfOutputA
Type: SystemGuid
Identifier of the language related to the meeting desk.
audioVideoDelay
Type: SystemInt32
The delay of the audio to be in sync with the video.
outputLanguageSetB
Type: System.Collections.GenericICollection Guid
Language set for output B.
outputLanguageSetC
Type: System.Collections.GenericICollection Guid
Language set for output C.
headphone
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmHeadphoneTypes
Headphone used for meeting desk.
outBLanguageId
Type: SystemGuid
Language set for out B.
outCLanguageId
Type: SystemGuid
Language set for out C.
preselectALanguageId
Type: SystemGuid
Pre selected A Language.
preselectBLanguageId
Type: SystemGuid
Pre selected B Language.
preselectCLanguageId
Type: SystemGuid
Pre selected C Language.
preselectDLanguageId
Type: SystemGuid
Pre selected D Language.
preselectELanguageId
Type: SystemGuid
Pre selected E Language.
preselectFLanguageId
Type: SystemGuid
Pre selected F Language.
preselectGLanguageId
Type: SystemGuid
Pre selected G Language.
automaticMicrophoneSelection
Type: SystemBoolean
Automatic microphone selection setting.
preselectEButtonFunction
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmIDeskButtonFunctionType
Pre select E button function
preselectFButtonFunction
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmIDeskButtonFunctionType
Pre select F button function
preselectGButtonFunction
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmIDeskButtonFunctionType
Pre select G button function
eButtonFunctionSet
Type: System.Collections.GenericIList DcnmIDeskButtonFunctionType
E Button functions set
fButtonFunctionSet
Type: System.Collections.GenericIList DcnmIDeskButtonFunctionType
F Button functions set
gButtonFunctionSet
Type: System.Collections.GenericIList DcnmIDeskButtonFunctionType
G Button functions set
See Also

Reference

DcnmMeetingDeskInfo Class
DcnmMeetingDeskInfo Overload


DcnmMeetingDeskInfo Properties

The DcnmMeetingDeskInfo type exposes the following members.

Properties
 | Name | Description
Public property | AudioVideoDelay | Gets the delay of the audio to be in sync with the video.
Public property | AutomaticMicrophoneSelection | Gets or sets a value indicating whether automatic microphone selection is enabled or not.
Public property | EButtonFunctionSet | Gets the button functions' set of E.
Public property | FButtonFunctionSet | Gets the button functions' set of F.
Public property | GButtonFunctionSet | Gets the button functions' set of G.
Public property | Headphone | Gets the headphone used for the Desk
Public property | LanguageIdOfOutputA | Gets the language used for the A-output on the Desk
Public property | MeetingId | Gets or sets the related meeting of this Meeting booth.
Public property | OutBLanguageId | Gets the language used for the B-Output.
Public property | OutCLanguageId | Gets the language used for the C-Output.
Public property | OutputLanguageSetB | Gets the language list for the B-output selection options
Public property | OutputLanguageSetC | Gets the language list for the C-output selection options
Public property | PreselectALanguageId | Gets the language used for the preselect A language.
Public property | PreselectBLanguageId | Gets the language used for the preselect B language.
Public property | PreselectCLanguageId | Gets the language used for the preselect C language.
Public property | PreselectDLanguageId | Gets the language used for the preselect D language.
Public property | PreselectEButtonFunction | Gets the button function used for preselect E button function.
Public property | PreselectELanguageId | Gets the language used for the preselect E language.
Public property | PreselectFButtonFunction | Gets the button function used for preselect F button function.
Public property | PreselectFLanguageId | Gets the language used for the preselect F language.
Public property | PreselectGButtonFunction | Gets the button function used for preselect G button function.
Public property | PreselectGLanguageId | Gets the language used for the preselect G language.
Public property | SeatId | Gets the related seat (Interpreter desk) assigned for this meeting desk.
Top
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.AudioVideoDelay Property

DcnmMeetingDeskInfoAudioVideoDelay Property

Gets the delay of the audio to be in sync with the video.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int AudioVideoDelay { get; set; }
Public Property AudioVideoDelay As Integer
    Get
    Set
public:
property int AudioVideoDelay {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
When a value is provided in this property the audio (floor) delay is automatically enabled and the interpreter gets the option to switch the floor audio between original (no delay) and in sync with video (delayed).
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.AutomaticMicrophoneSelection Property

DcnmMeetingDeskInfoAutomaticMicrophoneSelection Property

Gets or sets a value indicating whether automatic microphone selection is enabled or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AutomaticMicrophoneSelection { get; }
Public ReadOnly Property AutomaticMicrophoneSelection As Boolean
    Get
public:
property bool AutomaticMicrophoneSelection {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.EButtonFunctionSet Property

DcnmMeetingDeskInfoEButtonFunctionSet Property

Gets the button functions' set of E.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<DcnmIDeskButtonFunctionType> EButtonFunctionSet { get; }
Public ReadOnly Property EButtonFunctionSet As IList(Of DcnmIDeskButtonFunctionType)
    Get
public:
property IList<DcnmIDeskButtonFunctionType>^ EButtonFunctionSet {
    IList<DcnmIDeskButtonFunctionType>^ get ();
}

Property Value

Type: IList DcnmIDeskButtonFunctionType
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.FButtonFunctionSet Property

DcnmMeetingDeskInfoFButtonFunctionSet Property

Gets the button functions' set of F.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<DcnmIDeskButtonFunctionType> FButtonFunctionSet { get; }
Public ReadOnly Property FButtonFunctionSet As IList(Of DcnmIDeskButtonFunctionType)
    Get
public:
property IList<DcnmIDeskButtonFunctionType>^ FButtonFunctionSet {
    IList<DcnmIDeskButtonFunctionType>^ get ();
}

Property Value

Type: IList DcnmIDeskButtonFunctionType
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.GButtonFunctionSet Property

DcnmMeetingDeskInfoGButtonFunctionSet Property

Gets the button functions' set of G.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<DcnmIDeskButtonFunctionType> GButtonFunctionSet { get; }
Public ReadOnly Property GButtonFunctionSet As IList(Of DcnmIDeskButtonFunctionType)
    Get
public:
property IList<DcnmIDeskButtonFunctionType>^ GButtonFunctionSet {
    IList<DcnmIDeskButtonFunctionType>^ get ();
}

Property Value

Type: IList DcnmIDeskButtonFunctionType
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.Headphone Property

DcnmMeetingDeskInfoHeadphone Property

Gets the headphone used for the Desk

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmHeadphoneTypes Headphone { get; }
Public ReadOnly Property Headphone As DcnmHeadphoneTypes
    Get
public:
property DcnmHeadphoneTypes Headphone {
    DcnmHeadphoneTypes get ();
}

Property Value

Type: DcnmHeadphoneTypes
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.LanguageIdOfOutputA Property

DcnmMeetingDeskInfoLanguageIdOfOutputA Property

Gets the language used for the A-output on the Desk

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid LanguageIdOfOutputA { get; set; }
Public Property LanguageIdOfOutputA As Guid
    Get
    Set
public:
property Guid LanguageIdOfOutputA {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.MeetingId Property

DcnmMeetingDeskInfoMeetingId Property

Gets or sets the related meeting of this Meeting booth.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid MeetingId { get; set; }
Public Property MeetingId As Guid
    Get
    Set
public:
property Guid MeetingId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.OutBLanguageId Property

DcnmMeetingDeskInfoOutBLanguageId Property

Gets the language used for the B-Output.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid OutBLanguageId { get; }
Public ReadOnly Property OutBLanguageId As Guid
    Get
public:
property Guid OutBLanguageId {
    Guid get ();
}

Property Value

Type: Guid
Remarks
The IDesk will only show and enable this language on the B-output if the language ID specified for this field is present the the OutputLanguageSetB list.
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.OutCLanguageId Property

DcnmMeetingDeskInfoOutCLanguageId Property

Gets the language used for the C-Output.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid OutCLanguageId { get; }
Public ReadOnly Property OutCLanguageId As Guid
    Get
public:
property Guid OutCLanguageId {
    Guid get ();
}

Property Value

Type: Guid
Remarks
The IDesk will only show and enable this language on the C-output if the language ID specified for this field is present the the OutputLanguageSetC list.
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.OutputLanguageSetB Property

DcnmMeetingDeskInfoOutputLanguageSetB Property

Gets the language list for the B-output selection options

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public ICollection<Guid> OutputLanguageSetB { get; }
Public ReadOnly Property OutputLanguageSetB As ICollection(Of Guid)
    Get
public:
property ICollection<Guid>^ OutputLanguageSetB {
    ICollection<Guid>^ get ();
}

Property Value

Type: ICollection Guid
Remarks
When the list is empty by default the B-Output selection options is fixed to only the A-Output langauge.
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.OutputLanguageSetC Property

DcnmMeetingDeskInfoOutputLanguageSetC Property

Gets the language list for the C-output selection options

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public ICollection<Guid> OutputLanguageSetC { get; }
Public ReadOnly Property OutputLanguageSetC As ICollection(Of Guid)
    Get
public:
property ICollection<Guid>^ OutputLanguageSetC {
    ICollection<Guid>^ get ();
}

Property Value

Type: ICollection Guid
Remarks
When the list is empty by default the C-Ouput is disabled (no selection options).
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.PreselectALanguageId Property

DcnmMeetingDeskInfoPreselectALanguageId Property

Gets the language used for the preselect A language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid PreselectALanguageId { get; }
Public ReadOnly Property PreselectALanguageId As Guid
    Get
public:
property Guid PreselectALanguageId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.PreselectBLanguageId Property

DcnmMeetingDeskInfoPreselectBLanguageId Property

Gets the language used for the preselect B language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid PreselectBLanguageId { get; }
Public ReadOnly Property PreselectBLanguageId As Guid
    Get
public:
property Guid PreselectBLanguageId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.PreselectCLanguageId Property

DcnmMeetingDeskInfoPreselectCLanguageId Property

Gets the language used for the preselect C language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid PreselectCLanguageId { get; }
Public ReadOnly Property PreselectCLanguageId As Guid
    Get
public:
property Guid PreselectCLanguageId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.PreselectDLanguageId Property

DcnmMeetingDeskInfoPreselectDLanguageId Property

Gets the language used for the preselect D language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid PreselectDLanguageId { get; }
Public ReadOnly Property PreselectDLanguageId As Guid
    Get
public:
property Guid PreselectDLanguageId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.PreselectEButtonFunction Property

DcnmMeetingDeskInfoPreselectEButtonFunction Property

Gets the button function used for preselect E button function.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmIDeskButtonFunctionType PreselectEButtonFunction { get; }
Public ReadOnly Property PreselectEButtonFunction As DcnmIDeskButtonFunctionType
    Get
public:
property DcnmIDeskButtonFunctionType PreselectEButtonFunction {
    DcnmIDeskButtonFunctionType get ();
}

Property Value

Type: DcnmIDeskButtonFunctionType
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.PreselectELanguageId Property

DcnmMeetingDeskInfoPreselectELanguageId Property

Gets the language used for the preselect E language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid PreselectELanguageId { get; }
Public ReadOnly Property PreselectELanguageId As Guid
    Get
public:
property Guid PreselectELanguageId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.PreselectFButtonFunction Property

DcnmMeetingDeskInfoPreselectFButtonFunction Property

Gets the button function used for preselect F button function.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmIDeskButtonFunctionType PreselectFButtonFunction { get; }
Public ReadOnly Property PreselectFButtonFunction As DcnmIDeskButtonFunctionType
    Get
public:
property DcnmIDeskButtonFunctionType PreselectFButtonFunction {
    DcnmIDeskButtonFunctionType get ();
}

Property Value

Type: DcnmIDeskButtonFunctionType
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.PreselectFLanguageId Property

DcnmMeetingDeskInfoPreselectFLanguageId Property

Gets the language used for the preselect F language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid PreselectFLanguageId { get; }
Public ReadOnly Property PreselectFLanguageId As Guid
    Get
public:
property Guid PreselectFLanguageId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.PreselectGButtonFunction Property

DcnmMeetingDeskInfoPreselectGButtonFunction Property

Gets the button function used for preselect G button function.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmIDeskButtonFunctionType PreselectGButtonFunction { get; }
Public ReadOnly Property PreselectGButtonFunction As DcnmIDeskButtonFunctionType
    Get
public:
property DcnmIDeskButtonFunctionType PreselectGButtonFunction {
    DcnmIDeskButtonFunctionType get ();
}

Property Value

Type: DcnmIDeskButtonFunctionType
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.PreselectGLanguageId Property

DcnmMeetingDeskInfoPreselectGLanguageId Property

Gets the language used for the preselect G language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid PreselectGLanguageId { get; }
Public ReadOnly Property PreselectGLanguageId As Guid
    Get
public:
property Guid PreselectGLanguageId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo.SeatId Property

DcnmMeetingDeskInfoSeatId Property

Gets the related seat (Interpreter desk) assigned for this meeting desk.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid SeatId { get; }
Public ReadOnly Property SeatId As Guid
    Get
public:
property Guid SeatId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingDeskInfo Methods

The DcnmMeetingDeskInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmMeetingDeskInfo Class


DcnmMeetingLanguageInfo Class

Class representing the meeting language information within a meeting.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMeetingLanguageInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmMeetingLanguageInfo
Public Class DcnmMeetingLanguageInfo
public ref class DcnmMeetingLanguageInfo

The DcnmMeetingLanguageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmMeetingLanguageInfo(DcnmMeetingLanguageInfo) | Copy constructor
Public method | DcnmMeetingLanguageInfo(Guid, Guid) | Obsolete. Constructor
Public method | DcnmMeetingLanguageInfo(Guid, Guid, DcnmLanguageSourceType, Boolean, Int32) | Obsolete. Constructor
Public method | DcnmMeetingLanguageInfo(Guid, Guid, DcnmLanguageSourceType, Boolean, Int32, Boolean, Single, Boolean, Boolean) | Constructor
Top
Properties
 | Name | Description
Public property | LanguageId | Gets or sets the identifier of the language supported by the system.
Public property | LanguageSourceType | Gets or sets the type of language source.
 | MaximumStream2Headroom | The maximum headroom value for language stream 2.
Public property | MeetingId | Gets the meeting where the language is related to.
 | MinimumStream2Headroom | The minimum headroom value for language stream 2.
Public property | OrderNumber | Gets or set the order number.
Public property | OutputToDante | Gets or sets the indication if the interpretation of this meeting language should be sent to Dante also.
Public property | Stream2Enable | Enable or disable the second language stream
Public property | Stream2FloorFill | Enable of disable floor filling for the second language stream.
Public property | Stream2Headroom | Get or set the audio headroom in dB for the second language stream.
Public property | Stream2OutputToDante | Set to true in order to transmit the second language stream over DANTE instead of OMNEO.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmMeetingLanguageInfo Constructor

Overload List
 | Name | Description
Public method | DcnmMeetingLanguageInfo(DcnmMeetingLanguageInfo) | Copy constructor
Public method | DcnmMeetingLanguageInfo(Guid, Guid) | Obsolete. Constructor
Public method | DcnmMeetingLanguageInfo(Guid, Guid, DcnmLanguageSourceType, Boolean, Int32) | Obsolete. Constructor
Public method | DcnmMeetingLanguageInfo(Guid, Guid, DcnmLanguageSourceType, Boolean, Int32, Boolean, Single, Boolean, Boolean) | Constructor
Top
See Also

Reference

DcnmMeetingLanguageInfo Class


DcnmMeetingLanguageInfo Constructor (DcnmMeetingLanguageInfo)

Copy constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmMeetingLanguageInfo(
    DcnmMeetingLanguageInfo other
)
Public Sub New (
    other As DcnmMeetingLanguageInfo
)
public:
DcnmMeetingLanguageInfo(
    DcnmMeetingLanguageInfo^ other
)

Parameters

other
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMeetingLanguageInfo
The other class to copy from
See Also

Reference

DcnmMeetingLanguageInfo Class
DcnmMeetingLanguageInfo Overload


DcnmMeetingLanguageInfo Constructor (Guid, Guid)

Note: This API is now obsolete.

Constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This constructor is deprecated, please use the constructor with the stream2 parameters instead.")]
public DcnmMeetingLanguageInfo(
    Guid meetingId,
    Guid languageId
)
<ObsoleteAttribute("This constructor is deprecated, please use the constructor with the stream2 parameters instead.")>
Public Sub New (
    meetingId As Guid,
    languageId As Guid
)
public:
[ObsoleteAttribute(L"This constructor is deprecated, please use the constructor with the stream2 parameters instead.")]
DcnmMeetingLanguageInfo(
    Guid meetingId,
    Guid languageId
)

Parameters

meetingId
Type: SystemGuid
The identification of the meeting.
languageId
Type: SystemGuid
The identifier of the language supported by the system.
Remarks
This constructor is deprecated, please use DcnmMeetingLanguageInfo(Guid, Guid, DcnmLanguageSourceType, Boolean, Int32, Boolean, Single, Boolean, Boolean) instead.
See Also

Reference

DcnmMeetingLanguageInfo Class
DcnmMeetingLanguageInfo Overload


DcnmMeetingLanguageInfo Constructor (Guid, Guid, DcnmLanguageSourceType, Boolean, Int32)

Note: This API is now obsolete.

Constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This constructor is deprecated, please use the constructor with the stream2 parameters instead.")]
public DcnmMeetingLanguageInfo(
    Guid meetingId,
    Guid languageId,
    DcnmLanguageSourceType languageSourceType,
    bool outputToDante,
    int orderNumber
)
<ObsoleteAttribute("This constructor is deprecated, please use the constructor with the stream2 parameters instead.")>
Public Sub New (
    meetingId As Guid,
    languageId As Guid,
    languageSourceType As DcnmLanguageSourceType,
    outputToDante As Boolean,
    orderNumber As Integer
)
public:
[ObsoleteAttribute(L"This constructor is deprecated, please use the constructor with the stream2 parameters instead.")]
DcnmMeetingLanguageInfo(
    Guid meetingId,
    Guid languageId,
    DcnmLanguageSourceType languageSourceType,
    bool outputToDante,
    int orderNumber
)

Parameters

meetingId
Type: SystemGuid
The identification of the meeting.
languageId
Type: SystemGuid
The identifier of the language supported by the system.
languageSourceType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLanguageSourceType
Type of language source. Possible values are: DcnmLanguageSourceType
outputToDante
Type: SystemBoolean
Indication if the interpretation of this meeting language should be sent to Dante also.
orderNumber
Type: SystemInt32
Order number.
Remarks
This constructor is deprecated, please use DcnmMeetingLanguageInfo(Guid, Guid, DcnmLanguageSourceType, Boolean, Int32, Boolean, Single, Boolean, Boolean) instead.
See Also

Reference

DcnmMeetingLanguageInfo Class
DcnmMeetingLanguageInfo Overload


DcnmMeetingLanguageInfo Constructor (Guid, Guid, DcnmLanguageSourceType, Boolean, Int32, Boolean, Single, Boolean, Boolean)

Constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmMeetingLanguageInfo(
    Guid meetingId,
    Guid languageId,
    DcnmLanguageSourceType languageSourceType,
    bool outputToDante,
    int orderNumber,
    bool stream2Enable,
    float stream2Headroom,
    bool stream2OutputToDante,
    bool stream2FloorFill
)
Public Sub New (
    meetingId As Guid,
    languageId As Guid,
    languageSourceType As DcnmLanguageSourceType,
    outputToDante As Boolean,
    orderNumber As Integer,
    stream2Enable As Boolean,
    stream2Headroom As Single,
    stream2OutputToDante As Boolean,
    stream2FloorFill As Boolean
)
public:
DcnmMeetingLanguageInfo(
    Guid meetingId,
    Guid languageId,
    DcnmLanguageSourceType languageSourceType,
    bool outputToDante,
    int orderNumber,
    bool stream2Enable,
    float stream2Headroom,
    bool stream2OutputToDante,
    bool stream2FloorFill
)

Parameters

meetingId
Type: SystemGuid
The identification of the meeting.
languageId
Type: SystemGuid
The identifier of the language supported by the system.
languageSourceType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLanguageSourceType
Type of language source. Possible values are: DcnmLanguageSourceType
outputToDante
Type: SystemBoolean
Indication if the interpretation of this meeting language should be sent to Dante also.
orderNumber
Type: SystemInt32
Order number.
stream2Enable
Type: SystemBoolean
Enable the second language stream.
stream2Headroom
Type: SystemSingle
The signal headroom in dB for the second language stream.
stream2OutputToDante
Type: SystemBoolean
Transmit the second language stream over DANTE instead of OMNEO.
stream2FloorFill
Type: SystemBoolean
Enable or disable floor copy on the second language stream.
See Also

Reference

DcnmMeetingLanguageInfo Class
DcnmMeetingLanguageInfo Overload


DcnmMeetingLanguageInfo Properties

The DcnmMeetingLanguageInfo type exposes the following members.

Properties
 | Name | Description
Public property | LanguageId | Gets or sets the identifier of the language supported by the system.
Public property | LanguageSourceType | Gets or sets the type of language source.
 | MaximumStream2Headroom | The maximum headroom value for language stream 2.
Public property | MeetingId | Gets the meeting where the language is related to.
 | MinimumStream2Headroom | The minimum headroom value for language stream 2.
Public property | OrderNumber | Gets or set the order number.
Public property | OutputToDante | Gets or sets the indication if the interpretation of this meeting language should be sent to Dante also.
Public property | Stream2Enable | Enable or disable the second language stream
Public property | Stream2FloorFill | Enable of disable floor filling for the second language stream.
Public property | Stream2Headroom | Get or set the audio headroom in dB for the second language stream.
Public property | Stream2OutputToDante | Set to true in order to transmit the second language stream over DANTE instead of OMNEO.
Top
See Also

Reference

DcnmMeetingLanguageInfo Class


DcnmMeetingLanguageInfo.LanguageId Property

DcnmMeetingLanguageInfoLanguageId Property

Gets or sets the identifier of the language supported by the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid LanguageId { get; set; }
Public Property LanguageId As Guid
    Get
    Set
public:
property Guid LanguageId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
Remarks
When multiple booths are assigned to the same language, all the booths work together for the same language.
See Also

Reference

DcnmMeetingLanguageInfo Class


DcnmMeetingLanguageInfo.LanguageSourceType Property

DcnmMeetingLanguageInfoLanguageSourceType Property

Gets or sets the type of language source.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmLanguageSourceType LanguageSourceType { get; set; }
Public Property LanguageSourceType As DcnmLanguageSourceType
    Get
    Set
public:
property DcnmLanguageSourceType LanguageSourceType {
    DcnmLanguageSourceType get ();
    void set (DcnmLanguageSourceType value);
}

Property Value

Type: DcnmLanguageSourceType
See Also

Reference

DcnmMeetingLanguageInfo Class


DcnmMeetingLanguageInfo.MaximumStream2Headroom Property

DcnmMeetingLanguageInfoMaximumStream2Headroom Property

The maximum headroom value for language stream 2.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static int MaximumStream2Headroom { get; }
Public Shared ReadOnly Property MaximumStream2Headroom As Integer
    Get
public:
static property int MaximumStream2Headroom {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmMeetingLanguageInfo Class


DcnmMeetingLanguageInfo.MeetingId Property

DcnmMeetingLanguageInfoMeetingId Property

Gets the meeting where the language is related to.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid MeetingId { get; set; }
Public Property MeetingId As Guid
    Get
    Set
public:
property Guid MeetingId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingLanguageInfo Class


DcnmMeetingLanguageInfo.MinimumStream2Headroom Property

DcnmMeetingLanguageInfoMinimumStream2Headroom Property

The minimum headroom value for language stream 2.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static int MinimumStream2Headroom { get; }
Public Shared ReadOnly Property MinimumStream2Headroom As Integer
    Get
public:
static property int MinimumStream2Headroom {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmMeetingLanguageInfo Class


DcnmMeetingLanguageInfo.OrderNumber Property

DcnmMeetingLanguageInfoOrderNumber Property

Gets or set the order number.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int OrderNumber { get; set; }
Public Property OrderNumber As Integer
    Get
    Set
public:
property int OrderNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DcnmMeetingLanguageInfo Class


DcnmMeetingLanguageInfo.OutputToDante Property

DcnmMeetingLanguageInfoOutputToDante Property

Gets or sets the indication if the interpretation of this meeting language should be sent to Dante also.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool OutputToDante { get; set; }
Public Property OutputToDante As Boolean
    Get
    Set
public:
property bool OutputToDante {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DcnmMeetingLanguageInfo Class


DcnmMeetingLanguageInfo.Stream2Enable Property

DcnmMeetingLanguageInfoStream2Enable Property

Enable or disable the second language stream

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool Stream2Enable { get; set; }
Public Property Stream2Enable As Boolean
    Get
    Set
public:
property bool Stream2Enable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DcnmMeetingLanguageInfo Class


DcnmMeetingLanguageInfo.Stream2FloorFill Property

DcnmMeetingLanguageInfoStream2FloorFill Property

Enable of disable floor filling for the second language stream.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool Stream2FloorFill { get; set; }
Public Property Stream2FloorFill As Boolean
    Get
    Set
public:
property bool Stream2FloorFill {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DcnmMeetingLanguageInfo Class


DcnmMeetingLanguageInfo.Stream2Headroom Property

DcnmMeetingLanguageInfoStream2Headroom Property

Get or set the audio headroom in dB for the second language stream.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public float Stream2Headroom { get; set; }
Public Property Stream2Headroom As Single
    Get
    Set
public:
property float Stream2Headroom {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

DcnmMeetingLanguageInfo Class


DcnmMeetingLanguageInfo.Stream2OutputToDante Property

DcnmMeetingLanguageInfoStream2OutputToDante Property

Set to true in order to transmit the second language stream over DANTE instead of OMNEO.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool Stream2OutputToDante { get; set; }
Public Property Stream2OutputToDante As Boolean
    Get
    Set
public:
property bool Stream2OutputToDante {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DcnmMeetingLanguageInfo Class


DcnmMeetingLanguageInfo Methods

The DcnmMeetingLanguageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmMeetingLanguageInfo Class


DcnmMeetingPreparationInfo Class

Container holding the information of a meeting.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMeetingPreparationInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmMeetingPreparationInfo
Public Class DcnmMeetingPreparationInfo
public ref class DcnmMeetingPreparationInfo

The DcnmMeetingPreparationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Guid) | Obsolete. Deprecated constructor...
Public method | DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Guid, DcnmIdentificationSetting) | Obsolete. Deprecated constructor...
Public method | DcnmMeetingPreparationInfo(String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid) | Obsolete. Deprecated constructor...
Public method | DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid) | Obsolete. Deprecated constructor...
Public method | DcnmMeetingPreparationInfo(String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationSetting) | Obsolete. Deprecated constructor...
Public method | DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationSetting) | Obsolete. Deprecated constructor...
Public method | DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationSetting, Boolean) | Obsolete. Deprecated constructor...
Public method | DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationMethod, DcnmVerificationMethod, Boolean, Boolean) | Obsolete. Constructor...
Public method | DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationMethod, DcnmVerificationMethod, Boolean, Boolean, DcnmQuorumInfo) | Constructor...
Top
Properties
 | Name | Description
Public property | AutoOpenOnActivate | Open the meeting on activation.
Public property | AutoStartAgendaOnOpen | Start the agenda on meeting open.
Public property | DefaultDiscussionId | The default discussion for the meeting.
Public property | Description | The description of the meeting.
Public property | DocumentationRef | The link to meeting specific documentation.
Public property | FixedSeating | Flag to indicate if participants are allowed to be seated only at the assigned seat.
Public property | IdentificationMethod | The identification mode for the meeting.
Public property | IdentificationSetting | The identification setting for the meeting.
Public property | MeetingEndDate | The end date of the meeting.
Public property | MeetingId | The ID of the meeting.
Public property | MeetingStartDate | The start date of the meeting.
Public property | QuorumInfo | The quorum information for the meeting.
Public property | Title | The title of the meeting.
Public property | UseDefaultMeetingInterpretationSettings | Flag to check whether to use default Interpretation settings for meeting.
Public property | VerificationMethod | The verification mode for the meeting.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
MEETING_DEFAULT_AUTO_OPEN_ON_ACTIVATE | Default value for automatically opening meeting on activation.
MEETING_DEFAULT_AUTO_START_AGENDA_ON_OPEN | Default value for automatically start agenda on meeting open.
MEETING_DEFAULT_INTERPRETATION_SETTINGS | Default value for default interpretation settings on meeting creation.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmMeetingPreparationInfo Constructor

Overload List
 | Name | Description
Public method | DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Guid) | Obsolete. Deprecated constructor...
Public method | DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Guid, DcnmIdentificationSetting) | Obsolete. Deprecated constructor...
Public method | DcnmMeetingPreparationInfo(String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid) | Obsolete. Deprecated constructor...
Public method | DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid) | Obsolete. Deprecated constructor...
Public method | DcnmMeetingPreparationInfo(String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationSetting) | Obsolete. Deprecated constructor...
Public method | DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationSetting) | Obsolete. Deprecated constructor...
Public method | DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationSetting, Boolean) | Obsolete. Deprecated constructor...
Public method | DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationMethod, DcnmVerificationMethod, Boolean, Boolean) | Obsolete. Constructor...
Public method | DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationMethod, DcnmVerificationMethod, Boolean, Boolean, DcnmQuorumInfo) | Constructor...
Top
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo Constructor (Guid, String, String, DateTime, DateTime, Uri, Guid)

Note: This API is now obsolete.

Deprecated constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with quorum  field")]
public DcnmMeetingPreparationInfo(
    Guid meetingId,
    string title,
    string description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri documentationRef,
    Guid defaultDiscussionId
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with quorum  field")>
Public Sub New (
    meetingId As Guid,
    title As String,
    description As String,
    meetingStartDate As DateTime,
    meetingEndDate As DateTime,
    documentationRef As Uri,
    defaultDiscussionId As Guid
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with quorum  field")]
DcnmMeetingPreparationInfo(
    Guid meetingId,
    String^ title,
    String^ description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri^ documentationRef,
    Guid defaultDiscussionId
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting.
title
Type: SystemString
The title of the meeting.
description
Type: SystemString
The description of the meeting.
meetingStartDate
Type: SystemDateTime
The start date of the meeting.
meetingEndDate
Type: SystemDateTime
The end date of the meeting.
documentationRef
Type: SystemUri
The link to meeting specific documentation.
defaultDiscussionId
Type: SystemGuid
The default discussion for the meeting.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationMethod, DcnmVerificationMethod, Boolean, Boolean, DcnmQuorumInfo) instead.
See Also

Reference

DcnmMeetingPreparationInfo Class
DcnmMeetingPreparationInfo Overload


DcnmMeetingPreparationInfo Constructor (Guid, String, String, DateTime, DateTime, Uri, Guid, DcnmIdentificationSetting)

Note: This API is now obsolete.

Deprecated constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with quorum field")]
public DcnmMeetingPreparationInfo(
    Guid meetingId,
    string title,
    string description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri documentationRef,
    Guid defaultDiscussionId,
    DcnmIdentificationSetting identificationSetting
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with quorum field")>
Public Sub New (
    meetingId As Guid,
    title As String,
    description As String,
    meetingStartDate As DateTime,
    meetingEndDate As DateTime,
    documentationRef As Uri,
    defaultDiscussionId As Guid,
    identificationSetting As DcnmIdentificationSetting
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with quorum field")]
DcnmMeetingPreparationInfo(
    Guid meetingId,
    String^ title,
    String^ description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri^ documentationRef,
    Guid defaultDiscussionId,
    DcnmIdentificationSetting identificationSetting
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting.
title
Type: SystemString
The title of the meeting.
description
Type: SystemString
The description of the meeting.
meetingStartDate
Type: SystemDateTime
The start date of the meeting.
meetingEndDate
Type: SystemDateTime
The end date of the meeting.
documentationRef
Type: SystemUri
The link to meeting specific documentation.
defaultDiscussionId
Type: SystemGuid
The default discussion for the meeting.
identificationSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmIdentificationSetting
The identification setting for the meeting.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationMethod, DcnmVerificationMethod, Boolean, Boolean, DcnmQuorumInfo) instead.
See Also

Reference

DcnmMeetingPreparationInfo Class
DcnmMeetingPreparationInfo Overload


DcnmMeetingPreparationInfo Constructor (String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid)

Note: This API is now obsolete.

Deprecated constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with quorum field")]
public DcnmMeetingPreparationInfo(
    string title,
    string description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri documentationRef,
    bool autoOpenOnActivate,
    bool autoStartAgendaOnOpen,
    Guid defaultDiscussionId
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with quorum field")>
Public Sub New (
    title As String,
    description As String,
    meetingStartDate As DateTime,
    meetingEndDate As DateTime,
    documentationRef As Uri,
    autoOpenOnActivate As Boolean,
    autoStartAgendaOnOpen As Boolean,
    defaultDiscussionId As Guid
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with quorum field")]
DcnmMeetingPreparationInfo(
    String^ title,
    String^ description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri^ documentationRef,
    bool autoOpenOnActivate,
    bool autoStartAgendaOnOpen,
    Guid defaultDiscussionId
)

Parameters

title
Type: SystemString
The title of the meeting.
description
Type: SystemString
The description of the meeting.
meetingStartDate
Type: SystemDateTime
The meeting start date of the meeting.
meetingEndDate
Type: SystemDateTime
The meeting end date of the meeting.
documentationRef
Type: SystemUri
The link to meeting specific documentation.
autoOpenOnActivate
Type: SystemBoolean
Open the meeting on activation.
autoStartAgendaOnOpen
Type: SystemBoolean
Start the agenda on meeting open.
defaultDiscussionId
Type: SystemGuid
The default discussion for the meeting.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationMethod, DcnmVerificationMethod, Boolean, Boolean, DcnmQuorumInfo) instead.
See Also

Reference

DcnmMeetingPreparationInfo Class
DcnmMeetingPreparationInfo Overload


DcnmMeetingPreparationInfo Constructor (Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid)

Note: This API is now obsolete.

Deprecated constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with quorum field")]
public DcnmMeetingPreparationInfo(
    Guid meetingId,
    string title,
    string description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri documentationRef,
    bool autoOpenOnActivate,
    bool autoStartAgendaOnOpen,
    Guid defaultDiscussionId
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with quorum field")>
Public Sub New (
    meetingId As Guid,
    title As String,
    description As String,
    meetingStartDate As DateTime,
    meetingEndDate As DateTime,
    documentationRef As Uri,
    autoOpenOnActivate As Boolean,
    autoStartAgendaOnOpen As Boolean,
    defaultDiscussionId As Guid
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with quorum field")]
DcnmMeetingPreparationInfo(
    Guid meetingId,
    String^ title,
    String^ description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri^ documentationRef,
    bool autoOpenOnActivate,
    bool autoStartAgendaOnOpen,
    Guid defaultDiscussionId
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting.
title
Type: SystemString
The title of the meeting.
description
Type: SystemString
The description of the meeting.
meetingStartDate
Type: SystemDateTime
The start date of the meeting.
meetingEndDate
Type: SystemDateTime
The end date of the meeting.
documentationRef
Type: SystemUri
The link to meeting specific documentation.
autoOpenOnActivate
Type: SystemBoolean
Open the meeting on activation.
autoStartAgendaOnOpen
Type: SystemBoolean
Start the agenda on meeting open.
defaultDiscussionId
Type: SystemGuid
The default discussion for the meeting.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationMethod, DcnmVerificationMethod, Boolean, Boolean, DcnmQuorumInfo) instead.
See Also

Reference

DcnmMeetingPreparationInfo Class
DcnmMeetingPreparationInfo Overload


DcnmMeetingPreparationInfo Constructor (String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationSetting)

Note: This API is now obsolete.

Deprecated constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with quorum field")]
public DcnmMeetingPreparationInfo(
    string title,
    string description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri documentationRef,
    bool autoOpenOnActivate,
    bool autoStartAgendaOnOpen,
    Guid defaultDiscussionId,
    DcnmIdentificationSetting identificationSetting
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with quorum field")>
Public Sub New (
    title As String,
    description As String,
    meetingStartDate As DateTime,
    meetingEndDate As DateTime,
    documentationRef As Uri,
    autoOpenOnActivate As Boolean,
    autoStartAgendaOnOpen As Boolean,
    defaultDiscussionId As Guid,
    identificationSetting As DcnmIdentificationSetting
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with quorum field")]
DcnmMeetingPreparationInfo(
    String^ title,
    String^ description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri^ documentationRef,
    bool autoOpenOnActivate,
    bool autoStartAgendaOnOpen,
    Guid defaultDiscussionId,
    DcnmIdentificationSetting identificationSetting
)

Parameters

title
Type: SystemString
The title of the meeting.
description
Type: SystemString
The description of the meeting.
meetingStartDate
Type: SystemDateTime
The meeting start date of the meeting.
meetingEndDate
Type: SystemDateTime
The meeting end date of the meeting.
documentationRef
Type: SystemUri
The link to meeting specific documentation.
autoOpenOnActivate
Type: SystemBoolean
Open the meeting on activation.
autoStartAgendaOnOpen
Type: SystemBoolean
Start the agenda on meeting open.
defaultDiscussionId
Type: SystemGuid
The default discussion for the meeting.
identificationSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmIdentificationSetting
The identification setting for the meeting.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationMethod, DcnmVerificationMethod, Boolean, Boolean, DcnmQuorumInfo) instead.
See Also

Reference

DcnmMeetingPreparationInfo Class
DcnmMeetingPreparationInfo Overload


DcnmMeetingPreparationInfo Constructor (Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationSetting)

Note: This API is now obsolete.

Deprecated constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with quorum field")]
public DcnmMeetingPreparationInfo(
    Guid meetingId,
    string title,
    string description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri documentationRef,
    bool autoOpenOnActivate,
    bool autoStartAgendaOnOpen,
    Guid defaultDiscussionId,
    DcnmIdentificationSetting identificationSetting
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with quorum field")>
Public Sub New (
    meetingId As Guid,
    title As String,
    description As String,
    meetingStartDate As DateTime,
    meetingEndDate As DateTime,
    documentationRef As Uri,
    autoOpenOnActivate As Boolean,
    autoStartAgendaOnOpen As Boolean,
    defaultDiscussionId As Guid,
    identificationSetting As DcnmIdentificationSetting
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with quorum field")]
DcnmMeetingPreparationInfo(
    Guid meetingId,
    String^ title,
    String^ description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri^ documentationRef,
    bool autoOpenOnActivate,
    bool autoStartAgendaOnOpen,
    Guid defaultDiscussionId,
    DcnmIdentificationSetting identificationSetting
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting.
title
Type: SystemString
The title of the meeting.
description
Type: SystemString
The description of the meeting.
meetingStartDate
Type: SystemDateTime
The start date of the meeting.
meetingEndDate
Type: SystemDateTime
The end date of the meeting.
documentationRef
Type: SystemUri
The link to meeting specific documentation.
autoOpenOnActivate
Type: SystemBoolean
Open the meeting on activation.
autoStartAgendaOnOpen
Type: SystemBoolean
Start the agenda on meeting open.
defaultDiscussionId
Type: SystemGuid
The default discussion for the meeting.
identificationSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmIdentificationSetting
The identification setting for the meeting.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationMethod, DcnmVerificationMethod, Boolean, Boolean, DcnmQuorumInfo) instead.
See Also

Reference

DcnmMeetingPreparationInfo Class
DcnmMeetingPreparationInfo Overload


DcnmMeetingPreparationInfo Constructor (Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationSetting, Boolean)

Note: This API is now obsolete.

Deprecated constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with quorum field")]
public DcnmMeetingPreparationInfo(
    Guid meetingId,
    string title,
    string description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri documentationRef,
    bool autoOpenOnActivate,
    bool autoStartAgendaOnOpen,
    Guid defaultDiscussionId,
    DcnmIdentificationSetting identificationSetting,
    bool useDefaultMeetingInterpretationSettings
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with quorum field")>
Public Sub New (
    meetingId As Guid,
    title As String,
    description As String,
    meetingStartDate As DateTime,
    meetingEndDate As DateTime,
    documentationRef As Uri,
    autoOpenOnActivate As Boolean,
    autoStartAgendaOnOpen As Boolean,
    defaultDiscussionId As Guid,
    identificationSetting As DcnmIdentificationSetting,
    useDefaultMeetingInterpretationSettings As Boolean
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with quorum field")]
DcnmMeetingPreparationInfo(
    Guid meetingId,
    String^ title,
    String^ description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri^ documentationRef,
    bool autoOpenOnActivate,
    bool autoStartAgendaOnOpen,
    Guid defaultDiscussionId,
    DcnmIdentificationSetting identificationSetting,
    bool useDefaultMeetingInterpretationSettings
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting.
title
Type: SystemString
The title of the meeting.
description
Type: SystemString
The description of the meeting.
meetingStartDate
Type: SystemDateTime
The start date of the meeting.
meetingEndDate
Type: SystemDateTime
The end date of the meeting.
documentationRef
Type: SystemUri
The link to meeting specific documentation.
autoOpenOnActivate
Type: SystemBoolean
Open the meeting on activation.
autoStartAgendaOnOpen
Type: SystemBoolean
Start the agenda on meeting open.
defaultDiscussionId
Type: SystemGuid
The default discussion for the meeting.
identificationSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmIdentificationSetting
The identification setting for the meeting.
useDefaultMeetingInterpretationSettings
Type: SystemBoolean
Flag to check whether to use default Interpretation settings for meeting.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmMeetingPreparationInfo(Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationMethod, DcnmVerificationMethod, Boolean, Boolean) instead.
See Also

Reference

DcnmMeetingPreparationInfo Class
DcnmMeetingPreparationInfo Overload


DcnmMeetingPreparationInfo Constructor (Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationMethod, DcnmVerificationMethod, Boolean, Boolean)

Note: This API is now obsolete.

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with quorum field")]
public DcnmMeetingPreparationInfo(
    Guid meetingId,
    string title,
    string description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri documentationRef,
    bool autoOpenOnActivate,
    bool autoStartAgendaOnOpen,
    Guid defaultDiscussionId,
    DcnmIdentificationMethod identificationMethod,
    DcnmVerificationMethod verificationMethod,
    bool useDefaultMeetingInterpretationSettings,
    bool fixedSeating
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with quorum field")>
Public Sub New (
    meetingId As Guid,
    title As String,
    description As String,
    meetingStartDate As DateTime,
    meetingEndDate As DateTime,
    documentationRef As Uri,
    autoOpenOnActivate As Boolean,
    autoStartAgendaOnOpen As Boolean,
    defaultDiscussionId As Guid,
    identificationMethod As DcnmIdentificationMethod,
    verificationMethod As DcnmVerificationMethod,
    useDefaultMeetingInterpretationSettings As Boolean,
    fixedSeating As Boolean
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with quorum field")]
DcnmMeetingPreparationInfo(
    Guid meetingId,
    String^ title,
    String^ description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri^ documentationRef,
    bool autoOpenOnActivate,
    bool autoStartAgendaOnOpen,
    Guid defaultDiscussionId,
    DcnmIdentificationMethod identificationMethod,
    DcnmVerificationMethod verificationMethod,
    bool useDefaultMeetingInterpretationSettings,
    bool fixedSeating
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting.
title
Type: SystemString
The title of the meeting.
description
Type: SystemString
The description of the meeting.
meetingStartDate
Type: SystemDateTime
The start date of the meeting.
meetingEndDate
Type: SystemDateTime
The end date of the meeting.
documentationRef
Type: SystemUri
The link to meeting specific documentation.
autoOpenOnActivate
Type: SystemBoolean
Open the meeting on activation.
autoStartAgendaOnOpen
Type: SystemBoolean
Start the agenda on meeting open.
defaultDiscussionId
Type: SystemGuid
The default discussion for the meeting.
identificationMethod
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmIdentificationMethod
The identification mode for the meeting.
verificationMethod
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVerificationMethod
The verification mode for the meeting.
useDefaultMeetingInterpretationSettings
Type: SystemBoolean
Flag to check whether to use default Interpretation settings for meeting.
fixedSeating
Type: SystemBoolean
Meeting is of type fixed seating
See Also

Reference

DcnmMeetingPreparationInfo Class
DcnmMeetingPreparationInfo Overload


DcnmMeetingPreparationInfo Constructor (Guid, String, String, DateTime, DateTime, Uri, Boolean, Boolean, Guid, DcnmIdentificationMethod, DcnmVerificationMethod, Boolean, Boolean, DcnmQuorumInfo)

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmMeetingPreparationInfo(
    Guid meetingId,
    string title,
    string description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri documentationRef,
    bool autoOpenOnActivate,
    bool autoStartAgendaOnOpen,
    Guid defaultDiscussionId,
    DcnmIdentificationMethod identificationMethod,
    DcnmVerificationMethod verificationMethod,
    bool useDefaultMeetingInterpretationSettings,
    bool fixedSeating,
    DcnmQuorumInfo quorumInfo
)
Public Sub New (
    meetingId As Guid,
    title As String,
    description As String,
    meetingStartDate As DateTime,
    meetingEndDate As DateTime,
    documentationRef As Uri,
    autoOpenOnActivate As Boolean,
    autoStartAgendaOnOpen As Boolean,
    defaultDiscussionId As Guid,
    identificationMethod As DcnmIdentificationMethod,
    verificationMethod As DcnmVerificationMethod,
    useDefaultMeetingInterpretationSettings As Boolean,
    fixedSeating As Boolean,
    quorumInfo As DcnmQuorumInfo
)
public:
DcnmMeetingPreparationInfo(
    Guid meetingId,
    String^ title,
    String^ description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    Uri^ documentationRef,
    bool autoOpenOnActivate,
    bool autoStartAgendaOnOpen,
    Guid defaultDiscussionId,
    DcnmIdentificationMethod identificationMethod,
    DcnmVerificationMethod verificationMethod,
    bool useDefaultMeetingInterpretationSettings,
    bool fixedSeating,
    DcnmQuorumInfo^ quorumInfo
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting.
title
Type: SystemString
The title of the meeting.
description
Type: SystemString
The description of the meeting.
meetingStartDate
Type: SystemDateTime
The start date of the meeting.
meetingEndDate
Type: SystemDateTime
The end date of the meeting.
documentationRef
Type: SystemUri
The link to meeting specific documentation.
autoOpenOnActivate
Type: SystemBoolean
Open the meeting on activation.
autoStartAgendaOnOpen
Type: SystemBoolean
Start the agenda on meeting open.
defaultDiscussionId
Type: SystemGuid
The default discussion for the meeting.
identificationMethod
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmIdentificationMethod
The identification mode for the meeting.
verificationMethod
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVerificationMethod
The verification mode for the meeting.
useDefaultMeetingInterpretationSettings
Type: SystemBoolean
Flag to check whether to use default Interpretation settings for meeting.
fixedSeating
Type: SystemBoolean
Flag to indicate if participants are allowed to be seated only at the assigned seat.
quorumInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmQuorumInfo
Quorum information for the meeting
See Also

Reference

DcnmMeetingPreparationInfo Class
DcnmMeetingPreparationInfo Overload
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmQuorumInfo


DcnmMeetingPreparationInfo Properties

The DcnmMeetingPreparationInfo type exposes the following members.

Properties
 | Name | Description
Public property | AutoOpenOnActivate | Open the meeting on activation.
Public property | AutoStartAgendaOnOpen | Start the agenda on meeting open.
Public property | DefaultDiscussionId | The default discussion for the meeting.
Public property | Description | The description of the meeting.
Public property | DocumentationRef | The link to meeting specific documentation.
Public property | FixedSeating | Flag to indicate if participants are allowed to be seated only at the assigned seat.
Public property | IdentificationMethod | The identification mode for the meeting.
Public property | IdentificationSetting | The identification setting for the meeting.
Public property | MeetingEndDate | The end date of the meeting.
Public property | MeetingId | The ID of the meeting.
Public property | MeetingStartDate | The start date of the meeting.
Public property | QuorumInfo | The quorum information for the meeting.
Public property | Title | The title of the meeting.
Public property | UseDefaultMeetingInterpretationSettings | Flag to check whether to use default Interpretation settings for meeting.
Public property | VerificationMethod | The verification mode for the meeting.
Top
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.AutoOpenOnActivate Property

DcnmMeetingPreparationInfoAutoOpenOnActivate Property

Open the meeting on activation.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AutoOpenOnActivate { get; }
Public ReadOnly Property AutoOpenOnActivate As Boolean
    Get
public:
property bool AutoOpenOnActivate {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.AutoStartAgendaOnOpen Property

DcnmMeetingPreparationInfoAutoStartAgendaOnOpen Property

Start the agenda on meeting open.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AutoStartAgendaOnOpen { get; }
Public ReadOnly Property AutoStartAgendaOnOpen As Boolean
    Get
public:
property bool AutoStartAgendaOnOpen {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.DefaultDiscussionId Property

DcnmMeetingPreparationInfoDefaultDiscussionId Property

The default discussion for the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid DefaultDiscussionId { get; }
Public ReadOnly Property DefaultDiscussionId As Guid
    Get
public:
property Guid DefaultDiscussionId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.Description Property

DcnmMeetingPreparationInfoDescription Property

The description of the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.DocumentationRef Property

DcnmMeetingPreparationInfoDocumentationRef Property

The link to meeting specific documentation.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Uri DocumentationRef { get; }
Public ReadOnly Property DocumentationRef As Uri
    Get
public:
property Uri^ DocumentationRef {
    Uri^ get ();
}

Property Value

Type: Uri
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.FixedSeating Property

DcnmMeetingPreparationInfoFixedSeating Property

Flag to indicate if participants are allowed to be seated only at the assigned seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool FixedSeating { get; }
Public ReadOnly Property FixedSeating As Boolean
    Get
public:
property bool FixedSeating {
    bool get ();
}

Property Value

Type: Boolean
true Participants are allowed to be seated only at the assigned seat. false Free seating.
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.IdentificationMethod Property

DcnmMeetingPreparationInfoIdentificationMethod Property

The identification mode for the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmIdentificationMethod IdentificationMethod { get; }
Public ReadOnly Property IdentificationMethod As DcnmIdentificationMethod
    Get
public:
property DcnmIdentificationMethod IdentificationMethod {
    DcnmIdentificationMethod get ();
}

Property Value

Type: DcnmIdentificationMethod
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.IdentificationSetting Property

DcnmMeetingPreparationInfoIdentificationSetting Property

The identification setting for the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmIdentificationSetting IdentificationSetting { get; }
Public ReadOnly Property IdentificationSetting As DcnmIdentificationSetting
    Get
public:
property DcnmIdentificationSetting IdentificationSetting {
    DcnmIdentificationSetting get ();
}

Property Value

Type: DcnmIdentificationSetting
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.MeetingEndDate Property

DcnmMeetingPreparationInfoMeetingEndDate Property

The end date of the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DateTime MeetingEndDate { get; }
Public ReadOnly Property MeetingEndDate As DateTime
    Get
public:
property DateTime MeetingEndDate {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.MeetingId Property

DcnmMeetingPreparationInfoMeetingId Property

The ID of the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid MeetingId { get; }
Public ReadOnly Property MeetingId As Guid
    Get
public:
property Guid MeetingId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.MeetingStartDate Property

DcnmMeetingPreparationInfoMeetingStartDate Property

The start date of the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DateTime MeetingStartDate { get; }
Public ReadOnly Property MeetingStartDate As DateTime
    Get
public:
property DateTime MeetingStartDate {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.QuorumInfo Property

DcnmMeetingPreparationInfoQuorumInfo Property

The quorum information for the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmQuorumInfo QuorumInfo { get; }
Public ReadOnly Property QuorumInfo As DcnmQuorumInfo
    Get
public:
property DcnmQuorumInfo^ QuorumInfo {
    DcnmQuorumInfo^ get ();
}

Property Value

Type: DcnmQuorumInfo
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.Title Property

DcnmMeetingPreparationInfoTitle Property

The title of the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.UseDefaultMeetingInterpretationSettings Property

DcnmMeetingPreparationInfoUseDefaultMeetingInterpretationSettings Property

Bosch Logo
Flag to check whether to use default Interpretation settings for meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool UseDefaultMeetingInterpretationSettings { get; }
Public ReadOnly Property UseDefaultMeetingInterpretationSettings As Boolean
    Get
public:
property bool UseDefaultMeetingInterpretationSettings {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.VerificationMethod Property

DcnmMeetingPreparationInfoVerificationMethod Property

The verification mode for the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVerificationMethod VerificationMethod { get; }
Public ReadOnly Property VerificationMethod As DcnmVerificationMethod
    Get
public:
property DcnmVerificationMethod VerificationMethod {
    DcnmVerificationMethod get ();
}

Property Value

Type: DcnmVerificationMethod
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo Methods

The DcnmMeetingPreparationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo Fields

The DcnmMeetingPreparationInfo type exposes the following members.

Fields
Name | Description
MEETING_DEFAULT_AUTO_OPEN_ON_ACTIVATE | Default value for automatically opening meeting on activation.
MEETING_DEFAULT_AUTO_START_AGENDA_ON_OPEN | Default value for automatically start agenda on meeting open.
MEETING_DEFAULT_INTERPRETATION_SETTINGS | Default value for default interpretation settings on meeting creation.
Top
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.MEETING_DEFAULT_AUTO_OPEN_ON_ACTIVATE Field

DcnmMeetingPreparationInfoMEETING_DEFAULT_AUTO_OPEN_ON_ACTIVATE Field

 Bosch Logo
Default value for automatically opening meeting on activation.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool MEETING_DEFAULT_AUTO_OPEN_ON_ACTIVATE = true
Public Const MEETING_DEFAULT_AUTO_OPEN_ON_ACTIVATE As Boolean = True
public:
literal bool MEETING_DEFAULT_AUTO_OPEN_ON_ACTIVATE = true

Field Value

Type: Boolean
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.MEETING_DEFAULT_AUTO_START_AGENDA_ON_OPEN Field

DcnmMeetingPreparationInfoMEETING_DEFAULT_AUTO_START_AGENDA_ON_OPEN Field

 Bosch Logo
Default value for automatically start agenda on meeting open.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool MEETING_DEFAULT_AUTO_START_AGENDA_ON_OPEN = false
Public Const MEETING_DEFAULT_AUTO_START_AGENDA_ON_OPEN As Boolean = False
public:
literal bool MEETING_DEFAULT_AUTO_START_AGENDA_ON_OPEN = false

Field Value

Type: Boolean
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingPreparationInfo.MEETING_DEFAULT_INTERPRETATION_SETTINGS Field

DcnmMeetingPreparationInfoMEETING_DEFAULT_INTERPRETATION_SETTINGS Field

 Bosch Logo
Default value for default interpretation settings on meeting creation.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool MEETING_DEFAULT_INTERPRETATION_SETTINGS = true
Public Const MEETING_DEFAULT_INTERPRETATION_SETTINGS As Boolean = True
public:
literal bool MEETING_DEFAULT_INTERPRETATION_SETTINGS = true

Field Value

Type: Boolean
See Also

Reference

DcnmMeetingPreparationInfo Class


DcnmMeetingState Enumeration

Defines the meeting states

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmMeetingState
Public Enumeration DcnmMeetingState
public enum class DcnmMeetingState
Members
Member name | Value | Description
Activated | 0 | Meeting is activated.
Deactivated | 1 | Meeting is deactivated.
Opened | 2 | Meeting is opened.
Closed | 3 | Meeting is closed.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmMeetingStatusInfo Class

Container holding the information of a meeting.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMeetingStatusInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmMeetingStatusInfo
Public Class DcnmMeetingStatusInfo
public ref class DcnmMeetingStatusInfo

The DcnmMeetingStatusInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmMeetingStatusInfo | Constructor...
Top
Properties
 | Name | Description
Public property | AgendaList | The agenda for the meeting.
Public property | AutoOpenOnActivate | Open the meeting on activation.
Public property | AutoStartAgendaOnOpen | Start the agenda on meeting open.
Public property | DefaultDiscussionId | The default discussion for the meeting.
Public property | Description | The description of the meeting.
Public property | DocumentationRef | The link to meeting specific documentation.
Public property | IsDefault | flag to indicate if this is the default meeting or not.
Public property | MeetingEndDate | The end date of the meeting.
Public property | MeetingId | The ID of hte meeting.
Public property | MeetingStartDate | The start date of the meeting.
Public property | State | the state of the meeting
Public property | Title | The title of the meeting.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
MEETING_DEFAULT_AUTO_OPEN_ON_ACTIVATE | Default value for automatically opening meeting on activation.
MEETING_DEFAULT_AUTO_START_AGENDA_ON_OPEN | Default valud for automatically start agenda on meeting open.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmMeetingStatusInfo Constructor

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmMeetingStatusInfo(
    Guid meetingId,
    string title,
    string description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    string documentationRef,
    bool autoOpenOnActivate,
    bool autoStartAgendaOnOpen,
    Guid defaultDiscussionId,
    Collection<DcnmAgendaTopicStatusInfo> agendaList,
    DcnmMeetingState state,
    bool isDefault
)
Public Sub New (
    meetingId As Guid,
    title As String,
    description As String,
    meetingStartDate As DateTime,
    meetingEndDate As DateTime,
    documentationRef As String,
    autoOpenOnActivate As Boolean,
    autoStartAgendaOnOpen As Boolean,
    defaultDiscussionId As Guid,
    agendaList As Collection(Of DcnmAgendaTopicStatusInfo),
    state As DcnmMeetingState,
    isDefault As Boolean
)
public:
DcnmMeetingStatusInfo(
    Guid meetingId,
    String^ title,
    String^ description,
    DateTime meetingStartDate,
    DateTime meetingEndDate,
    String^ documentationRef,
    bool autoOpenOnActivate,
    bool autoStartAgendaOnOpen,
    Guid defaultDiscussionId,
    Collection<DcnmAgendaTopicStatusInfo^>^ agendaList,
    DcnmMeetingState state,
    bool isDefault
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting.
title
Type: SystemString
The title of the meeting.
description
Type: SystemString
The description of the meeting.
meetingStartDate
Type: SystemDateTime
The start date of the meeting.
meetingEndDate
Type: SystemDateTime
The end date of the meeting.
documentationRef
Type: SystemString
The link to meeting specific documentation.
autoOpenOnActivate
Type: SystemBoolean
Open the meeting on activation.
autoStartAgendaOnOpen
Type: SystemBoolean
Start the agenda on meeting open.
defaultDiscussionId
Type: SystemGuid
The default discussion for the meeting.
agendaList
Type: System.Collections.ObjectModelCollection DcnmAgendaTopicStatusInfo
The agenda topic list for the meeting.
state
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMeetingState
the status of the meeting.
isDefault
Type: SystemBoolean
Flag indicating if the meeting is a default meeting.
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo Properties

The DcnmMeetingStatusInfo type exposes the following members.

Properties
 | Name | Description
Public property | AgendaList | The agenda for the meeting.
Public property | AutoOpenOnActivate | Open the meeting on activation.
Public property | AutoStartAgendaOnOpen | Start the agenda on meeting open.
Public property | DefaultDiscussionId | The default discussion for the meeting.
Public property | Description | The description of the meeting.
Public property | DocumentationRef | The link to meeting specific documentation.
Public property | IsDefault | flag to indicate if this is the default meeting or not.
Public property | MeetingEndDate | The end date of the meeting.
Public property | MeetingId | The ID of hte meeting.
Public property | MeetingStartDate | The start date of the meeting.
Public property | State | the state of the meeting
Public property | Title | The title of the meeting.
Top
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo.AgendaList Property

DcnmMeetingStatusInfoAgendaList Property

The agenda for the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Collection<DcnmAgendaTopicStatusInfo> AgendaList { get; }
Public ReadOnly Property AgendaList As Collection(Of DcnmAgendaTopicStatusInfo)
    Get
public:
property Collection<DcnmAgendaTopicStatusInfo^>^ AgendaList {
    Collection<DcnmAgendaTopicStatusInfo^>^ get ();
}

Property Value

Type: Collection DcnmAgendaTopicStatusInfo
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo.AutoOpenOnActivate Property

DcnmMeetingStatusInfoAutoOpenOnActivate Property

Open the meeting on activation.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AutoOpenOnActivate { get; }
Public ReadOnly Property AutoOpenOnActivate As Boolean
    Get
public:
property bool AutoOpenOnActivate {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo.AutoStartAgendaOnOpen Property

DcnmMeetingStatusInfoAutoStartAgendaOnOpen Property

Start the agenda on meeting open.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AutoStartAgendaOnOpen { get; }
Public ReadOnly Property AutoStartAgendaOnOpen As Boolean
    Get
public:
property bool AutoStartAgendaOnOpen {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo.DefaultDiscussionId Property

DcnmMeetingStatusInfoDefaultDiscussionId Property

The default discussion for the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid DefaultDiscussionId { get; }
Public ReadOnly Property DefaultDiscussionId As Guid
    Get
public:
property Guid DefaultDiscussionId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo.Description Property

DcnmMeetingStatusInfoDescription Property

The description of the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo.DocumentationRef Property

DcnmMeetingStatusInfoDocumentationRef Property

The link to meeting specific documentation.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string DocumentationRef { get; }
Public ReadOnly Property DocumentationRef As String
    Get
public:
property String^ DocumentationRef {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo.IsDefault Property

DcnmMeetingStatusInfoIsDefault Property

flag to indicate if this is the default meeting or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsDefault { get; }
Public ReadOnly Property IsDefault As Boolean
    Get
public:
property bool IsDefault {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo.MeetingEndDate Property

DcnmMeetingStatusInfoMeetingEndDate Property

The end date of the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DateTime MeetingEndDate { get; }
Public ReadOnly Property MeetingEndDate As DateTime
    Get
public:
property DateTime MeetingEndDate {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo.MeetingId Property

DcnmMeetingStatusInfoMeetingId Property

The ID of hte meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid MeetingId { get; }
Public ReadOnly Property MeetingId As Guid
    Get
public:
property Guid MeetingId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo.MeetingStartDate Property

DcnmMeetingStatusInfoMeetingStartDate Property

The start date of the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DateTime MeetingStartDate { get; }
Public ReadOnly Property MeetingStartDate As DateTime
    Get
public:
property DateTime MeetingStartDate {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo.State Property

DcnmMeetingStatusInfoState Property

the state of the meeting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmMeetingState State { get; }
Public ReadOnly Property State As DcnmMeetingState
    Get
public:
property DcnmMeetingState State {
    DcnmMeetingState get ();
}

Property Value

Type: DcnmMeetingState
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo.Title Property

DcnmMeetingStatusInfoTitle Property

The title of the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo Methods

The DcnmMeetingStatusInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo Fields

The DcnmMeetingStatusInfo type exposes the following members.

Fields
Name | Description
MEETING_DEFAULT_AUTO_OPEN_ON_ACTIVATE | Default value for automatically opening meeting on activation.
MEETING_DEFAULT_AUTO_START_AGENDA_ON_OPEN | Default valud for automatically start agenda on meeting open.
Top
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo.MEETING_DEFAULT_AUTO_OPEN_ON_ACTIVATE Field

DcnmMeetingStatusInfoMEETING_DEFAULT_AUTO_OPEN_ON_ACTIVATE Field

 Bosch Logo
Default value for automatically opening meeting on activation.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool MEETING_DEFAULT_AUTO_OPEN_ON_ACTIVATE = true
Public Const MEETING_DEFAULT_AUTO_OPEN_ON_ACTIVATE As Boolean = True
public:
literal bool MEETING_DEFAULT_AUTO_OPEN_ON_ACTIVATE = true

Field Value

Type: Boolean
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMeetingStatusInfo.MEETING_DEFAULT_AUTO_START_AGENDA_ON_OPEN Field

DcnmMeetingStatusInfoMEETING_DEFAULT_AUTO_START_AGENDA_ON_OPEN Field

 Bosch Logo
Default valud for automatically start agenda on meeting open.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool MEETING_DEFAULT_AUTO_START_AGENDA_ON_OPEN = false
Public Const MEETING_DEFAULT_AUTO_START_AGENDA_ON_OPEN As Boolean = False
public:
literal bool MEETING_DEFAULT_AUTO_START_AGENDA_ON_OPEN = false

Field Value

Type: Boolean
See Also

Reference

DcnmMeetingStatusInfo Class


DcnmMicrophoneOptions Class

The microphone options
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMicrophoneOptions

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmMicrophoneOptions
Public Class DcnmMicrophoneOptions
public ref class DcnmMicrophoneOptions

The DcnmMicrophoneOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmMicrophoneOptions | Default constructor
Public method | DcnmMicrophoneOptions(Int32, Boolean, Boolean, Boolean) | The microphone options
Top
Properties
 | Name | Description
Public property | AutoMicrophoneOff | Indicates whether the microphone should be turned off after 30 seconds of inactivity.
Public property | MicrophoneOffAfterShift | Indicates whether the microphone should be turned off after shift.
Public property | NumberOfOpenMicrophones | The number of open microphones for the current discussion.
Public property | UseAmbientMicrophone | Indicates whether the ambient microphone should be used for the current discussion.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DEFAULT_AUTO_MIC_OFF_AFTER_INACTIVITY | Default value for auto microphone off after period of inactivity.
DEFAULT_MIC_OFF_AFTER_SHIFT | Default value for microphone off after shift.
DEFAULT_OPEN_MICROPHONES | Default value for number of open microphones
DEFAULT_USE_AMBIENT | Default value for use of the ambient microphone.
MAX_OPEN_MICROPHONES | Maximum value for number of open microphones
MIN_OPEN_MICROPHONES | Minimum value for number of open microphones
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmMicrophoneOptions Constructor

Overload List
 | Name | Description
Public method | DcnmMicrophoneOptions | Default constructor
Public method | DcnmMicrophoneOptions(Int32, Boolean, Boolean, Boolean) | The microphone options
Top
See Also

Reference

DcnmMicrophoneOptions Class


DcnmMicrophoneOptions Constructor

Default constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmMicrophoneOptions()
Public Sub New
public:
DcnmMicrophoneOptions()
See Also

Reference

DcnmMicrophoneOptions Class
DcnmMicrophoneOptions Overload


DcnmMicrophoneOptions Constructor (Int32, Boolean, Boolean, Boolean)

The microphone options

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmMicrophoneOptions(
    int numberOfOpenMicrophones,
    bool useAmbientMicrophone,
    bool autoMicrophoneOff,
    bool microphoneOffAfterShift
)
Public Sub New (
    numberOfOpenMicrophones As Integer,
    useAmbientMicrophone As Boolean,
    autoMicrophoneOff As Boolean,
    microphoneOffAfterShift As Boolean
)
public:
DcnmMicrophoneOptions(
    int numberOfOpenMicrophones,
    bool useAmbientMicrophone,
    bool autoMicrophoneOff,
    bool microphoneOffAfterShift
)

Parameters

numberOfOpenMicrophones
Type: SystemInt32
The number of open microphones.
useAmbientMicrophone
Type: SystemBoolean
Use of the abient microphone.
autoMicrophoneOff
Type: SystemBoolean
Auto microphone off after 30 seconds of inactivity.
microphoneOffAfterShift
Type: SystemBoolean
Microphone after shift into speakers list.
See Also

Reference

DcnmMicrophoneOptions Class
DcnmMicrophoneOptions Overload


DcnmMicrophoneOptions Properties

The DcnmMicrophoneOptions type exposes the following members.

Properties
 | Name | Description
Public property | AutoMicrophoneOff | Indicates whether the microphone should be turned off after 30 seconds of inactivity.
Public property | MicrophoneOffAfterShift | Indicates whether the microphone should be turned off after shift.
Public property | NumberOfOpenMicrophones | The number of open microphones for the current discussion.
Public property | UseAmbientMicrophone | Indicates whether the ambient microphone should be used for the current discussion.
Top
See Also

Reference

DcnmMicrophoneOptions Class


DcnmMicrophoneOptions.AutoMicrophoneOff Property

DcnmMicrophoneOptionsAutoMicrophoneOff Property

Indicates whether the microphone should be turned off after 30 seconds of inactivity.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AutoMicrophoneOff { get; set; }
Public Property AutoMicrophoneOff As Boolean
    Get
    Set
public:
property bool AutoMicrophoneOff {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DcnmMicrophoneOptions Class


DcnmMicrophoneOptions.MicrophoneOffAfterShift Property

DcnmMicrophoneOptionsMicrophoneOffAfterShift Property

Indicates whether the microphone should be turned off after shift.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool MicrophoneOffAfterShift { get; set; }
Public Property MicrophoneOffAfterShift As Boolean
    Get
    Set
public:
property bool MicrophoneOffAfterShift {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DcnmMicrophoneOptions Class


DcnmMicrophoneOptions.NumberOfOpenMicrophones Property

DcnmMicrophoneOptionsNumberOfOpenMicrophones Property

The number of open microphones for the current discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int NumberOfOpenMicrophones { get; set; }
Public Property NumberOfOpenMicrophones As Integer
    Get
    Set
public:
property int NumberOfOpenMicrophones {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
In response mode, always equal to 1.
See Also

Reference

DcnmMicrophoneOptions Class


DcnmMicrophoneOptions.UseAmbientMicrophone Property

DcnmMicrophoneOptionsUseAmbientMicrophone Property

Indicates whether the ambient microphone should be used for the current discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool UseAmbientMicrophone { get; set; }
Public Property UseAmbientMicrophone As Boolean
    Get
    Set
public:
property bool UseAmbientMicrophone {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DcnmMicrophoneOptions Class


DcnmMicrophoneOptions Methods

The DcnmMicrophoneOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmMicrophoneOptions Class


DcnmMicrophoneOptions Fields

The DcnmMicrophoneOptions type exposes the following members.

Fields
Name | Description
DEFAULT_AUTO_MIC_OFF_AFTER_INACTIVITY | Default value for auto microphone off after period of inactivity.
DEFAULT_MIC_OFF_AFTER_SHIFT | Default value for microphone off after shift.
DEFAULT_OPEN_MICROPHONES | Default value for number of open microphones
DEFAULT_USE_AMBIENT | Default value for use of the ambient microphone.
MAX_OPEN_MICROPHONES | Maximum value for number of open microphones
MIN_OPEN_MICROPHONES | Minimum value for number of open microphones
Top
See Also

Reference

DcnmMicrophoneOptions Class


DcnmMicrophoneOptions.DEFAULT_AUTO_MIC_OFF_AFTER_INACTIVITY Field

DcnmMicrophoneOptionsDEFAULT_AUTO_MIC_OFF_AFTER_INACTIVITY Field

 Bosch Logo
Default value for auto microphone off after period of inactivity.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DEFAULT_AUTO_MIC_OFF_AFTER_INACTIVITY = false
Public Const DEFAULT_AUTO_MIC_OFF_AFTER_INACTIVITY As Boolean = False
public:
literal bool DEFAULT_AUTO_MIC_OFF_AFTER_INACTIVITY = false

Field Value

Type: Boolean
See Also

Reference

DcnmMicrophoneOptions Class


DcnmMicrophoneOptions.DEFAULT_MIC_OFF_AFTER_SHIFT Field

DcnmMicrophoneOptionsDEFAULT_MIC_OFF_AFTER_SHIFT Field

Default value for microphone off after shift.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DEFAULT_MIC_OFF_AFTER_SHIFT = false
Public Const DEFAULT_MIC_OFF_AFTER_SHIFT As Boolean = False
public:
literal bool DEFAULT_MIC_OFF_AFTER_SHIFT = false

Field Value

Type: Boolean
See Also

Reference

DcnmMicrophoneOptions Class


DcnmMicrophoneOptions.DEFAULT_OPEN_MICROPHONES Field

DcnmMicrophoneOptionsDEFAULT_OPEN_MICROPHONES Field

Default value for number of open microphones

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DEFAULT_OPEN_MICROPHONES = 2
Public Const DEFAULT_OPEN_MICROPHONES As Integer = 2
public:
literal int DEFAULT_OPEN_MICROPHONES = 2

Field Value

Type: Int32
See Also

Reference

DcnmMicrophoneOptions Class


DcnmMicrophoneOptions.DEFAULT_USE_AMBIENT Field

DcnmMicrophoneOptionsDEFAULT_USE_AMBIENT Field

Default value for use of the ambient microphone.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DEFAULT_USE_AMBIENT = true
Public Const DEFAULT_USE_AMBIENT As Boolean = True
public:
literal bool DEFAULT_USE_AMBIENT = true

Field Value

Type: Boolean
See Also

Reference

DcnmMicrophoneOptions Class


DcnmMicrophoneOptions.MAX_OPEN_MICROPHONES Field

DcnmMicrophoneOptionsMAX_OPEN_MICROPHONES Field

Maximum value for number of open microphones

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAX_OPEN_MICROPHONES = 25
Public Const MAX_OPEN_MICROPHONES As Integer = 25
public:
literal int MAX_OPEN_MICROPHONES = 25

Field Value

Type: Int32
See Also

Reference

DcnmMicrophoneOptions Class


DcnmMicrophoneOptions.MIN_OPEN_MICROPHONES Field

DcnmMicrophoneOptionsMIN_OPEN_MICROPHONES Field

Minimum value for number of open microphones

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MIN_OPEN_MICROPHONES = 1
Public Const MIN_OPEN_MICROPHONES As Integer = 1
public:
literal int MIN_OPEN_MICROPHONES = 1

Field Value

Type: Int32
See Also

Reference

DcnmMicrophoneOptions Class


DcnmMicrophoneSensitivityForSeat Class

Container holding the microphone sensitivity settings of a seat.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMicrophoneSensitivityForSeat

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmMicrophoneSensitivityForSeat
Public Class DcnmMicrophoneSensitivityForSeat
public ref class DcnmMicrophoneSensitivityForSeat

The DcnmMicrophoneSensitivityForSeat type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmMicrophoneSensitivityForSeat | Initializes a new instance of the DcnmMicrophoneSensitivityForSeat class.
Top
Properties
 | Name | Description
Public property | Level | The microphone sensitivity value in Db.
Public property | SeatId | The identifier of the seat.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmMicrophoneSensitivityForSeat Constructor

Initializes a new instance of the DcnmMicrophoneSensitivityForSeat class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmMicrophoneSensitivityForSeat(
    Guid seatId,
    float level
)
Public Sub New (
    seatId As Guid,
    level As Single
)
public:
DcnmMicrophoneSensitivityForSeat(
    Guid seatId,
    float level
)

Parameters

seatId
Type: SystemGuid
Identifier of the seat.
level
Type: SystemSingle
Microphone sensitivity value in dB.
See Also

Reference

DcnmMicrophoneSensitivityForSeat Class


DcnmMicrophoneSensitivityForSeat Properties

The DcnmMicrophoneSensitivityForSeat type exposes the following members.

Properties
 | Name | Description
Public property | Level | The microphone sensitivity value in Db.
Public property | SeatId | The identifier of the seat.
Top
See Also

Reference

DcnmMicrophoneSensitivityForSeat Class


DcnmMicrophoneSensitivityForSeat.Level Property

DcnmMicrophoneSensitivityForSeatLevel Property

The microphone sensitivity value in Db.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public float Level { get; set; }
Public Property Level As Single
    Get
    Set
public:
property float Level {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

DcnmMicrophoneSensitivityForSeat Class


DcnmMicrophoneSensitivityForSeat.SeatId Property

DcnmMicrophoneSensitivityForSeatSeatId Property

The identifier of the seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid SeatId { get; }
Public ReadOnly Property SeatId As Guid
    Get
public:
property Guid SeatId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmMicrophoneSensitivityForSeat Class


DcnmMicrophoneSensitivityForSeat Methods

The DcnmMicrophoneSensitivityForSeat type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmMicrophoneSensitivityForSeat Class


DcnmMicrophoneState Enumeration

The microphone state

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmMicrophoneState
Public Enumeration DcnmMicrophoneState
public enum class DcnmMicrophoneState
Members
Member name | Value | Description
Off | 0 | Microphone is off.
On | 1 | Microphone is on.
Mute | 2 | Microphone is muted.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmNotesFileInfo Class

Represents the notes file information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmNotesFileInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmNotesFileInfo
Public Class DcnmNotesFileInfo
public ref class DcnmNotesFileInfo

The DcnmNotesFileInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmNotesFileInfo | Constructor.
Top
Properties
 | Name | Description
Public property | CreationDate | Notes file creation date time.
Public property | FileName | Notes file Name
Public property | FileType | Notes file type.
Public property | IsTampered | Boolean hold whether file is tampered or not.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmNotesFileInfo Constructor

Constructor.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmNotesFileInfo(
    string fileName,
    DateTime creationDate,
    DcnmNotesFileType fileType,
    bool isTampered
)
Public Sub New (
    fileName As String,
    creationDate As DateTime,
    fileType As DcnmNotesFileType,
    isTampered As Boolean
)
public:
DcnmNotesFileInfo(
    String^ fileName,
    DateTime creationDate,
    DcnmNotesFileType fileType,
    bool isTampered
)

Parameters

fileName
Type: SystemString
File name
creationDate
Type: SystemDateTime
File creation Date
fileType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmNotesFileType
File Type
isTampered
Type: SystemBoolean
Boolean hold whether file is tampered or not.
See Also

Reference

DcnmNotesFileInfo Class
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmNotesFileType


DcnmNotesFileInfo Properties

The DcnmNotesFileInfo type exposes the following members.

Properties
 | Name | Description
Public property | CreationDate | Notes file creation date time.
Public property | FileName | Notes file Name
Public property | FileType | Notes file type.
Public property | IsTampered | Boolean hold whether file is tampered or not.
Top
See Also

Reference

DcnmNotesFileInfo Class


DcnmNotesFileInfo.CreationDate Property

DcnmNotesFileInfoCreationDate Property

Notes file creation date time.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DateTime CreationDate { get; }
Public ReadOnly Property CreationDate As DateTime
    Get
public:
property DateTime CreationDate {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

DcnmNotesFileInfo Class


DcnmNotesFileInfo.FileName Property

DcnmNotesFileInfoFileName Property

Notes file Name

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmNotesFileInfo Class


DcnmNotesFileInfo.FileType Property

DcnmNotesFileInfoFileType Property

Notes file type.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmNotesFileType FileType { get; }
Public ReadOnly Property FileType As DcnmNotesFileType
    Get
public:
property DcnmNotesFileType FileType {
    DcnmNotesFileType get ();
}

Property Value

Type: DcnmNotesFileType
See Also

Reference

DcnmNotesFileInfo Class


DcnmNotesFileInfo.IsTampered Property

DcnmNotesFileInfoIsTampered Property

Boolean hold whether file is tampered or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsTampered { get; }
Public ReadOnly Property IsTampered As Boolean
    Get
public:
property bool IsTampered {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmNotesFileInfo Class


DcnmNotesFileInfo Methods

The DcnmNotesFileInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmNotesFileInfo Class


DcnmNotesFileType Enumeration

Represents various notes file types

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmNotesFileType
Public Enumeration DcnmNotesFileType
public enum class DcnmNotesFileType
Members
Member name | Value | Description
Unknown | 0 | Represents file type is unknown
Meeting | 1 | Represents file type is meeting notes xml.
Voting | 2 | Represents file type is voting notes xml.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmOverviewCameraPreparationInfo Class

Container for the overview camera information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmOverviewCameraPreparationInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmOverviewCameraPreparationInfo
Public Class DcnmOverviewCameraPreparationInfo
public ref class DcnmOverviewCameraPreparationInfo

The DcnmOverviewCameraPreparationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmOverviewCameraPreparationInfo | Default constructor for class
Public method | DcnmOverviewCameraPreparationInfo(Guid, Guid, Int32) | Initializes a new instance of the DcnmOverviewCameraPreparationInfo class.
Top
Properties
 | Name | Description
Public property | AreaId | The identifier of the area.
Public property | CameraId | The identifier of the camera.
Public property | PrepositionId | The identifier of the preposition.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmOverviewCameraPreparationInfo Constructor

Overload List
 | Name | Description
Public method | DcnmOverviewCameraPreparationInfo | Default constructor for class
Public method | DcnmOverviewCameraPreparationInfo(Guid, Guid, Int32) | Initializes a new instance of the DcnmOverviewCameraPreparationInfo class.
Top
See Also

Reference

DcnmOverviewCameraPreparationInfo Class


DcnmOverviewCameraPreparationInfo Constructor

Default constructor for class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmOverviewCameraPreparationInfo()
Public Sub New
public:
DcnmOverviewCameraPreparationInfo()
See Also

Reference

DcnmOverviewCameraPreparationInfo Class
DcnmOverviewCameraPreparationInfo Overload


DcnmOverviewCameraPreparationInfo Constructor (Guid, Guid, Int32)

Initializes a new instance of the DcnmOverviewCameraPreparationInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmOverviewCameraPreparationInfo(
    Guid areaId,
    Guid cameraId,
    int prepositionId
)
Public Sub New (
    areaId As Guid,
    cameraId As Guid,
    prepositionId As Integer
)
public:
DcnmOverviewCameraPreparationInfo(
    Guid areaId,
    Guid cameraId,
    int prepositionId
)

Parameters

areaId
Type: SystemGuid
The name of the area.
cameraId
Type: SystemGuid
The identifier of the camera.
prepositionId
Type: SystemInt32
the id of the preposition
See Also

Reference

DcnmOverviewCameraPreparationInfo Class
DcnmOverviewCameraPreparationInfo Overload


DcnmOverviewCameraPreparationInfo Properties

The DcnmOverviewCameraPreparationInfo type exposes the following members.

Properties
 | Name | Description
Public property | AreaId | The identifier of the area.
Public property | CameraId | The identifier of the camera.
Public property | PrepositionId | The identifier of the preposition.
Top
See Also

Reference

DcnmOverviewCameraPreparationInfo Class


DcnmOverviewCameraPreparationInfo.AreaId Property

DcnmOverviewCameraPreparationInfoAreaId Property

The identifier of the area.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid AreaId { get; }
Public ReadOnly Property AreaId As Guid
    Get
public:
property Guid AreaId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmOverviewCameraPreparationInfo Class


DcnmOverviewCameraPreparationInfo.CameraId Property

DcnmOverviewCameraPreparationInfoCameraId Property

The identifier of the camera.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid CameraId { get; }
Public ReadOnly Property CameraId As Guid
    Get
public:
property Guid CameraId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmOverviewCameraPreparationInfo Class


DcnmOverviewCameraPreparationInfo.PrepositionId Property

DcnmOverviewCameraPreparationInfoPrepositionId Property

The identifier of the preposition.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int PrepositionId { get; }
Public ReadOnly Property PrepositionId As Integer
    Get
public:
property int PrepositionId {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmOverviewCameraPreparationInfo Class


DcnmOverviewCameraPreparationInfo Methods

The DcnmOverviewCameraPreparationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmOverviewCameraPreparationInfo Class


DcnmParticipantAccessDeniedInfo Class

Contains the participant access denied reasons
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmParticipantAccessDeniedInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmParticipantAccessDeniedInfo
Public Class DcnmParticipantAccessDeniedInfo
public ref class DcnmParticipantAccessDeniedInfo

The DcnmParticipantAccessDeniedInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmParticipantAccessDeniedInfo | Constructor...
Top
Properties
 | Name | Description
Public property | AccessDeniedReasons | Gets the participant access denied reasons
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
An DcnmParticipantLoginStatusInfo is used to retrieve the participant login access status based on available license count The DcnmParticipantAccessDeniedInfo represents
  • Participant access denied reasons
The IControlParticipant interface.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmParticipantAccessDeniedInfo Constructor

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantAccessDeniedInfo(
    IList<DcnmAccessDeniedReason> deniedReasons
)
Public Sub New (
    deniedReasons As IList(Of DcnmAccessDeniedReason)
)
public:
DcnmParticipantAccessDeniedInfo(
    IList<DcnmAccessDeniedReason>^ deniedReasons
)

Parameters

deniedReasons
Type: System.Collections.GenericIList DcnmAccessDeniedReason
Access denied reasons
See Also

Reference

DcnmParticipantAccessDeniedInfo Class


DcnmParticipantAccessDeniedInfo Properties

The DcnmParticipantAccessDeniedInfo type exposes the following members.

Properties
 | Name | Description
Public property | AccessDeniedReasons | Gets the participant access denied reasons
Top
See Also

Reference

DcnmParticipantAccessDeniedInfo Class


DcnmParticipantAccessDeniedInfo.AccessDeniedReasons Property

DcnmParticipantAccessDeniedInfoAccessDeniedReasons Property

Gets the participant access denied reasons

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<DcnmAccessDeniedReason> AccessDeniedReasons { get; }
Public ReadOnly Property AccessDeniedReasons As IList(Of DcnmAccessDeniedReason)
    Get
public:
property IList<DcnmAccessDeniedReason>^ AccessDeniedReasons {
    IList<DcnmAccessDeniedReason>^ get ();
}

Property Value

Type: IList DcnmAccessDeniedReason
See Also

Reference

DcnmParticipantAccessDeniedInfo Class


DcnmParticipantAccessDeniedInfo Methods

The DcnmParticipantAccessDeniedInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmParticipantAccessDeniedInfo Class


DcnmParticipantAndUserInfo Class

Defines the container for participant and user information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmParticipantAndUserInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmParticipantAndUserInfo
Public Class DcnmParticipantAndUserInfo
public ref class DcnmParticipantAndUserInfo

The DcnmParticipantAndUserInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmParticipantAndUserInfo | Constructor...
Top
Properties
 | Name | Description
Public property | ParticipantInfo | The participant information.
Public property | UserInfo | The user information.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmParticipantAndUserInfo Constructor

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantAndUserInfo(
    DcnmParticipantPreparationInfo2 participantInfo,
    DcnmUserPreparationInfo personInfo
)
Public Sub New (
    participantInfo As DcnmParticipantPreparationInfo2,
    personInfo As DcnmUserPreparationInfo
)
public:
DcnmParticipantAndUserInfo(
    DcnmParticipantPreparationInfo2^ participantInfo,
    DcnmUserPreparationInfo^ personInfo
)

Parameters

participantInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmParticipantPreparationInfo2
Participant information
personInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmUserPreparationInfo
Person information
See Also

Reference

DcnmParticipantAndUserInfo Class


DcnmParticipantAndUserInfo Properties

The DcnmParticipantAndUserInfo type exposes the following members.

Properties
 | Name | Description
Public property | ParticipantInfo | The participant information.
Public property | UserInfo | The user information.
Top
See Also

Reference

DcnmParticipantAndUserInfo Class


DcnmParticipantAndUserInfo.ParticipantInfo Property

DcnmParticipantAndUserInfoParticipantInfo Property

The participant information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantPreparationInfo2 ParticipantInfo { get; }
Public ReadOnly Property ParticipantInfo As DcnmParticipantPreparationInfo2
    Get
public:
property DcnmParticipantPreparationInfo2^ ParticipantInfo {
    DcnmParticipantPreparationInfo2^ get ();
}

Property Value

Type: DcnmParticipantPreparationInfo2
See Also

Reference

DcnmParticipantAndUserInfo Class


DcnmParticipantAndUserInfo.UserInfo Property

DcnmParticipantAndUserInfoUserInfo Property

The user information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmUserPreparationInfo UserInfo { get; }
Public ReadOnly Property UserInfo As DcnmUserPreparationInfo
    Get
public:
property DcnmUserPreparationInfo^ UserInfo {
    DcnmUserPreparationInfo^ get ();
}

Property Value

Type: DcnmUserPreparationInfo
See Also

Reference

DcnmParticipantAndUserInfo Class


DcnmParticipantAndUserInfo Methods

The DcnmParticipantAndUserInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmParticipantAndUserInfo Class


DcnmParticipantInfo Class

Defines the container for Dcnm participant information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmParticipantInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmParticipantInfo
Public Class DcnmParticipantInfo
public ref class DcnmParticipantInfo

The DcnmParticipantInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmParticipantInfo(Guid, DcnmPersonInfo, Boolean, Boolean, Boolean, Boolean, Int32) | Obsolete. Constructor...
Public method | DcnmParticipantInfo(Guid, DcnmPersonInfo, Boolean, Boolean, Boolean, Boolean, Int32, Boolean) | Obsolete. Constructor...
Public method | DcnmParticipantInfo(Guid, DcnmPersonInfo, Boolean, Boolean, Boolean, Boolean, Int32, Boolean, Boolean) | Obsolete. Constructor...
Public method | DcnmParticipantInfo(Guid, DcnmPersonInfo, Boolean, Boolean, Boolean, Boolean, Int32, Boolean, Boolean, DcnmSpecialOperationType) | Constructor...
Top
Properties
 | Name | Description
Public property | CanDiscuss | Indicates if the participant has discuss rights.
Public property | CanManageMeeting | Indicates if the participant has can manage meeting rights.
Public property | CanUsePriority | Indicates if the participant has priority rights.
Public property | CanVote | Indicates if the participant has vote rights.
Public property | HasSpecialPermission | Indicates if this participant has special permission.
Public property | Id | The identifier of the participant.
Public property | IsAuthenticated | Indicates if the participant is authenticated
Public property | PersonInfo | The person information of the participant.
Public property | VipType | The participant vip type.
Public property | VoteWeight | The vote weight.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmParticipantInfo Constructor

Overload List
 | Name | Description
Public method | DcnmParticipantInfo(Guid, DcnmPersonInfo, Boolean, Boolean, Boolean, Boolean, Int32) | Obsolete. Constructor...
Public method | DcnmParticipantInfo(Guid, DcnmPersonInfo, Boolean, Boolean, Boolean, Boolean, Int32, Boolean) | Obsolete. Constructor...
Public method | DcnmParticipantInfo(Guid, DcnmPersonInfo, Boolean, Boolean, Boolean, Boolean, Int32, Boolean, Boolean) | Obsolete. Constructor...
Public method | DcnmParticipantInfo(Guid, DcnmPersonInfo, Boolean, Boolean, Boolean, Boolean, Int32, Boolean, Boolean, DcnmSpecialOperationType) | Constructor...
Top
See Also

Reference

DcnmParticipantInfo Class


DcnmParticipantInfo Constructor (Guid, DcnmPersonInfo, Boolean, Boolean, Boolean, Boolean, Int32)

Note: This API is now obsolete.

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with HasSpecialPermision field")]
public DcnmParticipantInfo(
    Guid id,
    DcnmPersonInfo personInfo,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with HasSpecialPermision field")>
Public Sub New (
    id As Guid,
    personInfo As DcnmPersonInfo,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canVote As Boolean,
    canUsePriority As Boolean,
    voteWeight As Integer
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with HasSpecialPermision field")]
DcnmParticipantInfo(
    Guid id,
    DcnmPersonInfo^ personInfo,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight
)

Parameters

id
Type: SystemGuid
Identifier of the participant
personInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPersonInfo
The person information of the participant.
canDiscuss
Type: SystemBoolean
Discussion capability of the participant.
canManageMeeting
Type: SystemBoolean
Manage Meeting capability of the participant.
canVote
Type: SystemBoolean
Voting capability of the participant.
canUsePriority
Type: SystemBoolean
Priority capability of the participant.
voteWeight
Type: SystemInt32
Weight of the vote.
See Also

Reference

DcnmParticipantInfo Class
DcnmParticipantInfo Overload


DcnmParticipantInfo Constructor (Guid, DcnmPersonInfo, Boolean, Boolean, Boolean, Boolean, Int32, Boolean)

Note: This API is now obsolete.

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with HasSpecialPermision field")]
public DcnmParticipantInfo(
    Guid id,
    DcnmPersonInfo personInfo,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    bool isAuthenticated
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with HasSpecialPermision field")>
Public Sub New (
    id As Guid,
    personInfo As DcnmPersonInfo,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canVote As Boolean,
    canUsePriority As Boolean,
    voteWeight As Integer,
    isAuthenticated As Boolean
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with HasSpecialPermision field")]
DcnmParticipantInfo(
    Guid id,
    DcnmPersonInfo^ personInfo,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    bool isAuthenticated
)

Parameters

id
Type: SystemGuid
Identifier of the participant
personInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPersonInfo
The person information of the participant.
canDiscuss
Type: SystemBoolean
Discussion capability of the participant.
canManageMeeting
Type: SystemBoolean
Manage Meeting capability of the participant.
canVote
Type: SystemBoolean
Voting capability of the participant.
canUsePriority
Type: SystemBoolean
Priority capability of the participant.
voteWeight
Type: SystemInt32
Weight of the vote.
isAuthenticated
Type: SystemBoolean
Participant authentication state.
See Also

Reference

DcnmParticipantInfo Class
DcnmParticipantInfo Overload


DcnmParticipantInfo Constructor (Guid, DcnmPersonInfo, Boolean, Boolean, Boolean, Boolean, Int32, Boolean, Boolean)

Note: This API is now obsolete.

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with viptype field")]
public DcnmParticipantInfo(
    Guid id,
    DcnmPersonInfo personInfo,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    bool isAuthenticated,
    bool hasSpecialPermission
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with viptype field")>
Public Sub New (
    id As Guid,
    personInfo As DcnmPersonInfo,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canVote As Boolean,
    canUsePriority As Boolean,
    voteWeight As Integer,
    isAuthenticated As Boolean,
    hasSpecialPermission As Boolean
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with viptype field")]
DcnmParticipantInfo(
    Guid id,
    DcnmPersonInfo^ personInfo,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    bool isAuthenticated,
    bool hasSpecialPermission
)

Parameters

id
Type: SystemGuid
Identifier of the participant
personInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPersonInfo
The person information of the participant.
canDiscuss
Type: SystemBoolean
Discussion capability of the participant.
canManageMeeting
Type: SystemBoolean
Manage Meeting capability of the participant.
canVote
Type: SystemBoolean
Voting capability of the participant.
canUsePriority
Type: SystemBoolean
Priority capability of the participant.
voteWeight
Type: SystemInt32
Weight of the vote.
isAuthenticated
Type: SystemBoolean
Participant authentication state.
hasSpecialPermission
Type: SystemBoolean
Participant has special permission or not.
See Also

Reference

DcnmParticipantInfo Class
DcnmParticipantInfo Overload


DcnmParticipantInfo Constructor (Guid, DcnmPersonInfo, Boolean, Boolean, Boolean, Boolean, Int32, Boolean, Boolean, DcnmSpecialOperationType)

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantInfo(
    Guid id,
    DcnmPersonInfo personInfo,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    bool isAuthenticated,
    bool hasSpecialPermission,
    DcnmSpecialOperationType vipType
)
Public Sub New (
    id As Guid,
    personInfo As DcnmPersonInfo,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canVote As Boolean,
    canUsePriority As Boolean,
    voteWeight As Integer,
    isAuthenticated As Boolean,
    hasSpecialPermission As Boolean,
    vipType As DcnmSpecialOperationType
)
public:
DcnmParticipantInfo(
    Guid id,
    DcnmPersonInfo^ personInfo,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    bool isAuthenticated,
    bool hasSpecialPermission,
    DcnmSpecialOperationType vipType
)

Parameters

id
Type: SystemGuid
Identifier of the participant
personInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPersonInfo
The person information of the participant.
canDiscuss
Type: SystemBoolean
Discussion capability of the participant.
canManageMeeting
Type: SystemBoolean
Manage Meeting capability of the participant.
canVote
Type: SystemBoolean
Voting capability of the participant.
canUsePriority
Type: SystemBoolean
Priority capability of the participant.
voteWeight
Type: SystemInt32
Weight of the vote.
isAuthenticated
Type: SystemBoolean
Participant authentication state.
hasSpecialPermission
Type: SystemBoolean
Participant has special permission or not.
vipType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpecialOperationType
Participant vip type.
See Also

Reference

DcnmParticipantInfo Class
DcnmParticipantInfo Overload


DcnmParticipantInfo Properties

The DcnmParticipantInfo type exposes the following members.

Properties
 | Name | Description
Public property | CanDiscuss | Indicates if the participant has discuss rights.
Public property | CanManageMeeting | Indicates if the participant has can manage meeting rights.
Public property | CanUsePriority | Indicates if the participant has priority rights.
Public property | CanVote | Indicates if the participant has vote rights.
Public property | HasSpecialPermission | Indicates if this participant has special permission.
Public property | Id | The identifier of the participant.
Public property | IsAuthenticated | Indicates if the participant is authenticated
Public property | PersonInfo | The person information of the participant.
Public property | VipType | The participant vip type.
Public property | VoteWeight | The vote weight.
Top
See Also

Reference

DcnmParticipantInfo Class


DcnmParticipantInfo.CanDiscuss Property

DcnmParticipantInfoCanDiscuss Property

Indicates if the participant has discuss rights.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanDiscuss { get; }
Public ReadOnly Property CanDiscuss As Boolean
    Get
public:
property bool CanDiscuss {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmParticipantInfo Class


DcnmParticipantInfo.CanManageMeeting Property

DcnmParticipantInfoCanManageMeeting Property

Indicates if the participant has can manage meeting rights.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanManageMeeting { get; }
Public ReadOnly Property CanManageMeeting As Boolean
    Get
public:
property bool CanManageMeeting {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmParticipantInfo Class


DcnmParticipantInfo.CanUsePriority Property

DcnmParticipantInfoCanUsePriority Property

Indicates if the participant has priority rights.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanUsePriority { get; }
Public ReadOnly Property CanUsePriority As Boolean
    Get
public:
property bool CanUsePriority {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmParticipantInfo Class


DcnmParticipantInfo.CanVote Property

DcnmParticipantInfoCanVote Property

Indicates if the participant has vote rights.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanVote { get; }
Public ReadOnly Property CanVote As Boolean
    Get
public:
property bool CanVote {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmParticipantInfo Class


DcnmParticipantInfo.HasSpecialPermission Property

DcnmParticipantInfoHasSpecialPermission Property

Indicates if this participant has special permission.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool HasSpecialPermission { get; }
Public ReadOnly Property HasSpecialPermission As Boolean
    Get
public:
property bool HasSpecialPermission {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmParticipantInfo Class


DcnmParticipantInfo.Id Property

DcnmParticipantInfoId Property

The identifier of the participant.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid Id { get; }
Public ReadOnly Property Id As Guid
    Get
public:
property Guid Id {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmParticipantInfo Class


DcnmParticipantInfo.IsAuthenticated Property

DcnmParticipantInfoIsAuthenticated Property

Indicates if the participant is authenticated

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsAuthenticated { get; }
Public ReadOnly Property IsAuthenticated As Boolean
    Get
public:
property bool IsAuthenticated {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmParticipantInfo Class


DcnmParticipantInfo.PersonInfo Property

DcnmParticipantInfoPersonInfo Property

The person information of the participant.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmPersonInfo PersonInfo { get; }
Public ReadOnly Property PersonInfo As DcnmPersonInfo
    Get
public:
property DcnmPersonInfo^ PersonInfo {
    DcnmPersonInfo^ get ();
}

Property Value

Type: DcnmPersonInfo
See Also

Reference

DcnmParticipantInfo Class


DcnmParticipantInfo.VipType Property

DcnmParticipantInfoVipType Property

The participant vip type.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpecialOperationType VipType { get; }
Public ReadOnly Property VipType As DcnmSpecialOperationType
    Get
public:
property DcnmSpecialOperationType VipType {
    DcnmSpecialOperationType get ();
}

Property Value

Type: DcnmSpecialOperationType
See Also

Reference

DcnmParticipantInfo Class


DcnmParticipantInfo.VoteWeight Property

DcnmParticipantInfoVoteWeight Property

The vote weight.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int VoteWeight { get; }
Public ReadOnly Property VoteWeight As Integer
    Get
public:
property int VoteWeight {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmParticipantInfo Class


DcnmParticipantInfo Methods

The DcnmParticipantInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmParticipantInfo Class


DcnmParticipantPreparationInfo Class

Defines the container for Dcnm user information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmParticipantPreparationInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmParticipantPreparationInfo
Public Class DcnmParticipantPreparationInfo
public ref class DcnmParticipantPreparationInfo

The DcnmParticipantPreparationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32) | Deprecated Constructor...
Public method | DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String) | Deprecated Constructor...
Public method | DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String) | Deprecated Constructor...
Public method | DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32) | Deprecated constructor...
Public method | DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32, Boolean) | Deprecated constructor...
Public method | DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32, Boolean, String) | Deprecated constructor...
Public method | DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32, Boolean, String, Guid) | Constructor...
Top
Properties
 | Name | Description
Public property | AssignedAt | Identifier of seat where the participant is assigned to.
Public property | CanDiscuss | Indicates if the participant has discuss rights.
Public property | CanManageMeeting | Indicates if the participant has can manage meeting rights.
Public property | CanUsePriority | Indicates if the participant has priority rights.
Public property | CanVote | Indicates if the participant has vote rights.
Public property | Country | The country of the user.
Public property | Email | The email of the user.
Public property | FirstName | The first name of the user.
Public property | Group | The group to which the participant belongs to.
Public property | HasSpecialPermission | The flag to set whether participant has special permission or not.
Public property | HeadphoneLanguage | The preferred headphone language of person. If the value is empty or language not part of meeting then floor language will be the headphone language.
Public property | HeadphoneUiLanguage | Obsolete. The preferred headphone language of person. If the value is empty or language not part of meeting then floor language will be the headphone language.
Public property | Id | The identifier of the participant.
Public property | LastName | The last name of the user.
Public property | MeetingId | The identifier of the meeting.
Public property | MiddleName | The middle name of the user.
Public property | NfcId | NfcId of the person
Public property | PictureUpdatedNumber | The picture updated number .
Public property | Region | The region of the user.
Public property | ScreenLine | The screen line of the user.
Public property | Title | The title of the user.
Public property | UiLanguage | The preferred ui language of person on device. If value is null or empty then room’s language will be the ui language.
Public property | UserGroupId | The usergroup id of the user.
Public property | UserId | The identifier of the user.
Public property | VipType | The type of VIP.
Public property | VoteWeight | The vote weight.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmParticipantPreparationInfo Constructor

Overload List
 | Name | Description
Public method | DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32) | Deprecated Constructor...
Public method | DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String) | Deprecated Constructor...
Public method | DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String) | Deprecated Constructor...
Public method | DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32) | Deprecated constructor...
Public method | DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32, Boolean) | Deprecated constructor...
Public method | DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32, Boolean, String) | Deprecated constructor...
Public method | DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32, Boolean, String, Guid) | Constructor...
Top
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo Constructor (Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32)

Deprecated Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantPreparationInfo(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    Guid userGroupId,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    string screenLine,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight
)
Public Sub New (
    id As Guid,
    meetingId As Guid,
    assignedAt As Guid,
    vipType As DcnmSpecialOperationType,
    userId As Guid,
    userGroupId As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    screenLine As String,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canVote As Boolean,
    canUsePriority As Boolean,
    voteWeight As Integer
)
public:
DcnmParticipantPreparationInfo(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    Guid userGroupId,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    String^ screenLine,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight
)

Parameters

id
Type: SystemGuid
Identifier of the participant
meetingId
Type: SystemGuid
Identifier of the meeting
assignedAt
Type: SystemGuid
Identifier of seat where the participant is assigned to.
vipType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpecialOperationType
The type of VIP DcnmSpecialOperationType
userId
Type: SystemGuid
The identifier of the user.
userGroupId
Type: SystemGuid
The user group id of the user.
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
screenLine
Type: SystemString
The screen line of the user
canDiscuss
Type: SystemBoolean
Discussion capability of the participant
canManageMeeting
Type: SystemBoolean
Manage Meeting capability of the participant
canVote
Type: SystemBoolean
Voting capability of the participant
canUsePriority
Type: SystemBoolean
Priority capability of the participant
voteWeight
Type: SystemInt32
Weight of the vote
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32) instead.
See Also

Reference

DcnmParticipantPreparationInfo Class
DcnmParticipantPreparationInfo Overload


DcnmParticipantPreparationInfo Constructor (Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String)

Deprecated Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantPreparationInfo(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    Guid userGroupId,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    string screenLine,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    string group
)
Public Sub New (
    id As Guid,
    meetingId As Guid,
    assignedAt As Guid,
    vipType As DcnmSpecialOperationType,
    userId As Guid,
    userGroupId As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    screenLine As String,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canVote As Boolean,
    canUsePriority As Boolean,
    voteWeight As Integer,
    group As String
)
public:
DcnmParticipantPreparationInfo(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    Guid userGroupId,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    String^ screenLine,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    String^ group
)

Parameters

id
Type: SystemGuid
Identifier of the participant
meetingId
Type: SystemGuid
Identifier of the meeting
assignedAt
Type: SystemGuid
Identifier of seat where the participant is assigned to.
vipType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpecialOperationType
The type of VIP DcnmSpecialOperationType
userId
Type: SystemGuid
The identifier of the user.
userGroupId
Type: SystemGuid
The user group id of the user.
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
screenLine
Type: SystemString
The screen line of the user
canDiscuss
Type: SystemBoolean
Discussion capability of the participant
canManageMeeting
Type: SystemBoolean
Manage Meeting capability of the participant
canVote
Type: SystemBoolean
Voting capability of the participant
canUsePriority
Type: SystemBoolean
Priority capability of the participant
voteWeight
Type: SystemInt32
Weight of the vote
group
Type: SystemString
The group to which participant belongs
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32) instead.
See Also

Reference

DcnmParticipantPreparationInfo Class
DcnmParticipantPreparationInfo Overload


DcnmParticipantPreparationInfo Constructor (Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String)

Deprecated Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantPreparationInfo(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    Guid userGroupId,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    string screenLine,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    string group,
    string nfcId
)
Public Sub New (
    id As Guid,
    meetingId As Guid,
    assignedAt As Guid,
    vipType As DcnmSpecialOperationType,
    userId As Guid,
    userGroupId As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    screenLine As String,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canVote As Boolean,
    canUsePriority As Boolean,
    voteWeight As Integer,
    group As String,
    nfcId As String
)
public:
DcnmParticipantPreparationInfo(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    Guid userGroupId,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    String^ screenLine,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    String^ group,
    String^ nfcId
)

Parameters

id
Type: SystemGuid
Identifier of the participant
meetingId
Type: SystemGuid
Identifier of the meeting
assignedAt
Type: SystemGuid
Identifier of seat where the participant is assigned to.
vipType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpecialOperationType
The type of VIP DcnmSpecialOperationType
userId
Type: SystemGuid
The identifier of the user.
userGroupId
Type: SystemGuid
The user group id of the user.
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
screenLine
Type: SystemString
The screen line of the user
canDiscuss
Type: SystemBoolean
Discussion capability of the participant
canManageMeeting
Type: SystemBoolean
Manage Meeting capability of the participant
canVote
Type: SystemBoolean
Voting capability of the participant
canUsePriority
Type: SystemBoolean
Priority capability of the participant
voteWeight
Type: SystemInt32
Weight of the vote
group
Type: SystemString
The group to which participant belongs
nfcId
Type: SystemString
The NFCID of the person.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32) instead.
See Also

Reference

DcnmParticipantPreparationInfo Class
DcnmParticipantPreparationInfo Overload


DcnmParticipantPreparationInfo Constructor (Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32)

Deprecated constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantPreparationInfo(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    Guid userGroupId,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    string screenLine,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    string group,
    string nfcId,
    int pictureUpdatedNumber
)
Public Sub New (
    id As Guid,
    meetingId As Guid,
    assignedAt As Guid,
    vipType As DcnmSpecialOperationType,
    userId As Guid,
    userGroupId As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    screenLine As String,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canVote As Boolean,
    canUsePriority As Boolean,
    voteWeight As Integer,
    group As String,
    nfcId As String,
    pictureUpdatedNumber As Integer
)
public:
DcnmParticipantPreparationInfo(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    Guid userGroupId,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    String^ screenLine,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    String^ group,
    String^ nfcId,
    int pictureUpdatedNumber
)

Parameters

id
Type: SystemGuid
Identifier of the participant
meetingId
Type: SystemGuid
Identifier of the meeting
assignedAt
Type: SystemGuid
Identifier of seat where the participant is assigned to.
vipType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpecialOperationType
The type of VIP DcnmSpecialOperationType
userId
Type: SystemGuid
The identifier of the user.
userGroupId
Type: SystemGuid
The user group id of the user.
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
screenLine
Type: SystemString
The screen line of the user
canDiscuss
Type: SystemBoolean
Discussion capability of the participant
canManageMeeting
Type: SystemBoolean
Manage Meeting capability of the participant
canVote
Type: SystemBoolean
Voting capability of the participant
canUsePriority
Type: SystemBoolean
Priority capability of the participant
voteWeight
Type: SystemInt32
Weight of the vote
group
Type: SystemString
The group to which the participant belongs to.
nfcId
Type: SystemString
The NFCID of the person.
pictureUpdatedNumber
Type: SystemInt32
The picture updated number of the person.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32, Boolean) instead.
See Also

Reference

DcnmParticipantPreparationInfo Class
DcnmParticipantPreparationInfo Overload


DcnmParticipantPreparationInfo Constructor (Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32, Boolean)

Deprecated constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantPreparationInfo(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    Guid userGroupId,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    string screenLine,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    string group,
    string nfcId,
    int pictureUpdatedNumber,
    bool hasSpecialPermission
)
Public Sub New (
    id As Guid,
    meetingId As Guid,
    assignedAt As Guid,
    vipType As DcnmSpecialOperationType,
    userId As Guid,
    userGroupId As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    screenLine As String,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canVote As Boolean,
    canUsePriority As Boolean,
    voteWeight As Integer,
    group As String,
    nfcId As String,
    pictureUpdatedNumber As Integer,
    hasSpecialPermission As Boolean
)
public:
DcnmParticipantPreparationInfo(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    Guid userGroupId,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    String^ screenLine,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    String^ group,
    String^ nfcId,
    int pictureUpdatedNumber,
    bool hasSpecialPermission
)

Parameters

id
Type: SystemGuid
Identifier of the participant
meetingId
Type: SystemGuid
Identifier of the meeting
assignedAt
Type: SystemGuid
Identifier of seat where the participant is assigned to.
vipType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpecialOperationType
The type of VIP DcnmSpecialOperationType
userId
Type: SystemGuid
The identifier of the user.
userGroupId
Type: SystemGuid
The user group id of the user.
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
screenLine
Type: SystemString
The screen line of the user
canDiscuss
Type: SystemBoolean
Discussion capability of the participant
canManageMeeting
Type: SystemBoolean
Manage Meeting capability of the participant
canVote
Type: SystemBoolean
Voting capability of the participant
canUsePriority
Type: SystemBoolean
Priority capability of the participant
voteWeight
Type: SystemInt32
Weight of the vote
group
Type: SystemString
The group to which the participant belongs to.
nfcId
Type: SystemString
The NFCID of the person.
pictureUpdatedNumber
Type: SystemInt32
The picture updated number of the person.
hasSpecialPermission
Type: SystemBoolean
The particiapant has special permission or not.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32, Boolean, String, Guid) instead.
See Also

Reference

DcnmParticipantPreparationInfo Class
DcnmParticipantPreparationInfo Overload


DcnmParticipantPreparationInfo Constructor (Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32, Boolean, String)

Deprecated constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantPreparationInfo(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    Guid userGroupId,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    string screenLine,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    string group,
    string nfcId,
    int pictureUpdatedNumber,
    bool hasSpecialPermission,
    string email
)
Public Sub New (
    id As Guid,
    meetingId As Guid,
    assignedAt As Guid,
    vipType As DcnmSpecialOperationType,
    userId As Guid,
    userGroupId As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    screenLine As String,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canVote As Boolean,
    canUsePriority As Boolean,
    voteWeight As Integer,
    group As String,
    nfcId As String,
    pictureUpdatedNumber As Integer,
    hasSpecialPermission As Boolean,
    email As String
)
public:
DcnmParticipantPreparationInfo(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    Guid userGroupId,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    String^ screenLine,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    String^ group,
    String^ nfcId,
    int pictureUpdatedNumber,
    bool hasSpecialPermission,
    String^ email
)

Parameters

id
Type: SystemGuid
Identifier of the participant
meetingId
Type: SystemGuid
Identifier of the meeting
assignedAt
Type: SystemGuid
Identifier of seat where the participant is assigned to.
vipType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpecialOperationType
The type of VIP DcnmSpecialOperationType
userId
Type: SystemGuid
The identifier of the user.
userGroupId
Type: SystemGuid
The user group id of the user.
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
screenLine
Type: SystemString
The screen line of the user
canDiscuss
Type: SystemBoolean
Discussion capability of the participant
canManageMeeting
Type: SystemBoolean
Manage Meeting capability of the participant
canVote
Type: SystemBoolean
Voting capability of the participant
canUsePriority
Type: SystemBoolean
Priority capability of the participant
voteWeight
Type: SystemInt32
Weight of the vote
group
Type: SystemString
The group to which the participant belongs to.
nfcId
Type: SystemString
The NFCID of the person.
pictureUpdatedNumber
Type: SystemInt32
The picture updated number of the person.
hasSpecialPermission
Type: SystemBoolean
The particiapant has special permission or not.
email
Type: SystemString
The email id of the user.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmParticipantPreparationInfo(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32, Boolean, String, Guid) instead.
See Also

Reference

DcnmParticipantPreparationInfo Class
DcnmParticipantPreparationInfo Overload


DcnmParticipantPreparationInfo Constructor (Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Guid, String, String, String, String, String, String, String, Boolean, Boolean, Boolean, Boolean, Int32, String, String, Int32, Boolean, String, Guid)

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantPreparationInfo(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    Guid userGroupId,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    string screenLine,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    string group,
    string nfcId,
    int pictureUpdatedNumber,
    bool hasSpecialPermission,
    string uiLanguage,
    Guid headphoneLanguage
)
Public Sub New (
    id As Guid,
    meetingId As Guid,
    assignedAt As Guid,
    vipType As DcnmSpecialOperationType,
    userId As Guid,
    userGroupId As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    screenLine As String,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canVote As Boolean,
    canUsePriority As Boolean,
    voteWeight As Integer,
    group As String,
    nfcId As String,
    pictureUpdatedNumber As Integer,
    hasSpecialPermission As Boolean,
    uiLanguage As String,
    headphoneLanguage As Guid
)
public:
DcnmParticipantPreparationInfo(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    Guid userGroupId,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    String^ screenLine,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    String^ group,
    String^ nfcId,
    int pictureUpdatedNumber,
    bool hasSpecialPermission,
    String^ uiLanguage,
    Guid headphoneLanguage
)

Parameters

id
Type: SystemGuid
Identifier of the participant
meetingId
Type: SystemGuid
Identifier of the meeting
assignedAt
Type: SystemGuid
Identifier of seat where the participant is assigned to.
vipType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpecialOperationType
The type of VIP DcnmSpecialOperationType
userId
Type: SystemGuid
The identifier of the user.
userGroupId
Type: SystemGuid
The user group id of the user.
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
screenLine
Type: SystemString
The screen line of the user
canDiscuss
Type: SystemBoolean
Discussion capability of the participant
canManageMeeting
Type: SystemBoolean
Manage Meeting capability of the participant
canVote
Type: SystemBoolean
Voting capability of the participant
canUsePriority
Type: SystemBoolean
Priority capability of the participant
voteWeight
Type: SystemInt32
Weight of the vote
group
Type: SystemString
The group to which the participant belongs to.
nfcId
Type: SystemString
The NFCID of the person.
pictureUpdatedNumber
Type: SystemInt32
The picture updated number of the person.
hasSpecialPermission
Type: SystemBoolean
The particiapant has special permission or not.
uiLanguage
Type: SystemString
The preferred ui language of person on device. If value is null or empty then room’s language will be the ui language.
headphoneLanguage
Type: SystemGuid
The preferred headphone language of person. If the value is empty or language not part of meeting then floor language will be the headphone language.
See Also

Reference

DcnmParticipantPreparationInfo Class
DcnmParticipantPreparationInfo Overload


DcnmParticipantPreparationInfo Properties

The DcnmParticipantPreparationInfo type exposes the following members.

Properties
 | Name | Description
Public property | AssignedAt | Identifier of seat where the participant is assigned to.
Public property | CanDiscuss | Indicates if the participant has discuss rights.
Public property | CanManageMeeting | Indicates if the participant has can manage meeting rights.
Public property | CanUsePriority | Indicates if the participant has priority rights.
Public property | CanVote | Indicates if the participant has vote rights.
Public property | Country | The country of the user.
Public property | Email | The email of the user.
Public property | FirstName | The first name of the user.
Public property | Group | The group to which the participant belongs to.
Public property | HasSpecialPermission | The flag to set whether participant has special permission or not.
Public property | HeadphoneLanguage | The preferred headphone language of person. If the value is empty or language not part of meeting then floor language will be the headphone language.
Public property | HeadphoneUiLanguage | Obsolete. The preferred headphone language of person. If the value is empty or language not part of meeting then floor language will be the headphone language.
Public property | Id | The identifier of the participant.
Public property | LastName | The last name of the user.
Public property | MeetingId | The identifier of the meeting.
Public property | MiddleName | The middle name of the user.
Public property | NfcId | NfcId of the person
Public property | PictureUpdatedNumber | The picture updated number .
Public property | Region | The region of the user.
Public property | ScreenLine | The screen line of the user.
Public property | Title | The title of the user.
Public property | UiLanguage | The preferred ui language of person on device. If value is null or empty then room’s language will be the ui language.
Public property | UserGroupId | The usergroup id of the user.
Public property | UserId | The identifier of the user.
Public property | VipType | The type of VIP.
Public property | VoteWeight | The vote weight.
Top
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.AssignedAt Property

DcnmParticipantPreparationInfoAssignedAt Property

Identifier of seat where the participant is assigned to.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid AssignedAt { get; }
Public ReadOnly Property AssignedAt As Guid
    Get
public:
property Guid AssignedAt {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.CanDiscuss Property

DcnmParticipantPreparationInfoCanDiscuss Property

Indicates if the participant has discuss rights.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanDiscuss { get; }
Public ReadOnly Property CanDiscuss As Boolean
    Get
public:
property bool CanDiscuss {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.CanManageMeeting Property

DcnmParticipantPreparationInfoCanManageMeeting Property

Indicates if the participant has can manage meeting rights.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanManageMeeting { get; }
Public ReadOnly Property CanManageMeeting As Boolean
    Get
public:
property bool CanManageMeeting {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.CanUsePriority Property

DcnmParticipantPreparationInfoCanUsePriority Property

Indicates if the participant has priority rights.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanUsePriority { get; }
Public ReadOnly Property CanUsePriority As Boolean
    Get
public:
property bool CanUsePriority {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.CanVote Property

DcnmParticipantPreparationInfoCanVote Property

Indicates if the participant has vote rights.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanVote { get; }
Public ReadOnly Property CanVote As Boolean
    Get
public:
property bool CanVote {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.Country Property

DcnmParticipantPreparationInfoCountry Property

The country of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Country { get; }
Public ReadOnly Property Country As String
    Get
public:
property String^ Country {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.Email Property

DcnmParticipantPreparationInfoEmail Property

The email of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Email { get; }
Public ReadOnly Property Email As String
    Get
public:
property String^ Email {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.FirstName Property

DcnmParticipantPreparationInfoFirstName Property

The first name of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string FirstName { get; }
Public ReadOnly Property FirstName As String
    Get
public:
property String^ FirstName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.Group Property

DcnmParticipantPreparationInfoGroup Property

The group to which the participant belongs to.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Group { get; }
Public ReadOnly Property Group As String
    Get
public:
property String^ Group {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.HasSpecialPermission Property

DcnmParticipantPreparationInfoHasSpecialPermission Property

The flag to set whether participant has special permission or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool HasSpecialPermission { get; }
Public ReadOnly Property HasSpecialPermission As Boolean
    Get
public:
property bool HasSpecialPermission {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.HeadphoneLanguage Property

DcnmParticipantPreparationInfoHeadphoneLanguage Property

The preferred headphone language of person. If the value is empty or language not part of meeting then floor language will be the headphone language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid HeadphoneLanguage { get; }
Public ReadOnly Property HeadphoneLanguage As Guid
    Get
public:
property Guid HeadphoneLanguage {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.HeadphoneUiLanguage Property

DcnmParticipantPreparationInfoHeadphoneUiLanguage Property

Note: This API is now obsolete.

The preferred headphone language of person. If the value is empty or language not part of meeting then floor language will be the headphone language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The HeadphoneUiLanguage property is deprecated; please use HeadphoneLanguage property.")]
public Guid HeadphoneUiLanguage { get; }
<ObsoleteAttribute("The HeadphoneUiLanguage property is deprecated; please use HeadphoneLanguage property.")>
Public ReadOnly Property HeadphoneUiLanguage As Guid
    Get
public:
[ObsoleteAttribute(L"The HeadphoneUiLanguage property is deprecated; please use HeadphoneLanguage property.")]
property Guid HeadphoneUiLanguage {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.Id Property

DcnmParticipantPreparationInfoId Property

The identifier of the participant.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid Id { get; }
Public ReadOnly Property Id As Guid
    Get
public:
property Guid Id {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.LastName Property

DcnmParticipantPreparationInfoLastName Property

The last name of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string LastName { get; }
Public ReadOnly Property LastName As String
    Get
public:
property String^ LastName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.MeetingId Property

DcnmParticipantPreparationInfoMeetingId Property

The identifier of the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid MeetingId { get; }
Public ReadOnly Property MeetingId As Guid
    Get
public:
property Guid MeetingId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.MiddleName Property

DcnmParticipantPreparationInfoMiddleName Property

The middle name of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string MiddleName { get; }
Public ReadOnly Property MiddleName As String
    Get
public:
property String^ MiddleName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.NfcId Property

DcnmParticipantPreparationInfoNfcId Property

NfcId of the person

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string NfcId { get; }
Public ReadOnly Property NfcId As String
    Get
public:
property String^ NfcId {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.PictureUpdatedNumber Property

DcnmParticipantPreparationInfoPictureUpdatedNumber Property

The picture updated number .

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int PictureUpdatedNumber { get; }
Public ReadOnly Property PictureUpdatedNumber As Integer
    Get
public:
property int PictureUpdatedNumber {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.Region Property

DcnmParticipantPreparationInfoRegion Property

The region of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Region { get; }
Public ReadOnly Property Region As String
    Get
public:
property String^ Region {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.ScreenLine Property

DcnmParticipantPreparationInfoScreenLine Property

The screen line of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string ScreenLine { get; }
Public ReadOnly Property ScreenLine As String
    Get
public:
property String^ ScreenLine {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.Title Property

DcnmParticipantPreparationInfoTitle Property

The title of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.UiLanguage Property

DcnmParticipantPreparationInfoUiLanguage Property

The preferred ui language of person on device. If value is null or empty then room’s language will be the ui language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string UiLanguage { get; }
Public ReadOnly Property UiLanguage As String
    Get
public:
property String^ UiLanguage {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.UserGroupId Property

DcnmParticipantPreparationInfoUserGroupId Property

The usergroup id of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid UserGroupId { get; }
Public ReadOnly Property UserGroupId As Guid
    Get
public:
property Guid UserGroupId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.UserId Property

DcnmParticipantPreparationInfoUserId Property

The identifier of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid UserId { get; }
Public ReadOnly Property UserId As Guid
    Get
public:
property Guid UserId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.VipType Property

DcnmParticipantPreparationInfoVipType Property

The type of VIP.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpecialOperationType VipType { get; }
Public ReadOnly Property VipType As DcnmSpecialOperationType
    Get
public:
property DcnmSpecialOperationType VipType {
    DcnmSpecialOperationType get ();
}

Property Value

Type: DcnmSpecialOperationType
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo.VoteWeight Property

DcnmParticipantPreparationInfoVoteWeight Property

The vote weight.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int VoteWeight { get; }
Public ReadOnly Property VoteWeight As Integer
    Get
public:
property int VoteWeight {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo Methods

The DcnmParticipantPreparationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmParticipantPreparationInfo Class


DcnmParticipantPreparationInfo2 Class

Defines the container for Dcnm user information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmParticipantPreparationInfo2

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmParticipantPreparationInfo2
Public Class DcnmParticipantPreparationInfo2
public ref class DcnmParticipantPreparationInfo2

The DcnmParticipantPreparationInfo2 type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmParticipantPreparationInfo2(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Boolean, Boolean, Boolean, Boolean, Int32, Boolean) | Obsolete. Constructor...
Public method | DcnmParticipantPreparationInfo2(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Boolean, Boolean, Boolean, Boolean, Int32, Boolean, String, String) | Constructor...
Top
Properties
 | Name | Description
Public property | AssignedAt | Identifier of seat where the participant is assigned to.
Public property | CanDiscuss | Indicates if the participant has discuss rights.
Public property | CanManageMeeting | Indicates if the participant has can manage meeting rights.
Public property | CanUsePriority | Indicates if the participant has priority rights.
Public property | CanVote | Indicates if the participant has vote rights.
Public property | HasSpecialPermission | Boolean Value indicates if this participant has special permission. Special permission is shown in the Meeting Application as VIP and is used to show the request list to participants and is used to show voting results.
Public property | Id | The identifier of the participant.
Public property | MeetingId | The identifier of the meeting.
Public property | ScreenLine | Participant screen line.
Public property | UserId | The identifier of the user.
Public property | UserName | Participant user name.
Public property | VipType | The type of VIP.
Public property | VoteWeight | The vote weight.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmParticipantPreparationInfo2 Constructor

Overload List
 | Name | Description
Public method | DcnmParticipantPreparationInfo2(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Boolean, Boolean, Boolean, Boolean, Int32, Boolean) | Obsolete. Constructor...
Public method | DcnmParticipantPreparationInfo2(Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Boolean, Boolean, Boolean, Boolean, Int32, Boolean, String, String) | Constructor...
Top
See Also

Reference

DcnmParticipantPreparationInfo2 Class


DcnmParticipantPreparationInfo2 Constructor (Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Boolean, Boolean, Boolean, Boolean, Int32, Boolean)

Note: This API is now obsolete.

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the non obselete constructor instead.")]
public DcnmParticipantPreparationInfo2(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    bool hasSpecialPermission
)
<ObsoleteAttribute("This method is obsolete, please use the non obselete constructor instead.")>
Public Sub New (
    id As Guid,
    meetingId As Guid,
    assignedAt As Guid,
    vipType As DcnmSpecialOperationType,
    userId As Guid,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canVote As Boolean,
    canUsePriority As Boolean,
    voteWeight As Integer,
    hasSpecialPermission As Boolean
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the non obselete constructor instead.")]
DcnmParticipantPreparationInfo2(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    bool hasSpecialPermission
)

Parameters

id
Type: SystemGuid
Identifier of the participant
meetingId
Type: SystemGuid
Identifier of the meeting
assignedAt
Type: SystemGuid
Identifier of seat where the participant is assigned to.
vipType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpecialOperationType
The type of VIP DcnmSpecialOperationType assigned to this participant.
userId
Type: SystemGuid
The identifier of the user.
canDiscuss
Type: SystemBoolean
Discussion capability of the participant
canManageMeeting
Type: SystemBoolean
Manage Meeting capability of the participant
canVote
Type: SystemBoolean
Voting capability of the participant
canUsePriority
Type: SystemBoolean
Priority capability of the participant
voteWeight
Type: SystemInt32
Weight of the vote
hasSpecialPermission
Type: SystemBoolean
Boolean Value indicates if this participant has special permission. Special permission is shown in the Meeting Application as VIP and is used to show the request list to participants and is used to show voting results.
See Also

Reference

DcnmParticipantPreparationInfo2 Class
DcnmParticipantPreparationInfo2 Overload


DcnmParticipantPreparationInfo2 Constructor (Guid, Guid, Guid, DcnmSpecialOperationType, Guid, Boolean, Boolean, Boolean, Boolean, Int32, Boolean, String, String)

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantPreparationInfo2(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    bool hasSpecialPermission,
    string screenLine,
    string userName
)
Public Sub New (
    id As Guid,
    meetingId As Guid,
    assignedAt As Guid,
    vipType As DcnmSpecialOperationType,
    userId As Guid,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canVote As Boolean,
    canUsePriority As Boolean,
    voteWeight As Integer,
    hasSpecialPermission As Boolean,
    screenLine As String,
    userName As String
)
public:
DcnmParticipantPreparationInfo2(
    Guid id,
    Guid meetingId,
    Guid assignedAt,
    DcnmSpecialOperationType vipType,
    Guid userId,
    bool canDiscuss,
    bool canManageMeeting,
    bool canVote,
    bool canUsePriority,
    int voteWeight,
    bool hasSpecialPermission,
    String^ screenLine,
    String^ userName
)

Parameters

id
Type: SystemGuid
Identifier of the participant
meetingId
Type: SystemGuid
Identifier of the meeting
assignedAt
Type: SystemGuid
Identifier of seat where the participant is assigned to.
vipType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpecialOperationType
The type of VIP DcnmSpecialOperationType assigned to this participant.
userId
Type: SystemGuid
The identifier of the user.
canDiscuss
Type: SystemBoolean
Discussion capability of the participant
canManageMeeting
Type: SystemBoolean
Manage Meeting capability of the participant
canVote
Type: SystemBoolean
Voting capability of the participant
canUsePriority
Type: SystemBoolean
Priority capability of the participant
voteWeight
Type: SystemInt32
Weight of the vote
hasSpecialPermission
Type: SystemBoolean
Boolean Value indicates if this participant has special permission. Special permission is shown in the Meeting Application as VIP and is used to show the request list to participants and is used to show voting results.
screenLine
Type: SystemString
Participant screen line
userName
Type: SystemString
Participant user name
See Also

Reference

DcnmParticipantPreparationInfo2 Class
DcnmParticipantPreparationInfo2 Overload


DcnmParticipantPreparationInfo2 Properties

The DcnmParticipantPreparationInfo2 type exposes the following members.

Properties
 | Name | Description
Public property | AssignedAt | Identifier of seat where the participant is assigned to.
Public property | CanDiscuss | Indicates if the participant has discuss rights.
Public property | CanManageMeeting | Indicates if the participant has can manage meeting rights.
Public property | CanUsePriority | Indicates if the participant has priority rights.
Public property | CanVote | Indicates if the participant has vote rights.
Public property | HasSpecialPermission | Boolean Value indicates if this participant has special permission. Special permission is shown in the Meeting Application as VIP and is used to show the request list to participants and is used to show voting results.
Public property | Id | The identifier of the participant.
Public property | MeetingId | The identifier of the meeting.
Public property | ScreenLine | Participant screen line.
Public property | UserId | The identifier of the user.
Public property | UserName | Participant user name.
Public property | VipType | The type of VIP.
Public property | VoteWeight | The vote weight.
Top
See Also

Reference

DcnmParticipantPreparationInfo2 Class


DcnmParticipantPreparationInfo2.AssignedAt Property

DcnmParticipantPreparationInfo2AssignedAt Property

Identifier of seat where the participant is assigned to.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid AssignedAt { get; }
Public ReadOnly Property AssignedAt As Guid
    Get
public:
property Guid AssignedAt {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmParticipantPreparationInfo2 Class


DcnmParticipantPreparationInfo2.CanDiscuss Property

DcnmParticipantPreparationInfo2CanDiscuss Property

Indicates if the participant has discuss rights.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanDiscuss { get; }
Public ReadOnly Property CanDiscuss As Boolean
    Get
public:
property bool CanDiscuss {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmParticipantPreparationInfo2 Class


DcnmParticipantPreparationInfo2.CanManageMeeting Property

DcnmParticipantPreparationInfo2CanManageMeeting Property

Indicates if the participant has can manage meeting rights.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanManageMeeting { get; }
Public ReadOnly Property CanManageMeeting As Boolean
    Get
public:
property bool CanManageMeeting {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmParticipantPreparationInfo2 Class


DcnmParticipantPreparationInfo2.CanUsePriority Property

DcnmParticipantPreparationInfo2CanUsePriority Property

Indicates if the participant has priority rights.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanUsePriority { get; }
Public ReadOnly Property CanUsePriority As Boolean
    Get
public:
property bool CanUsePriority {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmParticipantPreparationInfo2 Class


DcnmParticipantPreparationInfo2.CanVote Property

DcnmParticipantPreparationInfo2CanVote Property

Indicates if the participant has vote rights.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanVote { get; }
Public ReadOnly Property CanVote As Boolean
    Get
public:
property bool CanVote {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmParticipantPreparationInfo2 Class


DcnmParticipantPreparationInfo2.HasSpecialPermission Property

DcnmParticipantPreparationInfo2HasSpecialPermission Property

Boolean Value indicates if this participant has special permission. Special permission is shown in the Meeting Application as VIP and is used to show the request list to participants and is used to show voting results.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool HasSpecialPermission { get; }
Public ReadOnly Property HasSpecialPermission As Boolean
    Get
public:
property bool HasSpecialPermission {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmParticipantPreparationInfo2 Class


DcnmParticipantPreparationInfo2.Id Property

DcnmParticipantPreparationInfo2Id Property

The identifier of the participant.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid Id { get; }
Public ReadOnly Property Id As Guid
    Get
public:
property Guid Id {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmParticipantPreparationInfo2 Class


DcnmParticipantPreparationInfo2.MeetingId Property

DcnmParticipantPreparationInfo2MeetingId Property

The identifier of the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid MeetingId { get; }
Public ReadOnly Property MeetingId As Guid
    Get
public:
property Guid MeetingId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmParticipantPreparationInfo2 Class


DcnmParticipantPreparationInfo2.ScreenLine Property

DcnmParticipantPreparationInfo2ScreenLine Property

Participant screen line.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string ScreenLine { get; }
Public ReadOnly Property ScreenLine As String
    Get
public:
property String^ ScreenLine {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmParticipantPreparationInfo2 Class


DcnmParticipantPreparationInfo2.UserId Property

DcnmParticipantPreparationInfo2UserId Property

The identifier of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid UserId { get; }
Public ReadOnly Property UserId As Guid
    Get
public:
property Guid UserId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmParticipantPreparationInfo2 Class


DcnmParticipantPreparationInfo2.UserName Property

DcnmParticipantPreparationInfo2UserName Property

Participant user name.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string UserName { get; }
Public ReadOnly Property UserName As String
    Get
public:
property String^ UserName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmParticipantPreparationInfo2 Class


DcnmParticipantPreparationInfo2.VipType Property

DcnmParticipantPreparationInfo2VipType Property

The type of VIP.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpecialOperationType VipType { get; }
Public ReadOnly Property VipType As DcnmSpecialOperationType
    Get
public:
property DcnmSpecialOperationType VipType {
    DcnmSpecialOperationType get ();
}

Property Value

Type: DcnmSpecialOperationType
See Also

Reference

DcnmParticipantPreparationInfo2 Class


DcnmParticipantPreparationInfo2.VoteWeight Property

DcnmParticipantPreparationInfo2VoteWeight Property

The vote weight.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int VoteWeight { get; }
Public ReadOnly Property VoteWeight As Integer
    Get
public:
property int VoteWeight {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmParticipantPreparationInfo2 Class


DcnmParticipantPreparationInfo2 Methods

The DcnmParticipantPreparationInfo2 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmParticipantPreparationInfo2 Class


DcnmParticipantSeatAssignmentInfo Class

Container for participant seat assignment info.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmParticipantSeatAssignmentInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmParticipantSeatAssignmentInfo
Public Class DcnmParticipantSeatAssignmentInfo
public ref class DcnmParticipantSeatAssignmentInfo

The DcnmParticipantSeatAssignmentInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmParticipantSeatAssignmentInfo | Default constructor for class
Public method | DcnmParticipantSeatAssignmentInfo(Guid, Guid) | Constructor for class.
Top
Properties
 | Name | Description
Public property | ParticipantId | The participant id.
Public property | SeatId | The seat id.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmParticipantSeatAssignmentInfo Constructor

Overload List
 | Name | Description
Public method | DcnmParticipantSeatAssignmentInfo | Default constructor for class
Public method | DcnmParticipantSeatAssignmentInfo(Guid, Guid) | Constructor for class.
Top
See Also

Reference

DcnmParticipantSeatAssignmentInfo Class


DcnmParticipantSeatAssignmentInfo Constructor

Default constructor for class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantSeatAssignmentInfo()
Public Sub New
public:
DcnmParticipantSeatAssignmentInfo()
See Also

Reference

DcnmParticipantSeatAssignmentInfo Class
DcnmParticipantSeatAssignmentInfo Overload


DcnmParticipantSeatAssignmentInfo Constructor (Guid, Guid)

Constructor for class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantSeatAssignmentInfo(
    Guid participantId,
    Guid seatId
)
Public Sub New (
    participantId As Guid,
    seatId As Guid
)
public:
DcnmParticipantSeatAssignmentInfo(
    Guid participantId,
    Guid seatId
)

Parameters

participantId
Type: SystemGuid
The participant id.
seatId
Type: SystemGuid
The seat id.
See Also

Reference

DcnmParticipantSeatAssignmentInfo Class
DcnmParticipantSeatAssignmentInfo Overload


DcnmParticipantSeatAssignmentInfo Properties

The DcnmParticipantSeatAssignmentInfo type exposes the following members.

Properties
 | Name | Description
Public property | ParticipantId | The participant id.
Public property | SeatId | The seat id.
Top
See Also

Reference

DcnmParticipantSeatAssignmentInfo Class


DcnmParticipantSeatAssignmentInfo.ParticipantId Property

DcnmParticipantSeatAssignmentInfoParticipantId Property

The participant id.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid ParticipantId { get; }
Public ReadOnly Property ParticipantId As Guid
    Get
public:
property Guid ParticipantId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmParticipantSeatAssignmentInfo Class


DcnmParticipantSeatAssignmentInfo.SeatId Property

DcnmParticipantSeatAssignmentInfoSeatId Property

The seat id.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid SeatId { get; }
Public ReadOnly Property SeatId As Guid
    Get
public:
property Guid SeatId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmParticipantSeatAssignmentInfo Class


DcnmParticipantSeatAssignmentInfo Methods

The DcnmParticipantSeatAssignmentInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmParticipantSeatAssignmentInfo Class


DcnmParticipationInfo Class

Contains the participation info for the participant in the active meeting.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmParticipationInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmParticipationInfo
Public Class DcnmParticipationInfo
public ref class DcnmParticipationInfo

The DcnmParticipationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmParticipationInfo | Constructor for class.
Top
Properties
 | Name | Description
Public property | Id | The identification of the participation.
Public property | ParticipantInfo | The participant information of the speaker.
Public property | SeatInfo | The seat information of the speaker
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
A participation is used to capture the relation between a single participant of a meeting and the seat where the participant is identified at. The DcnmParticipationInfo represents either
  • A unoccupied seat, no participant is identified as being seated at it. In this case the participant information of participation is empty.
  • A participant of the meeting who is not identified seated. In this case the seat information of the participation is empty.
  • A participant of the meeting who has identified himself at a seat. In this case both the participant and seat information in the participation contain valid info.
The DcnmParticipationInfo is identified by a unique identifier Id which is updated according the above mentioned relations. This participation identifier should be used when controlling speakers using the IControlSpeaker interface.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmParticipationInfo Constructor

Constructor for class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipationInfo(
    Guid id,
    DcnmParticipantInfo participantInfo,
    DcnmSeatInfo seatInfo
)
Public Sub New (
    id As Guid,
    participantInfo As DcnmParticipantInfo,
    seatInfo As DcnmSeatInfo
)
public:
DcnmParticipationInfo(
    Guid id,
    DcnmParticipantInfo^ participantInfo,
    DcnmSeatInfo^ seatInfo
)

Parameters

id
Type: SystemGuid
The participation identifier.
participantInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmParticipantInfo
The participant info.
seatInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSeatInfo
The seat info.
See Also

Reference

DcnmParticipationInfo Class


DcnmParticipationInfo Properties

The DcnmParticipationInfo type exposes the following members.

Properties
 | Name | Description
Public property | Id | The identification of the participation.
Public property | ParticipantInfo | The participant information of the speaker.
Public property | SeatInfo | The seat information of the speaker
Top
See Also

Reference

DcnmParticipationInfo Class


DcnmParticipationInfo.Id Property

DcnmParticipationInfoId Property

The identification of the participation.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid Id { get; }
Public ReadOnly Property Id As Guid
    Get
public:
property Guid Id {
    Guid get ();
}

Property Value

Type: Guid
Remarks
Based on whether or not a participant is identified at a seat in the meeting, the Id either represents the value for the seat Id in case of an unoccupied seat, or a Id in case of a participant (the participant may not be identified at a seat however).
See Also

Reference

DcnmParticipationInfo Class


DcnmParticipationInfo.ParticipantInfo Property

DcnmParticipationInfoParticipantInfo Property

The participant information of the speaker.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantInfo ParticipantInfo { get; }
Public ReadOnly Property ParticipantInfo As DcnmParticipantInfo
    Get
public:
property DcnmParticipantInfo^ ParticipantInfo {
    DcnmParticipantInfo^ get ();
}

Property Value

Type: DcnmParticipantInfo
See Also

Reference

DcnmParticipationInfo Class


DcnmParticipationInfo.SeatInfo Property

DcnmParticipationInfoSeatInfo Property

The seat information of the speaker

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSeatInfo SeatInfo { get; }
Public ReadOnly Property SeatInfo As DcnmSeatInfo
    Get
public:
property DcnmSeatInfo^ SeatInfo {
    DcnmSeatInfo^ get ();
}

Property Value

Type: DcnmSeatInfo
See Also

Reference

DcnmParticipationInfo Class


DcnmParticipationInfo Methods

The DcnmParticipationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmParticipationInfo Class


DcnmParticipationListInfo Class

Contains the participation info for the participants in a prepared meeting and is retreived during an active meeting.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmParticipationListInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmParticipationListInfo
Public Class DcnmParticipationListInfo
public ref class DcnmParticipationListInfo

The DcnmParticipationListInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmParticipationListInfo | Constructor for class.
Top
Properties
 | Name | Description
Public property | MeetingId | The meeting id.
Public property | ParticipationInfo | The participant information for the meeting.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmParticipationListInfo Constructor

Constructor for class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipationListInfo(
    Guid meetingId,
    IList<DcnmParticipationInfo> participationInfo
)
Public Sub New (
    meetingId As Guid,
    participationInfo As IList(Of DcnmParticipationInfo)
)
public:
DcnmParticipationListInfo(
    Guid meetingId,
    IList<DcnmParticipationInfo^>^ participationInfo
)

Parameters

meetingId
Type: SystemGuid
The id of the meeting.
participationInfo
Type: System.Collections.GenericIList DcnmParticipationInfo
The participation info.
See Also

Reference

DcnmParticipationListInfo Class


DcnmParticipationListInfo Properties

The DcnmParticipationListInfo type exposes the following members.

Properties
 | Name | Description
Public property | MeetingId | The meeting id.
Public property | ParticipationInfo | The participant information for the meeting.
Top
See Also

Reference

DcnmParticipationListInfo Class


DcnmParticipationListInfo.MeetingId Property

DcnmParticipationListInfoMeetingId Property

The meeting id.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid MeetingId { get; }
Public ReadOnly Property MeetingId As Guid
    Get
public:
property Guid MeetingId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmParticipationListInfo Class


DcnmParticipationListInfo.ParticipationInfo Property

DcnmParticipationListInfoParticipationInfo Property

The participant information for the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<DcnmParticipationInfo> ParticipationInfo { get; }
Public ReadOnly Property ParticipationInfo As IList(Of DcnmParticipationInfo)
    Get
public:
property IList<DcnmParticipationInfo^>^ ParticipationInfo {
    IList<DcnmParticipationInfo^>^ get ();
}

Property Value

Type: IList DcnmParticipationInfo
See Also

Reference

DcnmParticipationListInfo Class


DcnmParticipationListInfo Methods

The DcnmParticipationListInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmParticipationListInfo Class


DcnmPersonInfo Class

Contains the person information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPersonInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmPersonInfo
Public Class DcnmPersonInfo
public ref class DcnmPersonInfo

The DcnmPersonInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmPersonInfo | Default constructor.
Public method | DcnmPersonInfo(Guid, String, String, String, String, String, String, String) | Obsolete. Constructor...
Public method | DcnmPersonInfo(Guid, String, String, String, String, String, String, String, String) | Obsolete. Constructor...
Public method | DcnmPersonInfo(Guid, String, String, String, String, String, String, String, String, Int32) | Obsolete. Constructor...
Public method | DcnmPersonInfo(Guid, String, String, String, String, String, String, String, String, Int32, String, Guid) | Obsolete. Constructor...
Public method | DcnmPersonInfo(Guid, String, String, String, String, String, String, String, String, Int32, String, Guid, String, Boolean) | Obsolete. Constructor...
Public method | DcnmPersonInfo(Guid, String, String, String, String, String, String, String, String, String, Int32, String, Guid, String, Boolean) | Constructor...
Top
Properties
 | Name | Description
Public property | AudibleBeeps | The setting for persons in order to listen to beeps while voting.
Public property | Country | The country of the user.
Public property | Email | The user's email
Public property | FirstName | The first name of the user.
Public property | Group | The group of the user
Public property | HeadphoneLanguage | The headphone language of person on device.
Public property | Id | The identifier of the participant.
Public property | LastName | The last name of the user.
Public property | MiddleName | The middle name of the user.
Public property | PictureUpdatedNumber | The picture updated number of the user
Public property | Region | The region of the user.
Public property | ScreenLine | The screen line of the user.
Public property | Title | The title of the user.
Public property | UiLanguage | The person Ui language on device.
Public property | UserName | The user name of the user.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmPersonInfo Constructor

Overload List
 | Name | Description
Public method | DcnmPersonInfo | Default constructor.
Public method | DcnmPersonInfo(Guid, String, String, String, String, String, String, String) | Obsolete. Constructor...
Public method | DcnmPersonInfo(Guid, String, String, String, String, String, String, String, String) | Obsolete. Constructor...
Public method | DcnmPersonInfo(Guid, String, String, String, String, String, String, String, String, Int32) | Obsolete. Constructor...
Public method | DcnmPersonInfo(Guid, String, String, String, String, String, String, String, String, Int32, String, Guid) | Obsolete. Constructor...
Public method | DcnmPersonInfo(Guid, String, String, String, String, String, String, String, String, Int32, String, Guid, String, Boolean) | Obsolete. Constructor...
Public method | DcnmPersonInfo(Guid, String, String, String, String, String, String, String, String, String, Int32, String, Guid, String, Boolean) | Constructor...
Top
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo Constructor

Default constructor.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmPersonInfo()
Public Sub New
public:
DcnmPersonInfo()
See Also

Reference

DcnmPersonInfo Class
DcnmPersonInfo Overload


DcnmPersonInfo Constructor (Guid, String, String, String, String, String, String, String)

Note: This API is now obsolete.

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")]
public DcnmPersonInfo(
    Guid id,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    string screenLine
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")>
Public Sub New (
    id As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    screenLine As String
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection instead.")]
DcnmPersonInfo(
    Guid id,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    String^ screenLine
)

Parameters

id
Type: SystemGuid
Identifier of the participant
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
screenLine
Type: SystemString
The screen line of the user
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmPersonInfo(Guid, String, String, String, String, String, String, String, String, Int32) instead.
See Also

Reference

DcnmPersonInfo Class
DcnmPersonInfo Overload


DcnmPersonInfo Constructor (Guid, String, String, String, String, String, String, String, String)

Note: This API is now obsolete.

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")]
public DcnmPersonInfo(
    Guid id,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    string screenLine,
    string group
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")>
Public Sub New (
    id As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    screenLine As String,
    group As String
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection instead.")]
DcnmPersonInfo(
    Guid id,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    String^ screenLine,
    String^ group
)

Parameters

id
Type: SystemGuid
Identifier of the participant
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
screenLine
Type: SystemString
The screen line of the user
group
Type: SystemString
The group of the user
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmPersonInfo(Guid, String, String, String, String, String, String, String, String, Int32) instead.
See Also

Reference

DcnmPersonInfo Class
DcnmPersonInfo Overload


DcnmPersonInfo Constructor (Guid, String, String, String, String, String, String, String, String, Int32)

Note: This API is now obsolete.

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")]
public DcnmPersonInfo(
    Guid id,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    string screenLine,
    string group,
    int pictureUpdatedNumber
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")>
Public Sub New (
    id As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    screenLine As String,
    group As String,
    pictureUpdatedNumber As Integer
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection instead.")]
DcnmPersonInfo(
    Guid id,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    String^ screenLine,
    String^ group,
    int pictureUpdatedNumber
)

Parameters

id
Type: SystemGuid
Identifier of the participant
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
screenLine
Type: SystemString
The screen line of the user
group
Type: SystemString
The group of the user
pictureUpdatedNumber
Type: SystemInt32
The picture updated number of the user.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmPersonInfo(Guid, String, String, String, String, String, String, String, String, Int32, String, Guid) instead.
See Also

Reference

DcnmPersonInfo Class
DcnmPersonInfo Overload


DcnmPersonInfo Constructor (Guid, String, String, String, String, String, String, String, String, Int32, String, Guid)

Note: This API is now obsolete.

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")]
public DcnmPersonInfo(
    Guid id,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    string screenLine,
    string group,
    int pictureUpdatedNumber,
    string uiLanguage,
    Guid headphoneLanguage
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")>
Public Sub New (
    id As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    screenLine As String,
    group As String,
    pictureUpdatedNumber As Integer,
    uiLanguage As String,
    headphoneLanguage As Guid
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection instead.")]
DcnmPersonInfo(
    Guid id,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    String^ screenLine,
    String^ group,
    int pictureUpdatedNumber,
    String^ uiLanguage,
    Guid headphoneLanguage
)

Parameters

id
Type: SystemGuid
Identifier of the participant
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
screenLine
Type: SystemString
The screen line of the user
group
Type: SystemString
The group of the user
pictureUpdatedNumber
Type: SystemInt32
The picture updated number of the user.
uiLanguage
Type: SystemString
The ui language of user. It Should be one of the values returned by GetUiLanguagesAsync() or an empty string which represents Default Room's Language.
headphoneLanguage
Type: SystemGuid
The headphone language of user on device.
See Also

Reference

DcnmPersonInfo Class
DcnmPersonInfo Overload


DcnmPersonInfo Constructor (Guid, String, String, String, String, String, String, String, String, Int32, String, Guid, String, Boolean)

Note: This API is now obsolete.

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the non obselete constructor instead.")]
public DcnmPersonInfo(
    Guid id,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    string screenLine,
    string group,
    int pictureUpdatedNumber,
    string uiLanguage,
    Guid headphoneLanguage,
    string email,
    bool audibleBeeps
)
<ObsoleteAttribute("This method is obsolete, please use the non obselete constructor instead.")>
Public Sub New (
    id As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    screenLine As String,
    group As String,
    pictureUpdatedNumber As Integer,
    uiLanguage As String,
    headphoneLanguage As Guid,
    email As String,
    audibleBeeps As Boolean
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the non obselete constructor instead.")]
DcnmPersonInfo(
    Guid id,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    String^ screenLine,
    String^ group,
    int pictureUpdatedNumber,
    String^ uiLanguage,
    Guid headphoneLanguage,
    String^ email,
    bool audibleBeeps
)

Parameters

id
Type: SystemGuid
Identifier of the participant
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
screenLine
Type: SystemString
The screen line of the user
group
Type: SystemString
The group of the user
pictureUpdatedNumber
Type: SystemInt32
The picture updated number of the user.
uiLanguage
Type: SystemString
The ui language of user. It Should be one of the values returned by GetUiLanguagesAsync() or an empty string which represents Default Room's Language.
headphoneLanguage
Type: SystemGuid
The headphone language of user on device.
email
Type: SystemString
Email id of the user
audibleBeeps
Type: SystemBoolean
The setting for persons in order to listen to beeps while voting.
See Also

Reference

DcnmPersonInfo Class
DcnmPersonInfo Overload


DcnmPersonInfo Constructor (Guid, String, String, String, String, String, String, String, String, String, Int32, String, Guid, String, Boolean)

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmPersonInfo(
    Guid id,
    string userName,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    string screenLine,
    string group,
    int pictureUpdatedNumber,
    string uiLanguage,
    Guid headphoneLanguage,
    string email,
    bool audibleBeeps
)
Public Sub New (
    id As Guid,
    userName As String,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    screenLine As String,
    group As String,
    pictureUpdatedNumber As Integer,
    uiLanguage As String,
    headphoneLanguage As Guid,
    email As String,
    audibleBeeps As Boolean
)
public:
DcnmPersonInfo(
    Guid id,
    String^ userName,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    String^ screenLine,
    String^ group,
    int pictureUpdatedNumber,
    String^ uiLanguage,
    Guid headphoneLanguage,
    String^ email,
    bool audibleBeeps
)

Parameters

id
Type: SystemGuid
Identifier of the participant
userName
Type: SystemString
User name of the participant
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
screenLine
Type: SystemString
The screen line of the user
group
Type: SystemString
The group of the user
pictureUpdatedNumber
Type: SystemInt32
The picture updated number of the user.
uiLanguage
Type: SystemString
The ui language of user. It Should be one of the values returned by GetUiLanguagesAsync() or an empty string which represents Default Room's Language.
headphoneLanguage
Type: SystemGuid
The headphone language of user on device.
email
Type: SystemString
Email id of the user
audibleBeeps
Type: SystemBoolean
The setting for persons in order to listen to beeps while voting.
See Also

Reference

DcnmPersonInfo Class
DcnmPersonInfo Overload


DcnmPersonInfo Properties

The DcnmPersonInfo type exposes the following members.

Properties
 | Name | Description
Public property | AudibleBeeps | The setting for persons in order to listen to beeps while voting.
Public property | Country | The country of the user.
Public property | Email | The user's email
Public property | FirstName | The first name of the user.
Public property | Group | The group of the user
Public property | HeadphoneLanguage | The headphone language of person on device.
Public property | Id | The identifier of the participant.
Public property | LastName | The last name of the user.
Public property | MiddleName | The middle name of the user.
Public property | PictureUpdatedNumber | The picture updated number of the user
Public property | Region | The region of the user.
Public property | ScreenLine | The screen line of the user.
Public property | Title | The title of the user.
Public property | UiLanguage | The person Ui language on device.
Public property | UserName | The user name of the user.
Top
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo.AudibleBeeps Property

DcnmPersonInfoAudibleBeeps Property

The setting for persons in order to listen to beeps while voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AudibleBeeps { get; }
Public ReadOnly Property AudibleBeeps As Boolean
    Get
public:
property bool AudibleBeeps {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo.Country Property

DcnmPersonInfoCountry Property

The country of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Country { get; }
Public ReadOnly Property Country As String
    Get
public:
property String^ Country {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo.Email Property

DcnmPersonInfoEmail Property

The user's email

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Email { get; }
Public ReadOnly Property Email As String
    Get
public:
property String^ Email {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo.FirstName Property

DcnmPersonInfoFirstName Property

The first name of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string FirstName { get; }
Public ReadOnly Property FirstName As String
    Get
public:
property String^ FirstName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo.Group Property

DcnmPersonInfoGroup Property

The group of the user

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Group { get; }
Public ReadOnly Property Group As String
    Get
public:
property String^ Group {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo.HeadphoneLanguage Property

DcnmPersonInfoHeadphoneLanguage Property

The headphone language of person on device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid HeadphoneLanguage { get; }
Public ReadOnly Property HeadphoneLanguage As Guid
    Get
public:
property Guid HeadphoneLanguage {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo.Id Property

DcnmPersonInfoId Property

The identifier of the participant.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid Id { get; }
Public ReadOnly Property Id As Guid
    Get
public:
property Guid Id {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo.LastName Property

DcnmPersonInfoLastName Property

The last name of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string LastName { get; }
Public ReadOnly Property LastName As String
    Get
public:
property String^ LastName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo.MiddleName Property

DcnmPersonInfoMiddleName Property

The middle name of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string MiddleName { get; }
Public ReadOnly Property MiddleName As String
    Get
public:
property String^ MiddleName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo.PictureUpdatedNumber Property

DcnmPersonInfoPictureUpdatedNumber Property

The picture updated number of the user

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int PictureUpdatedNumber { get; }
Public ReadOnly Property PictureUpdatedNumber As Integer
    Get
public:
property int PictureUpdatedNumber {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo.Region Property

DcnmPersonInfoRegion Property

The region of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Region { get; }
Public ReadOnly Property Region As String
    Get
public:
property String^ Region {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo.ScreenLine Property

DcnmPersonInfoScreenLine Property

The screen line of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string ScreenLine { get; }
Public ReadOnly Property ScreenLine As String
    Get
public:
property String^ ScreenLine {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo.Title Property

DcnmPersonInfoTitle Property

The title of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo.UiLanguage Property

DcnmPersonInfoUiLanguage Property

The person Ui language on device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string UiLanguage { get; }
Public ReadOnly Property UiLanguage As String
    Get
public:
property String^ UiLanguage {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo.UserName Property

DcnmPersonInfoUserName Property

The user name of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string UserName { get; }
Public ReadOnly Property UserName As String
    Get
public:
property String^ UserName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmPersonInfo Class


DcnmPersonInfo Methods

The DcnmPersonInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmPersonInfo Class


DcnmPluginCommand Class

A command message that gets sent from an API client to a plugin
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPluginCommand

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmPluginCommand
Public Class DcnmPluginCommand
public ref class DcnmPluginCommand

The DcnmPluginCommand type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmPluginCommand | Initializes a new instance of the DcnmPluginCommand class
Top
Properties
 | Name | Description
Public property | Command | Name of the command to send. Use IPlugin.GetPlugin(PluginName).Methods to see what methods are supported by the plugin
Public property | Parameters | Parameters for the command.
Public property | PluginName | Name of the destination plugin. Use IPlugin.GetPlugins() to get a list of all available plugins
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmPluginCommand Constructor

Initializes a new instance of the DcnmPluginCommand class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmPluginCommand()
Public Sub New
public:
DcnmPluginCommand()
See Also

Reference

DcnmPluginCommand Class


DcnmPluginCommand Properties

The DcnmPluginCommand type exposes the following members.

Properties
 | Name | Description
Public property | Command | Name of the command to send. Use IPlugin.GetPlugin(PluginName).Methods to see what methods are supported by the plugin
Public property | Parameters | Parameters for the command.
Public property | PluginName | Name of the destination plugin. Use IPlugin.GetPlugins() to get a list of all available plugins
Top
See Also

Reference

DcnmPluginCommand Class


DcnmPluginCommand.Command Property

DcnmPluginCommandCommand Property

Name of the command to send. Use IPlugin.GetPlugin(PluginName).Methods to see what methods are supported by the plugin

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Command { get; set; }
Public Property Command As String
    Get
    Set
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DcnmPluginCommand Class


DcnmPluginCommand.Parameters Property

DcnmPluginCommandParameters Property

Parameters for the command.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Parameters { get; set; }
Public Property Parameters As String
    Get
    Set
public:
property String^ Parameters {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
By convention, paramters must always be a JSON formatted string. If a command needs no paramters, then at least an empty JSON string should be passed, that is "{}"
See Also

Reference

DcnmPluginCommand Class


DcnmPluginCommand.PluginName Property

DcnmPluginCommandPluginName Property

Name of the destination plugin. Use IPlugin.GetPlugins() to get a list of all available plugins

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string PluginName { get; set; }
Public Property PluginName As String
    Get
    Set
public:
property String^ PluginName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DcnmPluginCommand Class


DcnmPluginCommand Methods

The DcnmPluginCommand type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmPluginCommand Class


DcnmPluginCommandDescription Class

Describes a single command that can be executed on a plugin
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPluginCommandDescription

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmPluginCommandDescription
Public Class DcnmPluginCommandDescription
public ref class DcnmPluginCommandDescription

The DcnmPluginCommandDescription type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmPluginCommandDescription | Initializes a new instance of the DcnmPluginCommandDescription class
Top
Properties
 | Name | Description
Public property | Name | Name of the command
Public property | RequestSchema | The JSON schema of the command parameters
Public property | ResponseSchema | The JSON schema of the response of the command
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmPluginCommandDescription Constructor

Initializes a new instance of the DcnmPluginCommandDescription class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmPluginCommandDescription()
Public Sub New
public:
DcnmPluginCommandDescription()
See Also

Reference

DcnmPluginCommandDescription Class


DcnmPluginCommandDescription Properties

The DcnmPluginCommandDescription type exposes the following members.

Properties
 | Name | Description
Public property | Name | Name of the command
Public property | RequestSchema | The JSON schema of the command parameters
Public property | ResponseSchema | The JSON schema of the response of the command
Top
See Also

Reference

DcnmPluginCommandDescription Class


DcnmPluginCommandDescription.Name Property

DcnmPluginCommandDescriptionName Property

Name of the command

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DcnmPluginCommandDescription Class


DcnmPluginCommandDescription.RequestSchema Property

DcnmPluginCommandDescriptionRequestSchema Property

The JSON schema of the command parameters

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string RequestSchema { get; set; }
Public Property RequestSchema As String
    Get
    Set
public:
property String^ RequestSchema {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DcnmPluginCommandDescription Class


DcnmPluginCommandDescription.ResponseSchema Property

DcnmPluginCommandDescriptionResponseSchema Property

The JSON schema of the response of the command

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string ResponseSchema { get; set; }
Public Property ResponseSchema As String
    Get
    Set
public:
property String^ ResponseSchema {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DcnmPluginCommandDescription Class


DcnmPluginCommandDescription Methods

The DcnmPluginCommandDescription type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmPluginCommandDescription Class


DcnmPluginDescription Class

Describes a plugin
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPluginDescription

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmPluginDescription
Public Class DcnmPluginDescription
public ref class DcnmPluginDescription

The DcnmPluginDescription type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmPluginDescription | Initializes a new instance of the DcnmPluginDescription class
Top
Properties
 | Name | Description
Public property | Commands | All the methods supported by this plugin
Public property | Events | All the events that this plugin can generate
Public property | Interface | Identifies the interface exposed by the plugin
Public property | Name | Unique name of the plugin
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmPluginDescription Constructor

Initializes a new instance of the DcnmPluginDescription class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmPluginDescription()
Public Sub New
public:
DcnmPluginDescription()
See Also

Reference

DcnmPluginDescription Class


DcnmPluginDescription Properties

The DcnmPluginDescription type exposes the following members.

Properties
 | Name | Description
Public property | Commands | All the methods supported by this plugin
Public property | Events | All the events that this plugin can generate
Public property | Interface | Identifies the interface exposed by the plugin
Public property | Name | Unique name of the plugin
Top
See Also

Reference

DcnmPluginDescription Class


DcnmPluginDescription.Commands Property

DcnmPluginDescriptionCommands Property

All the methods supported by this plugin

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public ReadOnlyCollection<DcnmPluginCommandDescription> Commands { get; set; }
Public Property Commands As ReadOnlyCollection(Of DcnmPluginCommandDescription)
    Get
    Set
public:
property ReadOnlyCollection<DcnmPluginCommandDescription^>^ Commands {
    ReadOnlyCollection<DcnmPluginCommandDescription^>^ get ();
    void set (ReadOnlyCollection<DcnmPluginCommandDescription^>^ value);
}

Property Value

Type: ReadOnlyCollection DcnmPluginCommandDescription
See Also

Reference

DcnmPluginDescription Class


DcnmPluginDescription.Events Property

DcnmPluginDescriptionEvents Property

All the events that this plugin can generate

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public ReadOnlyCollection<DcnmPluginEventDescription> Events { get; set; }
Public Property Events As ReadOnlyCollection(Of DcnmPluginEventDescription)
    Get
    Set
public:
property ReadOnlyCollection<DcnmPluginEventDescription^>^ Events {
    ReadOnlyCollection<DcnmPluginEventDescription^>^ get ();
    void set (ReadOnlyCollection<DcnmPluginEventDescription^>^ value);
}

Property Value

Type: ReadOnlyCollection DcnmPluginEventDescription
See Also

Reference

DcnmPluginDescription Class


DcnmPluginDescription.Interface Property

DcnmPluginDescriptionInterface Property

Identifies the interface exposed by the plugin

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Interface { get; set; }
Public Property Interface As String
    Get
    Set
public:
property String^ Interface {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
By convention, the interface identification in in URI format.
interface://[interfacename].[company].[topLevelDomain]/Version
Multiple interfaces or versions may be exposed. The the Interface holds multiple URIs separated by a space. The version must be formatted according to semantic versioning specification given in https://semver.org/
See Also

Reference

DcnmPluginDescription Class


DcnmPluginDescription.Name Property

DcnmPluginDescriptionName Property

Unique name of the plugin

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
By convention, the Name is in URI format.
plugin://[pluginName].[company].[topLevelDomain]:[instance]/[possible optional additional identification]
For eample: plugin://mailserver.boschsecuritysystems.com:0, plugin://hallmonitor.boschsecuritysystems.com:5
See Also

Reference

DcnmPluginDescription Class


DcnmPluginDescription Methods

The DcnmPluginDescription type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmPluginDescription Class


DcnmPluginEvent Class

An event sent by a plugin
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPluginEvent

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmPluginEvent
Public Class DcnmPluginEvent
public ref class DcnmPluginEvent

The DcnmPluginEvent type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmPluginEvent | Initializes a new instance of the DcnmPluginEvent class
Top
Properties
 | Name | Description
Public property | Event | The event that the plugin sent. See IPlugin.GetPlugin(PluginName).Events for all the events that the plugin can send
Public property | Parameters | The parameters for the event.
Public property | PluginName | Name of the plugin that sent the event
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmPluginEvent Constructor

Initializes a new instance of the DcnmPluginEvent class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmPluginEvent()
Public Sub New
public:
DcnmPluginEvent()
See Also

Reference

DcnmPluginEvent Class


DcnmPluginEvent Properties

The DcnmPluginEvent type exposes the following members.

Properties
 | Name | Description
Public property | Event | The event that the plugin sent. See IPlugin.GetPlugin(PluginName).Events for all the events that the plugin can send
Public property | Parameters | The parameters for the event.
Public property | PluginName | Name of the plugin that sent the event
Top
See Also

Reference

DcnmPluginEvent Class


DcnmPluginEvent.Event Property

DcnmPluginEventEvent Property

The event that the plugin sent. See IPlugin.GetPlugin(PluginName).Events for all the events that the plugin can send

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Event { get; set; }
Public Property Event As String
    Get
    Set
public:
property String^ Event {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DcnmPluginEvent Class


DcnmPluginEvent.Parameters Property

DcnmPluginEventParameters Property

The parameters for the event.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Parameters { get; set; }
Public Property Parameters As String
    Get
    Set
public:
property String^ Parameters {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
By convention, the Parameters are always a JSON formatted string. If no parameters are needed, the string is an empty JSON object, i.e. "{}".
See Also

Reference

DcnmPluginEvent Class


DcnmPluginEvent.PluginName Property

DcnmPluginEventPluginName Property

Name of the plugin that sent the event

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string PluginName { get; set; }
Public Property PluginName As String
    Get
    Set
public:
property String^ PluginName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DcnmPluginEvent Class


DcnmPluginEvent Methods

The DcnmPluginEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmPluginEvent Class


DcnmPluginEventDescription Class

Describes an event that can be generated by a plugin
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPluginEventDescription

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmPluginEventDescription
Public Class DcnmPluginEventDescription
public ref class DcnmPluginEventDescription

The DcnmPluginEventDescription type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmPluginEventDescription | Initializes a new instance of the DcnmPluginEventDescription class
Top
Properties
 | Name | Description
Public property | EventSchema | The JSON schema of the event paramters
Public property | Name | Name of the event
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmPluginEventDescription Constructor

Initializes a new instance of the DcnmPluginEventDescription class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmPluginEventDescription()
Public Sub New
public:
DcnmPluginEventDescription()
See Also

Reference

DcnmPluginEventDescription Class


DcnmPluginEventDescription Properties

The DcnmPluginEventDescription type exposes the following members.

Properties
 | Name | Description
Public property | EventSchema | The JSON schema of the event paramters
Public property | Name | Name of the event
Top
See Also

Reference

DcnmPluginEventDescription Class


DcnmPluginEventDescription.EventSchema Property

DcnmPluginEventDescriptionEventSchema Property

The JSON schema of the event paramters

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string EventSchema { get; set; }
Public Property EventSchema As String
    Get
    Set
public:
property String^ EventSchema {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DcnmPluginEventDescription Class


DcnmPluginEventDescription.Name Property

DcnmPluginEventDescriptionName Property

Name of the event

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DcnmPluginEventDescription Class


DcnmPluginEventDescription Methods

The DcnmPluginEventDescription type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmPluginEventDescription Class


DcnmPluginRegistrations Class

Maintains changes in plugin registrations
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPluginRegistrations

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmPluginRegistrations
Public Class DcnmPluginRegistrations
public ref class DcnmPluginRegistrations

The DcnmPluginRegistrations type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmPluginRegistrations | Initializes a new instance of the DcnmPluginRegistrations class
Top
Properties
 | Name | Description
Public property | Items | A list of the names of all the registered plugins (that were added or removed)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmPluginRegistrations Constructor

Initializes a new instance of the DcnmPluginRegistrations class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmPluginRegistrations()
Public Sub New
public:
DcnmPluginRegistrations()
See Also

Reference

DcnmPluginRegistrations Class


DcnmPluginRegistrations Properties

The DcnmPluginRegistrations type exposes the following members.

Properties
 | Name | Description
Public property | Items | A list of the names of all the registered plugins (that were added or removed)
Top
See Also

Reference

DcnmPluginRegistrations Class


DcnmPluginRegistrations.Items Property

DcnmPluginRegistrationsItems Property

A list of the names of all the registered plugins (that were added or removed)

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Collection<string> Items { get; }
Public ReadOnly Property Items As Collection(Of String)
    Get
public:
property Collection<String^>^ Items {
    Collection<String^>^ get ();
}

Property Value

Type: Collection String
See Also

Reference

DcnmPluginRegistrations Class


DcnmPluginRegistrations Methods

The DcnmPluginRegistrations type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmPluginRegistrations Class


DcnmPowerState Enumeration

The power state

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmPowerState
Public Enumeration DcnmPowerState
public enum class DcnmPowerState
Members
Member name | Value | Description
PoweredOn | 0 | The power is on.
PoweredOff | 1 | The power is off.
PoweringOn | 2 | The power is being turned on.
PoweringOff | 3 | The power is being turned off.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmPriorityMode Enumeration

The different priority modes supported by the Dcnm system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmPriorityMode
Public Enumeration DcnmPriorityMode
public enum class DcnmPriorityMode
Members
Member name | Value | Description
MuteAllSpeaker | 0 | Mute all speakers during a priority
CancelAllSpeakerAndRequest | 1 | Cancel all speakers and request during a priority
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmPriorityOptions Class

The priority settings for the active discussion
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPriorityOptions

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmPriorityOptions
Public Class DcnmPriorityOptions
public ref class DcnmPriorityOptions

The DcnmPriorityOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmPriorityOptions | Default constructor
Public method | DcnmPriorityOptions(DcnmPriorityMode, Boolean) | The constructor for the priority options.
Top
Properties
 | Name | Description
Public property | PriorityMode | The DcnmPriorityMode
Public property | PriorityToneActive | Indicates if the priority tone is active.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DEFAULT_PRIORITY_MODE | The default priority mode
DEFAULT_PRIORITY_TONE_ACTIVE | The default priority tone
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmPriorityOptions Constructor

Overload List
 | Name | Description
Public method | DcnmPriorityOptions | Default constructor
Public method | DcnmPriorityOptions(DcnmPriorityMode, Boolean) | The constructor for the priority options.
Top
See Also

Reference

DcnmPriorityOptions Class


DcnmPriorityOptions Constructor

Default constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmPriorityOptions()
Public Sub New
public:
DcnmPriorityOptions()
See Also

Reference

DcnmPriorityOptions Class
DcnmPriorityOptions Overload


DcnmPriorityOptions Constructor (DcnmPriorityMode, Boolean)

The constructor for the priority options.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmPriorityOptions(
    DcnmPriorityMode priorityMode,
    bool priorityToneActive
)
Public Sub New (
    priorityMode As DcnmPriorityMode,
    priorityToneActive As Boolean
)
public:
DcnmPriorityOptions(
    DcnmPriorityMode priorityMode,
    bool priorityToneActive
)

Parameters

priorityMode
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPriorityMode
The DcnmPriorityMode
priorityToneActive
Type: SystemBoolean
priority tone active
See Also

Reference

DcnmPriorityOptions Class
DcnmPriorityOptions Overload


DcnmPriorityOptions Properties

The DcnmPriorityOptions type exposes the following members.

Properties
 | Name | Description
Public property | PriorityMode | The DcnmPriorityMode
Public property | PriorityToneActive | Indicates if the priority tone is active.
Top
See Also

Reference

DcnmPriorityOptions Class


DcnmPriorityOptions.PriorityMode Property

DcnmPriorityOptionsPriorityMode Property

The DcnmPriorityMode

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmPriorityMode PriorityMode { get; }
Public ReadOnly Property PriorityMode As DcnmPriorityMode
    Get
public:
property DcnmPriorityMode PriorityMode {
    DcnmPriorityMode get ();
}

Property Value

Type: DcnmPriorityMode
See Also

Reference

DcnmPriorityOptions Class


DcnmPriorityOptions.PriorityToneActive Property

DcnmPriorityOptionsPriorityToneActive Property

Indicates if the priority tone is active.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool PriorityToneActive { get; }
Public ReadOnly Property PriorityToneActive As Boolean
    Get
public:
property bool PriorityToneActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmPriorityOptions Class


DcnmPriorityOptions Methods

The DcnmPriorityOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmPriorityOptions Class


DcnmPriorityOptions Fields

The DcnmPriorityOptions type exposes the following members.

Fields
Name | Description
DEFAULT_PRIORITY_MODE | The default priority mode
DEFAULT_PRIORITY_TONE_ACTIVE | The default priority tone
Top
See Also

Reference

DcnmPriorityOptions Class


DcnmPriorityOptions.DEFAULT_PRIORITY_MODE Field

DcnmPriorityOptionsDEFAULT_PRIORITY_MODE Field

The default priority mode

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const DcnmPriorityMode DEFAULT_PRIORITY_MODE = DcnmPriorityMode.MuteAllSpeaker
Public Const DEFAULT_PRIORITY_MODE As DcnmPriorityMode = DcnmPriorityMode.MuteAllSpeaker
public:
literal DcnmPriorityMode DEFAULT_PRIORITY_MODE = DcnmPriorityMode.MuteAllSpeaker

Field Value

Type: DcnmPriorityMode
See Also

Reference

DcnmPriorityOptions Class


DcnmPriorityOptions.DEFAULT_PRIORITY_TONE_ACTIVE Field

DcnmPriorityOptionsDEFAULT_PRIORITY_TONE_ACTIVE Field

The default priority tone

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DEFAULT_PRIORITY_TONE_ACTIVE = true
Public Const DEFAULT_PRIORITY_TONE_ACTIVE As Boolean = True
public:
literal bool DEFAULT_PRIORITY_TONE_ACTIVE = true

Field Value

Type: Boolean
See Also

Reference

DcnmPriorityOptions Class


DcnmQuorumInfo Class

Holds quorum information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmQuorumInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmQuorumInfo
Public Class DcnmQuorumInfo
public ref class DcnmQuorumInfo

The DcnmQuorumInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmQuorumInfo | Class holds quorum information.
Top
Properties
 | Name | Description
Public property | QuorumCondition | Quorum condition operator DcnmComparisonOperators.
Public property | QuorumDenominatorExpression | Quorum denominator expression. Can get variables from QuorumVariables
Public property | QuorumNumeratorExpression | Quorum numerator expression. Can get variables from QuorumVariables
Public property | QuorumThresholdExpression | Quorum threshold to decide whether quorum for meeting is reached or not.
Public property | UseQuorum | Flag indicates whether to use quorum or not.
Public property | UseVoteWeight | Flag indicates whether to use vote weight while calculating quorum.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmQuorumInfo Constructor

Class holds quorum information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmQuorumInfo(
    bool useQuorum,
    bool useVoteWeight,
    string quorumNumeratorExpression,
    string quorumDenominatorExpression,
    string quorumThresholdExpression,
    DcnmComparisonOperators quorumCondition
)
Public Sub New (
    useQuorum As Boolean,
    useVoteWeight As Boolean,
    quorumNumeratorExpression As String,
    quorumDenominatorExpression As String,
    quorumThresholdExpression As String,
    quorumCondition As DcnmComparisonOperators
)
public:
DcnmQuorumInfo(
    bool useQuorum,
    bool useVoteWeight,
    String^ quorumNumeratorExpression,
    String^ quorumDenominatorExpression,
    String^ quorumThresholdExpression,
    DcnmComparisonOperators quorumCondition
)

Parameters

useQuorum
Type: SystemBoolean
Flag indicates whether to use quorum.
useVoteWeight
Type: SystemBoolean
Flag indicates whether to use vote weight while calculating quorum.
quorumNumeratorExpression
Type: SystemString
Quorum numerator expression. Can get variables from QuorumVariables.
quorumDenominatorExpression
Type: SystemString
Quorum denominator expression. Can get variables from QuorumVariables.
quorumThresholdExpression
Type: SystemString
Quorum threshold to decide whether quorum for meeting is reached or not.
quorumCondition
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmComparisonOperators
Quorum condition operator DcnmComparisonOperators.
See Also

Reference

DcnmQuorumInfo Class


DcnmQuorumInfo Properties

The DcnmQuorumInfo type exposes the following members.

Properties
 | Name | Description
Public property | QuorumCondition | Quorum condition operator DcnmComparisonOperators.
Public property | QuorumDenominatorExpression | Quorum denominator expression. Can get variables from QuorumVariables
Public property | QuorumNumeratorExpression | Quorum numerator expression. Can get variables from QuorumVariables
Public property | QuorumThresholdExpression | Quorum threshold to decide whether quorum for meeting is reached or not.
Public property | UseQuorum | Flag indicates whether to use quorum or not.
Public property | UseVoteWeight | Flag indicates whether to use vote weight while calculating quorum.
Top
See Also

Reference

DcnmQuorumInfo Class


DcnmQuorumInfo.QuorumCondition Property

DcnmQuorumInfoQuorumCondition Property

Quorum condition operator DcnmComparisonOperators.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmComparisonOperators QuorumCondition { get; }
Public ReadOnly Property QuorumCondition As DcnmComparisonOperators
    Get
public:
property DcnmComparisonOperators QuorumCondition {
    DcnmComparisonOperators get ();
}

Property Value

Type: DcnmComparisonOperators
See Also

Reference

DcnmQuorumInfo Class


DcnmQuorumInfo.QuorumDenominatorExpression Property

DcnmQuorumInfoQuorumDenominatorExpression Property

Quorum denominator expression. Can get variables from QuorumVariables

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string QuorumDenominatorExpression { get; }
Public ReadOnly Property QuorumDenominatorExpression As String
    Get
public:
property String^ QuorumDenominatorExpression {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmQuorumInfo Class


DcnmQuorumInfo.QuorumNumeratorExpression Property

DcnmQuorumInfoQuorumNumeratorExpression Property

Quorum numerator expression. Can get variables from QuorumVariables

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string QuorumNumeratorExpression { get; }
Public ReadOnly Property QuorumNumeratorExpression As String
    Get
public:
property String^ QuorumNumeratorExpression {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmQuorumInfo Class


DcnmQuorumInfo.QuorumThresholdExpression Property

DcnmQuorumInfoQuorumThresholdExpression Property

Quorum threshold to decide whether quorum for meeting is reached or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string QuorumThresholdExpression { get; }
Public ReadOnly Property QuorumThresholdExpression As String
    Get
public:
property String^ QuorumThresholdExpression {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmQuorumInfo Class


DcnmQuorumInfo.UseQuorum Property

DcnmQuorumInfoUseQuorum Property

Flag indicates whether to use quorum or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool UseQuorum { get; }
Public ReadOnly Property UseQuorum As Boolean
    Get
public:
property bool UseQuorum {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmQuorumInfo Class


DcnmQuorumInfo.UseVoteWeight Property

DcnmQuorumInfoUseVoteWeight Property

Flag indicates whether to use vote weight while calculating quorum.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool UseVoteWeight { get; }
Public ReadOnly Property UseVoteWeight As Boolean
    Get
public:
property bool UseVoteWeight {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmQuorumInfo Class


DcnmQuorumInfo Methods

The DcnmQuorumInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmQuorumInfo Class


DcnmQuorumResult Class

Class repesents quorum results.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmQuorumResult

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmQuorumResult
Public Class DcnmQuorumResult
public ref class DcnmQuorumResult

The DcnmQuorumResult type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmQuorumResult | Constructor.
Top
Properties
 | Name | Description
Public property | ComparisonOperators | Comparison operator used in quorum expression.
Public property | DenominatorExpressionValue | Quorum denominator expression evaluated value.
Public property | IsEnabled | Indicates whether quorum is enabled.
Public property | NumeratorExpressionValue | Quorum numerator expression evaluated value.
Public property | Status | Indicates quorum status .
Public property | ThresholdExpressionValue | Evaluated quorum threshold expression value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmQuorumResult Constructor

Constructor.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmQuorumResult(
    bool isEnabled,
    float numeratorValue,
    float denominatorValue,
    float thresholdValue,
    DcnmStatusType status,
    DcnmComparisonOperators comparisonOperator
)
Public Sub New (
    isEnabled As Boolean,
    numeratorValue As Single,
    denominatorValue As Single,
    thresholdValue As Single,
    status As DcnmStatusType,
    comparisonOperator As DcnmComparisonOperators
)
public:
DcnmQuorumResult(
    bool isEnabled,
    float numeratorValue,
    float denominatorValue,
    float thresholdValue,
    DcnmStatusType status,
    DcnmComparisonOperators comparisonOperator
)

Parameters

isEnabled
Type: SystemBoolean
Indicates if quorum is enabled
numeratorValue
Type: SystemSingle
Evaluated numerator expression value.
denominatorValue
Type: SystemSingle
Evaluated denominator expression value.
thresholdValue
Type: SystemSingle
Evaluated quorum threshold expression value.
status
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStatusType
Indicates quorum status .
comparisonOperator
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmComparisonOperators
Comparison operator used in expression.
See Also

Reference

DcnmQuorumResult Class
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStatusType


DcnmQuorumResult Properties

The DcnmQuorumResult type exposes the following members.

Properties
 | Name | Description
Public property | ComparisonOperators | Comparison operator used in quorum expression.
Public property | DenominatorExpressionValue | Quorum denominator expression evaluated value.
Public property | IsEnabled | Indicates whether quorum is enabled.
Public property | NumeratorExpressionValue | Quorum numerator expression evaluated value.
Public property | Status | Indicates quorum status .
Public property | ThresholdExpressionValue | Evaluated quorum threshold expression value.
Top
See Also

Reference

DcnmQuorumResult Class


DcnmQuorumResult.ComparisonOperators Property

DcnmQuorumResultComparisonOperators Property

Comparison operator used in quorum expression.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmComparisonOperators ComparisonOperators { get; }
Public ReadOnly Property ComparisonOperators As DcnmComparisonOperators
    Get
public:
property DcnmComparisonOperators ComparisonOperators {
    DcnmComparisonOperators get ();
}

Property Value

Type: DcnmComparisonOperators
See Also

Reference

DcnmQuorumResult Class


DcnmQuorumResult.DenominatorExpressionValue Property

DcnmQuorumResultDenominatorExpressionValue Property

Quorum denominator expression evaluated value.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public float DenominatorExpressionValue { get; }
Public ReadOnly Property DenominatorExpressionValue As Single
    Get
public:
property float DenominatorExpressionValue {
    float get ();
}

Property Value

Type: Single
See Also

Reference

DcnmQuorumResult Class


DcnmQuorumResult.IsEnabled Property

DcnmQuorumResultIsEnabled Property

Indicates whether quorum is enabled.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsEnabled { get; }
Public ReadOnly Property IsEnabled As Boolean
    Get
public:
property bool IsEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmQuorumResult Class


DcnmQuorumResult.NumeratorExpressionValue Property

DcnmQuorumResultNumeratorExpressionValue Property

Quorum numerator expression evaluated value.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public float NumeratorExpressionValue { get; }
Public ReadOnly Property NumeratorExpressionValue As Single
    Get
public:
property float NumeratorExpressionValue {
    float get ();
}

Property Value

Type: Single
See Also

Reference

DcnmQuorumResult Class


DcnmQuorumResult.Status Property

DcnmQuorumResultStatus Property

Indicates quorum status .

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmStatusType Status { get; }
Public ReadOnly Property Status As DcnmStatusType
    Get
public:
property DcnmStatusType Status {
    DcnmStatusType get ();
}

Property Value

Type: DcnmStatusType
See Also

Reference

DcnmQuorumResult Class
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStatusType


DcnmQuorumResult.ThresholdExpressionValue Property

DcnmQuorumResultThresholdExpressionValue Property

Evaluated quorum threshold expression value.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public float ThresholdExpressionValue { get; }
Public ReadOnly Property ThresholdExpressionValue As Single
    Get
public:
property float ThresholdExpressionValue {
    float get ();
}

Property Value

Type: Single
See Also

Reference

DcnmQuorumResult Class


DcnmQuorumResult Methods

The DcnmQuorumResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmQuorumResult Class


DcnmRequesterInfo Class

Defines a request entry
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmRequesterInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmRequesterInfo
Public Class DcnmRequesterInfo
public ref class DcnmRequesterInfo

The DcnmRequesterInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmRequesterInfo(Guid, Boolean, DcnmParticipantInfo, DcnmSeatInfo) | Constructor for class...
Public method | DcnmRequesterInfo(Guid, Boolean, DcnmParticipantInfo, DcnmSeatInfo, DcnmSpeechTimerInfo) | Constructor for class...
Top
Properties
 | Name | Description
Public property | IsFirst | Indicates whether the request if first to speak.
Public property | ParticipantInfo | The participant information of the speaker.
Public property | RequesterId | The speaker id.
Public property | SeatInfo | The seat information of the speaker
Public property | SpeechTimerInfo | Speech timer information of the speaker
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmRequesterInfo Constructor

Overload List
 | Name | Description
Public method | DcnmRequesterInfo(Guid, Boolean, DcnmParticipantInfo, DcnmSeatInfo) | Constructor for class...
Public method | DcnmRequesterInfo(Guid, Boolean, DcnmParticipantInfo, DcnmSeatInfo, DcnmSpeechTimerInfo) | Constructor for class...
Top
See Also

Reference

DcnmRequesterInfo Class


DcnmRequesterInfo Constructor (Guid, Boolean, DcnmParticipantInfo, DcnmSeatInfo)

Constructor for class...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmRequesterInfo(
    Guid requesterId,
    bool isFirst,
    DcnmParticipantInfo participantInfo,
    DcnmSeatInfo seatInfo
)
Public Sub New (
    requesterId As Guid,
    isFirst As Boolean,
    participantInfo As DcnmParticipantInfo,
    seatInfo As DcnmSeatInfo
)
public:
DcnmRequesterInfo(
    Guid requesterId,
    bool isFirst,
    DcnmParticipantInfo^ participantInfo,
    DcnmSeatInfo^ seatInfo
)

Parameters

requesterId
Type: SystemGuid
The id of the requester.
isFirst
Type: SystemBoolean
Indicates whether the requester is first to speak.
participantInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmParticipantInfo
The participant info of the requester.
seatInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSeatInfo
The seat info of the requester.
See Also

Reference

DcnmRequesterInfo Class
DcnmRequesterInfo Overload


DcnmRequesterInfo Constructor (Guid, Boolean, DcnmParticipantInfo, DcnmSeatInfo, DcnmSpeechTimerInfo)

Constructor for class...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmRequesterInfo(
    Guid requesterId,
    bool isFirst,
    DcnmParticipantInfo participantInfo,
    DcnmSeatInfo seatInfo,
    DcnmSpeechTimerInfo speechTimerInfo
)
Public Sub New (
    requesterId As Guid,
    isFirst As Boolean,
    participantInfo As DcnmParticipantInfo,
    seatInfo As DcnmSeatInfo,
    speechTimerInfo As DcnmSpeechTimerInfo
)
public:
DcnmRequesterInfo(
    Guid requesterId,
    bool isFirst,
    DcnmParticipantInfo^ participantInfo,
    DcnmSeatInfo^ seatInfo,
    DcnmSpeechTimerInfo^ speechTimerInfo
)

Parameters

requesterId
Type: SystemGuid
The id of the requester.
isFirst
Type: SystemBoolean
Indicates whether the requester is first to speak.
participantInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmParticipantInfo
The participant info of the requester.
seatInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSeatInfo
The seat info of the requester.
speechTimerInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpeechTimerInfo
The speech timerof the requester.
See Also

Reference

DcnmRequesterInfo Class
DcnmRequesterInfo Overload


DcnmRequesterInfo Properties

The DcnmRequesterInfo type exposes the following members.

Properties
 | Name | Description
Public property | IsFirst | Indicates whether the request if first to speak.
Public property | ParticipantInfo | The participant information of the speaker.
Public property | RequesterId | The speaker id.
Public property | SeatInfo | The seat information of the speaker
Public property | SpeechTimerInfo | Speech timer information of the speaker
Top
See Also

Reference

DcnmRequesterInfo Class


DcnmRequesterInfo.IsFirst Property

DcnmRequesterInfoIsFirst Property

Indicates whether the request if first to speak.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsFirst { get; }
Public ReadOnly Property IsFirst As Boolean
    Get
public:
property bool IsFirst {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmRequesterInfo Class


DcnmRequesterInfo.ParticipantInfo Property

DcnmRequesterInfoParticipantInfo Property

The participant information of the speaker.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantInfo ParticipantInfo { get; }
Public ReadOnly Property ParticipantInfo As DcnmParticipantInfo
    Get
public:
property DcnmParticipantInfo^ ParticipantInfo {
    DcnmParticipantInfo^ get ();
}

Property Value

Type: DcnmParticipantInfo
See Also

Reference

DcnmRequesterInfo Class


DcnmRequesterInfo.RequesterId Property

DcnmRequesterInfoRequesterId Property

The speaker id.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid RequesterId { get; }
Public ReadOnly Property RequesterId As Guid
    Get
public:
property Guid RequesterId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmRequesterInfo Class


DcnmRequesterInfo.SeatInfo Property

DcnmRequesterInfoSeatInfo Property

The seat information of the speaker

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSeatInfo SeatInfo { get; }
Public ReadOnly Property SeatInfo As DcnmSeatInfo
    Get
public:
property DcnmSeatInfo^ SeatInfo {
    DcnmSeatInfo^ get ();
}

Property Value

Type: DcnmSeatInfo
See Also

Reference

DcnmRequesterInfo Class


DcnmRequesterInfo.SpeechTimerInfo Property

DcnmRequesterInfoSpeechTimerInfo Property

Speech timer information of the speaker

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpeechTimerInfo SpeechTimerInfo { get; }
Public ReadOnly Property SpeechTimerInfo As DcnmSpeechTimerInfo
    Get
public:
property DcnmSpeechTimerInfo^ SpeechTimerInfo {
    DcnmSpeechTimerInfo^ get ();
}

Property Value

Type: DcnmSpeechTimerInfo
See Also

Reference

DcnmRequesterInfo Class


DcnmRequesterInfo Methods

The DcnmRequesterInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmRequesterInfo Class


DcnmRequestToResponseOptions Class

Defines a container for the request to response options.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmRequestToResponseOptions

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmRequestToResponseOptions
Public Class DcnmRequestToResponseOptions
public ref class DcnmRequestToResponseOptions

The DcnmRequestToResponseOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmRequestToResponseOptions | Default constructor.
Public method | DcnmRequestToResponseOptions(Int32, Boolean) | Constructor...
Top
Properties
 | Name | Description
Public property | AllowCancelResponse | Allow cancellation of response.
Public property | MaxResponses | The maximum number of responses allowed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DISCUSS_DEFAULT_ALLOW_CANCEL_RESPONSE | Default value for allow cancel request
DISCUSS_DEFAULT_MAX_RESPONSES | Maximum value for number of requests in the requests list
DISCUSS_DEFAULT_MIN_RESPONSES | Minimum value for number of requests in the requests list
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmRequestToResponseOptions Constructor

Overload List
 | Name | Description
Public method | DcnmRequestToResponseOptions | Default constructor.
Public method | DcnmRequestToResponseOptions(Int32, Boolean) | Constructor...
Top
See Also

Reference

DcnmRequestToResponseOptions Class


DcnmRequestToResponseOptions Constructor

Default constructor.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmRequestToResponseOptions()
Public Sub New
public:
DcnmRequestToResponseOptions()
See Also

Reference

DcnmRequestToResponseOptions Class
DcnmRequestToResponseOptions Overload


DcnmRequestToResponseOptions Constructor (Int32, Boolean)

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmRequestToResponseOptions(
    int maxResponses,
    bool allowCancelResponse
)
Public Sub New (
    maxResponses As Integer,
    allowCancelResponse As Boolean
)
public:
DcnmRequestToResponseOptions(
    int maxResponses,
    bool allowCancelResponse
)

Parameters

maxResponses
Type: SystemInt32
The maximum number of requests allowed, value between 0 and DISCUSS_DEFAULT_MAX_RESPONSES.
allowCancelResponse
Type: SystemBoolean
Allow cancellation of responses.
See Also

Reference

DcnmRequestToResponseOptions Class
DcnmRequestToResponseOptions Overload


DcnmRequestToResponseOptions Properties

The DcnmRequestToResponseOptions type exposes the following members.

Properties
 | Name | Description
Public property | AllowCancelResponse | Allow cancellation of response.
Public property | MaxResponses | The maximum number of responses allowed.
Top
See Also

Reference

DcnmRequestToResponseOptions Class


DcnmRequestToResponseOptions.AllowCancelResponse Property

DcnmRequestToResponseOptionsAllowCancelResponse Property

Allow cancellation of response.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AllowCancelResponse { get; }
Public ReadOnly Property AllowCancelResponse As Boolean
    Get
public:
property bool AllowCancelResponse {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmRequestToResponseOptions Class


DcnmRequestToResponseOptions.MaxResponses Property

DcnmRequestToResponseOptionsMaxResponses Property

The maximum number of responses allowed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int MaxResponses { get; }
Public ReadOnly Property MaxResponses As Integer
    Get
public:
property int MaxResponses {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmRequestToResponseOptions Class


DcnmRequestToResponseOptions Methods

The DcnmRequestToResponseOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmRequestToResponseOptions Class


DcnmRequestToResponseOptions Fields

The DcnmRequestToResponseOptions type exposes the following members.

Fields
Name | Description
DISCUSS_DEFAULT_ALLOW_CANCEL_RESPONSE | Default value for allow cancel request
DISCUSS_DEFAULT_MAX_RESPONSES | Maximum value for number of requests in the requests list
DISCUSS_DEFAULT_MIN_RESPONSES | Minimum value for number of requests in the requests list
Top
See Also

Reference

DcnmRequestToResponseOptions Class


DcnmRequestToResponseOptions.DISCUSS_DEFAULT_ALLOW_CANCEL_RESPONSE Field

DcnmRequestToResponseOptionsDISCUSS_DEFAULT_ALLOW_CANCEL_RESPONSE Field

 Bosch Logo
Default value for allow cancel request

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DISCUSS_DEFAULT_ALLOW_CANCEL_RESPONSE = true
Public Const DISCUSS_DEFAULT_ALLOW_CANCEL_RESPONSE As Boolean = True
public:
literal bool DISCUSS_DEFAULT_ALLOW_CANCEL_RESPONSE = true

Field Value

Type: Boolean
See Also

Reference

DcnmRequestToResponseOptions Class


DcnmRequestToResponseOptions.DISCUSS_DEFAULT_MAX_RESPONSES Field

DcnmRequestToResponseOptionsDISCUSS_DEFAULT_MAX_RESPONSES Field

 Bosch Logo
Maximum value for number of requests in the requests list

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DISCUSS_DEFAULT_MAX_RESPONSES = 99
Public Const DISCUSS_DEFAULT_MAX_RESPONSES As Integer = 99
public:
literal int DISCUSS_DEFAULT_MAX_RESPONSES = 99

Field Value

Type: Int32
See Also

Reference

DcnmRequestToResponseOptions Class


DcnmRequestToResponseOptions.DISCUSS_DEFAULT_MIN_RESPONSES Field

DcnmRequestToResponseOptionsDISCUSS_DEFAULT_MIN_RESPONSES Field

 Bosch Logo
Minimum value for number of requests in the requests list

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DISCUSS_DEFAULT_MIN_RESPONSES = 1
Public Const DISCUSS_DEFAULT_MIN_RESPONSES As Integer = 1
public:
literal int DISCUSS_DEFAULT_MIN_RESPONSES = 1

Field Value

Type: Int32
See Also

Reference

DcnmRequestToResponseOptions Class


DcnmRequestToSpeakOptions Class

Defines a container for the request to speak options.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmRequestToSpeakOptions

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmRequestToSpeakOptions
Public Class DcnmRequestToSpeakOptions
public ref class DcnmRequestToSpeakOptions

The DcnmRequestToSpeakOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmRequestToSpeakOptions | Default constructor
Public method | DcnmRequestToSpeakOptions(Int32, Boolean, Boolean, Boolean, Boolean, Boolean) | Obsolete. Constructor...
Public method | DcnmRequestToSpeakOptions(Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Obsolete. Constructor...
Public method | DcnmRequestToSpeakOptions(Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Constructor...
Top
Properties
 | Name | Description
Public property | AllowCancelRequest | Allow cancellation of requests.
Public property | AllowMicrophoneMute | Allow microphone mute
Public property | AllowMicrophoneOff | Allow switching microphone off.
Public property | AllowRequestToSpeak | Allow request to speak.
Public property | MaxRequests | The maximum number of requests allowed.
Public property | ShowFirstRequestOnSeat | Indicates whether user can view first request on seat.
Public property | ShowWaitingIndicatorOnSeat | Show waiting indicator at seat.
Public property | ShowWaitingList | Indicates whether user can view waiting list.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DISCUSS_DEFAULT_ALLOW_CANCEL_REQUEST | Default value for allow cancel request
DISCUSS_DEFAULT_ALLOW_ISSUE_REQUEST | Default value for allow issue request
DISCUSS_DEFAULT_ALLOW_MICROPHONE_OFF | Default value for allow microphone off after shift
DISCUSS_DEFAULT_OPEN_MICROPHONES | Default value for number of open microphones
DISCUSS_DEFAULT_REQUESTS | Default value for number of requests in the requests list
DISCUSS_DEFAULT_SHOW_FIRST_REQUEST | Default value for allow show first in request list on device
DISCUSS_DEFAULT_SHOW_WAITING_INDICATOR | Default value for showing waiting indicator.
DISCUSS_MAX_OPEN_MICROPHONES | Maximum value for number of open microphones
DISCUSS_MAX_REQUESTS | Maximum value for number of requests in the requests list
DISCUSS_MIN_OPEN_MICROPHONES | Minimum value for number of open microphones
DISCUSS_MIN_REQUESTS | Minimum value for number of requests in the requests list
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmRequestToSpeakOptions Constructor

Overload List
 | Name | Description
Public method | DcnmRequestToSpeakOptions | Default constructor
Public method | DcnmRequestToSpeakOptions(Int32, Boolean, Boolean, Boolean, Boolean, Boolean) | Obsolete. Constructor...
Public method | DcnmRequestToSpeakOptions(Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Obsolete. Constructor...
Public method | DcnmRequestToSpeakOptions(Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Constructor...
Top
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions Constructor

Default constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmRequestToSpeakOptions()
Public Sub New
public:
DcnmRequestToSpeakOptions()
See Also

Reference

DcnmRequestToSpeakOptions Class
DcnmRequestToSpeakOptions Overload


DcnmRequestToSpeakOptions Constructor (Int32, Boolean, Boolean, Boolean, Boolean, Boolean)

Note: This API is now obsolete.

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with allowMicrophoneMute field")]
public DcnmRequestToSpeakOptions(
    int maxRequests,
    bool allowRequestToSpeak,
    bool allowCancelRequest,
    bool allowMicrophoneOff,
    bool showFirstRequestOnSeat,
    bool showWaitingIndicatorOnSeat
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with allowMicrophoneMute field")>
Public Sub New (
    maxRequests As Integer,
    allowRequestToSpeak As Boolean,
    allowCancelRequest As Boolean,
    allowMicrophoneOff As Boolean,
    showFirstRequestOnSeat As Boolean,
    showWaitingIndicatorOnSeat As Boolean
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with allowMicrophoneMute field")]
DcnmRequestToSpeakOptions(
    int maxRequests,
    bool allowRequestToSpeak,
    bool allowCancelRequest,
    bool allowMicrophoneOff,
    bool showFirstRequestOnSeat,
    bool showWaitingIndicatorOnSeat
)

Parameters

maxRequests
Type: SystemInt32
The maximum number of requests allowed, value between DISCUSS_MIN_REQUESTS and DISCUSS_MAX_REQUESTS.
allowRequestToSpeak
Type: SystemBoolean
Allow request to speak.
allowCancelRequest
Type: SystemBoolean
Allow cancellation of requests.
allowMicrophoneOff
Type: SystemBoolean
Allow switching microphone off.
showFirstRequestOnSeat
Type: SystemBoolean
Show at seat if first request.
showWaitingIndicatorOnSeat
Type: SystemBoolean
Show waiting indicator on seat.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmRequestToSpeakOptions(Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) instead.
See Also

Reference

DcnmRequestToSpeakOptions Class
DcnmRequestToSpeakOptions Overload


DcnmRequestToSpeakOptions Constructor (Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

Note: This API is now obsolete.

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with allowMicrophoneMute field")]
public DcnmRequestToSpeakOptions(
    int maxRequests,
    bool allowRequestToSpeak,
    bool allowCancelRequest,
    bool allowMicrophoneOff,
    bool showFirstRequestOnSeat,
    bool showWaitingIndicatorOnSeat,
    bool showWaitingList
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with allowMicrophoneMute field")>
Public Sub New (
    maxRequests As Integer,
    allowRequestToSpeak As Boolean,
    allowCancelRequest As Boolean,
    allowMicrophoneOff As Boolean,
    showFirstRequestOnSeat As Boolean,
    showWaitingIndicatorOnSeat As Boolean,
    showWaitingList As Boolean
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with allowMicrophoneMute field")]
DcnmRequestToSpeakOptions(
    int maxRequests,
    bool allowRequestToSpeak,
    bool allowCancelRequest,
    bool allowMicrophoneOff,
    bool showFirstRequestOnSeat,
    bool showWaitingIndicatorOnSeat,
    bool showWaitingList
)

Parameters

maxRequests
Type: SystemInt32
The maximum number of requests allowed, value between DISCUSS_MIN_REQUESTS and DISCUSS_MAX_REQUESTS.
allowRequestToSpeak
Type: SystemBoolean
Allow request to speak.
allowCancelRequest
Type: SystemBoolean
Allow cancellation of requests.
allowMicrophoneOff
Type: SystemBoolean
Allow switching microphone off.
showFirstRequestOnSeat
Type: SystemBoolean
Show at seat if first request.
showWaitingIndicatorOnSeat
Type: SystemBoolean
Show waiting indicator on seat.
showWaitingList
Type: SystemBoolean
Show waiting list on seat
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmRequestToSpeakOptions(Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) instead.
See Also

Reference

DcnmRequestToSpeakOptions Class
DcnmRequestToSpeakOptions Overload


DcnmRequestToSpeakOptions Constructor (Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmRequestToSpeakOptions(
    int maxRequests,
    bool allowRequestToSpeak,
    bool allowCancelRequest,
    bool allowMicrophoneOff,
    bool allowMicrophoneMute,
    bool showFirstRequestOnSeat,
    bool showWaitingIndicatorOnSeat,
    bool showWaitingList
)
Public Sub New (
    maxRequests As Integer,
    allowRequestToSpeak As Boolean,
    allowCancelRequest As Boolean,
    allowMicrophoneOff As Boolean,
    allowMicrophoneMute As Boolean,
    showFirstRequestOnSeat As Boolean,
    showWaitingIndicatorOnSeat As Boolean,
    showWaitingList As Boolean
)
public:
DcnmRequestToSpeakOptions(
    int maxRequests,
    bool allowRequestToSpeak,
    bool allowCancelRequest,
    bool allowMicrophoneOff,
    bool allowMicrophoneMute,
    bool showFirstRequestOnSeat,
    bool showWaitingIndicatorOnSeat,
    bool showWaitingList
)

Parameters

maxRequests
Type: SystemInt32
The maximum number of requests allowed, value between DISCUSS_MIN_REQUESTS and DISCUSS_MAX_REQUESTS.
allowRequestToSpeak
Type: SystemBoolean
Allow request to speak.
allowCancelRequest
Type: SystemBoolean
Allow cancellation of requests.
allowMicrophoneOff
Type: SystemBoolean
Allow switching microphone off.
allowMicrophoneMute
Type: SystemBoolean
Allow microphone mute.
showFirstRequestOnSeat
Type: SystemBoolean
Show at seat if first request.
showWaitingIndicatorOnSeat
Type: SystemBoolean
Show waiting indicator on seat.
showWaitingList
Type: SystemBoolean
Show waiting list on seat
See Also

Reference

DcnmRequestToSpeakOptions Class
DcnmRequestToSpeakOptions Overload


DcnmRequestToSpeakOptions Properties

The DcnmRequestToSpeakOptions type exposes the following members.

Properties
 | Name | Description
Public property | AllowCancelRequest | Allow cancellation of requests.
Public property | AllowMicrophoneMute | Allow microphone mute
Public property | AllowMicrophoneOff | Allow switching microphone off.
Public property | AllowRequestToSpeak | Allow request to speak.
Public property | MaxRequests | The maximum number of requests allowed.
Public property | ShowFirstRequestOnSeat | Indicates whether user can view first request on seat.
Public property | ShowWaitingIndicatorOnSeat | Show waiting indicator at seat.
Public property | ShowWaitingList | Indicates whether user can view waiting list.
Top
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.AllowCancelRequest Property

DcnmRequestToSpeakOptionsAllowCancelRequest Property

Allow cancellation of requests.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AllowCancelRequest { get; }
Public ReadOnly Property AllowCancelRequest As Boolean
    Get
public:
property bool AllowCancelRequest {
    bool get ();
}

Property Value

Type: Boolean
Remarks
In open automatic mode, set to true automatically.
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.AllowMicrophoneMute Property

DcnmRequestToSpeakOptionsAllowMicrophoneMute Property

Allow microphone mute

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AllowMicrophoneMute { get; }
Public ReadOnly Property AllowMicrophoneMute As Boolean
    Get
public:
property bool AllowMicrophoneMute {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.AllowMicrophoneOff Property

DcnmRequestToSpeakOptionsAllowMicrophoneOff Property

Allow switching microphone off.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AllowMicrophoneOff { get; }
Public ReadOnly Property AllowMicrophoneOff As Boolean
    Get
public:
property bool AllowMicrophoneOff {
    bool get ();
}

Property Value

Type: Boolean
Remarks
In open automatic mode, set to true automatically.
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.AllowRequestToSpeak Property

DcnmRequestToSpeakOptionsAllowRequestToSpeak Property

Allow request to speak.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AllowRequestToSpeak { get; }
Public ReadOnly Property AllowRequestToSpeak As Boolean
    Get
public:
property bool AllowRequestToSpeak {
    bool get ();
}

Property Value

Type: Boolean
Remarks
In open automatic mode, set to true automatically.
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.MaxRequests Property

DcnmRequestToSpeakOptionsMaxRequests Property

The maximum number of requests allowed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int MaxRequests { get; }
Public ReadOnly Property MaxRequests As Integer
    Get
public:
property int MaxRequests {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.ShowFirstRequestOnSeat Property

DcnmRequestToSpeakOptionsShowFirstRequestOnSeat Property

Indicates whether user can view first request on seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool ShowFirstRequestOnSeat { get; }
Public ReadOnly Property ShowFirstRequestOnSeat As Boolean
    Get
public:
property bool ShowFirstRequestOnSeat {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.ShowWaitingIndicatorOnSeat Property

DcnmRequestToSpeakOptionsShowWaitingIndicatorOnSeat Property

Show waiting indicator at seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool ShowWaitingIndicatorOnSeat { get; }
Public ReadOnly Property ShowWaitingIndicatorOnSeat As Boolean
    Get
public:
property bool ShowWaitingIndicatorOnSeat {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.ShowWaitingList Property

DcnmRequestToSpeakOptionsShowWaitingList Property

Indicates whether user can view waiting list.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool ShowWaitingList { get; }
Public ReadOnly Property ShowWaitingList As Boolean
    Get
public:
property bool ShowWaitingList {
    bool get ();
}

Property Value

Type: Boolean
Remarks
In order to view waiting list in meeting application or synoptic layout:
  • Participant right: can manage or has special permission.
  • User right: Seat should have manage meeting rights.
  • Or ShowWaitingList must be true
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions Methods

The DcnmRequestToSpeakOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions Fields

The DcnmRequestToSpeakOptions type exposes the following members.

Fields
Name | Description
DISCUSS_DEFAULT_ALLOW_CANCEL_REQUEST | Default value for allow cancel request
DISCUSS_DEFAULT_ALLOW_ISSUE_REQUEST | Default value for allow issue request
DISCUSS_DEFAULT_ALLOW_MICROPHONE_OFF | Default value for allow microphone off after shift
DISCUSS_DEFAULT_OPEN_MICROPHONES | Default value for number of open microphones
DISCUSS_DEFAULT_REQUESTS | Default value for number of requests in the requests list
DISCUSS_DEFAULT_SHOW_FIRST_REQUEST | Default value for allow show first in request list on device
DISCUSS_DEFAULT_SHOW_WAITING_INDICATOR | Default value for showing waiting indicator.
DISCUSS_MAX_OPEN_MICROPHONES | Maximum value for number of open microphones
DISCUSS_MAX_REQUESTS | Maximum value for number of requests in the requests list
DISCUSS_MIN_OPEN_MICROPHONES | Minimum value for number of open microphones
DISCUSS_MIN_REQUESTS | Minimum value for number of requests in the requests list
Top
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.DISCUSS_DEFAULT_ALLOW_CANCEL_REQUEST Field

DcnmRequestToSpeakOptionsDISCUSS_DEFAULT_ALLOW_CANCEL_REQUEST Field

 Bosch Logo
Default value for allow cancel request

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DISCUSS_DEFAULT_ALLOW_CANCEL_REQUEST = true
Public Const DISCUSS_DEFAULT_ALLOW_CANCEL_REQUEST As Boolean = True
public:
literal bool DISCUSS_DEFAULT_ALLOW_CANCEL_REQUEST = true

Field Value

Type: Boolean
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.DISCUSS_DEFAULT_ALLOW_ISSUE_REQUEST Field

DcnmRequestToSpeakOptionsDISCUSS_DEFAULT_ALLOW_ISSUE_REQUEST Field

 Bosch Logo
Default value for allow issue request

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DISCUSS_DEFAULT_ALLOW_ISSUE_REQUEST = true
Public Const DISCUSS_DEFAULT_ALLOW_ISSUE_REQUEST As Boolean = True
public:
literal bool DISCUSS_DEFAULT_ALLOW_ISSUE_REQUEST = true

Field Value

Type: Boolean
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.DISCUSS_DEFAULT_ALLOW_MICROPHONE_OFF Field

DcnmRequestToSpeakOptionsDISCUSS_DEFAULT_ALLOW_MICROPHONE_OFF Field

 Bosch Logo
Default value for allow microphone off after shift

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DISCUSS_DEFAULT_ALLOW_MICROPHONE_OFF = true
Public Const DISCUSS_DEFAULT_ALLOW_MICROPHONE_OFF As Boolean = True
public:
literal bool DISCUSS_DEFAULT_ALLOW_MICROPHONE_OFF = true

Field Value

Type: Boolean
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.DISCUSS_DEFAULT_OPEN_MICROPHONES Field

DcnmRequestToSpeakOptionsDISCUSS_DEFAULT_OPEN_MICROPHONES Field

 Bosch Logo
Default value for number of open microphones

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DISCUSS_DEFAULT_OPEN_MICROPHONES = 2
Public Const DISCUSS_DEFAULT_OPEN_MICROPHONES As Integer = 2
public:
literal int DISCUSS_DEFAULT_OPEN_MICROPHONES = 2

Field Value

Type: Int32
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.DISCUSS_DEFAULT_REQUESTS Field

DcnmRequestToSpeakOptionsDISCUSS_DEFAULT_REQUESTS Field

Default value for number of requests in the requests list

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DISCUSS_DEFAULT_REQUESTS = 10
Public Const DISCUSS_DEFAULT_REQUESTS As Integer = 10
public:
literal int DISCUSS_DEFAULT_REQUESTS = 10

Field Value

Type: Int32
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.DISCUSS_DEFAULT_SHOW_FIRST_REQUEST Field

DcnmRequestToSpeakOptionsDISCUSS_DEFAULT_SHOW_FIRST_REQUEST Field

 Bosch Logo
Default value for allow show first in request list on device

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DISCUSS_DEFAULT_SHOW_FIRST_REQUEST = true
Public Const DISCUSS_DEFAULT_SHOW_FIRST_REQUEST As Boolean = True
public:
literal bool DISCUSS_DEFAULT_SHOW_FIRST_REQUEST = true

Field Value

Type: Boolean
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.DISCUSS_DEFAULT_SHOW_WAITING_INDICATOR Field

DcnmRequestToSpeakOptionsDISCUSS_DEFAULT_SHOW_WAITING_INDICATOR Field

 Bosch Logo
Default value for showing waiting indicator.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DISCUSS_DEFAULT_SHOW_WAITING_INDICATOR = true
Public Const DISCUSS_DEFAULT_SHOW_WAITING_INDICATOR As Boolean = True
public:
literal bool DISCUSS_DEFAULT_SHOW_WAITING_INDICATOR = true

Field Value

Type: Boolean
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.DISCUSS_MAX_OPEN_MICROPHONES Field

DcnmRequestToSpeakOptionsDISCUSS_MAX_OPEN_MICROPHONES Field

Maximum value for number of open microphones

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DISCUSS_MAX_OPEN_MICROPHONES = 25
Public Const DISCUSS_MAX_OPEN_MICROPHONES As Integer = 25
public:
literal int DISCUSS_MAX_OPEN_MICROPHONES = 25

Field Value

Type: Int32
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.DISCUSS_MAX_REQUESTS Field

DcnmRequestToSpeakOptionsDISCUSS_MAX_REQUESTS Field

Maximum value for number of requests in the requests list

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DISCUSS_MAX_REQUESTS = 200
Public Const DISCUSS_MAX_REQUESTS As Integer = 200
public:
literal int DISCUSS_MAX_REQUESTS = 200

Field Value

Type: Int32
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.DISCUSS_MIN_OPEN_MICROPHONES Field

DcnmRequestToSpeakOptionsDISCUSS_MIN_OPEN_MICROPHONES Field

Minimum value for number of open microphones

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DISCUSS_MIN_OPEN_MICROPHONES = 1
Public Const DISCUSS_MIN_OPEN_MICROPHONES As Integer = 1
public:
literal int DISCUSS_MIN_OPEN_MICROPHONES = 1

Field Value

Type: Int32
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRequestToSpeakOptions.DISCUSS_MIN_REQUESTS Field

DcnmRequestToSpeakOptionsDISCUSS_MIN_REQUESTS Field

Minimum value for number of requests in the requests list

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DISCUSS_MIN_REQUESTS = 0
Public Const DISCUSS_MIN_REQUESTS As Integer = 0
public:
literal int DISCUSS_MIN_REQUESTS = 0

Field Value

Type: Int32
See Also

Reference

DcnmRequestToSpeakOptions Class


DcnmRoomAudioSettingsInfo Class

Implementation of the DcnmRoomAudioSettingsInfo class.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmRoomAudioSettingsInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmRoomAudioSettingsInfo
Public Class DcnmRoomAudioSettingsInfo
public ref class DcnmRoomAudioSettingsInfo

The DcnmRoomAudioSettingsInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmRoomAudioSettingsInfo | Initializes a new instance of the DcnmRoomAudioSettingsInfo class.
Public method | DcnmRoomAudioSettingsInfo(IListDcnmAudioEqualizerSettings, IListDcnmAudioGainSetting, IListDcnmAudioSelectionSetting) | Initializes a new instance of the DcnmRoomAudioSettingsInfo class.
Top
Properties
 | Name | Description
Public property | AudioEqualizerSettingsList | List of audio equalizer settings.
Public property | AudioGainSettingList | List of audio gain settings.
Public property | AudioSelectionSettingList | List of audio selection settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmRoomAudioSettingsInfo Constructor

Overload List
 | Name | Description
Public method | DcnmRoomAudioSettingsInfo | Initializes a new instance of the DcnmRoomAudioSettingsInfo class.
Public method | DcnmRoomAudioSettingsInfo(IListDcnmAudioEqualizerSettings, IListDcnmAudioGainSetting, IListDcnmAudioSelectionSetting) | Initializes a new instance of the DcnmRoomAudioSettingsInfo class.
Top
See Also

Reference

DcnmRoomAudioSettingsInfo Class


DcnmRoomAudioSettingsInfo Constructor

Initializes a new instance of the DcnmRoomAudioSettingsInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmRoomAudioSettingsInfo()
Public Sub New
public:
DcnmRoomAudioSettingsInfo()
See Also

Reference

DcnmRoomAudioSettingsInfo Class
DcnmRoomAudioSettingsInfo Overload


DcnmRoomAudioSettingsInfo Constructor (IList(DcnmAudioEqualizerSettings), IList(DcnmAudioGainSetting), IList(DcnmAudioSelectionSetting))

DcnmRoomAudioSettingsInfo Constructor (IListDcnmAudioEqualizerSettings, IListDcnmAudioGainSetting, IListDcnmAudioSelectionSetting)

 Bosch Logo
Initializes a new instance of the DcnmRoomAudioSettingsInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmRoomAudioSettingsInfo(
    IList<DcnmAudioEqualizerSettings> audioEqualizerSettingsList,
    IList<DcnmAudioGainSetting> audioGainSettingList,
    IList<DcnmAudioSelectionSetting> audioSelectionSettingList
)
Public Sub New (
    audioEqualizerSettingsList As IList(Of DcnmAudioEqualizerSettings),
    audioGainSettingList As IList(Of DcnmAudioGainSetting),
    audioSelectionSettingList As IList(Of DcnmAudioSelectionSetting)
)
public:
DcnmRoomAudioSettingsInfo(
    IList<DcnmAudioEqualizerSettings^>^ audioEqualizerSettingsList,
    IList<DcnmAudioGainSetting^>^ audioGainSettingList,
    IList<DcnmAudioSelectionSetting^>^ audioSelectionSettingList
)

Parameters

audioEqualizerSettingsList
Type: System.Collections.GenericIList DcnmAudioEqualizerSettings
List of audio equalizer settings.
audioGainSettingList
Type: System.Collections.GenericIList DcnmAudioGainSetting
List of audio gain settings.
audioSelectionSettingList
Type: System.Collections.GenericIList DcnmAudioSelectionSetting
List of audio selection settings.
See Also

Reference

DcnmRoomAudioSettingsInfo Class
DcnmRoomAudioSettingsInfo Overload


DcnmRoomAudioSettingsInfo Properties

The DcnmRoomAudioSettingsInfo type exposes the following members.

Properties
 | Name | Description
Public property | AudioEqualizerSettingsList | List of audio equalizer settings.
Public property | AudioGainSettingList | List of audio gain settings.
Public property | AudioSelectionSettingList | List of audio selection settings.
Top
See Also

Reference

DcnmRoomAudioSettingsInfo Class


DcnmRoomAudioSettingsInfo.AudioEqualizerSettingsList Property

DcnmRoomAudioSettingsInfoAudioEqualizerSettingsList Property

List of audio equalizer settings.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<DcnmAudioEqualizerSettings> AudioEqualizerSettingsList { get; }
Public ReadOnly Property AudioEqualizerSettingsList As IList(Of DcnmAudioEqualizerSettings)
    Get
public:
property IList<DcnmAudioEqualizerSettings^>^ AudioEqualizerSettingsList {
    IList<DcnmAudioEqualizerSettings^>^ get ();
}

Property Value

Type: IList DcnmAudioEqualizerSettings
See Also

Reference

DcnmRoomAudioSettingsInfo Class


DcnmRoomAudioSettingsInfo.AudioGainSettingList Property

DcnmRoomAudioSettingsInfoAudioGainSettingList Property

List of audio gain settings.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<DcnmAudioGainSetting> AudioGainSettingList { get; }
Public ReadOnly Property AudioGainSettingList As IList(Of DcnmAudioGainSetting)
    Get
public:
property IList<DcnmAudioGainSetting^>^ AudioGainSettingList {
    IList<DcnmAudioGainSetting^>^ get ();
}

Property Value

Type: IList DcnmAudioGainSetting
See Also

Reference

DcnmRoomAudioSettingsInfo Class


DcnmRoomAudioSettingsInfo.AudioSelectionSettingList Property

DcnmRoomAudioSettingsInfoAudioSelectionSettingList Property

List of audio selection settings.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<DcnmAudioSelectionSetting> AudioSelectionSettingList { get; }
Public ReadOnly Property AudioSelectionSettingList As IList(Of DcnmAudioSelectionSetting)
    Get
public:
property IList<DcnmAudioSelectionSetting^>^ AudioSelectionSettingList {
    IList<DcnmAudioSelectionSetting^>^ get ();
}

Property Value

Type: IList DcnmAudioSelectionSetting
See Also

Reference

DcnmRoomAudioSettingsInfo Class


DcnmRoomAudioSettingsInfo Methods

The DcnmRoomAudioSettingsInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmRoomAudioSettingsInfo Class


DcnmSeatAssignmentInfo Class

Represents a container for seat installation information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSeatConfigurationInfo
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSeatAssignmentInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmSeatAssignmentInfo : DcnmSeatConfigurationInfo
Public Class DcnmSeatAssignmentInfo
    Inherits DcnmSeatConfigurationInfo
public ref class DcnmSeatAssignmentInfo : public DcnmSeatConfigurationInfo

The DcnmSeatAssignmentInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmSeatAssignmentInfo | Constructor...
Top
Properties
 | Name | Description
Public property | AreaId | The identifier of the area the seat is in. (Inherited from DcnmSeatConfigurationInfo.)
Public property | Attributes | The (device-)specific attributes available at the seat. (Inherited from DcnmSeatConfigurationInfo.)
Public property | CameraId | The identifier of the camera. (Inherited from DcnmSeatConfigurationInfo.)
Public property | CanDiscuss | Indicates if the seat has discuss rights. (Inherited from DcnmSeatConfigurationInfo.)
Public property | CanManageMeeting | Indicates if the seat has can manage meeting rights. (Inherited from DcnmSeatConfigurationInfo.)
Public property | CanUsePriority | Indicates if the seat has priority rights. (Inherited from DcnmSeatConfigurationInfo.)
Public property | Devices | A collection of values of which each entry indicates; the identifier(s) of the assigned device and the actual availability at this seat.
Public property | HasIdentificationLicense | Obsolete. Gets indicating whether this instance has an identification license. (Inherited from DcnmSeatConfigurationInfo.)
Public property | HasIdentificationLicense2 | Gets indicating whether this instance has an identification license. (Inherited from DcnmSeatConfigurationInfo.)
Public property | HasLanguageDistributionLicense | Obsolete. Gets a value indicating whether this instance has language distribution license. (Inherited from DcnmSeatConfigurationInfo.)
Public property | HasLanguageDistributionLicense2 | Gets a value indicating whether this instance has language distribution license. (Inherited from DcnmSeatConfigurationInfo.)
Public property | HasSpecialPermission | Indicates whether seat has special permission or not. (Inherited from DcnmSeatConfigurationInfo.)
Public property | HasVotingLicense | Obsolete. Gets a value indicating whether this instance has voting license. (Inherited from DcnmSeatConfigurationInfo.)
Public property | HasVotingLicense2 | Gets a value indicating whether this instance has voting license. (Inherited from DcnmSeatConfigurationInfo.)
Public property | Id | The identifier of the seat. (Inherited from DcnmSeatConfigurationInfo.)
Public property | Name | The name of the seat. (Inherited from DcnmSeatConfigurationInfo.)
Public property | PrepositionId | The identifier of the preposition. (Inherited from DcnmSeatConfigurationInfo.)
Public property | SeatNumber | The seat number. (Inherited from DcnmSeatConfigurationInfo.)
Public property | SeatType | The type of seat. (Inherited from DcnmSeatConfigurationInfo.)
Public property | VisType | The type of VIS. (Inherited from DcnmSeatConfigurationInfo.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmSeatAssignmentInfo Constructor

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSeatAssignmentInfo(
    DcnmSeatConfigurationInfo seatInfo,
    IList<DcnmDeviceAtSeat> devices
)
Public Sub New (
    seatInfo As DcnmSeatConfigurationInfo,
    devices As IList(Of DcnmDeviceAtSeat)
)
public:
DcnmSeatAssignmentInfo(
    DcnmSeatConfigurationInfo^ seatInfo,
    IList<DcnmDeviceAtSeat^>^ devices
)

Parameters

seatInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSeatConfigurationInfo
The information regarding the seat.
devices
Type: System.Collections.GenericIList DcnmDeviceAtSeat
A collection of values of which each entry indicates; the identifier(s) of the assigned device and the actual availability at this seat.
See Also

Reference

DcnmSeatAssignmentInfo Class


DcnmSeatAssignmentInfo Properties

The DcnmSeatAssignmentInfo type exposes the following members.

Properties
 | Name | Description
Public property | AreaId | The identifier of the area the seat is in. (Inherited from DcnmSeatConfigurationInfo.)
Public property | Attributes | The (device-)specific attributes available at the seat. (Inherited from DcnmSeatConfigurationInfo.)
Public property | CameraId | The identifier of the camera. (Inherited from DcnmSeatConfigurationInfo.)
Public property | CanDiscuss | Indicates if the seat has discuss rights. (Inherited from DcnmSeatConfigurationInfo.)
Public property | CanManageMeeting | Indicates if the seat has can manage meeting rights. (Inherited from DcnmSeatConfigurationInfo.)
Public property | CanUsePriority | Indicates if the seat has priority rights. (Inherited from DcnmSeatConfigurationInfo.)
Public property | Devices | A collection of values of which each entry indicates; the identifier(s) of the assigned device and the actual availability at this seat.
Public property | HasIdentificationLicense | Obsolete. Gets indicating whether this instance has an identification license. (Inherited from DcnmSeatConfigurationInfo.)
Public property | HasIdentificationLicense2 | Gets indicating whether this instance has an identification license. (Inherited from DcnmSeatConfigurationInfo.)
Public property | HasLanguageDistributionLicense | Obsolete. Gets a value indicating whether this instance has language distribution license. (Inherited from DcnmSeatConfigurationInfo.)
Public property | HasLanguageDistributionLicense2 | Gets a value indicating whether this instance has language distribution license. (Inherited from DcnmSeatConfigurationInfo.)
Public property | HasSpecialPermission | Indicates whether seat has special permission or not. (Inherited from DcnmSeatConfigurationInfo.)
Public property | HasVotingLicense | Obsolete. Gets a value indicating whether this instance has voting license. (Inherited from DcnmSeatConfigurationInfo.)
Public property | HasVotingLicense2 | Gets a value indicating whether this instance has voting license. (Inherited from DcnmSeatConfigurationInfo.)
Public property | Id | The identifier of the seat. (Inherited from DcnmSeatConfigurationInfo.)
Public property | Name | The name of the seat. (Inherited from DcnmSeatConfigurationInfo.)
Public property | PrepositionId | The identifier of the preposition. (Inherited from DcnmSeatConfigurationInfo.)
Public property | SeatNumber | The seat number. (Inherited from DcnmSeatConfigurationInfo.)
Public property | SeatType | The type of seat. (Inherited from DcnmSeatConfigurationInfo.)
Public property | VisType | The type of VIS. (Inherited from DcnmSeatConfigurationInfo.)
Top
See Also

Reference

DcnmSeatAssignmentInfo Class


DcnmSeatAssignmentInfo.Devices Property

DcnmSeatAssignmentInfoDevices Property

A collection of values of which each entry indicates; the identifier(s) of the assigned device and the actual availability at this seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<DcnmDeviceAtSeat> Devices { get; }
Public ReadOnly Property Devices As IList(Of DcnmDeviceAtSeat)
    Get
public:
property IList<DcnmDeviceAtSeat^>^ Devices {
    IList<DcnmDeviceAtSeat^>^ get ();
}

Property Value

Type: IList DcnmDeviceAtSeat
See Also

Reference

DcnmSeatAssignmentInfo Class


DcnmSeatAssignmentInfo Methods

The DcnmSeatAssignmentInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmSeatAssignmentInfo Class


DcnmSeatConfigurationInfo Class

Container for the seat information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSeatConfigurationInfo
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSeatAssignmentInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmSeatConfigurationInfo
Public Class DcnmSeatConfigurationInfo
public ref class DcnmSeatConfigurationInfo

The DcnmSeatConfigurationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmSeatConfigurationInfo(Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, Boolean, Boolean, Guid, Int32) | Obsolete. Initializes a new instance of the DcnmSeatConfigurationInfo class.
Public method | DcnmSeatConfigurationInfo(Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, DcnmLicenseStateType, DcnmLicenseStateType, DcnmLicenseStateType, Guid, Int32) | Obsolete. Initializes a new instance of the DcnmSeatConfigurationInfo class.
Public method | DcnmSeatConfigurationInfo(Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, Boolean, Boolean, Guid, Int32, Boolean) | Obsolete. Initializes a new instance of the DcnmSeatConfigurationInfo class.
Public method | DcnmSeatConfigurationInfo(Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, DcnmLicenseStateType, DcnmLicenseStateType, DcnmLicenseStateType, Guid, Int32, DcnmSeatType, Int32) | Obsolete. Initializes a new instance of the DcnmSeatConfigurationInfo class.
Public method | DcnmSeatConfigurationInfo(Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, DcnmLicenseStateType, DcnmLicenseStateType, DcnmLicenseStateType, Guid, Int32, DcnmSeatType, Int32, Boolean) | Obsolete. Initializes a new instance of the DcnmSeatConfigurationInfo class.
Public method | DcnmSeatConfigurationInfo(Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, DcnmLicenseStateType, DcnmLicenseStateType, DcnmLicenseStateType, Guid, Int32, DcnmSeatType, ICollectionString, Int32, Boolean) | Initializes a new instance of the DcnmSeatConfigurationInfo class.
Top
Properties
 | Name | Description
Public property | AreaId | The identifier of the area the seat is in.
Public property | Attributes | The (device-)specific attributes available at the seat.
Public property | CameraId | The identifier of the camera.
Public property | CanDiscuss | Indicates if the seat has discuss rights.
Public property | CanManageMeeting | Indicates if the seat has can manage meeting rights.
Public property | CanUsePriority | Indicates if the seat has priority rights.
Public property | HasIdentificationLicense | Obsolete. Gets indicating whether this instance has an identification license.
Public property | HasIdentificationLicense2 | Gets indicating whether this instance has an identification license.
Public property | HasLanguageDistributionLicense | Obsolete. Gets a value indicating whether this instance has language distribution license.
Public property | HasLanguageDistributionLicense2 | Gets a value indicating whether this instance has language distribution license.
Public property | HasSpecialPermission | Indicates whether seat has special permission or not.
Public property | HasVotingLicense | Obsolete. Gets a value indicating whether this instance has voting license.
Public property | HasVotingLicense2 | Gets a value indicating whether this instance has voting license.
Public property | Id | The identifier of the seat.
Public property | Name | The name of the seat.
Public property | PrepositionId | The identifier of the preposition.
Public property | SeatNumber | The seat number.
Public property | SeatType | The type of seat.
Public property | VisType | The type of VIS.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmSeatConfigurationInfo Constructor

There are six overloads for this method
There are six overloads for this method
There are six overloads for this method
There are six overloads for this method
There are six overloads for this method
Overload List
 | Name | Description
Public method | DcnmSeatConfigurationInfo(Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, Boolean, Boolean, Guid, Int32) | Obsolete. Initializes a new instance of the DcnmSeatConfigurationInfo class.
Public method | DcnmSeatConfigurationInfo(Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, DcnmLicenseStateType, DcnmLicenseStateType, DcnmLicenseStateType, Guid, Int32) | Obsolete. Initializes a new instance of the DcnmSeatConfigurationInfo class.
Public method | DcnmSeatConfigurationInfo(Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, Boolean, Boolean, Guid, Int32, Boolean) | Obsolete. Initializes a new instance of the DcnmSeatConfigurationInfo class.
Public method | DcnmSeatConfigurationInfo(Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, DcnmLicenseStateType, DcnmLicenseStateType, DcnmLicenseStateType, Guid, Int32, DcnmSeatType, Int32) | Obsolete. Initializes a new instance of the DcnmSeatConfigurationInfo class.
Public method | DcnmSeatConfigurationInfo(Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, DcnmLicenseStateType, DcnmLicenseStateType, DcnmLicenseStateType, Guid, Int32, DcnmSeatType, Int32, Boolean) | Obsolete. Initializes a new instance of the DcnmSeatConfigurationInfo class.
Public method | DcnmSeatConfigurationInfo(Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, DcnmLicenseStateType, DcnmLicenseStateType, DcnmLicenseStateType, Guid, Int32, DcnmSeatType, ICollectionString, Int32, Boolean) | Initializes a new instance of the DcnmSeatConfigurationInfo class.
Top
See Also

Reference

DcnmSeatConfigurationInfo Class
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
DcnmSeatConfigurationInfoDcnmSeatConfigurationInfo(Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, DcnmLicenseStateType, DcnmLicenseStateType, DcnmLicenseStateType, Guid, Int32)


DcnmSeatConfigurationInfo Constructor (Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, Boolean, Boolean, Guid, Int32)

Note: This API is now obsolete.

Initializes a new instance of the DcnmSeatConfigurationInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with the SeatType enumeration")]
public DcnmSeatConfigurationInfo(
    Guid id,
    string name,
    Guid areaId,
    DcnmSpecialOperationType visType,
    bool canDiscuss,
    bool canManageMeeting,
    bool canUsePriority,
    bool hasLanguageDistributionLicense,
    bool hasVotingLicense,
    Guid cameraId,
    int prepositionId
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with the SeatType enumeration")>
Public Sub New (
    id As Guid,
    name As String,
    areaId As Guid,
    visType As DcnmSpecialOperationType,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canUsePriority As Boolean,
    hasLanguageDistributionLicense As Boolean,
    hasVotingLicense As Boolean,
    cameraId As Guid,
    prepositionId As Integer
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with the SeatType enumeration")]
DcnmSeatConfigurationInfo(
    Guid id,
    String^ name,
    Guid areaId,
    DcnmSpecialOperationType visType,
    bool canDiscuss,
    bool canManageMeeting,
    bool canUsePriority,
    bool hasLanguageDistributionLicense,
    bool hasVotingLicense,
    Guid cameraId,
    int prepositionId
)

Parameters

id
Type: SystemGuid
The identifier of the seat.
name
Type: SystemString
The name of the seat.
areaId
Type: SystemGuid
The area the seat is in.
visType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpecialOperationType
The type of VIS.DcnmSpecialOperationType
canDiscuss
Type: SystemBoolean
Discussion capability at the seat.
canManageMeeting
Type: SystemBoolean
Manage Meeting capability at the seat.
canUsePriority
Type: SystemBoolean
Priority capability at the seat.
hasLanguageDistributionLicense
Type: SystemBoolean
Whether this instance has language distribution license.
hasVotingLicense
Type: SystemBoolean
Whether this instance has voting license.
cameraId
Type: SystemGuid
the camera Id.
prepositionId
Type: SystemInt32
the preposition Id.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmSeatConfigurationInfo(Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, Boolean, Boolean, Guid, Int32, Boolean) instead
See Also

Reference

DcnmSeatConfigurationInfo Class
DcnmSeatConfigurationInfo Overload


DcnmSeatConfigurationInfo Constructor (Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, DcnmLicenseStateType, DcnmLicenseStateType, DcnmLicenseStateType, Guid, Int32)

Note: This API is now obsolete.

Initializes a new instance of the DcnmSeatConfigurationInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with the SeatType enumeration")]
public DcnmSeatConfigurationInfo(
    Guid id,
    string name,
    Guid areaId,
    DcnmSpecialOperationType visType,
    bool canDiscuss,
    bool canManageMeeting,
    bool canUsePriority,
    DcnmLicenseStateType hasLanguageDistributionLicense,
    DcnmLicenseStateType hasVotingLicense,
    DcnmLicenseStateType hasIdentificationLicense,
    Guid cameraId,
    int prepositionId
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with the SeatType enumeration")>
Public Sub New (
    id As Guid,
    name As String,
    areaId As Guid,
    visType As DcnmSpecialOperationType,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canUsePriority As Boolean,
    hasLanguageDistributionLicense As DcnmLicenseStateType,
    hasVotingLicense As DcnmLicenseStateType,
    hasIdentificationLicense As DcnmLicenseStateType,
    cameraId As Guid,
    prepositionId As Integer
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with the SeatType enumeration")]
DcnmSeatConfigurationInfo(
    Guid id,
    String^ name,
    Guid areaId,
    DcnmSpecialOperationType visType,
    bool canDiscuss,
    bool canManageMeeting,
    bool canUsePriority,
    DcnmLicenseStateType hasLanguageDistributionLicense,
    DcnmLicenseStateType hasVotingLicense,
    DcnmLicenseStateType hasIdentificationLicense,
    Guid cameraId,
    int prepositionId
)

Parameters

id
Type: SystemGuid
The identifier of the seat.
name
Type: SystemString
The name of the seat.
areaId
Type: SystemGuid
The area the seat is in.
visType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpecialOperationType
The type of VIS.DcnmSpecialOperationType
canDiscuss
Type: SystemBoolean
Discussion capability at the seat.
canManageMeeting
Type: SystemBoolean
Manage Meeting capability at the seat.
canUsePriority
Type: SystemBoolean
Priority capability at the seat.
hasLanguageDistributionLicense
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLicenseStateType
Whether this instance has language distribution license.
hasVotingLicense
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLicenseStateType
Whether this instance has voting license.
hasIdentificationLicense
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLicenseStateType
Whether this instance has an identification license.
cameraId
Type: SystemGuid
the camera Id.
prepositionId
Type: SystemInt32
the preposition Id.
See Also

Reference

DcnmSeatConfigurationInfo Class
DcnmSeatConfigurationInfo Overload


DcnmSeatConfigurationInfo Constructor (Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, Boolean, Boolean, Guid, Int32, Boolean)

Note: This API is now obsolete.

Initializes a new instance of the DcnmSeatConfigurationInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with the SeatType enumeration")]
public DcnmSeatConfigurationInfo(
    Guid id,
    string name,
    Guid areaId,
    DcnmSpecialOperationType visType,
    bool canDiscuss,
    bool canManageMeeting,
    bool canUsePriority,
    bool hasLanguageDistributionLicense,
    bool hasVotingLicense,
    Guid cameraId,
    int prepositionId,
    bool hasIdentificationLicense
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with the SeatType enumeration")>
Public Sub New (
    id As Guid,
    name As String,
    areaId As Guid,
    visType As DcnmSpecialOperationType,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canUsePriority As Boolean,
    hasLanguageDistributionLicense As Boolean,
    hasVotingLicense As Boolean,
    cameraId As Guid,
    prepositionId As Integer,
    hasIdentificationLicense As Boolean
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with the SeatType enumeration")]
DcnmSeatConfigurationInfo(
    Guid id,
    String^ name,
    Guid areaId,
    DcnmSpecialOperationType visType,
    bool canDiscuss,
    bool canManageMeeting,
    bool canUsePriority,
    bool hasLanguageDistributionLicense,
    bool hasVotingLicense,
    Guid cameraId,
    int prepositionId,
    bool hasIdentificationLicense
)

Parameters

id
Type: SystemGuid
The identifier of the seat.
name
Type: SystemString
The name of the seat.
areaId
Type: SystemGuid
The area the seat is in.
visType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpecialOperationType
The type of VIS.DcnmSpecialOperationType
canDiscuss
Type: SystemBoolean
Discussion capability at the seat.
canManageMeeting
Type: SystemBoolean
Manage Meeting capability at the seat.
canUsePriority
Type: SystemBoolean
Priority capability at the seat.
hasLanguageDistributionLicense
Type: SystemBoolean
Whether this instance has language distribution license.
hasVotingLicense
Type: SystemBoolean
Whether this instance has voting license.
cameraId
Type: SystemGuid
the camera Id.
prepositionId
Type: SystemInt32
the preposition Id.
hasIdentificationLicense
Type: SystemBoolean
Whether this instance has an identification license.
See Also

Reference

DcnmSeatConfigurationInfo Class
DcnmSeatConfigurationInfo Overload


DcnmSeatConfigurationInfo Constructor (Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, DcnmLicenseStateType, DcnmLicenseStateType, DcnmLicenseStateType, Guid, Int32, DcnmSeatType, Int32)

Note: This API is now obsolete.

Initializes a new instance of the DcnmSeatConfigurationInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with HasSpecialPermision field")]
public DcnmSeatConfigurationInfo(
    Guid id,
    string name,
    Guid areaId,
    DcnmSpecialOperationType visType,
    bool canDiscuss,
    bool canManageMeeting,
    bool canUsePriority,
    DcnmLicenseStateType hasLanguageDistributionLicense,
    DcnmLicenseStateType hasVotingLicense,
    DcnmLicenseStateType hasIdentificationLicense,
    Guid cameraId,
    int prepositionId,
    DcnmSeatType seatType,
    int seatNumber
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with HasSpecialPermision field")>
Public Sub New (
    id As Guid,
    name As String,
    areaId As Guid,
    visType As DcnmSpecialOperationType,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canUsePriority As Boolean,
    hasLanguageDistributionLicense As DcnmLicenseStateType,
    hasVotingLicense As DcnmLicenseStateType,
    hasIdentificationLicense As DcnmLicenseStateType,
    cameraId As Guid,
    prepositionId As Integer,
    seatType As DcnmSeatType,
    seatNumber As Integer
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with HasSpecialPermision field")]
DcnmSeatConfigurationInfo(
    Guid id,
    String^ name,
    Guid areaId,
    DcnmSpecialOperationType visType,
    bool canDiscuss,
    bool canManageMeeting,
    bool canUsePriority,
    DcnmLicenseStateType hasLanguageDistributionLicense,
    DcnmLicenseStateType hasVotingLicense,
    DcnmLicenseStateType hasIdentificationLicense,
    Guid cameraId,
    int prepositionId,
    DcnmSeatType seatType,
    int seatNumber
)

Parameters

id
Type: SystemGuid
The identifier of the seat.
name
Type: SystemString
The name of the seat.
areaId
Type: SystemGuid
The area the seat is in.
visType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpecialOperationType
The type of VIS.DcnmSpecialOperationType
canDiscuss
Type: SystemBoolean
Discussion capability at the seat.
canManageMeeting
Type: SystemBoolean
Manage Meeting capability at the seat.
canUsePriority
Type: SystemBoolean
Priority capability at the seat.
hasLanguageDistributionLicense
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLicenseStateType
Whether this instance has language distribution license.
hasVotingLicense
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLicenseStateType
Whether this instance has voting license.
hasIdentificationLicense
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLicenseStateType
Whether this instance has an identification license.
cameraId
Type: SystemGuid
the camera Id.
prepositionId
Type: SystemInt32
the preposition Id.
seatType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSeatType
Represents the type of seat DcnmSeatType
seatNumber
Type: SystemInt32
The seat number.
See Also

Reference

DcnmSeatConfigurationInfo Class
DcnmSeatConfigurationInfo Overload


DcnmSeatConfigurationInfo Constructor (Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, DcnmLicenseStateType, DcnmLicenseStateType, DcnmLicenseStateType, Guid, Int32, DcnmSeatType, Int32, Boolean)

Note: This API is now obsolete.

Initializes a new instance of the DcnmSeatConfigurationInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")]
public DcnmSeatConfigurationInfo(
    Guid id,
    string name,
    Guid areaId,
    DcnmSpecialOperationType visType,
    bool canDiscuss,
    bool canManageMeeting,
    bool canUsePriority,
    DcnmLicenseStateType hasLanguageDistributionLicense,
    DcnmLicenseStateType hasVotingLicense,
    DcnmLicenseStateType hasIdentificationLicense,
    Guid cameraId,
    int prepositionId,
    DcnmSeatType seatType,
    int seatNumber,
    bool hasSpecialPermission
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")>
Public Sub New (
    id As Guid,
    name As String,
    areaId As Guid,
    visType As DcnmSpecialOperationType,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canUsePriority As Boolean,
    hasLanguageDistributionLicense As DcnmLicenseStateType,
    hasVotingLicense As DcnmLicenseStateType,
    hasIdentificationLicense As DcnmLicenseStateType,
    cameraId As Guid,
    prepositionId As Integer,
    seatType As DcnmSeatType,
    seatNumber As Integer,
    hasSpecialPermission As Boolean
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection instead.")]
DcnmSeatConfigurationInfo(
    Guid id,
    String^ name,
    Guid areaId,
    DcnmSpecialOperationType visType,
    bool canDiscuss,
    bool canManageMeeting,
    bool canUsePriority,
    DcnmLicenseStateType hasLanguageDistributionLicense,
    DcnmLicenseStateType hasVotingLicense,
    DcnmLicenseStateType hasIdentificationLicense,
    Guid cameraId,
    int prepositionId,
    DcnmSeatType seatType,
    int seatNumber,
    bool hasSpecialPermission
)

Parameters

id
Type: SystemGuid
The identifier of the seat.
name
Type: SystemString
The name of the seat.
areaId
Type: SystemGuid
The area the seat is in.
visType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpecialOperationType
The type of VIS.DcnmSpecialOperationType
canDiscuss
Type: SystemBoolean
Discussion capability at the seat.
canManageMeeting
Type: SystemBoolean
Manage Meeting capability at the seat.
canUsePriority
Type: SystemBoolean
Priority capability at the seat.
hasLanguageDistributionLicense
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLicenseStateType
Whether this instance has language distribution license.
hasVotingLicense
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLicenseStateType
Whether this instance has voting license.
hasIdentificationLicense
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLicenseStateType
Whether this instance has an identification license.
cameraId
Type: SystemGuid
the camera Id.
prepositionId
Type: SystemInt32
the preposition Id.
seatType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSeatType
Represents the type of seat DcnmSeatType
seatNumber
Type: SystemInt32
The seat number.
hasSpecialPermission
Type: SystemBoolean
Flag indicates whether seat has special permission or not.
See Also

Reference

DcnmSeatConfigurationInfo Class
DcnmSeatConfigurationInfo Overload


DcnmSeatConfigurationInfo Constructor (Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, DcnmLicenseStateType, DcnmLicenseStateType, DcnmLicenseStateType, Guid, Int32, DcnmSeatType, ICollection(String), Int32, Boolean)

DcnmSeatConfigurationInfo Constructor (Guid, String, Guid, DcnmSpecialOperationType, Boolean, Boolean, Boolean, DcnmLicenseStateType, DcnmLicenseStateType, DcnmLicenseStateType, Guid, Int32, DcnmSeatType, ICollectionString, Int32, Boolean)

 Bosch Logo
Initializes a new instance of the DcnmSeatConfigurationInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSeatConfigurationInfo(
    Guid id,
    string name,
    Guid areaId,
    DcnmSpecialOperationType visType,
    bool canDiscuss,
    bool canManageMeeting,
    bool canUsePriority,
    DcnmLicenseStateType hasLanguageDistributionLicense,
    DcnmLicenseStateType hasVotingLicense,
    DcnmLicenseStateType hasIdentificationLicense,
    Guid cameraId,
    int prepositionId,
    DcnmSeatType seatType,
    ICollection<string> attributes,
    int seatNumber,
    bool hasSpecialPermission
)
Public Sub New (
    id As Guid,
    name As String,
    areaId As Guid,
    visType As DcnmSpecialOperationType,
    canDiscuss As Boolean,
    canManageMeeting As Boolean,
    canUsePriority As Boolean,
    hasLanguageDistributionLicense As DcnmLicenseStateType,
    hasVotingLicense As DcnmLicenseStateType,
    hasIdentificationLicense As DcnmLicenseStateType,
    cameraId As Guid,
    prepositionId As Integer,
    seatType As DcnmSeatType,
    attributes As ICollection(Of String),
    seatNumber As Integer,
    hasSpecialPermission As Boolean
)
public:
DcnmSeatConfigurationInfo(
    Guid id,
    String^ name,
    Guid areaId,
    DcnmSpecialOperationType visType,
    bool canDiscuss,
    bool canManageMeeting,
    bool canUsePriority,
    DcnmLicenseStateType hasLanguageDistributionLicense,
    DcnmLicenseStateType hasVotingLicense,
    DcnmLicenseStateType hasIdentificationLicense,
    Guid cameraId,
    int prepositionId,
    DcnmSeatType seatType,
    ICollection<String^>^ attributes,
    int seatNumber,
    bool hasSpecialPermission
)

Parameters

id
Type: SystemGuid
The identifier of the seat.
name
Type: SystemString
The name of the seat.
areaId
Type: SystemGuid
The area the seat is in.
visType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpecialOperationType
The type of VIS.DcnmSpecialOperationType
canDiscuss
Type: SystemBoolean
Discussion capability at the seat.
canManageMeeting
Type: SystemBoolean
Manage Meeting capability at the seat.
canUsePriority
Type: SystemBoolean
Priority capability at the seat.
hasLanguageDistributionLicense
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLicenseStateType
Whether this instance has language distribution license.
hasVotingLicense
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLicenseStateType
Whether this instance has voting license.
hasIdentificationLicense
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLicenseStateType
Whether this instance has an identification license.
cameraId
Type: SystemGuid
the camera Id.
prepositionId
Type: SystemInt32
the preposition Id.
seatType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSeatType
Represents the type of seat DcnmSeatType
attributes
Type: System.Collections.GenericICollection String
The (device-)specific attributes available at the seat.
seatNumber
Type: SystemInt32
The seat number.
hasSpecialPermission
Type: SystemBoolean
Flag indicates whether seat has special permission or not.
See Also

Reference

DcnmSeatConfigurationInfo Class
DcnmSeatConfigurationInfo Overload


DcnmSeatConfigurationInfo Properties

The DcnmSeatConfigurationInfo type exposes the following members.

Properties
 | Name | Description
Public property | AreaId | The identifier of the area the seat is in.
Public property | Attributes | The (device-)specific attributes available at the seat.
Public property | CameraId | The identifier of the camera.
Public property | CanDiscuss | Indicates if the seat has discuss rights.
Public property | CanManageMeeting | Indicates if the seat has can manage meeting rights.
Public property | CanUsePriority | Indicates if the seat has priority rights.
Public property | HasIdentificationLicense | Obsolete. Gets indicating whether this instance has an identification license.
Public property | HasIdentificationLicense2 | Gets indicating whether this instance has an identification license.
Public property | HasLanguageDistributionLicense | Obsolete. Gets a value indicating whether this instance has language distribution license.
Public property | HasLanguageDistributionLicense2 | Gets a value indicating whether this instance has language distribution license.
Public property | HasSpecialPermission | Indicates whether seat has special permission or not.
Public property | HasVotingLicense | Obsolete. Gets a value indicating whether this instance has voting license.
Public property | HasVotingLicense2 | Gets a value indicating whether this instance has voting license.
Public property | Id | The identifier of the seat.
Public property | Name | The name of the seat.
Public property | PrepositionId | The identifier of the preposition.
Public property | SeatNumber | The seat number.
Public property | SeatType | The type of seat.
Public property | VisType | The type of VIS.
Top
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.AreaId Property

DcnmSeatConfigurationInfoAreaId Property

The identifier of the area the seat is in.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid AreaId { get; }
Public ReadOnly Property AreaId As Guid
    Get
public:
property Guid AreaId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.Attributes Property

DcnmSeatConfigurationInfoAttributes Property

The (device-)specific attributes available at the seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public ICollection<string> Attributes { get; }
Public ReadOnly Property Attributes As ICollection(Of String)
    Get
public:
property ICollection<String^>^ Attributes {
    ICollection<String^>^ get ();
}

Property Value

Type: ICollection String
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.CameraId Property

DcnmSeatConfigurationInfoCameraId Property

The identifier of the camera.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid CameraId { get; }
Public ReadOnly Property CameraId As Guid
    Get
public:
property Guid CameraId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.CanDiscuss Property

DcnmSeatConfigurationInfoCanDiscuss Property

Indicates if the seat has discuss rights.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanDiscuss { get; }
Public ReadOnly Property CanDiscuss As Boolean
    Get
public:
property bool CanDiscuss {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.CanManageMeeting Property

DcnmSeatConfigurationInfoCanManageMeeting Property

Indicates if the seat has can manage meeting rights.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanManageMeeting { get; }
Public ReadOnly Property CanManageMeeting As Boolean
    Get
public:
property bool CanManageMeeting {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.CanUsePriority Property

DcnmSeatConfigurationInfoCanUsePriority Property

Indicates if the seat has priority rights.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanUsePriority { get; }
Public ReadOnly Property CanUsePriority As Boolean
    Get
public:
property bool CanUsePriority {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.HasIdentificationLicense Property

DcnmSeatConfigurationInfoHasIdentificationLicense Property

Note: This API is now obsolete.

Gets indicating whether this instance has an identification license.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is Obsolete, use the HasIdentificationLicense2 property")]
public bool HasIdentificationLicense { get; }
<ObsoleteAttribute("This property is Obsolete, use the HasIdentificationLicense2 property")>
Public ReadOnly Property HasIdentificationLicense As Boolean
    Get
public:
[ObsoleteAttribute(L"This property is Obsolete, use the HasIdentificationLicense2 property")]
property bool HasIdentificationLicense {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.HasIdentificationLicense2 Property

DcnmSeatConfigurationInfoHasIdentificationLicense2 Property

Gets indicating whether this instance has an identification license.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmLicenseStateType HasIdentificationLicense2 { get; }
Public ReadOnly Property HasIdentificationLicense2 As DcnmLicenseStateType
    Get
public:
property DcnmLicenseStateType HasIdentificationLicense2 {
    DcnmLicenseStateType get ();
}

Property Value

Type: DcnmLicenseStateType
Remarks
This property provides the Indentification license assigned. Any Implied value set for this property during the update of the seat configuration will reset the assigned license.
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.HasLanguageDistributionLicense Property

DcnmSeatConfigurationInfoHasLanguageDistributionLicense Property

Bosch Logo

Note: This API is now obsolete.

Gets a value indicating whether this instance has language distribution license.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is Obsolete, use the HasLanguageDistributionLicense2 property")]
public bool HasLanguageDistributionLicense { get; }
<ObsoleteAttribute("This property is Obsolete, use the HasLanguageDistributionLicense2 property")>
Public ReadOnly Property HasLanguageDistributionLicense As Boolean
    Get
public:
[ObsoleteAttribute(L"This property is Obsolete, use the HasLanguageDistributionLicense2 property")]
property bool HasLanguageDistributionLicense {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.HasLanguageDistributionLicense2 Property

DcnmSeatConfigurationInfoHasLanguageDistributionLicense2 Property

Bosch Logo
Gets a value indicating whether this instance has language distribution license.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmLicenseStateType HasLanguageDistributionLicense2 { get; }
Public ReadOnly Property HasLanguageDistributionLicense2 As DcnmLicenseStateType
    Get
public:
property DcnmLicenseStateType HasLanguageDistributionLicense2 {
    DcnmLicenseStateType get ();
}

Property Value

Type: DcnmLicenseStateType
Remarks
This property providesing the Voting license either assigned or recieved due to the attachment of the DCNM-DLS device to this seat. Any Implied value set for this property during the update of the seat configuration will reset the assigned license.
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.HasSpecialPermission Property

DcnmSeatConfigurationInfoHasSpecialPermission Property

Indicates whether seat has special permission or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool HasSpecialPermission { get; }
Public ReadOnly Property HasSpecialPermission As Boolean
    Get
public:
property bool HasSpecialPermission {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.HasVotingLicense Property

DcnmSeatConfigurationInfoHasVotingLicense Property

Note: This API is now obsolete.

Gets a value indicating whether this instance has voting license.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is Obsolete, use the HasVotingLicense2 property")]
public bool HasVotingLicense { get; }
<ObsoleteAttribute("This property is Obsolete, use the HasVotingLicense2 property")>
Public ReadOnly Property HasVotingLicense As Boolean
    Get
public:
[ObsoleteAttribute(L"This property is Obsolete, use the HasVotingLicense2 property")]
property bool HasVotingLicense {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.HasVotingLicense2 Property

DcnmSeatConfigurationInfoHasVotingLicense2 Property

Gets a value indicating whether this instance has voting license.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmLicenseStateType HasVotingLicense2 { get; }
Public ReadOnly Property HasVotingLicense2 As DcnmLicenseStateType
    Get
public:
property DcnmLicenseStateType HasVotingLicense2 {
    DcnmLicenseStateType get ();
}

Property Value

Type: DcnmLicenseStateType
Remarks
This property providesing the Voting license either assigned or recieved due to the attachment of the DCNM-DVT device to this seat. Any Implied value set for this property during the update of the seat configuration will reset the assigned license.
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.Id Property

DcnmSeatConfigurationInfoId Property

The identifier of the seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid Id { get; }
Public ReadOnly Property Id As Guid
    Get
public:
property Guid Id {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.Name Property

DcnmSeatConfigurationInfoName Property

The name of the seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.PrepositionId Property

DcnmSeatConfigurationInfoPrepositionId Property

The identifier of the preposition.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int PrepositionId { get; }
Public ReadOnly Property PrepositionId As Integer
    Get
public:
property int PrepositionId {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.SeatNumber Property

DcnmSeatConfigurationInfoSeatNumber Property

The seat number.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int SeatNumber { get; }
Public ReadOnly Property SeatNumber As Integer
    Get
public:
property int SeatNumber {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.SeatType Property

DcnmSeatConfigurationInfoSeatType Property

The type of seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSeatType SeatType { get; }
Public ReadOnly Property SeatType As DcnmSeatType
    Get
public:
property DcnmSeatType SeatType {
    DcnmSeatType get ();
}

Property Value

Type: DcnmSeatType
Remarks
Represents whether the seat is ParticipantSeat or a InterpreterSeat
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo.VisType Property

DcnmSeatConfigurationInfoVisType Property

The type of VIS.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpecialOperationType VisType { get; }
Public ReadOnly Property VisType As DcnmSpecialOperationType
    Get
public:
property DcnmSpecialOperationType VisType {
    DcnmSpecialOperationType get ();
}

Property Value

Type: DcnmSpecialOperationType
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatConfigurationInfo Methods

The DcnmSeatConfigurationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmSeatConfigurationInfo Class


DcnmSeatInfo Class

Container for the seat information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSeatInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmSeatInfo
Public Class DcnmSeatInfo
public ref class DcnmSeatInfo

The DcnmSeatInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmSeatInfo | Default constructor.
Public method | DcnmSeatInfo(Guid, String) | Constructor...
Top
Properties
 | Name | Description
Public property | Id | The identifier of the seat.
Public property | Name | The name of the seat.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmSeatInfo Constructor

Overload List
 | Name | Description
Public method | DcnmSeatInfo | Default constructor.
Public method | DcnmSeatInfo(Guid, String) | Constructor...
Top
See Also

Reference

DcnmSeatInfo Class


DcnmSeatInfo Constructor

Default constructor.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSeatInfo()
Public Sub New
public:
DcnmSeatInfo()
See Also

Reference

DcnmSeatInfo Class
DcnmSeatInfo Overload


DcnmSeatInfo Constructor (Guid, String)

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSeatInfo(
    Guid id,
    string name
)
Public Sub New (
    id As Guid,
    name As String
)
public:
DcnmSeatInfo(
    Guid id,
    String^ name
)

Parameters

id
Type: SystemGuid
The identifier of the seat.
name
Type: SystemString
The name of the seat.
See Also

Reference

DcnmSeatInfo Class
DcnmSeatInfo Overload


DcnmSeatInfo Properties

The DcnmSeatInfo type exposes the following members.

Properties
 | Name | Description
Public property | Id | The identifier of the seat.
Public property | Name | The name of the seat.
Top
See Also

Reference

DcnmSeatInfo Class


DcnmSeatInfo.Id Property

DcnmSeatInfoId Property

The identifier of the seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid Id { get; }
Public ReadOnly Property Id As Guid
    Get
public:
property Guid Id {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmSeatInfo Class


DcnmSeatInfo.Name Property

DcnmSeatInfoName Property

The name of the seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmSeatInfo Class


DcnmSeatInfo Methods

The DcnmSeatInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmSeatInfo Class


DcnmSeatType Enumeration

Defines the available seat types within the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmSeatType
Public Enumeration DcnmSeatType
public enum class DcnmSeatType
Members
Member name | Value | Description
ParticipantSeat | 0 | Seat for a participant.
InterpreterSeat | 1 | Seat for an interpreter.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmSpeakerInfo Class

Defines a speaker entry in the speakersList
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpeakerInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmSpeakerInfo
Public Class DcnmSpeakerInfo
public ref class DcnmSpeakerInfo

The DcnmSpeakerInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmSpeakerInfo(Guid, DcnmMicrophoneState, DcnmParticipantInfo, DcnmSeatInfo) | Constructor for class.
Public method | DcnmSpeakerInfo(Guid, DcnmMicrophoneState, DcnmParticipantInfo, DcnmSeatInfo, DcnmSpeechTimerInfo) | Constructor for class.
Top
Properties
 | Name | Description
Public property | MicrophoneState | The microphone state of the speaker.
Public property | ParticipantInfo | The participant information of the speaker.
Public property | SeatInfo | The seat information of the speaker
Public property | SpeakerId | The speaker id.
Public property | SpeechTimerInfo | Speech timer information of the speaker
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Note: Inorder to tell if a speaker list entry is for a remote participant, Use GetSeats to find all the seats. Use DcnmSpeakerInfo.SeatInfo.Id to find the seat in the list returned from GetSeats. Check if the seat has the "Remote" attribute. In synoptic, use the seats SeatType property.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmSpeakerInfo Constructor

Overload List
 | Name | Description
Public method | DcnmSpeakerInfo(Guid, DcnmMicrophoneState, DcnmParticipantInfo, DcnmSeatInfo) | Constructor for class.
Public method | DcnmSpeakerInfo(Guid, DcnmMicrophoneState, DcnmParticipantInfo, DcnmSeatInfo, DcnmSpeechTimerInfo) | Constructor for class.
Top
See Also

Reference

DcnmSpeakerInfo Class


DcnmSpeakerInfo Constructor (Guid, DcnmMicrophoneState, DcnmParticipantInfo, DcnmSeatInfo)

Constructor for class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpeakerInfo(
    Guid speakerId,
    DcnmMicrophoneState microphoneState,
    DcnmParticipantInfo participantInfo,
    DcnmSeatInfo seatInfo
)
Public Sub New (
    speakerId As Guid,
    microphoneState As DcnmMicrophoneState,
    participantInfo As DcnmParticipantInfo,
    seatInfo As DcnmSeatInfo
)
public:
DcnmSpeakerInfo(
    Guid speakerId,
    DcnmMicrophoneState microphoneState,
    DcnmParticipantInfo^ participantInfo,
    DcnmSeatInfo^ seatInfo
)

Parameters

speakerId
Type: SystemGuid
The speaker id.
microphoneState
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMicrophoneState
The microphone state of the speaker.
participantInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmParticipantInfo
The participant info of the speaker.
seatInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSeatInfo
The seat info of the speaker.
See Also

Reference

DcnmSpeakerInfo Class
DcnmSpeakerInfo Overload


DcnmSpeakerInfo Constructor (Guid, DcnmMicrophoneState, DcnmParticipantInfo, DcnmSeatInfo, DcnmSpeechTimerInfo)

Constructor for class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpeakerInfo(
    Guid speakerId,
    DcnmMicrophoneState microphoneState,
    DcnmParticipantInfo participantInfo,
    DcnmSeatInfo seatInfo,
    DcnmSpeechTimerInfo speechTimerInfo
)
Public Sub New (
    speakerId As Guid,
    microphoneState As DcnmMicrophoneState,
    participantInfo As DcnmParticipantInfo,
    seatInfo As DcnmSeatInfo,
    speechTimerInfo As DcnmSpeechTimerInfo
)
public:
DcnmSpeakerInfo(
    Guid speakerId,
    DcnmMicrophoneState microphoneState,
    DcnmParticipantInfo^ participantInfo,
    DcnmSeatInfo^ seatInfo,
    DcnmSpeechTimerInfo^ speechTimerInfo
)

Parameters

speakerId
Type: SystemGuid
The speaker id.
microphoneState
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMicrophoneState
The microphone state of the speaker.
participantInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmParticipantInfo
The participant info of the speaker.
seatInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSeatInfo
The seat info of the speaker.
speechTimerInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpeechTimerInfo
Speech timer info of the speaker
See Also

Reference

DcnmSpeakerInfo Class
DcnmSpeakerInfo Overload


DcnmSpeakerInfo Properties

The DcnmSpeakerInfo type exposes the following members.

Properties
 | Name | Description
Public property | MicrophoneState | The microphone state of the speaker.
Public property | ParticipantInfo | The participant information of the speaker.
Public property | SeatInfo | The seat information of the speaker
Public property | SpeakerId | The speaker id.
Public property | SpeechTimerInfo | Speech timer information of the speaker
Top
See Also

Reference

DcnmSpeakerInfo Class


DcnmSpeakerInfo.MicrophoneState Property

DcnmSpeakerInfoMicrophoneState Property

The microphone state of the speaker.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmMicrophoneState MicrophoneState { get; }
Public ReadOnly Property MicrophoneState As DcnmMicrophoneState
    Get
public:
property DcnmMicrophoneState MicrophoneState {
    DcnmMicrophoneState get ();
}

Property Value

Type: DcnmMicrophoneState
See Also

Reference

DcnmSpeakerInfo Class


DcnmSpeakerInfo.ParticipantInfo Property

DcnmSpeakerInfoParticipantInfo Property

The participant information of the speaker.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmParticipantInfo ParticipantInfo { get; }
Public ReadOnly Property ParticipantInfo As DcnmParticipantInfo
    Get
public:
property DcnmParticipantInfo^ ParticipantInfo {
    DcnmParticipantInfo^ get ();
}

Property Value

Type: DcnmParticipantInfo
See Also

Reference

DcnmSpeakerInfo Class


DcnmSpeakerInfo.SeatInfo Property

DcnmSpeakerInfoSeatInfo Property

The seat information of the speaker

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSeatInfo SeatInfo { get; }
Public ReadOnly Property SeatInfo As DcnmSeatInfo
    Get
public:
property DcnmSeatInfo^ SeatInfo {
    DcnmSeatInfo^ get ();
}

Property Value

Type: DcnmSeatInfo
See Also

Reference

DcnmSpeakerInfo Class


DcnmSpeakerInfo.SpeakerId Property

DcnmSpeakerInfoSpeakerId Property

The speaker id.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid SpeakerId { get; }
Public ReadOnly Property SpeakerId As Guid
    Get
public:
property Guid SpeakerId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmSpeakerInfo Class


DcnmSpeakerInfo.SpeechTimerInfo Property

DcnmSpeakerInfoSpeechTimerInfo Property

Speech timer information of the speaker

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpeechTimerInfo SpeechTimerInfo { get; }
Public ReadOnly Property SpeechTimerInfo As DcnmSpeechTimerInfo
    Get
public:
property DcnmSpeechTimerInfo^ SpeechTimerInfo {
    DcnmSpeechTimerInfo^ get ();
}

Property Value

Type: DcnmSpeechTimerInfo
See Also

Reference

DcnmSpeakerInfo Class


DcnmSpeakerInfo Methods

The DcnmSpeakerInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmSpeakerInfo Class


DcnmSpeakerViewingOptions Class

The different speaker viewing options supported by the Dcnm system.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpeakerViewingOptions

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmSpeakerViewingOptions
Public Class DcnmSpeakerViewingOptions
public ref class DcnmSpeakerViewingOptions

The DcnmSpeakerViewingOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmSpeakerViewingOptions | Default constructor
Public method | DcnmSpeakerViewingOptions(Boolean, Boolean) | Constructor...
Public method | DcnmSpeakerViewingOptions(Boolean, Boolean, Boolean) | Constructor...
Public method | DcnmSpeakerViewingOptions(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Constructor...
Top
Properties
 | Name | Description
Public property | DisplayLogo | Indicates whether customer logo is displayed.
Public property | DisplayNewestSpeakerImage | Indicates whether the image of newest speaker is displayed.
Public property | DisplaySpeakerImage | Indicates whether the image of speaker is displayed.
Public property | DisplayVideoOnDevice | Indicates whether video is displayed on device
Public property | SpeakerViewingOn | Indicates whether Speaker Viewing is on.
Public property | SpeakerViewingOverride | Indicates whether default Speaker Viewing behaviour is overridden.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmSpeakerViewingOptions Constructor

Overload List
 | Name | Description
Public method | DcnmSpeakerViewingOptions | Default constructor
Public method | DcnmSpeakerViewingOptions(Boolean, Boolean) | Constructor...
Public method | DcnmSpeakerViewingOptions(Boolean, Boolean, Boolean) | Constructor...
Public method | DcnmSpeakerViewingOptions(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Constructor...
Top
See Also

Reference

DcnmSpeakerViewingOptions Class


DcnmSpeakerViewingOptions Constructor

Default constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpeakerViewingOptions()
Public Sub New
public:
DcnmSpeakerViewingOptions()
See Also

Reference

DcnmSpeakerViewingOptions Class
DcnmSpeakerViewingOptions Overload


DcnmSpeakerViewingOptions Constructor (Boolean, Boolean)

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpeakerViewingOptions(
    bool speakerViewingOn,
    bool speakerViewingOverride
)
Public Sub New (
    speakerViewingOn As Boolean,
    speakerViewingOverride As Boolean
)
public:
DcnmSpeakerViewingOptions(
    bool speakerViewingOn,
    bool speakerViewingOverride
)

Parameters

speakerViewingOn
Type: SystemBoolean
Indicates whether Speaker Viewing is on.
speakerViewingOverride
Type: SystemBoolean
Indicates whether default Speaker Viewing behaviour is overridden.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmSpeakerViewingOptions(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) instead.
See Also

Reference

DcnmSpeakerViewingOptions Class
DcnmSpeakerViewingOptions Overload


DcnmSpeakerViewingOptions Constructor (Boolean, Boolean, Boolean)

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpeakerViewingOptions(
    bool speakerViewingOn,
    bool speakerViewingOverride,
    bool displayVideoOnDevice
)
Public Sub New (
    speakerViewingOn As Boolean,
    speakerViewingOverride As Boolean,
    displayVideoOnDevice As Boolean
)
public:
DcnmSpeakerViewingOptions(
    bool speakerViewingOn,
    bool speakerViewingOverride,
    bool displayVideoOnDevice
)

Parameters

speakerViewingOn
Type: SystemBoolean
Indicates whether Speaker Viewing is on.
speakerViewingOverride
Type: SystemBoolean
Indicates whether default Speaker Viewing behaviour is overridden.
displayVideoOnDevice
Type: SystemBoolean
Indicates whether video is displayed on device.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmSpeakerViewingOptions(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) instead.
See Also

Reference

DcnmSpeakerViewingOptions Class
DcnmSpeakerViewingOptions Overload


DcnmSpeakerViewingOptions Constructor (Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpeakerViewingOptions(
    bool speakerViewingOn,
    bool speakerViewingOverride,
    bool displayVideoOnDevice,
    bool displayLogo,
    bool displayNewestSpeakerImage,
    bool displaySpeakerImage
)
Public Sub New (
    speakerViewingOn As Boolean,
    speakerViewingOverride As Boolean,
    displayVideoOnDevice As Boolean,
    displayLogo As Boolean,
    displayNewestSpeakerImage As Boolean,
    displaySpeakerImage As Boolean
)
public:
DcnmSpeakerViewingOptions(
    bool speakerViewingOn,
    bool speakerViewingOverride,
    bool displayVideoOnDevice,
    bool displayLogo,
    bool displayNewestSpeakerImage,
    bool displaySpeakerImage
)

Parameters

speakerViewingOn
Type: SystemBoolean
Indicates if speaker viewing is on.
speakerViewingOverride
Type: SystemBoolean
Indicates if speaker viewing override is active.
displayVideoOnDevice
Type: SystemBoolean
Indicates whether video is displayed on device
displayLogo
Type: SystemBoolean
Indicates whether customer logo is displayed.
displayNewestSpeakerImage
Type: SystemBoolean
Indicates whether the image of newest speaker is displayed.
displaySpeakerImage
Type: SystemBoolean
Indicates whether the image of speaker is displayed.
See Also

Reference

DcnmSpeakerViewingOptions Class
DcnmSpeakerViewingOptions Overload


DcnmSpeakerViewingOptions Properties

The DcnmSpeakerViewingOptions type exposes the following members.

Properties
 | Name | Description
Public property | DisplayLogo | Indicates whether customer logo is displayed.
Public property | DisplayNewestSpeakerImage | Indicates whether the image of newest speaker is displayed.
Public property | DisplaySpeakerImage | Indicates whether the image of speaker is displayed.
Public property | DisplayVideoOnDevice | Indicates whether video is displayed on device
Public property | SpeakerViewingOn | Indicates whether Speaker Viewing is on.
Public property | SpeakerViewingOverride | Indicates whether default Speaker Viewing behaviour is overridden.
Top
See Also

Reference

DcnmSpeakerViewingOptions Class


DcnmSpeakerViewingOptions.DisplayLogo Property

DcnmSpeakerViewingOptionsDisplayLogo Property

Indicates whether customer logo is displayed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool DisplayLogo { get; }
Public ReadOnly Property DisplayLogo As Boolean
    Get
public:
property bool DisplayLogo {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmSpeakerViewingOptions Class


DcnmSpeakerViewingOptions.DisplayNewestSpeakerImage Property

DcnmSpeakerViewingOptionsDisplayNewestSpeakerImage Property

Indicates whether the image of newest speaker is displayed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool DisplayNewestSpeakerImage { get; }
Public ReadOnly Property DisplayNewestSpeakerImage As Boolean
    Get
public:
property bool DisplayNewestSpeakerImage {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmSpeakerViewingOptions Class


DcnmSpeakerViewingOptions.DisplaySpeakerImage Property

DcnmSpeakerViewingOptionsDisplaySpeakerImage Property

Indicates whether the image of speaker is displayed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool DisplaySpeakerImage { get; }
Public ReadOnly Property DisplaySpeakerImage As Boolean
    Get
public:
property bool DisplaySpeakerImage {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmSpeakerViewingOptions Class


DcnmSpeakerViewingOptions.DisplayVideoOnDevice Property

DcnmSpeakerViewingOptionsDisplayVideoOnDevice Property

Indicates whether video is displayed on device

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool DisplayVideoOnDevice { get; }
Public ReadOnly Property DisplayVideoOnDevice As Boolean
    Get
public:
property bool DisplayVideoOnDevice {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmSpeakerViewingOptions Class


DcnmSpeakerViewingOptions.SpeakerViewingOn Property

DcnmSpeakerViewingOptionsSpeakerViewingOn Property

Indicates whether Speaker Viewing is on.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool SpeakerViewingOn { get; }
Public ReadOnly Property SpeakerViewingOn As Boolean
    Get
public:
property bool SpeakerViewingOn {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmSpeakerViewingOptions Class


DcnmSpeakerViewingOptions.SpeakerViewingOverride Property

DcnmSpeakerViewingOptionsSpeakerViewingOverride Property

Indicates whether default Speaker Viewing behaviour is overridden.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool SpeakerViewingOverride { get; }
Public ReadOnly Property SpeakerViewingOverride As Boolean
    Get
public:
property bool SpeakerViewingOverride {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmSpeakerViewingOptions Class


DcnmSpeakerViewingOptions Methods

The DcnmSpeakerViewingOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmSpeakerViewingOptions Class


DcnmSpecialOperationType Enumeration

Defines the available VIP types within the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmSpecialOperationType
Public Enumeration DcnmSpecialOperationType
public enum class DcnmSpecialOperationType
Members
Member name | Value | Description
None | 0 | No Vip, regular participant
ButtonOperated | 1 | VIP, Button operated
PttOperated | 2 | VIP, Push To Talk (PTT) operated
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmSpeechTimerInfo Class

Contains speech timer information
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpeechTimerInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmSpeechTimerInfo
Public Class DcnmSpeechTimerInfo
public ref class DcnmSpeechTimerInfo

The DcnmSpeechTimerInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmSpeechTimerInfo(Int32, Int32) | Obsolete. Constructor
Public method | DcnmSpeechTimerInfo(Int32, Int32, Int32) | Constructor
Top
Properties
 | Name | Description
Public property | RemainingSpeechDuration | Remaining speech time of the speaker in miliseconds.
Public property | SpeechStartTime | Start time of the speaker.This represents number of miliseconds since Dicentis server booted up, This can be used in sync time delay between server and clients.
Public property | TotalSpeechTime | The current total speech time
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmSpeechTimerInfo Constructor

Overload List
 | Name | Description
Public method | DcnmSpeechTimerInfo(Int32, Int32) | Obsolete. Constructor
Public method | DcnmSpeechTimerInfo(Int32, Int32, Int32) | Constructor
Top
See Also

Reference

DcnmSpeechTimerInfo Class


DcnmSpeechTimerInfo Constructor (Int32, Int32)

Note: This API is now obsolete.

Constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with TotalSpeechTime")]
public DcnmSpeechTimerInfo(
    int remainingSpeechDuration,
    int speechStartTime
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with TotalSpeechTime")>
Public Sub New (
    remainingSpeechDuration As Integer,
    speechStartTime As Integer
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with TotalSpeechTime")]
DcnmSpeechTimerInfo(
    int remainingSpeechDuration,
    int speechStartTime
)

Parameters

remainingSpeechDuration
Type: SystemInt32
Remaining speech Duration of the speech
speechStartTime
Type: SystemInt32
Start time of the speech
See Also

Reference

DcnmSpeechTimerInfo Class
DcnmSpeechTimerInfo Overload


DcnmSpeechTimerInfo Constructor (Int32, Int32, Int32)

Constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpeechTimerInfo(
    int remainingSpeechDuration,
    int speechStartTime,
    int totalSpeechTime
)
Public Sub New (
    remainingSpeechDuration As Integer,
    speechStartTime As Integer,
    totalSpeechTime As Integer
)
public:
DcnmSpeechTimerInfo(
    int remainingSpeechDuration,
    int speechStartTime,
    int totalSpeechTime
)

Parameters

remainingSpeechDuration
Type: SystemInt32
Remaining speech Duration of the speech
speechStartTime
Type: SystemInt32
Start time of the speech
totalSpeechTime
Type: SystemInt32
Total speech time>
See Also

Reference

DcnmSpeechTimerInfo Class
DcnmSpeechTimerInfo Overload


DcnmSpeechTimerInfo Properties

The DcnmSpeechTimerInfo type exposes the following members.

Properties
 | Name | Description
Public property | RemainingSpeechDuration | Remaining speech time of the speaker in miliseconds.
Public property | SpeechStartTime | Start time of the speaker.This represents number of miliseconds since Dicentis server booted up, This can be used in sync time delay between server and clients.
Public property | TotalSpeechTime | The current total speech time
Top
See Also

Reference

DcnmSpeechTimerInfo Class


DcnmSpeechTimerInfo.RemainingSpeechDuration Property

DcnmSpeechTimerInfoRemainingSpeechDuration Property

Remaining speech time of the speaker in miliseconds.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int RemainingSpeechDuration { get; }
Public ReadOnly Property RemainingSpeechDuration As Integer
    Get
public:
property int RemainingSpeechDuration {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmSpeechTimerInfo Class


DcnmSpeechTimerInfo.SpeechStartTime Property

DcnmSpeechTimerInfoSpeechStartTime Property

Start time of the speaker.This represents number of miliseconds since Dicentis server booted up, This can be used in sync time delay between server and clients.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int SpeechStartTime { get; }
Public ReadOnly Property SpeechStartTime As Integer
    Get
public:
property int SpeechStartTime {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmSpeechTimerInfo Class


DcnmSpeechTimerInfo.TotalSpeechTime Property

DcnmSpeechTimerInfoTotalSpeechTime Property

The current total speech time

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int TotalSpeechTime { get; }
Public ReadOnly Property TotalSpeechTime As Integer
    Get
public:
property int TotalSpeechTime {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmSpeechTimerInfo Class


DcnmSpeechTimerInfo Methods

The DcnmSpeechTimerInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmSpeechTimerInfo Class


DcnmSpeechTimerOptions Class

Message container for the speech timer options
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpeechTimerOptions

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmSpeechTimerOptions
Public Class DcnmSpeechTimerOptions
public ref class DcnmSpeechTimerOptions

The DcnmSpeechTimerOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmSpeechTimerOptions | Default constructor
Public method | DcnmSpeechTimerOptions(Boolean, Int32, Boolean, Boolean, Boolean, Int32, Boolean) | Speech timer options
Top
Properties
 | Name | Description
Public property | AdjustSpeechTime | Indicates whether adjust speech time is enabled
Public property | AdjustSpeechTimeDuration | Indicates the duration of adjust speech time
Public property | ShowLastSpeechMinute | Indicates whether the microphone button should blink during the last minute of the speech timer
Public property | ShowLastSpeechMinuteOnMicLed | Indicates whether the microphone led should blink during the last minute of the speech timer
Public property | SpeechTimer | Indicates whether speech timer option is enabled
Public property | SpeechTimerDuration | Indicates the duration for speech timer
Public property | TurnMicrophoneOffWhenTimerHasReached | Indicates whether the microphone should be turned off when timer has reached
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DEFAULT_ADJUST_SPEECH_TIME | Default value for adjust speech time
DEFAULT_ADJUST_SPEECH_TIME_DURATION | Default value for adjust speech time duration
DEFAULT_SHOW_LAST_SPEECH_MINUTE | Default value for blinking microphone button in the last minute
DEFAULT_SHOW_LAST_SPEECH_MINUTE_ON_MIC_LED | Default value for blinking microphone led in the last minute
DEFAULT_SPEECH_TIMER | Default value for speech timer
DEFAULT_SPEECH_TIMER_DURATION | Minimum value for speech timer duration
DEFAULT_TURN_MICROPHONE_OFF_WHEN_TIMER_REACHED | Default value for turning microphone off when timer has reached
MAXIMUM_ADJUST_SPEECH_TIMER_SECONDS | Maximum adjust speech timer value
MAXIMUM_NEGATIVE_SPEECH_TIME_LIMIT | The maximum nagative speech time value in seconds
MAXIMUM_SPEECH_TIME_LIMIT | The maximum speech time value in seconds
MAXIMUM_SPEECH_TIMER_SECONDS | Maximum speech timer value
MINIMUM_ADJUST_SPEECH_TIMER_SECONDS | Minimum adjust speech timer value
MINIMUM_SPEECH_TIME_LIMIT | The minimum speech time value in seconds
MINIMUM_SPEECH_TIMER_SECONDS | Minimum speech timer value
SECONDS_FOR_MILLISECONDS | Converting Seconds from milli seconds
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmSpeechTimerOptions Constructor

Overload List
 | Name | Description
Public method | DcnmSpeechTimerOptions | Default constructor
Public method | DcnmSpeechTimerOptions(Boolean, Int32, Boolean, Boolean, Boolean, Int32, Boolean) | Speech timer options
Top
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions Constructor

Default constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpeechTimerOptions()
Public Sub New
public:
DcnmSpeechTimerOptions()
See Also

Reference

DcnmSpeechTimerOptions Class
DcnmSpeechTimerOptions Overload


DcnmSpeechTimerOptions Constructor (Boolean, Int32, Boolean, Boolean, Boolean, Int32, Boolean)

Speech timer options

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpeechTimerOptions(
    bool speechTimer,
    int speechTimerDuration,
    bool showLastSpeechMinute,
    bool showLastSpeechMinuteOnMicLed,
    bool adjustSpeechTime,
    int adjustSpeechTimeDuration,
    bool turnMicrophoneOffWhenTimerHasReached
)
Public Sub New (
    speechTimer As Boolean,
    speechTimerDuration As Integer,
    showLastSpeechMinute As Boolean,
    showLastSpeechMinuteOnMicLed As Boolean,
    adjustSpeechTime As Boolean,
    adjustSpeechTimeDuration As Integer,
    turnMicrophoneOffWhenTimerHasReached As Boolean
)
public:
DcnmSpeechTimerOptions(
    bool speechTimer,
    int speechTimerDuration,
    bool showLastSpeechMinute,
    bool showLastSpeechMinuteOnMicLed,
    bool adjustSpeechTime,
    int adjustSpeechTimeDuration,
    bool turnMicrophoneOffWhenTimerHasReached
)

Parameters

speechTimer
Type: SystemBoolean
Speech timer option
speechTimerDuration
Type: SystemInt32
Duration of the speech time
showLastSpeechMinute
Type: SystemBoolean
Last minute blinking of microphone button if true
showLastSpeechMinuteOnMicLed
Type: SystemBoolean
Last minute blinking of microphone led if true
adjustSpeechTime
Type: SystemBoolean
Adjust speech time option
adjustSpeechTimeDuration
Type: SystemInt32
Duration of adjust speech time
turnMicrophoneOffWhenTimerHasReached
Type: SystemBoolean
Turns microphone off when timer has reached
See Also

Reference

DcnmSpeechTimerOptions Class
DcnmSpeechTimerOptions Overload


DcnmSpeechTimerOptions Properties

The DcnmSpeechTimerOptions type exposes the following members.

Properties
 | Name | Description
Public property | AdjustSpeechTime | Indicates whether adjust speech time is enabled
Public property | AdjustSpeechTimeDuration | Indicates the duration of adjust speech time
Public property | ShowLastSpeechMinute | Indicates whether the microphone button should blink during the last minute of the speech timer
Public property | ShowLastSpeechMinuteOnMicLed | Indicates whether the microphone led should blink during the last minute of the speech timer
Public property | SpeechTimer | Indicates whether speech timer option is enabled
Public property | SpeechTimerDuration | Indicates the duration for speech timer
Public property | TurnMicrophoneOffWhenTimerHasReached | Indicates whether the microphone should be turned off when timer has reached
Top
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.AdjustSpeechTime Property

DcnmSpeechTimerOptionsAdjustSpeechTime Property

Indicates whether adjust speech time is enabled

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AdjustSpeechTime { get; set; }
Public Property AdjustSpeechTime As Boolean
    Get
    Set
public:
property bool AdjustSpeechTime {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.AdjustSpeechTimeDuration Property

DcnmSpeechTimerOptionsAdjustSpeechTimeDuration Property

Indicates the duration of adjust speech time

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int AdjustSpeechTimeDuration { get; set; }
Public Property AdjustSpeechTimeDuration As Integer
    Get
    Set
public:
property int AdjustSpeechTimeDuration {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.ShowLastSpeechMinute Property

DcnmSpeechTimerOptionsShowLastSpeechMinute Property

Indicates whether the microphone button should blink during the last minute of the speech timer

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool ShowLastSpeechMinute { get; set; }
Public Property ShowLastSpeechMinute As Boolean
    Get
    Set
public:
property bool ShowLastSpeechMinute {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.ShowLastSpeechMinuteOnMicLed Property

DcnmSpeechTimerOptionsShowLastSpeechMinuteOnMicLed Property

Indicates whether the microphone led should blink during the last minute of the speech timer

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool ShowLastSpeechMinuteOnMicLed { get; set; }
Public Property ShowLastSpeechMinuteOnMicLed As Boolean
    Get
    Set
public:
property bool ShowLastSpeechMinuteOnMicLed {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.SpeechTimer Property

DcnmSpeechTimerOptionsSpeechTimer Property

Indicates whether speech timer option is enabled

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool SpeechTimer { get; set; }
Public Property SpeechTimer As Boolean
    Get
    Set
public:
property bool SpeechTimer {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.SpeechTimerDuration Property

DcnmSpeechTimerOptionsSpeechTimerDuration Property

Indicates the duration for speech timer

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int SpeechTimerDuration { get; set; }
Public Property SpeechTimerDuration As Integer
    Get
    Set
public:
property int SpeechTimerDuration {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.TurnMicrophoneOffWhenTimerHasReached Property

DcnmSpeechTimerOptionsTurnMicrophoneOffWhenTimerHasReached Property

Bosch Logo
Indicates whether the microphone should be turned off when timer has reached

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool TurnMicrophoneOffWhenTimerHasReached { get; set; }
Public Property TurnMicrophoneOffWhenTimerHasReached As Boolean
    Get
    Set
public:
property bool TurnMicrophoneOffWhenTimerHasReached {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions Methods

The DcnmSpeechTimerOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions Fields

The DcnmSpeechTimerOptions type exposes the following members.

Fields
Name | Description
DEFAULT_ADJUST_SPEECH_TIME | Default value for adjust speech time
DEFAULT_ADJUST_SPEECH_TIME_DURATION | Default value for adjust speech time duration
DEFAULT_SHOW_LAST_SPEECH_MINUTE | Default value for blinking microphone button in the last minute
DEFAULT_SHOW_LAST_SPEECH_MINUTE_ON_MIC_LED | Default value for blinking microphone led in the last minute
DEFAULT_SPEECH_TIMER | Default value for speech timer
DEFAULT_SPEECH_TIMER_DURATION | Minimum value for speech timer duration
DEFAULT_TURN_MICROPHONE_OFF_WHEN_TIMER_REACHED | Default value for turning microphone off when timer has reached
MAXIMUM_ADJUST_SPEECH_TIMER_SECONDS | Maximum adjust speech timer value
MAXIMUM_NEGATIVE_SPEECH_TIME_LIMIT | The maximum nagative speech time value in seconds
MAXIMUM_SPEECH_TIME_LIMIT | The maximum speech time value in seconds
MAXIMUM_SPEECH_TIMER_SECONDS | Maximum speech timer value
MINIMUM_ADJUST_SPEECH_TIMER_SECONDS | Minimum adjust speech timer value
MINIMUM_SPEECH_TIME_LIMIT | The minimum speech time value in seconds
MINIMUM_SPEECH_TIMER_SECONDS | Minimum speech timer value
SECONDS_FOR_MILLISECONDS | Converting Seconds from milli seconds
Top
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.DEFAULT_ADJUST_SPEECH_TIME Field

DcnmSpeechTimerOptionsDEFAULT_ADJUST_SPEECH_TIME Field

Default value for adjust speech time

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DEFAULT_ADJUST_SPEECH_TIME = false
Public Const DEFAULT_ADJUST_SPEECH_TIME As Boolean = False
public:
literal bool DEFAULT_ADJUST_SPEECH_TIME = false

Field Value

Type: Boolean
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.DEFAULT_ADJUST_SPEECH_TIME_DURATION Field

DcnmSpeechTimerOptionsDEFAULT_ADJUST_SPEECH_TIME_DURATION Field

 Bosch Logo
Default value for adjust speech time duration

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DEFAULT_ADJUST_SPEECH_TIME_DURATION = 60
Public Const DEFAULT_ADJUST_SPEECH_TIME_DURATION As Integer = 60
public:
literal int DEFAULT_ADJUST_SPEECH_TIME_DURATION = 60

Field Value

Type: Int32
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.DEFAULT_SHOW_LAST_SPEECH_MINUTE Field

DcnmSpeechTimerOptionsDEFAULT_SHOW_LAST_SPEECH_MINUTE Field

Default value for blinking microphone button in the last minute

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DEFAULT_SHOW_LAST_SPEECH_MINUTE = true
Public Const DEFAULT_SHOW_LAST_SPEECH_MINUTE As Boolean = True
public:
literal bool DEFAULT_SHOW_LAST_SPEECH_MINUTE = true

Field Value

Type: Boolean
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.DEFAULT_SHOW_LAST_SPEECH_MINUTE_ON_MIC_LED Field

DcnmSpeechTimerOptionsDEFAULT_SHOW_LAST_SPEECH_MINUTE_ON_MIC_LED Field

 Bosch Logo
Default value for blinking microphone led in the last minute

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DEFAULT_SHOW_LAST_SPEECH_MINUTE_ON_MIC_LED = true
Public Const DEFAULT_SHOW_LAST_SPEECH_MINUTE_ON_MIC_LED As Boolean = True
public:
literal bool DEFAULT_SHOW_LAST_SPEECH_MINUTE_ON_MIC_LED = true

Field Value

Type: Boolean
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.DEFAULT_SPEECH_TIMER Field

DcnmSpeechTimerOptionsDEFAULT_SPEECH_TIMER Field

Default value for speech timer

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DEFAULT_SPEECH_TIMER = false
Public Const DEFAULT_SPEECH_TIMER As Boolean = False
public:
literal bool DEFAULT_SPEECH_TIMER = false

Field Value

Type: Boolean
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.DEFAULT_SPEECH_TIMER_DURATION Field

DcnmSpeechTimerOptionsDEFAULT_SPEECH_TIMER_DURATION Field

Minimum value for speech timer duration

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DEFAULT_SPEECH_TIMER_DURATION = 180
Public Const DEFAULT_SPEECH_TIMER_DURATION As Integer = 180
public:
literal int DEFAULT_SPEECH_TIMER_DURATION = 180

Field Value

Type: Int32
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.DEFAULT_TURN_MICROPHONE_OFF_WHEN_TIMER_REACHED Field

DcnmSpeechTimerOptionsDEFAULT_TURN_MICROPHONE_OFF_WHEN_TIMER_REACHED Field

 Bosch Logo
Default value for turning microphone off when timer has reached

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DEFAULT_TURN_MICROPHONE_OFF_WHEN_TIMER_REACHED = false
Public Const DEFAULT_TURN_MICROPHONE_OFF_WHEN_TIMER_REACHED As Boolean = False
public:
literal bool DEFAULT_TURN_MICROPHONE_OFF_WHEN_TIMER_REACHED = false

Field Value

Type: Boolean
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.MAXIMUM_ADJUST_SPEECH_TIMER_SECONDS Field

DcnmSpeechTimerOptionsMAXIMUM_ADJUST_SPEECH_TIMER_SECONDS Field

 Bosch Logo
Maximum adjust speech timer value

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAXIMUM_ADJUST_SPEECH_TIMER_SECONDS = 600
Public Const MAXIMUM_ADJUST_SPEECH_TIMER_SECONDS As Integer = 600
public:
literal int MAXIMUM_ADJUST_SPEECH_TIMER_SECONDS = 600

Field Value

Type: Int32
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.MAXIMUM_NEGATIVE_SPEECH_TIME_LIMIT Field

DcnmSpeechTimerOptionsMAXIMUM_NEGATIVE_SPEECH_TIME_LIMIT Field

 Bosch Logo
The maximum nagative speech time value in seconds

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAXIMUM_NEGATIVE_SPEECH_TIME_LIMIT = -1800000
Public Const MAXIMUM_NEGATIVE_SPEECH_TIME_LIMIT As Integer = -1800000
public:
literal int MAXIMUM_NEGATIVE_SPEECH_TIME_LIMIT = -1800000

Field Value

Type: Int32
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.MAXIMUM_SPEECH_TIME_LIMIT Field

DcnmSpeechTimerOptionsMAXIMUM_SPEECH_TIME_LIMIT Field

The maximum speech time value in seconds

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAXIMUM_SPEECH_TIME_LIMIT = 5940000
Public Const MAXIMUM_SPEECH_TIME_LIMIT As Integer = 5940000
public:
literal int MAXIMUM_SPEECH_TIME_LIMIT = 5940000

Field Value

Type: Int32
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.MAXIMUM_SPEECH_TIMER_SECONDS Field

DcnmSpeechTimerOptionsMAXIMUM_SPEECH_TIMER_SECONDS Field

Maximum speech timer value

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAXIMUM_SPEECH_TIMER_SECONDS = 5940
Public Const MAXIMUM_SPEECH_TIMER_SECONDS As Integer = 5940
public:
literal int MAXIMUM_SPEECH_TIMER_SECONDS = 5940

Field Value

Type: Int32
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.MINIMUM_ADJUST_SPEECH_TIMER_SECONDS Field

DcnmSpeechTimerOptionsMINIMUM_ADJUST_SPEECH_TIMER_SECONDS Field

 Bosch Logo
Minimum adjust speech timer value

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MINIMUM_ADJUST_SPEECH_TIMER_SECONDS = 1
Public Const MINIMUM_ADJUST_SPEECH_TIMER_SECONDS As Integer = 1
public:
literal int MINIMUM_ADJUST_SPEECH_TIMER_SECONDS = 1

Field Value

Type: Int32
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.MINIMUM_SPEECH_TIME_LIMIT Field

DcnmSpeechTimerOptionsMINIMUM_SPEECH_TIME_LIMIT Field

The minimum speech time value in seconds

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MINIMUM_SPEECH_TIME_LIMIT = 1000
Public Const MINIMUM_SPEECH_TIME_LIMIT As Integer = 1000
public:
literal int MINIMUM_SPEECH_TIME_LIMIT = 1000

Field Value

Type: Int32
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.MINIMUM_SPEECH_TIMER_SECONDS Field

DcnmSpeechTimerOptionsMINIMUM_SPEECH_TIMER_SECONDS Field

Minimum speech timer value

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MINIMUM_SPEECH_TIMER_SECONDS = 1
Public Const MINIMUM_SPEECH_TIMER_SECONDS As Integer = 1
public:
literal int MINIMUM_SPEECH_TIMER_SECONDS = 1

Field Value

Type: Int32
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmSpeechTimerOptions.SECONDS_FOR_MILLISECONDS Field

DcnmSpeechTimerOptionsSECONDS_FOR_MILLISECONDS Field

Converting Seconds from milli seconds

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int SECONDS_FOR_MILLISECONDS = 1000
Public Const SECONDS_FOR_MILLISECONDS As Integer = 1000
public:
literal int SECONDS_FOR_MILLISECONDS = 1000

Field Value

Type: Int32
See Also

Reference

DcnmSpeechTimerOptions Class


DcnmStatusType Enumeration

This is for holding Majority and Quorum status

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmStatusType
Public Enumeration DcnmStatusType
public enum class DcnmStatusType
Members
Member name | Value | Description
True | 0 | It means quorum or majority is reached.
False | 1 | It means quorum or majority is not reached.
Error | 2 | It means some error in formula or in calculation.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmStoreVotingResultType Enumeration

Defines the available options to store voting results.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmStoreVotingResultType
Public Enumeration DcnmStoreVotingResultType
public enum class DcnmStoreVotingResultType
Members
Member name | Value | Description
IndividualsAndTotals | 0 |
OnlyTotals | 1 |
DoNotStoreResults | 2 |
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmSystemChannelMappingNumbers Class

DcnmSystemChannelMappingNumbers class statically defines the system channel numbers for the mapping.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSystemChannelMappingNumbers

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static class DcnmSystemChannelMappingNumbers
Public NotInheritable Class DcnmSystemChannelMappingNumbers
public ref class DcnmSystemChannelMappingNumbers abstract sealed

The DcnmSystemChannelMappingNumbers type exposes the following members.

Fields
Name | Description
END_OF_INPUT_CHANNELS | Ending number of the input channels
END_OF_OUTPUT_CHANNELS | Ending number of the output channels
EXTERNAL_INPUT_CHANNEL_1 | Channel number of the external input channel 1
EXTERNAL_INPUT_CHANNEL_2 | Channel number of the external input channel 2
EXTERNAL_OUTPUT_CHANNEL_1 | Channel number of the external output channel 1
EXTERNAL_OUTPUT_CHANNEL_2 | Channel number of the external output channel 2
OUTPUT_FLOOR | Channel number of the output floor
START_OF_INPUT_CHANNELS | Starting number of the input channels
START_OF_OUTPUT_CHANNELS | Starting number of the output channels
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmSystemChannelMappingNumbers Fields

The DcnmSystemChannelMappingNumbers type exposes the following members.

Fields
Name | Description
END_OF_INPUT_CHANNELS | Ending number of the input channels
END_OF_OUTPUT_CHANNELS | Ending number of the output channels
EXTERNAL_INPUT_CHANNEL_1 | Channel number of the external input channel 1
EXTERNAL_INPUT_CHANNEL_2 | Channel number of the external input channel 2
EXTERNAL_OUTPUT_CHANNEL_1 | Channel number of the external output channel 1
EXTERNAL_OUTPUT_CHANNEL_2 | Channel number of the external output channel 2
OUTPUT_FLOOR | Channel number of the output floor
START_OF_INPUT_CHANNELS | Starting number of the input channels
START_OF_OUTPUT_CHANNELS | Starting number of the output channels
Top
See Also

Reference

DcnmSystemChannelMappingNumbers Class


DcnmSystemChannelMappingNumbers.END_OF_INPUT_CHANNELS Field

DcnmSystemChannelMappingNumbersEND_OF_INPUT_CHANNELS Field

Ending number of the input channels

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int END_OF_INPUT_CHANNELS = 100
Public Const END_OF_INPUT_CHANNELS As Integer = 100
public:
literal int END_OF_INPUT_CHANNELS = 100

Field Value

Type: Int32
See Also

Reference

DcnmSystemChannelMappingNumbers Class


DcnmSystemChannelMappingNumbers.END_OF_OUTPUT_CHANNELS Field

DcnmSystemChannelMappingNumbersEND_OF_OUTPUT_CHANNELS Field

Ending number of the output channels

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int END_OF_OUTPUT_CHANNELS = 100
Public Const END_OF_OUTPUT_CHANNELS As Integer = 100
public:
literal int END_OF_OUTPUT_CHANNELS = 100

Field Value

Type: Int32
See Also

Reference

DcnmSystemChannelMappingNumbers Class


DcnmSystemChannelMappingNumbers.EXTERNAL_INPUT_CHANNEL_1 Field

DcnmSystemChannelMappingNumbersEXTERNAL_INPUT_CHANNEL_1 Field

 Bosch Logo
Channel number of the external input channel 1

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int EXTERNAL_INPUT_CHANNEL_1 = -1
Public Const EXTERNAL_INPUT_CHANNEL_1 As Integer = -1
public:
literal int EXTERNAL_INPUT_CHANNEL_1 = -1

Field Value

Type: Int32
See Also

Reference

DcnmSystemChannelMappingNumbers Class


DcnmSystemChannelMappingNumbers.EXTERNAL_INPUT_CHANNEL_2 Field

DcnmSystemChannelMappingNumbersEXTERNAL_INPUT_CHANNEL_2 Field

 Bosch Logo
Channel number of the external input channel 2

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int EXTERNAL_INPUT_CHANNEL_2 = -2
Public Const EXTERNAL_INPUT_CHANNEL_2 As Integer = -2
public:
literal int EXTERNAL_INPUT_CHANNEL_2 = -2

Field Value

Type: Int32
See Also

Reference

DcnmSystemChannelMappingNumbers Class


DcnmSystemChannelMappingNumbers.EXTERNAL_OUTPUT_CHANNEL_1 Field

DcnmSystemChannelMappingNumbersEXTERNAL_OUTPUT_CHANNEL_1 Field

 Bosch Logo
Channel number of the external output channel 1

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int EXTERNAL_OUTPUT_CHANNEL_1 = -3
Public Const EXTERNAL_OUTPUT_CHANNEL_1 As Integer = -3
public:
literal int EXTERNAL_OUTPUT_CHANNEL_1 = -3

Field Value

Type: Int32
See Also

Reference

DcnmSystemChannelMappingNumbers Class


DcnmSystemChannelMappingNumbers.EXTERNAL_OUTPUT_CHANNEL_2 Field

DcnmSystemChannelMappingNumbersEXTERNAL_OUTPUT_CHANNEL_2 Field

 Bosch Logo
Channel number of the external output channel 2

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int EXTERNAL_OUTPUT_CHANNEL_2 = -4
Public Const EXTERNAL_OUTPUT_CHANNEL_2 As Integer = -4
public:
literal int EXTERNAL_OUTPUT_CHANNEL_2 = -4

Field Value

Type: Int32
See Also

Reference

DcnmSystemChannelMappingNumbers Class


DcnmSystemChannelMappingNumbers.OUTPUT_FLOOR Field

DcnmSystemChannelMappingNumbersOUTPUT_FLOOR Field

Channel number of the output floor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int OUTPUT_FLOOR = 0
Public Const OUTPUT_FLOOR As Integer = 0
public:
literal int OUTPUT_FLOOR = 0

Field Value

Type: Int32
See Also

Reference

DcnmSystemChannelMappingNumbers Class


DcnmSystemChannelMappingNumbers.START_OF_INPUT_CHANNELS Field

DcnmSystemChannelMappingNumbersSTART_OF_INPUT_CHANNELS Field

Starting number of the input channels

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int START_OF_INPUT_CHANNELS = 1
Public Const START_OF_INPUT_CHANNELS As Integer = 1
public:
literal int START_OF_INPUT_CHANNELS = 1

Field Value

Type: Int32
See Also

Reference

DcnmSystemChannelMappingNumbers Class


DcnmSystemChannelMappingNumbers.START_OF_OUTPUT_CHANNELS Field

DcnmSystemChannelMappingNumbersSTART_OF_OUTPUT_CHANNELS Field

 Bosch Logo
Starting number of the output channels

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int START_OF_OUTPUT_CHANNELS = 1
Public Const START_OF_OUTPUT_CHANNELS As Integer = 1
public:
literal int START_OF_OUTPUT_CHANNELS = 1

Field Value

Type: Int32
See Also

Reference

DcnmSystemChannelMappingNumbers Class


DcnmTemplatePreparationInfo Class

Message container for the template preparation info.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmTemplatePreparationInfo
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDiscussionPreparationInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmTemplatePreparationInfo
Public Class DcnmTemplatePreparationInfo
public ref class DcnmTemplatePreparationInfo

The DcnmTemplatePreparationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmTemplatePreparationInfo(Guid, String, DcnmDiscussionOptions, DcnmMicrophoneOptions, DcnmRequestToSpeakOptions, DcnmRequestToResponseOptions, DcnmPriorityOptions, DcnmSpeakerViewingOptions) | Initializes a new instance of the DcnmTemplatePreparationInfo class.
Public method | DcnmTemplatePreparationInfo(Guid, String, DcnmDiscussionOptions, DcnmMicrophoneOptions, DcnmRequestToSpeakOptions, DcnmRequestToResponseOptions, DcnmPriorityOptions, DcnmSpeakerViewingOptions, DcnmSpeechTimerOptions) | Initializes a new instance of the DcnmTemplatePreparationInfo class.
Top
Properties
 | Name | Description
Public property | DiscussionOptions | the discussion control mode
Public property | MicrophoneOptions | The microphone options.
Public property | Name | The name of the discussion template.
Public property | PriorityOptions | The priority options.
Public property | RequestOptions | The request options.
Public property | ResponseOptions | The response options.
Public property | SpeakerViewingOptions | The speaker viewing options
Public property | SpeechTimerOptions | The speech timer options
Public property | TemplateId | The template identifier
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmTemplatePreparationInfo Constructor

Overload List
 | Name | Description
Public method | DcnmTemplatePreparationInfo(Guid, String, DcnmDiscussionOptions, DcnmMicrophoneOptions, DcnmRequestToSpeakOptions, DcnmRequestToResponseOptions, DcnmPriorityOptions, DcnmSpeakerViewingOptions) | Initializes a new instance of the DcnmTemplatePreparationInfo class.
Public method | DcnmTemplatePreparationInfo(Guid, String, DcnmDiscussionOptions, DcnmMicrophoneOptions, DcnmRequestToSpeakOptions, DcnmRequestToResponseOptions, DcnmPriorityOptions, DcnmSpeakerViewingOptions, DcnmSpeechTimerOptions) | Initializes a new instance of the DcnmTemplatePreparationInfo class.
Top
See Also

Reference

DcnmTemplatePreparationInfo Class


DcnmTemplatePreparationInfo Constructor (Guid, String, DcnmDiscussionOptions, DcnmMicrophoneOptions, DcnmRequestToSpeakOptions, DcnmRequestToResponseOptions, DcnmPriorityOptions, DcnmSpeakerViewingOptions)

Initializes a new instance of the DcnmTemplatePreparationInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmTemplatePreparationInfo(
    Guid templateId,
    string name,
    DcnmDiscussionOptions discussionOptions,
    DcnmMicrophoneOptions microphoneOptions,
    DcnmRequestToSpeakOptions requestOptions,
    DcnmRequestToResponseOptions responseOptions,
    DcnmPriorityOptions priorityOptions,
    DcnmSpeakerViewingOptions speakerViewingOptions
)
Public Sub New (
    templateId As Guid,
    name As String,
    discussionOptions As DcnmDiscussionOptions,
    microphoneOptions As DcnmMicrophoneOptions,
    requestOptions As DcnmRequestToSpeakOptions,
    responseOptions As DcnmRequestToResponseOptions,
    priorityOptions As DcnmPriorityOptions,
    speakerViewingOptions As DcnmSpeakerViewingOptions
)
public:
DcnmTemplatePreparationInfo(
    Guid templateId,
    String^ name,
    DcnmDiscussionOptions^ discussionOptions,
    DcnmMicrophoneOptions^ microphoneOptions,
    DcnmRequestToSpeakOptions^ requestOptions,
    DcnmRequestToResponseOptions^ responseOptions,
    DcnmPriorityOptions^ priorityOptions,
    DcnmSpeakerViewingOptions^ speakerViewingOptions
)

Parameters

templateId
Type: SystemGuid
The template id.
name
Type: SystemString
The name.
discussionOptions
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDiscussionOptions
The discussion options.
microphoneOptions
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMicrophoneOptions
The microphone options.
requestOptions
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmRequestToSpeakOptions
The request options.
responseOptions
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmRequestToResponseOptions
The response options.
priorityOptions
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPriorityOptions
The priority options.
speakerViewingOptions
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpeakerViewingOptions
The speaker viewing options.
See Also

Reference

DcnmTemplatePreparationInfo Class
DcnmTemplatePreparationInfo Overload


DcnmTemplatePreparationInfo Constructor (Guid, String, DcnmDiscussionOptions, DcnmMicrophoneOptions, DcnmRequestToSpeakOptions, DcnmRequestToResponseOptions, DcnmPriorityOptions, DcnmSpeakerViewingOptions, DcnmSpeechTimerOptions)

Initializes a new instance of the DcnmTemplatePreparationInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmTemplatePreparationInfo(
    Guid templateId,
    string name,
    DcnmDiscussionOptions discussionOptions,
    DcnmMicrophoneOptions microphoneOptions,
    DcnmRequestToSpeakOptions requestOptions,
    DcnmRequestToResponseOptions responseOptions,
    DcnmPriorityOptions priorityOptions,
    DcnmSpeakerViewingOptions speakerViewingOptions,
    DcnmSpeechTimerOptions speechTimerOptions
)
Public Sub New (
    templateId As Guid,
    name As String,
    discussionOptions As DcnmDiscussionOptions,
    microphoneOptions As DcnmMicrophoneOptions,
    requestOptions As DcnmRequestToSpeakOptions,
    responseOptions As DcnmRequestToResponseOptions,
    priorityOptions As DcnmPriorityOptions,
    speakerViewingOptions As DcnmSpeakerViewingOptions,
    speechTimerOptions As DcnmSpeechTimerOptions
)
public:
DcnmTemplatePreparationInfo(
    Guid templateId,
    String^ name,
    DcnmDiscussionOptions^ discussionOptions,
    DcnmMicrophoneOptions^ microphoneOptions,
    DcnmRequestToSpeakOptions^ requestOptions,
    DcnmRequestToResponseOptions^ responseOptions,
    DcnmPriorityOptions^ priorityOptions,
    DcnmSpeakerViewingOptions^ speakerViewingOptions,
    DcnmSpeechTimerOptions^ speechTimerOptions
)

Parameters

templateId
Type: SystemGuid
The template id.
name
Type: SystemString
The name.
discussionOptions
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDiscussionOptions
The discussion options.
microphoneOptions
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMicrophoneOptions
The microphone options.
requestOptions
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmRequestToSpeakOptions
The request options.
responseOptions
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmRequestToResponseOptions
The response options.
priorityOptions
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPriorityOptions
The priority options.
speakerViewingOptions
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpeakerViewingOptions
The speaker viewing options.
speechTimerOptions
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpeechTimerOptions
The speech timer options.
See Also

Reference

DcnmTemplatePreparationInfo Class
DcnmTemplatePreparationInfo Overload


DcnmTemplatePreparationInfo Properties

The DcnmTemplatePreparationInfo type exposes the following members.

Properties
 | Name | Description
Public property | DiscussionOptions | the discussion control mode
Public property | MicrophoneOptions | The microphone options.
Public property | Name | The name of the discussion template.
Public property | PriorityOptions | The priority options.
Public property | RequestOptions | The request options.
Public property | ResponseOptions | The response options.
Public property | SpeakerViewingOptions | The speaker viewing options
Public property | SpeechTimerOptions | The speech timer options
Public property | TemplateId | The template identifier
Top
See Also

Reference

DcnmTemplatePreparationInfo Class


DcnmTemplatePreparationInfo.DiscussionOptions Property

DcnmTemplatePreparationInfoDiscussionOptions Property

the discussion control mode

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDiscussionOptions DiscussionOptions { get; }
Public ReadOnly Property DiscussionOptions As DcnmDiscussionOptions
    Get
public:
property DcnmDiscussionOptions^ DiscussionOptions {
    DcnmDiscussionOptions^ get ();
}

Property Value

Type: DcnmDiscussionOptions
See Also

Reference

DcnmTemplatePreparationInfo Class


DcnmTemplatePreparationInfo.MicrophoneOptions Property

DcnmTemplatePreparationInfoMicrophoneOptions Property

The microphone options.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmMicrophoneOptions MicrophoneOptions { get; }
Public ReadOnly Property MicrophoneOptions As DcnmMicrophoneOptions
    Get
public:
property DcnmMicrophoneOptions^ MicrophoneOptions {
    DcnmMicrophoneOptions^ get ();
}

Property Value

Type: DcnmMicrophoneOptions
See Also

Reference

DcnmTemplatePreparationInfo Class


DcnmTemplatePreparationInfo.Name Property

DcnmTemplatePreparationInfoName Property

The name of the discussion template.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmTemplatePreparationInfo Class


DcnmTemplatePreparationInfo.PriorityOptions Property

DcnmTemplatePreparationInfoPriorityOptions Property

The priority options.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmPriorityOptions PriorityOptions { get; }
Public ReadOnly Property PriorityOptions As DcnmPriorityOptions
    Get
public:
property DcnmPriorityOptions^ PriorityOptions {
    DcnmPriorityOptions^ get ();
}

Property Value

Type: DcnmPriorityOptions
See Also

Reference

DcnmTemplatePreparationInfo Class


DcnmTemplatePreparationInfo.RequestOptions Property

DcnmTemplatePreparationInfoRequestOptions Property

The request options.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmRequestToSpeakOptions RequestOptions { get; }
Public ReadOnly Property RequestOptions As DcnmRequestToSpeakOptions
    Get
public:
property DcnmRequestToSpeakOptions^ RequestOptions {
    DcnmRequestToSpeakOptions^ get ();
}

Property Value

Type: DcnmRequestToSpeakOptions
See Also

Reference

DcnmTemplatePreparationInfo Class


DcnmTemplatePreparationInfo.ResponseOptions Property

DcnmTemplatePreparationInfoResponseOptions Property

The response options.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmRequestToResponseOptions ResponseOptions { get; }
Public ReadOnly Property ResponseOptions As DcnmRequestToResponseOptions
    Get
public:
property DcnmRequestToResponseOptions^ ResponseOptions {
    DcnmRequestToResponseOptions^ get ();
}

Property Value

Type: DcnmRequestToResponseOptions
See Also

Reference

DcnmTemplatePreparationInfo Class


DcnmTemplatePreparationInfo.SpeakerViewingOptions Property

DcnmTemplatePreparationInfoSpeakerViewingOptions Property

The speaker viewing options

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpeakerViewingOptions SpeakerViewingOptions { get; }
Public ReadOnly Property SpeakerViewingOptions As DcnmSpeakerViewingOptions
    Get
public:
property DcnmSpeakerViewingOptions^ SpeakerViewingOptions {
    DcnmSpeakerViewingOptions^ get ();
}

Property Value

Type: DcnmSpeakerViewingOptions
See Also

Reference

DcnmTemplatePreparationInfo Class


DcnmTemplatePreparationInfo.SpeechTimerOptions Property

DcnmTemplatePreparationInfoSpeechTimerOptions Property

The speech timer options

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmSpeechTimerOptions SpeechTimerOptions { get; }
Public ReadOnly Property SpeechTimerOptions As DcnmSpeechTimerOptions
    Get
public:
property DcnmSpeechTimerOptions^ SpeechTimerOptions {
    DcnmSpeechTimerOptions^ get ();
}

Property Value

Type: DcnmSpeechTimerOptions
See Also

Reference

DcnmTemplatePreparationInfo Class


DcnmTemplatePreparationInfo.TemplateId Property

DcnmTemplatePreparationInfoTemplateId Property

The template identifier

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid TemplateId { get; }
Public ReadOnly Property TemplateId As Guid
    Get
public:
property Guid TemplateId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmTemplatePreparationInfo Class


DcnmTemplatePreparationInfo Methods

The DcnmTemplatePreparationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmTemplatePreparationInfo Class


DcnmUserAccountPreparationInfo Class

Defines a container for the user account info.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmUserAccountPreparationInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmUserAccountPreparationInfo
Public Class DcnmUserAccountPreparationInfo
public ref class DcnmUserAccountPreparationInfo

The DcnmUserAccountPreparationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmUserAccountPreparationInfo(String, String) | Constructor..
Public method | DcnmUserAccountPreparationInfo(DcnmUserPreparationInfo, String, String) | Constructor..
Public method | DcnmUserAccountPreparationInfo(Guid, String, String, String) | Constructor..
Public method | DcnmUserAccountPreparationInfo(DcnmUserPreparationInfo, String, String, String) | Constructor..
Top
Properties
 | Name | Description
Public property | Password | The password of the user.
Public property | PinCode | The pin code of the user.
Public property | User | The user information.
Public property | UserId | The user identifier.
Public property | UserName | The username of the user.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmUserAccountPreparationInfo Constructor

Overload List
 | Name | Description
Public method | DcnmUserAccountPreparationInfo(String, String) | Constructor..
Public method | DcnmUserAccountPreparationInfo(DcnmUserPreparationInfo, String, String) | Constructor..
Public method | DcnmUserAccountPreparationInfo(Guid, String, String, String) | Constructor..
Public method | DcnmUserAccountPreparationInfo(DcnmUserPreparationInfo, String, String, String) | Constructor..
Top
See Also

Reference

DcnmUserAccountPreparationInfo Class


DcnmUserAccountPreparationInfo Constructor (String, String)

Constructor..

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmUserAccountPreparationInfo(
    string userName,
    string password
)
Public Sub New (
    userName As String,
    password As String
)
public:
DcnmUserAccountPreparationInfo(
    String^ userName,
    String^ password
)

Parameters

userName
Type: SystemString
The username of the user.
password
Type: SystemString
The password of the user.
See Also

Reference

DcnmUserAccountPreparationInfo Class
DcnmUserAccountPreparationInfo Overload


DcnmUserAccountPreparationInfo Constructor (DcnmUserPreparationInfo, String, String)

Constructor..

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmUserAccountPreparationInfo(
    DcnmUserPreparationInfo user,
    string userName,
    string password
)
Public Sub New (
    user As DcnmUserPreparationInfo,
    userName As String,
    password As String
)
public:
DcnmUserAccountPreparationInfo(
    DcnmUserPreparationInfo^ user,
    String^ userName,
    String^ password
)

Parameters

user
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmUserPreparationInfo
The user details derived from DcnmUserPreparationInfo.
userName
Type: SystemString
The username of the user.
password
Type: SystemString
The password of the user.
See Also

Reference

DcnmUserAccountPreparationInfo Class
DcnmUserAccountPreparationInfo Overload


DcnmUserAccountPreparationInfo Constructor (Guid, String, String, String)

Constructor..

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmUserAccountPreparationInfo(
    Guid userId,
    string userName,
    string password,
    string pinCode
)
Public Sub New (
    userId As Guid,
    userName As String,
    password As String,
    pinCode As String
)
public:
DcnmUserAccountPreparationInfo(
    Guid userId,
    String^ userName,
    String^ password,
    String^ pinCode
)

Parameters

userId
Type: SystemGuid
The user identifier.
userName
Type: SystemString
The username of the user.
password
Type: SystemString
The password of the user.
pinCode
Type: SystemString
The pin code of the user.
See Also

Reference

DcnmUserAccountPreparationInfo Class
DcnmUserAccountPreparationInfo Overload


DcnmUserAccountPreparationInfo Constructor (DcnmUserPreparationInfo, String, String, String)

Constructor..

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmUserAccountPreparationInfo(
    DcnmUserPreparationInfo user,
    string userName,
    string password,
    string pinCode
)
Public Sub New (
    user As DcnmUserPreparationInfo,
    userName As String,
    password As String,
    pinCode As String
)
public:
DcnmUserAccountPreparationInfo(
    DcnmUserPreparationInfo^ user,
    String^ userName,
    String^ password,
    String^ pinCode
)

Parameters

user
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmUserPreparationInfo
The user details derived from DcnmUserPreparationInfo.
userName
Type: SystemString
The username of the user.
password
Type: SystemString
The password of the user.
pinCode
Type: SystemString
The pin code of the user.
See Also

Reference

DcnmUserAccountPreparationInfo Class
DcnmUserAccountPreparationInfo Overload


DcnmUserAccountPreparationInfo Properties

The DcnmUserAccountPreparationInfo type exposes the following members.

Properties
 | Name | Description
Public property | Password | The password of the user.
Public property | PinCode | The pin code of the user.
Public property | User | The user information.
Public property | UserId | The user identifier.
Public property | UserName | The username of the user.
Top
See Also

Reference

DcnmUserAccountPreparationInfo Class


DcnmUserAccountPreparationInfo.Password Property

DcnmUserAccountPreparationInfoPassword Property

The password of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Password { get; }
Public ReadOnly Property Password As String
    Get
public:
property String^ Password {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserAccountPreparationInfo Class


DcnmUserAccountPreparationInfo.PinCode Property

DcnmUserAccountPreparationInfoPinCode Property

The pin code of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string PinCode { get; set; }
Public Property PinCode As String
    Get
    Set
public:
property String^ PinCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DcnmUserAccountPreparationInfo Class


DcnmUserAccountPreparationInfo.User Property

DcnmUserAccountPreparationInfoUser Property

The user information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmUserPreparationInfo User { get; }
Public ReadOnly Property User As DcnmUserPreparationInfo
    Get
public:
property DcnmUserPreparationInfo^ User {
    DcnmUserPreparationInfo^ get ();
}

Property Value

Type: DcnmUserPreparationInfo
See Also

Reference

DcnmUserAccountPreparationInfo Class


DcnmUserAccountPreparationInfo.UserId Property

DcnmUserAccountPreparationInfoUserId Property

The user identifier.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid UserId { get; }
Public ReadOnly Property UserId As Guid
    Get
public:
property Guid UserId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmUserAccountPreparationInfo Class


DcnmUserAccountPreparationInfo.UserName Property

DcnmUserAccountPreparationInfoUserName Property

The username of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string UserName { get; }
Public ReadOnly Property UserName As String
    Get
public:
property String^ UserName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserAccountPreparationInfo Class


DcnmUserAccountPreparationInfo Methods

The DcnmUserAccountPreparationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmUserAccountPreparationInfo Class


DcnmUserDefinedDeviceInstance Class

User defined device instance.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmUserDefinedDeviceInstance

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmUserDefinedDeviceInstance
Public Class DcnmUserDefinedDeviceInstance
public ref class DcnmUserDefinedDeviceInstance

The DcnmUserDefinedDeviceInstance type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmUserDefinedDeviceInstance(Guid, Guid, String) | Initialise a user defined device instance.
Public method | DcnmUserDefinedDeviceInstance(Guid, Guid, Guid, String) | Initialise a user defined device instance.
Top
Properties
 | Name | Description
Public property | AreaControllerId | The Id of the area controller that is responsible for controller the area where the device is installed.
Public property | DeviceId | Unique Id of the device instance.
Public property | DeviceParameters | Instance specific parameters.
Public property | TypeId | Unique Id that maps to a set of device capabilities.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmUserDefinedDeviceInstance Constructor

Overload List
 | Name | Description
Public method | DcnmUserDefinedDeviceInstance(Guid, Guid, String) | Initialise a user defined device instance.
Public method | DcnmUserDefinedDeviceInstance(Guid, Guid, Guid, String) | Initialise a user defined device instance.
Top
See Also

Reference

DcnmUserDefinedDeviceInstance Class


DcnmUserDefinedDeviceInstance Constructor (Guid, Guid, String)

Initialise a user defined device instance.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmUserDefinedDeviceInstance(
    Guid areaControllerId,
    Guid typeId,
    string deviceParameters
)
Public Sub New (
    areaControllerId As Guid,
    typeId As Guid,
    deviceParameters As String
)
public:
DcnmUserDefinedDeviceInstance(
    Guid areaControllerId,
    Guid typeId,
    String^ deviceParameters
)

Parameters

areaControllerId
Type: SystemGuid
Id of the area controller that is responsible for controlling the area where the device is installed.
typeId
Type: SystemGuid
Unique Id that maps to a set of device capabilities.
deviceParameters
Type: SystemString
Instance specific parameters.
See Also

Reference

DcnmUserDefinedDeviceInstance Class
DcnmUserDefinedDeviceInstance Overload


DcnmUserDefinedDeviceInstance Constructor (Guid, Guid, Guid, String)

Initialise a user defined device instance.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmUserDefinedDeviceInstance(
    Guid deviceId,
    Guid areaControllerId,
    Guid typeId,
    string deviceParameters
)
Public Sub New (
    deviceId As Guid,
    areaControllerId As Guid,
    typeId As Guid,
    deviceParameters As String
)
public:
DcnmUserDefinedDeviceInstance(
    Guid deviceId,
    Guid areaControllerId,
    Guid typeId,
    String^ deviceParameters
)

Parameters

deviceId
Type: SystemGuid
Unique Id of the device instance.
areaControllerId
Type: SystemGuid
Id of the area controller that is responsible for controlling the area where the device is installed.
typeId
Type: SystemGuid
Unique Id that maps to a set of device capabilities.
deviceParameters
Type: SystemString
Instance specific parameters.
See Also

Reference

DcnmUserDefinedDeviceInstance Class
DcnmUserDefinedDeviceInstance Overload


DcnmUserDefinedDeviceInstance Properties

The DcnmUserDefinedDeviceInstance type exposes the following members.

Properties
 | Name | Description
Public property | AreaControllerId | The Id of the area controller that is responsible for controller the area where the device is installed.
Public property | DeviceId | Unique Id of the device instance.
Public property | DeviceParameters | Instance specific parameters.
Public property | TypeId | Unique Id that maps to a set of device capabilities.
Top
See Also

Reference

DcnmUserDefinedDeviceInstance Class


DcnmUserDefinedDeviceInstance.AreaControllerId Property

DcnmUserDefinedDeviceInstanceAreaControllerId Property

The Id of the area controller that is responsible for controller the area where the device is installed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid AreaControllerId { get; }
Public ReadOnly Property AreaControllerId As Guid
    Get
public:
property Guid AreaControllerId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmUserDefinedDeviceInstance Class


DcnmUserDefinedDeviceInstance.DeviceId Property

DcnmUserDefinedDeviceInstanceDeviceId Property

Unique Id of the device instance.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid DeviceId { get; }
Public ReadOnly Property DeviceId As Guid
    Get
public:
property Guid DeviceId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmUserDefinedDeviceInstance Class


DcnmUserDefinedDeviceInstance.DeviceParameters Property

DcnmUserDefinedDeviceInstanceDeviceParameters Property

Instance specific parameters.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string DeviceParameters { get; }
Public ReadOnly Property DeviceParameters As String
    Get
public:
property String^ DeviceParameters {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserDefinedDeviceInstance Class


DcnmUserDefinedDeviceInstance.TypeId Property

DcnmUserDefinedDeviceInstanceTypeId Property

Unique Id that maps to a set of device capabilities.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid TypeId { get; }
Public ReadOnly Property TypeId As Guid
    Get
public:
property Guid TypeId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmUserDefinedDeviceInstance Class


DcnmUserDefinedDeviceInstance Methods

The DcnmUserDefinedDeviceInstance type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmUserDefinedDeviceInstance Class


DcnmUserInfo Class

Represents the account of a user logged on, including his personal information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmUserInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmUserInfo
Public Class DcnmUserInfo
public ref class DcnmUserInfo

The DcnmUserInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmUserInfo | Constructor...
Top
Properties
 | Name | Description
Public property | FirstName | The first name of the user.
Public property | LastName | The last name of the user.
Public property | MiddleName | The middle name of the user.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmUserInfo Constructor

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmUserInfo(
    string firstName,
    string middleName,
    string lastName
)
Public Sub New (
    firstName As String,
    middleName As String,
    lastName As String
)
public:
DcnmUserInfo(
    String^ firstName,
    String^ middleName,
    String^ lastName
)

Parameters

firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
See Also

Reference

DcnmUserInfo Class


DcnmUserInfo Properties

The DcnmUserInfo type exposes the following members.

Properties
 | Name | Description
Public property | FirstName | The first name of the user.
Public property | LastName | The last name of the user.
Public property | MiddleName | The middle name of the user.
Top
See Also

Reference

DcnmUserInfo Class


DcnmUserInfo.FirstName Property

DcnmUserInfoFirstName Property

The first name of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string FirstName { get; }
Public ReadOnly Property FirstName As String
    Get
public:
property String^ FirstName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserInfo Class


DcnmUserInfo.LastName Property

DcnmUserInfoLastName Property

The last name of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string LastName { get; }
Public ReadOnly Property LastName As String
    Get
public:
property String^ LastName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserInfo Class


DcnmUserInfo.MiddleName Property

DcnmUserInfoMiddleName Property

The middle name of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string MiddleName { get; }
Public ReadOnly Property MiddleName As String
    Get
public:
property String^ MiddleName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserInfo Class


DcnmUserInfo Methods

The DcnmUserInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmUserInfo Class


DcnmUserPreparationInfo Class

Defines the container for Dcnm user information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmUserPreparationInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmUserPreparationInfo
Public Class DcnmUserPreparationInfo
public ref class DcnmUserPreparationInfo

The DcnmUserPreparationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmUserPreparationInfo(String, String, String, String, String, String, Guid) | Obsolete. Deprecated Constructor...
Public method | DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid) | Obsolete. Deprecated Constructor...
Public method | DcnmUserPreparationInfo(String, String, String, String, String, String, Guid, String) | Obsolete. Deprecated Constructor...
Public method | DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String) | Obsolete. Deprecated Constructor...
Public method | DcnmUserPreparationInfo(String, String, String, String, String, String, Guid, String, String) | Obsolete. Deprecated Constructor...
Public method | DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String, String) | Obsolete. Deprecated Constructor...
Public method | DcnmUserPreparationInfo(String, String, String, String, String, String, Guid, String, String, Int32) | Obsolete. Deprecated Constructor...
Public method | DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String, String, Int32) | Obsolete. Deprecated Constructor...
Public method | DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String, String, Int32, String, Guid) | Obsolete. Deprecated constructor...
Public method | DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String, String, Int32, String, Guid, String, Boolean) | Constructor...
Top
Properties
 | Name | Description
Public property | AudibleBeeps | The setting for persons in order to listen to beeps while voting.
Public property | Country | The country of the user.
Public property | Email | The user's email
Public property | FirstName | The first name of the user.
Public property | Group | The group of the user
Public property | HeadphoneLanguageId | The preferred headphone language of person. If the value is empty or language not part of meeting then floor language will be the headphone language.
Public property | LastName | The last name of the user.
Public property | MiddleName | The middle name of the user.
Public property | NFCId | The NFC of the user
Public property | PictureUpdatedNumber | The picture updated number
Public property | Region | The region of the user.
Public property | Title | The title of the user.
Public property | UiLanguage | The preferred ui language of person on device. If value is null or empty then room’s language will be the ui language.
Public property | UserGroupId | The identifier of the group to which the user belongs to.
Public property | UserId | The identifier of the user.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmUserPreparationInfo Constructor

Overload List
 | Name | Description
Public method | DcnmUserPreparationInfo(String, String, String, String, String, String, Guid) | Obsolete. Deprecated Constructor...
Public method | DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid) | Obsolete. Deprecated Constructor...
Public method | DcnmUserPreparationInfo(String, String, String, String, String, String, Guid, String) | Obsolete. Deprecated Constructor...
Public method | DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String) | Obsolete. Deprecated Constructor...
Public method | DcnmUserPreparationInfo(String, String, String, String, String, String, Guid, String, String) | Obsolete. Deprecated Constructor...
Public method | DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String, String) | Obsolete. Deprecated Constructor...
Public method | DcnmUserPreparationInfo(String, String, String, String, String, String, Guid, String, String, Int32) | Obsolete. Deprecated Constructor...
Public method | DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String, String, Int32) | Obsolete. Deprecated Constructor...
Public method | DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String, String, Int32, String, Guid) | Obsolete. Deprecated constructor...
Public method | DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String, String, Int32, String, Guid, String, Boolean) | Constructor...
Top
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo Constructor (String, String, String, String, String, String, Guid)

Note: This API is now obsolete.

Deprecated Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")]
public DcnmUserPreparationInfo(
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    Guid userGroupId
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")>
Public Sub New (
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    userGroupId As Guid
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection instead.")]
DcnmUserPreparationInfo(
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    Guid userGroupId
)

Parameters

firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
userGroupId
Type: SystemGuid
The identifier of the group the user is assigned to.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String, String, Int32) instead.
See Also

Reference

DcnmUserPreparationInfo Class
DcnmUserPreparationInfo Overload


DcnmUserPreparationInfo Constructor (Guid, String, String, String, String, String, String, Guid)

Note: This API is now obsolete.

Deprecated Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")]
public DcnmUserPreparationInfo(
    Guid userId,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    Guid userGroupId
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")>
Public Sub New (
    userId As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    userGroupId As Guid
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection instead.")]
DcnmUserPreparationInfo(
    Guid userId,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    Guid userGroupId
)

Parameters

userId
Type: SystemGuid
The identifier of the user.
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
userGroupId
Type: SystemGuid
The identifier of the group the user is assigned to.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String, String, Int32) instead.
See Also

Reference

DcnmUserPreparationInfo Class
DcnmUserPreparationInfo Overload


DcnmUserPreparationInfo Constructor (String, String, String, String, String, String, Guid, String)

Note: This API is now obsolete.

Deprecated Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")]
public DcnmUserPreparationInfo(
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    Guid userGroupId,
    string group
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")>
Public Sub New (
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    userGroupId As Guid,
    group As String
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection instead.")]
DcnmUserPreparationInfo(
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    Guid userGroupId,
    String^ group
)

Parameters

firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
userGroupId
Type: SystemGuid
The identifier of the group the user is assigned to.
group
Type: SystemString
The group of the user.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String, String, Int32) instead.
See Also

Reference

DcnmUserPreparationInfo Class
DcnmUserPreparationInfo Overload


DcnmUserPreparationInfo Constructor (Guid, String, String, String, String, String, String, Guid, String)

Note: This API is now obsolete.

Deprecated Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")]
public DcnmUserPreparationInfo(
    Guid userId,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    Guid userGroupId,
    string group
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")>
Public Sub New (
    userId As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    userGroupId As Guid,
    group As String
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection instead.")]
DcnmUserPreparationInfo(
    Guid userId,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    Guid userGroupId,
    String^ group
)

Parameters

userId
Type: SystemGuid
The identifier of the user.
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
userGroupId
Type: SystemGuid
The identifier of the group the user is assigned to.
group
Type: SystemString
The group of the user.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String, String, Int32) instead.
See Also

Reference

DcnmUserPreparationInfo Class
DcnmUserPreparationInfo Overload


DcnmUserPreparationInfo Constructor (String, String, String, String, String, String, Guid, String, String)

Note: This API is now obsolete.

Deprecated Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")]
public DcnmUserPreparationInfo(
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    Guid userGroupId,
    string group,
    string nfcId
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")>
Public Sub New (
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    userGroupId As Guid,
    group As String,
    nfcId As String
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection instead.")]
DcnmUserPreparationInfo(
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    Guid userGroupId,
    String^ group,
    String^ nfcId
)

Parameters

firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
userGroupId
Type: SystemGuid
The identifier of the group the user is assigned to.
group
Type: SystemString
The group of the user.
nfcId
Type: SystemString
The NFC of the user.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String, String, Int32) instead.
See Also

Reference

DcnmUserPreparationInfo Class
DcnmUserPreparationInfo Overload


DcnmUserPreparationInfo Constructor (Guid, String, String, String, String, String, String, Guid, String, String)

Note: This API is now obsolete.

Deprecated Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")]
public DcnmUserPreparationInfo(
    Guid userId,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    Guid userGroupId,
    string group,
    string nfcId
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")>
Public Sub New (
    userId As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    userGroupId As Guid,
    group As String,
    nfcId As String
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection instead.")]
DcnmUserPreparationInfo(
    Guid userId,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    Guid userGroupId,
    String^ group,
    String^ nfcId
)

Parameters

userId
Type: SystemGuid
The identifier of the user.
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
userGroupId
Type: SystemGuid
The identifier of the group the user is assigned to.
group
Type: SystemString
The group of the user.
nfcId
Type: SystemString
The NFC of the user.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String, String, Int32) instead.
See Also

Reference

DcnmUserPreparationInfo Class
DcnmUserPreparationInfo Overload


DcnmUserPreparationInfo Constructor (String, String, String, String, String, String, Guid, String, String, Int32)

Note: This API is now obsolete.

Deprecated Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")]
public DcnmUserPreparationInfo(
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    Guid userGroupId,
    string group,
    string nfcId,
    int pictureUpdatedNumber
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")>
Public Sub New (
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    userGroupId As Guid,
    group As String,
    nfcId As String,
    pictureUpdatedNumber As Integer
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection instead.")]
DcnmUserPreparationInfo(
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    Guid userGroupId,
    String^ group,
    String^ nfcId,
    int pictureUpdatedNumber
)

Parameters

firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
userGroupId
Type: SystemGuid
The identifier of the group the user is assigned to.
group
Type: SystemString
The group of the user
nfcId
Type: SystemString
The NFC ID of the user
pictureUpdatedNumber
Type: SystemInt32
The picture updated number of the person.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String, String, Int32) instead.
See Also

Reference

DcnmUserPreparationInfo Class
DcnmUserPreparationInfo Overload


DcnmUserPreparationInfo Constructor (Guid, String, String, String, String, String, String, Guid, String, String, Int32)

Note: This API is now obsolete.

Deprecated Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")]
public DcnmUserPreparationInfo(
    Guid userId,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    Guid userGroupId,
    string group,
    string nfcId,
    int pictureUpdatedNumber
)
<ObsoleteAttribute("This method is obsolete, please use the constructor with Attributes collection instead.")>
Public Sub New (
    userId As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    userGroupId As Guid,
    group As String,
    nfcId As String,
    pictureUpdatedNumber As Integer
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the constructor with Attributes collection instead.")]
DcnmUserPreparationInfo(
    Guid userId,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    Guid userGroupId,
    String^ group,
    String^ nfcId,
    int pictureUpdatedNumber
)

Parameters

userId
Type: SystemGuid
The identifier of the user.
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
userGroupId
Type: SystemGuid
The identifier of the group the user is assigned to.
group
Type: SystemString
The group of the user.
nfcId
Type: SystemString
The NFC of the user.
pictureUpdatedNumber
Type: SystemInt32
The picture updated number of the person.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmUserPreparationInfo(Guid, String, String, String, String, String, String, Guid, String, String, Int32, String, Guid) instead.
See Also

Reference

DcnmUserPreparationInfo Class
DcnmUserPreparationInfo Overload


DcnmUserPreparationInfo Constructor (Guid, String, String, String, String, String, String, Guid, String, String, Int32, String, Guid)

Note: This API is now obsolete.

Deprecated constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, please use the non - obsolete constructor.")]
public DcnmUserPreparationInfo(
    Guid userId,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    Guid userGroupId,
    string group,
    string nfcId,
    int pictureUpdatedNumber,
    string uiLanguage,
    Guid headphoneLanguageId
)
<ObsoleteAttribute("This method is obsolete, please use the non - obsolete constructor.")>
Public Sub New (
    userId As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    userGroupId As Guid,
    group As String,
    nfcId As String,
    pictureUpdatedNumber As Integer,
    uiLanguage As String,
    headphoneLanguageId As Guid
)
public:
[ObsoleteAttribute(L"This method is obsolete, please use the non - obsolete constructor.")]
DcnmUserPreparationInfo(
    Guid userId,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    Guid userGroupId,
    String^ group,
    String^ nfcId,
    int pictureUpdatedNumber,
    String^ uiLanguage,
    Guid headphoneLanguageId
)

Parameters

userId
Type: SystemGuid
The identifier of the user.
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
userGroupId
Type: SystemGuid
The identifier of the group the user is assigned to.
group
Type: SystemString
The group of the user.
nfcId
Type: SystemString
The NFC of the user.
pictureUpdatedNumber
Type: SystemInt32
The picture updated number of the person.
uiLanguage
Type: SystemString
The preferred ui language of person on device. If value is null or empty then room’s language will be the ui language.
headphoneLanguageId
Type: SystemGuid
The preferred headphone language of person. If the value is empty or language not part of meeting then floor language will be the headphone language.
See Also

Reference

DcnmUserPreparationInfo Class
DcnmUserPreparationInfo Overload


DcnmUserPreparationInfo Constructor (Guid, String, String, String, String, String, String, Guid, String, String, Int32, String, Guid, String, Boolean)

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmUserPreparationInfo(
    Guid userId,
    string firstName,
    string middleName,
    string lastName,
    string title,
    string country,
    string region,
    Guid userGroupId,
    string group,
    string nfcId,
    int pictureUpdatedNumber,
    string uiLanguage,
    Guid headphoneLanguageId,
    string email,
    bool audibleBeeps
)
Public Sub New (
    userId As Guid,
    firstName As String,
    middleName As String,
    lastName As String,
    title As String,
    country As String,
    region As String,
    userGroupId As Guid,
    group As String,
    nfcId As String,
    pictureUpdatedNumber As Integer,
    uiLanguage As String,
    headphoneLanguageId As Guid,
    email As String,
    audibleBeeps As Boolean
)
public:
DcnmUserPreparationInfo(
    Guid userId,
    String^ firstName,
    String^ middleName,
    String^ lastName,
    String^ title,
    String^ country,
    String^ region,
    Guid userGroupId,
    String^ group,
    String^ nfcId,
    int pictureUpdatedNumber,
    String^ uiLanguage,
    Guid headphoneLanguageId,
    String^ email,
    bool audibleBeeps
)

Parameters

userId
Type: SystemGuid
The identifier of the user.
firstName
Type: SystemString
The first name of the user.
middleName
Type: SystemString
The middle name of the user.
lastName
Type: SystemString
The last name of the user.
title
Type: SystemString
The title of the user.
country
Type: SystemString
The country where the user comes from.
region
Type: SystemString
The region of the country
userGroupId
Type: SystemGuid
The identifier of the group the user is assigned to.
group
Type: SystemString
The group of the user.
nfcId
Type: SystemString
The NFC of the user.
pictureUpdatedNumber
Type: SystemInt32
The picture updated number of the person.
uiLanguage
Type: SystemString
The preferred ui language of person on device. If value is null or empty then room’s language will be the ui language.
headphoneLanguageId
Type: SystemGuid
The preferred headphone language of person. If the value is empty or language not part of meeting then floor language will be the headphone language.
email
Type: SystemString
The user's email
audibleBeeps
Type: SystemBoolean
The user setting to enable audible beeps.
See Also

Reference

DcnmUserPreparationInfo Class
DcnmUserPreparationInfo Overload


DcnmUserPreparationInfo Properties

The DcnmUserPreparationInfo type exposes the following members.

Properties
 | Name | Description
Public property | AudibleBeeps | The setting for persons in order to listen to beeps while voting.
Public property | Country | The country of the user.
Public property | Email | The user's email
Public property | FirstName | The first name of the user.
Public property | Group | The group of the user
Public property | HeadphoneLanguageId | The preferred headphone language of person. If the value is empty or language not part of meeting then floor language will be the headphone language.
Public property | LastName | The last name of the user.
Public property | MiddleName | The middle name of the user.
Public property | NFCId | The NFC of the user
Public property | PictureUpdatedNumber | The picture updated number
Public property | Region | The region of the user.
Public property | Title | The title of the user.
Public property | UiLanguage | The preferred ui language of person on device. If value is null or empty then room’s language will be the ui language.
Public property | UserGroupId | The identifier of the group to which the user belongs to.
Public property | UserId | The identifier of the user.
Top
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo.AudibleBeeps Property

DcnmUserPreparationInfoAudibleBeeps Property

The setting for persons in order to listen to beeps while voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AudibleBeeps { get; }
Public ReadOnly Property AudibleBeeps As Boolean
    Get
public:
property bool AudibleBeeps {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo.Country Property

DcnmUserPreparationInfoCountry Property

The country of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Country { get; }
Public ReadOnly Property Country As String
    Get
public:
property String^ Country {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo.Email Property

DcnmUserPreparationInfoEmail Property

The user's email

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Email { get; }
Public ReadOnly Property Email As String
    Get
public:
property String^ Email {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo.FirstName Property

DcnmUserPreparationInfoFirstName Property

The first name of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string FirstName { get; }
Public ReadOnly Property FirstName As String
    Get
public:
property String^ FirstName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo.Group Property

DcnmUserPreparationInfoGroup Property

The group of the user

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Group { get; }
Public ReadOnly Property Group As String
    Get
public:
property String^ Group {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo.HeadphoneLanguageId Property

DcnmUserPreparationInfoHeadphoneLanguageId Property

The preferred headphone language of person. If the value is empty or language not part of meeting then floor language will be the headphone language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid HeadphoneLanguageId { get; }
Public ReadOnly Property HeadphoneLanguageId As Guid
    Get
public:
property Guid HeadphoneLanguageId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo.LastName Property

DcnmUserPreparationInfoLastName Property

The last name of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string LastName { get; }
Public ReadOnly Property LastName As String
    Get
public:
property String^ LastName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo.MiddleName Property

DcnmUserPreparationInfoMiddleName Property

The middle name of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string MiddleName { get; }
Public ReadOnly Property MiddleName As String
    Get
public:
property String^ MiddleName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo.NFCId Property

DcnmUserPreparationInfoNFCId Property

The NFC of the user

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string NFCId { get; }
Public ReadOnly Property NFCId As String
    Get
public:
property String^ NFCId {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo.PictureUpdatedNumber Property

DcnmUserPreparationInfoPictureUpdatedNumber Property

The picture updated number

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int PictureUpdatedNumber { get; }
Public ReadOnly Property PictureUpdatedNumber As Integer
    Get
public:
property int PictureUpdatedNumber {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo.Region Property

DcnmUserPreparationInfoRegion Property

The region of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Region { get; }
Public ReadOnly Property Region As String
    Get
public:
property String^ Region {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo.Title Property

DcnmUserPreparationInfoTitle Property

The title of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo.UiLanguage Property

DcnmUserPreparationInfoUiLanguage Property

The preferred ui language of person on device. If value is null or empty then room’s language will be the ui language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string UiLanguage { get; }
Public ReadOnly Property UiLanguage As String
    Get
public:
property String^ UiLanguage {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo.UserGroupId Property

DcnmUserPreparationInfoUserGroupId Property

The identifier of the group to which the user belongs to.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid UserGroupId { get; }
Public ReadOnly Property UserGroupId As Guid
    Get
public:
property Guid UserGroupId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo.UserId Property

DcnmUserPreparationInfoUserId Property

The identifier of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid UserId { get; }
Public ReadOnly Property UserId As Guid
    Get
public:
property Guid UserId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserPreparationInfo Methods

The DcnmUserPreparationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmUserPreparationInfo Class


DcnmUserSecurityClaimsInfo Class

Contains user security claims.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmUserSecurityClaimsInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmUserSecurityClaimsInfo
Public Class DcnmUserSecurityClaimsInfo
public ref class DcnmUserSecurityClaimsInfo

The DcnmUserSecurityClaimsInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmUserSecurityClaimsInfo | Constructor...
Public method | DcnmUserSecurityClaimsInfo(Guid, String, String, String, String, String, String, IListDcnmConferenceSecurityClaim) | Initializes a new instance of the DcnmUserSecurityClaimsInfo class.
Top
Properties
 | Name | Description
Public property | ConferenceSecurityClaims | A collection of claims if the user.
Public property | Country | The country the user is from.
Public property | Region | The regsion the user is from.
Public property | Title | The title of the user.
Public property | UserFirstName | The first name of the user.
Public property | UserId | The identification of the user.
Public property | UserLastName | The last name of the user.
Public property | UserMiddleName | The middle name of the user.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmUserSecurityClaimsInfo Constructor

Overload List
 | Name | Description
Public method | DcnmUserSecurityClaimsInfo | Constructor...
Public method | DcnmUserSecurityClaimsInfo(Guid, String, String, String, String, String, String, IListDcnmConferenceSecurityClaim) | Initializes a new instance of the DcnmUserSecurityClaimsInfo class.
Top
See Also

Reference

DcnmUserSecurityClaimsInfo Class


DcnmUserSecurityClaimsInfo Constructor

Constructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmUserSecurityClaimsInfo()
Public Sub New
public:
DcnmUserSecurityClaimsInfo()
See Also

Reference

DcnmUserSecurityClaimsInfo Class
DcnmUserSecurityClaimsInfo Overload


DcnmUserSecurityClaimsInfo Constructor (Guid, String, String, String, String, String, String, IList(DcnmConferenceSecurityClaim))

DcnmUserSecurityClaimsInfo Constructor (Guid, String, String, String, String, String, String, IListDcnmConferenceSecurityClaim)

 Bosch Logo
Initializes a new instance of the DcnmUserSecurityClaimsInfo class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmUserSecurityClaimsInfo(
    Guid userId,
    string title,
    string userFirstName,
    string userMiddleName,
    string userLastName,
    string country,
    string region,
    IList<DcnmConferenceSecurityClaim> conferenceSecurityClaims
)
Public Sub New (
    userId As Guid,
    title As String,
    userFirstName As String,
    userMiddleName As String,
    userLastName As String,
    country As String,
    region As String,
    conferenceSecurityClaims As IList(Of DcnmConferenceSecurityClaim)
)
public:
DcnmUserSecurityClaimsInfo(
    Guid userId,
    String^ title,
    String^ userFirstName,
    String^ userMiddleName,
    String^ userLastName,
    String^ country,
    String^ region,
    IList<DcnmConferenceSecurityClaim>^ conferenceSecurityClaims
)

Parameters

userId
Type: SystemGuid
The user id.
title
Type: SystemString
The title of the user.
userFirstName
Type: SystemString
First name of the user.
userMiddleName
Type: SystemString
Name of the user middle.
userLastName
Type: SystemString
Last name of the user.
country
Type: SystemString
The country the user is from.
region
Type: SystemString
The region the user is from.
conferenceSecurityClaims
Type: System.Collections.GenericIList DcnmConferenceSecurityClaim
The conference security claims.
See Also

Reference

DcnmUserSecurityClaimsInfo Class
DcnmUserSecurityClaimsInfo Overload


DcnmUserSecurityClaimsInfo Properties

The DcnmUserSecurityClaimsInfo type exposes the following members.

Properties
 | Name | Description
Public property | ConferenceSecurityClaims | A collection of claims if the user.
Public property | Country | The country the user is from.
Public property | Region | The regsion the user is from.
Public property | Title | The title of the user.
Public property | UserFirstName | The first name of the user.
Public property | UserId | The identification of the user.
Public property | UserLastName | The last name of the user.
Public property | UserMiddleName | The middle name of the user.
Top
See Also

Reference

DcnmUserSecurityClaimsInfo Class


DcnmUserSecurityClaimsInfo.ConferenceSecurityClaims Property

DcnmUserSecurityClaimsInfoConferenceSecurityClaims Property

A collection of claims if the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<DcnmConferenceSecurityClaim> ConferenceSecurityClaims { get; }
Public ReadOnly Property ConferenceSecurityClaims As IList(Of DcnmConferenceSecurityClaim)
    Get
public:
property IList<DcnmConferenceSecurityClaim>^ ConferenceSecurityClaims {
    IList<DcnmConferenceSecurityClaim>^ get ();
}

Property Value

Type: IList DcnmConferenceSecurityClaim
See Also

Reference

DcnmUserSecurityClaimsInfo Class


DcnmUserSecurityClaimsInfo.Country Property

DcnmUserSecurityClaimsInfoCountry Property

The country the user is from.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Country { get; }
Public ReadOnly Property Country As String
    Get
public:
property String^ Country {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserSecurityClaimsInfo Class


DcnmUserSecurityClaimsInfo.Region Property

DcnmUserSecurityClaimsInfoRegion Property

The regsion the user is from.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Region { get; }
Public ReadOnly Property Region As String
    Get
public:
property String^ Region {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserSecurityClaimsInfo Class


DcnmUserSecurityClaimsInfo.Title Property

DcnmUserSecurityClaimsInfoTitle Property

The title of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserSecurityClaimsInfo Class


DcnmUserSecurityClaimsInfo.UserFirstName Property

DcnmUserSecurityClaimsInfoUserFirstName Property

The first name of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string UserFirstName { get; }
Public ReadOnly Property UserFirstName As String
    Get
public:
property String^ UserFirstName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserSecurityClaimsInfo Class


DcnmUserSecurityClaimsInfo.UserId Property

DcnmUserSecurityClaimsInfoUserId Property

The identification of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid UserId { get; }
Public ReadOnly Property UserId As Guid
    Get
public:
property Guid UserId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmUserSecurityClaimsInfo Class


DcnmUserSecurityClaimsInfo.UserLastName Property

DcnmUserSecurityClaimsInfoUserLastName Property

The last name of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string UserLastName { get; }
Public ReadOnly Property UserLastName As String
    Get
public:
property String^ UserLastName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserSecurityClaimsInfo Class


DcnmUserSecurityClaimsInfo.UserMiddleName Property

DcnmUserSecurityClaimsInfoUserMiddleName Property

The middle name of the user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string UserMiddleName { get; }
Public ReadOnly Property UserMiddleName As String
    Get
public:
property String^ UserMiddleName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmUserSecurityClaimsInfo Class


DcnmUserSecurityClaimsInfo Methods

The DcnmUserSecurityClaimsInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmUserSecurityClaimsInfo Class


DcnmVerificationMethod Enumeration

The method how the person should prove his identity.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmVerificationMethod
Public Enumeration DcnmVerificationMethod
public enum class DcnmVerificationMethod
Members
Member name | Value | Description
None | 0 | No verification required.
Confirmation | 1 | Verification by confirmation.
Password | 2 | Verification by password.
PINCode | 3 | Verification by PIN-code.
ExternalSystem | 4 | Verification by external system.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmVoiceModeOptions Class

Message container for speaker in voice mode options.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVoiceModeOptions

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmVoiceModeOptions
Public Class DcnmVoiceModeOptions
public ref class DcnmVoiceModeOptions

The DcnmVoiceModeOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmVoiceModeOptions | Default Constructor
Public method | DcnmVoiceModeOptions(Boolean, Boolean, Int32, Int32) | VoiceModeOptions
Top
Properties
 | Name | Description
Public property | AttackTime | The minimal number of ms of presence of audio, before a participant/seat is displayed in the speakerslist
Public property | ReleaseTime | The number of ms of absence of audio, before a participant/seat is removed from the speakerslist
Public property | ShowMicLedInVoiceMode | Flag to indicate whether MIC LED will be on for speaker in voice mode
Public property | ShowSpeakerInVoiceMode | Flag to indicate whether speaker list will pe populated in voice mode
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmVoiceModeOptions Constructor

Overload List
 | Name | Description
Public method | DcnmVoiceModeOptions | Default Constructor
Public method | DcnmVoiceModeOptions(Boolean, Boolean, Int32, Int32) | VoiceModeOptions
Top
See Also

Reference

DcnmVoiceModeOptions Class


DcnmVoiceModeOptions Constructor

Default Constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVoiceModeOptions()
Public Sub New
public:
DcnmVoiceModeOptions()
See Also

Reference

DcnmVoiceModeOptions Class
DcnmVoiceModeOptions Overload


DcnmVoiceModeOptions Constructor (Boolean, Boolean, Int32, Int32)

VoiceModeOptions

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVoiceModeOptions(
    bool showSpeakerInVoiceMode,
    bool showMicLedInVoiceMode,
    int attackTime,
    int releaseTime
)
Public Sub New (
    showSpeakerInVoiceMode As Boolean,
    showMicLedInVoiceMode As Boolean,
    attackTime As Integer,
    releaseTime As Integer
)
public:
DcnmVoiceModeOptions(
    bool showSpeakerInVoiceMode,
    bool showMicLedInVoiceMode,
    int attackTime,
    int releaseTime
)

Parameters

showSpeakerInVoiceMode
Type: SystemBoolean
if set to true [speaker list will be populated in voice mode.]
showMicLedInVoiceMode
Type: SystemBoolean
if set to true [MIC LED of speaker will be ON in voice mode.]
attackTime
Type: SystemInt32
The minimal number of ms of presence of audio, before a participant/seat is displayed in the speakerslist
releaseTime
Type: SystemInt32
The number of ms of absence of audio, before a participant/seat is removed from the speakerslist
See Also

Reference

DcnmVoiceModeOptions Class
DcnmVoiceModeOptions Overload


DcnmVoiceModeOptions Properties

The DcnmVoiceModeOptions type exposes the following members.

Properties
 | Name | Description
Public property | AttackTime | The minimal number of ms of presence of audio, before a participant/seat is displayed in the speakerslist
Public property | ReleaseTime | The number of ms of absence of audio, before a participant/seat is removed from the speakerslist
Public property | ShowMicLedInVoiceMode | Flag to indicate whether MIC LED will be on for speaker in voice mode
Public property | ShowSpeakerInVoiceMode | Flag to indicate whether speaker list will pe populated in voice mode
Top
See Also

Reference

DcnmVoiceModeOptions Class


DcnmVoiceModeOptions.AttackTime Property

DcnmVoiceModeOptionsAttackTime Property

The minimal number of ms of presence of audio, before a participant/seat is displayed in the speakerslist

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int AttackTime { get; }
Public ReadOnly Property AttackTime As Integer
    Get
public:
property int AttackTime {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmVoiceModeOptions Class


DcnmVoiceModeOptions.ReleaseTime Property

DcnmVoiceModeOptionsReleaseTime Property

The number of ms of absence of audio, before a participant/seat is removed from the speakerslist

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int ReleaseTime { get; }
Public ReadOnly Property ReleaseTime As Integer
    Get
public:
property int ReleaseTime {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmVoiceModeOptions Class


DcnmVoiceModeOptions.ShowMicLedInVoiceMode Property

DcnmVoiceModeOptionsShowMicLedInVoiceMode Property

Flag to indicate whether MIC LED will be on for speaker in voice mode

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool ShowMicLedInVoiceMode { get; }
Public ReadOnly Property ShowMicLedInVoiceMode As Boolean
    Get
public:
property bool ShowMicLedInVoiceMode {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmVoiceModeOptions Class


DcnmVoiceModeOptions.ShowSpeakerInVoiceMode Property

DcnmVoiceModeOptionsShowSpeakerInVoiceMode Property

Flag to indicate whether speaker list will pe populated in voice mode

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool ShowSpeakerInVoiceMode { get; }
Public ReadOnly Property ShowSpeakerInVoiceMode As Boolean
    Get
public:
property bool ShowSpeakerInVoiceMode {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmVoiceModeOptions Class


DcnmVoiceModeOptions Methods

The DcnmVoiceModeOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmVoiceModeOptions Class


DcnmVoteMajorityInfo Class

Holds voting majority information.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVoteMajorityInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmVoteMajorityInfo
Public Class DcnmVoteMajorityInfo
public ref class DcnmVoteMajorityInfo

The DcnmVoteMajorityInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmVoteMajorityInfo | Class holds voting majority information.
Top
Properties
 | Name | Description
Public property | IsEnabled | Flag indicates whether majority is enabled for voting.
Public property | MajorityCondition | Majority condition operator DcnmComparisonOperators.
Public property | MajorityDenominatorExpression | Hundred percent settings for majority. Can get variables from MajorityVariables
Public property | MajorityNumeratorExpression | In favor for majority. Can get variables from MajorityVariables
Public property | MajorityThresholdExpression | Majority threshold to decide whether voting can be approved or not.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmVoteMajorityInfo Constructor

Class holds voting majority information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVoteMajorityInfo(
    bool isEnabled,
    string majorityNumeratorExpression,
    string majorityDenominatorExpression,
    string majorityThresholdExpression,
    DcnmComparisonOperators majorityCondition
)
Public Sub New (
    isEnabled As Boolean,
    majorityNumeratorExpression As String,
    majorityDenominatorExpression As String,
    majorityThresholdExpression As String,
    majorityCondition As DcnmComparisonOperators
)
public:
DcnmVoteMajorityInfo(
    bool isEnabled,
    String^ majorityNumeratorExpression,
    String^ majorityDenominatorExpression,
    String^ majorityThresholdExpression,
    DcnmComparisonOperators majorityCondition
)

Parameters

isEnabled
Type: SystemBoolean
Flag indicates whether majority is enabled for voting.
majorityNumeratorExpression
Type: SystemString
In favor for majority. Can get variables from MajorityVariables.
majorityDenominatorExpression
Type: SystemString
Hundred percent setting for majority. Can get variables from MajorityVariables
majorityThresholdExpression
Type: SystemString
Majority threshold to decide whether voting can be approved or not.
majorityCondition
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmComparisonOperators
Majority condition operator DcnmComparisonOperators.
See Also

Reference

DcnmVoteMajorityInfo Class


DcnmVoteMajorityInfo Properties

The DcnmVoteMajorityInfo type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled | Flag indicates whether majority is enabled for voting.
Public property | MajorityCondition | Majority condition operator DcnmComparisonOperators.
Public property | MajorityDenominatorExpression | Hundred percent settings for majority. Can get variables from MajorityVariables
Public property | MajorityNumeratorExpression | In favor for majority. Can get variables from MajorityVariables
Public property | MajorityThresholdExpression | Majority threshold to decide whether voting can be approved or not.
Top
See Also

Reference

DcnmVoteMajorityInfo Class


DcnmVoteMajorityInfo.IsEnabled Property

DcnmVoteMajorityInfoIsEnabled Property

Flag indicates whether majority is enabled for voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool IsEnabled { get; }
Public ReadOnly Property IsEnabled As Boolean
    Get
public:
property bool IsEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmVoteMajorityInfo Class


DcnmVoteMajorityInfo.MajorityCondition Property

DcnmVoteMajorityInfoMajorityCondition Property

Majority condition operator DcnmComparisonOperators.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmComparisonOperators MajorityCondition { get; }
Public ReadOnly Property MajorityCondition As DcnmComparisonOperators
    Get
public:
property DcnmComparisonOperators MajorityCondition {
    DcnmComparisonOperators get ();
}

Property Value

Type: DcnmComparisonOperators
See Also

Reference

DcnmVoteMajorityInfo Class


DcnmVoteMajorityInfo.MajorityDenominatorExpression Property

DcnmVoteMajorityInfoMajorityDenominatorExpression Property

Hundred percent settings for majority. Can get variables from MajorityVariables

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string MajorityDenominatorExpression { get; }
Public ReadOnly Property MajorityDenominatorExpression As String
    Get
public:
property String^ MajorityDenominatorExpression {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmVoteMajorityInfo Class


DcnmVoteMajorityInfo.MajorityNumeratorExpression Property

DcnmVoteMajorityInfoMajorityNumeratorExpression Property

In favor for majority. Can get variables from MajorityVariables

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string MajorityNumeratorExpression { get; }
Public ReadOnly Property MajorityNumeratorExpression As String
    Get
public:
property String^ MajorityNumeratorExpression {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmVoteMajorityInfo Class


DcnmVoteMajorityInfo.MajorityThresholdExpression Property

DcnmVoteMajorityInfoMajorityThresholdExpression Property

Majority threshold to decide whether voting can be approved or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string MajorityThresholdExpression { get; }
Public ReadOnly Property MajorityThresholdExpression As String
    Get
public:
property String^ MajorityThresholdExpression {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmVoteMajorityInfo Class


DcnmVoteMajorityInfo Methods

The DcnmVoteMajorityInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmVoteMajorityInfo Class


DcnmVotingAnswer Enumeration

Represents the voting answers

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmVotingAnswer
Public Enumeration DcnmVotingAnswer
public enum class DcnmVotingAnswer
Members
Member name | Value | Description
NotVoted | 0 | No voting answer provided yet
Yes | 1 | Voting answer is yes
No | 2 | Voting answer is no
Abstain | 3 | Voting answer is abstain
DNPV | 4 | Voting answer is DNPV (Do Not Participate in Vote)
For | 5 | Voting answer is for
Against | 6 | Voting answer is against
Present | 7 | Indicates present for voting.
VoteCasted | 8 | Indicates vote is cast.
A | 9 | Voting answer is A
B | 10 | Voting answer is B
C | 11 | Voting answer is C
D | 12 | Voting answer is D
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmVotingAnswerSet Enumeration

Voting answer set info

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmVotingAnswerSet
Public Enumeration DcnmVotingAnswerSet
public enum class DcnmVotingAnswerSet
Members
Member name | Value | Description
YesNo | 0 |
YesNoAbstain | 1 |
YesNoAbstainDnpv | 2 |
ForAgainst | 3 |
ForAgainstAbstain | 4 |
ForAgainstAbstainDnpv | 5 |
ForAbstain | 6 |
YesAbstain | 7 |
AB | 8 |
ABC | 9 |
ABCD | 10 |
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmVotingHundredPercentSettings Enumeration

Represents the voting hundred percent settings.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmVotingHundredPercentSettings
Public Enumeration DcnmVotingHundredPercentSettings
public enum class DcnmVotingHundredPercentSettings
Members
Member name | Value | Description
AuthorizedForVoting | 0 | Total votes is calculated based on vote authorization.
AuthorizedForVotingAndPresentInMeeting | 1 | Total votes is calculated based on vote authorization and participants present in meeting.
PresentButton | 2 | Total votes is calculated based on present button.
CastVotes | 3 | Total votes is calculated based on vote casted.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmVotingPreparationInfo Class

Definition of Voting
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingPreparationInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmVotingPreparationInfo
Public Class DcnmVotingPreparationInfo
public ref class DcnmVotingPreparationInfo

The DcnmVotingPreparationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmVotingPreparationInfo | Default Constructor
Public method | DcnmVotingPreparationInfo(Guid, Guid, DcnmVotingType, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType) | Obsolete. Initializes instance of the class
Public method | DcnmVotingPreparationInfo(Guid, Guid, DcnmVotingType, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, DcnmVotingHundredPercentSettings, Boolean) | Obsolete. Initializes instance of the class
Public method | DcnmVotingPreparationInfo(Guid, Guid, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting) | Obsolete. Initializes instance of the class
Public method | DcnmVotingPreparationInfo(Guid, Guid, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean) | Obsolete. Initializes instance of the class
Public method | DcnmVotingPreparationInfo(Guid, Guid, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, DcnmVotingHundredPercentSettings, Boolean, Boolean, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmStoreVotingResultType) | Obsolete. Initializes instance of the class
Public method | DcnmVotingPreparationInfo(Guid, Guid, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean, Boolean, DcnmVotingAnswer) | Initializes instance of the class
Top
Properties
 | Name | Description
Public property | AutoAnswerEnabled | Flag to indicate whether auto answer enabled or not.
Public property | AutoCastVoteAnswer | Auto answer for voting. when AutoAnswerEnabled is true and no vote was cast upon closing of the voting round.
Public property | CanChangeCastVote | Flag to indicate whether vote can be changed after cast.
Public property | DisplayOnlyTotalResultsForApi | Obsolete. Display total results to api.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForParticipants | Obsolete. Displays total results to participants.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights | Obsolete. Display total results to participants with manage meeting rights.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForSpecialPermission | Obsolete. Display voting total results to special permission.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForApi | Obsolete. Display voting results for api.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForParticipants | Obsolete. Displays voting results for participants.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForParticipantsWithManageMeetingRights | Obsolete. Display voting individual and group result for participants with manage meeting rights.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForSpecialPermission | Obsolete. Display voting results to special permission.DcnmDisplayVotingResultType
Public property | DocumentationLink | The link to voting specific documentation
Public property | HideAnswerButton | Flag indicate to hide casted answer.DcnmDisplayVotingResultType
Public property | IndividualVoteCastedResultDisplaySettings | Options to show individual vote casted.DcnmVotingResultDisplaySetting
Public property | IndividualVoteResultDisplaySettings | Display voting results .DcnmVotingResultDisplaySetting
Public property | MajorityResultDisplaySettings | Option to display majority results.DcnmVotingResultDisplaySetting
Public property | MeetingId | Meeting id of the voting
Public property | OrderNumber | Order number of voting
Public property | ReferenceNumber | Reference number of the voting
Public property | StoreVotingResults | Voting store option.DcnmStoreVotingResultType
Public property | TotalVoteResultDisplaySettings | Display only total results option.DcnmVotingResultDisplaySetting
Public property | TotalVotesCastedResultDisplaySettings | Options to show total cast vote option.DcnmVotingResultDisplaySetting
Public property | TypeOfVoting | The type of voting
Public property | UsePresentButton | Indicates whether to use present button in voting round or not.
Public property | UseVoteWeight | Consider vote weight of participant for this voting round.
Public property | VoteMajority | Option to set majority details.DcnmVoteMajorityInfo
Public property | VotingAnswerSet | Voting answer set type
Public property | VotingDescription | Description of the voting
Public property | VotingHundredPercentSettings | Obsolete. Voting hundred percent settings
Public property | VotingId | Id of the voting
Public property | VotingSubject | Subject of the voting
Public property | VotingTimeDuration | Voting time duration
Public property | VotingTimerType | Voting timer type
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmVotingPreparationInfo Constructor

Overload List
 | Name | Description
Public method | DcnmVotingPreparationInfo | Default Constructor
Public method | DcnmVotingPreparationInfo(Guid, Guid, DcnmVotingType, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType) | Obsolete. Initializes instance of the class
Public method | DcnmVotingPreparationInfo(Guid, Guid, DcnmVotingType, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, DcnmVotingHundredPercentSettings, Boolean) | Obsolete. Initializes instance of the class
Public method | DcnmVotingPreparationInfo(Guid, Guid, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting) | Obsolete. Initializes instance of the class
Public method | DcnmVotingPreparationInfo(Guid, Guid, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean) | Obsolete. Initializes instance of the class
Public method | DcnmVotingPreparationInfo(Guid, Guid, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, DcnmVotingHundredPercentSettings, Boolean, Boolean, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmStoreVotingResultType) | Obsolete. Initializes instance of the class
Public method | DcnmVotingPreparationInfo(Guid, Guid, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean, Boolean, DcnmVotingAnswer) | Initializes instance of the class
Top
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo Constructor

Default Constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingPreparationInfo()
Public Sub New
public:
DcnmVotingPreparationInfo()
See Also

Reference

DcnmVotingPreparationInfo Class
DcnmVotingPreparationInfo Overload


DcnmVotingPreparationInfo Constructor (Guid, Guid, DcnmVotingType, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType)

Note: This API is now obsolete.

Initializes instance of the class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingPreparationInfo(
    Guid meetingID,
    Guid votingId,
    DcnmVotingType typeOfVoting,
    string referenceNumber,
    string votingSubject,
    string votingDescription,
    string documentationLink,
    int orderNumber,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    meetingID As Guid,
    votingId As Guid,
    typeOfVoting As DcnmVotingType,
    referenceNumber As String,
    votingSubject As String,
    votingDescription As String,
    documentationLink As String,
    orderNumber As Integer,
    votingAnswerSet As DcnmVotingAnswerSet,
    votingTimeDuration As Integer,
    votingTimerType As DcnmVotingTimerType
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingPreparationInfo(
    Guid meetingID,
    Guid votingId,
    DcnmVotingType typeOfVoting,
    String^ referenceNumber,
    String^ votingSubject,
    String^ votingDescription,
    String^ documentationLink,
    int orderNumber,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType
)

Parameters

meetingID
Type: SystemGuid
Id of the meeting
votingId
Type: SystemGuid
Id of the voting
typeOfVoting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingType
The type of voting
referenceNumber
Type: SystemString
Reference number of the voting
votingSubject
Type: SystemString
Subject of the voting
votingDescription
Type: SystemString
Description of the voting
documentationLink
Type: SystemString
Documentation link
orderNumber
Type: SystemInt32
Order number
votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
Voting answer set
votingTimeDuration
Type: SystemInt32
Voting time duration
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
Voting timer type
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmVotingPreparationInfo(Guid, Guid, DcnmVotingType, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, DcnmVotingHundredPercentSettings, Boolean) instead.
See Also

Reference

DcnmVotingPreparationInfo Class
DcnmVotingPreparationInfo Overload


DcnmVotingPreparationInfo Constructor (Guid, Guid, DcnmVotingType, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, DcnmVotingHundredPercentSettings, Boolean)

Note: This API is now obsolete.

Initializes instance of the class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingPreparationInfo(
    Guid meetingID,
    Guid votingId,
    DcnmVotingType typeOfVoting,
    string referenceNumber,
    string votingSubject,
    string votingDescription,
    string documentationLink,
    int orderNumber,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    DcnmVotingHundredPercentSettings votingHundredPercentSettings,
    bool useVoteWeight
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    meetingID As Guid,
    votingId As Guid,
    typeOfVoting As DcnmVotingType,
    referenceNumber As String,
    votingSubject As String,
    votingDescription As String,
    documentationLink As String,
    orderNumber As Integer,
    votingAnswerSet As DcnmVotingAnswerSet,
    votingTimeDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    votingHundredPercentSettings As DcnmVotingHundredPercentSettings,
    useVoteWeight As Boolean
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingPreparationInfo(
    Guid meetingID,
    Guid votingId,
    DcnmVotingType typeOfVoting,
    String^ referenceNumber,
    String^ votingSubject,
    String^ votingDescription,
    String^ documentationLink,
    int orderNumber,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    DcnmVotingHundredPercentSettings votingHundredPercentSettings,
    bool useVoteWeight
)

Parameters

meetingID
Type: SystemGuid
Id of the meeting
votingId
Type: SystemGuid
Id of the voting
typeOfVoting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingType
The type of voting
referenceNumber
Type: SystemString
Reference number of the voting
votingSubject
Type: SystemString
Subject of the voting
votingDescription
Type: SystemString
Description of the voting
documentationLink
Type: SystemString
Documentation link
orderNumber
Type: SystemInt32
Order number
votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
Voting answer set
votingTimeDuration
Type: SystemInt32
Voting time duration
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
Voting timer type
votingHundredPercentSettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingHundredPercentSettings
Voting hundred percent settings
useVoteWeight
Type: SystemBoolean
Flag to set whether participant vote weight considered or not.
See Also

Reference

DcnmVotingPreparationInfo Class
DcnmVotingPreparationInfo Overload


DcnmVotingPreparationInfo Constructor (Guid, Guid, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDispl

DcnmVotingPreparationInfo Constructor (Guid, Guid, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting)

 Bosch Logo

Note: This API is now obsolete.

Initializes instance of the class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingPreparationInfo(
    Guid meetingID,
    Guid votingId,
    string referenceNumber,
    string votingSubject,
    string votingDescription,
    string documentationLink,
    int orderNumber,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    bool useVoteWeight,
    bool hideAnswerButton,
    bool usePresentButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVoteMajorityInfo votingMajority,
    DcnmVotingResultDisplaySetting individualVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting totalVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting majorityResultDisplaySettings,
    DcnmVotingResultDisplaySetting individualVoteCastedResultDisplaySettings,
    DcnmVotingResultDisplaySetting totalVotesCastedResultDisplaySettings
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    meetingID As Guid,
    votingId As Guid,
    referenceNumber As String,
    votingSubject As String,
    votingDescription As String,
    documentationLink As String,
    orderNumber As Integer,
    votingAnswerSet As DcnmVotingAnswerSet,
    votingTimeDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    useVoteWeight As Boolean,
    hideAnswerButton As Boolean,
    usePresentButton As Boolean,
    storeVotingResults As DcnmStoreVotingResultType,
    votingMajority As DcnmVoteMajorityInfo,
    individualVoteResultDisplaySettings As DcnmVotingResultDisplaySetting,
    totalVoteResultDisplaySettings As DcnmVotingResultDisplaySetting,
    majorityResultDisplaySettings As DcnmVotingResultDisplaySetting,
    individualVoteCastedResultDisplaySettings As DcnmVotingResultDisplaySetting,
    totalVotesCastedResultDisplaySettings As DcnmVotingResultDisplaySetting
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingPreparationInfo(
    Guid meetingID,
    Guid votingId,
    String^ referenceNumber,
    String^ votingSubject,
    String^ votingDescription,
    String^ documentationLink,
    int orderNumber,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    bool useVoteWeight,
    bool hideAnswerButton,
    bool usePresentButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVoteMajorityInfo^ votingMajority,
    DcnmVotingResultDisplaySetting^ individualVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ totalVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ majorityResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ individualVoteCastedResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ totalVotesCastedResultDisplaySettings
)

Parameters

meetingID
Type: SystemGuid
Id of the meeting
votingId
Type: SystemGuid
Id of the voting
referenceNumber
Type: SystemString
Reference number of the voting
votingSubject
Type: SystemString
Subject of the voting
votingDescription
Type: SystemString
Description of the voting
documentationLink
Type: SystemString
Documentation link
orderNumber
Type: SystemInt32
Order number
votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
Voting answer set
votingTimeDuration
Type: SystemInt32
Voting time duration
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
Voting timer type
useVoteWeight
Type: SystemBoolean
Flag to set whether participant vote weight considered or not.
hideAnswerButton
Type: SystemBoolean
If this flag is true then participant can not see casted answer button.
usePresentButton
Type: SystemBoolean
If this flag is true then present button will be enabled for voting round.
storeVotingResults
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStoreVotingResultType
Option to store voting results will be store. DcnmStoreVotingResultType
votingMajority
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVoteMajorityInfo
Voting majority information.
individualVoteResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show individual voting results. DcnmVotingResultDisplaySetting
totalVoteResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show voting total result option.DcnmVotingResultDisplaySetting
majorityResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show display majority result option.DcnmVotingResultDisplaySetting
individualVoteCastedResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show individual vote result option.DcnmVotingResultDisplaySetting
totalVotesCastedResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show total vote cast option.DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingPreparationInfo Class
DcnmVotingPreparationInfo Overload


DcnmVotingPreparationInfo Constructor (Guid, Guid, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDispl

DcnmVotingPreparationInfo Constructor (Guid, Guid, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean)

 Bosch Logo

Note: This API is now obsolete.

Initializes instance of the class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingPreparationInfo(
    Guid meetingID,
    Guid votingId,
    string referenceNumber,
    string votingSubject,
    string votingDescription,
    string documentationLink,
    int orderNumber,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    bool useVoteWeight,
    bool hideAnswerButton,
    bool usePresentButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVoteMajorityInfo votingMajority,
    DcnmVotingResultDisplaySetting individualVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting totalVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting majorityResultDisplaySettings,
    DcnmVotingResultDisplaySetting individualVoteCastedResultDisplaySettings,
    DcnmVotingResultDisplaySetting totalVotesCastedResultDisplaySettings,
    bool canChangeCastVote
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    meetingID As Guid,
    votingId As Guid,
    referenceNumber As String,
    votingSubject As String,
    votingDescription As String,
    documentationLink As String,
    orderNumber As Integer,
    votingAnswerSet As DcnmVotingAnswerSet,
    votingTimeDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    useVoteWeight As Boolean,
    hideAnswerButton As Boolean,
    usePresentButton As Boolean,
    storeVotingResults As DcnmStoreVotingResultType,
    votingMajority As DcnmVoteMajorityInfo,
    individualVoteResultDisplaySettings As DcnmVotingResultDisplaySetting,
    totalVoteResultDisplaySettings As DcnmVotingResultDisplaySetting,
    majorityResultDisplaySettings As DcnmVotingResultDisplaySetting,
    individualVoteCastedResultDisplaySettings As DcnmVotingResultDisplaySetting,
    totalVotesCastedResultDisplaySettings As DcnmVotingResultDisplaySetting,
    canChangeCastVote As Boolean
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingPreparationInfo(
    Guid meetingID,
    Guid votingId,
    String^ referenceNumber,
    String^ votingSubject,
    String^ votingDescription,
    String^ documentationLink,
    int orderNumber,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    bool useVoteWeight,
    bool hideAnswerButton,
    bool usePresentButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVoteMajorityInfo^ votingMajority,
    DcnmVotingResultDisplaySetting^ individualVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ totalVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ majorityResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ individualVoteCastedResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ totalVotesCastedResultDisplaySettings,
    bool canChangeCastVote
)

Parameters

meetingID
Type: SystemGuid
Id of the meeting
votingId
Type: SystemGuid
Id of the voting
referenceNumber
Type: SystemString
Reference number of the voting
votingSubject
Type: SystemString
Subject of the voting
votingDescription
Type: SystemString
Description of the voting
documentationLink
Type: SystemString
Documentation link
orderNumber
Type: SystemInt32
Order number
votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
Voting answer set
votingTimeDuration
Type: SystemInt32
Voting time duration
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
Voting timer type
useVoteWeight
Type: SystemBoolean
Flag to set whether participant vote weight considered or not.
hideAnswerButton
Type: SystemBoolean
If this flag is true then participant can not see casted answer button.
usePresentButton
Type: SystemBoolean
If this flag is true then present button will be enabled for voting round.
storeVotingResults
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStoreVotingResultType
Option to store voting results will be store. DcnmStoreVotingResultType
votingMajority
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVoteMajorityInfo
Voting majority information.
individualVoteResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show individual voting results. DcnmVotingResultDisplaySetting
totalVoteResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show voting total result option.DcnmVotingResultDisplaySetting
majorityResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show display majority result option.DcnmVotingResultDisplaySetting
individualVoteCastedResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show individual vote result option.DcnmVotingResultDisplaySetting
totalVotesCastedResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show total vote cast option.DcnmVotingResultDisplaySetting
canChangeCastVote
Type: SystemBoolean
Flag to indicate whether can change cast vote.
See Also

Reference

DcnmVotingPreparationInfo Class
DcnmVotingPreparationInfo Overload


DcnmVotingPreparationInfo Constructor (Guid, Guid, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, DcnmVotingHundredPercentSettings, Boolean, Boolean, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResul

DcnmVotingPreparationInfo Constructor (Guid, Guid, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, DcnmVotingHundredPercentSettings, Boolean, Boolean, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmStoreVotingResultType)

 Bosch Logo

Note: This API is now obsolete.

Initializes instance of the class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingPreparationInfo(
    Guid meetingID,
    Guid votingId,
    string referenceNumber,
    string votingSubject,
    string votingDescription,
    string documentationLink,
    int orderNumber,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    DcnmVotingHundredPercentSettings votingHundredPercentSettings,
    bool useVoteWeight,
    bool hideAnswerButton,
    DcnmDisplayVotingResultType displayVotingResultsForParticipants,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForParticipants,
    DcnmDisplayVotingResultType displayVotingResultsForSpecialPermission,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForSpecialPermission,
    DcnmDisplayVotingResultType displayVotingResultsForApi,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForApi,
    DcnmDisplayVotingResultType displayVotingResultForParticipantsWithManageMeetingRights,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForParticipantsWithManageMeetingRights,
    DcnmStoreVotingResultType storeVotingResults
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    meetingID As Guid,
    votingId As Guid,
    referenceNumber As String,
    votingSubject As String,
    votingDescription As String,
    documentationLink As String,
    orderNumber As Integer,
    votingAnswerSet As DcnmVotingAnswerSet,
    votingTimeDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    votingHundredPercentSettings As DcnmVotingHundredPercentSettings,
    useVoteWeight As Boolean,
    hideAnswerButton As Boolean,
    displayVotingResultsForParticipants As DcnmDisplayVotingResultType,
    displayOnlyTotalResultsForParticipants As DcnmDisplayVotingResultType,
    displayVotingResultsForSpecialPermission As DcnmDisplayVotingResultType,
    displayOnlyTotalResultsForSpecialPermission As DcnmDisplayVotingResultType,
    displayVotingResultsForApi As DcnmDisplayVotingResultType,
    displayOnlyTotalResultsForApi As DcnmDisplayVotingResultType,
    displayVotingResultForParticipantsWithManageMeetingRights As DcnmDisplayVotingResultType,
    displayOnlyTotalResultsForParticipantsWithManageMeetingRights As DcnmDisplayVotingResultType,
    storeVotingResults As DcnmStoreVotingResultType
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingPreparationInfo(
    Guid meetingID,
    Guid votingId,
    String^ referenceNumber,
    String^ votingSubject,
    String^ votingDescription,
    String^ documentationLink,
    int orderNumber,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    DcnmVotingHundredPercentSettings votingHundredPercentSettings,
    bool useVoteWeight,
    bool hideAnswerButton,
    DcnmDisplayVotingResultType displayVotingResultsForParticipants,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForParticipants,
    DcnmDisplayVotingResultType displayVotingResultsForSpecialPermission,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForSpecialPermission,
    DcnmDisplayVotingResultType displayVotingResultsForApi,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForApi,
    DcnmDisplayVotingResultType displayVotingResultForParticipantsWithManageMeetingRights,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForParticipantsWithManageMeetingRights,
    DcnmStoreVotingResultType storeVotingResults
)

Parameters

meetingID
Type: SystemGuid
Id of the meeting
votingId
Type: SystemGuid
Id of the voting
referenceNumber
Type: SystemString
Reference number of the voting
votingSubject
Type: SystemString
Subject of the voting
votingDescription
Type: SystemString
Description of the voting
documentationLink
Type: SystemString
Documentation link
orderNumber
Type: SystemInt32
Order number
votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
Voting answer set
votingTimeDuration
Type: SystemInt32
Voting time duration
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
Voting timer type
votingHundredPercentSettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingHundredPercentSettings
Voting hundred percent settings
useVoteWeight
Type: SystemBoolean
Flag to set whether participant vote weight considered or not.
hideAnswerButton
Type: SystemBoolean
If this flag is true then participant can not see casted answer button.
displayVotingResultsForParticipants
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how participants can see individual and group results. DcnmDisplayVotingResultType
displayOnlyTotalResultsForParticipants
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how participants can see total results. DcnmDisplayVotingResultType
displayVotingResultsForSpecialPermission
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how special permission seats/participants can see individual and group results. DcnmDisplayVotingResultType
displayOnlyTotalResultsForSpecialPermission
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how seats/participants can see total results. DcnmDisplayVotingResultType
displayVotingResultsForApi
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how api systems can see individual and group results. DcnmDisplayVotingResultType
displayOnlyTotalResultsForApi
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how api system can see total results. DcnmDisplayVotingResultType
displayVotingResultForParticipantsWithManageMeetingRights
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to show voting result for participant with manage meeting rights
displayOnlyTotalResultsForParticipantsWithManageMeetingRights
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to show voting total result for participant with manage meeting rights
storeVotingResults
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStoreVotingResultType
Option to store voting results will be store. DcnmStoreVotingResultType
See Also

Reference

DcnmVotingPreparationInfo Class
DcnmVotingPreparationInfo Overload


DcnmVotingPreparationInfo Constructor (Guid, Guid, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDispl

DcnmVotingPreparationInfo Constructor (Guid, Guid, String, String, String, String, Int32, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean, Boolean, DcnmVotingAnswer)

 Bosch Logo
Initializes instance of the class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingPreparationInfo(
    Guid meetingID,
    Guid votingId,
    string referenceNumber,
    string votingSubject,
    string votingDescription,
    string documentationLink,
    int orderNumber,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    bool useVoteWeight,
    bool hideAnswerButton,
    bool usePresentButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVoteMajorityInfo votingMajority,
    DcnmVotingResultDisplaySetting individualVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting totalVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting majorityResultDisplaySettings,
    DcnmVotingResultDisplaySetting individualVoteCastedResultDisplaySettings,
    DcnmVotingResultDisplaySetting totalVotesCastedResultDisplaySettings,
    bool canChangeCastVote,
    bool autoAnswerEnabled,
    DcnmVotingAnswer autoCastVoteAnswer
)
Public Sub New (
    meetingID As Guid,
    votingId As Guid,
    referenceNumber As String,
    votingSubject As String,
    votingDescription As String,
    documentationLink As String,
    orderNumber As Integer,
    votingAnswerSet As DcnmVotingAnswerSet,
    votingTimeDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    useVoteWeight As Boolean,
    hideAnswerButton As Boolean,
    usePresentButton As Boolean,
    storeVotingResults As DcnmStoreVotingResultType,
    votingMajority As DcnmVoteMajorityInfo,
    individualVoteResultDisplaySettings As DcnmVotingResultDisplaySetting,
    totalVoteResultDisplaySettings As DcnmVotingResultDisplaySetting,
    majorityResultDisplaySettings As DcnmVotingResultDisplaySetting,
    individualVoteCastedResultDisplaySettings As DcnmVotingResultDisplaySetting,
    totalVotesCastedResultDisplaySettings As DcnmVotingResultDisplaySetting,
    canChangeCastVote As Boolean,
    autoAnswerEnabled As Boolean,
    autoCastVoteAnswer As DcnmVotingAnswer
)
public:
DcnmVotingPreparationInfo(
    Guid meetingID,
    Guid votingId,
    String^ referenceNumber,
    String^ votingSubject,
    String^ votingDescription,
    String^ documentationLink,
    int orderNumber,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    bool useVoteWeight,
    bool hideAnswerButton,
    bool usePresentButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVoteMajorityInfo^ votingMajority,
    DcnmVotingResultDisplaySetting^ individualVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ totalVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ majorityResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ individualVoteCastedResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ totalVotesCastedResultDisplaySettings,
    bool canChangeCastVote,
    bool autoAnswerEnabled,
    DcnmVotingAnswer autoCastVoteAnswer
)

Parameters

meetingID
Type: SystemGuid
Id of the meeting
votingId
Type: SystemGuid
Id of the voting
referenceNumber
Type: SystemString
Reference number of the voting
votingSubject
Type: SystemString
Subject of the voting
votingDescription
Type: SystemString
Description of the voting
documentationLink
Type: SystemString
Documentation link
orderNumber
Type: SystemInt32
Order number
votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
Voting answer set
votingTimeDuration
Type: SystemInt32
Voting time duration
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
Voting timer type
useVoteWeight
Type: SystemBoolean
Flag to set whether participant vote weight considered or not.
hideAnswerButton
Type: SystemBoolean
If this flag is true then participant can not see casted answer button.
usePresentButton
Type: SystemBoolean
If this flag is true then present button will be enabled for voting round.
storeVotingResults
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStoreVotingResultType
Option to store voting results will be store. DcnmStoreVotingResultType
votingMajority
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVoteMajorityInfo
Voting majority information.
individualVoteResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show individual voting results. DcnmVotingResultDisplaySetting
totalVoteResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show voting total result option.DcnmVotingResultDisplaySetting
majorityResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show display majority result option.DcnmVotingResultDisplaySetting
individualVoteCastedResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show individual vote result option.DcnmVotingResultDisplaySetting
totalVotesCastedResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show total vote cast option.DcnmVotingResultDisplaySetting
canChangeCastVote
Type: SystemBoolean
Flag to indicate whether can change cast vote.
autoAnswerEnabled
Type: SystemBoolean
Flag to indicate whether auto answer enabled or not.
autoCastVoteAnswer
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswer
Auto answer for vote. when AutoAnswerEnabled is true and no vote was cast upon closing of the voting round.
See Also

Reference

DcnmVotingPreparationInfo Class
DcnmVotingPreparationInfo Overload


DcnmVotingPreparationInfo Properties

The DcnmVotingPreparationInfo type exposes the following members.

Properties
 | Name | Description
Public property | AutoAnswerEnabled | Flag to indicate whether auto answer enabled or not.
Public property | AutoCastVoteAnswer | Auto answer for voting. when AutoAnswerEnabled is true and no vote was cast upon closing of the voting round.
Public property | CanChangeCastVote | Flag to indicate whether vote can be changed after cast.
Public property | DisplayOnlyTotalResultsForApi | Obsolete. Display total results to api.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForParticipants | Obsolete. Displays total results to participants.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights | Obsolete. Display total results to participants with manage meeting rights.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForSpecialPermission | Obsolete. Display voting total results to special permission.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForApi | Obsolete. Display voting results for api.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForParticipants | Obsolete. Displays voting results for participants.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForParticipantsWithManageMeetingRights | Obsolete. Display voting individual and group result for participants with manage meeting rights.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForSpecialPermission | Obsolete. Display voting results to special permission.DcnmDisplayVotingResultType
Public property | DocumentationLink | The link to voting specific documentation
Public property | HideAnswerButton | Flag indicate to hide casted answer.DcnmDisplayVotingResultType
Public property | IndividualVoteCastedResultDisplaySettings | Options to show individual vote casted.DcnmVotingResultDisplaySetting
Public property | IndividualVoteResultDisplaySettings | Display voting results .DcnmVotingResultDisplaySetting
Public property | MajorityResultDisplaySettings | Option to display majority results.DcnmVotingResultDisplaySetting
Public property | MeetingId | Meeting id of the voting
Public property | OrderNumber | Order number of voting
Public property | ReferenceNumber | Reference number of the voting
Public property | StoreVotingResults | Voting store option.DcnmStoreVotingResultType
Public property | TotalVoteResultDisplaySettings | Display only total results option.DcnmVotingResultDisplaySetting
Public property | TotalVotesCastedResultDisplaySettings | Options to show total cast vote option.DcnmVotingResultDisplaySetting
Public property | TypeOfVoting | The type of voting
Public property | UsePresentButton | Indicates whether to use present button in voting round or not.
Public property | UseVoteWeight | Consider vote weight of participant for this voting round.
Public property | VoteMajority | Option to set majority details.DcnmVoteMajorityInfo
Public property | VotingAnswerSet | Voting answer set type
Public property | VotingDescription | Description of the voting
Public property | VotingHundredPercentSettings | Obsolete. Voting hundred percent settings
Public property | VotingId | Id of the voting
Public property | VotingSubject | Subject of the voting
Public property | VotingTimeDuration | Voting time duration
Public property | VotingTimerType | Voting timer type
Top
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.AutoAnswerEnabled Property

DcnmVotingPreparationInfoAutoAnswerEnabled Property

Flag to indicate whether auto answer enabled or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AutoAnswerEnabled { get; }
Public ReadOnly Property AutoAnswerEnabled As Boolean
    Get
public:
property bool AutoAnswerEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.AutoCastVoteAnswer Property

DcnmVotingPreparationInfoAutoCastVoteAnswer Property

Auto answer for voting. when AutoAnswerEnabled is true and no vote was cast upon closing of the voting round.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingAnswer AutoCastVoteAnswer { get; }
Public ReadOnly Property AutoCastVoteAnswer As DcnmVotingAnswer
    Get
public:
property DcnmVotingAnswer AutoCastVoteAnswer {
    DcnmVotingAnswer get ();
}

Property Value

Type: DcnmVotingAnswer
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.CanChangeCastVote Property

DcnmVotingPreparationInfoCanChangeCastVote Property

Flag to indicate whether vote can be changed after cast.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanChangeCastVote { get; }
Public ReadOnly Property CanChangeCastVote As Boolean
    Get
public:
property bool CanChangeCastVote {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.DisplayOnlyTotalResultsForApi Property

DcnmVotingPreparationInfoDisplayOnlyTotalResultsForApi Property

Bosch Logo

Note: This API is now obsolete.

Display total results to api.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ExternalSystemViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayOnlyTotalResultsForApi { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ExternalSystemViewingOption instead.")>
Public ReadOnly Property DisplayOnlyTotalResultsForApi As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayOnlyTotalResults.ExternalSystemViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayOnlyTotalResultsForApi {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.DisplayOnlyTotalResultsForParticipants Property

DcnmVotingPreparationInfoDisplayOnlyTotalResultsForParticipants Property

Bosch Logo

Note: This API is now obsolete.

Displays total results to participants.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ParticipantViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayOnlyTotalResultsForParticipants { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ParticipantViewingOption instead.")>
Public ReadOnly Property DisplayOnlyTotalResultsForParticipants As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayOnlyTotalResults.ParticipantViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayOnlyTotalResultsForParticipants {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights Property

DcnmVotingPreparationInfoDisplayOnlyTotalResultsForParticipantsWithManageMeetingRights Property

Bosch Logo

Note: This API is now obsolete.

Display total results to participants with manage meeting rights.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ManageMeetingRightsViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ManageMeetingRightsViewingOption instead.")>
Public ReadOnly Property DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayOnlyTotalResults.ManageMeetingRightsViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.DisplayOnlyTotalResultsForSpecialPermission Property

DcnmVotingPreparationInfoDisplayOnlyTotalResultsForSpecialPermission Property

Bosch Logo

Note: This API is now obsolete.

Display voting total results to special permission.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.SpecialPermissionViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayOnlyTotalResultsForSpecialPermission { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.SpecialPermissionViewingOption instead.")>
Public ReadOnly Property DisplayOnlyTotalResultsForSpecialPermission As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayOnlyTotalResults.SpecialPermissionViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayOnlyTotalResultsForSpecialPermission {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.DisplayVotingResultsForApi Property

DcnmVotingPreparationInfoDisplayVotingResultsForApi Property

Note: This API is now obsolete.

Display voting results for api.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ExternalSystemViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayVotingResultsForApi { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ExternalSystemViewingOption instead.")>
Public ReadOnly Property DisplayVotingResultsForApi As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayIndividualVotingResults.ExternalSystemViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayVotingResultsForApi {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.DisplayVotingResultsForParticipants Property

DcnmVotingPreparationInfoDisplayVotingResultsForParticipants Property

Bosch Logo

Note: This API is now obsolete.

Displays voting results for participants.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ParticipantViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayVotingResultsForParticipants { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ParticipantViewingOption instead.")>
Public ReadOnly Property DisplayVotingResultsForParticipants As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayIndividualVotingResults.ParticipantViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayVotingResultsForParticipants {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.DisplayVotingResultsForParticipantsWithManageMeetingRights Property

DcnmVotingPreparationInfoDisplayVotingResultsForParticipantsWithManageMeetingRights Property

Bosch Logo

Note: This API is now obsolete.

Display voting individual and group result for participants with manage meeting rights.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ManageMeetingRightsViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayVotingResultsForParticipantsWithManageMeetingRights { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ManageMeetingRightsViewingOption instead.")>
Public ReadOnly Property DisplayVotingResultsForParticipantsWithManageMeetingRights As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayIndividualVotingResults.ManageMeetingRightsViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayVotingResultsForParticipantsWithManageMeetingRights {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.DisplayVotingResultsForSpecialPermission Property

DcnmVotingPreparationInfoDisplayVotingResultsForSpecialPermission Property

Bosch Logo

Note: This API is now obsolete.

Display voting results to special permission.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.SpecialPermissionViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayVotingResultsForSpecialPermission { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.SpecialPermissionViewingOption instead.")>
Public ReadOnly Property DisplayVotingResultsForSpecialPermission As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayIndividualVotingResults.SpecialPermissionViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayVotingResultsForSpecialPermission {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.DocumentationLink Property

DcnmVotingPreparationInfoDocumentationLink Property

The link to voting specific documentation

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string DocumentationLink { get; }
Public ReadOnly Property DocumentationLink As String
    Get
public:
property String^ DocumentationLink {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.HideAnswerButton Property

DcnmVotingPreparationInfoHideAnswerButton Property

Flag indicate to hide casted answer.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool HideAnswerButton { get; }
Public ReadOnly Property HideAnswerButton As Boolean
    Get
public:
property bool HideAnswerButton {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.IndividualVoteCastedResultDisplaySettings Property

DcnmVotingPreparationInfoIndividualVoteCastedResultDisplaySettings Property

Bosch Logo
Options to show individual vote casted.DcnmVotingResultDisplaySetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResultDisplaySetting IndividualVoteCastedResultDisplaySettings { get; }
Public ReadOnly Property IndividualVoteCastedResultDisplaySettings As DcnmVotingResultDisplaySetting
    Get
public:
property DcnmVotingResultDisplaySetting^ IndividualVoteCastedResultDisplaySettings {
    DcnmVotingResultDisplaySetting^ get ();
}

Property Value

Type: DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.IndividualVoteResultDisplaySettings Property

DcnmVotingPreparationInfoIndividualVoteResultDisplaySettings Property

Bosch Logo
Display voting results .DcnmVotingResultDisplaySetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResultDisplaySetting IndividualVoteResultDisplaySettings { get; }
Public ReadOnly Property IndividualVoteResultDisplaySettings As DcnmVotingResultDisplaySetting
    Get
public:
property DcnmVotingResultDisplaySetting^ IndividualVoteResultDisplaySettings {
    DcnmVotingResultDisplaySetting^ get ();
}

Property Value

Type: DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.MajorityResultDisplaySettings Property

DcnmVotingPreparationInfoMajorityResultDisplaySettings Property

Bosch Logo
Option to display majority results.DcnmVotingResultDisplaySetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResultDisplaySetting MajorityResultDisplaySettings { get; }
Public ReadOnly Property MajorityResultDisplaySettings As DcnmVotingResultDisplaySetting
    Get
public:
property DcnmVotingResultDisplaySetting^ MajorityResultDisplaySettings {
    DcnmVotingResultDisplaySetting^ get ();
}

Property Value

Type: DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.MeetingId Property

DcnmVotingPreparationInfoMeetingId Property

Meeting id of the voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid MeetingId { get; }
Public ReadOnly Property MeetingId As Guid
    Get
public:
property Guid MeetingId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.OrderNumber Property

DcnmVotingPreparationInfoOrderNumber Property

Order number of voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int OrderNumber { get; }
Public ReadOnly Property OrderNumber As Integer
    Get
public:
property int OrderNumber {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.ReferenceNumber Property

DcnmVotingPreparationInfoReferenceNumber Property

Reference number of the voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string ReferenceNumber { get; }
Public ReadOnly Property ReferenceNumber As String
    Get
public:
property String^ ReferenceNumber {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.StoreVotingResults Property

DcnmVotingPreparationInfoStoreVotingResults Property

Voting store option.DcnmStoreVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmStoreVotingResultType StoreVotingResults { get; }
Public ReadOnly Property StoreVotingResults As DcnmStoreVotingResultType
    Get
public:
property DcnmStoreVotingResultType StoreVotingResults {
    DcnmStoreVotingResultType get ();
}

Property Value

Type: DcnmStoreVotingResultType
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.TotalVoteResultDisplaySettings Property

DcnmVotingPreparationInfoTotalVoteResultDisplaySettings Property

Bosch Logo
Display only total results option.DcnmVotingResultDisplaySetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResultDisplaySetting TotalVoteResultDisplaySettings { get; }
Public ReadOnly Property TotalVoteResultDisplaySettings As DcnmVotingResultDisplaySetting
    Get
public:
property DcnmVotingResultDisplaySetting^ TotalVoteResultDisplaySettings {
    DcnmVotingResultDisplaySetting^ get ();
}

Property Value

Type: DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.TotalVotesCastedResultDisplaySettings Property

DcnmVotingPreparationInfoTotalVotesCastedResultDisplaySettings Property

Bosch Logo
Options to show total cast vote option.DcnmVotingResultDisplaySetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResultDisplaySetting TotalVotesCastedResultDisplaySettings { get; }
Public ReadOnly Property TotalVotesCastedResultDisplaySettings As DcnmVotingResultDisplaySetting
    Get
public:
property DcnmVotingResultDisplaySetting^ TotalVotesCastedResultDisplaySettings {
    DcnmVotingResultDisplaySetting^ get ();
}

Property Value

Type: DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.TypeOfVoting Property

DcnmVotingPreparationInfoTypeOfVoting Property

The type of voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingType TypeOfVoting { get; }
Public ReadOnly Property TypeOfVoting As DcnmVotingType
    Get
public:
property DcnmVotingType TypeOfVoting {
    DcnmVotingType get ();
}

Property Value

Type: DcnmVotingType
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.UsePresentButton Property

DcnmVotingPreparationInfoUsePresentButton Property

Indicates whether to use present button in voting round or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool UsePresentButton { get; }
Public ReadOnly Property UsePresentButton As Boolean
    Get
public:
property bool UsePresentButton {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.UseVoteWeight Property

DcnmVotingPreparationInfoUseVoteWeight Property

Consider vote weight of participant for this voting round.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool UseVoteWeight { get; }
Public ReadOnly Property UseVoteWeight As Boolean
    Get
public:
property bool UseVoteWeight {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.VoteMajority Property

DcnmVotingPreparationInfoVoteMajority Property

Option to set majority details.DcnmVoteMajorityInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVoteMajorityInfo VoteMajority { get; }
Public ReadOnly Property VoteMajority As DcnmVoteMajorityInfo
    Get
public:
property DcnmVoteMajorityInfo^ VoteMajority {
    DcnmVoteMajorityInfo^ get ();
}

Property Value

Type: DcnmVoteMajorityInfo
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.VotingAnswerSet Property

DcnmVotingPreparationInfoVotingAnswerSet Property

Voting answer set type

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingAnswerSet VotingAnswerSet { get; }
Public ReadOnly Property VotingAnswerSet As DcnmVotingAnswerSet
    Get
public:
property DcnmVotingAnswerSet VotingAnswerSet {
    DcnmVotingAnswerSet get ();
}

Property Value

Type: DcnmVotingAnswerSet
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.VotingDescription Property

DcnmVotingPreparationInfoVotingDescription Property

Description of the voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string VotingDescription { get; }
Public ReadOnly Property VotingDescription As String
    Get
public:
property String^ VotingDescription {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.VotingHundredPercentSettings Property

DcnmVotingPreparationInfoVotingHundredPercentSettings Property

Bosch Logo

Note: This API is now obsolete.

Voting hundred percent settings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete;")]
public DcnmVotingHundredPercentSettings VotingHundredPercentSettings { get; }
<ObsoleteAttribute("This property is obsolete;")>
Public ReadOnly Property VotingHundredPercentSettings As DcnmVotingHundredPercentSettings
    Get
public:
[ObsoleteAttribute(L"This property is obsolete;")]
property DcnmVotingHundredPercentSettings VotingHundredPercentSettings {
    DcnmVotingHundredPercentSettings get ();
}

Property Value

Type: DcnmVotingHundredPercentSettings
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.VotingId Property

DcnmVotingPreparationInfoVotingId Property

Id of the voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid VotingId { get; }
Public ReadOnly Property VotingId As Guid
    Get
public:
property Guid VotingId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.VotingSubject Property

DcnmVotingPreparationInfoVotingSubject Property

Subject of the voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string VotingSubject { get; }
Public ReadOnly Property VotingSubject As String
    Get
public:
property String^ VotingSubject {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.VotingTimeDuration Property

DcnmVotingPreparationInfoVotingTimeDuration Property

Voting time duration

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int VotingTimeDuration { get; }
Public ReadOnly Property VotingTimeDuration As Integer
    Get
public:
property int VotingTimeDuration {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo.VotingTimerType Property

DcnmVotingPreparationInfoVotingTimerType Property

Voting timer type

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingTimerType VotingTimerType { get; }
Public ReadOnly Property VotingTimerType As DcnmVotingTimerType
    Get
public:
property DcnmVotingTimerType VotingTimerType {
    DcnmVotingTimerType get ();
}

Property Value

Type: DcnmVotingTimerType
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingPreparationInfo Methods

The DcnmVotingPreparationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmVotingPreparationInfo Class


DcnmVotingResult Class

Contains voting result information
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResult

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmVotingResult
Public Class DcnmVotingResult
public ref class DcnmVotingResult

The DcnmVotingResult type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmVotingResult | Constructor
Top
Properties
 | Name | Description
Public property | Count | Holds voting count
Public property | VotingAnswer | Holds voting answer
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmVotingResult Constructor

Constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResult(
    int count,
    DcnmVotingAnswer votingAnswer
)
Public Sub New (
    count As Integer,
    votingAnswer As DcnmVotingAnswer
)
public:
DcnmVotingResult(
    int count,
    DcnmVotingAnswer votingAnswer
)

Parameters

count
Type: SystemInt32
Count of answer
votingAnswer
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswer
Answer type
See Also

Reference

DcnmVotingResult Class


DcnmVotingResult Properties

The DcnmVotingResult type exposes the following members.

Properties
 | Name | Description
Public property | Count | Holds voting count
Public property | VotingAnswer | Holds voting answer
Top
See Also

Reference

DcnmVotingResult Class


DcnmVotingResult.Count Property

DcnmVotingResultCount Property

Holds voting count

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmVotingResult Class


DcnmVotingResult.VotingAnswer Property

DcnmVotingResultVotingAnswer Property

Holds voting answer

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingAnswer VotingAnswer { get; }
Public ReadOnly Property VotingAnswer As DcnmVotingAnswer
    Get
public:
property DcnmVotingAnswer VotingAnswer {
    DcnmVotingAnswer get ();
}

Property Value

Type: DcnmVotingAnswer
See Also

Reference

DcnmVotingResult Class


DcnmVotingResult Methods

The DcnmVotingResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmVotingResult Class


DcnmVotingResultDisplaySetting Class

Class holds display voting results option.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmVotingResultDisplaySetting
Public Class DcnmVotingResultDisplaySetting
public ref class DcnmVotingResultDisplaySetting

The DcnmVotingResultDisplaySetting type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmVotingResultDisplaySetting | Constructor
Top
Properties
 | Name | Description
Public property | ExternalSystemViewingOption | Display voting result option for API or external application.DcnmDisplayVotingResultType
Public property | ManageMeetingRightsViewingOption | Display voting result option for manage meeting rights.DcnmDisplayVotingResultType
Public property | ParticipantViewingOption | Display voting result option for participant.DcnmDisplayVotingResultType
Public property | SpecialPermissionViewingOption | Display voting result option for VIP or special permission.DcnmDisplayVotingResultType
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmVotingResultDisplaySetting Constructor

Constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResultDisplaySetting(
    DcnmDisplayVotingResultType participantViewingOption,
    DcnmDisplayVotingResultType specialPermissionViewingOption,
    DcnmDisplayVotingResultType manageMeetingRightsViewingOption,
    DcnmDisplayVotingResultType externalSystemViewingOption
)
Public Sub New (
    participantViewingOption As DcnmDisplayVotingResultType,
    specialPermissionViewingOption As DcnmDisplayVotingResultType,
    manageMeetingRightsViewingOption As DcnmDisplayVotingResultType,
    externalSystemViewingOption As DcnmDisplayVotingResultType
)
public:
DcnmVotingResultDisplaySetting(
    DcnmDisplayVotingResultType participantViewingOption,
    DcnmDisplayVotingResultType specialPermissionViewingOption,
    DcnmDisplayVotingResultType manageMeetingRightsViewingOption,
    DcnmDisplayVotingResultType externalSystemViewingOption
)

Parameters

participantViewingOption
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Display voting result option for participant.
specialPermissionViewingOption
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Display voting result option for Vip or special permission.
manageMeetingRightsViewingOption
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Display voting result option for manage meeting rights.
externalSystemViewingOption
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Display voting result option for external or API
See Also

Reference

DcnmVotingResultDisplaySetting Class


DcnmVotingResultDisplaySetting Properties

The DcnmVotingResultDisplaySetting type exposes the following members.

Properties
 | Name | Description
Public property | ExternalSystemViewingOption | Display voting result option for API or external application.DcnmDisplayVotingResultType
Public property | ManageMeetingRightsViewingOption | Display voting result option for manage meeting rights.DcnmDisplayVotingResultType
Public property | ParticipantViewingOption | Display voting result option for participant.DcnmDisplayVotingResultType
Public property | SpecialPermissionViewingOption | Display voting result option for VIP or special permission.DcnmDisplayVotingResultType
Top
See Also

Reference

DcnmVotingResultDisplaySetting Class


DcnmVotingResultDisplaySetting.ExternalSystemViewingOption Property

DcnmVotingResultDisplaySettingExternalSystemViewingOption Property

Bosch Logo
Display voting result option for API or external application.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDisplayVotingResultType ExternalSystemViewingOption { get; }
Public ReadOnly Property ExternalSystemViewingOption As DcnmDisplayVotingResultType
    Get
public:
property DcnmDisplayVotingResultType ExternalSystemViewingOption {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingResultDisplaySetting Class


DcnmVotingResultDisplaySetting.ManageMeetingRightsViewingOption Property

DcnmVotingResultDisplaySettingManageMeetingRightsViewingOption Property

Bosch Logo
Display voting result option for manage meeting rights.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDisplayVotingResultType ManageMeetingRightsViewingOption { get; }
Public ReadOnly Property ManageMeetingRightsViewingOption As DcnmDisplayVotingResultType
    Get
public:
property DcnmDisplayVotingResultType ManageMeetingRightsViewingOption {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingResultDisplaySetting Class


DcnmVotingResultDisplaySetting.ParticipantViewingOption Property

DcnmVotingResultDisplaySettingParticipantViewingOption Property

Bosch Logo
Display voting result option for participant.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDisplayVotingResultType ParticipantViewingOption { get; }
Public ReadOnly Property ParticipantViewingOption As DcnmDisplayVotingResultType
    Get
public:
property DcnmDisplayVotingResultType ParticipantViewingOption {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingResultDisplaySetting Class


DcnmVotingResultDisplaySetting.SpecialPermissionViewingOption Property

DcnmVotingResultDisplaySettingSpecialPermissionViewingOption Property

Bosch Logo
Display voting result option for VIP or special permission.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmDisplayVotingResultType SpecialPermissionViewingOption { get; }
Public ReadOnly Property SpecialPermissionViewingOption As DcnmDisplayVotingResultType
    Get
public:
property DcnmDisplayVotingResultType SpecialPermissionViewingOption {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingResultDisplaySetting Class


DcnmVotingResultDisplaySetting Methods

The DcnmVotingResultDisplaySetting type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmVotingResultDisplaySetting Class


DcnmVotingSettingsInfo Class

Definition of Voting Settings Info
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingSettingsInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmVotingSettingsInfo
Public Class DcnmVotingSettingsInfo
public ref class DcnmVotingSettingsInfo

The DcnmVotingSettingsInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmVotingSettingsInfo | Default Constructor
Public method | DcnmVotingSettingsInfo(DcnmVotingAnswerSet, DcnmVotingType, Int32, DcnmVotingTimerType) | Obsolete. Initializes instance of the class
Public method | DcnmVotingSettingsInfo(DcnmVotingAnswerSet, DcnmVotingType, Int32, DcnmVotingTimerType, DcnmVotingHundredPercentSettings, Boolean) | Obsolete. Initializes instance of the class
Public method | DcnmVotingSettingsInfo(DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting) | Obsolete. Initializes instance of the class
Public method | DcnmVotingSettingsInfo(DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean) | Obsolete. Initializes instance of the class
Public method | DcnmVotingSettingsInfo(DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, DcnmVotingHundredPercentSettings, Boolean, Boolean, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmStoreVotingResultType) | Obsolete. Initializes instance of the class
Public method | DcnmVotingSettingsInfo(DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean, Boolean, DcnmVotingAnswer) | Initializes instance of the class
Top
Properties
 | Name | Description
Public property | AutoAnswerEnabled | Flag to indicate whether auto answer enabled or not.
Public property | AutoCastVoteAnswer | Auto answer for voting. when AutoAnswerEnabled is true and no vote was cast upon closing of the voting round.
Public property | CanChangeCastVote | Flag to indicate whether vote can be changed after cast.
Public property | DisplayOnlyTotalResultsForApi | Obsolete. Display total results to external system.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForParticipants | Obsolete. Displays total results to participants.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights | Obsolete. Display total results to participants with manage meeting rights.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForSpecialPermission | Obsolete. Display voting total results to VIP.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForApi | Obsolete. Display voting results for external system.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForParticipants | Obsolete. Displays voting results for participants.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForParticipantsWithManageMeetingRights | Obsolete. Display voting individual and group result for participants with manage meeting rights.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForSpecialPermission | Obsolete. Display voting results to VIP.DcnmDisplayVotingResultType
Public property | HideAnswerButton | Flag indicate to hide casted answer.
Public property | IndividualVoteCastedResultDisplaySettings | Options to show individual vote casted.DcnmVotingResultDisplaySetting
Public property | IndividualVoteResultDisplaySettings | Display voting results .DcnmVotingResultDisplaySetting
Public property | MajorityResultDisplaySettings | Option to display majority results.DcnmVotingResultDisplaySetting
Public property | StoreVotingResults | Voting store option.DcnmStoreVotingResultType
Public property | TotalVoteCastedResultDisplaySettings | Options to show total cast vote option.DcnmVotingResultDisplaySetting
Public property | TotalVotesResultDisplaySettings | Display only total results option.DcnmVotingResultDisplaySetting
Public property | TypeOfVoting | The type of voting
Public property | UsePresentButton | Indicates whether to use present button in voting round or not.
Public property | UseVoteWeight | Consider vote weight of participant for this voting round.
Public property | VoteMajority | Option to set majority details.DcnmVoteMajorityInfo
Public property | VotingAnswerSet | Voting answer set Type
Public property | VotingDuration | The voting duration
Public property | VotingHundredPercentSettings | Obsolete. The voting hundred percent settings
Public property | VotingTimerType | The voting timer type
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmVotingSettingsInfo Constructor

Overload List
 | Name | Description
Public method | DcnmVotingSettingsInfo | Default Constructor
Public method | DcnmVotingSettingsInfo(DcnmVotingAnswerSet, DcnmVotingType, Int32, DcnmVotingTimerType) | Obsolete. Initializes instance of the class
Public method | DcnmVotingSettingsInfo(DcnmVotingAnswerSet, DcnmVotingType, Int32, DcnmVotingTimerType, DcnmVotingHundredPercentSettings, Boolean) | Obsolete. Initializes instance of the class
Public method | DcnmVotingSettingsInfo(DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting) | Obsolete. Initializes instance of the class
Public method | DcnmVotingSettingsInfo(DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean) | Obsolete. Initializes instance of the class
Public method | DcnmVotingSettingsInfo(DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, DcnmVotingHundredPercentSettings, Boolean, Boolean, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmStoreVotingResultType) | Obsolete. Initializes instance of the class
Public method | DcnmVotingSettingsInfo(DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean, Boolean, DcnmVotingAnswer) | Initializes instance of the class
Top
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo Constructor

Default Constructor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingSettingsInfo()
Public Sub New
public:
DcnmVotingSettingsInfo()
See Also

Reference

DcnmVotingSettingsInfo Class
DcnmVotingSettingsInfo Overload


DcnmVotingSettingsInfo Constructor (DcnmVotingAnswerSet, DcnmVotingType, Int32, DcnmVotingTimerType)

Note: This API is now obsolete.

Initializes instance of the class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingSettingsInfo(
    DcnmVotingAnswerSet votingAnswerSet,
    DcnmVotingType votingType,
    int votingDuration,
    DcnmVotingTimerType votingTimerType
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    votingAnswerSet As DcnmVotingAnswerSet,
    votingType As DcnmVotingType,
    votingDuration As Integer,
    votingTimerType As DcnmVotingTimerType
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingSettingsInfo(
    DcnmVotingAnswerSet votingAnswerSet,
    DcnmVotingType votingType,
    int votingDuration,
    DcnmVotingTimerType votingTimerType
)

Parameters

votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
votingAnswerSet
votingType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingType
The type of voting.
votingDuration
Type: SystemInt32
The voting time duration.
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
The type of voting timer.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmVotingSettingsInfo(DcnmVotingAnswerSet, DcnmVotingType, Int32, DcnmVotingTimerType, DcnmVotingHundredPercentSettings, Boolean) instead.
See Also

Reference

DcnmVotingSettingsInfo Class
DcnmVotingSettingsInfo Overload


DcnmVotingSettingsInfo Constructor (DcnmVotingAnswerSet, DcnmVotingType, Int32, DcnmVotingTimerType, DcnmVotingHundredPercentSettings, Boolean)

Note: This API is now obsolete.

Initializes instance of the class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingSettingsInfo(
    DcnmVotingAnswerSet votingAnswerSet,
    DcnmVotingType votingType,
    int votingDuration,
    DcnmVotingTimerType votingTimerType,
    DcnmVotingHundredPercentSettings votingHundredPercentSettings,
    bool useVoteWeight
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    votingAnswerSet As DcnmVotingAnswerSet,
    votingType As DcnmVotingType,
    votingDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    votingHundredPercentSettings As DcnmVotingHundredPercentSettings,
    useVoteWeight As Boolean
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingSettingsInfo(
    DcnmVotingAnswerSet votingAnswerSet,
    DcnmVotingType votingType,
    int votingDuration,
    DcnmVotingTimerType votingTimerType,
    DcnmVotingHundredPercentSettings votingHundredPercentSettings,
    bool useVoteWeight
)

Parameters

votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
votingAnswerSet
votingType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingType
The type of voting.
votingDuration
Type: SystemInt32
The voting time duration.
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
The type of voting timer.
votingHundredPercentSettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingHundredPercentSettings
The voting hundred percent settings.
useVoteWeight
Type: SystemBoolean
If this flag is true then use participant vote weight other wise vote weight will be 1.
See Also

Reference

DcnmVotingSettingsInfo Class
DcnmVotingSettingsInfo Overload


DcnmVotingSettingsInfo Constructor (DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingR

DcnmVotingSettingsInfo Constructor (DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting)

 Bosch Logo

Note: This API is now obsolete.

Initializes instance of the class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingSettingsInfo(
    DcnmVotingAnswerSet votingAnswerSet,
    int votingDuration,
    DcnmVotingTimerType votingTimerType,
    bool useVoteWeight,
    bool hideAnswerButton,
    bool usePresentButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVoteMajorityInfo votingMajority,
    DcnmVotingResultDisplaySetting individualVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting totalVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting majorityResultDisplaySettings,
    DcnmVotingResultDisplaySetting individualVoteCastedDisplaySettings,
    DcnmVotingResultDisplaySetting totalVotesCastedDisplaySettings
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    votingAnswerSet As DcnmVotingAnswerSet,
    votingDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    useVoteWeight As Boolean,
    hideAnswerButton As Boolean,
    usePresentButton As Boolean,
    storeVotingResults As DcnmStoreVotingResultType,
    votingMajority As DcnmVoteMajorityInfo,
    individualVoteResultDisplaySettings As DcnmVotingResultDisplaySetting,
    totalVoteResultDisplaySettings As DcnmVotingResultDisplaySetting,
    majorityResultDisplaySettings As DcnmVotingResultDisplaySetting,
    individualVoteCastedDisplaySettings As DcnmVotingResultDisplaySetting,
    totalVotesCastedDisplaySettings As DcnmVotingResultDisplaySetting
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingSettingsInfo(
    DcnmVotingAnswerSet votingAnswerSet,
    int votingDuration,
    DcnmVotingTimerType votingTimerType,
    bool useVoteWeight,
    bool hideAnswerButton,
    bool usePresentButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVoteMajorityInfo^ votingMajority,
    DcnmVotingResultDisplaySetting^ individualVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ totalVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ majorityResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ individualVoteCastedDisplaySettings,
    DcnmVotingResultDisplaySetting^ totalVotesCastedDisplaySettings
)

Parameters

votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
votingAnswerSet
votingDuration
Type: SystemInt32
The voting time duration.
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
The type of voting timer.
useVoteWeight
Type: SystemBoolean
If this flag is true then use participant vote weight other wise vote weight will be 1.
hideAnswerButton
Type: SystemBoolean
If this flag is true then participant can not see casted answer button.
usePresentButton
Type: SystemBoolean
If this flag is true then present button will be enabled for voting round.
storeVotingResults
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStoreVotingResultType
Option to store voting results will be store.DcnmStoreVotingResultType
votingMajority
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVoteMajorityInfo
Indicates whether to use majority in voting round or not
individualVoteResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show individual voting result. DcnmVotingResultDisplaySetting
totalVoteResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show voting total result. DcnmVotingResultDisplaySetting
majorityResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show display majority result. DcnmVotingResultDisplaySetting
individualVoteCastedDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show individual votes cast option. DcnmVotingResultDisplaySetting
totalVotesCastedDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show total votes cast option. DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingSettingsInfo Class
DcnmVotingSettingsInfo Overload


DcnmVotingSettingsInfo Constructor (DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingR

DcnmVotingSettingsInfo Constructor (DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean)

 Bosch Logo

Note: This API is now obsolete.

Initializes instance of the class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingSettingsInfo(
    DcnmVotingAnswerSet votingAnswerSet,
    int votingDuration,
    DcnmVotingTimerType votingTimerType,
    bool useVoteWeight,
    bool hideAnswerButton,
    bool usePresentButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVoteMajorityInfo votingMajority,
    DcnmVotingResultDisplaySetting individualVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting totalVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting majorityResultDisplaySettings,
    DcnmVotingResultDisplaySetting individualVoteCastedDisplaySettings,
    DcnmVotingResultDisplaySetting totalVotesCastedDisplaySettings,
    bool canChangeCastVote
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    votingAnswerSet As DcnmVotingAnswerSet,
    votingDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    useVoteWeight As Boolean,
    hideAnswerButton As Boolean,
    usePresentButton As Boolean,
    storeVotingResults As DcnmStoreVotingResultType,
    votingMajority As DcnmVoteMajorityInfo,
    individualVoteResultDisplaySettings As DcnmVotingResultDisplaySetting,
    totalVoteResultDisplaySettings As DcnmVotingResultDisplaySetting,
    majorityResultDisplaySettings As DcnmVotingResultDisplaySetting,
    individualVoteCastedDisplaySettings As DcnmVotingResultDisplaySetting,
    totalVotesCastedDisplaySettings As DcnmVotingResultDisplaySetting,
    canChangeCastVote As Boolean
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingSettingsInfo(
    DcnmVotingAnswerSet votingAnswerSet,
    int votingDuration,
    DcnmVotingTimerType votingTimerType,
    bool useVoteWeight,
    bool hideAnswerButton,
    bool usePresentButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVoteMajorityInfo^ votingMajority,
    DcnmVotingResultDisplaySetting^ individualVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ totalVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ majorityResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ individualVoteCastedDisplaySettings,
    DcnmVotingResultDisplaySetting^ totalVotesCastedDisplaySettings,
    bool canChangeCastVote
)

Parameters

votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
votingAnswerSet
votingDuration
Type: SystemInt32
The voting time duration.
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
The type of voting timer.
useVoteWeight
Type: SystemBoolean
If this flag is true then use participant vote weight other wise vote weight will be 1.
hideAnswerButton
Type: SystemBoolean
If this flag is true then participant can not see casted answer button.
usePresentButton
Type: SystemBoolean
If this flag is true then present button will be enabled for voting round.
storeVotingResults
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStoreVotingResultType
Option to store voting results will be store.DcnmStoreVotingResultType
votingMajority
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVoteMajorityInfo
Indicates whether to use majority in voting round or not
individualVoteResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show individual voting result. DcnmVotingResultDisplaySetting
totalVoteResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show voting total result. DcnmVotingResultDisplaySetting
majorityResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show display majority result. DcnmVotingResultDisplaySetting
individualVoteCastedDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show individual votes cast option. DcnmVotingResultDisplaySetting
totalVotesCastedDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show total votes cast option. DcnmVotingResultDisplaySetting
canChangeCastVote
Type: SystemBoolean
Flag to indicate whether can change cast vote.
See Also

Reference

DcnmVotingSettingsInfo Class
DcnmVotingSettingsInfo Overload


DcnmVotingSettingsInfo Constructor (DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, DcnmVotingHundredPercentSettings, Boolean, Boolean, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingR

DcnmVotingSettingsInfo Constructor (DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, DcnmVotingHundredPercentSettings, Boolean, Boolean, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmStoreVotingResultType)

 Bosch Logo

Note: This API is now obsolete.

Initializes instance of the class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingSettingsInfo(
    DcnmVotingAnswerSet votingAnswerSet,
    int votingDuration,
    DcnmVotingTimerType votingTimerType,
    DcnmVotingHundredPercentSettings votingHundredPercentSettings,
    bool useVoteWeight,
    bool hideAnswerButton,
    DcnmDisplayVotingResultType displayVotingResultsForParticipants,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForParticipants,
    DcnmDisplayVotingResultType displayVotingResultsForSpecialPermission,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForSpecialPermission,
    DcnmDisplayVotingResultType displayVotingResultsForApi,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForApi,
    DcnmDisplayVotingResultType displayVotingResultForParticipantsWithManageMeetingRights,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForParticipantsWithManageMeetingRights,
    DcnmStoreVotingResultType storeVotingResults
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    votingAnswerSet As DcnmVotingAnswerSet,
    votingDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    votingHundredPercentSettings As DcnmVotingHundredPercentSettings,
    useVoteWeight As Boolean,
    hideAnswerButton As Boolean,
    displayVotingResultsForParticipants As DcnmDisplayVotingResultType,
    displayOnlyTotalResultsForParticipants As DcnmDisplayVotingResultType,
    displayVotingResultsForSpecialPermission As DcnmDisplayVotingResultType,
    displayOnlyTotalResultsForSpecialPermission As DcnmDisplayVotingResultType,
    displayVotingResultsForApi As DcnmDisplayVotingResultType,
    displayOnlyTotalResultsForApi As DcnmDisplayVotingResultType,
    displayVotingResultForParticipantsWithManageMeetingRights As DcnmDisplayVotingResultType,
    displayOnlyTotalResultsForParticipantsWithManageMeetingRights As DcnmDisplayVotingResultType,
    storeVotingResults As DcnmStoreVotingResultType
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingSettingsInfo(
    DcnmVotingAnswerSet votingAnswerSet,
    int votingDuration,
    DcnmVotingTimerType votingTimerType,
    DcnmVotingHundredPercentSettings votingHundredPercentSettings,
    bool useVoteWeight,
    bool hideAnswerButton,
    DcnmDisplayVotingResultType displayVotingResultsForParticipants,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForParticipants,
    DcnmDisplayVotingResultType displayVotingResultsForSpecialPermission,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForSpecialPermission,
    DcnmDisplayVotingResultType displayVotingResultsForApi,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForApi,
    DcnmDisplayVotingResultType displayVotingResultForParticipantsWithManageMeetingRights,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForParticipantsWithManageMeetingRights,
    DcnmStoreVotingResultType storeVotingResults
)

Parameters

votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
votingAnswerSet
votingDuration
Type: SystemInt32
The voting time duration.
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
The type of voting timer.
votingHundredPercentSettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingHundredPercentSettings
The voting hundred percent settings.
useVoteWeight
Type: SystemBoolean
If this flag is true then use participant vote weight other wise vote weight will be 1.
hideAnswerButton
Type: SystemBoolean
If this flag is true then participant can not see casted answer button.
displayVotingResultsForParticipants
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how participants can see individual and group results.
displayOnlyTotalResultsForParticipants
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how participants can see total results. DcnmDisplayVotingResultType
displayVotingResultsForSpecialPermission
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how special permission participants/seats can see individual and group results. DcnmDisplayVotingResultType
displayOnlyTotalResultsForSpecialPermission
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how special permission participants/seats can see total results. DcnmDisplayVotingResultType
displayVotingResultsForApi
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how api systems can see individual and group results. DcnmDisplayVotingResultType
displayOnlyTotalResultsForApi
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how api systems can see total results. DcnmDisplayVotingResultType
displayVotingResultForParticipantsWithManageMeetingRights
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to show voting result for participant with manage meeting rights. DcnmDisplayVotingResultType
displayOnlyTotalResultsForParticipantsWithManageMeetingRights
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to show voting total result for participant with manage meeting rights DcnmDisplayVotingResultType
storeVotingResults
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStoreVotingResultType
Option to store voting results will be store.DcnmStoreVotingResultType
See Also

Reference

DcnmVotingSettingsInfo Class
DcnmVotingSettingsInfo Overload


DcnmVotingSettingsInfo Constructor (DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingR

DcnmVotingSettingsInfo Constructor (DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, Boolean, Boolean, Boolean, DcnmStoreVotingResultType, DcnmVoteMajorityInfo, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean, Boolean, DcnmVotingAnswer)

 Bosch Logo
Initializes instance of the class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingSettingsInfo(
    DcnmVotingAnswerSet votingAnswerSet,
    int votingDuration,
    DcnmVotingTimerType votingTimerType,
    bool useVoteWeight,
    bool hideAnswerButton,
    bool usePresentButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVoteMajorityInfo votingMajority,
    DcnmVotingResultDisplaySetting individualVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting totalVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting majorityResultDisplaySettings,
    DcnmVotingResultDisplaySetting individualVoteCastedDisplaySettings,
    DcnmVotingResultDisplaySetting totalVotesCastedDisplaySettings,
    bool canChangeCastVote,
    bool autoAnswerEnabled,
    DcnmVotingAnswer autoCastVoteAnswer
)
Public Sub New (
    votingAnswerSet As DcnmVotingAnswerSet,
    votingDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    useVoteWeight As Boolean,
    hideAnswerButton As Boolean,
    usePresentButton As Boolean,
    storeVotingResults As DcnmStoreVotingResultType,
    votingMajority As DcnmVoteMajorityInfo,
    individualVoteResultDisplaySettings As DcnmVotingResultDisplaySetting,
    totalVoteResultDisplaySettings As DcnmVotingResultDisplaySetting,
    majorityResultDisplaySettings As DcnmVotingResultDisplaySetting,
    individualVoteCastedDisplaySettings As DcnmVotingResultDisplaySetting,
    totalVotesCastedDisplaySettings As DcnmVotingResultDisplaySetting,
    canChangeCastVote As Boolean,
    autoAnswerEnabled As Boolean,
    autoCastVoteAnswer As DcnmVotingAnswer
)
public:
DcnmVotingSettingsInfo(
    DcnmVotingAnswerSet votingAnswerSet,
    int votingDuration,
    DcnmVotingTimerType votingTimerType,
    bool useVoteWeight,
    bool hideAnswerButton,
    bool usePresentButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVoteMajorityInfo^ votingMajority,
    DcnmVotingResultDisplaySetting^ individualVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ totalVoteResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ majorityResultDisplaySettings,
    DcnmVotingResultDisplaySetting^ individualVoteCastedDisplaySettings,
    DcnmVotingResultDisplaySetting^ totalVotesCastedDisplaySettings,
    bool canChangeCastVote,
    bool autoAnswerEnabled,
    DcnmVotingAnswer autoCastVoteAnswer
)

Parameters

votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
votingAnswerSet
votingDuration
Type: SystemInt32
The voting time duration.
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
The type of voting timer.
useVoteWeight
Type: SystemBoolean
If this flag is true then use participant vote weight other wise vote weight will be 1.
hideAnswerButton
Type: SystemBoolean
If this flag is true then participant can not see casted answer button.
usePresentButton
Type: SystemBoolean
If this flag is true then present button will be enabled for voting round.
storeVotingResults
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStoreVotingResultType
Option to store voting results will be store.DcnmStoreVotingResultType
votingMajority
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVoteMajorityInfo
Indicates whether to use majority in voting round or not
individualVoteResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show individual voting result. DcnmVotingResultDisplaySetting
totalVoteResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show voting total result. DcnmVotingResultDisplaySetting
majorityResultDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show display majority result. DcnmVotingResultDisplaySetting
individualVoteCastedDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show individual votes cast option. DcnmVotingResultDisplaySetting
totalVotesCastedDisplaySettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Options to show total votes cast option. DcnmVotingResultDisplaySetting
canChangeCastVote
Type: SystemBoolean
Flag to indicate whether can change cast vote.
autoAnswerEnabled
Type: SystemBoolean
Flag to indicate whether auto answer is enabled or not.
autoCastVoteAnswer
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswer
Auto answer for vote. when AutoAnswerEnabled is true and no vote was cast upon closing of the voting round.
See Also

Reference

DcnmVotingSettingsInfo Class
DcnmVotingSettingsInfo Overload


DcnmVotingSettingsInfo Properties

The DcnmVotingSettingsInfo type exposes the following members.

Properties
 | Name | Description
Public property | AutoAnswerEnabled | Flag to indicate whether auto answer enabled or not.
Public property | AutoCastVoteAnswer | Auto answer for voting. when AutoAnswerEnabled is true and no vote was cast upon closing of the voting round.
Public property | CanChangeCastVote | Flag to indicate whether vote can be changed after cast.
Public property | DisplayOnlyTotalResultsForApi | Obsolete. Display total results to external system.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForParticipants | Obsolete. Displays total results to participants.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights | Obsolete. Display total results to participants with manage meeting rights.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForSpecialPermission | Obsolete. Display voting total results to VIP.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForApi | Obsolete. Display voting results for external system.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForParticipants | Obsolete. Displays voting results for participants.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForParticipantsWithManageMeetingRights | Obsolete. Display voting individual and group result for participants with manage meeting rights.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForSpecialPermission | Obsolete. Display voting results to VIP.DcnmDisplayVotingResultType
Public property | HideAnswerButton | Flag indicate to hide casted answer.
Public property | IndividualVoteCastedResultDisplaySettings | Options to show individual vote casted.DcnmVotingResultDisplaySetting
Public property | IndividualVoteResultDisplaySettings | Display voting results .DcnmVotingResultDisplaySetting
Public property | MajorityResultDisplaySettings | Option to display majority results.DcnmVotingResultDisplaySetting
Public property | StoreVotingResults | Voting store option.DcnmStoreVotingResultType
Public property | TotalVoteCastedResultDisplaySettings | Options to show total cast vote option.DcnmVotingResultDisplaySetting
Public property | TotalVotesResultDisplaySettings | Display only total results option.DcnmVotingResultDisplaySetting
Public property | TypeOfVoting | The type of voting
Public property | UsePresentButton | Indicates whether to use present button in voting round or not.
Public property | UseVoteWeight | Consider vote weight of participant for this voting round.
Public property | VoteMajority | Option to set majority details.DcnmVoteMajorityInfo
Public property | VotingAnswerSet | Voting answer set Type
Public property | VotingDuration | The voting duration
Public property | VotingHundredPercentSettings | Obsolete. The voting hundred percent settings
Public property | VotingTimerType | The voting timer type
Top
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.AutoAnswerEnabled Property

DcnmVotingSettingsInfoAutoAnswerEnabled Property

Flag to indicate whether auto answer enabled or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AutoAnswerEnabled { get; set; }
Public Property AutoAnswerEnabled As Boolean
    Get
    Set
public:
property bool AutoAnswerEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.AutoCastVoteAnswer Property

DcnmVotingSettingsInfoAutoCastVoteAnswer Property

Auto answer for voting. when AutoAnswerEnabled is true and no vote was cast upon closing of the voting round.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingAnswer AutoCastVoteAnswer { get; }
Public ReadOnly Property AutoCastVoteAnswer As DcnmVotingAnswer
    Get
public:
property DcnmVotingAnswer AutoCastVoteAnswer {
    DcnmVotingAnswer get ();
}

Property Value

Type: DcnmVotingAnswer
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.CanChangeCastVote Property

DcnmVotingSettingsInfoCanChangeCastVote Property

Flag to indicate whether vote can be changed after cast.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanChangeCastVote { get; set; }
Public Property CanChangeCastVote As Boolean
    Get
    Set
public:
property bool CanChangeCastVote {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.DisplayOnlyTotalResultsForApi Property

DcnmVotingSettingsInfoDisplayOnlyTotalResultsForApi Property

Note: This API is now obsolete.

Display total results to external system.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ExternalSystemViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayOnlyTotalResultsForApi { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ExternalSystemViewingOption instead.")>
Public ReadOnly Property DisplayOnlyTotalResultsForApi As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayOnlyTotalResults.ExternalSystemViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayOnlyTotalResultsForApi {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.DisplayOnlyTotalResultsForParticipants Property

DcnmVotingSettingsInfoDisplayOnlyTotalResultsForParticipants Property

Bosch Logo

Note: This API is now obsolete.

Displays total results to participants.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ParticipantViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayOnlyTotalResultsForParticipants { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ParticipantViewingOption instead.")>
Public ReadOnly Property DisplayOnlyTotalResultsForParticipants As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayOnlyTotalResults.ParticipantViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayOnlyTotalResultsForParticipants {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights Property

DcnmVotingSettingsInfoDisplayOnlyTotalResultsForParticipantsWithManageMeetingRights Property

Bosch Logo

Note: This API is now obsolete.

Display total results to participants with manage meeting rights.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ManageMeetingRightsViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ManageMeetingRightsViewingOption instead.")>
Public ReadOnly Property DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayOnlyTotalResults.ManageMeetingRightsViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.DisplayOnlyTotalResultsForSpecialPermission Property

DcnmVotingSettingsInfoDisplayOnlyTotalResultsForSpecialPermission Property

Bosch Logo

Note: This API is now obsolete.

Display voting total results to VIP.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.SpecialPermissionViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayOnlyTotalResultsForSpecialPermission { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.SpecialPermissionViewingOption instead.")>
Public ReadOnly Property DisplayOnlyTotalResultsForSpecialPermission As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayOnlyTotalResults.SpecialPermissionViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayOnlyTotalResultsForSpecialPermission {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.DisplayVotingResultsForApi Property

DcnmVotingSettingsInfoDisplayVotingResultsForApi Property

Note: This API is now obsolete.

Display voting results for external system.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ExternalSystemViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayVotingResultsForApi { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ExternalSystemViewingOption instead.")>
Public ReadOnly Property DisplayVotingResultsForApi As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayIndividualVotingResults.ExternalSystemViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayVotingResultsForApi {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.DisplayVotingResultsForParticipants Property

DcnmVotingSettingsInfoDisplayVotingResultsForParticipants Property

Bosch Logo

Note: This API is now obsolete.

Displays voting results for participants.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ParticipantViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayVotingResultsForParticipants { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ParticipantViewingOption instead.")>
Public ReadOnly Property DisplayVotingResultsForParticipants As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayIndividualVotingResults.ParticipantViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayVotingResultsForParticipants {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.DisplayVotingResultsForParticipantsWithManageMeetingRights Property

DcnmVotingSettingsInfoDisplayVotingResultsForParticipantsWithManageMeetingRights Property

Bosch Logo

Note: This API is now obsolete.

Display voting individual and group result for participants with manage meeting rights.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ManageMeetingRightsViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayVotingResultsForParticipantsWithManageMeetingRights { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ManageMeetingRightsViewingOption instead.")>
Public ReadOnly Property DisplayVotingResultsForParticipantsWithManageMeetingRights As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayIndividualVotingResults.ManageMeetingRightsViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayVotingResultsForParticipantsWithManageMeetingRights {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.DisplayVotingResultsForSpecialPermission Property

DcnmVotingSettingsInfoDisplayVotingResultsForSpecialPermission Property

Bosch Logo

Note: This API is now obsolete.

Display voting results to VIP.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.SpecialPermissionViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayVotingResultsForSpecialPermission { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.SpecialPermissionViewingOption instead.")>
Public ReadOnly Property DisplayVotingResultsForSpecialPermission As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayIndividualVotingResults.SpecialPermissionViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayVotingResultsForSpecialPermission {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.HideAnswerButton Property

DcnmVotingSettingsInfoHideAnswerButton Property

Flag indicate to hide casted answer.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool HideAnswerButton { get; }
Public ReadOnly Property HideAnswerButton As Boolean
    Get
public:
property bool HideAnswerButton {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.IndividualVoteCastedResultDisplaySettings Property

DcnmVotingSettingsInfoIndividualVoteCastedResultDisplaySettings Property

Bosch Logo
Options to show individual vote casted.DcnmVotingResultDisplaySetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResultDisplaySetting IndividualVoteCastedResultDisplaySettings { get; }
Public ReadOnly Property IndividualVoteCastedResultDisplaySettings As DcnmVotingResultDisplaySetting
    Get
public:
property DcnmVotingResultDisplaySetting^ IndividualVoteCastedResultDisplaySettings {
    DcnmVotingResultDisplaySetting^ get ();
}

Property Value

Type: DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.IndividualVoteResultDisplaySettings Property

DcnmVotingSettingsInfoIndividualVoteResultDisplaySettings Property

Bosch Logo
Display voting results .DcnmVotingResultDisplaySetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResultDisplaySetting IndividualVoteResultDisplaySettings { get; }
Public ReadOnly Property IndividualVoteResultDisplaySettings As DcnmVotingResultDisplaySetting
    Get
public:
property DcnmVotingResultDisplaySetting^ IndividualVoteResultDisplaySettings {
    DcnmVotingResultDisplaySetting^ get ();
}

Property Value

Type: DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.MajorityResultDisplaySettings Property

DcnmVotingSettingsInfoMajorityResultDisplaySettings Property

Option to display majority results.DcnmVotingResultDisplaySetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResultDisplaySetting MajorityResultDisplaySettings { get; }
Public ReadOnly Property MajorityResultDisplaySettings As DcnmVotingResultDisplaySetting
    Get
public:
property DcnmVotingResultDisplaySetting^ MajorityResultDisplaySettings {
    DcnmVotingResultDisplaySetting^ get ();
}

Property Value

Type: DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.StoreVotingResults Property

DcnmVotingSettingsInfoStoreVotingResults Property

Voting store option.DcnmStoreVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmStoreVotingResultType StoreVotingResults { get; }
Public ReadOnly Property StoreVotingResults As DcnmStoreVotingResultType
    Get
public:
property DcnmStoreVotingResultType StoreVotingResults {
    DcnmStoreVotingResultType get ();
}

Property Value

Type: DcnmStoreVotingResultType
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.TotalVoteCastedResultDisplaySettings Property

DcnmVotingSettingsInfoTotalVoteCastedResultDisplaySettings Property

Bosch Logo
Options to show total cast vote option.DcnmVotingResultDisplaySetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResultDisplaySetting TotalVoteCastedResultDisplaySettings { get; }
Public ReadOnly Property TotalVoteCastedResultDisplaySettings As DcnmVotingResultDisplaySetting
    Get
public:
property DcnmVotingResultDisplaySetting^ TotalVoteCastedResultDisplaySettings {
    DcnmVotingResultDisplaySetting^ get ();
}

Property Value

Type: DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.TotalVotesResultDisplaySettings Property

DcnmVotingSettingsInfoTotalVotesResultDisplaySettings Property

Bosch Logo
Display only total results option.DcnmVotingResultDisplaySetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResultDisplaySetting TotalVotesResultDisplaySettings { get; }
Public ReadOnly Property TotalVotesResultDisplaySettings As DcnmVotingResultDisplaySetting
    Get
public:
property DcnmVotingResultDisplaySetting^ TotalVotesResultDisplaySettings {
    DcnmVotingResultDisplaySetting^ get ();
}

Property Value

Type: DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.TypeOfVoting Property

DcnmVotingSettingsInfoTypeOfVoting Property

The type of voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingType TypeOfVoting { get; }
Public ReadOnly Property TypeOfVoting As DcnmVotingType
    Get
public:
property DcnmVotingType TypeOfVoting {
    DcnmVotingType get ();
}

Property Value

Type: DcnmVotingType
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.UsePresentButton Property

DcnmVotingSettingsInfoUsePresentButton Property

Indicates whether to use present button in voting round or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool UsePresentButton { get; }
Public ReadOnly Property UsePresentButton As Boolean
    Get
public:
property bool UsePresentButton {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.UseVoteWeight Property

DcnmVotingSettingsInfoUseVoteWeight Property

Consider vote weight of participant for this voting round.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool UseVoteWeight { get; }
Public ReadOnly Property UseVoteWeight As Boolean
    Get
public:
property bool UseVoteWeight {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.VoteMajority Property

DcnmVotingSettingsInfoVoteMajority Property

Option to set majority details.DcnmVoteMajorityInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVoteMajorityInfo VoteMajority { get; }
Public ReadOnly Property VoteMajority As DcnmVoteMajorityInfo
    Get
public:
property DcnmVoteMajorityInfo^ VoteMajority {
    DcnmVoteMajorityInfo^ get ();
}

Property Value

Type: DcnmVoteMajorityInfo
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.VotingAnswerSet Property

DcnmVotingSettingsInfoVotingAnswerSet Property

Voting answer set Type

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingAnswerSet VotingAnswerSet { get; }
Public ReadOnly Property VotingAnswerSet As DcnmVotingAnswerSet
    Get
public:
property DcnmVotingAnswerSet VotingAnswerSet {
    DcnmVotingAnswerSet get ();
}

Property Value

Type: DcnmVotingAnswerSet
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.VotingDuration Property

DcnmVotingSettingsInfoVotingDuration Property

The voting duration

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int VotingDuration { get; }
Public ReadOnly Property VotingDuration As Integer
    Get
public:
property int VotingDuration {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.VotingHundredPercentSettings Property

DcnmVotingSettingsInfoVotingHundredPercentSettings Property

Note: This API is now obsolete.

The voting hundred percent settings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete;")]
public DcnmVotingHundredPercentSettings VotingHundredPercentSettings { get; }
<ObsoleteAttribute("This property is obsolete;")>
Public ReadOnly Property VotingHundredPercentSettings As DcnmVotingHundredPercentSettings
    Get
public:
[ObsoleteAttribute(L"This property is obsolete;")]
property DcnmVotingHundredPercentSettings VotingHundredPercentSettings {
    DcnmVotingHundredPercentSettings get ();
}

Property Value

Type: DcnmVotingHundredPercentSettings
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo.VotingTimerType Property

DcnmVotingSettingsInfoVotingTimerType Property

The voting timer type

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingTimerType VotingTimerType { get; }
Public ReadOnly Property VotingTimerType As DcnmVotingTimerType
    Get
public:
property DcnmVotingTimerType VotingTimerType {
    DcnmVotingTimerType get ();
}

Property Value

Type: DcnmVotingTimerType
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingSettingsInfo Methods

The DcnmVotingSettingsInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmVotingSettingsInfo Class


DcnmVotingState Enumeration

Defines the voting states.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmVotingState
Public Enumeration DcnmVotingState
public enum class DcnmVotingState
Members
Member name | Value | Description
Closed | 0 | Indicates the voting is closed. Initial state of the voting and the result of a voting which was activated and has been deactivated.
Ready | 1 | Indicates the voting is ready. Result of a closed voting which has been activated.
Opened | 2 | Indicates the voting is opened. Result of an activated voting being opened, an on-hold voting that has been resumed or a voting which was done that has been opened again.
OnHold | 3 | Indicates the voting is on hold. Result of an opened voting which is placed on hold.
Done | 4 | Indicates the voting is completed. Result of an open or on-hold voting being closed.
Canceled | 5 | Indicates the voting is canceled. Result of an opened or on-hold voting that has been deactivated.
Accepted | 6 | Indicates the voting is accepted. Result of a voting which is done and the results have been accepted.
Rejected | 7 | Indicates the voting is rejected. Result of a voting which is done and the results have been rejected.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmVotingStatusInfo Class

Container holding the information of a voting.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingStatusInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmVotingStatusInfo
Public Class DcnmVotingStatusInfo
public ref class DcnmVotingStatusInfo

The DcnmVotingStatusInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmVotingStatusInfo(Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, String, IListDcnmVotingAnswer, Int32) | Obsolete. Constructor for the voting status information.
Public method | DcnmVotingStatusInfo(Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, String, DcnmInterimResultType, IListDcnmVotingAnswer, Int32) | Obsolete. Constructor for the voting status information.
Public method | DcnmVotingStatusInfo(Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Int32) | Obsolete. Constructor for the voting status information.
Public method | DcnmVotingStatusInfo(Guid, Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Int32) | Obsolete. Constructor for the voting status information.
Public method | DcnmVotingStatusInfo(Guid, Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, DcnmVotingHundredPercentSettings, Boolean, Int32) | Obsolete. Constructor for the voting status information.
Public method | DcnmVotingStatusInfo(Guid, Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Boolean, Boolean, Int32, Boolean, DcnmStoreVotingResultType, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting) | Obsolete. Constructor for the voting status information.
Public method | DcnmVotingStatusInfo(Guid, Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Boolean, Boolean, Int32, Boolean, DcnmStoreVotingResultType, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean) | Obsolete. Constructor for the voting status information.
Public method | DcnmVotingStatusInfo(Guid, Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, DcnmVotingHundredPercentSettings, Boolean, Int32, Boolean, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmStoreVotingResultType) | Obsolete. Constructor for the voting status information.
Public method | DcnmVotingStatusInfo(Guid, Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Boolean, Boolean, Int32, Boolean, DcnmStoreVotingResultType, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean, Boolean, DcnmVotingAnswer) | Constructor for the voting status information.
Top
Properties
 | Name | Description
Public property | AutoAnswerEnabled | Flag to indicate whether auto answer enabled or not.
Public property | AutoCastVoteAnswer | Auto answer for voting. when AutoAnswerEnabled is true and no vote was cast upon closing of the voting round.
Public property | CanChangeCastVote | Flag to indicate whether vote can be changed after cast.
Public property | Description | The description of the voting.
Public property | DisplayOnlyTotalResultsForApi | Obsolete. Display total results to external system.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForParticipants | Obsolete. Displays total results to particpants.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights | Obsolete. Display total results to particpants with manage meeting rights.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForSpecialPermission | Obsolete. Display voting total results to VIP.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForApi | Obsolete. Display voting results for external system.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForParticipants | Obsolete. Displays voting results for participants.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForParticipantsWithManageMeetingRights | Obsolete. Display voting individual and group result for participants with manage meeting rights.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForSpecialPermission | Obsolete. Display voting results to VIP.DcnmDisplayVotingResultType
Public property | DocumentationLink | The DocumentationLink of the voting.
Public property | HideAnswerButton | Flag indicate to hide casted answer.
Public property | IndividualVoteCastedDisplaySettings | Options to show individual vote casted.DcnmVotingResultDisplaySetting
Public property | IndividualVoteDisplaySettings | Display voting results .DcnmVotingResultDisplaySetting
Public property | MajorityDisplaySettings | Option to display majority results.DcnmVotingResultDisplaySetting
Public property | MeetingId | The ID of the meeting to which this voting is related
Public property | OrderNumber | The order number of the voting.
Public property | ReferenceNumber | The voting reference number.
Public property | RunCount | The run count of the currently active voting.
Public property | State | The state of the voting
Public property | StoreVotingResults | Voting store option.DcnmStoreVotingResultType
Public property | Subject | The subject of the voting.
Public property | TotalVoteDisplaySettings | Display only total results option.DcnmVotingResultDisplaySetting
Public property | TotalVotesCastedDisplaySettings | Options to show total cast vote option.DcnmVotingResultDisplaySetting
Public property | UsePresentButton | Use present button
Public property | UseVoteWeight | Use vote weight.
Public property | VotingAnswers | Collection of voting answers
Public property | VotingAnswerSet | The voting answer set type.
Public property | VotingHundredPercentSettings | Obsolete. The voting hundred percent settings.
Public property | VotingId | The ID of the voting.
Public property | VotingInstanceId | The ID of the voting.
Public property | VotingTimeDuration | Voting time duration
Public property | VotingTimerType | Voting timer type
Public property | VotingType | The type of voting.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmVotingStatusInfo Constructor

Overload List
 | Name | Description
Public method | DcnmVotingStatusInfo(Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, String, IListDcnmVotingAnswer, Int32) | Obsolete. Constructor for the voting status information.
Public method | DcnmVotingStatusInfo(Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, String, DcnmInterimResultType, IListDcnmVotingAnswer, Int32) | Obsolete. Constructor for the voting status information.
Public method | DcnmVotingStatusInfo(Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Int32) | Obsolete. Constructor for the voting status information.
Public method | DcnmVotingStatusInfo(Guid, Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Int32) | Obsolete. Constructor for the voting status information.
Public method | DcnmVotingStatusInfo(Guid, Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, DcnmVotingHundredPercentSettings, Boolean, Int32) | Obsolete. Constructor for the voting status information.
Public method | DcnmVotingStatusInfo(Guid, Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Boolean, Boolean, Int32, Boolean, DcnmStoreVotingResultType, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting) | Obsolete. Constructor for the voting status information.
Public method | DcnmVotingStatusInfo(Guid, Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Boolean, Boolean, Int32, Boolean, DcnmStoreVotingResultType, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean) | Obsolete. Constructor for the voting status information.
Public method | DcnmVotingStatusInfo(Guid, Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, DcnmVotingHundredPercentSettings, Boolean, Int32, Boolean, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmStoreVotingResultType) | Obsolete. Constructor for the voting status information.
Public method | DcnmVotingStatusInfo(Guid, Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Boolean, Boolean, Int32, Boolean, DcnmStoreVotingResultType, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean, Boolean, DcnmVotingAnswer) | Constructor for the voting status information.
Top
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo Constructor (Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, String, IList(DcnmVotingAnswer), Int32)

DcnmVotingStatusInfo Constructor (Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, String, IListDcnmVotingAnswer, Int32)

 Bosch Logo

Note: This API is now obsolete.

Constructor for the voting status information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    DcnmVotingType votingType,
    string referenceNumber,
    string subject,
    string description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    string documentationLink,
    IList<DcnmVotingAnswer> votingAnswers,
    int runCount
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    meetingId As Guid,
    votingId As Guid,
    votingType As DcnmVotingType,
    referenceNumber As String,
    subject As String,
    description As String,
    orderNumber As Integer,
    state As DcnmVotingState,
    votingAnswerSet As DcnmVotingAnswerSet,
    documentationLink As String,
    votingAnswers As IList(Of DcnmVotingAnswer),
    runCount As Integer
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    DcnmVotingType votingType,
    String^ referenceNumber,
    String^ subject,
    String^ description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    String^ documentationLink,
    IList<DcnmVotingAnswer>^ votingAnswers,
    int runCount
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting to which this voting is related.
votingId
Type: SystemGuid
The identifier of the voting.
votingType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingType
The type of voting.
referenceNumber
Type: SystemString
The reference number of the voting.
subject
Type: SystemString
The subject of the voting.
description
Type: SystemString
The description of the voting.
orderNumber
Type: SystemInt32
The order-number of the voting.
state
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingState
The state of the voting.
votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
The voting answer set type
documentationLink
Type: SystemString
Documentation link
votingAnswers
Type: System.Collections.GenericIList DcnmVotingAnswer
The voting answers
runCount
Type: SystemInt32
The run count of the currently active voting.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmVotingStatusInfo(Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Int32) instead.
See Also

Reference

DcnmVotingStatusInfo Class
DcnmVotingStatusInfo Overload


DcnmVotingStatusInfo Constructor (Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, String, DcnmInterimResultType, IList(DcnmVotingAnswer), Int32)

DcnmVotingStatusInfo Constructor (Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, String, DcnmInterimResultType, IListDcnmVotingAnswer, Int32)

 Bosch Logo

Note: This API is now obsolete.

Constructor for the voting status information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    string referenceNumber,
    string subject,
    string description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    string documentationLink,
    DcnmInterimResultType interimResultsType,
    IList<DcnmVotingAnswer> votingAnswers,
    int runCount
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    meetingId As Guid,
    votingId As Guid,
    referenceNumber As String,
    subject As String,
    description As String,
    orderNumber As Integer,
    state As DcnmVotingState,
    votingAnswerSet As DcnmVotingAnswerSet,
    documentationLink As String,
    interimResultsType As DcnmInterimResultType,
    votingAnswers As IList(Of DcnmVotingAnswer),
    runCount As Integer
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    String^ referenceNumber,
    String^ subject,
    String^ description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    String^ documentationLink,
    DcnmInterimResultType interimResultsType,
    IList<DcnmVotingAnswer>^ votingAnswers,
    int runCount
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting to which this voting is related.
votingId
Type: SystemGuid
The identifier of the voting.
referenceNumber
Type: SystemString
The reference number of the voting.
subject
Type: SystemString
The subject of the voting.
description
Type: SystemString
The description of the voting.
orderNumber
Type: SystemInt32
The order-number of the voting.
state
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingState
The state of the voting.
votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
The voting answer set type
documentationLink
Type: SystemString
Documentation link
interimResultsType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterimResultType
Interim vote result type
votingAnswers
Type: System.Collections.GenericIList DcnmVotingAnswer
The voting answers
runCount
Type: SystemInt32
The run count of the currently active voting.
Remarks
This is a deprecated constructor, used for backward compatibility. Use DcnmVotingStatusInfo(Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Int32) instead.
See Also

Reference

DcnmVotingStatusInfo Class
DcnmVotingStatusInfo Overload


DcnmVotingStatusInfo Constructor (Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IList(DcnmVotingAnswer), Int32)

DcnmVotingStatusInfo Constructor (Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Int32)

 Bosch Logo

Note: This API is now obsolete.

Constructor for the voting status information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    DcnmVotingType votingType,
    string referenceNumber,
    string subject,
    string description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    string documentationLink,
    IList<DcnmVotingAnswer> votingAnswers,
    int runCount
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    meetingId As Guid,
    votingId As Guid,
    votingType As DcnmVotingType,
    referenceNumber As String,
    subject As String,
    description As String,
    orderNumber As Integer,
    state As DcnmVotingState,
    votingAnswerSet As DcnmVotingAnswerSet,
    votingTimeDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    documentationLink As String,
    votingAnswers As IList(Of DcnmVotingAnswer),
    runCount As Integer
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    DcnmVotingType votingType,
    String^ referenceNumber,
    String^ subject,
    String^ description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    String^ documentationLink,
    IList<DcnmVotingAnswer>^ votingAnswers,
    int runCount
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting to which this voting is related.
votingId
Type: SystemGuid
The identifier of the voting.
votingType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingType
The type of voting.
referenceNumber
Type: SystemString
The reference number of the voting.
subject
Type: SystemString
The subject of the voting.
description
Type: SystemString
The description of the voting.
orderNumber
Type: SystemInt32
The order-number of the voting.
state
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingState
The state of the voting.
votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
The voting answer set type
votingTimeDuration
Type: SystemInt32
The voting time duration
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
The voting timer type
documentationLink
Type: SystemString
Documentation link
votingAnswers
Type: System.Collections.GenericIList DcnmVotingAnswer
The voting answers
runCount
Type: SystemInt32
The run count of the currently active voting.
Remarks
This is a deprecated constructor, used for backward compatibility.
See Also

Reference

DcnmVotingStatusInfo Class
DcnmVotingStatusInfo Overload


DcnmVotingStatusInfo Constructor (Guid, Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IList(DcnmVotingAnswer), Int32)

DcnmVotingStatusInfo Constructor (Guid, Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Int32)

 Bosch Logo

Note: This API is now obsolete.

Constructor for the voting status information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    Guid votingInstanceId,
    DcnmVotingType votingType,
    string referenceNumber,
    string subject,
    string description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    string documentationLink,
    IList<DcnmVotingAnswer> votingAnswers,
    int runCount
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    meetingId As Guid,
    votingId As Guid,
    votingInstanceId As Guid,
    votingType As DcnmVotingType,
    referenceNumber As String,
    subject As String,
    description As String,
    orderNumber As Integer,
    state As DcnmVotingState,
    votingAnswerSet As DcnmVotingAnswerSet,
    votingTimeDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    documentationLink As String,
    votingAnswers As IList(Of DcnmVotingAnswer),
    runCount As Integer
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    Guid votingInstanceId,
    DcnmVotingType votingType,
    String^ referenceNumber,
    String^ subject,
    String^ description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    String^ documentationLink,
    IList<DcnmVotingAnswer>^ votingAnswers,
    int runCount
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting to which this voting is related.
votingId
Type: SystemGuid
The identifier of the voting.
votingInstanceId
Type: SystemGuid
The voting instance. Updated every time a voting is activated to a new unique Guid
votingType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingType
The type of voting.
referenceNumber
Type: SystemString
The reference number of the voting.
subject
Type: SystemString
The subject of the voting.
description
Type: SystemString
The description of the voting.
orderNumber
Type: SystemInt32
The order-number of the voting.
state
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingState
The state of the voting.
votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
The voting answer set type
votingTimeDuration
Type: SystemInt32
The voting time duration
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
The voting timer type
documentationLink
Type: SystemString
Documentation link
votingAnswers
Type: System.Collections.GenericIList DcnmVotingAnswer
The voting answers
runCount
Type: SystemInt32
The run count of the currently active voting.
Remarks
This is a deprecated constructor, used for backward compatibility.
See Also

Reference

DcnmVotingStatusInfo Class
DcnmVotingStatusInfo Overload


DcnmVotingStatusInfo Constructor (Guid, Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IList(DcnmVotingAnswer), DcnmVotingHundredPercentSettings, Boolean, Int32)

DcnmVotingStatusInfo Constructor (Guid, Guid, Guid, DcnmVotingType, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, DcnmVotingHundredPercentSettings, Boolean, Int32)

 Bosch Logo

Note: This API is now obsolete.

Constructor for the voting status information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    Guid votingInstanceId,
    DcnmVotingType votingType,
    string referenceNumber,
    string subject,
    string description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    string documentationLink,
    IList<DcnmVotingAnswer> votingAnswers,
    DcnmVotingHundredPercentSettings votingHundredPercentSettings,
    bool useVoteWeight,
    int runCount
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    meetingId As Guid,
    votingId As Guid,
    votingInstanceId As Guid,
    votingType As DcnmVotingType,
    referenceNumber As String,
    subject As String,
    description As String,
    orderNumber As Integer,
    state As DcnmVotingState,
    votingAnswerSet As DcnmVotingAnswerSet,
    votingTimeDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    documentationLink As String,
    votingAnswers As IList(Of DcnmVotingAnswer),
    votingHundredPercentSettings As DcnmVotingHundredPercentSettings,
    useVoteWeight As Boolean,
    runCount As Integer
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    Guid votingInstanceId,
    DcnmVotingType votingType,
    String^ referenceNumber,
    String^ subject,
    String^ description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    String^ documentationLink,
    IList<DcnmVotingAnswer>^ votingAnswers,
    DcnmVotingHundredPercentSettings votingHundredPercentSettings,
    bool useVoteWeight,
    int runCount
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting to which this voting is related.
votingId
Type: SystemGuid
The identifier of the voting.
votingInstanceId
Type: SystemGuid
The voting instance. Updated every time a voting is activated to a new unique Guid
votingType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingType
The type of voting.
referenceNumber
Type: SystemString
The reference number of the voting.
subject
Type: SystemString
The subject of the voting.
description
Type: SystemString
The description of the voting.
orderNumber
Type: SystemInt32
The order-number of the voting.
state
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingState
The state of the voting.
votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
The voting answer set type
votingTimeDuration
Type: SystemInt32
The voting time duration
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
The voting timer type
documentationLink
Type: SystemString
Documentation link
votingAnswers
Type: System.Collections.GenericIList DcnmVotingAnswer
The voting answers
votingHundredPercentSettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingHundredPercentSettings
The voting hundred percent settings.
useVoteWeight
Type: SystemBoolean
Flag to indicate whether consider participant vote weight or not.
runCount
Type: SystemInt32
The run count of the currently active voting.
See Also

Reference

DcnmVotingStatusInfo Class
DcnmVotingStatusInfo Overload


DcnmVotingStatusInfo Constructor (Guid, Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IList(DcnmVotingAnswer), Boolean, Boolean, Int32, Boolean, DcnmStoreVotingResultType, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySe

DcnmVotingStatusInfo Constructor (Guid, Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Boolean, Boolean, Int32, Boolean, DcnmStoreVotingResultType, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting)

 Bosch Logo

Note: This API is now obsolete.

Constructor for the voting status information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    Guid votingInstanceId,
    string referenceNumber,
    string subject,
    string description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    string documentationLink,
    IList<DcnmVotingAnswer> votingAnswers,
    bool usePresentButton,
    bool useVoteWeight,
    int runCount,
    bool hideAnswerButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVotingResultDisplaySetting displayIndividualVoteResultSetting,
    DcnmVotingResultDisplaySetting displayOnlyTotalResultSetting,
    DcnmVotingResultDisplaySetting displayMajorityResultSetting,
    DcnmVotingResultDisplaySetting displayIndividualVoteCastResultSetting,
    DcnmVotingResultDisplaySetting displayTotalVoteCastedResultSetting
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    meetingId As Guid,
    votingId As Guid,
    votingInstanceId As Guid,
    referenceNumber As String,
    subject As String,
    description As String,
    orderNumber As Integer,
    state As DcnmVotingState,
    votingAnswerSet As DcnmVotingAnswerSet,
    votingTimeDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    documentationLink As String,
    votingAnswers As IList(Of DcnmVotingAnswer),
    usePresentButton As Boolean,
    useVoteWeight As Boolean,
    runCount As Integer,
    hideAnswerButton As Boolean,
    storeVotingResults As DcnmStoreVotingResultType,
    displayIndividualVoteResultSetting As DcnmVotingResultDisplaySetting,
    displayOnlyTotalResultSetting As DcnmVotingResultDisplaySetting,
    displayMajorityResultSetting As DcnmVotingResultDisplaySetting,
    displayIndividualVoteCastResultSetting As DcnmVotingResultDisplaySetting,
    displayTotalVoteCastedResultSetting As DcnmVotingResultDisplaySetting
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    Guid votingInstanceId,
    String^ referenceNumber,
    String^ subject,
    String^ description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    String^ documentationLink,
    IList<DcnmVotingAnswer>^ votingAnswers,
    bool usePresentButton,
    bool useVoteWeight,
    int runCount,
    bool hideAnswerButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVotingResultDisplaySetting^ displayIndividualVoteResultSetting,
    DcnmVotingResultDisplaySetting^ displayOnlyTotalResultSetting,
    DcnmVotingResultDisplaySetting^ displayMajorityResultSetting,
    DcnmVotingResultDisplaySetting^ displayIndividualVoteCastResultSetting,
    DcnmVotingResultDisplaySetting^ displayTotalVoteCastedResultSetting
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting to which this voting is related.
votingId
Type: SystemGuid
The identifier of the voting.
votingInstanceId
Type: SystemGuid
The voting instance. Updated every time a voting is activated to a new unique Guid
referenceNumber
Type: SystemString
The reference number of the voting.
subject
Type: SystemString
The subject of the voting.
description
Type: SystemString
The description of the voting.
orderNumber
Type: SystemInt32
The order-number of the voting.
state
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingState
The state of the voting.
votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
The voting answer set type
votingTimeDuration
Type: SystemInt32
The voting time duration
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
The voting timer type
documentationLink
Type: SystemString
Documentation link
votingAnswers
Type: System.Collections.GenericIList DcnmVotingAnswer
The voting answers
usePresentButton
Type: SystemBoolean
Flag to indicate whether present button is used in voting or not.
useVoteWeight
Type: SystemBoolean
Flag to indicate whether consider participant vote weight or not.
runCount
Type: SystemInt32
The run count of the currently active voting.
hideAnswerButton
Type: SystemBoolean
If this flag is true then participant can not see casted answer button.
storeVotingResults
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStoreVotingResultType
Option to store voting results will be store.DcnmStoreVotingResultType
displayIndividualVoteResultSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Setting for displaying individual vote results.DcnmVotingResultDisplaySetting
displayOnlyTotalResultSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Setting for displaying only total results.DcnmVotingResultDisplaySetting
displayMajorityResultSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Settings for displaying majority results.DcnmVotingResultDisplaySetting
displayIndividualVoteCastResultSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Settings for display individual vote casted result settingDcnmVotingResultDisplaySetting
displayTotalVoteCastedResultSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Settings for display total vote casted result settingDcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingStatusInfo Class
DcnmVotingStatusInfo Overload


DcnmVotingStatusInfo Constructor (Guid, Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IList(DcnmVotingAnswer), Boolean, Boolean, Int32, Boolean, DcnmStoreVotingResultType, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySe

DcnmVotingStatusInfo Constructor (Guid, Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Boolean, Boolean, Int32, Boolean, DcnmStoreVotingResultType, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean)

 Bosch Logo

Note: This API is now obsolete.

Constructor for the voting status information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    Guid votingInstanceId,
    string referenceNumber,
    string subject,
    string description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    string documentationLink,
    IList<DcnmVotingAnswer> votingAnswers,
    bool usePresentButton,
    bool useVoteWeight,
    int runCount,
    bool hideAnswerButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVotingResultDisplaySetting displayIndividualVoteResultSetting,
    DcnmVotingResultDisplaySetting displayOnlyTotalResultSetting,
    DcnmVotingResultDisplaySetting displayMajorityResultSetting,
    DcnmVotingResultDisplaySetting displayIndividualVoteCastResultSetting,
    DcnmVotingResultDisplaySetting displayTotalVoteCastedResultSetting,
    bool canChangeCastVote
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    meetingId As Guid,
    votingId As Guid,
    votingInstanceId As Guid,
    referenceNumber As String,
    subject As String,
    description As String,
    orderNumber As Integer,
    state As DcnmVotingState,
    votingAnswerSet As DcnmVotingAnswerSet,
    votingTimeDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    documentationLink As String,
    votingAnswers As IList(Of DcnmVotingAnswer),
    usePresentButton As Boolean,
    useVoteWeight As Boolean,
    runCount As Integer,
    hideAnswerButton As Boolean,
    storeVotingResults As DcnmStoreVotingResultType,
    displayIndividualVoteResultSetting As DcnmVotingResultDisplaySetting,
    displayOnlyTotalResultSetting As DcnmVotingResultDisplaySetting,
    displayMajorityResultSetting As DcnmVotingResultDisplaySetting,
    displayIndividualVoteCastResultSetting As DcnmVotingResultDisplaySetting,
    displayTotalVoteCastedResultSetting As DcnmVotingResultDisplaySetting,
    canChangeCastVote As Boolean
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    Guid votingInstanceId,
    String^ referenceNumber,
    String^ subject,
    String^ description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    String^ documentationLink,
    IList<DcnmVotingAnswer>^ votingAnswers,
    bool usePresentButton,
    bool useVoteWeight,
    int runCount,
    bool hideAnswerButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVotingResultDisplaySetting^ displayIndividualVoteResultSetting,
    DcnmVotingResultDisplaySetting^ displayOnlyTotalResultSetting,
    DcnmVotingResultDisplaySetting^ displayMajorityResultSetting,
    DcnmVotingResultDisplaySetting^ displayIndividualVoteCastResultSetting,
    DcnmVotingResultDisplaySetting^ displayTotalVoteCastedResultSetting,
    bool canChangeCastVote
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting to which this voting is related.
votingId
Type: SystemGuid
The identifier of the voting.
votingInstanceId
Type: SystemGuid
The voting instance. Updated every time a voting is activated to a new unique Guid
referenceNumber
Type: SystemString
The reference number of the voting.
subject
Type: SystemString
The subject of the voting.
description
Type: SystemString
The description of the voting.
orderNumber
Type: SystemInt32
The order-number of the voting.
state
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingState
The state of the voting.
votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
The voting answer set type
votingTimeDuration
Type: SystemInt32
The voting time duration
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
The voting timer type
documentationLink
Type: SystemString
Documentation link
votingAnswers
Type: System.Collections.GenericIList DcnmVotingAnswer
The voting answers
usePresentButton
Type: SystemBoolean
Flag to indicate whether present button is used in voting or not.
useVoteWeight
Type: SystemBoolean
Flag to indicate whether consider participant vote weight or not.
runCount
Type: SystemInt32
The run count of the currently active voting.
hideAnswerButton
Type: SystemBoolean
If this flag is true then participant can not see casted answer button.
storeVotingResults
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStoreVotingResultType
Option to store voting results will be store.DcnmStoreVotingResultType
displayIndividualVoteResultSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Setting for displaying individual vote results.DcnmVotingResultDisplaySetting
displayOnlyTotalResultSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Setting for displaying only total results.DcnmVotingResultDisplaySetting
displayMajorityResultSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Settings for displaying majority results.DcnmVotingResultDisplaySetting
displayIndividualVoteCastResultSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Settings for display individual vote casted result settingDcnmVotingResultDisplaySetting
displayTotalVoteCastedResultSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Settings for display total vote casted result settingDcnmVotingResultDisplaySetting
canChangeCastVote
Type: SystemBoolean
Flag to indicate whether can change cast vote.
See Also

Reference

DcnmVotingStatusInfo Class
DcnmVotingStatusInfo Overload


DcnmVotingStatusInfo Constructor (Guid, Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IList(DcnmVotingAnswer), DcnmVotingHundredPercentSettings, Boolean, Int32, Boolean, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, D

DcnmVotingStatusInfo Constructor (Guid, Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, DcnmVotingHundredPercentSettings, Boolean, Int32, Boolean, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmDisplayVotingResultType, DcnmStoreVotingResultType)

 Bosch Logo

Note: This API is now obsolete.

Constructor for the voting status information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the non-obsolete constructor")]
public DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    Guid votingInstanceId,
    string referenceNumber,
    string subject,
    string description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    string documentationLink,
    IList<DcnmVotingAnswer> votingAnswers,
    DcnmVotingHundredPercentSettings votingHundredPercentSettings,
    bool useVoteWeight,
    int runCount,
    bool hideAnswerButton,
    DcnmDisplayVotingResultType displayVotingResultsForParticipants,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForParticipants,
    DcnmDisplayVotingResultType displayVotingResultsForSpecialPermission,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForSpecialPermission,
    DcnmDisplayVotingResultType displayVotingResultsForApi,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForApi,
    DcnmDisplayVotingResultType displayVotingResultForParticipantsWithManageMeetingRights,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForParticipantsWithManageMeetingRights,
    DcnmStoreVotingResultType storeVotingResults
)
<ObsoleteAttribute("Please use the non-obsolete constructor")>
Public Sub New (
    meetingId As Guid,
    votingId As Guid,
    votingInstanceId As Guid,
    referenceNumber As String,
    subject As String,
    description As String,
    orderNumber As Integer,
    state As DcnmVotingState,
    votingAnswerSet As DcnmVotingAnswerSet,
    votingTimeDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    documentationLink As String,
    votingAnswers As IList(Of DcnmVotingAnswer),
    votingHundredPercentSettings As DcnmVotingHundredPercentSettings,
    useVoteWeight As Boolean,
    runCount As Integer,
    hideAnswerButton As Boolean,
    displayVotingResultsForParticipants As DcnmDisplayVotingResultType,
    displayOnlyTotalResultsForParticipants As DcnmDisplayVotingResultType,
    displayVotingResultsForSpecialPermission As DcnmDisplayVotingResultType,
    displayOnlyTotalResultsForSpecialPermission As DcnmDisplayVotingResultType,
    displayVotingResultsForApi As DcnmDisplayVotingResultType,
    displayOnlyTotalResultsForApi As DcnmDisplayVotingResultType,
    displayVotingResultForParticipantsWithManageMeetingRights As DcnmDisplayVotingResultType,
    displayOnlyTotalResultsForParticipantsWithManageMeetingRights As DcnmDisplayVotingResultType,
    storeVotingResults As DcnmStoreVotingResultType
)
public:
[ObsoleteAttribute(L"Please use the non-obsolete constructor")]
DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    Guid votingInstanceId,
    String^ referenceNumber,
    String^ subject,
    String^ description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    String^ documentationLink,
    IList<DcnmVotingAnswer>^ votingAnswers,
    DcnmVotingHundredPercentSettings votingHundredPercentSettings,
    bool useVoteWeight,
    int runCount,
    bool hideAnswerButton,
    DcnmDisplayVotingResultType displayVotingResultsForParticipants,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForParticipants,
    DcnmDisplayVotingResultType displayVotingResultsForSpecialPermission,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForSpecialPermission,
    DcnmDisplayVotingResultType displayVotingResultsForApi,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForApi,
    DcnmDisplayVotingResultType displayVotingResultForParticipantsWithManageMeetingRights,
    DcnmDisplayVotingResultType displayOnlyTotalResultsForParticipantsWithManageMeetingRights,
    DcnmStoreVotingResultType storeVotingResults
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting to which this voting is related.
votingId
Type: SystemGuid
The identifier of the voting.
votingInstanceId
Type: SystemGuid
The voting instance. Updated every time a voting is activated to a new unique Guid
referenceNumber
Type: SystemString
The reference number of the voting.
subject
Type: SystemString
The subject of the voting.
description
Type: SystemString
The description of the voting.
orderNumber
Type: SystemInt32
The order-number of the voting.
state
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingState
The state of the voting.
votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
The voting answer set type
votingTimeDuration
Type: SystemInt32
The voting time duration
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
The voting timer type
documentationLink
Type: SystemString
Documentation link
votingAnswers
Type: System.Collections.GenericIList DcnmVotingAnswer
The voting answers
votingHundredPercentSettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingHundredPercentSettings
The voting hundred percent settings.
useVoteWeight
Type: SystemBoolean
Flag to indicate whether consider participant vote weight or not.
runCount
Type: SystemInt32
The run count of the currently active voting.
hideAnswerButton
Type: SystemBoolean
If this flag is true then participant can not see casted answer button.
displayVotingResultsForParticipants
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how participants can see individual and group results.DcnmDisplayVotingResultType
displayOnlyTotalResultsForParticipants
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how participants can see total results.DcnmDisplayVotingResultType
displayVotingResultsForSpecialPermission
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how vip can see individual and group results.DcnmDisplayVotingResultType
displayOnlyTotalResultsForSpecialPermission
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how vip can see total results.DcnmDisplayVotingResultType
displayVotingResultsForApi
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how external system can see individual and group results.DcnmDisplayVotingResultType
displayOnlyTotalResultsForApi
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to set how external system can see total results.DcnmDisplayVotingResultType
displayVotingResultForParticipantsWithManageMeetingRights
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to show voting result for participant with manage meeting rights. DcnmDisplayVotingResultType
displayOnlyTotalResultsForParticipantsWithManageMeetingRights
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDisplayVotingResultType
Options to show voting total result for participant with manage meeting rights DcnmDisplayVotingResultType
storeVotingResults
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStoreVotingResultType
Option to store voting results will be store.DcnmStoreVotingResultType
See Also

Reference

DcnmVotingStatusInfo Class
DcnmVotingStatusInfo Overload


DcnmVotingStatusInfo Constructor (Guid, Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IList(DcnmVotingAnswer), Boolean, Boolean, Int32, Boolean, DcnmStoreVotingResultType, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySe

DcnmVotingStatusInfo Constructor (Guid, Guid, Guid, String, String, String, Int32, DcnmVotingState, DcnmVotingAnswerSet, Int32, DcnmVotingTimerType, String, IListDcnmVotingAnswer, Boolean, Boolean, Int32, Boolean, DcnmStoreVotingResultType, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, DcnmVotingResultDisplaySetting, Boolean, Boolean, DcnmVotingAnswer)

 Bosch Logo
Constructor for the voting status information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    Guid votingInstanceId,
    string referenceNumber,
    string subject,
    string description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    string documentationLink,
    IList<DcnmVotingAnswer> votingAnswers,
    bool usePresentButton,
    bool useVoteWeight,
    int runCount,
    bool hideAnswerButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVotingResultDisplaySetting displayIndividualVoteResultSetting,
    DcnmVotingResultDisplaySetting displayOnlyTotalResultSetting,
    DcnmVotingResultDisplaySetting displayMajorityResultSetting,
    DcnmVotingResultDisplaySetting displayIndividualVoteCastResultSetting,
    DcnmVotingResultDisplaySetting displayTotalVoteCastedResultSetting,
    bool canChangeCastVote,
    bool autoAnswerEnabled,
    DcnmVotingAnswer autoCastVoteAnswer
)
Public Sub New (
    meetingId As Guid,
    votingId As Guid,
    votingInstanceId As Guid,
    referenceNumber As String,
    subject As String,
    description As String,
    orderNumber As Integer,
    state As DcnmVotingState,
    votingAnswerSet As DcnmVotingAnswerSet,
    votingTimeDuration As Integer,
    votingTimerType As DcnmVotingTimerType,
    documentationLink As String,
    votingAnswers As IList(Of DcnmVotingAnswer),
    usePresentButton As Boolean,
    useVoteWeight As Boolean,
    runCount As Integer,
    hideAnswerButton As Boolean,
    storeVotingResults As DcnmStoreVotingResultType,
    displayIndividualVoteResultSetting As DcnmVotingResultDisplaySetting,
    displayOnlyTotalResultSetting As DcnmVotingResultDisplaySetting,
    displayMajorityResultSetting As DcnmVotingResultDisplaySetting,
    displayIndividualVoteCastResultSetting As DcnmVotingResultDisplaySetting,
    displayTotalVoteCastedResultSetting As DcnmVotingResultDisplaySetting,
    canChangeCastVote As Boolean,
    autoAnswerEnabled As Boolean,
    autoCastVoteAnswer As DcnmVotingAnswer
)
public:
DcnmVotingStatusInfo(
    Guid meetingId,
    Guid votingId,
    Guid votingInstanceId,
    String^ referenceNumber,
    String^ subject,
    String^ description,
    int orderNumber,
    DcnmVotingState state,
    DcnmVotingAnswerSet votingAnswerSet,
    int votingTimeDuration,
    DcnmVotingTimerType votingTimerType,
    String^ documentationLink,
    IList<DcnmVotingAnswer>^ votingAnswers,
    bool usePresentButton,
    bool useVoteWeight,
    int runCount,
    bool hideAnswerButton,
    DcnmStoreVotingResultType storeVotingResults,
    DcnmVotingResultDisplaySetting^ displayIndividualVoteResultSetting,
    DcnmVotingResultDisplaySetting^ displayOnlyTotalResultSetting,
    DcnmVotingResultDisplaySetting^ displayMajorityResultSetting,
    DcnmVotingResultDisplaySetting^ displayIndividualVoteCastResultSetting,
    DcnmVotingResultDisplaySetting^ displayTotalVoteCastedResultSetting,
    bool canChangeCastVote,
    bool autoAnswerEnabled,
    DcnmVotingAnswer autoCastVoteAnswer
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting to which this voting is related.
votingId
Type: SystemGuid
The identifier of the voting.
votingInstanceId
Type: SystemGuid
The voting instance. Updated every time a voting is activated to a new unique Guid
referenceNumber
Type: SystemString
The reference number of the voting.
subject
Type: SystemString
The subject of the voting.
description
Type: SystemString
The description of the voting.
orderNumber
Type: SystemInt32
The order-number of the voting.
state
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingState
The state of the voting.
votingAnswerSet
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswerSet
The voting answer set type
votingTimeDuration
Type: SystemInt32
The voting time duration
votingTimerType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingTimerType
The voting timer type
documentationLink
Type: SystemString
Documentation link
votingAnswers
Type: System.Collections.GenericIList DcnmVotingAnswer
The voting answers
usePresentButton
Type: SystemBoolean
Flag to indicate whether present button is used in voting or not.
useVoteWeight
Type: SystemBoolean
Flag to indicate whether consider participant vote weight or not.
runCount
Type: SystemInt32
The run count of the currently active voting.
hideAnswerButton
Type: SystemBoolean
If this flag is true then participant can not see casted answer button.
storeVotingResults
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmStoreVotingResultType
Option to store voting results will be store.DcnmStoreVotingResultType
displayIndividualVoteResultSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Setting for displaying individual vote results.DcnmVotingResultDisplaySetting
displayOnlyTotalResultSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Setting for displaying only total results.DcnmVotingResultDisplaySetting
displayMajorityResultSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Settings for displaying majority results.DcnmVotingResultDisplaySetting
displayIndividualVoteCastResultSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Settings for display individual vote casted result settingDcnmVotingResultDisplaySetting
displayTotalVoteCastedResultSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingResultDisplaySetting
Settings for display total vote casted result settingDcnmVotingResultDisplaySetting
canChangeCastVote
Type: SystemBoolean
Flag to indicate whether can change cast vote.
autoAnswerEnabled
Type: SystemBoolean
Flag to indicate whether auto answer enabled or not.
autoCastVoteAnswer
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswer
Auto answer for vote. when AutoAnswerEnabled is true and no vote was cast upon closing of the voting round.
See Also

Reference

DcnmVotingStatusInfo Class
DcnmVotingStatusInfo Overload


DcnmVotingStatusInfo Properties

The DcnmVotingStatusInfo type exposes the following members.

Properties
 | Name | Description
Public property | AutoAnswerEnabled | Flag to indicate whether auto answer enabled or not.
Public property | AutoCastVoteAnswer | Auto answer for voting. when AutoAnswerEnabled is true and no vote was cast upon closing of the voting round.
Public property | CanChangeCastVote | Flag to indicate whether vote can be changed after cast.
Public property | Description | The description of the voting.
Public property | DisplayOnlyTotalResultsForApi | Obsolete. Display total results to external system.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForParticipants | Obsolete. Displays total results to particpants.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights | Obsolete. Display total results to particpants with manage meeting rights.DcnmDisplayVotingResultType
Public property | DisplayOnlyTotalResultsForSpecialPermission | Obsolete. Display voting total results to VIP.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForApi | Obsolete. Display voting results for external system.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForParticipants | Obsolete. Displays voting results for participants.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForParticipantsWithManageMeetingRights | Obsolete. Display voting individual and group result for participants with manage meeting rights.DcnmDisplayVotingResultType
Public property | DisplayVotingResultsForSpecialPermission | Obsolete. Display voting results to VIP.DcnmDisplayVotingResultType
Public property | DocumentationLink | The DocumentationLink of the voting.
Public property | HideAnswerButton | Flag indicate to hide casted answer.
Public property | IndividualVoteCastedDisplaySettings | Options to show individual vote casted.DcnmVotingResultDisplaySetting
Public property | IndividualVoteDisplaySettings | Display voting results .DcnmVotingResultDisplaySetting
Public property | MajorityDisplaySettings | Option to display majority results.DcnmVotingResultDisplaySetting
Public property | MeetingId | The ID of the meeting to which this voting is related
Public property | OrderNumber | The order number of the voting.
Public property | ReferenceNumber | The voting reference number.
Public property | RunCount | The run count of the currently active voting.
Public property | State | The state of the voting
Public property | StoreVotingResults | Voting store option.DcnmStoreVotingResultType
Public property | Subject | The subject of the voting.
Public property | TotalVoteDisplaySettings | Display only total results option.DcnmVotingResultDisplaySetting
Public property | TotalVotesCastedDisplaySettings | Options to show total cast vote option.DcnmVotingResultDisplaySetting
Public property | UsePresentButton | Use present button
Public property | UseVoteWeight | Use vote weight.
Public property | VotingAnswers | Collection of voting answers
Public property | VotingAnswerSet | The voting answer set type.
Public property | VotingHundredPercentSettings | Obsolete. The voting hundred percent settings.
Public property | VotingId | The ID of the voting.
Public property | VotingInstanceId | The ID of the voting.
Public property | VotingTimeDuration | Voting time duration
Public property | VotingTimerType | Voting timer type
Public property | VotingType | The type of voting.
Top
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.AutoAnswerEnabled Property

DcnmVotingStatusInfoAutoAnswerEnabled Property

Flag to indicate whether auto answer enabled or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool AutoAnswerEnabled { get; }
Public ReadOnly Property AutoAnswerEnabled As Boolean
    Get
public:
property bool AutoAnswerEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.AutoCastVoteAnswer Property

DcnmVotingStatusInfoAutoCastVoteAnswer Property

Auto answer for voting. when AutoAnswerEnabled is true and no vote was cast upon closing of the voting round.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingAnswer AutoCastVoteAnswer { get; }
Public ReadOnly Property AutoCastVoteAnswer As DcnmVotingAnswer
    Get
public:
property DcnmVotingAnswer AutoCastVoteAnswer {
    DcnmVotingAnswer get ();
}

Property Value

Type: DcnmVotingAnswer
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.CanChangeCastVote Property

DcnmVotingStatusInfoCanChangeCastVote Property

Flag to indicate whether vote can be changed after cast.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool CanChangeCastVote { get; }
Public ReadOnly Property CanChangeCastVote As Boolean
    Get
public:
property bool CanChangeCastVote {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.Description Property

DcnmVotingStatusInfoDescription Property

The description of the voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.DisplayOnlyTotalResultsForApi Property

DcnmVotingStatusInfoDisplayOnlyTotalResultsForApi Property

Note: This API is now obsolete.

Display total results to external system.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ExternalSystemViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayOnlyTotalResultsForApi { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ExternalSystemViewingOption instead.")>
Public ReadOnly Property DisplayOnlyTotalResultsForApi As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayOnlyTotalResults.ExternalSystemViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayOnlyTotalResultsForApi {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.DisplayOnlyTotalResultsForParticipants Property

DcnmVotingStatusInfoDisplayOnlyTotalResultsForParticipants Property

Bosch Logo

Note: This API is now obsolete.

Displays total results to particpants.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ParticipantViewingOption.")]
public DcnmDisplayVotingResultType DisplayOnlyTotalResultsForParticipants { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ParticipantViewingOption.")>
Public ReadOnly Property DisplayOnlyTotalResultsForParticipants As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayOnlyTotalResults.ParticipantViewingOption.")]
property DcnmDisplayVotingResultType DisplayOnlyTotalResultsForParticipants {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights Property

DcnmVotingStatusInfoDisplayOnlyTotalResultsForParticipantsWithManageMeetingRights Property

Bosch Logo

Note: This API is now obsolete.

Display total results to particpants with manage meeting rights.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ManageMeetingRightsViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.ManageMeetingRightsViewingOption instead.")>
Public ReadOnly Property DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayOnlyTotalResults.ManageMeetingRightsViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayOnlyTotalResultsForParticipantsWithManageMeetingRights {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.DisplayOnlyTotalResultsForSpecialPermission Property

DcnmVotingStatusInfoDisplayOnlyTotalResultsForSpecialPermission Property

Bosch Logo

Note: This API is now obsolete.

Display voting total results to VIP.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.SpecialPermissionViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayOnlyTotalResultsForSpecialPermission { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayOnlyTotalResults.SpecialPermissionViewingOption instead.")>
Public ReadOnly Property DisplayOnlyTotalResultsForSpecialPermission As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayOnlyTotalResults.SpecialPermissionViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayOnlyTotalResultsForSpecialPermission {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.DisplayVotingResultsForApi Property

DcnmVotingStatusInfoDisplayVotingResultsForApi Property

Note: This API is now obsolete.

Display voting results for external system.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ExternalSystemViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayVotingResultsForApi { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ExternalSystemViewingOption instead.")>
Public ReadOnly Property DisplayVotingResultsForApi As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayIndividualVotingResults.ExternalSystemViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayVotingResultsForApi {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.DisplayVotingResultsForParticipants Property

DcnmVotingStatusInfoDisplayVotingResultsForParticipants Property

Bosch Logo

Note: This API is now obsolete.

Displays voting results for participants.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ParticipantViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayVotingResultsForParticipants { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ParticipantViewingOption instead.")>
Public ReadOnly Property DisplayVotingResultsForParticipants As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayIndividualVotingResults.ParticipantViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayVotingResultsForParticipants {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.DisplayVotingResultsForParticipantsWithManageMeetingRights Property

DcnmVotingStatusInfoDisplayVotingResultsForParticipantsWithManageMeetingRights Property

Bosch Logo

Note: This API is now obsolete.

Display voting individual and group result for participants with manage meeting rights.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ManageMeetingRightsViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayVotingResultsForParticipantsWithManageMeetingRights { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.ManageMeetingRightsViewingOption instead.")>
Public ReadOnly Property DisplayVotingResultsForParticipantsWithManageMeetingRights As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayIndividualVotingResults.ManageMeetingRightsViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayVotingResultsForParticipantsWithManageMeetingRights {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.DisplayVotingResultsForSpecialPermission Property

DcnmVotingStatusInfoDisplayVotingResultsForSpecialPermission Property

Bosch Logo

Note: This API is now obsolete.

Display voting results to VIP.DcnmDisplayVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.SpecialPermissionViewingOption instead.")]
public DcnmDisplayVotingResultType DisplayVotingResultsForSpecialPermission { get; }
<ObsoleteAttribute("This property is obsolete; please use DisplayIndividualVotingResults.SpecialPermissionViewingOption instead.")>
Public ReadOnly Property DisplayVotingResultsForSpecialPermission As DcnmDisplayVotingResultType
    Get
public:
[ObsoleteAttribute(L"This property is obsolete; please use DisplayIndividualVotingResults.SpecialPermissionViewingOption instead.")]
property DcnmDisplayVotingResultType DisplayVotingResultsForSpecialPermission {
    DcnmDisplayVotingResultType get ();
}

Property Value

Type: DcnmDisplayVotingResultType
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.DocumentationLink Property

DcnmVotingStatusInfoDocumentationLink Property

The DocumentationLink of the voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string DocumentationLink { get; }
Public ReadOnly Property DocumentationLink As String
    Get
public:
property String^ DocumentationLink {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.HideAnswerButton Property

DcnmVotingStatusInfoHideAnswerButton Property

Flag indicate to hide casted answer.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool HideAnswerButton { get; }
Public ReadOnly Property HideAnswerButton As Boolean
    Get
public:
property bool HideAnswerButton {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.IndividualVoteCastedDisplaySettings Property

DcnmVotingStatusInfoIndividualVoteCastedDisplaySettings Property

Bosch Logo
Options to show individual vote casted.DcnmVotingResultDisplaySetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResultDisplaySetting IndividualVoteCastedDisplaySettings { get; }
Public ReadOnly Property IndividualVoteCastedDisplaySettings As DcnmVotingResultDisplaySetting
    Get
public:
property DcnmVotingResultDisplaySetting^ IndividualVoteCastedDisplaySettings {
    DcnmVotingResultDisplaySetting^ get ();
}

Property Value

Type: DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.IndividualVoteDisplaySettings Property

DcnmVotingStatusInfoIndividualVoteDisplaySettings Property

Display voting results .DcnmVotingResultDisplaySetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResultDisplaySetting IndividualVoteDisplaySettings { get; }
Public ReadOnly Property IndividualVoteDisplaySettings As DcnmVotingResultDisplaySetting
    Get
public:
property DcnmVotingResultDisplaySetting^ IndividualVoteDisplaySettings {
    DcnmVotingResultDisplaySetting^ get ();
}

Property Value

Type: DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.MajorityDisplaySettings Property

DcnmVotingStatusInfoMajorityDisplaySettings Property

Option to display majority results.DcnmVotingResultDisplaySetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResultDisplaySetting MajorityDisplaySettings { get; }
Public ReadOnly Property MajorityDisplaySettings As DcnmVotingResultDisplaySetting
    Get
public:
property DcnmVotingResultDisplaySetting^ MajorityDisplaySettings {
    DcnmVotingResultDisplaySetting^ get ();
}

Property Value

Type: DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.MeetingId Property

DcnmVotingStatusInfoMeetingId Property

The ID of the meeting to which this voting is related

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid MeetingId { get; }
Public ReadOnly Property MeetingId As Guid
    Get
public:
property Guid MeetingId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.OrderNumber Property

DcnmVotingStatusInfoOrderNumber Property

The order number of the voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int OrderNumber { get; }
Public ReadOnly Property OrderNumber As Integer
    Get
public:
property int OrderNumber {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.ReferenceNumber Property

DcnmVotingStatusInfoReferenceNumber Property

The voting reference number.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string ReferenceNumber { get; }
Public ReadOnly Property ReferenceNumber As String
    Get
public:
property String^ ReferenceNumber {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.RunCount Property

DcnmVotingStatusInfoRunCount Property

The run count of the currently active voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int RunCount { get; }
Public ReadOnly Property RunCount As Integer
    Get
public:
property int RunCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.State Property

DcnmVotingStatusInfoState Property

The state of the voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingState State { get; }
Public ReadOnly Property State As DcnmVotingState
    Get
public:
property DcnmVotingState State {
    DcnmVotingState get ();
}

Property Value

Type: DcnmVotingState
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.StoreVotingResults Property

DcnmVotingStatusInfoStoreVotingResults Property

Voting store option.DcnmStoreVotingResultType

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmStoreVotingResultType StoreVotingResults { get; }
Public ReadOnly Property StoreVotingResults As DcnmStoreVotingResultType
    Get
public:
property DcnmStoreVotingResultType StoreVotingResults {
    DcnmStoreVotingResultType get ();
}

Property Value

Type: DcnmStoreVotingResultType
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.Subject Property

DcnmVotingStatusInfoSubject Property

The subject of the voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string Subject { get; }
Public ReadOnly Property Subject As String
    Get
public:
property String^ Subject {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.TotalVoteDisplaySettings Property

DcnmVotingStatusInfoTotalVoteDisplaySettings Property

Display only total results option.DcnmVotingResultDisplaySetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResultDisplaySetting TotalVoteDisplaySettings { get; }
Public ReadOnly Property TotalVoteDisplaySettings As DcnmVotingResultDisplaySetting
    Get
public:
property DcnmVotingResultDisplaySetting^ TotalVoteDisplaySettings {
    DcnmVotingResultDisplaySetting^ get ();
}

Property Value

Type: DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.TotalVotesCastedDisplaySettings Property

DcnmVotingStatusInfoTotalVotesCastedDisplaySettings Property

Options to show total cast vote option.DcnmVotingResultDisplaySetting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingResultDisplaySetting TotalVotesCastedDisplaySettings { get; }
Public ReadOnly Property TotalVotesCastedDisplaySettings As DcnmVotingResultDisplaySetting
    Get
public:
property DcnmVotingResultDisplaySetting^ TotalVotesCastedDisplaySettings {
    DcnmVotingResultDisplaySetting^ get ();
}

Property Value

Type: DcnmVotingResultDisplaySetting
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.UsePresentButton Property

DcnmVotingStatusInfoUsePresentButton Property

Use present button

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool UsePresentButton { get; }
Public ReadOnly Property UsePresentButton As Boolean
    Get
public:
property bool UsePresentButton {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.UseVoteWeight Property

DcnmVotingStatusInfoUseVoteWeight Property

Use vote weight.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool UseVoteWeight { get; }
Public ReadOnly Property UseVoteWeight As Boolean
    Get
public:
property bool UseVoteWeight {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.VotingAnswers Property

DcnmVotingStatusInfoVotingAnswers Property

Collection of voting answers

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public IList<DcnmVotingAnswer> VotingAnswers { get; }
Public ReadOnly Property VotingAnswers As IList(Of DcnmVotingAnswer)
    Get
public:
property IList<DcnmVotingAnswer>^ VotingAnswers {
    IList<DcnmVotingAnswer>^ get ();
}

Property Value

Type: IList DcnmVotingAnswer
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.VotingAnswerSet Property

DcnmVotingStatusInfoVotingAnswerSet Property

The voting answer set type.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingAnswerSet VotingAnswerSet { get; }
Public ReadOnly Property VotingAnswerSet As DcnmVotingAnswerSet
    Get
public:
property DcnmVotingAnswerSet VotingAnswerSet {
    DcnmVotingAnswerSet get ();
}

Property Value

Type: DcnmVotingAnswerSet
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.VotingHundredPercentSettings Property

DcnmVotingStatusInfoVotingHundredPercentSettings Property

Note: This API is now obsolete.

The voting hundred percent settings.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is obsolete;")]
public DcnmVotingHundredPercentSettings VotingHundredPercentSettings { get; }
<ObsoleteAttribute("This property is obsolete;")>
Public ReadOnly Property VotingHundredPercentSettings As DcnmVotingHundredPercentSettings
    Get
public:
[ObsoleteAttribute(L"This property is obsolete;")]
property DcnmVotingHundredPercentSettings VotingHundredPercentSettings {
    DcnmVotingHundredPercentSettings get ();
}

Property Value

Type: DcnmVotingHundredPercentSettings
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.VotingId Property

DcnmVotingStatusInfoVotingId Property

The ID of the voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid VotingId { get; }
Public ReadOnly Property VotingId As Guid
    Get
public:
property Guid VotingId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.VotingInstanceId Property

DcnmVotingStatusInfoVotingInstanceId Property

The ID of the voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid VotingInstanceId { get; }
Public ReadOnly Property VotingInstanceId As Guid
    Get
public:
property Guid VotingInstanceId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.VotingTimeDuration Property

DcnmVotingStatusInfoVotingTimeDuration Property

Voting time duration

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int VotingTimeDuration { get; }
Public ReadOnly Property VotingTimeDuration As Integer
    Get
public:
property int VotingTimeDuration {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.VotingTimerType Property

DcnmVotingStatusInfoVotingTimerType Property

Voting timer type

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingTimerType VotingTimerType { get; }
Public ReadOnly Property VotingTimerType As DcnmVotingTimerType
    Get
public:
property DcnmVotingTimerType VotingTimerType {
    DcnmVotingTimerType get ();
}

Property Value

Type: DcnmVotingTimerType
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo.VotingType Property

DcnmVotingStatusInfoVotingType Property

The type of voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVotingType VotingType { get; }
Public ReadOnly Property VotingType As DcnmVotingType
    Get
public:
property DcnmVotingType VotingType {
    DcnmVotingType get ();
}

Property Value

Type: DcnmVotingType
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingStatusInfo Methods

The DcnmVotingStatusInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmVotingStatusInfo Class


DcnmVotingTimerType Enumeration

Type of voting timer.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmVotingTimerType
Public Enumeration DcnmVotingTimerType
public enum class DcnmVotingTimerType
Members
Member name | Value | Description
NoVotingTimer | 0 | No need to use voting timer.
KeepVotingOpen | 1 | Need to keep voting open when voting time is reached.
HoldVotingRound | 2 | Need to hold voting round when voting time is reached..
CloseVotingRound | 3 | Need to close voting round when voting time is reached.
Remarks

A voting round can be configured to be time bound. Below are the details of this configuration. Below are the details of this configuration

  • NoVotingTimer - When a voting is configured with no timer, then that voting is not time bound.
  • KeepVotingOpen - Voting round is time bound. For ex: assume that voting time limit is set to 10 seconds. On reaching 00:00, voting will continue to maintain its state and the timer will start negative countdown. The timer will stop on reaching -09:59 although the voting will continue.
  • HoldVotingRound - Voting round is time bound. On reaching 00:00 the voting round is put on hold and the timer is stopped. To continue the voting round, it need to be resumed manually. The timer will start from 00:00, where it stopped. The timer will continue, if the voting round is not stopped till it reaches -09:59 and then the timer stops. Nevertheless, on reaching -09:59 voting will continue.
  • CloseVotingRound - Voting round is time bound. On reaching 00:00, voting round will be closed.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmVotingType Enumeration

The type of voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmVotingType
Public Enumeration DcnmVotingType
public enum class DcnmVotingType
Members
Member name | Value | Description
OpenWithTotalAndIndividualInterimResults | 0 | The open voting type with total and individual interim results
OpenWithTotalInterimResults | 1 | The open voting type with total interim results
PreventInfluence | 2 | Prevent influencing voting type
SecretBallotWithTotalInterimResults | 3 | The secret voting type with total interim results
SecretBallotWithNoInterimResults | 4 | The secret voting type with no interim results
OpenWithNoInterimResults | 5 | The open voting type with no iterim results
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmVUMeterReadings Class

Implementation of the DcnmVUMeterReadings class.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVUMeterReadings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmVUMeterReadings
Public Class DcnmVUMeterReadings
public ref class DcnmVUMeterReadings

The DcnmVUMeterReadings type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmVUMeterReadings | Initializes a new instance of the DcnmVUMeterReadings class.
Public method | DcnmVUMeterReadings(DictionaryDcnmLevelSensorType, Single) | Initializes a new instance of the DcnmVUMeterReadings class.
Top
Properties
 | Name | Description
Public property | ReadingsDictionary | Dictionary of level readings per sensor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmVUMeterReadings Constructor

Overload List
 | Name | Description
Public method | DcnmVUMeterReadings | Initializes a new instance of the DcnmVUMeterReadings class.
Public method | DcnmVUMeterReadings(DictionaryDcnmLevelSensorType, Single) | Initializes a new instance of the DcnmVUMeterReadings class.
Top
See Also

Reference

DcnmVUMeterReadings Class


DcnmVUMeterReadings Constructor

Initializes a new instance of the DcnmVUMeterReadings class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVUMeterReadings()
Public Sub New
public:
DcnmVUMeterReadings()
See Also

Reference

DcnmVUMeterReadings Class
DcnmVUMeterReadings Overload


DcnmVUMeterReadings Constructor (Dictionary(DcnmLevelSensorType, Single))

DcnmVUMeterReadings Constructor (DictionaryDcnmLevelSensorType, Single)

 Bosch Logo
Initializes a new instance of the DcnmVUMeterReadings class.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmVUMeterReadings(
    Dictionary<DcnmLevelSensorType, float> readingsDictionary
)
Public Sub New (
    readingsDictionary As Dictionary(Of DcnmLevelSensorType, Single)
)
public:
DcnmVUMeterReadings(
    Dictionary<DcnmLevelSensorType, float>^ readingsDictionary
)

Parameters

readingsDictionary
Type: System.Collections.GenericDictionary DcnmLevelSensorType, Single
Dictionary of readings per sensor.
See Also

Reference

DcnmVUMeterReadings Class
DcnmVUMeterReadings Overload


DcnmVUMeterReadings Properties

The DcnmVUMeterReadings type exposes the following members.

Properties
 | Name | Description
Public property | ReadingsDictionary | Dictionary of level readings per sensor
Top
See Also

Reference

DcnmVUMeterReadings Class


DcnmVUMeterReadings.ReadingsDictionary Property

DcnmVUMeterReadingsReadingsDictionary Property

Dictionary of level readings per sensor

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Dictionary<DcnmLevelSensorType, float> ReadingsDictionary { get; }
Public ReadOnly Property ReadingsDictionary As Dictionary(Of DcnmLevelSensorType, Single)
    Get
public:
property Dictionary<DcnmLevelSensorType, float>^ ReadingsDictionary {
    Dictionary<DcnmLevelSensorType, float>^ get ();
}

Property Value

Type: Dictionary DcnmLevelSensorType, Single
See Also

Reference

DcnmVUMeterReadings Class


DcnmVUMeterReadings Methods

The DcnmVUMeterReadings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmVUMeterReadings Class


DcnmWaitingSpeakerInfo Class

Container for the waiting speaker entry.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmWaitingSpeakerInfo

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class DcnmWaitingSpeakerInfo
Public Class DcnmWaitingSpeakerInfo
public ref class DcnmWaitingSpeakerInfo

The DcnmWaitingSpeakerInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DcnmWaitingSpeakerInfo | Default constructor.
Public method | DcnmWaitingSpeakerInfo(Guid, Guid) | Comstructor...
Public method | DcnmWaitingSpeakerInfo(Guid, Int32, Guid, Guid) | Comstructor...
Top
Properties
 | Name | Description
Public property | DiscussionId | The identifier of the discussion of the waiting speaker.
Public property | OrderId | The order of the waiting speaker.
Public property | ParticipantId | The identifier of the associated participant of the waiting speaker.
Public property | WaitingSpeakerId | The identifier of the waiting speaker.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DcnmWaitingSpeakerInfo Constructor

Overload List
 | Name | Description
Public method | DcnmWaitingSpeakerInfo | Default constructor.
Public method | DcnmWaitingSpeakerInfo(Guid, Guid) | Comstructor...
Public method | DcnmWaitingSpeakerInfo(Guid, Int32, Guid, Guid) | Comstructor...
Top
See Also

Reference

DcnmWaitingSpeakerInfo Class


DcnmWaitingSpeakerInfo Constructor

Default constructor.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmWaitingSpeakerInfo()
Public Sub New
public:
DcnmWaitingSpeakerInfo()
See Also

Reference

DcnmWaitingSpeakerInfo Class
DcnmWaitingSpeakerInfo Overload


DcnmWaitingSpeakerInfo Constructor (Guid, Guid)

Comstructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmWaitingSpeakerInfo(
    Guid discussionId,
    Guid participantId
)
Public Sub New (
    discussionId As Guid,
    participantId As Guid
)
public:
DcnmWaitingSpeakerInfo(
    Guid discussionId,
    Guid participantId
)

Parameters

discussionId
Type: SystemGuid
The identifier of the discussion.
participantId
Type: SystemGuid
The identifier of the associated participant.
See Also

Reference

DcnmWaitingSpeakerInfo Class
DcnmWaitingSpeakerInfo Overload


DcnmWaitingSpeakerInfo Constructor (Guid, Int32, Guid, Guid)

Comstructor...

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public DcnmWaitingSpeakerInfo(
    Guid waitingSpeakerId,
    int order,
    Guid discussionId,
    Guid participantId
)
Public Sub New (
    waitingSpeakerId As Guid,
    order As Integer,
    discussionId As Guid,
    participantId As Guid
)
public:
DcnmWaitingSpeakerInfo(
    Guid waitingSpeakerId,
    int order,
    Guid discussionId,
    Guid participantId
)

Parameters

waitingSpeakerId
Type: SystemGuid
The identifier of the waiting speaker.
order
Type: SystemInt32
The order of speaking for the speaker.
discussionId
Type: SystemGuid
The identifier of the discussion.
participantId
Type: SystemGuid
The identifier of the associated participant.
See Also

Reference

DcnmWaitingSpeakerInfo Class
DcnmWaitingSpeakerInfo Overload


DcnmWaitingSpeakerInfo Properties

The DcnmWaitingSpeakerInfo type exposes the following members.

Properties
 | Name | Description
Public property | DiscussionId | The identifier of the discussion of the waiting speaker.
Public property | OrderId | The order of the waiting speaker.
Public property | ParticipantId | The identifier of the associated participant of the waiting speaker.
Public property | WaitingSpeakerId | The identifier of the waiting speaker.
Top
See Also

Reference

DcnmWaitingSpeakerInfo Class


DcnmWaitingSpeakerInfo.DiscussionId Property

DcnmWaitingSpeakerInfoDiscussionId Property

The identifier of the discussion of the waiting speaker.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid DiscussionId { get; }
Public ReadOnly Property DiscussionId As Guid
    Get
public:
property Guid DiscussionId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmWaitingSpeakerInfo Class


DcnmWaitingSpeakerInfo.OrderId Property

DcnmWaitingSpeakerInfoOrderId Property

The order of the waiting speaker.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public int OrderId { get; }
Public ReadOnly Property OrderId As Integer
    Get
public:
property int OrderId {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DcnmWaitingSpeakerInfo Class


DcnmWaitingSpeakerInfo.ParticipantId Property

DcnmWaitingSpeakerInfoParticipantId Property

The identifier of the associated participant of the waiting speaker.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid ParticipantId { get; }
Public ReadOnly Property ParticipantId As Guid
    Get
public:
property Guid ParticipantId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmWaitingSpeakerInfo Class


DcnmWaitingSpeakerInfo.WaitingSpeakerId Property

DcnmWaitingSpeakerInfoWaitingSpeakerId Property

The identifier of the waiting speaker.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public Guid WaitingSpeakerId { get; }
Public ReadOnly Property WaitingSpeakerId As Guid
    Get
public:
property Guid WaitingSpeakerId {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

DcnmWaitingSpeakerInfo Class


DcnmWaitingSpeakerInfo Methods

The DcnmWaitingSpeakerInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DcnmWaitingSpeakerInfo Class


DcnmWebcastingLicense Enumeration

This class contains the webcasting license definitions

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DcnmWebcastingLicense
Public Enumeration DcnmWebcastingLicense
public enum class DcnmWebcastingLicense
Members
Member name | Value | Description
None | 0 | No license
WA | 1 | License for webcasting
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DeviceAttributes Class

The overall set of attributes that can be present at a device.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDeviceAttributes

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static class DeviceAttributes
Public NotInheritable Class DeviceAttributes
public ref class DeviceAttributes abstract sealed

The DeviceAttributes type exposes the following members.

Fields
Name | Description
AutoCreateSeat | Create seat automatically when device is connected
AutoDeviceCleanUp | Remove seat when device disconnects
AutoRemoveSeat | Remove seat automatically when device disconnects
Camera | Groups the camera specific functionality
CameraPanasonic | Panasonic brand camera
CameraSony | Sony brand camera
Delegate | Groups the delegate specific functionality
HideDevice | Hidden device.
HideSeat | Hidden device seat.
HideUnassignedDevice | This attribute when set for the device, will hide the device in the Meeting application, when device is in unassigned state.
IncludesLicenseLSSL | Implicitily includes the LSSL-license already
IncludesLicenseLSVT | Implicitily includes the LSVT-license already
Interpreter | Groups the interpreter specific functionality
InterpreterDante | Interpreters using Dante to externally interface with the system
InterpreterDicentis | Interpreters using DICENTIS interpretation equipment
InterpreterOmneo | Interpreters using OMNEO to externally interface with the system
MayControlVolume | Device enables control volume capablities.
MayPowerOff | Device enables power off capabilities.
Operator | Groups the operator specific functionality
PostponesPlayingWelcomeTone | Supports postponing the playing of the welcome tone until all connected
Remote | Device is remote
RequiresLicenseLSID | Requires the LSID-license from the system
RequiresLicenseLSSL | Requires the LSSL-license from the system
RequiresLicenseLSVT | Requires the LSVT-license from the system
SupportsAudioControl | Device provices audio control (for example APS)
SupportsAutomaticSeating | Supports being automatically assigned a seat
SupportsDuality | Supports the device as having multiple primary instances
SupportsDualUse | Supports dual use at the device
SupportsLanguageDistribution | Device supports language distribution (for example TXO)
SupportsMerge | Supports merging of (audio)
SupportsMultimedia | Device has multimedia capabilities (for example MMD).
SupportsOmneoRouting | Device supports Omneo routing
SupportsOmneoRouting4Or16Channels | Device supports Omneo routing with 4 or 16 channels
SupportsOmneoRouting64Channels | Device supports Omneo routing with 64 channels
SupportsOnvif | Supports ONVIF protocol to interface
SupportsPowerSwitching | Device provides power (for example PS/APS)
SupportsPresentation | Device has presentation capabilities.
SupportsPTZ | Device support PTZ (for example PTZ Onvif camera)
SupportsRostrum | Supports the device to be combined into a rostrum seat
SupportsSeating | Supports being at a seat in a conference room or booth
SupportsSpeaking | Supports providing speech through a microphone
SupportsVideo | Supports video capabilities at the device
SupportsVideoStreaming | Device provides video streaming
SupportsVideoSwitching | Device supports video switching (for example videoswitch device)
VirtualDevice | Device is a virtual device.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DeviceAttributes Fields

The DeviceAttributes type exposes the following members.

Fields
Name | Description
AutoCreateSeat | Create seat automatically when device is connected
AutoDeviceCleanUp | Remove seat when device disconnects
AutoRemoveSeat | Remove seat automatically when device disconnects
Camera | Groups the camera specific functionality
CameraPanasonic | Panasonic brand camera
CameraSony | Sony brand camera
Delegate | Groups the delegate specific functionality
HideDevice | Hidden device.
HideSeat | Hidden device seat.
HideUnassignedDevice | This attribute when set for the device, will hide the device in the Meeting application, when device is in unassigned state.
IncludesLicenseLSSL | Implicitily includes the LSSL-license already
IncludesLicenseLSVT | Implicitily includes the LSVT-license already
Interpreter | Groups the interpreter specific functionality
InterpreterDante | Interpreters using Dante to externally interface with the system
InterpreterDicentis | Interpreters using DICENTIS interpretation equipment
InterpreterOmneo | Interpreters using OMNEO to externally interface with the system
MayControlVolume | Device enables control volume capablities.
MayPowerOff | Device enables power off capabilities.
Operator | Groups the operator specific functionality
PostponesPlayingWelcomeTone | Supports postponing the playing of the welcome tone until all connected
Remote | Device is remote
RequiresLicenseLSID | Requires the LSID-license from the system
RequiresLicenseLSSL | Requires the LSSL-license from the system
RequiresLicenseLSVT | Requires the LSVT-license from the system
SupportsAudioControl | Device provices audio control (for example APS)
SupportsAutomaticSeating | Supports being automatically assigned a seat
SupportsDuality | Supports the device as having multiple primary instances
SupportsDualUse | Supports dual use at the device
SupportsLanguageDistribution | Device supports language distribution (for example TXO)
SupportsMerge | Supports merging of (audio)
SupportsMultimedia | Device has multimedia capabilities (for example MMD).
SupportsOmneoRouting | Device supports Omneo routing
SupportsOmneoRouting4Or16Channels | Device supports Omneo routing with 4 or 16 channels
SupportsOmneoRouting64Channels | Device supports Omneo routing with 64 channels
SupportsOnvif | Supports ONVIF protocol to interface
SupportsPowerSwitching | Device provides power (for example PS/APS)
SupportsPresentation | Device has presentation capabilities.
SupportsPTZ | Device support PTZ (for example PTZ Onvif camera)
SupportsRostrum | Supports the device to be combined into a rostrum seat
SupportsSeating | Supports being at a seat in a conference room or booth
SupportsSpeaking | Supports providing speech through a microphone
SupportsVideo | Supports video capabilities at the device
SupportsVideoStreaming | Device provides video streaming
SupportsVideoSwitching | Device supports video switching (for example videoswitch device)
VirtualDevice | Device is a virtual device.
Top
See Also

Reference

DeviceAttributes Class


DeviceAttributes.AutoCreateSeat Field

DeviceAttributesAutoCreateSeat Field

Create seat automatically when device is connected

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string AutoCreateSeat = "AutoCreateSeat"
Public Const AutoCreateSeat As String = "AutoCreateSeat"
public:
literal String^ AutoCreateSeat = "AutoCreateSeat"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.AutoDeviceCleanUp Field

DeviceAttributesAutoDeviceCleanUp Field

Remove seat when device disconnects

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string AutoDeviceCleanUp = "AutoDeviceCleanUp"
Public Const AutoDeviceCleanUp As String = "AutoDeviceCleanUp"
public:
literal String^ AutoDeviceCleanUp = "AutoDeviceCleanUp"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.AutoRemoveSeat Field

DeviceAttributesAutoRemoveSeat Field

Remove seat automatically when device disconnects

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string AutoRemoveSeat = "AutoRemoveSeat"
Public Const AutoRemoveSeat As String = "AutoRemoveSeat"
public:
literal String^ AutoRemoveSeat = "AutoRemoveSeat"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.Camera Field

DeviceAttributesCamera Field

Groups the camera specific functionality

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string Camera = "Camera"
Public Const Camera As String = "Camera"
public:
literal String^ Camera = "Camera"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.CameraPanasonic Field

DeviceAttributesCameraPanasonic Field

Panasonic brand camera

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string CameraPanasonic = "CameraPanasonic"
Public Const CameraPanasonic As String = "CameraPanasonic"
public:
literal String^ CameraPanasonic = "CameraPanasonic"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.CameraSony Field

DeviceAttributesCameraSony Field

Sony brand camera

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string CameraSony = "CameraSony"
Public Const CameraSony As String = "CameraSony"
public:
literal String^ CameraSony = "CameraSony"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.Delegate Field

DeviceAttributesDelegate Field

Groups the delegate specific functionality

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string Delegate = "Delegate"
Public Const Delegate As String = "Delegate"
public:
literal String^ Delegate = "Delegate"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.HideDevice Field

DeviceAttributesHideDevice Field

Hidden device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string HideDevice = "HideDevice"
Public Const HideDevice As String = "HideDevice"
public:
literal String^ HideDevice = "HideDevice"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.HideSeat Field

DeviceAttributesHideSeat Field

Hidden device seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string HideSeat = "HideSeat"
Public Const HideSeat As String = "HideSeat"
public:
literal String^ HideSeat = "HideSeat"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.HideUnassignedDevice Field

DeviceAttributesHideUnassignedDevice Field

This attribute when set for the device, will hide the device in the Meeting application, when device is in unassigned state.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string HideUnassignedDevice = "HideUnassignedDevice"
Public Const HideUnassignedDevice As String = "HideUnassignedDevice"
public:
literal String^ HideUnassignedDevice = "HideUnassignedDevice"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.IncludesLicenseLSSL Field

DeviceAttributesIncludesLicenseLSSL Field

Implicitily includes the LSSL-license already

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string IncludesLicenseLSSL = "IncludesLicenseLSSL"
Public Const IncludesLicenseLSSL As String = "IncludesLicenseLSSL"
public:
literal String^ IncludesLicenseLSSL = "IncludesLicenseLSSL"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.IncludesLicenseLSVT Field

DeviceAttributesIncludesLicenseLSVT Field

Implicitily includes the LSVT-license already

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string IncludesLicenseLSVT = "IncludesLicenseLSVT"
Public Const IncludesLicenseLSVT As String = "IncludesLicenseLSVT"
public:
literal String^ IncludesLicenseLSVT = "IncludesLicenseLSVT"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.Interpreter Field

DeviceAttributesInterpreter Field

Groups the interpreter specific functionality

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string Interpreter = "Interpreter"
Public Const Interpreter As String = "Interpreter"
public:
literal String^ Interpreter = "Interpreter"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.InterpreterDante Field

DeviceAttributesInterpreterDante Field

Interpreters using Dante to externally interface with the system

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string InterpreterDante = "InterpreterDante"
Public Const InterpreterDante As String = "InterpreterDante"
public:
literal String^ InterpreterDante = "InterpreterDante"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.InterpreterDicentis Field

DeviceAttributesInterpreterDicentis Field

Interpreters using DICENTIS interpretation equipment

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string InterpreterDicentis = "InterpreterDicentis"
Public Const InterpreterDicentis As String = "InterpreterDicentis"
public:
literal String^ InterpreterDicentis = "InterpreterDicentis"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.InterpreterOmneo Field

DeviceAttributesInterpreterOmneo Field

Interpreters using OMNEO to externally interface with the system

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string InterpreterOmneo = "InterpreterOmneo"
Public Const InterpreterOmneo As String = "InterpreterOmneo"
public:
literal String^ InterpreterOmneo = "InterpreterOmneo"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.MayControlVolume Field

DeviceAttributesMayControlVolume Field

Device enables control volume capablities.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string MayControlVolume = "MayControlVolume"
Public Const MayControlVolume As String = "MayControlVolume"
public:
literal String^ MayControlVolume = "MayControlVolume"

Field Value

Type: String
Remarks
Note: If the 3rd party application wants to Control Volume of the system, it should enable this attribute, so that the option can be seen and enabled in meeting application.
See Also

Reference

DeviceAttributes Class


DeviceAttributes.MayPowerOff Field

DeviceAttributesMayPowerOff Field

Device enables power off capabilities.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string MayPowerOff = "MayPowerOff"
Public Const MayPowerOff As String = "MayPowerOff"
public:
literal String^ MayPowerOff = "MayPowerOff"

Field Value

Type: String
Remarks
Note: If the 3rd party application wants to power off the system, it should enable this attribute, so that the option can be seen and enabled in meeting application.
See Also

Reference

DeviceAttributes Class


DeviceAttributes.Operator Field

DeviceAttributesOperator Field

Groups the operator specific functionality

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string Operator = "Operator"
Public Const Operator As String = "Operator"
public:
literal String^ Operator = "Operator"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.PostponesPlayingWelcomeTone Field

DeviceAttributesPostponesPlayingWelcomeTone Field

Supports postponing the playing of the welcome tone until all connected

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string PostponesPlayingWelcomeTone = "PostponesPlayingWelcomeTone"
Public Const PostponesPlayingWelcomeTone As String = "PostponesPlayingWelcomeTone"
public:
literal String^ PostponesPlayingWelcomeTone = "PostponesPlayingWelcomeTone"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.Remote Field

DeviceAttributesRemote Field

Device is remote

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string Remote = "Remote"
Public Const Remote As String = "Remote"
public:
literal String^ Remote = "Remote"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.RequiresLicenseLSID Field

DeviceAttributesRequiresLicenseLSID Field

Requires the LSID-license from the system

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string RequiresLicenseLSID = "RequiresLicenseLSID"
Public Const RequiresLicenseLSID As String = "RequiresLicenseLSID"
public:
literal String^ RequiresLicenseLSID = "RequiresLicenseLSID"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.RequiresLicenseLSSL Field

DeviceAttributesRequiresLicenseLSSL Field

Requires the LSSL-license from the system

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string RequiresLicenseLSSL = "RequiresLicenseLSSL"
Public Const RequiresLicenseLSSL As String = "RequiresLicenseLSSL"
public:
literal String^ RequiresLicenseLSSL = "RequiresLicenseLSSL"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.RequiresLicenseLSVT Field

DeviceAttributesRequiresLicenseLSVT Field

Requires the LSVT-license from the system

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string RequiresLicenseLSVT = "RequiresLicenseLSVT"
Public Const RequiresLicenseLSVT As String = "RequiresLicenseLSVT"
public:
literal String^ RequiresLicenseLSVT = "RequiresLicenseLSVT"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsAudioControl Field

DeviceAttributesSupportsAudioControl Field

Device provices audio control (for example APS)

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsAudioControl = "SupportsAudioControl"
Public Const SupportsAudioControl As String = "SupportsAudioControl"
public:
literal String^ SupportsAudioControl = "SupportsAudioControl"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsAutomaticSeating Field

DeviceAttributesSupportsAutomaticSeating Field

Supports being automatically assigned a seat

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsAutomaticSeating = "SupportsAutomaticSeating"
Public Const SupportsAutomaticSeating As String = "SupportsAutomaticSeating"
public:
literal String^ SupportsAutomaticSeating = "SupportsAutomaticSeating"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsDuality Field

DeviceAttributesSupportsDuality Field

Supports the device as having multiple primary instances

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsDuality = "SupportsDuality"
Public Const SupportsDuality As String = "SupportsDuality"
public:
literal String^ SupportsDuality = "SupportsDuality"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsDualUse Field

DeviceAttributesSupportsDualUse Field

Supports dual use at the device

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsDualUse = "SupportsDualUse"
Public Const SupportsDualUse As String = "SupportsDualUse"
public:
literal String^ SupportsDualUse = "SupportsDualUse"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsLanguageDistribution Field

DeviceAttributesSupportsLanguageDistribution Field

Device supports language distribution (for example TXO)

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsLanguageDistribution = "SupportsLanguageDistribution"
Public Const SupportsLanguageDistribution As String = "SupportsLanguageDistribution"
public:
literal String^ SupportsLanguageDistribution = "SupportsLanguageDistribution"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsMerge Field

DeviceAttributesSupportsMerge Field

Supports merging of (audio)

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsMerge = "SupportsMerge"
Public Const SupportsMerge As String = "SupportsMerge"
public:
literal String^ SupportsMerge = "SupportsMerge"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsMultimedia Field

DeviceAttributesSupportsMultimedia Field

Device has multimedia capabilities (for example MMD).

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsMultimedia = "SupportsMultimedia"
Public Const SupportsMultimedia As String = "SupportsMultimedia"
public:
literal String^ SupportsMultimedia = "SupportsMultimedia"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsOmneoRouting Field

DeviceAttributesSupportsOmneoRouting Field

Device supports Omneo routing

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsOmneoRouting = "SupportsOmneoRouting"
Public Const SupportsOmneoRouting As String = "SupportsOmneoRouting"
public:
literal String^ SupportsOmneoRouting = "SupportsOmneoRouting"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsOmneoRouting4Or16Channels Field

DeviceAttributesSupportsOmneoRouting4Or16Channels Field

Device supports Omneo routing with 4 or 16 channels

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsOmneoRouting4Or16Channels = "SupportsOmneoRouting4Or16Channels"
Public Const SupportsOmneoRouting4Or16Channels As String = "SupportsOmneoRouting4Or16Channels"
public:
literal String^ SupportsOmneoRouting4Or16Channels = "SupportsOmneoRouting4Or16Channels"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsOmneoRouting64Channels Field

DeviceAttributesSupportsOmneoRouting64Channels Field

Device supports Omneo routing with 64 channels

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsOmneoRouting64Channels = "SupportsOmneoRouting64Channels"
Public Const SupportsOmneoRouting64Channels As String = "SupportsOmneoRouting64Channels"
public:
literal String^ SupportsOmneoRouting64Channels = "SupportsOmneoRouting64Channels"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsOnvif Field

DeviceAttributesSupportsOnvif Field

Supports ONVIF protocol to interface

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsOnvif = "SupportsOnvif"
Public Const SupportsOnvif As String = "SupportsOnvif"
public:
literal String^ SupportsOnvif = "SupportsOnvif"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsPowerSwitching Field

DeviceAttributesSupportsPowerSwitching Field

Device provides power (for example PS/APS)

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsPowerSwitching = "SupportsPowerSwitching"
Public Const SupportsPowerSwitching As String = "SupportsPowerSwitching"
public:
literal String^ SupportsPowerSwitching = "SupportsPowerSwitching"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsPresentation Field

DeviceAttributesSupportsPresentation Field

Device has presentation capabilities.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsPresentation = "SupportsPresentation"
Public Const SupportsPresentation As String = "SupportsPresentation"
public:
literal String^ SupportsPresentation = "SupportsPresentation"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsPTZ Field

DeviceAttributesSupportsPTZ Field

Device support PTZ (for example PTZ Onvif camera)

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsPTZ = "SupportsPTZ"
Public Const SupportsPTZ As String = "SupportsPTZ"
public:
literal String^ SupportsPTZ = "SupportsPTZ"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsRostrum Field

DeviceAttributesSupportsRostrum Field

Supports the device to be combined into a rostrum seat

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsRostrum = "SupportsRostrum"
Public Const SupportsRostrum As String = "SupportsRostrum"
public:
literal String^ SupportsRostrum = "SupportsRostrum"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsSeating Field

DeviceAttributesSupportsSeating Field

Supports being at a seat in a conference room or booth

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsSeating = "SupportsSeating"
Public Const SupportsSeating As String = "SupportsSeating"
public:
literal String^ SupportsSeating = "SupportsSeating"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsSpeaking Field

DeviceAttributesSupportsSpeaking Field

Supports providing speech through a microphone

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsSpeaking = "SupportsSpeaking"
Public Const SupportsSpeaking As String = "SupportsSpeaking"
public:
literal String^ SupportsSpeaking = "SupportsSpeaking"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsVideo Field

DeviceAttributesSupportsVideo Field

Supports video capabilities at the device

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsVideo = "SupportsVideo"
Public Const SupportsVideo As String = "SupportsVideo"
public:
literal String^ SupportsVideo = "SupportsVideo"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsVideoStreaming Field

DeviceAttributesSupportsVideoStreaming Field

Device provides video streaming

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsVideoStreaming = "SupportsVideoStreaming"
Public Const SupportsVideoStreaming As String = "SupportsVideoStreaming"
public:
literal String^ SupportsVideoStreaming = "SupportsVideoStreaming"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.SupportsVideoSwitching Field

DeviceAttributesSupportsVideoSwitching Field

Device supports video switching (for example videoswitch device)

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string SupportsVideoSwitching = "SupportsVideoSwitching"
Public Const SupportsVideoSwitching As String = "SupportsVideoSwitching"
public:
literal String^ SupportsVideoSwitching = "SupportsVideoSwitching"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceAttributes.VirtualDevice Field

DeviceAttributesVirtualDevice Field

Device is a virtual device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const string VirtualDevice = "VirtualDevice"
Public Const VirtualDevice As String = "VirtualDevice"
public:
literal String^ VirtualDevice = "VirtualDevice"

Field Value

Type: String
See Also

Reference

DeviceAttributes Class


DeviceInstanceNames Enumeration

The different device instance names supported by the Dcnm system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public enum DeviceInstanceNames
Public Enumeration DeviceInstanceNames
public enum class DeviceInstanceNames
Members
Member name | Value | Description
FirstInstancePrimary | 0 | Used to indicate first instance primary.
FirstInstanceSecondary | 1 | Used to indicate first instance secondary.
SecondInstancePrimary | 2 | Used to indicate second instance primary.
SecondInstanceSecondary | 3 | Used to indicate second instance secondary.
RightInstance | 0 | Used to indicate right instance.
LeftInstance | 1 | Used to indicate left instance.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DiscussionConstants Class

The supported discussion constants
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesDiscussionConstants

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static class DiscussionConstants
Public NotInheritable Class DiscussionConstants
public ref class DiscussionConstants abstract sealed

The DiscussionConstants type exposes the following members.

Fields
Name | Description
DEFAULT_ATTACK_TIME_DURATION | Default attack time value
DEFAULT_DISCUSSION_ID | The default discussion ID.
DEFAULT_RELEASE_TIME_DURATION | Default release time value
DEFAULT_SHOW_MIC_LED_IN_VOICE_MODE | Default flag to show mic led in voice mode
DEFAULT_SHOW_SPEAKER_IN_VOICE_MODE | Default flag to show speaker in voice mode
DISCUSS_DEFAULT_OPEN_MICROPHONES | Default value for number of open microphones
DISCUSS_DEFAULT_REQUESTS | Default value for number of requests
DISCUSS_MAX_OPEN_MICROPHONES | Maximum value for number of open microphones
DISCUSS_MAX_REQUESTS | Maximum value for number of requests
DISCUSS_MAX_RESPONSES | Maximum value for number of responses
DISCUSS_MIN_OPEN_MICROPHONES | Minimum value for number of open microphones
DISCUSS_MIN_REQUESTS | Minimum value for number of requests
DISCUSS_MIN_RESPONSES | Minimum value for number of responses
MAXIMUM_ATTACK_TIME_DURATION | Maximum attack time value
MAXIMUM_RELEASE_TIME_DURATION | Maximum release time value
MINIMUM_ATTACK_TIME_DURATION | Minimum attack time value
MINIMUM_RELEASE_TIME_DURATION | Minimum release time value
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


DiscussionConstants Fields

The DiscussionConstants type exposes the following members.

Fields
Name | Description
DEFAULT_ATTACK_TIME_DURATION | Default attack time value
DEFAULT_DISCUSSION_ID | The default discussion ID.
DEFAULT_RELEASE_TIME_DURATION | Default release time value
DEFAULT_SHOW_MIC_LED_IN_VOICE_MODE | Default flag to show mic led in voice mode
DEFAULT_SHOW_SPEAKER_IN_VOICE_MODE | Default flag to show speaker in voice mode
DISCUSS_DEFAULT_OPEN_MICROPHONES | Default value for number of open microphones
DISCUSS_DEFAULT_REQUESTS | Default value for number of requests
DISCUSS_MAX_OPEN_MICROPHONES | Maximum value for number of open microphones
DISCUSS_MAX_REQUESTS | Maximum value for number of requests
DISCUSS_MAX_RESPONSES | Maximum value for number of responses
DISCUSS_MIN_OPEN_MICROPHONES | Minimum value for number of open microphones
DISCUSS_MIN_REQUESTS | Minimum value for number of requests
DISCUSS_MIN_RESPONSES | Minimum value for number of responses
MAXIMUM_ATTACK_TIME_DURATION | Maximum attack time value
MAXIMUM_RELEASE_TIME_DURATION | Maximum release time value
MINIMUM_ATTACK_TIME_DURATION | Minimum attack time value
MINIMUM_RELEASE_TIME_DURATION | Minimum release time value
Top
See Also

Reference

DiscussionConstants Class


DiscussionConstants.DEFAULT_ATTACK_TIME_DURATION Field

DiscussionConstantsDEFAULT_ATTACK_TIME_DURATION Field

Default attack time value

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DEFAULT_ATTACK_TIME_DURATION = 2000
Public Const DEFAULT_ATTACK_TIME_DURATION As Integer = 2000
public:
literal int DEFAULT_ATTACK_TIME_DURATION = 2000

Field Value

Type: Int32
See Also

Reference

DiscussionConstants Class


DiscussionConstants.DEFAULT_DISCUSSION_ID Field

DiscussionConstantsDEFAULT_DISCUSSION_ID Field

The default discussion ID.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static readonly Guid DEFAULT_DISCUSSION_ID
Public Shared ReadOnly DEFAULT_DISCUSSION_ID As Guid
public:
static initonly Guid DEFAULT_DISCUSSION_ID

Field Value

Type: Guid
See Also

Reference

DiscussionConstants Class


DiscussionConstants.DEFAULT_RELEASE_TIME_DURATION Field

DiscussionConstantsDEFAULT_RELEASE_TIME_DURATION Field

Default release time value

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DEFAULT_RELEASE_TIME_DURATION = 500
Public Const DEFAULT_RELEASE_TIME_DURATION As Integer = 500
public:
literal int DEFAULT_RELEASE_TIME_DURATION = 500

Field Value

Type: Int32
See Also

Reference

DiscussionConstants Class


DiscussionConstants.DEFAULT_SHOW_MIC_LED_IN_VOICE_MODE Field

DiscussionConstantsDEFAULT_SHOW_MIC_LED_IN_VOICE_MODE Field

Default flag to show mic led in voice mode

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DEFAULT_SHOW_MIC_LED_IN_VOICE_MODE = false
Public Const DEFAULT_SHOW_MIC_LED_IN_VOICE_MODE As Boolean = False
public:
literal bool DEFAULT_SHOW_MIC_LED_IN_VOICE_MODE = false

Field Value

Type: Boolean
See Also

Reference

DiscussionConstants Class


DiscussionConstants.DEFAULT_SHOW_SPEAKER_IN_VOICE_MODE Field

DiscussionConstantsDEFAULT_SHOW_SPEAKER_IN_VOICE_MODE Field

Default flag to show speaker in voice mode

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DEFAULT_SHOW_SPEAKER_IN_VOICE_MODE = false
Public Const DEFAULT_SHOW_SPEAKER_IN_VOICE_MODE As Boolean = False
public:
literal bool DEFAULT_SHOW_SPEAKER_IN_VOICE_MODE = false

Field Value

Type: Boolean
See Also

Reference

DiscussionConstants Class


DiscussionConstants.DISCUSS_DEFAULT_OPEN_MICROPHONES Field

DiscussionConstantsDISCUSS_DEFAULT_OPEN_MICROPHONES Field

Default value for number of open microphones

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DISCUSS_DEFAULT_OPEN_MICROPHONES = 2
Public Const DISCUSS_DEFAULT_OPEN_MICROPHONES As Integer = 2
public:
literal int DISCUSS_DEFAULT_OPEN_MICROPHONES = 2

Field Value

Type: Int32
See Also

Reference

DiscussionConstants Class


DiscussionConstants.DISCUSS_DEFAULT_REQUESTS Field

DiscussionConstantsDISCUSS_DEFAULT_REQUESTS Field

Default value for number of requests

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DISCUSS_DEFAULT_REQUESTS = 10
Public Const DISCUSS_DEFAULT_REQUESTS As Integer = 10
public:
literal int DISCUSS_DEFAULT_REQUESTS = 10

Field Value

Type: Int32
See Also

Reference

DiscussionConstants Class


DiscussionConstants.DISCUSS_MAX_OPEN_MICROPHONES Field

DiscussionConstantsDISCUSS_MAX_OPEN_MICROPHONES Field

Maximum value for number of open microphones

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DISCUSS_MAX_OPEN_MICROPHONES = 25
Public Const DISCUSS_MAX_OPEN_MICROPHONES As Integer = 25
public:
literal int DISCUSS_MAX_OPEN_MICROPHONES = 25

Field Value

Type: Int32
See Also

Reference

DiscussionConstants Class


DiscussionConstants.DISCUSS_MAX_REQUESTS Field

DiscussionConstantsDISCUSS_MAX_REQUESTS Field

Maximum value for number of requests

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DISCUSS_MAX_REQUESTS = 200
Public Const DISCUSS_MAX_REQUESTS As Integer = 200
public:
literal int DISCUSS_MAX_REQUESTS = 200

Field Value

Type: Int32
See Also

Reference

DiscussionConstants Class


DiscussionConstants.DISCUSS_MAX_RESPONSES Field

DiscussionConstantsDISCUSS_MAX_RESPONSES Field

Maximum value for number of responses

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DISCUSS_MAX_RESPONSES = 10
Public Const DISCUSS_MAX_RESPONSES As Integer = 10
public:
literal int DISCUSS_MAX_RESPONSES = 10

Field Value

Type: Int32
See Also

Reference

DiscussionConstants Class


DiscussionConstants.DISCUSS_MIN_OPEN_MICROPHONES Field

DiscussionConstantsDISCUSS_MIN_OPEN_MICROPHONES Field

Minimum value for number of open microphones

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DISCUSS_MIN_OPEN_MICROPHONES = 1
Public Const DISCUSS_MIN_OPEN_MICROPHONES As Integer = 1
public:
literal int DISCUSS_MIN_OPEN_MICROPHONES = 1

Field Value

Type: Int32
See Also

Reference

DiscussionConstants Class


DiscussionConstants.DISCUSS_MIN_REQUESTS Field

DiscussionConstantsDISCUSS_MIN_REQUESTS Field

Minimum value for number of requests

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DISCUSS_MIN_REQUESTS = 0
Public Const DISCUSS_MIN_REQUESTS As Integer = 0
public:
literal int DISCUSS_MIN_REQUESTS = 0

Field Value

Type: Int32
See Also

Reference

DiscussionConstants Class


DiscussionConstants.DISCUSS_MIN_RESPONSES Field

DiscussionConstantsDISCUSS_MIN_RESPONSES Field

Minimum value for number of responses

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int DISCUSS_MIN_RESPONSES = 1
Public Const DISCUSS_MIN_RESPONSES As Integer = 1
public:
literal int DISCUSS_MIN_RESPONSES = 1

Field Value

Type: Int32
See Also

Reference

DiscussionConstants Class


DiscussionConstants.MAXIMUM_ATTACK_TIME_DURATION Field

DiscussionConstantsMAXIMUM_ATTACK_TIME_DURATION Field

Maximum attack time value

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAXIMUM_ATTACK_TIME_DURATION = 10000
Public Const MAXIMUM_ATTACK_TIME_DURATION As Integer = 10000
public:
literal int MAXIMUM_ATTACK_TIME_DURATION = 10000

Field Value

Type: Int32
See Also

Reference

DiscussionConstants Class


DiscussionConstants.MAXIMUM_RELEASE_TIME_DURATION Field

DiscussionConstantsMAXIMUM_RELEASE_TIME_DURATION Field

Maximum release time value

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAXIMUM_RELEASE_TIME_DURATION = 10000
Public Const MAXIMUM_RELEASE_TIME_DURATION As Integer = 10000
public:
literal int MAXIMUM_RELEASE_TIME_DURATION = 10000

Field Value

Type: Int32
See Also

Reference

DiscussionConstants Class


DiscussionConstants.MINIMUM_ATTACK_TIME_DURATION Field

DiscussionConstantsMINIMUM_ATTACK_TIME_DURATION Field

Minimum attack time value

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MINIMUM_ATTACK_TIME_DURATION = 0
Public Const MINIMUM_ATTACK_TIME_DURATION As Integer = 0
public:
literal int MINIMUM_ATTACK_TIME_DURATION = 0

Field Value

Type: Int32
See Also

Reference

DiscussionConstants Class


DiscussionConstants.MINIMUM_RELEASE_TIME_DURATION Field

DiscussionConstantsMINIMUM_RELEASE_TIME_DURATION Field

Minimum release time value

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MINIMUM_RELEASE_TIME_DURATION = 0
Public Const MINIMUM_RELEASE_TIME_DURATION As Integer = 0
public:
literal int MINIMUM_RELEASE_TIME_DURATION = 0

Field Value

Type: Int32
See Also

Reference

DiscussionConstants Class


HeadphoneDescription Class

Tag for headphone name
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesHeadphoneDescription

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static class HeadphoneDescription
<ExtensionAttribute>
Public NotInheritable Class HeadphoneDescription
[ExtensionAttribute]
public ref class HeadphoneDescription abstract sealed

The HeadphoneDescription type exposes the following members.

Methods
Name | Description
GetDescriptionT | Get the description of the headphone enum
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


HeadphoneDescription Methods

The HeadphoneDescription type exposes the following members.

Methods
Name | Description
GetDescriptionT | Get the description of the headphone enum
Top
See Also

Reference

HeadphoneDescription Class


HeadphoneDescription.GetDescription(T) Method

HeadphoneDescriptionGetDescriptionT Method

Get the description of the headphone enum

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static string GetDescription<T>(
    this T id
)

<ExtensionAttribute>
Public Shared Function GetDescription(Of T) (
    id As T
) As String
public:
[ExtensionAttribute]
generic<typename T>
static String^ GetDescription(
    T id
)

Parameters

id
Type: T
The enum variable name

Type Parameters

T
The enumtype

Return Value

Type: String
a string containing description of the enum

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

HeadphoneDescription Class
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmHeadphoneTypes


IApi Interface

Main interface of the Windows API, providing basic functionality.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IApi : IDisposable
Public Interface IApi
    Inherits IDisposable
public interface class IApi : IDisposable

The IApi type exposes the following members.

Properties
 | Name | Description
Public property | CanAuthenticate | Indicates whether it is possible to authenticate a user.
Public property | CurrentApiState | Indicates the operational state of the API.
Public property | DicentisCapabilities | Returns collection of Dicentis Capabilities.
Public property | DicentisVersion | Version of Dicentis system to which API is connected.
Public property | IsOpen | Indicates whether the API is opened for use.
Public property | IsUserLoggedOn | Indicates whether a user is currently logged on to the system.
Public property | LoggedOnUserId | User id of the logged in user.
Public property | VersionMismatchError | Indicates if there has been a version mismatch between the API and the system.
Top
Methods
 | Name | Description
Public method | AuthenticateUserAsync | Logs on a user in the system using username/password combination.
Public method | AuthenticateWindowsSystemUserAsync | Obsolete. This method is deprecated and no longer supported. Windows System user authentication through this API is no longer available, and usage should be discontinued.
Public method | CloseAsync | Closes the API for use.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | OpenAsync(ActionTaskBoolean) | Opens the API for use.
Public method | OpenAsync(String, ActionTaskBoolean) | Opens the API for use.
Public method | RevokeUserAsync | Logs off the current user in the system.
Public method | SetCallbackContext | Define thread for executing API events
Public method | SetTaskCompletionContext | Set thread for task completions
Top
Events
 | Name | Description
Public event | ApiStateChanged | Occurs when the operational state of the API has changed.
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | OpenStateChanged | Occurs when the operational state of the API transits to or from Online. true if online, false if no longer online.
Public event | VersionMismatchErrorDetected | Occurs when a version mismatch error was detected between API and the system.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IApi Properties

The IApi type exposes the following members.

Properties
 | Name | Description
Public property | CanAuthenticate | Indicates whether it is possible to authenticate a user.
Public property | CurrentApiState | Indicates the operational state of the API.
Public property | DicentisCapabilities | Returns collection of Dicentis Capabilities.
Public property | DicentisVersion | Version of Dicentis system to which API is connected.
Public property | IsOpen | Indicates whether the API is opened for use.
Public property | IsUserLoggedOn | Indicates whether a user is currently logged on to the system.
Public property | LoggedOnUserId | User id of the logged in user.
Public property | VersionMismatchError | Indicates if there has been a version mismatch between the API and the system.
Top
See Also

Reference

IApi Interface


IApi.CanAuthenticate Property

IApiCanAuthenticate Property

Indicates whether it is possible to authenticate a user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanAuthenticate { get; }
ReadOnly Property CanAuthenticate As Boolean
    Get
property bool CanAuthenticate {
    bool get ();
}

Property Value

Type: Boolean
true if authenticating a user is possible, false otherwise.
See Also

Reference

IApi Interface


IApi.CurrentApiState Property

IApiCurrentApiState Property

Indicates the operational state of the API.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
DcnmApiState CurrentApiState { get; }
ReadOnly Property CurrentApiState As DcnmApiState
    Get
property DcnmApiState CurrentApiState {
    DcnmApiState get ();
}

Property Value

Type: DcnmApiState
Online if API is open, Offline otherwise.
See Also

Reference

IApi Interface


IApi.DicentisCapabilities Property

IApiDicentisCapabilities Property

Returns collection of Dicentis Capabilities.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
ReadOnlyCollection<string> DicentisCapabilities { get; }
ReadOnly Property DicentisCapabilities As ReadOnlyCollection(Of String)
    Get
property ReadOnlyCollection<String^>^ DicentisCapabilities {
    ReadOnlyCollection<String^>^ get ();
}

Property Value

Type: ReadOnlyCollection String
Collection of Dicentis Capabilities
See Also

Reference

IApi Interface


IApi.DicentisVersion Property

IApiDicentisVersion Property

Version of Dicentis system to which API is connected.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Version DicentisVersion { get; }
ReadOnly Property DicentisVersion As Version
    Get
property Version^ DicentisVersion {
    Version^ get ();
}

Property Value

Type: Version
Assembly version of Dicentis system if API is open, 0.0.0.0 otherwise.
See Also

Reference

IApi Interface


IApi.IsOpen Property

IApiIsOpen Property

Indicates whether the API is opened for use.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsOpen { get; }
ReadOnly Property IsOpen As Boolean
    Get
property bool IsOpen {
    bool get ();
}

Property Value

Type: Boolean
true if opened, false if closed.
See Also

Reference

IApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IApiOpenAsync(ActionTaskBoolean)
IApiOpenAsync(String, ActionTaskBoolean)
IApiCloseAsync(ActionTask)


IApi.IsUserLoggedOn Property

IApiIsUserLoggedOn Property

Indicates whether a user is currently logged on to the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsUserLoggedOn { get; }
ReadOnly Property IsUserLoggedOn As Boolean
    Get
property bool IsUserLoggedOn {
    bool get ();
}

Property Value

Type: Boolean
true if a user is logged on, false otherwise.
See Also

Reference

IApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IApiAuthenticateUserAsync(String, String, ActionTaskBoolean)
IApiAuthenticateWindowsSystemUserAsync(ActionTaskBoolean)


IApi.LoggedOnUserId Property

IApiLoggedOnUserId Property

User id of the logged in user.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Guid LoggedOnUserId { get; }
ReadOnly Property LoggedOnUserId As Guid
    Get
property Guid LoggedOnUserId {
    Guid get ();
}

Property Value

Type: Guid
User id if a user is logged on, Guid.Empty otherwise.
See Also

Reference

IApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IApiAuthenticateUserAsync(String, String, ActionTaskBoolean)
IApiAuthenticateWindowsSystemUserAsync(ActionTaskBoolean)


IApi.VersionMismatchError Property

IApiVersionMismatchError Property

Indicates if there has been a version mismatch between the API and the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool VersionMismatchError { get; }
ReadOnly Property VersionMismatchError As Boolean
    Get
property bool VersionMismatchError {
    bool get ();
}

Property Value

Type: Boolean
true if version does not match, false otherwise.
See Also

Reference

IApi Interface


IApi Methods

The IApi type exposes the following members.

Methods
 | Name | Description
Public method | AuthenticateUserAsync | Logs on a user in the system using username/password combination.
Public method | AuthenticateWindowsSystemUserAsync | Obsolete. This method is deprecated and no longer supported. Windows System user authentication through this API is no longer available, and usage should be discontinued.
Public method | CloseAsync | Closes the API for use.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | OpenAsync(ActionTaskBoolean) | Opens the API for use.
Public method | OpenAsync(String, ActionTaskBoolean) | Opens the API for use.
Public method | RevokeUserAsync | Logs off the current user in the system.
Public method | SetCallbackContext | Define thread for executing API events
Public method | SetTaskCompletionContext | Set thread for task completions
Top
See Also

Reference

IApi Interface


IApi.AuthenticateUserAsync Method

IApiAuthenticateUserAsync Method

Logs on a user in the system using username/password combination.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> AuthenticateUserAsync(
    string userName,
    string password,
    Action<Task<bool>> onFinish = null
)
Function AuthenticateUserAsync (
    userName As String,
    password As String,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ AuthenticateUserAsync(
    String^ userName,
    String^ password,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

userName
Type: SystemString
The username of the user.
password
Type: SystemString
The unencrypted password.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the user authentication. The 'Result' property of the task is true if authenticating the user succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If user name is null or empty.
Remarks
For the user to be able to login, CanAuthenticate should be true, otherwise the user will not be able to login. To check the Authentication status of the user see IsUserLoggedOn
See Also

Reference

IApi Interface


IApi.AuthenticateWindowsSystemUserAsync Method

IApiAuthenticateWindowsSystemUserAsync Method

Note: This API is now obsolete.

This method is deprecated and no longer supported. Windows System user authentication through this API is no longer available, and usage should be discontinued.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("AuthenticateWindowsSystemUserAsync is deprecated and no longer supported. Please use alternative authentication methods.")]
Task<bool> AuthenticateWindowsSystemUserAsync(
    Action<Task<bool>> onFinish = null
)
<ObsoleteAttribute("AuthenticateWindowsSystemUserAsync is deprecated and no longer supported. Please use alternative authentication methods.")>
Function AuthenticateWindowsSystemUserAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
[ObsoleteAttribute(L"AuthenticateWindowsSystemUserAsync is deprecated and no longer supported. Please use alternative authentication methods.")]
Task<bool>^ AuthenticateWindowsSystemUserAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
This argument will be ignored as method is deprecated

Return Value

Type: Task Boolean
Always returns false
See Also

Reference

IApi Interface


IApi.CloseAsync Method

IApiCloseAsync Method

Closes the API for use.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task CloseAsync(
    Action<Task> onFinish = null
)
Function CloseAsync (
    Optional onFinish As Action(Of Task) = Nothing
) As Task
Task^ CloseAsync(
    Action<Task^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task
Optional action for asynchronous handling of the result.

Return Value

Type: Task
Task processing the API close.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
To close the API, the state of API should be either DcnmApiState.Online or DcnmApiState.Opening

Events triggered and Properties modified while opening the api are as follows:

Events triggered:

  • OpenStateChanged
  • ApiStateChanged
  • CapabilitiesChanged
Properties
  • IsOpen
  • CanAuthenticate

See Also

Reference

IApi Interface


IApi.OpenAsync Method

IApiOpenAsync Method

Overload List
 | Name | Description
Public method | OpenAsync(ActionTaskBoolean) | Opens the API for use.
Public method | OpenAsync(String, ActionTaskBoolean) | Opens the API for use.
Top
See Also

Reference

IApi Interface


IApi.OpenAsync Method (Action(Task(Boolean)))

IApiOpenAsync Method (ActionTaskBoolean)

 Bosch Logo
Opens the API for use.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> OpenAsync(
    Action<Task<bool>> onFinish = null
)
Function OpenAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ OpenAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the API open. The 'Result' property of the task is true if opening the API succeeded, else false. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Events triggered and Properties modified while opening the api are as follows:

Events triggered:

  • OpenStateChanged
  • ApiStateChanged
  • CapabilitiesChanged
Properties
  • IsOpen
  • CanAuthenticate

See Also

Reference

IApi Interface
OpenAsync Overload


IApi.OpenAsync Method (String, Action(Task(Boolean)))

IApiOpenAsync Method (String, ActionTaskBoolean)

 Bosch Logo
Opens the API for use.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> OpenAsync(
    string hostNameOrAddress,
    Action<Task<bool>> onFinish = null
)
Function OpenAsync (
    hostNameOrAddress As String,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ OpenAsync(
    String^ hostNameOrAddress,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

hostNameOrAddress
Type: SystemString
Host name or IP address.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the API open. The 'Result' property of the task is true if opening the API succeeded, else false. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Events triggered and Properties modified while opening the api are as follows:

Events triggered:

  • OpenStateChanged
  • ApiStateChanged
  • CapabilitiesChanged
Properties
  • IsOpen
  • CanAuthenticate

See Also

Reference

IApi Interface
OpenAsync Overload


IApi.RevokeUserAsync Method

IApiRevokeUserAsync Method

Logs off the current user in the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task RevokeUserAsync(
    Action<Task> onFinish = null
)
Function RevokeUserAsync (
    Optional onFinish As Action(Of Task) = Nothing
) As Task
Task^ RevokeUserAsync(
    Action<Task^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task
Optional action for asynchronous handling of the result.

Return Value

Type: Task
Task processing the user revoke.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
IsUserLoggedOn is set to false.
See Also

Reference

IApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IApiAuthenticateUserAsync(String, String, ActionTaskBoolean)
IApiAuthenticateWindowsSystemUserAsync(ActionTaskBoolean)


IApi.SetCallbackContext Method

IApiSetCallbackContext Method

Define thread for executing API events

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
void SetCallbackContext(
    SynchronizationContext context
)
Sub SetCallbackContext (
    context As SynchronizationContext
)
void SetCallbackContext(
    SynchronizationContext^ context
)

Parameters

context
Type: System.ThreadingSynchronizationContext
The synchronization context to use, or null to run on the APIs thread
Remarks
Set which thread (pool) will execute all API events by specifying the synchronization context. Callbacks are also known as delegates. The default context serializes all callbacks on a single thread - so callbacks are handled one by one. This is a different thread than the thread used by SetTaskCompletionContext. It is best to set the context before calling IApi.Open(). A common synchronization context to use is the System.Windows.Threading.DispatcherSynchronizationContext that ensures that all callbacks are handled through the UIs message queue.
See Also

Reference

IApi Interface


IApi.SetTaskCompletionContext Method

IApiSetTaskCompletionContext Method

Set thread for task completions

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
void SetTaskCompletionContext(
    SynchronizationContext context
)
Sub SetTaskCompletionContext (
    context As SynchronizationContext
)
void SetTaskCompletionContext(
    SynchronizationContext^ context
)

Parameters

context
Type: System.ThreadingSynchronizationContext
The synchronization context to use, or null to run on the APIs thread
Remarks
Set which thread (pool) will execute all task completion routines specifying the synchronization context. Callbacks are also known as delegates. The default context serializes all callbacks on a single thread - so callbacks are handled one by one. This is a different thread than the thread used by SetTaskCompletionContext. It is best to set the context before calling IApi.Open(). A common synchronization context to use is the System.Windows.Threading.DispatcherSynchronizationContext that ensures that all callbacks are handled through the UIs message queue.
See Also

Reference

IApi Interface


IApi Events

The IApi type exposes the following members.

Events
 | Name | Description
Public event | ApiStateChanged | Occurs when the operational state of the API has changed.
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | OpenStateChanged | Occurs when the operational state of the API transits to or from Online. true if online, false if no longer online.
Public event | VersionMismatchErrorDetected | Occurs when a version mismatch error was detected between API and the system.
Top
See Also

Reference

IApi Interface


IApi.ApiStateChanged Event

IApiApiStateChanged Event

Occurs when the operational state of the API has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmApiState>> ApiStateChanged
Event ApiStateChanged As EventHandler(Of ApiEventArgs(Of DcnmApiState))
 event EventHandler<ApiEventArgs<DcnmApiState>^>^ ApiStateChanged {
    void add (EventHandler<ApiEventArgs<DcnmApiState>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmApiState>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmApiState
See Also

Reference

IApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IApiOpenAsync(ActionTaskBoolean)
IApiOpenAsync(String, ActionTaskBoolean)
IApiCloseAsync(ActionTask)


IApi.CapabilitiesChanged Event

IApiCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IApi Interface


IApi.OpenStateChanged Event

IApiOpenStateChanged Event

Occurs when the operational state of the API transits to or from Online. true if online, false if no longer online.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<bool>> OpenStateChanged
Event OpenStateChanged As EventHandler(Of ApiEventArgs(Of Boolean))
 event EventHandler<ApiEventArgs<bool>^>^ OpenStateChanged {
    void add (EventHandler<ApiEventArgs<bool>^>^ value);
    void remove (EventHandler<ApiEventArgs<bool>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Boolean
See Also

Reference

IApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IApiOpenAsync(ActionTaskBoolean)
IApiOpenAsync(String, ActionTaskBoolean)
IApiCloseAsync(ActionTask)


IApi.VersionMismatchErrorDetected Event

IApiVersionMismatchErrorDetected Event

Occurs when a version mismatch error was detected between API and the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler VersionMismatchErrorDetected
Event VersionMismatchErrorDetected As EventHandler
 event EventHandler^ VersionMismatchErrorDetected {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IApi Interface


IAttention Interface

Represents the attention interface to put attention to the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IAttention : IDisposable
Public Interface IAttention
    Inherits IDisposable
public interface class IAttention : IDisposable

The IAttention type exposes the following members.

Properties
 | Name | Description
Public property | CanIssuePriority | Indicates whether it is possible to issue a priority.
Public property | CanSummon | Indicates whether it is possible to summon.
Public property | IsPriorityActive | Indicates whether a priority is active.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | IssuePriorityAsync | Issues a request to activate a priority in the system.
Public method | StopPriorityAsync | Deactivates an active priority.
Public method | SummonAsync | Activates a summon.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | PriorityDenied | Occurs when the priority is denied.
Public event | PriorityGranted | Occurs when the priority is granted.
Public event | PriorityRevoked | Occurs when the priority is revoked.
Top
Remarks
The attention interface in generally is used by the participant having CanManage rights. The goal is to get attention of the participants by interrupting the discussion or just placing a summon tone.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IAttention Properties

The IAttention type exposes the following members.

Properties
 | Name | Description
Public property | CanIssuePriority | Indicates whether it is possible to issue a priority.
Public property | CanSummon | Indicates whether it is possible to summon.
Public property | IsPriorityActive | Indicates whether a priority is active.
Top
See Also

Reference

IAttention Interface


IAttention.CanIssuePriority Property

IAttentionCanIssuePriority Property

Indicates whether it is possible to issue a priority.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanIssuePriority { get; }
ReadOnly Property CanIssuePriority As Boolean
    Get
property bool CanIssuePriority {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Priority is an attention tone to mute delegate microphones.

Requires:
  • Participant right: Can use priority
  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode
See Also

Reference

IAttention Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IAttentionIssuePriorityAsync(ActionTaskBoolean)


IAttention.CanSummon Property

IAttentionCanSummon Property

Indicates whether it is possible to summon.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanSummon { get; }
ReadOnly Property CanSummon As Boolean
    Get
property bool CanSummon {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Meeting preparation and management.
  • Participant right: Can manage.
See Also

Reference

IAttention Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IAttentionSummonAsync(ActionTaskBoolean)


IAttention.IsPriorityActive Property

IAttentionIsPriorityActive Property

Indicates whether a priority is active.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsPriorityActive { get; }
ReadOnly Property IsPriorityActive As Boolean
    Get
property bool IsPriorityActive {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Priority is an attention tone to mute delegate microphones.

Requires:
  • User right: Prepare users
See Also

Reference

IAttention Interface


IAttention Methods

The IAttention type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | IssuePriorityAsync | Issues a request to activate a priority in the system.
Public method | StopPriorityAsync | Deactivates an active priority.
Public method | SummonAsync | Activates a summon.
Top
See Also

Reference

IAttention Interface


IAttention.IssuePriorityAsync Method

IAttentionIssuePriorityAsync Method

Issues a request to activate a priority in the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> IssuePriorityAsync(
    Action<Task<bool>> onFinish = null
)
Function IssuePriorityAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ IssuePriorityAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the priority. The 'Result' property of the task is true if request to issue priority has been delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Priority is an attention tone to mute delegate microphones. Priority is activated if IsPriorityActive is false, otherwise Priority will be denied

In order to let this method work properly, the CanIssuePriority property need to be true.

Following event are triggered when a request to activate a priority is issued.

  • PriorityGranted - if the request to activate the priority is successful.
  • PriorityDenied - if the request to activate the priority is unsuccessful.

See Also

Reference

IAttention Interface


IAttention.StopPriorityAsync Method

IAttentionStopPriorityAsync Method

Deactivates an active priority.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> StopPriorityAsync(
    Action<Task<bool>> onFinish = null
)
Function StopPriorityAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ StopPriorityAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the priority stop. The 'Result' property of the task is true if the request to stop or de-activate priority is delivered, otherwise it is set to false. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Priority is an attention tone to mute delegate microphones.

Requires:

  • CanIssuePriority

Event trigerred after a priority is deactivated are as follows

  • PriorityRevoked
See Also

Reference

IAttention Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IAttentionIsPriorityActive


IAttention.SummonAsync Method

IAttentionSummonAsync Method

Activates a summon.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SummonAsync(
    Action<Task<bool>> onFinish = null
)
Function SummonAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SummonAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the summon. The 'Result' property of the task is true if the request to summon is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanSummon
See Also

Reference

IAttention Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IAttentionCanSummon


IAttention Events

The IAttention type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | PriorityDenied | Occurs when the priority is denied.
Public event | PriorityGranted | Occurs when the priority is granted.
Public event | PriorityRevoked | Occurs when the priority is revoked.
Top
See Also

Reference

IAttention Interface


IAttention.CapabilitiesChanged Event

IAttentionCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IAttention Interface


IAttention.PriorityDenied Event

IAttentionPriorityDenied Event

Occurs when the priority is denied.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler PriorityDenied
Event PriorityDenied As EventHandler
 event EventHandler^ PriorityDenied {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
Remarks

Priority is an attention tone to mute delegate microphones.

See Also

Reference

IAttention Interface


IAttention.PriorityGranted Event

IAttentionPriorityGranted Event

Occurs when the priority is granted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler PriorityGranted
Event PriorityGranted As EventHandler
 event EventHandler^ PriorityGranted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
Remarks

Priority is an attention tone to mute delegate microphones.

See Also

Reference

IAttention Interface


IAttention.PriorityRevoked Event

IAttentionPriorityRevoked Event

Occurs when the priority is revoked.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler PriorityRevoked
Event PriorityRevoked As EventHandler
 event EventHandler^ PriorityRevoked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
Remarks

Priority is an attention tone to mute delegate microphones.

See Also

Reference

IAttention Interface


IConfigArea Interface

Represents an interface to configure an area.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IConfigArea : IDisposable
Public Interface IConfigArea
    Inherits IDisposable
public interface class IConfigArea : IDisposable

The IConfigArea type exposes the following members.

Properties
 | Name | Description
Public property | CanAdjustMicrophoneSensitivity | Indicates whether it is possible to adjust the microphone sensitivity for seats.
Public property | CanConfigureAreas | Indicates whether it is possible to configure areas.
Public property | CanConfigureSeatCameraInformation | Indicates whether it is possible to configure seat camera information.
Public property | CanConfigureSimultaneousInterpretation | Indicates whether it is possible to configure simultaneous interpretation.
Public property | MaxMicrophoneSensitivity | Contains the maximum microphone sensitivity value in dB the Dicentis system supports.
Public property | MicrophoneSensitivityStepSize | Contains the recommended microphone sensitivity steps size in dB.
Public property | MinMicrophoneSensitivity | Contains the minimum microphone sensitivity value in dB the Dicentis system supports.
Top
Methods
 | Name | Description
Public method | CreateSeatsAsync | Creates the seats in the given area.
Public method | DeleteSeatsAsync | Deletes the given seats.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetSeatsAsync | Retrieves the seats in given area.
Public method | ResetMicrophoneSensitivityForAllSeatsToDefaultAsync | Resets the microphone sensitivity for the seats with the specified ids to the default level (0 dB).
Public method | RetrieveMicrophoneSensitivityOfSeatAsync | Requests for the microphone sensitivity in dB of the seat with the specified id.
Public method | UpdateMicrophoneSensitivityForSeatsAsync | Adjusts the microphone sensitivity for the seats with the specified ids to the specified level (in dB). Also persists the level if specified.
Public method | UpdateSeatsAsync | Updates the information of the given seats.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | MicrophoneSensitivityForSeatsUpdated | Occurs when the microphone sensitivity of a seat was changed.
Public event | SeatsCreated | Occurs when seats are created.
Public event | SeatsDeleted | Occurs when seats are deleted.
Public event | SeatsUpdated | Occurs when seats are updated.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IConfigArea Properties

The IConfigArea type exposes the following members.

Properties
 | Name | Description
Public property | CanAdjustMicrophoneSensitivity | Indicates whether it is possible to adjust the microphone sensitivity for seats.
Public property | CanConfigureAreas | Indicates whether it is possible to configure areas.
Public property | CanConfigureSeatCameraInformation | Indicates whether it is possible to configure seat camera information.
Public property | CanConfigureSimultaneousInterpretation | Indicates whether it is possible to configure simultaneous interpretation.
Public property | MaxMicrophoneSensitivity | Contains the maximum microphone sensitivity value in dB the Dicentis system supports.
Public property | MicrophoneSensitivityStepSize | Contains the recommended microphone sensitivity steps size in dB.
Public property | MinMicrophoneSensitivity | Contains the minimum microphone sensitivity value in dB the Dicentis system supports.
Top
See Also

Reference

IConfigArea Interface


IConfigArea.CanAdjustMicrophoneSensitivity Property

IConfigAreaCanAdjustMicrophoneSensitivity Property

Indicates whether it is possible to adjust the microphone sensitivity for seats.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanAdjustMicrophoneSensitivity { get; }
ReadOnly Property CanAdjustMicrophoneSensitivity As Boolean
    Get
property bool CanAdjustMicrophoneSensitivity {
    bool get ();
}

Property Value

Type: Boolean
true if it is allowed to configure microphone sensitivity for seats; otherwise, false.
Remarks
Requires:
  • Functional license: Prepare and manage meeting
  • User right: Activate meeting
See Also

Reference

IConfigArea Interface


IConfigArea.CanConfigureAreas Property

IConfigAreaCanConfigureAreas Property

Indicates whether it is possible to configure areas.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanConfigureAreas { get; }
ReadOnly Property CanConfigureAreas As Boolean
    Get
property bool CanConfigureAreas {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • User right: Configure System.
See Also

Reference

IConfigArea Interface


IConfigArea.CanConfigureSeatCameraInformation Property

IConfigAreaCanConfigureSeatCameraInformation Property

Indicates whether it is possible to configure seat camera information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanConfigureSeatCameraInformation { get; }
ReadOnly Property CanConfigureSeatCameraInformation As Boolean
    Get
property bool CanConfigureSeatCameraInformation {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • User right: Configure System.
  • Functional license: Camera Control.
See Also

Reference

IConfigArea Interface


IConfigArea.CanConfigureSimultaneousInterpretation Property

IConfigAreaCanConfigureSimultaneousInterpretation Property

Indicates whether it is possible to configure simultaneous interpretation.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanConfigureSimultaneousInterpretation { get; }
ReadOnly Property CanConfigureSimultaneousInterpretation As Boolean
    Get
property bool CanConfigureSimultaneousInterpretation {
    bool get ();
}

Property Value

Type: Boolean
true if it is allowed to configure simultaneous interpretation; otherwise, false.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Simultaneous Interpretation
See Also

Reference

IConfigArea Interface


IConfigArea.MaxMicrophoneSensitivity Property

IConfigAreaMaxMicrophoneSensitivity Property

Contains the maximum microphone sensitivity value in dB the Dicentis system supports.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
float MaxMicrophoneSensitivity { get; }
ReadOnly Property MaxMicrophoneSensitivity As Single
    Get
property float MaxMicrophoneSensitivity {
    float get ();
}

Property Value

Type: Single
See Also

Reference

IConfigArea Interface


IConfigArea.MicrophoneSensitivityStepSize Property

IConfigAreaMicrophoneSensitivityStepSize Property

Contains the recommended microphone sensitivity steps size in dB.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
float MicrophoneSensitivityStepSize { get; }
ReadOnly Property MicrophoneSensitivityStepSize As Single
    Get
property float MicrophoneSensitivityStepSize {
    float get ();
}

Property Value

Type: Single
See Also

Reference

IConfigArea Interface


IConfigArea.MinMicrophoneSensitivity Property

IConfigAreaMinMicrophoneSensitivity Property

Contains the minimum microphone sensitivity value in dB the Dicentis system supports.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
float MinMicrophoneSensitivity { get; }
ReadOnly Property MinMicrophoneSensitivity As Single
    Get
property float MinMicrophoneSensitivity {
    float get ();
}

Property Value

Type: Single
See Also

Reference

IConfigArea Interface


IConfigArea Methods

The IConfigArea type exposes the following members.

Methods
 | Name | Description
Public method | CreateSeatsAsync | Creates the seats in the given area.
Public method | DeleteSeatsAsync | Deletes the given seats.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetSeatsAsync | Retrieves the seats in given area.
Public method | ResetMicrophoneSensitivityForAllSeatsToDefaultAsync | Resets the microphone sensitivity for the seats with the specified ids to the default level (0 dB).
Public method | RetrieveMicrophoneSensitivityOfSeatAsync | Requests for the microphone sensitivity in dB of the seat with the specified id.
Public method | UpdateMicrophoneSensitivityForSeatsAsync | Adjusts the microphone sensitivity for the seats with the specified ids to the specified level (in dB). Also persists the level if specified.
Public method | UpdateSeatsAsync | Updates the information of the given seats.
Top
See Also

Reference

IConfigArea Interface


IConfigArea.CreateSeatsAsync Method

IConfigAreaCreateSeatsAsync Method

Creates the seats in the given area.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CreateSeatsAsync(
    IList<DcnmSeatConfigurationInfo> seatInfos,
    Action<Task<bool>> onFinish = null
)
Function CreateSeatsAsync (
    seatInfos As IList(Of DcnmSeatConfigurationInfo),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CreateSeatsAsync(
    IList<DcnmSeatConfigurationInfo^>^ seatInfos,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

seatInfos
Type: System.Collections.GenericIList DcnmSeatConfigurationInfo
The seat information to create the seats with
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the seats creation. The 'Result' property of the task is true if creating seat succeeds, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If seats are empty or null.
Remarks
Requires:
  • CanConfigureAreas
  • Optionally: CanConfigureSeatCameraInformation
  • Creating seats of type InterpreterSeat requires: CanConfigureSimultaneousInterpretation If the seatInfos list contains seats of type InterpreterSeat and ParticipantSeat, Creation fails if CanConfigureSimultaneousInterpretation is false .
See Also

Reference

IConfigArea Interface


IConfigArea.DeleteSeatsAsync Method

IConfigAreaDeleteSeatsAsync Method

Deletes the given seats.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeleteSeatsAsync(
    IList<Guid> seatIds,
    Action<Task<bool>> onFinish = null
)
Function DeleteSeatsAsync (
    seatIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeleteSeatsAsync(
    IList<Guid>^ seatIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

seatIds
Type: System.Collections.GenericIList Guid
The seats to delete.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the seats deletion. The 'Result' property of the task is true if deleting seat succeeds, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If seats are empty or null.
Remarks
Requires:
  • CanConfigureAreas
  • Deleting seats of type InterpreterSeat requires: CanConfigureSimultaneousInterpretation If the seatIds list contains seats of type InterpreterSeat and ParticipantSeat, Delete fails if CanConfigureSimultaneousInterpretation is false .
See Also

Reference

IConfigArea Interface


IConfigArea.GetSeatsAsync Method

IConfigAreaGetSeatsAsync Method

Retrieves the seats in given area.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmSeatConfigurationInfo>> GetSeatsAsync(
    Guid areaId,
    Action<Task<IList<DcnmSeatConfigurationInfo>>> onFinish = null
)
Function GetSeatsAsync (
    areaId As Guid,
    Optional onFinish As Action(Of Task(Of IList(Of DcnmSeatConfigurationInfo))) = Nothing
) As Task(Of IList(Of DcnmSeatConfigurationInfo))
Task<IList<DcnmSeatConfigurationInfo^>^>^ GetSeatsAsync(
    Guid areaId,
    Action<Task<IList<DcnmSeatConfigurationInfo^>^>^>^ onFinish = nullptr
)

Parameters

areaId
Type: SystemGuid
The area to get the seats from.
onFinish (Optional)
Type: SystemAction Task IList DcnmSeatConfigurationInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmSeatConfigurationInfo
Task processing the seats retrieval. The 'Result' property of the task holds the list of retrieved seats. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If area Id is empty.
See Also

Reference

IConfigArea Interface


IConfigArea.ResetMicrophoneSensitivityForAllSeatsToDefaultAsync Method

IConfigAreaResetMicrophoneSensitivityForAllSeatsToDefaultAsync Method

Bosch Logo
Resets the microphone sensitivity for the seats with the specified ids to the default level (0 dB).

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> ResetMicrophoneSensitivityForAllSeatsToDefaultAsync(
    Action<Task<bool>> onFinish = null
)
Function ResetMicrophoneSensitivityForAllSeatsToDefaultAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ ResetMicrophoneSensitivityForAllSeatsToDefaultAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the resetting of the microphone sensitivity of the seat with the specified id. The 'Result' property of the task is true if resetting the microphone sensitivity succeeds, false otherwise.
See Also

Reference

IConfigArea Interface


IConfigArea.RetrieveMicrophoneSensitivityOfSeatAsync Method

IConfigAreaRetrieveMicrophoneSensitivityOfSeatAsync Method

Requests for the microphone sensitivity in dB of the seat with the specified id.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<float> RetrieveMicrophoneSensitivityOfSeatAsync(
    Guid seatId,
    Action<Task<float>> onFinish = null
)
Function RetrieveMicrophoneSensitivityOfSeatAsync (
    seatId As Guid,
    Optional onFinish As Action(Of Task(Of Single)) = Nothing
) As Task(Of Single)
Task<float>^ RetrieveMicrophoneSensitivityOfSeatAsync(
    Guid seatId,
    Action<Task<float>^>^ onFinish = nullptr
)

Parameters

seatId
Type: SystemGuid
The seat for which to request the microphone sensitivity.
onFinish (Optional)
Type: SystemAction Task Single
Optional action for asynchronous handling of the result.

Return Value

Type: Task Single
Task processing the request for the microphone sensitivity of the seat with the specified id. The 'Result' property of the task contains the microphone sensitivity in dB, 0 otherwise.
See Also

Reference

IConfigArea Interface


IConfigArea.UpdateMicrophoneSensitivityForSeatsAsync Method

IConfigAreaUpdateMicrophoneSensitivityForSeatsAsync Method

Adjusts the microphone sensitivity for the seats with the specified ids to the specified level (in dB). Also persists the level if specified.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateMicrophoneSensitivityForSeatsAsync(
    IList<DcnmMicrophoneSensitivityForSeat> microphoneSensitivityForSeats,
    bool persist = true,
    Action<Task<bool>> onFinish = null
)
Function UpdateMicrophoneSensitivityForSeatsAsync (
    microphoneSensitivityForSeats As IList(Of DcnmMicrophoneSensitivityForSeat),
    Optional persist As Boolean = true,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateMicrophoneSensitivityForSeatsAsync(
    IList<DcnmMicrophoneSensitivityForSeat^>^ microphoneSensitivityForSeats,
    bool persist = true,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

microphoneSensitivityForSeats
Type: System.Collections.GenericIList DcnmMicrophoneSensitivityForSeat
List of seats for which to adjust the microphone sensitivity.
persist (Optional)
Type: SystemBoolean
Indication if the microphone sensitivity should be persisted for the seat.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the adjustment of the microphone sensitivity of the seat with the specified id. The 'Result' property of the task is true if adjusting the microphone sensitivity succeeds, false otherwise.
Remarks
Requires:
  • CanAdjustMicrophoneSensitivity
Remarks
For only listening to the changed microphone sensitivity the persist flag can be set to false until the user applies the new microphone sensitivity; then the persist flag should be set to true (default). When the persist flag is never set to true the latest values will not be persisted meaning that the request returns the last persisted values.
See Also

Reference

IConfigArea Interface


IConfigArea.UpdateSeatsAsync Method

IConfigAreaUpdateSeatsAsync Method

Updates the information of the given seats.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateSeatsAsync(
    IList<DcnmSeatConfigurationInfo> seatInfos,
    Action<Task<bool>> onFinish = null
)
Function UpdateSeatsAsync (
    seatInfos As IList(Of DcnmSeatConfigurationInfo),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateSeatsAsync(
    IList<DcnmSeatConfigurationInfo^>^ seatInfos,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

seatInfos
Type: System.Collections.GenericIList DcnmSeatConfigurationInfo
The seat information to update the seats with
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing seats update. The 'Result' property of the task is true if updating seat succeeds, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If seats are empty or null.
Remarks
Requires:
  • CanConfigureAreas
  • Optionally: CanConfigureSeatCameraInformation
  • Updating seats of type InterpreterSeat requires: CanConfigureSimultaneousInterpretation If the seatInfos list contains seats of type InterpreterSeat and ParticipantSeat, Update fails if CanConfigureSimultaneousInterpretation is false .
See Also

Reference

IConfigArea Interface


IConfigArea Events

The IConfigArea type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | MicrophoneSensitivityForSeatsUpdated | Occurs when the microphone sensitivity of a seat was changed.
Public event | SeatsCreated | Occurs when seats are created.
Public event | SeatsDeleted | Occurs when seats are deleted.
Public event | SeatsUpdated | Occurs when seats are updated.
Top
See Also

Reference

IConfigArea Interface


IConfigArea.CapabilitiesChanged Event

IConfigAreaCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IConfigArea Interface


IConfigArea.MicrophoneSensitivityForSeatsUpdated Event

IConfigAreaMicrophoneSensitivityForSeatsUpdated Event

Occurs when the microphone sensitivity of a seat was changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmMicrophoneSensitivityForSeat>>> MicrophoneSensitivityForSeatsUpdated
Event MicrophoneSensitivityForSeatsUpdated As EventHandler(Of ApiEventArgs(Of IList(Of DcnmMicrophoneSensitivityForSeat)))
 event EventHandler<ApiEventArgs<IList<DcnmMicrophoneSensitivityForSeat^>^>^>^ MicrophoneSensitivityForSeatsUpdated {
    void add (EventHandler<ApiEventArgs<IList<DcnmMicrophoneSensitivityForSeat^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmMicrophoneSensitivityForSeat^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmMicrophoneSensitivityForSeat
See Also

Reference

IConfigArea Interface


IConfigArea.SeatsCreated Event

IConfigAreaSeatsCreated Event

Occurs when seats are created.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmSeatConfigurationInfo>>> SeatsCreated
Event SeatsCreated As EventHandler(Of ApiEventArgs(Of IList(Of DcnmSeatConfigurationInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmSeatConfigurationInfo^>^>^>^ SeatsCreated {
    void add (EventHandler<ApiEventArgs<IList<DcnmSeatConfigurationInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmSeatConfigurationInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmSeatConfigurationInfo
See Also

Reference

IConfigArea Interface


IConfigArea.SeatsDeleted Event

IConfigAreaSeatsDeleted Event

Occurs when seats are deleted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<Guid>>> SeatsDeleted
Event SeatsDeleted As EventHandler(Of ApiEventArgs(Of IList(Of Guid)))
 event EventHandler<ApiEventArgs<IList<Guid>^>^>^ SeatsDeleted {
    void add (EventHandler<ApiEventArgs<IList<Guid>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<Guid>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList Guid
See Also

Reference

IConfigArea Interface


IConfigArea.SeatsUpdated Event

IConfigAreaSeatsUpdated Event

Occurs when seats are updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmSeatConfigurationInfo>>> SeatsUpdated
Event SeatsUpdated As EventHandler(Of ApiEventArgs(Of IList(Of DcnmSeatConfigurationInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmSeatConfigurationInfo^>^>^>^ SeatsUpdated {
    void add (EventHandler<ApiEventArgs<IList<DcnmSeatConfigurationInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmSeatConfigurationInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmSeatConfigurationInfo
See Also

Reference

IConfigArea Interface


IConfigInterpretation Interface

Represents the interface to configure interpretation for the default meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IConfigInterpretation : IDisposable
Public Interface IConfigInterpretation
    Inherits IDisposable
public interface class IConfigInterpretation : IDisposable

The IConfigInterpretation type exposes the following members.

Properties
 | Name | Description
Public property | CanConfigureDanteLanguageChannels | Indicates whether it is possible to configure Dante languages or sending to Dante devices.
Public property | CanConfigureDesksAndBooths | Indicates whether it is possible to configure interpretation desks and booths.
Public property | CanConfigureInterpretationLanguages | Indicates whether it is possible to configure interpretation languages.
Public property | CanConfigureInterpretationMicrophoneModes | Indicates whether it is possible to configure interpretation microphone modes.
Top
Methods
 | Name | Description
Public method | AutoReconfigureMeetingDesksAsync | Autoreconfigure the specified seats in the specified meeting.
Public method | ChangeMeetingLanguagesOrderAsync | Updates the order of the meeting languages.
Public method | CreateMeetingLanguageAsync | Creates/Adds a meeting language
Public method | CreateMeetingLanguagesAsync | Creates/Adds a list of meeting languages
Public method | DeleteMeetingLanguageAsync | Deletes the information of the given meeting language.
Public method | DeleteMeetingLanguagesAsync | Deletes the information of the given list of meeting languages.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetAvailableDanteLicensesAsync | Gets the amount of available Dante licenses.
Public method | GetInterpretationSettingsAsync | Retrieves the interpretation settings for the meetingId.
Public method | GetMeetingLanguagesAsync | Retrieves the meeting languages defined for the default meeting.
Public method | RetrieveMeetingBoothAsync | Retrieves the meeting booth information for speficied meeting and area
Public method | RetrieveMeetingDeskAsync | Retrieves the meeting desk information for speficied meeting and seat.
Public method | RetrieveMeetingDesksAsync | Retrieves the meeting desks for speficied meeting.
Public method | UpdateInterpretationSettingsAsync | >Updates the information of interpretation settings
Public method | UpdateMeetingBoothInfoAsync | Updates the information of already eixisting meeting booth. If meeting booth information does not already exists, this function creates new meeting booth with passed information
Public method | UpdateMeetingDeskInfoAsync | Updates the information of already existing meeting desk. If meeting desk information does not already exists, this function creates new meeting desk with passed information
Public method | UpdateMeetingLanguageAsync | Updates the information of the given meeting language.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | InterpretationSettingsUpdated | Occurs when interpretation mode setings are updated.
Public event | MeetingBoothInfoChanged | Occurs when a meeting booth is changed.
Public event | MeetingDeskInfoChanged | Occurs when a meeting desk is changed.
Public event | MeetingLanguageCreated | Occurs when a meeting language is created.
Public event | MeetingLanguageDeleted | Occurs when a meeting language is deleted.
Public event | MeetingLanguageOrderChanged | Occurs when the order of meeting languages is changed.
Public event | MeetingLanguagesCreated | Occurs when a list of meeting languages is created.
Public event | MeetingLanguagesDeleted | Occurs when a list of meeting languages is deleted.
Public event | MeetingLanguageUpdated | Occurs when a meeting language is updated.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IConfigInterpretation Properties

The IConfigInterpretation type exposes the following members.

Properties
 | Name | Description
Public property | CanConfigureDanteLanguageChannels | Indicates whether it is possible to configure Dante languages or sending to Dante devices.
Public property | CanConfigureDesksAndBooths | Indicates whether it is possible to configure interpretation desks and booths.
Public property | CanConfigureInterpretationLanguages | Indicates whether it is possible to configure interpretation languages.
Public property | CanConfigureInterpretationMicrophoneModes | Indicates whether it is possible to configure interpretation microphone modes.
Top
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.CanConfigureDanteLanguageChannels Property

IConfigInterpretationCanConfigureDanteLanguageChannels Property

Bosch Logo
Indicates whether it is possible to configure Dante languages or sending to Dante devices.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanConfigureDanteLanguageChannels { get; }
ReadOnly Property CanConfigureDanteLanguageChannels As Boolean
    Get
property bool CanConfigureDanteLanguageChannels {
    bool get ();
}

Property Value

Type: Boolean
true if it is allowed to configure Dante languages or sending to Dante devices; otherwise, false.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Dante
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.CanConfigureDesksAndBooths Property

IConfigInterpretationCanConfigureDesksAndBooths Property

Indicates whether it is possible to configure interpretation desks and booths.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanConfigureDesksAndBooths { get; }
ReadOnly Property CanConfigureDesksAndBooths As Boolean
    Get
property bool CanConfigureDesksAndBooths {
    bool get ();
}

Property Value

Type: Boolean
true if it is allowed to configure interpretation desks and booths; otherwise, false.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Simultaneous Interpretation
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.CanConfigureInterpretationLanguages Property

IConfigInterpretationCanConfigureInterpretationLanguages Property

Bosch Logo
Indicates whether it is possible to configure interpretation languages.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanConfigureInterpretationLanguages { get; }
ReadOnly Property CanConfigureInterpretationLanguages As Boolean
    Get
property bool CanConfigureInterpretationLanguages {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Meeting preparation and management
  • Functional license: Simultaneaous Interpretation
  • User right: Prepare meeting and agenda.
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.CanConfigureInterpretationMicrophoneModes Property

IConfigInterpretationCanConfigureInterpretationMicrophoneModes Property

Bosch Logo
Indicates whether it is possible to configure interpretation microphone modes.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanConfigureInterpretationMicrophoneModes { get; }
ReadOnly Property CanConfigureInterpretationMicrophoneModes As Boolean
    Get
property bool CanConfigureInterpretationMicrophoneModes {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Meeting preparation and management
  • Functional license: Simultaneaous Interpretation
  • User right: Prepare meeting and agenda.
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation Methods

The IConfigInterpretation type exposes the following members.

Methods
 | Name | Description
Public method | AutoReconfigureMeetingDesksAsync | Autoreconfigure the specified seats in the specified meeting.
Public method | ChangeMeetingLanguagesOrderAsync | Updates the order of the meeting languages.
Public method | CreateMeetingLanguageAsync | Creates/Adds a meeting language
Public method | CreateMeetingLanguagesAsync | Creates/Adds a list of meeting languages
Public method | DeleteMeetingLanguageAsync | Deletes the information of the given meeting language.
Public method | DeleteMeetingLanguagesAsync | Deletes the information of the given list of meeting languages.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetAvailableDanteLicensesAsync | Gets the amount of available Dante licenses.
Public method | GetInterpretationSettingsAsync | Retrieves the interpretation settings for the meetingId.
Public method | GetMeetingLanguagesAsync | Retrieves the meeting languages defined for the default meeting.
Public method | RetrieveMeetingBoothAsync | Retrieves the meeting booth information for speficied meeting and area
Public method | RetrieveMeetingDeskAsync | Retrieves the meeting desk information for speficied meeting and seat.
Public method | RetrieveMeetingDesksAsync | Retrieves the meeting desks for speficied meeting.
Public method | UpdateInterpretationSettingsAsync | >Updates the information of interpretation settings
Public method | UpdateMeetingBoothInfoAsync | Updates the information of already eixisting meeting booth. If meeting booth information does not already exists, this function creates new meeting booth with passed information
Public method | UpdateMeetingDeskInfoAsync | Updates the information of already existing meeting desk. If meeting desk information does not already exists, this function creates new meeting desk with passed information
Public method | UpdateMeetingLanguageAsync | Updates the information of the given meeting language.
Top
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.AutoReconfigureMeetingDesksAsync Method

IConfigInterpretationAutoReconfigureMeetingDesksAsync Method

Autoreconfigure the specified seats in the specified meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> AutoReconfigureMeetingDesksAsync(
    Guid meetingId,
    IList<Guid> seatIds,
    Action<Task<bool>> onFinish = null
)
Function AutoReconfigureMeetingDesksAsync (
    meetingId As Guid,
    seatIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ AutoReconfigureMeetingDesksAsync(
    Guid meetingId,
    IList<Guid>^ seatIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
Meeting identifier.
seatIds
Type: System.Collections.GenericIList Guid
The seats which have to be reconfigured. If no seats specified (null), then all seats in the meeting are reconfigured.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the autoreconfigure the result property holds: true if autoreconfigure was successfully, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If seat id list is empty.
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.ChangeMeetingLanguagesOrderAsync Method

IConfigInterpretationChangeMeetingLanguagesOrderAsync Method

Updates the order of the meeting languages.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> ChangeMeetingLanguagesOrderAsync(
    Guid meetingId,
    IList<int> meetingLanguageIds,
    Action<Task<bool>> onFinish = null
)
Function ChangeMeetingLanguagesOrderAsync (
    meetingId As Guid,
    meetingLanguageIds As IList(Of Integer),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ ChangeMeetingLanguagesOrderAsync(
    Guid meetingId,
    IList<int>^ meetingLanguageIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
Identifies the meeting
meetingLanguageIds
Type: System.Collections.GenericIList Int32
The sorted list with language ids.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the meeting language order. The 'Result' property of the task is true if changing the order of the meeting languages succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the meeting id is empty or the list of meeting language id's is null or empty.
Remarks
Requires:
  • CanConfigureInterpretationLanguages
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.CreateMeetingLanguageAsync Method

IConfigInterpretationCreateMeetingLanguageAsync Method

Creates/Adds a meeting language

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CreateMeetingLanguageAsync(
    DcnmMeetingLanguageInfo meetingLanguageInfo,
    Action<Task<bool>> onFinish = null
)
Function CreateMeetingLanguageAsync (
    meetingLanguageInfo As DcnmMeetingLanguageInfo,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CreateMeetingLanguageAsync(
    DcnmMeetingLanguageInfo^ meetingLanguageInfo,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

meetingLanguageInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMeetingLanguageInfo
The language information to create the meeting language.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the meeting language creation. The 'Result' property of the task contains the indication if the creation of the meeting language succeeds. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If meeting id is empty, or meeting language info is null.
ArgumentOutOfRangeException | When Source2Headroom value is out of range .
Remarks
Requires:
  • CanConfigureInterpretationLanguages
Note Note
The language inside the meeting language information must be unique for the meeting.
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.CreateMeetingLanguagesAsync Method

IConfigInterpretationCreateMeetingLanguagesAsync Method

Creates/Adds a list of meeting languages

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CreateMeetingLanguagesAsync(
    IList<DcnmMeetingLanguageInfo> meetingLanguageInfos,
    Action<Task<bool>> onFinish = null
)
Function CreateMeetingLanguagesAsync (
    meetingLanguageInfos As IList(Of DcnmMeetingLanguageInfo),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CreateMeetingLanguagesAsync(
    IList<DcnmMeetingLanguageInfo^>^ meetingLanguageInfos,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

meetingLanguageInfos
Type: System.Collections.GenericIList DcnmMeetingLanguageInfo
The list of language informations to create the meeting languages.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the meeting languages creation. The 'Result' property of the task contains the indication if the creation of the list of the meeting languages succeeds. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If meeting id is empty, or meeting language info is null.
ArgumentOutOfRangeException | When one or more Source2Headroom values is out of range .
Remarks
Requires:
  • CanConfigureInterpretationLanguages
Note Note
The language inside the list of meeting language informations must be unique for the meeting.
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.DeleteMeetingLanguageAsync Method

IConfigInterpretationDeleteMeetingLanguageAsync Method

Deletes the information of the given meeting language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeleteMeetingLanguageAsync(
    Guid meetingId,
    int orderId,
    Action<Task<bool>> onFinish = null
)
Function DeleteMeetingLanguageAsync (
    meetingId As Guid,
    orderId As Integer,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeleteMeetingLanguageAsync(
    Guid meetingId,
    int orderId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The meeting identifier of which to delete the meeting language.
orderId
Type: SystemInt32
The order identifier of the meeting language to delete.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing meeting language delete. The 'Result' property of the task is true if delete meeting language succeeds, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the meeting id is empty, the meeting language id is empty or the meeting and meeting language combination does not exist.
Remarks
Requires:
  • CanConfigureInterpretationLanguages
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.DeleteMeetingLanguagesAsync Method

IConfigInterpretationDeleteMeetingLanguagesAsync Method

Deletes the information of the given list of meeting languages.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeleteMeetingLanguagesAsync(
    Guid meetingId,
    IList<int> orderIds,
    Action<Task<bool>> onFinish = null
)
Function DeleteMeetingLanguagesAsync (
    meetingId As Guid,
    orderIds As IList(Of Integer),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeleteMeetingLanguagesAsync(
    Guid meetingId,
    IList<int>^ orderIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The meeting identifier of which to delete the list of meeting languages.
orderIds
Type: System.Collections.GenericIList Int32
The list of order identifiers of the meeting languages to delete.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing meeting languages delete. The 'Result' property of the task is true if delete meeting languages succeeds, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the meeting id is empty, the meeting language id is empty or the meeting and meeting language combination does not exist.
Remarks
Requires:
  • CanConfigureInterpretationLanguages
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.GetAvailableDanteLicensesAsync Method

IConfigInterpretationGetAvailableDanteLicensesAsync Method

Gets the amount of available Dante licenses.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<int> GetAvailableDanteLicensesAsync(
    Guid meetingId,
    Action<Task<int>> onFinish = null
)
Function GetAvailableDanteLicensesAsync (
    meetingId As Guid,
    Optional onFinish As Action(Of Task(Of Integer)) = Nothing
) As Task(Of Integer)
Task<int>^ GetAvailableDanteLicensesAsync(
    Guid meetingId,
    Action<Task<int>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting for which to retrieve the amount of available Dante licenses.
onFinish (Optional)
Type: SystemAction Task Int32
Optional action for asynchronous handling of the result.

Return Value

Type: Task Int32
The amount of Dante licenses available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.GetInterpretationSettingsAsync Method

IConfigInterpretationGetInterpretationSettingsAsync Method

Retrieves the interpretation settings for the meetingId.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<DcnmInterpretationSettingsInfo> GetInterpretationSettingsAsync(
    Guid meetingId,
    Action<Task<DcnmInterpretationSettingsInfo>> onFinish = null
)
Function GetInterpretationSettingsAsync (
    meetingId As Guid,
    Optional onFinish As Action(Of Task(Of DcnmInterpretationSettingsInfo)) = Nothing
) As Task(Of DcnmInterpretationSettingsInfo)
Task<DcnmInterpretationSettingsInfo^>^ GetInterpretationSettingsAsync(
    Guid meetingId,
    Action<Task<DcnmInterpretationSettingsInfo^>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The meeting id for which interpretation settings needs to be fetched.
onFinish (Optional)
Type: SystemAction Task DcnmInterpretationSettingsInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task DcnmInterpretationSettingsInfo
Task processing the interpretation settings retrieval. The 'Result' property of the task holds the list of retrieved interpretation settings. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanConfigureInterpretationMicrophoneModes
If meetingId is Guid.Empty, then interpretation settings of Default Meeting will be fetched.
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.GetMeetingLanguagesAsync Method

IConfigInterpretationGetMeetingLanguagesAsync Method

Retrieves the meeting languages defined for the default meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmMeetingLanguageInfo>> GetMeetingLanguagesAsync(
    Guid meetingId,
    Action<Task<IList<DcnmMeetingLanguageInfo>>> onFinish = null
)
Function GetMeetingLanguagesAsync (
    meetingId As Guid,
    Optional onFinish As Action(Of Task(Of IList(Of DcnmMeetingLanguageInfo))) = Nothing
) As Task(Of IList(Of DcnmMeetingLanguageInfo))
Task<IList<DcnmMeetingLanguageInfo^>^>^ GetMeetingLanguagesAsync(
    Guid meetingId,
    Action<Task<IList<DcnmMeetingLanguageInfo^>^>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The meeting identifier.
onFinish (Optional)
Type: SystemAction Task IList DcnmMeetingLanguageInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmMeetingLanguageInfo
Task processing the meeting languages retrieval. The 'Result' property of the task holds the list of retrieved languages. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If meeting id is empty.
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.RetrieveMeetingBoothAsync Method

IConfigInterpretationRetrieveMeetingBoothAsync Method

Retrieves the meeting booth information for speficied meeting and area

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<DcnmMeetingBoothInfo> RetrieveMeetingBoothAsync(
    Guid meetingId,
    Guid areaId,
    Action<Task<DcnmMeetingBoothInfo>> onFinish = null
)
Function RetrieveMeetingBoothAsync (
    meetingId As Guid,
    areaId As Guid,
    Optional onFinish As Action(Of Task(Of DcnmMeetingBoothInfo)) = Nothing
) As Task(Of DcnmMeetingBoothInfo)
Task<DcnmMeetingBoothInfo^>^ RetrieveMeetingBoothAsync(
    Guid meetingId,
    Guid areaId,
    Action<Task<DcnmMeetingBoothInfo^>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The meeting identifier.
areaId
Type: SystemGuid
The area identifier.
onFinish (Optional)
Type: SystemAction Task DcnmMeetingBoothInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task DcnmMeetingBoothInfo
Task processing the meeting booth information retrieval. The 'Result' property of the task holds the retrieved meeting booth information. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If area id is empty.
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.RetrieveMeetingDeskAsync Method

IConfigInterpretationRetrieveMeetingDeskAsync Method

Retrieves the meeting desk information for speficied meeting and seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<DcnmMeetingDeskInfo> RetrieveMeetingDeskAsync(
    Guid meetingId,
    Guid seatId,
    Action<Task<DcnmMeetingDeskInfo>> onFinish = null
)
Function RetrieveMeetingDeskAsync (
    meetingId As Guid,
    seatId As Guid,
    Optional onFinish As Action(Of Task(Of DcnmMeetingDeskInfo)) = Nothing
) As Task(Of DcnmMeetingDeskInfo)
Task<DcnmMeetingDeskInfo^>^ RetrieveMeetingDeskAsync(
    Guid meetingId,
    Guid seatId,
    Action<Task<DcnmMeetingDeskInfo^>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The meeting identifier.
seatId
Type: SystemGuid
The seat identifier.
onFinish (Optional)
Type: SystemAction Task DcnmMeetingDeskInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task DcnmMeetingDeskInfo
Task processing the meeting desk information retrieval. The 'Result' property of the task holds the retrieved meeting desk information. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If seat id is empty.
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.RetrieveMeetingDesksAsync Method

IConfigInterpretationRetrieveMeetingDesksAsync Method

Retrieves the meeting desks for speficied meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmMeetingDeskInfo>> RetrieveMeetingDesksAsync(
    Guid meetingId,
    Action<Task<IList<DcnmMeetingDeskInfo>>> onFinish = null
)
Function RetrieveMeetingDesksAsync (
    meetingId As Guid,
    Optional onFinish As Action(Of Task(Of IList(Of DcnmMeetingDeskInfo))) = Nothing
) As Task(Of IList(Of DcnmMeetingDeskInfo))
Task<IList<DcnmMeetingDeskInfo^>^>^ RetrieveMeetingDesksAsync(
    Guid meetingId,
    Action<Task<IList<DcnmMeetingDeskInfo^>^>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The meeting identifier.
onFinish (Optional)
Type: SystemAction Task IList DcnmMeetingDeskInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmMeetingDeskInfo
Task processing the meeting desk information retrieval. The 'Result' property of the task holds the retrieved meeting desks information. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If seat id is empty.
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.UpdateInterpretationSettingsAsync Method

IConfigInterpretationUpdateInterpretationSettingsAsync Method

Bosch Logo
>Updates the information of interpretation settings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateInterpretationSettingsAsync(
    DcnmInterpretationSettingsInfo interpretationSettingsInfo,
    Action<Task<bool>> onFinish = null
)
Function UpdateInterpretationSettingsAsync (
    interpretationSettingsInfo As DcnmInterpretationSettingsInfo,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateInterpretationSettingsAsync(
    DcnmInterpretationSettingsInfo^ interpretationSettingsInfo,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

interpretationSettingsInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationSettingsInfo
The interpretation information to update the interpretation settings with.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing interpretation settings update. The 'Result' property of the task is true if updating interpretation settings succeeds, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If interpretation settings information is null.
ArgumentOutOfRangeException
  • If SpeakSlowRequestReleaseTime is not between SPEAKSLOW_MIN_RELEASETIME and SPEAKSLOW_MAX_CONFIGVALUE
  • If MinimumSpeakSlowRequest is not between SPEAKSLOW_MIN_REQUESTS and SPEAKSLOW_MAX_CONFIGVALUE
  • If SpeakSlowSignallingReleaseTime is not between SPEAKSLOW_MIN_RELEASETIME and SPEAKSLOW_MAX_CONFIGVALUE
Remarks
Requires:
  • CanConfigureInterpretationMicrophoneModes
If interpretationSettingsInfo.MeetingId is Guid.Empty, then interpretation settings information for Default Meeting will be updated.
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.UpdateMeetingBoothInfoAsync Method

IConfigInterpretationUpdateMeetingBoothInfoAsync Method

Updates the information of already eixisting meeting booth. If meeting booth information does not already exists, this function creates new meeting booth with passed information

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateMeetingBoothInfoAsync(
    DcnmMeetingBoothInfo meetingBoothInfo,
    Action<Task<bool>> onFinish = null
)
Function UpdateMeetingBoothInfoAsync (
    meetingBoothInfo As DcnmMeetingBoothInfo,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateMeetingBoothInfoAsync(
    DcnmMeetingBoothInfo^ meetingBoothInfo,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

meetingBoothInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMeetingBoothInfo
The meeting booth information DcnmMeetingBoothInfoto update.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing meeting booth update. The 'Result' property of the task is true if updating meeting booth info succeeds, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the meeting booth information is null
Remarks
Requires:
  • CanConfigureDesksAndBooths
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.UpdateMeetingDeskInfoAsync Method

IConfigInterpretationUpdateMeetingDeskInfoAsync Method

Updates the information of already existing meeting desk. If meeting desk information does not already exists, this function creates new meeting desk with passed information

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateMeetingDeskInfoAsync(
    DcnmMeetingDeskInfo meetingDeskInfo,
    Action<Task<bool>> onFinish = null
)
Function UpdateMeetingDeskInfoAsync (
    meetingDeskInfo As DcnmMeetingDeskInfo,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateMeetingDeskInfoAsync(
    DcnmMeetingDeskInfo^ meetingDeskInfo,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

meetingDeskInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMeetingDeskInfo
The meeting desk information DcnmMeetingDeskInfo to update.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing meeting desk information update. The 'Result' property of the task is true if updating meeting desk information succeeds, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the meeting desk information is null or the audio video delay value is below 0 or above 1000.
Remarks
Requires:
  • CanConfigureDesksAndBooths
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.UpdateMeetingLanguageAsync Method

IConfigInterpretationUpdateMeetingLanguageAsync Method

Updates the information of the given meeting language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateMeetingLanguageAsync(
    DcnmMeetingLanguageInfo meetingLanguageInfo,
    Action<Task<bool>> onFinish = null
)
Function UpdateMeetingLanguageAsync (
    meetingLanguageInfo As DcnmMeetingLanguageInfo,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateMeetingLanguageAsync(
    DcnmMeetingLanguageInfo^ meetingLanguageInfo,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

meetingLanguageInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMeetingLanguageInfo
The language information to update the meeting language with.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing meeting languages update. The 'Result' property of the task is true if updating meeting language succeeds, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the meeting id is empty, the meeting language information is null or the meeting and meeting language combination does not exist.
ArgumentOutOfRangeException | When Source2Headroom value is out of range .
Remarks
Requires:
  • CanConfigureInterpretationLanguages
Note Note
The language inside the meeting language information must be unique for the default meeting.
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation Events

The IConfigInterpretation type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | InterpretationSettingsUpdated | Occurs when interpretation mode setings are updated.
Public event | MeetingBoothInfoChanged | Occurs when a meeting booth is changed.
Public event | MeetingDeskInfoChanged | Occurs when a meeting desk is changed.
Public event | MeetingLanguageCreated | Occurs when a meeting language is created.
Public event | MeetingLanguageDeleted | Occurs when a meeting language is deleted.
Public event | MeetingLanguageOrderChanged | Occurs when the order of meeting languages is changed.
Public event | MeetingLanguagesCreated | Occurs when a list of meeting languages is created.
Public event | MeetingLanguagesDeleted | Occurs when a list of meeting languages is deleted.
Public event | MeetingLanguageUpdated | Occurs when a meeting language is updated.
Top
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.CapabilitiesChanged Event

IConfigInterpretationCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.InterpretationSettingsUpdated Event

IConfigInterpretationInterpretationSettingsUpdated Event

Occurs when interpretation mode setings are updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmInterpretationSettingsInfo>> InterpretationSettingsUpdated
Event InterpretationSettingsUpdated As EventHandler(Of ApiEventArgs(Of DcnmInterpretationSettingsInfo))
 event EventHandler<ApiEventArgs<DcnmInterpretationSettingsInfo^>^>^ InterpretationSettingsUpdated {
    void add (EventHandler<ApiEventArgs<DcnmInterpretationSettingsInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmInterpretationSettingsInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmInterpretationSettingsInfo
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.MeetingBoothInfoChanged Event

IConfigInterpretationMeetingBoothInfoChanged Event

Occurs when a meeting booth is changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmMeetingBoothInfo>> MeetingBoothInfoChanged
Event MeetingBoothInfoChanged As EventHandler(Of ApiEventArgs(Of DcnmMeetingBoothInfo))
 event EventHandler<ApiEventArgs<DcnmMeetingBoothInfo^>^>^ MeetingBoothInfoChanged {
    void add (EventHandler<ApiEventArgs<DcnmMeetingBoothInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmMeetingBoothInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmMeetingBoothInfo
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.MeetingDeskInfoChanged Event

IConfigInterpretationMeetingDeskInfoChanged Event

Occurs when a meeting desk is changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmMeetingDeskInfo>> MeetingDeskInfoChanged
Event MeetingDeskInfoChanged As EventHandler(Of ApiEventArgs(Of DcnmMeetingDeskInfo))
 event EventHandler<ApiEventArgs<DcnmMeetingDeskInfo^>^>^ MeetingDeskInfoChanged {
    void add (EventHandler<ApiEventArgs<DcnmMeetingDeskInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmMeetingDeskInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmMeetingDeskInfo
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.MeetingLanguageCreated Event

IConfigInterpretationMeetingLanguageCreated Event

Occurs when a meeting language is created.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmMeetingLanguageInfo>> MeetingLanguageCreated
Event MeetingLanguageCreated As EventHandler(Of ApiEventArgs(Of DcnmMeetingLanguageInfo))
 event EventHandler<ApiEventArgs<DcnmMeetingLanguageInfo^>^>^ MeetingLanguageCreated {
    void add (EventHandler<ApiEventArgs<DcnmMeetingLanguageInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmMeetingLanguageInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmMeetingLanguageInfo
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.MeetingLanguageDeleted Event

IConfigInterpretationMeetingLanguageDeleted Event

Occurs when a meeting language is deleted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmMeetingLanguageInfo>> MeetingLanguageDeleted
Event MeetingLanguageDeleted As EventHandler(Of ApiEventArgs(Of DcnmMeetingLanguageInfo))
 event EventHandler<ApiEventArgs<DcnmMeetingLanguageInfo^>^>^ MeetingLanguageDeleted {
    void add (EventHandler<ApiEventArgs<DcnmMeetingLanguageInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmMeetingLanguageInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmMeetingLanguageInfo
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.MeetingLanguageOrderChanged Event

IConfigInterpretationMeetingLanguageOrderChanged Event

Occurs when the order of meeting languages is changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler MeetingLanguageOrderChanged
Event MeetingLanguageOrderChanged As EventHandler
 event EventHandler^ MeetingLanguageOrderChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.MeetingLanguagesCreated Event

IConfigInterpretationMeetingLanguagesCreated Event

Occurs when a list of meeting languages is created.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmMeetingLanguageInfo>>> MeetingLanguagesCreated
Event MeetingLanguagesCreated As EventHandler(Of ApiEventArgs(Of IList(Of DcnmMeetingLanguageInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmMeetingLanguageInfo^>^>^>^ MeetingLanguagesCreated {
    void add (EventHandler<ApiEventArgs<IList<DcnmMeetingLanguageInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmMeetingLanguageInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmMeetingLanguageInfo
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.MeetingLanguagesDeleted Event

IConfigInterpretationMeetingLanguagesDeleted Event

Occurs when a list of meeting languages is deleted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmMeetingLanguageInfo>>> MeetingLanguagesDeleted
Event MeetingLanguagesDeleted As EventHandler(Of ApiEventArgs(Of IList(Of DcnmMeetingLanguageInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmMeetingLanguageInfo^>^>^>^ MeetingLanguagesDeleted {
    void add (EventHandler<ApiEventArgs<IList<DcnmMeetingLanguageInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmMeetingLanguageInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmMeetingLanguageInfo
See Also

Reference

IConfigInterpretation Interface


IConfigInterpretation.MeetingLanguageUpdated Event

IConfigInterpretationMeetingLanguageUpdated Event

Occurs when a meeting language is updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmMeetingLanguageInfo>> MeetingLanguageUpdated
Event MeetingLanguageUpdated As EventHandler(Of ApiEventArgs(Of DcnmMeetingLanguageInfo))
 event EventHandler<ApiEventArgs<DcnmMeetingLanguageInfo^>^>^ MeetingLanguageUpdated {
    void add (EventHandler<ApiEventArgs<DcnmMeetingLanguageInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmMeetingLanguageInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmMeetingLanguageInfo
See Also

Reference

IConfigInterpretation Interface


IConfigLanguage Interface

Represents the interface to configure / extend the languages present in the system

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IConfigLanguage : IDisposable
Public Interface IConfigLanguage
    Inherits IDisposable
public interface class IConfigLanguage : IDisposable

The IConfigLanguage type exposes the following members.

Properties
 | Name | Description
Public property | CanConfigureLanguages | Indicates whether it is possible to configure languages.
Top
Methods
 | Name | Description
Public method | CreateLanguageAsync | Creates/Adds a language
Public method | DeleteLanguageAsync | deletes the information of the given language.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetLanguagesAsync | Retrieves the languages present.
Public method | UpdateLanguageAsync | Updates the information of the given language.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | LanguageCreated | Occurs when a language is created.
Public event | LanguageDeleted | Occurs when a language is deleted.
Public event | LanguageUpdated | Occurs when a language is updated.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IConfigLanguage Properties

The IConfigLanguage type exposes the following members.

Properties
 | Name | Description
Public property | CanConfigureLanguages | Indicates whether it is possible to configure languages.
Top
See Also

Reference

IConfigLanguage Interface


IConfigLanguage.CanConfigureLanguages Property

IConfigLanguageCanConfigureLanguages Property

Indicates whether it is possible to configure languages.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanConfigureLanguages { get; }
ReadOnly Property CanConfigureLanguages As Boolean
    Get
property bool CanConfigureLanguages {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • User right: Configure System.
See Also

Reference

IConfigLanguage Interface


IConfigLanguage Methods

The IConfigLanguage type exposes the following members.

Methods
 | Name | Description
Public method | CreateLanguageAsync | Creates/Adds a language
Public method | DeleteLanguageAsync | deletes the information of the given language.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetLanguagesAsync | Retrieves the languages present.
Public method | UpdateLanguageAsync | Updates the information of the given language.
Top
See Also

Reference

IConfigLanguage Interface


IConfigLanguage.CreateLanguageAsync Method

IConfigLanguageCreateLanguageAsync Method

Creates/Adds a language

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<Guid> CreateLanguageAsync(
    DcnmLanguageInfo languageInfo,
    Action<Task<Guid>> onFinish = null
)
Function CreateLanguageAsync (
    languageInfo As DcnmLanguageInfo,
    Optional onFinish As Action(Of Task(Of Guid)) = Nothing
) As Task(Of Guid)
Task<Guid>^ CreateLanguageAsync(
    DcnmLanguageInfo^ languageInfo,
    Action<Task<Guid>^>^ onFinish = nullptr
)

Parameters

languageInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLanguageInfo
The language information to create the language.
onFinish (Optional)
Type: SystemAction Task Guid
Optional action for asynchronous handling of the result.

Return Value

Type: Task Guid
Task processing the language creation. The 'Result' property of the task contains the Guid if succeeded, empty otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If language info is null.
Remarks
Requires:
  • CanConfigureLanguages

The provided language can only added if the abbreviation of the language is unique.

See Also

Reference

IConfigLanguage Interface


IConfigLanguage.DeleteLanguageAsync Method

IConfigLanguageDeleteLanguageAsync Method

deletes the information of the given language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeleteLanguageAsync(
    Guid languageId,
    Action<Task<bool>> onFinish = null
)
Function DeleteLanguageAsync (
    languageId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeleteLanguageAsync(
    Guid languageId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

languageId
Type: SystemGuid
The language indentification to delete.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing languages delete. The 'Result' property of the task is true if updating language succeeds, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If language id is empty or null.
Remarks
Requires:
  • CanConfigureLanguages

Only user-defined languages (the UserDefined flag is set) can be deleted. In case the flag is not set, the delete action is ignored.

See Also

Reference

IConfigLanguage Interface


IConfigLanguage.GetLanguagesAsync Method

IConfigLanguageGetLanguagesAsync Method

Retrieves the languages present.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmLanguageInfo>> GetLanguagesAsync(
    Action<Task<IList<DcnmLanguageInfo>>> onFinish = null
)
Function GetLanguagesAsync (
    Optional onFinish As Action(Of Task(Of IList(Of DcnmLanguageInfo))) = Nothing
) As Task(Of IList(Of DcnmLanguageInfo))
Task<IList<DcnmLanguageInfo^>^>^ GetLanguagesAsync(
    Action<Task<IList<DcnmLanguageInfo^>^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task IList DcnmLanguageInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmLanguageInfo
Task processing the languages retrieval. The 'Result' property of the task holds the list of retrieved languages. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
The returned list of languages is by default ordered on OrderId and Abbreviation (both ascending).
See Also

Reference

IConfigLanguage Interface


IConfigLanguage.UpdateLanguageAsync Method

IConfigLanguageUpdateLanguageAsync Method

Updates the information of the given language.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateLanguageAsync(
    DcnmLanguageInfo languageInfo,
    Action<Task<bool>> onFinish = null
)
Function UpdateLanguageAsync (
    languageInfo As DcnmLanguageInfo,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateLanguageAsync(
    DcnmLanguageInfo^ languageInfo,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

languageInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmLanguageInfo
The language information to update the language with.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing languages update. The 'Result' property of the task is true if updating language succeeds, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If language info is null.
Remarks
Requires:
  • CanConfigureLanguages

For pre-defined languages (UserDefined flag is not set) only the OrderId can be changed. All other preperties on the provided language information is ignored.

For user defined languages all parameters can be changed.

See Also

Reference

IConfigLanguage Interface


IConfigLanguage Events

The IConfigLanguage type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | LanguageCreated | Occurs when a language is created.
Public event | LanguageDeleted | Occurs when a language is deleted.
Public event | LanguageUpdated | Occurs when a language is updated.
Top
See Also

Reference

IConfigLanguage Interface


IConfigLanguage.CapabilitiesChanged Event

IConfigLanguageCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IConfigLanguage Interface


IConfigLanguage.LanguageCreated Event

IConfigLanguageLanguageCreated Event

Occurs when a language is created.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmLanguageInfo>> LanguageCreated
Event LanguageCreated As EventHandler(Of ApiEventArgs(Of DcnmLanguageInfo))
 event EventHandler<ApiEventArgs<DcnmLanguageInfo^>^>^ LanguageCreated {
    void add (EventHandler<ApiEventArgs<DcnmLanguageInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmLanguageInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmLanguageInfo
See Also

Reference

IConfigLanguage Interface


IConfigLanguage.LanguageDeleted Event

IConfigLanguageLanguageDeleted Event

Occurs when a language is deleted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<Guid>> LanguageDeleted
Event LanguageDeleted As EventHandler(Of ApiEventArgs(Of Guid))
 event EventHandler<ApiEventArgs<Guid>^>^ LanguageDeleted {
    void add (EventHandler<ApiEventArgs<Guid>^>^ value);
    void remove (EventHandler<ApiEventArgs<Guid>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Guid
See Also

Reference

IConfigLanguage Interface


IConfigLanguage.LanguageUpdated Event

IConfigLanguageLanguageUpdated Event

Occurs when a language is updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmLanguageInfo>> LanguageUpdated
Event LanguageUpdated As EventHandler(Of ApiEventArgs(Of DcnmLanguageInfo))
 event EventHandler<ApiEventArgs<DcnmLanguageInfo^>^>^ LanguageUpdated {
    void add (EventHandler<ApiEventArgs<DcnmLanguageInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmLanguageInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmLanguageInfo
See Also

Reference

IConfigLanguage Interface


IConfigSite Interface

Represents an interface to configure a site.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IConfigSite : IDisposable
Public Interface IConfigSite
    Inherits IDisposable
public interface class IConfigSite : IDisposable

The IConfigSite type exposes the following members.

Properties
 | Name | Description
Public property | CanConfigureSimultaneousInterpretation | Indicates whether it is possible to configure simultaneous interpretation.
Public property | CanConfigureSite | Indicates whether it is possible to configure a site.
Top
Methods
 | Name | Description
Public method | CreateAreaAsync | Creates a new area using the specified area configuration information.
Public method | DeleteAreaAsync | Removes the area.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetAreasAsync(ActionTaskIListDcnmAreaConfigurationInfo) | Gets all the meeting areas at all area controllers.
Public method | GetAreasAsync(Guid, ActionTaskIListDcnmAreaConfigurationInfo) | Gets all the meeting areas for the specified area controller.
Public method | GetAutoPowerOffDelayAsync | Retrieves auto power off delay value configured in system. Returned power off delay timer value in seconds.
Public method | GetUiLanguagesAsync | Gets the user interface languages supported.
Public method | RetrieveMaxLanguagesAsync | Retrieves maximum number of interpretation languages.
Public method | RetrieveWebcastingLicenseAsync | Retrieves the available webcasting license.
Public method | SetAutoPowerOffDelayAsync | Updates auto power off delay in system.
Public method | UpdateAreaAsync | Updates the area configuration information.
Public method | UpdateImageServerInfoAsync | Updates the image server info.
Public method | UpdateMaxLanguagesAsync | Updates the maximum number of interpretation languages.
Public method | ValidateImageServerConnectionAsync | Validates image server connection.
Top
Events
 | Name | Description
Public event | AutoPowerOffDelayChanged | Occurs when auto power off delay value is updated.
Public event | CapabilitiesChanged | Occurs when the capabilities of the API changed.
Public event | MaxLanguagesChanged | Occurs when the Max Languages setting has changed.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IConfigSite Properties

The IConfigSite type exposes the following members.

Properties
 | Name | Description
Public property | CanConfigureSimultaneousInterpretation | Indicates whether it is possible to configure simultaneous interpretation.
Public property | CanConfigureSite | Indicates whether it is possible to configure a site.
Top
See Also

Reference

IConfigSite Interface


IConfigSite.CanConfigureSimultaneousInterpretation Property

IConfigSiteCanConfigureSimultaneousInterpretation Property

Indicates whether it is possible to configure simultaneous interpretation.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanConfigureSimultaneousInterpretation { get; }
ReadOnly Property CanConfigureSimultaneousInterpretation As Boolean
    Get
property bool CanConfigureSimultaneousInterpretation {
    bool get ();
}

Property Value

Type: Boolean
true if it is allowed to configure simultaneous interpretation; otherwise, false.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Simultaneous Interpretation
See Also

Reference

IConfigSite Interface


IConfigSite.CanConfigureSite Property

IConfigSiteCanConfigureSite Property

Indicates whether it is possible to configure a site.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanConfigureSite { get; }
ReadOnly Property CanConfigureSite As Boolean
    Get
property bool CanConfigureSite {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IConfigSite Interface


IConfigSite Methods

The IConfigSite type exposes the following members.

Methods
 | Name | Description
Public method | CreateAreaAsync | Creates a new area using the specified area configuration information.
Public method | DeleteAreaAsync | Removes the area.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetAreasAsync(ActionTaskIListDcnmAreaConfigurationInfo) | Gets all the meeting areas at all area controllers.
Public method | GetAreasAsync(Guid, ActionTaskIListDcnmAreaConfigurationInfo) | Gets all the meeting areas for the specified area controller.
Public method | GetAutoPowerOffDelayAsync | Retrieves auto power off delay value configured in system. Returned power off delay timer value in seconds.
Public method | GetUiLanguagesAsync | Gets the user interface languages supported.
Public method | RetrieveMaxLanguagesAsync | Retrieves maximum number of interpretation languages.
Public method | RetrieveWebcastingLicenseAsync | Retrieves the available webcasting license.
Public method | SetAutoPowerOffDelayAsync | Updates auto power off delay in system.
Public method | UpdateAreaAsync | Updates the area configuration information.
Public method | UpdateImageServerInfoAsync | Updates the image server info.
Public method | UpdateMaxLanguagesAsync | Updates the maximum number of interpretation languages.
Public method | ValidateImageServerConnectionAsync | Validates image server connection.
Top
See Also

Reference

IConfigSite Interface


IConfigSite.CreateAreaAsync Method

IConfigSiteCreateAreaAsync Method

Creates a new area using the specified area configuration information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<Guid> CreateAreaAsync(
    DcnmAreaConfigurationInfo areaConfigurationInfo,
    Action<Task<Guid>> onFinish = null
)
Function CreateAreaAsync (
    areaConfigurationInfo As DcnmAreaConfigurationInfo,
    Optional onFinish As Action(Of Task(Of Guid)) = Nothing
) As Task(Of Guid)
Task<Guid>^ CreateAreaAsync(
    DcnmAreaConfigurationInfo^ areaConfigurationInfo,
    Action<Task<Guid>^>^ onFinish = nullptr
)

Parameters

areaConfigurationInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAreaConfigurationInfo
The area configuration information.
onFinish (Optional)
Type: SystemAction Task Guid
Optional action for asynchronous handling of the result.

Return Value

Type: Task Guid
Task processing the creation of a area. The 'Result' property of the task holds the guid of the created booth. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanConfigureSimultaneousInterpretation
This method is intended to create area of type BoothArea and not MeetingArea, else create will fail
See Also

Reference

IConfigSite Interface


IConfigSite.DeleteAreaAsync Method

IConfigSiteDeleteAreaAsync Method

Removes the area.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeleteAreaAsync(
    Guid areaId,
    Action<Task<bool>> onFinish = null
)
Function DeleteAreaAsync (
    areaId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeleteAreaAsync(
    Guid areaId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

areaId
Type: SystemGuid
The identifier of the area.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the deletion of a area. The 'Result' property of the task holds the indication if the delete succeeded. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanConfigureSimultaneousInterpretation
The area can only be deleted if it is empty i.e. there are no desks in the specified area. This method cannot be used to delete the MeetingArea
See Also

Reference

IConfigSite Interface


IConfigSite.GetAreasAsync Method

IConfigSiteGetAreasAsync Method

There are two overloads for this method
Overload List
 | Name | Description
Public method | GetAreasAsync(ActionTaskIListDcnmAreaConfigurationInfo) | Gets all the meeting areas at all area controllers.
Public method | GetAreasAsync(Guid, ActionTaskIListDcnmAreaConfigurationInfo) | Gets all the meeting areas for the specified area controller.
Top
See Also

Reference

IConfigSite Interface


IConfigSite.GetAreasAsync Method (Action(Task(IList(DcnmAreaConfigurationInfo))))

IConfigSiteGetAreasAsync Method (ActionTaskIListDcnmAreaConfigurationInfo)

 Bosch Logo
Gets all the meeting areas at all area controllers.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmAreaConfigurationInfo>> GetAreasAsync(
    Action<Task<IList<DcnmAreaConfigurationInfo>>> onFinish = null
)
Function GetAreasAsync (
    Optional onFinish As Action(Of Task(Of IList(Of DcnmAreaConfigurationInfo))) = Nothing
) As Task(Of IList(Of DcnmAreaConfigurationInfo))
Task<IList<DcnmAreaConfigurationInfo^>^>^ GetAreasAsync(
    Action<Task<IList<DcnmAreaConfigurationInfo^>^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task IList DcnmAreaConfigurationInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmAreaConfigurationInfo
Task processing the retrieval of meeting areas (from an area controller). The 'Result' property of the task holds the list of available meeting areas. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
This function retrieves all the areas existing in the system
See Also

Reference

IConfigSite Interface
GetAreasAsync Overload


IConfigSite.GetAreasAsync Method (Guid, Action(Task(IList(DcnmAreaConfigurationInfo))))

IConfigSiteGetAreasAsync Method (Guid, ActionTaskIListDcnmAreaConfigurationInfo)

 Bosch Logo
Gets all the meeting areas for the specified area controller.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmAreaConfigurationInfo>> GetAreasAsync(
    Guid areaControllerId,
    Action<Task<IList<DcnmAreaConfigurationInfo>>> onFinish = null
)
Function GetAreasAsync (
    areaControllerId As Guid,
    Optional onFinish As Action(Of Task(Of IList(Of DcnmAreaConfigurationInfo))) = Nothing
) As Task(Of IList(Of DcnmAreaConfigurationInfo))
Task<IList<DcnmAreaConfigurationInfo^>^>^ GetAreasAsync(
    Guid areaControllerId,
    Action<Task<IList<DcnmAreaConfigurationInfo^>^>^>^ onFinish = nullptr
)

Parameters

areaControllerId
Type: SystemGuid
The identifier of the area controller.
onFinish (Optional)
Type: SystemAction Task IList DcnmAreaConfigurationInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmAreaConfigurationInfo
Task processing the retrieval of meeting areas (from an area controller). The 'Result' property of the task holds the list of available meeting areas. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
This function retrieves areas for the specified areaControllerId
See Also

Reference

IConfigSite Interface
GetAreasAsync Overload


IConfigSite.GetAutoPowerOffDelayAsync Method

IConfigSiteGetAutoPowerOffDelayAsync Method

Retrieves auto power off delay value configured in system. Returned power off delay timer value in seconds.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<int> GetAutoPowerOffDelayAsync(
    Action<Task<int>> onFinish = null
)
Function GetAutoPowerOffDelayAsync (
    Optional onFinish As Action(Of Task(Of Integer)) = Nothing
) As Task(Of Integer)
Task<int>^ GetAutoPowerOffDelayAsync(
    Action<Task<int>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Int32
Optional action for asynchronous handling of the result.

Return Value

Type: Task Int32
Task processing the auto power off delay retrieval. The 'Result' property of the task contains the auto power off delay. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IConfigSite Interface


IConfigSite.GetUiLanguagesAsync Method

IConfigSiteGetUiLanguagesAsync Method

Gets the user interface languages supported.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<string>> GetUiLanguagesAsync(
    Action<Task<IList<string>>> onFinish = null
)
Function GetUiLanguagesAsync (
    Optional onFinish As Action(Of Task(Of IList(Of String))) = Nothing
) As Task(Of IList(Of String))
Task<IList<String^>^>^ GetUiLanguagesAsync(
    Action<Task<IList<String^>^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task IList String
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList String
The task processing the UI languages retrieval. The 'Result' property of the task holds the list of supported languages formatted according the RFC 1766 standard. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IConfigSite Interface


IConfigSite.RetrieveMaxLanguagesAsync Method

IConfigSiteRetrieveMaxLanguagesAsync Method

Retrieves maximum number of interpretation languages.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<int> RetrieveMaxLanguagesAsync(
    Action<Task<int>> onFinish = null
)
Function RetrieveMaxLanguagesAsync (
    Optional onFinish As Action(Of Task(Of Integer)) = Nothing
) As Task(Of Integer)
Task<int>^ RetrieveMaxLanguagesAsync(
    Action<Task<int>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Int32
Optional action for asynchronous handling of the result.

Return Value

Type: Task Int32
A task that retrieves the max languages setting which is returned via the tasks's Result property. Note that the Result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IConfigSite Interface


IConfigSite.RetrieveWebcastingLicenseAsync Method

IConfigSiteRetrieveWebcastingLicenseAsync Method

Retrieves the available webcasting license.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<DcnmWebcastingLicense> RetrieveWebcastingLicenseAsync(
    Action<Task<DcnmWebcastingLicense>> onFinish = null
)
Function RetrieveWebcastingLicenseAsync (
    Optional onFinish As Action(Of Task(Of DcnmWebcastingLicense)) = Nothing
) As Task(Of DcnmWebcastingLicense)
Task<DcnmWebcastingLicense>^ RetrieveWebcastingLicenseAsync(
    Action<Task<DcnmWebcastingLicense>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task DcnmWebcastingLicense
Optional action for asynchronous handling of the result.

Return Value

Type: Task DcnmWebcastingLicense
Task processing the webcasting license retrieval. The 'Result' property of the task contains the available webcasting license. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IConfigSite Interface


IConfigSite.SetAutoPowerOffDelayAsync Method

IConfigSiteSetAutoPowerOffDelayAsync Method

Updates auto power off delay in system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetAutoPowerOffDelayAsync(
    int powerOffDelay,
    Action<Task<bool>> onFinish = null
)
Function SetAutoPowerOffDelayAsync (
    powerOffDelay As Integer,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetAutoPowerOffDelayAsync(
    int powerOffDelay,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

powerOffDelay
Type: SystemInt32
Power off delay value in seconds
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the auto power off delay timer update. The 'Result' property of the task holds the return value of the function. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If power off delay value is negative number.
Remarks
The powerOffDelay value 0(zero) indicates auto power off is disabled
See Also

Reference

IConfigSite Interface


IConfigSite.UpdateAreaAsync Method

IConfigSiteUpdateAreaAsync Method

Updates the area configuration information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateAreaAsync(
    DcnmAreaConfigurationInfo areaConfigurationInfo,
    Action<Task<bool>> onFinish = null
)
Function UpdateAreaAsync (
    areaConfigurationInfo As DcnmAreaConfigurationInfo,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateAreaAsync(
    DcnmAreaConfigurationInfo^ areaConfigurationInfo,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

areaConfigurationInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAreaConfigurationInfo
The area configuration information.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the update of a area. The 'Result' property of the task holds the indication if the update succeeded. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanConfigureSimultaneousInterpretation
This method allows updating for the area type BoothArea
See Also

Reference

IConfigSite Interface


IConfigSite.UpdateImageServerInfoAsync Method

IConfigSiteUpdateImageServerInfoAsync Method

Updates the image server info.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateImageServerInfoAsync(
    DcnmImageServerInfo imageServerInfo,
    Action<Task<bool>> onFinish = null
)
Function UpdateImageServerInfoAsync (
    imageServerInfo As DcnmImageServerInfo,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateImageServerInfoAsync(
    DcnmImageServerInfo^ imageServerInfo,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

imageServerInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmImageServerInfo
Image server info
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the image server info update. The 'Result' property of the task holds the return value of the function. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IConfigSite Interface


IConfigSite.UpdateMaxLanguagesAsync Method

IConfigSiteUpdateMaxLanguagesAsync Method

Updates the maximum number of interpretation languages.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateMaxLanguagesAsync(
    int maxLanguages,
    Action<Task> onFinish = null
)
Function UpdateMaxLanguagesAsync (
    maxLanguages As Integer,
    Optional onFinish As Action(Of Task) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateMaxLanguagesAsync(
    int maxLanguages,
    Action<Task^>^ onFinish = nullptr
)

Parameters

maxLanguages
Type: SystemInt32
The maximum number of interpreter languages. Valid values for maxLanguages are:
Value | Description
50 | The system supports 50 languages with 2 audio streams per language. The first stream contains the audio for the DICENTIS system. The second stream contains unprocessed audio with configurable headroom for use in external systems. The properties for the second audio stream can be configured by setting the appropriate stream2 properties in DcnmMeetingLanguageInfo
100 | The system supports 100 languages with a single audio streams per language.
onFinish (Optional)
Type: SystemAction Task
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
A task that updates the max languages. When the update succeeds, the task returns true and in every other case it returns false.
Exceptions
Exception | Condition
ArgumentException | If maxLanguages is passed an unsupported value.
ObjectDisposedException | If object already disposed.
See Also

Reference

IConfigSite Interface


IConfigSite.ValidateImageServerConnectionAsync Method

IConfigSiteValidateImageServerConnectionAsync Method

Validates image server connection.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> ValidateImageServerConnectionAsync(
    DcnmImageServerInfo imageServerInfo,
    Action<Task<bool>> onFinish = null
)
Function ValidateImageServerConnectionAsync (
    imageServerInfo As DcnmImageServerInfo,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ ValidateImageServerConnectionAsync(
    DcnmImageServerInfo^ imageServerInfo,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

imageServerInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmImageServerInfo
Image server info
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the validate image server connection. The 'Result' property of the task holds the return value of the function. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IConfigSite Interface


IConfigSite Events

The IConfigSite type exposes the following members.

Events
 | Name | Description
Public event | AutoPowerOffDelayChanged | Occurs when auto power off delay value is updated.
Public event | CapabilitiesChanged | Occurs when the capabilities of the API changed.
Public event | MaxLanguagesChanged | Occurs when the Max Languages setting has changed.
Top
See Also

Reference

IConfigSite Interface


IConfigSite.AutoPowerOffDelayChanged Event

IConfigSiteAutoPowerOffDelayChanged Event

Occurs when auto power off delay value is updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<int>> AutoPowerOffDelayChanged
Event AutoPowerOffDelayChanged As EventHandler(Of ApiEventArgs(Of Integer))
 event EventHandler<ApiEventArgs<int>^>^ AutoPowerOffDelayChanged {
    void add (EventHandler<ApiEventArgs<int>^>^ value);
    void remove (EventHandler<ApiEventArgs<int>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Int32
See Also

Reference

IConfigSite Interface


IConfigSite.CapabilitiesChanged Event

IConfigSiteCapabilitiesChanged Event

Occurs when the capabilities of the API changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IConfigSite Interface


IConfigSite.MaxLanguagesChanged Event

IConfigSiteMaxLanguagesChanged Event

Occurs when the Max Languages setting has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<int>> MaxLanguagesChanged
Event MaxLanguagesChanged As EventHandler(Of ApiEventArgs(Of Integer))
 event EventHandler<ApiEventArgs<int>^>^ MaxLanguagesChanged {
    void add (EventHandler<ApiEventArgs<int>^>^ value);
    void remove (EventHandler<ApiEventArgs<int>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Int32
See Also

Reference

IConfigSite Interface


IConfigUserDefinedDeviceInstances Interface

An interface for configuring user defined device instances.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IConfigUserDefinedDeviceInstances : IDisposable
Public Interface IConfigUserDefinedDeviceInstances
    Inherits IDisposable
public interface class IConfigUserDefinedDeviceInstances : IDisposable

The IConfigUserDefinedDeviceInstances type exposes the following members.

Properties
 | Name | Description
Public property | CanConfigureUserDefinedDeviceInstances | Check whether the current user is allowed to configure user defined device instances.
Top
Methods
 | Name | Description
Public method | CreateUserDefinedDeviceInstanceAsync | Create a user defined device instance.
Public method | DeleteUserDefinedDeviceInstanceAsync | Delete a user defined device instance.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetUserDefinedDeviceInstanceAsync | Retreive a specific user defined device instance.
Public method | GetUserDefinedDeviceInstancesAsync | Retreive all user defined device instances.
Public method | UpdateUserDefinedDeviceInstanceAsync | Update an existing user defined device instance.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | UserDefinedDeviceInstanceCreated | Occurs when a new user defined device instance is created.
Public event | UserDefinedDeviceInstanceDeleted | Occurs when an existing user defined device instance is deleted.
Public event | UserDefinedDeviceInstanceUpdated | Occurs when an existing user defined device instance is updated.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IConfigUserDefinedDeviceInstances Properties

The IConfigUserDefinedDeviceInstances type exposes the following members.

Properties
 | Name | Description
Public property | CanConfigureUserDefinedDeviceInstances | Check whether the current user is allowed to configure user defined device instances.
Top
See Also

Reference

IConfigUserDefinedDeviceInstances Interface


IConfigUserDefinedDeviceInstances.CanConfigureUserDefinedDeviceInstances Property

IConfigUserDefinedDeviceInstancesCanConfigureUserDefinedDeviceInstances Property

Bosch Logo
Check whether the current user is allowed to configure user defined device instances.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanConfigureUserDefinedDeviceInstances { get; }
ReadOnly Property CanConfigureUserDefinedDeviceInstances As Boolean
    Get
property bool CanConfigureUserDefinedDeviceInstances {
    bool get ();
}

Return Value

Type: Boolean
true if the current user is allowed and false otherwise.
See Also

Reference

IConfigUserDefinedDeviceInstances Interface


IConfigUserDefinedDeviceInstances Methods

The IConfigUserDefinedDeviceInstances type exposes the following members.

Methods
 | Name | Description
Public method | CreateUserDefinedDeviceInstanceAsync | Create a user defined device instance.
Public method | DeleteUserDefinedDeviceInstanceAsync | Delete a user defined device instance.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetUserDefinedDeviceInstanceAsync | Retreive a specific user defined device instance.
Public method | GetUserDefinedDeviceInstancesAsync | Retreive all user defined device instances.
Public method | UpdateUserDefinedDeviceInstanceAsync | Update an existing user defined device instance.
Top
See Also

Reference

IConfigUserDefinedDeviceInstances Interface


IConfigUserDefinedDeviceInstances.CreateUserDefinedDeviceInstanceAsync Method

IConfigUserDefinedDeviceInstancesCreateUserDefinedDeviceInstanceAsync Method

Bosch Logo
Create a user defined device instance.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<Guid> CreateUserDefinedDeviceInstanceAsync(
    DcnmUserDefinedDeviceInstance instance,
    Action<Task<Guid>> onFinish = null
)
Function CreateUserDefinedDeviceInstanceAsync (
    instance As DcnmUserDefinedDeviceInstance,
    Optional onFinish As Action(Of Task(Of Guid)) = Nothing
) As Task(Of Guid)
Task<Guid>^ CreateUserDefinedDeviceInstanceAsync(
    DcnmUserDefinedDeviceInstance^ instance,
    Action<Task<Guid>^>^ onFinish = nullptr
)

Parameters

instance
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmUserDefinedDeviceInstance
The user defined device instance to create.
onFinish (Optional)
Type: SystemAction Task Guid
Optional action that handles the asynchronous result.

Return Value

Type: Task Guid
An asynchronous task for creating the device instance. On completion, the tasks' Result property is the identifier of the newly create user-defined device instance if succeeded and is an empty guid otherwise.
Remarks
Only a technician is allowed to create user defined device instances.
See Also

Reference

IConfigUserDefinedDeviceInstances Interface


IConfigUserDefinedDeviceInstances.DeleteUserDefinedDeviceInstanceAsync Method

IConfigUserDefinedDeviceInstancesDeleteUserDefinedDeviceInstanceAsync Method

Bosch Logo
Delete a user defined device instance.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeleteUserDefinedDeviceInstanceAsync(
    Guid instanceId,
    Action<Task<bool>> onFinish = null
)
Function DeleteUserDefinedDeviceInstanceAsync (
    instanceId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeleteUserDefinedDeviceInstanceAsync(
    Guid instanceId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

instanceId
Type: SystemGuid
The id of the device instance to delete.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action that handles the asynchronous result.

Return Value

Type: Task Boolean
An asynchronous task for updating the device instance. On completion, the tasks' Result property is true if the user defined device was successfully deleted and is false otherwise.
Remarks
Only a technician is allowed to delete user defined device instances.
See Also

Reference

IConfigUserDefinedDeviceInstances Interface


IConfigUserDefinedDeviceInstances.GetUserDefinedDeviceInstanceAsync Method

IConfigUserDefinedDeviceInstancesGetUserDefinedDeviceInstanceAsync Method

Bosch Logo
Retreive a specific user defined device instance.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<DcnmUserDefinedDeviceInstance> GetUserDefinedDeviceInstanceAsync(
    Guid instanceId,
    Action<Task<DcnmUserDefinedDeviceInstance>> onFinish = null
)
Function GetUserDefinedDeviceInstanceAsync (
    instanceId As Guid,
    Optional onFinish As Action(Of Task(Of DcnmUserDefinedDeviceInstance)) = Nothing
) As Task(Of DcnmUserDefinedDeviceInstance)
Task<DcnmUserDefinedDeviceInstance^>^ GetUserDefinedDeviceInstanceAsync(
    Guid instanceId,
    Action<Task<DcnmUserDefinedDeviceInstance^>^>^ onFinish = nullptr
)

Parameters

instanceId
Type: SystemGuid
The Id of the device instance to retreive.
onFinish (Optional)
Type: SystemAction Task DcnmUserDefinedDeviceInstance
Optional action that handles the asynchronous result.

Return Value

Type: Task DcnmUserDefinedDeviceInstance
An asynchronous task for retreiving the device instances. On completion, the tasks' Result property contains the requested device information if it exists. Otherwise, Result will be null.
See Also

Reference

IConfigUserDefinedDeviceInstances Interface


IConfigUserDefinedDeviceInstances.GetUserDefinedDeviceInstancesAsync Method

IConfigUserDefinedDeviceInstancesGetUserDefinedDeviceInstancesAsync Method

Bosch Logo
Retreive all user defined device instances.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmUserDefinedDeviceInstance>> GetUserDefinedDeviceInstancesAsync(
    Action<Task<IList<DcnmUserDefinedDeviceInstance>>> onFinish = null
)
Function GetUserDefinedDeviceInstancesAsync (
    Optional onFinish As Action(Of Task(Of IList(Of DcnmUserDefinedDeviceInstance))) = Nothing
) As Task(Of IList(Of DcnmUserDefinedDeviceInstance))
Task<IList<DcnmUserDefinedDeviceInstance^>^>^ GetUserDefinedDeviceInstancesAsync(
    Action<Task<IList<DcnmUserDefinedDeviceInstance^>^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task IList DcnmUserDefinedDeviceInstance
Optional action that handles the asynchronous result.

Return Value

Type: Task IList DcnmUserDefinedDeviceInstance
An asynchronous task for retreiving the device instances. On completion, the tasks' Result property contains a list of all known user defined device instances.
See Also

Reference

IConfigUserDefinedDeviceInstances Interface


IConfigUserDefinedDeviceInstances.UpdateUserDefinedDeviceInstanceAsync Method

IConfigUserDefinedDeviceInstancesUpdateUserDefinedDeviceInstanceAsync Method

Bosch Logo
Update an existing user defined device instance.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateUserDefinedDeviceInstanceAsync(
    DcnmUserDefinedDeviceInstance instance,
    Action<Task<bool>> onFinish = null
)
Function UpdateUserDefinedDeviceInstanceAsync (
    instance As DcnmUserDefinedDeviceInstance,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateUserDefinedDeviceInstanceAsync(
    DcnmUserDefinedDeviceInstance^ instance,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

instance
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmUserDefinedDeviceInstance
The device instance to update.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action that handles the asynchronous result.

Return Value

Type: Task Boolean
An asynchronous task for updating the device instance. On completion, the tasks' Result property is true if the user defined device was successfully updated and is false otherwise.
Remarks
Only a technician is allowed to update user defined device instances.
See Also

Reference

IConfigUserDefinedDeviceInstances Interface


IConfigUserDefinedDeviceInstances Events

The IConfigUserDefinedDeviceInstances type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | UserDefinedDeviceInstanceCreated | Occurs when a new user defined device instance is created.
Public event | UserDefinedDeviceInstanceDeleted | Occurs when an existing user defined device instance is deleted.
Public event | UserDefinedDeviceInstanceUpdated | Occurs when an existing user defined device instance is updated.
Top
See Also

Reference

IConfigUserDefinedDeviceInstances Interface


IConfigUserDefinedDeviceInstances.CapabilitiesChanged Event

IConfigUserDefinedDeviceInstancesCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IConfigUserDefinedDeviceInstances Interface


IConfigUserDefinedDeviceInstances.UserDefinedDeviceInstanceCreated Event

IConfigUserDefinedDeviceInstancesUserDefinedDeviceInstanceCreated Event

 Bosch Logo
Occurs when a new user defined device instance is created.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmUserDefinedDeviceInstance>> UserDefinedDeviceInstanceCreated
Event UserDefinedDeviceInstanceCreated As EventHandler(Of ApiEventArgs(Of DcnmUserDefinedDeviceInstance))
 event EventHandler<ApiEventArgs<DcnmUserDefinedDeviceInstance^>^>^ UserDefinedDeviceInstanceCreated {
    void add (EventHandler<ApiEventArgs<DcnmUserDefinedDeviceInstance^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmUserDefinedDeviceInstance^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmUserDefinedDeviceInstance
See Also

Reference

IConfigUserDefinedDeviceInstances Interface


IConfigUserDefinedDeviceInstances.UserDefinedDeviceInstanceDeleted Event

IConfigUserDefinedDeviceInstancesUserDefinedDeviceInstanceDeleted Event

 Bosch Logo
Occurs when an existing user defined device instance is deleted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<Guid>> UserDefinedDeviceInstanceDeleted
Event UserDefinedDeviceInstanceDeleted As EventHandler(Of ApiEventArgs(Of Guid))
 event EventHandler<ApiEventArgs<Guid>^>^ UserDefinedDeviceInstanceDeleted {
    void add (EventHandler<ApiEventArgs<Guid>^>^ value);
    void remove (EventHandler<ApiEventArgs<Guid>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Guid
See Also

Reference

IConfigUserDefinedDeviceInstances Interface


IConfigUserDefinedDeviceInstances.UserDefinedDeviceInstanceUpdated Event

IConfigUserDefinedDeviceInstancesUserDefinedDeviceInstanceUpdated Event

 Bosch Logo
Occurs when an existing user defined device instance is updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmUserDefinedDeviceInstance>> UserDefinedDeviceInstanceUpdated
Event UserDefinedDeviceInstanceUpdated As EventHandler(Of ApiEventArgs(Of DcnmUserDefinedDeviceInstance))
 event EventHandler<ApiEventArgs<DcnmUserDefinedDeviceInstance^>^>^ UserDefinedDeviceInstanceUpdated {
    void add (EventHandler<ApiEventArgs<DcnmUserDefinedDeviceInstance^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmUserDefinedDeviceInstance^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmUserDefinedDeviceInstance
See Also

Reference

IConfigUserDefinedDeviceInstances Interface


IControlCamera Interface

Defines the interface to control the active camera.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IControlCamera : IDisposable
Public Interface IControlCamera
    Inherits IDisposable
public interface class IControlCamera : IDisposable

The IControlCamera type exposes the following members.

Properties
 | Name | Description
Public property | CanControlCamera | Indicates the user is able to control camera.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestActiveCameraStateAsync | Requests for the currently active camera state.
Public method | SetFocusAsync | Sets focus for camera
Public method | SetIrisAsync | Sets iris for camera
Public method | SetMoveAsync | Set the move parameters for current (active) camera
Public method | SetStopAsync | Stops camera Pan and Tilt
Public method | SetStoreAsync | Stores preposition for the active preposition of the camera
Public method | SetZoomAsync | Sets zoom for camera
Top
Events
 | Name | Description
Public event | CameraActiveStateChanged | Occurs when the active state of one or more cameras has changed.
Public event | CapabilitiesChanged | Occurs when the access rights of the logged on user changed.
Top
Remarks
This class control the active camera and its active preposition. When changes are made to the camera and the SetStoreAsync(ActionTaskBoolean) method is used, the new values will be stored to the currently active prepostition of the selected camera.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IControlCamera Properties

The IControlCamera type exposes the following members.

Properties
 | Name | Description
Public property | CanControlCamera | Indicates the user is able to control camera.
Top
See Also

Reference

IControlCamera Interface


IControlCamera.CanControlCamera Property

IControlCameraCanControlCamera Property

Indicates the user is able to control camera.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanControlCamera { get; }
ReadOnly Property CanControlCamera As Boolean
    Get
property bool CanControlCamera {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Camera Control.
  • Participant right: Can Manage.
  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode
See Also

Reference

IControlCamera Interface


IControlCamera Methods

The IControlCamera type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestActiveCameraStateAsync | Requests for the currently active camera state.
Public method | SetFocusAsync | Sets focus for camera
Public method | SetIrisAsync | Sets iris for camera
Public method | SetMoveAsync | Set the move parameters for current (active) camera
Public method | SetStopAsync | Stops camera Pan and Tilt
Public method | SetStoreAsync | Stores preposition for the active preposition of the camera
Public method | SetZoomAsync | Sets zoom for camera
Top
See Also

Reference

IControlCamera Interface


IControlCamera.RequestActiveCameraStateAsync Method

IControlCameraRequestActiveCameraStateAsync Method

Requests for the currently active camera state.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestActiveCameraStateAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestActiveCameraStateAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestActiveCameraStateAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the currently active camera state request. The 'Result' property of the task holds the return value of the function. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlCamera Interface


IControlCamera.SetFocusAsync Method

IControlCameraSetFocusAsync Method

Sets focus for camera

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetFocusAsync(
    int focusValue,
    Action<Task<bool>> onFinish = null
)
Function SetFocusAsync (
    focusValue As Integer,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetFocusAsync(
    int focusValue,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

focusValue
Type: SystemInt32
Focus value passed to the camera. The focus value is define as either the value '-1' to reduce the focus distance a single step or the value '+1' to increase the focus distance a single step. Any other value is not allowed.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the set focus. The 'Result' property of the task holds the return value of the function. The result is True when the command is passed to the camera, False otherwise. Note that the result getter blocks until the list is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentOutOfRangeException | if the focusValue is not one of the predefined values.
Remarks

The focus value as passed to the fucntion will only change the focus one step in the provided direction. In order to adjust the focus further this method has to be called again. When the camera has reached its zoom limit, nothing happens.

Requires:

  • CanControlCamera
See Also

Reference

IControlCamera Interface


IControlCamera.SetIrisAsync Method

IControlCameraSetIrisAsync Method

Sets iris for camera

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetIrisAsync(
    int irisValue,
    Action<Task<bool>> onFinish = null
)
Function SetIrisAsync (
    irisValue As Integer,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetIrisAsync(
    int irisValue,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

irisValue
Type: SystemInt32
Iris value passed to the camera. The iris value is define as either the value '-1' to lower the iris or the value '+1' to widen the iris. Any other value is not allowed.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the set iris. The 'Result' property of the task holds the return value of the function. The result is True when the command is passed to the camera, False otherwise. Note that the result getter blocks until the list is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentOutOfRangeException | if the irisValue is not one of the predefined values.
Remarks

The iris value as passed to the fucntion will only change the iris one step in the provided direction. In order to adjust the iris further this method has to be called again. When the camera has reached it iris limit, nothing happens.

Requires:

  • CanControlCamera
See Also

Reference

IControlCamera Interface


IControlCamera.SetMoveAsync Method

IControlCameraSetMoveAsync Method

Set the move parameters for current (active) camera

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetMoveAsync(
    int speedX,
    int speedY,
    Action<Task<bool>> onFinish = null
)
Function SetMoveAsync (
    speedX As Integer,
    speedY As Integer,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetMoveAsync(
    int speedX,
    int speedY,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

speedX
Type: SystemInt32
Speed of the camera in the horizontal direction in the range of -100 to +100. Negative values moves the camera to the left, positive values moves the camera to the right.
speedY
Type: SystemInt32
Speed of the camera in the vertical direction in the range of -100 to +100. Negative values moves the camera down, positive values moves the camera up.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the set move. The 'Result' property of the task holds the return value of the function. The result is True when the command is passed to the camera, False otherwise. Note that the result getter blocks until the list is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentOutOfRangeException | if (one of) the speed values is out of range.
Remarks

The defined speed as passed to the function is valid for maximal 1 second. In order to keep the camera moving in a direction this command has to be repeated within a second. To stop the camera when the location is reached, use the SetStopAsync(ActionTaskBoolean) method

Requires:

  • Functional license: Camera Control.
  • Participant right: Can Manage.
  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode
See Also

Reference

IControlCamera Interface


IControlCamera.SetStopAsync Method

IControlCameraSetStopAsync Method

Stops camera Pan and Tilt

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetStopAsync(
    Action<Task<bool>> onFinish = null
)
Function SetStopAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetStopAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the set stop. The 'Result' property of the task holds the return value of the function. The result is True when the command is passed to the camera, False otherwise. Note that the result getter blocks until the list is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanControlCamera
See Also

Reference

IControlCamera Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IControlCameraSetMoveAsync(Int32, Int32, ActionTaskBoolean)


IControlCamera.SetStoreAsync Method

IControlCameraSetStoreAsync Method

Stores preposition for the active preposition of the camera

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetStoreAsync(
    Action<Task<bool>> onFinish = null
)
Function SetStoreAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetStoreAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the set store. The 'Result' property of the task holds the return value of the function. The result is True when the command is passed to the camera, False otherwise. Note that the result getter blocks until the list is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanControlCamera
See Also

Reference

IControlCamera Interface


IControlCamera.SetZoomAsync Method

IControlCameraSetZoomAsync Method

Sets zoom for camera

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetZoomAsync(
    int zoomValue,
    Action<Task<bool>> onFinish = null
)
Function SetZoomAsync (
    zoomValue As Integer,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetZoomAsync(
    int zoomValue,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

zoomValue
Type: SystemInt32
Zoom value passed to the camera. The zoom value is define as either the value '-1' to zoom out a single step or the value '+1' to zoom in a single step. Any other value is not allowed.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the set zoom. The 'Result' property of the task holds the return value of the function. The result is True when the command is passed to the camera, False otherwise. Note that the result getter blocks until the list is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentOutOfRangeException | if the zoomValue is not one of the predefined values.
Remarks

The zoom value as passed to the fucntion will only zoom one step in the provided direction. In order to zoom further this method has to be called again. When the camera has reached its zoom limit, nothing happens.

Requires:

  • CanControlCamera
See Also

Reference

IControlCamera Interface


IControlCamera Events

The IControlCamera type exposes the following members.

Events
 | Name | Description
Public event | CameraActiveStateChanged | Occurs when the active state of one or more cameras has changed.
Public event | CapabilitiesChanged | Occurs when the access rights of the logged on user changed.
Top
See Also

Reference

IControlCamera Interface


IControlCamera.CameraActiveStateChanged Event

IControlCameraCameraActiveStateChanged Event

Occurs when the active state of one or more cameras has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmCameraStatusInfo>> CameraActiveStateChanged
Event CameraActiveStateChanged As EventHandler(Of ApiEventArgs(Of DcnmCameraStatusInfo))
 event EventHandler<ApiEventArgs<DcnmCameraStatusInfo^>^>^ CameraActiveStateChanged {
    void add (EventHandler<ApiEventArgs<DcnmCameraStatusInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmCameraStatusInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmCameraStatusInfo
See Also

Reference

IControlCamera Interface


IControlCamera.CapabilitiesChanged Event

IControlCameraCapabilitiesChanged Event

Occurs when the access rights of the logged on user changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IControlCamera Interface


IControlDiscussion Interface

Defines the interface for discussion control

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IControlDiscussion : IDisposable
Public Interface IControlDiscussion
    Inherits IDisposable
public interface class IControlDiscussion : IDisposable

The IControlDiscussion type exposes the following members.

Properties
 | Name | Description
Public property | CanControlAdvancedDiscussions | Indicates the user is able to control advanced discussion.
Public property | CanControlDiscussion | Indicates the user is able to control discussion.
Public property | CanViewWaitingList | Indicates whether user can view waiting list.
Public property | HasSpecialPermission | Indicates the user has special permission.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestDiscussionOptionsAsync | Triggers the request for a discussion options update.
Public method | RequestDiscussionStatusAsync | Triggers the request for a discussion status update.
Public method | RequestMicrophoneOptionsAsync | Triggers the request for a microphone options update.
Public method | RequestPriorityOptionsAsync | Triggers the request for a priority options update.
Public method | RequestRequestToResponseOptionsAsync | Triggers the request for a request to response options update.
Public method | RequestRequestToSpeakOptionsAsync | Triggers the request for a request to speak options update.
Public method | RequestSpeechTimerOptionsAsync | Triggers the request for a speech timer options update
Public method | SetDiscussionOptionsAsync | Sets the discussion options.
Public method | SetMicrophoneOptionsAsync | Sets the microphone options.
Public method | SetPriorityOptionsAsync | Sets the priority options.
Public method | SetRequestToResponseOptionsAsync | Sets the request to response options.
Public method | SetRequestToSpeakOptionsAsync | Sets the request to speak options.
Public method | SetSpeechTimerOptionsAsync | Sets the speech timer options
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | DiscussionOptionsChanged | Occurs when the discussion control mode of the discussion changed.
Public event | DiscussionStatusChanged | Occurs when the state of the discussion changed.
Public event | MicrophoneOptionsChanged | Occurs when the microphone options of the discussion changed.
Public event | PriorityOptionsChanged | Occurs when the priority options of the discussion changed.
Public event | RequestToResponseOptionsChanged | Occurs when the request to response options of the discussion changed.
Public event | RequestToSpeakOptionsChanged | Occurs when the request to speak options of the discussion changed.
Public event | SpeechTimerOptionsChanged | Occurs when the speech timer options have changed.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IControlDiscussion Properties

The IControlDiscussion type exposes the following members.

Properties
 | Name | Description
Public property | CanControlAdvancedDiscussions | Indicates the user is able to control advanced discussion.
Public property | CanControlDiscussion | Indicates the user is able to control discussion.
Public property | CanViewWaitingList | Indicates whether user can view waiting list.
Public property | HasSpecialPermission | Indicates the user has special permission.
Top
See Also

Reference

IControlDiscussion Interface


IControlDiscussion.CanControlAdvancedDiscussions Property

IControlDiscussionCanControlAdvancedDiscussions Property

Indicates the user is able to control advanced discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanControlAdvancedDiscussions { get; }
ReadOnly Property CanControlAdvancedDiscussions As Boolean
    Get
property bool CanControlAdvancedDiscussions {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Advance license: DCNM_LPP_PE, DCNM_LPU_PE, DCNM_LPPP_P1Y, DCNM_LPUP_P1Y, DCNM_LPUP_S1Y, DCNM_LPPP_S1Y, DCNM_DEMO.
  • Participant right: Can Manage.
  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode
See Also

Reference

IControlDiscussion Interface


IControlDiscussion.CanControlDiscussion Property

IControlDiscussionCanControlDiscussion Property

Indicates the user is able to control discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanControlDiscussion { get; }
ReadOnly Property CanControlDiscussion As Boolean
    Get
property bool CanControlDiscussion {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Participant right: Can Manage.
  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode
See Also

Reference

IControlDiscussion Interface


IControlDiscussion.CanViewWaitingList Property

IControlDiscussionCanViewWaitingList Property

Indicates whether user can view waiting list.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanViewWaitingList { get; }
ReadOnly Property CanViewWaitingList As Boolean
    Get
property bool CanViewWaitingList {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode
Remarks
In order to view waiting list in meeting application or synoptic layout:
  • Participant right: can manage or has special permission.
  • User right: Seat should have manage meeting rights.
  • Or ShowWaitingList in DcnmRequestToSpeakOptions must be true.
See Also

Reference

IControlDiscussion Interface


IControlDiscussion.HasSpecialPermission Property

IControlDiscussionHasSpecialPermission Property

Indicates the user has special permission.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool HasSpecialPermission { get; }
ReadOnly Property HasSpecialPermission As Boolean
    Get
property bool HasSpecialPermission {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Participant right: Has special permission.
  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode
See Also

Reference

IControlDiscussion Interface


IControlDiscussion Methods

The IControlDiscussion type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestDiscussionOptionsAsync | Triggers the request for a discussion options update.
Public method | RequestDiscussionStatusAsync | Triggers the request for a discussion status update.
Public method | RequestMicrophoneOptionsAsync | Triggers the request for a microphone options update.
Public method | RequestPriorityOptionsAsync | Triggers the request for a priority options update.
Public method | RequestRequestToResponseOptionsAsync | Triggers the request for a request to response options update.
Public method | RequestRequestToSpeakOptionsAsync | Triggers the request for a request to speak options update.
Public method | RequestSpeechTimerOptionsAsync | Triggers the request for a speech timer options update
Public method | SetDiscussionOptionsAsync | Sets the discussion options.
Public method | SetMicrophoneOptionsAsync | Sets the microphone options.
Public method | SetPriorityOptionsAsync | Sets the priority options.
Public method | SetRequestToResponseOptionsAsync | Sets the request to response options.
Public method | SetRequestToSpeakOptionsAsync | Sets the request to speak options.
Public method | SetSpeechTimerOptionsAsync | Sets the speech timer options
Top
See Also

Reference

IControlDiscussion Interface


IControlDiscussion.RequestDiscussionOptionsAsync Method

IControlDiscussionRequestDiscussionOptionsAsync Method

Triggers the request for a discussion options update.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestDiscussionOptionsAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestDiscussionOptionsAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestDiscussionOptionsAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the discussion options request. The 'Result' property of the task is true if the request to retrieve discussion options is delivered,false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode

Event triggered if the request is processed successfully is:

  • DiscussionOptionsChanged

See Also

Reference

IControlDiscussion Interface


IControlDiscussion.RequestDiscussionStatusAsync Method

IControlDiscussionRequestDiscussionStatusAsync Method

Triggers the request for a discussion status update.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestDiscussionStatusAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestDiscussionStatusAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestDiscussionStatusAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the discussion status request. The 'Result' property of the task is true if the request to retrieve the discussion status is delivered successfully,otherwise false. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode

Event triggered if the request is processed successfully is:

  • DiscussionStatusChanged

See Also

Reference

IControlDiscussion Interface


IControlDiscussion.RequestMicrophoneOptionsAsync Method

IControlDiscussionRequestMicrophoneOptionsAsync Method

Triggers the request for a microphone options update.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestMicrophoneOptionsAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestMicrophoneOptionsAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestMicrophoneOptionsAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the microphone options request. The 'Result' property of the task is true if request to retrieve the microphone options is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode

Event triggered if the request is processed successfully is:

  • MicrophoneOptionsChanged

See Also

Reference

IControlDiscussion Interface


IControlDiscussion.RequestPriorityOptionsAsync Method

IControlDiscussionRequestPriorityOptionsAsync Method

Triggers the request for a priority options update.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestPriorityOptionsAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestPriorityOptionsAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestPriorityOptionsAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the priority options request. The 'Result' property of the task is true if request to retrieve the priority options is delivered successfully, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode

Event triggered if the request is processed successfully is:

  • PriorityOptionsChanged

See Also

Reference

IControlDiscussion Interface


IControlDiscussion.RequestRequestToResponseOptionsAsync Method

IControlDiscussionRequestRequestToResponseOptionsAsync Method

Bosch Logo
Triggers the request for a request to response options update.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestRequestToResponseOptionsAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestRequestToResponseOptionsAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestRequestToResponseOptionsAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request to response options request. The 'Result' property of the task is true if request to retrieve the "Request to Response" option is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode

Event triggered if the request is processed successfully is:

  • RequestToResponseOptionsChanged

See Also

Reference

IControlDiscussion Interface


IControlDiscussion.RequestRequestToSpeakOptionsAsync Method

IControlDiscussionRequestRequestToSpeakOptionsAsync Method

Triggers the request for a request to speak options update.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestRequestToSpeakOptionsAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestRequestToSpeakOptionsAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestRequestToSpeakOptionsAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request to speak options request. The 'Result' property of the task is true, if the request to retrieve the "Request to Speak" option is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode

Event triggered if the request is processed sussessfully is:

  • RequestToSpeakOptionsChanged

See Also

Reference

IControlDiscussion Interface


IControlDiscussion.RequestSpeechTimerOptionsAsync Method

IControlDiscussionRequestSpeechTimerOptionsAsync Method

Triggers the request for a speech timer options update

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestSpeechTimerOptionsAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestSpeechTimerOptionsAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestSpeechTimerOptionsAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the speech timer options set. The 'Result' property of the task holds the return value of the function. if request to retrieve the speech timer options is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode

Event triggered if the request is processed successfully is:

  • SpeechTimerOptionsChanged

See Also

Reference

IControlDiscussion Interface


IControlDiscussion.SetDiscussionOptionsAsync Method

IControlDiscussionSetDiscussionOptionsAsync Method

Sets the discussion options.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetDiscussionOptionsAsync(
    DcnmDiscussionOptions options,
    Action<Task<bool>> onFinish = null
)
Function SetDiscussionOptionsAsync (
    options As DcnmDiscussionOptions,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetDiscussionOptionsAsync(
    DcnmDiscussionOptions^ options,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

options
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDiscussionOptions
The discussion mode options to set
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the discussion options set. The 'Result' property of the task is true if the request to set various discussion options is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If options are null.
UnauthorizedAccessException | If license are insufficient for advance discussion
Remarks
Requires:

  • CanControlDiscussion

Event triggered if the request is processed successfully is:

  • DiscussionOptionsChanged

See Also

Reference

IControlDiscussion Interface


IControlDiscussion.SetMicrophoneOptionsAsync Method

IControlDiscussionSetMicrophoneOptionsAsync Method

Sets the microphone options.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetMicrophoneOptionsAsync(
    DcnmMicrophoneOptions options,
    Action<Task<bool>> onFinish = null
)
Function SetMicrophoneOptionsAsync (
    options As DcnmMicrophoneOptions,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetMicrophoneOptionsAsync(
    DcnmMicrophoneOptions^ options,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

options
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmMicrophoneOptions
The microphone options to set
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the microphone options set. The 'Result' property of the task is true if the request to set microphone options is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If options are null.
ArgumentOutOfRangeException | If number of open microphones is out of range.
Remarks

Requires:

  • CanControlDiscussion

Event triggered if the request is processed successfully is:

  • MicrophoneOptionsChanged

See Also

Reference

IControlDiscussion Interface


IControlDiscussion.SetPriorityOptionsAsync Method

IControlDiscussionSetPriorityOptionsAsync Method

Sets the priority options.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetPriorityOptionsAsync(
    DcnmPriorityOptions options,
    Action<Task<bool>> onFinish = null
)
Function SetPriorityOptionsAsync (
    options As DcnmPriorityOptions,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetPriorityOptionsAsync(
    DcnmPriorityOptions^ options,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

options
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPriorityOptions
The priority options to set
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the priority options set. The 'Result' property of the task is true if the request to set priority options is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If options are null.
Remarks

Requires:

  • CanControlDiscussion

Event triggered if the request is processed successfully is:

  • PriorityOptionsChanged

See Also

Reference

IControlDiscussion Interface


IControlDiscussion.SetRequestToResponseOptionsAsync Method

IControlDiscussionSetRequestToResponseOptionsAsync Method

Sets the request to response options.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetRequestToResponseOptionsAsync(
    DcnmRequestToResponseOptions options,
    Action<Task<bool>> onFinish = null
)
Function SetRequestToResponseOptionsAsync (
    options As DcnmRequestToResponseOptions,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetRequestToResponseOptionsAsync(
    DcnmRequestToResponseOptions^ options,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

options
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmRequestToResponseOptions
The request to response options to set
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request to response options set. The 'Result' property of the task is true if the request to set the "Request to Response" option is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If options are null.
ArgumentOutOfRangeException | If number of max responses is out of range.
UnauthorizedAccessException | If license are insufficient for advance discussion
Remarks

Requires:

  • CanControlDiscussion

Event triggered if the request is processed successfully is:

  • RequestToResponseOptionsChanged

See Also

Reference

IControlDiscussion Interface


IControlDiscussion.SetRequestToSpeakOptionsAsync Method

IControlDiscussionSetRequestToSpeakOptionsAsync Method

Sets the request to speak options.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetRequestToSpeakOptionsAsync(
    DcnmRequestToSpeakOptions options,
    Action<Task<bool>> onFinish = null
)
Function SetRequestToSpeakOptionsAsync (
    options As DcnmRequestToSpeakOptions,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetRequestToSpeakOptionsAsync(
    DcnmRequestToSpeakOptions^ options,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

options
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmRequestToSpeakOptions
The request to speak options to set
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request to speak options set. The 'Result' property of the task is true if the request to set "Request To Speak" option is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If options are null.
ArgumentOutOfRangeException | If MaxRequests is not between DISCUSS_MIN_REQUESTS and DISCUSS_MAX_REQUESTS
Remarks
Requires:

  • CanControlDiscussion

Event triggered if the request is processed sussessfully is:

  • RequestToSpeakOptionsChanged

See Also

Reference

IControlDiscussion Interface


IControlDiscussion.SetSpeechTimerOptionsAsync Method

IControlDiscussionSetSpeechTimerOptionsAsync Method

Sets the speech timer options

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetSpeechTimerOptionsAsync(
    DcnmSpeechTimerOptions options,
    Action<Task<bool>> onFinish = null
)
Function SetSpeechTimerOptionsAsync (
    options As DcnmSpeechTimerOptions,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetSpeechTimerOptionsAsync(
    DcnmSpeechTimerOptions^ options,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

options
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmSpeechTimerOptions
The speech timer options to set
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the speech timer options set. The 'Result' property of the task holds the return value of the function. if the request to set speech timer options is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If options are null.
ArgumentOutOfRangeException
  • If speech duration option is more than maximum value (99 minutes or 5940 seconds) or minimum value (1 sec).
  • If adjust speech duration option is more than maximum value (10 minutes or 600 seconds) or minimum value (1 sec).
UnauthorizedAccessException | If license are insufficient for advance discussion
Remarks

Requires:

  • CanControlDiscussion

Event triggered if the request is processed successfully is:

  • SpeechTimerOptionsChanged

See Also

Reference

IControlDiscussion Interface


IControlDiscussion Events

The IControlDiscussion type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | DiscussionOptionsChanged | Occurs when the discussion control mode of the discussion changed.
Public event | DiscussionStatusChanged | Occurs when the state of the discussion changed.
Public event | MicrophoneOptionsChanged | Occurs when the microphone options of the discussion changed.
Public event | PriorityOptionsChanged | Occurs when the priority options of the discussion changed.
Public event | RequestToResponseOptionsChanged | Occurs when the request to response options of the discussion changed.
Public event | RequestToSpeakOptionsChanged | Occurs when the request to speak options of the discussion changed.
Public event | SpeechTimerOptionsChanged | Occurs when the speech timer options have changed.
Top
See Also

Reference

IControlDiscussion Interface


IControlDiscussion.CapabilitiesChanged Event

IControlDiscussionCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IControlDiscussion Interface


IControlDiscussion.DiscussionOptionsChanged Event

IControlDiscussionDiscussionOptionsChanged Event

Occurs when the discussion control mode of the discussion changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmDiscussionOptions>> DiscussionOptionsChanged
Event DiscussionOptionsChanged As EventHandler(Of ApiEventArgs(Of DcnmDiscussionOptions))
 event EventHandler<ApiEventArgs<DcnmDiscussionOptions^>^>^ DiscussionOptionsChanged {
    void add (EventHandler<ApiEventArgs<DcnmDiscussionOptions^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmDiscussionOptions^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmDiscussionOptions
See Also

Reference

IControlDiscussion Interface


IControlDiscussion.DiscussionStatusChanged Event

IControlDiscussionDiscussionStatusChanged Event

Occurs when the state of the discussion changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmDiscussionInfo>> DiscussionStatusChanged
Event DiscussionStatusChanged As EventHandler(Of ApiEventArgs(Of DcnmDiscussionInfo))
 event EventHandler<ApiEventArgs<DcnmDiscussionInfo^>^>^ DiscussionStatusChanged {
    void add (EventHandler<ApiEventArgs<DcnmDiscussionInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmDiscussionInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmDiscussionInfo
See Also

Reference

IControlDiscussion Interface


IControlDiscussion.MicrophoneOptionsChanged Event

IControlDiscussionMicrophoneOptionsChanged Event

Occurs when the microphone options of the discussion changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmMicrophoneOptions>> MicrophoneOptionsChanged
Event MicrophoneOptionsChanged As EventHandler(Of ApiEventArgs(Of DcnmMicrophoneOptions))
 event EventHandler<ApiEventArgs<DcnmMicrophoneOptions^>^>^ MicrophoneOptionsChanged {
    void add (EventHandler<ApiEventArgs<DcnmMicrophoneOptions^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmMicrophoneOptions^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmMicrophoneOptions
See Also

Reference

IControlDiscussion Interface


IControlDiscussion.PriorityOptionsChanged Event

IControlDiscussionPriorityOptionsChanged Event

Occurs when the priority options of the discussion changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmPriorityOptions>> PriorityOptionsChanged
Event PriorityOptionsChanged As EventHandler(Of ApiEventArgs(Of DcnmPriorityOptions))
 event EventHandler<ApiEventArgs<DcnmPriorityOptions^>^>^ PriorityOptionsChanged {
    void add (EventHandler<ApiEventArgs<DcnmPriorityOptions^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmPriorityOptions^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmPriorityOptions
See Also

Reference

IControlDiscussion Interface


IControlDiscussion.RequestToResponseOptionsChanged Event

IControlDiscussionRequestToResponseOptionsChanged Event

Occurs when the request to response options of the discussion changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmRequestToResponseOptions>> RequestToResponseOptionsChanged
Event RequestToResponseOptionsChanged As EventHandler(Of ApiEventArgs(Of DcnmRequestToResponseOptions))
 event EventHandler<ApiEventArgs<DcnmRequestToResponseOptions^>^>^ RequestToResponseOptionsChanged {
    void add (EventHandler<ApiEventArgs<DcnmRequestToResponseOptions^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmRequestToResponseOptions^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmRequestToResponseOptions
See Also

Reference

IControlDiscussion Interface


IControlDiscussion.RequestToSpeakOptionsChanged Event

IControlDiscussionRequestToSpeakOptionsChanged Event

Occurs when the request to speak options of the discussion changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmRequestToSpeakOptions>> RequestToSpeakOptionsChanged
Event RequestToSpeakOptionsChanged As EventHandler(Of ApiEventArgs(Of DcnmRequestToSpeakOptions))
 event EventHandler<ApiEventArgs<DcnmRequestToSpeakOptions^>^>^ RequestToSpeakOptionsChanged {
    void add (EventHandler<ApiEventArgs<DcnmRequestToSpeakOptions^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmRequestToSpeakOptions^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmRequestToSpeakOptions
See Also

Reference

IControlDiscussion Interface


IControlDiscussion.SpeechTimerOptionsChanged Event

IControlDiscussionSpeechTimerOptionsChanged Event

Occurs when the speech timer options have changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmSpeechTimerOptions>> SpeechTimerOptionsChanged
Event SpeechTimerOptionsChanged As EventHandler(Of ApiEventArgs(Of DcnmSpeechTimerOptions))
 event EventHandler<ApiEventArgs<DcnmSpeechTimerOptions^>^>^ SpeechTimerOptionsChanged {
    void add (EventHandler<ApiEventArgs<DcnmSpeechTimerOptions^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmSpeechTimerOptions^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmSpeechTimerOptions
See Also

Reference

IControlDiscussion Interface


IControlInterpretation Interface

Represents the interface to control interpretation.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IControlInterpretation : IDisposable
Public Interface IControlInterpretation
    Inherits IDisposable
public interface class IControlInterpretation : IDisposable

The IControlInterpretation type exposes the following members.

Properties
 | Name | Description
Public property | CanControlInterpretation | Indicates whether it is possible to control interpretation.
Top
Methods
 | Name | Description
Public method | CancelInterpreterMetaFunctionAsync | Cancels interpreter meta function request asynchronously.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GrantInterpretationAsync | Grants the interpretation asynchronous.
Public method | IssueInterpreterMetaFunctionAsync | Issues interpreter meta function request asynchronously.
Public method | RaiseBoothNotificationAsync | Raises a notification in the given booth.
Public method | RequestBoothNotificationsAsync | Requests the currently active booth notifications asynchronous.
Public method | RequestInterpretationLanguagesAsync | Requests the interpretation languages asynchronous.
Public method | RequestInterpretationRoutingListAsync | Requests the interpretation routing list asynchronous.
Public method | RequestInterpreterMetaRequestAsync | Requests interpreter meta request status
Public method | SelectFloorAsync | Selects the floor as input source.
Public method | SelectInputLanguageAsync | Selects the in preset language for A/B/C/D/E/F/G input.
Public method | SelectRelayAsync | Selects the relay language as input source.
Public method | SetOutPresetAsync | Sets the out preset language for B/C output.
Top
Events
 | Name | Description
Public event | BoothNotificationsChanged | Occurs when the booth notifications changed.
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | InterpretationLanguagesChanged | Occurs when the interpretation languages changed.
Public event | InterpretationMetaRequestStatusChanged | Occurs when interpretation meta requests changed.
Public event | InterpretationRoutingListChanged | Occurs when the interpretation routing list changed.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
SystemIDisposable


IControlInterpretation Properties

The IControlInterpretation type exposes the following members.

Properties
 | Name | Description
Public property | CanControlInterpretation | Indicates whether it is possible to control interpretation.
Top
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.CanControlInterpretation Property

IControlInterpretationCanControlInterpretation Property

Indicates whether it is possible to control interpretation.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanControlInterpretation { get; }
ReadOnly Property CanControlInterpretation As Boolean
    Get
property bool CanControlInterpretation {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Interpretation preparation and management
  • Seat right: Control(Manage) meeting.
See Also

Reference

IControlInterpretation Interface


IControlInterpretation Methods

The IControlInterpretation type exposes the following members.

Methods
 | Name | Description
Public method | CancelInterpreterMetaFunctionAsync | Cancels interpreter meta function request asynchronously.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GrantInterpretationAsync | Grants the interpretation asynchronous.
Public method | IssueInterpreterMetaFunctionAsync | Issues interpreter meta function request asynchronously.
Public method | RaiseBoothNotificationAsync | Raises a notification in the given booth.
Public method | RequestBoothNotificationsAsync | Requests the currently active booth notifications asynchronous.
Public method | RequestInterpretationLanguagesAsync | Requests the interpretation languages asynchronous.
Public method | RequestInterpretationRoutingListAsync | Requests the interpretation routing list asynchronous.
Public method | RequestInterpreterMetaRequestAsync | Requests interpreter meta request status
Public method | SelectFloorAsync | Selects the floor as input source.
Public method | SelectInputLanguageAsync | Selects the in preset language for A/B/C/D/E/F/G input.
Public method | SelectRelayAsync | Selects the relay language as input source.
Public method | SetOutPresetAsync | Sets the out preset language for B/C output.
Top
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.CancelInterpreterMetaFunctionAsync Method

IControlInterpretationCancelInterpreterMetaFunctionAsync Method

Bosch Logo
Cancels interpreter meta function request asynchronously.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CancelInterpreterMetaFunctionAsync(
    Guid seatId,
    List<DcnmInterpretationMetaRequestType> requests,
    Action<Task<bool>> onFinish = null
)
Function CancelInterpreterMetaFunctionAsync (
    seatId As Guid,
    requests As List(Of DcnmInterpretationMetaRequestType),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CancelInterpreterMetaFunctionAsync(
    Guid seatId,
    List<DcnmInterpretationMetaRequestType>^ requests,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

seatId
Type: SystemGuid
seat id
requests
Type: System.Collections.GenericList DcnmInterpretationMetaRequestType
request of type DcnmInterpretationMetaRequestType
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the set output cancel interpreter request. The 'Result' property of the task contains the indication if the output cancel interpreter request succeeds. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If seat id is empty.
Remarks
Requires:
  • CanControlInterpretation
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.GrantInterpretationAsync Method

IControlInterpretationGrantInterpretationAsync Method

Grants the interpretation asynchronous.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> GrantInterpretationAsync(
    Guid seatId,
    DcnmInterpretationMicrophoneState microphoneState,
    Action<Task<bool>> onFinish = null
)
Function GrantInterpretationAsync (
    seatId As Guid,
    microphoneState As DcnmInterpretationMicrophoneState,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ GrantInterpretationAsync(
    Guid seatId,
    DcnmInterpretationMicrophoneState microphoneState,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

seatId
Type: SystemGuid
The seat identifier.
microphoneState
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationMicrophoneState
The microphone state.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the grant interpretation. The 'Result' property of the task contains the indication if the grant interpretation succeeds. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If seat id is empty.
Remarks

Granting interpretation for B/C outputs when set of B/C languages is not configured or output preset is None, then interpretation is granted to the currently selected output preset on interpretation device.

Requires:

  • CanControlInterpretation

See Also

Reference

IControlInterpretation Interface


IControlInterpretation.IssueInterpreterMetaFunctionAsync Method

IControlInterpretationIssueInterpreterMetaFunctionAsync Method

Bosch Logo
Issues interpreter meta function request asynchronously.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> IssueInterpreterMetaFunctionAsync(
    Guid seatId,
    List<DcnmInterpretationMetaRequestType> requests,
    Action<Task<bool>> onFinish = null
)
Function IssueInterpreterMetaFunctionAsync (
    seatId As Guid,
    requests As List(Of DcnmInterpretationMetaRequestType),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ IssueInterpreterMetaFunctionAsync(
    Guid seatId,
    List<DcnmInterpretationMetaRequestType>^ requests,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

seatId
Type: SystemGuid
seat id
requests
Type: System.Collections.GenericList DcnmInterpretationMetaRequestType
request of type DcnmInterpretationMetaRequestType
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the set output issue interpreter request. The 'Result' property of the task contains the indication if the output issue interpreter request succeeds. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If seat id is empty.
Remarks
Requires:
  • CanControlInterpretation
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.RaiseBoothNotificationAsync Method

IControlInterpretationRaiseBoothNotificationAsync Method

Raises a notification in the given booth.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RaiseBoothNotificationAsync(
    Guid boothId,
    string notifications,
    Action<Task<bool>> onFinish = null
)
Function RaiseBoothNotificationAsync (
    boothId As Guid,
    notifications As String,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RaiseBoothNotificationAsync(
    Guid boothId,
    String^ notifications,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

boothId
Type: SystemGuid
The booth identifier to raise the notification for.
notifications
Type: SystemString
The notifications to be raised, BoothNotifications for supported booth notifications.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the raise booth notification. The 'Result' property of the task contains the indication if the raising of the booth notification succeeds. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If booth id is empty.
Remarks
Requires:
  • CanControlInterpretation
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.RequestBoothNotificationsAsync Method

IControlInterpretationRequestBoothNotificationsAsync Method

Requests the currently active booth notifications asynchronous.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestBoothNotificationsAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestBoothNotificationsAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestBoothNotificationsAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the retrieve booth notifications. The 'Result' property of the task is true if the request for the booth notifications is delivered, false if the request is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.RequestInterpretationLanguagesAsync Method

IControlInterpretationRequestInterpretationLanguagesAsync Method

Bosch Logo
Requests the interpretation languages asynchronous.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestInterpretationLanguagesAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestInterpretationLanguagesAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestInterpretationLanguagesAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the retrieve interpretation languages. The 'Result' property of the task is true if the request for the interpretation languages is delivered, false if the request is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.RequestInterpretationRoutingListAsync Method

IControlInterpretationRequestInterpretationRoutingListAsync Method

Bosch Logo
Requests the interpretation routing list asynchronous.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestInterpretationRoutingListAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestInterpretationRoutingListAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestInterpretationRoutingListAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the interpretation routing retrieval. The 'Result' property of the task is true if the request for the interpretation routing list is delivered, false if the request is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanControlInterpretation
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.RequestInterpreterMetaRequestAsync Method

IControlInterpretationRequestInterpreterMetaRequestAsync Method

Bosch Logo
Requests interpreter meta request status

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestInterpreterMetaRequestAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestInterpreterMetaRequestAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestInterpreterMetaRequestAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the interpreter meta request status. The 'Result' property of the task is true if the interpretation meta request status from system is active, else false. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.SelectFloorAsync Method

IControlInterpretationSelectFloorAsync Method

Selects the floor as input source.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SelectFloorAsync(
    Guid seatId,
    Action<Task<bool>> onFinish = null
)
Function SelectFloorAsync (
    seatId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SelectFloorAsync(
    Guid seatId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

seatId
Type: SystemGuid
The seat identifier.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the select floor. The 'Result' property of the task contains the indication if the selection of floor succeeds. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If seat id is empty.
Remarks
Requires:
  • CanControlInterpretation
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.SelectInputLanguageAsync Method

IControlInterpretationSelectInputLanguageAsync Method

Selects the in preset language for A/B/C/D/E/F/G input.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SelectInputLanguageAsync(
    Guid seatId,
    DcnmInterpretationInPresetState presetState,
    Guid languageId,
    Action<Task<bool>> onFinish = null
)
Function SelectInputLanguageAsync (
    seatId As Guid,
    presetState As DcnmInterpretationInPresetState,
    languageId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SelectInputLanguageAsync(
    Guid seatId,
    DcnmInterpretationInPresetState presetState,
    Guid languageId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

seatId
Type: SystemGuid
The seat identifier.
presetState
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationInPresetState
The in preset state.
languageId
Type: SystemGuid
The language identifier.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the select input language preset. The 'Result' property of the task contains the indication if the select language on input succeeds. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If seat id or language id is empty.
Remarks
Requires:
  • CanControlInterpretation
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.SelectRelayAsync Method

IControlInterpretationSelectRelayAsync Method

Selects the relay language as input source.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SelectRelayAsync(
    Guid seatId,
    Action<Task<bool>> onFinish = null
)
Function SelectRelayAsync (
    seatId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SelectRelayAsync(
    Guid seatId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

seatId
Type: SystemGuid
The seat identifier.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the select relay language. The 'Result' property of the task contains the indication if the selection of relay language succeeds. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If seat id is empty.
Remarks
Requires:
  • CanControlInterpretation
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.SetOutPresetAsync Method

IControlInterpretationSetOutPresetAsync Method

Sets the out preset language for B/C output.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetOutPresetAsync(
    Guid seatId,
    DcnmInterpretationOutPresetState presetState,
    Guid languageId,
    Action<Task<bool>> onFinish = null
)
Function SetOutPresetAsync (
    seatId As Guid,
    presetState As DcnmInterpretationOutPresetState,
    languageId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetOutPresetAsync(
    Guid seatId,
    DcnmInterpretationOutPresetState presetState,
    Guid languageId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

seatId
Type: SystemGuid
The seat identifier.
presetState
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmInterpretationOutPresetState
The out preset state.
languageId
Type: SystemGuid
The seat identifier.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the set output preset. The 'Result' property of the task contains the indication if the output preset succeeds. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If seat id is empty.
Remarks
Requires:
  • CanControlInterpretation
See Also

Reference

IControlInterpretation Interface


IControlInterpretation Events

The IControlInterpretation type exposes the following members.

Events
 | Name | Description
Public event | BoothNotificationsChanged | Occurs when the booth notifications changed.
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | InterpretationLanguagesChanged | Occurs when the interpretation languages changed.
Public event | InterpretationMetaRequestStatusChanged | Occurs when interpretation meta requests changed.
Public event | InterpretationRoutingListChanged | Occurs when the interpretation routing list changed.
Top
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.BoothNotificationsChanged Event

IControlInterpretationBoothNotificationsChanged Event

Occurs when the booth notifications changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmBoothNotificationInfo>>> BoothNotificationsChanged
Event BoothNotificationsChanged As EventHandler(Of ApiEventArgs(Of IList(Of DcnmBoothNotificationInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmBoothNotificationInfo^>^>^>^ BoothNotificationsChanged {
    void add (EventHandler<ApiEventArgs<IList<DcnmBoothNotificationInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmBoothNotificationInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmBoothNotificationInfo
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.CapabilitiesChanged Event

IControlInterpretationCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.InterpretationLanguagesChanged Event

IControlInterpretationInterpretationLanguagesChanged Event

Occurs when the interpretation languages changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmInterpretationLanguageInfo>>> InterpretationLanguagesChanged
Event InterpretationLanguagesChanged As EventHandler(Of ApiEventArgs(Of IList(Of DcnmInterpretationLanguageInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmInterpretationLanguageInfo^>^>^>^ InterpretationLanguagesChanged {
    void add (EventHandler<ApiEventArgs<IList<DcnmInterpretationLanguageInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmInterpretationLanguageInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmInterpretationLanguageInfo
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.InterpretationMetaRequestStatusChanged Event

IControlInterpretationInterpretationMetaRequestStatusChanged Event

 Bosch Logo
Occurs when interpretation meta requests changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmInterpretationMetaRequestInfo>> InterpretationMetaRequestStatusChanged
Event InterpretationMetaRequestStatusChanged As EventHandler(Of ApiEventArgs(Of DcnmInterpretationMetaRequestInfo))
 event EventHandler<ApiEventArgs<DcnmInterpretationMetaRequestInfo^>^>^ InterpretationMetaRequestStatusChanged {
    void add (EventHandler<ApiEventArgs<DcnmInterpretationMetaRequestInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmInterpretationMetaRequestInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmInterpretationMetaRequestInfo
See Also

Reference

IControlInterpretation Interface


IControlInterpretation.InterpretationRoutingListChanged Event

IControlInterpretationInterpretationRoutingListChanged Event

Occurs when the interpretation routing list changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmInterpretationRoutingInfo>>> InterpretationRoutingListChanged
Event InterpretationRoutingListChanged As EventHandler(Of ApiEventArgs(Of IList(Of DcnmInterpretationRoutingInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmInterpretationRoutingInfo^>^>^>^ InterpretationRoutingListChanged {
    void add (EventHandler<ApiEventArgs<IList<DcnmInterpretationRoutingInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmInterpretationRoutingInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmInterpretationRoutingInfo
See Also

Reference

IControlInterpretation Interface


IControlMeeting Interface

Defines the interface for meeting control

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IControlMeeting : IDisposable
Public Interface IControlMeeting
    Inherits IDisposable
public interface class IControlMeeting : IDisposable

The IControlMeeting type exposes the following members.

Properties
 | Name | Description
Public property | CanActivateMeeting | Indicates whether the user is able to activate meetings.
Public property | CanControlMeeting | Indicates whether the user is able to control meetings.
Top
Methods
 | Name | Description
Public method | ActivateMeetingAsync | Activate a meeting
Public method | BackToActiveAsync | Returns the seats to the current meeting status after an external app was started.
Public method | CloseAgendaTopicAsync | Closes a agenda topic
Public method | CloseMeetingAsync | Closes a meeting
Public method | DeactivateMeetingAsync | Deactivate a meeting
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | OpenAgendaTopicAsync | Opens a agenda topic
Public method | OpenMeetingAsync | Opens a meeting
Public method | RequestActiveMeetingStatusAsync | Requests status of currently active meeting.
Public method | RequestAgendaForPreparedMeetingAsync | Requests for the agenda for the prepared meeting.
Public method | RequestMeetingsListAsync | Requests for the meetings list and the current active meeting.
Public method | RequestParticipantsForPreparedMeetingAsync | Requests for the participants for the prepared meeting.
Public method | StartExternalAppAsync | Starts an external application at the seats in the meeting.
Top
Events
 | Name | Description
Public event | ActiveMeetingStatusChanged | Occurs when the activation status of a meeting changes
Public event | AgendaForMeetingReceived | Occurs when the agenda for prepared meetings have been received
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
 | MeetingsListChanged | Occurs when the meetings list has changed
Public event | ParticipantsForMeetingReceived | Occurs when the participants for prepared meetings have been received
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IControlMeeting Properties

The IControlMeeting type exposes the following members.

Properties
 | Name | Description
Public property | CanActivateMeeting | Indicates whether the user is able to activate meetings.
Public property | CanControlMeeting | Indicates whether the user is able to control meetings.
Top
See Also

Reference

IControlMeeting Interface


IControlMeeting.CanActivateMeeting Property

IControlMeetingCanActivateMeeting Property

Indicates whether the user is able to activate meetings.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanActivateMeeting { get; }
ReadOnly Property CanActivateMeeting As Boolean
    Get
property bool CanActivateMeeting {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Meeting preparation and management.
  • User right: Activate Meeting.
See Also

Reference

IControlMeeting Interface


IControlMeeting.CanControlMeeting Property

IControlMeetingCanControlMeeting Property

Indicates whether the user is able to control meetings.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanControlMeeting { get; }
ReadOnly Property CanControlMeeting As Boolean
    Get
property bool CanControlMeeting {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Meeting preparation and management.
  • Participant right: Can Manage.
See Also

Reference

IControlMeeting Interface


IControlMeeting Methods

The IControlMeeting type exposes the following members.

Methods
 | Name | Description
Public method | ActivateMeetingAsync | Activate a meeting
Public method | BackToActiveAsync | Returns the seats to the current meeting status after an external app was started.
Public method | CloseAgendaTopicAsync | Closes a agenda topic
Public method | CloseMeetingAsync | Closes a meeting
Public method | DeactivateMeetingAsync | Deactivate a meeting
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | OpenAgendaTopicAsync | Opens a agenda topic
Public method | OpenMeetingAsync | Opens a meeting
Public method | RequestActiveMeetingStatusAsync | Requests status of currently active meeting.
Public method | RequestAgendaForPreparedMeetingAsync | Requests for the agenda for the prepared meeting.
Public method | RequestMeetingsListAsync | Requests for the meetings list and the current active meeting.
Public method | RequestParticipantsForPreparedMeetingAsync | Requests for the participants for the prepared meeting.
Public method | StartExternalAppAsync | Starts an external application at the seats in the meeting.
Top
See Also

Reference

IControlMeeting Interface


IControlMeeting.ActivateMeetingAsync Method

IControlMeetingActivateMeetingAsync Method

Activate a meeting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> ActivateMeetingAsync(
    Guid meetingId,
    Action<Task<bool>> onFinish = null
)
Function ActivateMeetingAsync (
    meetingId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ ActivateMeetingAsync(
    Guid meetingId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The id of the meeting to be activated.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the meeting activation. The 'Result' property of the task is true if the request to activate a meeting is delivered, false when the request to activate is meeting is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If meeting id is empty.
Remarks

Requires:

  • CanActivateMeeting

Events triggered if the request to activate a meeting is processed successfully are as follows:

  • ActiveMeetingStatusChanged

See Also

Reference

IControlMeeting Interface


IControlMeeting.BackToActiveAsync Method

IControlMeetingBackToActiveAsync Method

Returns the seats to the current meeting status after an external app was started.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> BackToActiveAsync(
    Action<Task<bool>> onFinish = null
)
Function BackToActiveAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ BackToActiveAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the external app activation. The 'Result' property of the task is true if the request to return the seats to current meeting status is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanControlMeeting
See Also

Reference

IControlMeeting Interface


IControlMeeting.CloseAgendaTopicAsync Method

IControlMeetingCloseAgendaTopicAsync Method

Closes a agenda topic

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CloseAgendaTopicAsync(
    Guid agendaTopicId,
    Action<Task<bool>> onFinish = null
)
Function CloseAgendaTopicAsync (
    agendaTopicId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CloseAgendaTopicAsync(
    Guid agendaTopicId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

agendaTopicId
Type: SystemGuid
The agenda topic id
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the agenda topic close. The 'Result' property of the task is true if the request to close a agenda topic is delivered, false if the request is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

An empty Guid also closes current open agenda.

Requires:

  • CanControlMeeting

Events triggered if the request to close a agenda topic is processed successfully are as follows:

  • ActiveMeetingStatusChanged

See Also

Reference

IControlMeeting Interface


IControlMeeting.CloseMeetingAsync Method

IControlMeetingCloseMeetingAsync Method

Closes a meeting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CloseMeetingAsync(
    Action<Task<bool>> onFinish = null
)
Function CloseMeetingAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CloseMeetingAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchornous handling of the result.

Return Value

Type: Task Boolean
Task processing the meeting close. The 'Result' property of the task is true if the request to close a meeting is delivered, false if the request is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • CanControlMeeting

Events triggered if the request to close a meeting is processed successfully are as follows:

  • ActiveMeetingStatusChanged

See Also

Reference

IControlMeeting Interface


IControlMeeting.DeactivateMeetingAsync Method

IControlMeetingDeactivateMeetingAsync Method

Deactivate a meeting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeactivateMeetingAsync(
    Action<Task<bool>> onFinish = null
)
Function DeactivateMeetingAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeactivateMeetingAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the meeting deactivation. The 'Result' property of the task is true if the request to deactivate a meeting is delivered, false if request is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • CanActivateMeeting

Events triggered if the request to deactivate a meeting is processed successfully are as follows:

  • ActiveMeetingStatusChanged

See Also

Reference

IControlMeeting Interface


IControlMeeting.OpenAgendaTopicAsync Method

IControlMeetingOpenAgendaTopicAsync Method

Opens a agenda topic

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> OpenAgendaTopicAsync(
    Guid agendaTopicId,
    Action<Task<bool>> onFinish = null
)
Function OpenAgendaTopicAsync (
    agendaTopicId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ OpenAgendaTopicAsync(
    Guid agendaTopicId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

agendaTopicId
Type: SystemGuid
The agenda topic id
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the agenda topic open. The 'Result' property of the task is true if the request to open a agenda topic is delivered, false if the request is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If agenda topic id is empty.
Remarks

Requires:

  • CanControlMeeting

Events triggered if the request to open a agenda topic is processed successfully are as follows:

  • ActiveMeetingStatusChanged

See Also

Reference

IControlMeeting Interface


IControlMeeting.OpenMeetingAsync Method

IControlMeetingOpenMeetingAsync Method

Opens a meeting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> OpenMeetingAsync(
    Action<Task<bool>> onFinish = null
)
Function OpenMeetingAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ OpenMeetingAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the meeting open. The 'Result' property of the task is true if the request to open a meeting is delivered, false if the request is not delivred. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • CanControlMeeting

Events triggered if the request to open a meeting is processed successfully are as follows:

  • ActiveMeetingStatusChanged

See Also

Reference

IControlMeeting Interface


IControlMeeting.RequestActiveMeetingStatusAsync Method

IControlMeetingRequestActiveMeetingStatusAsync Method

Requests status of currently active meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestActiveMeetingStatusAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestActiveMeetingStatusAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestActiveMeetingStatusAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the meeting retrieval. The 'Result' property of the task is true if the request to retrieve the status of active meeting is delivered, false if the request is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlMeeting Interface


IControlMeeting.RequestAgendaForPreparedMeetingAsync Method

IControlMeetingRequestAgendaForPreparedMeetingAsync Method

Requests for the agenda for the prepared meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestAgendaForPreparedMeetingAsync(
    Guid meetingId,
    Action<Task<bool>> onFinish = null
)
Function RequestAgendaForPreparedMeetingAsync (
    meetingId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestAgendaForPreparedMeetingAsync(
    Guid meetingId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The meeting id.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the meeting list retrieval. The 'Result' property of the task is true if the request to retrieve agenda of a prepared meeting is delivered, false if the request is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If meeting id is empty.
Remarks

AgendaForMeetingReceived is triggered if the request is processed successfully, along with the list of participants.

See Also

Reference

IControlMeeting Interface


IControlMeeting.RequestMeetingsListAsync Method

IControlMeetingRequestMeetingsListAsync Method

Requests for the meetings list and the current active meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestMeetingsListAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestMeetingsListAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestMeetingsListAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the meeting list retrieval. The 'Result' property of the task is true if the request for list of meeting is delivered, false if the request is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlMeeting Interface


IControlMeeting.RequestParticipantsForPreparedMeetingAsync Method

IControlMeetingRequestParticipantsForPreparedMeetingAsync Method

Bosch Logo
Requests for the participants for the prepared meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestParticipantsForPreparedMeetingAsync(
    Guid meetingId,
    Action<Task<bool>> onFinish = null
)
Function RequestParticipantsForPreparedMeetingAsync (
    meetingId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestParticipantsForPreparedMeetingAsync(
    Guid meetingId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The meeting id.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the meeting list retrieval. The 'Result' property of the task is true if the request to retrieve the participants of a meeting is delivered successfully, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If meeting id is empty.
Remarks

ParticipantsForMeetingReceived is triggered if the request is processed successfully, along with the list of participants.

See Also

Reference

IControlMeeting Interface


IControlMeeting.StartExternalAppAsync Method

IControlMeetingStartExternalAppAsync Method

Starts an external application at the seats in the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> StartExternalAppAsync(
    string extAppName,
    Action<Task<bool>> onFinish = null
)
Function StartExternalAppAsync (
    extAppName As String,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ StartExternalAppAsync(
    String^ extAppName,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

extAppName
Type: SystemString
Package name of the external application to start. E.a. com.company.appname
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the external app activation. The 'Result' property of the task is true if the request to start external app is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If external application name is null or empty.
Remarks
Requires:
  • CanControlMeeting
See Also

Reference

IControlMeeting Interface


IControlMeeting Events

The IControlMeeting type exposes the following members.

Events
 | Name | Description
Public event | ActiveMeetingStatusChanged | Occurs when the activation status of a meeting changes
Public event | AgendaForMeetingReceived | Occurs when the agenda for prepared meetings have been received
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
 | MeetingsListChanged | Occurs when the meetings list has changed
Public event | ParticipantsForMeetingReceived | Occurs when the participants for prepared meetings have been received
Top
See Also

Reference

IControlMeeting Interface


IControlMeeting.ActiveMeetingStatusChanged Event

IControlMeetingActiveMeetingStatusChanged Event

Occurs when the activation status of a meeting changes

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmMeetingStatusInfo>> ActiveMeetingStatusChanged
Event ActiveMeetingStatusChanged As EventHandler(Of ApiEventArgs(Of DcnmMeetingStatusInfo))
 event EventHandler<ApiEventArgs<DcnmMeetingStatusInfo^>^>^ ActiveMeetingStatusChanged {
    void add (EventHandler<ApiEventArgs<DcnmMeetingStatusInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmMeetingStatusInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmMeetingStatusInfo
Remarks
This event only reports the activation status of the meeting (becoming or leaving the active state), including the default meeting. The event is not triggered when other elements of the related meeting changes, like the title and attached DcnmAgendaTopicStatusInfo data. When you are also interested in changes of these element, register for the MeetingsListChanged event.
See Also

Reference

IControlMeeting Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IControlMeetingMeetingsListChanged


IControlMeeting.AgendaForMeetingReceived Event

IControlMeetingAgendaForMeetingReceived Event

Occurs when the agenda for prepared meetings have been received

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmAgendaTopicStatusInfo>>> AgendaForMeetingReceived
Event AgendaForMeetingReceived As EventHandler(Of ApiEventArgs(Of IList(Of DcnmAgendaTopicStatusInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmAgendaTopicStatusInfo^>^>^>^ AgendaForMeetingReceived {
    void add (EventHandler<ApiEventArgs<IList<DcnmAgendaTopicStatusInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmAgendaTopicStatusInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmAgendaTopicStatusInfo
See Also

Reference

IControlMeeting Interface


IControlMeeting.CapabilitiesChanged Event

IControlMeetingCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IControlMeeting Interface


IControlMeeting.MeetingsListChanged Event

IControlMeetingMeetingsListChanged Event

Occurs when the meetings list has changed

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmMeetingStatusInfo>>> MeetingsListChanged
Event MeetingsListChanged As EventHandler(Of ApiEventArgs(Of IList(Of DcnmMeetingStatusInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmMeetingStatusInfo^>^>^>^ MeetingsListChanged {
    void add (EventHandler<ApiEventArgs<IList<DcnmMeetingStatusInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmMeetingStatusInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmMeetingStatusInfo
Remarks

This event signals that the one or more meeting as present in the meeting list is changed, added ot removed.

Caution note Caution
The default meeting is not part of the list reported. This implies that when the default meeting is active non of the meetings in the list have the Activated state. To get an event when the default meeting becomes active, register on the ActiveMeetingStatusChanged.

When you like to follow the active DcnmAgendaTopicStatusInfo changes, you have to register for this event and filter the meeting on State equal to either Activated and Opened.

Examples

The example below shows how to create a generic methor to handle the active meeting changes, including the attached agenda-topics.

C#
Copy
// Register for the events
MainWindowsApi.ControlMeeting.ActiveMeetingStatusChanged += OnActiveMeetingStatusChanged;
MainWindowsApi.ControlMeeting.MeetingsListChanged += OnMeetingsListChanged;

/// <summary>Handles changes of the meeting list</summary>
/// <remarks>Looks in the list of meetings for the active meeting and passed that
/// <see href="DcnmMeetingStatusInfo"/> to the original handler function</remarks>
private void OnMeetingsListChanged(object sender, ApiEventArgs<IList<DcnmMeetingStatusInfo>> e)
{
    foreach (var meetingInfo in e.Parameter)
    {
        if (meetingInfo.State == DcnmMeetingState.Activated ||
            meetingInfo.State == DcnmMeetingState.Opened)
        {
            OnActiveMeetingStatusChanged(sender, new ApiEventArgs<DcnmMeetingStatusInfo>(meetingInfo));
        }
    }
}

/// <summary>Handles the changes of the active meeting</summary>
private void OnActiveMeetingStatusChanged(object sender, ApiEventArgs<DcnmMeetingStatusInfo> e)
{
    DcnmMeetingStatusInfo meetingStatusInfo = e.Paramter;
    // Do processing the meeting

    foreach (var agendaStatusInfo in meetingStatusInfo.AgendaList)
    {
        // process active / inactive agenda topic based on Active state
        if (agendaStatusInfo.Active)
        {
            // ...
        }
    }
}
See Also

Reference

IControlMeeting Interface


IControlMeeting.ParticipantsForMeetingReceived Event

IControlMeetingParticipantsForMeetingReceived Event

Occurs when the participants for prepared meetings have been received

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmParticipationListInfo>> ParticipantsForMeetingReceived
Event ParticipantsForMeetingReceived As EventHandler(Of ApiEventArgs(Of DcnmParticipationListInfo))
 event EventHandler<ApiEventArgs<DcnmParticipationListInfo^>^>^ ParticipantsForMeetingReceived {
    void add (EventHandler<ApiEventArgs<DcnmParticipationListInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmParticipationListInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmParticipationListInfo
See Also

Reference

IControlMeeting Interface


IControlParticipant Interface

Defines the interface for participant control

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IControlParticipant : IDisposable
Public Interface IControlParticipant
    Inherits IDisposable
public interface class IControlParticipant : IDisposable

The IControlParticipant type exposes the following members.

Properties
 | Name | Description
Public property | CanControlParticipant | Indicates whether the user is able to control a participant.
Public property | IsLoggedOnUserParticipantForMeeting | Indicates whether the logged on user is a participant for meeting
Top
Methods
 | Name | Description
Public method | AuthenticateParticipantAtDeviceAsync | Authenticates participant at device.
Public method | AuthenticateParticipantAtSeatAsync | Authenticates participant at seat.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestAttendanceInfoAsync | Requests for the Attendance summary of the current meeting.
Public method | RequestParticipantAccessDeniedStatusAsync | Requests for the participant access denied status of current meeting.
Public method | RequestParticipantsListAsync | Requests for the participants list of the current meeting.
Public method | UnIdentifyAllParticipantsAsync | Forcing participants to logoff from seat.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | ParticipantAccessDenied | Occurs when the participant access is denied
Public event | ParticipantAttendanceSummaryChanged | Occurs when the Participant Attendance Summary has changed
Public event | ParticipantsListChanged | Occurs when the participants list has changed
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IControlParticipant Properties

The IControlParticipant type exposes the following members.

Properties
 | Name | Description
Public property | CanControlParticipant | Indicates whether the user is able to control a participant.
Public property | IsLoggedOnUserParticipantForMeeting | Indicates whether the logged on user is a participant for meeting
Top
See Also

Reference

IControlParticipant Interface


IControlParticipant.CanControlParticipant Property

IControlParticipantCanControlParticipant Property

Indicates whether the user is able to control a participant.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanControlParticipant { get; }
ReadOnly Property CanControlParticipant As Boolean
    Get
property bool CanControlParticipant {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode
See Also

Reference

IControlParticipant Interface


IControlParticipant.IsLoggedOnUserParticipantForMeeting Property

IControlParticipantIsLoggedOnUserParticipantForMeeting Property

Bosch Logo
Indicates whether the logged on user is a participant for meeting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsLoggedOnUserParticipantForMeeting { get; }
ReadOnly Property IsLoggedOnUserParticipantForMeeting As Boolean
    Get
property bool IsLoggedOnUserParticipantForMeeting {
    bool get ();
}

Return Value

Type: Boolean
True if logged user is a participant, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlParticipant Interface


IControlParticipant Methods

The IControlParticipant type exposes the following members.

Methods
 | Name | Description
Public method | AuthenticateParticipantAtDeviceAsync | Authenticates participant at device.
Public method | AuthenticateParticipantAtSeatAsync | Authenticates participant at seat.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestAttendanceInfoAsync | Requests for the Attendance summary of the current meeting.
Public method | RequestParticipantAccessDeniedStatusAsync | Requests for the participant access denied status of current meeting.
Public method | RequestParticipantsListAsync | Requests for the participants list of the current meeting.
Public method | UnIdentifyAllParticipantsAsync | Forcing participants to logoff from seat.
Top
See Also

Reference

IControlParticipant Interface


IControlParticipant.AuthenticateParticipantAtDeviceAsync Method

IControlParticipantAuthenticateParticipantAtDeviceAsync Method

Bosch Logo
Authenticates participant at device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> AuthenticateParticipantAtDeviceAsync(
    Guid deviceId,
    Guid personId,
    Action<Task<bool>> onFinish = null
)
Function AuthenticateParticipantAtDeviceAsync (
    deviceId As Guid,
    personId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ AuthenticateParticipantAtDeviceAsync(
    Guid deviceId,
    Guid personId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

deviceId
Type: SystemGuid
device id to authenticate person
personId
Type: SystemGuid
person id of the participant
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the authenticate participant. The 'Result' property of the task is true if the request to authentication, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Device id that is provided during method call should be valid GUID of Conference device which is active during authentication process. If invalid device id is provided the authentication request will return false. Person id that is provided during method call should be valid GUID of a DCNM user. If valid device id and invalid person id is provided following errors are shown on device
  • 'Participant not part of the meeting' message is shown when person id does not belong any particpant of the meeting
  • 'You are using wrong seat' message is shown when person is not assigned to the device he is trying to login
  • 'Please provide valid credentials' message is shown when person id does not match with any DCNM user
To log off a person at device, provide Guid.Empty as person id
See Also

Reference

IControlParticipant Interface


IControlParticipant.AuthenticateParticipantAtSeatAsync Method

IControlParticipantAuthenticateParticipantAtSeatAsync Method

Authenticates participant at seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> AuthenticateParticipantAtSeatAsync(
    Guid seatId,
    Guid personId,
    Action<Task<bool>> onFinish = null
)
Function AuthenticateParticipantAtSeatAsync (
    seatId As Guid,
    personId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ AuthenticateParticipantAtSeatAsync(
    Guid seatId,
    Guid personId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

seatId
Type: SystemGuid
Seat id to authenticate person
personId
Type: SystemGuid
person id of the participant
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the authenticate participant. The 'Result' property of the task is true if the request to authentication, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Seat id that is provided during method call should be valid GUID of Conference device which is active during authentication process. If invalid seat id is provided the authentication request will return false. Person id that is provided during method call should be valid GUID of a DCNM user. If valid device id and invalid person id is provided following errors are shown on device
  • 'Participant not part of the meeting' message is shown when person id does not belong any particpant of the meeting
  • 'You are using wrong seat' message is shown when person is not assigned to the device he is trying to login
  • 'Please provide valid credentials' message is shown when person id does not match with any DCNM user
To log off a person at device, provide Guid.Empty as person id
See Also

Reference

IControlParticipant Interface


IControlParticipant.RequestAttendanceInfoAsync Method

IControlParticipantRequestAttendanceInfoAsync Method

Requests for the Attendance summary of the current meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestAttendanceInfoAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestAttendanceInfoAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestAttendanceInfoAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the QuickAccess list request. The 'Result' property of the task is true, if the request to retrieve the quick access list is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlParticipant Interface


IControlParticipant.RequestParticipantAccessDeniedStatusAsync Method

IControlParticipantRequestParticipantAccessDeniedStatusAsync Method

Bosch Logo
Requests for the participant access denied status of current meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestParticipantAccessDeniedStatusAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestParticipantAccessDeniedStatusAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestParticipantAccessDeniedStatusAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the participant access denied status request. The 'Result' property of the task is true, if the request to retrieve the participant access denied status is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlParticipant Interface


IControlParticipant.RequestParticipantsListAsync Method

IControlParticipantRequestParticipantsListAsync Method

Requests for the participants list of the current meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestParticipantsListAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestParticipantsListAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestParticipantsListAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the participant list request. The 'Result' property of the task is true, if the request to retrieve the participants list is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlParticipant Interface


IControlParticipant.UnIdentifyAllParticipantsAsync Method

IControlParticipantUnIdentifyAllParticipantsAsync Method

Forcing participants to logoff from seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UnIdentifyAllParticipantsAsync(
    Action<Task<bool>> onFinish = null
)
Function UnIdentifyAllParticipantsAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UnIdentifyAllParticipantsAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the logoff from seat for participants. The 'Result' property of the task is true, if the request to logoff participants, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlParticipant Interface


IControlParticipant Events

The IControlParticipant type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | ParticipantAccessDenied | Occurs when the participant access is denied
Public event | ParticipantAttendanceSummaryChanged | Occurs when the Participant Attendance Summary has changed
Public event | ParticipantsListChanged | Occurs when the participants list has changed
Top
See Also

Reference

IControlParticipant Interface


IControlParticipant.CapabilitiesChanged Event

IControlParticipantCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IControlParticipant Interface


IControlParticipant.ParticipantAccessDenied Event

IControlParticipantParticipantAccessDenied Event

Occurs when the participant access is denied

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmParticipantAccessDeniedInfo>> ParticipantAccessDenied
Event ParticipantAccessDenied As EventHandler(Of ApiEventArgs(Of DcnmParticipantAccessDeniedInfo))
 event EventHandler<ApiEventArgs<DcnmParticipantAccessDeniedInfo^>^>^ ParticipantAccessDenied {
    void add (EventHandler<ApiEventArgs<DcnmParticipantAccessDeniedInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmParticipantAccessDeniedInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmParticipantAccessDeniedInfo
See Also

Reference

IControlParticipant Interface


IControlParticipant.ParticipantAttendanceSummaryChanged Event

IControlParticipantParticipantAttendanceSummaryChanged Event

Occurs when the Participant Attendance Summary has changed

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmAttendanceInfo>> ParticipantAttendanceSummaryChanged
Event ParticipantAttendanceSummaryChanged As EventHandler(Of ApiEventArgs(Of DcnmAttendanceInfo))
 event EventHandler<ApiEventArgs<DcnmAttendanceInfo^>^>^ ParticipantAttendanceSummaryChanged {
    void add (EventHandler<ApiEventArgs<DcnmAttendanceInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmAttendanceInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmAttendanceInfo
See Also

Reference

IControlParticipant Interface


IControlParticipant.ParticipantsListChanged Event

IControlParticipantParticipantsListChanged Event

Occurs when the participants list has changed

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmParticipationInfo>>> ParticipantsListChanged
Event ParticipantsListChanged As EventHandler(Of ApiEventArgs(Of IList(Of DcnmParticipationInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmParticipationInfo^>^>^>^ ParticipantsListChanged {
    void add (EventHandler<ApiEventArgs<IList<DcnmParticipationInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmParticipationInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmParticipationInfo
See Also

Reference

IControlParticipant Interface


IControlPresentation Interface

Interface for control presentation

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IControlPresentation : IDisposable
Public Interface IControlPresentation
    Inherits IDisposable
public interface class IControlPresentation : IDisposable

The IControlPresentation type exposes the following members.

Properties
 | Name | Description
Public property | CanControlPresentation | Indicates whether the user is allowed to control the presentation.
Public property | IsPresentationActive | Indicates whether the presentation is active or not.
Top
Methods
 | Name | Description
Public method | ActivatePresentationAsync | Activates the presentation
Public method | DeactivatePresentationAsync | Deactivates the presentation
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestPresentationStateAsync | Triggers the request for the current state of the presentation.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the access rights of the logged on user changed.
Public event | PresentationStateChanged | Event indicating the presentation state has changed.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IControlPresentation Properties

The IControlPresentation type exposes the following members.

Properties
 | Name | Description
Public property | CanControlPresentation | Indicates whether the user is allowed to control the presentation.
Public property | IsPresentationActive | Indicates whether the presentation is active or not.
Top
See Also

Reference

IControlPresentation Interface


IControlPresentation.CanControlPresentation Property

IControlPresentationCanControlPresentation Property

Indicates whether the user is allowed to control the presentation.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanControlPresentation { get; }
ReadOnly Property CanControlPresentation As Boolean
    Get
property bool CanControlPresentation {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Media Sharing.
  • Seat license: Video.
  • Participant right: Can Manage.
See Also

Reference

IControlPresentation Interface


IControlPresentation.IsPresentationActive Property

IControlPresentationIsPresentationActive Property

Indicates whether the presentation is active or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsPresentationActive { get; }
ReadOnly Property IsPresentationActive As Boolean
    Get
property bool IsPresentationActive {
    bool get ();
}

Return Value

Type: Boolean
Boolean indicating whether the presentation is currently active or not.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlPresentation Interface


IControlPresentation Methods

The IControlPresentation type exposes the following members.

Methods
 | Name | Description
Public method | ActivatePresentationAsync | Activates the presentation
Public method | DeactivatePresentationAsync | Deactivates the presentation
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestPresentationStateAsync | Triggers the request for the current state of the presentation.
Top
See Also

Reference

IControlPresentation Interface


IControlPresentation.ActivatePresentationAsync Method

IControlPresentationActivatePresentationAsync Method

Activates the presentation

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> ActivatePresentationAsync(
    Action<Task<bool>> onFinish = null
)
Function ActivatePresentationAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ ActivatePresentationAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the presentation start. The 'Result' property of the task is true, if the request to start a presentation is delivered successfully, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanControlPresentation
See Also

Reference

IControlPresentation Interface


IControlPresentation.DeactivatePresentationAsync Method

IControlPresentationDeactivatePresentationAsync Method

Deactivates the presentation

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeactivatePresentationAsync(
    Action<Task<bool>> onFinish = null
)
Function DeactivatePresentationAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeactivatePresentationAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the presentation stop. The 'Result' property of the task is true, if the request to stop a presentation is delivered successfully, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanControlPresentation
See Also

Reference

IControlPresentation Interface


IControlPresentation.RequestPresentationStateAsync Method

IControlPresentationRequestPresentationStateAsync Method

Triggers the request for the current state of the presentation.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestPresentationStateAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestPresentationStateAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestPresentationStateAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the presentation state request. The 'Result' property of the task holds the return value of the function. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlPresentation Interface


IControlPresentation Events

The IControlPresentation type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the access rights of the logged on user changed.
Public event | PresentationStateChanged | Event indicating the presentation state has changed.
Top
See Also

Reference

IControlPresentation Interface


IControlPresentation.CapabilitiesChanged Event

IControlPresentationCapabilitiesChanged Event

Occurs when the access rights of the logged on user changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IControlPresentation Interface


IControlPresentation.PresentationStateChanged Event

IControlPresentationPresentationStateChanged Event

Event indicating the presentation state has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<bool>> PresentationStateChanged
Event PresentationStateChanged As EventHandler(Of ApiEventArgs(Of Boolean))
 event EventHandler<ApiEventArgs<bool>^>^ PresentationStateChanged {
    void add (EventHandler<ApiEventArgs<bool>^>^ value);
    void remove (EventHandler<ApiEventArgs<bool>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Boolean
See Also

Reference

IControlPresentation Interface


IControlSpeaker Interface

Defines the interface for speaker control

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IControlSpeaker : IDisposable
Public Interface IControlSpeaker
    Inherits IDisposable
public interface class IControlSpeaker : IDisposable

The IControlSpeaker type exposes the following members.

Properties
 | Name | Description
Public property | CanControlSpeaker | Indicates whether the user is able to control a speaker.
Top
Methods
 | Name | Description
Public method | CancelImportantSpeakersAsync | Refuses an active important speaker from speaking.
Public method | CancelRequestsAsync | Cancels a request to speak of a participant..
Public method | CancelRespondersAsync | Refuses an active responder from speaking.
Public method | CancelResponseRequestsAsync | Cancels a request to respond of a participant.
Public method | CancelSpeakersAsync | Refuses an active speaker from speaking.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GrantRequestAsync | Allows a participant to be added to the waiting list.
Public method | GrantResponseRequestAsync | Allows a participant to be added to the response request waiting list.
Public method | GrantSpeechAsync | Allows a participant to speak.
Public method | RequestActualSpeakerAsync | Requests for the actual speaker of the active discussion.
Public method | RequestImportantSpeakersListAsync | Requests for the important speakers requests list of the active discussion.
Public method | RequestMicrophonesActiveAsync | Request to activate the microphones for the list of participants. This request is only possible in response mode and only for speakers and/or responders.
Public method | RequestMicrophonesInactiveAsync | Request to deactivate the microphones for the list of participants. This request is only possible in response mode and only for speakers and/or responders.
Public method | RequestPriorityListAsync | Requests for the priority list of the active discussion.
Public method | RequestRequestsListAsync | Requests for the request list of the active discussion.
Public method | RequestRespondersListAsync | Requests for the responders list of the active discussion.
Public method | RequestResponseRequestsListAsync | Requests for the response requests list of the active discussion.
Public method | RequestSpeakersListAsync | Requests for the speakers list of the active discussion.
Public method | SetSpeechTimeAsync(Guid, Int32, DcnmDiscussionType, ActionTaskBoolean) | Sets the updated speech time for the given participant id
Public method | SetSpeechTimeAsync(Guid, Int32, DcnmDiscussionType, Boolean, ActionTaskBoolean) | Sets the updated speech time for the given participant id
Public method | ShiftFirstRequestAsync | Rejects the oldest speaker from speaking and adds the oldest participant in the request list to the speakers list.
Public method | ShiftFirstResponseRequestAsync | Rejects the speaker in the responders list and adds the oldest participant in the response request list to the responders list.
Public method | ShiftRequestsAsync | Shifts the given participants to the speakers list, and removes the oldest speaker in the speakers list.
Public method | ShiftResponseRequestsAsync | Shifts the given participant(s) to the responders list, and removes the oldest speaker in the responders list..
Top
Events
 | Name | Description
Public event | ActualSpeakerChanged | Obsolete. Occurs when the actual speaker has changed.
Public event | ActualSpeakerImageChanged | Occurs when the actual speaker image changed.
Public event | ActualSpeakerVideoChanged | Occurs when the actual speaker video changed.
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | ImportantSpeakersListChanged | Occurs when the important speakers list has changed.
Public event | PriorityListChanged | Occurs when the priority list has changed
Public event | RequestsListChanged | Occurs when the requests list has changed
Public event | RespondersListChanged | Occurs when the response list has changed.
Public event | ResponseRequestsListChanged | Occurs when the response requests list has changed.
Public event | SpeakersListChanged | Occurs when the speakers list has changed
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IControlSpeaker Properties

The IControlSpeaker type exposes the following members.

Properties
 | Name | Description
Public property | CanControlSpeaker | Indicates whether the user is able to control a speaker.
Top
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.CanControlSpeaker Property

IControlSpeakerCanControlSpeaker Property

Indicates whether the user is able to control a speaker.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanControlSpeaker { get; }
ReadOnly Property CanControlSpeaker As Boolean
    Get
property bool CanControlSpeaker {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Participant right: Can Manage.
  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode
See Also

Reference

IControlSpeaker Interface


IControlSpeaker Methods

The IControlSpeaker type exposes the following members.

Methods
 | Name | Description
Public method | CancelImportantSpeakersAsync | Refuses an active important speaker from speaking.
Public method | CancelRequestsAsync | Cancels a request to speak of a participant..
Public method | CancelRespondersAsync | Refuses an active responder from speaking.
Public method | CancelResponseRequestsAsync | Cancels a request to respond of a participant.
Public method | CancelSpeakersAsync | Refuses an active speaker from speaking.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GrantRequestAsync | Allows a participant to be added to the waiting list.
Public method | GrantResponseRequestAsync | Allows a participant to be added to the response request waiting list.
Public method | GrantSpeechAsync | Allows a participant to speak.
Public method | RequestActualSpeakerAsync | Requests for the actual speaker of the active discussion.
Public method | RequestImportantSpeakersListAsync | Requests for the important speakers requests list of the active discussion.
Public method | RequestMicrophonesActiveAsync | Request to activate the microphones for the list of participants. This request is only possible in response mode and only for speakers and/or responders.
Public method | RequestMicrophonesInactiveAsync | Request to deactivate the microphones for the list of participants. This request is only possible in response mode and only for speakers and/or responders.
Public method | RequestPriorityListAsync | Requests for the priority list of the active discussion.
Public method | RequestRequestsListAsync | Requests for the request list of the active discussion.
Public method | RequestRespondersListAsync | Requests for the responders list of the active discussion.
Public method | RequestResponseRequestsListAsync | Requests for the response requests list of the active discussion.
Public method | RequestSpeakersListAsync | Requests for the speakers list of the active discussion.
Public method | SetSpeechTimeAsync(Guid, Int32, DcnmDiscussionType, ActionTaskBoolean) | Sets the updated speech time for the given participant id
Public method | SetSpeechTimeAsync(Guid, Int32, DcnmDiscussionType, Boolean, ActionTaskBoolean) | Sets the updated speech time for the given participant id
Public method | ShiftFirstRequestAsync | Rejects the oldest speaker from speaking and adds the oldest participant in the request list to the speakers list.
Public method | ShiftFirstResponseRequestAsync | Rejects the speaker in the responders list and adds the oldest participant in the response request list to the responders list.
Public method | ShiftRequestsAsync | Shifts the given participants to the speakers list, and removes the oldest speaker in the speakers list.
Public method | ShiftResponseRequestsAsync | Shifts the given participant(s) to the responders list, and removes the oldest speaker in the responders list..
Top
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.CancelImportantSpeakersAsync Method

IControlSpeakerCancelImportantSpeakersAsync Method

Refuses an active important speaker from speaking.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CancelImportantSpeakersAsync(
    IList<Guid> participantIds,
    Action<Task<bool>> onFinish = null
)
Function CancelImportantSpeakersAsync (
    participantIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CancelImportantSpeakersAsync(
    IList<Guid>^ participantIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantIds
Type: System.Collections.GenericIList Guid
The identification of the participants to cancel, typically being a list of Id of DcnmParticipationInfo.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the speech cancel. The 'Result' property of the task is true, if the request to stop active important speakers from speaking, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participantIds are null or empty.
Remarks
Requires:
  • CanControlSpeaker should be set to true.
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.CancelRequestsAsync Method

IControlSpeakerCancelRequestsAsync Method

Cancels a request to speak of a participant..

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CancelRequestsAsync(
    IList<Guid> participantIds,
    Action<Task<bool>> onFinish = null
)
Function CancelRequestsAsync (
    participantIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CancelRequestsAsync(
    IList<Guid>^ participantIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantIds
Type: System.Collections.GenericIList Guid
The identification of the participants to cancel, typically being a list of Id of DcnmParticipationInfo.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request cancel. The 'Result' property of the task is true, if the request to cancel a participants' request to speak is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participantIds are null or empty.
Remarks

Requires:

  • CanControlSpeakershould be set to true.

Events triggered once a participant is removed from request list are as follows:

  • RequestsListChanged

See Also

Reference

IControlSpeaker Interface


IControlSpeaker.CancelRespondersAsync Method

IControlSpeakerCancelRespondersAsync Method

Refuses an active responder from speaking.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CancelRespondersAsync(
    IList<Guid> participantIds,
    Action<Task<bool>> onFinish = null
)
Function CancelRespondersAsync (
    participantIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CancelRespondersAsync(
    IList<Guid>^ participantIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantIds
Type: System.Collections.GenericIList Guid
The identification of the participants to cancel, typically being a list of Id of DcnmParticipationInfo.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the speech cancel. The 'Result' property of the task is true, if the request to stop active responders from speaking is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participantIds are null or empty.
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.CancelResponseRequestsAsync Method

IControlSpeakerCancelResponseRequestsAsync Method

Cancels a request to respond of a participant.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CancelResponseRequestsAsync(
    IList<Guid> participantIds,
    Action<Task<bool>> onFinish = null
)
Function CancelResponseRequestsAsync (
    participantIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CancelResponseRequestsAsync(
    IList<Guid>^ participantIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantIds
Type: System.Collections.GenericIList Guid
The identification of the participants to cancel, typically being a list of Id of DcnmParticipationInfo.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request cancel. The 'Result' property of the task is true, if the requset to cancel participants' request to respond is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participantIds are null or empty.
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.CancelSpeakersAsync Method

IControlSpeakerCancelSpeakersAsync Method

Refuses an active speaker from speaking.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CancelSpeakersAsync(
    IList<Guid> participantIds,
    Action<Task<bool>> onFinish = null
)
Function CancelSpeakersAsync (
    participantIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CancelSpeakersAsync(
    IList<Guid>^ participantIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantIds
Type: System.Collections.GenericIList Guid
The identification of the participants to cancel, typically being a list of Id of DcnmParticipationInfo.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the speech cancel. The 'Result' property of the task is true, if the request to stop active speakers from speaking is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participantIds are null or empty.
Remarks

Requires:

  • CanControlSpeaker should be set to true.

Events triggered once a active speaker is stopped from speaking are as follows:

  • SpeakersListChanged

See Also

Reference

IControlSpeaker Interface


IControlSpeaker.GrantRequestAsync Method

IControlSpeakerGrantRequestAsync Method

Allows a participant to be added to the waiting list.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> GrantRequestAsync(
    Guid participantId,
    Action<Task<bool>> onFinish = null
)
Function GrantRequestAsync (
    participantId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ GrantRequestAsync(
    Guid participantId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantId
Type: SystemGuid
The identification of the participant, typically being Id of DcnmParticipationInfo passed as value.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the waiting list addition. The 'Result' property of the task is true, if the request to add a participant to waiting list is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participant id is empty.
Remarks

Requires:

  • CanControlSpeaker should be set to true.

Events triggered once a participant is added to waiting list are as follows

  • RequestsListChanged

See Also

Reference

IControlSpeaker Interface


IControlSpeaker.GrantResponseRequestAsync Method

IControlSpeakerGrantResponseRequestAsync Method

Allows a participant to be added to the response request waiting list.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> GrantResponseRequestAsync(
    Guid participantId,
    Action<Task<bool>> onFinish = null
)
Function GrantResponseRequestAsync (
    participantId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ GrantResponseRequestAsync(
    Guid participantId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantId
Type: SystemGuid
The identification of the participant, typically being Id of DcnmParticipationInfo passed as value.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the response request waiting list addition. The 'Result' property of the task is true, if the request to add a participant to response request waiting list is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participant id is empty.
Remarks

Requires:

  • CanControlSpeaker should be set to true.

Events triggered once a participant is added to response request waiting list are as follows

  • ResponseRequestsListChanged

See Also

Reference

IControlSpeaker Interface


IControlSpeaker.GrantSpeechAsync Method

IControlSpeakerGrantSpeechAsync Method

Allows a participant to speak.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> GrantSpeechAsync(
    Guid participantId,
    Action<Task<bool>> onFinish = null
)
Function GrantSpeechAsync (
    participantId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ GrantSpeechAsync(
    Guid participantId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantId
Type: SystemGuid
The identification of the participant, typically being Id of DcnmParticipationInfo passed as value.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the speech grant. The 'Result' property of the task is true if the request to grant speech is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participant id is empty.
Remarks

Requires:

  • CanControlSpeaker should be set to true.

Events triggered once a participant is allowed to speak are as follows:

  • SpeakersListChanged

See Also

Reference

IControlSpeaker Interface


IControlSpeaker.RequestActualSpeakerAsync Method

IControlSpeakerRequestActualSpeakerAsync Method

Requests for the actual speaker of the active discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestActualSpeakerAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestActualSpeakerAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestActualSpeakerAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the actual speaker retrieval. The 'Result' property of the task is true, if the request actual speakers is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.RequestImportantSpeakersListAsync Method

IControlSpeakerRequestImportantSpeakersListAsync Method

Requests for the important speakers requests list of the active discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestImportantSpeakersListAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestImportantSpeakersListAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestImportantSpeakersListAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the important speakers list retrieval. The 'Result' property of the task is true, if the request to retrieve the list of important speakers is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.RequestMicrophonesActiveAsync Method

IControlSpeakerRequestMicrophonesActiveAsync Method

Request to activate the microphones for the list of participants. This request is only possible in response mode and only for speakers and/or responders.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestMicrophonesActiveAsync(
    IList<Guid> participantIds,
    Action<Task<bool>> onFinish = null
)
Function RequestMicrophonesActiveAsync (
    participantIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestMicrophonesActiveAsync(
    IList<Guid>^ participantIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantIds
Type: System.Collections.GenericIList Guid
The identification of the participants of which to activate the microphones, typically being a list of Id of DcnmParticipationInfo.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request to activate the microphones. The 'Result' property of the task holds the return value of the function. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participantIds are null or empty.
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.RequestMicrophonesInactiveAsync Method

IControlSpeakerRequestMicrophonesInactiveAsync Method

Request to deactivate the microphones for the list of participants. This request is only possible in response mode and only for speakers and/or responders.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestMicrophonesInactiveAsync(
    IList<Guid> participantIds,
    Action<Task<bool>> onFinish = null
)
Function RequestMicrophonesInactiveAsync (
    participantIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestMicrophonesInactiveAsync(
    IList<Guid>^ participantIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantIds
Type: System.Collections.GenericIList Guid
The identification of the participants of which to deactivate the microphones, typically being a list of Id of DcnmParticipationInfo.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request to deactivate the microphones. The 'Result' property of the task holds the return value of the function. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participantIds are null or empty.
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.RequestPriorityListAsync Method

IControlSpeakerRequestPriorityListAsync Method

Requests for the priority list of the active discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestPriorityListAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestPriorityListAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestPriorityListAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the priority list retrieval. The 'Result' property of the task is true, if the request to retrieve priority list is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.RequestRequestsListAsync Method

IControlSpeakerRequestRequestsListAsync Method

Requests for the request list of the active discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestRequestsListAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestRequestsListAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestRequestsListAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request list retrieval. The 'Result' property of the task is true, if the request to retrieve request list is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.RequestRespondersListAsync Method

IControlSpeakerRequestRespondersListAsync Method

Requests for the responders list of the active discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestRespondersListAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestRespondersListAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestRespondersListAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the responders list retrieval. The 'Result' property of the task is true, if the request to retrieve responders list is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.RequestResponseRequestsListAsync Method

IControlSpeakerRequestResponseRequestsListAsync Method

Requests for the response requests list of the active discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestResponseRequestsListAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestResponseRequestsListAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestResponseRequestsListAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the response requests list retrieval. The 'Result' property of the task is true, if the request to retrieve the response request list is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.RequestSpeakersListAsync Method

IControlSpeakerRequestSpeakersListAsync Method

Requests for the speakers list of the active discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestSpeakersListAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestSpeakersListAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestSpeakersListAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the speakers list retrieval. The 'Result' property of the task is true, if the request retrieve speakers list is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.SetSpeechTimeAsync Method

IControlSpeakerSetSpeechTimeAsync Method

Overload List
 | Name | Description
Public method | SetSpeechTimeAsync(Guid, Int32, DcnmDiscussionType, ActionTaskBoolean) | Sets the updated speech time for the given participant id
Public method | SetSpeechTimeAsync(Guid, Int32, DcnmDiscussionType, Boolean, ActionTaskBoolean) | Sets the updated speech time for the given participant id
Top
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.SetSpeechTimeAsync Method (Guid, Int32, DcnmDiscussionType, Action(Task(Boolean)))

IControlSpeakerSetSpeechTimeAsync Method (Guid, Int32, DcnmDiscussionType, ActionTaskBoolean)

 Bosch Logo
Sets the updated speech time for the given participant id

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetSpeechTimeAsync(
    Guid participantId,
    int speechDuration,
    DcnmDiscussionType discussionType,
    Action<Task<bool>> onFinish = null
)
Function SetSpeechTimeAsync (
    participantId As Guid,
    speechDuration As Integer,
    discussionType As DcnmDiscussionType,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetSpeechTimeAsync(
    Guid participantId,
    int speechDuration,
    DcnmDiscussionType discussionType,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantId
Type: SystemGuid
participant identication number
speechDuration
Type: SystemInt32
speech duration for the participant
discussionType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDiscussionType
discussion participant type
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the shift. The 'Result' property of the task is true, if the requset to shift participants from response requests list to response list is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If info is empty.
Remarks

Requires:

  • CanControlSpeaker should be set to true.

Events triggered once speech time for a given participant is updated, are:

  • SpeakersListChanged

See Also

Reference

IControlSpeaker Interface
SetSpeechTimeAsync Overload


IControlSpeaker.SetSpeechTimeAsync Method (Guid, Int32, DcnmDiscussionType, Boolean, Action(Task(Boolean)))

IControlSpeakerSetSpeechTimeAsync Method (Guid, Int32, DcnmDiscussionType, Boolean, ActionTaskBoolean)

 Bosch Logo
Sets the updated speech time for the given participant id

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetSpeechTimeAsync(
    Guid participantId,
    int speechDuration,
    DcnmDiscussionType discussionType,
    bool resetSpeechTime,
    Action<Task<bool>> onFinish = null
)
Function SetSpeechTimeAsync (
    participantId As Guid,
    speechDuration As Integer,
    discussionType As DcnmDiscussionType,
    resetSpeechTime As Boolean,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetSpeechTimeAsync(
    Guid participantId,
    int speechDuration,
    DcnmDiscussionType discussionType,
    bool resetSpeechTime,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantId
Type: SystemGuid
participant identication number
speechDuration
Type: SystemInt32
speech duration for the participant
discussionType
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDiscussionType
discussion participant type
resetSpeechTime
Type: SystemBoolean
flag indicating whether to reset speech time to configure value.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the shift. The 'Result' property of the task is true, if the requset to shift participants from response requests list to response list is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If info is empty.
Remarks

Requires:

  • CanControlSpeaker should be set to true.

Events triggered once speech time for a given participant is updated, are:

  • SpeakersListChanged

See Also

Reference

IControlSpeaker Interface
SetSpeechTimeAsync Overload


IControlSpeaker.ShiftFirstRequestAsync Method

IControlSpeakerShiftFirstRequestAsync Method

Rejects the oldest speaker from speaking and adds the oldest participant in the request list to the speakers list.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> ShiftFirstRequestAsync(
    Action<Task<bool>> onFinish = null
)
Function ShiftFirstRequestAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ ShiftFirstRequestAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the shift. The 'Result' property of the task is true, if the requset to shift the oldest participant in the request list is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • CanControlSpeaker

Events triggered when the first request is shifted are as follows:

  • RequestsListChanged
  • SpeakersListChanged

See Also

Reference

IControlSpeaker Interface


IControlSpeaker.ShiftFirstResponseRequestAsync Method

IControlSpeakerShiftFirstResponseRequestAsync Method

Rejects the speaker in the responders list and adds the oldest participant in the response request list to the responders list.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> ShiftFirstResponseRequestAsync(
    Action<Task<bool>> onFinish = null
)
Function ShiftFirstResponseRequestAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ ShiftFirstResponseRequestAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the shift. The 'Result' property of the task is true, if the requset to shift the oldest participant in the request list is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • CanControlSpeaker

Events triggered when the first request is shifted are as follows:

  • ResponseRequestsListChanged
  • SpeakersListChanged

See Also

Reference

IControlSpeaker Interface


IControlSpeaker.ShiftRequestsAsync Method

IControlSpeakerShiftRequestsAsync Method

Shifts the given participants to the speakers list, and removes the oldest speaker in the speakers list.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> ShiftRequestsAsync(
    IList<Guid> participantIds,
    Action<Task<bool>> onFinish = null
)
Function ShiftRequestsAsync (
    participantIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ ShiftRequestsAsync(
    IList<Guid>^ participantIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantIds
Type: System.Collections.GenericIList Guid
The identification of the participants to shift, typically being a list of Id of DcnmParticipationInfo.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the shift. The 'Result' property of the task is true, if the requset to shift participants from request list to speakers list is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participantIds is null or empty.
Remarks

Requires:

  • CanControlSpeaker

Events triggered when a request is shifted are as follows:

  • RequestsListChanged
  • SpeakersListChanged

See Also

Reference

IControlSpeaker Interface


IControlSpeaker.ShiftResponseRequestsAsync Method

IControlSpeakerShiftResponseRequestsAsync Method

Shifts the given participant(s) to the responders list, and removes the oldest speaker in the responders list..

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> ShiftResponseRequestsAsync(
    IList<Guid> participantIds,
    Action<Task<bool>> onFinish = null
)
Function ShiftResponseRequestsAsync (
    participantIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ ShiftResponseRequestsAsync(
    IList<Guid>^ participantIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantIds
Type: System.Collections.GenericIList Guid
The identification of the participants to shift, typically being a list of Id of DcnmParticipationInfo.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the shift. The 'Result' property of the task is true, if the requset to shift participants from response requests list to response list is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participantIds is null or empty.
Remarks

Events triggered are as follows:

  • ResponseRequestsListChanged
  • RespondersListChanged

See Also

Reference

IControlSpeaker Interface


IControlSpeaker Events

The IControlSpeaker type exposes the following members.

Events
 | Name | Description
Public event | ActualSpeakerChanged | Obsolete. Occurs when the actual speaker has changed.
Public event | ActualSpeakerImageChanged | Occurs when the actual speaker image changed.
Public event | ActualSpeakerVideoChanged | Occurs when the actual speaker video changed.
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | ImportantSpeakersListChanged | Occurs when the important speakers list has changed.
Public event | PriorityListChanged | Occurs when the priority list has changed
Public event | RequestsListChanged | Occurs when the requests list has changed
Public event | RespondersListChanged | Occurs when the response list has changed.
Public event | ResponseRequestsListChanged | Occurs when the response requests list has changed.
Public event | SpeakersListChanged | Occurs when the speakers list has changed
Top
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.ActualSpeakerChanged Event

IControlSpeakerActualSpeakerChanged Event

Note: This API is now obsolete.

Occurs when the actual speaker has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The ActualSpeakerChanged event handler is deprecated; please use ActualSpeakerImageChanged instead.")]
event EventHandler<ApiEventArgs<DcnmParticipantInfo>> ActualSpeakerChanged
<ObsoleteAttribute("The ActualSpeakerChanged event handler is deprecated; please use ActualSpeakerImageChanged instead.")>
Event ActualSpeakerChanged As EventHandler(Of ApiEventArgs(Of DcnmParticipantInfo))
[ObsoleteAttribute(L"The ActualSpeakerChanged event handler is deprecated; please use ActualSpeakerImageChanged instead.")]
 event EventHandler<ApiEventArgs<DcnmParticipantInfo^>^>^ ActualSpeakerChanged {
    void add (EventHandler<ApiEventArgs<DcnmParticipantInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmParticipantInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmParticipantInfo
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.ActualSpeakerImageChanged Event

IControlSpeakerActualSpeakerImageChanged Event

Occurs when the actual speaker image changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmParticipantInfo>> ActualSpeakerImageChanged
Event ActualSpeakerImageChanged As EventHandler(Of ApiEventArgs(Of DcnmParticipantInfo))
 event EventHandler<ApiEventArgs<DcnmParticipantInfo^>^>^ ActualSpeakerImageChanged {
    void add (EventHandler<ApiEventArgs<DcnmParticipantInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmParticipantInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmParticipantInfo
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.ActualSpeakerVideoChanged Event

IControlSpeakerActualSpeakerVideoChanged Event

Occurs when the actual speaker video changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmParticipantInfo>> ActualSpeakerVideoChanged
Event ActualSpeakerVideoChanged As EventHandler(Of ApiEventArgs(Of DcnmParticipantInfo))
 event EventHandler<ApiEventArgs<DcnmParticipantInfo^>^>^ ActualSpeakerVideoChanged {
    void add (EventHandler<ApiEventArgs<DcnmParticipantInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmParticipantInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmParticipantInfo
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.CapabilitiesChanged Event

IControlSpeakerCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.ImportantSpeakersListChanged Event

IControlSpeakerImportantSpeakersListChanged Event

Occurs when the important speakers list has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmSpeakerInfo>>> ImportantSpeakersListChanged
Event ImportantSpeakersListChanged As EventHandler(Of ApiEventArgs(Of IList(Of DcnmSpeakerInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmSpeakerInfo^>^>^>^ ImportantSpeakersListChanged {
    void add (EventHandler<ApiEventArgs<IList<DcnmSpeakerInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmSpeakerInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmSpeakerInfo
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.PriorityListChanged Event

IControlSpeakerPriorityListChanged Event

Occurs when the priority list has changed

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmSpeakerInfo>>> PriorityListChanged
Event PriorityListChanged As EventHandler(Of ApiEventArgs(Of IList(Of DcnmSpeakerInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmSpeakerInfo^>^>^>^ PriorityListChanged {
    void add (EventHandler<ApiEventArgs<IList<DcnmSpeakerInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmSpeakerInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmSpeakerInfo
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.RequestsListChanged Event

IControlSpeakerRequestsListChanged Event

Occurs when the requests list has changed

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmRequesterInfo>>> RequestsListChanged
Event RequestsListChanged As EventHandler(Of ApiEventArgs(Of IList(Of DcnmRequesterInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmRequesterInfo^>^>^>^ RequestsListChanged {
    void add (EventHandler<ApiEventArgs<IList<DcnmRequesterInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmRequesterInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmRequesterInfo
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.RespondersListChanged Event

IControlSpeakerRespondersListChanged Event

Occurs when the response list has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmSpeakerInfo>>> RespondersListChanged
Event RespondersListChanged As EventHandler(Of ApiEventArgs(Of IList(Of DcnmSpeakerInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmSpeakerInfo^>^>^>^ RespondersListChanged {
    void add (EventHandler<ApiEventArgs<IList<DcnmSpeakerInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmSpeakerInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmSpeakerInfo
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.ResponseRequestsListChanged Event

IControlSpeakerResponseRequestsListChanged Event

Occurs when the response requests list has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmRequesterInfo>>> ResponseRequestsListChanged
Event ResponseRequestsListChanged As EventHandler(Of ApiEventArgs(Of IList(Of DcnmRequesterInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmRequesterInfo^>^>^>^ ResponseRequestsListChanged {
    void add (EventHandler<ApiEventArgs<IList<DcnmRequesterInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmRequesterInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmRequesterInfo
See Also

Reference

IControlSpeaker Interface


IControlSpeaker.SpeakersListChanged Event

IControlSpeakerSpeakersListChanged Event

Occurs when the speakers list has changed

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmSpeakerInfo>>> SpeakersListChanged
Event SpeakersListChanged As EventHandler(Of ApiEventArgs(Of IList(Of DcnmSpeakerInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmSpeakerInfo^>^>^>^ SpeakersListChanged {
    void add (EventHandler<ApiEventArgs<IList<DcnmSpeakerInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmSpeakerInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmSpeakerInfo
See Also

Reference

IControlSpeaker Interface


IControlVoting Interface

Defines the interface for voting control.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IControlVoting : IDisposable
Public Interface IControlVoting
    Inherits IDisposable
public interface class IControlVoting : IDisposable

The IControlVoting type exposes the following members.

Properties
 | Name | Description
Public property | CanControlVoting | Indicates whether the user is able to control votings.
Top
Methods
 | Name | Description
Public method | ActivateAdHocVotingAsync | Activates an ad-hoc voting from meeting aplication
Public method | ActivateVotingAsync | Activates a voting
Public method | CloseVotingAsync | Closes the active voting
Public method | DeactivateVotingAsync | Deactivates the active voting
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | HoldVotingAsync | Holds the active voting
Public method | OpenVotingAsync | Opens the active voting
Public method | RequestVotingScriptAsync | Requests for the voting script and the current active voting of the current meeting.
Public method | RequestVotingScriptForMeetingAsync | Requests for the voting script for a meeting.
Public method | ResumeVotingAsync | Resumes the active voting
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | RemainingVotingTimeChanged | Occurs when remaining voting time changes.
Public event | VotingScriptChanged | Occurs when the voting script has changed for the current meeting.
Public event | VotingScriptForMeetingReceived | Occurs when the requested voting script for a meeting has been received.
Top
Remarks

Controlling the voting sequence can be done by using it's actual state, initially starting in state: Closed.

From state Closed:

  • Activate voting - State changes to: Ready

From state Ready:

  • Deactivate voting - State changes to: Cancelled
  • Open voting - State changes to: Opened

From state Opened:

  • Hold voting - State changes to: OnHold
  • Close voting - State changes to: Done
  • Deactivate voting - State changes to: Cancelled

From state OnHold:

  • Resume voting - State changes to: Opened
  • Close voting - State changes to: Done
  • Deactivate voting - State changes to: Cancelled

From state Done:

  • Deactivate (true) - State changes to: Accepted
  • Deactivate (false) - State changes to: Rejected
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IControlVoting Properties

The IControlVoting type exposes the following members.

Properties
 | Name | Description
Public property | CanControlVoting | Indicates whether the user is able to control votings.
Top
See Also

Reference

IControlVoting Interface


IControlVoting.CanControlVoting Property

IControlVotingCanControlVoting Property

Indicates whether the user is able to control votings.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanControlVoting { get; }
ReadOnly Property CanControlVoting As Boolean
    Get
property bool CanControlVoting {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
The user needs to be logged in for this property to be enabled. It requires:
  • Functional license: Voting preparation or Virtual license :DCNM_PBL(indicates presence of any participant based license)
  • Seat license: Voting at seat
  • Participant right: Can vote
  • Participant right: Can Manage.
See Also

Reference

IControlVoting Interface


IControlVoting Methods

The IControlVoting type exposes the following members.

Methods
 | Name | Description
Public method | ActivateAdHocVotingAsync | Activates an ad-hoc voting from meeting aplication
Public method | ActivateVotingAsync | Activates a voting
Public method | CloseVotingAsync | Closes the active voting
Public method | DeactivateVotingAsync | Deactivates the active voting
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | HoldVotingAsync | Holds the active voting
Public method | OpenVotingAsync | Opens the active voting
Public method | RequestVotingScriptAsync | Requests for the voting script and the current active voting of the current meeting.
Public method | RequestVotingScriptForMeetingAsync | Requests for the voting script for a meeting.
Public method | ResumeVotingAsync | Resumes the active voting
Top
See Also

Reference

IControlVoting Interface


IControlVoting.ActivateAdHocVotingAsync Method

IControlVotingActivateAdHocVotingAsync Method

Activates an ad-hoc voting from meeting aplication

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> ActivateAdHocVotingAsync(
    string number,
    string subject,
    string description,
    Action<Task<bool>> onFinish = null
)
Function ActivateAdHocVotingAsync (
    number As String,
    subject As String,
    description As String,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ ActivateAdHocVotingAsync(
    String^ number,
    String^ subject,
    String^ description,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

number
Type: SystemString
voting number for the ad-hoc voting. If the length is more than 50 characters, it will be truncated automatically to 50 characters.
subject
Type: SystemString
subject of the ad-hoc voting. If the length is more than 50 characters, it will be truncated automatically to 50 characters.
description
Type: SystemString
description of the ad-hoc voting. If the length is more than 255 characters, it will be truncated automatically to 255 characters.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the ad-hoc voting activation. The 'Result' property of the task is true if the request to activate an ad-hoc voting is delivered, false when the request to activate the ad-hoc voting is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
To deactivate the ad-hoc voting, use DeactivateVotingAsync(Boolean, ActionTaskBoolean)

Requires:

  • CanControlVoting

Events triggered if the request to activate an ad-hoc voting is processed successfully are as follows:

  • VotingScriptChanged

See Also

Reference

IControlVoting Interface


IControlVoting.ActivateVotingAsync Method

IControlVotingActivateVotingAsync Method

Activates a voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> ActivateVotingAsync(
    Guid votingId,
    Action<Task<bool>> onFinish = null
)
Function ActivateVotingAsync (
    votingId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ ActivateVotingAsync(
    Guid votingId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

votingId
Type: SystemGuid
The id of the voting to be activated.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the voting activation. The 'Result' property of the task is true if the request to activate a voting is delivered, false when the request to activate the voting is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If voting id is empty.
Remarks
To deactivate the voting, use DeactivateVotingAsync(Boolean, ActionTaskBoolean)

Requires:

  • CanControlVoting
  • Functional license: Voting preparation

Events triggered if the request to activate a voting is processed successfully are as follows:

  • VotingScriptChanged

See Also

Reference

IControlVoting Interface


IControlVoting.CloseVotingAsync Method

IControlVotingCloseVotingAsync Method

Closes the active voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CloseVotingAsync(
    Action<Task<bool>> onFinish = null
)
Function CloseVotingAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CloseVotingAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing closing the voting. The 'Result' property of the task is true if the request to close a voting is delivered, false when the request to close the voting is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • CanControlVoting

Events triggered if the request to close a voting is processed successfully are as follows:

  • VotingScriptChanged

See Also

Reference

IControlVoting Interface


IControlVoting.DeactivateVotingAsync Method

IControlVotingDeactivateVotingAsync Method

Deactivates the active voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeactivateVotingAsync(
    bool votingAccepted = true,
    Action<Task<bool>> onFinish = null
)
Function DeactivateVotingAsync (
    Optional votingAccepted As Boolean = true,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeactivateVotingAsync(
    bool votingAccepted = true,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

votingAccepted (Optional)
Type: SystemBoolean
Indicates if the voting is accepted or not. Only used to accept or reject the voting results.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the voting deactivation. The 'Result' property of the task is true if the request to deactivate a voting is delivered, false when the request to deactivate the voting is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

If one accepts or rejects a voting round when it is not closed, then this will be handled the same as a deactivate voting round and result in a aborted/canceled voting round

Requires:

  • CanControlVoting

Events triggered if the request to deactivate a voting is processed successfully are as follows:

  • VotingScriptChanged

See Also

Reference

IControlVoting Interface


IControlVoting.HoldVotingAsync Method

IControlVotingHoldVotingAsync Method

Holds the active voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> HoldVotingAsync(
    Action<Task<bool>> onFinish = null
)
Function HoldVotingAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ HoldVotingAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing holding the voting. The 'Result' property of the task is true if the request to hold a voting is delivered, false when the request to hold the voting is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • CanControlVoting

Events triggered if the request to hold a voting is processed successfully are as follows:

  • VotingScriptChanged

See Also

Reference

IControlVoting Interface


IControlVoting.OpenVotingAsync Method

IControlVotingOpenVotingAsync Method

Opens the active voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> OpenVotingAsync(
    Action<Task<bool>> onFinish = null
)
Function OpenVotingAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ OpenVotingAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing opening the voting. The 'Result' property of the task is true if the request to open a voting is delivered, false when the request to open the voting is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • CanControlVoting

Events triggered if the request to open a voting is processed successfully are as follows:

  • VotingScriptChanged

See Also

Reference

IControlVoting Interface


IControlVoting.RequestVotingScriptAsync Method

IControlVotingRequestVotingScriptAsync Method

Requests for the voting script and the current active voting of the current meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestVotingScriptAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestVotingScriptAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestVotingScriptAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the voting script retrieval. The 'Result' property of the task is true if the request for the voting script is delivered, false if the request is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

VotingScriptChanged is triggered if the request is processed successfully, along with the voting script.

See Also

Reference

IControlVoting Interface


IControlVoting.RequestVotingScriptForMeetingAsync Method

IControlVotingRequestVotingScriptForMeetingAsync Method

Requests for the voting script for a meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestVotingScriptForMeetingAsync(
    Guid meetingId,
    Action<Task<bool>> onFinish = null
)
Function RequestVotingScriptForMeetingAsync (
    meetingId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestVotingScriptForMeetingAsync(
    Guid meetingId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The meeting id.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the voting script retrieval. The 'Result' property of the task is true if the request to retrieve the voting script of a meeting is delivered, false if the request is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If meeting id is empty.
Remarks

VotingScriptForMeetingReceived is triggered if the request is processed successfully, along with the voting script.

See Also

Reference

IControlVoting Interface


IControlVoting.ResumeVotingAsync Method

IControlVotingResumeVotingAsync Method

Resumes the active voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> ResumeVotingAsync(
    Action<Task<bool>> onFinish = null
)
Function ResumeVotingAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ ResumeVotingAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing resuming the voting. The 'Result' property of the task is true if the request to resume a voting is delivered, false when the request to resume the voting is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • CanControlVoting

Events triggered if the request to resume a voting is processed successfully are as follows:

  • VotingScriptChanged

See Also

Reference

IControlVoting Interface


IControlVoting Events

The IControlVoting type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | RemainingVotingTimeChanged | Occurs when remaining voting time changes.
Public event | VotingScriptChanged | Occurs when the voting script has changed for the current meeting.
Public event | VotingScriptForMeetingReceived | Occurs when the requested voting script for a meeting has been received.
Top
See Also

Reference

IControlVoting Interface


IControlVoting.CapabilitiesChanged Event

IControlVotingCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IControlVoting Interface


IControlVoting.RemainingVotingTimeChanged Event

IControlVotingRemainingVotingTimeChanged Event

Occurs when remaining voting time changes.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<string>> RemainingVotingTimeChanged
Event RemainingVotingTimeChanged As EventHandler(Of ApiEventArgs(Of String))
 event EventHandler<ApiEventArgs<String^>^>^ RemainingVotingTimeChanged {
    void add (EventHandler<ApiEventArgs<String^>^>^ value);
    void remove (EventHandler<ApiEventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs String
See Also

Reference

IControlVoting Interface


IControlVoting.VotingScriptChanged Event

IControlVotingVotingScriptChanged Event

Occurs when the voting script has changed for the current meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmVotingStatusInfo>>> VotingScriptChanged
Event VotingScriptChanged As EventHandler(Of ApiEventArgs(Of IList(Of DcnmVotingStatusInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmVotingStatusInfo^>^>^>^ VotingScriptChanged {
    void add (EventHandler<ApiEventArgs<IList<DcnmVotingStatusInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmVotingStatusInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmVotingStatusInfo
See Also

Reference

IControlVoting Interface


IControlVoting.VotingScriptForMeetingReceived Event

IControlVotingVotingScriptForMeetingReceived Event

Occurs when the requested voting script for a meeting has been received.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmVotingStatusInfo>>> VotingScriptForMeetingReceived
Event VotingScriptForMeetingReceived As EventHandler(Of ApiEventArgs(Of IList(Of DcnmVotingStatusInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmVotingStatusInfo^>^>^>^ VotingScriptForMeetingReceived {
    void add (EventHandler<ApiEventArgs<IList<DcnmVotingStatusInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmVotingStatusInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmVotingStatusInfo
See Also

Reference

IControlVoting Interface


IDeviceApi Interface

Special interface providing, on top of the base functionality, the device specific functions.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IDeviceApi : IApi,
    IDisposable
Public Interface IDeviceApi
    Inherits IApi, IDisposable
public interface class IDeviceApi : IApi,
    IDisposable

The IDeviceApi type exposes the following members.

Properties
 | Name | Description
Public property | CanAuthenticate | Indicates whether it is possible to authenticate a user. (Inherited from IApi.)
Public property | CanConnectAsDevice | Indicates whether it is possible to connect as a device to the system.
Public property | CanInstallAsDevice | Indicates whether it is possible to install this connected device at a seat.
Public property | CanSelfSelect | Indicates whether it is possible to select this connected device from itself.
Public property | CanUninstallAsDevice | Indicates whether it is possible to uninstall this connected device from its seat.
Public property | CurrentApiState | Indicates the operational state of the API. (Inherited from IApi.)
Public property | CurrentApplicationState | Indicates the application state of the device.
Public property | CurrentDeviceConnectionState | Indicates the device connection state of the API.
Public property | DicentisCapabilities | Returns collection of Dicentis Capabilities. (Inherited from IApi.)
Public property | DicentisVersion | Version of Dicentis system to which API is connected. (Inherited from IApi.)
Public property | IdentificationMethod | Gets identificaion type for meeting.
Public property | IsEnabledAsDevice | Indicates whether the device is enabled.
Public property | IsOpen | Indicates whether the API is opened for use. (Inherited from IApi.)
Public property | IsUserLoggedOn | Indicates whether a user is currently logged on to the system. (Inherited from IApi.)
Public property | LoggedOnUserId | User id of the logged in user. (Inherited from IApi.)
Public property | UserAccessMethod | Obsolete. Indicates the way needed for gaining access to the system (through the device).
Public property | UserIdentifiedAtDevice | Gets the identification of the user access/using this device.
Public property | VerificationMethod | Gets verification type for the meeting.
Public property | VersionMismatchError | Indicates if there has been a version mismatch between the API and the system. (Inherited from IApi.)
Top
Methods
 | Name | Description
Public method | AuthenticateUserAsync | Logs on a user in the system using username/password combination. (Inherited from IApi.)
Public method | AuthenticateWindowsSystemUserAsync | Obsolete. This method is deprecated and no longer supported. Windows System user authentication through this API is no longer available, and usage should be discontinued. (Inherited from IApi.)
Public method | CloseAsync | Closes the API for use. (Inherited from IApi.)
Public method | ConnectAsDeviceAsync(String, ActionTaskBoolean) | Obsolete. Connects the calling application as a device to the system.
Public method | ConnectAsDeviceAsync(String, CollectionString, ActionTaskBoolean) | Connects the calling application as a device to the system.
Public method | DisconnectAsDeviceAsync | Disconnects the calling application as a device to the system.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ExecuteActionCommandAsync | Executes an the action command in the system.
Public method | InstallAsync | Installs this device in the system at a new seat. After being installed at a seat, the device will be enabled for use in the system.
Public method | InstallAtSeatAsync | Installs this device in the system at the identified seat. After being installed at a seat, the device will be enabled for use in the system.
Public method | InstallAtSeatByNumberAsync | Installs a device at a seat resolved by area and seat name.
Public method | OpenAsync(ActionTaskBoolean) | Opens the API for use. (Inherited from IApi.)
Public method | OpenAsync(String, ActionTaskBoolean) | Opens the API for use. (Inherited from IApi.)
Public method | RevokeUserAsync | Logs off the current user in the system. (Inherited from IApi.)
Public method | SelectAsync | Selects the device.
Public method | SetCallbackContext | Define thread for executing API events (Inherited from IApi.)
Public method | SetTaskCompletionContext | Set thread for task completions (Inherited from IApi.)
Public method | UninstallAsync | Uninstalls this device from its seat. After being uninstalled from its seat, the device will be disabled for use in the system.
Top
Events
 | Name | Description
Public event | ActionCommandReceived | Indicates an action command was received.
Public event | ApiStateChanged | Occurs when the operational state of the API has changed. (Inherited from IApi.)
Public event | ApplicationModeStateChanged | Occurs when the installation mode state of the connected device changes.
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change. (Inherited from IApi.)
Public event | ConnectionStateChanged | Occurs when the connection state transits to or from Connected. true if connected, false if not connected (anymore).
Public event | DescriptionChanged | Occurs when the description of the connected devices changes.
Public event | DeviceApiConnectionStateChanged | Occurs when the connection state as device changes
Public event | EnabledStateChanged | Occurs when the enabled/disables state of the connected device changes.
Public event | OpenStateChanged | Occurs when the operational state of the API transits to or from Online. true if online, false if no longer online. (Inherited from IApi.)
Public event | SelectedStateChanged | Occurs when the selected state of the connected devices changes.
Public event | UserIdentified | Indicates a user is identified accessing/using the device.
Public event | VersionMismatchErrorDetected | Occurs when a version mismatch error was detected between API and the system. (Inherited from IApi.)
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IDeviceApi Properties

The IDeviceApi type exposes the following members.

Properties
 | Name | Description
Public property | CanAuthenticate | Indicates whether it is possible to authenticate a user. (Inherited from IApi.)
Public property | CanConnectAsDevice | Indicates whether it is possible to connect as a device to the system.
Public property | CanInstallAsDevice | Indicates whether it is possible to install this connected device at a seat.
Public property | CanSelfSelect | Indicates whether it is possible to select this connected device from itself.
Public property | CanUninstallAsDevice | Indicates whether it is possible to uninstall this connected device from its seat.
Public property | CurrentApiState | Indicates the operational state of the API. (Inherited from IApi.)
Public property | CurrentApplicationState | Indicates the application state of the device.
Public property | CurrentDeviceConnectionState | Indicates the device connection state of the API.
Public property | DicentisCapabilities | Returns collection of Dicentis Capabilities. (Inherited from IApi.)
Public property | DicentisVersion | Version of Dicentis system to which API is connected. (Inherited from IApi.)
Public property | IdentificationMethod | Gets identificaion type for meeting.
Public property | IsEnabledAsDevice | Indicates whether the device is enabled.
Public property | IsOpen | Indicates whether the API is opened for use. (Inherited from IApi.)
Public property | IsUserLoggedOn | Indicates whether a user is currently logged on to the system. (Inherited from IApi.)
Public property | LoggedOnUserId | User id of the logged in user. (Inherited from IApi.)
Public property | UserAccessMethod | Obsolete. Indicates the way needed for gaining access to the system (through the device).
Public property | UserIdentifiedAtDevice | Gets the identification of the user access/using this device.
Public property | VerificationMethod | Gets verification type for the meeting.
Public property | VersionMismatchError | Indicates if there has been a version mismatch between the API and the system. (Inherited from IApi.)
Top
See Also

Reference

IDeviceApi Interface


IDeviceApi.CanConnectAsDevice Property

IDeviceApiCanConnectAsDevice Property

Indicates whether it is possible to connect as a device to the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanConnectAsDevice { get; }
ReadOnly Property CanConnectAsDevice As Boolean
    Get
property bool CanConnectAsDevice {
    bool get ();
}

Property Value

Type: Boolean
true if connection as device is possible, false otherwise.
See Also

Reference

IDeviceApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IDeviceApiConnectAsDeviceAsync(String, CollectionString, ActionTaskBoolean)
IDeviceApiDisconnectAsDeviceAsync(ActionTask)


IDeviceApi.CanInstallAsDevice Property

IDeviceApiCanInstallAsDevice Property

Indicates whether it is possible to install this connected device at a seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanInstallAsDevice { get; }
ReadOnly Property CanInstallAsDevice As Boolean
    Get
property bool CanInstallAsDevice {
    bool get ();
}

Property Value

Type: Boolean
true if installation of the connected device is possible, false otherwise.
See Also

Reference

IDeviceApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IDeviceApiInstallAsync(ActionTaskBoolean)


IDeviceApi.CanSelfSelect Property

IDeviceApiCanSelfSelect Property

Indicates whether it is possible to select this connected device from itself.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanSelfSelect { get; }
ReadOnly Property CanSelfSelect As Boolean
    Get
property bool CanSelfSelect {
    bool get ();
}

Property Value

Type: Boolean
true if selection of the connected device is possible, false otherwise.
See Also

Reference

IDeviceApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IDeviceApiSelectAsync(ActionTaskBoolean)


IDeviceApi.CanUninstallAsDevice Property

IDeviceApiCanUninstallAsDevice Property

Indicates whether it is possible to uninstall this connected device from its seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanUninstallAsDevice { get; }
ReadOnly Property CanUninstallAsDevice As Boolean
    Get
property bool CanUninstallAsDevice {
    bool get ();
}

Property Value

Type: Boolean
true if uninstallation of the connected device is possible, false otherwise.
See Also

Reference

IDeviceApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IDeviceApiUninstallAsync(ActionTaskBoolean)


IDeviceApi.CurrentApplicationState Property

IDeviceApiCurrentApplicationState Property

Indicates the application state of the device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
DcnmApplicationState CurrentApplicationState { get; }
ReadOnly Property CurrentApplicationState As DcnmApplicationState
    Get
property DcnmApplicationState CurrentApplicationState {
    DcnmApplicationState get ();
}

Property Value

Type: DcnmApplicationState
ConferenceMode if application is in conference mode, InstallMode if application is in install mode, WaitForMode otherwise.
See Also

Reference

IDeviceApi Interface


IDeviceApi.CurrentDeviceConnectionState Property

IDeviceApiCurrentDeviceConnectionState Property

Indicates the device connection state of the API.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
DcnmDeviceConnectionState CurrentDeviceConnectionState { get; }
ReadOnly Property CurrentDeviceConnectionState As DcnmDeviceConnectionState
    Get
property DcnmDeviceConnectionState CurrentDeviceConnectionState {
    DcnmDeviceConnectionState get ();
}

Property Value

Type: DcnmDeviceConnectionState
See Also

Reference

IDeviceApi Interface


IDeviceApi.IdentificationMethod Property

IDeviceApiIdentificationMethod Property

Gets identificaion type for meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
DcnmIdentificationMethod IdentificationMethod { get; }
ReadOnly Property IdentificationMethod As DcnmIdentificationMethod
    Get
property DcnmIdentificationMethod IdentificationMethod {
    DcnmIdentificationMethod get ();
}

Property Value

Type: DcnmIdentificationMethod
See Also

Reference

IDeviceApi Interface


IDeviceApi.IsEnabledAsDevice Property

IDeviceApiIsEnabledAsDevice Property

Indicates whether the device is enabled.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsEnabledAsDevice { get; }
ReadOnly Property IsEnabledAsDevice As Boolean
    Get
property bool IsEnabledAsDevice {
    bool get ();
}

Property Value

Type: Boolean
true if device is enabled, false otherwise.
See Also

Reference

IDeviceApi Interface


IDeviceApi.UserAccessMethod Property

IDeviceApiUserAccessMethod Property

Note: This API is now obsolete.

Indicates the way needed for gaining access to the system (through the device).

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This property is Obsolete, use the IdentificationMethod and VerificationMethod  property")]
DcnmAccessMethod UserAccessMethod { get; }
<ObsoleteAttribute("This property is Obsolete, use the IdentificationMethod and VerificationMethod  property")>
ReadOnly Property UserAccessMethod As DcnmAccessMethod
    Get
[ObsoleteAttribute(L"This property is Obsolete, use the IdentificationMethod and VerificationMethod  property")]
property DcnmAccessMethod UserAccessMethod {
    DcnmAccessMethod get ();
}

Property Value

Type: DcnmAccessMethod
See Also

Reference

IDeviceApi Interface


IDeviceApi.UserIdentifiedAtDevice Property

IDeviceApiUserIdentifiedAtDevice Property

Gets the identification of the user access/using this device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
DcnmUserInfo UserIdentifiedAtDevice { get; }
ReadOnly Property UserIdentifiedAtDevice As DcnmUserInfo
    Get
property DcnmUserInfo^ UserIdentifiedAtDevice {
    DcnmUserInfo^ get ();
}

Property Value

Type: DcnmUserInfo
See Also

Reference

IDeviceApi Interface


IDeviceApi.VerificationMethod Property

IDeviceApiVerificationMethod Property

Gets verification type for the meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
DcnmVerificationMethod VerificationMethod { get; }
ReadOnly Property VerificationMethod As DcnmVerificationMethod
    Get
property DcnmVerificationMethod VerificationMethod {
    DcnmVerificationMethod get ();
}

Property Value

Type: DcnmVerificationMethod
See Also

Reference

IDeviceApi Interface


IDeviceApi Methods

The IDeviceApi type exposes the following members.

Methods
 | Name | Description
Public method | AuthenticateUserAsync | Logs on a user in the system using username/password combination. (Inherited from IApi.)
Public method | AuthenticateWindowsSystemUserAsync | Obsolete. This method is deprecated and no longer supported. Windows System user authentication through this API is no longer available, and usage should be discontinued. (Inherited from IApi.)
Public method | CloseAsync | Closes the API for use. (Inherited from IApi.)
Public method | ConnectAsDeviceAsync(String, ActionTaskBoolean) | Obsolete. Connects the calling application as a device to the system.
Public method | ConnectAsDeviceAsync(String, CollectionString, ActionTaskBoolean) | Connects the calling application as a device to the system.
Public method | DisconnectAsDeviceAsync | Disconnects the calling application as a device to the system.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ExecuteActionCommandAsync | Executes an the action command in the system.
Public method | InstallAsync | Installs this device in the system at a new seat. After being installed at a seat, the device will be enabled for use in the system.
Public method | InstallAtSeatAsync | Installs this device in the system at the identified seat. After being installed at a seat, the device will be enabled for use in the system.
Public method | InstallAtSeatByNumberAsync | Installs a device at a seat resolved by area and seat name.
Public method | OpenAsync(ActionTaskBoolean) | Opens the API for use. (Inherited from IApi.)
Public method | OpenAsync(String, ActionTaskBoolean) | Opens the API for use. (Inherited from IApi.)
Public method | RevokeUserAsync | Logs off the current user in the system. (Inherited from IApi.)
Public method | SelectAsync | Selects the device.
Public method | SetCallbackContext | Define thread for executing API events (Inherited from IApi.)
Public method | SetTaskCompletionContext | Set thread for task completions (Inherited from IApi.)
Public method | UninstallAsync | Uninstalls this device from its seat. After being uninstalled from its seat, the device will be disabled for use in the system.
Top
See Also

Reference

IDeviceApi Interface


IDeviceApi.ConnectAsDeviceAsync Method

IDeviceApiConnectAsDeviceAsync Method

Overload List
 | Name | Description
Public method | ConnectAsDeviceAsync(String, ActionTaskBoolean) | Obsolete. Connects the calling application as a device to the system.
Public method | ConnectAsDeviceAsync(String, CollectionString, ActionTaskBoolean) | Connects the calling application as a device to the system.
Top
See Also

Reference

IDeviceApi Interface


IDeviceApi.ConnectAsDeviceAsync Method (String, Action(Task(Boolean)))

IDeviceApiConnectAsDeviceAsync Method (String, ActionTaskBoolean)

 Bosch Logo

Note: This API is now obsolete.

Connects the calling application as a device to the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("This method is obsolete, use the ConnectAsDeviceAsync method with deviceAttributes argument")]
Task<bool> ConnectAsDeviceAsync(
    string uniqueId,
    Action<Task<bool>> onFinish = null
)
<ObsoleteAttribute("This method is obsolete, use the ConnectAsDeviceAsync method with deviceAttributes argument")>
Function ConnectAsDeviceAsync (
    uniqueId As String,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
[ObsoleteAttribute(L"This method is obsolete, use the ConnectAsDeviceAsync method with deviceAttributes argument")]
Task<bool>^ ConnectAsDeviceAsync(
    String^ uniqueId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

uniqueId
Type: SystemString
The system-wide unique name of the calling application.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the device connect. The 'Result' property of the task is true if connect as device succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If unique id is null or empty.
Remarks
To be able to connect the calling application as a device following conditions have to be met.
  • IsOpen should be set to true.
  • CanConnectAsDevice should be set to true.
  • DcnmDeviceConnectionState should be in Disconnected state.
If a calling application has been connected successfully as a device, then following events will be triggered.
  • ConnectionStateChanged
  • DeviceApiConnectionStateChanged
  • EnabledStateChanged
  • SelectedStateChanged
  • DescriptionChanged
  • ApplicationModeStateChanged
See Also

Reference

IDeviceApi Interface
ConnectAsDeviceAsync Overload


IDeviceApi.ConnectAsDeviceAsync Method (String, Collection(String), Action(Task(Boolean)))

IDeviceApiConnectAsDeviceAsync Method (String, CollectionString, ActionTaskBoolean)

 Bosch Logo
Connects the calling application as a device to the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> ConnectAsDeviceAsync(
    string uniqueId,
    Collection<string> deviceAttributes,
    Action<Task<bool>> onFinish = null
)
Function ConnectAsDeviceAsync (
    uniqueId As String,
    deviceAttributes As Collection(Of String),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ ConnectAsDeviceAsync(
    String^ uniqueId,
    Collection<String^>^ deviceAttributes,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

uniqueId
Type: SystemString
The system-wide unique name of the calling application.
deviceAttributes
Type: System.Collections.ObjectModelCollection String
Attributes representing properties of device.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the device connect. The 'Result' property of the task is true if connect as device succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If unique id is null or empty.
Remarks
To be able to connect the calling application as a device following conditions have to be met.
  • IsOpen should be set to true.
  • CanConnectAsDevice should be set to true.
  • DcnmDeviceConnectionState should be in Disconnected state.
If a calling application has been connected successfully as a device, then following events will be triggered.
  • ConnectionStateChanged
  • DeviceApiConnectionStateChanged
  • EnabledStateChanged
  • SelectedStateChanged
  • DescriptionChanged
  • ApplicationModeStateChanged
See Also

Reference

IDeviceApi Interface
ConnectAsDeviceAsync Overload
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch.Dcnm.Interfaces.Api.InterfacesDeviceAttributes


IDeviceApi.DisconnectAsDeviceAsync Method

IDeviceApiDisconnectAsDeviceAsync Method

Disconnects the calling application as a device to the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task DisconnectAsDeviceAsync(
    Action<Task> onFinish = null
)
Function DisconnectAsDeviceAsync (
    Optional onFinish As Action(Of Task) = Nothing
) As Task
Task^ DisconnectAsDeviceAsync(
    Action<Task^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task
Optional action for asynchronous handling of the result.

Return Value

Type: Task
Task processing the device disconnect. The 'Result' property of the task is true if disconnect as device succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
To be able to disconect a device the DcnmApiState should be either Opening or Online.
See Also

Reference

IDeviceApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IDeviceApiCanConnectAsDevice
IDeviceApiConnectionStateChanged
IDeviceApiDeviceApiConnectionStateChanged
IDeviceApiEnabledStateChanged
IDeviceApiSelectedStateChanged
IDeviceApiDescriptionChanged
IDeviceApiApplicationModeStateChanged


IDeviceApi.ExecuteActionCommandAsync Method

IDeviceApiExecuteActionCommandAsync Method

Executes an the action command in the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> ExecuteActionCommandAsync(
    DcnmActionCommand action,
    Action<Task<bool>> onFinish = null
)
Function ExecuteActionCommandAsync (
    action As DcnmActionCommand,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ ExecuteActionCommandAsync(
    DcnmActionCommand^ action,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

action
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmActionCommand
The action to execute.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the action execution request. The 'Result' property of the task is true if request succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IDeviceApi Interface


IDeviceApi.InstallAsync Method

IDeviceApiInstallAsync Method

Installs this device in the system at a new seat. After being installed at a seat, the device will be enabled for use in the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> InstallAsync(
    Action<Task<bool>> onFinish = null
)
Function InstallAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ InstallAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the device installation. The 'Result' property of the task is true if install succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
To be able to install a device, CanInstallAsDevice should be true.
See Also

Reference

IDeviceApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IDeviceApiCanInstallAsDevice


IDeviceApi.InstallAtSeatAsync Method

IDeviceApiInstallAtSeatAsync Method

Installs this device in the system at the identified seat. After being installed at a seat, the device will be enabled for use in the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> InstallAtSeatAsync(
    Guid seatId,
    Action<Task<bool>> onFinish = null
)
Function InstallAtSeatAsync (
    seatId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ InstallAtSeatAsync(
    Guid seatId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

seatId
Type: SystemGuid
The identifier of the seat to install the device at.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the device installation. The 'Result' property of the task is true if install at seat succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If seat id is empty.
Remarks
To be able to install a device, CanInstallAsDevice should be true..
See Also

Reference

IDeviceApi Interface


IDeviceApi.InstallAtSeatByNumberAsync Method

IDeviceApiInstallAtSeatByNumberAsync Method

Installs a device at a seat resolved by area and seat name.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> InstallAtSeatByNumberAsync(
    int areaNumber,
    int seatNumber,
    Action<Task<bool>> onFinish = null
)
Function InstallAtSeatByNumberAsync (
    areaNumber As Integer,
    seatNumber As Integer,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ InstallAtSeatByNumberAsync(
    int areaNumber,
    int seatNumber,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

areaNumber
Type: SystemInt32
The number of the area.
seatNumber
Type: SystemInt32
The number of the seat.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the device installation. The 'Result' property of the task is true if install at seat succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If seat id is empty.
Remarks
To be able to install a device, CanInstallAsDevice should be true..
See Also

Reference

IDeviceApi Interface


IDeviceApi.SelectAsync Method

IDeviceApiSelectAsync Method

Selects the device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SelectAsync(
    Action<Task<bool>> onFinish = null
)
Function SelectAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SelectAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the device selection. The 'Result' property of the task is true if select succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
To be able to install a device, CanSelfSelect should be true.
See Also

Reference

IDeviceApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IDeviceApiCanSelfSelect


IDeviceApi.UninstallAsync Method

IDeviceApiUninstallAsync Method

Uninstalls this device from its seat. After being uninstalled from its seat, the device will be disabled for use in the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UninstallAsync(
    Action<Task<bool>> onFinish = null
)
Function UninstallAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UninstallAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the device uninstallation. The 'Result' property of the task is true if uninstall succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
To be able to install a device, CanUninstallAsDevice should be true.
See Also

Reference

IDeviceApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IDeviceApiCanUninstallAsDevice


IDeviceApi Events

The IDeviceApi type exposes the following members.

Events
 | Name | Description
Public event | ActionCommandReceived | Indicates an action command was received.
Public event | ApiStateChanged | Occurs when the operational state of the API has changed. (Inherited from IApi.)
Public event | ApplicationModeStateChanged | Occurs when the installation mode state of the connected device changes.
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change. (Inherited from IApi.)
Public event | ConnectionStateChanged | Occurs when the connection state transits to or from Connected. true if connected, false if not connected (anymore).
Public event | DescriptionChanged | Occurs when the description of the connected devices changes.
Public event | DeviceApiConnectionStateChanged | Occurs when the connection state as device changes
Public event | EnabledStateChanged | Occurs when the enabled/disables state of the connected device changes.
Public event | OpenStateChanged | Occurs when the operational state of the API transits to or from Online. true if online, false if no longer online. (Inherited from IApi.)
Public event | SelectedStateChanged | Occurs when the selected state of the connected devices changes.
Public event | UserIdentified | Indicates a user is identified accessing/using the device.
Public event | VersionMismatchErrorDetected | Occurs when a version mismatch error was detected between API and the system. (Inherited from IApi.)
Top
See Also

Reference

IDeviceApi Interface


IDeviceApi.ActionCommandReceived Event

IDeviceApiActionCommandReceived Event

Indicates an action command was received.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmActionCommand>> ActionCommandReceived
Event ActionCommandReceived As EventHandler(Of ApiEventArgs(Of DcnmActionCommand))
 event EventHandler<ApiEventArgs<DcnmActionCommand^>^>^ ActionCommandReceived {
    void add (EventHandler<ApiEventArgs<DcnmActionCommand^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmActionCommand^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmActionCommand
See Also

Reference

IDeviceApi Interface


IDeviceApi.ApplicationModeStateChanged Event

IDeviceApiApplicationModeStateChanged Event

Occurs when the installation mode state of the connected device changes.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmApplicationState>> ApplicationModeStateChanged
Event ApplicationModeStateChanged As EventHandler(Of ApiEventArgs(Of DcnmApplicationState))
 event EventHandler<ApiEventArgs<DcnmApplicationState>^>^ ApplicationModeStateChanged {
    void add (EventHandler<ApiEventArgs<DcnmApplicationState>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmApplicationState>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmApplicationState
See Also

Reference

IDeviceApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IDeviceApiConnectAsDeviceAsync(String, CollectionString, ActionTaskBoolean)
IDeviceApiDisconnectAsDeviceAsync(ActionTask)


IDeviceApi.ConnectionStateChanged Event

IDeviceApiConnectionStateChanged Event

Occurs when the connection state transits to or from Connected. true if connected, false if not connected (anymore).

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<bool>> ConnectionStateChanged
Event ConnectionStateChanged As EventHandler(Of ApiEventArgs(Of Boolean))
 event EventHandler<ApiEventArgs<bool>^>^ ConnectionStateChanged {
    void add (EventHandler<ApiEventArgs<bool>^>^ value);
    void remove (EventHandler<ApiEventArgs<bool>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Boolean
See Also

Reference

IDeviceApi Interface


IDeviceApi.DescriptionChanged Event

IDeviceApiDescriptionChanged Event

Occurs when the description of the connected devices changes.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<string>> DescriptionChanged
Event DescriptionChanged As EventHandler(Of ApiEventArgs(Of String))
 event EventHandler<ApiEventArgs<String^>^>^ DescriptionChanged {
    void add (EventHandler<ApiEventArgs<String^>^>^ value);
    void remove (EventHandler<ApiEventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs String
See Also

Reference

IDeviceApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IDeviceApiConnectAsDeviceAsync(String, CollectionString, ActionTaskBoolean)
IDeviceApiDisconnectAsDeviceAsync(ActionTask)


IDeviceApi.DeviceApiConnectionStateChanged Event

IDeviceApiDeviceApiConnectionStateChanged Event

Occurs when the connection state as device changes

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmDeviceConnectionState>> DeviceApiConnectionStateChanged
Event DeviceApiConnectionStateChanged As EventHandler(Of ApiEventArgs(Of DcnmDeviceConnectionState))
 event EventHandler<ApiEventArgs<DcnmDeviceConnectionState>^>^ DeviceApiConnectionStateChanged {
    void add (EventHandler<ApiEventArgs<DcnmDeviceConnectionState>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmDeviceConnectionState>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmDeviceConnectionState
See Also

Reference

IDeviceApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IDeviceApiConnectAsDeviceAsync(String, CollectionString, ActionTaskBoolean)
IDeviceApiDisconnectAsDeviceAsync(ActionTask)


IDeviceApi.EnabledStateChanged Event

IDeviceApiEnabledStateChanged Event

Occurs when the enabled/disables state of the connected device changes.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<bool>> EnabledStateChanged
Event EnabledStateChanged As EventHandler(Of ApiEventArgs(Of Boolean))
 event EventHandler<ApiEventArgs<bool>^>^ EnabledStateChanged {
    void add (EventHandler<ApiEventArgs<bool>^>^ value);
    void remove (EventHandler<ApiEventArgs<bool>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Boolean
See Also

Reference

IDeviceApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IDeviceApiConnectAsDeviceAsync(String, CollectionString, ActionTaskBoolean)
IDeviceApiDisconnectAsDeviceAsync(ActionTask)


IDeviceApi.SelectedStateChanged Event

IDeviceApiSelectedStateChanged Event

Occurs when the selected state of the connected devices changes.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<bool>> SelectedStateChanged
Event SelectedStateChanged As EventHandler(Of ApiEventArgs(Of Boolean))
 event EventHandler<ApiEventArgs<bool>^>^ SelectedStateChanged {
    void add (EventHandler<ApiEventArgs<bool>^>^ value);
    void remove (EventHandler<ApiEventArgs<bool>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Boolean
See Also

Reference

IDeviceApi Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
IDeviceApiConnectAsDeviceAsync(String, CollectionString, ActionTaskBoolean)
IDeviceApiDisconnectAsDeviceAsync(ActionTask)


IDeviceApi.UserIdentified Event

IDeviceApiUserIdentified Event

Indicates a user is identified accessing/using the device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<bool>> UserIdentified
Event UserIdentified As EventHandler(Of ApiEventArgs(Of Boolean))
 event EventHandler<ApiEventArgs<bool>^>^ UserIdentified {
    void add (EventHandler<ApiEventArgs<bool>^>^ value);
    void remove (EventHandler<ApiEventArgs<bool>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Boolean
See Also

Reference

IDeviceApi Interface


IEquipment Interface

Represents an interface to retrieve info about equipment in the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IEquipment : IDisposable
Public Interface IEquipment
    Inherits IDisposable
public interface class IEquipment : IDisposable

The IEquipment type exposes the following members.

Properties
 | Name | Description
Public property | CanConfigureSystem | Indicates whether it is possible to configure in the system.
Public property | CanDiagnoseDevices | Indicates whether it is possible to diagnose devices in the system.
Public property | CanPowerOffEquipment | Indicates whether it is possible to power off devices in the system.
Public property | CanPowerOnEquipment | Indicates whether it is possible to power on devices in the system.
Public property | EquipmentPowerState | Indicates the equipment power state.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetDeviceFlushPanelsAsync | Gets the flush panels connected to the given set of devices..
Public method | GetDevicesAsync | Gets the devices connected to the system.
Public method | PowerOffEquipmentAsync | Powers off the equipment.
Public method | PowerOnEquipmentAsync | Powers on the equipment.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | EquipmentOperationalStateChanged | Occurs when the operational state of the equipment has changed.
Public event | EquipmentPowerStateChanged | Occurs when the power state of the equipment has changed.
Top
Remarks

Equipment in the system represents the devices in the system. An equipment is identified by means of its Id in the DcnmDeviceInfo class. Special attention has to be made for devices having the Dual-Use license assigned:

  • The device represents itself as two equipments, each having its DcnmDeviceInfo class.
  • both equiment of the same device have equal SerialNumber, TypeOf, Version and Name
  • Distinqtion regarding the different sub-devices can be identified by the SubDeviceInstance property.

Before use of a equiment, you must check the DeviceState property whether the device is Operational. Using a equipment not being Operational may result in exceptions on the interface calls. (applicable for all functions where a equiment Identification is required.)

See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IEquipment Properties

The IEquipment type exposes the following members.

Properties
 | Name | Description
Public property | CanConfigureSystem | Indicates whether it is possible to configure in the system.
Public property | CanDiagnoseDevices | Indicates whether it is possible to diagnose devices in the system.
Public property | CanPowerOffEquipment | Indicates whether it is possible to power off devices in the system.
Public property | CanPowerOnEquipment | Indicates whether it is possible to power on devices in the system.
Public property | EquipmentPowerState | Indicates the equipment power state.
Top
See Also

Reference

IEquipment Interface


IEquipment.CanConfigureSystem Property

IEquipmentCanConfigureSystem Property

Indicates whether it is possible to configure in the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanConfigureSystem { get; }
ReadOnly Property CanConfigureSystem As Boolean
    Get
property bool CanConfigureSystem {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • User right: Configure System.
See Also

Reference

IEquipment Interface


IEquipment.CanDiagnoseDevices Property

IEquipmentCanDiagnoseDevices Property

Indicates whether it is possible to diagnose devices in the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanDiagnoseDevices { get; }
ReadOnly Property CanDiagnoseDevices As Boolean
    Get
property bool CanDiagnoseDevices {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IEquipment Interface


IEquipment.CanPowerOffEquipment Property

IEquipmentCanPowerOffEquipment Property

Indicates whether it is possible to power off devices in the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanPowerOffEquipment { get; }
ReadOnly Property CanPowerOffEquipment As Boolean
    Get
property bool CanPowerOffEquipment {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Device has capability: Power Off.
See Also

Reference

IEquipment Interface


IEquipment.CanPowerOnEquipment Property

IEquipmentCanPowerOnEquipment Property

Indicates whether it is possible to power on devices in the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanPowerOnEquipment { get; }
ReadOnly Property CanPowerOnEquipment As Boolean
    Get
property bool CanPowerOnEquipment {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Device has capability: Power On.
See Also

Reference

IEquipment Interface


IEquipment.EquipmentPowerState Property

IEquipmentEquipmentPowerState Property

Indicates the equipment power state.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
DcnmPowerState EquipmentPowerState { get; }
ReadOnly Property EquipmentPowerState As DcnmPowerState
    Get
property DcnmPowerState EquipmentPowerState {
    DcnmPowerState get ();
}

Return Value

Type: DcnmPowerState
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IEquipment Interface


IEquipment Methods

The IEquipment type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetDeviceFlushPanelsAsync | Gets the flush panels connected to the given set of devices..
Public method | GetDevicesAsync | Gets the devices connected to the system.
Public method | PowerOffEquipmentAsync | Powers off the equipment.
Public method | PowerOnEquipmentAsync | Powers on the equipment.
Top
See Also

Reference

IEquipment Interface


IEquipment.GetDeviceFlushPanelsAsync Method

IEquipmentGetDeviceFlushPanelsAsync Method

Gets the flush panels connected to the given set of devices..

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmFlushDevicePanelInfo>> GetDeviceFlushPanelsAsync(
    IList<Guid> deviceIds,
    Action<Task<IList<DcnmFlushDevicePanelInfo>>> onFinish = null
)
Function GetDeviceFlushPanelsAsync (
    deviceIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of IList(Of DcnmFlushDevicePanelInfo))) = Nothing
) As Task(Of IList(Of DcnmFlushDevicePanelInfo))
Task<IList<DcnmFlushDevicePanelInfo^>^>^ GetDeviceFlushPanelsAsync(
    IList<Guid>^ deviceIds,
    Action<Task<IList<DcnmFlushDevicePanelInfo^>^>^>^ onFinish = nullptr
)

Parameters

deviceIds
Type: System.Collections.GenericIList Guid
The flush devices to retrieve the connected flush panels for.
onFinish (Optional)
Type: SystemAction Task IList DcnmFlushDevicePanelInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmFlushDevicePanelInfo
Task processing the device flush panels retrieval . The 'Result' property of the task holds the list of retrieved panels per requested device. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IEquipment Interface


IEquipment.GetDevicesAsync Method

IEquipmentGetDevicesAsync Method

Gets the devices connected to the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmDeviceInfo>> GetDevicesAsync(
    Action<Task<IList<DcnmDeviceInfo>>> onFinish = null
)
Function GetDevicesAsync (
    Optional onFinish As Action(Of Task(Of IList(Of DcnmDeviceInfo))) = Nothing
) As Task(Of IList(Of DcnmDeviceInfo))
Task<IList<DcnmDeviceInfo^>^>^ GetDevicesAsync(
    Action<Task<IList<DcnmDeviceInfo^>^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task IList DcnmDeviceInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmDeviceInfo
Task processing the device retrieval . The 'Result' property of the task holds the list of retrieved devices. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IEquipment Interface


IEquipment.PowerOffEquipmentAsync Method

IEquipmentPowerOffEquipmentAsync Method

Powers off the equipment.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> PowerOffEquipmentAsync(
    Action<Task<bool>> onFinish = null
)
Function PowerOffEquipmentAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ PowerOffEquipmentAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the power off. The 'Result' property of the task is true, if the request to power off an equipment is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

To be able to power on a device CanPowerOffEquipment should be true.

Events triggered and Properties modified once the device is powered on are as follows

Events triggered:

  • EquipmentPowerStateChanged

Properties modified:

  • EquipmentPowerState

See Also

Reference

IEquipment Interface


IEquipment.PowerOnEquipmentAsync Method

IEquipmentPowerOnEquipmentAsync Method

Powers on the equipment.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> PowerOnEquipmentAsync(
    Action<Task<bool>> onFinish = null
)
Function PowerOnEquipmentAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ PowerOnEquipmentAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the power on. The 'Result' property of the task is true, if the request to power on an equipment is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

To be able to power on a device CanPowerOnEquipment should be true.

Events triggered and Properties modified once the device is powered on are as follows

Events triggered:

  • EquipmentPowerStateChanged

Properties modified:

  • EquipmentPowerState

See Also

Reference

IEquipment Interface


IEquipment Events

The IEquipment type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | EquipmentOperationalStateChanged | Occurs when the operational state of the equipment has changed.
Public event | EquipmentPowerStateChanged | Occurs when the power state of the equipment has changed.
Top
See Also

Reference

IEquipment Interface


IEquipment.CapabilitiesChanged Event

IEquipmentCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IEquipment Interface


IEquipment.EquipmentOperationalStateChanged Event

IEquipmentEquipmentOperationalStateChanged Event

Occurs when the operational state of the equipment has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmDeviceInfo>>> EquipmentOperationalStateChanged
Event EquipmentOperationalStateChanged As EventHandler(Of ApiEventArgs(Of IList(Of DcnmDeviceInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmDeviceInfo^>^>^>^ EquipmentOperationalStateChanged {
    void add (EventHandler<ApiEventArgs<IList<DcnmDeviceInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmDeviceInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmDeviceInfo
See Also

Reference

IEquipment Interface


IEquipment.EquipmentPowerStateChanged Event

IEquipmentEquipmentPowerStateChanged Event

Occurs when the power state of the equipment has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmPowerState>> EquipmentPowerStateChanged
Event EquipmentPowerStateChanged As EventHandler(Of ApiEventArgs(Of DcnmPowerState))
 event EventHandler<ApiEventArgs<DcnmPowerState>^>^ EquipmentPowerStateChanged {
    void add (EventHandler<ApiEventArgs<DcnmPowerState>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmPowerState>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmPowerState
See Also

Reference

IEquipment Interface


IInstallArea Interface

Represents an interface to install an area.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IInstallArea : IDisposable
Public Interface IInstallArea
    Inherits IDisposable
public interface class IInstallArea : IDisposable

The IInstallArea type exposes the following members.

Properties
 | Name | Description
Public property | CanConfigureSimultaneousInterpretation | Indicates whether it is possible to configure simultaneous interpretation.
Public property | CanInstallAreas | Indicates whether it is possible to install areas.
Top
Methods
 | Name | Description
Public method | AssignDeviceToSeatAsync | Assigns a device to a seat.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetAssignedSeatsAsync | Retrieves the seats in the area having devices assigned.
Public method | GetEmptySeatsAsync | Retrieves the seats in the area having no devices assigned.
Public method | GetUnassignedDevicesAsync | Retrieves the devices that are not assigned to a seat.
Public method | UnassignDeviceFromSeatAsync | Unassigns a device to a seat.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IInstallArea Properties

The IInstallArea type exposes the following members.

Properties
 | Name | Description
Public property | CanConfigureSimultaneousInterpretation | Indicates whether it is possible to configure simultaneous interpretation.
Public property | CanInstallAreas | Indicates whether it is possible to install areas.
Top
See Also

Reference

IInstallArea Interface


IInstallArea.CanConfigureSimultaneousInterpretation Property

IInstallAreaCanConfigureSimultaneousInterpretation Property

Indicates whether it is possible to configure simultaneous interpretation.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanConfigureSimultaneousInterpretation { get; }
ReadOnly Property CanConfigureSimultaneousInterpretation As Boolean
    Get
property bool CanConfigureSimultaneousInterpretation {
    bool get ();
}

Property Value

Type: Boolean
true if it is allowed to configure simultaneous interpretation; otherwise, false.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Simultaneous Interpretation
See Also

Reference

IInstallArea Interface


IInstallArea.CanInstallAreas Property

IInstallAreaCanInstallAreas Property

Indicates whether it is possible to install areas.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanInstallAreas { get; }
ReadOnly Property CanInstallAreas As Boolean
    Get
property bool CanInstallAreas {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • User right: Configure System.
See Also

Reference

IInstallArea Interface


IInstallArea Methods

The IInstallArea type exposes the following members.

Methods
 | Name | Description
Public method | AssignDeviceToSeatAsync | Assigns a device to a seat.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetAssignedSeatsAsync | Retrieves the seats in the area having devices assigned.
Public method | GetEmptySeatsAsync | Retrieves the seats in the area having no devices assigned.
Public method | GetUnassignedDevicesAsync | Retrieves the devices that are not assigned to a seat.
Public method | UnassignDeviceFromSeatAsync | Unassigns a device to a seat.
Top
See Also

Reference

IInstallArea Interface


IInstallArea.AssignDeviceToSeatAsync Method

IInstallAreaAssignDeviceToSeatAsync Method

Assigns a device to a seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> AssignDeviceToSeatAsync(
    Guid deviceId,
    Guid seatId,
    Action<Task<bool>> onFinish = null
)
Function AssignDeviceToSeatAsync (
    deviceId As Guid,
    seatId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ AssignDeviceToSeatAsync(
    Guid deviceId,
    Guid seatId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

deviceId
Type: SystemGuid
The device to assign.
seatId
Type: SystemGuid
The seat to assign to.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the device assign. The 'Result' property of the task is true if assign device to seat succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If device id or seat id is empty.
Remarks

A device can only be assigned to a seat if it is connected. Note that UserDefinedDevices may take a while to get connected after they have been created. So always wait for the ondeviceconnected event of a device before assigning it to a seat.

Requires:
  • CanInstallAreas
  • Assigning devices of type InterpretationDevice to InterpreterSeat requires: CanConfigureSimultaneousInterpretation
See Also

Reference

IInstallArea Interface


IInstallArea.GetAssignedSeatsAsync Method

IInstallAreaGetAssignedSeatsAsync Method

Retrieves the seats in the area having devices assigned.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmSeatAssignmentInfo>> GetAssignedSeatsAsync(
    Guid areaId,
    Action<Task<IList<DcnmSeatAssignmentInfo>>> onFinish = null
)
Function GetAssignedSeatsAsync (
    areaId As Guid,
    Optional onFinish As Action(Of Task(Of IList(Of DcnmSeatAssignmentInfo))) = Nothing
) As Task(Of IList(Of DcnmSeatAssignmentInfo))
Task<IList<DcnmSeatAssignmentInfo^>^>^ GetAssignedSeatsAsync(
    Guid areaId,
    Action<Task<IList<DcnmSeatAssignmentInfo^>^>^>^ onFinish = nullptr
)

Parameters

areaId
Type: SystemGuid
The area from which to get the seats from.
onFinish (Optional)
Type: SystemAction Task IList DcnmSeatAssignmentInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmSeatAssignmentInfo
Task processing the seats retrieval. The 'Result' property of the task holds the retrieved seats. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If area id is empty.
See Also

Reference

IInstallArea Interface


IInstallArea.GetEmptySeatsAsync Method

IInstallAreaGetEmptySeatsAsync Method

Retrieves the seats in the area having no devices assigned.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmSeatConfigurationInfo>> GetEmptySeatsAsync(
    Guid areaId,
    Action<Task<IList<DcnmSeatConfigurationInfo>>> onFinish = null
)
Function GetEmptySeatsAsync (
    areaId As Guid,
    Optional onFinish As Action(Of Task(Of IList(Of DcnmSeatConfigurationInfo))) = Nothing
) As Task(Of IList(Of DcnmSeatConfigurationInfo))
Task<IList<DcnmSeatConfigurationInfo^>^>^ GetEmptySeatsAsync(
    Guid areaId,
    Action<Task<IList<DcnmSeatConfigurationInfo^>^>^>^ onFinish = nullptr
)

Parameters

areaId
Type: SystemGuid
The area from which to get the seats from.
onFinish (Optional)
Type: SystemAction Task IList DcnmSeatConfigurationInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmSeatConfigurationInfo
Task processing the seats retrieval. The 'Result' property of the task holds the retrieved seats. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If area id is empty.
See Also

Reference

IInstallArea Interface


IInstallArea.GetUnassignedDevicesAsync Method

IInstallAreaGetUnassignedDevicesAsync Method

Retrieves the devices that are not assigned to a seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<Guid>> GetUnassignedDevicesAsync(
    Action<Task<IList<Guid>>> onFinish = null
)
Function GetUnassignedDevicesAsync (
    Optional onFinish As Action(Of Task(Of IList(Of Guid))) = Nothing
) As Task(Of IList(Of Guid))
Task<IList<Guid>^>^ GetUnassignedDevicesAsync(
    Action<Task<IList<Guid>^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task IList Guid
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList Guid
Task processing the device retrieval. The 'Result' property of the task holds the ids of the retrieved devices. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IInstallArea Interface


IInstallArea.UnassignDeviceFromSeatAsync Method

IInstallAreaUnassignDeviceFromSeatAsync Method

Unassigns a device to a seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UnassignDeviceFromSeatAsync(
    Guid deviceId,
    Action<Task<bool>> onFinish = null
)
Function UnassignDeviceFromSeatAsync (
    deviceId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UnassignDeviceFromSeatAsync(
    Guid deviceId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

deviceId
Type: SystemGuid
The device to unassign.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the device unassign. The 'Result' property of the task is true if unassign device from seat succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If device id is empty.
Remarks
Requires:
  • CanInstallAreas
  • If device is of type remote then operation will fail.
See Also

Reference

IInstallArea Interface


INotesFiles Interface

An interface for operation related to meeting and voting notes xml's.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface INotesFiles : IDisposable
Public Interface INotesFiles
    Inherits IDisposable
public interface class INotesFiles : IDisposable

The INotesFiles type exposes the following members.

Methods
 | Name | Description
Public method | CheckNotesFileTamperedAsync | Checks whether the notes file is tampered or has an invalid certificate
Public method | DeleteNotesFilesAsync | Deletes specified notes files
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetNotesFileInfoAsync | Gets meeting and/or voting xml files list from system.
Public method | TransformNotesFileAsync | XSL transforms the specified meeting or voting notes XML file.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API changed.
Public event | NotesFileListUpdated | Occurs notes files created or updated or deleted.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


INotesFiles Methods

The INotesFiles type exposes the following members.

Methods
 | Name | Description
Public method | CheckNotesFileTamperedAsync | Checks whether the notes file is tampered or has an invalid certificate
Public method | DeleteNotesFilesAsync | Deletes specified notes files
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetNotesFileInfoAsync | Gets meeting and/or voting xml files list from system.
Public method | TransformNotesFileAsync | XSL transforms the specified meeting or voting notes XML file.
Top
See Also

Reference

INotesFiles Interface


INotesFiles.CheckNotesFileTamperedAsync Method

INotesFilesCheckNotesFileTamperedAsync Method

Checks whether the notes file is tampered or has an invalid certificate

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<DcnmDocumentVerificationResponse> CheckNotesFileTamperedAsync(
    string fileName,
    Action<Task<DcnmDocumentVerificationResponse>> onFinish = null
)
Function CheckNotesFileTamperedAsync (
    fileName As String,
    Optional onFinish As Action(Of Task(Of DcnmDocumentVerificationResponse)) = Nothing
) As Task(Of DcnmDocumentVerificationResponse)
Task<DcnmDocumentVerificationResponse^>^ CheckNotesFileTamperedAsync(
    String^ fileName,
    Action<Task<DcnmDocumentVerificationResponse^>^>^ onFinish = nullptr
)

Parameters

fileName
Type: SystemString
Name of the file to check whether it is tampered or not
onFinish (Optional)
Type: SystemAction Task DcnmDocumentVerificationResponse
Optional action for asynchronous handling of the result

Return Value

Type: Task DcnmDocumentVerificationResponse
Task processing the notes files tamper detection. The 'Result' property of the task returns document verification status.
See Also

Reference

INotesFiles Interface


INotesFiles.DeleteNotesFilesAsync Method

INotesFilesDeleteNotesFilesAsync Method

Deletes specified notes files

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeleteNotesFilesAsync(
    Collection<string> fileNames,
    Action<Task<bool>> onFinish = null
)
Function DeleteNotesFilesAsync (
    fileNames As Collection(Of String),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeleteNotesFilesAsync(
    Collection<String^>^ fileNames,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

fileNames
Type: System.Collections.ObjectModelCollection String
Names of files to delete
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result

Return Value

Type: Task Boolean
Task processing the notes files deletion. The 'Result' property of the task holds the success status of the task.
See Also

Reference

INotesFiles Interface


INotesFiles.GetNotesFileInfoAsync Method

INotesFilesGetNotesFileInfoAsync Method

Gets meeting and/or voting xml files list from system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmNotesFileInfo>> GetNotesFileInfoAsync(
    DateTime startDate,
    DateTime endDate,
    Action<Task<IList<DcnmNotesFileInfo>>> onFinish = null
)
Function GetNotesFileInfoAsync (
    startDate As DateTime,
    endDate As DateTime,
    Optional onFinish As Action(Of Task(Of IList(Of DcnmNotesFileInfo))) = Nothing
) As Task(Of IList(Of DcnmNotesFileInfo))
Task<IList<DcnmNotesFileInfo^>^>^ GetNotesFileInfoAsync(
    DateTime startDate,
    DateTime endDate,
    Action<Task<IList<DcnmNotesFileInfo^>^>^>^ onFinish = nullptr
)

Parameters

startDate
Type: SystemDateTime
The start date of file for search.
endDate
Type: SystemDateTime
The end date of the file for search.
onFinish (Optional)
Type: SystemAction Task IList DcnmNotesFileInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmNotesFileInfo
Task processing the xml notes retrieval. The 'Result' property of the task holds the list of files. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

INotesFiles Interface


INotesFiles.TransformNotesFileAsync Method

INotesFilesTransformNotesFileAsync Method

XSL transforms the specified meeting or voting notes XML file.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<string> TransformNotesFileAsync(
    string fileName,
    Action<Task<string>> onFinish = null
)
Function TransformNotesFileAsync (
    fileName As String,
    Optional onFinish As Action(Of Task(Of String)) = Nothing
) As Task(Of String)
Task<String^>^ TransformNotesFileAsync(
    String^ fileName,
    Action<Task<String^>^>^ onFinish = nullptr
)

Parameters

fileName
Type: SystemString
Name of the file to be XSL transformed.
onFinish (Optional)
Type: SystemAction Task String
Optional action for asynchronous handling of the result.

Return Value

Type: Task String
Task processing the transformed notes retrieval. The 'Result' property of the task holds the transformed notes Note that the result getter blocks until the return value is available.
See Also

Reference

INotesFiles Interface


INotesFiles Events

The INotesFiles type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API changed.
Public event | NotesFileListUpdated | Occurs notes files created or updated or deleted.
Top
See Also

Reference

INotesFiles Interface


INotesFiles.CapabilitiesChanged Event

INotesFilesCapabilitiesChanged Event

Occurs when the capabilities of the API changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

INotesFiles Interface


INotesFiles.NotesFileListUpdated Event

INotesFilesNotesFileListUpdated Event

Occurs notes files created or updated or deleted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler NotesFileListUpdated
Event NotesFileListUpdated As EventHandler
 event EventHandler^ NotesFileListUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

INotesFiles Interface


InterpreterConstants Class

The supported interpreter constants
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesInterpreterConstants

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static class InterpreterConstants
Public NotInheritable Class InterpreterConstants
public ref class InterpreterConstants abstract sealed

The InterpreterConstants type exposes the following members.

Fields
Name | Description
DEFAULT_AUTO_RELAY | The default value for auto relay
MAX_BOOTH_NUMBER | The maximum number of booth which can be created.
MAX_DESK_NUMBER | The maximum number of desk which can be created in a booth.
MAX_LANGUAGE_ORDER_NUMBER | The maximum value of order number which is available and can be assigned to languages.
MAX_LANGUAGES_WHEN_ALL_USED | Value for the maximum number of interpretation languages when every languages gets one audio stream.
MAX_LANGUAGES_WHEN_UNPROCESSED_USED | Value for the maximum number of interpretation languages when every languages gets two audio streams.
REMOTE_INTERPRETER_DEVICE_TYPE_ID | Remote interpreter device type Id.
SOURCE2_MAX_HEADROOM | The maximum source to headroom value
SOURCE2_MIN_HEADROOM | The minimum source to headroom value
SPEAKSLOW_MAX_CONFIGVALUE | The maximum speak slow requests / maxmum speak slow request release time value / maximum speak slow signalling release time value.
SPEAKSLOW_MIN_RELEASETIME | The minimum speak slow release time value
SPEAKSLOW_MIN_REQUESTS | The minimum speak slow request value
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


InterpreterConstants Fields

The InterpreterConstants type exposes the following members.

Fields
Name | Description
DEFAULT_AUTO_RELAY | The default value for auto relay
MAX_BOOTH_NUMBER | The maximum number of booth which can be created.
MAX_DESK_NUMBER | The maximum number of desk which can be created in a booth.
MAX_LANGUAGE_ORDER_NUMBER | The maximum value of order number which is available and can be assigned to languages.
MAX_LANGUAGES_WHEN_ALL_USED | Value for the maximum number of interpretation languages when every languages gets one audio stream.
MAX_LANGUAGES_WHEN_UNPROCESSED_USED | Value for the maximum number of interpretation languages when every languages gets two audio streams.
REMOTE_INTERPRETER_DEVICE_TYPE_ID | Remote interpreter device type Id.
SOURCE2_MAX_HEADROOM | The maximum source to headroom value
SOURCE2_MIN_HEADROOM | The minimum source to headroom value
SPEAKSLOW_MAX_CONFIGVALUE | The maximum speak slow requests / maxmum speak slow request release time value / maximum speak slow signalling release time value.
SPEAKSLOW_MIN_RELEASETIME | The minimum speak slow release time value
SPEAKSLOW_MIN_REQUESTS | The minimum speak slow request value
Top
See Also

Reference

InterpreterConstants Class


InterpreterConstants.DEFAULT_AUTO_RELAY Field

InterpreterConstantsDEFAULT_AUTO_RELAY Field

The default value for auto relay

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const bool DEFAULT_AUTO_RELAY = false
Public Const DEFAULT_AUTO_RELAY As Boolean = False
public:
literal bool DEFAULT_AUTO_RELAY = false

Field Value

Type: Boolean
See Also

Reference

InterpreterConstants Class


InterpreterConstants.MAX_BOOTH_NUMBER Field

InterpreterConstantsMAX_BOOTH_NUMBER Field

The maximum number of booth which can be created.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAX_BOOTH_NUMBER = 100
Public Const MAX_BOOTH_NUMBER As Integer = 100
public:
literal int MAX_BOOTH_NUMBER = 100

Field Value

Type: Int32
See Also

Reference

InterpreterConstants Class


InterpreterConstants.MAX_DESK_NUMBER Field

InterpreterConstantsMAX_DESK_NUMBER Field

The maximum number of desk which can be created in a booth.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAX_DESK_NUMBER = 100
Public Const MAX_DESK_NUMBER As Integer = 100
public:
literal int MAX_DESK_NUMBER = 100

Field Value

Type: Int32
See Also

Reference

InterpreterConstants Class


InterpreterConstants.MAX_LANGUAGE_ORDER_NUMBER Field

InterpreterConstantsMAX_LANGUAGE_ORDER_NUMBER Field

The maximum value of order number which is available and can be assigned to languages.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAX_LANGUAGE_ORDER_NUMBER = 1000
Public Const MAX_LANGUAGE_ORDER_NUMBER As Integer = 1000
public:
literal int MAX_LANGUAGE_ORDER_NUMBER = 1000

Field Value

Type: Int32
See Also

Reference

InterpreterConstants Class


InterpreterConstants.MAX_LANGUAGES_WHEN_ALL_USED Field

InterpreterConstantsMAX_LANGUAGES_WHEN_ALL_USED Field

Value for the maximum number of interpretation languages when every languages gets one audio stream.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAX_LANGUAGES_WHEN_ALL_USED = 100
Public Const MAX_LANGUAGES_WHEN_ALL_USED As Integer = 100
public:
literal int MAX_LANGUAGES_WHEN_ALL_USED = 100

Field Value

Type: Int32
See Also

Reference

InterpreterConstants Class


InterpreterConstants.MAX_LANGUAGES_WHEN_UNPROCESSED_USED Field

InterpreterConstantsMAX_LANGUAGES_WHEN_UNPROCESSED_USED Field

 Bosch Logo
Value for the maximum number of interpretation languages when every languages gets two audio streams.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAX_LANGUAGES_WHEN_UNPROCESSED_USED = 50
Public Const MAX_LANGUAGES_WHEN_UNPROCESSED_USED As Integer = 50
public:
literal int MAX_LANGUAGES_WHEN_UNPROCESSED_USED = 50

Field Value

Type: Int32
See Also

Reference

InterpreterConstants Class


InterpreterConstants.REMOTE_INTERPRETER_DEVICE_TYPE_ID Field

InterpreterConstantsREMOTE_INTERPRETER_DEVICE_TYPE_ID Field

Remote interpreter device type Id.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static readonly Guid REMOTE_INTERPRETER_DEVICE_TYPE_ID
Public Shared ReadOnly REMOTE_INTERPRETER_DEVICE_TYPE_ID As Guid
public:
static initonly Guid REMOTE_INTERPRETER_DEVICE_TYPE_ID

Field Value

Type: Guid
See Also

Reference

InterpreterConstants Class


InterpreterConstants.SOURCE2_MAX_HEADROOM Field

InterpreterConstantsSOURCE2_MAX_HEADROOM Field

The maximum source to headroom value

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int SOURCE2_MAX_HEADROOM = 30
Public Const SOURCE2_MAX_HEADROOM As Integer = 30
public:
literal int SOURCE2_MAX_HEADROOM = 30

Field Value

Type: Int32
See Also

Reference

InterpreterConstants Class


InterpreterConstants.SOURCE2_MIN_HEADROOM Field

InterpreterConstantsSOURCE2_MIN_HEADROOM Field

The minimum source to headroom value

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int SOURCE2_MIN_HEADROOM = 3
Public Const SOURCE2_MIN_HEADROOM As Integer = 3
public:
literal int SOURCE2_MIN_HEADROOM = 3

Field Value

Type: Int32
See Also

Reference

InterpreterConstants Class


InterpreterConstants.SPEAKSLOW_MAX_CONFIGVALUE Field

InterpreterConstantsSPEAKSLOW_MAX_CONFIGVALUE Field

The maximum speak slow requests / maxmum speak slow request release time value / maximum speak slow signalling release time value.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int SPEAKSLOW_MAX_CONFIGVALUE = 99
Public Const SPEAKSLOW_MAX_CONFIGVALUE As Integer = 99
public:
literal int SPEAKSLOW_MAX_CONFIGVALUE = 99

Field Value

Type: Int32
See Also

Reference

InterpreterConstants Class


InterpreterConstants.SPEAKSLOW_MIN_RELEASETIME Field

InterpreterConstantsSPEAKSLOW_MIN_RELEASETIME Field

The minimum speak slow release time value

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int SPEAKSLOW_MIN_RELEASETIME = 0
Public Const SPEAKSLOW_MIN_RELEASETIME As Integer = 0
public:
literal int SPEAKSLOW_MIN_RELEASETIME = 0

Field Value

Type: Int32
See Also

Reference

InterpreterConstants Class


InterpreterConstants.SPEAKSLOW_MIN_REQUESTS Field

InterpreterConstantsSPEAKSLOW_MIN_REQUESTS Field

The minimum speak slow request value

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int SPEAKSLOW_MIN_REQUESTS = 1
Public Const SPEAKSLOW_MIN_REQUESTS As Integer = 1
public:
literal int SPEAKSLOW_MIN_REQUESTS = 1

Field Value

Type: Int32
See Also

Reference

InterpreterConstants Class


IPlugin Interface

Plugin interface to allow third party components to communicate with one another

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IPlugin
Public Interface IPlugin
public interface class IPlugin

The IPlugin type exposes the following members.

Methods
 | Name | Description
Public method | GetPluginAsync | Retrieve details of a specific plugin
Public method | GetPluginsAsync | Retrieves all the plugins. Use GetPluginAsync to retrieve details of a specific plugin
Public method | RegisterPluginAsync | Register a plugin
Public method | SendPluginCommandAsync | Send a command to a plugin
Public method | SubscribePluginEventAsync | Subscribe to an event coming from a plugin
Public method | UnregisterPluginAsync | Unregister a plugin
Public method | UnsubscribePluginEventAsync | Unsubscribe from an event coming from a plugin
Top
Events
 | Name | Description
Public event | PluginsAdded | Fires every time a plugin has been added to the system
Public event | PluginsRemoved | Fires every time a plugin is removed from the system
Top
Remarks
Plugins are Dicentis API applications that register themselves using the RegiserPluginAsync method. A plugin exposes an interface that can be called by any other Dicentis Api application. However, the interface itself is not defined within Dicentis, but is fully defined by the plugin.
Any Dicentis API application can send commands to a plugin, and get a response from that plugin. A plugin advertises its command set in the command descritption that is part of the plugin registration.
Plugins can send events. Any API application can register for events coming from a specific plugin. Only those API applications that have registered for a specific event, will be notified of the event when it changes.
Command parameters and return values, and event parameters, are a single string. Although the plugin implementation poses no limitation on the usage of the string, the standard usage is to fill the string parameter with a JSON formatted string. This allows easy adaptation of the interface (missing fields will get a default value, unecessary fields can be ignored) in the future.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IPlugin Methods

The IPlugin type exposes the following members.

Methods
 | Name | Description
Public method | GetPluginAsync | Retrieve details of a specific plugin
Public method | GetPluginsAsync | Retrieves all the plugins. Use GetPluginAsync to retrieve details of a specific plugin
Public method | RegisterPluginAsync | Register a plugin
Public method | SendPluginCommandAsync | Send a command to a plugin
Public method | SubscribePluginEventAsync | Subscribe to an event coming from a plugin
Public method | UnregisterPluginAsync | Unregister a plugin
Public method | UnsubscribePluginEventAsync | Unsubscribe from an event coming from a plugin
Top
See Also

Reference

IPlugin Interface


IPlugin.GetPluginAsync Method

IPluginGetPluginAsync Method

Retrieve details of a specific plugin

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<DcnmPluginDescription> GetPluginAsync(
    string pluginName,
    CancellationToken ct
)
Function GetPluginAsync (
    pluginName As String,
    ct As CancellationToken
) As Task(Of DcnmPluginDescription)
Task<DcnmPluginDescription^>^ GetPluginAsync(
    String^ pluginName,
    CancellationToken ct
)

Parameters

pluginName
Type: SystemString
The name of the plugin
ct
Type: System.ThreadingCancellationToken
Token that can be used to cancel the operation

Return Value

Type: Task DcnmPluginDescription
Details on the plugin. null if the plugin does not exist or is no longer registered
See Also

Reference

IPlugin Interface


IPlugin.GetPluginsAsync Method

IPluginGetPluginsAsync Method

Retrieves all the plugins. Use GetPluginAsync to retrieve details of a specific plugin

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<Collection<string>> GetPluginsAsync(
    CancellationToken ct
)
Function GetPluginsAsync (
    ct As CancellationToken
) As Task(Of Collection(Of String))
Task<Collection<String^>^>^ GetPluginsAsync(
    CancellationToken ct
)

Parameters

ct
Type: System.ThreadingCancellationToken
Token that can be used to cancel the operation

Return Value

Type: Task Collection String
collection of all the plugins currently registered in the Dicentis system
See Also

Reference

IPlugin Interface


IPlugin.RegisterPluginAsync Method

IPluginRegisterPluginAsync Method

Register a plugin

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IPluginInstance> RegisterPluginAsync(
    DcnmPluginDescription plugin,
    PluginCommandDelegate handler,
    CancellationToken ct
)
Function RegisterPluginAsync (
    plugin As DcnmPluginDescription,
    handler As PluginCommandDelegate,
    ct As CancellationToken
) As Task(Of IPluginInstance)
Task<IPluginInstance^>^ RegisterPluginAsync(
    DcnmPluginDescription^ plugin,
    PluginCommandDelegate^ handler,
    CancellationToken ct
)

Parameters

plugin
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPluginDescription
Detailed description of the plugin
handler
Type: Bosch.Dcnm.Interfaces.Api.InterfacesPluginCommandDelegate
A delegate that will process the commands sent to the plugin
ct
Type: System.ThreadingCancellationToken
Token that can be used to cancel the operation

Return Value

Type: Task IPluginInstance
The plugin instance on success. Null on failure
Remarks
A plugin can be registered only once. See the description of the plugin name in DcnmPluginDescription for details on naming of plugins, and how to allow multiple plugins of the same type
The handler will be called on TaskScheduler.Current
See Also

Reference

IPlugin Interface


IPlugin.SendPluginCommandAsync Method

IPluginSendPluginCommandAsync Method

Send a command to a plugin

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<string> SendPluginCommandAsync(
    DcnmPluginCommand msg,
    CancellationToken ct
)
Function SendPluginCommandAsync (
    msg As DcnmPluginCommand,
    ct As CancellationToken
) As Task(Of String)
Task<String^>^ SendPluginCommandAsync(
    DcnmPluginCommand^ msg,
    CancellationToken ct
)

Parameters

msg
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPluginCommand
The message to send. The message includes the destination plugin, the command and the paramters
ct
Type: System.ThreadingCancellationToken
Token that can be used to cancel the operation

Return Value

Type: Task String
The result returned from the plugin. null if an error occurred during message delivery. A plugin may return an empty string to indicate that an error occurred in the plugin
See Also

Reference

IPlugin Interface


IPlugin.SubscribePluginEventAsync Method

IPluginSubscribePluginEventAsync Method

Subscribe to an event coming from a plugin

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SubscribePluginEventAsync(
    string pluginName,
    string eventName,
    PluginEventDelegate handler,
    CancellationToken ct
)
Function SubscribePluginEventAsync (
    pluginName As String,
    eventName As String,
    handler As PluginEventDelegate,
    ct As CancellationToken
) As Task(Of Boolean)
Task<bool>^ SubscribePluginEventAsync(
    String^ pluginName,
    String^ eventName,
    PluginEventDelegate^ handler,
    CancellationToken ct
)

Parameters

pluginName
Type: SystemString
The name of the plugin to subscribe to
eventName
Type: SystemString
The name of the event to subscribe to
handler
Type: Bosch.Dcnm.Interfaces.Api.InterfacesPluginEventDelegate
The delegate that processes the event
ct
Type: System.ThreadingCancellationToken
Token that can be used to cancel the operation

Return Value

Type: Task Boolean
Subscribe always succeeds, false if the plugin was not available currently.
Exceptions
Exception | Condition
SubscribePluginEventAsync(String, String, PluginEventDelegate, CancellationToken) | The subscription was already subscribed.
Remarks
The last event sent by the plugin is notified to the handler soon after calling SubscribePluginEventAsync. Note that this is a "status" like event. The services maintain the last state of the event, and distribute it. There is no guarantee that every call to SendEvent by a plugin server resutls in a call toe the handler every time. The only guarentee is that the last call made to the hander conveys the last value sent the the plugin.
Multiple subscriptions to the same event can be subscribed to, as long as each subscription has a different handler.
It is possible to subscribe to events for plugins that are not registered.
The handler will be called on TaskScheduler.Current
It is possible that the handler gets called twice with the same value.
See Also

Reference

IPlugin Interface


IPlugin.UnregisterPluginAsync Method

IPluginUnregisterPluginAsync Method

Unregister a plugin

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UnregisterPluginAsync(
    IPluginInstance pluginInstance,
    CancellationToken ct
)
Function UnregisterPluginAsync (
    pluginInstance As IPluginInstance,
    ct As CancellationToken
) As Task(Of Boolean)
Task<bool>^ UnregisterPluginAsync(
    IPluginInstance^ pluginInstance,
    CancellationToken ct
)

Parameters

pluginInstance
Type: Bosch.Dcnm.Interfaces.Api.InterfacesIPluginInstance
The plugin to unregister
ct
Type: System.ThreadingCancellationToken
Token that can be used to cancel the operation

Return Value

Type: Task Boolean
true on success
See Also

Reference

IPlugin Interface


IPlugin.UnsubscribePluginEventAsync Method

IPluginUnsubscribePluginEventAsync Method

Unsubscribe from an event coming from a plugin

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UnsubscribePluginEventAsync(
    string pluginName,
    string eventName,
    PluginEventDelegate handler,
    CancellationToken ct
)
Function UnsubscribePluginEventAsync (
    pluginName As String,
    eventName As String,
    handler As PluginEventDelegate,
    ct As CancellationToken
) As Task(Of Boolean)
Task<bool>^ UnsubscribePluginEventAsync(
    String^ pluginName,
    String^ eventName,
    PluginEventDelegate^ handler,
    CancellationToken ct
)

Parameters

pluginName
Type: SystemString
The name of the plugin to unsubscribe from
eventName
Type: SystemString
The name of the event to unsubscribe from
handler
Type: Bosch.Dcnm.Interfaces.Api.InterfacesPluginEventDelegate
The delegate that processes the event
ct
Type: System.ThreadingCancellationToken
Token that can be used to cancel the operation

Return Value

Type: Task Boolean
Unsubscribe always succeeds, false if the plugin was not available currently.
See Also

Reference

IPlugin Interface


IPlugin Events

The IPlugin type exposes the following members.

Events
 | Name | Description
Public event | PluginsAdded | Fires every time a plugin has been added to the system
Public event | PluginsRemoved | Fires every time a plugin is removed from the system
Top
See Also

Reference

IPlugin Interface


IPlugin.PluginsAdded Event

IPluginPluginsAdded Event

Fires every time a plugin has been added to the system

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmPluginRegistrations>> PluginsAdded
Event PluginsAdded As EventHandler(Of ApiEventArgs(Of DcnmPluginRegistrations))
 event EventHandler<ApiEventArgs<DcnmPluginRegistrations^>^>^ PluginsAdded {
    void add (EventHandler<ApiEventArgs<DcnmPluginRegistrations^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmPluginRegistrations^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmPluginRegistrations
Remarks
When you add a handler to this event, the handler is immediately called with all the plugins that are present in the system. After this first time, only the newly added handlers are added.
If you maintain a cache of all the present plugins, note that there are cases that a single plugin can be notified multiple times.
When the API disconnects, pluginsRemoved is not called. Please register to the ApiStateChanged event and clear your cache when the API goes offline.
When the API reconnects, PluginsAdded event handlers are called automatically with all the present plugins.
See Also

Reference

IPlugin Interface


IPlugin.PluginsRemoved Event

IPluginPluginsRemoved Event

Fires every time a plugin is removed from the system

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmPluginRegistrations>> PluginsRemoved
Event PluginsRemoved As EventHandler(Of ApiEventArgs(Of DcnmPluginRegistrations))
 event EventHandler<ApiEventArgs<DcnmPluginRegistrations^>^>^ PluginsRemoved {
    void add (EventHandler<ApiEventArgs<DcnmPluginRegistrations^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmPluginRegistrations^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmPluginRegistrations
See Also

Reference

IPlugin Interface


IPluginInstance Interface

Represents Plugin instance interface.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IPluginInstance
Public Interface IPluginInstance
public interface class IPluginInstance

The IPluginInstance type exposes the following members.

Methods
 | Name | Description
Public method | SendPluginEventAsync | Send an event to all subscribers of the event
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IPluginInstance Methods

The IPluginInstance type exposes the following members.

Methods
 | Name | Description
Public method | SendPluginEventAsync | Send an event to all subscribers of the event
Top
See Also

Reference

IPluginInstance Interface


IPluginInstance.SendPluginEventAsync Method

IPluginInstanceSendPluginEventAsync Method

Send an event to all subscribers of the event

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SendPluginEventAsync(
    string eventName,
    string parameters,
    CancellationToken ct
)
Function SendPluginEventAsync (
    eventName As String,
    parameters As String,
    ct As CancellationToken
) As Task(Of Boolean)
Task<bool>^ SendPluginEventAsync(
    String^ eventName,
    String^ parameters,
    CancellationToken ct
)

Parameters

eventName
Type: SystemString
The event to publish
parameters
Type: SystemString
The JSON formatted parameters for the event. Must not be null. Must be at least an empty JOSN formatted object "{}"
ct
Type: System.ThreadingCancellationToken
Token that allows cancelling the asynchronous task

Return Value

Type: Task Boolean
true on success
See Also

Reference

IPluginInstance Interface


IPrepareAgendaTopic Interface

Defines the interface for preparing agenda topics

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IPrepareAgendaTopic : IDisposable
Public Interface IPrepareAgendaTopic
    Inherits IDisposable
public interface class IPrepareAgendaTopic : IDisposable

The IPrepareAgendaTopic type exposes the following members.

Properties
 | Name | Description
Public property | CanPrepareAgendaTopics | Indicates whether the user is able to prepare agenda topics.
Top
Methods
 | Name | Description
Public method | ChangeAgendaTopicOrderAsync | Updates the order of the agenda topics.
Public method | CopyAgendaTopicAsync | Copies an agenda topic with the given agenda topic information.
Public method | CreateAgendaTopicAsync | Creates an agenda topic with the given agenda topic information.
Public method | DeleteAgendaTopicAsync | Deletes a prepared agenda topic.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RetrieveAgendaTopicsForMeetingAsync | Retrieves the agenda topics for the given meeting from the system.
Public method | UpdateAgendaTopicAsync | Updates a prepared agenda topic with the given agenda topic information.
Top
Events
 | Name | Description
Public event | AgendaTopicCreated | Occurs when an agenda topic has been created.
Public event | AgendaTopicDeleted | Occurs when an agenda topic has been deleted.
Public event | AgendaTopicOrderChanged | Occurs when the agenda topic order has changed.
Public event | AgendaTopicUpdated | Occurs when an agenda topic has been updated.
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IPrepareAgendaTopic Properties

The IPrepareAgendaTopic type exposes the following members.

Properties
 | Name | Description
Public property | CanPrepareAgendaTopics | Indicates whether the user is able to prepare agenda topics.
Top
See Also

Reference

IPrepareAgendaTopic Interface


IPrepareAgendaTopic.CanPrepareAgendaTopics Property

IPrepareAgendaTopicCanPrepareAgendaTopics Property

Indicates whether the user is able to prepare agenda topics.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanPrepareAgendaTopics { get; }
ReadOnly Property CanPrepareAgendaTopics As Boolean
    Get
property bool CanPrepareAgendaTopics {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Meeting preparation and management.
  • User right: Prepare meeting and agenda.
See Also

Reference

IPrepareAgendaTopic Interface


IPrepareAgendaTopic Methods

The IPrepareAgendaTopic type exposes the following members.

Methods
 | Name | Description
Public method | ChangeAgendaTopicOrderAsync | Updates the order of the agenda topics.
Public method | CopyAgendaTopicAsync | Copies an agenda topic with the given agenda topic information.
Public method | CreateAgendaTopicAsync | Creates an agenda topic with the given agenda topic information.
Public method | DeleteAgendaTopicAsync | Deletes a prepared agenda topic.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RetrieveAgendaTopicsForMeetingAsync | Retrieves the agenda topics for the given meeting from the system.
Public method | UpdateAgendaTopicAsync | Updates a prepared agenda topic with the given agenda topic information.
Top
See Also

Reference

IPrepareAgendaTopic Interface


IPrepareAgendaTopic.ChangeAgendaTopicOrderAsync Method

IPrepareAgendaTopicChangeAgendaTopicOrderAsync Method

Updates the order of the agenda topics.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> ChangeAgendaTopicOrderAsync(
    IList<Guid> agendaTopicIds,
    Action<Task<bool>> onFinish = null
)
Function ChangeAgendaTopicOrderAsync (
    agendaTopicIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ ChangeAgendaTopicOrderAsync(
    IList<Guid>^ agendaTopicIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

agendaTopicIds
Type: System.Collections.GenericIList Guid
The sorted list with agenda item ids.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the agenda topic reorder . The 'Result' property of the task is true if change topic order succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the list of agenda topics is null or empty.
Remarks
Requires:
  • CanPrepareAgendaTopics
See Also

Reference

IPrepareAgendaTopic Interface


IPrepareAgendaTopic.CopyAgendaTopicAsync Method

IPrepareAgendaTopicCopyAgendaTopicAsync Method

Copies an agenda topic with the given agenda topic information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<Guid> CopyAgendaTopicAsync(
    DcnmAgendaTopicPreparationInfo agendaTopicInfo,
    Action<Task<Guid>> onFinish = null
)
Function CopyAgendaTopicAsync (
    agendaTopicInfo As DcnmAgendaTopicPreparationInfo,
    Optional onFinish As Action(Of Task(Of Guid)) = Nothing
) As Task(Of Guid)
Task<Guid>^ CopyAgendaTopicAsync(
    DcnmAgendaTopicPreparationInfo^ agendaTopicInfo,
    Action<Task<Guid>^>^ onFinish = nullptr
)

Parameters

agendaTopicInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAgendaTopicPreparationInfo
The container holding the information of the agenda topic.
onFinish (Optional)
Type: SystemAction Task Guid
Optional action for asynchronous handling of the result.

Return Value

Type: Task Guid
Task processing the agenda topic creation. The 'Result' property of the task holds the id of the newly created agenda topic. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If agenda topic info is empty.
Remarks
Requires:
  • CanPrepareAgendaTopics
See Also

Reference

IPrepareAgendaTopic Interface


IPrepareAgendaTopic.CreateAgendaTopicAsync Method

IPrepareAgendaTopicCreateAgendaTopicAsync Method

Creates an agenda topic with the given agenda topic information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<Guid> CreateAgendaTopicAsync(
    DcnmAgendaTopicPreparationInfo agendaTopicInfo,
    Action<Task<Guid>> onFinish = null
)
Function CreateAgendaTopicAsync (
    agendaTopicInfo As DcnmAgendaTopicPreparationInfo,
    Optional onFinish As Action(Of Task(Of Guid)) = Nothing
) As Task(Of Guid)
Task<Guid>^ CreateAgendaTopicAsync(
    DcnmAgendaTopicPreparationInfo^ agendaTopicInfo,
    Action<Task<Guid>^>^ onFinish = nullptr
)

Parameters

agendaTopicInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAgendaTopicPreparationInfo
The container holding the information of the agenda topic.
onFinish (Optional)
Type: SystemAction Task Guid
Optional action for asynchronous handling of the result.

Return Value

Type: Task Guid
Task processing the agenda topic creation. The 'Result' property of the task holds the id of the created agenda topic. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If agenda topic info is empty.
Remarks
Requires:
  • CanPrepareAgendaTopics
See Also

Reference

IPrepareAgendaTopic Interface


IPrepareAgendaTopic.DeleteAgendaTopicAsync Method

IPrepareAgendaTopicDeleteAgendaTopicAsync Method

Deletes a prepared agenda topic.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeleteAgendaTopicAsync(
    Guid agendaTopicId,
    Action<Task<bool>> onFinish = null
)
Function DeleteAgendaTopicAsync (
    agendaTopicId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeleteAgendaTopicAsync(
    Guid agendaTopicId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

agendaTopicId
Type: SystemGuid
The identifier of the agenda topic to be deleted.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the agenda topic deletion. The 'Result' property of the task is true if deleting agenda topic succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If agenda topic id is empty.
Remarks
Requires:
  • CanPrepareAgendaTopics
See Also

Reference

IPrepareAgendaTopic Interface


IPrepareAgendaTopic.RetrieveAgendaTopicsForMeetingAsync Method

IPrepareAgendaTopicRetrieveAgendaTopicsForMeetingAsync Method

Bosch Logo
Retrieves the agenda topics for the given meeting from the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmAgendaTopicPreparationInfo>> RetrieveAgendaTopicsForMeetingAsync(
    Guid meetingId,
    Action<Task<IList<DcnmAgendaTopicPreparationInfo>>> onFinish = null
)
Function RetrieveAgendaTopicsForMeetingAsync (
    meetingId As Guid,
    Optional onFinish As Action(Of Task(Of IList(Of DcnmAgendaTopicPreparationInfo))) = Nothing
) As Task(Of IList(Of DcnmAgendaTopicPreparationInfo))
Task<IList<DcnmAgendaTopicPreparationInfo^>^>^ RetrieveAgendaTopicsForMeetingAsync(
    Guid meetingId,
    Action<Task<IList<DcnmAgendaTopicPreparationInfo^>^>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The meetingId to retrieve the topics for
onFinish (Optional)
Type: SystemAction Task IList DcnmAgendaTopicPreparationInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmAgendaTopicPreparationInfo
Task processing the agenda topic retrieval. The 'Result' property of the task holds the retrieved agenda topics. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If meeting id is empty.
See Also

Reference

IPrepareAgendaTopic Interface


IPrepareAgendaTopic.UpdateAgendaTopicAsync Method

IPrepareAgendaTopicUpdateAgendaTopicAsync Method

Updates a prepared agenda topic with the given agenda topic information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateAgendaTopicAsync(
    DcnmAgendaTopicPreparationInfo agendaTopicInfo,
    Action<Task<bool>> onFinish = null
)
Function UpdateAgendaTopicAsync (
    agendaTopicInfo As DcnmAgendaTopicPreparationInfo,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateAgendaTopicAsync(
    DcnmAgendaTopicPreparationInfo^ agendaTopicInfo,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

agendaTopicInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAgendaTopicPreparationInfo
The container holding the information of the meeting.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the agenda topic update. The 'Result' property of the task is true if updating agenda topic succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If agenda topic info or agendaTopicId is empty.
Remarks

Requires:

  • CanPrepareAgendaTopics

  • Event AgendaTopicUpdated is triggered if the request is processed successfully, along with the updated values of the agenda.

See Also

Reference

IPrepareAgendaTopic Interface


IPrepareAgendaTopic Events

The IPrepareAgendaTopic type exposes the following members.

Events
 | Name | Description
Public event | AgendaTopicCreated | Occurs when an agenda topic has been created.
Public event | AgendaTopicDeleted | Occurs when an agenda topic has been deleted.
Public event | AgendaTopicOrderChanged | Occurs when the agenda topic order has changed.
Public event | AgendaTopicUpdated | Occurs when an agenda topic has been updated.
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Top
See Also

Reference

IPrepareAgendaTopic Interface


IPrepareAgendaTopic.AgendaTopicCreated Event

IPrepareAgendaTopicAgendaTopicCreated Event

Occurs when an agenda topic has been created.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmAgendaTopicPreparationInfo>> AgendaTopicCreated
Event AgendaTopicCreated As EventHandler(Of ApiEventArgs(Of DcnmAgendaTopicPreparationInfo))
 event EventHandler<ApiEventArgs<DcnmAgendaTopicPreparationInfo^>^>^ AgendaTopicCreated {
    void add (EventHandler<ApiEventArgs<DcnmAgendaTopicPreparationInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmAgendaTopicPreparationInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmAgendaTopicPreparationInfo
See Also

Reference

IPrepareAgendaTopic Interface


IPrepareAgendaTopic.AgendaTopicDeleted Event

IPrepareAgendaTopicAgendaTopicDeleted Event

Occurs when an agenda topic has been deleted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<Guid>> AgendaTopicDeleted
Event AgendaTopicDeleted As EventHandler(Of ApiEventArgs(Of Guid))
 event EventHandler<ApiEventArgs<Guid>^>^ AgendaTopicDeleted {
    void add (EventHandler<ApiEventArgs<Guid>^>^ value);
    void remove (EventHandler<ApiEventArgs<Guid>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Guid
See Also

Reference

IPrepareAgendaTopic Interface


IPrepareAgendaTopic.AgendaTopicOrderChanged Event

IPrepareAgendaTopicAgendaTopicOrderChanged Event

Occurs when the agenda topic order has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<Guid>>> AgendaTopicOrderChanged
Event AgendaTopicOrderChanged As EventHandler(Of ApiEventArgs(Of IList(Of Guid)))
 event EventHandler<ApiEventArgs<IList<Guid>^>^>^ AgendaTopicOrderChanged {
    void add (EventHandler<ApiEventArgs<IList<Guid>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<Guid>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList Guid
See Also

Reference

IPrepareAgendaTopic Interface


IPrepareAgendaTopic.AgendaTopicUpdated Event

IPrepareAgendaTopicAgendaTopicUpdated Event

Occurs when an agenda topic has been updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmAgendaTopicPreparationInfo>> AgendaTopicUpdated
Event AgendaTopicUpdated As EventHandler(Of ApiEventArgs(Of DcnmAgendaTopicPreparationInfo))
 event EventHandler<ApiEventArgs<DcnmAgendaTopicPreparationInfo^>^>^ AgendaTopicUpdated {
    void add (EventHandler<ApiEventArgs<DcnmAgendaTopicPreparationInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmAgendaTopicPreparationInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmAgendaTopicPreparationInfo
See Also

Reference

IPrepareAgendaTopic Interface


IPrepareAgendaTopic.CapabilitiesChanged Event

IPrepareAgendaTopicCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IPrepareAgendaTopic Interface


IPrepareCamera Interface

Defines the interface to register cameras.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IPrepareCamera : IDisposable
Public Interface IPrepareCamera
    Inherits IDisposable
public interface class IPrepareCamera : IDisposable

The IPrepareCamera type exposes the following members.

Properties
 | Name | Description
Public property | CanPrepareCameras | Indicates whether it is possible to register a camera or not.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetCamerasAsync | Triggers the request to retrieve all the cameras.
Public method | GetOverviewCamerasAsync | Triggers the request to retrieve the overview cameras for the current area.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IPrepareCamera Properties

The IPrepareCamera type exposes the following members.

Properties
 | Name | Description
Public property | CanPrepareCameras | Indicates whether it is possible to register a camera or not.
Top
See Also

Reference

IPrepareCamera Interface


IPrepareCamera.CanPrepareCameras Property

IPrepareCameraCanPrepareCameras Property

Indicates whether it is possible to register a camera or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanPrepareCameras { get; }
ReadOnly Property CanPrepareCameras As Boolean
    Get
property bool CanPrepareCameras {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Camera Control.
  • User right: Configure system.
See Also

Reference

IPrepareCamera Interface


IPrepareCamera Methods

The IPrepareCamera type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetCamerasAsync | Triggers the request to retrieve all the cameras.
Public method | GetOverviewCamerasAsync | Triggers the request to retrieve the overview cameras for the current area.
Top
See Also

Reference

IPrepareCamera Interface


IPrepareCamera.GetCamerasAsync Method

IPrepareCameraGetCamerasAsync Method

Triggers the request to retrieve all the cameras.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmCameraPreparationInfo>> GetCamerasAsync(
    Action<Task<IList<DcnmCameraPreparationInfo>>> onFinish = null
)
Function GetCamerasAsync (
    Optional onFinish As Action(Of Task(Of IList(Of DcnmCameraPreparationInfo))) = Nothing
) As Task(Of IList(Of DcnmCameraPreparationInfo))
Task<IList<DcnmCameraPreparationInfo^>^>^ GetCamerasAsync(
    Action<Task<IList<DcnmCameraPreparationInfo^>^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task IList DcnmCameraPreparationInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmCameraPreparationInfo
Task processing the camera retrieval. The 'Result' property of the task holds the retrieved cameras. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IPrepareCamera Interface


IPrepareCamera.GetOverviewCamerasAsync Method

IPrepareCameraGetOverviewCamerasAsync Method

Triggers the request to retrieve the overview cameras for the current area.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<DcnmOverviewCameraPreparationInfo> GetOverviewCamerasAsync(
    Action<Task<DcnmOverviewCameraPreparationInfo>> onFinish = null
)
Function GetOverviewCamerasAsync (
    Optional onFinish As Action(Of Task(Of DcnmOverviewCameraPreparationInfo)) = Nothing
) As Task(Of DcnmOverviewCameraPreparationInfo)
Task<DcnmOverviewCameraPreparationInfo^>^ GetOverviewCamerasAsync(
    Action<Task<DcnmOverviewCameraPreparationInfo^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task DcnmOverviewCameraPreparationInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task DcnmOverviewCameraPreparationInfo
Task processing the camera retrieval. The 'Result' property of the task holds the retrieved overview camera Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IPrepareCamera Interface


IPrepareCamera Events

The IPrepareCamera type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Top
See Also

Reference

IPrepareCamera Interface


IPrepareCamera.CapabilitiesChanged Event

IPrepareCameraCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IPrepareCamera Interface


IPrepareDiscussion Interface

Defines the interface for preparing discussions and discussion profiles.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IPrepareDiscussion : IDisposable
Public Interface IPrepareDiscussion
    Inherits IDisposable
public interface class IPrepareDiscussion : IDisposable

The IPrepareDiscussion type exposes the following members.

Properties
 | Name | Description
Public property | CanPrepareAdvancedDiscussions | Indicates whether the user is able to prepare advanced discussions. only with premium and ultimate licenses user should be able to prepare advanced discussion options. Advanced discussion settings will have "Response discussion mode and its options" , "Speech timer options" and "Show active microphone with Attack and Release time options".
Public property | CanPrepareDiscussions | Indicates whether the user is able to prepare discussions.
Public property | CanPrepareSpeakerViewingOptions | Indicates whether the user is able to prepare speaker viewing options.
Public property | CanPrepareVoiceModeOptions | Indicates whether the user can prepare the voice mode options in the discussion
Top
Methods
 | Name | Description
Public method | CreateDiscussionFromTemplateAsync | Creates a new discussion from the values in the identified profile.
Public method | CreateNewDiscussionAsync | Creates a new discussion from default values.
Public method | CreateTemplateAsync | Creates a discussion profile.
Public method | DeleteDiscussionAsync | Deletes the identified discussion.
Public method | DeleteTemplateAsync | Deletes the identified discussion profile.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetDiscussionByIdAsync | Retrieves the identified discussion and information from the system.
Public method | GetDiscussionsAsync | Retrieves the discussions and information from the system.
Public method | GetTemplateByIdAsync | Retrieves the identified discussion profile and information from the system.
Public method | GetTemplatesAsync | Retrieves the discussion profiles and information from the system.
Public method | UpdateDiscussionAsync | Updates a discussion from the given values.
Public method | UpdateTemplateAsync | Updates a discussion profile from the given values.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | DiscussionCreated | Occurs when a discussion has been created.
Public event | DiscussionDeleted | Occurs when a discussion has been deleted.
Public event | DiscussionUpdated | Occurs when a discussion has been updated.
Public event | TemplateCreated | Occurs when a discussion profile has been created.
Public event | TemplateDeleted | Occurs when a discussion profile has been deleted.
Public event | TemplateUpdated | Occurs when a discussion profile has been updated.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IPrepareDiscussion Properties

The IPrepareDiscussion type exposes the following members.

Properties
 | Name | Description
Public property | CanPrepareAdvancedDiscussions | Indicates whether the user is able to prepare advanced discussions. only with premium and ultimate licenses user should be able to prepare advanced discussion options. Advanced discussion settings will have "Response discussion mode and its options" , "Speech timer options" and "Show active microphone with Attack and Release time options".
Public property | CanPrepareDiscussions | Indicates whether the user is able to prepare discussions.
Public property | CanPrepareSpeakerViewingOptions | Indicates whether the user is able to prepare speaker viewing options.
Public property | CanPrepareVoiceModeOptions | Indicates whether the user can prepare the voice mode options in the discussion
Top
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.CanPrepareAdvancedDiscussions Property

IPrepareDiscussionCanPrepareAdvancedDiscussions Property

Indicates whether the user is able to prepare advanced discussions. only with premium and ultimate licenses user should be able to prepare advanced discussion options. Advanced discussion settings will have "Response discussion mode and its options" , "Speech timer options" and "Show active microphone with Attack and Release time options".

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanPrepareAdvancedDiscussions { get; }
ReadOnly Property CanPrepareAdvancedDiscussions As Boolean
    Get
property bool CanPrepareAdvancedDiscussions {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Meeting preparation and management.
  • Advance license: DCNM_LPP_PE, DCNM_LPU_PE, DCNM_LPPP_P1Y, DCNM_LPUP_P1Y, DCNM_LPUP_S1Y, DCNM_LPPP_S1Y, DCNM_DEMO.
  • User right: Prepare meeting and agenda.
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.CanPrepareDiscussions Property

IPrepareDiscussionCanPrepareDiscussions Property

Indicates whether the user is able to prepare discussions.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanPrepareDiscussions { get; }
ReadOnly Property CanPrepareDiscussions As Boolean
    Get
property bool CanPrepareDiscussions {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Meeting preparation and management.
  • User right: Prepare meeting and agenda.
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.CanPrepareSpeakerViewingOptions Property

IPrepareDiscussionCanPrepareSpeakerViewingOptions Property

Indicates whether the user is able to prepare speaker viewing options.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanPrepareSpeakerViewingOptions { get; }
ReadOnly Property CanPrepareSpeakerViewingOptions As Boolean
    Get
property bool CanPrepareSpeakerViewingOptions {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Meeting preparation and management.
  • Functional license: Camera Control
  • Functional license: Participant Database
  • User right: Prepare meeting and agenda.
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.CanPrepareVoiceModeOptions Property

IPrepareDiscussionCanPrepareVoiceModeOptions Property

Indicates whether the user can prepare the voice mode options in the discussion

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanPrepareVoiceModeOptions { get; }
ReadOnly Property CanPrepareVoiceModeOptions As Boolean
    Get
property bool CanPrepareVoiceModeOptions {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Show active microphone in voice mode license.
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion Methods

The IPrepareDiscussion type exposes the following members.

Methods
 | Name | Description
Public method | CreateDiscussionFromTemplateAsync | Creates a new discussion from the values in the identified profile.
Public method | CreateNewDiscussionAsync | Creates a new discussion from default values.
Public method | CreateTemplateAsync | Creates a discussion profile.
Public method | DeleteDiscussionAsync | Deletes the identified discussion.
Public method | DeleteTemplateAsync | Deletes the identified discussion profile.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetDiscussionByIdAsync | Retrieves the identified discussion and information from the system.
Public method | GetDiscussionsAsync | Retrieves the discussions and information from the system.
Public method | GetTemplateByIdAsync | Retrieves the identified discussion profile and information from the system.
Public method | GetTemplatesAsync | Retrieves the discussion profiles and information from the system.
Public method | UpdateDiscussionAsync | Updates a discussion from the given values.
Public method | UpdateTemplateAsync | Updates a discussion profile from the given values.
Top
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.CreateDiscussionFromTemplateAsync Method

IPrepareDiscussionCreateDiscussionFromTemplateAsync Method

Creates a new discussion from the values in the identified profile.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<Guid> CreateDiscussionFromTemplateAsync(
    Guid templateId,
    Action<Task<Guid>> onFinish = null
)
Function CreateDiscussionFromTemplateAsync (
    templateId As Guid,
    Optional onFinish As Action(Of Task(Of Guid)) = Nothing
) As Task(Of Guid)
Task<Guid>^ CreateDiscussionFromTemplateAsync(
    Guid templateId,
    Action<Task<Guid>^>^ onFinish = nullptr
)

Parameters

templateId
Type: SystemGuid
The identification of the profile.
onFinish (Optional)
Type: SystemAction Task Guid
Optional action for asynchronous handling of the result.

Return Value

Type: Task Guid
Task processing the discussion creation . The 'Result' property of the task holds the id of the created discussion. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If profile id is empty.
Remarks
Requires:
  • CanPrepareDiscussions
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.CreateNewDiscussionAsync Method

IPrepareDiscussionCreateNewDiscussionAsync Method

Creates a new discussion from default values.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<Guid> CreateNewDiscussionAsync(
    Action<Task<Guid>> onFinish = null
)
Function CreateNewDiscussionAsync (
    Optional onFinish As Action(Of Task(Of Guid)) = Nothing
) As Task(Of Guid)
Task<Guid>^ CreateNewDiscussionAsync(
    Action<Task<Guid>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Guid
Optional action for asynchronous handling of the result.

Return Value

Type: Task Guid
Task processing the discussion creation. The 'Result' property of the task holds the id of the created discussion. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanPrepareDiscussions
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.CreateTemplateAsync Method

IPrepareDiscussionCreateTemplateAsync Method

Creates a discussion profile.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<Guid> CreateTemplateAsync(
    DcnmTemplatePreparationInfo templateInfo,
    Action<Task<Guid>> onFinish = null
)
Function CreateTemplateAsync (
    templateInfo As DcnmTemplatePreparationInfo,
    Optional onFinish As Action(Of Task(Of Guid)) = Nothing
) As Task(Of Guid)
Task<Guid>^ CreateTemplateAsync(
    DcnmTemplatePreparationInfo^ templateInfo,
    Action<Task<Guid>^>^ onFinish = nullptr
)

Parameters

templateInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmTemplatePreparationInfo
The information of the discussion profile.
onFinish (Optional)
Type: SystemAction Task Guid
Optional action for asynchronous handling of the result.

Return Value

Type: Task Guid
Task processing the discussion profile creation. The 'Result' property of the task holds the id of the created discussion profile. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If discussion profile info is null.
ArgumentOutOfRangeException
  • If speech duration option is more than maximum value (99 minutes or 5940 seconds) or minimum value (1 sec).
  • If adjust speech duration option is more than maximum value (10 minutes or 600 seconds) or minimum value (1 sec).
  • If MaxRequests in RequestOptions is not between DISCUSS_MIN_REQUESTS and DISCUSS_MAX_REQUESTS
  • If MaxResponses in ResponseOptions is not between DISCUSS_DEFAULT_MIN_RESPONSES and DISCUSS_DEFAULT_MAX_RESPONSES
  • If NumberOfOpenMicrophones in MicrophoneOptions is not between MIN_OPEN_MICROPHONES and MAX_OPEN_MICROPHONES
Remarks
Requires:
  • CanPrepareDiscussions
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.DeleteDiscussionAsync Method

IPrepareDiscussionDeleteDiscussionAsync Method

Deletes the identified discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeleteDiscussionAsync(
    Guid discussionId,
    Action<Task<bool>> onFinish = null
)
Function DeleteDiscussionAsync (
    discussionId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeleteDiscussionAsync(
    Guid discussionId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

discussionId
Type: SystemGuid
The discussion to delete.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the discussion deletion. The 'Result' property of the task is true if deleting discussion succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If discussion id is empty.
Remarks
Requires:
  • CanPrepareDiscussions
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.DeleteTemplateAsync Method

IPrepareDiscussionDeleteTemplateAsync Method

Deletes the identified discussion profile.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeleteTemplateAsync(
    Guid templateId,
    Action<Task<bool>> onFinish = null
)
Function DeleteTemplateAsync (
    templateId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeleteTemplateAsync(
    Guid templateId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

templateId
Type: SystemGuid
The discussion profile to delete.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the discussion profile deletion. The 'Result' property of the task is true if deleting discussion process succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If profile id is empty.
Remarks
Requires:
  • CanPrepareDiscussions
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.GetDiscussionByIdAsync Method

IPrepareDiscussionGetDiscussionByIdAsync Method

Retrieves the identified discussion and information from the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<DcnmDiscussionPreparationInfo> GetDiscussionByIdAsync(
    Guid discussionId,
    Action<Task<DcnmDiscussionPreparationInfo>> onFinish = null
)
Function GetDiscussionByIdAsync (
    discussionId As Guid,
    Optional onFinish As Action(Of Task(Of DcnmDiscussionPreparationInfo)) = Nothing
) As Task(Of DcnmDiscussionPreparationInfo)
Task<DcnmDiscussionPreparationInfo^>^ GetDiscussionByIdAsync(
    Guid discussionId,
    Action<Task<DcnmDiscussionPreparationInfo^>^>^ onFinish = nullptr
)

Parameters

discussionId
Type: SystemGuid
The identification of the requested discussion.
onFinish (Optional)
Type: SystemAction Task DcnmDiscussionPreparationInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task DcnmDiscussionPreparationInfo
Task processing the discussion retrieval. The 'Result' property of the task holds the retrieved discussions. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If discussion id is empty.
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.GetDiscussionsAsync Method

IPrepareDiscussionGetDiscussionsAsync Method

Retrieves the discussions and information from the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmDiscussionPreparationInfo>> GetDiscussionsAsync(
    Action<Task<IList<DcnmDiscussionPreparationInfo>>> onFinish = null
)
Function GetDiscussionsAsync (
    Optional onFinish As Action(Of Task(Of IList(Of DcnmDiscussionPreparationInfo))) = Nothing
) As Task(Of IList(Of DcnmDiscussionPreparationInfo))
Task<IList<DcnmDiscussionPreparationInfo^>^>^ GetDiscussionsAsync(
    Action<Task<IList<DcnmDiscussionPreparationInfo^>^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task IList DcnmDiscussionPreparationInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmDiscussionPreparationInfo
Task processing the discussion retrieval. The 'Result' property of the task holds the retrieved discussions. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.GetTemplateByIdAsync Method

IPrepareDiscussionGetTemplateByIdAsync Method

Retrieves the identified discussion profile and information from the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<DcnmTemplatePreparationInfo> GetTemplateByIdAsync(
    Guid templateId,
    Action<Task<DcnmTemplatePreparationInfo>> onFinish = null
)
Function GetTemplateByIdAsync (
    templateId As Guid,
    Optional onFinish As Action(Of Task(Of DcnmTemplatePreparationInfo)) = Nothing
) As Task(Of DcnmTemplatePreparationInfo)
Task<DcnmTemplatePreparationInfo^>^ GetTemplateByIdAsync(
    Guid templateId,
    Action<Task<DcnmTemplatePreparationInfo^>^>^ onFinish = nullptr
)

Parameters

templateId
Type: SystemGuid
The identification of the requested discussion profile.
onFinish (Optional)
Type: SystemAction Task DcnmTemplatePreparationInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task DcnmTemplatePreparationInfo
Task processing the discussion profile retrieval. The 'Result' property of the task holds the retrieved discussion profile. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If profile id is empty.
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.GetTemplatesAsync Method

IPrepareDiscussionGetTemplatesAsync Method

Retrieves the discussion profiles and information from the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmTemplatePreparationInfo>> GetTemplatesAsync(
    Action<Task<IList<DcnmTemplatePreparationInfo>>> onFinish = null
)
Function GetTemplatesAsync (
    Optional onFinish As Action(Of Task(Of IList(Of DcnmTemplatePreparationInfo))) = Nothing
) As Task(Of IList(Of DcnmTemplatePreparationInfo))
Task<IList<DcnmTemplatePreparationInfo^>^>^ GetTemplatesAsync(
    Action<Task<IList<DcnmTemplatePreparationInfo^>^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task IList DcnmTemplatePreparationInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmTemplatePreparationInfo
Task processing the discussion profile retrieval. The 'Result' property of the task holds the retrieved profiles. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.UpdateDiscussionAsync Method

IPrepareDiscussionUpdateDiscussionAsync Method

Updates a discussion from the given values.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateDiscussionAsync(
    DcnmDiscussionPreparationInfo discussionInfo,
    Action<Task<bool>> onFinish = null
)
Function UpdateDiscussionAsync (
    discussionInfo As DcnmDiscussionPreparationInfo,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateDiscussionAsync(
    DcnmDiscussionPreparationInfo^ discussionInfo,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

discussionInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmDiscussionPreparationInfo
The information of the discussion to update
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the discussion update. The 'Result' property of the task is true if updating discussion succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If discussion info is null.
ArgumentOutOfRangeException
  • If speech duration option is more than maximum value (99 minutes or 5940 seconds) or minimum value (1 sec).
  • If adjust speech duration option is more than maximum value (10 minutes or 600 seconds) or minimum value (1 sec).
Remarks
Requires:
  • CanPrepareDiscussions
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.UpdateTemplateAsync Method

IPrepareDiscussionUpdateTemplateAsync Method

Updates a discussion profile from the given values.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateTemplateAsync(
    DcnmTemplatePreparationInfo templateInfo,
    Action<Task<bool>> onFinish = null
)
Function UpdateTemplateAsync (
    templateInfo As DcnmTemplatePreparationInfo,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateTemplateAsync(
    DcnmTemplatePreparationInfo^ templateInfo,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

templateInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmTemplatePreparationInfo
The information of the dicussion profile to update.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the discussion profile update . The 'Result' property of the task is true if updating discussion profile succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If profile info is null.
ArgumentOutOfRangeException
  • If speech duration option is more than maximum value (99 minutes or 5940 seconds) or minimum value (1 sec).
  • If adjust speech duration option is more than maximum value (10 minutes or 600 seconds) or minimum value (1 sec).
  • If MaxRequests in RequestOptions is not between DISCUSS_MIN_REQUESTS and DISCUSS_MAX_REQUESTS
  • If MaxResponses in ResponseOptions is not between DISCUSS_DEFAULT_MIN_RESPONSES and DISCUSS_DEFAULT_MAX_RESPONSES
  • If NumberOfOpenMicrophones in MicrophoneOptions is not between MIN_OPEN_MICROPHONES and MAX_OPEN_MICROPHONES
Remarks
Requires:
  • CanPrepareDiscussions
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion Events

The IPrepareDiscussion type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | DiscussionCreated | Occurs when a discussion has been created.
Public event | DiscussionDeleted | Occurs when a discussion has been deleted.
Public event | DiscussionUpdated | Occurs when a discussion has been updated.
Public event | TemplateCreated | Occurs when a discussion profile has been created.
Public event | TemplateDeleted | Occurs when a discussion profile has been deleted.
Public event | TemplateUpdated | Occurs when a discussion profile has been updated.
Top
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.CapabilitiesChanged Event

IPrepareDiscussionCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.DiscussionCreated Event

IPrepareDiscussionDiscussionCreated Event

Occurs when a discussion has been created.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmDiscussionPreparationInfo>> DiscussionCreated
Event DiscussionCreated As EventHandler(Of ApiEventArgs(Of DcnmDiscussionPreparationInfo))
 event EventHandler<ApiEventArgs<DcnmDiscussionPreparationInfo^>^>^ DiscussionCreated {
    void add (EventHandler<ApiEventArgs<DcnmDiscussionPreparationInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmDiscussionPreparationInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmDiscussionPreparationInfo
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.DiscussionDeleted Event

IPrepareDiscussionDiscussionDeleted Event

Occurs when a discussion has been deleted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<Guid>> DiscussionDeleted
Event DiscussionDeleted As EventHandler(Of ApiEventArgs(Of Guid))
 event EventHandler<ApiEventArgs<Guid>^>^ DiscussionDeleted {
    void add (EventHandler<ApiEventArgs<Guid>^>^ value);
    void remove (EventHandler<ApiEventArgs<Guid>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Guid
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.DiscussionUpdated Event

IPrepareDiscussionDiscussionUpdated Event

Occurs when a discussion has been updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmDiscussionPreparationInfo>> DiscussionUpdated
Event DiscussionUpdated As EventHandler(Of ApiEventArgs(Of DcnmDiscussionPreparationInfo))
 event EventHandler<ApiEventArgs<DcnmDiscussionPreparationInfo^>^>^ DiscussionUpdated {
    void add (EventHandler<ApiEventArgs<DcnmDiscussionPreparationInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmDiscussionPreparationInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmDiscussionPreparationInfo
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.TemplateCreated Event

IPrepareDiscussionTemplateCreated Event

Occurs when a discussion profile has been created.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmTemplatePreparationInfo>> TemplateCreated
Event TemplateCreated As EventHandler(Of ApiEventArgs(Of DcnmTemplatePreparationInfo))
 event EventHandler<ApiEventArgs<DcnmTemplatePreparationInfo^>^>^ TemplateCreated {
    void add (EventHandler<ApiEventArgs<DcnmTemplatePreparationInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmTemplatePreparationInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmTemplatePreparationInfo
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.TemplateDeleted Event

IPrepareDiscussionTemplateDeleted Event

Occurs when a discussion profile has been deleted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<Guid>> TemplateDeleted
Event TemplateDeleted As EventHandler(Of ApiEventArgs(Of Guid))
 event EventHandler<ApiEventArgs<Guid>^>^ TemplateDeleted {
    void add (EventHandler<ApiEventArgs<Guid>^>^ value);
    void remove (EventHandler<ApiEventArgs<Guid>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Guid
See Also

Reference

IPrepareDiscussion Interface


IPrepareDiscussion.TemplateUpdated Event

IPrepareDiscussionTemplateUpdated Event

Occurs when a discussion profile has been updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmTemplatePreparationInfo>> TemplateUpdated
Event TemplateUpdated As EventHandler(Of ApiEventArgs(Of DcnmTemplatePreparationInfo))
 event EventHandler<ApiEventArgs<DcnmTemplatePreparationInfo^>^>^ TemplateUpdated {
    void add (EventHandler<ApiEventArgs<DcnmTemplatePreparationInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmTemplatePreparationInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmTemplatePreparationInfo
See Also

Reference

IPrepareDiscussion Interface


IPrepareMeeting Interface

Defines the interface for preparing meetings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IPrepareMeeting : IDisposable
Public Interface IPrepareMeeting
    Inherits IDisposable
public interface class IPrepareMeeting : IDisposable

The IPrepareMeeting type exposes the following members.

Properties
 | Name | Description
Public property | CanPrepareMeetings | Indicates whether the user is able to prepare meetings.
Public property | QuorumVariables | Retrieves variables used in quorum formula.
Top
Methods
 | Name | Description
Public method | DeleteMeetingAsync | Deletes a prepared meeting.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetMeetingsAsync | Retrieves the meetings and information from the system.
Public method | RetrieveAutoStartMeetingIdAsync | Retrieve's auto-start meetingId.
Public method | SetAutoStartMeetingIdAsync | Set's a prepared meeting as auto-start meeting.
Top
Events
 | Name | Description
Public event | AutoStartMeetingIdChanged | Occurs when a meeting has been set as auto-start.
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | MeetingCreated | Occurs when a meeting has been created.
Public event | MeetingDeleted | Occurs when a meeting has been deleted.
Public event | MeetingUpdated | Occurs when a meeting has been updated.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IPrepareMeeting Properties

The IPrepareMeeting type exposes the following members.

Properties
 | Name | Description
Public property | CanPrepareMeetings | Indicates whether the user is able to prepare meetings.
Public property | QuorumVariables | Retrieves variables used in quorum formula.
Top
See Also

Reference

IPrepareMeeting Interface


IPrepareMeeting.CanPrepareMeetings Property

IPrepareMeetingCanPrepareMeetings Property

Indicates whether the user is able to prepare meetings.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanPrepareMeetings { get; }
ReadOnly Property CanPrepareMeetings As Boolean
    Get
property bool CanPrepareMeetings {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Meeting preparation and management.
  • User right: Prepare meeting and agenda.
See Also

Reference

IPrepareMeeting Interface


IPrepareMeeting.QuorumVariables Property

IPrepareMeetingQuorumVariables Property

Retrieves variables used in quorum formula.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
IList<string> QuorumVariables { get; }
ReadOnly Property QuorumVariables As IList(Of String)
    Get
property IList<String^>^ QuorumVariables {
    IList<String^>^ get ();
}

Property Value

Type: IList String
Remarks
These variables can be used in quorum formula for meeting.
See Also

Reference

IPrepareMeeting Interface


IPrepareMeeting Methods

The IPrepareMeeting type exposes the following members.

Methods
 | Name | Description
Public method | DeleteMeetingAsync | Deletes a prepared meeting.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetMeetingsAsync | Retrieves the meetings and information from the system.
Public method | RetrieveAutoStartMeetingIdAsync | Retrieve's auto-start meetingId.
Public method | SetAutoStartMeetingIdAsync | Set's a prepared meeting as auto-start meeting.
Top
See Also

Reference

IPrepareMeeting Interface


IPrepareMeeting.DeleteMeetingAsync Method

IPrepareMeetingDeleteMeetingAsync Method

Deletes a prepared meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeleteMeetingAsync(
    Guid meetingId,
    Action<Task<bool>> onFinish = null
)
Function DeleteMeetingAsync (
    meetingId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeleteMeetingAsync(
    Guid meetingId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting to be deleted.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the meeting deletion. The 'Result' property of the task is true if deleting meeting succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If meeting id is empty.
Remarks
Requires:
  • CanPrepareMeetings
See Also

Reference

IPrepareMeeting Interface


IPrepareMeeting.GetMeetingsAsync Method

IPrepareMeetingGetMeetingsAsync Method

Retrieves the meetings and information from the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmMeetingPreparationInfo>> GetMeetingsAsync(
    Action<Task<IList<DcnmMeetingPreparationInfo>>> onFinish = null
)
Function GetMeetingsAsync (
    Optional onFinish As Action(Of Task(Of IList(Of DcnmMeetingPreparationInfo))) = Nothing
) As Task(Of IList(Of DcnmMeetingPreparationInfo))
Task<IList<DcnmMeetingPreparationInfo^>^>^ GetMeetingsAsync(
    Action<Task<IList<DcnmMeetingPreparationInfo^>^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task IList DcnmMeetingPreparationInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmMeetingPreparationInfo
Task processing the meeting retrieval. The 'Result' property of the task holds the retrieved meetings. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IPrepareMeeting Interface


IPrepareMeeting.RetrieveAutoStartMeetingIdAsync Method

IPrepareMeetingRetrieveAutoStartMeetingIdAsync Method

Retrieve's auto-start meetingId.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<Guid> RetrieveAutoStartMeetingIdAsync(
    Action<Task<Guid>> onFinish = null
)
Function RetrieveAutoStartMeetingIdAsync (
    Optional onFinish As Action(Of Task(Of Guid)) = Nothing
) As Task(Of Guid)
Task<Guid>^ RetrieveAutoStartMeetingIdAsync(
    Action<Task<Guid>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Guid
Optional action for asynchronous handling of the result.

Return Value

Type: Task Guid
Task processing the retrieval of auto-start meetingId. The 'Result' property of the task holds the auto-start meetingId. Note that the result getter blocks until the return value is available.
Remarks
Requires:
  • CanPrepareMeetings
See Also

Reference

IPrepareMeeting Interface


IPrepareMeeting.SetAutoStartMeetingIdAsync Method

IPrepareMeetingSetAutoStartMeetingIdAsync Method

Set's a prepared meeting as auto-start meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> SetAutoStartMeetingIdAsync(
    Guid meetingId,
    Action<Task<bool>> onFinish = null
)
Function SetAutoStartMeetingIdAsync (
    meetingId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ SetAutoStartMeetingIdAsync(
    Guid meetingId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The identifier of the meeting to be set as auto-start meeting.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the meeting for auto-start. The 'Result' property of the task is true if auto-start meeting succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanPrepareMeetings
A prepared meeting once set as auto-start, will automatically start that meeting when services restart, or when devices power on with no prepared meeting running.
See Also

Reference

IPrepareMeeting Interface


IPrepareMeeting Events

The IPrepareMeeting type exposes the following members.

Events
 | Name | Description
Public event | AutoStartMeetingIdChanged | Occurs when a meeting has been set as auto-start.
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | MeetingCreated | Occurs when a meeting has been created.
Public event | MeetingDeleted | Occurs when a meeting has been deleted.
Public event | MeetingUpdated | Occurs when a meeting has been updated.
Top
See Also

Reference

IPrepareMeeting Interface


IPrepareMeeting.AutoStartMeetingIdChanged Event

IPrepareMeetingAutoStartMeetingIdChanged Event

Occurs when a meeting has been set as auto-start.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<Guid>> AutoStartMeetingIdChanged
Event AutoStartMeetingIdChanged As EventHandler(Of ApiEventArgs(Of Guid))
 event EventHandler<ApiEventArgs<Guid>^>^ AutoStartMeetingIdChanged {
    void add (EventHandler<ApiEventArgs<Guid>^>^ value);
    void remove (EventHandler<ApiEventArgs<Guid>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Guid
See Also

Reference

IPrepareMeeting Interface


IPrepareMeeting.CapabilitiesChanged Event

IPrepareMeetingCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IPrepareMeeting Interface


IPrepareMeeting.MeetingCreated Event

IPrepareMeetingMeetingCreated Event

Occurs when a meeting has been created.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmMeetingPreparationInfo>> MeetingCreated
Event MeetingCreated As EventHandler(Of ApiEventArgs(Of DcnmMeetingPreparationInfo))
 event EventHandler<ApiEventArgs<DcnmMeetingPreparationInfo^>^>^ MeetingCreated {
    void add (EventHandler<ApiEventArgs<DcnmMeetingPreparationInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmMeetingPreparationInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmMeetingPreparationInfo
See Also

Reference

IPrepareMeeting Interface


IPrepareMeeting.MeetingDeleted Event

IPrepareMeetingMeetingDeleted Event

Occurs when a meeting has been deleted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<Guid>> MeetingDeleted
Event MeetingDeleted As EventHandler(Of ApiEventArgs(Of Guid))
 event EventHandler<ApiEventArgs<Guid>^>^ MeetingDeleted {
    void add (EventHandler<ApiEventArgs<Guid>^>^ value);
    void remove (EventHandler<ApiEventArgs<Guid>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Guid
See Also

Reference

IPrepareMeeting Interface


IPrepareMeeting.MeetingUpdated Event

IPrepareMeetingMeetingUpdated Event

Occurs when a meeting has been updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmMeetingPreparationInfo>> MeetingUpdated
Event MeetingUpdated As EventHandler(Of ApiEventArgs(Of DcnmMeetingPreparationInfo))
 event EventHandler<ApiEventArgs<DcnmMeetingPreparationInfo^>^>^ MeetingUpdated {
    void add (EventHandler<ApiEventArgs<DcnmMeetingPreparationInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmMeetingPreparationInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmMeetingPreparationInfo
See Also

Reference

IPrepareMeeting Interface


IPrepareParticipant Interface

Note: This API is now obsolete.

Defines the interface for preparing participants

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The IPrepareParticipant API interface is deprecated; please use IPrepareParticipant2 instead.")]
public interface IPrepareParticipant : IDisposable
<ObsoleteAttribute("The IPrepareParticipant API interface is deprecated; please use IPrepareParticipant2 instead.")>
Public Interface IPrepareParticipant
    Inherits IDisposable
[ObsoleteAttribute(L"The IPrepareParticipant API interface is deprecated; please use IPrepareParticipant2 instead.")]
public interface class IPrepareParticipant : IDisposable

The IPrepareParticipant type exposes the following members.

Properties
 | Name | Description
Public property | CanConfigureScreenLineFormat | Obsolete. Indicates whether the user is able to configure screen line format.
Public property | CanPrepareParticipants | Obsolete. Indicates whether the user is able to prepare participants.
Top
Methods
 | Name | Description
Public method | AssignParticipantsToSeatsAsync | Obsolete. Assign participants to the given seat.
Public method | DeleteParticipantsAsync | Obsolete. Deletes prepared participants.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RegisterParticipantsAsync | Obsolete. Registers participants with the given participant information. If DcnmParticipantPreparationInfo.UserId is Empty, then it creates a new person and registers as a participant. Otherwise it registers participants with the given information but the person information will not be updated.
Public method | RetrieveParticipantsForMeetingAsync | Obsolete. Retrieves the participants and information from the system.
Public method | RetrieveScreenLineFormatAsync | Obsolete. Retrieves current screen line format.
Public method | UnassignParticipantsToSeatAsync | Obsolete. Unassigns participants from their seat.
Public method | UpdateParticipantsAsync | Obsolete. Updates prepared participants with the given participants information.
Public method | UpdateScreenLineFormatAsync | Obsolete. Updates screen line format.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Obsolete. Occurs when the capabilities of the API change.
Public event | ParticipantsDeleted | Obsolete. Occurs when participants are deleted.
Public event | ParticipantsRegistered | Obsolete. Occurs when participants are registered.
Public event | ParticipantsUpdated | Obsolete. Occurs when participants are updated.
Public event | ScreenLineFormatUpdated | Obsolete. Occurs when screen line format is updated.
Public event | ScreenLineFormatValidationFailed | Obsolete. Occurs when screen line format validation failed.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IPrepareParticipant Properties

The IPrepareParticipant type exposes the following members.

Properties
 | Name | Description
Public property | CanConfigureScreenLineFormat | Obsolete. Indicates whether the user is able to configure screen line format.
Public property | CanPrepareParticipants | Obsolete. Indicates whether the user is able to prepare participants.
Top
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant.CanConfigureScreenLineFormat Property

IPrepareParticipantCanConfigureScreenLineFormat Property

Note: This API is now obsolete.

Indicates whether the user is able to configure screen line format.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The CanConfigureScreenLineFormat property is deprecated; please use IPrepareParticipant2.CanConfigureScreenLineFormat instead.")]
bool CanConfigureScreenLineFormat { get; }
<ObsoleteAttribute("The CanConfigureScreenLineFormat property is deprecated; please use IPrepareParticipant2.CanConfigureScreenLineFormat instead.")>
ReadOnly Property CanConfigureScreenLineFormat As Boolean
    Get
[ObsoleteAttribute(L"The CanConfigureScreenLineFormat property is deprecated; please use IPrepareParticipant2.CanConfigureScreenLineFormat instead.")]
property bool CanConfigureScreenLineFormat {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • User right: Configure system.
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant.CanPrepareParticipants Property

IPrepareParticipantCanPrepareParticipants Property

Note: This API is now obsolete.

Indicates whether the user is able to prepare participants.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The CanPrepareParticipants property is deprecated; please use IPrepareParticipant2.CanPrepareParticipants instead.")]
bool CanPrepareParticipants { get; }
<ObsoleteAttribute("The CanPrepareParticipants property is deprecated; please use IPrepareParticipant2.CanPrepareParticipants instead.")>
ReadOnly Property CanPrepareParticipants As Boolean
    Get
[ObsoleteAttribute(L"The CanPrepareParticipants property is deprecated; please use IPrepareParticipant2.CanPrepareParticipants instead.")]
property bool CanPrepareParticipants {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Meeting preparation and management.
  • Functional license: Participant Database.
  • User right: Prepare meeting and agenda.
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant Methods

The IPrepareParticipant type exposes the following members.

Methods
 | Name | Description
Public method | AssignParticipantsToSeatsAsync | Obsolete. Assign participants to the given seat.
Public method | DeleteParticipantsAsync | Obsolete. Deletes prepared participants.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RegisterParticipantsAsync | Obsolete. Registers participants with the given participant information. If DcnmParticipantPreparationInfo.UserId is Empty, then it creates a new person and registers as a participant. Otherwise it registers participants with the given information but the person information will not be updated.
Public method | RetrieveParticipantsForMeetingAsync | Obsolete. Retrieves the participants and information from the system.
Public method | RetrieveScreenLineFormatAsync | Obsolete. Retrieves current screen line format.
Public method | UnassignParticipantsToSeatAsync | Obsolete. Unassigns participants from their seat.
Public method | UpdateParticipantsAsync | Obsolete. Updates prepared participants with the given participants information.
Public method | UpdateScreenLineFormatAsync | Obsolete. Updates screen line format.
Top
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant.AssignParticipantsToSeatsAsync Method

IPrepareParticipantAssignParticipantsToSeatsAsync Method

Note: This API is now obsolete.

Assign participants to the given seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The AssignParticipantsToSeatsAsync method is deprecated; please use IPrepareParticipant2.AssignParticipantsToSeatsAsync instead.")]
Task<bool> AssignParticipantsToSeatsAsync(
    IList<DcnmParticipantSeatAssignmentInfo> participantInfos,
    Action<Task<bool>> onFinish = null
)
<ObsoleteAttribute("The AssignParticipantsToSeatsAsync method is deprecated; please use IPrepareParticipant2.AssignParticipantsToSeatsAsync instead.")>
Function AssignParticipantsToSeatsAsync (
    participantInfos As IList(Of DcnmParticipantSeatAssignmentInfo),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
[ObsoleteAttribute(L"The AssignParticipantsToSeatsAsync method is deprecated; please use IPrepareParticipant2.AssignParticipantsToSeatsAsync instead.")]
Task<bool>^ AssignParticipantsToSeatsAsync(
    IList<DcnmParticipantSeatAssignmentInfo^>^ participantInfos,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantInfos
Type: System.Collections.GenericIList DcnmParticipantSeatAssignmentInfo
The list of participant / seat assignments.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the participant to seat assignment . The 'Result' property of the task is true if assigning participant to seat succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participant infos are null.
Remarks
Requires:
  • CanPrepareParticipants
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant.DeleteParticipantsAsync Method

IPrepareParticipantDeleteParticipantsAsync Method

Note: This API is now obsolete.

Deletes prepared participants.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The DeleteParticipantsAsync method is deprecated; please use IPrepareParticipant2.DeleteParticipantsAsync instead.")]
Task<bool> DeleteParticipantsAsync(
    IList<Guid> participantIds,
    Action<Task<bool>> onFinish = null
)
<ObsoleteAttribute("The DeleteParticipantsAsync method is deprecated; please use IPrepareParticipant2.DeleteParticipantsAsync instead.")>
Function DeleteParticipantsAsync (
    participantIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
[ObsoleteAttribute(L"The DeleteParticipantsAsync method is deprecated; please use IPrepareParticipant2.DeleteParticipantsAsync instead.")]
Task<bool>^ DeleteParticipantsAsync(
    IList<Guid>^ participantIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantIds
Type: System.Collections.GenericIList Guid
The list of identifiers of the participants to be deleted.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the participant deletion. The 'Result' property of the task is true if deleting participants succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participant ids are null or empty.
Remarks
Requires:
  • CanPrepareParticipants
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant.RegisterParticipantsAsync Method

IPrepareParticipantRegisterParticipantsAsync Method

Note: This API is now obsolete.

Registers participants with the given participant information. If DcnmParticipantPreparationInfo.UserId is Empty, then it creates a new person and registers as a participant. Otherwise it registers participants with the given information but the person information will not be updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The RegisterParticipantsAsync method is deprecated; please use IPrepareParticipant2.RegisterParticipantsAsync instead.")]
Task<bool> RegisterParticipantsAsync(
    IList<DcnmParticipantPreparationInfo> participantInfos,
    Action<Task<bool>> onFinish = null
)
<ObsoleteAttribute("The RegisterParticipantsAsync method is deprecated; please use IPrepareParticipant2.RegisterParticipantsAsync instead.")>
Function RegisterParticipantsAsync (
    participantInfos As IList(Of DcnmParticipantPreparationInfo),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
[ObsoleteAttribute(L"The RegisterParticipantsAsync method is deprecated; please use IPrepareParticipant2.RegisterParticipantsAsync instead.")]
Task<bool>^ RegisterParticipantsAsync(
    IList<DcnmParticipantPreparationInfo^>^ participantInfos,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantInfos
Type: System.Collections.GenericIList DcnmParticipantPreparationInfo
The list of participant informations.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the participants registration. The 'Result' property of the task is true if registering participant succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participant infos are null.
Remarks
Requires:
  • CanPrepareParticipants
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant.RetrieveParticipantsForMeetingAsync Method

IPrepareParticipantRetrieveParticipantsForMeetingAsync Method

Bosch Logo

Note: This API is now obsolete.

Retrieves the participants and information from the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The RetrieveParticipantsForMeetingAsync method is deprecated; please use IPrepareParticipant2.RetrieveParticipantsForMeetingAsync instead.")]
Task<IList<DcnmParticipantPreparationInfo>> RetrieveParticipantsForMeetingAsync(
    Guid meetingId,
    Action<Task<IList<DcnmParticipantPreparationInfo>>> onFinish = null
)
<ObsoleteAttribute("The RetrieveParticipantsForMeetingAsync method is deprecated; please use IPrepareParticipant2.RetrieveParticipantsForMeetingAsync instead.")>
Function RetrieveParticipantsForMeetingAsync (
    meetingId As Guid,
    Optional onFinish As Action(Of Task(Of IList(Of DcnmParticipantPreparationInfo))) = Nothing
) As Task(Of IList(Of DcnmParticipantPreparationInfo))
[ObsoleteAttribute(L"The RetrieveParticipantsForMeetingAsync method is deprecated; please use IPrepareParticipant2.RetrieveParticipantsForMeetingAsync instead.")]
Task<IList<DcnmParticipantPreparationInfo^>^>^ RetrieveParticipantsForMeetingAsync(
    Guid meetingId,
    Action<Task<IList<DcnmParticipantPreparationInfo^>^>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The meeting for which to retrieve the participants
onFinish (Optional)
Type: SystemAction Task IList DcnmParticipantPreparationInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmParticipantPreparationInfo
Task processing the participant retrieval. The 'Result' property of the task holds the retrieved participants. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If meeting id is empty.
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant.RetrieveScreenLineFormatAsync Method

IPrepareParticipantRetrieveScreenLineFormatAsync Method

Note: This API is now obsolete.

Retrieves current screen line format.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The RetrieveScreenLineFormatAsync method is deprecated; please use IPrepareParticipant2.RetrieveScreenLineFormatAsync instead.")]
Task<string> RetrieveScreenLineFormatAsync(
    Action<Task<string>> onFinish = null
)
<ObsoleteAttribute("The RetrieveScreenLineFormatAsync method is deprecated; please use IPrepareParticipant2.RetrieveScreenLineFormatAsync instead.")>
Function RetrieveScreenLineFormatAsync (
    Optional onFinish As Action(Of Task(Of String)) = Nothing
) As Task(Of String)
[ObsoleteAttribute(L"The RetrieveScreenLineFormatAsync method is deprecated; please use IPrepareParticipant2.RetrieveScreenLineFormatAsync instead.")]
Task<String^>^ RetrieveScreenLineFormatAsync(
    Action<Task<String^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task String
Optional action for asynchronous handling of the result.

Return Value

Type: Task String
Task processing the screen line retrieval. The 'Result' property of the task contains the retrieved screen line. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant.UnassignParticipantsToSeatAsync Method

IPrepareParticipantUnassignParticipantsToSeatAsync Method

Note: This API is now obsolete.

Unassigns participants from their seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The UnassignParticipantsToSeatAsync method is deprecated; please use IPrepareParticipant2.UnassignParticipantsToSeatAsync instead.")]
Task<bool> UnassignParticipantsToSeatAsync(
    IList<Guid> participantIds,
    Action<Task<bool>> onFinish = null
)
<ObsoleteAttribute("The UnassignParticipantsToSeatAsync method is deprecated; please use IPrepareParticipant2.UnassignParticipantsToSeatAsync instead.")>
Function UnassignParticipantsToSeatAsync (
    participantIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
[ObsoleteAttribute(L"The UnassignParticipantsToSeatAsync method is deprecated; please use IPrepareParticipant2.UnassignParticipantsToSeatAsync instead.")]
Task<bool>^ UnassignParticipantsToSeatAsync(
    IList<Guid>^ participantIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantIds
Type: System.Collections.GenericIList Guid
The list of participants to unassign from its seat.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the unassignment . The 'Result' property of the task is true if unassigning participant from seat succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participant ids are null or empty.
Remarks
Requires:
  • CanPrepareParticipants
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant.UpdateParticipantsAsync Method

IPrepareParticipantUpdateParticipantsAsync Method

Note: This API is now obsolete.

Updates prepared participants with the given participants information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The UpdateParticipantsAsync method is deprecated; please use IPrepareParticipant2.UpdateParticipantsAsync instead.")]
Task<bool> UpdateParticipantsAsync(
    IList<DcnmParticipantPreparationInfo> participantInfos,
    Action<Task<bool>> onFinish = null
)
<ObsoleteAttribute("The UpdateParticipantsAsync method is deprecated; please use IPrepareParticipant2.UpdateParticipantsAsync instead.")>
Function UpdateParticipantsAsync (
    participantInfos As IList(Of DcnmParticipantPreparationInfo),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
[ObsoleteAttribute(L"The UpdateParticipantsAsync method is deprecated; please use IPrepareParticipant2.UpdateParticipantsAsync instead.")]
Task<bool>^ UpdateParticipantsAsync(
    IList<DcnmParticipantPreparationInfo^>^ participantInfos,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantInfos
Type: System.Collections.GenericIList DcnmParticipantPreparationInfo
The list of information of the updated participants.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the participant update. The 'Result' property of the task is true if updating participant succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participant infos are null.
Remarks
Requires:
  • CanPrepareParticipants
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant.UpdateScreenLineFormatAsync Method

IPrepareParticipantUpdateScreenLineFormatAsync Method

Note: This API is now obsolete.

Updates screen line format.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The UpdateScreenLineFormatAsync method is deprecated; please use IPrepareParticipant2.UpdateScreenLineFormatAsync instead.")]
Task<bool> UpdateScreenLineFormatAsync(
    string screenLine,
    Action<Task<bool>> onFinish = null
)
<ObsoleteAttribute("The UpdateScreenLineFormatAsync method is deprecated; please use IPrepareParticipant2.UpdateScreenLineFormatAsync instead.")>
Function UpdateScreenLineFormatAsync (
    screenLine As String,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
[ObsoleteAttribute(L"The UpdateScreenLineFormatAsync method is deprecated; please use IPrepareParticipant2.UpdateScreenLineFormatAsync instead.")]
Task<bool>^ UpdateScreenLineFormatAsync(
    String^ screenLine,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

screenLine
Type: SystemString
The screen line format to update with.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the screen line update. The 'Result' property of the task is true if updating the screen line succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the screen line is null or empty.
Remarks
Requires:
  • CanConfigureScreenLineFormat
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant Events

The IPrepareParticipant type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Obsolete. Occurs when the capabilities of the API change.
Public event | ParticipantsDeleted | Obsolete. Occurs when participants are deleted.
Public event | ParticipantsRegistered | Obsolete. Occurs when participants are registered.
Public event | ParticipantsUpdated | Obsolete. Occurs when participants are updated.
Public event | ScreenLineFormatUpdated | Obsolete. Occurs when screen line format is updated.
Public event | ScreenLineFormatValidationFailed | Obsolete. Occurs when screen line format validation failed.
Top
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant.CapabilitiesChanged Event

IPrepareParticipantCapabilitiesChanged Event

Note: This API is now obsolete.

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The CapabilitiesChanged event handler is deprecated; please use IPrepareParticipant2.CapabilitiesChanged instead.")]
event EventHandler CapabilitiesChanged
<ObsoleteAttribute("The CapabilitiesChanged event handler is deprecated; please use IPrepareParticipant2.CapabilitiesChanged instead.")>
Event CapabilitiesChanged As EventHandler
[ObsoleteAttribute(L"The CapabilitiesChanged event handler is deprecated; please use IPrepareParticipant2.CapabilitiesChanged instead.")]
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant.ParticipantsDeleted Event

IPrepareParticipantParticipantsDeleted Event

Note: This API is now obsolete.

Occurs when participants are deleted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The ParticipantsDeleted event handler is deprecated; please use IPrepareParticipant2.ParticipantsDeleted instead.")]
event EventHandler<ApiEventArgs<IList<Guid>>> ParticipantsDeleted
<ObsoleteAttribute("The ParticipantsDeleted event handler is deprecated; please use IPrepareParticipant2.ParticipantsDeleted instead.")>
Event ParticipantsDeleted As EventHandler(Of ApiEventArgs(Of IList(Of Guid)))
[ObsoleteAttribute(L"The ParticipantsDeleted event handler is deprecated; please use IPrepareParticipant2.ParticipantsDeleted instead.")]
 event EventHandler<ApiEventArgs<IList<Guid>^>^>^ ParticipantsDeleted {
    void add (EventHandler<ApiEventArgs<IList<Guid>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<Guid>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList Guid
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant.ParticipantsRegistered Event

IPrepareParticipantParticipantsRegistered Event

Note: This API is now obsolete.

Occurs when participants are registered.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The ParticipantsRegistered event handler is deprecated; please use IPrepareParticipant2.ParticipantsRegistered instead.")]
event EventHandler<ApiEventArgs<IList<DcnmParticipantPreparationInfo>>> ParticipantsRegistered
<ObsoleteAttribute("The ParticipantsRegistered event handler is deprecated; please use IPrepareParticipant2.ParticipantsRegistered instead.")>
Event ParticipantsRegistered As EventHandler(Of ApiEventArgs(Of IList(Of DcnmParticipantPreparationInfo)))
[ObsoleteAttribute(L"The ParticipantsRegistered event handler is deprecated; please use IPrepareParticipant2.ParticipantsRegistered instead.")]
 event EventHandler<ApiEventArgs<IList<DcnmParticipantPreparationInfo^>^>^>^ ParticipantsRegistered {
    void add (EventHandler<ApiEventArgs<IList<DcnmParticipantPreparationInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmParticipantPreparationInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmParticipantPreparationInfo
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant.ParticipantsUpdated Event

IPrepareParticipantParticipantsUpdated Event

Note: This API is now obsolete.

Occurs when participants are updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The ParticipantsUpdated event handler is deprecated; please use IPrepareParticipant2.ParticipantsUpdated instead.")]
event EventHandler<ApiEventArgs<IList<DcnmParticipantPreparationInfo>>> ParticipantsUpdated
<ObsoleteAttribute("The ParticipantsUpdated event handler is deprecated; please use IPrepareParticipant2.ParticipantsUpdated instead.")>
Event ParticipantsUpdated As EventHandler(Of ApiEventArgs(Of IList(Of DcnmParticipantPreparationInfo)))
[ObsoleteAttribute(L"The ParticipantsUpdated event handler is deprecated; please use IPrepareParticipant2.ParticipantsUpdated instead.")]
 event EventHandler<ApiEventArgs<IList<DcnmParticipantPreparationInfo^>^>^>^ ParticipantsUpdated {
    void add (EventHandler<ApiEventArgs<IList<DcnmParticipantPreparationInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmParticipantPreparationInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmParticipantPreparationInfo
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant.ScreenLineFormatUpdated Event

IPrepareParticipantScreenLineFormatUpdated Event

Note: This API is now obsolete.

Occurs when screen line format is updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The ScreenLineFormatUpdated event handler is deprecated; please use IPrepareParticipant2.ScreenLineFormatUpdated instead.")]
event EventHandler<ApiEventArgs<string>> ScreenLineFormatUpdated
<ObsoleteAttribute("The ScreenLineFormatUpdated event handler is deprecated; please use IPrepareParticipant2.ScreenLineFormatUpdated instead.")>
Event ScreenLineFormatUpdated As EventHandler(Of ApiEventArgs(Of String))
[ObsoleteAttribute(L"The ScreenLineFormatUpdated event handler is deprecated; please use IPrepareParticipant2.ScreenLineFormatUpdated instead.")]
 event EventHandler<ApiEventArgs<String^>^>^ ScreenLineFormatUpdated {
    void add (EventHandler<ApiEventArgs<String^>^>^ value);
    void remove (EventHandler<ApiEventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs String
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant.ScreenLineFormatValidationFailed Event

IPrepareParticipantScreenLineFormatValidationFailed Event

Note: This API is now obsolete.

Occurs when screen line format validation failed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The ScreenLineFormatValidationFailed event handler is deprecated; please use IPrepareParticipant2.ScreenLineFormatValidationFailed instead.")]
event EventHandler<ApiEventArgs<string>> ScreenLineFormatValidationFailed
<ObsoleteAttribute("The ScreenLineFormatValidationFailed event handler is deprecated; please use IPrepareParticipant2.ScreenLineFormatValidationFailed instead.")>
Event ScreenLineFormatValidationFailed As EventHandler(Of ApiEventArgs(Of String))
[ObsoleteAttribute(L"The ScreenLineFormatValidationFailed event handler is deprecated; please use IPrepareParticipant2.ScreenLineFormatValidationFailed instead.")]
 event EventHandler<ApiEventArgs<String^>^>^ ScreenLineFormatValidationFailed {
    void add (EventHandler<ApiEventArgs<String^>^>^ value);
    void remove (EventHandler<ApiEventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs String
See Also

Reference

IPrepareParticipant Interface


IPrepareParticipant2 Interface

Defines the interface for assigning participant , assigning seat to participant, un assigning seat from participant , retrieving and updating screen line format for participants.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IPrepareParticipant2 : IDisposable
Public Interface IPrepareParticipant2
    Inherits IDisposable
public interface class IPrepareParticipant2 : IDisposable

The IPrepareParticipant2 type exposes the following members.

Properties
 | Name | Description
Public property | CanConfigureScreenLineFormat | Indicates whether the user is able to configure screen line format.
Public property | CanPrepareParticipants | Indicates whether the user is able to prepare participants.
Top
Methods
 | Name | Description
Public method | AssignParticipantsToSeatsAsync | Assign participants to the given seat.
Public method | DeleteParticipantsAsync | Deletes prepared participants.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RegisterParticipantsAsync | Registers participants with the given participant details to a meeting. Person id should belong to participant user group id. Before registering a person to meeting person must be created.
Public method | RetrieveParticipantsForMeetingAsync | Retrieves the participants and person information from the system.
Public method | RetrieveScreenLineFormatAsync | Retrieves current screen line format.
Public method | UnassignParticipantsToSeatAsync | Unassigns participants from their seat.
Public method | UpdateParticipantsAsync | Updates prepared participants with the given participants information.
Public method | UpdateScreenLineFormatAsync | Updates screen line format.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | ParticipantsDeleted | Occurs when participants are deleted.
Public event | ParticipantsRegistered | Occurs when participants are registered.
Public event | ParticipantsUpdated | Occurs when participants are updated.
Public event | ScreenLineFormatUpdated | Occurs when screen line format is updated.
Public event | ScreenLineFormatValidationFailed | Occurs when screen line format validation failed.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IPrepareParticipant2 Properties

The IPrepareParticipant2 type exposes the following members.

Properties
 | Name | Description
Public property | CanConfigureScreenLineFormat | Indicates whether the user is able to configure screen line format.
Public property | CanPrepareParticipants | Indicates whether the user is able to prepare participants.
Top
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2.CanConfigureScreenLineFormat Property

IPrepareParticipant2CanConfigureScreenLineFormat Property

Indicates whether the user is able to configure screen line format.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanConfigureScreenLineFormat { get; }
ReadOnly Property CanConfigureScreenLineFormat As Boolean
    Get
property bool CanConfigureScreenLineFormat {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • User right: Configure system.
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2.CanPrepareParticipants Property

IPrepareParticipant2CanPrepareParticipants Property

Indicates whether the user is able to prepare participants.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanPrepareParticipants { get; }
ReadOnly Property CanPrepareParticipants As Boolean
    Get
property bool CanPrepareParticipants {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Meeting preparation and management.
  • Functional license: Participant Database.
  • User right: Prepare meeting and agenda.
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2 Methods

The IPrepareParticipant2 type exposes the following members.

Methods
 | Name | Description
Public method | AssignParticipantsToSeatsAsync | Assign participants to the given seat.
Public method | DeleteParticipantsAsync | Deletes prepared participants.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RegisterParticipantsAsync | Registers participants with the given participant details to a meeting. Person id should belong to participant user group id. Before registering a person to meeting person must be created.
Public method | RetrieveParticipantsForMeetingAsync | Retrieves the participants and person information from the system.
Public method | RetrieveScreenLineFormatAsync | Retrieves current screen line format.
Public method | UnassignParticipantsToSeatAsync | Unassigns participants from their seat.
Public method | UpdateParticipantsAsync | Updates prepared participants with the given participants information.
Public method | UpdateScreenLineFormatAsync | Updates screen line format.
Top
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2.AssignParticipantsToSeatsAsync Method

IPrepareParticipant2AssignParticipantsToSeatsAsync Method

Assign participants to the given seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> AssignParticipantsToSeatsAsync(
    IList<DcnmParticipantSeatAssignmentInfo> participantInfos,
    Action<Task<bool>> onFinish = null
)
Function AssignParticipantsToSeatsAsync (
    participantInfos As IList(Of DcnmParticipantSeatAssignmentInfo),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ AssignParticipantsToSeatsAsync(
    IList<DcnmParticipantSeatAssignmentInfo^>^ participantInfos,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantInfos
Type: System.Collections.GenericIList DcnmParticipantSeatAssignmentInfo
The list of participant / seat assignments.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the participant to seat assignment . The 'Result' property of the task is true if assigning participant to seat succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participant infos are null.
Remarks
Requires:
  • CanPrepareParticipants
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2.DeleteParticipantsAsync Method

IPrepareParticipant2DeleteParticipantsAsync Method

Deletes prepared participants.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeleteParticipantsAsync(
    IList<Guid> participantIds,
    Action<Task<bool>> onFinish = null
)
Function DeleteParticipantsAsync (
    participantIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeleteParticipantsAsync(
    IList<Guid>^ participantIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantIds
Type: System.Collections.GenericIList Guid
The list of identifiers of the participants to be deleted.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the participant deletion. The 'Result' property of the task is true if deleting participants succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participant ids are null or empty.
Remarks
Requires:
  • CanPrepareParticipants
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2.RegisterParticipantsAsync Method

IPrepareParticipant2RegisterParticipantsAsync Method

Registers participants with the given participant details to a meeting. Person id should belong to participant user group id. Before registering a person to meeting person must be created.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmParticipantAndUserInfo>> RegisterParticipantsAsync(
    IList<DcnmParticipantPreparationInfo2> participants,
    Action<Task<IList<DcnmParticipantAndUserInfo>>> onFinish = null
)
Function RegisterParticipantsAsync (
    participants As IList(Of DcnmParticipantPreparationInfo2),
    Optional onFinish As Action(Of Task(Of IList(Of DcnmParticipantAndUserInfo))) = Nothing
) As Task(Of IList(Of DcnmParticipantAndUserInfo))
Task<IList<DcnmParticipantAndUserInfo^>^>^ RegisterParticipantsAsync(
    IList<DcnmParticipantPreparationInfo2^>^ participants,
    Action<Task<IList<DcnmParticipantAndUserInfo^>^>^>^ onFinish = nullptr
)

Parameters

participants
Type: System.Collections.GenericIList DcnmParticipantPreparationInfo2
The list of participant details to be registered.
onFinish (Optional)
Type: SystemAction Task IList DcnmParticipantAndUserInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmParticipantAndUserInfo
Task processing the registering participant and user info list. The 'Result' property of the task is list of successfully registered participant. If multiple participant are regsitered at once, and one of them fails, then the size of the output list is smaller than the size of the input list. If no participant is registered then this function returns empty list. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participant infos are null.
Remarks
Requires:
  • CanPrepareParticipants
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2.RetrieveParticipantsForMeetingAsync Method

IPrepareParticipant2RetrieveParticipantsForMeetingAsync Method

Bosch Logo
Retrieves the participants and person information from the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmParticipantAndUserInfo>> RetrieveParticipantsForMeetingAsync(
    Guid meetingId,
    Action<Task<IList<DcnmParticipantAndUserInfo>>> onFinish = null
)
Function RetrieveParticipantsForMeetingAsync (
    meetingId As Guid,
    Optional onFinish As Action(Of Task(Of IList(Of DcnmParticipantAndUserInfo))) = Nothing
) As Task(Of IList(Of DcnmParticipantAndUserInfo))
Task<IList<DcnmParticipantAndUserInfo^>^>^ RetrieveParticipantsForMeetingAsync(
    Guid meetingId,
    Action<Task<IList<DcnmParticipantAndUserInfo^>^>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
The meeting for which to retrieve the participants
onFinish (Optional)
Type: SystemAction Task IList DcnmParticipantAndUserInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmParticipantAndUserInfo
Task processing the participant retrieval. The 'Result' property of the task holds the retrieved participants. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If meeting id is empty.
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2.RetrieveScreenLineFormatAsync Method

IPrepareParticipant2RetrieveScreenLineFormatAsync Method

Retrieves current screen line format.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<string> RetrieveScreenLineFormatAsync(
    Action<Task<string>> onFinish = null
)
Function RetrieveScreenLineFormatAsync (
    Optional onFinish As Action(Of Task(Of String)) = Nothing
) As Task(Of String)
Task<String^>^ RetrieveScreenLineFormatAsync(
    Action<Task<String^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task String
Optional action for asynchronous handling of the result.

Return Value

Type: Task String
Task processing the screen line retrieval. The 'Result' property of the task contains the retrieved screen line. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2.UnassignParticipantsToSeatAsync Method

IPrepareParticipant2UnassignParticipantsToSeatAsync Method

Unassigns participants from their seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UnassignParticipantsToSeatAsync(
    IList<Guid> participantIds,
    Action<Task<bool>> onFinish = null
)
Function UnassignParticipantsToSeatAsync (
    participantIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UnassignParticipantsToSeatAsync(
    IList<Guid>^ participantIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantIds
Type: System.Collections.GenericIList Guid
The list of participants to unassign from its seat.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the unassignment . The 'Result' property of the task is true if unassigning participant from seat succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participant ids are null or empty.
Remarks
Requires:
  • CanPrepareParticipants
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2.UpdateParticipantsAsync Method

IPrepareParticipant2UpdateParticipantsAsync Method

Updates prepared participants with the given participants information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateParticipantsAsync(
    IList<DcnmParticipantPreparationInfo2> participantInfos,
    Action<Task<bool>> onFinish = null
)
Function UpdateParticipantsAsync (
    participantInfos As IList(Of DcnmParticipantPreparationInfo2),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateParticipantsAsync(
    IList<DcnmParticipantPreparationInfo2^>^ participantInfos,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

participantInfos
Type: System.Collections.GenericIList DcnmParticipantPreparationInfo2
The list of information of participants to update.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the participant update. The 'Result' property of the task is true if updating participant succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If participant infos are null.
Remarks
Requires:
  • CanPrepareParticipants
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2.UpdateScreenLineFormatAsync Method

IPrepareParticipant2UpdateScreenLineFormatAsync Method

Updates screen line format.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateScreenLineFormatAsync(
    string screenLine,
    Action<Task<bool>> onFinish = null
)
Function UpdateScreenLineFormatAsync (
    screenLine As String,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateScreenLineFormatAsync(
    String^ screenLine,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

screenLine
Type: SystemString
The screen line format to update with.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the screen line update. The 'Result' property of the task is true if updating the screen line succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the screen line is null or empty.
Remarks
Requires:
  • CanConfigureScreenLineFormat
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2 Events

The IPrepareParticipant2 type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | ParticipantsDeleted | Occurs when participants are deleted.
Public event | ParticipantsRegistered | Occurs when participants are registered.
Public event | ParticipantsUpdated | Occurs when participants are updated.
Public event | ScreenLineFormatUpdated | Occurs when screen line format is updated.
Public event | ScreenLineFormatValidationFailed | Occurs when screen line format validation failed.
Top
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2.CapabilitiesChanged Event

IPrepareParticipant2CapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2.ParticipantsDeleted Event

IPrepareParticipant2ParticipantsDeleted Event

Occurs when participants are deleted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<Guid>>> ParticipantsDeleted
Event ParticipantsDeleted As EventHandler(Of ApiEventArgs(Of IList(Of Guid)))
 event EventHandler<ApiEventArgs<IList<Guid>^>^>^ ParticipantsDeleted {
    void add (EventHandler<ApiEventArgs<IList<Guid>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<Guid>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList Guid
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2.ParticipantsRegistered Event

IPrepareParticipant2ParticipantsRegistered Event

Occurs when participants are registered.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmParticipantAndUserInfo>>> ParticipantsRegistered
Event ParticipantsRegistered As EventHandler(Of ApiEventArgs(Of IList(Of DcnmParticipantAndUserInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmParticipantAndUserInfo^>^>^>^ ParticipantsRegistered {
    void add (EventHandler<ApiEventArgs<IList<DcnmParticipantAndUserInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmParticipantAndUserInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmParticipantAndUserInfo
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2.ParticipantsUpdated Event

IPrepareParticipant2ParticipantsUpdated Event

Occurs when participants are updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmParticipantAndUserInfo>>> ParticipantsUpdated
Event ParticipantsUpdated As EventHandler(Of ApiEventArgs(Of IList(Of DcnmParticipantAndUserInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmParticipantAndUserInfo^>^>^>^ ParticipantsUpdated {
    void add (EventHandler<ApiEventArgs<IList<DcnmParticipantAndUserInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmParticipantAndUserInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmParticipantAndUserInfo
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2.ScreenLineFormatUpdated Event

IPrepareParticipant2ScreenLineFormatUpdated Event

Occurs when screen line format is updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<string>> ScreenLineFormatUpdated
Event ScreenLineFormatUpdated As EventHandler(Of ApiEventArgs(Of String))
 event EventHandler<ApiEventArgs<String^>^>^ ScreenLineFormatUpdated {
    void add (EventHandler<ApiEventArgs<String^>^>^ value);
    void remove (EventHandler<ApiEventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs String
See Also

Reference

IPrepareParticipant2 Interface


IPrepareParticipant2.ScreenLineFormatValidationFailed Event

IPrepareParticipant2ScreenLineFormatValidationFailed Event

Occurs when screen line format validation failed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<string>> ScreenLineFormatValidationFailed
Event ScreenLineFormatValidationFailed As EventHandler(Of ApiEventArgs(Of String))
 event EventHandler<ApiEventArgs<String^>^>^ ScreenLineFormatValidationFailed {
    void add (EventHandler<ApiEventArgs<String^>^>^ value);
    void remove (EventHandler<ApiEventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs String
See Also

Reference

IPrepareParticipant2 Interface


IPreparePerson Interface

Defines the interface to register users.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IPreparePerson : IDisposable
Public Interface IPreparePerson
    Inherits IDisposable
public interface class IPreparePerson : IDisposable

The IPreparePerson type exposes the following members.

Properties
 | Name | Description
Public property | CanRegisterPerson | Indicates whether it is possible to perpare meeting and agenda.
Top
Methods
 | Name | Description
Public method | CheckPersonPasswordAsync | Checks user name and password are correct
Public method | CreatePersonAsync | Obsolete. Creates one or more persons in the system. User group id should be guid of participant user group only otherwise creation operation will fail.
Public method | CreatePersonsAsync | Creates one or more persons in the system. User group id should be guid of participant user group only otherwise creation operation will fail.
Public method | DeletePersonAsync | Deletes one or more persons.
Public method | DeletePersonPictureAsync | Delete person picture.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetPersonAsync | Triggers the request to retrieve all the persons.
Public method | UpdatePersonAsync | Updates the person in the system.. User group id should be guid of participant user group only otherwise update operation will fail.
Public method | UpdatePersonPasswordAsync | Updates the person password in the system..
Public method | UpdatePersonPictureAsync | Updates the person picture.
Public method | UpdatePersonsPinCodeAsync | Updates the person pin code in the system..
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | PersonsAccountUpdated | Occurs when persons account are updated.
Public event | PersonsCreated | Occurs when persons are created.
Public event | PersonsDeleted | Occurs when persons are deleted.
Public event | PersonsUpdated | Occurs when persons are updated.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IPreparePerson Properties

The IPreparePerson type exposes the following members.

Properties
 | Name | Description
Public property | CanRegisterPerson | Indicates whether it is possible to perpare meeting and agenda.
Top
See Also

Reference

IPreparePerson Interface


IPreparePerson.CanRegisterPerson Property

IPreparePersonCanRegisterPerson Property

Indicates whether it is possible to perpare meeting and agenda.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanRegisterPerson { get; }
ReadOnly Property CanRegisterPerson As Boolean
    Get
property bool CanRegisterPerson {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • User right: Prepare meeting and agenda and can
See Also

Reference

IPreparePerson Interface


IPreparePerson Methods

The IPreparePerson type exposes the following members.

Methods
 | Name | Description
Public method | CheckPersonPasswordAsync | Checks user name and password are correct
Public method | CreatePersonAsync | Obsolete. Creates one or more persons in the system. User group id should be guid of participant user group only otherwise creation operation will fail.
Public method | CreatePersonsAsync | Creates one or more persons in the system. User group id should be guid of participant user group only otherwise creation operation will fail.
Public method | DeletePersonAsync | Deletes one or more persons.
Public method | DeletePersonPictureAsync | Delete person picture.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetPersonAsync | Triggers the request to retrieve all the persons.
Public method | UpdatePersonAsync | Updates the person in the system.. User group id should be guid of participant user group only otherwise update operation will fail.
Public method | UpdatePersonPasswordAsync | Updates the person password in the system..
Public method | UpdatePersonPictureAsync | Updates the person picture.
Public method | UpdatePersonsPinCodeAsync | Updates the person pin code in the system..
Top
See Also

Reference

IPreparePerson Interface


IPreparePerson.CheckPersonPasswordAsync Method

IPreparePersonCheckPersonPasswordAsync Method

Checks user name and password are correct

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<DcnmUserSecurityClaimsInfo> CheckPersonPasswordAsync(
    string userId,
    string password,
    Action<Task<DcnmUserSecurityClaimsInfo>> onFinish = null
)
Function CheckPersonPasswordAsync (
    userId As String,
    password As String,
    Optional onFinish As Action(Of Task(Of DcnmUserSecurityClaimsInfo)) = Nothing
) As Task(Of DcnmUserSecurityClaimsInfo)
Task<DcnmUserSecurityClaimsInfo^>^ CheckPersonPasswordAsync(
    String^ userId,
    String^ password,
    Action<Task<DcnmUserSecurityClaimsInfo^>^>^ onFinish = nullptr
)

Parameters

userId
Type: SystemString
The user Id.
password
Type: SystemString
The new password.
onFinish (Optional)
Type: SystemAction Task DcnmUserSecurityClaimsInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task DcnmUserSecurityClaimsInfo
Task processing the user password check. The 'Result' property of the task is true if user id and password are correct, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the list of user info is null.
See Also

Reference

IPreparePerson Interface


IPreparePerson.CreatePersonAsync Method

IPreparePersonCreatePersonAsync Method

Note: This API is now obsolete.

Creates one or more persons in the system. User group id should be guid of participant user group only otherwise creation operation will fail.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The CreatePersonAsync method is deprecated; please use CreatePersonsAsync method instead.")]
Task<bool> CreatePersonAsync(
    IList<DcnmUserAccountPreparationInfo> userAccountInfos,
    Action<Task<bool>> onFinish = null
)
<ObsoleteAttribute("The CreatePersonAsync method is deprecated; please use CreatePersonsAsync method instead.")>
Function CreatePersonAsync (
    userAccountInfos As IList(Of DcnmUserAccountPreparationInfo),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
[ObsoleteAttribute(L"The CreatePersonAsync method is deprecated; please use CreatePersonsAsync method instead.")]
Task<bool>^ CreatePersonAsync(
    IList<DcnmUserAccountPreparationInfo^>^ userAccountInfos,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

userAccountInfos
Type: System.Collections.GenericIList DcnmUserAccountPreparationInfo
The info about the users to be created.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the person creation. The 'Result' property of the task is true if create person succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the list of user info is null.
Remarks
Requires:
  • CanRegisterPerson
See Also

Reference

IPreparePerson Interface


IPreparePerson.CreatePersonsAsync Method

IPreparePersonCreatePersonsAsync Method

Creates one or more persons in the system. User group id should be guid of participant user group only otherwise creation operation will fail.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmUserAccountPreparationInfo>> CreatePersonsAsync(
    IList<DcnmUserAccountPreparationInfo> userAccountInfos,
    Action<Task<IList<DcnmUserAccountPreparationInfo>>> onFinish = null
)
Function CreatePersonsAsync (
    userAccountInfos As IList(Of DcnmUserAccountPreparationInfo),
    Optional onFinish As Action(Of Task(Of IList(Of DcnmUserAccountPreparationInfo))) = Nothing
) As Task(Of IList(Of DcnmUserAccountPreparationInfo))
Task<IList<DcnmUserAccountPreparationInfo^>^>^ CreatePersonsAsync(
    IList<DcnmUserAccountPreparationInfo^>^ userAccountInfos,
    Action<Task<IList<DcnmUserAccountPreparationInfo^>^>^>^ onFinish = nullptr
)

Parameters

userAccountInfos
Type: System.Collections.GenericIList DcnmUserAccountPreparationInfo
The info about the users to be created.
onFinish (Optional)
Type: SystemAction Task IList DcnmUserAccountPreparationInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmUserAccountPreparationInfo
Task processing the person creation. The 'Result' property of the task is list of successfully created persons. If multiple persons are created at once, and one of them fails, then the size of the output list is smaller than the size of the input list. If no person is created then this function returns empty list. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the list of user info is null or email is invalid.
Remarks
Requires:
  • CanRegisterPerson
See Also

Reference

IPreparePerson Interface


IPreparePerson.DeletePersonAsync Method

IPreparePersonDeletePersonAsync Method

Deletes one or more persons.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeletePersonAsync(
    IList<Guid> userIds,
    Action<Task<bool>> onFinish = null
)
Function DeletePersonAsync (
    userIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeletePersonAsync(
    IList<Guid>^ userIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

userIds
Type: System.Collections.GenericIList Guid
The ids of the users to be deleted.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the user deletion. The 'Result' property of the task is true if deleting users succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the list of user ids is null.
Remarks
Requires:
  • CanRegisterPerson
See Also

Reference

IPreparePerson Interface


IPreparePerson.DeletePersonPictureAsync Method

IPreparePersonDeletePersonPictureAsync Method

Delete person picture.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeletePersonPictureAsync(
    Guid personId,
    Action<Task<bool>> onFinish = null
)
Function DeletePersonPictureAsync (
    personId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeletePersonPictureAsync(
    Guid personId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

personId
Type: SystemGuid
The id of the person.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing to delete person image. The 'Result' property of the task is true if deleting person picture succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the list of user ids is null.
Remarks
Requires:
  • CanRegisterPerson
See Also

Reference

IPreparePerson Interface


IPreparePerson.GetPersonAsync Method

IPreparePersonGetPersonAsync Method

Triggers the request to retrieve all the persons.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmUserAccountPreparationInfo>> GetPersonAsync(
    Action<Task<IList<DcnmUserAccountPreparationInfo>>> onFinish = null
)
Function GetPersonAsync (
    Optional onFinish As Action(Of Task(Of IList(Of DcnmUserAccountPreparationInfo))) = Nothing
) As Task(Of IList(Of DcnmUserAccountPreparationInfo))
Task<IList<DcnmUserAccountPreparationInfo^>^>^ GetPersonAsync(
    Action<Task<IList<DcnmUserAccountPreparationInfo^>^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task IList DcnmUserAccountPreparationInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmUserAccountPreparationInfo
Task processing the user retrieval. The 'Result' property of the task holds the retrieved persons. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IPreparePerson Interface


IPreparePerson.UpdatePersonAsync Method

IPreparePersonUpdatePersonAsync Method

Updates the person in the system.. User group id should be guid of participant user group only otherwise update operation will fail.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdatePersonAsync(
    IList<DcnmUserAccountPreparationInfo> userAccountInfos,
    Action<Task<bool>> onFinish = null
)
Function UpdatePersonAsync (
    userAccountInfos As IList(Of DcnmUserAccountPreparationInfo),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdatePersonAsync(
    IList<DcnmUserAccountPreparationInfo^>^ userAccountInfos,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

userAccountInfos
Type: System.Collections.GenericIList DcnmUserAccountPreparationInfo
The info of the persons that are updated.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the user update. The 'Result' property of the task is true if updating persons succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the list of user info is null or email is invalid.
Remarks
Requires:
  • CanRegisterPerson
See Also

Reference

IPreparePerson Interface


IPreparePerson.UpdatePersonPasswordAsync Method

IPreparePersonUpdatePersonPasswordAsync Method

Updates the person password in the system..

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdatePersonPasswordAsync(
    Guid userId,
    string password,
    Action<Task<bool>> onFinish = null
)
Function UpdatePersonPasswordAsync (
    userId As Guid,
    password As String,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdatePersonPasswordAsync(
    Guid userId,
    String^ password,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

userId
Type: SystemGuid
The user Id.
password
Type: SystemString
The new password.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the person password update. The 'Result' property of the task is true if updating person password succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the user id is empty.
Remarks
Requires:
  • CanRegisterPerson
See Also

Reference

IPreparePerson Interface


IPreparePerson.UpdatePersonPictureAsync Method

IPreparePersonUpdatePersonPictureAsync Method

Updates the person picture.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdatePersonPictureAsync(
    Guid personId,
    byte[] personImage,
    Action<Task<bool>> onFinish = null
)
Function UpdatePersonPictureAsync (
    personId As Guid,
    personImage As Byte(),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdatePersonPictureAsync(
    Guid personId,
    array<unsigned char>^ personImage,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

personId
Type: SystemGuid
The id of the person to upload picture .
personImage
Type: SystemByte
The byte array of person image to upload to system.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the person image upload. The 'Result' property of the task is true if uploading picture succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the list of user ids is null.
Remarks
Requires:
  • CanRegisterPerson
See Also

Reference

IPreparePerson Interface


IPreparePerson.UpdatePersonsPinCodeAsync Method

IPreparePersonUpdatePersonsPinCodeAsync Method

Updates the person pin code in the system..

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdatePersonsPinCodeAsync(
    IList<DcnmUserAccountPreparationInfo> usersAccountInfoCollection,
    Action<Task<bool>> onFinish = null
)
Function UpdatePersonsPinCodeAsync (
    usersAccountInfoCollection As IList(Of DcnmUserAccountPreparationInfo),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdatePersonsPinCodeAsync(
    IList<DcnmUserAccountPreparationInfo^>^ usersAccountInfoCollection,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

usersAccountInfoCollection
Type: System.Collections.GenericIList DcnmUserAccountPreparationInfo
The user account info list.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the person pin code update. The 'Result' property of the task is true if updating person pin code succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the user id is empty.
Remarks
Requires:
  • CanRegisterPerson
See Also

Reference

IPreparePerson Interface


IPreparePerson Events

The IPreparePerson type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | PersonsAccountUpdated | Occurs when persons account are updated.
Public event | PersonsCreated | Occurs when persons are created.
Public event | PersonsDeleted | Occurs when persons are deleted.
Public event | PersonsUpdated | Occurs when persons are updated.
Top
See Also

Reference

IPreparePerson Interface


IPreparePerson.CapabilitiesChanged Event

IPreparePersonCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IPreparePerson Interface


IPreparePerson.PersonsAccountUpdated Event

IPreparePersonPersonsAccountUpdated Event

Occurs when persons account are updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmUserAccountPreparationInfo>>> PersonsAccountUpdated
Event PersonsAccountUpdated As EventHandler(Of ApiEventArgs(Of IList(Of DcnmUserAccountPreparationInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmUserAccountPreparationInfo^>^>^>^ PersonsAccountUpdated {
    void add (EventHandler<ApiEventArgs<IList<DcnmUserAccountPreparationInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmUserAccountPreparationInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmUserAccountPreparationInfo
See Also

Reference

IPreparePerson Interface


IPreparePerson.PersonsCreated Event

IPreparePersonPersonsCreated Event

Occurs when persons are created.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmUserAccountPreparationInfo>>> PersonsCreated
Event PersonsCreated As EventHandler(Of ApiEventArgs(Of IList(Of DcnmUserAccountPreparationInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmUserAccountPreparationInfo^>^>^>^ PersonsCreated {
    void add (EventHandler<ApiEventArgs<IList<DcnmUserAccountPreparationInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmUserAccountPreparationInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmUserAccountPreparationInfo
See Also

Reference

IPreparePerson Interface


IPreparePerson.PersonsDeleted Event

IPreparePersonPersonsDeleted Event

Occurs when persons are deleted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<Guid>>> PersonsDeleted
Event PersonsDeleted As EventHandler(Of ApiEventArgs(Of IList(Of Guid)))
 event EventHandler<ApiEventArgs<IList<Guid>^>^>^ PersonsDeleted {
    void add (EventHandler<ApiEventArgs<IList<Guid>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<Guid>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList Guid
See Also

Reference

IPreparePerson Interface


IPreparePerson.PersonsUpdated Event

IPreparePersonPersonsUpdated Event

Occurs when persons are updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmUserAccountPreparationInfo>>> PersonsUpdated
Event PersonsUpdated As EventHandler(Of ApiEventArgs(Of IList(Of DcnmUserAccountPreparationInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmUserAccountPreparationInfo^>^>^>^ PersonsUpdated {
    void add (EventHandler<ApiEventArgs<IList<DcnmUserAccountPreparationInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmUserAccountPreparationInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmUserAccountPreparationInfo
See Also

Reference

IPreparePerson Interface


IPrepareSystemChannels Interface

Defines the interface to create, updated, delete system channels.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IPrepareSystemChannels : IDisposable
Public Interface IPrepareSystemChannels
    Inherits IDisposable
public interface class IPrepareSystemChannels : IDisposable

The IPrepareSystemChannels type exposes the following members.

Properties
 | Name | Description
Public property | CanPrepareSystemChannels | Indicates whether it is possible to prepare system channels or not.
Top
Methods
 | Name | Description
Public method | CreateSystemChannelAsync | Creates one or more channels in the system.
Public method | DeleteSystemChannelAsync | Deletes one or more channel inputs in the system.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetSystemChannelsAsync | Triggers the request to retrieve all the channels.
Public method | ResolveInOutDeviceNameById | Resolves the device name of identified input/output device.
Public method | UpdateSystemChannelAsync | Updates one or more channels in the system.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | SystemChannelsCreated | Occurs when channel have been created.
Public event | SystemChannelsDeleted | Occurs when channel inputs has been deleted.
Public event | SystemChannelsUpdated | Occurs when existing channel inputs have been updated.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IPrepareSystemChannels Properties

The IPrepareSystemChannels type exposes the following members.

Properties
 | Name | Description
Public property | CanPrepareSystemChannels | Indicates whether it is possible to prepare system channels or not.
Top
See Also

Reference

IPrepareSystemChannels Interface


IPrepareSystemChannels.CanPrepareSystemChannels Property

IPrepareSystemChannelsCanPrepareSystemChannels Property

Indicates whether it is possible to prepare system channels or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanPrepareSystemChannels { get; }
ReadOnly Property CanPrepareSystemChannels As Boolean
    Get
property bool CanPrepareSystemChannels {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • User right: Configure system
See Also

Reference

IPrepareSystemChannels Interface


IPrepareSystemChannels Methods

The IPrepareSystemChannels type exposes the following members.

Methods
 | Name | Description
Public method | CreateSystemChannelAsync | Creates one or more channels in the system.
Public method | DeleteSystemChannelAsync | Deletes one or more channel inputs in the system.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetSystemChannelsAsync | Triggers the request to retrieve all the channels.
Public method | ResolveInOutDeviceNameById | Resolves the device name of identified input/output device.
Public method | UpdateSystemChannelAsync | Updates one or more channels in the system.
Top
See Also

Reference

IPrepareSystemChannels Interface


IPrepareSystemChannels.CreateSystemChannelAsync Method

IPrepareSystemChannelsCreateSystemChannelAsync Method

Creates one or more channels in the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CreateSystemChannelAsync(
    IList<DcnmChannelMappingInfo> systemChannelInfos,
    Action<Task<bool>> onFinish = null
)
Function CreateSystemChannelAsync (
    systemChannelInfos As IList(Of DcnmChannelMappingInfo),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CreateSystemChannelAsync(
    IList<DcnmChannelMappingInfo^>^ systemChannelInfos,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

systemChannelInfos
Type: System.Collections.GenericIList DcnmChannelMappingInfo
The info about the channel inputs to be created.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchonous handling of the result.

Return Value

Type: Task Boolean
Task processing the channel inputs creation. The 'Result' property of the task is true if creation succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the list of channel input info is null.
AggregateException | If the provided device is not operational (see: DcnmDeviceOperationalState).
Remarks
Requires:
  • CanPrepareSystemChannels

To create a new system channel, the provided device (references by DeviceId in the DcnmChannelMappingInfo class) must be operational. The operational state can be check using the information of the IEquipment interface.

See Also

Reference

IPrepareSystemChannels Interface
Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch.Dcnm.Interfaces.Api.InterfacesIEquipment
Bosch.Dcnm.Interfaces.Api.InterfacesDcnmChannelMappingInfo


IPrepareSystemChannels.DeleteSystemChannelAsync Method

IPrepareSystemChannelsDeleteSystemChannelAsync Method

Deletes one or more channel inputs in the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeleteSystemChannelAsync(
    IList<Guid> inOutChannelIds,
    Action<Task<bool>> onFinish = null
)
Function DeleteSystemChannelAsync (
    inOutChannelIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeleteSystemChannelAsync(
    IList<Guid>^ inOutChannelIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

inOutChannelIds
Type: System.Collections.GenericIList Guid
The info about the channel inputs to be deleted.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchonous handling of the result.

Return Value

Type: Task Boolean
Task processing the channel inputs update. The 'Result' property of the task is true if update succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the list of channel input info is null.
Remarks
Requires:
  • CanPrepareSystemChannels
See Also

Reference

IPrepareSystemChannels Interface


IPrepareSystemChannels.GetSystemChannelsAsync Method

IPrepareSystemChannelsGetSystemChannelsAsync Method

Triggers the request to retrieve all the channels.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmChannelMappingInfo>> GetSystemChannelsAsync(
    Action<Task<IList<DcnmChannelMappingInfo>>> onFinish = null
)
Function GetSystemChannelsAsync (
    Optional onFinish As Action(Of Task(Of IList(Of DcnmChannelMappingInfo))) = Nothing
) As Task(Of IList(Of DcnmChannelMappingInfo))
Task<IList<DcnmChannelMappingInfo^>^>^ GetSystemChannelsAsync(
    Action<Task<IList<DcnmChannelMappingInfo^>^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task IList DcnmChannelMappingInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmChannelMappingInfo
Task processing the channel inputs retrieval. The 'Result' property of the task holds the retrieved channel inputs. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IPrepareSystemChannels Interface


IPrepareSystemChannels.ResolveInOutDeviceNameById Method

IPrepareSystemChannelsResolveInOutDeviceNameById Method

Resolves the device name of identified input/output device.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<string> ResolveInOutDeviceNameById(
    Guid deviceId,
    Action<Task<string>> onFinish = null
)
Function ResolveInOutDeviceNameById (
    deviceId As Guid,
    Optional onFinish As Action(Of Task(Of String)) = Nothing
) As Task(Of String)
Task<String^>^ ResolveInOutDeviceNameById(
    Guid deviceId,
    Action<Task<String^>^>^ onFinish = nullptr
)

Parameters

deviceId
Type: SystemGuid
The ID of the device to resolve the name for.
onFinish (Optional)
Type: SystemAction Task String
Optional action for asynchonous handling of the result.

Return Value

Type: Task String
Task processing the resolving of the name. The 'Result' property of the task is true if resolve succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If an invalid ID is passed.
Remarks
Requires:
  • CanPrepareSystemChannels
See Also

Reference

IPrepareSystemChannels Interface


IPrepareSystemChannels.UpdateSystemChannelAsync Method

IPrepareSystemChannelsUpdateSystemChannelAsync Method

Updates one or more channels in the system.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateSystemChannelAsync(
    IList<DcnmChannelMappingInfo> systemChannelInfos,
    Action<Task<bool>> onFinish = null
)
Function UpdateSystemChannelAsync (
    systemChannelInfos As IList(Of DcnmChannelMappingInfo),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateSystemChannelAsync(
    IList<DcnmChannelMappingInfo^>^ systemChannelInfos,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

systemChannelInfos
Type: System.Collections.GenericIList DcnmChannelMappingInfo
The info about the channel inputs to be updated.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchonous handling of the result.

Return Value

Type: Task Boolean
Task processing the channel inputs update. The 'Result' property of the task is true if udpate succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If the list of channel input info is null.
Remarks
Requires:
  • CanPrepareSystemChannels
See Also

Reference

IPrepareSystemChannels Interface


IPrepareSystemChannels Events

The IPrepareSystemChannels type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | SystemChannelsCreated | Occurs when channel have been created.
Public event | SystemChannelsDeleted | Occurs when channel inputs has been deleted.
Public event | SystemChannelsUpdated | Occurs when existing channel inputs have been updated.
Top
See Also

Reference

IPrepareSystemChannels Interface


IPrepareSystemChannels.CapabilitiesChanged Event

IPrepareSystemChannelsCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IPrepareSystemChannels Interface


IPrepareSystemChannels.SystemChannelsCreated Event

IPrepareSystemChannelsSystemChannelsCreated Event

Occurs when channel have been created.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmChannelMappingInfo>>> SystemChannelsCreated
Event SystemChannelsCreated As EventHandler(Of ApiEventArgs(Of IList(Of DcnmChannelMappingInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmChannelMappingInfo^>^>^>^ SystemChannelsCreated {
    void add (EventHandler<ApiEventArgs<IList<DcnmChannelMappingInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmChannelMappingInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmChannelMappingInfo
See Also

Reference

IPrepareSystemChannels Interface


IPrepareSystemChannels.SystemChannelsDeleted Event

IPrepareSystemChannelsSystemChannelsDeleted Event

Occurs when channel inputs has been deleted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<Guid>>> SystemChannelsDeleted
Event SystemChannelsDeleted As EventHandler(Of ApiEventArgs(Of IList(Of Guid)))
 event EventHandler<ApiEventArgs<IList<Guid>^>^>^ SystemChannelsDeleted {
    void add (EventHandler<ApiEventArgs<IList<Guid>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<Guid>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList Guid
See Also

Reference

IPrepareSystemChannels Interface


IPrepareSystemChannels.SystemChannelsUpdated Event

IPrepareSystemChannelsSystemChannelsUpdated Event

Occurs when existing channel inputs have been updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmChannelMappingInfo>>> SystemChannelsUpdated
Event SystemChannelsUpdated As EventHandler(Of ApiEventArgs(Of IList(Of DcnmChannelMappingInfo)))
 event EventHandler<ApiEventArgs<IList<DcnmChannelMappingInfo^>^>^>^ SystemChannelsUpdated {
    void add (EventHandler<ApiEventArgs<IList<DcnmChannelMappingInfo^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmChannelMappingInfo^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmChannelMappingInfo
See Also

Reference

IPrepareSystemChannels Interface


IPrepareUser Interface

Defines the interface to register users.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IPrepareUser : IDisposable
Public Interface IPrepareUser
    Inherits IDisposable
public interface class IPrepareUser : IDisposable

The IPrepareUser type exposes the following members.

Properties
 | Name | Description
Public property | CanRegisterUsers | Indicates whether it is possible to register a user or not.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetUsersAsync | Triggers the request to retrieve all the users.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IPrepareUser Properties

The IPrepareUser type exposes the following members.

Properties
 | Name | Description
Public property | CanRegisterUsers | Indicates whether it is possible to register a user or not.
Top
See Also

Reference

IPrepareUser Interface


IPrepareUser.CanRegisterUsers Property

IPrepareUserCanRegisterUsers Property

Indicates whether it is possible to register a user or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanRegisterUsers { get; }
ReadOnly Property CanRegisterUsers As Boolean
    Get
property bool CanRegisterUsers {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • User right: Prepare users
See Also

Reference

IPrepareUser Interface


IPrepareUser Methods

The IPrepareUser type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetUsersAsync | Triggers the request to retrieve all the users.
Top
See Also

Reference

IPrepareUser Interface


IPrepareUser.GetUsersAsync Method

IPrepareUserGetUsersAsync Method

Triggers the request to retrieve all the users.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmUserAccountPreparationInfo>> GetUsersAsync(
    Action<Task<IList<DcnmUserAccountPreparationInfo>>> onFinish = null
)
Function GetUsersAsync (
    Optional onFinish As Action(Of Task(Of IList(Of DcnmUserAccountPreparationInfo))) = Nothing
) As Task(Of IList(Of DcnmUserAccountPreparationInfo))
Task<IList<DcnmUserAccountPreparationInfo^>^>^ GetUsersAsync(
    Action<Task<IList<DcnmUserAccountPreparationInfo^>^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task IList DcnmUserAccountPreparationInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task IList DcnmUserAccountPreparationInfo
Task processing the user retrieval. The 'Result' property of the task holds the retrieved users. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IPrepareUser Interface


IPrepareVoting Interface

Interface for the voting preparation

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IPrepareVoting : IDisposable
Public Interface IPrepareVoting
    Inherits IDisposable
public interface class IPrepareVoting : IDisposable

The IPrepareVoting type exposes the following members.

Properties
 | Name | Description
Public property | CanPrepareAdhocVoting | Indicates weather the user is able to update adhoc voting script
Public property | CanPrepareVotingScript | Indicates weather the user is able to create voting script
Public property | MajorityVariables | Retrieves variables used in vote majority formula.
Top
Methods
 | Name | Description
Public method | ChangeVotingOrderAsync | Updates the order of the voting.
Public method | CopyVotingAsync | Copies voting
Public method | CreateVotingAsync | Creates voting
Public method | CreateVotingFromDefaultSettingsAsync | Creates voting from default voting settings
Public method | DeleteVotingAsync | Deletes voting
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetDefaultVotingSettingsAsync | Retrieves default the voting settings
Public method | RetrieveVotingsForMeetingAsync | Retrieves the votings for the given meeting
Public method | UpdateDefaultVotingSettingsAsync | Updates a default voting settings with the given voting settings information.
Public method | UpdateVotingAsync | Update voting
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | DefaultVotingSettingsUpdated | Occurs when the default vote settings has changed.
Public event | VotingCreated | Occurs when the voting is created
Public event | VotingDeleted | Occurs when the voting is deleted
Public event | VotingOrderChanged | Occurs when the voting order has changed.
Public event | VotingUpdated | Occurs when the voting is updated
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IPrepareVoting Properties

The IPrepareVoting type exposes the following members.

Properties
 | Name | Description
Public property | CanPrepareAdhocVoting | Indicates weather the user is able to update adhoc voting script
Public property | CanPrepareVotingScript | Indicates weather the user is able to create voting script
Public property | MajorityVariables | Retrieves variables used in vote majority formula.
Top
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.CanPrepareAdhocVoting Property

IPrepareVotingCanPrepareAdhocVoting Property

Indicates weather the user is able to update adhoc voting script

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanPrepareAdhocVoting { get; }
ReadOnly Property CanPrepareAdhocVoting As Boolean
    Get
property bool CanPrepareAdhocVoting {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.CanPrepareVotingScript Property

IPrepareVotingCanPrepareVotingScript Property

Indicates weather the user is able to create voting script

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanPrepareVotingScript { get; }
ReadOnly Property CanPrepareVotingScript As Boolean
    Get
property bool CanPrepareVotingScript {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.MajorityVariables Property

IPrepareVotingMajorityVariables Property

Retrieves variables used in vote majority formula.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
IList<string> MajorityVariables { get; }
ReadOnly Property MajorityVariables As IList(Of String)
    Get
property IList<String^>^ MajorityVariables {
    IList<String^>^ get ();
}

Return Value

Type: IList String
These variables can be used in vote majority formula.
See Also

Reference

IPrepareVoting Interface


IPrepareVoting Methods

The IPrepareVoting type exposes the following members.

Methods
 | Name | Description
Public method | ChangeVotingOrderAsync | Updates the order of the voting.
Public method | CopyVotingAsync | Copies voting
Public method | CreateVotingAsync | Creates voting
Public method | CreateVotingFromDefaultSettingsAsync | Creates voting from default voting settings
Public method | DeleteVotingAsync | Deletes voting
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetDefaultVotingSettingsAsync | Retrieves default the voting settings
Public method | RetrieveVotingsForMeetingAsync | Retrieves the votings for the given meeting
Public method | UpdateDefaultVotingSettingsAsync | Updates a default voting settings with the given voting settings information.
Public method | UpdateVotingAsync | Update voting
Top
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.ChangeVotingOrderAsync Method

IPrepareVotingChangeVotingOrderAsync Method

Updates the order of the voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> ChangeVotingOrderAsync(
    IList<Guid> votingIds,
    Action<Task<bool>> onFinish = null
)
Function ChangeVotingOrderAsync (
    votingIds As IList(Of Guid),
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ ChangeVotingOrderAsync(
    IList<Guid>^ votingIds,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

votingIds
Type: System.Collections.GenericIList Guid
The sorted list with voting Ids.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the voting reorder . The 'Result' property of the task is true if change voting order succeeded, false otherwise. Note that the result getter blocks until the return value is available.
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.CopyVotingAsync Method

IPrepareVotingCopyVotingAsync Method

Copies voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<Guid> CopyVotingAsync(
    DcnmVotingPreparationInfo votingInfo,
    Action<Task<Guid>> onFinish = null
)
Function CopyVotingAsync (
    votingInfo As DcnmVotingPreparationInfo,
    Optional onFinish As Action(Of Task(Of Guid)) = Nothing
) As Task(Of Guid)
Task<Guid>^ CopyVotingAsync(
    DcnmVotingPreparationInfo^ votingInfo,
    Action<Task<Guid>^>^ onFinish = nullptr
)

Parameters

votingInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingPreparationInfo
Contains the information of the voting
onFinish (Optional)
Type: SystemAction Task Guid
Optional action for asynchronous handling of the result.

Return Value

Type: Task Guid
Task processing the voting copying. The 'Result' property of the task holds the id of the copied voting. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If voting info is empty or invalid majority formula.
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.CreateVotingAsync Method

IPrepareVotingCreateVotingAsync Method

Creates voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<Guid> CreateVotingAsync(
    DcnmVotingPreparationInfo votingInfo,
    Action<Task<Guid>> onFinish = null
)
Function CreateVotingAsync (
    votingInfo As DcnmVotingPreparationInfo,
    Optional onFinish As Action(Of Task(Of Guid)) = Nothing
) As Task(Of Guid)
Task<Guid>^ CreateVotingAsync(
    DcnmVotingPreparationInfo^ votingInfo,
    Action<Task<Guid>^>^ onFinish = nullptr
)

Parameters

votingInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingPreparationInfo
Contains the information of the voting
onFinish (Optional)
Type: SystemAction Task Guid
Optional action for asynchronous handling of the result.

Return Value

Type: Task Guid
Task processing the voting creation. The 'Result' property of the task holds the id of the created voting. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If voting info is empty or invalid majority formula.
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.CreateVotingFromDefaultSettingsAsync Method

IPrepareVotingCreateVotingFromDefaultSettingsAsync Method

Creates voting from default voting settings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<Guid> CreateVotingFromDefaultSettingsAsync(
    Guid meetingId,
    Action<Task<Guid>> onFinish = null
)
Function CreateVotingFromDefaultSettingsAsync (
    meetingId As Guid,
    Optional onFinish As Action(Of Task(Of Guid)) = Nothing
) As Task(Of Guid)
Task<Guid>^ CreateVotingFromDefaultSettingsAsync(
    Guid meetingId,
    Action<Task<Guid>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
Meeting id for which voting has to be created
onFinish (Optional)
Type: SystemAction Task Guid
Optional action for asynchronous handling of the result.

Return Value

Type: Task Guid
Task processing the voting creation. The 'Result' property of the task holds the id of the created voting. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If voting info is empty.
Remarks
Default voting settings are updated using UpdateDefaultVotingSettingsAsync(DcnmVotingSettingsInfo, ActionTaskBoolean) method
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.DeleteVotingAsync Method

IPrepareVotingDeleteVotingAsync Method

Deletes voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> DeleteVotingAsync(
    Guid votingId,
    Action<Task<bool>> onFinish = null
)
Function DeleteVotingAsync (
    votingId As Guid,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ DeleteVotingAsync(
    Guid votingId,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

votingId
Type: SystemGuid
Id of the voting to delete
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result

Return Value

Type: Task Boolean
Task processing the voting deletion. The 'Result' property of the task holds true, if the deletion is successful otherwise false Note that the result getter blocks until the return value is available
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If voting info is empty.
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.GetDefaultVotingSettingsAsync Method

IPrepareVotingGetDefaultVotingSettingsAsync Method

Retrieves default the voting settings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<DcnmVotingSettingsInfo> GetDefaultVotingSettingsAsync(
    Action<Task<DcnmVotingSettingsInfo>> onFinish = null
)
Function GetDefaultVotingSettingsAsync (
    Optional onFinish As Action(Of Task(Of DcnmVotingSettingsInfo)) = Nothing
) As Task(Of DcnmVotingSettingsInfo)
Task<DcnmVotingSettingsInfo^>^ GetDefaultVotingSettingsAsync(
    Action<Task<DcnmVotingSettingsInfo^>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task DcnmVotingSettingsInfo
Optional action for asynchronous handling of the result.

Return Value

Type: Task DcnmVotingSettingsInfo
Task processing the default voting settings retrieval. The 'Result' property of the task holds the return value of the function. Note that the result getter blocks until the return value is available.
Remarks
These settings can be used as base settings for newly created votings
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.RetrieveVotingsForMeetingAsync Method

IPrepareVotingRetrieveVotingsForMeetingAsync Method

Retrieves the votings for the given meeting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<IList<DcnmVotingPreparationInfo>> RetrieveVotingsForMeetingAsync(
    Guid meetingId,
    Action<Task<IList<DcnmVotingPreparationInfo>>> onFinish = null
)
Function RetrieveVotingsForMeetingAsync (
    meetingId As Guid,
    Optional onFinish As Action(Of Task(Of IList(Of DcnmVotingPreparationInfo))) = Nothing
) As Task(Of IList(Of DcnmVotingPreparationInfo))
Task<IList<DcnmVotingPreparationInfo^>^>^ RetrieveVotingsForMeetingAsync(
    Guid meetingId,
    Action<Task<IList<DcnmVotingPreparationInfo^>^>^>^ onFinish = nullptr
)

Parameters

meetingId
Type: SystemGuid
Id of the meeting to retrieve votings
onFinish (Optional)
Type: SystemAction Task IList DcnmVotingPreparationInfo
Optional action for asynchronous handling of the result

Return Value

Type: Task IList DcnmVotingPreparationInfo
Task processing the voting retrieval. The 'Result' property of the task holds the retrieved votings. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException | If meeting id is empty.
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.UpdateDefaultVotingSettingsAsync Method

IPrepareVotingUpdateDefaultVotingSettingsAsync Method

Updates a default voting settings with the given voting settings information.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateDefaultVotingSettingsAsync(
    DcnmVotingSettingsInfo votingSettingsInfo,
    Action<Task<bool>> onFinish = null
)
Function UpdateDefaultVotingSettingsAsync (
    votingSettingsInfo As DcnmVotingSettingsInfo,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateDefaultVotingSettingsAsync(
    DcnmVotingSettingsInfo^ votingSettingsInfo,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

votingSettingsInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingSettingsInfo
The container holding the information of the meeting.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the voting update. The 'Result' property of the task holds the return value of the function. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException
  • If voting info is empty or invalid majority formula.
  • If AutoCastVoteAnswer is not part of selected VotingAnswerSet.
Remarks
These default voting settings are used when creating voting with default settings and for ad hoc voting
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.UpdateVotingAsync Method

IPrepareVotingUpdateVotingAsync Method

Update voting

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> UpdateVotingAsync(
    DcnmVotingPreparationInfo votingInfo,
    Action<Task<bool>> onFinish = null
)
Function UpdateVotingAsync (
    votingInfo As DcnmVotingPreparationInfo,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ UpdateVotingAsync(
    DcnmVotingPreparationInfo^ votingInfo,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

votingInfo
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingPreparationInfo
Contains voting information
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result

Return Value

Type: Task Boolean
Task processing the voting update. The 'Result' property of the task holds true, if update is successful otherwise false Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentException
  • If voting info is empty or invalid majority formula.
  • If AutoCastVoteAnswer is not part of selected VotingAnswerSet.
See Also

Reference

IPrepareVoting Interface


IPrepareVoting Events

The IPrepareVoting type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | DefaultVotingSettingsUpdated | Occurs when the default vote settings has changed.
Public event | VotingCreated | Occurs when the voting is created
Public event | VotingDeleted | Occurs when the voting is deleted
Public event | VotingOrderChanged | Occurs when the voting order has changed.
Public event | VotingUpdated | Occurs when the voting is updated
Top
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.CapabilitiesChanged Event

IPrepareVotingCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.DefaultVotingSettingsUpdated Event

IPrepareVotingDefaultVotingSettingsUpdated Event

Occurs when the default vote settings has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmVotingSettingsInfo>> DefaultVotingSettingsUpdated
Event DefaultVotingSettingsUpdated As EventHandler(Of ApiEventArgs(Of DcnmVotingSettingsInfo))
 event EventHandler<ApiEventArgs<DcnmVotingSettingsInfo^>^>^ DefaultVotingSettingsUpdated {
    void add (EventHandler<ApiEventArgs<DcnmVotingSettingsInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmVotingSettingsInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmVotingSettingsInfo
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.VotingCreated Event

IPrepareVotingVotingCreated Event

Occurs when the voting is created

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmVotingPreparationInfo>> VotingCreated
Event VotingCreated As EventHandler(Of ApiEventArgs(Of DcnmVotingPreparationInfo))
 event EventHandler<ApiEventArgs<DcnmVotingPreparationInfo^>^>^ VotingCreated {
    void add (EventHandler<ApiEventArgs<DcnmVotingPreparationInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmVotingPreparationInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmVotingPreparationInfo
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.VotingDeleted Event

IPrepareVotingVotingDeleted Event

Occurs when the voting is deleted

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<Guid>> VotingDeleted
Event VotingDeleted As EventHandler(Of ApiEventArgs(Of Guid))
 event EventHandler<ApiEventArgs<Guid>^>^ VotingDeleted {
    void add (EventHandler<ApiEventArgs<Guid>^>^ value);
    void remove (EventHandler<ApiEventArgs<Guid>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Guid
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.VotingOrderChanged Event

IPrepareVotingVotingOrderChanged Event

Occurs when the voting order has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<Guid>>> VotingOrderChanged
Event VotingOrderChanged As EventHandler(Of ApiEventArgs(Of IList(Of Guid)))
 event EventHandler<ApiEventArgs<IList<Guid>^>^>^ VotingOrderChanged {
    void add (EventHandler<ApiEventArgs<IList<Guid>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<Guid>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList Guid
See Also

Reference

IPrepareVoting Interface


IPrepareVoting.VotingUpdated Event

IPrepareVotingVotingUpdated Event

Occurs when the voting is updated

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmVotingPreparationInfo>> VotingUpdated
Event VotingUpdated As EventHandler(Of ApiEventArgs(Of DcnmVotingPreparationInfo))
 event EventHandler<ApiEventArgs<DcnmVotingPreparationInfo^>^>^ VotingUpdated {
    void add (EventHandler<ApiEventArgs<DcnmVotingPreparationInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmVotingPreparationInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmVotingPreparationInfo
See Also

Reference

IPrepareVoting Interface


IRoomAudioControl Interface

Interface for room audio control

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IRoomAudioControl : IDisposable
Public Interface IRoomAudioControl
    Inherits IDisposable
public interface class IRoomAudioControl : IDisposable

The IRoomAudioControl type exposes the following members.

Properties
 | Name | Description
Public property | AudioControlPossible | Indicates whether the user is able to alter the gain settings
Public property | CanConfigureSystemAudio | Indicates whether the user is allowed to configure the gain settings
Public property | CanControlSystemAudio | Indicates whether the user is allowed to control the gain settings
Public property | MaxVolumeLevel | The maximum volume level
Public property | MinVolumeLevel | The minimal volume level.
Public property | RoomAudioRoutingState | Room audio routing state.
Top
Methods
 | Name | Description
Public method | AdjustAudioEqualizerSettingsAsync | Adjusts the audio equalizer settings.
Public method | AdjustAudioGainSettingsAsync | Adjusts the specified audio gain setting.
Public method | AdjustAudioSelectionSettingsAsync | Adjusts the specified audio selection setting.
Public method | CancelVUMeterReadingsAsync | Cancels the request for the publication of VU Meter readings
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestAudioSettingsAsync | Requests the audio settings.
Public method | RequestRoomAudioRoutingStateAsync | Requests whether room audio routing is UP or DOWN.
Public method | RequestVUMeterReadingsAsync | Requests the publication of VU Meter readings
Top
Events
 | Name | Description
Public event | AudioControlStateChanged | Event indicating the audio control state has changed.
Public event | AudioSettingsChanged | Event indicating the audio settings have changed.
Public event | CapabilitiesChanged | Occurs when the access rights of the logged on user changed.
Public event | RoomAudioRoutingStateChanged | Event indicating the room audio routing is UP or DOWN.
Public event | VUMeterReadingsChanged | Event providing the new VU meter readings
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IRoomAudioControl Properties

The IRoomAudioControl type exposes the following members.

Properties
 | Name | Description
Public property | AudioControlPossible | Indicates whether the user is able to alter the gain settings
Public property | CanConfigureSystemAudio | Indicates whether the user is allowed to configure the gain settings
Public property | CanControlSystemAudio | Indicates whether the user is allowed to control the gain settings
Public property | MaxVolumeLevel | The maximum volume level
Public property | MinVolumeLevel | The minimal volume level.
Public property | RoomAudioRoutingState | Room audio routing state.
Top
See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.AudioControlPossible Property

IRoomAudioControlAudioControlPossible Property

Indicates whether the user is able to alter the gain settings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool AudioControlPossible { get; }
ReadOnly Property AudioControlPossible As Boolean
    Get
property bool AudioControlPossible {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.CanConfigureSystemAudio Property

IRoomAudioControlCanConfigureSystemAudio Property

Indicates whether the user is allowed to configure the gain settings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanConfigureSystemAudio { get; }
ReadOnly Property CanConfigureSystemAudio As Boolean
    Get
property bool CanConfigureSystemAudio {
    bool get ();
}

Property Value

Type: Boolean
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • User group right: Configure system
See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.CanControlSystemAudio Property

IRoomAudioControlCanControlSystemAudio Property

Indicates whether the user is allowed to control the gain settings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanControlSystemAudio { get; }
ReadOnly Property CanControlSystemAudio As Boolean
    Get
property bool CanControlSystemAudio {
    bool get ();
}

Property Value

Type: Boolean
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Device has capability: Volume control
See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.MaxVolumeLevel Property

IRoomAudioControlMaxVolumeLevel Property

The maximum volume level

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
int MaxVolumeLevel { get; }
ReadOnly Property MaxVolumeLevel As Integer
    Get
property int MaxVolumeLevel {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.MinVolumeLevel Property

IRoomAudioControlMinVolumeLevel Property

The minimal volume level.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
int MinVolumeLevel { get; }
ReadOnly Property MinVolumeLevel As Integer
    Get
property int MinVolumeLevel {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.RoomAudioRoutingState Property

IRoomAudioControlRoomAudioRoutingState Property

Room audio routing state.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool RoomAudioRoutingState { get; }
ReadOnly Property RoomAudioRoutingState As Boolean
    Get
property bool RoomAudioRoutingState {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl Methods

The IRoomAudioControl type exposes the following members.

Methods
 | Name | Description
Public method | AdjustAudioEqualizerSettingsAsync | Adjusts the audio equalizer settings.
Public method | AdjustAudioGainSettingsAsync | Adjusts the specified audio gain setting.
Public method | AdjustAudioSelectionSettingsAsync | Adjusts the specified audio selection setting.
Public method | CancelVUMeterReadingsAsync | Cancels the request for the publication of VU Meter readings
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestAudioSettingsAsync | Requests the audio settings.
Public method | RequestRoomAudioRoutingStateAsync | Requests whether room audio routing is UP or DOWN.
Public method | RequestVUMeterReadingsAsync | Requests the publication of VU Meter readings
Top
See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.AdjustAudioEqualizerSettingsAsync Method

IRoomAudioControlAdjustAudioEqualizerSettingsAsync Method

Adjusts the audio equalizer settings.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> AdjustAudioEqualizerSettingsAsync(
    DcnmAudioEqualizerSettings equalizerSettings,
    Action<Task<bool>> onFinish = null
)
Function AdjustAudioEqualizerSettingsAsync (
    equalizerSettings As DcnmAudioEqualizerSettings,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ AdjustAudioEqualizerSettingsAsync(
    DcnmAudioEqualizerSettings^ equalizerSettings,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

equalizerSettings
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAudioEqualizerSettings
The audio equalizer settings to set.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the equalizer settings adjustment. The 'Result' property of the task is true if adjusting equalizer settings succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentOutOfRangeException | If equalizer setting values (filter number, gain, frequency, Q-Factor) are out of range
See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.AdjustAudioGainSettingsAsync Method

IRoomAudioControlAdjustAudioGainSettingsAsync Method

Adjusts the specified audio gain setting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> AdjustAudioGainSettingsAsync(
    DcnmAudioGainSetting audioGainSetting,
    Action<Task<bool>> onFinish = null
)
Function AdjustAudioGainSettingsAsync (
    audioGainSetting As DcnmAudioGainSetting,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ AdjustAudioGainSettingsAsync(
    DcnmAudioGainSetting^ audioGainSetting,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

audioGainSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAudioGainSetting
The audio gain setting to be adjusted.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the volume adjustment. The 'Result' property of the task holds the return value of the function.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentOutOfRangeException | When gain value is out of range
See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.AdjustAudioSelectionSettingsAsync Method

IRoomAudioControlAdjustAudioSelectionSettingsAsync Method

Adjusts the specified audio selection setting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> AdjustAudioSelectionSettingsAsync(
    DcnmAudioSelectionSetting audioSelectionSetting,
    Action<Task<bool>> onFinish = null
)
Function AdjustAudioSelectionSettingsAsync (
    audioSelectionSetting As DcnmAudioSelectionSetting,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ AdjustAudioSelectionSettingsAsync(
    DcnmAudioSelectionSetting^ audioSelectionSetting,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

audioSelectionSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmAudioSelectionSetting
The audio selection setting to be adjusted.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the volume adjustment. The 'Result' property of the task holds the return value of the function.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentOutOfRangeException | When gain value is out of range
See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.CancelVUMeterReadingsAsync Method

IRoomAudioControlCancelVUMeterReadingsAsync Method

Cancels the request for the publication of VU Meter readings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CancelVUMeterReadingsAsync(
    Action<Task<bool>> onFinish = null
)
Function CancelVUMeterReadingsAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CancelVUMeterReadingsAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request. The 'Result' property of the task is true, if the request to start publishing is delivered, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Event VUMeterReadingsChanged is triggered, containing a set of VU meter values.

See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.RequestAudioSettingsAsync Method

IRoomAudioControlRequestAudioSettingsAsync Method

Requests the audio settings.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestAudioSettingsAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestAudioSettingsAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestAudioSettingsAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request. The 'Result' property of the task is true, if the request to retrieve the gain setting is delivered, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Event AudioSettingsChanged is triggered, along with a list of gain, seleciton and equalizer settings.

See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.RequestRoomAudioRoutingStateAsync Method

IRoomAudioControlRequestRoomAudioRoutingStateAsync Method

Requests whether room audio routing is UP or DOWN.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestRoomAudioRoutingStateAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestRoomAudioRoutingStateAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestRoomAudioRoutingStateAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request. The 'Result' property of the task is true, if the request to start publishing is delivered, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Event RoomAudioRoutingStateChanged is triggered, containing boolean indicating UP of DOWN.

See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.RequestVUMeterReadingsAsync Method

IRoomAudioControlRequestVUMeterReadingsAsync Method

Requests the publication of VU Meter readings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestVUMeterReadingsAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestVUMeterReadingsAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestVUMeterReadingsAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request. The 'Result' property of the task is true, if the request to start publishing is delivered, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Event VUMeterReadingsChanged is triggered, containing a set of VU meter values.

See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl Events

The IRoomAudioControl type exposes the following members.

Events
 | Name | Description
Public event | AudioControlStateChanged | Event indicating the audio control state has changed.
Public event | AudioSettingsChanged | Event indicating the audio settings have changed.
Public event | CapabilitiesChanged | Occurs when the access rights of the logged on user changed.
Public event | RoomAudioRoutingStateChanged | Event indicating the room audio routing is UP or DOWN.
Public event | VUMeterReadingsChanged | Event providing the new VU meter readings
Top
See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.AudioControlStateChanged Event

IRoomAudioControlAudioControlStateChanged Event

Event indicating the audio control state has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<bool>> AudioControlStateChanged
Event AudioControlStateChanged As EventHandler(Of ApiEventArgs(Of Boolean))
 event EventHandler<ApiEventArgs<bool>^>^ AudioControlStateChanged {
    void add (EventHandler<ApiEventArgs<bool>^>^ value);
    void remove (EventHandler<ApiEventArgs<bool>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Boolean
See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.AudioSettingsChanged Event

IRoomAudioControlAudioSettingsChanged Event

Event indicating the audio settings have changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmRoomAudioSettingsInfo>> AudioSettingsChanged
Event AudioSettingsChanged As EventHandler(Of ApiEventArgs(Of DcnmRoomAudioSettingsInfo))
 event EventHandler<ApiEventArgs<DcnmRoomAudioSettingsInfo^>^>^ AudioSettingsChanged {
    void add (EventHandler<ApiEventArgs<DcnmRoomAudioSettingsInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmRoomAudioSettingsInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmRoomAudioSettingsInfo
See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.CapabilitiesChanged Event

IRoomAudioControlCapabilitiesChanged Event

Occurs when the access rights of the logged on user changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.RoomAudioRoutingStateChanged Event

IRoomAudioControlRoomAudioRoutingStateChanged Event

Event indicating the room audio routing is UP or DOWN.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<bool>> RoomAudioRoutingStateChanged
Event RoomAudioRoutingStateChanged As EventHandler(Of ApiEventArgs(Of Boolean))
 event EventHandler<ApiEventArgs<bool>^>^ RoomAudioRoutingStateChanged {
    void add (EventHandler<ApiEventArgs<bool>^>^ value);
    void remove (EventHandler<ApiEventArgs<bool>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Boolean
See Also

Reference

IRoomAudioControl Interface


IRoomAudioControl.VUMeterReadingsChanged Event

IRoomAudioControlVUMeterReadingsChanged Event

Event providing the new VU meter readings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmVUMeterReadings>> VUMeterReadingsChanged
Event VUMeterReadingsChanged As EventHandler(Of ApiEventArgs(Of DcnmVUMeterReadings))
 event EventHandler<ApiEventArgs<DcnmVUMeterReadings^>^>^ VUMeterReadingsChanged {
    void add (EventHandler<ApiEventArgs<DcnmVUMeterReadings^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmVUMeterReadings^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmVUMeterReadings
See Also

Reference

IRoomAudioControl Interface


ISpeak Interface

Represents an interface to participate in an ongoing discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface ISpeak : IDisposable
Public Interface ISpeak
    Inherits IDisposable
public interface class ISpeak : IDisposable

The ISpeak type exposes the following members.

Properties
 | Name | Description
Public property | CanIssueImportantRequest | Indicates the user is able to issue an important request in the discussion.
Public property | CanIssueRequest | Indicates the user is able to issue a request to speak in a discussion.
Public property | CanIssueResponse | Indicates the user is able to issue a request to respond in a discussion.
Public property | CanToggle | Indicates the user is able to use toggle behaviour on the UI for issueing an request in the discussion.
Public property | IsFirstRequestPending | Indicates whether a request to speak ahas been issued and pending to be granted speech. The request is the first request about to be granted.
Public property | IsFirstResponsePending | Indicates whether a request to respond has been issued and pending to be granted response. The response-request is the first request about to be granted.
Public property | IsImportantSpeechGranted | Indicates currently important speech has been granted.
Public property | IsMicrophoneOn | Indicates whether the speaker microphone is on or not
Public property | IsRequestListFull | Indicates whether the request list is full
Public property | IsRequestPending | Indicates whether a request to speak has been issued and pending to be granted speech.
Public property | IsResponseGranted | Indicates currently response has been granted.
Public property | IsResponseRequestListFull | Indicates whether the response request list is full
Public property | IsResponseRequestPending | Indicates whether a request to respond has been issued and pending to be granted response.
Public property | IsSpeakersListFull | Indicates whether the speakers list is full
Public property | IsSpeechGranted | Indicates currently speech has been granted.
Top
Methods
 | Name | Description
Public method | CancelImportantRequestAsync | Indicates the user is done/ready important speaking in the discussion.
Public method | CancelRequestAsync | Indicates the user is done/ready speaking in the discussion..
Public method | CancelResponseRequestAsync | Indicates the user is done/ready responding in the discussion..
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | IssueImportantRequestToSpeakAsync | Indicates the user wishes to issue an important request to speak.
Public method | IssueRequestToRespondAsync | Indicates the user wishes to issue a request to respond.
Public method | IssueRequestToSpeakAsync | Indicates the user wishes to issue a request to speak.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | ImportantRequestDenied | Important request was denied.
Public event | ImportantRequestGranted | Important request was granted, i.e. the participant who issued the important request can actually start speaking.
Public event | ImportantSpeechRevoked | The important speech was revoked. i.e. by the chairman or because of a priority.
Public event | RequestAccepted | An issued request has been accepted and is now present in the request list.
Public event | RequestListFullStateChanged | Indicates the request list full state has changed.
Public event | RequestRejected | The request to speak issued by the participant was rejected (the request list my be full).
Public event | ResponseGranted | Request to respond was granted, i.e. the participant who issued the request can actually start responding at his seat.
Public event | ResponseRequestAccepted | An issued response-request has been accepted and is now present in the response-request list.
Public event | ResponseRequestListFullStateChanged | Indicates the response request list full state has changed.
Public event | ResponseRequestRejected | The request to respond issued by the participant was rejected (the response-request list my be full).
Public event | ResponseRevoked | Response was revoked, i.e. if a granted response-request is in the response-request list (participant not responding) then the response-request has been removed from the list, or the participant is currently responding and no longer allowed to (at his seat).
Public event | SpeakerListFullStateChanged | Indicates the speaker list full state has changed.
Public event | SpeechGranted | Request to speak was granted, i.e. the participant who issued the request can actually start speaking at his seat.
Public event | SpeechRevoked | Speech was revoked, i.e. if a granted request is in the request list (participant not speaking) then the request has been removed from the list, or the participant is currently speaking and no longer allowed to speak (at his seat).
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


ISpeak Properties

The ISpeak type exposes the following members.

Properties
 | Name | Description
Public property | CanIssueImportantRequest | Indicates the user is able to issue an important request in the discussion.
Public property | CanIssueRequest | Indicates the user is able to issue a request to speak in a discussion.
Public property | CanIssueResponse | Indicates the user is able to issue a request to respond in a discussion.
Public property | CanToggle | Indicates the user is able to use toggle behaviour on the UI for issueing an request in the discussion.
Public property | IsFirstRequestPending | Indicates whether a request to speak ahas been issued and pending to be granted speech. The request is the first request about to be granted.
Public property | IsFirstResponsePending | Indicates whether a request to respond has been issued and pending to be granted response. The response-request is the first request about to be granted.
Public property | IsImportantSpeechGranted | Indicates currently important speech has been granted.
Public property | IsMicrophoneOn | Indicates whether the speaker microphone is on or not
Public property | IsRequestListFull | Indicates whether the request list is full
Public property | IsRequestPending | Indicates whether a request to speak has been issued and pending to be granted speech.
Public property | IsResponseGranted | Indicates currently response has been granted.
Public property | IsResponseRequestListFull | Indicates whether the response request list is full
Public property | IsResponseRequestPending | Indicates whether a request to respond has been issued and pending to be granted response.
Public property | IsSpeakersListFull | Indicates whether the speakers list is full
Public property | IsSpeechGranted | Indicates currently speech has been granted.
Top
See Also

Reference

ISpeak Interface


ISpeak.CanIssueImportantRequest Property

ISpeakCanIssueImportantRequest Property

Indicates the user is able to issue an important request in the discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanIssueImportantRequest { get; }
ReadOnly Property CanIssueImportantRequest As Boolean
    Get
property bool CanIssueImportantRequest {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Participant right: Can discuss
  • Participant VIP type: PTT operated, button operated or voice operated
See Also

Reference

ISpeak Interface


ISpeak.CanIssueRequest Property

ISpeakCanIssueRequest Property

Indicates the user is able to issue a request to speak in a discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanIssueRequest { get; }
ReadOnly Property CanIssueRequest As Boolean
    Get
property bool CanIssueRequest {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Participant right: Can discuss
See Also

Reference

ISpeak Interface


ISpeak.CanIssueResponse Property

ISpeakCanIssueResponse Property

Indicates the user is able to issue a request to respond in a discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanIssueResponse { get; }
ReadOnly Property CanIssueResponse As Boolean
    Get
property bool CanIssueResponse {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Functional license: Discuss management extended
  • Participant right: Can discuss
See Also

Reference

ISpeak Interface


ISpeak.CanToggle Property

ISpeakCanToggle Property

Indicates the user is able to use toggle behaviour on the UI for issueing an request in the discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanToggle { get; }
ReadOnly Property CanToggle As Boolean
    Get
property bool CanToggle {
    bool get ();
}

Property Value

Type: Boolean
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Participant right: Can discuss
  • Participant VIP type: PTT operated
See Also

Reference

ISpeak Interface


ISpeak.IsFirstRequestPending Property

ISpeakIsFirstRequestPending Property

Indicates whether a request to speak ahas been issued and pending to be granted speech. The request is the first request about to be granted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsFirstRequestPending { get; }
ReadOnly Property IsFirstRequestPending As Boolean
    Get
property bool IsFirstRequestPending {
    bool get ();
}

Property Value

Type: Boolean
true if first pending, false otherwise.
See Also

Reference

ISpeak Interface


ISpeak.IsFirstResponsePending Property

ISpeakIsFirstResponsePending Property

Indicates whether a request to respond has been issued and pending to be granted response. The response-request is the first request about to be granted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsFirstResponsePending { get; }
ReadOnly Property IsFirstResponsePending As Boolean
    Get
property bool IsFirstResponsePending {
    bool get ();
}

Property Value

Type: Boolean
true if first pending, false otherwise.
See Also

Reference

ISpeak Interface


ISpeak.IsImportantSpeechGranted Property

ISpeakIsImportantSpeechGranted Property

Indicates currently important speech has been granted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsImportantSpeechGranted { get; }
ReadOnly Property IsImportantSpeechGranted As Boolean
    Get
property bool IsImportantSpeechGranted {
    bool get ();
}

Property Value

Type: Boolean
true if important speaking, false otherwise.
See Also

Reference

ISpeak Interface


ISpeak.IsMicrophoneOn Property

ISpeakIsMicrophoneOn Property

Indicates whether the speaker microphone is on or not

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsMicrophoneOn { get; }
ReadOnly Property IsMicrophoneOn As Boolean
    Get
property bool IsMicrophoneOn {
    bool get ();
}

Property Value

Type: Boolean
true if on, false otherwise.
See Also

Reference

ISpeak Interface


ISpeak.IsRequestListFull Property

ISpeakIsRequestListFull Property

Indicates whether the request list is full

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsRequestListFull { get; }
ReadOnly Property IsRequestListFull As Boolean
    Get
property bool IsRequestListFull {
    bool get ();
}

Property Value

Type: Boolean
true if request list full, false otherwise.
See Also

Reference

ISpeak Interface


ISpeak.IsRequestPending Property

ISpeakIsRequestPending Property

Indicates whether a request to speak has been issued and pending to be granted speech.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsRequestPending { get; }
ReadOnly Property IsRequestPending As Boolean
    Get
property bool IsRequestPending {
    bool get ();
}

Property Value

Type: Boolean
true if pending, false otherwise.
See Also

Reference

ISpeak Interface


ISpeak.IsResponseGranted Property

ISpeakIsResponseGranted Property

Indicates currently response has been granted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsResponseGranted { get; }
ReadOnly Property IsResponseGranted As Boolean
    Get
property bool IsResponseGranted {
    bool get ();
}

Property Value

Type: Boolean
true if responding, false otherwise.
See Also

Reference

ISpeak Interface


ISpeak.IsResponseRequestListFull Property

ISpeakIsResponseRequestListFull Property

Indicates whether the response request list is full

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsResponseRequestListFull { get; }
ReadOnly Property IsResponseRequestListFull As Boolean
    Get
property bool IsResponseRequestListFull {
    bool get ();
}

Property Value

Type: Boolean
true if response request list full, false otherwise.
See Also

Reference

ISpeak Interface


ISpeak.IsResponseRequestPending Property

ISpeakIsResponseRequestPending Property

Indicates whether a request to respond has been issued and pending to be granted response.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsResponseRequestPending { get; }
ReadOnly Property IsResponseRequestPending As Boolean
    Get
property bool IsResponseRequestPending {
    bool get ();
}

Property Value

Type: Boolean
true if pending, false otherwise.
See Also

Reference

ISpeak Interface


ISpeak.IsSpeakersListFull Property

ISpeakIsSpeakersListFull Property

Indicates whether the speakers list is full

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsSpeakersListFull { get; }
ReadOnly Property IsSpeakersListFull As Boolean
    Get
property bool IsSpeakersListFull {
    bool get ();
}

Property Value

Type: Boolean
true if speakers list full, false otherwise.
See Also

Reference

ISpeak Interface


ISpeak.IsSpeechGranted Property

ISpeakIsSpeechGranted Property

Indicates currently speech has been granted.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsSpeechGranted { get; }
ReadOnly Property IsSpeechGranted As Boolean
    Get
property bool IsSpeechGranted {
    bool get ();
}

Property Value

Type: Boolean
true if speaking, false otherwise.
See Also

Reference

ISpeak Interface


ISpeak Methods

The ISpeak type exposes the following members.

Methods
 | Name | Description
Public method | CancelImportantRequestAsync | Indicates the user is done/ready important speaking in the discussion.
Public method | CancelRequestAsync | Indicates the user is done/ready speaking in the discussion..
Public method | CancelResponseRequestAsync | Indicates the user is done/ready responding in the discussion..
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | IssueImportantRequestToSpeakAsync | Indicates the user wishes to issue an important request to speak.
Public method | IssueRequestToRespondAsync | Indicates the user wishes to issue a request to respond.
Public method | IssueRequestToSpeakAsync | Indicates the user wishes to issue a request to speak.
Top
See Also

Reference

ISpeak Interface


ISpeak.CancelImportantRequestAsync Method

ISpeakCancelImportantRequestAsync Method

Indicates the user is done/ready important speaking in the discussion.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CancelImportantRequestAsync(
    Action<Task<bool>> onFinish = null
)
Function CancelImportantRequestAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CancelImportantRequestAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the cancel. The 'Result' property of the task is true if the request to cancel important request is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanIssueImportantRequest

Events triggered are as follows:

  • ImportantSpeechRevoked

See Also

Reference

ISpeak Interface


ISpeak.CancelRequestAsync Method

ISpeakCancelRequestAsync Method

Indicates the user is done/ready speaking in the discussion..

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CancelRequestAsync(
    Action<Task<bool>> onFinish = null
)
Function CancelRequestAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CancelRequestAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the cancel. The 'Result' property of the task is true, if the request to cancel a "Request" is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanIssueRequest

Events triggered are as follows:

  • RequestRejected - if the user is removed from the request list
  • SpeechRevoked - if the user is removed from the speakers list

See Also

Reference

ISpeak Interface


ISpeak.CancelResponseRequestAsync Method

ISpeakCancelResponseRequestAsync Method

Indicates the user is done/ready responding in the discussion..

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CancelResponseRequestAsync(
    Action<Task<bool>> onFinish = null
)
Function CancelResponseRequestAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CancelResponseRequestAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the cancel. The 'Result' property of the task is true, if the request to cancel a "response request" is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanIssueResponse

Events triggered are as follows:

  • ResponseRequestRejected - if the user is removed from response request list
  • ResponseRevoked - if the user is removed from responders list

See Also

Reference

ISpeak Interface


ISpeak.IssueImportantRequestToSpeakAsync Method

ISpeakIssueImportantRequestToSpeakAsync Method

Indicates the user wishes to issue an important request to speak.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> IssueImportantRequestToSpeakAsync(
    Action<Task<bool>> onFinish = null
)
Function IssueImportantRequestToSpeakAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ IssueImportantRequestToSpeakAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request. The 'Result' property of the task is true if, the request to "Issue important request" is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanIssueImportantRequest

Events triggered are as follows:

  • ImportantRequestGranted - if the user's the request to issue a important is accepted.
  • ImportantRequestDenied - if the user's the request to issue a important is rejected

See Also

Reference

ISpeak Interface


ISpeak.IssueRequestToRespondAsync Method

ISpeakIssueRequestToRespondAsync Method

Indicates the user wishes to issue a request to respond.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> IssueRequestToRespondAsync(
    Action<Task<bool>> onFinish = null
)
Function IssueRequestToRespondAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ IssueRequestToRespondAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request. The 'Result' property of the task is true if, the requset to "Issue request to respond" is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • CanIssueResponse

Events triggered are as follows:

  • ResponseRequestAccepted - if the user is added to response request list
  • ResponseGranted - if the user is added to responders list

See Also

Reference

ISpeak Interface


ISpeak.IssueRequestToSpeakAsync Method

ISpeakIssueRequestToSpeakAsync Method

Indicates the user wishes to issue a request to speak.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> IssueRequestToSpeakAsync(
    Action<Task<bool>> onFinish = null
)
Function IssueRequestToSpeakAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ IssueRequestToSpeakAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request. The 'Result' property of the task is true if the request to "Issue request to speak" is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • CanIssueRequest
  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode

Events triggered are as follows:

  • RequestAccepted - if the user is added to the request list
  • SpeechGranted - if the user is added to the speakers list

See Also

Reference

ISpeak Interface


ISpeak Events

The ISpeak type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | ImportantRequestDenied | Important request was denied.
Public event | ImportantRequestGranted | Important request was granted, i.e. the participant who issued the important request can actually start speaking.
Public event | ImportantSpeechRevoked | The important speech was revoked. i.e. by the chairman or because of a priority.
Public event | RequestAccepted | An issued request has been accepted and is now present in the request list.
Public event | RequestListFullStateChanged | Indicates the request list full state has changed.
Public event | RequestRejected | The request to speak issued by the participant was rejected (the request list my be full).
Public event | ResponseGranted | Request to respond was granted, i.e. the participant who issued the request can actually start responding at his seat.
Public event | ResponseRequestAccepted | An issued response-request has been accepted and is now present in the response-request list.
Public event | ResponseRequestListFullStateChanged | Indicates the response request list full state has changed.
Public event | ResponseRequestRejected | The request to respond issued by the participant was rejected (the response-request list my be full).
Public event | ResponseRevoked | Response was revoked, i.e. if a granted response-request is in the response-request list (participant not responding) then the response-request has been removed from the list, or the participant is currently responding and no longer allowed to (at his seat).
Public event | SpeakerListFullStateChanged | Indicates the speaker list full state has changed.
Public event | SpeechGranted | Request to speak was granted, i.e. the participant who issued the request can actually start speaking at his seat.
Public event | SpeechRevoked | Speech was revoked, i.e. if a granted request is in the request list (participant not speaking) then the request has been removed from the list, or the participant is currently speaking and no longer allowed to speak (at his seat).
Top
See Also

Reference

ISpeak Interface


ISpeak.CapabilitiesChanged Event

ISpeakCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISpeak Interface


ISpeak.ImportantRequestDenied Event

ISpeakImportantRequestDenied Event

Important request was denied.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler ImportantRequestDenied
Event ImportantRequestDenied As EventHandler
 event EventHandler^ ImportantRequestDenied {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISpeak Interface


ISpeak.ImportantRequestGranted Event

ISpeakImportantRequestGranted Event

Important request was granted, i.e. the participant who issued the important request can actually start speaking.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler ImportantRequestGranted
Event ImportantRequestGranted As EventHandler
 event EventHandler^ ImportantRequestGranted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISpeak Interface


ISpeak.ImportantSpeechRevoked Event

ISpeakImportantSpeechRevoked Event

The important speech was revoked. i.e. by the chairman or because of a priority.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler ImportantSpeechRevoked
Event ImportantSpeechRevoked As EventHandler
 event EventHandler^ ImportantSpeechRevoked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISpeak Interface


ISpeak.RequestAccepted Event

ISpeakRequestAccepted Event

An issued request has been accepted and is now present in the request list.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<bool>> RequestAccepted
Event RequestAccepted As EventHandler(Of ApiEventArgs(Of Boolean))
 event EventHandler<ApiEventArgs<bool>^>^ RequestAccepted {
    void add (EventHandler<ApiEventArgs<bool>^>^ value);
    void remove (EventHandler<ApiEventArgs<bool>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Boolean
See Also

Reference

ISpeak Interface


ISpeak.RequestListFullStateChanged Event

ISpeakRequestListFullStateChanged Event

Indicates the request list full state has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<bool>> RequestListFullStateChanged
Event RequestListFullStateChanged As EventHandler(Of ApiEventArgs(Of Boolean))
 event EventHandler<ApiEventArgs<bool>^>^ RequestListFullStateChanged {
    void add (EventHandler<ApiEventArgs<bool>^>^ value);
    void remove (EventHandler<ApiEventArgs<bool>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Boolean
See Also

Reference

ISpeak Interface


ISpeak.RequestRejected Event

ISpeakRequestRejected Event

The request to speak issued by the participant was rejected (the request list my be full).

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler RequestRejected
Event RequestRejected As EventHandler
 event EventHandler^ RequestRejected {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISpeak Interface


ISpeak.ResponseGranted Event

ISpeakResponseGranted Event

Request to respond was granted, i.e. the participant who issued the request can actually start responding at his seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler ResponseGranted
Event ResponseGranted As EventHandler
 event EventHandler^ ResponseGranted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISpeak Interface


ISpeak.ResponseRequestAccepted Event

ISpeakResponseRequestAccepted Event

An issued response-request has been accepted and is now present in the response-request list.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<bool>> ResponseRequestAccepted
Event ResponseRequestAccepted As EventHandler(Of ApiEventArgs(Of Boolean))
 event EventHandler<ApiEventArgs<bool>^>^ ResponseRequestAccepted {
    void add (EventHandler<ApiEventArgs<bool>^>^ value);
    void remove (EventHandler<ApiEventArgs<bool>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Boolean
See Also

Reference

ISpeak Interface


ISpeak.ResponseRequestListFullStateChanged Event

ISpeakResponseRequestListFullStateChanged Event

Indicates the response request list full state has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<bool>> ResponseRequestListFullStateChanged
Event ResponseRequestListFullStateChanged As EventHandler(Of ApiEventArgs(Of Boolean))
 event EventHandler<ApiEventArgs<bool>^>^ ResponseRequestListFullStateChanged {
    void add (EventHandler<ApiEventArgs<bool>^>^ value);
    void remove (EventHandler<ApiEventArgs<bool>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Boolean
See Also

Reference

ISpeak Interface


ISpeak.ResponseRequestRejected Event

ISpeakResponseRequestRejected Event

The request to respond issued by the participant was rejected (the response-request list my be full).

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler ResponseRequestRejected
Event ResponseRequestRejected As EventHandler
 event EventHandler^ ResponseRequestRejected {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISpeak Interface


ISpeak.ResponseRevoked Event

ISpeakResponseRevoked Event

Response was revoked, i.e. if a granted response-request is in the response-request list (participant not responding) then the response-request has been removed from the list, or the participant is currently responding and no longer allowed to (at his seat).

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler ResponseRevoked
Event ResponseRevoked As EventHandler
 event EventHandler^ ResponseRevoked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISpeak Interface


ISpeak.SpeakerListFullStateChanged Event

ISpeakSpeakerListFullStateChanged Event

Indicates the speaker list full state has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<bool>> SpeakerListFullStateChanged
Event SpeakerListFullStateChanged As EventHandler(Of ApiEventArgs(Of Boolean))
 event EventHandler<ApiEventArgs<bool>^>^ SpeakerListFullStateChanged {
    void add (EventHandler<ApiEventArgs<bool>^>^ value);
    void remove (EventHandler<ApiEventArgs<bool>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Boolean
See Also

Reference

ISpeak Interface


ISpeak.SpeechGranted Event

ISpeakSpeechGranted Event

Request to speak was granted, i.e. the participant who issued the request can actually start speaking at his seat.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler SpeechGranted
Event SpeechGranted As EventHandler
 event EventHandler^ SpeechGranted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISpeak Interface


ISpeak.SpeechRevoked Event

ISpeakSpeechRevoked Event

Speech was revoked, i.e. if a granted request is in the request list (participant not speaking) then the request has been removed from the list, or the participant is currently speaking and no longer allowed to speak (at his seat).

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler SpeechRevoked
Event SpeechRevoked As EventHandler
 event EventHandler^ SpeechRevoked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISpeak Interface


ISystemAudioControl Interface

Note: This API is now obsolete.

Interface for system audio control

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The ISystemAudioControl API interface is deprecated; please use IRoomAudioControl instead.")]
public interface ISystemAudioControl : IDisposable
<ObsoleteAttribute("The ISystemAudioControl API interface is deprecated; please use IRoomAudioControl instead.")>
Public Interface ISystemAudioControl
    Inherits IDisposable
[ObsoleteAttribute(L"The ISystemAudioControl API interface is deprecated; please use IRoomAudioControl instead.")]
public interface class ISystemAudioControl : IDisposable

The ISystemAudioControl type exposes the following members.

Properties
 | Name | Description
Public property | AudioControlPossible | Obsolete. Indicates whether the user is able to alter the gain settings
Public property | CanConfigureSystemAudio | Obsolete. Indicates whether the user is allowed to configure the gain settings
Public property | CanControlSystemAudio | Obsolete. Indicates whether the user is allowed to control the gain settings
Public property | MaxVolumeLevel | Obsolete. The maximum volume level
Public property | MinVolumeLevel | Obsolete. The minimal volume level.
Top
Methods
 | Name | Description
Public method | AdjustGainAsync | Obsolete. Adjusts the gain setting for a specific gain type.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestGainsAsync | Obsolete. Requests the gain settings.
Public method | RequestMuteAsync | Obsolete. Requests the mute state.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Obsolete. Occurs when the access rights of the logged on user changed.
Public event | GainSettingsChanged | Obsolete. Event indicating the gain setting has changed.
Public event | MuteStateChanged | Obsolete. Event indicating the mute state has changed.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


ISystemAudioControl Properties

The ISystemAudioControl type exposes the following members.

Properties
 | Name | Description
Public property | AudioControlPossible | Obsolete. Indicates whether the user is able to alter the gain settings
Public property | CanConfigureSystemAudio | Obsolete. Indicates whether the user is allowed to configure the gain settings
Public property | CanControlSystemAudio | Obsolete. Indicates whether the user is allowed to control the gain settings
Public property | MaxVolumeLevel | Obsolete. The maximum volume level
Public property | MinVolumeLevel | Obsolete. The minimal volume level.
Top
See Also

Reference

ISystemAudioControl Interface


ISystemAudioControl.AudioControlPossible Property

ISystemAudioControlAudioControlPossible Property

Note: This API is now obsolete.

Indicates whether the user is able to alter the gain settings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The AudioControlPossible property is deprecated; please use AudioControlPossible property of IRoomAudioControl instead.")]
bool AudioControlPossible { get; }
<ObsoleteAttribute("The AudioControlPossible property is deprecated; please use AudioControlPossible property of IRoomAudioControl instead.")>
ReadOnly Property AudioControlPossible As Boolean
    Get
[ObsoleteAttribute(L"The AudioControlPossible property is deprecated; please use AudioControlPossible property of IRoomAudioControl instead.")]
property bool AudioControlPossible {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISystemAudioControl Interface


ISystemAudioControl.CanConfigureSystemAudio Property

ISystemAudioControlCanConfigureSystemAudio Property

Note: This API is now obsolete.

Indicates whether the user is allowed to configure the gain settings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The CanConfigureSystemAudio property is deprecated; please use CanConfigureSystemAudio property of IRoomAudioControl instead.")]
bool CanConfigureSystemAudio { get; }
<ObsoleteAttribute("The CanConfigureSystemAudio property is deprecated; please use CanConfigureSystemAudio property of IRoomAudioControl instead.")>
ReadOnly Property CanConfigureSystemAudio As Boolean
    Get
[ObsoleteAttribute(L"The CanConfigureSystemAudio property is deprecated; please use CanConfigureSystemAudio property of IRoomAudioControl instead.")]
property bool CanConfigureSystemAudio {
    bool get ();
}

Property Value

Type: Boolean
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • User group right: Configure system
See Also

Reference

ISystemAudioControl Interface


ISystemAudioControl.CanControlSystemAudio Property

ISystemAudioControlCanControlSystemAudio Property

Note: This API is now obsolete.

Indicates whether the user is allowed to control the gain settings

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The CanControlSystemAudio property is deprecated; please use CanControlSystemAudio property of IRoomAudioControl instead.")]
bool CanControlSystemAudio { get; }
<ObsoleteAttribute("The CanControlSystemAudio property is deprecated; please use CanControlSystemAudio property of IRoomAudioControl instead.")>
ReadOnly Property CanControlSystemAudio As Boolean
    Get
[ObsoleteAttribute(L"The CanControlSystemAudio property is deprecated; please use CanControlSystemAudio property of IRoomAudioControl instead.")]
property bool CanControlSystemAudio {
    bool get ();
}

Property Value

Type: Boolean
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
Requires:
  • Device has capability: Volume control
See Also

Reference

ISystemAudioControl Interface


ISystemAudioControl.MaxVolumeLevel Property

ISystemAudioControlMaxVolumeLevel Property

Note: This API is now obsolete.

The maximum volume level

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The MaxVolumeLevel property is deprecated; please use MaxVolumeLevel property of IRoomAudioControl instead.")]
int MaxVolumeLevel { get; }
<ObsoleteAttribute("The MaxVolumeLevel property is deprecated; please use MaxVolumeLevel property of IRoomAudioControl instead.")>
ReadOnly Property MaxVolumeLevel As Integer
    Get
[ObsoleteAttribute(L"The MaxVolumeLevel property is deprecated; please use MaxVolumeLevel property of IRoomAudioControl instead.")]
property int MaxVolumeLevel {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ISystemAudioControl Interface


ISystemAudioControl.MinVolumeLevel Property

ISystemAudioControlMinVolumeLevel Property

Note: This API is now obsolete.

The minimal volume level.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The MinVolumeLevel property is deprecated; please use MinVolumeLevel property of IRoomAudioControl instead.")]
int MinVolumeLevel { get; }
<ObsoleteAttribute("The MinVolumeLevel property is deprecated; please use MinVolumeLevel property of IRoomAudioControl instead.")>
ReadOnly Property MinVolumeLevel As Integer
    Get
[ObsoleteAttribute(L"The MinVolumeLevel property is deprecated; please use MinVolumeLevel property of IRoomAudioControl instead.")]
property int MinVolumeLevel {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ISystemAudioControl Interface


ISystemAudioControl Methods

The ISystemAudioControl type exposes the following members.

Methods
 | Name | Description
Public method | AdjustGainAsync | Obsolete. Adjusts the gain setting for a specific gain type.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestGainsAsync | Obsolete. Requests the gain settings.
Public method | RequestMuteAsync | Obsolete. Requests the mute state.
Top
See Also

Reference

ISystemAudioControl Interface


ISystemAudioControl.AdjustGainAsync Method

ISystemAudioControlAdjustGainAsync Method

Note: This API is now obsolete.

Adjusts the gain setting for a specific gain type.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The AdjustGainAsync method is deprecated; please use AdjustAudioGainSettingsAsync method of IRoomAudioControl instead.")]
Task<bool> AdjustGainAsync(
    DcnmGainSetting gainSetting,
    Action<Task<bool>> onFinish = null
)
<ObsoleteAttribute("The AdjustGainAsync method is deprecated; please use AdjustAudioGainSettingsAsync method of IRoomAudioControl instead.")>
Function AdjustGainAsync (
    gainSetting As DcnmGainSetting,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
[ObsoleteAttribute(L"The AdjustGainAsync method is deprecated; please use AdjustAudioGainSettingsAsync method of IRoomAudioControl instead.")]
Task<bool>^ AdjustGainAsync(
    DcnmGainSetting^ gainSetting,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

gainSetting
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmGainSetting
The new gainsetting, containing the gain type and the new gain value.
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the gain adjustment. The 'Result' property of the task is true, if the request to adjust gain settings is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
ArgumentOutOfRangeException | When gain value is out of range
Remarks

Requires:

  • CanControlSystemAudio OR CanConfigureSystemAudio
  • AudioControlPossible

Event GainSettingsChanged is triggered, along with a list of gain settings that contain gain type and corresponding value.

See Also

Reference

ISystemAudioControl Interface


ISystemAudioControl.RequestGainsAsync Method

ISystemAudioControlRequestGainsAsync Method

Note: This API is now obsolete.

Requests the gain settings.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The RequestGainsAsync method is deprecated; please use RequestAudioSettingsAsync method of IRoomAudioControl instead.")]
Task<bool> RequestGainsAsync(
    Action<Task<bool>> onFinish = null
)
<ObsoleteAttribute("The RequestGainsAsync method is deprecated; please use RequestAudioSettingsAsync method of IRoomAudioControl instead.")>
Function RequestGainsAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
[ObsoleteAttribute(L"The RequestGainsAsync method is deprecated; please use RequestAudioSettingsAsync method of IRoomAudioControl instead.")]
Task<bool>^ RequestGainsAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request. The 'Result' property of the task is true, if the request to retrieve the gain setting is delivered, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Event GainSettingsChanged is triggered, along with a list of gain settings that contain gain type and corresponding value.

See Also

Reference

ISystemAudioControl Interface


ISystemAudioControl.RequestMuteAsync Method

ISystemAudioControlRequestMuteAsync Method

Note: This API is now obsolete.

Requests the mute state.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The RequestMuteAsync method is deprecated; please use RequestAudioSettingsAsync method of IRoomAudioControl instead.")]
Task<bool> RequestMuteAsync(
    Action<Task<bool>> onFinish = null
)
<ObsoleteAttribute("The RequestMuteAsync method is deprecated; please use RequestAudioSettingsAsync method of IRoomAudioControl instead.")>
Function RequestMuteAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
[ObsoleteAttribute(L"The RequestMuteAsync method is deprecated; please use RequestAudioSettingsAsync method of IRoomAudioControl instead.")]
Task<bool>^ RequestMuteAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request. The 'Result' property of the task is true if requesting mute succeeded, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Events triggered:

  • MuteStateChanged

See Also

Reference

ISystemAudioControl Interface


ISystemAudioControl Events

The ISystemAudioControl type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Obsolete. Occurs when the access rights of the logged on user changed.
Public event | GainSettingsChanged | Obsolete. Event indicating the gain setting has changed.
Public event | MuteStateChanged | Obsolete. Event indicating the mute state has changed.
Top
See Also

Reference

ISystemAudioControl Interface


ISystemAudioControl.CapabilitiesChanged Event

ISystemAudioControlCapabilitiesChanged Event

Note: This API is now obsolete.

Occurs when the access rights of the logged on user changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The CapabilitiesChanged event is deprecated; please use CapabilitiesChanged event of IRoomAudioControl instead.")]
event EventHandler CapabilitiesChanged
<ObsoleteAttribute("The CapabilitiesChanged event is deprecated; please use CapabilitiesChanged event of IRoomAudioControl instead.")>
Event CapabilitiesChanged As EventHandler
[ObsoleteAttribute(L"The CapabilitiesChanged event is deprecated; please use CapabilitiesChanged event of IRoomAudioControl instead.")]
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISystemAudioControl Interface


ISystemAudioControl.GainSettingsChanged Event

ISystemAudioControlGainSettingsChanged Event

Note: This API is now obsolete.

Event indicating the gain setting has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The GainSettingsChanged event is deprecated; please use AudioSettingsChanged event of IRoomAudioControl instead.")]
event EventHandler<ApiEventArgs<List<DcnmGainSetting>>> GainSettingsChanged
<ObsoleteAttribute("The GainSettingsChanged event is deprecated; please use AudioSettingsChanged event of IRoomAudioControl instead.")>
Event GainSettingsChanged As EventHandler(Of ApiEventArgs(Of List(Of DcnmGainSetting)))
[ObsoleteAttribute(L"The GainSettingsChanged event is deprecated; please use AudioSettingsChanged event of IRoomAudioControl instead.")]
 event EventHandler<ApiEventArgs<List<DcnmGainSetting^>^>^>^ GainSettingsChanged {
    void add (EventHandler<ApiEventArgs<List<DcnmGainSetting^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<List<DcnmGainSetting^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs List DcnmGainSetting
See Also

Reference

ISystemAudioControl Interface


ISystemAudioControl.MuteStateChanged Event

ISystemAudioControlMuteStateChanged Event

Note: This API is now obsolete.

Event indicating the mute state has changed.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("The MuteStateChanged event is deprecated; please use AudioSettingsChanged event of IRoomAudioControl instead.")]
event EventHandler<ApiEventArgs<bool>> MuteStateChanged
<ObsoleteAttribute("The MuteStateChanged event is deprecated; please use AudioSettingsChanged event of IRoomAudioControl instead.")>
Event MuteStateChanged As EventHandler(Of ApiEventArgs(Of Boolean))
[ObsoleteAttribute(L"The MuteStateChanged event is deprecated; please use AudioSettingsChanged event of IRoomAudioControl instead.")]
 event EventHandler<ApiEventArgs<bool>^>^ MuteStateChanged {
    void add (EventHandler<ApiEventArgs<bool>^>^ value);
    void remove (EventHandler<ApiEventArgs<bool>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs Boolean
See Also

Reference

ISystemAudioControl Interface


ISystemVideoControl Interface

Interface for system video functions.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface ISystemVideoControl : IDisposable
Public Interface ISystemVideoControl
    Inherits IDisposable
public interface class ISystemVideoControl : IDisposable

The ISystemVideoControl type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestVideoMetadataAddressAsync | Requests for video metadata multicast address .
Top
Events
 | Name | Description
Public event | VideoMetadataAddressChanged | Event indicating the video metadata multicast address has been updated.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


ISystemVideoControl Methods

The ISystemVideoControl type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestVideoMetadataAddressAsync | Requests for video metadata multicast address .
Top
See Also

Reference

ISystemVideoControl Interface


ISystemVideoControl.RequestVideoMetadataAddressAsync Method

ISystemVideoControlRequestVideoMetadataAddressAsync Method

Requests for video metadata multicast address .

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestVideoMetadataAddressAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestVideoMetadataAddressAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestVideoMetadataAddressAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the video metadata multicast address retrieval. The 'Result' property of the task is true, if the multicast addredss is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

ISystemVideoControl Interface


ISystemVideoControl Events

The ISystemVideoControl type exposes the following members.

Events
 | Name | Description
Public event | VideoMetadataAddressChanged | Event indicating the video metadata multicast address has been updated.
Top
See Also

Reference

ISystemVideoControl Interface


ISystemVideoControl.VideoMetadataAddressChanged Event

ISystemVideoControlVideoMetadataAddressChanged Event

Event indicating the video metadata multicast address has been updated.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<string>> VideoMetadataAddressChanged
Event VideoMetadataAddressChanged As EventHandler(Of ApiEventArgs(Of String))
 event EventHandler<ApiEventArgs<String^>^>^ VideoMetadataAddressChanged {
    void add (EventHandler<ApiEventArgs<String^>^>^ value);
    void remove (EventHandler<ApiEventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs String
See Also

Reference

ISystemVideoControl Interface


IVote Interface

Represents an interface to participate in an ongoing voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IVote : IDisposable
Public Interface IVote
    Inherits IDisposable
public interface class IVote : IDisposable

The IVote type exposes the following members.

Properties
 | Name | Description
Public property | CanVote | Indicates the user is able to vote in the active voting.
Public property | IsVotingActive | Indicates whether a voting is active or not.
Top
Methods
 | Name | Description
Public method | CastVoteAsync | Casts a vote for the active voting.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestActiveVotingStatusAsync | Requests status of currently active voting.
Public method | RequestCastedVoteAsync | Requests the actual casted vote in the running voting.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | VoteCasted | Occurs when casting a vote was successful or indicates which vote has been casted before.
Public event | VotingStatusChanged | Occurs when the operational state of a voting changes within the current meeting.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IVote Properties

The IVote type exposes the following members.

Properties
 | Name | Description
Public property | CanVote | Indicates the user is able to vote in the active voting.
Public property | IsVotingActive | Indicates whether a voting is active or not.
Top
See Also

Reference

IVote Interface


IVote.CanVote Property

IVoteCanVote Property

Indicates the user is able to vote in the active voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanVote { get; }
ReadOnly Property CanVote As Boolean
    Get
property bool CanVote {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
The user needs to be logged in for this property to be enabled. It requires:
  • Functional license: Voting preparation or Virtual license :DCNM_PBL(indicates presence of any participant based license).
  • Seat license: Voting at seat
  • Participant right: Can vote
See Also

Reference

IVote Interface


IVote.IsVotingActive Property

IVoteIsVotingActive Property

Indicates whether a voting is active or not.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool IsVotingActive { get; }
ReadOnly Property IsVotingActive As Boolean
    Get
property bool IsVotingActive {
    bool get ();
}

Return Value

Type: Boolean
Boolean indicating whether a voting is currently active or not.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
See Also

Reference

IVote Interface


IVote Methods

The IVote type exposes the following members.

Methods
 | Name | Description
Public method | CastVoteAsync | Casts a vote for the active voting.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestActiveVotingStatusAsync | Requests status of currently active voting.
Public method | RequestCastedVoteAsync | Requests the actual casted vote in the running voting.
Top
See Also

Reference

IVote Interface


IVote.CastVoteAsync Method

IVoteCastVoteAsync Method

Casts a vote for the active voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> CastVoteAsync(
    DcnmVotingAnswer votingAnswer,
    Action<Task<bool>> onFinish = null
)
Function CastVoteAsync (
    votingAnswer As DcnmVotingAnswer,
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ CastVoteAsync(
    DcnmVotingAnswer votingAnswer,
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

votingAnswer
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmVotingAnswer
The answer given for the voting
onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the request. The 'Result' property of the task is true if the request to "Cast a vote" is delivered, false otherwise. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

Requires:

  • CanVote
  • DcnmApplicationState should be in DcnmApplicationState.ConferenceMode

Events triggered are as follows:

  • VoteCasted - if the vote is successfully casted

See Also

Reference

IVote Interface


IVote.RequestActiveVotingStatusAsync Method

IVoteRequestActiveVotingStatusAsync Method

Requests status of currently active voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestActiveVotingStatusAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestActiveVotingStatusAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestActiveVotingStatusAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the voting retrieval. The 'Result' property of the task is true if the request to retrieve the status of active voting is delivered, false if the request is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

VotingStatusChanged is triggered if the request is processed successfully, along with the status of the currently active voting.

See Also

Reference

IVote Interface


IVote.RequestCastedVoteAsync Method

IVoteRequestCastedVoteAsync Method

Requests the actual casted vote in the running voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestCastedVoteAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestCastedVoteAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestCastedVoteAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the casted vote retrieval. The 'Result' property of the task is true if the request to retrieve the actual casted vote in the running voting of a meeting is delivered, false if the request is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

VoteCasted is triggered if the request is processed successfully, along with the casted vote.

See Also

Reference

IVote Interface


IVote Events

The IVote type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | VoteCasted | Occurs when casting a vote was successful or indicates which vote has been casted before.
Public event | VotingStatusChanged | Occurs when the operational state of a voting changes within the current meeting.
Top
See Also

Reference

IVote Interface


IVote.CapabilitiesChanged Event

IVoteCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IVote Interface


IVote.VoteCasted Event

IVoteVoteCasted Event

Occurs when casting a vote was successful or indicates which vote has been casted before.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmVotingAnswer>> VoteCasted
Event VoteCasted As EventHandler(Of ApiEventArgs(Of DcnmVotingAnswer))
 event EventHandler<ApiEventArgs<DcnmVotingAnswer>^>^ VoteCasted {
    void add (EventHandler<ApiEventArgs<DcnmVotingAnswer>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmVotingAnswer>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmVotingAnswer
See Also

Reference

IVote Interface


IVote.VotingStatusChanged Event

IVoteVotingStatusChanged Event

Occurs when the operational state of a voting changes within the current meeting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmVotingStatusInfo>> VotingStatusChanged
Event VotingStatusChanged As EventHandler(Of ApiEventArgs(Of DcnmVotingStatusInfo))
 event EventHandler<ApiEventArgs<DcnmVotingStatusInfo^>^>^ VotingStatusChanged {
    void add (EventHandler<ApiEventArgs<DcnmVotingStatusInfo^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmVotingStatusInfo^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmVotingStatusInfo
See Also

Reference

IVote Interface


IVotingResult Interface

Defines the interface for voting result.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface IVotingResult : IDisposable
Public Interface IVotingResult
    Inherits IDisposable
public interface class IVotingResult : IDisposable

The IVotingResult type exposes the following members.

Properties
 | Name | Description
Public property | CanViewVoteResults | Indicates the user is able to view the results of the active voting.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestIndividualVotingResultAsync | Request for the individual voting result.
Public method | RequestVotingResultAsync | Request for the voting result.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | IndividualVotingResultUpdated | Occurs when individual voting result is published from voting services.
Public event | MajorityResultUpdated | Occurs when voting result is published from voting services.
Public event | VotingResultUpdated | Occurs when voting result is published from voting services.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


IVotingResult Properties

The IVotingResult type exposes the following members.

Properties
 | Name | Description
Public property | CanViewVoteResults | Indicates the user is able to view the results of the active voting.
Top
See Also

Reference

IVotingResult Interface


IVotingResult.CanViewVoteResults Property

IVotingResultCanViewVoteResults Property

Indicates the user is able to view the results of the active voting.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool CanViewVoteResults { get; }
ReadOnly Property CanViewVoteResults As Boolean
    Get
property bool CanViewVoteResults {
    bool get ();
}

Return Value

Type: Boolean
True if possible, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks
The user needs to be logged in for this property to be enabled. It requires:
  • Functional license: Voting preparation or Virtual license :DCNM_PBL(indicates presence of any participant based license)
  • Seat license: Voting at seat
See Also

Reference

IVotingResult Interface


IVotingResult Methods

The IVotingResult type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RequestIndividualVotingResultAsync | Request for the individual voting result.
Public method | RequestVotingResultAsync | Request for the voting result.
Top
See Also

Reference

IVotingResult Interface


IVotingResult.RequestIndividualVotingResultAsync Method

IVotingResultRequestIndividualVotingResultAsync Method

Request for the individual voting result.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestIndividualVotingResultAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestIndividualVotingResultAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestIndividualVotingResultAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the individual voting result retrieval. The 'Result' property of the task is true if the request to retrieve the individual voting result, false if the request is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

IndividualVotingResultUpdated is triggered if the request is processed successfully, along with the voting result.

See Also

Reference

IVotingResult Interface


IVotingResult.RequestVotingResultAsync Method

IVotingResultRequestVotingResultAsync Method

Request for the voting result.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
Task<bool> RequestVotingResultAsync(
    Action<Task<bool>> onFinish = null
)
Function RequestVotingResultAsync (
    Optional onFinish As Action(Of Task(Of Boolean)) = Nothing
) As Task(Of Boolean)
Task<bool>^ RequestVotingResultAsync(
    Action<Task<bool>^>^ onFinish = nullptr
)

Parameters

onFinish (Optional)
Type: SystemAction Task Boolean
Optional action for asynchronous handling of the result.

Return Value

Type: Task Boolean
Task processing the voting result retrieval. The 'Result' property of the task is true if the request to retrieve the voting result, false if the request is not delivered. Note that the result getter blocks until the return value is available.
Exceptions
Exception | Condition
ObjectDisposedException | If object already disposed.
Remarks

VotingResultUpdated is triggered if the request is processed successfully, along with the voting result. MajorityResultUpdated is triggered if the request is processed successfully, along with the voting result.

See Also

Reference

IVotingResult Interface


IVotingResult Events

The IVotingResult type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when the capabilities of the API change.
Public event | IndividualVotingResultUpdated | Occurs when individual voting result is published from voting services.
Public event | MajorityResultUpdated | Occurs when voting result is published from voting services.
Public event | VotingResultUpdated | Occurs when voting result is published from voting services.
Top
See Also

Reference

IVotingResult Interface


IVotingResult.CapabilitiesChanged Event

IVotingResultCapabilitiesChanged Event

Occurs when the capabilities of the API change.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler CapabilitiesChanged
Event CapabilitiesChanged As EventHandler
 event EventHandler^ CapabilitiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IVotingResult Interface


IVotingResult.IndividualVotingResultUpdated Event

IVotingResultIndividualVotingResultUpdated Event

Occurs when individual voting result is published from voting services.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmIndividualVotingResult>>> IndividualVotingResultUpdated
Event IndividualVotingResultUpdated As EventHandler(Of ApiEventArgs(Of IList(Of DcnmIndividualVotingResult)))
 event EventHandler<ApiEventArgs<IList<DcnmIndividualVotingResult^>^>^>^ IndividualVotingResultUpdated {
    void add (EventHandler<ApiEventArgs<IList<DcnmIndividualVotingResult^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmIndividualVotingResult^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmIndividualVotingResult
See Also

Reference

IVotingResult Interface


IVotingResult.MajorityResultUpdated Event

IVotingResultMajorityResultUpdated Event

Occurs when voting result is published from voting services.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<DcnmMajorityResult>> MajorityResultUpdated
Event MajorityResultUpdated As EventHandler(Of ApiEventArgs(Of DcnmMajorityResult))
 event EventHandler<ApiEventArgs<DcnmMajorityResult^>^>^ MajorityResultUpdated {
    void add (EventHandler<ApiEventArgs<DcnmMajorityResult^>^>^ value);
    void remove (EventHandler<ApiEventArgs<DcnmMajorityResult^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs DcnmMajorityResult
See Also

Reference

IVotingResult Interface


IVotingResult.VotingResultUpdated Event

IVotingResultVotingResultUpdated Event

Occurs when voting result is published from voting services.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
event EventHandler<ApiEventArgs<IList<DcnmVotingResult>>> VotingResultUpdated
Event VotingResultUpdated As EventHandler(Of ApiEventArgs(Of IList(Of DcnmVotingResult)))
 event EventHandler<ApiEventArgs<IList<DcnmVotingResult^>^>^>^ VotingResultUpdated {
    void add (EventHandler<ApiEventArgs<IList<DcnmVotingResult^>^>^>^ value);
    void remove (EventHandler<ApiEventArgs<IList<DcnmVotingResult^>^>^>^ value);
}

Value

Type: SystemEventHandler ApiEventArgs IList DcnmVotingResult
See Also

Reference

IVotingResult Interface


MeetingConstants Class

The supported Meeting constants
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesMeetingConstants

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class MeetingConstants
Public Class MeetingConstants
public ref class MeetingConstants

The MeetingConstants type exposes the following members.

Constructors
 | Name | Description
Public method | MeetingConstants | Initializes a new instance of the MeetingConstants class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
MAX_URL_SIZE | The maximum length of URL supported.
PARTICIPANTGROUPID | The default ID of Participant User Group.
SITE_DEFAULT_MEETING_ID | Site default meeting Id.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


MeetingConstants Constructor

Initializes a new instance of the MeetingConstants class

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public MeetingConstants()
Public Sub New
public:
MeetingConstants()
See Also

Reference

MeetingConstants Class


MeetingConstants Methods

The MeetingConstants type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MeetingConstants Class


MeetingConstants Fields

The MeetingConstants type exposes the following members.

Fields
Name | Description
MAX_URL_SIZE | The maximum length of URL supported.
PARTICIPANTGROUPID | The default ID of Participant User Group.
SITE_DEFAULT_MEETING_ID | Site default meeting Id.
Top
See Also

Reference

MeetingConstants Class


MeetingConstants.MAX_URL_SIZE Field

MeetingConstantsMAX_URL_SIZE Field

The maximum length of URL supported.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAX_URL_SIZE = 255
Public Const MAX_URL_SIZE As Integer = 255
public:
literal int MAX_URL_SIZE = 255

Field Value

Type: Int32
See Also

Reference

MeetingConstants Class


MeetingConstants.PARTICIPANTGROUPID Field

MeetingConstantsPARTICIPANTGROUPID Field

The default ID of Participant User Group.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static readonly Guid PARTICIPANTGROUPID
Public Shared ReadOnly PARTICIPANTGROUPID As Guid
public:
static initonly Guid PARTICIPANTGROUPID

Field Value

Type: Guid
See Also

Reference

MeetingConstants Class


MeetingConstants.SITE_DEFAULT_MEETING_ID Field

MeetingConstantsSITE_DEFAULT_MEETING_ID Field

Site default meeting Id.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static readonly Guid SITE_DEFAULT_MEETING_ID
Public Shared ReadOnly SITE_DEFAULT_MEETING_ID As Guid
public:
static initonly Guid SITE_DEFAULT_MEETING_ID

Field Value

Type: Guid
See Also

Reference

MeetingConstants Class


PluginCommandDelegate Delegate

Delegate that gets called when a plugin needs to execute a command

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public delegate Task<string> PluginCommandDelegate(
    DcnmPluginCommand msg,
    CancellationToken ct
)
Public Delegate Function PluginCommandDelegate (
    msg As DcnmPluginCommand,
    ct As CancellationToken
) As Task(Of String)
public delegate Task<String^>^ PluginCommandDelegate(
    DcnmPluginCommand^ msg,
    CancellationToken ct
)

Parameters

msg
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPluginCommand
The message that is received from the caller
ct
Type: System.ThreadingCancellationToken
Token that can be used to cancel the operation

Return Value

Type: Task String
A (JSON formatted) string containing the response returned from executing the command
Remarks
This method is always called as an asynchronous task. It is always run on the same TaskScheduler as was current when the plugin was registered.
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


PluginEventDelegate Delegate

Delegate that gets called when a plugin sends an event to an API application

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public delegate void PluginEventDelegate(
    DcnmPluginEvent msg
)
Public Delegate Sub PluginEventDelegate (
    msg As DcnmPluginEvent
)
public delegate void PluginEventDelegate(
    DcnmPluginEvent^ msg
)

Parameters

msg
Type: Bosch.Dcnm.Interfaces.Api.InterfacesDcnmPluginEvent
The message that the plugin sends to the Dicentis Api application
Remarks
This method is called as an asynchronous task. It is always run on the same TaskScheduler as was current when the event subscription was made
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


VotingConstants Class

The supported Voting constants
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.InterfacesVotingConstants

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static class VotingConstants
Public NotInheritable Class VotingConstants
public ref class VotingConstants abstract sealed

The VotingConstants type exposes the following members.

Fields
Name | Description
MAXIMUM_VOTING_TIME_LIMIT | Maximum voting time limit.
MINIMUM_VOTING_TIME_LIMIT | Minimum voting time limit.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Interfaces Namespace
Bosch Security Systems

(c) Bosch Security System B.V., 2025


VotingConstants Fields

The VotingConstants type exposes the following members.

Fields
Name | Description
MAXIMUM_VOTING_TIME_LIMIT | Maximum voting time limit.
MINIMUM_VOTING_TIME_LIMIT | Minimum voting time limit.
Top
See Also

Reference

VotingConstants Class


VotingConstants.MAXIMUM_VOTING_TIME_LIMIT Field

VotingConstantsMAXIMUM_VOTING_TIME_LIMIT Field

Maximum voting time limit.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MAXIMUM_VOTING_TIME_LIMIT = 3600
Public Const MAXIMUM_VOTING_TIME_LIMIT As Integer = 3600
public:
literal int MAXIMUM_VOTING_TIME_LIMIT = 3600

Field Value

Type: Int32
See Also

Reference

VotingConstants Class


VotingConstants.MINIMUM_VOTING_TIME_LIMIT Field

VotingConstantsMINIMUM_VOTING_TIME_LIMIT Field

Minimum voting time limit.

Namespace: Bosch.Dcnm.Interfaces.Api.Interfaces
Assembly: Bosch.Dcnm.Interfaces.Api.Interfaces (in Bosch.Dcnm.Interfaces.Api.Interfaces.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public const int MINIMUM_VOTING_TIME_LIMIT = 5
Public Const MINIMUM_VOTING_TIME_LIMIT As Integer = 5
public:
literal int MINIMUM_VOTING_TIME_LIMIT = 5

Field Value

Type: Int32
See Also

Reference

VotingConstants Class


Bosch.Dcnm.Interfaces.Api.Logic.Plugins Namespace

Namespace holding the interfaces of the Plugins.
Classes
 | Class | Description
Public class | EventKey | Defines type-specific method for determining equality of instances.


EventKey Class

Defines type-specific method for determining equality of instances.
Inheritance Hierarchy
SystemObject
Bosch.Dcnm.Interfaces.Api.Logic.PluginsEventKey

Namespace: Bosch.Dcnm.Interfaces.Api.Logic.Plugins
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public class EventKey : IEquatable<EventKey>
Public Class EventKey
    Implements IEquatable(Of EventKey)
public ref class EventKey : IEquatable<EventKey^>

The EventKey type exposes the following members.

Constructors
 | Name | Description
Public method | EventKey | Initializes a new instance of the EventKey class
Top
Properties
 | Name | Description
Public property | EventName | Event name.
Public property | PluginName | Plugin name.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equals to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(EventKey) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default Hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
Equality | Equaltity comparer.
Inequality | Not-equaltity comparer.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Logic.Plugins Namespace


EventKey Constructor

Initializes a new instance of the EventKey class

Namespace: Bosch.Dcnm.Interfaces.Api.Logic.Plugins
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public EventKey()
Public Sub New
public:
EventKey()
See Also

Reference

EventKey Class
Bosch.Dcnm.Interfaces.Api.Logic.Plugins Namespace


EventKey Properties

The EventKey type exposes the following members.

Properties
 | Name | Description
Public property | EventName | Event name.
Public property | PluginName | Plugin name.
Top
See Also

Reference

EventKey Class
Bosch.Dcnm.Interfaces.Api.Logic.Plugins Namespace


EventKey.EventName Property

EventKeyEventName Property

Event name.

Namespace: Bosch.Dcnm.Interfaces.Api.Logic.Plugins
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string EventName { get; set; }
Public Property EventName As String
    Get
    Set
public:
property String^ EventName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

EventKey Class
Bosch.Dcnm.Interfaces.Api.Logic.Plugins Namespace


EventKey.PluginName Property

EventKeyPluginName Property

Plugin name.

Namespace: Bosch.Dcnm.Interfaces.Api.Logic.Plugins
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public string PluginName { get; set; }
Public Property PluginName As String
    Get
    Set
public:
property String^ PluginName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

EventKey Class
Bosch.Dcnm.Interfaces.Api.Logic.Plugins Namespace


EventKey Methods

The EventKey type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equals to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(EventKey) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default Hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EventKey Class
Bosch.Dcnm.Interfaces.Api.Logic.Plugins Namespace


EventKey.Equals Method

EventKeyEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equals to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(EventKey) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

EventKey Class
Bosch.Dcnm.Interfaces.Api.Logic.Plugins Namespace


EventKey.Equals Method (Object)

EventKeyEquals Method (Object)

 Bosch Logo
Determines whether the specified object is equals to the current object.

Namespace: Bosch.Dcnm.Interfaces.Api.Logic.Plugins
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
specified object.

Return Value

Type: Boolean
True if equals, false otherwise.
See Also

Reference

EventKey Class
Equals Overload
Bosch.Dcnm.Interfaces.Api.Logic.Plugins Namespace


EventKey.Equals Method (EventKey)

EventKeyEquals Method (EventKey)

 Bosch Logo
Indicates whether the current object is equal to another object of the same type.

Namespace: Bosch.Dcnm.Interfaces.Api.Logic.Plugins
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public bool Equals(
    EventKey other
)
Public Function Equals (
    other As EventKey
) As Boolean
public:
virtual bool Equals(
    EventKey^ other
) sealed

Parameters

other
Type: Bosch.Dcnm.Interfaces.Api.Logic.PluginsEventKey
Other object.

Return Value

Type: Boolean
True if equals, false otherwise.

Implements

IEquatableTEquals(T)
See Also

Reference

EventKey Class
Equals Overload
Bosch.Dcnm.Interfaces.Api.Logic.Plugins Namespace


EventKey.GetHashCode Method

EventKeyGetHashCode Method

Serves as the default Hash function.

Namespace: Bosch.Dcnm.Interfaces.Api.Logic.Plugins
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override

Return Value

Type: Int32
Hashcode.
See Also

Reference

EventKey Class
Bosch.Dcnm.Interfaces.Api.Logic.Plugins Namespace


EventKey Operators

The EventKey type exposes the following members.

Operators
Name | Description
Equality | Equaltity comparer.
Inequality | Not-equaltity comparer.
Top
See Also

Reference

EventKey Class
Bosch.Dcnm.Interfaces.Api.Logic.Plugins Namespace


EventKey.Equality Operator

EventKeyEquality Operator

Equaltity comparer.

Namespace: Bosch.Dcnm.Interfaces.Api.Logic.Plugins
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static bool operator ==(
    EventKey left,
    EventKey right
)
Public Shared Operator = (
    left As EventKey,
    right As EventKey
) As Boolean
public:
static bool operator ==(
    EventKey^ left,
    EventKey^ right
)

Parameters

left
Type: Bosch.Dcnm.Interfaces.Api.Logic.PluginsEventKey
Left event key.
right
Type: Bosch.Dcnm.Interfaces.Api.Logic.PluginsEventKey
Right event key.

Return Value

Type: Boolean
True if equals, false otherwise.
See Also

Reference

EventKey Class
Bosch.Dcnm.Interfaces.Api.Logic.Plugins Namespace


EventKey.Inequality Operator

EventKeyInequality Operator

Not-equaltity comparer.

Namespace: Bosch.Dcnm.Interfaces.Api.Logic.Plugins
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public static bool operator !=(
    EventKey left,
    EventKey right
)
Public Shared Operator <> (
    left As EventKey,
    right As EventKey
) As Boolean
public:
static bool operator !=(
    EventKey^ left,
    EventKey^ right
)

Parameters

left
Type: Bosch.Dcnm.Interfaces.Api.Logic.PluginsEventKey
Left event key.
right
Type: Bosch.Dcnm.Interfaces.Api.Logic.PluginsEventKey
Right event key.

Return Value

Type: Boolean
True if not equals, false otherwise.
See Also

Reference

EventKey Class
Bosch.Dcnm.Interfaces.Api.Logic.Plugins Namespace


Bosch.Dcnm.Interfaces.Api.Services Namespace

Namespace holding the interfaces of the Services.
Interfaces
 | Interface | Description
Public interface | ICapabilities | Interface to check the capabilities.


ICapabilities Interface

Interface to check the capabilities.

Namespace: Bosch.Dcnm.Interfaces.Api.Services
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
public interface ICapabilities
Public Interface ICapabilities
public interface class ICapabilities

The ICapabilities type exposes the following members.

Methods
 | Name | Description
Public method | HasCapability | Verifies whether a given capability is available.
Top
See Also

Reference

Bosch.Dcnm.Interfaces.Api.Services Namespace


ICapabilities Methods

The ICapabilities type exposes the following members.

Methods
 | Name | Description
Public method | HasCapability | Verifies whether a given capability is available.
Top
See Also

Reference

ICapabilities Interface
Bosch.Dcnm.Interfaces.Api.Services Namespace


ICapabilities.HasCapability Method

ICapabilitiesHasCapability Method

Verifies whether a given capability is available.

Namespace: Bosch.Dcnm.Interfaces.Api.Services
Assembly: Bosch.Dcnm.Interfaces.Api (in Bosch.Dcnm.Interfaces.Api.dll) Version: 6.40.39777
Syntax
C#
VB
C++
Copy
bool HasCapability(
    int capability
)
Function HasCapability (
    capability As Integer
) As Boolean
bool HasCapability(
    int capability
)

Parameters

capability
Type: SystemInt32
The capability to query.

Return Value

Type: Boolean
true if capability is present, false if not.
See Also

Reference

ICapabilities Interface
Bosch.Dcnm.Interfaces.Api.Services Namespace


API Demonstrator

This section of the documentation describes the usage of API Demonstrator. API Demonstrator is a application which communicates with DICENTIS services to configure, prepare and manage DICENTIS conference system, using DICENTIS API module.

The User Interface

The user interface of the API Demonstrator application guides you through the actions required to configure, prepare and manage the DICENTIS conference system.

API demo 1 - main

With reference to the above image, the user interface of the API Demonstrator is divided into the following sections:

  1. Connection Section: This section facilitates the connection and disconnection of API Demonstrator and describes the connection state of the API demonstrator. See How to connect to the system for details.

  2. Implementation section: Describes the usage of various API's of DICENTIS API module. This section is further divided into 3 sections:

    1. Properties section

    2. Commands section

    3. Data section

  3. Logging section: Logs the results of the calls made to functions of various API's of DICENTIS API module.

    The logging section contains a list box, which logs the following:

    • Results of the functions called

    • Properties whose value will be modified

    • Events triggered

    • Exceptions

    When a function is called, with the help of these logs the developer can understand the relationship between functions, properties involved, events triggered. Hence helping the developer understand the system better.

    Api Demo Logging

Implementation Section

Implementation section contains several tabs, each representing a API from DICENTIS API module. Each tab contains the properties, and Commands available of the API, and optionally can contain Data, which will be used to call API functions.

Api Demo 2 tabs

Properties section

This section contains all the properties of a particular API. Each property is represented by a label. Value of the property is represented by the following colors.

  • Green: Value of the property is true.

  • Gray: Value of the property is false.

Commands section

This section contains the API functions which are called from the demonstrator. The function use the data present in the data section to call a function of a API. As a result of the function call, events are triggered and properties are modified. The logging section logs which events and properties are modified.

Data section

This section represents both input as well as the outcome of a API. Data required by certain commands to call a function is present in this section along with the outcome of a function call.


History

Dicentis Api History

Version

DICENTIS 6.40

Interfaces

  • IApi

Methods made obsolete

  • AuthenticateWindowsSystemUserAsync

DICENTIS 6.30

Classes updated:

  • DcnmPersonInfo

    Property added

    1. UserName

  • DcnmParticipantPreparationInfo2

    Property added

    1. UserName

    2. ScreenLine

DICENTIS 6.20

Interface extended

  • IControlSpeaker

Methods added:

  • SetSpeechTimeAsync

  • IApi

Properties added:

  • DicentisCapabilites

Classes updated

  • ApiBase

    Property added

    1. DicentisCapabilities

Example code added

Example code for "Create auto-start meeting and assign participants same as seats" added in IPrepareMeeting tab.

DICENTIS 6.10

Interface extended

  • IConfigArea

Properties added:

  • CanAdjustMicrophoneSensitivity

  • MinMicrophoneSensitivity

  • MaxMicrophoneSensitivity

  • MicrophoneSensitivityStepSize

Methods added:

  • UpdateMicrophoneSensitivityForSeatsAsync

  • RetrieveMicrophoneSensitivityOfSeatAsync

  • ResetMicrophoneSensitivityForAllSeatsToDefaultAsync

Event added:

  • MicrophoneSensitivityForSeatsUpdated

Class added:

  • DcnmMicrophoneSensitivityForSeat

Classes updated

  • DcnmVotingSettingsInfo

    Property added

    1. AutoAnswerEnabled

    2. AutoCastVoteAnswer

  • DcnmVotingPreparationInfo

    Property added

    1. AutoAnswerEnabled

    2. AutoCastVoteAnswer

  • DcnmVotingStatusInfo

    Property added

    1. AutoAnswerEnabled

    2. AutoCastVoteAnswer

Interfaces

  • DcnmVotingSettingsInfo

Property added

  1. CanChangeCastVote

  • DcnmVotingPreparationInfo

Property added

  1. CanChangeCastVote

  • DcnmVotingStatusInfo

Property added

  1. CanChangeCastVote

Enum Updated

  • DcnmVotingAnswerSet

DICENTIS 5.10

Interfaces

  • IPrepareAgendaTopic

Property added

  1. CanPrepareAgendaTopics

Method added

  1. RetrieveAgendaTopicsForMeetingAsync

  2. CreateAgendaTopicAsync

  3. CopyAgendaTopicAsync

  4. UpdateAgendaTopicAsync

  5. ChangeAgendaTopicOrderAsync

  6. DeleteAgendaTopicAsync

Event added

  1. CapabilitiesChanged

  2. AgendaTopicCreated

  3. AgendaTopicUpdated

  4. AgendaTopicDeleted

  5. AgendaTopicOrderChanged

Classes

    Updated

      DcnmInterpretationSettingsInfo

Enum

    Updated

      DcnmHeadphoneTypes

DICENTIS 4.4

DicentisConstants

  • DeviceAttributes

Attributes added

  1. MayPowerOff

  2. MayControlVolume

DICENTIS 4.3

Interfaces

  • IControlDiscussion

Property added

  1. CanControlAdvancedDiscussions

  • IPrepareDiscussion

Property added

  1. CanPrepareAdvancedDiscussions

  • IPrepareMeeting

Methods added

  1. SetAutoStartMeetingIdAsync

  2. RetrieveAutoStartMeetingIdAsync

DICENTIS 4.2

Interfaces

  • IControlParticipant

Method added

  1. RequestParticipantAccessDeniedStatusAsync

Event added

  1. ParticipantAccessDenied

  • ISystemVideoControl

Method added

  1. RequestVideoMetadataAddressAsync

Event added

  1. VideoMetadataAddressChanged

Classes

    Added

      DcnmParticipantAccessDeniedInfo

      DcnmAccessDeniedReason

      Enum

        Updated

          DcnmIdentificationMethod

            Removed : QRCode